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Introduction 
The HP ART software provides several options to manage the language of your content so you 
can easily produce translated versions of your HP ART content. This process allows you to 
translate the text in your course modules, along with the information notes and action notes in 
simulations. If your company uses a localized application GUI, you can also reproduce the 
simulations so that the simulation screen images reflect your company’s actual application.  

Translation and Localization Options 
Your environment and training needs dictate the amount of translation and localization 
required for your ART training material. HP outlines the following three scenarios to assist you 
in this process:  

• Scenario 1: Phrases Only 

• Scenario 2: All Text Content 

• Scenario 3: Full Localization 

Scenario 1: Phrases Only 
The Phrases Only option updates the current course module and simulation files with the 
phrases that are already documented and translated in the HP ART template. The result is 
content that will include some English along with your language of choice. It does not require 
an outside translator. In this scenario: 

• Phrases listed in the HP ART template are used to translate content. 

o Simulation action notes that have not been edited are translated. 

o Button names in the HP ART GUI are translated. 

• Course module content and simulation information notes remain in English. 

• Job aids must be reattached and simulation links in the course module must be 
updated. 
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Scenario 2: All Text Content 
The All Text Content option includes the Phrases Only actions plus all other text content. The 
text content is exported to an XML Localization Interchange File Format (XLIFF) and sent to a 
translation company. Additional content that is not included in the XLIFF files is manually 
added to an Excel spreadsheet for translation. The result is that all text content is translated to 
the desired language. In this scenario: 

• Tasks from the Phrases Only option listed above are performed.  

• All text content in course module and simulation files is exported to an XLIFF file to be 
translated by a translation company.  

• Additional content not included in the XLIFF file is documented in an Excel spreadsheet 
to be translated and manually entered into the course module.  

Scenario 3: Full Localization 
The Full Localization process includes the All Text Content actions plus a re-recording of all 
simulations to include application images that reflect the local installation. The result is a fully 
translated and localized training package. In this scenario: 

• Tasks from the All Text Content option above are performed. 

• Images that contain English text are updated with translations.  

• Simulations are re-recorded using localized application GUIs so that application 
images are localized.  
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Getting Started 
Before beginning a translation or localization process, review the topics below.  

Prepare File Hierarchy 
As you translate and localize your ART files, many different types of files are used and 
generated. The following folder structure is strongly recommended to help organize the files 
during this process. HP recommends that you create a folder named C:\ART\ with the sub-
structure illustrated below. 

 

Folder Description 

ART Translation [Project 
Name] 

Main folder for each ART course. Name the folder to match 
your project title.  

exported_xliff_files Storage location for XLIFF files when using the Manage 
Content Language>Export command.  

published_content 

01_intro 

02_module_name 

0x_module_name 

Use as an outbox location when publishing recordings and 
courses so that you can view them locally. The published job 
aid file is linked to the course file. For organizational 
purposes, you should create sub-folders for each module.  

source 

01_intro 

02_module_name 

0x_module_name  

Use this folder to store the English course file (.ULC) and the 
recordings (.UDC) files. Create sub-folders for each module. 

translated 

01_intro 

02_module_name 

0x_module_name 

Use this folder to store the translated course file (.ULC) and the 
recording (.UDC) files. Create sub-folders for each module.  

translated_xliff_files Storage location for XLIFF files received back from the 
translation company.  
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Languages Available in the Template 
The image below shows the General > Languages page in the HP ART template. This list 
indicates over 30 languages that HP ART supports to aid you in your translation efforts.  
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Phrases Already Translated 
The Phrases tab in the HP ART template shows the boilerplate text that is used throughout the 
course modules and simulations. These phrases have already been translated so that you do 
not need to incur a translation cost. When you export a file to the XLIFF format these phrases 
show as translated.  

See the Appendix for details on how to export the phrases for review.  
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XML Localization Interchange File Format (XLIFF)  
For each exported language, one XML Localization Interchange File Format (XLIFF) file is 
created. The exported XLIFF file(s) contain all phrases and author-entered text in the content. 
Phrases and boilerplate text provided with the template (for example, "Show Me!") are 
automatically translated to the phrases provided in the template. To translate the author-
entered text, the XLIFF file is sent to a translation company. The XLIFF file is then imported back 
into the ART file so that both phrases and author-entered text are imported, enabling 
production of translated training material. 

Below is an example of an XLIFF file for a simulation. This image shows the phrase "Show 
Me!" translated to the selected language, since "Show Me!" is a phrase in the ART template. 

 

Below is the same XLIFF file showing author-entered text from an information note. This text 
requires translation by a translation company. 
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Additional Content to Translate 
If you are conducting an All Text Content or Full Localization translation, be aware that 
several types of content are not extracted with the XLIFF file and need to be manually 
extracted for translation. The best practice is to create an Excel spreadsheet and manually 
add this content so that it can be translated along with the XLIFF files. The items that are not 
automatically extracted are: 

• Description and Module fields on the HP ART File>Properties>Properties page. 

• The copyright in the footer of the job aids. (This is stored in the HP ART template 
Blocks>Footer; may not require translation.) 

• Author-entered field descriptions in job aids. 

• Text input examples in job aids. (May not require translation.) 

Below is a sample of an Excel spreadhseet to use for translation.  

 

Localized Check Boxes 
The purpose of the Localized option is to assign a language tag to non-text elements (images, 
simulations, etc.) to assist in identifying items that require additional editing after the course is 
translated.  

Images  

• In HP ART's Edit Image dialog box, check the Localized check box to indicate that 
the image is specific to the current language. For example, if an image contains 
English text, check the Localized check box so that it is tagged for updating. 
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Simulation page in course 

• In HP ART's Insert Simulation dialog box, check the Localized check box to indicate 
that the simulation is specific to the current language and you want to re-record it.  

 

Once the course is translated, the Localized language tag allows authors to identify pages 
that require additional edits. For example, if an image has English text that will require 
localization, the author checks the Localized check box on the Edit Image dialog box. After 
the course is translated, the author enables the Highlight steps with Non-Localized 
Elements filter using Tools>Options>Filters.  

 

 Copyright 2014 Hewlett-Packard Development Company, L.P. 
Page 10 of 72  SEP2014 



 
Translation and Localization Guide for HP ART 5.1 

 

When this filter is enabled, pages listed in the Course pane are highlighted if they require 
localization. The image below shows a translated course. The Service Desk Workflow image 
had the Localized checkbox selected in the English version. In the translated version, after the 
filter was enabled, the Course pane shows the exclamation highlight indicating this page 
requires additional edits. In this case, a new image should be added with the new language. 
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Guided Re-Record 
Use the guided Re-Record feature in HP ART when your target application has been localized 
and you want to capture new screen images using the same steps in the original simulation. 
The Re-Record feature creates a new HP ART simulation file (.UDC) and appends the file name 
with the selected language. The translated phrases from the HP ART template are used during 
the re-recording. In most cases, re-record will be the first step when doing a full localization. 
Information notes remain in English and can be translated with the XLIFF process. Timing of 
information notes may need to be adjusted, and the timing of action notes needs to be 
reestablished after all translation is complete.  

When you open an existing document and select Re-Record, a guide pane opens in the 
recorder preview pane to display the guide steps. Use the guide steps to help you re-create 
the required actions in the target language. 

Template Updates 
If you are going to create new courses and simulations in another language, you may want to 
change the following English text items to your desired language. These text items are in the 
ART template on the Blocks page.  

• Assessment Confirmation 

• Assessment Note 

• Footer 

• Header 

• Highlighted Info Note 

• Note Purpose 

• Quiz Me Note 

• Show Me Note 

• SME Note 

• Test Me Note 

• Try Me Note 
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Scenario 1: Phrases Only 
The graphic below shows a high-level overview of the Phrases Only scenario.  

 

Follow the steps below to translate specific text phrases identified in the ART template. 

Alternative: See the Appendix: Translate Phrases for One File for an alternative approach 
to pull in translated phrases for one file at a time.  

Create XLIFF Files 
1. Review the "Prepare File Hierarchy" section in this document and ensure your English 

ART source files are available.  
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2. With HP ART open, batch export the .ULC and .UDC files for a specific module by 
selecting File>Manage Content Language>Batch Export…. 
Note: For a single file, select File>Manage Content Language>Export.… 

 

3. In the Batch Export… dialog box:  

• Select the export language(s). 

• Complete the Export from: field with your source file location. 

• Complete the Export to: field with your desired output location –
exported_xliff_files. 

• Select an export option. The option Create XLIFF file and include 
screen titles exports the most text.  

  

 Copyright 2014 Hewlett-Packard Development Company, L.P. 
Page 14 of 72  SEP2014 



 
Translation and Localization Guide for HP ART 5.1 

• Click Export. 

 

4. The summary window shows the XLIFF files created. Note that each file name is 
appended with the word phrase and an abbreviation for the language selected.  
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5. Review the exported_xliff_files folder.  
A new folder for each file was created. In each folder is the XLIFF file for the 
associated language.  

NOTE: Do not change the folder structure or ART will not be able to import the 
updated XLIFF files. 

 

Import the Exported XLIFF Files and Create Translations 
The translated phrases from the HP ART template are imported during this process. 

1. Using the batch process, import the XLIFF files you just exported for a specific module 
by selecting File>Manage Content Language>Batch Import…. 
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2. In the Batch Import… dialog box:  

• Select the import language(s) 

• Complete the Import To: field with the file location for your new language 
source files. 

• Complete the Import from: field with the location of the exported XLIFF 
files. 

• Click Import. 
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3. The Importing summary lists the status of each file. Click OK.  
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4. To create the translated files, select File>Manage Content Language>Batch Create 
Translations…. 

 

5. In the Create Translations… dialog box: 

• Select the desired language(s). 

• Complete the Inbox: field with your source file location. 

• Complete the Outbox: field with the desired location of your new translated 
files – translated. 
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• Click Translate. 
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6. The Translation Summary dialog box is displayed. Note that each source file is 
matched with a new file that is appended with the abbreviation for the language 
selected. Click OK.  

 

7. Review the files created in the translated folder. A sub-folder is created for each file. 
The file name is appended with the language abbreviation.  
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8. Move the .UDC files into the same folder with the .ULC file. Delete the empty folders. 

 
 

9. Review the translated phrases in the simulation files. Below is an example of a 
simulation file with the Phrases Only translated. You will see that only the phrases are 
translated, while the author-entered content is in English.  
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10. Review the translated phrases in the course module file. Below is the launch dialog 
box showing the translated phrases. 
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Below is a course page showing the translated phrases. Notice that the GUI buttons 
and the title Summary are translated and the author entered content is in English. 

 

Attach Translated Job Aids and Update Simulation Links 
1. For each module, batch publish the translated simulation .UDC files to create PDF job 

aids. 

2. Use the Manage>Resources menu option to attach the translated job aids to the course 
module .ULC file.  

3. On each course module simulation page (including the Test Me), select Edit Simulation 
Properties link located in the lower right section of the page. 

4. In the Insert Simulation dialog box: 

• Change the Insert: field to Local. 

• Select the appropriate file in the Source file: list. 
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• Click Insert and the simulation will publish so that the most current file is 
attached. 

 

Conduct Quality Review 
1. Publish the course. 

2. Check all translated text to ensure that text is not cut-off or overlapping other content. 
This is particularly important in the simulation notes.  

3. Check the timing in all simulations and adjust as necessary.  

4. Check that the translated job aids are properly attached.  
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Scenario 2: All Text Content 
The graphic below shows a high-level overview of the All Text Content scenario. 

 

Follow the steps below to translate both the phrases and any author-entered content in the 
course modules and simulations. 

Create XLIFF Files 
1. Review the "Prepare File Hierarchy" section in this document and ensure your English 

ART source files are available.  

 Copyright 2014 Hewlett-Packard Development Company, L.P. 
Page 26 of 72  SEP2014 



 
Translation and Localization Guide for HP ART 5.1 

2. With HP ART open, batch export the .ULC and .UDC files for a specific module by 
selecting File>Manage Content Language>Batch Export…. 
Note: For a single file, select File>Manage Content Language>Export.… 

 

3. In the Batch Export… dialog box:  

• Select the export language(s). 

• Complete the Export from: field with your source file location. 

• Complete the Export to: field with your desired output location -- 
exported_xliff_files. 

• Select an export option. The option Create XLIFF file and include 
screen titles exports the most text.  
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• Click Export. 
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4. The summary window shows the XLIFF files created. Note that each file name is 
appended with the word phrase and an abbreviation for the language selected.  

 

 

5. Review the exported_xliff_files folder. 
A new folder for each file was created. In each folder is the XLIFF file for the 
associated language.  

NOTE: Do not change the folder structure or ART will not be able to import the 
updated XLIFF files. 
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Document Additional Content to Translate 
Several types of content are not extracted with the XLIFF file and need to be manually added 
to an Excel spreadsheet so that they can be translated. These items are: 

• Description and Module fields on the HP ART File>Properties>Properties page. 

• The copyright in the footer of the job aids. (This is stored in the HP ART template 
Blocks>Footer; may not require translation.) 

• Author-entered field descriptions in job aids. 

• If you are using the ART web site to deploy your content, include properties and titles 
used on the web site.  

• Text input examples in job aids. (May not require translation.) 

 

1. Create an Excel spreadsheet with a list of English terms and a column for the 
translation.  
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2. For all source files (both .ULC and .UDC), copy the properties (Description and 
Module) fields into the Excel spreadsheet. Keep in mind that some of the values may 
be duplicates and only need to be added to the sheet once. 

For the course module file .ULC properties, select File>Properties…>Properties: 
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For the simulation file .UDC properties, select File>Properties…>Properties: 
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Below is an example of what the in-progress spreadsheet may look like. 

 

3. For each simulation .UDC file, go to the Document view and locate tables that indicate 
text input. Copy the Description and Example: text into the Excel spreadsheet. 
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4. Open the HP ART template and copy the Footer copyright text into the Excel 
spreadsheet.  

 

Below is an example of what the spreadsheet may look like with entries prior to 
translation.  
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Send/Receive back XLIFF Files and the Excel sheet for Translation 
1. Send the XLIFF files and Excel spreadsheet to a translation company. 

2. Receive translated files from the translation company.  

3. Place the XLIFF files in the project hierarchy folder translated_xliff_files. 
NOTE: The files should be in the same folder structure as when they were exported, or 
ART will not be able to import the updated XLIFF files. 

Import the Translated XLIFF Files and Create Translations 
With the translated XLIFF files in the folder translated_xliff_files, complete the following: 

1. With HP ART open, batch import the XLIFF files for a specific module by selecting 
File>Manage Content Language>Batch Import…. 
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2. In the Batch Import… dialog box:  

• Select the import language(s). 

• Complete the Import To: field with your source file location. 

• Complete the Import from: field with the location of your translated XLIFF 
files – translated_xliff_files. 

• Click Import. 
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3. The Importing summary lists the status of each file. Click OK.  
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4. To create the translated files, select File>Manage Content Language>Batch Create 
Translations…. 

 

5. In the Create Translations… dialog box: 

• Select the desired language(s). 

• Complete the Inbox: field with your source file location. 

• Complete the Outbox: field with the desired location of your new translated 
files – translated. 
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• Click Translate. 
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6. The Translation Summary dialog box is displayed. Note that each file name is 
appended with the abbreviation for the language selected. Click OK.  

 

7. Review the files created in the translate folder. A sub-folder was created for each file. 
The file name is appended with the language abbreviation.  

 

  

 Copyright 2014 Hewlett-Packard Development Company, L.P. 
Page 40 of 72  SEP2014 



 
Translation and Localization Guide for HP ART 5.1 

8. Move the .UDC files into the same folder with the .ULC file. Delete the empty folders. 

 
 

Update Additional Translated Content Entered into Source Files 
1. Receive the translated Excel spreadsheet from the translation company. 

 

2. Copy the translated items to their appropriate locations in the newly translated files. 
Note: Ensure you are working with the source files that are appended with the 
language abbreviation.  

3. In simulation .UDC files, resize all bubbles to fit translated text. Adjust the Auto 
Playback timing if necessary. Ensure that the action notes are delayed so that they are 
not on the screen at the same time as the information note.  

4. Ensure that all text has been translated appropriately.  

Attach Translated Job Aids and Update Simulation Links 
1. For each module, batch publish the translated simulation .UDC files to create PDF job 

aids. 

2. Use Manage>Resources menu option to attach the translated job aids to the course 
module .ULC file. 
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3. On each course module simulation page (including the Test Me), select Edit Simulation 
Properties link located in the lower right section of the page.  

4. In the Insert Simulation dialog box: 

• Change the Insert: field to Local. 

• Select the appropriate file in the Source file: list. 

• Click Insert and the simulation will publish so that the most current file is 
attached. 

 
 

Conduct Quality Review 
1. Publish the course. 

2. Check all translated text to ensure that text is not cut-off or overlapping other content. 
This is particularly important in the simulation notes.  

3. Check the timing in all simulations and adjust as necessary.  

4. Check that the translated job aids are properly attached.  
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Scenario 3: Full Localization 
The graphic below shows a high-level overview of the Full Localization scenario. 

 

Follow the steps below to translate all of the text content and update the simulation images to 
your localized application. 

Use Guided Re-Record to Create New Simulations 
1. Prepare the target application so that you can create new simulations. Remember to 

change the resolution to 1024 x 768.  

2. In HP ART, open the current simulation file you need to re-record.  
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3. To start the re-record process, select File>Manage Content Language>Re-Record [file 
name]. 

 

4. In the Re-Record dialog box  

• Select the desired language from the Languages drop-down list. 

• Complete the Outbox: field with the desired location of your new translated 
files. 
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• Click Re-Record. 

 

5. Use the guide pane to help you re-create the required actions in the localized 
application.  
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6. After completing all of the steps, save the file. Notice that the file name is appended 
with the language abbreviation, and the phrases such as Show Me! and Try Me! are 
in the new language. The author-entered text will be translated with the XLIFF file.  

 

7. Repeat this process for all simulations.  

Create XLIFF Files 
1. Review the "Prepare File Hierarchy" section in this document and ensure your ART 

source files are available.  
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2. In the course module file, click the Localized check box in the Edit Image… dialog 
box for images that contain English text and require localization. Save and close the 
file. 

 

3. With HP ART open, batch export the .ULC and .UDC files for a specific module by 
selecting File>Manage Content Language>Batch Export…. 
Note: For a single file, select File>Manage Content Language>Export.… 
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4. In the Batch Export… dialog box:  

• Select the export language(s). 

• Complete the Export from: field with your source file location. 

• Complete the Export to: field with your desired output location –
exported_xliff_files. 

• Select an export option. The option Create XLIFF file and include 
screen titles exports the most text.  

• Click Export. 
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5. The summary window shows the XLIFF files created. Note that each file name is 
appended with the word phrase and an abbreviation for the language selected. 

 

 

 

6. Review the exported_xliff_files folder.  
A new folder for each file was created. In each folder is the XLIFF file for the 
associated language.  

NOTE: Do not change the folder structure or ART will not be able to import the 
updated XLIFF files.   
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Document Additional Content to Translate 
Several types of content are not extracted with the XLIFF file and need to be manually added 
to an Excel spreadsheet so that they can be translated. These items are: 

• Description and Module fields on the HP ART File>Properties>Properties page. 

• The copyright in the footer of the job aids. (This is stored in the HP ART template 
Blocks>Footer; may not require translation.) 

• If you are using the ART web site to deploy your content, include properties and titles 
used on the web site on the Excel spreadsheet. 

• Author-entered field descriptions in job aids. 

• Text input examples in job aids. (May not require translation.) 

 

1. Create an Excel spreadsheet with a list of English terms and a column for the 
translation.  
Optional: You may want to include a column for Notes that could include file names 
and location of text, to make it easier to find where to insert the translated text.  
 

 

 

2. For all source files (both .ULC and .UDC), copy the properties (Description and 
Module) fields into the Excel spreadsheet. Keep in mind some of the values may be 
duplicates and only need to be added to the sheet once. 
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For the course file .ULC properties, select File>Properties…>Properties: 
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For the simulation file .UDC properties, select File>Properties…>Properties: 

 

Below is an example of what the in-progress spreadsheet may look like. 
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3. For each simulation .UDC file, go to the Document view and locate tables that indicate 
text input. Copy the Description and Example: text into the Excel spreadsheet. 

 

  

 Copyright 2014 Hewlett-Packard Development Company, L.P. 
SEP2014  Page 53 of 72 



 

Translation and Localization Guide for HP ART 5.1 

4. Open the HP ART template and copy the Footer copyright text into the Excel 
spreadsheet.  

 

Below is an example of what the spreadsheet may look like with entries prior to 
translation.  
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Send/Receive back XLIFF Files and the Excel sheet for Translation 
1. Send the XLIFF files and Excel spreadsheet to a translation company. 

2. Receive translated files from the translation company.  

3. Place the XLIFF files in the project hierarchy folder translated_xliff_files. 
NOTE: The files should be in the same folder structure as when they were exported or 
ART will not be able to import the updated XLIFF files. 

Import the Translated XLIFF File and Create Translations 
With the translated XLIFF files in the folder translated_xliff_files, complete the following: 

1. With HP ART open, batch import the XLIFF files for a specific module by selecting 
File>Manage Content Language>Batch Import…. 
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2. In the Batch Import… dialog box:  

• Select the import language(s). 

• Complete the Import To: field with your source file location. 

• Complete the Import from: field with the location of your translated XLIFF 
files – translated_xliff_files. 

• Click Import. 
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3. The Importing summary lists the status of each file. Click OK.  
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4. To create the translated files, select File>Manage Content Language>Batch Create 
Translations…. 

 

5. In the Create Translations… dialog box: 

• Select the desired language(s). 

• Complete the Inbox: field with your source file location. 

• Complete the Outbox: field with the desired location of your new translated 
files – translated. 
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• Click Translate. 
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6. The Translation Summary dialog box is displayed. Note that each file name is 
appended with the abbreviation for the language selected. Click OK.  

 

7. Review the files created in the translate folder. A sub-folder was created for each file. 
The file name is appended with the language abbreviation.  
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8. Move the .UDC files into the same folder with the .ULC file. Delete the empty folders. 

 
 

Update Additional Translated Content Entered into Source Files 
1. Receive the translated Excel spread sheet from the translation company. 

 

2. Copy the translated items to their appropriate location in the newly translated files. 
Note: Ensure you are working with the source files that are appended with the 
language abbreviation.  

3. In simulation .UDC files, resize all bubbles to fit translated text. Adjust the Auto 
Playback timing if necessary. Ensure that the action notes are delayed so that they are 
not on the screen at the same time as the information note.  

4. Ensure that all text has been translated appropriately.  
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Update Images Tagged as Localized 
1. With the translated course module file open, enable the filter Highlight steps 

with Non-Localized Elements filter using Tools>Options>Filters. This highlights 
the pages with the Localized option selected. 

 

2. Review any page with an exclamation highlight in the Course pane. 

 

3. Add the updated images to the pages.  
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Attach Translated Job Aids and Update Simulation Links 
1. For each module, batch publish the translated simulation .UDC files to create PDF job 

aids. 

2. Use Manage>Resources menu option to attach the translated job aids to the course 
module .ULC file. 

3. On each course module simulation page (Including the Test Me), select Edit Simulation 
Properties located in the lower right section of the page. 

4. In the Insert Simulation dialog box: 

• Change the Insert: field to Local. 

• Select the appropriate file in the Source file: list. 

• Click Insert. The simulation is published so that the most current file is attached. 

 
 

Conduct Quality Review 
1. Publish the course. 

2. Check all translated text to ensure that text is not cut-off or overlapping other content. 
This is particularly important in the simulation notes.  

3. Check the timing in all simulations and adjust as necessary.  

4. Check that the translated job aids are properly attached.  
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Appendix  
Translate Phrases for One File 
You can apply the translated boilerplate phrases in the ART template to a specific language 
one file at a time instead of using the batch publish process shown in Scenario 1. This method 
DOES NOT translate the following: 

• Custom text 

• Screenshot titles/contents 

• Images (screenshots, buttons, etc.) 

• Custom note text 

The example below uses the art5_02_service-desk_sm9-30.udc file and translates the 
ART phrases to German. 

1. Open your desired ART file in the ART editor. 

2. Use File>Save As… to save the file under a new name. When asked if you want to 
save the file with a new ID, select Yes. A best practice is to append the file name with 
the new language. For this example, german, is added to the end of the file name.  

 

3. Open the Properties dialog box by selecting File>Properties.... 
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4. Select the desired output language using the Language drop-down box. In this 
example, Deutsch is selected for German.  

 

5. Click OK.  
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6. After the phrases are applied any page that has an item with the Localized check box 
selected in Properties will have the exclamation icon indicated addition editing is 
required. In this example, this is indicating that the simulation still requires translation.  

 

8. Publish and view the .ULC file.  

9. Notice the phrases translated in the Launch dialog box.  
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7. Launch the module and notice the phrases, including the GUI buttons that have been 
translated.  
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Export Template Phrases 
To view a list of the translated boilerplate phrases, export the template phrases to an XLIFF 
file. This process is similar to exporting the .UDC or .ULC file.  

1. With HP ART open, open the HP ART template (ART5-11 HP ART Templatev1.udt) or 
your customized template by selecting File>Open>Template.  

1. Ensure that all languages are enabled on the General tab, Languages page. 

2. In the menu, select File>Manage Content Language>Export [Template 
name].udt. 

3. Select the desired output languages. 

 

4. Complete the Export to: field with your desired output location. 
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5. Click Export. 

6. The export summary is displayed. Open one of the exported XLIFFs (such as Spanish). 
You may open the XLIFF file in applications such as Excel or Notepad, or an XLIFF 
editor. 
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7. View and compare the languages from the source language to the target language. 
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Export Audio Transcript 
If you have added audio to your course, the audio transcript is included in the XLIFF files if the 
Localized check box is selected in the Audio tab. It must be checked for each page that has 
audio. 
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