
 

 

User Manual 

Adoption Readiness Tool 

Creating Content 

Version 5.30.1 

Revision I/March 2016 

 

 

 



PROPRIETARY RIGHTS NOTICE 

This user manual contains proprietary and confidential information of ANCILE Solutions, Inc. This manual is 
furnished under license only for the use and information of the licensee, and the content is subject to change 
without notice. Use of the contents of this manual for any purpose other than that for which it was provided is 

prohibited. This manual may not be reprinted or redistributed to any third party without the prior written 
consent of ANCILE Solutions, Inc. ANCILE Solutions, Inc. does not warrant or guarantee the contents of this 

user manual. 

ANCILE uPerform®, ANCILE uLearn™, ANCILE Info Pak™, ANCILE uAlign™, and ANCILE uBenchmark™ 
are registered trademarks of ANCILE Solutions, Inc. in the U.S. and foreign countries. All other product and 
company names referenced herein are the registered or unregistered trademarks of their respective owners. 

Your ART Enterprise Learning Edition Tool (ART) is built on a tool called ANCILE uPerform®, which is 
developed by ANCILE Solutions. Throughout your ART Author product, you will see the term "Powered by 
ANCILE Solutions™" and, throughout your documentation, you may see references to both ANCILE and 

uPerform. You may also see screen shots that include uPerform in the graphic rather than as it displays on 
your screen as ART. The terms ART and uPerform are, for the case of this documentation only, 

interchangeable. Any time you see uPerform or uPerform Author, you can substitute ART or ART Author. For 
example, if you see a direction to "Open the uPerform Content" you should instead "Open the ART Content" . 

 

 

  

 

 

 

 

COPYRIGHT © 2016 ANCILE Solutions, Inc. and Hewlett-Packard Enterprise Development Company, L.P. 
ALL RIGHTS RESERVED 

 

 

 





Table of Contents 

 

i 

 

Contents 

Chapter 1: Introduction............................................................................. 1 

What is Adoption Readiness Tool? .............................................................................................. 2 
About This Manual ................................................................................................................... 2 
Who Should Read This Manual ............................................................................................... 2 
Organization Of This Manual .................................................................................................. 3 

Conventions Used In This Manual ............................................................................................... 4 

Terminology Used In This Manual .......................................................................................... 5 
Available Technical Support ........................................................................................................ 6 

Chapter 2: Getting Started ........................................................................ 7 

Confirming the Required Hardware and Software ....................................................................... 8 

Installation .................................................................................................................................... 9 
Overview of the Editor Installation .......................................................................................... 9 
Installation Parameters and Properties ..................................................................................... 9 

Running the Install with a setup.ini File ................................................................................ 14 
Running the .msi File Directly ............................................................................................... 14 

Installing the Editor Software - Express ................................................................................ 15 

Implementing with Citrix ....................................................................................................... 15 

Starting the Editor ...................................................................................................................... 17 
Using the Quick Start Panel ....................................................................................................... 18 
Managing Your Editor Configuration Settings .......................................................................... 20 

Getting Help on the Editor ......................................................................................................... 27 
Exiting ........................................................................................................................................ 28 

Uninstalling ................................................................................................................................ 29 
Upgrading from a Previous Version........................................................................................... 30 

Chapter 3: Exploring the Editor Workspace ......................................... 31 

Introduction to the Editor Workspace ........................................................................................ 32 

Overview of the Content Area and Task Pane ....................................................................... 32 

Using Right-Click Menus....................................................................................................... 34 

Using the Content Area .......................................................................................................... 35 

Chapter 4: Creating and Opening Content ............................................ 37 

Introduction to Creating and Opening Content .......................................................................... 38 
Specify Document and Simulation Editor Options .................................................................... 39 
Specify Course Editor Options ................................................................................................... 45 
Creating Content ........................................................................................................................ 46 



Table of Contents 

 

ii 

 

Open Content .............................................................................................................................. 49 

Opening Content .................................................................................................................... 49 

Chapter 5: Recording Procedural Content ............................................ 51 

Introduction to Recording Procedural Content .......................................................................... 52 
Preparing to Record .................................................................................................................... 53 

Preparing Your Computer ...................................................................................................... 53 

Starting the Recorder .................................................................................................................. 54 
Displaying the Recorder Preview Pane .................................................................................. 56 
Preparing Your Data ............................................................................................................... 56 

Capturing Controls ..................................................................................................................... 57 
Specifying Recorder Tuning Options ......................................................................................... 59 

Using the Screen Percent Differential Feature ........................................................................... 61 
Using Image Mode ..................................................................................................................... 62 

Using Undo and Redo ................................................................................................................ 63 
Minimizing the Recorder Window ............................................................................................. 64 

Recording Audio ........................................................................................................................ 65 
Using Notes in the Recorder ...................................................................................................... 66 
Pausing and Stopping the Recorder ........................................................................................... 67 

Chapter 6: Managing Content Languages ............................................. 69 

Introduction to Managing Content Languages ........................................................................... 70 
Creating Translated Documents ................................................................................................. 71 

Using Guided Re-Record Functionality ..................................................................................... 79 

Re-Record Prerequisites: Before You Get Started ..................................................................... 80 
Re-Record Scenarios .................................................................................................................. 81 

Scenario 1: Translating Before Re-Record ............................................................................ 81 

Scenario 2: Translating After Re-Record ............................................................................... 81 
Scenario 3: Using Translation and Guided Re-Record in Parallel ......................................... 82 

What Happens During Guided Re-Record? ............................................................................... 83 
Exporting, Importing, and Applying XLIFF Translations ..................................................... 85 

Chapter 7: Editing and Formatting: Basics ........................................... 91 

Introduction to Editing and Formatting: Basics ......................................................................... 92 
Specify Content Properties ......................................................................................................... 93 

Using Undo and Redo During Editing ....................................................................................... 96 
Using Spellcheck ........................................................................................................................ 97 

Using Save ................................................................................................................................ 100 
Using Save As .......................................................................................................................... 101 
Printing ..................................................................................................................................... 102 
Closing ..................................................................................................................................... 103 

Chapter 8: Editing and Formatting: Procedural Content ................... 105 



Table of Contents 

 

iii 

 

Introduction to Editing and Formatting: Procedural Content ................................................... 106 

Inserting Standard Simulation Objects ..................................................................................... 107 
Inserting a Highlighted Note ................................................................................................ 110 

Editing Standard Simulation Objects ....................................................................................... 115 
Editing Steps ........................................................................................................................ 115 
Editing Notes ........................................................................................................................ 122 

Editing a Note: Style ............................................................................................................ 126 
Editing Actions ..................................................................................................................... 129 

Using Document Sections ........................................................................................................ 140 
Editing Document Sections .................................................................................................. 141 
Inserting Objects in Document Sections .............................................................................. 142 

Editing Objects in Document Sections ................................................................................. 147 

Modifying Paragraphs .......................................................................................................... 153 

Modifying Characters ........................................................................................................... 154 
Working With Images, Masks, and Callouts ............................................................................ 155 

Working with Images ........................................................................................................... 156 
Viewing an Image Mask ...................................................................................................... 157 

Creating an Image Mask ...................................................................................................... 158 
Editing an Image Mask ........................................................................................................ 159 

Copying and Pasting an Image Mask ................................................................................... 160 
Deleting an Image Mask ...................................................................................................... 161 
Working with Callouts ......................................................................................................... 161 

Generating the Exercise Section .............................................................................................. 165 
Required Data Table ............................................................................................................. 165 

Tasks Section ........................................................................................................................ 165 
Change the Language of Default Text ..................................................................................... 167 

Changing the Language of Default Text .............................................................................. 167 
Working with the Screenflow .................................................................................................. 168 

Chapter 9: Editing and Formatting: Courses ...................................... 171 

Introduction to Editing and Formatting: Courses ..................................................................... 172 

Working with Lessons .............................................................................................................. 174 
Working with Pages ................................................................................................................. 177 

Displaying Answers From Another Page ............................................................................. 180 
Working with Flexible Stencils ................................................................................................ 182 
Editing Course Content ............................................................................................................ 186 

Managing Resources, Embedded Simulations, and Images ..................................................... 188 
Using Images ............................................................................................................................ 191 

Using Page Transitions ............................................................................................................. 193 
Using Animations ..................................................................................................................... 197 
Editing Interaction Pages ......................................................................................................... 204 
Importing Microsoft PowerPoint Content ................................................................................ 211 
Using Hotspots, Popups, and Links ......................................................................................... 217 

Insert Published Simulations and Course Content ................................................................... 222 
Working with Flash Content .................................................................................................... 226 



Table of Contents 

 

iv 

 

Using Audio Files ..................................................................................................................... 228 

Using Text to Speech ............................................................................................................... 233 
Using Video Files ..................................................................................................................... 235 
Working with Assessment Sections, Self-Tests, and Branches ............................................... 239 

Creating Custom Assessment Feedback for a Page ............................................................. 242 
Working with Branches ........................................................................................................ 245 

Chapter 10: Editing and Formatting: Student Guides and Course 
Packages ............................................................................................... 251 

Introduction to Editing and Formatting Student Guides and Course Packages ....................... 252 

Working With a Student Guide ................................................................................................ 253 

Working with Course Packages ............................................................................................... 257 

Chapter 11: Searching Content ............................................................ 261 

Introduction to Searching ......................................................................................................... 262 

Searching Within Content ........................................................................................................ 263 

Chapter 12: Using the Glossary ........................................................... 267 

Introduction to the Glossary ..................................................................................................... 268 

Create the Glossary .................................................................................................................. 269 
Open and Save the Glossary ..................................................................................................... 271 
Adding Terms and Definitions ................................................................................................. 272 

Updating Terms and Definitions .............................................................................................. 273 

Browsing the Glossary ............................................................................................................. 274 
Using Globalize ........................................................................................................................ 275 
Publish the Glossary ................................................................................................................. 277 

Integrating a Published Glossary into the Website .............................................................. 278 
Export a Glossary File .............................................................................................................. 279 

Chapter 13: Using Annotations ............................................................ 281 

Introduction to Annotations ..................................................................................................... 282 
Viewing Annotations ................................................................................................................ 283 
Creating, Viewing, and Hiding Annotation Sets ...................................................................... 285 
Managing Annotation Sets ....................................................................................................... 288 

Managing Annotation Notes .................................................................................................... 291 

Chapter 14: Using Custom Skins and Modifying CSS Files ............... 293 

Creating and Customizing Skins .............................................................................................. 294 

Creating Skins .......................................................................................................................... 295 
Managing Custom Skins .......................................................................................................... 296 
Guidance on Modifying Cascading Style Sheets ..................................................................... 297 

Chapter 15: Previewing and Publishing Content ................................ 301 



Table of Contents 

 

v 

 

Introduction to Previewing and Publishing Content ................................................................ 302 

Overview of Document Publishing ...................................................................................... 302 
Overview of Simulation Publishing ..................................................................................... 303 
Overview of Course Publishing ........................................................................................... 304 
Overview of Student Guide Publishing ................................................................................ 304 
Overview of Course Package Publishing ............................................................................. 304 

Overview of Guided Help Publishing .................................................................................. 304 
Previewing a Simulation .......................................................................................................... 305 
Previewing a Course ................................................................................................................. 306 
Publishing Content ................................................................................................................... 307 
Viewing and Working with Published Content ........................................................................ 310 

Viewing Documents ............................................................................................................. 310 

Viewing Simulations ............................................................................................................ 311 

Viewing Courses .................................................................................................................. 313 
Viewing Student Guides and Course Packages .................................................................... 314 
Viewing Simulations on the Apple iPad .............................................................................. 315 
Viewing Guided Help ........................................................................................................... 315 

Chapter 16: Using Author Templates .................................................. 317 

Introduction to Author Templates ............................................................................................ 318 
Managing Author Templates .................................................................................................... 319 

Create and Open a New Author Template ........................................................................... 319 
Specifying New Template Settings: General ....................................................................... 321 
Specifying New Template Settings: Properties .................................................................... 328 

Specifying New Template Settings: Phrases ........................................................................ 331 

Specifying New Template Settings: Publications ................................................................ 333 
Specifying New Template Settings: Styles .......................................................................... 375 
Specifying New Template Settings: Blocks ......................................................................... 382 

Specifying New Template Settings: Sections ...................................................................... 385 
Export and Import an Author Template ................................................................................... 389 
Delete an Author Template ...................................................................................................... 392 

Chapter 17: Building a Website ............................................................ 393 

Introduction to the Website ...................................................................................................... 394 
Create the Website ................................................................................................................... 395 

Exploring the Website Editor ............................................................................................... 395 
Planning and Designing the Website ................................................................................... 396 
What Can My Website Include? .......................................................................................... 396 
Page and Link Limits ........................................................................................................... 397 

Open and Save the Website ...................................................................................................... 399 

Building the Website Structure Manually ................................................................................ 400 
Create and Edit Pages ........................................................................................................... 400 

Adding Content to the Website ................................................................................................ 403 
Add and Edit Content Links ................................................................................................. 403 



Table of Contents 

 

vi 

 

Populating the Website Structure Automatically ..................................................................... 408 

Viewing Website Properties ..................................................................................................... 410 
Set Link List Details ............................................................................................................. 411 

Refreshing the Website ............................................................................................................ 413 
Publishing the Website ............................................................................................................. 414 
Batch Publish Process .............................................................................................................. 416 

Navigate the Website ............................................................................................................... 418 
Overview of Navigation Pages ............................................................................................. 418 
Overview of Content Pages .................................................................................................. 418 

Making Your Website Available to End Users ........................................................................ 420 
Overview of the Website Directory Structure ...................................................................... 420 

Directory Structure Details ................................................................................................... 421 

Transferring Your Website to a Server ................................................................................ 422 

Chapter 18: Creating Online Help ........................................................ 423 

Introduction to Creating Online Help....................................................................................... 424 

Types of Help Available ...................................................................................................... 424 
Enabling Online Help ............................................................................................................... 433 

Enabling Help in the SAP R/3 and APO Environments ...................................................... 433 

Limitations When Providing Help in the SAP SRM and Enterprise Portal Environments . 434 
Enabling Help in the SAP SRM Environment ..................................................................... 434 

Configuring SAP Portal for Use with Context-Sensitive Help ................................................ 436 
Setting the Help URL Using the PCD Inspector ...................................................................... 443 
Configuring SAP SRM 4-6 for Use with Context-Sensitive Help ........................................... 445 

Enabling Help for SAP CRM ............................................................................................... 448 

Publishing the Website ......................................................................................................... 450 
Enabling Help for Oracle E-Business .................................................................................. 454 
Publishing the Website ......................................................................................................... 456 

Context-Sensitive Help for Siebel ............................................................................................ 462 
Creating a Siebel Custom Menu and Publishing the Website .............................................. 462 
Publishing the Website ......................................................................................................... 464 

Creating Content and Requesting Help ................................................................................ 465 
Configuring PeopleSoft for Use with Context-Sensitive Help ................................................ 467 

Appendix A: Configuring Java Access Bridge for Recording ........... 471 

Glossary of Terms ................................................................................. 473 

Index ...................................................................................................... 481 

  



 

1 

 

Chapter 1: Introduction 

Adoption Readiness Tool provides authors with a robust content 

development environment to expedite your development and delivery 

of training materials. 
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What is Adoption Readiness Tool? 

The Adoption Readiness Tool application is a content development and delivery tool designed to 

enable authors to create documents, simulations, and eLearning courses. The ART recording 

functionality allows authors to capture screens, buttons, fields, and other data as the author 

completes a task. Via one automated recording session, ART creates a dual-function, single-

source document that is both a step-by-step procedural document and an interactive simulation. 

Authors can produce a variety of document output types and simulation playback modes. 

Published content can support classroom training, performance support websites, and online help. 

HTML output is particularly well-suited to provide context-sensitive help, and simulations of the 

target application and actual scenarios are a useful component of realistic training programs. 

In addition to recording, authors can use the re-recording functionality to automatically repeat the 

steps made during an initial recording in a supported SAP environment. Re-recording makes 

modifications to the original recording by substituting author-provided values and translations for 

the original content and can be repeated for all application-supported languages. 

Authors can also rapidly produce eLearning courses. Courses can be published to a performance 

support website or to a Learning Management System (LMS). The LMS delivery method is well-

suited for standardizing and delivering training courses for business-specific processes. 

In order to deliver published content to end users, there is functionality that allows for easy 

creation and management of a performance support website. 

 

About This Manual 

This manual provides details regarding the authoring of content and the creation of a glossary and 

a performance support website. 

 

Who Should Read This Manual 

This manual includes overview information and step-by-step procedures for content authors who 

develop documentation for end users. Authors have the following rights and responsibilities: 

 Create and edit documents, simulations, eLearning courses, course packages, 

and student guides. 
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Organization Of This Manual 

This manual contains information intended for content authors. This manual also contains a 

glossary with terms and definitions relevant to the concepts discussed within this manual. 
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Conventions Used In This Manual 

The following conventions are used in this manual: 

Style Description 

Bold Indicates a field name, button name, or an option. 

Example: 

Click General on the left pane. 

Italic Indicates a screen or window title. 

Example: 

The Step Properties window is displayed. 

SMALL CAPS AND 

GREATER THAN SYMBOL 

(>) 

Indicates a menu path. 

Example: 

Select FILE > SAVE AS. 

 

Indicates an important concept or a caution. 

 

Indicates a helpful hint or amplifying information. 
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Terminology Used In This Manual 

The following conventions are used in this manual: 

Product Term(s) Usage 

ART Editor These terms represent the Desktop application 

of the ART software. The Editor application is 

where authors record, create, and edit 

documents. 

 

Hewlett Packard 

Enterprise 

Development LP Rapid 

Recorder 

Rapid Recorder, RR These terms represent the standalone 

recording application of the ART software. 

ART Document Documents, Output Types These represents the different output types 

available in the ART software Editor such as 

BPP, configuration document, course, cue 

card, exercise, quick reference, simulation, 

student guide, simulation, and work 

instruction.  
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Available Technical Support 

In addition to the online help delivered with the application, there are several additional support 

mechanisms: 

 The Product Support Center available at http://softwaresupport.hp.com/. 

 Optional instructor-led training. For additional information about our training 

services, contact your sales representative. 
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Chapter 2: Getting Started 

The Editor has several hardware and software requirements for 

installation and operation. 

After installation, you can access features via a Quick Start panel and 

obtain online help via the Editor. 
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Confirming the Required Hardware and Software 

Your environment must meet minimum hardware and software specifications to install and 

operate the application. A complete set of hardware and software requirements can be found in the 

Technical Specifications. 
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Installation 

Overview of the Editor Installation 

The Editor installation is delivered as a single file wrapper or, in the Microsoft terminology, 

bootstrapper executable. The bootstrapper executable contains the Editor Microsoft Installer 

package (the .msi file) and the redistributable packages for various prerequisites. When the install 

is executed, a check is performed to ensure that the following prerequisites are installed on the 

computer: 

 Capturing Engine by ANCILE Solutions 

 ANCILE JRE Configuration Utility 

 Microsoft .NET Framework (required for JSharp to install) 

 Microsoft Visual C++ Redistributable 

 MSXML 

 Visual JSharp .NET Redistributable Package 

 Windows Automation API 

 Windows Imaging Component (requirement for .NET) 

 Windows Installer 

 
For required versions of the above software, refer to the Technical Specifications. 

If a prerequisite is not present on the target computer, the installation extracts the pertinent 

Microsoft redistributable package to a local source folder and executes the package automatically. 

After all prerequisite conditions are met; the Editor Microsoft Installer package is extracted to a 

temporary folder and executed. 

 

Installation Parameters and Properties 

The parameters described in the following table can be used when running the delivered 

installation executable. Some of these properties exist in the .msi file and their defined value is 
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used when the .msi file is run. Others are parameters that are passed to the Windows Installer 

service to control whether a log file is created or how much of the user interface is displayed. 

Property Name Possible Value(s) Usage Example/Description 

COMPANY 

NAME 

The value for this field is 

provided and is the company 

name under which Adoption 

Readiness Tool was licensed. 

COMPANYNAME="Hewlett Packard 

Enterprise Development LP" 

When passed on the command line to the 

setup package, the value should be 

wrapped in quotation marks if it contains 

spaces. 

This property populates the "Company 

Name" field on the Customer 

Information dialog. 

PRODUCT_ID The value for this field is 

provided. 

PRODUCT_ID=XXXXXX-XXXXXX-

XXXXXX-XXXXXX-XXXXXX-

XXXXXX 

This property populates the "Product 

Key" field on the Customer Information 

dialog. 

APP_ 

DESKTOP_ 

SHORTCUT 

1 or "" (null) Any non-null value will set the option to 

create a desktop shortcut for the 

application. 

To turn off the creation of a desktop 

shortcut, pass: 

APP_DESKTOP_SHORTCUT=\

"\". 

The default value of this property is 1. 

INSTALLDIR 
 

INSTALLDIR=C:\Program 

Files\[applicationdirectory]\ 

Defines the folder path where the 

application will be installed. A trailing 

backslash should be included. 

When passed on the command line to the 

setup package, the value should be 

wrapped in quotation marks if the path 

contains spaces. 
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Property Name Possible Value(s) Usage Example/Description 

INSTALL_ 

LANGUAGE 

 

ISO Codes are case-sensitive. 

Bulgarian (bg-BG) 

Catalan (ca-ES) 

Chinese (zh-CN) 

Chinese - Taiwan (zh-TW) 

Croatian (hr-HR) 

Czech (cs-CZ) 

Danish (da-DK) 

Dutch - Netherlands (nl-NL) 

Dutch - Belgium (nl-BE) 

English - US (en-US) 

English - UK (en-GB) 

Finnish (fi-FI) 

French - Canada (fr-CA) 

French - France (fr-FR) 

German (de-DE) 

Greek (el-GR) 

Hungarian (hu-HU) 

Indonesian (id-ID) 

Italian (it-IT) 

Japanese (ja-JP) 

Korean (ko-KR) 

Norwegian (nb-NO) 

Polish (pl-PL) 

Portuguese - Portugal (pt-PT) 

Portuguese - Brazil (pt-BR) 

Romanian (ro-RO) 

Russian (ru-RU) 

Spanish - Spain (es-ES) 

Swedish (sv-SE) 

Thai (th-TH) 

Turkish (tr-TR) 

INSTALL_LANGUAGE=en-US 

This property sets the default user 

interface language for the Editor 

application. 

Note: This selection does not change the 

user interface for the setup program. 

 

Parameter Name Usage Example/Description 

/s : silent mode Setup.exe/s 

Running the install executable in silent mode suppresses the 

initialization dialog and launches any needed pre-requisites 

in silent mode. 

To run the full install silently, use Setup.exe/s/v"/qn" 
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Parameter Name Usage Example/Description 

/v : pass arguments to Msiexec setup.exe /v"/l*v c:\test.log MYPROPERTY1=\"value1\" 

/qb" 

Use the /v option to pass command-line options and values 

of public properties through to Msiexec.exe.  

Note that as shown above, when you want to specify that a 

double quote character is not a delimiter for the command 

line but a delimiter for the property, use \" 

/a : administrative installation The /a option causes the installation executable to perform an 

administrative installation. An administrative installation 

copies (and uncompresses) your data files to a directory 

specified by the user, but it does not create shortcuts, register 

COM servers, or create an uninstallation log.  

If you want to extract the pre-requisites from setup.exe, add 

a path after the /a parameter to extract the prerequisites to 

that location.  Do not use a trailing backslash.  A sample 

command is: 

setup.exe /a"C:\temp" 

/b: cache installation locally With the /b option, the user can specify the directory in 

which to cache the installation files.  If you want to extract 

the MSI from setup.exe, specify the path after the /b 

parameter to extract the prerequisites to that location.  Do not 

use a trailing backslash.  A sample command is: 

setup.exe /b"C:\temp" 

/w : wait setup.exe /w 

The /w option forces the installation executable to wait until 

the installation is complete before exiting. 

/x : uninstall mode The /x option causes the installation executable to uninstall a 

previously installed product. 
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Parameter Name Usage Example/Description 

/L /L*v C:\test\install.log 

"/L" is the standard Windows Installer parameter used to 

ensure a log is created. 

This set of parameters would create a verbose log file with 

all available information using the filename install.log in the 

C:\test folder. 

Possible values include: 

i - Status messages 

w - Nonfatal warnings 

e - All error messages 

a - Start up of actions 

r - Action-specific records 

u - User requests 

c - Initial UI parameters 

m - Out-of-memory or fatal exit information 

o - Out-of-disk-space messages 

p - Terminal properties 

v - Verbose output 

x - Extra debugging information 

+ - Append to existing log file 

! - Flush each line to the log 

* - Log all information, except for v and x options 

/q [n|b|r|f][+|-][!] Use any of the standard Windows Installer display option 

values. Windows Installer runs in full UI mode (/qf) by 

default. 

If you use any of the values other than "full UI" you must 

define values for the properties listed above in order for the 

install to succeed. 

Possible values include: 

/qn - no UI 

/qb - basic UI 

/qr - reduced UI 

/qf - full UI 

/qb+ basic UI with modal dialog at the end 

/qb- basic UI without a modal dialog at the end 

Use the ! parameter to suppress the Cancel button 

 

For more information about Windows Installer command line parameters, refer to the Microsoft 

Website at http://msdn.microsoft.com/en-us/library/Aa367988.aspx 

http://msdn2.microsoft.com/en-us/library/Aa367988.aspx. 

These parameters can be used either in a setup.ini file or passed via the command line. When used 

in a setup.ini file, each parameter should be on a separate line in the file. If you pass the /v 

http://msdn2.microsoft.com/en-us/library/Aa367988.aspx
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parameter at the command prompt when launching Setup.exe, any parameters that are specified 

for the CmdLine keyname in Setup.ini are ignored. 

The proper format for the file data is VariableName=value. Do not include a space before or 

after the '=' sign. 

Supported parameters are indicated by a Project Type of "Basic MSI." 

 

Running the Install with a setup.ini File 

If you are using a setup.ini file, you must run the installation with a special command line switch - 

/m=setup.ini. For example: 

setup.exe /m=setup.ini 

The installation (the .exe file) has only two user interface elements: an initial splash screen and a 

possible error message as described previously. The .msi file has a full user interface typically 

seen in an installation package. The QUIET parameter defined previously controls the user 

interface level of the .msi file. To set the .exe file to have no user interface (that is, hide the splash 

screen and any error messages), the .exe file must be run with a "/s" command line switch. For 

example: 

setup.exe /s 

To set the .msi to have no user interface when run from within the .exe file, the QUIET parameter 

must be used. All properties must be defined because the .msi will run without a user interface. 

The parameters also may be used from the command line directly. In general, spaces are used to 

separate the parameters on the command line. Since some values may contain spaces, those 

particular values should be wrapped in double-quote marks. The preceding table identifies to 

which parameters this applies. 

If you use the /S or /M switches that pertain to the .exe file, they must precede any of the other 

parameters on the command line. 

 

Running the .msi File Directly 

There are other parameters that can be used when using Windows Installer. These parameters are 

not covered here and are not supported by the installation package (the .exe file). To use these 

parameters, or if you would prefer to run the .msi file directly, the .msi file and the prerequisite 

redistributables can be extracted to a local folder via an Administrative install. For example: 

setup.exe /a"C:\uncompressed\prqs" /s /v"/qn TARGETDIR=\"c:\uncompressed\msi"" 

If you choose to run the .msi file directly, all prerequisites should be installed prior to the Editor 

application. 
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Installing the Editor Software - Express 

1. Insert the installation CD or navigate to the location of the setup.exe file. 

2. If necessary, double-click on the .exe file to begin the installation. 

3. Click Next. 

4. Complete the following information: 

Field Description 

Company Name Enter your company or organization name delivered 

with the software. This value should be entered 

exactly as provided. 

Product Key Enter the product key delivered with the software. 

This value should be entered exactly as provided. 

5. Click Next. 

6. Optionally, select Browse to specify a destination folder other than the default. 

7. Optionally, select the Client checkbox to create a desktop shortcut for the application. 

8. Click Next. 

9. Select the desired interface language from the drop-down list. 

10. Click Next. 

11. Click Install. 

12. Click Finish. 
 

Implementing with Citrix 

If you are planning to use the application in a Citrix environment, perform the following 

procedure to ensure a smooth implementation: 

1. Close the Editor. 

2.  Locate your current ART resources directory. (Example: START > PROGRAMS >ART > 

ART RESOURCES). 
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3. Note the templates directory. The default location is: 

C:\Users\[username]\AppData\Roaming\[applicationdirectory]\version X.xx\templates. 

4. Navigate to the client program files. The default location is: C:\Program 

Files\[applicationdirectory]\client. 

5. Create a backup copy of the install.config file. 

6. Edit the install.config file to add the new location you would like to create. The area to be 

edited is displayed in bold below: 

(Example using D: drive: 

<?xml version="1.0" encoding=UTF-8?> 

<InstallConfig> 

 <BaseAppData>D:\Resources</BaseAppData> 
<CompanyName>HP</CompanyName> 

 <Language>en-US</Language> 

 <ProductId>XXXXXX-XXXXXX-XXXXXX-XXXXXX-XXXXXX-

XXXXXX</ProductId> 

</InstallConfig> 

 
In Windows 7 or later environments, you must have Administrator rights in order to 

edit install.config. 

7. Save and close the install.config file. 

8. Start the Editor software. 

9. The new resources directory will display similar to C:\[username]\HP\ART\version X.xx. 

10. On the Shortcut tab, update the Target field to reflect the location you noted in Step 6. 

11. Copy the templates from the directory you noted in Step 3 into the new directory created in 

Step 9. 

12. These steps will need to be performed after upgrading to a new version of  Editor from a 

previous version that has been configured to work with Citrix. 
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Starting the Editor 

The Editor operates in a standalone mode; the server delivered with the full product suite is not 

available with the product. Consequently, options related to server functionality are disabled in the 

Editor. 

 

Starting the Editor 

Select START > PROGRAMS and select the installation path for the application. 

 



Chapter 2: Getting Started 

18 Hewlett Packard Enterprise Develoment LP 

 

Using the Quick Start Panel 

Upon startup of the Editor, the Quick Start panel is displayed. 

 
The Quick Start panel provides easy access to the basic authoring functions, including recording 

and editing. You can enable or disable the display of the Quick Start panel. 

 

Using the Quick Start Options 

The following options are available from the Quick Start panel: 

Option Description 

New Starts the Editor to create new content. For more 

information, refer to Creating Content. 

Open local Opens existing content from the local computer. For 

more information, refer to Opening Content. 

Batch Publish Publishes one or more files locally on your 

computer. For more information, refer to Previewing 

and Publishing Content (on page 301). 

Launch Editor Launches the editing application to provide access to 

all author functionality. 
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Disabling the Quick Start Panel 

From the Quick Start panel, select the DON'T SHOW THIS WINDOW AGAIN checkbox to disable 

display of the panel. You can also disable the Quick Start panel from the FILE > PREFERENCES 

menu. 

1. Open the Editor. 

2. Select FILE > PREFERENCES. 

3. Click General on the left pane.  

4. Select the Don't show this window again checkbox.  

5. Click OK. 

 
 

Enabling the Quick Start Panel 

1. Open the Editor. 

2. Select FILE > PREFERENCES. 

3. Click General on the left pane.  

4. Deselect the Don't show this window again checkbox.  

5. Click OK. 
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Managing Your Editor Configuration Settings 

The following basic configuration settings can be specified in the Editor from the FILE > 

PREFERENCES menu. Prior to using the Editor to create content, you should review these settings 

and determine the best options for your needs: 

 Appearance: Enable or disable the Quick Start panel and specify the language 

of the application interface. The following languages are supported: Bulgarian, 

Catalan, Chinese (Traditional), Chinese (Simplified), Croatian, Czech, Danish, 

Dutch (Belgium), Dutch (Netherlands), English (US), English (UK), Finnish, 

French (Canada), French (France), German, Greek, Hungarian, Indonesian, 

Italian, Japanese, Korean, Norwegian, Polish, Portuguese (Brazil), Portuguese 

(Portugal), Romanian, Russian, Spanish, Swedish, Thai, and Turkish. 

 Logging: Specify the level of logging you want to record. The higher the log 

level, the more information the application will log. For details on setting log 

levels, refer to Specifying Logs (on page 23). 

 File Types: Make the current application the default application for the listed 

file types or choose the file types that you want to open by default. 

 Auto Save: Select to have the Editor automatically save documents as you 

work. 

 Audio: Specify recording device and quality for audio files created with the 

Editor. For details, refer to Specifying Course and Simulation Audio Options 

(on page 39). 

 Document Editor: Set the maximum screen size. For details on configuring the 

Document Editor, refer to Specifying Document Editor Options (on page 39). 

 Simulation Editor: Set options to control the display of Simulation Editor 

features. For details on configuring the Simulation Editor, refer to Specifying 

Simulation Editor Options (on page 40). 

 Filters: Highlight steps in the task pane as a warning icon. For details on 

setting step filters, refer to Specifying Filter Options (on page 41). 

 Course Editor: Set options to control the display of Course Editor features. For 

details on using the Course Editor, refer to Editing and Formatting: Courses 

(on page 171). 
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 Manage Local Templates: Import, export, and remove local templates. For 

details on managing local templates, refer to Managing Local Templates (on 

page 320). 

 Manage Local Custom Skins: Import, export, remove, check-in, or preview 

custom skins. For details on managing local custom skins, refer to Managing 

Custom Skins (on page 296). 

 File Scrubber: Allows you to scrub documents of translation data. For details 

on using the file scrubber, refer to Executing the File Scrubber (on page 25). 

 Recorder: Elect to capture only the target application during recording 

(ignoring applications other than the selected application), or elect to capture 

only the window for the active application(s). 

 
 

Selecting the Interface 

 
After specifying the interface language, you must restart the Editor for the changes to 

take effect. 

1. Open the Editor. 

2. Select FILE > PREFERENCES. 

3. Click General on the left pane. 

 

4. Select your desired language from the Interface language drop-down list. 

5. Click OK. 
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Specifying Recording and HTML Capture Modes 

1. Open the Editor. 

2. Select FILE > PREFERENCES. 

3. Click Recorder on the left pane. 

 

4. Choose from the following options: 

If You Want To Then 

Display the entire desktop screen shot 

in the document 

Select Always use desktop screen shot in the 

Document editor. 

Display the entire desktop screen shot 

in the simulation 

Select Always use desktop screen shot in the 

Simulation editor. 

Capture screen information for context-

sensitive help 

Select Enable interaction with SAP Scripting 

(for SAP Windows GUI context-sensitive 

help). 

5. In the Recording mode drop-down list, choose from the following options: 

If You Want To Then 

Capture only the window for the active 

application(s) 

Select Active Window from the Recording 

mode drop-down list 

Capture only the target application 

during recording 

Select Application from the Recording mode 

drop-down list 

6. In the Recorder Html Capture Mode drop-down list, choose from the following options: 

If You Want To Then 

Capture only the active frame when 

recording in an Internet browser 

Select Active Frame. 
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If You Want To Then 

Capture only the top-most frame when 

recording in an Internet browser 

Select Top-most Frame. 

Capture the entire browser window 

when recording in an Internet browser 

Select Entire Browser Window. 

7. Select the audio quality from the Recording Quality drop-down list. 

8. Click OK. 
 

Specifying Editor Options 

For more information on specifying Document and Simulation Editor options, refer to Specify 

Document and Simulation Editor Options (on page 39). 

 

Specifying Logs 

1. Open the Editor. 

2. Select FILE > PREFERENCES. 

3. Click General on the left pane. 

 

4. Click OK. 

 
These logs are stored in  

C:\Users\[username]\AppData\Roaming\[applicationdirectory]\version X.xx\logs. 
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Specifying File Type Associations 

If you have two or more versions of the application installed on your computer, you can specify 

which application is the default for the associated file types (.ucp, .udc, .udt, .ulc, .upg, .usg, 

.uskin, .utask, and .uws). 

1. Open the Editor you want to be the default application. 

2. Select FILE > PREFERENCES. 

3. Click General on the left pane. 

 

4. Under File Types, choose from the following options: 

If You Then 

Are using Windows 8 Click Set associations. 

Select the file extensions you want the Editor to open 

by default. 

Click Save. 

Are NOT using Windows 8 Check the Make the default application for the 

following file types check box. 

5. Click OK. 

 
 

Specifying Auto Save Settings 

You can specify the Editor to automatically and frequently save a document you are working on.  

1. Select FILE > PREFERENCES. 
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2. Click General on the left pane. 

 

3. Under Auto Save, select the Automatically save documents checkbox.  

 
The auto save functionality occurs every two minutes. This setting is not adjustable.  

4. Click OK. 

 
If you want to delete the auto saved files from the directory where they are stored, click 

Remove Auto Save Files and click OK. Auto saved files are removed automatically and 

periodically after a successful recovery of an auto saved file. Manually removing the auto 

saved files by clicking the Remove Auto Save Files button should not need to be performed 

often. 

 

 
 

Executing the File Scrubber 

The File Scrubber allows you to scrub documents of translated data so the documents are no 

longer associated with previous translated data. 

1. Select FILE > PREFERENCES. 
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2. Click File Scrubber on the left pane. 

 

3. Select the Remove imported translation data checkbox. Optionally, select the Remove 

language specific action data checkbox. 

4. Click Browse... to specify the root directory containing the content. 

5. Click Scrub Files. 

 
A progress bar displays the status of the processing. When the process is complete, the 

scrubbed content can be checked into an alternate project on the Server. 

 
 



Chapter 2: Getting Started 

 

Hewlett Packard Enterprise Develoment LP 27 

 

 

Getting Help on the Editor 

The Help menu provides access to online help and the Product Support Center. 

From the Help menu, you can also quickly identify your product version. 

 

Accessing Help Files for the Editor 

Select HELP > CONTENTS... from the Editor. 

 

Accessing the Product Support Center 

Select HELP > ONLINE SUPPORT from the Editor to access the Product Support Center. 

 

 

Viewing the Editor Version 

1. Select HELP > ABOUT... from the Editor. 
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Exiting 

If you attempt to exit the Editor without saving your content, you will receive a prompt 

confirming you want to exit prior to saving. 

 

Exiting the Editor 

Select FILE > EXIT from the Editor. 
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Uninstalling 

The Editor application can be uninstalled from your computer using standard Microsoft Windows 

Installer uninstall functionality. 

 

Uninstalling the Editor Software 

1. Select START > SETTINGS > CONTROL PANEL > ADD OR REMOVE PROGRAMS. 

2. Select Client from the Currently installed programs list. 

3. Click Remove. 

4. Click Yes at the prompt to confirm. 

5. Close the Add or Remove Programs window. 

 
Application information for individual users is stored in the Documents and Settings or 

Users folders on the computer. The uninstall does not remove this content. 
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Upgrading from a Previous Version 

The Editor upgrade is designed to allow you to install a new version on top of your current 

version. Refer to the Release Notes and Technical Specifications prior to upgrading. 

 

Upgrading Content and Templates 

Your content and custom templates are automatically upgraded during the following activities: 

 Content is upgraded when it is opened for editing. 

 Content and templates are temporarily upgraded during publishing. The 

temporary upgrades are deleted upon completion of publishing. 

 Existing templates are upgraded and placed in the current version’s Documents 

and Settings or Users folder the first time the Editor is launched. 

 
To take advantage of template features in the latest version, you must create new 

content with the most current standard author template; new template features are not 

available in upgraded documents. For more information, refer to Creating a New 

Author Template. 
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Chapter 3: Exploring the Editor 
Workspace 

The Editor workspace uses standard features such as a menu bar and 

toolbars. The interface provides two main working areas: the content 

area and the task pane. These areas provide access to your content and 

the ability to edit your content. 
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Introduction to the Editor Workspace 

The Editor workspace provides access to all authoring functions and the tools to help you 

maintain consistency and manage your content. Specifically, the Editor workspace includes the 

following functionality: 

 Create and edit documents, simulations, and courses 

 Insert steps, actions, notes, links, and tooltips into documents and simulations 

 Insert hotspots and web links into courses 

 Specify formatting options, such as font and paragraph style 

 Use spellcheck, glossary, and annotation functionality 

 Create and update your website 

 

Overview of the Content Area and Task Pane 

In addition to standard application features such as menus and toolbars, the Editor includes the 

following main areas: 

 The procedural content area contains the document, simulation, and 

screenflow views. The course content area contains the course, audio, and 

preview views. The content area also displays the functions to manage 

glossary terms and definitions and create a website. 

 The task pane view is customizable and can include such information as an 

outline view of the content, and a list of annotation sets for the current content. 
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Using the Menu 

The menu provides access to all author functionality. 

The options available on a menu are dependent upon the content you are displaying. Based on 

what type of content you are viewing, the available options within a menu will differ. 

 
 

Using the Toolbars 

The toolbar options displayed below the menu bar are customizable and are dependent upon your 

toolbar display selections and the content you are displaying. Based on what type of content you 

are viewing, the available toolbar options will differ. 

 

1. Select the different tabs across the top (File, Home, Insert, Translations, and View) to change 

the available toolbar buttons and options. 
 

Customizing the Toolbar 

1. Right-click on the toolbar to display the three toolbar menu options. 

 
The Add to Quick Access Toolbar option will display only if you right-click while 

having your mouse cursor on a button. 

 

2. Perform one of the following options: 

If You Want To Then 

Add a button to the Quick Access 

Toolbar 

Verify your mouse is on the proper button, and 

Click Add to Quick Access Toolbar. 

Go to Step 3. 

Display the Quick Access Toolbar 

below the Ribbon instead of above it, 

which is the default location 

Click Show Quick Access Toolbar below 

Ribbon. 

Go to Step 4. 

Minimize the Ribbon bar Click Minimize the Ribbon. 
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3. The Bold button has been added to the Quick Access Toolbar. 

 

4. The Quick Access Toolbar has been placed below the Ribbon 

 

5. The Quick Access Toolbar has been minimized. 
 

Using Right-Click Menus 

Right-click menus are available throughout the Editor workspace to provide shortcut methods of 

performing a variety of tasks. The menu options differ depending upon the type of field or object 

that is selected when the right-click action is performed. 

Some of the right-click menu options available include: 

 Cut 

 Copy 

 Paste 

 Delete 

 Undo/Redo 

 Edit steps, actions, notes, and callouts 

 Edit tooltips, screens, and images 

 Various character and paragraph format options 

 Various insertion and editing options 
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Using the Content Area 

The content area displays a WYSIWYG (what you see is what you get) view of the underlying 

extensible markup language (XML) structure of the document and simulation. 

 

Changing Content Views 

Tabs in the lower left allow you to select the desired view of procedural content: document, 

simulation, or screenflow. Additionally, you can right click on an item in the task pane and select 

"Edit in document view" or "Edit in simulation view". If you are in course mode, you can select 

the desired view of course content: course, audio, or preview. If you are in website mode, you can 

select the page or content view. 

To display a particular view in the content area, select the desired tab. 

 

 
You may encounter a slight time delay when switching between views. This is due to the 

processing necessary to reformat the data for display. 

 
It is good practice to save your file before switching the views. 

 
 

Viewing the Status Bar 

The status bar at the bottom of the Editor window provides information on processing status and 

the glossary terms or page links remaining within the system limit. 

 
 

Using the Task Pane 

The following task panes are available in the Editor. Selection availability is dependent on the file 

type that is open, and the view displayed. 

 Annotations: Displays the annotation sets available for the displayed 

document. 

 Course: Displays the lessons and pages in the course. 

 Layout: Displays an outline view of the sections and the steps in the document. 
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 Steps: Displays the steps in the simulation. 

 Pages: Displays page hierarchy information for the website. 

 Glossary: Displays the list of terms. 

When you click on an element in the task pane, the content area refreshes to display the 

corresponding information in the content area. To change the displayed task pane, select the 

desired pane from the VIEW menu, or click the down arrow in the upper right of the task pane. 
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Chapter 4: Creating and Opening 
Content 

In addition to recording a target application to produce a document and 

simulation, the Editor can be used to create and open content 

independent of the recorder. 
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Introduction to Creating and Opening Content 

In addition to recording a task to create procedural content, you can use the Editor to: 

 Create a file into which recorded steps and amplifying information can be 

added. When you create content, the document, simulation, and screenflow 

views are generated. 

 Rapidly create eLearning courses. When you create course content, the course, 

audio, and preview views are generated. 

 Combine concepts, procedures, and exercises related to a series of tasks or a 

process into a student guide. 

 Combine multiple eLearning courses and documents into a single SCORM 

package for use with an LMS. 

Lastly, the Editor is used to create a project-wide glossary of terms and definitions and a website 

to provide end users with access to content. 
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Specify Document and Simulation Editor Options 

You have several options to control the display of features within the Document and Simulation 

Editor. 

 

Specifying Course and Simulation Audio Options 

1. Select FILE > PREFERENCES. 

2. Click Audio on the left pane. 

 

3. Complete the following fields: 

Field Description 

Recording Device Specify the input recording device. This selection is 

machine specific. 

Recording Quality Specify the audio quality setting. 

Setting MP3 WAV 

High 320kbps  16-bit 

Medium 128kbps 8-bit 

Low 64kbps 8-bit 
 

4. Click OK. 
 

Specifying Document Editor Options 

1. Select FILE > PREFERENCES. 
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2. Click Document Editor on the left pane. 

 

3. Complete the following fields: 

Field Description 

Width Specify the maximum pixel width for the displayed 

document. 

Height Specify the maximum pixel height for the displayed 

document. 

4. Select Show R/O/C column to display the Required, Optional, Conditional columns in the 

Document Editor. 

5. Optionally, select Use full-text option value in R/O/C column. 

6. Select the Show callouts checkbox to enable the display of callouts in the Document Editor. 

 
Enabling this option does not affect published output. 

7. Click OK. 
 

Specifying Simulation Editor Options 

1. Select FILE > PREFERENCES. 
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2. Click Simulation Editor on the left pane. 

 

3. Complete the following fields: 

Field Description 

Mouse action Specify the color of the mouse action displayed in the Editor. 

Key action Specify the color of the key action displayed in the Editor. 

Edit action Specify the color of the text action displayed in the Editor. 

Tooltip Specify the color of the tooltip displayed in the Editor. 

Action hotspot: Width Specify the initial width of the hotspot. 

Action hotspot: Height Specify the initial height of the hotspot. 

Note: Width Specify the initial width of the note. 

Note: Height Specify the initial height of the note. 

4. Optionally, choose custom colors by clicking More Colors on the color drop-down list. 

5. Select Show Action Notes to display action notes in the Simulation Editor. 

6. Select Auto Size Notes to automatically resize the note to fit its contents. 

7. Select Show Action Points to display action points in the Simulation Editor. 

8. Click OK. 
 

Specifying Filter Options 

1. Select FILE > PREFERENCES. 
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2. Click Filters on the left pane. 

 

3. Choose from the following options: 

Field Description 

Highlight steps with Broken 

Step Links 

This option will highlight steps in the task pane that 

contain broken step links. 

Highlight steps with Missing 

text in edit actions 

This option will highlight edit steps in the task pane that 

are missing text in an edit action. 

Highlight steps with Missing 

hint text in edit actions 

This option will highlight edit steps in the task pane that 

are missing hint text. 

Highlight steps with Possible 

incorrect hotspot location 

This option will highlight steps in the task pane that 

might contain incorrect hotspot locations. 

Highlight steps with Unknown 

control types 

This option will highlight steps in the task pane that 

contain unknown control types. For more information on 

control types, refer to Editing an Action: Advanced (on 

page 135). 

Highlight steps with Note 

duration longer than step 

duration 

This option will highlight steps in the task pane that 

contain a longer note duration than step duration. 

Highlight steps with Manual 

audio 

This option will highlight steps in the task pane that do 

not contain text to speech (TTS). For more information 

on TTS, refer to Using Text to Speech (on page 233). 

Highlight steps with Non-

Localized Elements 

This option will highlight steps in the task pane that are 

not localized.  

Highlight steps with 

Overlapping Notes 

This option will highlight steps in the task pane that may 

contain overlapping notes. 

Highlight screens with Scaled 

screen image in Word/PDF/Print 

output 

This option will highlight screens where the image will 

be scaled for Word, PDF, and Print outputs. This option 

helps reduce the occurrence of screen image scaling, 

which degrades image quality. 

Highlight steps with Manual 

audio (under Course Filters) 

This option will highlight steps in the task pane for 

courses that do not contain text to speech (TTS). For 

more information on TTS, refer to Using Text to Speech 

(on page 233). 
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Field Description 

Highlight steps with Non-

Localized Elements (under 

Course Filters) 

This option will highlight steps in the task pane for 

courses that are not localized 

Highlight steps with Cropped 

text in Word or PDF output 

(under Course Filters) 

This option will highlight steps where too much text is 

entered on course content pane. This filter alerts you that 

if the course is published to Word and/or PDF outputs, it 

would not publish in its entirety. It would publish 

"cropped." (This does not occur for HTML output, since 

content panes can be scrolled in dynamic output.)  

 
Highlighting displays in the task pane as a warning icon. When you hover the mouse 

over the step, a tooltip will display containing more details regarding the missing 

information. 

4. Click OK. 
 

Specifying Screenshot and Scripting Options for the Recorder 

1. Select FILE > PREFERENCES. 

2. Click Recorder on the left pane. 

 

3. Select Always use desktop screen shot in the Document editor to display the entire desktop 

screenshot in your document. 

4. Select Always use desktop screen shot in the Simulation editor to display the entire 

desktop screenshot in your simulation. 

5. Select Enable interaction with SAP Scripting (for SAP Windows GUI context-sensitive 

help) to capture screen information for context-sensitive help. 

6. Select a Recording mode from the drop-down list. 
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7. Select a Recorder Html Capture Mode from the drop-down list. 

8. Select the audio quality from the Recording Quality drop-down list. 

9. Click OK. 
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Specify Course Editor Options 

You have several options to control the display of hotspots within the Course Editor. For more 

information, refer to Inserting a Hotspot on an Image (on page 217). 

 

Specifying Course Editor Options 

1. Select FILE > PREFERENCES. 

2. Click Course Editor on the left pane. 

 

3. Complete the following fields: 

Field Description 

Background color Specify the color of the hotspot background. 

Width Specify the initial width of the hotspot. 

Height Specify the initial height of the hotspot. 

4. Optionally, choose custom colors by clicking More Colors on the color drop-down list. 

5. Click OK. 
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Creating Content 

Creating Content 

1. From the Editor, select FILE > NEW. 

 

2. Enter a name in the Name field. 

 
While there is no limit to the amount of characters in the name, the Server will display 

only the first 60 characters. 

3. In the Type drop-down list, select one of the following options: 

If You Want To Then 

Create and record a new document Select Recording. 

Create a blank document Select Document. 

Create a course Select Course. 

Create a student guide Select Student Guide. 

Create a course package Select Course Package. 

Create a template For more information, refer to Using Author 

Templates (on page 317). 

Create a glossary Refer to Creating a Glossary (on page 269). 

Create a website Refer to Creating a Website (on page 398). 

4. Select a template from the Template listbox. 

5. Select a language from the Language drop-down list. 

 
This option is not available for course packages. 
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6. Click Browse ... to select a location in which to store your  content. 

 
The default location is C:\Users\[username]\Documents. 

7. Click OK. 

 
Selecting Recording displays the Recorder window. Selecting Document creates a 

blank document. Selecting Course displays the root course page in the Editor window. 

8. If you selected Course, choose one of the following stencils: 

Field Description 

Flash This stencil creates a standard content page 

containing a single Flash file. 

Full This stencil creates a standard content page with 

text. 

Half - Bottom This stencil creates a standard content page with text 

on the bottom of the page. An optional image can be 

placed on top. 

Half - Left This stencil creates a standard content page with text 

on the left of the page. An optional image can be 

placed to the right. 

Half - Right This stencil creates a standard content page with text 

on the right of the page. An optional image can be 

placed to the left. 

Half - Two Image - Bottom This stencil creates a standard content page with text 

on the bottom of the page. Two optional images can 

be placed on top. 

Half - Two Image - Left This stencil creates a standard content page with text 

on the left of the page. Two optional images can be 

placed to the right. 

Half - Two Image - Right This stencil creates a standard content page with text 

on the right of the page. Two optional images can be 

placed to the left. 

Image This stencil creates a standard content page 

containing an image. 

Image - Diagonal - Left This stencil creates a standard content page with text 

on the top left and bottom right of the page. Two 

optional images can be placed diagonally within the 

stencil. 

Image - Diagonal - Right This stencil creates a standard content page with text 

on the top right and bottom left of the page. Two 

optional images can be placed diagonally within the 

stencil. 

Video This stencil creates a standard content page 

containing a video. 
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Field Description 

Video - Half - Left This stencil creates a standard content page. An 

optional video can be placed to the right. 

Video - Half - Right This stencil creates a standard content page. An 

optional video can be placed to the left. 

Simulation This stencil creates a content page for embedding a 

Simulation. 

Simulation - Half - Right This stencil creates a page for embedding a 

Simulation. An optional image can be placed to the 

left. 

9. Click OK. 

For more information on editing and formatting procedural content, refer to Editing and 

Formatting: Procedural Content (see "Specifying Simulation Editor Options" on page 40). 

For more information on editing and formatting course content, refer to Editing and Formatting: 

Courses (on page 171). 

For more information on editing and formatting student guides, refer to Editing and Formatting: 

Student Guides and Course Packages (on page 251). 
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Open Content 

Only one content item can be open in the Editor at a time (for example, one course). 

 

Opening Content 

1. From the Editor, select FILE > OPEN > OPEN LOCAL.... 

2. In the Open window, browse to the location of your document, simulation, course, glossary, 

or website, and click Open to display the content in the Editor. 
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Document and simulation files have a .udc extension. Courses have a .ulc extension. 

Student guide files have a .usg extension. Glossary files have a .upg extension. 

Website files have a .uws extension. You can also use Windows Explorer to browse to 

the file, and double-click to open the file in the Editor. 

 

 



 

51 

 

Chapter 5: Recording Procedural 
Content 

The application  records your actions in Microsoft Windows, web-

based, Java, and enterprise applications, and outputs a professionally 

formatted document and simulation. You can capture screens, buttons, 

edit fields, and more in the target application. 

The recording process captures information to simultaneously produce 

both a simulation view and a document view of procedural content. 
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Introduction to Recording Procedural Content 

The recording functionality reduces procedural content development time and cost by 

automatically capturing each screen, step, field entry, and button in the target application. As you 

record, the application watches your actions in the application, captures each step in the task, and 

converts the result to professionally formatted documents and simulations. You simply start the 

recorder, perform the actions that you would like to document, turn the recorder off, and then 

make edits to the resulting content. 

For detailed information on enterprise applications supported by the recorder, refer to the 

Technical Specifications. 

In addition, control recognition recording is available for non-accessible applications. Control 

recognition recording uses image processing to capture screens and entered information. For more 

information, refer to Specifying Recorder Tuning Options (on page 59). 
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Preparing to Record 

Before you begin recording the target application, prepare your computer and the data you will 

need to complete a task. In addition, you should perform several test recordings using your target 

application. You may find it helpful to prepare a quick reference that outlines for authors the 

standards you are using for recording and provides any helpful tips to use during the recording 

and editing processes. 

If you are planning to use the guided Re-Record functionality, refer to Managing Content 

Languages (on page 69) before you begin the recording process. 

 

Preparing Your Computer 

To create a consistent recording environment, the following are several suggestions for ensuring 

standardization among all authors: 

 Ensure all authors are using the same windows and buttons scheme or theme. 

 Ensure all authors are using the same Microsoft Windows color scheme. 

 Ensure all authors are using the same Microsoft Windows color palette 

settings (for example, Highest [32 bit]). 

 Standardize the Desktop area setting for all authors to maintain consistency for 

screen captures. 

 Ensure all authors are using the same Microsoft Windows font size (for 

example, "Normal"). 

 If you are recording the HP GUI, ensure all authors are using the same version 

of the GUI and have specified consistent font and color settings in the GUI. 

 If you are recording the SAP GUI, ensure all authors are using the same 

version of the GUI and have specified consistent font and color settings in the 

GUI. 

 If you are recording the Oracle application, ensure all authors are using the 

same Oracle color settings. Maximize the Oracle window before recording. 

 If you are recording Adobe forms in Adobe Reader, ensure all authors turn off 

the Adobe Reader "protected mode" setting. 



Chapter 5: Recording Procedural Content 

54 Hewlett Packard Enterprise Develoment LP 

 

Starting the Recorder 

 
The application does not support recording on secondary monitors. If you use dual 

monitors, ensure that the application you want to record is displayed on the primary 

monitor. 

 
 

Start Recording 

1. Select START > PROGRAMS > [APPLICATIONDIRECTORY]. 

2. Use one of the following two methods to start the recorder: 

If Then 

You are starting the recorder from the 

Quick Start panel 

Select the New option. 

You are starting the recorder from the 

Editor application 
Select FILE > NEW. 

3. Select Recording from the Type drop-down list. 

 

4. Complete the following fields: 

Field Description 

File name Enter the filename. 

Do not use special characters in the filename. 

Template Select the template from the listbox. 

Language Select the language for the document from the drop-

down list. 
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Location Enter, or browse to, the location where the file will 

be saved. 

The default save location is C:\Users\Documents. 

5. Click OK. 

 
If the template's simulation maximum screen height and width do not match the screen 

height and width of your primary screen, you will receive a warning message. To 

capture the best image quality, your primary screen's settings should match those used 

in the template. If you ignore the warning and continue recording without changing the 

screen settings, image quality will be impacted. For more information on setting the 

template's simulation maximum screen height and width, refer to Default Publication 

Settings: Simulation: User Interface Settings (on page 345) in the Managing Content 

manual. 

6. Select one of the following options: 

If You Want To Then 

Record across a series of applications. Go to Step 9. 

Record a single target application 

If you have specified to record a single 

target application, you must specify the 

application after entering the project 

and template information. For 

information on specifying a recording 

mode, refer to Specifying Recording 

and HTML Capture Modes. 

Go to Step 7. 

Record the active window for the 

application(s). 

Go to Step 9. 

7. From the Select Application window, select the target application. 

8. Click OK to display the Recorder window. 

 

9. Click  to start recording. 

For detailed information on capturing various controls, refer to Capturing Controls (on page 57). 
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Displaying the Recorder Preview Pane 

During recording, a real-time preview of the recorded actions is displayed in a preview pane in the 

Recorder window. The preview pane allows you to view data as it is being captured. The preview 

pane and window are not captured during recording. 

 
 

You can hide or display the recorder preview pane. 

Click  to toggle the display of the preview pane during recording. 

 

Preparing Your Data 

Before recording a task, you should identify data that will allow you to navigate through the task 

and will also serve as example data in the procedure. This will ensure you can proceed through the 

task easily and without errors. 

You may find it helpful to sketch a screen flow to capture usable data and provide you with a map 

to use while recording the task. A rough sketch can be helpful while recording and can serve as a 

reference later during editing to verify the recorded data. 
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Capturing Controls 

The recording process captures a variety of interface objects, including screens, buttons, tabs, 

checkboxes, drag-and-drop actions, menu paths, edit fields, grids, trees, radio buttons, match 

codes, list items, and combo boxes. 

 
The application does not support recording on secondary monitors. If you use dual 

monitors, ensure that the application you want to record is displayed on the primary 

monitor. 

The following table provides an overview of recorder capabilities, limitations, and the steps you 

must take to capture specific objects. 

 
 

Object Description Required Steps 

Edit Fields The recorder captures field labels 

and data. The field name, a generic 

placeholder description, and the data 

that was entered will be captured. 

1. Click or tab in the field. 

2. Type in the field. 

3. Exit the field. 

To capture default data, click or tab into 

the field containing the default data and 

exit the field. The default data and field 

name will be captured. In the document 

view, data is inserted into a 

Field/Description table. 

If a value exists in the field on exit, the 

recorder will capture this value. If the 

field is empty, the recorder captures a 

step without a value in the field. 

If you want to capture only the characters 

typed, instead of all characters in the 

field, change the Capture Typing Text 

Mode value to Typed Characters. For 

more information, refer to Specifying 

Recorder Tuning Options (on page 59). 



Chapter 5: Recording Procedural Content 

58 Hewlett Packard Enterprise Develoment LP 

 

Object Description Required Steps 

Menu Paths Menu paths are automatically 

recorded. The recorder captures 

menu text when you click on the 

text. 

Simply execute the menu path, and the 

recorder will capture the first initial click 

as a step and then display the full menu 

path as a single step. 

Grids When entering data into a table, the 

field labels are typically located at 

the top of the column. The recorder 

will capture both the row and the 

column label. 

1. Click in the grid cell. 

2. Enter data. 

3. Click out of the cell. 

Screens New screens are captured 

automatically as you progress 

through a task. 

A screen image is captured for every step. 

The following types of actions will 

trigger a new screen shot to be displayed 

in the document view (In a simulation 

view each step is displayed with its 

corresponding screen image.). The order 

that the criteria are applied is as follows: 

1. When you take an action on a screen, 

the recorder checks if the screen title is 

different than the previous steps screen 

title. If yes, a new screen image is 

displayed. 

2. If the screen title did not change, the 

recorder checks if the dimensions of the 

active region are different than the screen 

captured for the previous step. If yes, a 

new screen image is displayed. 

3. If the previous action was performed 

on a tab or a menu item control, a new 

screen image is displayed. 

The recorder also captures the last screen 

upon stopping the recording process. 

Match Codes, 

Buttons, 

Checkboxes, 

Combo Boxes, 

Tree Items, Tab 

Controls, 

Labels, Links, 

Radio Buttons, 

and Images 

The recorder captures match codes, 

the button image, the checkbox or 

radio button and the associated 

label, and any other images on 

which you click. 

Click on the button, checkbox, radio 

button, or image. 

If you are planning to Re-Record and are 

selecting a combo box, be sure to click a 

selection in a combo box, even if the 

default value in the combo box is not the 

one desired. 

Combination 

Keystrokes 

Keystrokes are captured and 

recorded as new steps. 

Type combinations keystrokes Ctrl+N 

and Alt+F are supported. 

Command combination keystrokes 

ALT+TAB, CTRL+ALT+DEL, and 

ALT+ESC are not supported. 

Function Keys Function keys are captured and 

recorded as new steps. 

Type the function keys F1-F9, F11, and 

F12. 
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Specifying Recorder Tuning Options 

The recorder tuning option allows you to specify how you want the recorder to handle certain 

actions during the recording process. These options are useful for when you want to record 

supported target applications, as well as record unknown and inaccessible controls. 

 

Selecting the Recorder Tuning Options 

1. Click  on the Recorder window. Click the drop-down arrow to the far right to access the 

Recorder Tuning options.  

 

2. Choose from the following options: 

Field Description 

Enable target recognition  Select Enable target recognition to enable the 

recorder to capture screen regions, titles, and 

context-sensitive help data that is specific to the 

target application. 

Go to Step 3. 

Use only image processing 

for control recognition  

Select Use only image processing for control 

recognition to capture control information when it 

is known that the target is not captured well by a 

plug-in. For a list of available plug-ins, refer to the 

Technical Specifications. 

Go to Step 4. 

3. Choose one of the following options: 

Field Description 

Entire Value Captures characters in a text box after the user 

exits the text box. 

Typed characters Monitors the captured characters as they are 

typed based on keyboard or IME output. 

4. Select the amount of delay for the screen shot capture. 
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5. Click OK. 
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Using the Screen Percent Differential Feature 

The screen differential allows you to choose the percent of pixels that must change on a screen 

before a new screen shot is displayed. This is helpful if you are recording several actions on the 

same screen as you might not want a new screen shot for each action unless a significant portion 

of the screen has changed. 

A higher screen differential will yield fewer screen shots; a lower screen differential will yield 

more screen shots. 

 

Adjusting the Screen Percent Differential 

1. Click the drop-down arrow next to the 100 (the default setting) to access the screen percent 

differential.  

 

2. Select, or enter, the percent of pixels in the  field on the Recorder window.  
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Using Image Mode 

The image mode option allows you to capture a specific area of the screen that does not have 

clearly defined edges or boundaries. The resulting image is inserted into your content as a new 

step. 

 

Using Image Mode During Recording 

1. Open a document and record at least one step in the desired application window. 

2. Click  on the Recorder window to activate image mode. 

 
The cursor displays as a crosshair. 

3. Click in the window where you want to capture an image. 

4. Click and hold the left mouse button as you drag a rectangle around the image you want to 

capture. 

5. Release the mouse button to turn off image mode and capture the selected area. 

 
The image will be inserted as a new step. 
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Using Undo and Redo 

The undo and redo options allow you to remove and restore data captured during recording. 

 

Using Undo During Recording 

Click  on the Recorder window to remove the last item recorded. 

 
You can click  more than once to remove additional items that have been recorded. 

The undo functionality caches up to nineteen steps. 

 

 

Using Redo During Recording 

Click  on the Recorder window to restore the last item that was removed with the undo 

function. 

 You can click  more than once to restore additional items that were removed. 
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Minimizing the Recorder Window 

You can minimize the Recorder window to the Microsoft Windows task tray. 

Click  on the Recorder window to toggle between minimizing and displaying the window 

during recording.  

 
To restore the window display, right-click on the icon in the task tray and select Show Toolbar. 
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Recording Audio 

The audio option allows you to capture audio while recording an application. 

 

Testing Audio 

The first time you click  on the Recorder window, the Audio Testing window displays. 

 

1. Select a recording device from the drop down list. 

2. Click  and record audio. 

3. Click  once you have finished recording audio. 

4. Click  to playback the file. This button is disabled until there is an audio file available for 

playback. 

5. Click OK when finished. 
 

Using Audio During Recording 

1. Click  on the Recorder window to start capturing audio. 

 
Audio is captured only when the recorder is recording. 

2. Record audio and then capture the associated step. Audio is associated to the next recorded 

step. 

3. When finished capturing audio, click Turn off Audio recording or click Stop. Stopping the 

recording will also turn off audio capture. 
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Using Notes in the Recorder 

You can insert notes into the recording to help explain an action or to provide details regarding the 

next recorded step. 

 

Inserting Notes 

1. Click  on the Recorder window to create a new note. 

2. Insert text into the note, as needed. 

 

3. Select the note and resize or move it, as needed. 

 
Inserted notes are associated to the next recorded step. Notes disappear from the screen 

and cannot be edited or deleted after you start or continue the recording. 

4. Insert another note, as needed, or record your next step. 
 

Deleting Notes 

Notes can only be deleted before recording the associated step. To delete a note, click X in the 

upper right corner of the note. 
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Pausing and Stopping the Recorder 

You can pause the recorder during the data capture process. While the recorder is paused, you can 

open other applications and perform other tasks without recording those actions. 

When you have finished recording, you must stop the recorder to complete processing and save 

your content. 

 

Pausing the Recorder 

Click  on the Recorder window to pause the recorder. 

 
Remember to resume recording when you are ready. 

 

 

Stopping the Recorder 

Click  on the Recorder window to stop the recorder. 

 
After stopping the recorder you will receive a prompt asking if you would like to check 

in the task. 
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Chapter 6: Managing Content Languages 

You can also expedite the creation of content in other languages. In 

particular, the guided Re-Record functionality allows you to easily 

repeat steps from an original document in a new document. 
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Introduction to Managing Content Languages 

There are several options to manage the language of your content so you can easily produce 

translated versions of your ART content. Three options are available for managing content 

languages: 

 Create translated documents: Creates a new ART document with text in the 

new target language(s). This functionality is useful in cases where you have 

customized your ART documents and phrases and want to export content in 

XLIFF format for translation in order to create a new version with translated 

text. For more information, refer to Creating Translated Documents (on page 

71). 

 Use Guided Re-Record to capture graphics in another language: Creates a new 

ART document with text and graphics (screens, buttons, and images) in the 

new target language(s.) This functionality is useful if you have customized 

your documents and phrases and plan to include translated graphics in your 

new documents. This is the most robust translation option. For more 

information, refer to Using Guided Re-Record Functionality (on page 79). 

 Create translations of standard ART-provided boilerplate text: Creates a new 

ART document by morphing ART-provided boilerplate text into another 

language. This functionality is useful if you have not customized your ART 

documents and phrases. For more information, refer to Change the Language 

of Default Text (on page 167) for instructions on changing the document 

language property. 
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Creating Translated Documents 

Exporting Content for Translation 

1. Open the content. 

2. Select TRANSLATIONS > EXPORT CURRENT. 

 

3. Select the language(s) corresponding to the translated content to be created. 

4. Choose from the following options: 

Field Description 

Create XLIFF file for Re-

Recording 

This option is not recommended for use with 

exporting content for translation because it does not 

include step text or screen titles. 

For more information on Re-Recording, refer to 

Using Guided Re-Record Functionality (on page 

79). 

Create XLIFF file and 

include screen titles 

Select Create XLIFF files and include screen 

titles to create an XLIFF file for translation that 

includes step text and screen titles. 

Create XLIFF file without 

including screen titles 

Select Create XLIFF files without including 

screen titles to create an XLIFF file for translation 

that includes step text but does not include screen 

titles. 

Include annotation sets Select this option if you want to include your 

annotations in the XLIFF file.  
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5. Click  to browse to an export location. 

 
Note the export location for later use. 

6. Click OK. 

7. Click Export. 

 

8. Perform one of the following options: 

If You Want To Then 

Edit the files to translate Refer to Editing Exported Files (on page 72). 

Close the export summary window Click OK. 

 
 

Editing Exported Files 

For each exported language, one XML Localization Interchange File Format (XLIFF) file is 

created. The exported XLIFF file(s) contain all phrases and author-entered text in the content. 

Both the phrases and the author-entered text must be translated. Boilerplate text provided with the 

template (for example, "Use this procedure to") is automatically translated via the phrases 

provided in the template. 

The file is formatted to facilitate translation by displaying the source (original) text co-located 

next to the target translated text. 

1. Open the exported XLIFF file in the desired editor. 

 
The XLIFF file can be edited in Notepad, in an HTML editor, or via a specialized 

XLIFF editor such as Xliff Editor or Heartsome. 
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2. Edit the text or data values as necessary. 

3. Save the file(s). 
 

Importing Translated Content 

 
You must perform an export before you can import the files. For more information, 

refer to Exporting Content for Translation (on page 71). 

1. Open the content that has been exported and edited. 

2. Select TRANSLATIONS> IMPORT CURRENT. 

 

3. Click  to select the import location. 

 
This location must match the Export to location specified in Exporting Content for 

Translation (on page 71). 

4. Select the exported language(s) for import. 

5. Click OK. 
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6. Click Import. 

 

7. Click OK. 
 

Create Translations for a Single Document 

1. Open the content for which you want to create translated file(s). 

2. Select TRANSLATIONS> TRANSLATE CURRENT. 

 

3. Expand the template used for the content. 

4. Select the language(s) corresponding to the translated content files to be created. 

5. Click  next to Outbox to select an Outbox location. 

6. Click Translate. 

7. Click OK. 

8. On the Translation Summary window, click the name of the translated file to view in the 

Editor. 
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Batch Exporting Content for Translation 

1. Select TRANSLATIONS > EXPORT BATCH. 

 

2. Expand the template(s) used for the content. 

3. Select the language(s) corresponding to the new translation content to be created. 

4. Click  next to Export from to select the folder containing the content to export. 

 
Note the export location for later use. 

All application content in this location that is associated with the selected template(s) 

will be processed. 

5. Click OK. 

6. Click  next to Export to to select an export location. 

 
Note the export location for later use. 

7. Click OK. 

8. Choose from the following options: 

Field Description 

Create XLIFF file for Re-

Recording 

This option is not recommended for use with 

exporting content for translation because this option 

does not include step text. 

For more information on Re-Recording, refer to 

Using Guided Re-Record Functionality (on page 

79). 
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Field Description 

Create XLIFF file and 

include screen titles 

Select Create XLIFF files and include screen 

titles to create an XLIFF file for translation that 

includes screen titles. 

Create XLIFF file without 

including screen titles 

Select Create XLIFF files without including 

screen titles to create an XLIFF file for translation 

that does not includes screen titles. 

Include annotation sets Select this option if you want to include your 

annotations in the XLIFF file.  

9. Click Export. 

 

10. Perform one of the following options: 

If You Want To Then 

Edit the files to translate text and 

values 

Refer to Editing Exported Files (on page 72) for 

information on editing exported files. 

Close the batch export summary 

window 

Click OK. 

 
 

Batch Importing Translated Content 

 
You must perform an export before you can import files. For more information, refer to 

Batch Exporting Content for Translation (on page 75). 
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1. Select TRANSLATIONS > IMPORT BATCH. 

 

2. Expand the template(s) used for the content. 

3. Select the exported language(s) for the content. 

4. Click  next to Import to to select the folder containing the content to import. 

 
This location must match the Export from location specified in Batch Exporting 

Content for Translation (on page 75). 

5. Click OK. 

6. Click  next to Import from to select the folder containing the content to import. 

 
This location must match the Export to location specified in Batch Exporting Content 

for Translation (on page 75). 

7. Click OK. 

8. Click Import. 

 

9. Click OK. 
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Creating Translated Files in Batch Mode 

1. Select TRANSLATIONS > TRANSLATE BATCH. 

 

2. Expand the template(s) used for the content. 

3. Select the language(s) corresponding to the translated content files to be created. 

4. Click  next to Inbox to select an Inbox location. 

5. Click  next to Outbox to select an Outbox location. 

6. Click Translate. 

7. Click OK. 

8. On the Translation Summary window, click the name of a translated file to view in the 

Editor. 
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Using Guided Re-Record Functionality 

Guided Re-Record functionality allows you to recreate steps from an original document into a 

new document, as well as capture translated screen images and graphics. 

When you open an existing document and select to Re-Record, a guide pane opens in the recorder 

preview pane to display the guide steps. Use the guide steps to help you recreate the required 

actions in the target language. 
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Re-Record Prerequisites: Before You Get Started 

Before you initially record a document that will eventually be re-recorded, you must: 

 Review Capturing Controls in the Target Application for an overview of 

recorder capabilities, limitations, and the steps you must take to capture 

specific objects. 

 Review recording preparation guidelines and recorder options as specified in 

Specify Document and Simulation Editor Options. 

 Select the desired language(s) for Re-Record within the template as specified 

in Specifying General Settings: Languages. 

 Use the following guidelines to help ensure a smooth re-recording session: 

 Ensure the desired target languages are installed in the application to be 

recorded. 

 Use the pause feature if you must take a break. Stopping the re-recording will 

end the session. 

 Do not move action notes; simply perform the action as guided. If you think 

you will need to adjust the position before re-recording, perform the 

adjustment in the original source document before you start the re-recording 

session. 

 Ensure you are re-recording with the same screen resolution as the original 

content. 

 Add any additional information to the resulting document via the Insert > 

Steps functionality in the Editor; however, if you need to pause the recorder to 

record additional steps into a document based on a language-related change in 

process, ensure you resume the guided re-record functionality before 

continuing. 

 Do not resize or move windows during a session. 

 Perform only the actions necessary to perform the tasks being documented. 
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Re-Record Scenarios 

Guided Re-Record allows you to recreate steps in a new language document, as well as apply 

translations to documents after Re-Recording has been completed. 

 

Scenario 1: Translating Before Re-Record 

Pre-translation guided Re-Record is used with an exported, translated, and imported original 

document. Scenario 1 is the "all at once" option. The re-recorded document contains all 

translations, with no additional action required beyond basic editing and quality assurance. For 

more information on applying translations, refer to Importing Content for Guided Re-Record 

Using Scenario 1 (on page 88): 

1. Export phrases. 

2. Translate phrases. 

3. Import phrases. 

4. Re-record the document. 
 

Scenario 2: Translating After Re-Record 

Post-translation guided Re-Record can be used before translation is complete. This allows you to 

re-record your documents and create your XLIFF translation files from the re-recorded document. 

This is useful if you plan to add additional information to your re-recorded documents and want to 

ensure that information is translated. For more information on applying translations, refer to 

Applying XLIFF Translations for Guided Re-Record Using Scenarios 2 and 3 (on page 89): 

1. Re-record the document. 

2. Export from the re-recorded document. 

3. Translate phrases. 

4. Apply the XLIFF translations to the re-recorded document. 
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Scenario 3: Using Translation and Guided Re-Record in Parallel 

A parallel translation for guided Re-Record can be used before translation is complete. Since the 

export is from the original document, translations applied to the re-recorded document will 

overwrite what was captured by the Recorder during the re-record process. This allows you to 

retain and translate custom step text you added to the original document. 

It is recommended that screen titles, button names, menu and list item values, etc. not be 

translated as these may appear differently in the new language. For example, if your step text 

reads, "Press Collect," where "Press" is the custom text and "Collect" is the button name, you will 

be able to retain and translate "Press." For more information on applying translations, refer to 

Applying XLIFF Translations for Guided Re-Record Using Scenarios 2 and 3 (on page 89). 

1. Export from the original document. 

2. Translate phrases. 

3. Re-record the document. 

4. When both translation and re-recording are complete, apply the XLIFF translations to the re-

recorded document. 
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What Happens During Guided Re-Record? 

Guided Re-Record is a simple, flexible way to create translated content for a wide range of 

applications. Guided Re-Record can be used on any .udc file. 

During the guided Re-Record process, the application displays an on-screen script that you can 

follow while recording a new document in a different language. Guided Re-Recording displays a 

list of screens and steps from a previously recorded document, and prompts you with the steps to 

take to record the same steps again in the target application. 

Guided Re-Record screen prompts display as: 

 A new pane in the recorder toolbar that displays the list of steps in the original 

file 

 An action hotspot directly on the application screen that indicates where the 

next action should occur 

 An action note that displays the action text for the step 

 

Using Guided Re-Record 

1. Open the document to be Re -Recorded. 

2. Select TRANSLATIONS > RE-RECORD. 

 

3. If presented with the prompt, choose from the following options: 

If You Want To Then 

Save the changes Click OK. 
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If You Want To Then 

Continue Re-Recording Click Cancel. 

4. Select one of the available language(s) from the Languages drop-down list. 

5. Click  to select an Outbox location. 

6. Click OK. 

7. Click Re-Record. 

 

8. Click  to begin the Re-Record process. 

9. Use the guide pane as a prompt to assist in recreating the steps in the target application. 

10. Optionally, perform one of the following during the Re-Record process. If the toolbar is 

hidden, right-click on the recorder icon in the system tray to access these functions. 

If You Want To Then 

Pause the Re-Record guide script Click . 

Use the guide script pause feature if you need to 

record an additional language-based step that is 

not part of the original document. 

Ensure you click  when you are ready to 

resume the Re-Record guide script. 
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If You Want To Then 

Pause the recorder 
Click . 

Use the record pause feature if you need to take a 

break from recording and Re-Recording. 

Ensure you click  when you are ready to 

resume recording. If you have also paused the 

Re-Record guide script, ensure you click  to 

resume. 

Stop the Re-Record process 
Click . 

Use the stop feature only when you are finished 

Re-Recording. The stop feature ends Re-

Recording for the document. 

Hide the Re-Record pane 
Click . 

Hide or show the guide pane Click  .  

Hide or show notes Click  . 

Hide or show hotspots Click . 

View step details 
Click  to open an additional step detail pane 

to help ensure you re-record the correct 

information. 

11. Click  to stop the guided Re-Record process. 

 
The re-recorded document will open in the Editor. 

 

 

Exporting, Importing, and Applying XLIFF Translations 

Exporting Content for Guided Re-Record 

1. Open the content. 
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2. Select TRANSLATIONS > EXPORT CURRENT. 

 

3. Select the language(s) corresponding to the translated content to be created. 

4. Choose from the following options: 

If You Want To Then 

Create XLIFF file for Re-

Recording 

Select this option to generate the XLIFF file 

required for Re-Recording. This option does not 

include screen titles or step text. 

This model is recommended for use with Scenario 1 

and Scenario 2. For more information, refer to 

Scenario 1: Translating Before Re-Record (on page 

81) and Scenario 2: Translating After Re-Record (on 

page 81). 

Create XLIFF file and 

include screen titles and step 

text 

This option is not recommended for use with Guided 

Re-Record because Guided Re-Record replaces 

screen titles based on the user interface you are Re-

Recording. 

If you want the ability to translate screen titles, refer 

to Creating Translated Documents (on page 71). 

Create XLIFF file without 

including screen titles 

Select Create XLIFF files without including 

screen titles to create an XLIFF file for Re-

Recording. This option includes step text but does 

not include screen titles. 

This model is recommended for use with Scenario 3. 

For more information, refer to Scenario 3: Using 

Translation and Guided Re-Record in Parallel (on 

page 82). 

Include annotation sets Select this option if you want to include your 

annotations in the XLIFF file.  

5. Click  to browse to an export location. 
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Note the export location for later use. 

6. Click OK. 

7. Click Export. 

 

8. Perform one of the following options: 

If You Want To Then 

Edit the files to translate text or values Refer to Editing Exported Files (on page 72). 

Close the export summary window Click OK. 

 
 

Editing Exported Content for Guided Re-Record 

For each exported language, one XML Localization Interchange File Format (XLIFF) file is 

created. The exported XLIFF file(s) contain all phrases and author-entered text in the content. 

Both the phrases and the author-entered text must be translated. Boilerplate text provided with the 

template (for example, "Use this procedure to") is automatically translated via the phrases 

provided in the template. 

The file is formatted to facilitate translation by displaying the source (original) text co-located 

next to the target translated text. 

1. Open the exported XLIFF file in the desired editor. 

 
The XLIFF file can be edited via a specialized XLIFF editor such as Xliff Editor or 

Heartsome. 
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2. Edit the text or data values as necessary. 

3. Save the file(s). 
 

Importing Content for Guided Re-Record Using Scenario 1 

 
For more information on Scenario One, refer to Scenario 1: Translating 

Before Re-Record (on page 81). 

You must perform an export before you can import the files. For more 

information, refer to Exporting Content for Guided Re-Record (on 

page 85). 

1. Open the application file that has been exported. 

2. Select TRANSLATIONS > IMPORT CURRENT. 

 

3. Click  in the Import From field. 

4. Navigate to the Export to location specified in Exporting Content for Guided Re-Record (on 

page 85). 

5. Select the folder containing languages you want to import. 

6. Click OK. 

7. Select the exported language(s) for import. 



Chapter 6: Managing Content Languages 

 

Hewlett Packard Enterprise Develoment LP 89 

 

 

8. Click Import. 

 

9. Click OK. 
 

Applying XLIFF Translations for Guided Re-Record Using Scenarios 2 and 3 

 
For more information on Scenarios 2 and 3, refer to Scenario 2: Translating After Re-

Record (on page 81) and Scenario 3: Using Translation and Guided Re-Record in 

Parallel (on page 82). 

You must perform an export and Guided Re-Record before you can apply XLIFF 

translations. For more information, refer to Exporting Content for Guided Re-Record 

(on page 85) and Using Guided Re-Record Functionality (on page 79). 

1. Open the Re-Recorded file. 

2. Select TRANSLATIONS > APPLY. 

3. Navigate to the location of the exported and translated XLIFF file. 

4. Select the [filename]_[language].xlf file for which you want to apply translations. For 

example: NewDocument_ru-RU.xlf 

5. Click Open. 

6. Click OK to close the message indicating that the translations were applied successfully. 
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Chapter 7: Editing and Formatting: 
Basics 

Basic editing and formatting refers to standard editing features 

available within the Editor. These features apply to all application files. 
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Introduction to Editing and Formatting: Basics 

You can enhance your content using basic editing and formatting functionality. 

Some of the editing and formatting functions available to you include: 

 Modify content properties such as title 

 Cut, copy, and paste text 

 Spellcheck 

 Change the language of default text for content 
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Specify Content Properties 

All application content can be tagged with both built-in and custom properties. Properties are 

useful in specifying metadata about content. For example, the Transaction Code property is 

needed in the SAP environment to enable the context-sensitive help link from SAP to ART 

content. 

Several built-in property fields are delivered with the default template. You can enable and 

customize display of these properties to your authors by creating a new author template. Custom 

properties may include such items as business owner or a documentation reference number. For 

detailed information on creating a new template, refer to Using Author Templates. 

 

Specifying General Properties 

1. Create or open content. 

2. Select FILE > DOCUMENT PROPERTIES.... 

3. Click General on the left pane. 

 
Information such as the size, creation date, and last modified date are displayed as 

view-only information. 

 

4. Review the following fields: 

Field Description 

Title Edit the name for the content. 
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Field Description 

Language For information on changing the language of 

existing content text, refer to Change the Language 

of Default Text (on page 167). 

If the content is translated, select the desired 

language for the content from the drop-down list to 

enable globalization of definitions in the content. 

For information on translated content, refer to Using 

Save As. 

Allow simulation publishing 

on the Server 

To enable Server publishing of the document to 

simulation output, select the Allow Simulation 

publishing on the Server checkbox. 

This option is not available in course mode. 

Click OK. 
 

Specifying Built-In or Custom Properties 

By default, the display of all built-in properties, with the exception of Description, is disabled in 

the template. You can enable display of those properties necessary for your authors by creating a 

custom template. 

1. For information on enabling built-in properties or adding custom properties to your template, 

refer to Managing Built In Properties (on page 328). 

2. Create or open content. 

3. Select FILE > DOCUMENT PROPERTIES.... 

4. Click Properties on the left pane. 
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5. Enter values for the properties in the Value column, or select available properties from the 

drop-down lists. 

6. Click OK. 
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Using Undo and Redo During Editing 

You can undo and redo one or more editing actions in the Editor workspace. 

 

Using Undo During Editing 

Click the Undo button on the Home toolbar to remove the last edit. 

 
You can select the Undo option more than once to remove additional edits. The undo 

functionality caches up to twenty steps. 

 

 

Using Redo During Editing 

Click the Redo button on the Home toolbar to re-apply the last edit. 

 
You can select the Redo option more than once to restore additional edits. 
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Using Spellcheck 

During the spellcheck process, action text, step text, notes, narrative, tooltip text, and course 

content are reviewed. The spellcheck process does not include audio transcript text. 

 
The proofing language for the spellcheck is based on the current file's language. 

 
 

Starting a Spellcheck 

1. Create or open a file. 

2. Select HOME > SPELLCHECK. 

 
To apply changes to the entire file, allow spellcheck to complete the entire spellcheck 

task. 

 

 

Specifying Spellcheck Options 

1. Create or open a file. 

2. Select FILE > SPELLCHECK OPTIONS. 

 

3. Choose one of the following options: 
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If You Want To Then 

Allow the spellchecker to suggest 

corrections 

Select Always suggest corrections. 

Enable the spellchecker to suggest from 

main dictionaries only 

Select Suggest from main dictionaries only. 

Ignore words in uppercase Select Ignore words in UPPERCASE. 

Ignore words with numbers Select Ignore words with numbers. 

Ignore Internet and file addresses Select Ignore internet and file addresses. 

4. Optionally, under Main Dictionaries, click Add to select a dictionary. 

 
When working with multiple languages, you can add a main dictionary in another 

language so you will have the ability to spellcheck in multiple languages. When you 

click the Add button, you will need to browse to where the application's dictionaries 

are located. The default location is: C:\Program Files 

(x86)\[applicationdirectory]\Client\data\spellcheck. You will have to add your 

additional language dictionaries in this location in order to select them from the 

Spellcheck options. 

5. Optionally, under Custom Dictionaries, perform one of the following: 

 
When you use the spellcheck, it compares the words in your document with those in 

the main dictionary. The main dictionary contains most common words, but it might 

not include proper names, technical terms, or acronyms that you use. In addition, some 

words might be capitalized differently in the main dictionary than what you want in 

your document. Adding such words or capitalization to a custom dictionary prevents 

the spellcheck from flagging them as misspelled words. 

If You Want To Then 

Change the default Click on the dictionary you want to specify as the 

default.  You have to select a custom dictionary 

that is not the default or else the Change Default 

button will not activate.  

Click Change Default. 

Create a new custom dictionary Click New.... 

Browse to the location of the existing dictionary. 

Name the file. 

Click Save. 

 
To add words to a dictionary 

during spellcheck, you must 

create a custom dictionary from 

the default dictionary. You 

cannot add words to the default 

dictionary. 
 

Add an existing dictionary Click Add... to specify a dictionary. 

Edit an existing dictionary Click on the dictionary in the list box. 

Click Edit to edit the dictionary. 
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Remove a custom dictionary  Click on the dictionary in the list box. 

Click Remove to remove the dictionary. 

6. Click OK. 
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Using Save 

When you save your work, the content is saved on your local hard drive. The save location is 

specified when you first record or create the content. The Editor notifies you of progress, success, 

and failure in the status bar. 

The Editor automatically saves your work every 2 minutes. If the Editor is closed without saving, 

the last auto-saved copy of your work can be recovered. 

 

Saving Your Work 

1. Create or open content. 

2. Select FILE > SAVE. 

 
It is good practice to save your file before switching between views. 
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Using Save As 

The Save As functionality in the Editor is specifically designed to enable you to create a copy of 

the file. 

 

Using Save As to Create a Duplicate of Content 

1. Create or open content. 

2. Select FILE > SAVE AS.... 

3. Click No to create a copy. 

4. Enter a name in the File name field. 

 
Avoid the use of special characters when naming your content. 

5. Click Save. 

The duplicate will display in the Editor. 

 

Using Save As to Assign a New ID to Content 

1. Create or open content. 

2. Select File > Save As.... 

3. Click Yes to assign a new ID. 

4. Enter a name in the File name field. 

 
Avoid the use of special characters when naming your content. 

5. Click Save. 

The file with the new ID is displayed in the Editor. 
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Printing 

You can send the document view of your procedural content directly to the printer. Header and 

footer information is not included in the print output. You can also print a student guide and a 

storyboard of course content. 

 

Printing Content 

1. Create or open content. 

2. Perform one of the following options: 

If You Want To Then 

Print a document, simulation, student 

guide, or course storyboard 
Select FILE > PRINT. 

Print a course storyboard with 

annotations 

Open the course. 

Select VIEW > ANNOTATIONS. 

Select the annotation set you want to print. 

Select FILE > PRINT. 

 
Printing a course storyboard with 

annotations can provide helpful hints 

to end users and additional 

information for course instructors. 
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Closing 

Only one file can be open at a time. Close the existing open file before opening a new file. 

 

Closing the Current File 

Click FILE > CLOSE to close the current file. 

If you attempt to exit the Editor prior to saving your content, you will receive a prompt 

confirming you want to exit prior to saving. 
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Chapter 8: Editing and Formatting: 
Procedural Content 

After recording is complete, you have many options for adding and 

formatting content in both the document and simulation views. 

In addition to inserting standard objects such as steps, actions, tooltips, 

and notes, you can also specify note and step properties. 
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Introduction to Editing and Formatting: Procedural Content 

After you have captured actions in the target application, you can enhance your content using 

basic editing and formatting functionality. For basic formatting functionality, refer to Editing and 

Formatting: Basics (on page 91). In addition, you can edit procedural content to insert steps, notes, 

tooltips, and branches. 

Edits performed in one view affect the other view. In other words, when you insert a note in the 

simulation view, this note is also inserted in the corresponding location in the document view. 

Edits should be performed on content stored on your local computer. 

 
As you edit content, icons will appear in the different views to help the author identify the content 

type or action. Here is a list of the icons an author may see: 

 Audio attached to left-click action 

 
Document view/simulation view with a screen, but no action 

 Edit action/multiple key action 

 Free text area 

 Left-click action 

 
Notes 

 Right-click action 

 Screenshot that contains a step 

 Section 

 Single press/Key action 

 
Table 
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Inserting Standard Simulation Objects 

You can insert several standard simulation objects including: 

 Step: You can insert one or more steps from a new recording session or from 

an existing ART document. In addition, you can insert default steps or 

substeps during editing. 

 Note: Two types of notes are available: default notes, which can be inserted 

from the template and are intended to provide standardization across content, 

and action notes, which are automatically created and include the action text 

for an action. You can enable or disable the display of action notes. 

 Action: An action hotspot is indicated as a border around the relevant item. 

For example, an action hotspot may be displayed around a button to indicate 

that clicking the button is the desired user action. 

 Tooltip: Tooltips are displayed as notes that pop up when a user hovers over a 

specific area of the screen. 

 Branch: Branches allow you to create a primary simulation path and include 

secondary path(s) that produce the same end result but offer alternative 

methods of reaching the result. 

 

Inserting Steps 

You can use the recorder to capture your actions and create one or more new steps, or you can 

insert steps from an existing ART document. 

 
For information on editing steps properties, refer to Editing Steps (on page 115). 

 

 

Inserting a Newly-Recorded Step 

1. In the Editor workspace, click the Simulation tab. 

2. Select the position to insert the new step(s) in the Steps task pane. 
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3. Select INSERT > STEPS > FROM RECORDING... to display the recorder preview pane. 

 

4. Click  to begin recording. 

5. Perform the desired steps in the target application. 

6. Click  to stop the recording process. 
 

Inserting Steps from an Existing Simulation 

1. In the Editor workspace, click the Simulation tab. 

2. Select the position to insert the steps in the Steps task pane. 

3. Select INSERT > STEPS FROM DOCUMENT. 

4. Browse to the location of the existing document, select the .udc file, and click Open. 

 

5. In the Steps area, expand the tree view to locate the steps you want to import. 

 
A preview of the step is displayed to the right of the tree view. You can import more 

than one step at a time. Each step will be inserted as a new step within the simulation. 

6. Select the checkbox next to the steps(s) to import.  

7. Click OK. 
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Inserting Steps and Substeps 

1. In the Editor workspace, click the Simulation tab. 

2. Select the position to insert the new step(s) or substep(s) in the Steps task pane. 

3. Perform one of the following options: 

If You Want To Then 

Insert a step Select INSERT > QUICK BLOCK > STEP. 

Insert a substep Select INSERT > QUICK BLOCK > SUBSTEP. 

Create an information-only step from a 

step containing an action. 

Delete the action(s) from the step. 

Information-only steps are steps that contain 

notes and references but no action. 

4. Edit the step as desired. 
 

Inserting Notes 

Notes can be added to simulation steps to help explain an action, provide details regarding the 

step, or to provide tips to the user in playback mode. The notes display as callout boxes on top of 

the target application. 

Two types of notes are available: 

 Default Notes: A standard, information- and icon-only note that provides 

additional details for a step and provides the option to optionally highlight and 

draw attention to a specific area within a step. 

 Highlighted Notes: An information note that automatically highlights and 

draws attention to a specific area within a step. 

 
For information on note formatting options, refer to Editing Notes (on page 122). For 

information on customizing notes, refer to Specifying New Template Settings: Styles 

(on page 375). 

 

 

Inserting a Default Note 

1. In the Editor workspace, click the Simulation tab. 

2. Select the desired step in the Steps task pane. 
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3. Select INSERT > NOTE > NOTE. 

 

4. Double-click on the new note, and enter text. 

 
In addition to text, you can create a hyperlink within the note by highlighting the 

desired link text, right-clicking, and selecting INSERT > WEB LINK from the right-

click menu. 

 

 

Inserting a Highlighted Note 

1. In the Editor workspace, click the Simulation tab. 

2. Select the desired step in the Steps task pane. 

3. Select INSERT > NOTE > HIGHLIGHTED NOTE. 

 

4. Double-click on the new note, and enter text. 
 

Displaying and Hiding Action Notes in the Simulation Editor 

1. In the Editor workspace, select the Simulation tab. 

2. Right-click on the action note rubber band. 

3. Select Edit Action... to display the Action Properties window.  
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4. Click [Action Type] Action in the left pane. 

 

5. Select the Show Action Note checkbox. 

6. Click OK. 

 
For information on enabling display of action notes in published output, refer to 

Default Publication Settings: Simulation: General Settings (on page 341). For 

information on editing action notes, refer to Editing Actions (on page 129). 

 

 

Inserting Actions, Tooltips, and Branches 

Action hotspots indicate an action that must be taken to proceed to the next lesson step or branch. 

Hotspots display as colored rectangles that highlight the area of action: 

 Mouse - the area to perform a mouse action (for example, click, right-click, 

double-click). 

 Edit/Text - the area in which text must be entered to complete the action. 

 Key - the key required to execute the action (for example, F1, F2, Tab, 1, 2, a, 

b, c). 

 Drag & Drop - the areas to perform a drag-and-drop mouse action (for 

example, left down, drag, left up). 

Tooltips can be added to simulation steps to provide amplifying information about a button or area 

of the screen when the user hovers over the tooltip area. 

A branch allows you to create a primary simulation and include secondary simulations, which 

allow the same end result but offer alternative paths. 
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Although the steps to insert a branch are essentially the same as inserting steps, some pre-planning 

is usually required to ensure the simulation logic flows properly. As with the insertion of steps, 

new branches can originate as steps from an existing simulation or be captured during a new 

recording session. Secondary branches can be directed to any step in the simulation. 

 

Inserting an Action 

1. In the Editor workspace, click the Simulation tab. 

2. Select the desired step in the Steps task pane. 

3. Select INSERT and click MOUSE, EDIT, KEY PRESS, or DRAG & DROP to display the Action 

Properties window. 

 

 
For information on editing action properties, refer to Editing Actions (on page 129). 

 

 

Inserting a Tooltip 

1. In the Editor workspace, click the Simulation tab. 

2. Select the desired step in the Steps task pane. 
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3. Select INSERT > TOOLTIP... to display the Tooltip Properties window. 

 

 
For information on editing tooltip properties, refer to Editing a Tooltip (on page 137). 

 
 

Inserting a Branch for Display During Auto Playback 

1. In the Editor workspace, click the Simulation tab. 

2. Select the position to insert the branch steps in the Steps task pane. 

3. As necessary, record or insert the new branch steps. 

4. Insert the branching action that will lead to the new step via INSERT > [ACTION TYPE] 

(MOUSE, KEY PRESS, DRAG & DROP). 

5. In the Action Properties window, click [Action Type] in the left pane. 

6. Set the Go to step option for this action to be the first step in the new branch. 

7. Click OK. 

8. Right-click on the branch step from which the branch will initiate. 

9. Select Edit Step to display the Step Properties window. 
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10. Click Auto Playback in the left pane. 

 

11. In the Go to step listbox, select the action that should be simulated in the output for Auto 

Playback mode. 

12. Click OK. 

The branch will display under the appropriate step in the Task Pane. 

 
 



Chapter 8: Editing and Formatting: Procedural Content 

 

Hewlett Packard Enterprise Develoment LP 115 

 

 

Editing Standard Simulation Objects 

The standard simulation objects - steps, notes, actions, and tooltips - can be edited to modify their 

display and functionality. The Steps task pane displays the text-only information about the step. 

You can use the step text editor to edit the step information. 

In addition to editing simulation objects using the toolbar and right-click menu, you can double-

click on steps within the task pane to open the Step Properties window. 

 

Editing Steps 

You can edit the general, audio, auto playback, screen, and step text properties of a simulation 

step by right-clicking or double-clicking on a step in the task pane. 

You can view context information for enterprise systems recorded using the application. This will 

assist in setting up context-sensitive help with the Server, as an author will be able to easily 

identify screen information within a ART document. For more information on context-sensitive 

help, refer to Setting Up Online Help. 

 

Editing a Simulation Step: Reordering Steps 

1. In the Steps task pane, click on the step you want to move. 

2. Drag the step to above or below the step where you want it to display. 

 
This action will automatically renumber the steps. 
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Editing a Simulation Step: Step Text Editor 

1. Select VIEW > SHOW STEP TEXT EDITOR to display the step text editor. 

 

2. In the Steps task pane, select the step to be edited. 

 
Action text is highlighted with the background color of the action note styles. Action 

text displays in the same color as the text within the note. This will allow you to 

confirm that the text you are editing is for an action. 

3. Edit the step text in the editor. 

4. Optionally, click Regenerate Text to revert to the last saved text. 
 

Editing a Simulation Step: General Properties 

1. Double-click on the step in the Steps task pane. 

2. Select General in the left pane. 

 

3. Edit the following fields: 
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Field Description 

Help text To display the default help text when the user makes 

an incorrect response during the Self-Test or 

Assessment mode, enable the Use default help text 

checkbox. 

To display custom help text, disable the Use default 

help text checkbox, and enter your text in the Help 

text field. 

Cursor image Browse to select the cursor graphic displayed during 

the particular step. 

Use composite Brings extra attention to the hotspot by slowly 

blacking out the screen (except for the hotspot area) 

and then returning to the screen display. 

Include in assessment grade To include this step in the grade calculated for 

Assessment mode, select the Include in assessment 

grade checkbox. 

Visibility To display this step in the simulation view, select the 

Simulation View checkbox. 

To display this step in the document view, select the 

Document View checkbox. 

4. Click OK. 
 

Editing a Simulation Step: Audio Properties 

 
To enable MP3 recording, refer to Installing LAME (on page 228). 

1. Double-click on the step in the Steps task pane. 

2. Click Audio in the left pane. 

  

 
For more information, see Importing an Audio File (on page 230) and Creating an 

Audio File (on page 229). 
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3. From the Audio source drop-down list, select one of the following options: 

If You Want To Then 

Disable text to speech and include 

manual audio file. 

Select Manual. 

Click Browse... to select the audio file. 

Enable text to speech for step text. Select Step text [TTS]). 

Enable text to speech for transcript. From the Audio source drop-down list, select 

Transcript [TTS]). 

Enable text to speech for step text 

followed by transcript. 

Select Step text followed by transcript [TTS]). 

Enable text to speech for transcript 

followed by step text. This is the 

default setting. 

Select Transcript followed by step text [TTS]). 

 
For more information on using text to speech options, refer to Using Text to Speech 

(on page 233). 

4. Select  to launch the Recording Options dialog. 

5. Complete the following fields: 

Field Description 

Recording Device Specify the input recording device. This selection is 

computer specific. 

Recording Quality Specify the audio quality setting. 

Setting MP3 WAV 

High 320kbps 16-bit sampling 

Medium 128kbps 8-bit sampling 

Low 64kbps 8-bit sampling 
 

Transcript Enter text in the Transcript text box. 

6. Once you have set your options, the following controls are activated: 

Control Description 

      
Click Pause to pause the current recording 

     
Click Stop to stop the current recording. 

     
Click Play to review the current recording. 

7. Click OK to save your changes and close the Recording Options dialog. 

8. Select Localized to mark the content for localization. 

9. Click OK. 
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Editing a Simulation Step: Auto Playback Properties 

1. Double-click on the step in the Steps task pane. 

2. Click Auto Playback in the left pane. 

 

3. Edit the following fields: 

Field Description 

Time length Specify the delay between each simulation step 

during Auto Playback mode. 

To use the default wait time specified in the 

template, select Use default time length. 

To specify a custom wait time, enter the value in the 

Time length field. 

Go to step Edit the next step or action to be displayed during 

Auto Playback mode. 

Use this option to set which branch should be 

displayed in Auto Playback mode. 

4. Click OK. 
 

Editing a Simulation Step: Screen Properties 

1. Double-click on the step in the Steps task pane. 

2. Click Screen in the left pane. 
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3. Optionally, you can edit the screen title of the main window of the target application during 

this particular step. 

 

4. As desired, select one of the following options: 

If You Want To Then 

Paste a new image from the clipboard Copy the new background image to be used to 

your Microsoft Windows clipboard. 

Click Paste. 

Copy the current image to the clipboard 

for editing in an external application 

Click Copy, and edit the image in the external 

application. 

Copy the edited image to your Microsoft 

Windows clipboard, and click Paste (as 

described above) to replace the background 

image. 

Change the display of the image to 

reflect either the entire desktop or only 

the application window 

Click Edit..., and select Regions on the resulting 

screen. 

Select the area you want to display. 

Click OK. 

Click OK. 

 
If the clipboard image you are pasting is larger than the current image, a prompt is 

displayed. Select Yes to resize the clipboard image before pasting, or select No to 

insert the image without resizing. 

5. Click OK. 
 

Editing a Simulation Step: Step Text Properties 

1. Double-click on the step in the Steps task pane. 
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2. Click Step text in the left pane. 

 

 

3. Edit the following fields: 

Field Description 

Step text Displays the current step text. 

Actions You can select any action text in the Actions list 

box and click Insert to include the text in the step 

text. 

You can also insert additional text before or after the 

action text by entering the text in the Step text field. 

For example, you can insert "and" or "or" to join 

two actions in a sentence. 

4. Click OK. 
 

Editing a Simulation Step: Viewing and Editing Context Information 

1. Double-click on the step in the Steps task pane. 

2. Click Context Information in the left pane. 

 

3. Review/edit the following fields: 
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When an author records applications for which context information is captured by the 

recorder, that data is placed into the PrimaryContextID, SecondaryContextID, and 

TertiaryContextID fields at the step-level. 

Depending on the application or enterprise system recorder, some of these fields will 

may not be populated. If a step has an action, then these fields will be editable. When a 

step has multiple actions then three fields will show Context Information of default 

action. 

 
Depending on the application or enterprise system recorder, some fields will not be 

populated. 

Field 
Description 

Primary Displays the transaction code(s) or screen ID(s) 

associated with the step. 

Secondary Displays the ID for the screen. 

Tertiary Displays the location of the application recorded 

into the step. 

 

 

Editing Notes 

You can edit and format note text, modify the note display characteristics, and edit the note 

pointer location and icon. 

Notes and action notes have different characteristics. For more information on editing action 

notes, refer to Editing an Action: Edit (on page 130). 

 

Editing a Note: Note Text 

1. Double-click on the note. 

2. Highlight the text to be edited or place the cursor at the insertion point. 

3. Right-click and select from among the following edit and format options: 

Option Description 

Edit Several editing options are available, including: 

undo and redo; cut, copy, paste; find and replace; 

select all; and delete. 
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Option Description 

Format Select Font Dialog to specify the font style and size. 

Select Font Color to specify the font color. 

Modify the character format using the Bold, Italic, 

Underline, Superscript, Subscript, and Strikeout 

options. 

To return the character format to the default, select 

Normal. 

Modify the paragraph format using the indent and 

list functionality. 

Justify Select Left, Center, or Right to specify the text 

justification. 

Icon Select an icon for the note. 

Insert: Heading Select INSERT > INSERT HEADING. 

Insert: Example Select INSERT > INSERT EXAMPLE. 

Insert: Menu Item Select INSERT > INSERT MENU ITEM. 

Insert: Standard Code Select INSERT > STANDARD CODE. 

Search for a standard code or select from the Code 

list. 

Insert: Line Select INSERT > INSERT LINE. 

The line will be placed before the text if the cursor is 

at the beginning of the text; or the line will be placed 

after the text if the cursor is at the end of the text. 

Insert: Image Right-click on the text for which you want to insert 

an image, and select INSERT > INSERT IMAGE. 

Specify the image location, caption, and alignment. 

Check the Localized checkbox to indicate that the 

image is specific to the current language. 

Insert: Captured Image Highlight the text for which you want to insert a 

captured image, and select INSERT > CAPTURED 

IMAGE. 

Specify the application to capture. 

Click and drag the crosshair to select the image to 

capture. 

Insert: Table Right-click on the text for which you want to insert a 

table, and select INSERT > INSERT TABLE. 

Specify the properties. 
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Option Description 

Insert: Link Highlight the text for the link, and select INSERT > 

INSERT LINK. 

Specify the type of link, the target window, and 

location. 

Check the Localized checkbox to indicate that the 

link is specific to the current language. 

You must publish the document in order to activate 

the link. 

Insert: Field Entry Select INSERT > INSERT FIELD ENTRY. 

Insert: Page Break Select INSERT > INSERT PAGE BREAK. 

Free text Select INSERT > FREE TEXT and select from the 

available free text options. 

Note Select INSERT > NOTE and select Note or 

Highlighted Note to insert a new note. 

Steps Select INSERT > STEPS and select from the 

available options to insert a new step after the note. 

 
Many of the text format options are also available via the toolbars. 

 

 

Editing a Note: General 

1. Right-click on the note in the Editor workspace. 

2. Select Edit Note... to display the Note Properties window. 

3. Click General in the left pane. 
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4. Edit the following fields: 

Field Description 

Icon Select a note icon from the drop-down list. 

Document View To display this note in the document view, select the 

Document View checkbox. 

Enable callout in document 

view 

To display a callout for this note, select the Enable 

callout in document view checkbox. 

 
Callouts must be enabled in the Template 

Editor and in the options menu in order 

for them to display in published output. 

For more information, refer toDefault 

Publication Settings: Document (on page 

338) and Specify Document and 

Simulation Editor Options (on page 39). 
 

Simulation View Select the checkbox next to Assessment Tutorial, 

Auto Playback Tutorial, Self Test Tutorial, and/or 

Standard Tutorial to display this note in the 

simulation views. 

5. Click OK. 
 

Editing a Note: Format 

1. Right-click on the note in the Editor workspace. 

2. Select Edit Note... to display the Note Properties window. 

3. Click Format in the left pane. 

 

4. Click the picture of the desired note format. 

5. Click OK. 
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Editing a Note: Style 

1. Right-click on the note in the Editor workspace. 

2. Select Edit Note... to display the Note Properties window. 

3. Click Style in the left pane. 

 

4. Edit the following fields: 

Field Description 

Style (Document) Select a note icon from the drop-down list. 

Style (Simulation) To display this note in the document view, select 

the Document View checkbox. 

Width To display this note in the simulation view, select 

the Simulation View checkbox. 

Height To display a callout for this note, select the Enable 

callout in document view checkbox. 

Border Color Click ... to select a color for the border. 

Border size Select a border size from the drop-down list. 

Background color Click ... to select a background color. 

Number of consecutive steps 

shown over 

Click the up or down arrow to select a number of 

consecutives steps to which the note style should be 

applied. 

5. Click OK. 
 

Editing a Note: Highlight Area 

1. Right-click on the note in the Editor workspace. 

2. Select Edit Note... to display the Note Properties window. 
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3. Click Highlighted Area in the left pane. 

 

4. Edit the following fields: 

Option Description 

Display Highlighted Area Select the Display Highlighted Area checkbox to 

display the highlighted area for the note. 

Border Color Select a border color from the drop-down or click 

Select to choose a custom color. 

Border Size Select a border size for the highlighted area. 

Fill Color Select a fill color from the drop-down or click Select 

to choose a custom color. 

Transparency Select a transparency for the highlighted area. 

 
 

Editing a Note: Source 

1. Right-click on the note in the Editor workspace. 

2. Select Edit Note... to display the Note Properties window. 
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3. Click Source in the left pane. 

 

4. Edit the source code. 

 
Knowledge of HTML is required. 

 

 

Editing a Note: Auto Playback Timing 

1. Right-click on the note in the Editor workspace. 

2. Select Edit Note... to display the Note Properties window. 

3. Click Auto Playback Timing in the left pane. 

 

4. Edit the following fields: 

Option Description 

Display Delay Select the wait time before the note is displayed. 

Duration Select the amount of time the note is displayed 

before it is removed from the screen. 
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Option Description 

Entry Animation Select an animation method used to make the note 

visible on screen. 

Exit Animation Select an animation method used when the note is 

removed from the screen. 

5. Click OK. 
 

Editing Actions 

You can edit and format the general and display properties of mouse, edit, key, and drag & drop 

actions. 

You can also switch an action type, which allows you to utilize existing content without having to 

recreate a step.  

 

Editing an Action: Mouse 

1. Right-click on the mouse action rubber band in the Editor workspace. 

2. Select Edit Action... to display the Action Properties window. 

3. Click Mouse action in the left pane. 

 

4. Edit the following fields: 

Field Description 

Action Select the mouse action required for the user to 

move to the next step. 

Modifiers If necessary, specify the Shift, Control, and/or Alt 

key modifiers to accompany the mouse action. 
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Field Description 

Go to step Edit the next step to be displayed after performing 

the action. 

Use this option to create a new branch in the 

simulation. 

Show Action Note Select this option to display the action note in the 

Simulation Editor. 

Show Action Right To Left Select this option to display the action from right to 

left. 

Action text Enter the specific instructional text to display to the 

user. 

This text is also displayed in action notes and step 

text. Right-click in this field to format the text. 

To reflect a change in the action type or a change in 

the language, click Reset to Default Text to reset 

the action text. (You must click Apply to save any 

changes in the current session before you can reflect 

the changes via Reset to Default Text.) 

5. To edit hotspot properties, refer to Editing an Action: Hotspot (on page 134). 

6. To edit advanced properties, refer to Editing an Action: Advanced (on page 135). 

7. Click OK. 
 

Editing an Action: Edit 

1. Right-click on the edit action rubber band in the Editor workspace. 

2. Select Edit Action... to display the Action Properties window. 

3. Select Edit action in the left pane. 

 

4. Edit the following fields: 
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Field Description 

Entry type Select the type of text entry required for the user to 

move to the next step. 

Free text playback means the user can enter 

anything in this field to proceed to the next step. 

Exact text playback means the user must enter text 

that matches your designated entry. 

Regular Expression playback allows the user to 

enter any data matching the specified regular 

expression pattern to proceed to the next step. When 

using regular expression, the user must press a 

specific key to exit the field: the Enter key is 

supported in Flash output. 

Enter the expression in the Text field. 

Example: Email address 

Example: ^([a-z\.]+)@([a-z\.]+)$  

In this example, abc@xxx.org would be permitted, 

while ABC@xxx.org would not be permitted. 

Example: ^([a-zA-Z0-9]+)@acme.com$  

In this example, any email address (in upper- or 

lowercase) from acme.com would be permitted. 

Example Text Type the specific text or regular expression pattern 

the user must enter. 

Go to step Edit the next step to be displayed after performing 

the action. 

Use this option to create a new branch in the 

simulation. 

Hint Enter the hint to be displayed during Self-Test or 

Assessment modes. 

Show Action Note Select this option to toggle the display of the action 

note in the Simulation Editor. 

Show Action Right To Left Select this option to display the action from right to 

left. 

Action text Enter the specific instructional text to display to the 

user. 

To reflect a change in the action type or a change in 

the language, click Reset to Default Text to reset 

the action text. (You must click Apply to save any 

changes in the current session before you can reflect 

the changes via Reset to Default Text.) 

5. To edit hotspot properties, refer to Editing an Action: Hotspot (on page 134). 
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6. To edit advanced properties, refer to Editing an Action: Advanced (on page 135). 

7. Click OK. 
 

Editing an Action: Key 

1. Right-click on the key action rubber band in the Editor workspace. 

2. Select Edit Action... to display the Action Properties window. 

3. Click Key action in the left pane. 

 

4. Edit the following fields: 

Field Description 

Key Select the key action required for the user to move 

to the next step. 

Modifiers If necessary, specify the Shift, Control, and/or Alt 

key modifiers to accompany the key action. 

Go to step Edit the next step to be displayed after performing 

the action. 

Use this option to create a new branch in the 

simulation. 

Hint Enter the hint to be displayed during Self-Test or 

Assessment modes. 

Show Action Note Select this option to toggle the display of the action 

note in the Simulation Editor. 

Show Action Right To Left Select this option to display the action from right to 

left. 
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Field Description 

Action text Enter the specific instructional text to display to the 

user. 

To reflect a change in the action type or a change in 

the language, click Reset to Default Text to reset 

the action text. (You must click Apply to save any 

changes in the current session before you can reflect 

the changes via Reset to Default Text.) 

5. To edit hotspot properties, refer to Editing an Action: Hotspot (on page 134). 

6. To edit advanced properties, refer to Editing an Action: Advanced (on page 135). 

7. Click OK. 
 

Editing an Action: Drag & Drop 

1. Right-click on the drag & drop action rubber band in the Editor workspace. 

2. Select Edit Action... to display the Action Properties window. 

3. Click Drag & Drop action in the left pane. 

 

4. Edit the following fields: 

Field Description 

Modifiers If necessary, specify the Shift, Control, and/or Alt 

key modifiers to accompany the key action. 

Go to step Edit the next step to be displayed after performing 

the action. 

Use this option to create a new branch in the 

simulation. 
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Field Description 

Show Action Note Select this option to toggle the display of the action 

note in the Simulation Editor. 

Show Action Right To Left Select this option to display the action from right to 

left. 

Action text Enter the specific instructional text to display to the 

user. 

To reflect a change in the action type or a change in 

the language, click Reset to Default Text to reset 

the action text. (You must click Apply to save any 

changes in the current session before you can reflect 

the changes via Reset to Default Text.) 

5. To edit hotspot properties, refer to Editing an Action: Hotspot (on page 134). 

6. Click OK. 
 

Editing an Action: Hotspot 

1. Right-click on the [Action Type] rubber band. 

2. Select Edit Action... to display the Action Properties window.  

3. Click Hotspot in the left pane. 

 

4. Edit the following fields: 

 
Options display based on the action type selected. 

Field Description 

Width Specify the width of the hotspot in pixels. 

Height Specify the height of the hotspot in pixels. 



Chapter 8: Editing and Formatting: Procedural Content 

 

Hewlett Packard Enterprise Develoment LP 135 

 

 

Border size Select the width of the hotspot border from the drop-

down list. 

Playback color Select the playback color of the hotspot from the 

drop-down list. 

Select the Use default setting checkbox to specify 

the template default. 

Cursor image Browse to select the cursor graphic displayed inside 

the action hotspot. 

5. Click OK. 
 

Editing an Action: Advanced 

1. Right-click on the [Action Type] rubber band. 

2. Select Edit Action... to display the Action Properties window. 

3. Click Advanced in the left pane. 

 

4. Select a control type for the action rubber band from the Control Type drop-down list. 

 
This is useful if you want to change the control type for the action on a step. For 

example, if you want to change "Main Menu" to "Menu item," or if you have inserted a 

step manually and want to define a control type for the action. For example, changing 

the manually-inserted action from the default "Unknown" to "List Box." 

5. Select an action type from the Action Type drop-down list. 

6. Click OK. 
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Editing an Action: Auto Playback Timing 

1. Right-click on the [Action Type] rubberband. 

2. Select Edit Action... to display the Action Properties window. 

3. Click Auto Playback Timing in the left pane. 

 

4. If you want to manually select the auto playback timing options for the rubber band, deselect 

the Use default timing checkbox and edit the fields in Step5. 

5. Edit the following fields: 

Option Description 

Display Delay Select the wait time before the action is displayed. 

Action Animation Delay Select the wait time before the animation begins. 

Action Animation Duration This field is not editable. The default value must be 

used. 

Entry Animation Select an animation method used to make the action 

visible on screen. 

Exit Animation Select an animation method used when the action is 

removed from the screen. 

6. Click OK. 
 

Displaying and Hiding Action Notes in the Simulation Editor 

1. In the Editor workspace, select the Simulation tab. 

2. Right-click on the action note rubber band. 

3. Select Edit Action... to display the Action Properties window.  
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4. Click [Action Type] Action in the left pane. 

 

5. Select the Show Action Note checkbox. 

6. Click OK. 

 
For information on enabling display of action notes in published output, refer to 

Default Publication Settings: Simulation: General Settings (on page 341). For 

information on editing action notes, refer to Editing Actions (on page 129). 

 

 

Moving and Adjusting a Rubber Band 

1. Click on the rubber band. 

2. Drag the rubber band to the desired location on the image, or click and drag on a sizing handle 

to resize. 

 
Optionally, you can use the cursor keys to move the rubber band around on the image. 

The action note tail will snap to the location closest to the center point of the action 

note associated with the hotspot. 

 
 

Editing a Tooltip 

1. Right-click on the tooltip in the Editor workspace. 
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2. Select Edit Tooltip... to display the Tooltip Properties window. 

 

3. Click General in the left pane, and edit the following fields: 

Field Description 

Text Enter the specific text to display to the user. 

Width Specify the width of the hotspot in pixels. 

Height Specify the height of the hotspot in pixels. 

4. Click OK. 
 

Editing a Branch for Display in Auto Playback 

1. Click on the branch step in the Steps task pane. 

2. In the Content Pane, right-click on the branch action rubber band. 

3. Select Edit Action... to display the Action Properties window. 

4. Click the [Action Type] in the left pane. 

 

5. Select the desired step number or action in the Go to step field. 

6. To edit hotspot properties, refer to Editing an Action: Hotspot (on page 134). 

7. To edit Advanced properties, refer to Editing an Action: Advanced (on page 135). 
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8. Click OK. 
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Using Document Sections 

The document view in the Editor is divided into several sections. Sections are used to provide 

'containers' for specialized information that you may wish to use in your published content. The 

inclusion and order of sections is dictated by your template. 

Sections are displayed in the Layout task pane. When you expand a section displayed in the task 

pane, you can click on a sub-section to navigate to that location in the content area. 

 
Several standard document sections are delivered with the application: 

 Purpose (Overview) - contains front matter information. 

 Configuration Information: Lists information such as configuration menu path, 

key field changes, and date of configuration change. 

 Test Information: Documents the test conditions, expected results, and actual 

results that ensure that the related transaction has been correctly configured 

and documented and is functioning correctly in the system. 

 ASAP BPP: Mimics the business process procedure (BPP) documents 

delivered with an Accelerated SAP (ASAP) implementation. 

 Exercise/Data Sheet: Provides a user training document that includes data for a 

given procedure, and tasks and questions for students to complete. For 

additional information on the exercise section, refer to Generating the Exercise 

Section (on page 165). 
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 Screenflow: Provides a graphical overview of the entire task or process. For 

additional information on the screenflow section, refer to Working with the 

Screenflow (on page 168). 

 Procedure - end user procedures with steps, field description tables, and screen 

shots. 

 Result - provides a location to enter any final comments or notes. 

Sections can be included or excluded from your documents via the template. In addition, the 

administrator can create custom sections within the author template. For more information on 

author templates, refer to Create and Open a New Author Template (on page 319). 

 

Editing Document Sections 

The document view in the Editor contains overview information consisting of: 

 Purpose: intention of the document 

 Trigger: activities that may trigger use of the documented procedure 

 Prerequisites: requirements for using the documented procedure 

 Menu Path: menu path for initiating the application or transaction addressed in 

the document 

 Transaction Code: references the transaction code to which the document 

refers 

 Helpful Hints: information that the end user may find beneficial 

In addition, each application document contains a Result section at the conclusion of the 

procedure steps. These sections, and the Configuration, Test, and ASAP BPP sections, can be 

edited to include supplemental text, tables, and images. 

The majority of editing and formatting options are available from both the toolbars and the right-

click menu. 
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Inserting Objects in Document Sections 

Inserting Text 

1. Create or open a document. 

2. Click the Document tab. 

3. Place the cursor at the desired insertion point. 

4. Enter text. 
 

Inserting a Manual Page Break 

1. Place the cursor where you want to insert the page break. 

2. Select INSERT > PAGE BREAK. 

3. To remove, right-click on the page break or the step after the page break and select Remove 

Page Break. 
 

Inserting a Web, File, or Intra Link 

1. Highlight the free text or text within a note. 

2. Select INSERT > LINK to enter a link to a URL or file. Select INSERT > INTRA-LINK to add a 

link to a location within the document. 

3. Enter text and, as desired, complete the following fields: 

Field Description 

Type Select Web Link to add a link to a URL or to a file. 

Select Intra-Link to add a link to a location within 

the document. 

Text Displays the text selected for link. This field is not 

editable. 

Target For a web link, select the action for the link: 

Default: Opens the link based on your browser 

settings. 

New Window: Opens the link in a new browser 

window. 

Same Window: Opens the link in an existing 

browser window. 

Link Location Enter a URL address. 
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Field Description 

Intra-Link Location Select a location within the document. 

4. Check the Localized checkbox to mark the content for localization. 

5. Click Insert. 
 

Inserting Headings, Examples, and Menu Items 

1. Create or open a document. 

2. Click the Document tab. 

3. Place the cursor at the desired insertion point. 

4. As desired, select one of the following options: 

If You Want To Then 

Insert a heading and sub-bullets Select INSERT > HEADER. 

Insert an example Select INSERT > EXAMPLE. 

Insert a menu item Select INSERT > MENU ITEM. 

Insert a standard code Select INSERT > QUICK BLOCK 

>DOCUMENT CODE. 

 
 

Inserting a Table 

1. Position the cursor where the table is to be inserted in the Document Editor. 
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2. Select INSERT > TABLE. 

 

3. Complete the following fields: 

Field Description 

Rows Enter the number of table rows. 

Columns Enter the number of table columns. 

Border Enter a value for the table border width. 

Include Header Row in Table Specify if the table should include a header row. 

Alignment Specify a Left, Center, or Right alignment for the 

position of the table. If Default is selected the 

template settings are used. 

Width Specify Percent or Pixels, and enter the width of the 

table. 

Table Style Specify a style for the table. 

Table Header Style Specify a style for the table header. 

Cell Padding Specify the amount of space between the border of 

the cell and the content of the cell. 

Cell Spacing Specify the amount of space between the cells 

within a table. 

Table Cell Style Specify a style for the table cells. 

 
For more information on setting table styles in the template, refer to Specifying Styles 

(on page 375). 
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4. Click Insert to insert the table. 
 

Inserting and Deleting Rows and Columns 

1. Right-click on the table and select Table. 

2. Choose from the following options: 

Field Description 

Properties Allows you to edit the properties specified in 

Inserting a Table (on page 143). 

Insert Row Inserts a row below the selected row. 

Delete Row Deletes the selected row. 

Insert Column Inserts a column to the left of the selected column. 

Delete Column Deletes the selected column. 

 
 

Inserting and Editing a Field/Description or an If/Then Table 

A Field/Description table is used to capture the name of the field; whether the field is required, 

optional, or conditional; and a description of the field. An editable area below the table allows you 

to enter additional information about what the table contains. 

An If/Then table provides the user with more than one performance option before continuing to 

the next step. 

1. Position the cursor where the table is to be inserted. 

2. Select INSERT > QUICK BLOCK > STEP. 

3. Position the cursor in the step you just inserted. 

4. Select INSERT > QUICK BLOCK. 

5. Choose from the following options: 

If You Want To Then 

Insert a Field/Description Table Select Field. 

Insert an If/Then Table Select If. 

6. Optionally, right-click within the table, and select INSERT > QUICK BLOCK > FIELD ENTRY 

to insert a new field into the table. 



Chapter 8: Editing and Formatting: Procedural Content 

146 Hewlett Packard Enterprise Develoment LP 

 

7. Optionally, click on the Example text and press the Delete key to remove the Example field 

from the table. 

 
Manually inserted Field/Description tables are not globalized. For more information on 

globalizing, refer to Using Globalize. 

 

Inserting an If/Then/Go To Table 

An If/Then/Go To table provides a user with more than one performance option to complete 

before branching to another step. 

1. Click the Simulation tab 

2. Select the step in which you want to insert an If/Then/Go To table. 

3. Select INSERT > [ACTION TYPE]. 

4. Edit the action properties. 

5. Click OK. 

6. Right-click on the step and select Edit in document view to edit the If/Then/Go To table. 

7. Optionally, right-click in a row and select Move Up or Move Down to reorder the rows in the 

table. 
 

Inserting a Free Text Block 

1. Position the cursor where the free text block is to be inserted. 

2. Select INSERT > QUICK BLOCK> FREE TEXT. 
 

Inserting a Note 

1. Position the cursor where the note is to be inserted. 

2. Select INSERT > NOTE > NOTE OR HIGHLIGHTED NOTE. 

 
Notes can be added to Field/Description tables by dragging the note into the Field 

Description item on the task pane. Dropping a note in a Field/ Description table with a 

horizontal bar at the bottom of the task pane item will drop the note into that row of the 

Field/Description table, beneath the example, while dropping a note with the horizontal 

bar above the row will split the Field/Description table rows. Dropping the note with 

the horizontal bar above the top field description example will cause the note to be 

placed above the Field/Description table. 
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Inserting an Icon 

1. Position the cursor in the free text block, note, or Field/Description into which you want to 

insert an icon. 

2. Right-click and select ICON > [ICON]. You can also click INSERT > ICON from the toolbar. 
 

Inserting a Step 

1. Position the cursor where the step is to be inserted. 

2. Select INSERT > QUICK BLOCK > [STEP]. 

3. As desired, select one of the following options: 

If You Want To Then 

Insert a new Field_Description table for 

a step 

Select Field. 

Insert a new If_Then table for a step Select If. 

Insert a new step with the text "Start 

the transaction using the menu path or 

transaction code:" 

Select Start the task using the menu path. 

Insert a new step Select Step. 

Insert a new substep Select SUBSTEP. 

 
If you are inserting a step from the first step, you will be prompted as to where you 

want to insert the step. 

 

 

Editing Objects in Document Sections 

Editing Button Image Layout 

1. Create or open a document. 

2. Click the Document tab. 

3. Navigate to the step containing the button image you want to edit. 
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4. Right-click on the image. 

5. Select Edit Image. 

 

6. Choose from the following options: 

Field Description 

Location Location of the button or image. 

Caption Enter a caption for the button or image. 

Layout Select Left or Right from the drop-down menu for 

the location of your button or image. For example, 

selecting Right positions the button or image to the 

right of the step text. 

Use template zoom options Check Use template zoom options to default to the 

template options for zooming images. 

Enable zoom Check Enable zoom to enable the image to be 

zoomed within the published layout. 

7. Click Insert. 
 

Copying Steps, Notes, and Free Text Blocks 

1. In the Task Pane, right-click on the step, note, or free text block to be copied. 

2. Select EDIT > COPY. 

3. Click below the object where you would like to insert the step, note, or free text. 

4. Right-click, and select EDIT > PASTE to paste the step, note, or free text. 
 

Deleting Steps, Notes, and Free text Blocks 

1. In the Task Pane, right-click on the step, note, or free text block to be deleted. 

2. Select EDIT > DELETE to delete the object. 
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Deleting a Web Link 

1. Right-click on the web link you want to delete. 

2. Click Remove Link. 
 

Editing Text 

1. Create or open a document. 

2. Highlight the text to be edited. 

3. Right-click and select the desired option from the Edit submenu. 
 

Editing the Format of Blocks Within a Section 

1. Create or open a document. 

2. Click the Document tab. 

3. Double-click the desired block in the Layout pane (for example, Configuration Information). 

4. Click Format in the left pane. 

5. Select a style from the Style drop-down list. 

6. Optionally, select or deselect the Visible checkbox. 

7. Click Source in the left pane. 

8. Edit the source code. 

 
Basic knowledge of HTML is required. 

For detailed information on editing blocks, refer to Specifying New Template Settings: Blocks (on 

page 382). 

9. Click OK. 
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Editing Notes and Free Text 

1. Create or open a document. 

2. Click the Document tab. 

3. In the Content Area, right-click on the note or free text you want to edit. 

4. Choose from the following options: 

If You Want To Then 

Insert an object Select Insert, and select an object from the list. 

Delete the note or free text Select EDIT > DELETE. 

Modify the note or free text Select EDIT > [Freetext or Note] ..., and go to 

Step 5. 

5. In the Format pane choose from the following options: 

 
Depending on the item selected, some of the following options may not display. 

Field Description 

Document Select a style from the Style drop-down list. Click in 

the checkbox next to Visible to enable display in 

published output. 

Simulation Select a style from the Style drop-down list. Click in 

the checkbox next to Visible to enable display in 

published output. 

Note Select an icon from the Icon drop-down list. Click 

the checkbox next to Pointer to enable a pointer in 

published output. 

6. In the Source pane, edit the note or free text. 

7. Click OK to apply changes. 
 

Editing Steps 

1. Create or open a document. 

2. Click the Document tab. 

3. Perform one of the following options: 
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If You Want To Then 

Edit a single step In the Task Pane, right-click on the step you 

want to edit. 

Select Insert, and select an object from the list. 

Go to Step 5. 

Edit multiple steps In the Task Pane, Shift+left-click, or Ctrl+left-

click, to select multiple steps. 

Right-click on any selected step. 

Go to Step 4. 

4. Choose from the following options: 

If You Want To Then 

Insert an object Select Insert, and select an object from the list. 

Delete the step Select Delete. 

Modify the step Select Edit Step ... and go to Step 5. 

Copy the step Select Copy. 

Paste content in the selected step Select Paste. 

Cut the step to paste in another location 

within the document 

Select Cut. 

Edit the step in simulation view Select Edit in Simulation View to open the step 

in simulation view and edit. 

5. Right-click on any step and select Edit Step.... 

6. In the Format pane choose from the following options: 

Field Description 

Document Select a style from the Style drop-down list. 

Select the Make Step Visible checkbox to enable 

display in the published output. 

Select the Make Callouts Visible checkbox to 

enable display in the published output. 

Simulation Select the Make Step Visible checkbox to enable 

display in the published output. 

Step Numbers Select a style from the Style drop-down list to select 

the style of the step-action type. 

Select a level from the Level drop-down list to 

enable the step as a sub-step. 
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7. In the Source pane, edit the source code. 

 
Depending on what action the step contains, this pane may not be available. Basic 

knowledge of HTML is required. 

8. In the Screen pane, choose from the following options: 

Field Description 

Screen title Select a screen title from the Screen title drop-down 

list or manually specify a caption. 

Optionally, select Use this screen title in all views. 

Use this screen title in all 

views 

Select the Use this screen title in all views option 

to use the selected screen title for all matching 

screens in the document. 

Current background image Click Edit... or use the Copy and Paste commands 

to specify a screen to use for the step or to choose an 

appropriate thumbnail on the Available Backgrounds 

window. 

Show the screen for this step 

in the document 

Only if it is the first time this screen is used: 

Displays a new screen only if the screen is different 

from the previous step. This is the default action. 

Never: Does not display a screen for this step. 

Always: Displays a new screen for the step. 

9. In the Step pane, choose from the following options: 

 
This pane is only available if the object is a field entry in a Field/Description table. 
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If You Want To Then 

Enable a field Click the Enabled checkbox to display the label 

during publication. 

Add a new label Click Add. 

Enter a caption in the Caption field. 

Select a location from the Location drop-down list. 

Click OK. 

Modify a field Select a label from the Label window. 

Click Modify. 

Edit the caption in the Caption field. 

Edit the location in the Location drop-down list. 

Click OK. 

Delete a field Select a label from the Label window. 

Click Delete. 

Specify a field requirement Select Required, Optional, or Conditional from the 

Required drop-down list to determine the 

requirement for the step. 

Optionally, you can edit the requirement by clicking 

on the requirement in the R/O/C column in the 

Field/Description table in the Editor Pane, and then 

selecting a requirement from the drop-down list. 

Show example section Select Show Example Section to display the 

example section. 

Enter example text Enter text to display in the example section. 

10. Click Context Information in the left pane. 

11. Review the context information. 

 
For more information, refer to Editing a Simulation Step: Viewing Context 

Information (see "Editing a Simulation Step: Viewing and Editing Context 

Information" on page 121). 

12. Click OK. 
 

Modifying Paragraphs 

Setting the Paragraph Format 

1. Right-click within the paragraph you wish to edit and select Format. 
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2. Modify the paragraph format using the indent and list functionalities. 
 

Setting the Paragraph Justification 

1. Right-click within the paragraph you wish to edit, and select Justify. 

2. Select Left, Center, or Right to specify the text justification. 
 

Modifying Characters 

Setting the Font Type and Size 

1. Highlight the text. 

2. Right-click and select Format. 

3. Select Font Dialog to specify the font style and size, or select Font Color to specify the font 

color. 
 

Setting the Character Format 

1. Highlight the text. 

2. Right-click and select Format. 

3. Modify the character format using the Bold, Italic, Underline, Superscript, Subscript, and 

Strikeout options. To return the character format to the default, select Normal. 
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Working With Images, Masks, and Callouts 

Images allow you to provide graphic examples within your documents and simulations. You can 

control what displays in your images and reduce the amount of time your authors spend editing 

and formatting after image capture. You don't have to take extra steps to modify a screen shot, 

alter information, or move action notes to hide non-pertinent information.  

Callouts allow you to bring attention to specific controls and regions on screen images within a 

published document. Two types of callouts are available: 

 Numbered callouts, which are automatically created for mouse, edit, and drag-

and-drop actions; field/description tables; and if/then tables within the 

procedure section of a document. These callouts display as a number in the left 

or right margins of the screen image. For a field/description or if/then table, 

the callout will display in published output as a bracket that highlights a group 

of fields. For all other actions, the callout displays as a trajectory line. 

 Non-step callouts, which you can create manually anywhere within the 

procedure section of the document. Non-step callouts display and are edited 

like simulation notes. 

Callout display is enabled in the simulation by editing the step properties. Callout display and line 

color in published content is controlled within the template. For more information, refer to Default 

Publication Settings: Document (on page 338). 

Callout lines are created and adjusted according to the following conditions: 

Condition How the Line is Drawn 

The step number is placed 

within the vertical coordinate 

range of the hotspot. 

The starting point of the callout will display on the 

side of the action note with the central vertical 

coordinate matching. For example, center to center. 

A horizontal line will be drawn to connect the step 

number with the starting point of the callout. 

The step number is placed 

above/below the vertical 

coordinate range of the 

hotspot. 

The starting point of the callout will display at the 

top/bottom center of the hotspot. A vertical line is 

drawn from that position to the central vertical 

coordinate of the step number. A horizontal line is 

drawn to connect the vertical line with the step 

number. 

The step number is placed 

above/below the vertical 

coordinate range of the 

combined hotspot region. 

A Z-shaped line will connect the center of the 

bracket to the step number. The vertical split of the 

Z-shaped line will start halfway between the step 

number and the bracket.  
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Condition How the Line is Drawn 

The step number is placed 

within the vertical coordinate 

range of the hotspot. 

You can shift the callout horizontally from the 

margin to the callout hotspot. In the case of range 

callouts, the limiting hotspot will be the hotspot 

closest to the margin that the callout step number is 

drawn on. 

Step number is placed 

above/below the vertical 

coordinate range of the 

hotspot. 

You can shift the callout horizontally within 

horizontal range of the callout hotspot. If a hotspot 

covers a textbox, you can only shift the callout along 

the bottom or top side of the textbox. 

 
 

Working with Images 

Editing Images 

1. Create or open a document. 

2. Click the Document tab. 

3. Navigate to the step containing the image you want to edit. 

4. Right-click on the image. 

5. Select Edit Screen.... 

 

6. Perform one of the following options: 

If You Want To Then 

Resize the image Click on the up or down arrow in the Image Size 

field. 

Crop the image Grab a sizing handle and drag to crop the image. 
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If You Want To Then 

Determine the region that 

displays 

Select an image from the Regions drop-down list. 

Mark the content for 

localization 

Check the Localized checkbox on the toolbar. 

7. Click OK. 
 

Resetting Screen Images 

You can reset an image to its originally-recorded state as long as the image has not been saved. 

Resetting an image will remove all masks, callout edits, and additional image edits you have made 

to the screen. 

1. Create or open a document. 

2. Click the Document tab. 

3. Navigate to the step containing the image you want to edit. 

4. Right-click on the image. 

5. Select Edit Screen.... 

 

6. Click Reset. 
 

Viewing an Image Mask 

1. Create or open a document. 

2. Click the Document tab. 
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3. Navigate to the step containing the mask you want to view. 

4. Right-click on the image containing the mask. 

5. Select Edit Screen.... 

 

6. Select VIEW > MASKS. 
 

Creating an Image Mask 

1. Create or open a document. 

2. Click the Document tab. 

3. Navigate to the step containing an image for which you want to create a mask. 

4. Right-click on the image and select Edit Screen.... 

 

5. Click . 

 
The mask will display as a small, rectangular, black box in the upper left corner of the 

screen image. 

6. Select the mask, and drag it to the area you want to mask. 
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7. Click OK. 
 

Editing an Image Mask 

1. Create or open a document. 

2. Click the Document tab. 

3. Navigate to the step containing the mask you want to edit. 

4. Right-click on the image containing the mask. 

5. Select Edit Screen.... 

 

6. Select VIEW > MASK PROPERTIES. 

 

7. Choose from the following options: 

Field Description 

Left, Top, Width, Height Enter values in the Left, Right, Height, and 

Width fields, or grab a sizing handle on the mask 

within the image, and drag it to the size you want 

the mask to cover. The Left, Right, Height, and 
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Field Description 
Width fields will adjust accordingly. 

Background Click ... to select a background color. 

Border Color Click ... to select a background color. 

Border Thickness Chose a border thickness from the drop-down list. 

Preview Allows you to preview the mask. 

Steps Select the steps for which you want to include the 

mask. 

8. Click the X to close the Mask Properties window. 

9. Click OK. 
 

Copying and Pasting an Image Mask 

1. Create or open a document. 

2. Click the Document tab. 

3. Navigate to the step containing the image you want to copy and paste. 

4. Right-click on the image containing the mask. 

5. Select Edit Screen.... 

 

6. Select the mask you want to copy. 

7. Click  to copy the mask. 

8. Click   to paste the mask. 
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Deleting an Image Mask 

1. Create or open a document. 

2. Click the Document tab. 

3. Navigate to the step containing the mask you want to delete. 

4. Right-click on the image containing the mask. 

5. Select Edit Screen.... 

 

6. Right-click on the mask to be deleted. 

7. Select Delete. 

8. Click OK. 
 

Working with Callouts 

Inserting a Numbered Callout 

If callout functionality has been enabled in the template and visibility turned on within the 

document options, numbered callouts are automatically inserted into the document. 

For information on enabling functionality within the template, refer to Default Publication 

Settings: Document (on page 338). For information on enabling visibility within the document, 

Specifying Document Editor Options (on page 39). 

 
Simulation View must be enabled in order to activate the display of callouts. 
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Inserting a Non-Step Callout 

1. Create or open a document. 

2. Click the Simulation tab. 

3. Navigate to the step for which you want to create a callout. 

4. Select INSERT > NOTE > NOTE. 

5. Reposition the callout within the screen image. 

 
Non-step callouts will not display in the document view if they are placed outside the 

screen image. 

6. Right-click on the note. 

7. Select Edit Note.... 

8. Click General on the left pane. 

9. Select the Enable callout in document view checkbox. 

 
Simulation View must be enabled in order to activate the display of callouts. 

10. Click OK. 
 

Viewing Callouts 

1. Create or open a document. 

2. Click the Document tab. 

3. Navigate to the step containing the callout you want to view. 

4. Right-click on the image containing the callout. 
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5. Select Edit Screen.... 

 

6. Select VIEW > CALLOUTS. 
 

Editing a Numbered Callout 

1. Create or open a document. 

2. Click the Document tab. 

3. Navigate to the step containing the numbered callout you want to edit. 

4. Right-click on the image containing the callout. 

5. Select Edit Screen.... 

 

6. Click on a callout. 

 
The displayed number is the step number to which the callout is associated. 

7. Perform one of the following actions: 
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If You Want To Then 

Edit the location of the callout number Drag the callout up, down, left, or right to change 

the angle of the trajectory line. 

Edit the destination of the trajectory 

line 

Click on the circular grip and move it left or right 

to adjust the destination of the trajectory line. 

8. Click OK. 

 
Callout line color is defined in the template. For more information, refer to Specifying 

General Settings: Information (on page 321). 

 

 

Editing a Non-Step Callout 

1. Create or open a document. 

2. Click the Document tab. 

3. Navigate to the step containing the non-step callout you want to edit. 

4. Edit the callout as you would a simulation note. For more information, refer to Editing Notes 

(on page 122). 
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Generating the Exercise Section 

The Exercise section is automatically generated based on the information contained in the 

Procedure section of the document. To limit rework, you should complete editing of the Procedure 

section before generating the exercise section. 

If you must repopulate the Exercise section after initial creation, refer to Rebuilding the Exercise 

Section (on page 166). 

When generating the Exercise section, data is taken from the field description tables and screen 

titles to create and populate the Required Data table and the Tasks section. 

 

Required Data Table 

A required data table is created from field description tables in the Procedure section. The 

required data table lists field names and the values listed as examples in the Field/Description 

tables. If the recorder was used to capture data, these examples are the actual data typed during the 

task. It does not matter if the examples were automatically inserted during recording or manually 

inserted later. 

 

Tasks Section 

Specific tasks are created for each screen documented. These tasks are created from the screen 

titles that exist in the Procedure section. It does not matter if the screens were originally captured 

during recording or were inserted later in editing. 

 

Generating the Exercise Section 

1. Open the document. 

2. Select INSERT > QUICK BLOCK > EXERCISE/DATA SHEET. 

3. Scroll to the Exercise section and edit the section as needed. 
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Adding User-Specific Data 

In certain transactions, the same data cannot be used for every user in the training environment, 

and user-specific data must be used. This user-specific data will not automatically be created by 

the template and must be populated by the author. 

1. Open the document. 

2. Scroll to the User-Specific Data subsection. 

3. Double-click to highlight the xxxx generic text in the column headings, and type the desired 

student identifier (for example, "Student 1"). 

4. Double-click to highlight the xxxx generic text in the rows, and type the user-specific data. 
 

Replacing the Boilerplate Questions 

You should enter customized questions and answers in the Tasks subsection. 

1. Double-click to highlight the xxxx generic text. 

2. Type the appropriate question or answer. 
 

Rebuilding the Exercise Section 

The Exercise section is automatically populated based on the information contained in the 

Procedure section of the document. While it is recommended that you complete the Procedure 

section before including the Exercise section, you can rebuild your exercise information after 

initial creation if necessary. 

 
When you rebuild the Exercise section, any text you have entered in the tables, tasks, 

or question and answer areas will be overwritten. 

1. To rebuild the exercise section, select HOME > UPDATE EXERCISE. 
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Change the Language of Default Text 

After document creation, you can morph the language of the boilerplate text and simulation action 

text in your document, simulation, or course. The boilerplate text includes such phrases as "Use 

this procedure to" and "Helpful Hints." The simulation action text includes such standard 

introductory step text as "Click," "Type," and "Press." 

Only default text can be morphed. Text you type in the document, simulation, or course views is 

not morphed to another language. In addition, if you have customized simulation action text, these 

customizations will be lost during morphing. 

 

Changing the Language of Default Text 

1. Open the document. 

2. Select FILE > PROPERTIES.... 

3. Select the new language from the Language drop-down list. 

4. Click OK. 

5. Click Yes at the confirmation prompt. 
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Working with the Screenflow 

The screenflow is an additional view available from the Editor workspace. The screenflow 

provides a graphical overview of the entire task or process. The screenflow is automatically 

updated as elements are added or edited in either the document or the simulation view. Branching 

is not depicted in the screenflow. 

When published in HTML output, the screenflow displays at the beginning of the document and is 

mapped so that each screen in the flow is hyperlinked to the correlating step in the procedure. 

 

Viewing the Screenflow 

1. Select the Screenflow tab in the upper left. 

 

 
 

Customizing the Screenflow Display 

1. Choose one or more of the following options: 

If You Want To Then 

Display the screens in a thumbnail view Select the Thumbnail View radio button in the 

task pane. 

The view that is selected in the document will be 

reflected in the published output. 

Display only the screen title bars with 

optional additional information 

Select the Step View radio button in the task 

pane. 

When displaying the step view, you can also 

elect to display a list of the fields and/or the steps 

on the screen. 

The view that is selected in the document will be 

reflected in the published output. 
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If You Want To Then 

Edit the screen title Double-click in the screen title portion of the 

screen image, and select a new title from the 

drop-down menu or enter a new title. 

 
Changing the screen title in this manner in the 

screenflow view will also change the screen title 

for all screens with the same title in the 

document view. After changing the screen title, a 

pop-up window will appear asking if you also 

want to change the screen title in simulation 

view. Click Yes to change it, or click No to not 

change the title in simulation view.  

Quickly navigate to a particular step in 

the document or simulation views 

Right-click on the screen image and select Edit 

in document view or Edit in simulation view. 
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Chapter 9: Editing and Formatting: 
Courses 

After you have created a course, you have many options for editing and 

formatting content in the course.  

In addition to inserting standard objects such as lessons, pages, and 

assessment sections, you can also insert text, images, videos, 

hyperlinks, resources, hotspots, Microsoft PowerPoint content, Adobe 

Flash content, audio, page transitions and animations. 
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Introduction to Editing and Formatting: Courses 

After you have created a course, you can enhance your course using basic editing and formatting 

functionality. For basic formatting functionality, refer to Editing and Formatting: Basics (on page 

91). In addition, you can edit course content to include such options as inserting text, images, 

pages, Microsoft PowerPoint content, video, and Flash content. Edits should be performed on 

content stored on your local computer. 

Courses are made up of a course root page, lesson folders, pages (standard or interaction), and 

optional branching or assessment sections. Standard content pages can contain conceptual 

information about the course topic, and interaction pages quiz the end user on course materials. 

Results of the optional branching or assessment sections can be tracked and analyzed using a 

Learning Management System (LMS). 

Lessons are similar to a chapter in a textbook. You can use lessons to introduce content, and then 

use pages to deliver topic details to the end user. The following is an illustration of a typical 

course hierarchy within the Course Editor: 

 
Some of the editing and formatting functions available to you include: 

 Insert text and images, and apply formatting 

 Insert procedural content 

 Import Microsoft PowerPoint content 

 Import content from another ART course 

 Insert hotspots and links 

 Manage resources 

 Embed Flash content 

 Insert MP3 audio files 

 Insert videos 
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 Create self-tests 

 Create branching sections 

 Create assessments for integration with an LMS 
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Working with Lessons 

Course lessons are folders that contain pages. Pages are inserted into lesson folders to create the 

course content. You can use standard content pages to provide conceptual information to end 

users. You can use interaction pages to quiz the user throughout the course, then track and analyze 

results via an LMS. 

For detailed information on creating a course, refer to Creating Content. 

 

Inserting a Lesson 

1. Create or open a course. 

2. In the Course Pane area, select the course root page or place the cursor where you want to 

insert a lesson. 

3. Select INSERT > INSERT LESSON.... 

 

4. Enter a name in the Name field. 

5. Choose a stencil from the following options: 

Stencil Options 

Flash This stencil creates a standard content page 

containing a single Flash file. 

Full This stencil creates a standard content page with 

text. 

Half - Bottom This stencil creates a standard content page with text 

on the bottom of the page. An optional image can be 

placed on top. 

Half - Left This stencil creates a standard content page with text 

on the left of the page. An optional image can be 

placed to the right. 
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Stencil Options 

Half - Right This stencil creates a standard content page with text 

on the right of the page. An optional image can be 

placed to the left. 

Half - Two Image - Bottom This stencil creates a standard content page with text 

on the bottom of the page. Two optional images can 

be placed on top. 

Half - Two Image - Left This stencil creates a standard content page with text 

on the left of the page. Two optional images can be 

placed to the right. 

Half - Two Image - Right This stencil creates a standard content page with text 

on the right of the page. Two optional images can be 

placed to the left. 

Image This stencil creates a standard content page 

containing an image. 

Image - Diagonal - Left This stencil creates a standard content page with text 

on the top left and bottom right of the page. Two 

optional images can be placed diagonally within the 

stencil. 

Image - Diagonal - Right This stencil creates a standard content page with text 

on the top right and bottom left of the page. Two 

optional images can be placed diagonally within the 

stencil. 

Video This stencil creates a standard content page 

containing a video. 

Video - Half - Left This stencil creates a standard content page. An 

optional video can be placed to the right. 

Video - Half - Right This stencil creates a standard content page. An 

optional video can be placed to the left.  

Simulation This stencil creates a page for embedding a 

Simulation. 

Simulation - Half - Right This stencil creates a page for embedding a 

Simulation. An optional image can be placed to the 

left. 

6. Click OK. 

 
A caution icon will display in the outline view on a lesson that does not contain pages 

or that contains pages that have not been filled out completely. 
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7. In the course content pane, complete the following fields: 

 
Based on the page selected, some of the following options may not be displayed. 

Field Description 

{Enter content title here} Click to highlight the placeholder and overwrite 

with the title of the lesson. 

{Enter content here} Click to highlight the placeholder and overwrite 

with the lesson page content. 

Add Picture... icon Click the image to browse to the image location. 

Add Video... icon Click the image to browse to the video location. 

Edit Simulation Properties Select an option from the Insert drop-down and 

browse to the published simulation location, or 

select a simulation from the Available Simulations 

list. 

Select the options for Mode visibility. 

Check the Localized checkbox to indicate that the 

simulation is specific to the current language. 

Update Simulations Browse to the local source file location. 

Select an embedded simulation and click Update. 

 
For more information on changing the course page layout, refer to Working with 

Flexible Stencils. 
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Working with Pages 

Pages contain the content for the course. The layout of a page is based on the stencil that you 

choose when you insert a new page into the course. Two types of stencils are available: 

 Standard Content: Contains informational content and optional images, 

simulations or videos. 

 Interaction: Contains content consisting of questions and answers and optional 

images. These stencils use traditional eLearning models such as multiple 

choice, drag and drop, and fill-in. 

Interaction pages can be used with an LMS for tracking purposes, or as a standalone self-test for 

the user. For more information on working with assessments and self-tests, refer to Working with 

Assessments and Self-Tests. 

 

Inserting a Page 

1. Create or open a course. 

2. In the Course Pane, click on a course root folder, lesson, page, or assessment. 

3. Select INSERT > PAGE.... 

 

4. Enter a name in the Name field. 

5. Choose a stencil from the following options: 

 
Based on where the page is inserted, some of the following options may not be 

displayed. 
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Stencil Option 

Flash This stencil creates a standard content page 

containing a single Flash file. 

Full This stencil creates a standard content page with 

text. 

Half - Bottom This stencil creates a standard content page with text 

on the bottom of the page. An optional image can be 

placed on top. 

Half - Left This stencil creates a standard content page with text 

on the left of the page. An optional image can be 

placed to the right. 

Half - Right This stencil creates a standard content page with text 

on the right of the page. An optional image can be 

placed to the left. 

Half - Two Image - Bottom This stencil creates a standard content page with text 

on the bottom of the page. Two optional images can 

be placed on top. 

Half - Two Image - Left This stencil creates a standard content page with text 

on the left of the page. Two optional images can be 

placed to the right. 

Half - Two Image - Right This stencil creates a standard content page with text 

on the right of the page. Two optional images can be 

placed to the left. 

Image This stencil creates a standard content page 

containing an image. The image size is configurable. 

Image - Diagonal - Left This stencil creates a standard content page with text 

on the top left and bottom right of the page. Two 

optional images can be placed diagonally within the 

stencil. 

Image - Diagonal - Right This stencil creates a standard content page with text 

on the top right and bottom left of the page. Two 

optional images can be placed diagonally within the 

stencil. 

Video This stencil creates a standard content page 

containing a video. 

Video - Half - Left This stencil creates a standard content page. A video 

can be placed to the right. 

Video - Half - Right This stencil creates a standard content page. A video 

can be placed to the left. 

Branching This stencil creates a branch that allows the user to 

decide where to go next in the course. 

Drag and Drop This stencil creates an interaction page featuring one 

matching item per definition. 

Drag and Drop - Many-to-

One 

This stencil creates an interaction page featuring one 

or more drag-and-drop responses to a single 

question. 
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Drag and Drop - Sequencing This stencil creates an interaction page featuring one 

or more draggable responses to a single question. 

Fill In - Multiple This stencil creates an interaction page that allows 

the user to enter responses to multiple questions. 

Fill In - Single This stencil creates an interaction page that allows 

the user to enter a response to a single question. 

Hotspot - Single This stencil creates a page featuring text and an 

image. A hotspot area can be defined in the image as 

the correct response. 

Multiple Choice This stencil creates an interaction page featuring 

several possible responses to a single question. Only 

one response is correct. 

Multiple Choice - Half This stencil creates an interaction page featuring 

several possible responses to a single question. Only 

one response is correct. An optional image can be 

placed to the right. 

Multiple Correct This stencil creates an interaction page featuring 

several possible responses to a single question. One 

or more responses may be correct. 

Multiple Correct - Half This stencil creates an interaction page featuring 

several possible responses to a single question. One 

or more responses may be correct. An optional 

image can be placed to the right. 

Simulation This stencil creates a page for embedding a 

Simulation. 

Simulation - Half - Right This stencil creates a page for embedding a 

Simulation. An optional image can be placed to the 

left. 

6. Click OK. 

 
A caution icon will display in the outline view on a lesson that does not contain pages 

or that contains pages that have not been filled out completely. 
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For more information on changing the course page layout, refer to Working with 

Flexible Stencils. 

 
 

Displaying Answers From Another Page 

Answers from a multiple choice knowledge check page can be displayed on another page. This 

allows answers the user has selected earlier in the course to be displayed on a later page. Answers 

can only be displayed from multiple choice pages and the answers can only be displayed onto 

pages with a text area. 

 

Displaying Another Page's Answer 

 
Only pages with a text area can display another page's answer. 

1. Right-click on the page in the Course Pane and select EDIT PAGE.... 

 
You can also right click on the page in the course content area. 

 

2. Select the Display another page's answer on this page checkbox. 

3. Select a page from the Display the answer from list. 

4. Click OK.  

 
The answer will only display in the published HTML output. You will not see the 

answer in the preview or in the Word or PDF published outputs. 
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Working with Flexible Stencils 

Authors can make changes to all of the different course stencil types except for assessments and 

full page Flash stencils. The content areas within the stencils can be split into smaller content 

areas, flipped around on the course element (lesson or page), changed to different types of 

content, and removed.  

The Design tab is only visible in the Editor when working with courses.  

 
The Design tab allows authors to: 

 Change course element stencil options 

 Split a content area vertically or horizontally 

 Flip a content area  

 Change a content area to content, title, image, or video 

 Remove content areas 

 The dividers, referred to as "slider bars," between content areas within a course element are now 

adjustable, allowing the author to change the size of each content area. The area percentage is 

displayed while moving the slider bar. These adjustments will be reflected in the Editor as well as 

the published output for all course elements except for assessments. Adjusting the slider bars on 

assessment pages is intended to allow the author to comfortably view all answers on a given page, 

especially when many answers are added. These assessment adjustments are for the Editor only 

and are not reflected in the published output.  

 

 
You can use the undo/redo editing function with flexible stencils. 
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Switching a Stencil 

 
This functionality is not available for assessments. 

1. In the Course Pane, click on the lesson or page you want to switch stencils. 

2. Click the Design tab. 

3. Click the Switch Stencil button. 

 

4. Choose a stencil from the list of options. 

 
When switching between stencils, content will be preserved as long as it is supported 

by the new stencil. For example, if switching from a stencil layout that supports images 

to a stencil layout that does not support images, images may be lost.  

5. Click OK. 

 
You can use the undo/redo editing function if needed. 

 
 

Splitting Content Areas 

 
This functionality is not available for assessments and full page Flash stencils. 

1. Select the content area on the course element to split. 

2. Click the Design tab. 

3. Choose from the following options in the Layout section: 

If You Want To Then 

Divide the content area as if it were cut 

in the middle from top to bottom 

Click the Split Vertical button. 
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If You Want To Then 

Divide the content area as if it were cut 

in the middle from left to right 

Click the Split Horizontal button. 

 
While there is no limit to the number of times you can split a content area, if an area is 

split into too many areas, it may not be visible in the Editor or the published output. 

 
You can use the undo/redo editing function if needed. 

 
Hover over the slider bar and content area to adjust the size of the content areas. 

 
 

Flipping Content Areas 

 
This functionality is not available for assessments and full page Flash stencils. 

1. Select the content area on the course element to flip. 

2. Click the Design tab. 

 
When you hover over the Flip button, the target content area to be flipped will be 

outlined in green.  

3. Click the Flip button.  

 
If a content area has been split into a group of several smaller areas, then each of the 

related target areas will be highlighted before flipping. The entire group will not be 

highlighted as one. 

 
You can use the undo/redo editing function if needed. 

 
Hover over the slider bar and content area to adjust the size of the content areas. 

 
 

Changing Content Area Types 

 
This functionality is not available for assessments and full page Flash stencils. 

1. Select the content area (title, content, image or video) on the course element to change. 

2. Click the Design tab. 

3. Chose from the following options in the Change Type section: 



Chapter 9: Editing and Formatting: Courses 

 

Hewlett Packard Enterprise Develoment LP 185 

 

 

If You Want To Then 

Change the selected content area type 

to content (text) 

Click the Change to Content button. 

Change the selected content area type 

to a title 

Click the Change to Title button. 

Change the selected content area type 

to an image 

Click the Change to Image button. 

Change the selected content area type 

to a video 

Click the Change to Video button. 

    
When switching between title and content types, the text will be retained since both are 

text elements. When switching from a content element to a video or image element, the 

text will be removed. When switching from a video or image to a content element, the 

video or image will be removed.  

 
You can use the undo/redo editing function if needed. 

 
Hover over the slider bar and content area to adjust the size of the content areas. 

 
 

Removing Content Areas 

 
This functionality is not available for assessments and full page Flash stencils. 

 
This functionality is only available when there is more than one content area on the 

course element. 

1. Select the content area (title, content, image or video) on the course element to remove. 

2. Click the Design tab. 

3. Click the Remove button.  

 
You will receive a message confirming that you want to delete the selected content 

area if it contains content (text, image or video). 

 
You can use the undo/redo editing function if needed. 
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Editing Course Content 

The Course Editor allows you to set formatting within a page. You can also reorder lessons and 

pages. By default, lessons and pages are inserted below the object selected in the Course Pane. 

 

Setting the Character Format 

1. Highlight the text you want to format. 

2. On the Home tab, select one of the following rich-text formatting options: 

Field Description 

Font Select the drop down to change the font style of the 

text. 

Size Select the drop down to change the size of the text. 

Clear all Select this option to clear all of the formatting from 

the text. 

Bold Select this option to bold the text. 

Italic Select this option to italicize the text. 

Underline Select this option to underline the text. 

Strikethrough Select this option to strikethrough the text. 

Subscript Select this option to move a character to the bottom 

of the character line. 

Superscript Select this option to move a character to the top of 

the character line. 

Color Select the drop down to change the color of the text. 

Bullet List Select this option to format the text in a bulleted list. 

Numbered List Select this option to format the text in a numbered 

list. 

Decrease Indentation Select this option to decrease the indentation of the 

text. 

Increase Indentation Select this option to increase the indentation of the 

text. 
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Field Description 

Align Left Select this option to align the text to the left margin. 

Center Select this option to center align the text. 

Align Right Select this option to align the text to the right 

margin. 

Bullet List Select this option to format the text in a bulleted list. 

Numbered List Select this option to format the text in a numbered 

list. 

Superscript Select this option to move a character to the top of 

the character line. 

 
To return the character format to normal, deselect the rich-text formatting from the 

toolbar. 

 

 

Reordering Lessons and Pages 

1. Click on the lesson or page you want to move. 

2. Choose from the following options: 

If You Want To Then 

Move the lesson or page above or 

below another lesson or page 

Drag the lesson or page above or below another 

item in the Course Pane. 

Move the lesson or page into another 

lesson or page 

Drag the lesson or page onto the item in the 

Course Pane. 
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Managing Resources, Embedded Simulations, and Images 

Resources, embedded simulations, and images can be managed from the Course Editor menu. 

Resources are links or documents that can be added to a course for additional information. 

Managing resources, embedded simulations and images allows authors to re-use information 

throughout a course, as well as providing simpler and faster updating by allowing the author to 

update and apply only once. 

 

Managing Resources 

1. From the Course Editor, select VIEW > RESOURCES from the menu. 

 

 
The resource panel is enabled in the template settings. For more information on 

enabling the resource panel, refer to Default Publication Settings: Course: General 

Settings (on page 357). 

2. Choose from the following options: 

If You Want To Then 

Add a resource Click Add. 

Enter a name and description. 

Click the URL radio button and enter a URL or 

click Document and browse to a document on 

your local computer. 

Click OK. 

Modify a resource Select a resource from the list, and click Modify. 

Edit the resource name, description, or content as 

needed. 

Click OK. 
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If You Want To Then 

Delete a resource Select a resource from the list, and click Delete. 

Click Yes. 

View a resource Select a resource from the list, and click View. 

The resource opens in a separate window. 

Move a resource Select a resource from the list, and click Move 

Up or Move Down to re-arrange the resources. 

3. Click OK. 
 

Managing Embedded Simulations 

1. From the Course Editor, select VIEW > EMBEDDED SIMULATIONS from the menu. 

 

 
If your embedded simulations are located in another file location, click  and 

navigate to your source file location on your local computer.  

2. Select a simulation from the list and click Update. 

 
The Update button is only available if the selected simulation has a status of Not 

Current, indicating the simulation has been revised. 

3. Click OK. 
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Managing Images 

1. From the Course Editor, select VIEW > IMAGES from the menu. 

 

2. Choose from the following options: 

If You Want To Then 

Add an image Click Add.... 

Browse and select an image from your local 

computer. 

Click Open. 

 
If two images are added with the 

same file name, the application will 

compare the files to determine if 

they are identical. If the images are 

identical, the first image will be 

used. 
 

Preview an image Select an image from the Available Images list 

and click Show Preview. 

Close the preview window. 

3. Click OK. 

 
Once the course is closed any images no longer being used will be removed from the 

Available Images list. 
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Using Images 

Images can be used to further illustrate a specific point in a lesson and also to enhance conceptual 

points or questions and answers. 

 

Inserting Images Into Pages 

1. During page creation, select a stencil that allows you to insert an image. For more 

information, refer to Inserting a Page (on page 177). 

2. In the content area, click the Add Picture... icon. 

3. Choose from the following options: 

If You Want To Then 

Insert an available image Select the image from the Available Images list. 

Insert a new image Click Add.... 

Navigate to the image you want to insert. 

Click Open. 

Preview an image Select an image from the Available Images list 

and click Show Preview. 

Close the image. 

4. Click OK. 

5. Choose one of the following options: 

If You Want To Then 

Select a different image Click the Change Picture... icon.  

Remove the image Click the Delete Picture... icon. 

 
 

Editing Images 

1. Navigate to the image you want to edit. 
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2. Right-click on the image and select Edit Image....  

 

3. Choose from the following options: 

Field Description 

Layout Select an alignment option for the current image. 

Use template zoom options If checked, the image will default to the template options for 

zooming images. 

Enable zoom If checked, the image will be able to be zoomed within the 

published layout. 

Width Select an image width. 

Height Select an image height. 

Maintain aspect ratio If checked, the image will adjust width/height when either is 

changed. 

Caption Enter a caption for the image. 

The maximum value is 255 characters. 

 
To view the caption, hover over the image in the 

published output. 
 

Localized If checked, the image will be localized. 

4. Click OK. 

 
Click the Change Picture... icon to select a different image. Click the Delete Picture... 

icon to remove the image. 
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Using Page Transitions 

Authors can insert transitions into courses. A transition can be applied to an entire course element 

(page, lesson, or assessment). A transition occurs when navigating between course pages (via the 

course navigation buttons or the course menu). Only one transition type is allowed per course 

element. 

The Transitions tab is only visible in the Editor when working with courses. 

 
The Transitions tab allows authors to: 

 Add and remove transitions to courses  

 Select directional effect options  

 Set durations 

The Transitions ribbon toolbar displays the transition effects of bounce, fade, slide, zoom, roll, 

and flip.  

Icons to the side of the course element indicate the presence of transitions. Hover over the 

transition icon to display more information about the transition. 

 

 
Transitions in an imported PowerPoint may not function as expected. 

 
For more information on which browser versions support transitions, refer to the 

Technical Specifications. 

 
When upgrading from a version earlier than 5.30, if the Enable Transitions field was 

selected a fade transition was applied to all of the course pages. 
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You can use the undo/redo editing function with transitions. 

 
 

Inserting a Transition 

 
Only one transition type is allowed per course element (page, lesson, or assessment). 

1. Navigate to the course element to apply the transition. 

2. Click the Transitions tab. 

3. Select one of the following transition effects: 

Field Description 

Bounce The course page will have a bouncing effect as it 

enters. 

Fade The course page will have a fading effect as it 

enters. 

Slide The course page will have a sliding effect as it 

enters. 

Zoom The course page will have a zooming effect as it 

enters. 

Roll The course page will have a rolling effect as it 

enters. 

Flip The course page will have a flipping effect as it 

enters. 

 
After the transition is inserted, an icon reflecting the motion of the transition will 

appear to the left of the course page. This icon represents the type of transition applied 

to that page. 

 
You can use the undo/redo editing function with transitions. 

 
 

Changing a Transition 

 
Only one transition type is allowed per course element (page, lesson, or assessment). 

1. Navigate to the appropriate course page. 

2. Click the Transitions tab. 

3. Choose from the following options: 
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If You Want To Then 

Change a transition Click the desired transition from the Transitions 

group. 

Remove a transition Click the Remove Transition button.  

 
You can use the undo/redo editing function with transitions. 

 
 

Applying Effect Options to a Transition 

1. Navigate to the appropriate course page with the transition. 

2. Click the Transitions tab. 

 
The Effect Options button will become available for the transition if the transition has 

directional effects. 

3. Click the Effect Options button. 

4. Select one of the following:  

 
The bounce, fade, and roll transitions do not have directional options available as there 

is only one way to have each of these transitions to appear.   

Field Description 

From Bottom  The transition will occur from the bottom.  

From Left  The transition will occur from the left.  

From Right  The transition will occur from the right.  

From Top  The transition will occur from the top.  

Horizontal  The transition will flip horizontally.  

 
Flip transition only  

 

Vertical  The transition will flip vertically. 

 
Flip transition only  

 
 

 
The Effect Options button will display the effect for the transition.  

 
You can use the undo/redo editing function with transitions. 
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Apply Existing Transition to All Course Pages 

 
When the Apply to All functionality is used, transitions on existing course pages will 

be deleted and replaced with the transition selected to Apply to All. 

1. Navigate to the appropriate course page with the transition. 

2. Click the Transitions tab. 

3. Click the Apply to All button to apply the current transition to all of the existing course pages 

and any newly created course pages. 

 
Every new course page created will have this transition applied even if the original 

course page containing the transition is deleted or the course is closed and then 

reopened.   

 
 You can use the undo/redo editing function with transitions. 

 
You can delete transitions from all of the existing course pages and any newly created 

course pages by clicking the Remove Transition and Apply to All buttons.  

 
To change or remove transitions on an individual course page, refer to Changing a 

Transition. 

 
 

Setting Transition Durations 

1. Navigate to the appropriate course page with the transition. 

2. Click the Transitions tab. 

3. Complete the following field in the Timing section: 

Field Description 

Duration  The amount of time in seconds the transition will 

last. The duration is from 1 - 59 seconds.  

The default value is 1.    

  
Enter the duration in seconds or use the up and down arrows to select the value. 

  
You can use the undo/redo editing function with transitions. 

 
 



Chapter 9: Editing and Formatting: Courses 

 

Hewlett Packard Enterprise Develoment LP 197 

 

 

Using Animations 

Authors can insert animation effects into courses. Animations can be added to an entire content 

area containing text, a paragraph of text or an image within a course element (lesson or page). 

Simulations, assessments, Flash and video do not support animations. 

The Animations tab is only visible in the Editor when working with courses.  

 
The Animations tab allows authors to: 

 Add and remove animations to courses by using entrance, emphasis, and exit 

animation options. 

 Apply effect options for animations based on direction or sequence. 

 Set animation triggers. 

 Set animation durations and delays. 

 Reorder animations. 

The Animations ribbon toolbar displays the entrance animations by default. You can scroll 

through the animations by clicking the Move up and Move down buttons on the right side of the 

list. You can also view all available animations by clicking on the More drop-down button at the 

bottom-right of the list.  

 

 

 
If a content area has multiple animations applied that are not the same, 

the Multiple animation icon is highlighted on the ribbon toolbar.  
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Numbers in boxes to the side of the course element indicate the presence of animations and the 

sequence in which the animations will be displayed after publishing. The sequence numbers can 

appear to the left or right of the course element. The first animation inserted will be designated 

with the “1,” the second, “2,” and so on.  

 
You can click the animation sequence number to see the object and animation associated with it. 

 
Multiple animations for an object are grouped together and only one animation sequence number 

displays. Hover the mouse over the group animation sequence number to view all of the animation 

sequence numbers in a vertical list. 

  
Animations in an imported PowerPoint may not function as expected. 

  
For more information on which browser versions support animations, refer to the 

Technical Specifications. 

  
You can use the undo/redo editing function with animations. 

  
 

Inserting an Animation 

1. Choose from the following options: 

If You Want To Then 

Apply an animation to a paragraph of 

text  

Select the text in the content area on the course 

element. 

 
If there are three sentences of text in a 

content area, you can apply a different 

animation to each sentence by selecting 

each sentence separately. 
 

Apply an animation to an image Select the image in the content area on the course 

element. 

 
The image must already be added into 

the course. 
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If You Want To Then 

Apply an animation to an entire content 

area containing text 

Select a content area on the course element.  

 
If the content area has multiple 

animations applied that are not the 

same, the Multiple animation icon is 

highlighted on the ribbon toolbar.  

 
 

 
Copying text or images that have animations does not copy the animation.  

2. Click Add Animation.  

 
You can also click the More drop down to expand the Animation ribbon. 

3. Choose from the following options: 

If You Want The Animation To 
Display Then 

When the selected object is first introduced 

during course playback  

Go to Step 4. 

While the selected object is displayed during 

course playback 

Go to Step 6. 

When the selected object exits during course 

playback 

Go to Step 8. 

4. Select one of the following entrance animation effects: 

Field Description 

Bounce The selected object will have a bouncing effect as 

it enters. 

Fade The selected object will have a fading effect as it 

enters. 

Slide The selected object will have a sliding effect as it 

enters. 

Zoom The selected object will have a zooming effect as 

it enters. 

Roll The selected object will have a rolling effect as it 

enters. 

Flip The selected object will have a flipping effect as 

it enters. 

5. Go to  Step 9. 

6. Select one of the following emphasis animation effects: 
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Field Description 

Flash The selected object will flash. 

Pulse The selected object will pulse.  

Shake The selected object will shake.  

7. Go to Step 9. 

8. Select one of the following exit animation effects: 

Field Description 

Bounce The selected object will have a bouncing effect as 

it exits. 

Fade The selected object will have a fading effect as it 

exits. 

Slide The selected object will have a sliding effect as it 

exits. 

Zoom The selected object will have a zooming effect as 

it exits. 

Roll The selected object will have a rolling effect as it 

exits. 

Flip The selected object will have a flipping effect as 

it exits. 

9. Repeat steps 1 - 8 to add more animations. 

 
After the animation is entered, a number will appear to the left or right of the selected 

object. This number represents the sequence in which the animations will display. 

 
You can use the undo/redo editing function with animations. 

 
 

Changing an Animation 

 
Copying text or images that have animations does not copy the animation.  

1. Choose from the following options: 

If You Want To Then 

Change an animation  Select the animation by clicking the actual object 

or clicking the associated animation sequence 

number. 

Click the More button to expand the Animation 

ribbon. 

Select the desired animation.  
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Remove an animation Select the animation by clicking the actual object 

or clicking the associated animation sequence 

number. 

Click Remove Animation.  

 
When removing an animation, the 

sequence number for the animations 

are renumbered automatically. For 

example, if there are 5 animations and 

animation #3 is removed, then the #4 

and #5 will become #3 and #4 

respectively.  

 
Deleting text or images that have 

animations, deletes the animation. 
 

 
You can use the undo/redo editing function with animations. 

 
 

Applying Effect Options to an Animation 

1. On the course element, select the animation by clicking the actual object or clicking the 

associated animation sequence number. 

2. Click the Effect Options button. 

3. Select one of the following:  

 
The roll, flash, pulse, and shake animations do not have directional options available as 

there is only one way to have each of these animations to appear.   

Field Description 

Direction: From Bottom  The animation will come in from the bottom.  

Direction: From Left  The animation will come in from the left.  

Direction: From Right  The animation will come in from the right.  

Direction: From Top  The selected object will come in from the top.  

Direction: Horizontal  The animation will flip horizontally.  

 
Flip animation only  
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Direction: Vertical  The animation will flip vertically. 

 
Flip animation only  

 
 

Sequence: As One Object  All of the text within the content area will be 

animated at the same time and with the same 

animation.  

 
This applies to an entire content area 

of text only. 

 
 

Sequence: All At Once  All paragraphs will be animated at the same time, 

but each paragraph can have different animations.  

 
This applies to an entire content area 

of text only. 

 
 

Sequence: By Paragraph  Each paragraph will be animated.  

 
This applies to an entire content 

area of text only.  

 
 

 
When an animation is selected, the Effect Options button will display the effect for 

that animation.  

 
You can use the undo/redo editing function with animations. 

 
 

Setting Animation Triggers 

1. On the course element, select the animation by clicking the actual object or clicking the 

associated animation sequence number. 

2. Select one of the following in the Start field: 

Field Description 

After Previous   The animation will start after the previous 

animation is completed.   

This is the default value. 

With Previous  The animation will start with the previous 

animation.  

Right Arrow Key  The animation will start when the right arrow key 

is pressed when navigating through a course in 

html published output.  

 
You can use the undo/redo editing function with animations. 
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Setting Animation Durations and Delays 

1. On the course element, select the animation by clicking the actual object or clicking the 

associated animation sequence number. 

2. Select one of the following in the Timing section: 

Field Description 

Duration  The amount of time in seconds the animation is 

displayed. The duration is from 1 - 59 seconds.  

 
The longer the duration is set, the 

slower the animation speed. 

Bounce animations have a default duration of 2 

seconds. All other animations have a default 

duration of 1 second.    

Delay  The amount of time in seconds the animation is 

delayed once it is triggered. The delay value is 

from 1 - 59 seconds.  

The default value is 0 seconds.  

  
Enter the duration and delay in seconds or use the up and down arrows to select the 

value. 

  
You can use the undo/redo editing function with animations. 

 
 

Reordering an Animation 

1. In the course content area, select the animation sequence number box.  

 
Hover your cursor over the animation sequence number to view all animation sequence 

numbers if multiple exist for an item. 

2. Click the Move Earlier or Move Later button to reorder the animation.  

 

 
You can use the undo/redo editing function with animations. 
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Editing Interaction Pages 

Interaction pages apply only to self-tests, branching pages, and pages within an assessment 

section. After you insert a page and choose an interaction page stencil, you must enter content into 

the fields and select your interactions in order to validate the page within the course. 

Interactions differ based on the stencil. Interactions only apply to stencils with a question and 

answer format. In some stencils, the question and answer displays as a term and definition. 

You can also customize the instructional phrases of your interactions. For example, you can 

modify, "Match the term on the left with the definition on the right" to read, "Select the best term 

for the definition." 

 

Customizing Instructional Phrases 

 
Customized instructional phrases will no longer translate when the course language is 

changed. You can customize interaction instructional phrases globally within the author 

template. For more information regarding author templates, refer to Managing Phrases 

(on page 331). 

1. Click to highlight text in the instructional phrase field. 

 

2. Enter new text. 
 

Editing Interactions for Drag and Drop 

1. Click on the {Enter question text here} field. 

2. Enter a question. 

3. Click on the {Enter term here} field. 

4. Enter a term. 

5. Click on the corresponding {Enter definition here} field. 
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6. Enter a definition. 

 

7. Choose from the following options: 

If You Want To Then 

Add terms and definitions Click the + icon beside the definition to add the 

new term and definition below. 

 
Adding too many terms and definitions 

will make it difficult to view the 

content in the course content area. 
 

Remove terms and definitions Click the X icon beside the definition to delete. 

 
The X icon will be disabled when only 

one interaction exists because there 

must be one interaction on the page. 

 
 

Adjust the content areas Hover over the slider bar and content area to 

adjust the size. 

 
Changes are only visible in the Editor. 

Published content will not be affected. 

 
 

 
Definitions will be randomized when the course is published. 

 
 

Editing Interactions for Drag and Drop - Many-to-One 

1. Click on the {Enter question text here} field. 

2. Enter a question. 

3. Click on an {Enter answer text here} field. 

4. Enter an answer. 
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5. Click the arrow next to the correct answer(s) to move the item to the answer pane. 

 

 
To move an incorrect answer from the answer pane, click the back arrow. 

6. Choose from the following options: 

If You Want To Then 

Add answers Click the + icon beside the answer to add a new 

answer below. 

 
Adding too many answers will make it 

difficult to view the content in the 

course content area. 
 

Remove answers Click the X icon beside the answer to delete. 

 
The X icon will be disabled when only 

one interaction exists because there 

must be one interaction on the page. 

 
 

Adjust the content areas Hover over the slider bar and content area to 

adjust the size. 

 
Changes are only visible in the Editor. 

Published content will not be affected. 

 
 

 
 

Editing Interactions for Drag and Drop - Sequencing 

1. Click on the {Enter question text here} field. 

2. Enter a question. 

3. Click on an {Enter answer text here} field. 

4. Enter an answer. 



Chapter 9: Editing and Formatting: Courses 

 

Hewlett Packard Enterprise Develoment LP 207 

 

 

5. Click the arrow next to the answer(s) to move the item to the answer pane. 

 

6. Use the up and down arrows to order the answers. 

 
To move an incorrect answer from the answer pane, click the back arrow. 

7. Choose from the following options: 

If You Want To Then 

Add answers Click the + icon beside the answer to add a new 

answer below. 

 
Adding too many answers will make it 

difficult to view the content in the 

course content area. 
 

Remove answers Click the X icon beside the answer to delete. 

 
The X icon will be 

disabled when only 

one interaction exists 

because there must be 

one interaction on the 

page. 

 
 

Adjust the content areas Hover over the slider bar and content area to 

adjust the size 

 
Changes are only 

visible in the Editor. 

Published content will 

not be affected. 
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Editing Interactions for Fill In - Multiple and Single 

1. Click on the {Enter question text here} field. 

2. Enter a question. 

3. Click on the {Enter term here} field. 

4. Enter a term. 

5. Click on the corresponding {Enter definition here} field. 

6. Enter a definition. 

 

 
If you have multiple correct definitions for a term, separate them with a comma. 

7. Choose from the following options: 

If You Want To Then 

Add terms and definitions Click the + icon beside the definition to add a 

new term and definition below. 

 
Adding too many terms and definitions 

will make it difficult to view the 

content in the course content area. 
 

Remove terms and definitions Click the X icon beside the definition to delete. 

 
The X icon will be disabled when 

only one interaction exists because 

there must be one interaction on the 

page. 

 
 

Adjust the content areas Hover over the slider bar and content area to 

adjust the size 

 
Changes are only visible in the Editor. 

Published content will not be affected. 
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Editing Interactions for Multiple Choice - Multiple and Half 

 
If you choose the Multiple Choice - Half stencil, you can insert an optional image to 

the right. For detailed information, refer to Using Images (on page 191). 

1. Click on the {Enter question text here} field. 

2. Enter a question. 

3. Click on the {Enter answer text here} field. 

4. Enter possible answer text. 

5. Click the radio button next to the correct answer. 

 

6. Choose from the following options: 

If You Want To Then 

Add answers Click the + icon beside the answer to add a new 

answer below. 

 
Adding too many answers will make it 

difficult to view the content in the 

course content area. 
 

Remove answers Click the X icon beside the answer to delete. 

 
The X icon will be disabled when 

only one interaction exists because 

there must be one interaction on the 

page. 

 
 

Adjust the content areas Hover over the slider bar and content area to 

adjust the size. 

 
Changes are only visible in the Editor. 

Published content will not be affected. 
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Editing Interactions for Multiple Correct - Multiple and Half 

 
If you choose the Multiple Correct - Half stencil, you can insert an optional image to 

the right. For detailed information, refer to Using Images (on page 191). 

1. Click on the {Enter question text here} field. 

2. Enter a question. 

3. Click on the {Enter answer text here} field. 

4. Enter possible answer text. 

5. Click the checkboxes next to the correct answers. 

 

6. Choose from the following options: 

If You Want To Then 

Add answers Click the + icon beside the answer to add a new 

answer below. 

 
Adding too many answers will make it 

difficult to view the content in the 

course content area. 
 

Remove answers Click the X icon beside the answer to delete. 

 
The X icon will be displayed when 

only one interaction exists because 

there must be one interaction on the 

page. 

 
 

Adjust the content areas Hover over the slider bar and content area to 

adjust the size. 

 
Changes are only visible in the Editor. 

Published content will not be affected. 
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Importing Microsoft PowerPoint Content 

Elements from Microsoft PowerPoint can be imported into presentations. For information on 

supported versions of Microsoft PowerPoint, refer to the Technical Specifications. There are three 

options for importing Microsoft PowerPoint elements: 

 Import a slide as a single image 

 Import graphics from the presentation 

 Import text elements from the presentation 

 
Animations in an imported PowerPoint may not function as expected. 

 
 

Importing PowerPoint Slides as Images 

1. Select INSERT > FROM POWERPOINT. 

 

2. Choose the .ppt or .pptx file from which you want to import slides. 

 
This action will open Microsoft PowerPoint. Do not close the application until you are 

finished importing slides. 

3. In the Slides area, expand the tree view to locate the slides you want to import.  
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A preview of the slide is displayed to the right of the tree view. You can import more 

than one slide at a time. Each slide will be inserted as an image in a new standard 

content page within the course. 

4. Select the checkbox next to the slide(s) titles to import. Do not select the Text or Pictures 

checkboxes under the slide title to import the slides as images; only select the slide title. 

5. Choose a stencil from the following options: 

Stencil Options 

Full This stencil creates a standard content page with 

text. 

Half - Bottom This stencil creates a standard content page with text 

on the bottom of the page. An optional image can be 

placed on top. 

Half - Left This stencil creates a standard content page with text 

on the left of the page. An optional image can be 

placed to the right. 

Half - Right This stencil creates a standard content page with text 

on the right of the page. An optional image can be 

placed to the left. 

Half - Two Image - Bottom This stencil creates a standard content page with text 

on the bottom of the page. Two optional images can 

be placed on top. 

Half - Two Image - Left This stencil creates a standard content page with text 

on the left of the page. Two optional images can be 

placed to the right. 

Half - Two Image - Right This stencil creates a standard content page with text 

on the right of the page. Two optional images can be 

placed to the left. 

Image This stencil creates a standard content page 

containing an image. 

Image - Diagonal - Left This stencil creates a standard content page with text 

on the top left and bottom right of the page. Two 

optional images can be placed diagonally within the 

stencil. 

Image - Diagonal - Right This stencil creates a standard content page with text 

on the top right and bottom left of the page. Two 

optional images can be placed diagonally within the 

stencil. 

6. Click OK. 

7. Click Yes to confirm the import. 
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Importing Graphics from PowerPoint Slides 

1. Select INSERT > FROM POWERPOINT. 

2. Choose the .ppt or .pptx file from which you want to import graphics. 

3. Click Open. 

 
This action will open Microsoft PowerPoint. Do not close the application until you are 

finished importing graphics. 

4. In the Slides area, expand the tree view to locate the pictures you want to import. 

 
 

 
A preview of the graphic is displayed to the right of the tree view. You can only import 

one graphic per slide; however, you can import graphics from other slides during a 

single import action. Each graphic is inserted as a new standard content page within 

the course. The image is not editable on the resulting page. 

5. Select the PICTURES checkbox next to the graphic(s) you want to import. 

6. Choose a stencil from the following options: 

Stencil Options 

Full This stencil creates a standard content page with 

text. 

It is recommended that you do not use the Standard - 

Full template as it does not support graphics. 

Half - Bottom This stencil creates a standard content page with text 

on the bottom of the page. An optional image can be 

placed on top. 

Half - Left This stencil creates a standard content page with text 

on the left of the page. An optional image can be 
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Stencil Options 

placed to the right. 

Half - Right This stencil creates a standard content page with text 

on the right of the page. An optional image can be 

placed to the left. 

Half - Two Image - Bottom This stencil creates a standard content page with text 

on the bottom of the page. Two optional images can 

be placed on top. 

Half - Two Image - Left This stencil creates a standard content page with text 

on the left of the page. Two optional images can be 

placed to the right. 

Half - Two Image - Right This stencil creates a standard content page with text 

on the right of the page. Two optional images can be 

placed to the left. 

Image This stencil creates a standard content page 

containing an image. 

Image - Diagonal - Left This stencil creates a standard content page with text 

on the top left and bottom right of the page. Two 

optional images can be placed diagonally within the 

stencil. 

Image - Diagonal - Right This stencil creates a standard content page with text 

on the top right and bottom left of the page. Two 

optional images can be placed diagonally within the 

stencil. 

7. Click OK. 

8. Click Yes to confirm the import. 
 

Importing Text from PowerPoint Slides 

 
It is recommended that you arrange the slide elements within PowerPoint using the 

Move to Back functionality so that the text box you wish to import as the title is the 

bottom/back-most element within each slide. 

1. Select INSERT > FROM POWERPOINT. 

2. Choose the .ppt or .pptx file from which you want to import text. 

3. Click Open. 

 
This action will open Microsoft PowerPoint. Do not close the application until you are 

finished importing text. 
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4. In the Slides area, expand the tree view to locate the text you want to import. 

 
 

 
A preview of the text is displayed to the right of the tree view. You can import more 

than one text element at a time. All text elements selected are imported into the content 

area of one new standard content page. Text elements are imported as plain text 

without character formatting. 

5. Select the Text checkbox next to the text item(s) you want to import. 

6. Choose a stencil from the following options: 

Stencil Options 

Full This stencil creates a standard content page with 

text. 

Half - Bottom This stencil creates a standard content page with text 

on the bottom of the page. An optional image can be 

placed on top. 

Half - Left This stencil creates a standard content page with text 

on the left of the page. An optional image can be 

placed to the right. 

Half - Right This stencil creates a standard content page with text 

on the right of the page. An optional image can be 

placed to the left. 

Half - Two Image - Bottom This stencil creates a standard content page with text 

on the bottom of the page. Two optional images can 

be placed on top. 

Half - Two Image - Left This stencil creates a standard content page with text 

on the left of the page. Two optional images can be 

placed to the right. 
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Stencil Options 

Half - Two Image - Right This stencil creates a standard content page with text 

on the right of the page. Two optional images can be 

placed to the left. 

Image - Diagonal - Left This stencil creates a standard content page with text 

on the top left and bottom right of the page. Two 

optional images can be placed diagonally within the 

stencil. 

Image - Diagonal - Right This stencil creates a standard content page with text 

on the top right and bottom left of the page. Two 

optional images can be placed diagonally within the 

stencil. 

7. Click OK. 

8. Click Yes to confirm the import. 
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Using Hotspots, Popups, and Links 

Hotspots can be inserted on images to provide additional information or hints to end users. In 

addition, you can insert the following items in text within standard content areas: 

 Popups- Displays text with the hotspot. Popups can be shown by default or 

displayed based on a trigger. 

 Web Link- Launches a destination website in a new web browser window. 

 Page Link- Opens another page within the course. 

 Resource Link- Opens a document in the current window or a new web 

browser window. 

 

Inserting a Hotspot on an Image 

1. Select a page that contains an image. 

2. Click on the image on which you want to insert the hotspot. 

3. Select INSERT > HOTSPOT to display the Hotspot Properties window. 

 

4. Click General in the left pane and choose from the following options: 

 
Depending on the type selected, some of the following options may not be displayed. 
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Field Description 

Type Specify Popup, Web Link, Page Link, or 

Resource Link. 

Popup: Displays text based on an assigned trigger. 

Web Link: Launches a webpage. 

Page Link: Links to another page within the course. 

Resource Link: Links to a document in a course 

page. 

Trigger Specify Mouse click or Mouse over. 

Tooltip Text Enter text to display when a user pauses the mouse 

on the popup. 

Title Enter text to be displayed as the hotspot title. 

Link Location Enter the location of the link. 

Show popup by default Select the Show popup by default checkbox to 

display the hotspot in published output. 

Localized Check the Localized checkbox to indicate that the 

link should be localized. 

5. Click Display in the left pane and choose from the following options: 

Field Description 

Background Color Specify a background color for the hotspot. This will 

display as a gradient box with a matching border in 

a published course. 

Image Specify an image for the hotspot. 

Layout Specify the position of the hotspot. Choose from 

Top left corner, Top right corner, Center, 

Bottom left corner, Bottom right corner. 

Visible Select the Visible checkbox to display the hotspot in 

published output. 

6. Click OK. 
 

Moving and Adjusting a Hotspot 

1. Click on the hotspot. 

2. Drag the hotspot to the desired location on the image, or click and drag on a sizing handle to 

resize. 

 
Optionally, you can use the cursor keys to move the hotspot around on the image. 
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Editing Hotspot Properties 

1. Right-click on the hotspot. 

2. Select Edit Hotspot.... 

 

3. Click General in the left pane and complete the following fields: 

 
Based on the type selected, some of the following options may not be displayed. 

Field Description 

Type Specify Popup, Web Link, Page Link, or 

Resource Link. 

Popup: Displays text based on an assigned trigger. 

Web Link: Launches a webpage. 

Page Link: Links to another page within the course. 

Resource Link: Links to a document in a course 

page. 

Trigger Specify Mouse click or Mouse over. 

Tooltip Text Enter text to display when a user pauses the mouse 

on the popup. 

Title Enter text to be displayed as the hotspot title. 

Show popup by default Select the Show popup by default checkbox to 

display the hotspot in published output. 

Localized Check the Localized checkbox to indicate that the 

link should be localized. 

4. Click Display in the left pane and choose from the following options: 
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Field Description 

Background Color Specify a background color for the hotspot. This will 

display as a gradient box with a matching border in 

a published course. 

Image Specify an image for the hotspot. 

Layout Specify the position of the hotspot. Choose from 

Top left corner, Top right corner, Center, 

Bottom left corner, Bottom right corner. 

Visible Select the Visible checkbox to display the hotspot in 

published output. 

5. Click OK. 
 

Inserting Popups, Web Links, Page Links, and Resource Links in Text 

 
Popups and links are inserted in the text of standard content pages, and can also be 

inserted into the directions of any interaction page. 

1. Select and highlight text within the content area. 

2. Right-click and select INSERT > INSERT LINK. 

 

3. Complete the following fields: 

 
Depending on the type selected, some of the following options may not be displayed. 

Field Description 

Type Specify Popup, Web Link, Page Link, or 

Resource Link. 

Popup: Displays text based on an assigned trigger. 

Web Link: Launches a webpage. 
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Page Link: Links to another page within the course. 

Resource Link: Links to a document in a course 

page. 

Link Location Specify a destination website, or a link to published 

content to launch from the published course. 

Page Expand or collapse the tree view as needed. 

Select a page from the list. 

Available Resources Select a resource from the list.  

Open in new window Select this option to open the link in a new window 

in the published course. 

 
Selecting this option will attempt to open 

the link in a new window; however, some 

applications' security settings will 

override this setting. 
 

Localized Check the Localized checkbox to indicate that the 

link should be localized. 

4. Click OK. 
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Insert Published Simulations and Course Content 

You can insert a published ART simulation via a simulation stencil. These stencils are accessible 

when creating a new course or when inserting a new page into an existing course. 

 
A course treats an inserted published ART simulation as a single page. A course will 

appear as a single object to an LMS. The LMS will not recognize the simulation as a 

standalone object. 

You can insert course content via the Insert menu. This option is available when inserting objects 

into an existing course. You can select only the pages you want to include in your course, 

decreasing the amount of time spent editing. 

 

Inserting Content from Existing Courses 

 
A caution icon will display in the outline view on a page for which content has not 

been filled out completely and on the Assessment section if there are no pages inserted 

into the assessment. 

1. Create or open a course. 

2. Select INSERT > FROM COURSE. 

3. Browse to the location of the existing course, select the .ulc file, and click Open. 

 

4. In the Page area, expand the tree view to locate the page(s) you want to import. 

 
A preview of the page is displayed to the right of the tree view. You can import more 

than one page at a time. Each page will be inserted as a new page within the course. 

5. Select the page(s) you want to import. 

6. Click OK. 

 
You can edit the course using the procedures described in Editing and Formatting: 

Basics (on page 91) and Editing and Formatting: Courses (on page 171). 
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Inserting Published Simulations 

1. Create or open a course. 

2. Select INSERT > PAGE, INSERT > LESSON, OR INSERT > ASSESSMENT. 

3. Select a simulation stencil. 

4. Enter a name in the Name field. 

5. Click OK. 

 

6. Click Edit Simulation Properties. 

 

7. Perform one of the following options: 

If You Want To Then 

Insert a new simulation Select Simulation from the Insert drop-down 

list. 

Click . 

Select the root folder containing all of the 

elements for the published simulation. 

Click OK. 
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If You Want To Then 

Insert a simulation from your local 

computer 

Select Local from the Insert drop-down list. 

Select a simulation from the Source file window. 

 
The local source directory is by default 

the same location as the course file. To 

change the local source file directory, 

select MANAGE > EMBEDDED 

SIMULATIONS from the menu. 
 

Use an available simulation Select a simulation from the Available 

Simulations window. 

 
This window lists all simulations that 

have been inserted into the course. 
 

8. Complete the following: 

Field Description 

Auto Playback Tutorial Select the checkbox to enable this playback option 

in a published course. 

Standard Tutorial Select the checkbox to enable this playback option 

in a published course. 

Self Test Tutorial Select the checkbox to enable this playback option 

in a published course. 

Assessment Tutorial Select the checkbox to enable this playback option 

in a published course. 

9. Click Insert. 
 

Inserting Updated Simulations 

1. Create or open a course. 

2. Select INSERT > PAGE, LESSON, OR ASSESSMENT. 

3. Select a simulation stencil. 

4. Enter a name in the Name field. 
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5. Click OK. 

 
 

6. Click Update Simulations. 

 

7. Select the updated simulation from the list. The Update button will only be available if the 

simulation has been revised since it was last inserted or updated. 

 
Simulations that have the source simulation on the Server will not be updated unless 

connected to the Server. 

8. Click OK. 

 
If any errors occur during the process, information will be written to the log file and a 

message will be displayed at the end of the process. 
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Working with Flash Content 

You can embed a single Flash file (.swf) into a course. The Flash content must contain all of the 

files necessary for playback. 

You can also edit the Flash file via settings in the Adobe Flash Player Settings. 

 
Flexible stencils and the right click menu are not available when working 

with Flash content.  

 
 

Embedding and Editing Flash Content 

1. Choose one of the following options: 

If You Want To Then 

Embed Flash content as a course root 

page 
Select FILE > NEW.... 

Enter a name in the File name field.  

Select Course from the Type drop-down list. 

Choose a template from the Template listbox. 

Click OK. 

Embed Flash content as a lesson Select the Insert tab. 

Click the Lesson button. 

Embed Flash content as a standard 

content page 

Select the Insert tab. 

Click the Page button. 

2. Enter a name in the Name field. 

3. Select the Flash stencil. 

4. Click OK. 

5. In the content area, click Add Flash content.... 

6. Navigate to the .swf file. 

7. Click Open. 

8. Right-click on the flash file in the Editor. 

9. Select Settings.... 
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10. Edit the settings using the Adobe Flash Player Settings window. 

11. Click Close. 
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Using Audio Files 

Audio files can help guide the end user through the course and provide supplemental information. 

Each page or step within a course or simulation can have a supported audio file - MP3 or WAV - 

associated with the content. 

 
Audio files must be in MP3 format to run on an iPad. 

 
Using WAV files will increase the size of a course compared to when using MP3 files. 

 Audio can be incorporated into two ways: 

 Create an audio recording from directly within the application. This capability 

is excellent for quick, simple recordings that will not require further editing or 

processing. By default, recording audio within the Editor will create WAV 

files. To convert WAV files to MP3, refer to Installing LAME (on page 228). 

 Import an audio file created with an external audio editor application. Using an 

external audio editor allows you more flexibility to enhance or edit your audio 

recording. 

If using WAV files, it is recommended to use the following settings to avoid distortion in the 

published output: 

WAV File Setting Recommendation 

Recorded bit depth 16-bit, mono 

Frequency (Hz) Between 32,000 - 44,1000 Hz 

Resulting Bitrate of WAV File 512kbps - 705kbps 

(i.e. 16 x 32,000 = 512k) 

 

 

Installing LAME 

To create MP3 files from within the Editor, your computer must have the LAME application 

installed within the application directory. 

 
To perform this task, you must be an Administrator on your computer. If you are not, 

contact your IT department for assistance. 

1. Perform a web search for "lame encoder download". 

2. Download the latest version of LAME that is compatible with your computer. 
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3. On your computer, navigate to your browser's Download folder. 

4. Double-click on the LAME zip file to open the file. 

5. Select both lame.exe and LAME_ENC.DLL. 

6. Right-click the selected files and select Copy. 

7. Navigate to LOCAL DISK (C:)>PROGRAM FILES>[applicationdirectory]>CLIENT>BIN or 

LOCAL DISK (C:)>PROGRAM FILES (X86)>[applicationdirectory]>CLIENT>BIN. 

8. Paste both files into the bin directory. 

9. If the Editor is running, restart the Editor for the changes to take effect.  

 
Once you have installed LAME, all recordings will be encoded as MP3 files. 

 
 

Creating an Audio File 

1. In the Course Pane area, select the page to contain the audio. 

2. Select HOME >RECORD to launch the Recording Options dialog window. 

 

3. Complete the following fields: 

Field Description 

Recording Device Specify the input recording device. This selection is 

machine specific. 

Recording Quality Specify the audio quality setting. 

Setting MP3 WAV 

High 320kbps  16-bit 

Medium 128kbps 8-bit 

Low 64kbps 8-bit 
 

Transcript Enter text for the transcript. 

4. Click  to start the recording. Length will display the recording length in seconds. 
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5. Once you have set your options, the following controls are activated: 

Control Description 

 Click Pause to pause the current recording. 

 
Click Stop to stop the current recording. 

 
Click Play to review the current recording. 

6. Click OK. 
 

Importing an Audio File 

 
The recommended MP3 encoding quality/bitrate is between 48-64 kbps. Ensure the file 

is converted to mono to keep the file size as small as possible. 

1. In the task pane, select the page for which you want to insert audio. 

2. Click the Audio tab on the top left. 

 

3. Select Manual from the Audio source drop-down list. 

4. Click Browse.... 

5. Choose the MP3 or WAV audio file to import. 

6. Click Open. 
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Playing an Audio File 

 
Adobe Flash must be installed to enable audio playback. 

1. In the task pane, select the page containing the audio. 

2. Click the Audio tab on the top left. 

3. Click . 

 You can adjust the volume using the slide bar . To stop the playback, click 

. 

 

 

Transcribing an Audio File 

1. In the task pane, select the page containing the audio. 

2. Click the Audio tab on the top left. 

 

3. Click in the Transcript field. 

4. Enter the text of the audio file. 

 
The transcript text is plain text. 
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Deleting an Audio File 

1. In the ask pane, select the page containing the audio. 

2. Click the Audio tab on the top left. 

 

3. Verify the audio file you want to delete is displayed in the Audio file field. You can use the 

Browse button to navigate to the proper file. 

4. Click the Delete button to delete the audio file. 

     
You will not be prompted to confirm the delete action. The file will be instantly deleted. 
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Using Text to Speech 

Course text and simulation step text can be converted into speech. Text to speech provides 

accessible outputs for visually impaired users. Authors can automatically convert text to audio 

that is available to the end user when playing the published output. In addition, text to speech 

allows audio to be translated and used in conjunction with XLIFF files. 

 
 

Configuring Available Voices for Text To Speech 

1. Open the proper application template and ensure that text to speech is enabled for simulations 

and courses. For more information on enabling text to speech, refer to Default Publication 

Settings: Simulation: General Settings (on page 341) and Default Publication Settings: 

Course: General Settings (on page 357). 

2. If you have not already done so, configure a voice for text to speech. For more information, 

refer Specifying General Settings: Text To Speech (on page 326). 

3. From the Editor, open the course or simulation for which you want to add text to speech. 

4. Select FILE > DOCUMENT Properties.... 

5. Click Text To Speech on the left pane. 

 

6. Select one of the following options: 

If You Want To Then 

Use the default template voice Check Use default template voice. 

Select a different voice Select a voice from the Available Voices drop-

down list. 
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If You Want To Then 

Preview the selected voice Enter text in the Preview Text field and click 

Play. 

7. Click OK. Text to speech audio is published within the course or simulation. 
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Using Video Files 

You can insert and embed video files into a course. Video files can be used to demonstrate a task 

or to further explain a concept. Well-made videos can reduce training time by quickly 

demonstrating a concept that would otherwise require much technical text or complicated 

diagrams. You can add multiple video formats; however, not all video formats are supported by 

all browsers. Please refer to the Technical Specifications for requirements.  

 
For more information on adding and enabling video formats, refer to Default 

Publication Settings: Course: General Settings (on page 357). 

 
 

Inserting a Video File 

1. During page creation, select a stencil that allows you to insert a video. For more information, 

refer to Inserting a Page (on page 177). 

 
There is no limit to how many videos can be added to a course page. 

2. In the content area, click the Add Video… icon. 

3. Choose one of the following options: 

If You Want To Then 

Insert a video Select Local Video in the Type drop-down list. 

Click Browse and locate the video you want to 

upload.  

Click Open after selecting the video file. 

Optionally, insert a caption for the video in the 

Caption field.  
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If You Want To Then 

Embed a video Select Embedded Video in the Type drop-down 

list. 

Optionally, insert a caption for the video in the 

Caption field.  

 
This is for screen readers only. A 

caption can be added at the end of 

the embedded code. This text will 

display below the video in the 

published output. 

Enter the embedded video code in the Embed 

Code field. 

 
Any text added after the <iframe> 

could result in the video not 

displaying correctly. 
 

4. Click OK. 

 
For embedded web videos, a placeholder image will be displayed. 

 
Adjusting the size of the content area will not adjust the size of an embedded video. 

The height and width must be adjusted in the embedded code.  

5. Choose one of the following options: 

If You Want To Then 

Select a different video Click the Change Video... icon.  

Remove the video Click the Delete Video... icon. 

 
 

Editing a Video File 

1. Navigate to the video you want to edit. 

2. Right-click on the video and select Edit Video…. 

3. Choose one of the following: 

If You Want To Then 

Edit a local video Go to Step 4. 
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Edit an embedded video Go to Step 6. 

 

 

4. Edit the following fields: 

Field Description 

Layout Select an alignment option for the current video. 

The default value is top left corner. 

Width Select a video width. 

Height Select a video height. 

Maintain aspect ratio If checked, the video will adjust width/height when either is 

changed. 

Start Time Select a start time within the video for video playback. 

 
If your video is 5 minutes long and you want to 

skip the first 2 minutes, the start time would be 3 

minutes.  
 

End Time Select an end time for video playback.  

The maximum value is the length of the video clip. 

Play on load If checked, the video will start automatically when loaded in the 

browser. 

The default value is selected. 

 
If you add multiple videos to a course page, you 

should modify this option to improve the end-user 

experience during playback. 
 

Loop If checked, the video clip will play on a continuous loop. 

Volume Select a volume level for the video. 

Caption Enter a caption for the video. 

The maximum value is 255 characters. 

 
Hovering over the video in the published output, 

displays the caption for local videos only. 
 

Localized If checked, the video will be localized. 
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5. Go to Step 7. 

 

6. Edit the following fields: 

Field Description 

Layout Select an alignment option for the current video. 

The default value is center. 

Caption Enter a caption for the video. 

The maximum value is 255 characters. 

 
A caption can be entered at the end of the 

embedded code. This text will display below the 

video in the published output. 
 

Embed Code Enter the embedded code for the video. 

 
Any text added after the <iframe> could result in 

the video not displaying correctly. 

 
The height and width are specified in the 

embedded code.  

 
You can add code to auto play the embedded 

video. 

 
 

Localized If checked, the video will be localized. 

 

 
Adjusting the size of the content area will not adjust the size of an 

embedded video. The height and width must be adjusted in the 

embedded code.  

7. Click OK. 
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Working with Assessment Sections, Self-Tests, and Branches 

Interaction pages are inserted into an assessment section to test user knowledge. Results can be 

tracked and reported via email, Active Server Pages (ASP), or a Learning Management System 

(LMS). 

Interaction pages can also be used as self-tests to provide ungraded feedback to a user during the 

course. Insert self-tests within a lesson to allow end users to test themselves on the knowledge in 

each lesson before moving into an optional graded assessment section. 

 

Inserting an Assessment Section 

1. Select INSERT > ASSESSMENT. 

2. Enter a name in the Name field. 

3. Choose a stencil from the following options: 

Stencil Options 

Full This stencil creates a standard content page with text. 

Half - Bottom This stencil creates a standard content page with text 

on the bottom of the page. An optional image can be 

placed on top. 

Half - Left This stencil creates a standard content page with text 

on the left of the page. An optional image can be 

placed to the right. 

Half - Right This stencil creates a standard content page with text 

on the right of the page. An optional image can be 

placed to the left. 

Half - Two Image - Bottom This stencil creates a standard content page with text 

on the bottom of the page. Two optional images can 

be placed on top. 

Half - Two Image - Left This stencil creates a standard content page with text 

on the left of the page. Two optional images can be 

placed to the right. 

Half - Two Image - Right This stencil creates a standard content page with text 

on the right of the page. Two optional images can be 

placed to the left. 
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Stencil Options 

Image This stencil creates a standard content page 

containing an image. 

Image - Diagonal - Left This stencil creates a standard content page with text 

on the top left and bottom right of the page. Two 

optional images can be placed diagonally within the 

stencil. 

Image - Diagonal - Right This stencil creates a standard content page with text 

on the top right and bottom left of the page. Two 

optional images can be placed diagonally within the 

stencil. 

Video This stencil creates a standard content page 

containing a video. 

Video - Half - Left This stencil creates a standard content page. An 

optional video can be placed to the right. 

Video - Half - Right This stencil creates a standard content page. An 

optional video can be placed to the left. 

4. Click OK. 
 

Inserting Interaction Pages Into an Assessment Section 

1. In the Course Pane, right-click on the assessment root page. 

2. Select Insert > Page.... 

3. Enter a name in the Name field. 

4. Choose a stencil from one of the following options: 

Stencil Options 

Drag and Drop This stencil creates an interaction page featuring one 

matching item per definition. 

Drag and Drop - Many-to-

One 

This stencil creates an interaction page featuring one 

or more drag-and-drop responses to a single 

question. 

Drag and Drop - Sequencing This stencil creates an interaction page featuring one 

or more draggable responses to a single question. 

Fill In - Multiple This stencil creates an interaction page that allows 

the user to enter responses to multiple questions. 

Fill In - Single This stencil creates an interaction page that allows 

the user to enter a response to a single question. 
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Stencil Options 

Hotspot Single This stencil creates a page featuring text and an 

image. A hotspot area can be defined in the image as 

the correct response. 

Multiple Choice This stencil creates an interaction page featuring 

several possible responses to a single question. Only 

one response is correct. 

Multiple Choice - Half This stencil creates an interaction page featuring 

several possible responses to a single question. Only 

one response is correct. An optional image can be 

placed to the right. 

Multiple Correct This stencil creates an interaction page featuring 

several possible responses to a single question. One 

or more responses may be correct. 

Multiple Correct - Half This stencil creates an interaction page featuring 

several possible responses to a single question. One 

or more responses may be correct. An optional 

image can be placed to the right. 

Simulation This stencil creates a standard content page that 

allows you to import a published simulation. 

Simulation - Half - Right This stencil creates a standard content page that 

allows you to import a published simulation. An 

optional image can be placed on the left. 

5. Click OK. 

 
For more information on interaction pages, refer to Editing Interaction Pages. 

 
 

Editing Assessment Section Properties 

1. In the Course Pane, right-click on the assessment root page. 

2. Select EDIT ASSESSMENT.... 

3. Edit the following options: 

Field Description 

Name Edit the assessment name. 
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Field Description 

Select questions from a 

question pool 

This option indicates to display a pre-determined 

number of interaction pages during the course. 

Number of questions to use Use the up and down arrows to specify the number 

of questions to display during the course. 

4. Click OK. 
 

Creating Custom Assessment Feedback for a Page 

1. In the Course Pane, right-click on an interaction page. 

2. Select Edit Assessment.... 

3. Select Custom Feedback. 

 

4. Select the Use custom feedback text checkbox. 

5. Complete the following fields: 

 
Depending on the type of page selected, some options may not display. 

 

Field Description 

Correct Enter the text to display in response to a correct 

answer. 

For example: That is correct. 

Incorrect Enter the text to display in response to an incorrect 

answer. 

For example: That is incorrect. Would you like to 

try again? 

6. Click OK. 
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Editing Custom Assessment Feedback for a Page 

1. In the Course Pane, right-click on the interaction page for which you want to edit custom 

assessment feedback. 

2. Select Edit Assessment.... 

 

3. Click Custom Feedback on the left pane. 

4. Select the Use custom feedback text checkbox. 

5. Edit/review the following fields: 

 
Depending on the type of page selected, some options may not display. 

Field Description 

Correct Enter a value to display for a correct answer. 

For example: Correct. 

Incorrect 

 

Enter a value to display for an incorrect answer. 

For example: Incorrect. Would you like to try again. 

6. Click OK. 
 

Creating a Self-Test 

1. Click on any page within a lesson. 
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2. Select INSERT > PAGE. 

 

3. Enter a name in the Name field. 

4. Choose from one of the following options: 

 
Stencils for standard content pages also display in this window. To create a self-test, 

choose only one of the stencils listed below. 

Stencil Options 

Branching This stencil creates an interaction page featuring 

several possible choices to a question. Making a 

choice results in going to an independent section of 

content. 

Drag and Drop This stencil creates an interaction page featuring one 

matching item per definition. 

Drag and Drop - Many-to-

One 

This stencil creates an interaction page featuring one 

or more drag-and-drop responses to a single 

question. 

Drag and Drop - Sequencing This stencil creates an interaction page featuring one 

or more draggable responses to a single question. 

Fill In - Multiple This stencil creates an interaction page that allows 

the user to enter responses to multiple questions. 

Fill In - Single This stencil creates an interaction page that allows 

the user to enter a response to a single question. 

Hotspot - Single This stencil creates a standard content page for 

writing, editing, and formatting text that includes a 

hotspot. An image can be placed on the right. 

Multiple Choice This stencil creates an interaction page featuring 

several possible responses to a single question. Only 

one response is correct. 

Multiple Choice - Half This stencil creates an interaction page featuring 

several possible responses to a single question. Only 

one response is correct. An optional image can be 

placed to the right. 

Multiple Correct This stencil creates an interaction page featuring 

several possible responses to a single question. One 

or more responses may be correct. 
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Multiple Correct - Half This stencil creates an interaction page featuring 

several possible responses to a single question. One 

or more responses may be correct. An optional 

image can be placed to the right. 

5. Click OK. 
 

Working with Branches 

You can use interaction and standard pages to create branches within your course. Branches allow 

users to choose where in the course they want to go and these choices are specified when you 

create the branch. The choice will cause the user to take a side road in the content. Based on input 

provided by the user, and the nature of the branch, the user can then return to the main flow of the 

course after all pages in the branch have been visited. Branches allow you to give a variety of 

options to your end users, which allows them to partake in the eLearning course based on their 

personal needs. 

 

Creating a Branch 

1. Select INSERT > PAGE. 

2. Enter a name in the Name field. 

3. Select the Branching stencil. 

4. Click OK. 

5. Click on the {Enter question text here} field. 

6. Enter a question. 
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7. Click the radio button next to the preferred choice: 

If You Want To Description 

Allow the user to choose 

which page to visit  

Select the No Default Choice (User must choose) 

radio button. 

Determine which page the 

user will visit next 

Select a one of the custom choice radio buttons. 

8. Click on the Choice 1 field. 

9. Enter text for the choice. 

10. Click on the Choice 2 field. 

11. Enter text for the choice. 

12. Choose from the following options: 

If You Want To Then 

Add more choices Enter text for the choice in the blank field. 

Adjust the content areas Hover over the slider bar and content area to 

adjust the size. 

 
Changes are only visible in the Editor. 

Published content will not be affected. 
 

13. On the Course Pane, right-click on a choice within the branching page. 

14. Select Insert Page.... 

 

15. Enter a name in the Name field. 

16. Choose a stencil from the following options: 

Stencil Option 

Flash This stencil creates a standard content page 

containing a single Flash file. 

Full This stencil creates a standard content page with 

text. 
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Stencil Option 

Half - Bottom This stencil creates a standard content page with text 

on the bottom of the page. An optional image can be 

placed on top. 

Half - Left This stencil creates a standard content page with text 

on the left of the page. An image can be placed to 

the right. 

Half - Right This stencil creates a standard content page with text 

on the right of the page. An image can be placed to 

the left. 

Half - Two Image - Bottom This stencil creates a standard content page with text 

on the bottom of the page. Two optional images can 

be placed on top. 

Half - Two Image - Left This stencil creates a standard content page with text 

on the left of the page. Two optional images can be 

placed to the right. 

Half - Two Image - Right This stencil creates a standard content page with text 

on the right of the page. Two optional images can be 

placed to the right. 

Image This stencil creates a standard content page 

containing an image. 

Image - Diagonal - Left This stencil creates a standard content page with text 

on the top left and bottom right of the page. Two 

optional images can be placed diagonally within the 

stencil. 

Image - Diagonal - Right This stencil creates a standard content page with text 

on the top right and bottom left of  the page. Two 

images can be placed diagonally within the stencil. 

Video This stencil creates a standard content page 

containing a video. 

Video - Half - Left This stencil creates a standard content page. An 

optional video can be placed to the right. 

Video - Half - Right This stencil creates a standard content page. An 

optional video can be placed to the right. 

Branching This stencil creates a branch that allows the user to 

decide where to go next in the course. 

Drag and Drop This stencil creates an interaction page featuring one 

matching item per definition. 

Drag and Drop - Many-to-

One 

This stencil creates an interaction page featuring one 

or more drag-and-drop responses to a single 

question. 

Drag and Drop - Sequencing This stencil creates an interaction page featuring one 

or more draggable responses to a single question. 
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Stencil Option 

Fill In - Multiple This stencil creates an interaction page that allows 

the user to enter responses to multiple questions. 

Fill In - Single This stencil creates an interaction page that  allows 

the user to enter a response to a single question.  

Hotspot Single This stencil creates a page featuring text and an 

image. A hotspot area can be defined in the image as 

the correct response. 

Multiple Choice This stencil creates an interaction page featuring 

several possible responses to a single question. Only 

one response is correct. 

Multiple Choice - Half This stencil creates an interaction page featuring 

several possible responses to a single question. Only 

one response is correct. An optional image can be 

placed to the right. 

Multiple Correct This stencil creates an interaction page featuring 

several possible responses to a single question. One 

or more responses may be correct. 

Multiple Correct - Half This stencil creates an interaction page featuring 

several possible responses to a single question. One 

or more responses may be correct. An optional 

image can be placed to the right. 

Simulation This stencil creates a page for embedding a 

Simulation. 

Simulation - Half - Right This stencil creates a page for embedding a 

Simulation. An optional image can be placed to the 

left. 

17. Click OK. 

18. Edit the stencil using one of the procedures in Editing and Formatting: Courses (on page 171). 

19. Repeat steps 13 - 18 to create additional pages within the branch choice. 

 
 

Editing Branching Page Properties 

1. Right-click on a choice within a branch. 

 
To edit branching properties, a choice must contain one or more pages. 

2. Select Edit Page.... 
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3. Select Termination in the left pane. 

 
 

 
The General tab is read only. The page name is not editable through the properties 

window. 

4. Choose from the following options: 

Field Description 

Terminate course on this 

page 

Select the Terminate course on this page checkbox 

to end the course once the user has completed this 

page. 

Send score to LMS Select the Send score to LMS checkbox to send the 

page score to a registered LMS. 

Send score as Select a score to be sent to the LMS. 

5. Click OK. 
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Chapter 10: Editing and Formatting: 
Student Guides and Course 
Packages 

You can edit and format a student guide to combine concepts, 

procedures, and exercises related to a series of tasks or a process. In 

addition, you can publish multiple application document and course 

files into a single master SCORM package.  
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Introduction to Editing and Formatting Student Guides and Course 
Packages 

Student guides allow you to combine concepts, procedures, and exercises related to a series of 

tasks or a process. Student guides can include application documents and courses, as well as 

Microsoft Word documents. By combining related information into one booklet, you can provide 

your end users with an easily printable collection of relevant content. 

Student guides can be published to Word format and have the file extension .usg. Published 

student guides can be checked into the Server as a managed document, or they can be printed out 

as a single file for distribution to end users.  

Creating a course package allows a mobile player within a learning management system (LMS), 

such as ANCILE uLearn, to recognize the course structure without the course structure being 

created manually. Course packages can be published locally and checked into the Server for 

content management.  

A course package allows you to publish multiple application content files into a single master 

SCORM package. You can combine documents and courses that are based on the same template, 

and specify the order in which content will be presented to the end user. When adding application 

source files, you have the option of selecting files that reside locally as well as on a Server. 

Course packages have the file extension .upc. 
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Working With a Student Guide 

Inserting Content Into a Student Guide 

1. Create a student guide using the procedure found in Creating Content. 

2. Perform one of the following options: 

If You Want To Then 

Insert source content Select Insert > Insert > Source File. 

Go to Step 3. 

Insert a Microsoft Word document Select Insert > Insert Word Document. 

Navigate to the .doc or .docx file you want to 

insert. 

Click OK. 

Go to Step 5. 

3. From the Insert menu, chose Local. 

4. Perform one of the following options:  

If You Want To Then 

Insert an eLearning course In the Source file window, click on the .ulc file 

you want to insert. 

Insert a published document In the Source file window, click on the .udc file 

you want to insert. 

In the Publication window, click on the 

publication type. Only those publication types 

that produce Word output are listed. 

5. Click Insert. 
 

Replacing Content within a Student Guide 

1. Open a student guide. 

2. Select the content you want to edit or replace in the Task Pane. 

3. Click Replace to the far right. 

4. In the Source file window, click on the .udc or .ulc file you want to insert. 
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5. In the Publication window, click on the publication type. 

 
Publication types will display for .udc files only if they can be published to Word 

format. For more information, refer to Previewing and Publishing Content (on page 

301). 

6. Click Insert. 
 

Replacing or Editing Microsoft Word Content Within a Student Guide 

1. Open a student guide. 

2. Select the Word file in the Task Pane that you would like to edit or replace. 

3. Perform one of the following options: 

If You Want To Then 

Replace the Word file Click Replace to the far right. 

Navigate to the replacement file. 

Click Open. 

Edit the existing Word file Click Edit and then click Yes on the pop-up window 

to open the file in Microsoft Word. 

Edit the Word file. 

In Word, select FILE > SAVE. 

In the Editor, click Yes when prompted to update the 

student guide. 

 

 

Reordering Content within a Student Guide 

1. Click on the content you want to move. 

2. Choose one of the following options: 

If You Want To Then 

Move the content above or below 

another item 

Drag the content above or below another item in 

the task pane. 

Move the content under another item to 

create a chapter 

Drag the content onto the item in the task pane. 
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Previewing the Table of Contents 

1. Open a student guide. 

2. Select Table of Contents in the Task Pane. 

3. Click Preview. 

 
The table of contents preview will open in Microsoft Word. Any edits made to the 

table of contents in Word will not be saved in the .usg file. 

The display is controlled by options available in the Template Editor. For more 

information, refer to Default Publication Settings: Student Guide (on page 350). 

4. Optionally, review the following fields: 

Field Description 

File name Displays the file name for the Student Guide. 

Source directory Displays the location where the student guide is 

saved on the author's local computer. 

 

 
After publishing a student guide, you must open the guide in Microsoft Word and 

update the table of contents as per Word's table of contents update functionality. 

 
 

Viewing and Editing Properties for Student Guide Content 

1. Open a  student guide. 

2. Select a file type from the Task Pane. 

3. Optionally, edit the name of the document in the Name field. 

 
This changes the display of the document name in the table of contents. 

4. Review the following information for source files: 

Field Description 

File name Displays the file name for the content 

Publication Displays the publication type. This option is 

available only for content created in the Editor. 
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GUID Displays the unique identifier for the content. This 

option is available only for content created in the 

Editor. 

Version Number Displays the current version number for the content. 

This option is available only for content created in 

the Editor. 

Language Displays the language of the content. This option is 

available only for content created in the Editor. 

Created Displays the creation date of the content to ensure 

content is up to date. 

Last Modified Display date and time the document was last 

modified. 

Last Accessed Displays the date and time the content was last 

accessed. 
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Working with Course Packages 

Inserting a Lesson Into a Course Package 

1. Create or open a course package. 

2. In the Course Package area, select the package root page or place the cursor where you want 

to insert a lesson. 

3. Select INSERT > LESSON. 

4. Enter a name for the lesson in the Name field. 
 

Inserting a Source File into a Course Package 

1. Create or open a course package. 

2. In the Course Package area, click on a root folder, lesson, or  source file. 

3. Select INSERT > SOURCE. 

 

4. From the Insert drop-down list, choose one of the following options: 

If You Want To Then 

Insert content saved to your local 

source directory 

Select Local. 

5. In the Source file window, click on the file you want to insert. 

6. In the Publication window, click on the publication type. Only those publication types that 

produce Flash output are listed.  

7. Click Insert. 
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Updating or Replacing a Source File 

1. Create or open a course package. 

2. In the Course Package area, click on the source file you want to replace. 

3. Click Replace to the far right. 

4. From the Insert drop-down list, choose one of the following options: 

If You Want To Then 

Update content saved to your local 

source directory 

Select Local. 

5. In the Source file window, click on the file you want to insert. 

6. In the Publication window, click on the publication type. Only those publication types that 

produce Flash output are listed.  

7. Click Insert. 

8. If you are updating a document from the Server, click Update to ensure you are inserting the 

most recent version from the Server. 
 

Reordering Content within a Course Package 

1. Click on the lesson or source file you want to move. 

2. Choose from the following options: 

If You Want To Then 

Move the lesson or source file above or 

below another lesson or source file 

Drag the lesson or page above or below another 

item in the Course Package pane. 

Move the lesson or page into another 

lesson 

Drag the lesson or page onto the item in the 

Course Package task pane. 

 
 

Viewing and Editing Properties for Course Packages 

1. Open a course package. 

2. Select a file type from the Course Package pane. 
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3. Optionally, edit the name of the document in the Name field. 

4. Review the following information for source files: 

Field Description 

File name Displays the file name for the content. 

Publication Displays the publication type. 

GUID Displays the unique identifier for the content. 

Version Number Displays the current version number for the content. 

Language Displays the language of the content. 

Created Displays the creation date of the content to ensure 

content is up to date. 

Last Modified Display date and time the document was last 

modified. 

Last Accessed Displays the date and time the content was last 

accessed. 
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Chapter 11: Searching Content 

Search functionality in the editor allows you to search within content. 
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Introduction to Searching 

In addition to basic search functionality, there is a find and replace feature to allow you to easily 

locate and change text within your content. 
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Searching Within Content 

Two search functions are available within a document or course: 

 Find one or more instances of particular text 

 Find and replace one or more instances of particular text 

You can search within notes, actions, steps, the document narrative, course text and annotations. 

 

Executing a Search 

1. Create or open content. 

2. Click HOME > FIND. 

3. Select the Find tab. 

4. Enter the search text in the Find field. 

 

5. Optionally, click Options to expand and collapse additional search criteria. 

6. Optionally, click Find whole words only to search for an exact word, or click Match case to 

search for words using case sensitivity. 

7. Click Find Next. 

8. To find additional instances of the search text, click Find Next. 
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9. Click Cancel to close the window. 
 

Using Find and Replace 

1. Create or open content. 

2. Select HOME > FIND. 

3. Select the Replace tab. 

4. Enter the search text in the Find field. 

5. Enter the replacement text in the Replace with field. 

 

6. Optionally, click More Options to expand and collapse additional search criteria. 

7. Optionally, click Find whole words only to search for an exact word, or click Match case to 

search for words using case sensitivity. 

8. Click Replace to find and replace the next instance of the search text, or click Replace All to 

find and replace all instances of the search text. 

9. To find additional instances of the text, click Find Next. 

10. Click Cancel to close the window. 
 

Performing a Quick Search 

1. Create or open content in the Document view. 
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2. Enter Ctrl+F. 

 

3. Enter the search term in the Find field. 

4. Optionally, click Find whole words only to search for an exact word, or click Match case to 

search for words using case sensitivity. 

5. Click Next. 

6. Repeat Step 5 to find the next instance of the term. 

7. Click the red X to close the window. 
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Chapter 12: Using the Glossary 

The application allows you to maintain a central file of terms and 

definitions used in procedural content. The glossary functionality 

ensures authors are using consistent and approved definitions. 
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Introduction to the Glossary 

Glossary functionality is provided to allow you to maintain a collection of terms and definitions 

used in procedural content. The glossary allows you to specify consistent, business-specific 

definitions for your terms and then automatically push these definitions into your documents. 

Terms and definitions are displayed in recorded Field/Description tables within the document 

view of content. Field description tables that are inserted during editing as a step will not support 

glossary functionality. The following is an illustration of a recorded Field/Description table. 

 
Maintaining terms and definitions in one file allows documents to be updated quickly and 

accurately. New terms can be added, and changes can be made to definitions for existing terms 

within the glossary. The glossary functionality supports one definition per term. 

Once you have standardized the valid terms and definitions, the administrator executes the 

globalization process to update definitions (descriptions) of terms (fields) within the documents 

prior to making the documents available to your end users. 

Only those documents created with the same template as that used by the current glossary 

template can be globalized. 

To ensure a manageable glossary file size and ensure optimum performance, there is a system 

limitation of 2500 terms that can be stored and managed in a Glossary. If an action within the 

glossary editor would cause this limit to be exceeded, a message is displayed. The number of 

available terms remaining is always displayed in the lower left. 

 
You can choose not to use a central glossary but, rather, have authors enter definitions 

directly into the Description column of tables. 
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Create the Glossary 

There are two methods for initially creating your glossary: 

 Create the glossary file from within the Editor and proceed to populate the file 

manually or via the globalization process. 

 Create the glossary file by importing an existing, tab-delimited text file 

containing terms and definitions or terms only. 

 

Creating a Glossary 

1. Select FILE > NEW from the Editor. 

2. Select Glossary from the Type drop-down list. 

 

3. Select Glossary from the Type drop-down list. 

4. Complete/review the following information: 

Field Description 

File name Enter the name of the glossary. 

Template Select the template associated with this glossary. 

The template controls the glossary layout and the 

term and definition styles used. 

Only documents created with this template can be 

globalized using this glossary. 

Language This field is not applicable to the glossary file type. 

Location As desired, edit the default location of the glossary. 
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5. Click OK. 

For information on adding terms and definitions to your glossary, refer to Adding a Term and 

Definition (on page 272). 

 

Creating a Glossary by Importing a Text File 

 
Prior to importing the text file, save the file using UTF-8 or Unicode encoding to 

ensure special characters are imported correctly. When saving a text file in Notepad, 

select FILE > SAVE AS... and specify UTF-8 or Unicode from the Encoding drop-

down list. 

1. Create the glossary file as described in Creating a Glossary (on page 269). 

2. Select TOOLS > IMPORT A GLOSSARY. 

3. Click Browse... to navigate to the tab-delimited text file. 

4. Click OK. 

5. At the confirmation prompt, click Yes to confirm replacement of any existing terms and 

definitions. 

 
If a line within the file includes a tab, a term and definition pair is imported. If a line 

within the file does not include a tab but does include text, a term is imported. 

6. Review the Application log for any errors. The log is stored in the 

C:\Users\[username]\AppData\Roaming\[applicationdirectory]\version X.xx\Logs directory. 
 



Chapter 12: Using the Glossary 

 

Hewlett Packard Enterprise Develoment LP 271 

 

 

Open and Save the Glossary 

Opening a Glossary 

1. Select FILE > OPEN > OPEN LOCAL.... 

2. Select the .upg file. 

3. Click Open. 
 

Saving a Glossary 

Perform one of the following actions: 

If You Want To Then 

Save an existing glossary Select FILE > SAVE. 

If this is the first time you are saving the file and 

the display of the Properties window is enabled, 

the Properties window is displayed. 

Save the open glossary as a new file Select FILE > SAVE AS.... 

Enter a new filename, and click Save. 
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Adding Terms and Definitions 

When you add a new term and definition pair, the pair is available to all application documents 

when a globalization process is executed. 

 

Adding a Term and Definition 

1. Select INSERT > INSERT TERM. 

 

2. Enter the new term in the Term field. 

3. Click OK. 

4. Perform one or more of the following actions: 

If You Want To Then 

Specify a definition from an existing 

term (a synonym) 

Click Use definition from another term. 

Select the synonym from the drop-down list. 

Add a definition Click Use own definition. 

Enter the definition. 

 
The term and definition pair are added. 

 

 

Adding a Definition to an Existing Term 

1. Select the term from the Glossary task pane. 

2. Enter a definition or specify a synonym. 
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Updating Terms and Definitions 

Editing a Term or Definition 

1. Select the term from the Glossary task pane. 

2. Edit the term or definition. 
 

Deleting a Term 

1. Select the term from the Glossary task pane. 

2. Select HOME > DELETE. 

 

3. Click Yes to delete the term. 

 
Deleting a term removes the term and its definition from the glossary. If you attempt to 

delete a term used as a synonym, a warning message is displayed. Any terms using the 

deleted term as a synonym will be updated to reflect a blank definition. 
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Browsing the Glossary 

You can search for one or more specific terms and view all undefined terms in the glossary. 

 

Viewing Term Information 

1. Select a term in the Glossary task pane. 

2. View the definition or synonym in the content area. 
 

Searching for a Term 

1. In the Glossary task pane, enter the term in the [Search for Term] field. 

 
The list refreshes to highlight the first term matching the search criteria. In addition, 

terms not matching the search criteria are filtered out of the list. 

2. View the associated definition or synonym in the content area. 
 

Viewing Undefined Terms 

In the Glossary task pane, click the View undefined terms only checkbox. 

 
The list refreshes to display terms with a synonym and terms without a definition. 
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Using Globalize 

Definitions for terms in application-created content can be updated using a process called 

globalization. During globalization, definitions are inserted into documents and new terms in 

documents are gathered for inclusion in the glossary. The globalization process affects only text 

within recorded Field/Description tables. Text within Field/Description tables inserted during 

editing is ignored. 

If a term exists in the document, but not in the glossary, the term is added to the glossary with a 

blank definition. The glossary will then need to be updated with a customized definition of the 

new term. You can then globalize to distribute the update to the documents containing the term. 

 
 

Only those documents created with the same template as that used by the current glossary file can 

be globalized. 

 
Definitions are never retrieved from documents during globalization. If an author has 

entered a definition for a term in a document, this definition will be overwritten by the 

globalization process. 

The glossary functionality is not case-sensitive, meaning that a term in a document will be 

considered the same as a term in the glossary regardless of whether the same capitalization rules 

are applied. Purchase order and Purchase Order in documents are considered the same term. The 

Glossary is character-string dependent, however; Purchase order (one space) is different than 

Purchase  order (two spaces). 
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Globalizing Documents 

You can globalize a batch of documents directly from the Editor workspace. This task is typically 

performed by your project administrator. During globalization, definitions are pushed to 

documents. Optionally, new terms (with a blank definition) are added to the glossary. 

The documents to be globalized must be stored in a location accessible by the computer executing 

the globalization. Prior to globalization, request that your authoring team upload their content to a 

designated file server. 

 

Globalizing a Batch of Documents 

1. Select INSERT > APPLY DEFINITIONS. 

 

2. Select one of the following options: 

If You Want To Then 

Apply definitions to a set of documents 

Click . 

Specify the location of the content. 

Click OK. 

Apply definitions to a set of documents 

and retrieve new terms from these 

documents 
Click . 

Specify the location of the content. 

Select Retrieve New Terms from Documents. 

Click OK. 

 

 
All application content in the specified folder and any subfolders is globalized. 

3. Optionally, review the Application log for details and information on any errors. The log is 

stored in the C:\Users\[username]\AppData\Roaming\[applicationdirectory]\version 

X.xx\Logs directory. 
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Publish the Glossary 

The following subsection describes the steps to publish your glossary. 

For detailed information on publishing documents, simulations, and courses, refer to Publishing 

Content. For information on batch publishing content, the glossary, and your website, refer to 

Batch Publishing (on page 416). 

 

Publishing the Active Glossary 

1. Select FILE > PUBLISH > PUBLISH CURRENT. 

 

2. Select the template corresponding to the glossary to be published. 

3. Optionally, browse to specify an outbox other than the default. 

 
The additional options below the outbox are applicable only if you are batch 

publishing content and the glossary. For information on batch publishing content, the 

glossary, and your website, refer to Batch Publishing (on page 416). 

4. Click Publish to publish the active glossary. 

 
When you publish the glossary, any existing, previously published glossary at the same 

location is deleted. 

When publishing is complete, a summary message is displayed with a hyperlink to the 

successfully published glossary. The name of the published glossary is determined by the entry in 

the glossary publication settings in your template.  For detailed information on glossary 

publication settings, refer to Manage All Publications (on page 333). 
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Optionally, review the Application and Transformation logs for detailed information on events. In 

Windows 7 and Windows 8, the logs are stored in the \User\App 

Data\Roaming\[applictiondatapath]\Version X.X\Logs directory. 

 
To print the glossary, open and print the published index.xml file located in the specified 

outbox at \[glossary name]\glossary\xml. 

 

 

Integrating a Published Glossary into the Website 

After publishing the glossary and website, the link to the glossary in the upper right of the website 

will automatically point to the glossary file. Ensure you move all published files to a central file or 

web server as described in Making Your Website Available to End Users (on page 420). 
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Export a Glossary File 

You can export a glossary file for import into the Server. This is useful if you have an glossary 

database and are planning to upgrade to the Server-based version of this application. 

 

Exporting a Glossary File 

1. Open a glossary file. 

2. Select INSERT > EXPORT. 

 

3. Click Browse... to navigate to the export location. 

4. Enter a file name in the File Name field. 

5. Click OK. 

 

6. Click OK. 

 

7. Click OK. 



Chapter 12: Using the Glossary 

280 Hewlett Packard Enterprise Develoment LP 

 

 



 

281 

 

Chapter 13: Using Annotations 

Annotation functionality within the Editor allows authors and 

reviewers to add notes and comments into content created in the Editor. 
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Introduction to Annotations 

Annotations allow authors and reviewers to insert comments in the form of notes directly within a 

document, simulation, or course. Annotations are created within a set; each author or reviewer can 

have a unique, customized annotation set to contain his notes to the author. 

Annotations display in the procedural view and in the course view. Annotations made in one 

procedural view will affect the other view. Annotations do not display on the published content 

available to end users. Course annotations can be displayed on a printed course storyboard. For 

more information, refer to Printing Content (on page 102). Printing course annotations can 

provide additional information for students and course instructors. 

You can display or hide annotations within content.You can toggle the display of annotation sets 

in the content area. 

 
Course annotations are displayed on the bottom of the content area. Document and 

simulation annotations are displayed in the task pane in the Document view. 
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Viewing Annotations 

Viewing an Annotation Set 

1. Open a document, simulation, or course. 

2. Perform one of the following actions: 

If You Want To Then 

View an annotation set for a document  Select the Document tab. 

Go to Step 3.  

View an annotation set for a simulation 

or course 

Select the Simulation or Course tab. 

Select VIEW > ANNOTATIONS to display the 

Annotation task pane if the annotations do not 

display at the bottom of the content pane. 

Go to Step 5.  

3. Click the drop-down arrow to the right of the Layout field on the Document tab. 

 

4. Click Annotations from the drop-down list. 

5. Perform one of the following: 

If You Want To Then 

View annotations for a document  Right-click on the annotation set in the task pane 

and select View.  

 
You can also double-click on the 

annotation set. 

The view will update and you will see the 

annotation column to the right of the document. 

Scroll through the document to view the 

annotation notes. This is why it is helpful to 

color-code the different annotation sets so it is 

easier to see the annotations.  

View annotations for a simulation or 

course 

In the content area, click on the tab name 

corresponding to the annotation set. Review the 

annotation notes. 
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Hiding All Annotation Sets 

1. Perform one of the following actions: 

If You Want To Then 

Hide annotations in a document  Select the Document tab. 

Right-click on an annotation set name in the task 

pane. 

Hide annotations in a simulation or 

course 

Select the Simulation or Course tab. Right-click 

on an annotation tab in the content area. 

2. Click Hide to hide all notes within the content area. 

 
If you want to switch back to document layout view, click the drop-down arrow to 

the right of Annotations and toggle back to Layout. 

 
If you want to turn off the annotations on the simulation and course views, go to 

VIEW > ANNOTATIONS and de-select the checkbox. 
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Creating, Viewing, and Hiding Annotation Sets 

An annotation set contains all the individual annotations made by one author or reviewer for a 

simulation, document, or course. A document or course can have more than one annotation set, 

but only one annotation set is viewable at a time. 

Creating an annotation set automatically creates all annotations within the set. Each annotation 

within an annotation set is associated with only one element in the document or one page in a 

course. Annotations are stored as part of the application content; they are not stored separately on 

the local computer. 

Annotations can also be hidden from view.  

 

Creating an Annotation Set 

1. Create or open a document, simulation, or course. 

2. Perform one of the following actions: 

If You Want To Then 

Create an annotation set for a document Select the Document or Simulation tab, and go 

to Step 3. 

Create an annotation set for a course or 

a simulation 

Go to Step 3. 

3. Select VIEW > VIEW ANNOTATIONS to display the Annotation task pane. 

4. Perform one of the following actions: 

If You Want To Then 

Create an annotation set for a document Right-click in the task pane, and go to Step 5. 

Create an annotation set for a course or 

a simulation 

Click on the Click here to create a new 

Annotation Set hyperlink, and go to Step 6. 
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5. Click New.... 

 

6. Complete the following fields: 

Field Description 

Name Enter the name of the annotation set. 

Owner Enter the name of the annotation author. 

Style: Font Face Specify a font for the annotation text from the drop-

down list or optionally browse to locate a font. 

Style: Font Size Specify a font size for the annotation text from the 

drop-down list. 

Style: Color Specify a font color for the annotation text or 

optionally browse to choose a custom font color. 

Style: Bold Click the checkbox to activate bold formatting. 

Style: Italic Click the checkbox to active italic formatting. 

Style: Background Color Specify a background color for the annotation note 

or optionally browse to choose a custom background 

color. 

7. Click OK. 
 

Entering Annotation Text 

1. Create or open a document, simulation, or course.  

2. Perform one of the following actions: 
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If You Want To Then 

Enter annotation text in a document or 

simulation 

 
Annotation text for 

documents can only be 

entered on the Simulation 

tab. 
 

Select the Simulation tab. 

Select VIEW > ANNOTATIONS to display the 

Annotation task pane. 

Go to Step 2. 

Enter annotation text in a course Select the Course tab. 

Select VIEW > ANNOTATIONS to display the 

Annotation task pane. 

Go to Step 2.  

 

 

3. In the content area, perform one of the following actions: 

If You Want To Then 

Enter annotation text in a document In the content area, double-click in the 

annotation note corresponding to the element you 

wish to annotate, and go to Step 4. 

Enter annotation text in a course or a 

simulation 

Navigate to the page you want to annotate. 

Click on the appropriate tab. 

Click in the annotation content area, and go to 

Step 4. 

4. Enter your annotation text. 
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Managing Annotation Sets 

You can create copies of existing annotation sets, modify an annotation set, and delete annotation 

sets. 

 

Duplicating an Annotation Set 

1. Open a document, simulation, or course. 

2. Perform one of the following actions: 

If You Want To Then 

Duplicate an annotation set in a 

document  

Select the Document tab. 

Go to Step 3.  

Duplicate an annotation set in  

simulation or course 

Select the Simulation or Course tab. 

Select VIEW > ANNOTATIONS to display the 

Annotation task pane if the annotations do not 

display at the bottom of the content pane. 

Go to Step 5.  

3. Click the drop-down arrow to the right of the Layout field on the Document tab. 

 

4. Click Annotations from the drop-down list. 

5. Perform one of the following actions: 

If You Want To Then 

Duplicate an annotation set in a 

document 

Right-click on the annotation set name in the task 

pane. 

Select Duplicate. 

Duplicate an annotation set in a course 

or a simulation 

Right-click on the tab of the annotation set you 

want to duplicate, and select Duplicate. 

6. Right-click on the duplicated annotation set, and select Modify. 

7. Specify the annotation set properties. For information on entering properties, refer to Creating 

an Annotation Set. 
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8. Click OK. 
 

Updating an Annotation Set 

1. Create or open a document, simulation, or course. 

2. Perform one of the following actions: 

If You Want To Then 

Update an annotation set in a document  Select the Document tab. 

Go to Step 3.  

Update an annotation set in  simulation 

or course 

Select the Simulation or Course tab. 

Select VIEW > ANNOTATIONS to display the 

Annotation task pane if the annotations do not 

display at the bottom of the content pane. 

Go to Step 5.  

3. Click the drop-down arrow to the right of the Layout field on the Document tab. 

 

4. Click Annotations from the drop-down list. 

5. Perform one of the following actions: 

If You Want To Then 

Update an annotation set in a document Right-click on the annotation set name in the task 

pane. 

Select Modify.... 

Update an annotation set in a course Right-click on the tab of the annotation set you 

want to duplicate, and select MODIFY.... 
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6. Edit the annotation set properties. For information on maintaining properties, refer to Creating 

an Annotation Set. 

7. Click OK. 
 

Deleting an Annotation Set 

1. Create or open a document, simulation, or course. 

2. Perform one of the following actions: 

If You Want To Then 

Update an annotation set in a document  Select the Document tab. 

Go to Step 3.  

Update an annotation set in  simulation 

or course 

Select the Simulation or Course tab. 

Select VIEW > ANNOTATIONS to display the 

Annotation task pane if the annotations do not 

display at the bottom of the content pane. 

Go to Step 5.  

3. Click the drop-down arrow to the right of the Layout field on the Document tab. 

 

4. Click Annotations from the drop-down list. 

5. Perform one of the following actions: 

If You Want To Then 

Delete an annotation set in a document Right-click on the annotation set name in the task 

pane. 

Select Delete.... 

Delete an annotation set in a course Right-click on the tab of the annotation set you 

want to duplicate, and select DELETE.... 

 

 

6. Click Yes at the confirmation prompt. 
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Managing Annotation Notes 

After you have created your annotation set and individual annotation notes, you can update the 

text within a note and modify the note format. 

 

Editing an Annotation Note 

1. Perform one of the following actions: 

If You Want To Then 

Edit an annotation note for a document Double-click on the annotation set name to edit, 

and go to Step 2. 

Edit an annotation note for a course or 

a simulation 

Go to Step 2. 

2. Click in the note in the content area. 

3. Edit text as desired. 
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Chapter 14: Using Custom Skins and 
Modifying CSS Files 

The application allows you to manage custom skins for courses, 

simulations, and guided help publications. You can deploy custom 

skins with the Editor to provide multiple authors the ability to share 

and use the custom skins. You can modify CSS files to incorporate 

your corporate standards and preferences. 
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Creating and Customizing Skins 

The application allows you to create and update custom skins for courses, simulations, and guided 

help publications. You can deploy the custom skin with the Editor to provide multiple authors the 

ability to share and use the custom skins. 
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Creating Skins 

Creating Skins 

If you do not want to leverage a standard skin delivered with the application, you can create a 

custom skin. 

1. Copy an existing skin from the 

C:\Users\[username]\AppData\Roaming\[applicationdirectory]\version X.xx\skins\[Course or 

Sim]\ ART folder. 

2. Paste the skin to the C:\Users\[username]\AppData\Roaming\[applicationdirectory]\version 

X.xx\skins\[Course or Sim]\custom folder. 

3. Rename the skin (the folder name). For example: Custom Skin 001 

4. Modify the skin.css located in the 

C:\Users\[username]\AppData\Roaming\[applicationdirectory]\version X.xx\skins\[Course or 

Sim]\custom\[renamed skin]\skin folder. 
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Managing Custom Skins 

Manage Local Custom Skins 

1. Select FILE > PREFERENCES. 

2. Click MANAGE LOCAL CUSTOM SKINS from the left pane. 

 

3. Perform one of the following options: 

If You Want To Then 

Import a custom skin Click Import.... 

Navigate to the .uskin file on your local 

computer and click Open. 

Click OK. 

Deploy a custom skin Select a skin from the list. 

Click Export.... 

 
Deployed custom skins have a .uskin 

file extension. 
 

Delete a custom skin Select a skin from the list. 

Click Remove.... 

Click Yes. 

4. Click Close. 
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Guidance on Modifying Cascading Style Sheets 

Guidance on Modifying Cascading Style Sheets 

You can modify the .css files to incorporate your corporate standards (for example, font and color 

scheme). 

 
A complete tutorial on modifying cascading style sheets is beyond the scope of this 

manual. Several books and websites discuss this topic in detail. In particular, the World 

Wide Web Consortium (W3C) provides helpful information at http://www.w3.org 

http://www.w3.org. 

The following table provides general guidance on performing common customization tasks in the 

style sheets. 

If You Want To Go To Modify 

Customize the placement of 

the Continue button on 

assessment stencils 

The assessment section of the 

content.css file. 

div#assessmentButtons to set the text 

alignment and background. 

div#assessmentButtons 

input[type=button] to set the borders 

and background of all the assessment 

buttons. 

input#btnContinue, input#btnRetry, 

input#btnReset, input#btnShowMe 

and input#btnSkipSim to set border, 

color and text alignment of each 

respective button individually. 

http://www.w3.org/
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If You Want To Go To Modify 

Override or replace images 

displayed in the course menu 

The menu section of the 

skin.css file. 

div#courseImage to set the image URL 

for the course icon. 

div#menuHereImage to set the image 

URL for the menu here icon. 

div#menuVisitedImage to set the 

image URL for the menu visited icon. 

div#menuMinusImage to set the image 

URL for the menu minus icon. 

div#menuPlusImage to set the image 

URL for the menu plus icon. 

div#menuAssessmentImage to set the 

image URL for the menu assessment 

icon. 

div#assessmentPassedImage to set the 

image URL for the assessment passed 

icon. 

div#postAssessmentPassedImage to 

set the image URL for the post 

assessment passed icon. 

div#postAssessmentImage to set the 

image URL for the post assessment 

icon. 

div#menuBranchImage to set the 

image URL for the menu branch icon. 

div#menuBranchChoiceImage to set 

the image URL for the menu branch 

choice icon. 

div#branchConnectorImage to set the 

image URL for the branch connector 

icon. 

div#singleBranchImage to set the 

image URL for the single branch icon. 

div#extendBranchImage to set the 

image URL for the extend branch icon. 

Modify the username prompt 

in courses and simulations 

The user name prompt page 

section of the skin.css file. 

body.uiPromptPageBackground to set 

the background of the prompt page. 

td.uiPromptBackground to set the 

image URL or background of the 

prompt box. 

div#titleTextDiv to set the text color, 

text alignment and font of the title. 

div.uiPromptText to set the text color, 

text alignment and font of the prompt 

text. 

Customize the loading page 

in courses, simulations, and 

guided help 

The loading section of the 

skin.css file. 

div#LoadingMessage to set the 

background color of the loading page. 

div#LoadingMessage div#loadingText 
to set the color and text alignment. 
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If You Want To Go To Modify 

div#loadingImage to set the logo 

dimensions and URL. 
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Chapter 15: Previewing and Publishing 
Content 

The application offers flexibility in the content types and formats that 

you can publish. Published content can be incorporated into your end 

user website. 
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Introduction to Previewing and Publishing Content 

Publishing has many functions, and allows you to: 

 Convert certain sections of a single document into complete, stand-alone 

publications intended for end user consumption.  

 Convert your course or simulation into web-ready content. 

 Create a printable booklet containing concepts, procedures, and exercises. 

 Combine multiple content files into a single master SCORM package for use 

with an LMS. 

 Produce guided help output to use during task execution. 

You may publish as often as necessary. Content that is locally published to the same location will 

overwrite existing content of the same format and type. 

For detailed information regarding publishing the glossary and website, refer to Publishing the 

Active Glossary (on page 277) and Publishing the Active Website (on page 414). 

 

Overview of Document Publishing 

Based on the settings specified by the author template you are using, the following document 

types may be available to publish: 

 ASAP BPP (Business Process Procedure) - Mimics the BPP documents that 

come with an Accelerated SAP (ASAP) implementation. 

 ASAP BPP Cue Card (HTML and XML formats only) - Mimics the ASAP 

BPP documents and provides a dynamic, multi-layer format designed 

specifically for context-sensitive help. 

 Configuration Information - Lists information such as configuration menu 

path, key field changes, and date of configuration change. 

 Cue Card (HTML and XML formats only) - Provides a dynamic, multi-layer 

document designed specifically for context-sensitive help, includes 

screenflows. 

 Exercise - Includes data for a given procedure, and tasks and questions for end 

users to complete. 
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 Quick Reference (Flow) - Includes overview information and a screenflow. 

 Quick Reference (Step) - Includes overview information and end user steps 

without screen images or field definitions. 

 Test Document - Includes scenarios and results used in system testing. 

 Work Instruction - Includes overview information, end user procedures with 

steps, field description tables, screen shots, and screenflows. 

 Test Script - Publishes an XML file and creates an "Images" folder containing 

images that correspond to each step in a document created with the 

application. A Microsoft Excel add-in allows you to upload this publication 

type to HP Quality Center version 9.2 or higher as a manual test script.  

Your available document publishing settings and output types is mandated by your template. For 

detailed information on creating and maintaining templates, refer to Using Author Templates - 

Express (see "Using Author Templates" on page 317). 

 

Overview of Simulation Publishing 

Simulations are published as interactive tutorials. Based on the settings specified by the template 

you are using, the following simulation playback modes may be available to publish: 

 Auto Playback: Replays the task; no user intervention is required. 

 Standard: Guides the user through the task with step-by-step instructions. 

 Self Test: Allows the user to attempt the task and provides guidance when an 

error is made. 

 Assessment: Allows results to be captured and integrated into custom or third-

party tracking applications. 

Interactive tutorials are output as HTML files. HTML output is viewable through standard web 

browsers. 

The tutorials are accessible through a main lesson homepage. The homepage display can be 

modified via your template. For detailed information on creating and maintaining templates to 

define your simulation publishing options, refer to Using Author Templates (on page 317). 
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Overview of Course Publishing 

Courses are published as self-paced content in HTML format, which provides optimal output 

performance by streaming audio after the content is buffered. Courses are interactive and can be 

played back using a supported web browser. 

In addition, you can publish courses to PDF, print, and Word for distribution to your end users. 

 

Overview of Student Guide Publishing 

Student guides are published to Microsoft Word format. You must ensure that all application 

source files exist in the same directory as the student guide. In addition, your source files must use 

the same template as the student guide to which they are inserted. 

 
After publishing a student guide, you must open the guide in Microsoft Word and 

update the table of contents as per Word's table of contents update functionality. 

 

 

Overview of Course Package Publishing 

A course package can automatically publish your course or simulation as an AICC- or SCORM-

conformant package ready for upload to your AICC or SCORM LMS. A course package (.ucp) 

can be published to a .zip file to allow you to combine multiple content files into a single master 

SCORM Package. 

 

Overview of Guided Help Publishing 

Guided Help is published HTML content designed to be used during task execution. Users can 

start guided help playback for on-the-job support. 
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Previewing a Simulation 

You can preview simulations prior to publishing output locally or by checking the content into the 

Server. 

1. Select FILE > PREVIEW SIMULATION... to display the Preview Simulation window. 

 

2. Click on one of the listed tutorial modes to launch the simulation. 

 
Hyperlinks and hotspots inserted into the simulation will not be active until the 

simulation is published. 

For detailed instructions on interacting with a simulation during playback, refer to Viewing 

Simulations (on page 311). 
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Previewing a Course 

You can preview individual course pages prior to publishing. Only one page can be viewed at a 

time. 

1. In the Course pane, click on the desired page to preview. 

 
Hyperlinks, hotspots, and simulations inserted into the course will not be active until 

the course is published. 

2. Select the Preview tab. 
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Publishing Content 

You can publish the current open content, or specify an inbox of  content to publish in batch 

mode. 

 
You must have Microsoft Office (specifically, Microsoft PowerPoint and Word) 

installed on your computer to locally publish .ppt, .pptx, .doc, .docx and .pps output. 

 

 

Publishing Active Content 

1. Select FILE > PUBLISH CURRENT.... 

 

2. Perform one of the following actions: 

If You Want To Then 

Publish documents and simulations Select the appropriate checkboxes to the left of 

the desired simulation and document types and 

formats. 

Publish a course Select the HTML, PDF, Print, or Word option. 

Publish a student guide Select the Word option. 

Publish a course package Select the zip option. 

Publish guided help Select the Guided Help option. 

3. Optionally, browse to specify an outbox other than the default. 

4. Click Publish to publish the selected output types and formats. 
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When publishing is complete, a summary message is displayed with a hyperlink to successfully 

published content. For detailed information on viewing simulation playback, refer to Viewing 

Simulations (on page 311). For detailed information on viewing a course, refer to Viewing 

Courses (on page 313). 

 

Batch Publishing Content 

1. Select FILE > BATCH PUBLISH.... 

 

2. Select the appropriate checkboxes to the left of the desired template, content types, glossa\-

ries, websites, and associated formats. 

3. Optionally, browse to specify an inbox and/or outbox other than the default. 

4. Optionally, select the Publish checkbox to publish only files in the inbox that have changed 

since the last publish operation. 

 
When this option is enabled, the application scans the inbox folder to determine which 

documents and courses have been modified since the last publish operation. The 

application then includes only these changed files in the list of content to be published 

to the outbox folder. 

5. Click Publish to publish the selected output types and formats. 

When publishing is complete, a summary message is displayed with hyperlinks to successfully 

published content. For detailed information on viewing simulation playback, refer to Viewing 

Simulations (on page 311). For detailed information on viewing course playback, refer to Viewing 

Courses (on page 313). 

 

Prerequisites for Importing Content into an LMS 

Perform the following steps to generate simulations and courses that are ready for import into 

your SCORM- or AICC-conformant LMS: 



Chapter 15: Previewing and Publishing Content 

 

Hewlett Packard Enterprise Develoment LP 309 

 

 

1. Select the Create package option within the template. Ensure the correct version of SCORM 

or AICC is selected. For more information, refer to Default Publication Settings: Course: 

LMS Settings (on page 363) and Default Publication Settings: Simulation: LMS Settings (on 

page 346). 

2. Publish the simulation(s) and/or course(s).  

 
If the content does not contain an assessment, only the completion status will be 

captured. For more information, refer to Publishing Content for Use in an LMS (on 

page 309). 

3. Locate the SCORM- or AICC-conformant .zip file in the published folder. 
 

Publishing Content for Use in an LMS 

1. Create or open a course or simulation.  

2. Select File > Publish Current... to publish the content to your local drive.  

 
The course or simulation template must have the Create Package option enabled.  For 

more information, refer to Default Publication Settings: Course: LMS Settings (on 

page 363) and Default Publication Settings: Simulation: LMS Settings (on page 346). 

3. Select the appropriate Course or Simulation output type(s).  

4. In the Outbox field, select a local folder. 

5. Click Publish. 

 
The publishing process will create a [your file name].zip file in one of the following 

locations depending on your document type:  

[applicationdirectory] Courses: [your file name]\course\html\ 

[applicationdirectory] Simulations: [your file name]sim\html\  

6. Provide the .zip file package to your LMS administrator for upload according to the 

appropriate LMS specifications. 
 



Chapter 15: Previewing and Publishing Content 

310 Hewlett Packard Enterprise Develoment LP 

 

Viewing and Working with Published Content 

Viewing Documents 

Published content is stored in the specified outbox folder. Within this folder, content is stored in 

subfolders based on file name. 

Within each folder, output type and format subfolders are displayed. Navigate to the desired 

subfolder and double-click on the index file to display content. 

 
 

Working with Test Scripts 

The test script publication publishes an XML file formatted for use in a Microsoft Excel 

spreadsheet. If you are using HP Quality Center version 10.0 or higher, the publication will also 

publish an "Images" folder containing images that correspond to each step in a document created 

by the application. The XML file contains paths to the images, which are automatically attached 

to the steps in HP Quality Center version 10.0 or higher. 

This document type is available only from the Editor. For more information on installing and 

configuring the Microsoft Excel Add-In, refer to the "Microsoft Excel Add-In Guide" provided 

with your supported version of HP Quality Center. 

The following provides an overview of how to enable and produce a test script publication: 

1. Enable Test Script on the Publications tab in the template. 

2. Publish the test script from the Editor. 

3. Open the test script in Microsoft Excel. Only the step text will be published in the Excel 

Spreadsheet (XML); no images will display. 
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4. Complete the Subject and Expected Results columns fields. Documents do not contain a 

field that represents these values. 

5. Upload the test script to HP Quality Center using the Microsoft Excel Add-in. 
 

Viewing Simulations 

If you are viewing a simulation outside of a SCORM- or AICC-conformant LMS, enter a 

username in the Please enter a user name for the test results field, and click . 

All output modes can be started by selecting a hyperlink on the published homepage. 

 
For detailed information on customizing playback modes, refer to Default Publication Settings: 

Simulation: General Settings (on page 341). 

 

Viewing a Standard Simulation 

In this playback mode, the end user interacts with the lesson. End users are shown the action 

hotspots, the steps in the Steps window, the step status bar, notes, and any incorporated audio. The 

end user performs the actions to complete the tutorial. 

Standard mode allows the end user to skip around in the lesson by selecting the desired step in the 

Steps window. The Steps window display can also be customized. 

The following playback options are available: 

If You Want To Then 

Enable or disable playback of an 

associated audio file 
Click  on the bottom right of the simulation 

playback page. 
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If You Want To Then 

Remove a bookmark To remove a bookmark, select the bookmarked 

step, and click . 

Hide the Steps window To hide the Step Window, click Hide Steps. 

Restore the Steps window To restore the Step Window, click Restore Steps. 

Send the simulation output to a printer To send the step text and screens to the printer, 

click  in the Step Window. 

Expand or collapse the Step Window 

window 

Click  in the Step Window. 

Move to the next or previous step Click   or   on the bottom left of the 

simulation playback page. 

 
 

Viewing an Auto Playback Simulation 

This playback mode will automatically run the lesson without user interaction. In this mode, the 

application performs the actions to complete the simulation with the user as an observer. Although 

the action hotspots and step status bar are viewable, the user has no input into the actions 

occurring during playback of the lesson. A Control Toolbar is displayed during the Auto Playback 

mode so that the user can reverse, pause, forward, stop, or resume the lesson playback. In 

addition, the user can move forward or backward by selecting a step in the Steps window. 

For instructions on creating printable output and inserting bookmarks, refer to Viewing a Standard 

Simulation (on page 311). In Auto Playback mode, the user must first stop the playback before 

inserting a bookmark. 

 

Viewing a Self-Test Simulation 

The Self-Test has no Steps window instructions, hotspots, notes, audio playback, or step status bar 

information. In this playback mode, the user is encouraged to remember and perform all necessary 

steps for testing purposes. 

If you have enabled the display of hints for this lesson or for all lessons, the hint for the 

nonessential data will display in the lower left of the playback window. For example, one step of 

the simulation assessment might require users to enter a training ID, but in real life they will enter 

their own user id. When creating the simulation, you can type a note in the hint field like "Type 

Training ID 0001 for this simulation. On the production site, you will use your own User ID." For 

more information on enabling hints, refer to Default Publication Settings: Simulation: General 

Settings (on page 341). 
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The user must perform all steps within the simulation from memory. If the user makes a mistake 

on a step, a Help window will display. By selecting Yes on the Help window, the system will 

display only the location of the required action with the appropriate hotspot. 

Upon completion of a lesson in Self-Test mode, the user will receive an accuracy score measuring 

his performance. 

 

Viewing an Assessment Simulation 

The Assessment mode has no Steps window instructions, hotspots, notes, audio playback, or step 

status bar information. In this playback mode, the user is encouraged to remember and perform all 

necessary steps for testing purposes. 

If you have enabled the display of hints for this lesson or for all lessons, the hint for the 

nonessential data will display in the lower left of the playback window. For example, one step of 

the simulation assessment might require users to enter a training ID, but in real life they will enter 

their own user id. When creating the simulation, you can type a note in the hint field like "Type 

Training ID 0001 for this simulation. On the production site, you will use your own User ID". For 

more information, refer to Default Publication Settings: Simulation: General Settings (on page 

341). 

This mode also provides the ability to send test results. To capture the results of an assessment 

tutorial if you are working outside of an LMS, you must enter a URL specifying the test result 

destination in the template. For complete details on specifying assessment options in the template, 

refer to Default Publication Settings: Simulation: General Settings (on page 341). 

The user must perform all steps within the simulation from memory. If the user makes a mistake 

on a step, a Help window will display. By selecting Yes on the Help window, the system will 

display only the location of the required action with the appropriate hotspot. 

Upon completion, the user will receive an accuracy score measuring his performance. 

A user can view, filter, and sort all assessment history on the Server, if applicable.  

 

Viewing Courses 

If you are using an LMS or score catcher, enter a username in the Please enter a user name for 

the test results field, and click . 



Chapter 15: Previewing and Publishing Content 

314 Hewlett Packard Enterprise Develoment LP 

 

View a course by selecting the Course hyperlink on the published homepage. 

 
Buttons such as Back and Next are used to navigate through the course. The Menu button allows 

the user to display an outline view of course content and identify his location within the course. 

The user can also jump to different pages within the course. 

The audio toolbar allows the user to play, pause, stop, and mute the audio that accompanies an 

individual page. 

The History option allows the user to display only pages that have been visited. For example, if a 

user wanted to change a choice, or review page content, selecting this option displays only the 

pages visited. This is useful if your course incorporates branching so that the user sees only 

content relevant to the branch selected, or if a user wants to go directly to a specific page that has 

already been visited. 

A user can opt to zoom into an image on a published page by hovering over the image and 

clicking the plus (+) sign on the image. This will open the image in a new window. 

When a user reaches the end of the course, the user will be given the option to continue into the 

assessment. 

A user can exit the course at any time by clicking Exit. The user will be prompted to confirm 

course results. 

Upon completion, the user will receive an accuracy score measuring his performance. 

 

Viewing Student Guides and Course Packages 

Published student guide content is stored in the specified saved location. You can view published 

student guides by opening them in Microsoft Word. 

Published course package content is stored as a .zip file in the specified saved location. You can 

view content within a published course package by opening the index.html file in a web browser. 
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Viewing Simulations on the Apple iPad 

The application supports playback of simulations on Apple iPads. Because the iPad does not 

natively support Windows-specific keys on its keyboard, the application provides specific key 

combinations to allow users to complete simulations. 

The following options are available: 

If You Want To Then 

Display iPad-specific help 
Click  on the bottom right of the simulation 

playback page. 

Enable a right-click event 
Click  on the bottom right of the simulation 

playback page. 

Enable the Control (CTRL) key 

Click  on the bottom right of the 

simulation playback page. 

Enable the Alt key 

Click  on the bottom right of the simulation 

playback page. 

Enable the Shift key 
Click  on the bottom right of the 

simulation playback page. 

 
 

Viewing Guided Help 

Guided help is launched by selecting the hyperlink on the published content home page. 
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Once the user starts playback, guided help will automatically run without user interaction. This 

mode is quite similar to the auto playback mode in simulations; the application performs the 

actions to complete the transaction with the user as an observer. 

 
A Control Toolbar is displayed in the guided help to allow users to reverse, pause, forward, stop, 

or resume the help playback. In addition, the user can move forward or backward by selecting a 

step in the Step window. 

If You Want To Then 

Play the playback 
Click  on the bottom right of the help 

playback page. 

Pause the playback 
Click  on the bottom right of the help 

playback page. 

Advance one step Click  on the bottom right of the help 

playback page. 

Reverse one step 
Click  on the bottom right of the help 

playback page. 

Change Options Click  on the top right to open Options. 

Refer to Setting Guided Help Options for 

additional information. 

Change to current step mode Click  on the top right of the help playback 

page to toggle between Current Step mode and 

Full View mode. 

Current Step mode focuses on the current step 

only. Full View mode displays the entire 

transaction and highlights the current step. 
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Chapter 16: Using Author Templates 

Author templates control the formatting and publishing options 

available to authors. Templates allow you to set standards and maintain 

consistency within your authoring team. The template also controls the 

functionality and display of your glossary and website. 
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Introduction to Author Templates 

A key capability of ART is the ability to allow administrators to establish and enforce standards 

through the use of author templates. Author templates contain configuration and style settings to 

control the appearance and content of your training materials. Templates help you to enforce 

consistency via these predetermined formatting and configuration settings. Consistent formatting 

enables your users to quickly and easily find information in all content. 

Author templates provide control over the following elements.  

 Styles - a group of formatting options that relate to paragraphs or character 

text. 

 Publications - a designator indicating content output. 

 Phrases - a group of culture-specific boilerplate text items that are placed into 

a block by default. 

 ART Properties - metadata such as document title, owner, and version used to 

describe content. 

 Image, Data, and Language Management - allows you to control images, data 

fields, and languages associated with a template. 

You can edit author templates via the Editor. 

The following diagram illustrates many of the basic procedural document elements that you can 

modify within the template: 
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Managing Author Templates 

At the start of your project, you should create a new template and specify your configuration 

settings. 

Each file is linked to a template via the template's unique 32-bit identifier. 

During creation and edit, author templates are stored on your computer in the following locations: 

 C:\Users\[username]\AppData\Roaming\[applicationdirectory]\version 

X.xx\templates 

You can manage local templates directly through the Editor. Author templates have a .udt file 

extension. 

 

Create and Open a New Author Template 

The following best practices apply to your use of author templates: 

 Create a new template using the FILE > NEW menu in the Editor. Do not copy 

and rename a .udt file. The copy process renames the file but does not modify 

the template's unique identifier. A document is linked to a template via the 

template identifier, not the template name. 

 After creating a .udt file, do not rename the file via Microsoft Windows 

Explorer as this may cause an author to have multiple template files with the 

same identifier. 
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Creating a New Author Template 

1. From the Editor, select File > New. 

 

2. Enter a name for the new template in the Name field. 

3. Select Template from the Type drop-down list. 

4. Select a template from the Template list. 

5. Click OK. 

 
Refer to any of the following subsections for more information on customizing the 

template. 

 

 

Opening a Template 

1. From the Editor, select FILE > OPEN > OPEN TEMPLATE. 

2. Select the template you want to open. 

3. Optionally, select Lock template for editing. 

4. Click OK. 

 
The standard author template delivered with the product cannot be opened in the 

Editor. 

 

 

Managing Local Templates 

1. Select FILE > PREFERENCES. 
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2. Click MANAGE LOCAL TEMPLATES from the left pane. 

 

3. Perform one of the following options: 

If You Want To Then 

Import a template Click Import.... 

Navigate to the template and click Open. 

Click OK. 

Export a template Select a template from the list. 

Click Export.... 

Navigate to the template and click Open. 

Enter a name for the template. 

Remove a template Select a template from the list. 

Click Remove. 

Click Yes. 

 
 

Specifying New Template Settings: General 

Specifying General Settings: Information 

1. From the Editor, open the new template. 

2. Click General on the status bar. 
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3. Click Information in the task pane. 

 

4. Review the following information: 

Field Description 

Name Specifies the name of the new template. 

GUID Specifies the unique ID of the template. 

Show file properties on first 

save 

Select the Show file properties on first save 

checkbox to display the Properties window to the 

author upon the first save during a new recording. 

Show "Press Return' step 

after Field Description Table 

If enabled, the 'Press Return' step is displayed after 

Field/Description tables. 

Field Label Separator Specifies what character should be used to separate 

multiple labels in a Field/Description table. 

Default Screen Display for 

Steps in the Document Editor 

Select from the following display options: Only if it 

is the first time this screen is used, Always, or 

Never. 

Callout Color Select the color to be used for displayed callouts. 

Optionally, click Select to choose a color. 

Background Color Select the background color to be used for displayed 

masks. 

Border Color Select the border color to be used for displayed 

masks. 

5. Perform one or more of the following options: 

If You Want To Then 

Add built-in or custom properties to be 

used to organize the website hierarchy 

Only enabled properties will be 

displayed in the Properties box. For 

detailed instructions on enabling built-

in and custom properties, refer to 

Specifying Built-In or Custom 

Properties (on page 94) 

Click on the desired property in the Properties 

box. 

Click the right arrow to move the property to the 

Hierarchy box. 

If you will be building your website based on 

properties, it is helpful to ensure the above 

option - Show file properties on first save - is 

enabled. This will prompt your authors to specify 

properties when creating content. 
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If You Want To Then 

Remove built-in or custom properties 

to be used to organize the website 

hierarchy 

Click on the desired property in the Hierarchy 

box. 

Click the left arrow to move the property to the 

Properties box. 

Specify the hierarchy of selected 

properties 

Use the up and down arrows to order the 

hierarchy of properties. 

6. Select FILE > SAVE to save the template. 
 

Specifying General Settings: Images 

1. From the Editor, open the new template. 

2. Click the General tab. 

3. Select Images in the Task Pane. 

 

4. Perform one of the following options: 

If You Want To Then 

Add an image to the template Click Add. 

Navigate to the image and click Open. 

Update an image Select the image to update, and click Update. 

Navigate to the updated image, and click Open. 

Delete a custom image Select the custom image from the list, and click 

Delete. 

At the prompt, click Yes. 

You cannot delete the standard images delivered 

with the application. 
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A preview of the selected image will display to the right. 

5. Select FILE > SAVE to save the template. 
 

Specifying General Settings: Data Files 

1. From the Editor, open the new template. 

2. Click the General tab. 

3. Select Data Files in the Task Pane. 

 

4. Perform one of the following options: 

If You Want To Then 

Add a data file to the template Click Add. 

Navigate to the data file and click Open. 

Update a data file Select the data file to update, and click Update. 

Navigate to the updated data file, and click 

Open. 

Modify a data file Select a data file, and click Modify. 

Edit the file, and select FILE > SAVE. 

Basic knowledge of HTML, CSS, and JavaScript 

is required. 

Optionally, click Change Editor ... to specify a 

different data file editor. 

Delete a custom data file Select the custom data file from the list, and click 

Delete. 

At the prompt, click Yes. 

You cannot delete the standard data files 

delivered with the application. 
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5. Select FILE > SAVE to save the template. 
 

Specifying General Settings: Languages 

1. From the Editor, open the new template. 

2. Click the General tab. 

3. Select Languages in the Task Pane. 

 

4. Perform one of the following options: 

If You Want To Then 

Manually select languages to be 

enabled in this template 

Deselect Use server languages. 

Select or deselect one or more checkboxes in the 

Visible column. 

Select all languages to be used in this 

template. 

Select Check All. 

5. Select FILE > SAVE to save the template. 
 

Specifying General Settings: Hotspot Images 

1. From the Editor, open the new template. 

2. Click the General tab. 
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3. Select Hotspot Images in the Task Pane. 

 

4. Perform one of the following options: 

If You Want To Then 

Add an image Click Add. 

Browse to the image and click Open. 

Update an image Select an image from the Images list and click 

Update. 

Browse to the updated image and click Open. 

Delete an image Select an image from the Images list and click 

Delete. 

Click Yes. 

Choose a replacement image Select an image from the Images list. 

Click the Replacement Image drop down list and 

select an image. 

5. Select FILE > SAVE to save the template. 
 

Specifying General Settings: Text To Speech 

1. From the Editor, open the new template. 

2. Click the General tab. 
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3. Select Text To Speech in the Task Pane. 

 

4. Perform one of the following options: 

If You Want To Then 

Store text to speech audio within the 

source document or course 

Check Store generated audio within 

documents and courses. 

Selecting this option allows authors to play the 

generated audio from the Editor without having 

text to speech voices installed on their computer. 

If this setting is disabled, the text to speech audio 

is saved only when the document or course is 

published. 

 
Storing text to speech audio within the 

source file will increase the size of the 

document or course. 
 

Change the length of the pause between 

words for text to speech playback 

Select from the following options: None, Extra 

Small, Small, Medium (default), Large, Extra 

Large. 

Configure a voice for text to speech Select a language/culture from the Available 

Voices list and click Configure. 

Choose a voice from the Available Voices list. 

Click OK when finished making a selection or 

Cancel to select another voice from the previous 

screen. 

 

 
SAPI5 compliant voices must be installed to use text to speech functionality. For more 

information, refer to the Technical Specifications. 

Additional voices may be installed on the Server for publishing, but not locally 

available on your machine. Please contact your local application administrator with 

any questions. 
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Specifying New Template Settings: Properties 

Managing Built In Properties 

1. From the Editor, open the new template. 

2. Click the Properties tab. 

 
 

3. To make the property visible to authors in the Properties... window, click the Visible 

checkbox. 

4. Perform one of the following options: 

If You Want To Then 

Move the value earlier in the list Click Move Up one or more times as needed. 

Move the value later in the list Click Move Down one or more times as needed. 

5. Click Modify. 

 

6. Perform one of the following options: 
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If You Want To Then 

Make the value visible. Check the Visible checkbox. 

Make the value translatable. Check the Translatable checkbox. This option is 

only available if the Visible checkbox is 

checked. 

Add a value Click Add. 

Enter a value. 

Click OK. 

Modify a value Select a value. 

Click Modify. 

Edit the text. 

Click OK.  

Delete a value Select a value. 

Click Delete. 

Click Yes. 

Add a custom phrase Click Select Phrase. 

Click Add. 

Select a language from the left. 

Enter the text in the content area. 

Click OK. 

Select a phrase Click Select Phrase. 

Select a language from the Language drop-down 

list. 

Select a phrase from the Phrase listbox. 

Optionally, enter text into the Phrases field to 

search for text. 

Click OK. 

7. Select FILE > SAVE to save the template. 
 

Creating and Managing Custom Properties 

1. From the Editor, open the new template. 

2. Click the Properties tab. 
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3. Select MANAGE CUSTOM PROPERTIES in the Task Pane. 

 

4. Select one of the following options: 

If You Want To Then 

Add a new custom property Click Add. 

Select a language from the drop-down list. 

Enter a name. 

Click OK. 

Go to Step 5. 

Modify an existing custom property Go to Step 5. 

Duplicate an existing custom property Select a custom property from the Task pane and 

click Duplicate. 

Select a language from the drop-down list. 

Enter a name. 

Click OK. 

Go to Step 5. 

Delete the selected property Select a custom property from the Task Pane and 

click Delete. 

Click Yes. 

Go to Step 5. 

Move the property earlier or later in the 

list. 

Select a custom property from the Task Pane and 

click Move Up or Move Down one or more 

times as needed. 

5. Select the custom property from the Task Pane and click Modify. 

6. Perform one of the following options: 

 
Based on the item selected, some options may not display. 

If You Want To Then 

Make the property visible to authors  Check the Visible checkbox. 

Make the property translatable Check the Translatable checkbox. This option is 

only available if the Visible checkbox is checked 
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and there are no values assigned to the property. 

Add values to the property Click Add. 

Enter a value. 

Click OK. 

Modify values to the property Select a value. 

Click Modify. 

Edit the text. 

Click OK. 

Delete values to the property Select a value. 

Click Delete. 

Click Yes. 

Move the value Select a value. 

Click Move Up or Move Down one or more 

times as needed. 

7. Click Select Phrase. 

8. Perform one of the following options: 

If You Want To Then 

Add a custom phrase Click Add. 

Select a language from the left. 

Enter the text in the content area. 

Click OK. 

Select a phrase Select a language from the Language drop-down 

list. 

Select a phrase from the Phrase listbox. 

Optionally, enter text into the Phrases field to 

search for text. 

Click OK. 

9. Select FILE > SAVE to save the template. 
 

Specifying New Template Settings: Phrases 

Managing Phrases 

1. From the Editor, open the new template. 
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2. Click the Phrases tab. 

 

3. Select a language from the Language drop-down list in the Task Pane. 

4. Choose a phrase name.  

 
The following table lists the phrases for actions during recording and the common 

phrases for keyboard keys. 

 

Field Description 

Click %s %t %u %s = label 

% t= control type 

%u = image 

Double-click %s %t %u %s = label 

% t= control type 

%u = image 

Right-click %s %t %u %s = label 

% t= control type 

%u = image 

Right double-click %s %t 

%u 

%s = label 

% t= control type 

%u = image 

Type %s in the %t %u %s = typed text 

Drag %s to %t %s = first image 

%t = second image 

Up, Down, Left, Right Press "Up" 

Press "Down" 

Press "Left" 

Press "Right" 
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Page Up, Page Down Press "Page Up" 

Press "Page Down" 

Tab Press "Tab" 

Return Press "Return" 

Home, End Press "Home" 

Press "End" 

Insert, Delete Press "Insert" 

Press "Delete" 

5. Perform one of the following options: 

If You Want To Then 

Add a phrase In the Content Pane, click Add. 

Select a language from the left navigation pane. 

Enter the phrase in the Content Pane. 

Click OK. 

Modify a phrase Select a phrase in the Content Pane. 

Click Modify. 

Optionally, select a new language from the left 

navigation pane. 

Edit the phrase in the Content Pane. 

Duplicate a phrase Select the phrase you want to duplicate from the 

Content Pane. 

Click Duplicate. 

Delete a phrase Select the phrase you want to delete. 

Click Delete. 

At the prompt, click Yes. 

6. Select FILE > SAVE to save the template. 
 

Specifying New Template Settings: Publications 

Manage All Publications 

1. From the Editor, open the new template. 
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2. Click the Publications tab. 

 

3. Click the checkbox in the Enabled column next to the publication types you want to activate. 

4. Choose from the following options: 

Field Description 

Course Preview Select an option from the drop-down list to display 

which style course you want to preview. 

 
You can create an option by duplicating 

and modifying the Course publication 

type as described in Duplicating, 

Deleting, and Moving Publication 

Types (on page 336). 
 

Simulation Preview Select an option from the drop-down list to display 

which style simulation you want to preview. 

 
You can create an option by duplicating 

and modifying the Simulation 

publication type as described in 

Duplicating, Deleting, and Moving 

Publication Types (on page 336). 
 

5. Select a publication type from the Manage All Publications list in the task pane. 

6. Click Select Phrase. 

7. Perform one of the following options: 

If You Want To Then 

Add a custom phrase Click Add. 

Select a language from the left. 

Enter the text in the Content area. 

Click OK. 
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If You Want To Then 

Select a phrase Select a language from the Language drop-down 

list. 

Select a phrase from the Phrase listbox. 

Optionally, enter text into the Phrases field to 

search for text. 

Click OK. 

8. Perform one of the following options: 

If You Want To Then 

Add a section Click Add. 

Select a section from the list. 

Click OK. 

Remove a section Click Remove. 

At the prompt, click Yes. 

Move the section earlier in the list Click Move Up one or more times as needed. 

Move the section later in the list Click Move Down one or more times as needed. 

 
Section functionality is not applicable to the glossary or website publication types. 

9. Review the publication type in the Type field. 

 
The Type field is not configurable. 

10. Enter a format name in the Name field. 

11. Perform one of the following options: 

If You Want To Then 

Use default publication settings Select the checkbox next to Use Default 

Publication Settings. 

Create custom publication settings Deselect the checkbox next to Use Default 

Publication Settings. 

Click a publication setting under the selected 

publication type. 

Refer to Setting Default Publication Settings for 

more information. 

12. Select FILE > SAVE to save the template. 
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Duplicating, Deleting, and Moving Publication Types 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

 
 

3. Choose from the following options: 

If You Want To Then 

Copy a publication type Select the publication type you want to copy, and 

click Duplicate. 

Delete a publication type Select the publication type you want to delete, 

and click Delete. 

Move the publication type earlier in the 

list 

Click Move Up one or more times as needed to 

determine where the publication type will display 

in the application website drop-down list. 

Move the publication type later in the 

list 

Click Move Down one or more times as needed 

to determine where the publication type will 

display in the application website drop-down list. 

4. Select FILE > SAVE to save the template. 
 

Setting Default Publication Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 
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3. Click Default Publication Settings in the task pane. 

 

4. Select one of the following options: 

If You Want To Then 

Modify document publication settings Select Document under Default Publication 

Settings in the task pane. 

Refer to Default Publication Settings: Document 

(on page 338) for more information. 

Modify simulation publication settings Select Simulation under Default Publication 

Settings in the task pane. 

Refer to Default Publication Settings: 

Simulation: General Settings (on page 341), 

Default Publication Settings: Simulation: User 

Interface Settings (on page 345), Default 

Publication Settings: Simulation: LMS Settings 

(on page 346), and Default Publication Settings: 

Simulation: Caption Settings (on page 348) for 

more information. 

Modify student guide publication 

settings 

Select Student Guide under Default Publication 

Settings in the task pane. 

Refer to Default Publication Settings: Student 

Guide (on page 350) for more information. 

Modify course package settings Select Course Package under Default 

Publication Settings in the task pane. 

Refer to Default Publication Settings: Course 

Package (on page 351) for more information. 
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If You Want To Then 

Modify course publication settings Select Course under Default Publication 

Settings in the task pane. 

Refer to Default Publication Settings: Course: 

General Settings (on page 357), Default 

Publication Settings: Course: User Interface 

Settings (on page 360), Default Publication 

Settings: Course: LMS Settings (on page 363), 

Default Publication Settings: Course: Caption 

Settings (on page 365), and Default Publication 

Settings: Course: Page Settings (on page 366) for 

more information. 

Modify guided help settings Select Guided Help under Default Publication 

Settings in the task pane. 

Refer to Default Publication Settings: Guided 

Help: General Settings (on page 352), Default 

Publication Settings: Guided Help: User 

Interface Settings (on page 353), Default 

Publication Settings: Guided Help: Captions (see 

"Default Publication Settings: Guided Help: 

Guided Help Captions" on page 355), and 

Default Publication Settings: Guided Help: 

Mobile Device Publication Settings (on page 

356) for more information. 

 

 

Default Publication Settings: Document 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Document under Default Publication Settings in the Task Pane. 
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The Editor has the capability to automatically crop screen images in Word, PDF, and Print published outputs. You 

can activate this feature by selecting the Crop screen shot to page size for Word, PDF, and Print publishing 

checkbox in the table below. Most monitors are wider than the standard letter layout page width. If full-size 

screenshot images are included in the .udc file by default, then they will be scaled to fit into the page for these 

published outputs. This can result in a degradation of image readability, especially with "wide screen" monitors. 

This option provides an automated way to avoid the scaling of screenshots in Word, PDF, and Print outputs.  

4. Complete/review the following fields: 

Field Description 

Show R/O/C column Select Show R/O/C column to display the R/O/C 

column in published output. 

Use full-text option value in 

R/O/C column 

Select Use full-text option value in R/O/C column 

to display Required, Optional, or Conditional in the 

published content. Show R/O/C column must be 

selected in order to enable this option. 

Show Example Sections Select Show Example Sections to display the 

example sections. 

Hide Empty Example 

Sections 

Select Hide Empty Example Sections to hide 

empty example sections.  Show Example Sections 

must be selected in order to enable this option. 

Mirror Margins Select Mirror Margins to create booklet-style, 

double-sided pages for PDF and Word outputs. 

Use compressed images to 

reduce Word and PDF file 

sizes 

Select this option to use compressed images in the 

Word and PDF outputs. Compressing images will 

reduce the overall file size for both Word and PDF 

files. 

Publish Exercise Answers Select Publish Exercise Answers to publish 

exercise answers. 

Show callouts Select Show callouts to display callouts in 

published outputs.  

 
Callouts will only display in 

publications containing screenshots. 

The font, font size, and line thickness of 

the callout is not configurable. 

This setting only applies to publications 

and is independent of the separate 

"Show callouts" setting in the 

Document Editor FILE > 

PREFERENCES that controls whether 

Editor callouts are visible in the Editor. 
 

Insert a page break before 

each screen shot 

Select Insert a page break before each screen shot 

to insert a break before screen shots. 

Screen Select minimum and maximum screen heights and 

widths. 
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Field Description 

Crop screen shot to page size 

for Word, PDF, and Print 

publishing 

Select to automatically crop screen images in Word, 

PDF, and Print published output. A red-dotted 

rectangle displays on the screenshot images that will 

be cropped in Word, PDF, and Print published 

outputs. This rectangle is drawn only in the 

Document Editor. If the size of a given screenshot 

image is less than the page size defined in the 

template, then the entire screen will be included in 

Word, PDF, and print published outputs even if the 

Crop screen shot to page size for Word, PDF, and 

Print publishing is turned on. 

 
Suggestions for using the auto-crop 

functionality: 

 
The location of the red rectangle is 

determined automatically with the 

intent of including as many of the steps 

associated with the current screenshot 

as possible. Therefore different areas of 

subsequent screens may be included in 

the cropped areas. Additional screens 

may be displayed in Document view 

automatically when auto-crop is turned 

on. For example: you have a document 

with 10 steps and only 1 screenshot is 

displayed in Document view. When you 

turn on auto-crop, only the first 7 steps 

fit within the crop rectangle size for the 

screen shot. The screenshot associated 

with step 8 will display and steps 8-10 

will display under that screen shot. So 

now you will see two screen shots in 

Document view.  

The cropped screen size takes the 

callout into account, if applicable, and 

will be adjusted accordingly.  
 

Maximum Screen Width Select maximum width for screenshots included in 

HTML publications.  

 
If the actual screenshot width is larger 

than this value, the screenshot will be 

scaled down to this width in the 

published output. 

 
 

Maximum Screen Height Select maximum height for screenshots included in 

HTML publications.  

 
If the actual screenshot height is larger 

than this value, the screenshot will be 

scaled down to this height in the 

published output. 
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Field Description 

Margins Select the unit of measurement and specify the 

margins for the top, bottom, left, and right pages. 

Page Size Select common size, unit of measurement and 

specify the height and width. 

5. Click the Publications tab. 

6. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Simulation: General Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Simulation under Default Publication Settings in the Task Pane. 

4. Select Simulation General Settings from the drop-down list. 

5. Complete the following fields: 

Field Description 

Case-Sensitive Select the Case-Sensitive checkbox to require the 

user to enter all text in the same case specified in the 

action properties (provided an Edit action of type 

'Exact String' is used). 

Require enter press Select the Require enter press checkbox to require 

the user to press enter after an action. 

Right click Select the mouse and key combination to be used to 

represent a right-click action in the simulation. 

Image Quality Select a percentage from the drop-down list. 

 

The Image Quality option allows you 

to specify the compression quality of 

the image. The default of 85% is 

recommended. 
 

Bookmark Select Enabled, Disabled, or Mode Specific from 

the drop-down list to select a display setting for 

bookmarks in the published output. 

Mode Order Use the Move Up and Move Down buttons to 

arrange the sequence of modes. 

6. Select one of the following Audio Source options: 
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The Audio Source options are only available after you have configured a voice in the 

template settings. For more information on configuring a voice, refer to Specifying 

General Settings: Text To Speech (on page 326).  

 

Field Description 

Manual Select Manual to disable text to speech. This is the 

default setting. 

Step Text (TTS) Select Step Text (TTS) to enable text to speech for 

step text only. 

Transcript (TTS) Select Transcript (TTS) to enable text to speech for 

transcript only. 

Step Text Followed by 

Transcript (TTS) 

Select Step Text Followed by Transcript (TTS) to 

enable text to speech for step text and transcript, 

respectively. 

Transcript Followed by Step 

Text (TTS) 

Select Transcript Followed by Step Text (TTS) to 

enable text to speech for transcript and step text, 

respectively. 

7. For Assessment mode, complete the following fields: 

Field Description 

Enabled Select to confirm that this mode is available for 

publishing. 

Help Mode Select from Auto playback mode, Standard mode, 

or Self-Test mode. 

Note Display Delay Select the wait time before notes are displayed. 

Note Entry Animation Select Fade In or Display. 

8. For Auto playback mode, complete the following fields 

Field Description 

Enabled  Select to confirm that this mode is available for 

publishing. 

Playback Timer Specify the default wait time between steps during 

auto playback. 

Display mouse path Select the Display mouse path checkbox to display 

mouse movements associated with each step of the 

simulation during auto playback. 

Loop auto playback mode Select this option to loop a simulation when viewed 

in auto-playback mode. 

Display action notes Select to display action notes. 

Display action note tail Select to display action note tail. 

Display hotspots Select to display hotspots. 



Chapter 16: Using Author Templates 

 

Hewlett Packard Enterprise Develoment LP 343 

 

 

Field Description 

Enable simulation typing 

sounds 

Select the Enable simulation typing sounds 

checkbox, and select a sound from the drop-down 

list to enable typing sounds during simulation 

playback. 

For information on adding sound files to the 

template, refer to Specifying General Settings: Data 

Files (on page Error! Bookmark not defined.). 

Default Action Display Delay Specify the default wait time for action display. 

Default Action Animation 

Delay 

Select the default wait time for action animation. 

Default Action Entry 

Animation 

Select Fade In or Display. 

Default Action Exit 

Animation 

Select Fade Out or Hide. 

9. For Self-Test mode, complete the following fields: 

Field Description 

Enabled Select to confirm that this mode is available for 

publishing. 

Help Mode Select from Auto playback mode or Standard 

mode. 

Note Display Delay Select the wait time for notes to display. 

Note Entry Animation Select Fade In or Display. 

10. For Standard mode, complete the following fields: 

Field Description 

Enabled Select to confirm that this mode is available for 

publishing. 

Display action notes Select the Display action notes checkbox to enable 

the display and publishing of the auto-generated 

action notes in simulations. 

Display action note tail Select to display action note tail. 

Display hotspots Select to display hotspots. 

Note Display Delay Select the wait time for notes to display. 

Note Entry Animation Select Fade In or Display. 

11. For Home Page, complete the following fields: 

 

These options are set in the document properties and are customizable. For more 

information on customizing properties, refer to Specifying New Template Settings: 

Properties (on page 328). 
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Field Description 

Title Select Title to display the title on the home page. 

Author Select Author to display the author on the home 

page. 

Description Select Description to display the description on the 

home page. 

Copyright Select Copyright to display the copyright on the 

home page. 

Publish date Select Publish Date to display the publish date on 

the home page. 

12. For Step Window, complete the following fields: 

Field Description 

Show step window Select the Show Step Window checkbox to display 

the Steps window to users during simulation 

playback. 

Height Select the height of the published step window. 

Width Select the width of the published step window. 

Dock on startup Select Dock on startup checkbox to set the dock 

position on startup.  

Dock Position Select a dock position. The dock position determines 

how the step window will display. Select from the 

following options: Default (LTR: Right - RTL: 

Left), Mirrored (LTR: Left - RTL: Right), Right, 

or Left. 

13. For Action Defaults, complete the following fields: 

Field Description 

Border color Select the color of the hotspot border. 

Optionally, specify custom colors by clicking Select 

to the right of the color drop-down list. 

Border size Select the size of the hotspot border. 

Flashing Select the checkbox next to Flashing to enable 

flashing hotspots. 

14. Select FILE > SAVE to save the template. 
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Default Publication Settings: Simulation: User Interface Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab on the status bar. 

3. Select Simulation under Default Publication Settings in the Task Pane. 

4. Select Simulation User Interface Settings from the drop-down list. 

 
 

5. Select a skin from the Skins drop-down list. 

 
A preview of the skin selection will display in the Preview window. 

6. Complete the following fields: 

Field Description 

Player Colors Select a background color, and primary and 

secondary colors for the banner background from 

the drop-down list. 

Text Colors Select a primary color for the banner text from the 

drop-down list. 

 

 
Optionally, specify custom colors by clicking Select to the right of the color drop-

down list. 

7. Choose from the following options: 

Field Description 

Enable Transitions Enables a smooth, animated transmission from step 

to step. This field defaults to selected.  
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Field Description 

Reuse existing window Determines whether the existing window is used, or 

another new window is opened when the user 

launches another option from the simulation launch 

page. 

Hide audio bar when audio is 

not present 

Hides the audio bar when audio is not present. 

Do not resize Opens the simulation in the current window size. 

Resize and center window Opens the simulation at the size specified by the 

screen width and height, and centers the simulation 

window. 

Start in full screen mode Opens the simulation in full screen mode. 

8. Under Screen, select a minimum and maximum screen height and width. 

 
This option is available only if Resize and center window is selected. 

9. Under Maximum Screen Size, select a minimum or maximum screen size. 

10. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Simulation: LMS Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Simulation under Default Publication Settings in the Task Pane. 

4. Select Simulation LMS Settings from the drop-down-list. 

 

5. Complete/review the following fields: 
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Field Description 

Create package Click the Create Package checkbox to create LMS-

conformant output for integration with a Learning 

Management System (LMS). 

Show hints Select the Show hints checkbox to display hints 

during the simulation self test or assessment test. 

Hints are nonessential data (for example, a user 

name) required to complete the simulation. 

Enable remote proxy support Only select the Enable remote proxy support 

checkbox if you are instructed to do so by Product 

Support. 

Display username prompt Select this option to display the username prompt on 

the home page. 

Package Type Select SCORM 2004, SCORM 1.2, or AICC from 

the drop-down list to select the output. 

You can edit the SCORM and AICC 

imsmanifest.xml file via the package editor. For 

more information, refer to Default Publication 

Settings: Package Editor (on page 370). 

Package Status Value Select a completion-type value from the drop-down 

list. 

This option is available only for SCORM 1.2 and 

AICC. 

Assessment URI Enter a destination URI (Uniform Resource 

Identifier) to send test results for capture by a 

custom-built utility instead of an LMS. You can 

create an Active Server Page (ASP) or Java Server 

Page (JSP) on a web server to receive the output for 

subsequent storage and reporting in a learning 

management system. Any technology that accepts 

the form Post method using HTTP can be used to 

handle the output. 

Example: http://www.yourcompany.com/results.asp 

Note that if the student's web browser security 

settings are set to High, warning messages will be 

displayed. 

 
The Create Package option must be 

disabled in order to enter a URI. 
 

6. Complete/review the following fields: 

Field Description 

Include in results Select the desired checkboxes to indicate the 

information to be captured when the simulation self 

test or assessment is completed. 
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Field Description 

Passing score Specify the required passing score. 

7. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Simulation: Caption Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Simulation under Default Publication Settings in the Task Pane. 

4. Select Simulation Caption Settings. 

 

5. Highlight a phrase in the phrase list. 

6. Click Select Phrase. 

7. Perform one of the following options: 

If You Want To Then 

Add a custom phrase Click Add. 

Select a language from the left. 

Enter the text in the content area. 

Click OK. 

Select a phrase Select a language from the Language drop-down 

list. 

Select a phrase from the Phrase listbox. 

Optionally, enter text into the Phrases field to 

search for text. 

Click OK. 
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8. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Simulation: Mobile Device 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Simulation under Default Publication Settings in the Task Pane. 

4. Select Mobile Device Publication Settings. 

 

5. Highlight an item in the Values list. 

6. Perform one of the following options: 

If You Want To Then 

Add a mobile device publication setting Click Add. 

Enter Operating System. 

Enter Browser. 

Click OK. 

Modify a mobile device publication 

setting 

Click Modify. 

Enter Operating System. 

Enter Browser. 

Click OK. 

Delete a mobile device publication 

setting 

Click Delete. 

Click Yes. 
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The Operating System and Browser settings are detected during launch. At this time, 

there are no custom settings for each mobile device. 

7. Select FILE > SAVE to save the template. 

 
 

Default Publication Settings: Student Guide 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Student Guide under Default Publication Settings in the Task Pane. 

 

4. Complete/review the following fields: 

Field Description 

Mirror Margins Select Mirror Margins to create booklet-style, 

double-sided pages for output. 

Table of Contents Select Publish Table of Contents to create a table 

of contents for output. 

Select Display section titles in the table of 

contents to display the section titles in inserted 

content in the published output. 

Select Display course cover pages to display the 

course cover page in published output. 

Margins Select the unit of measurement and specify the 

margins for the top, bottom, left, and right pages. 
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Field Description 

Page Size Select size and unit of measurement. 

5. Choose from the following options: 

If You Want To Then 

Add a style Select the style you want to copy, and click Add.... 

Delete a style Select the style you want to delete, and click Delete. 

Move the style earlier in the 

list 

Click Move Up one or more times as needed to 

determine where the style will display in the table of 

contents. 

Move the style later in the list Click Move Down one or more times as needed to 

determine where the style will display in the table of 

contents. 

6. Click Select Phrase to select a phrase for the player. 

7. Perform one of the following options: 

If You Want To Then 

Add a custom phrase Click Add. 

Select a language from the left. 

Enter the text in the content area. 

Click OK. 

Select a phrase Select a language from the Language drop-down 

list. 

Select a phrase from the Phrase listbox. 

Optionally, enter text into the Phrases field to 

search for text. 

Click OK. 

8. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Course Package 

1. From the Editor, open the new template. 

2. Click the Publications tab. 
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3. Select Course Package under Default Publication Settings in the Task Pane. 

 

4. Select SCORM 2004 or SCORM 1.2 from the drop-down list to select the output. 

5. If you are using SCORM 1.2, select a completion-type value from the drop-down list. 

6. Select FILE > SAVE to save the template. 

 
 

Default Publication Settings: Guided Help: General Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Selected Guided Help under Default Publication Settings in the Task Pane. 

 

4. Select Guided Help General Settings from the drop-down list. 

5. Complete the following fields: 

Field Description 

Playback Timer Select the up-down controls to set the default time in 

seconds that guided help displays for each page. If 

the playback timer is set to 0 or a negative number, 

Guided Help with not automatically progress. The 

user must manually step through the Guided Help. 
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Allow User to Store 

Preferences 

Select Allow User to Store Preferences checkbox 

to allow users to store preference settings for 

playback time, screen location of Guided Help, 

window size and window mode 

(maximize/minimize). 

6. Complete the following fields: 

 
These options are set in the document properties and are customizable. For more 

information on customizing properties, refer to Specifying New Template Settings: 

Properties. (see "Specifying New Template Settings: Properties" on page 328) 

 

Field Description 

Title Select Title to display the title on the home page. 

Author Select Author to display the author on the home 

page. 

Description Select Description to display the description on the 

home page. 

Copyright Select Copyright to display the copyright on the 

home page. 

Publish date Select Publish Date to display the publish date on 

the home page. 

7. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Guided Help: User Interface Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Guided Help under Default Publication Settings in the Task Pane. 
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4. Select Guided Help User Interface Settings from the drop-down list. 

 

5. Select a skin from the Skins drop-down list. 

 
A preview of the skin selection will display in the Preview window. 

6. Complete the following fields: 

Field Description 

Player Colors Select primary and secondary colors from the drop-

down list. 

Text Colors Select primary and secondary, and link text colors 

from the drop-down list. 

 

 
Optionally, specify custom colors by clicking Select to the right of list. 

7. Select from the following options: 

Field Description 

Step Window Under Step Window, select a height and width, 

maximum image height and width, and screen 

position and whether to maximize on startup. 

General Enables a smooth, animated transmission from step 

to step. 

Also allows the help to always display on top of all 

other windows when running in Internet Explorer. 

8. Select FILE > SAVE to save the template. 
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Default Publication Settings: Guided Help: Guided Help Captions 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Guided Help under Default Publication Settings in the Task Pane. 

4. Select Guided Help Captions. 

 

5. Highlight a phrase in the phrase list. 

6. Click Select Phrase. 

7. Perform one of the following options: 

If You Want To Then 

Add a custom phrase Click Add. 

Select a language from the left. 

Enter the text in the content area. 

Click OK. 

Select a phrase Select a language from the Language drop-down 

list. 

Select a phrase from the Phrase listbox. 

Optionally, enter text into the Phrases field to 

search for text. 

Click OK. 

8. Select FILE > SAVE to save the template. 
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Default Publication Settings: Guided Help: Mobile Device Publication Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Guided Help under Default Publication Settings in the Task Pane. 

4. Select Mobile Device Publication Settings from the drop-down list. 

 

5. Perform one of the following options: 

If You Want To Then 

Add a new operating 

system/browser configuration 

Click Add. 

Enter an operating system in the Operating System 

field. 

Enter the Browser type in the Browser field. 

Click OK. 

Modify an existing operating 

system/browser configuration 

Select an operating system/browser combination. 

Select Modify. 

Change operating system/browser setting as desired. 

Click OK. 

Delete an existing operating 

system/browser configuration 

Select an operating system/browser combination. 

Select Delete. 

Click Yes. 

 

 
The Operating System and Browser settings are detected by Guided Help during 

launch. At this time, there are no custom settings for each mobile device. 

6. Select FILE > SAVE to save the template. 
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Default Publication Settings: Course: General Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Course under Default Publication Settings in the Task Pane. 

4. Select Course General Settings from the drop-down list. 

 
 

5. Complete the following fields: 

 
These options are pulled from the document properties and are customizable. For more 

information on customizing properties, refer to Specifying New Template Settings: 

Properties (on page 328). 

 

Field Description 

Title Select Title to display the title on the home page. 

Author Select Author to display the author on the home 

page. 

Description Select Description to display the description on the 

home page. 

Copyright Select Copyright to display the copyright on the 

home page. 

Publish date Select Publish Date to display the publish date on 

the home page. 

Simulation Stencil Mode 

Order 

Use the Move Up and Move Down buttons to set 

the simulation stencil mode order. 

Match the course stage size Select Match the course stage size to display the 

course at the same size as the imported PowerPoint. 

Specific dimensions Select Specific dimensions to display the course in 

a specified width and height. 
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Increase slide size if possible Select Increase slide size if possible to increase the 

size of the slides. 

6. Select one of the following Audio Source options: 

  
The Audio Source options are only available after you have configured a voice in the 

template settings. For more information on configuring a voice, refer to Specifying 

General Settings: Text To Speech (on page 326). 

Field Description 

Manual Select Manual to disable text to speech. This is the 

default setting. 

Page Text Areas (TTS) Select Page Text Areas (TTS) to enable text to 

speech for page text areas only. 

Transcript (TTS) Select Transcript (TTS) to enable text to speech for 

transcript only. 

Page Text Area Followed by 

Transcript (TTS) 

Select Page Text Area Followed by Transcript 

(TTS) to enable text to speech for page text area and 

transcript, respectively. 

Transcript Followed by Page 

Text Areas (TTS) 

Select Transcript Followed by Page Text Areas 

(TTS) to enable text to speech for transcript and 

page text areas, respectively. 

7. Choose from the following player elements: 

Field Description 

Back Enables the Back button in the published course. 

Exit Enables the Exit button in the published course. 

Exit Simulation Enables the Exit Simulation button in the embedded 

simulation in the published course. 

Glossary Enables the Glossary button in the published course.  

Help Enables the Help button in the published course. 

History Enables the History button in the published output. 

Menu Enables the Menu button in the published output. 

Next Enables the Next button in the published course. 
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Field Description 

Resources Enables the Resources button in the published 

output. 

The Default Display field is enabled when 

Resources is selected. 

Select the Page radio button to enter a URL to direct 

the Resources link to.  

Select the Panel radio button to have the Resources 

launch in a panel on the left-side of the course 

playback window 

8. Enter a URL in the URL field. 

 
Based on the player element selected, this option may not display. 

9. Select the Enable player element in published output checkbox to enable the use of the 

selected element. Repeat this step for each player element. 

10. Click Select Phrase to select a phrase for the player. 

11. Perform one of the following: 

If You Want To Then 

Add a custom phrase Click Add. 

Select a language from the left. 

Enter the text in the content area. 

Click OK. 

Select a phrase Select a language from the Language drop-down 

list. 

Select a phrase from the Phrase listbox. 

Optionally, enter text into the Phrases field to 

search for text. 

Click OK. 

12. Select one of the following feedback phrases: 

Field Description 

Correct Displays when the end user enters the correct 

answer. 

First Attempt Incorrect Displays when the end user enters an incorrect 

answer the first time. 

Second Attempt Incorrect Displays when the end user enters an incorrect 

answer the second time. 
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13. In the Video Input Formats area, select the Enabled checkbox next to the video format 

extension to enable the video format in published output. 

14. Perform one of the following: 

If You Want To Then 

Add a video input type Click Add. 

Insert the extension of a video input type to add 

to the available options. 

Click OK. 

Modify a video input type Click Modify. 

Edit the extension information. 

Click OK. 

Delete a video input type Click Delete. 

Click OK to confirm the deletion. 

Save changes made Select FILE > SAVE to save the template. 

 
 

Default Publication Settings: Course: User Interface Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Course under Default Publication Settings in the Task Pane. 
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4. Select Course User Interface Settings from the drop-down list. 

 

5. Select a skin from the Skins drop-down list. 

 
A preview of the skin selection will display in the Preview window. 

6. Complete the following fields: 

Field Description 

Player Colors Select a background color, course background user 

interface color, and player primary and secondary 

colors from the drop-down list. These colors will 

display in the published course output. 

Text Colors Select primary and secondary, and link text colors 

from the drop-down list. These colors will display in 

the published course output. 

 

 
Optionally, specify custom colors by clicking Select to the right of list. 

7. Select from the following options: 

Field Description 

Reuse existing window Determines whether the existing window is used, or 

another new window is opened when the user 

launches another option from the simulation launch 

page. 

Hide audio bar when audio is 

not present 

Hides the audio bar when audio is not present. 

Only display one popup at a 

time 

If selected, only one popup is displayed at any one 

time. 

Allow user to give up and fail 

assessment simulations 

Allows the user to quit and fail an assessment. 

Base progress on current 

location 

Shows percent complete based on where the user is 

in the course. 
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Field Description 

Base progress on percentage 

done 

Shows percent complete based on how much of the 

course a user has completed. 

Allow Image Zooming Specifies if image zooming is allowed and if it is the 

default setting. 

Do not resize Opens the course in the current window size. 

Resize and center window Opens the course at the size specified by the screen 

width and height, and centers the course window. 

Start in full screen mode Opens the course in full screen mode. 

Screen Width/Height Specifies the size of the course page content within 

the browser window. 

Stage Width/Height Specifies the size of the course page content within 

the browser window. 

Logo Select a logo to display in the published course and 

on the website. 

Logos are managed in the Image area of the 

Template Editor. For more information on images, 

refer to Specifying General Settings: Images (on 

page 323). 

Hotspot Interaction Select a stamp to indicate a hotspot in a course. 

Select a color for the hotspot. 

8. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Course: Mobile Device Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Course under Default Publication Settings in the Task Pane. 

4. Select Mobile Device Publication Settings from the drop-down list. 
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5. Perform one of the following options: 

If You Want To Then 

Add a new operating 

system/browser configuration 

Click Add. 

Enter an operating system in the Operating System 

field. 

Enter the Browser type in the Browser field. 

Click OK. 

Modify an existing operating 

system/browser configuration 

Select an operating system/browser combination. 

Select Modify. 

Change operating system/browser setting as desired. 

Click OK. 

Delete an existing operating 

system/browser configuration 

Select an operating system/browser combination. 

Select Delete. 

Click Yes. 

 

 
The Operating System and Browser pairs are detected during launch. At this time, 

there are no custom settings for each mobile device. 

6. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Course: LMS Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Course under Default Publication Settings in the Task Pane. 

4. Select Course LMS Settings from the drop-down list. 

 

5. Complete the following fields: 
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Field Description 

Create package Click the Create Package checkbox to create 

SCORM-conformant or AICC-conformant output 

for integration with a Learning Management System 

(LMS). 

Show answers Click the Show Answers button to display the 

answer at the end of the course. 

Enable remote proxy support Only select the Enable Remote Proxy Support 

checkbox if you are instructed to do so by Product 

Support. 

Display username prompt Select this option to display the username prompt on 

the home page. 

LMS Package Type Select SCORM 2004, SCORM 1.2, or AICC from 

the drop-down list to select the output. 

For more information on packages, refer to Default 

Publication Settings: Package Editor (on page 370). 

Package status value Select a completion-type value from the drop-down 

list. 

This option is available only for SCORM 1.2 and 

AICC. 

Assessment URI Enter a destination URI (Uniform Resource 

Identifier) to send test results for capture by a 

custom-built utility instead of an LMS. You can 

create an Active Server Page (ASP) or Java Server 

Page (JSP) on a web server to receive the output for 

subsequent storage and reporting in a learning 

management system. Any technology that accepts 

the form Post method using HTTP can be used to 

handle the output. 

Example: http://www.yourcompany.com/results.asp 

Note that if the student's web browser security 

settings are set to High, warning messages will be 

displayed. 

 
The Create Package option must be 

disabled in order to enter a URI. 
 

6. Complete the following fields: 
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Field Description 

Include in results Select the desired checkboxes to indicate the 

information to be captured when the course 

assessment is completed. 

 
Checkboxes are disabled if the Create 

Package option is enabled. 
 

Randomize questions in 

playback 

Select this option to randomize the order of 

assessment pages. 

Provide individual feedback Select this option to provide feedback on individual 

assessment questions. 

Passing score Specify the required passing score. 

Users may retake No questions: Users may not retake any questions. 

Incorrect questions: Users may retake only those 

questions that were answered incorrectly. 

All questions: Users may retake all questions. 

7. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Course: Caption Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Course under Default Publication Settings in the Task Pane. 

4. Select Course Caption Settings from the drop-down list. 

 

5. Highlight a phrase in the phrase listbox. 

6. Click Select Phrase. 
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7. Perform one of the following options: 

If You Want To Then 

Add a custom phrase Click Add. 

Select a language from the left. 

Enter the text in the content area. 

Click OK. 

Select a phrase Select a language from the Language drop-down 

list. 

Select a phrase from the Phrase listbox. 

Optionally, enter text into the Phrases field to 

search for text. 

Click OK. 

8. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Course: Page Settings 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Course under Default Publication Settings in the Task Pane. 

4. Select Course Page Settings from the drop-down list. 

 

5. Complete the following fields: 

Field Description 

Mirror Margins Select Mirror Margins to create booklet-style, 

double-sided pages for PDF and Word publication. 

Show audio transcript Select Show audio transcript to display the audio 

transcript in published courses. 
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Field Description 

Show assessment section Select Show assessment section to display the 

assessment section in a published course. 

Show answers Select Show answers to display assessment 

answers. 

Show course links Select Show course links to display links when you 

publish a course to Word or PDF format. 

6. Complete the following fields: 

Field Description 

Header Select Course Header, Student Guide Header, 

Header, Course Footer, Student Guide Footer, or 

Footer from the drop-down list to select the header. 

Footer Select Course Footer, Student Guide Footer, 

Footer, Course Header, Student Guide Header, 

or Header from the drop-down list to select the 

footer. 

Margins Specify margins for Top, Bottom, Left, and Right. 

Optionally, select the unit of measurement from the 

Unit drop-down box. 

Page Size Specify the common sizes, height, width, and unit of 

measurement. 

7. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Glossary 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Glossary under Default Publication Settings in the task pane. 

4. Complete the following fields: 
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Field Description 

Layout: Stylesheet Select the stylesheet used to control the layout of the 

glossary. 

Stylesheets are managed in the Data Files area of the 

Template Editor. For more information on data files, 

refer to Specifying General Settings: Data Files (on 

page 324). 

Glossary Text Styles: Term 

Text Style 

Select the style to be used for the glossary term text. 

Styles are managed in the Styles area of the 

Template Editor. For more information on styles, 

refer to Specifying Styles (on page 375). 

Glossary Text Styles: 

Definition Text Style 

Select the style to be used for the glossary definition 

text. 

Styles are managed in the Styles area of the 

Template Editor. For more information on styles, 

refer to Specifying Styles (on page 375). 

5. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Website 

1. From the Editor, open the new template. 

2. Click the Publications tab. 

3. Select Website under Default Publication Settings in the task pane. 

 

4. Complete the following fields: 
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Field Description 

Images: Page Icon Select an image for the page icon from the drop-

down list. 

Images are managed in the Images area of the 

Template Editor. For more information on Images, 

refer to Specifying General Settings: Images (on 

page 323). 

Images: Link Icon Select an image for the link icon from the drop-

down list. 

Images are managed in the Images area of the 

Template Editor. For more information on Images, 

refer to Specifying General Settings: Images (on 

page 323). 

Layout: Stylesheet Select the stylesheet used to control the layout of the 

website. 

Stylesheets are managed in the Data Files area of the 

Template Editor. For more information on data files, 

refer to Specifying General Settings: Data Files (on 

page 324). 

Styles: Top Navigation Link 

Text 

Select the style to be used for the navigation text 

displayed at the top of the website window. 

Styles are managed in the Styles area of the 

Template Editor. For more information on styles, 

refer to Specifying Styles (on page 375). 

Styles: Link Text Select the style to be used for hyperlinked text on 

the website. 

Styles are managed in the Styles area of the 

Template Editor. For more information on styles, 

refer to Specifying Styles (on page 375). 

Styles: Page Title Text Select the style to be used for page titles on the 

website. 

Styles are managed in the Styles area of the 

Template Editor. For more information on styles, 

refer to Specifying Styles (on page 375). 

Styles: Page Description Text Select the style to be used for page description text 

on the website. 

Styles are managed in the Styles area of the 

Template Editor. For more information on styles, 

refer to Specifying Styles (on page 375). 

Global Links: Home Link 

Caption 

Click Select Phrase to specify an alternate phrase 

for the home link on the website. The default is 

"Home". 

Show glossary link Select this checkbox to display the hyperlink to the 

glossary from the website. 
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Field Description 

Global Links: Glossary Link 

Caption 

Click Select Phrase to specify an alternate phrase 

for the glossary link on the website. The default is 

"Glossary". 

Show Help Link Select this option to display the help link. 

Help Link Caption Click Select Phrase to select a phrase for the help 

link. Show Help Link must be enabled. 

Help Link URL Enter a URL for the help link. Show Help Link 

must be enabled. 

5. Perform one or more of the following options: 

If You Want To Then 

Hide links to content not yet published 

to the website 

Select the checkbox to the left of Hide links to 

unpublished content. 

Change the message displayed when a 

user selects a hyperlink for unpublished 

content 

Enter the message to be displayed. 

This option is not available if you have selected 

to hide links to unpublished content. 

Specify a property from which to build 

quick launch pages for use with SAP 

and Help Launchpad. 

You must have first enabled or created 

the specified property via the template 

Properties tab. 

Select the transaction code property to enable 

context-sensitive help based on the SAP 

transaction code. 

For more information on other properties used 

for applications other than SAP R/3, refer to 

Transferring Your Website to a Server (on page 

422). 

Select the separator to be used if an 

author specifies multiple property 

values for content 

When entering multiple values for the specified 

property, you must select a separator to define 

these values. The default value is a comma. 

6. Select FILE > SAVE to save the template. 
 

Default Publication Settings: Package Editor 

 
You can edit the SCORM and AICC imsmanifest.xml file via the package editor. 

1. From the Editor, open the new template. 

2. Click the Publications tab. 
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3. Select Package Editor in the Task Pane. 

 

4. Select the package file type from the Package File drop down list. 

5. In the code box, insert the cursor where you want to insert a variable. 

6. Select the variable(s) to be included from the Variables list. 

7. Click the right arrow to add the variable(s) to the package file. 

8. Edit the file as desired. 

9. Repeat Steps 5 through 8 for each element you want to add. 

10. Select FILE > SAVE to save the template. 

 
The application supports the following elements from the SCORM/AICC 

specifications: 

Package File Supported Data Elements 

SCORM 1.2 Lesson Status 

(cmi.core.lesson_status) 

Lesson Location 

(cmi.core.lesson_location) 

Suspend Data 

(cmi.suspend_data) 

Raw Score (cmi.core.score.raw) 

Min Score (cmi.core.score.min) 

Max Score 

(cmi.core.score.max) 

Session Time 

(cmi.core.session_time) 

Interactions (cmi.interactions) 

Interaction ID 

(cmi.interactions.n.id) 

Interaction Time 

(cmi.interactions.n.time) 
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Interaction Type 

(cmi.interactions.n.type) 

Interaction Correct Response 

(cmi.interactions.n.correct_resp

onses.n.pattern) 

Interaction Student Response 

(cmi.interactions.n.student_resp

onse) 

Interaction Result 

(cmi.interactions.n.result) 

*Interaction Description 

(rwd.interactions.n.description) 

SCORM 2004 Completion Status 

(cmi.completion_status) 

Success Status 

(cmi.success_status) 

Lesson Location (cmi.location) 

Suspend Data 

(cmi.suspend_data) 

Raw Score (cmi.score.raw) 

Min Score (cmi.score.min) 

Max Score (cmi.score.max) 

Scaled Score (cmi.score.scaled) 

Session Time 

(cmi.session_time) 

Interactions (cmi.interactions) 

Interaction ID 

(cmi.interactions.n.id) 

Interaction Type 

(cmi.interactions.n.type) 

Interaction Correct Response 

(cmi.interactions.n.correct_resp

onses.n.pattern) 

Interaction Student Response 

(cmi.interactions.n.student_resp

onse) 

Interaction Result 

(cmi.interactions.n.result) 

Interaction Description 

(cmi.interactions.n.description) 

AICC Lesson Location 

(Core.Lesson_Status) 

Lesson Status 

(Core.Lesson_Location) 

Suspend Data (Core_Lesson) 

Raw Score (Core.Score) 

Session Time (Core.Time) 
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The following table explains the Data Elements: 

Data Element Explanation 

Lesson Status Element utilized to specify the 

completion status of the SCO 

(completed/incomplete). This 

element can also be utilized to 

specify the mastery/success of 

the SCO (passed/failed). 

Completion Status Element utilized to specify the 

completion status of the SCO 

(completed/incomplete). 

Success Status The element utilized to specify 

the mastery of the SCO 

(passed/failed). 

Lesson Location The element used to specify the 

step/page at which the learner 

terminated the SCO. Also 

referred to as the SCO 

bookmark. 

Suspend Data The element utilized to persist 

content-specific information, 

such as the pages/steps the 

learner has viewed within the 

SCO. This element is primarily 

utilized by courses. 

Raw Score (0-100) The element utilized for 

specifying the score achieved by 

the learner within the SCO. The 

value is based on the 

performance within the 

assessment mode of a 

simulation, or within either an 

assessment or terminated 

branch, with scoring enabled, 

inserted into a course. 

Min Score The minimum score a learner 

can achieve within a lesson.  

This value is currently always 

set to a value of "0" (zero) 

within published content. 

Max Score The maximum score a learner 

can achieve within a lesson.  

This value is currently always 

set to a value of "100" within 

published content. 

Percent Complete The element utilized to specify 

the completion percentage of a 

learner within the SCO. 
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Scaled Score (0-10) The element utilized to specify 

the performance of a learner 

within the SCO that is scaled to 

fit with the range of 0 – 1.0.  

The value is based on the 

performance within the 

assessment mode of a 

simulation, or within either an 

assessment or terminated 

branch, with scoring enabled, 

inserted into a course. 

Session Time The time the learner has spent in 

the lesson during a given 

session. 

Interactions The data related to the 

questions/steps within an 

assessment. The value is based 

on the performance within the 

assessment mode of a 

simulation, or an assessment 

inserted into a course. 

Interaction ID - The unique 

identifier of the interaction. 

Interaction Time - A 

timestamp at which the 

interaction was completed. 

Interaction Type - The type of 

the interaction. 

Interaction Correct Response 

- The correct answer for the 

interaction. 

Interaction Student Response 

- The learner's response to the 

interaction. 

Interaction Result - The 

success outcome (correct or 

incorrect/wrong) 

Interaction Description - The 

description of the interaction, 

utilized to persist the question 

stem. In the case of SCORM 

1.2, this is a custom data model 

element that is utilized by 

ANCILE uLearn. 
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Specifying New Template Settings: Styles 

Specifying Styles 

1. From the Editor, open the new template. 

2. Click the Styles tab. 

 
 

3. Perform one of the following options: 

If You Want To Then 

Enable the use of language-specific 

fonts 

Select Enable Language Specific Style Fonts, 

and go to Step 4. 

Disable the use of language-specific 

fonts 

Deselect Enable Language Specific Style 

Fonts, and go to Step 7. 

4. Select Style Languages from the Task Pane. 
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5. Perform one of the following options: 

If You Want To Then 

Manually select style languages to be 

enabled in this template 

Select or deselect one or more checkboxes in the 

Enabled column. 

Select all languages to be used in this 

template. 

Select Check All. 

6. Select Manage All Styles from the Task Pane. 

7. Perform one of the following options: 

If You Want To Then 

Change the Action Note style Select a style from the Action Note Style drop-

down list. 

Change the Recorder Note style Select a style from the Recorder Note Style drop-

down list. 

8. The following styles are available from the Task Pane: 

Field Description 

Default Course Content Title 

Text 

The style to be used for the text displayed in the content 

title area of a course. 

Default Course Drag Drop 

Text 

The style to be used for the text displayed for drag and drop 

in a course. 

Default Course Page Title 

Text 

The style to be used for the text displayed as the page title 

in a course. 

Default Course Popup Text The style to be used for the text displayed as a popup in a 

course. 

Default Course Questions 

Text 

The style to be used for the text displayed as assessment 

questions in a course. 

Default Course Text The style to be used for the course text. 

Default Course Title Text The style to be used for the text displayed as the course 

title. 

Default Text The style to be used for the page text. 

Document Note The style to be used for the document note. 

Document Title The style to be used for the document title that displays at 

the top of a document. 

Example The style to be used for the example text. 

Example Phrase The style to be used for the example phrase text. 

Generic Table Text The style to be used for generic table text. 

Guided Help User Interface The style to be used for the text displayed in a guided help 

user interface. 

Link Text The style to be used for the link text. 

Page Description Text The style to be used for the page description text. 
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Field Description 

Page Title Text The style to be used for the page title text. 

Screen Caption The style to be used for the captions displayed above screen 

captures in a document. 

Section Name The style to be used for sections displayed in your 

document. 

Simulation Note The style to be used for simulation notes. 

Simulation User Interface The style to be used for simulation user interface. 

Step The style to be used for step text. 

Step Number The style to be used for the step number. 

Table Header The style to be used for the table header. 

Table of Contents The style to be used for table of contents heading. 

Table of Contents Heading 1-

6 

The style to be used for the levels within the table of 

contents. 

Table Text The style to be used for the table text. 

 
To remove the table border, including 

columns and rows, set the Border Color 

to Transparent. You must also set the 

Border Size to None under the Table 

Outline style to remove the entire table 

border. 
 

Table Outline The style to be used for the table outline. 

 
To remove the table border, including 

columns and rows, set the Border Size 

to None. You must also set the Border 

Color to Transparent under the Table 

Text style to remove the entire table 

border. 

 

 
 

Top Navigation Text The style to be used for the top navigation text displayed in 

a course. 
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9. Click Modify. 

10. Click Select Phrase. 

11. Perform one of the following options: 

If You Want To Then 

Add a custom phrase Click Add. 

Select a language from the left. 

Enter the text in the content area. 

Click OK. 

Select a phrase Select a language from the Language drop-down 

list. 

Select a phrase from the Phrase listbox. 

Optionally, enter text into the Phrases field to 

search for text. 

Click OK. 

12. Complete the following fields: 

 
Depending on the style selected, some of the following options may not be displayed. 
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13. Select FILE > SAVE to save the template. 
 

Field Description 

Font Click Select to choose a font. 

Size Specify the font size. 

Font Color Select a font color from the drop-down list. 

Optionally, click Select to create a custom color. 

Effects Click the checkbox(es) next to Bold, Underline, Italic, or 

Strikethrough, to apply rich text formatting. 

Use Language Specific Fonts Click the checkbox next to Use Language Specific Fonts 

and click Select to choose the language specific font(s). 

Justification Specify a justification setting from the drop-down list. The 

following justification styles are available: Default (LTR: 

Left -RTL: Right), Mirrored (LTR: Right - RTL: Left), 

Left, Right, Center, or Full. 

Margins Specify margins for Top, Bottom, Left, and Right. 

Optionally, select the unit of measurement from the Unit 

drop-down box. 

First Line Specify the indent of the first line. 

Optionally, select the unit of measurement from the Unit 

drop-down box. 

Background Color Specify a background color from the drop-down list. 

Optionally, click Select to create a custom color. 

Gradient Select the Gradient checkbox to apply a gradient to section 

header backgrounds in HMTL outputs viewable in 

supported versions of Internet Explorer. 

Start Color Specify a gradient start color from the drop-down list. 

Optionally, click Select to create a custom color. 

End Color Specify a gradient end color from the drop-down list. 

Optionally, click Select to create a custom color. 

Orientation Specify the orientation of the gradient from the drop-down 

list. 

Border Color Specify a border color from the drop-down list. 

Optionally, click Select to create a custom color. 

Border Size Specify the border width from the drop-down list. 

Apply to Bottom Border 

Only - HTML Only 

Specify the style be applied only to the bottom border. 
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Modifying, Duplicating, and Deleting Styles 

1. From the Editor, open the new template. 

2. Click the Styles tab. 

3. Select Manage All Styles from the task pane. 

 

4. Select a style from the Editor Pane. 

5. Choose from one of the following options: 

If You Want To Then 

Modify the selected style Click Modify, and refer to Specifying Styles (on 

page 375). 

Duplicate the style Click Duplicate. 

The duplicated style is added below the original 

style. Modify the property to specify a new name 

and characteristics. For more information, refer 

to Specifying Styles (on page 375). 

Delete the selected style Click Delete. 

At the prompt, click Yes. 

6. Click FILE > SAVE to save the template. 
 

Changing Bulk Styles 

1. From the Editor, open the new template. 

2. Click the Styles tab. 
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3. Select Bulk Style Change from the Task Pane. 

 

4. Select a style from the list. 

5. Click Load Style to view the current style settings for the item selected. 

6. Using the Ctrl or Shift key, select one or more styles for which you want to apply a bulk 

change. 

7. Complete the following fields: 

Field Description 

Font Select the checkbox next to Font to specify a font. 

Font Color Select the checkbox next to Font Color to specify a 

font color. 

Size Select the checkbox next to Size to specify a font 

size. 

Bold Select the checkbox next to Bold, and select Yes or 

No to specify a bold font. 

Underline Select the checkbox next to Underline, and select 

Yes or No to specify an underline font. 

Italic Select the checkbox next to Italic, and select Yes or 

No to specify an italic font. 

Strikethrough Select the checkbox next to Strikethrough, and 

select Yes or No to specify a strikethrough font. 

8. Click Apply. 

9. Select FILE > SAVE to save the template. 
 



Chapter 16: Using Author Templates 

382 Hewlett Packard Enterprise Develoment LP 

 

Viewing Styles 

1. From the Editor, open the new template. 

2. Click the Styles tab. 

3. Select Applied Styles from the Task Pane. 

 
 

 
A list of styles and their descriptions is displayed in the Editor Pane. 

 
 

Specifying New Template Settings: Blocks 

 
When editing the header/footer, it is recommended that a test publish be 

performed to see how the header/footer appears on published output. 

Based on the header/footer and page settings selected, the header/footer 

may print outside the designated space. If this occurs, it is recommended 

that you adjust the header/footer settings. For example, the width/height 

of the page, margins, and font size can cause the header/footer text to 

print outside the designated area. 

 

 
 

Specifying Blocks 

1. From the Editor, open the new template. 
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2. Click the Blocks tab. 

 
 

3. Perform one of the following options: 

If You Want To Then 

Modify a block Go to Step 5. 

Duplicate a block Select the block from the content area, and click 

Duplicate. 

Delete a block Select the block from the content area, and click 

Delete. 

At the prompt, click Yes. 

4. Optionally, select a step type from the Default Recorder Step drop-down list. 

5. Select one of the following blocks from the Task Pane: 

Field Description 

Activity The block that contains the task information. 

ASAP BPP The block that contains the business process 

description overview, input, output, comments, and 

tips and tricks. 

Configuration Information The block that contains the configuration 

information for the document. 

Course Footer The block that contains the course footer 

information. 

Course Header The block that contains the course header 

information. 

Exercise/Data Sheet The block that contains information relevant to the 

end user's task. 

Field The block that contains the Field/Description table. 

Footer The block that contains the footer information. 

Free Text The block that contains the boilerplate freetext. 
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Field Description 

Header The block that contains the header information. 

Heading The block that contains the heading boilerplate text. 

If The block that contains the If/Then table. 

Note The block that contains the note boilerplate text. 

Purpose The block that contains the trigger, prerequisites, 

menu path, transaction code, and helpful hints. 

Result The block that contains the percent complete. 

Screen Flow The block that contains the screen flow image file. 

Start the task using the menu 

path 

The block that contains the start transaction text. 

Step The block that contains the step boilerplate text. 

Student Guide Footer The block that contains the student guide footer 

information. 

Student Guide Header The block that contains the student guide header 

information. 

Substep The block that contains the substep boilerplate text. 

Test Information The block that contains the test history and 

scenarios. 

Test Scenarios The block that contains the table specific to test 

scenarios. 

6. Click Modify. 

7. Click Select Phrase. 

8. Perform one of the following options: 

If You Want To Then 

Add a custom phrase Click Add. 

Select a language from the left. 

Enter the text in the content area. 

Click OK. 

Select a phrase Select a language from the Language drop-down 

list. 

Select a phrase from the Phrase listbox. 

Optionally, enter text into the Phrases field to 

search for text. 

Click OK. 

9. In the content area, modify the text within the curly braces. 

10. Perform one or more of the following options: 
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If You Want To Then 

Modify the format of displayed block 

text 

Highlight the text to be formatted. 

Click Format..., and select from the Edit, 

Format, or Justify options. 

Insert an image, table, weblink, or line 

at the cursor location in the displayed 

block text 

Click Format..., and select from the Table or 

Insert options. 

Modify the format of an image Click Format..., and select Left or Right from 

the Image Layout options.. 

Insert a phrase or standard document 

property code at the cursor location in 

the displayed block text 

Click INSERT... > PHRASE... [or] Standard 

Code..., and select from the displayed list. 

View the content area in mirrored 

justification 

Select Mirrored View. 

11. Optionally, edit the source content of the block in the Source Pane. 

 
Basic knowledge of HTML, CSS, and JavaScript is required. 

12. Determine where the block is used in the This item is used by the items below pane. 

13. Under Format, select a style from the drop-down list. 

14. Click the checkbox next to Visible to display the block in published documentation. 

15. Select FILE > SAVE to save the template. 
 

Specifying New Template Settings: Sections 

Specifying Sections 

1. From the Editor, open the new template. 
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2. Click the Sections tab. 

 

3. Select a section from the Task Pane. 

4. Click the checkbox next to Visible to display the section in published documentation. 

 
New sections will display in all new documents and older documents will be upgraded 

to add newly added sections when opened. 

5. Complete the following fields: 

Field Description 

Header Specify the header for the section. 

Footer Specify the footer for the section. 

6. Click Select Phrase. 

7. Perform one of the following options: 

If You Want To Then 

Add a custom phrase Click Add. 

Select a language from the left. 

Enter the text in the content area. 

Click OK. 

Select a phrase Select a language from the Language drop-down 

list. 

Select a phrase from the Phrase listbox. 

Optionally, enter text into the Phrases field to 

search for text. 

Click OK. 

8. Under Content, perform one of the following options: 

If You Want To Then 

Add content to the section Click Add. 

Select a block from the list. 

Click OK. 
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If You Want To Then 

Remove content Click Remove. 

At the prompt, click Yes. 

Move content to earlier in the list Click Move Up one or more times as needed. 

Move content to later in the list Click Move Down one or more times as needed. 

9. Determine where the section is used in the This item is used by the items below area. 

10. Click FILE > SAVE to specify additional sections. 
 

Modifying, Duplicating, and Deleting Sections 

1. From the Editor, open the new template. 

2. Click the Sections tab. 

 

3. Perform one of the following options: 

If You Want To Then 

Modify a section Select the section from the Manage All Sections 

list in the Content Pane. 

Click Modify. 

For information on modifying a section, refer to 

Specifying Sections (on page 385). 

Duplicate a section Select the section from the content area, and 

click Duplicate. 

The duplicated section is added below the 

original section. Modify the property to specify a 

new name and characteristics. For information, 

refer to Specifying Sections (on page 385). 

Delete a section Select the section from the content area, and 

click Delete. 

At the prompt, click Yes. 
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If You Want To Then 

Move a section earlier in the list Select the section. 

Click Move Up one or more times as needed. 

Move the section later in the list Select the section. 

Click Move Down one or more times as needed. 

4. Click FILE > SAVE to save the template. 
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Export and Import an Author Template 

The application allows users to import and export author template phrases via the XML 

Localization Interchange File Format (XLIFF) for translating template content in to multiple 

languages. When a template is exported, one XLIFF file will be created for each language. When 

a template is imported, it is updated to contain the translated phrases. 

The file is formatted to facilitate translation by displaying the source (original) text co-located 

next to the target translated text. 

 
The XLIFF file can be edited in Notepad, in an HTML editor, or via a specialized 

XLIFF editor such as Xliff Editor or Heartsome. 

 

 

Exporting Template Content 

1. Start the Editor and open the desired template (.udt) file. 

2. Select TRANSLATIONS > EXPORT CURRENT. 

 

 

3. Select the target export language(s). 

 
Multiple languages can be selected. Click the checkbox beside the template name to 

select all languages. 

4. Click Export. 



Chapter 16: Using Author Templates 

390 Hewlett Packard Enterprise Develoment LP 

 

5. Optionally, select , to specify a destination folder other than the default. 

 
Only the template will be exported. Any depending application content will not be 

represented in the output. 

6. Click Export.  

 

7. Click OK. 
 

Importing Template Content 

1. Start the Editor and open the desired template (.udt) file. 

2. Select TRANSLATIONS> IMPORT CURRENT. 

 

3. Select the template and language(s) to import. 
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4. Click Import. 

 

5. Click OK. 

 
The template is now updated to include the translated phrases, and will be included in 

content using that template. 
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Delete an Author Template 

 
Create a backup of the template file prior to deleting the template. Any existing 

documents created with the deleted template cannot be opened after the template is 

deleted. 

 

 

Deleting an Author Template 

1. Select FILE > PREFERENCES. 

2. Click MANAGE LOCAL TEMPLATES on the left pane. 

3. Select the template you want to delete. 

4. Click Remove. 

5. Click OK. 
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Chapter 17: Building a Website 

You can design, build, and maintain a website to deliver content to 

your end users. In addition to standard application documents, 

simulations, student guides, and eLearning courses, non-ART content 

can be included in the website. 
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Introduction to the Website 

You can present published content to your end users via a website. You can rapidly build your 

website by assigning properties to application content and then leveraging these properties to 

automatically organize your website hierarchy. Alternately, you can manually create your website 

hierarchy and drag-and-drop content into the hierarchy structure. 

The website is a collection and organization of pages and content links, not a document 

repository. You must host the generated website, including the published content, on a web server 

or network file server to make the website available to your end users. 
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Create the Website 

Exploring the Website Editor 

The website editor consists of the following areas: 

 Content and Editing Area - displays the title and description of the selected 

page; also displays the content available from each page and the content 

available on the entire website. 

 Task Pane - displays a tree view of the website structure. 

 
 

Two tabs in the upper left allow you to customize your view of website content: 

 The Page tab displays the title, description, and included links for the page 

currently selected in the task pane. 

 The All Content tab displays the list of all links available for inclusion in the 

website. Only those links which have been added to a page will display on the 

website. 
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Planning and Designing the Website 

Before creating your website, you should determine the desired navigation structure to present to 

your end users. Some potential organization methods include: 

 Application module (for example, Sales, Human Resources, Finance) 

 Employee role (for example, Sales Clerk, Personnel Manager, Accountant) 

 Geographic or organizational location (for example, Headquarters, United 

States, Tokyo) 

 Business process or function (Sales Orders, Personnel Development, 

Budgeting) 

When working with the application, it is helpful to think of your navigation structure as being 

made up of pages, which can contain subpages and/or links. The pages in your website reflect 

your desired navigation structure. For example, you might have a page named "Sales" with a 

subpage named "Sales Clerk." 

There are two methods for structuring and populating your website: 

 Create your website structure manually by creating pages and populate the 

website by adding content links to these pages. 

 Automatically build your website structure and populate the website based on 

the properties of your content. For example, you can use the built-in Category 

properties within a template to specify your structure. You might specify 

Category 1 as business process and Category 2 as role. The template also 

allows you to specify a hierarchy of these category properties. After authors 

assign a value to the category properties within content, your published 

website would reflect a navigation structure based on business process as the 

primary selection and role as the secondary selection. 

 
If you will be automatically populating your website using properties, you should 

enable these properties in your project template, specify the valid values, and ensure 

your authors have access to this template prior to developing content. For detailed 

information on templates, refer to Using Author Templates (on page 317). 

 

 

What Can My Website Include? 

The following types of content can be included within a website: 

 Application-created content, including documents, simulations, and courses. 
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The website can only contain content that was created with the same template as the 

website. 

 Hyperlinks to non-ART content on other websites or to files stored on other 

servers or websites 

Within the website editor, the following icons are used to identify content types: 

  - indicates an application-created document/simulation or student guide. 

  - indicates an application-created course. 

  - indicates a link to another website or file. 

  - indicates a website page. 

  - indicates a page shortcut. 

  - indicates the source file cannot be found. 

 

Page and Link Limits 

The application is specifically designed to produce and manage small- and medium-size websites. 

Consequently, there is a limit of 1000 links or pages within the website to maximize performance 

and to keep the website to a manageable file size. 

Pages are displayed in the task pane. Links are displayed in the Links list. 

The number of remaining pages and links is displayed to the right of the tabs in the lower left. 

Pages and links that are copied and pasted are included in the limit. A shortcut to a page or link 

does not count against the limit. 

If you attempt to add a page or link and this action will exceed the limit, an error message is 

displayed. You cannot complete an operation that would result in exceeding the limit. 
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Creating a Website 

1. Select FILE > NEW from the Editor. 

 

2. Select Website from the Type drop-down list. 

3. Complete/review the following information: 

Field Description 

Name Enter the name of the website. 

The name you specify here will also be displayed at 

the top of published website pages. 

Template Select the template associated with this website. 

The template controls the website appearance and, if 

used, the properties on which the website 

organization is based. 

The website can only contain content that is 

generated by the selected template. 

For detailed information on templates, refer to 

"Using Templates" in the Managing Content 

manual. 

Language Select the website language from the drop-down list. 

This selection determines the language used in the 

list of available child documents on the published 

website. 

Location As desired, edit the default location of the website. 

4. Click OK. 
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Open and Save the Website 

Opening a Website 

1. Select FILE > OPEN > OPEN LOCAL.... 

2. Select the .uws file. 

3. Click Open. 

 
 

Saving the Website 

Perform one of the following actions: 

If You Want To Then 

Save an existing website Select FILE > SAVE. 

If this is the first time you are saving the file and 

the display of the Properties window is enabled, 

the Properties window is displayed. 

Save the open website as a new file Select FILE > SAVE AS.... 

Enter a new filename, and click Save. 
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Building the Website Structure Manually 

You can manually build your website structure by creating pages within the website editor. 

For information on leveraging content properties to automatically generate a website based on the 

values of the properties, refer to Populating the Website Structure Automatically (on page 408). 

 

Create and Edit Pages 

Pages contain links to content or to content stored on other websites. By defining pages and 

subpages, you create the website navigation structure that will be viewed by your end users. 

 

Creating a Page 

1. Select the Page tab. 

2. Select the parent of the new page in the Pages task pane. 

3. Select INSERT > PAGE. 

 

4. Enter the name of the page. This text will display at the top of this website page. 

5. Click OK. 
 

Editing a Page 

1. Select the Page tab. 

2. Select the page in the Pages task pane. 
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3. Edit the text in the Title or Description fields. Your changes are saved when you move to 

another page or when you exit a field. 

 
Only plain text is supported in these fields. 

 

 

Moving or Copying a Page 

1. Select the page to move or copy in the Pages task pane. 

2. Perform one of the following options: 

If You Want To Then 

Move the page Right-click on the page, and select Cut. 

Right-click on the new parent for the page, and 

select Paste to insert the page under the selected 

parent. 

OR 

Click and hold the left mouse button on the name 

of the page, and drag the page to the new 

location. A black line is displayed to indicate 

where the page will be inserted. 

Release the mouse button. 

Copy the page Right-click on the page, and select Copy. 

Right-click on the new parent for the page, and 

select Paste to insert the page under the selected 

parent. 

OR 

Control-click the left mouse button on the name 

of the page, and drag the page to the new 

location. A black line is displayed to indicate 

where the page will be inserted. 

Release the mouse button. 

Create a shortcut to an existing page Right-click on the page, and select Copy. 

Right-click on the new parent for the page, and 

select Paste Shortcut. 

The shortcut link is displayed in the Links list to 

the left. 
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Deleting a Page 

1. In the Pages task pane, right-click on the page to be deleted. 

2. Select Delete to remove the page from the website. 
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Adding Content to the Website 

Pages and subpages allow you to provide a structural organization to your website. Links are 

added to these pages to allow your end users to launch specific content items. 

 

Add and Edit Content Links 

When you add a link to a page, you are inserting a hyperlink to published application content or to 

non-ART content stored on another file or web server. You can add a single link to your website 

or import a folder of links. Links are created using relative paths, when possible. 

 

Adding a Link to a Page 

1. Select the page to contain the link from the Pages task pane. 

2. Select INSERT > LINK.... 

 

3. Perform one of the following options: 

If You Want To Then 

Create a link to content Select the File radio button and click ... to browse to 

the file. 

The Name field is automatically populated based on 

the filename. 
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Create a link to non-ART 

content 

Select the File radio button and click ... to browse to 

the file. 

The file must be located on a file or web server 

accessible by your end users. 

Enter the name of the document in the Name field. 

If desired, select Copy content to published 

website folder. This option copies content to the 

website folder during publishing. 

Create a link to a website 

location 

Enter a name for the website location in the Name 

field. 

Example: Acme Corporate Website 

Enter the complete website address in the Url field. 

Example: http://www.acme.com 

4. Click OK. 

 
The content link is displayed in the Links list. 

 

 

Adding Links via Drag-and-Drop 

1. Select the page to contain the link(s) from the Pages task pane. 

2. Select the Page tab. 

3. In Windows Explorer, select one or more files or a folder of files. 

4. Drag and drop the file(s) or folder into the Links list. 
 

Adding Multiple Links to a Page 

1. Select the page to contain the links from the Pages task pane. 

2. Select INSERT > MULTIPLE LINKS.... 
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3. Select the folder from which links should be imported. 

4. Click OK. 

 
The application will import links from the specified folder and all subfolders for all 

supported document types. These links will be added to the selected page. 

 

 

Editing a Link 

1. Select the Page or All Content tab. 

2. Right-click the link name, and select Properties. 

3. For non-ART content, you can edit the name and location fields and the prop\-entry values. 

For application-created content, only the location field may be edited. 
 

Moving and Copying a Link 

1. Select the Page tab. 

2. Perform one of the following options: 

If You Want To Then 

Move a link to another page Right-click on the link in the Links list, and 

select Cut. 

Right-click on the target page in the Pages task 

pane, and select Paste to insert the link on the 

selected page. 

OR 

Click and hold the left mouse button on the link 

in the Links list, and drag the link to the target 

page in the Pages task pane. 

Release the mouse button. 
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If You Want To Then 

Copy a link to another page Right-click on the link in the Links list, and 

select Copy. 

Right-click on the target page in the task pane, 

and select Paste to insert the link on the selected 

page. 

OR 

Control-click the left mouse button on the link in 

the Links list, and drag the link to the target page 

in the task pane. 

Release the mouse button. 

 
 

Reordering Links on a Page 

1. Select the Page tab. 

2. From the Pages task pane, select the page containing the links to be reordered. 

3. From the Links list, select the link to be reordered, and drag the link up or down within the 

list. 

 
A black line is displayed to indicate where the page will be inserted when you release 

the mouse button. Note that pages are always displayed above links in the list. 

4. Release the mouse button to move the link to the new position. 
 

Removing a Link from a Page 

1. Select the Page tab. 

2. From the Pages task pane, select the page containing the link to be removed. 

3. Right-click on the desired link in the Links list, and select Delete. 
 

Deleting a Link from the Website 

Deleting a link removes all instances of the link in the website. If you want to remove the link 

only from a specific page, remove the link via the Page tab. 

1. Select the All Content tab. 

2. Right-click on the desired link, and select Delete. 
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3. Click Yes to remove the link from the website. 
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Populating the Website Structure Automatically 

You can automatically populate your website structure by leveraging the properties and associated 

property values specified within your template and stored within the content. To enable use of this 

functionality, you perform the following steps: 

1. Enable built-in properties or create custom properties in your template. For example, you 

might designate Category 1 as Business Process. Refer to Specifying New Template Settings: 

Properties (on page 328) for detailed information on properties. 

2. Specify possible values for these properties in your template. For example, possible values for 

Business Process might include Sales Orders, Personnel Management, and Accounts Payable. 

3. Specify the hierarchy of the properties in your template. For example, Category 2 - Role - 

might be subordinate to the Business Process property. Refer to Specifying General Settings: 

Information (on page 321) for detailed information on specifying property hierarchy. 

4. Ensure the template is accessible from a location for your users to download. 

5. Instruct your authors to specify values for all applicable categories in each file. 

You are then ready to import content and automatically structure the website based on the content 

properties. 

 

Importing Content Links 

1. Select INSERT > INSERT MULTIPLE LINKS... to import one or more folders containing your 

content. 

 

2. Navigate to the folder location. 

3. Click OK. 

 
Refer to "Automatically Organizing the Website" below for detailed instructions on 

automatically organizing the imported content based on the content property values. 
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Automatically Organizing the Website 

1. Select TOOLS > ORGANIZE WEBSITE. 

 
A warning message displays indicating that the current website structure will be 

overwritten. 

2. Click OK. 

 
The Pages task pane is updated to reflect the properties and hierarchy specified in the 

template. Links to imported content are added to pages based on the property values 

specified in the content. 
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Viewing Website Properties 

Viewing Website Properties 

1. Select FILE > DOCUMENT PROPERTIES.... 

2. Click General on the left pane. 

 
Information such as the size, associated template, creation date, and last modified date 

are displayed as view-only information. 

 

3. As desired, edit the Title or Language fields. 

 
The data entered into the Title field will display as the header on the published 

website. 

4. Click OK. 
 

View Content Properties 

From the website editor, you can view properties of the included links. 

You can modify the properties of non-ART content only. To modify ART content properties, you 

must open and edit the file. 
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Viewing Link Properties 

1. Right-click on a link in the Links list, and select Properties. 

 

2. Perform one of the following options: 

If You Want To Then 

View general properties Select the General tab. 

View content properties Select the Properties tab. 

Edit the properties of non-ART content Select the Properties tab. 

Select or enter a value for the desired property. 

You cannot edit the properties of documents 

from the website editor. You must open and edit 

the document to modify the properties. 

3. Click OK. 
 

Set Link List Details 

Within the Links list you can specify up to four built-in or custom properties to display for the 

content items in the list. Examples of these properties include transaction code and content 

location. The Title and Type are always displayed. 

Note that you must have first enabled the desired properties in the template associated with the 

website. 

For detailed information on templates, refer to Using Author Templates (on page 317). 
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Setting Link List Details 

1. Select VIEW > CONFIGURE. 

 

2. Select up to four enabled built-in or custom properties available from the template to dis\-play 

as a column header in the Links list. You can also specify that the Location property be 

displayed. 

3. Click OK. 

 
 

 
The list is refreshed and the selected column headings are displayed. 
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Refreshing the Website 

You should periodically refresh your website if authors are continuing to make changes to 

materials and may be moving or deleting content. By executing a refresh, you can easily check 

and verify links without rebrowsing to find content items. 

The refresh process checks all links in the website and updates the titles or properties within 

content if these have changed. In addition, the refresh process will verify that content items are 

still available at the originally-specified locations. If content has been moved, the links are noted 

as 'source not found' in the Links list. Provided this content has already been published, it will 

still be available on the website, however. If source content is replaced, a subsequent refresh will 

repair these links.  

To execute a refresh, select VIEW > REFRESH. 
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Publishing the Website 

The following subsection describes the steps to publish your website. 

For detailed information on publishing documents, simulations, and courses, refer to Publishing 

Content (on page 307). For information on batch publishing content, the glossary, and your 

website, refer to Batch Publishing (on page 416). 

 

Publishing the Active Website 

1. Select FILE > PUBLISH > PUBLISH CURRENT.... 

 

2. Select the template corresponding to the website to be published. 

3. Optionally, browse to specify an outbox other than the default. 

4. Click Publish to publish the selected website. 

 
When you publish the website, any existing, previously published website at the same 

location is deleted. 

When publishing is complete, a summary message is displayed with a hyperlink to the 

successfully published website. On the published website, active links are only provided to 

documents and courses that have at least one published output in the outbox directory. If a 

document or course has no published content in the outbox directory, the publication settings in 

the template determine whether an inactive link or no link is shown. 

Optionally, review the Application and Transformation logs for detailed information on events. In 

Windows 7 and Windows 8, the logs are stored in the C:\Users\[username]\App 

Data\Roaming\[applicationdirectory]\Version X.X\Logs directory. 

Refer to Making Your Website Available to End Users (on page 420) for information on making 

the website available to end users. 
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Publishing Quick Launch Pages 

Quick launch pages are created during website publishing and are used in conjunction with Help 

Launchpad to provide context-sensitive help directly from SAP. The quick launch pages are 

summarized in a text file (fp_upload.txt), which is uploaded into your SAP system. 

Quick launch pages are intermediate web pages listing content files with a common property, 

typically the transaction code. If only one content file contains a unique property, then the quick 

launch page is an HTML redirect to the content. If multiple content files contain a common 

property, such as the transaction code VA01, the application builds an intermediate web page 

listing all content with this property. 

Refer to Default Publication Settings: Website (on page 368) for information on specifying the 

property from which to build the quick launch pages. 

After publishing, the quick launch text file is placed in the specified outbox in the \[website 

name]\flash\qlaunch folder. 

For complete details on setting up online help using quick launch pages, refer to Creating Online 

Help (on page 423). 
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Batch Publish Process 

When publishing content, one or more glossaries, and one or more websites in a batch operation, 

the following processing order is followed: 

1. All files in the specified inbox are read. 

2. If the inbox contains a glossary, definitions are updated in content and new terms are retrieved 

(provided these options are enabled in the Batch Publish... window). This step is repeated for 

each glossary selected to be published. 

3. Documents and courses are published. Only updated content is published if Express Publish 

is selected. 

4. If the inbox contains a website, the website is updated and published. This step is repeated for 

each website selected to be published. 
 

Batch Publishing 

1. Select FILE > PUBLISH > BATCH PUBLISH.... 

 

2. Select the appropriate checkboxes to the left of the desired template, content types and for\-

mats, website, and glossary. 

3. Optionally, browse to specify an inbox other than the default. 

4. Optionally, browse to specify an outbox other than the default. 

5. Perform one or more of the following options: 
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If You Want To Then 

Publish only files that have changed 

since the last publish operation 

Select the Express Publish checkbox. 

When this option is enabled, the application 

scans the inbox folder to determine which 

documents and courses have been modified since 

the last publish operation. The application then 

includes only these changed files in the list of 

content to be published to the outbox folder. 

Update the definitions in documents 

prior to publishing documents 

Select the Update terms definitions before 

publishing documents checkbox. 

If you are publishing many documents, updating 

terms may substantially increase the time 

necessary to complete the publish process. 

Automatically add new terms found in 

documents to the current glossary while 

updating the document definitions 

Select the Retrieve new terms from documents 

checkbox. 

This option is only enabled if the option to 

update term definitions is enabled. 

If you are publishing many documents, updating 

terms may substantially increase the time 

necessary to complete the publish process. 

6. Click Publish to publish the selected content. 

When publishing is complete, a summary message is displayed with hyperlinks to successfully 

published content. 
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Navigate the Website 

Overview of Navigation Pages 

The end user can navigate within the website by selecting one of the following links: 

 Home - Click to return to the home page. 

 Glossary - Click to display the list of terms and definitions. 

 Page or content link - Click on the page name or link to navigate within the 

website or display content. 

 
 

Overview of Content Pages 

After selecting a content link, the end user selects one of the available published types and formats 

from the drop-down list. 
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To return to a preceding page in the website, the end user clicks on a breadcrumb link in the upper 

left below the page title. 
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Making Your Website Available to End Users 

Overview of the Website Directory Structure 

The following list depicts the directory structure of the website after publishing. 

[Outbox Directory] 

 website name 

  website folder 

   xml folder 

    index.htm 

    site_index.htm 

    assets folder 

    content folder 

     [page id code] folder 

      index.xml 

      [link id code] folder 

       index.xml 

      [link id code] folder 

       index.xml 

      [link id code] folder 

       index.xml 

     [page id code] folder 

    qlaunch folder 

     fp_upload.txt 

     [property value] folder 

      index.xml 

      [link id code] folder 

       index.xml 

      [link id code] folder 

       index.xml 

     [property value] folder 
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     [property value] folder 

 

 

Directory Structure Details 

The index.htm file located in the \[outbox]\[website name]\[website folder]\xml directory is the 

launching page for the website. 

For each page in the website, the application creates a subdirectory within the \xml directory.  The 

name of the subdirectory is determined using a unique alphanumeric id code. To aid in navigating 

to content folders with an alphanumeric id code, open the site_index.htm file in the \xml directory. 

Within each page subdirectory, the application writes a single "index.xml" file.  The index.xml 

file contains the page information and XSLT stylesheet-linking information. 

For each document or course in the website, the application creates a subdirectory and writes a 

single "index.xml" file within the subdirectory.  The index.xml file contains the list of available 

publication types and formats for the content, along with XSLT stylesheet-linking information. 

The publication information in the template determines the link priority of the publish types and 

formats. 

A "qlaunch" subdirectory is created within the root \xml directory.  Within the "qlaunch" 

subdirectory, the application creates quick launch subdirectories, each with an "index.xml" file 

listing links that share a common value for the property specified in the template's publication 

settings. 

If only one link contains a particular value for the property, then the quick launch page will be a 

redirect to the link. If multiple content files contain the same value for the property, the quick 

launch page will list all links with that property. 

Within the "qlaunch" subdirectory is an "fp_upload.txt" text file containing an index of quick 

launch pages.  Your administrator must upload this file into Help Launchpad to provide context-

sensitive help for SAP R/3. Refer to Enabling Help in the SAP R/3 and APO Environments (on 

page 433) for detailed instructions. 

 
The standard Windows folder structure supports folder names up to 100 characters. If 

you are using SAP SRM, folder names can be up to 200 characters based on the 

transaction code associated with the folder. In this instance, the website will take the 

first 100 characters, append a unique code, and use this for the folder name in the 

directory structure. 
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Transferring Your Website to a Server 

To make your content available to end users, you must copy the entire contents of the outbox 

folder specified during publishing. 
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Chapter 18: Creating Online Help 

You can present published content to your end users via online, context-sensitive help integrated 

with SAP and other applications. 

Context-sensitive help can open directly from the user's location in the application to the relevant 

topic or work instruction. After a context-sensitive help search is conducted and the resulting 

document is opened, the content will automatically scroll to the first location in the document 

where the context matches the one from which help was called.  If multiple documents match the 

search results, then the user will have to select to the appropriate document from the list of search 

results.  

The auto-scroll functionality only applies to steps where the context data is captured by the 

recorder. To take advantage of the auto-scroll functionality, new or existing documents need to be 

published with version 5.20 or later. 

The application can automatically scroll to content for only HTML-based published documents 

including: 

 Any document type published to HTML that contains steps 

 Simulation auto and standard playback modes 

 Guided help 

Using the auto-scroll functionality requires an addition to the.xslt file used to generate the 

website. Refer to the section Enabling the Auto Scroll Functionality (on page 424). 
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Introduction to Creating Online Help 

You can present published content to your end users via a website and online, context-sensitive 

help. Via the website publishing process you can produce 'quick launch' pages which, in 

conjunction with the Help Launchpad product, are used to provide context-sensitive help directly 

from your SAP R/3 system. Online help via the SAP Enterprise Portal, Oracle, Siebel, and 

Microsoft Windows-based applications is also available. 

 
For information on publishing quick-launch pages, refer to Publishing Quick Launch 

Pages (on page 415). 

 

 

Types of Help Available 

The following subsections provide general information regarding establishing online, context-

sensitive help in the SAP, SAP Enterprise Portal, Oracle, Siebel and Microsoft Windows 

environments. Refer to the following user manuals and white papers for detailed instructions on 

establishing and maintaining online help: 

 Help Launchpad for ANCILE Info Pak 

 Context-Sensitive Help Solutions for Enterprise Systems (white paper) 

 Creating Content user manual 

 

Enabling the Auto Scroll Functionality 

To take advantage of the auto scroll functionality, new or existing websites and documents will 

have to be published with version 5.20 or later. The auto scroll functionality is only available 

with versions 5.2 and later. 

Before enabling the auto scroll functionality, please note that your content and custom templates 

automatically upgrade when opened for editing. If they are published prior to being opened in the 

Editor, then your content and templates are temporarily upgraded during publishing. The 

temporary upgrades are deleted upon completion of publishing. 

Existing templates are upgraded and placed in the current version’s Documents and Settings or 

Users folder the first time the Editor is launched after an upgrade. 

 
If you have customized the website.xslt file located at "...\website\xml\assets" folder, we recommend making a 

copy of the .xslt file prior to republishing. Refer to Publishing the Website (on page 414). 

1. From the Editor, open the template you want to modify. 
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2. Click the General tab. 

3. Select Data Files from the left pane. 

4. Click the .xlst template file to modify. 

5. Click Modify. 

 

6. Navigate to the function: "changeDoc(selectControl, index)". 

 
To locate this function, try searching for it using your text editor’s search feature. 
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7. Locate the line "document.getElementById('frameContent').src=newURL". 

 

8. Replace with: document.getElementById('frameContent').src = newURL + 

window.location.search; 

 
Add exactly this phrase: document.getElementById('frameContent').src = newURL + window.location.search; 

including the semicolon (;). 

The image below shows an “after” view of what this part of the .xslt file should look like. 
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9. Navigate to the second "}" under the line you just added. 

 

10. Copy the below code and paste it directly after the second "}". 

 
This will insert a new function to enable the content to scroll to the relevant location in the file after the user calls 

help. 

 

function finalizeIframeForUPEX() 

{ 

 //Auto scroll 

        var frameContent = document.getElementById("frameContent"); 

        if (frameContent != null) 

        { 

                var contentWindow = frameContent.contentWindow; 

                if (contentWindow != null) 

                { 

                        var scrollToHelpContentFunction = contentWindow.scrollToHelpContent; 

                        if (scrollToHelpContentFunction != null) 

                        { 

                                var getParameterByNameFunction = contentWindow.getParameterByName; 

                                if(getParameterByNameFunction != null) 
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                                { 

                                        var applicationName = getParameterByNameFunction('application'); 

                                        if (applicationName == "SAP+Portal") 

                                        { 

                                                var myVar = 

setTimeout(function(){scrollToHelpContentFunction()},1); 

                                        } 

                                        else 

                                        { 

                                                scrollToHelpContentFunction(); 

                                        } 

                                } 

                                else 

                                { 

                                        scrollToHelpContentFunction(); 

                                }       

                        } 

                } 

        } 
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} 

 

11. Navigate to the "init" function. 

 
To locate this function, try searching for "function init()" using your text editor’s search feature. 

 

12. Locate the line "Window.location = redirect.URL". 
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Note there are three instances of this line in the "init" function. Perform the following step for all three instances. 

13. Above the line "Window.location = redirect.URL," insert a line with the following text 

including the semicolon: redirectURL = redirectURL + window.location.search;  

 
Add exactly this phrase: redirectURL = redirectURL + window.location.search; including the semicolon (;). 

The image below shows an “after” view of what this part of the .xslt file should look like. 

 

14. Navigate to the iframe element with an id equal to:"frameContent". 

 
To locate this function, try searching for id="frameContent" using your editor’s search feature. 
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15. Immediately before the closing > tag, insert onload="finalizeIframeForUPEX()". 

 
Add exactly this phrase: onload="finalizeIframeForUPEX()". 

The image below shows an “after” view of what this part of the .xslt file should look like. 

 

16. Click FILE > SAVE from the text editor. 

17. Close the file. 

18. Click Yes to update the template when prompted. 
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Enabling Online Help 

Enabling Help in the SAP R/3 and APO Environments 

The Help Launchpad component allows SAP to display the correct content for each transaction in 

a browser window that displays on top of the SAP application. 

 

Enabling Help for SAP R/3 and APO 

1. Install the Help Launchpad Executable and ABAP Transport per the instructions provided in 

the Help Launchpad user manual. This task is typically performed by the SAP R/3 

administrator. 

2. Ensure you have enabled the transaction code property in your template and have made this 

template available to authors. 

3. Create content. 

4. To specify the transaction code for the content, select FILE > PROPERTIES... to open the 

Properties window. 

5. Select the Properties tab on the left. 

6. Enter the transaction code in the Transaction Code(s) field. For multiple transaction codes, 

separate these codes with the value specified in the associated template (for example, comma 

",", colon ":", or semi-colon ";"). 

7. Click OK. 

8. Publish the content and the website. 

9. Copy the published content and website to a shared network location. 

10. In SAP, create a Help Launchpad server via transaction code /RWD/ZF0 per the instruc\-tions 

provided in the Help Launchpad user manual. 

11. Enter the quick launch folder location (within the published website) in the Server Location 

field. 

12. Specify the location of the "fp_upload.txt" file (within the published website) in the Upload 

Location field. 
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13. In SAP, upload the transactions from the "fp_upload.txt" via transaction code /RWD/ZF0 per 

the instructions provided in the Help Launchpad  user manual. Ensure the pre 5.0 format 

checkbox is deselected. 

To access custom help within SAP, an end user performs the following steps: 

14. Start the transaction using the menu path or transaction code. 

15. Select HELP > CUSTOM HELP to display the context-sensitive help in a browser window on 

top of the SAP application. 
 

Limitations When Providing Help in the SAP SRM and Enterprise Portal 
Environments 

 For security reasons, the context-sensitive help solution for SAP SRM and 

SAP Enterprise Portal does not verify that the help content exists, nor does it 

direct users to an alternate location in the event that no context-sensitive help 

is available for a given context. 

 In SAP SRM and SAP Enterprise Portal, the Help menu essentially links to a 

page using a link that matches its ID. When there is no help content available 

at that location, an HTTP 404 (Page Not Found) error displays in the new 

browser window. 

 Due to limitations in cross-domain web document access, the required HTML 

code for activating the stay-on-top ActiveX control is not included in the code 

supplement for the SAP Enterprise Portal or SAP SRM context-sensitive help 

code supplements. 

 

Enabling Help in the SAP SRM Environment 

End-users interact with SAP Supplier Relationship Management (SRM) applications via a web-

based user interface. 

The ANCILE Help Launchpad Code Supplement allows SAP SRM to display the correct content 

for each screen in a browser window that displays on top of the SAP SRM application. 

 

Enabling Help for SAP SRM 

1. Install the ANCILE Help Launchpad Code Supplement per the instructions provided in the 

Context-Sensitive Help Solutions for Enterprise Systems white paper. This task is typically 

performed by the SAP SRM administrator. 
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2. Enter the quick launch folder (within the published website) in the Help_Server_Location 

field. 

3. Ensure you have enabled the transaction code property in your template and have made this 

template available to authors. 

4. Create content. 

5. To specify the SRM screen ID for the content, select FILE > PROPERTIES... to open the 

Properties window. 

6. Select the Properties tab on the left. 

7. Enter the screen ID code in the Transaction Code(s) field. For multiple transaction codes, 

separate these codes with the value specified in the associated template (for example, comma 

",", colon ":", or semi-colon ";"). 

8. Click OK. 

9. Publish the content and the website. 

10. Copy the published content and website to a shared network location. 

To access custom help within SAP SRM, an end user performs the following steps: 

11. Start the procedure by navigating to the desired screen. 

12. Select the Help link to display the context-sensitive help in a browser window on top of the 

SAP SRM application. 
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Configuring SAP Portal for Use with Context-Sensitive Help 

SAP EP is a web-based platform for delivering information from various sources to end users. 

Using the URL to Help Topic setting, the SAP EP can display the correct content for each 

iView/Portal Page in a browser window that displays on top of the SAP EP application. 

Context-sensitive help allows you to provide end users with quick and convenient access to help 

via an online performance support system. End users request help from the Server via a direct link 

in the SAP EP application. 

When creating custom Help links in an application that will be hosted in an iView, consider using 

an approach similar to that used in the context-sensitive solution for the iView itself.  

 Assign a unique identifier to each Help link. Recall that each iView in an SAP 

EP system has a unique alphanumeric identifier (for example, 

"com.sap.portal.createNewUser") that can be used as a reliable link between 

an iView and its related help content. Each custom Help link should also have 

a unique identifier that can be included in the properties of applicable 

documents. 

 Include the unique Help link identifier in documents. The application allows 

the author to specify the iView ID(s) to which the document applies. The Help 

link unique identifier should also be specified in the document. 

 
 

Creating a Template for Use with SAP Portal 

Context-sensitive help for SAP Portal is driven by context identifiers. Each screen in SAP Portal 

has a unique context identifier and these are gathered collectively for a procedure and 

automatically inserted into the transaction code property of a document. Context identifiers are 

used to call context-specific help on the screen in which the end user is working. 

Transaction code is a term and property used to identify a process. It is used in two separate 

instances: 

 Transaction code property: The Server matches this document property to 

the associated SAP CRM 2007 screen when a call for help is made from SAP 

Portal. 

 Transaction code block: In a document, this block displays the transaction 

code pertaining to the document created. 
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1. Create a template. 

 
A project administrator typically creates and customizes templates. For more 

information, refer to Using Author Templates (on page 317). 

2. Select the Blocks tab. 

3. Select Purpose. 

4. Turn off the display of the Transaction Code block in a document. 

5. Select the Properties tab. 

6. Enable the Transaction Code property. 

7. Select FILE > SAVE. 

8. Click the Publications tab. 

9. Select Website. 

10. Select Transaction Code(s) from the Build from Property field. 

11. Select Comma(,) from the Multiple Values Separated By field. 

12. Select FILE > SAVE. 

 
 

Publishing the Website 

As part of website publishing, you will also generate quick launch pages to enable communication 

between the website and SAP Portal. For information on publishing the website, refer to 

Publishing the Website (on page 414). 

 

Configuring SAP Portal to Send a Help Request to the Website 

 
The SAP system administrator must configure SAP Portal to send help requests to the 

Server. This configuration is specified by adding links to the web dynpro page for 

which you want to provide context-sensitive help. 

1. Log into SAP Portal. 

2. Locate the SAP Portal Business Package iView for which you want to create context-sensitive 

help. 
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3. Right-click on the iView. 

4. Select OPEN > OBJECT. 

5. Locate the Show Help Menu item. 

6. Select the Yes radio button. 

7. Open a new browser instance, and run the iView as a Portal end user. 

8. Copy the Object ID from the pop-up Details screen, omitting the pcd portion of the ID. 

9. Build the help call URL as [web server]/[website 

name]/website/website/xml/assets/redirect.html?iViewID=[iView ID]. 

10. Paste the URL into the URL to Help Topic property of the iView. 

11. Click Save. 

 
 

Recording an SAP Portal Document 

1. Log into SAP Portal. 

2. Perform one of the following options: 

If You Want To Then 

Record and edit the entire document Use the template created in Creating a Template 

for Use with SAP CRM 2007 (see "Creating a 

Template for Use with SAP CRM" on page 

449),to  record and edit the document using the 

Editor and the procedures described in Creating 

Online Help (on page 423). 

Go to Step 3. 

Insert steps into a previously recorded 

document 

Update the template associated with the 

document. 

Open the document. 

Select the Simulation tab. 

Select INSERT > STEPS > FROM NEW 

RECORDING. 

Record the steps in SAP Portal using the Editor 

and the procedures described in Recording 

Procedural Content (on page 51). 

Go to Step 3. 
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The recorder does not automatically gather transaction codes for screens containing an 

embedded SAP HTML GUI; however, you can obtain the transaction codes in this 

environment if you have integrated Help Launchpad with the SAP system you are 

displaying within the embedded HTML GUI. 

In the above scenario, select HELP > [CUSTOM] HELP within the transaction 

displayed in the HTML GUI. Review the web address field displayed in the new 

browser window, and identify the transaction code for this transaction. Copy the code 

and paste it into the Transaction Code property of the document you are currently 

recording. 

 

3. In the application, select FILE > PROPERTIES. 

4. Select Properties. 

 

5. Ensure the context identifier(s) have been inserted into the Transaction Code value field. 

6. Click OK. 

7. Save the document. 

8. Add the document to the website using the procedures described in Building a Website (on 

page 393). 

9. Publish the document using the procedures described in Previewing and Publishing Content 

(on page 301). 

10. Republish the website using the procedures described in the Building a Website (on page 

393). 

 
When the website is republished, the document will be available for the end user via 

the help icon in SAP Portal. 
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Enabling the Required iView/Portal Page Options 

To enable end users to access context-sensitive help for an iView/portal page, the Help option 

must be enabled. Each iView/portal page Help option is disabled by default; however, an SAP EP 

user with the appropriate permission to edit an iView/portal page can enable the Help option via 

the Property Editor. 

Each iView and portal page in a portal system can be contained in a tray. The tray includes the 

name of the iView/portal page and a drop-down menu of options such as Refresh, Open in New 

Window, Personalize, Details, and Help.  

To enable the iView/portal page required options: 

1. Log into SAP Enterprise Portal with Content Administrator permission. 

2. In the Portal Catalog, right-click on the desired iView/portal page and select OPEN > OBJECT. 

 
An iView or portal page may display in several different contexts based on your role 

within the SAP EP. For example, the "Create User" iView may be configured 

differently for Super Administrators than it is for Content Administrators. In addition, 

note the specific role(s) in which an iView/portal page is to be modified. If more than 

one role applies, the iView/portal page must be edited for all roles. 

3. In the editing area, select the Property Editor panel located to the right of the editing area. 

4. In the Property Category list, select Show All. 

5. For the Show 'Details' option property, click Yes. 

6. For the Show 'Help' option property, click Yes. 

7. For the Show Tray option property, click Yes. 

8. Click Save. 
 

Locating the iView/Portal Page ID 

Each iView and portal page in SAP EP has a unique alphanumeric identifier, which is registered 

in the portal content directory (PCD). The identifier is assigned when a new iView/portal page is 

created in the Portal Content Studio. Because identifiers are unique, they can be used as reliable 

links between an iView/portal page and its related help content. 

To link an iView or portal page to help content, the iView/portal page ID must be included in the 

properties of the applicable document(s). To allow authors to easily locate an iView/portal page’s 

ID, the Details option must be enabled. An author can determine the iView/portal page ID via its 

details window by selecting the Details option within SAP EP. This will display a new browser 

window containing the Portal Component and Object ID. 
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The Object ID is a string of alphanumeric characters. You may choose to use the entire Object ID 

as the iView/portal page ID, or simply use the segment of the Object ID that follows the last "/" 

divider. 

 

Including the iView/Portal Page ID in Documents 

The application allows the author to populate properties within the document. These properties are 

leveraged when building website navigation and quick launch pages. 

The application provide a Properties window for populating the Transaction Code(s) property 

within the document. 

To map a document to an iView/portal page via the Properties tab: 

1. Ensure that the Transaction Code(s) built-in property is marked as visible in the template. By 

default, the display of all built-in properties is disabled in the template. 

2. Open the desired document associated with the template. 

3. Select FILE>PROPERTIES.... 

4. Click Properties on the left pane. 

5. Select the Transaction Code(s) field. 

6. Enter the iView/portal page ID in the Transaction Code(s) field. For multiple IDs, separate 

each with a comma.  

7. Click OK. 

8. Select FILE > SAVE to save your document. 
 

Setting the Help URL for an iView/Portal Page 

The URL to Help Topic property was introduced in EP6 SP17 and EP7 SP10 as a simple way to 

direct end users to the correct help URL; however, if you wish to configure the help URL for 

iViews or portal pages for which the URL to Help Topic property is not available, you may do so 

by using the PCD Inspector. The procedure for determining which procedure to use for setting the 

help URL depends on the following criteria. 

 The version and service pack (SP) of your SAP EP system 

 Whether you wish to enable the Help option on an iView or portal page 
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SAP EP 
Version 

Service Pack 
(SP) Version 

Set Help URL for iViews 
via 

Set Help URL for 
Portal Pages via 

6 

 

Prior to SP17 PCD Inspector PCD Inspector 

SP 17-20 Portal Content Administrator PCD Inspector 

7 

 

Prior to SP 10 PCD Inspector PCD Inspector 

SP 10-12 Portal Content Administrator PCD Inspector 

SP 13 Portal Content Administrator Portal Content 

Administrator 

7.30 0 PCD Inspector PCD Inspector 

 
 

Setting the Help URL Using Portal Content Administration 

If you are setting the URL to Help Topic property for an iView/portal page, you may do so using 

Portal Content Administration. 

To set an iView/portal page URL to Help Topic property using Portal Content Administration: 

1. Log into SAP Enterprise Portal with Content Administrator permission. 

2. In the Portal Catalog, right-click on the desired iView/portal page and select OPEN > OBJECT. 

 
An iView or portal page may display in several different contexts based on role within 

the SAP EP. For example, the "Create User" iView may be configured differently for 

Super Administrators and Content Administrators.  Therefore, it is important to note 

the specific role(s) in which an iView/portal page is to be modified.  If more than one 

role applies, then the iView/portal page must be edited for all roles. 

3. Locate the Property Editor panel to the right of the editing area. 

4. In the Property Category list, select Show All. 

5. In the list of properties, scroll to the URL to Help Topic property, and enter the help topic 

location. Refer to Setting Up Stay-On-Top and Browser Controlled with ActiveX Mode in the 

Help Launchpad  user manual. 

6. Enter the complete address of the website/xml/qlaunch folder in the published website, 

followed by the iView/portal page ID and "/index.xml". For example: 

http://[server]/website/sml/qlaunch/[iView/portalpage ID]/index.xm. 

 
Only http addresses will produce the desired help results. For example, an iView with 

an ID of "com.sap.portal.usersInLast3Hours", the following address would be used: 

http://[server]/website/xml/qlaunch/com.sap.portal.usersInLast3Hours/index.xml. 

 
Use a forward slash (/) to indicate path separator. 

7. Click Save. 
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Setting the Help URL Using the PCD Inspector 

1. Log into SAP Enterprise Portal with Content Administrator permission. 

2. From the Portal's top menu, click System Administration. 

3. From the System Administration page, click Support. 

4. From the Support page Top Level Areas list, click Portal Content Directory. 

5. In the Test and Configuration Tools list, click PCD Inspector. You may see warnings at this 

point; confirm these warnings and continue. 

6. From the PCD Inspector browser, check the box next to portal_content. 

7. Click Browse Into. 

8. Repeat Step 6-7 as necessary until you reach the desired portal page. 

9. Select the checkbox next to the desired portal page, and click PropEditor. This will open a 

new browser window for the PCD Generic Layer Property Editor. 

10. Click Switch to PCM. 

11. From the List of All Properties list, choose com.sap.portal.iview.HelpURL. 

12. Click Edit. 

13. In the Property Value field, enter the complete address of the website/xml/qlaunch folder in 

the published website, followed by the iView/portal page ID and "/index.xml": 

http://[server]/website/xml/qlaunch/[iView/portal page ID]/index.xml. 

 
Only http addresses will produce the desired help results. For example, an iView with 

an ID of "com.sap.portal.usersInLast3Hours", the following address would be used: 

http://[server]/website/xml/qlaunch/com.sap.portal.usersInLast3Hours/index.xml. 

 
Use a forward slash (/) to indicate path separator. 

14. Click Save. 
 

Modifying the Help Link in the Portal Masthead 

By default, the Help link in the SAP EP masthead launches the SAP Help Portal; however, the 

Portal Content Administrator can change the URL that is displayed by this Help link. For 
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example, you may wish to have this Help link display the home page of your custom or 

application-generated website or display a specific page on your corporate intranet. 

To select the URL that is displayed by the Help link in the Portal masthead, perform the following 

steps: 

1. In the Portal Catalog, go to Portal Users > Standard Portal Users. 

2. Right-click on the Default Framework page and select OPEN > OBJECT. 

3. Check the Masthead iView checkbox and click Properties. 

4. In the Property Editor, from the Property Category drop-down list, select Navigation. 

5. In the Property Editor, locate the URL of Help Link property. 

6. In the URL of Help Link property, enter the URL of the site you want to display. 

7. Click Save. 
 

Requesting Help from SAP Portal 

1. Log into SAP Portal as an end user. 

2. Navigate to the desired screen. 

3. Click the help icon (?) for the screen. 

 
The website searches for available help for the screen based on the context identifier 

specified in the document. 

4. SAP Portal will open a new browser window displaying the following potential help options: 

 If a single help document has been created, the document displays in the new 

browser window. 

 If more than one help document has been created, a list of documents displays 

in the browser window. 

 If no help document has been created, an HTTP 404 (Page Not Found) error 

displays in the new browser window. 
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Configuring SAP SRM 4-6 for Use with Context-Sensitive Help 

SAP SRM captures context IDs and allows the SRM system to display the correct help content for 

each screen in a separate browser window. The context-sensitive help solution for SAP SRM 

provides custom help for only SRM Enterprise Buyers Professional (EBP) screens via the Help 

link in each screen. 

One of the things that can be contained within an SAP EP iView is the SAP SRM user interface. 

In other words, a user can perform an SAP SRM transaction from within an iView. If a customer 

wants context-sensitive help for an SAP EP iView (regardless of what the iView contains), then 

the context-sensitive help solution for SAP EP is required. 

 

Obtaining the Help Launchpad Code Supplement 

Download the Help Launchpad Code Supplement for SAP SRM from the Product Support Center. 

This code supplement was authored by ANCILE for use only by customers and partners. The code 

supplement file contains JavaScript code that redirects the SAP SRM’s existing Help link to a 

help page created with the application. 

 
 

Modifying the Workplace Integration API 

SAP Internet Transaction Server (ITS) embeds the wpintegration.js client-side script into every 

SRM screen at runtime.  This script provides programmatic access to several SRM screen 

functions, including the Help link.  By modifying the wpintegration.js script via the ABAP 

Workbench, we are able to intercept and redirect help calls made from this Help link. 

 
Refer to the appropriate instructions and SAP Note(s) for changing JavaScript files via 

the ABAP Workbench. 

To modify the Workplace Integration API: 

1. Log into the appropriate SAP System using SAP GUI. 

2. Open the ABAP Workbench Object Navigator using transaction SE80. 

3. In the Object Navigator, select the Internet Service BBPGLOBAL. The Web Application 

Builder is started. 

4. Select WPINTEGRATION.JS from the Mime Objects located under the BBPGLOBAL item 

in the Object list. 
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5. Right-click WPINTEGRATION.JS and select Change. 

6. If prompted, click the green check. 

7. If prompted, click Maint. in logon lang. 

8. Click Save As Local File. 

9. Create a backup copy of the wpintegration.js file (e.g., wpintegration.js.bak) on your local 

computer. 

10. In the Web Application Builder, scroll to the bottom of the wpintegration.js file. 

11. Append the Help Launchpad code supplement to the end of the wpintegration.js file. 

12. In the code supplement, locate and edit the following fields: 

Field Name Description 

HELP_SERVER_LOCATION Complete address of the qlaunch folder in the 

published website. 

The application's websites consist of a folder 

structure that stores the navigational pages, 

quick launch pages, and content for the web 

pages. This folder structure includes a qlaunch 

folder. 

HELP_FALLBACK_LOCATION Location of the fallback help, in case a 

scripting error occurs during context-sensitive 

help. 

 
The fallback help does not 

automatically redirect the user to a 

given website when there is a help 

page that cannot be found.  The 

context-sensitive help solution for 

SRM cannot determine whether or 

not a specific help page exists on a 

given website. 
 

SCREEN_ID_TEXT Message text used to indicate the screen ID 

SHOW_ID Determines whether the screen ID is displayed 

in the new window launched from the screen 

Help link: 

true = show screen ID 

false = show help content 

HELP_WINDOW_LEFT Help window left position in pixels  

HELP_WINDOW_TOP Help window top position in pixels  

HELP_WINDOW_WIDTH Help window width in pixels  

HELP_WINDOW_HEIGHT Help window height in pixels  
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1. Save the wpintegration.js file. 

2. Select the BBPGLOBAL Internet Service from the Object Navigator list. 

3. Click Publish. 

 
You should receive a message at the bottom of the screen stating the object published 

successfully. 

4. Refresh the SRM screen displayed in the web browser. 

 
You may need to clear your browser's cache or Temporary Internet Files. 

 
This modification affects all screens in the SRM system. Be sure to verify that each 

screen has online help available. 

 
 

Determining the Screen ID 

Each screen in an SRM system has a unique alphanumeric identifier (ID). This ID can be used as 

a reliable link between an SRM screen and its related help content.  To link an SRM screen to 

help content, the ID must first be included in the applicable document(s). 

If the SHOW_ID property is set to true, any user with access to an SRM screen can determine its 

ID using the Help link: 

1. In the wpintegration.js file, ensure that the SHOW_ID property is set to true. 

2. Save the wpintegration.js file. 

3. Click Publish. 

4. Refresh the SRM screen displayed in the web browser. 

 
You may need to clear your browser's cache or Temporary Internet Files. 

5. In the desired BSP application screen, select the Help link to open a new window that 

displays the ID for the screen. 
 

Including the SRM Screen ID in Documents 

The application allows the author to populate properties within the document, then it leverages 

these properties when building website navigation and quick launch pages. 

The application provides a Properties window for populating the Transaction Code(s) property 

within the document. To map a document to a SRM screen via the Properties tab: 
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1. Ensure that the Transaction Code(s) built-in property is marked as visible in the template. By 

default, the display of all built-in properties is disabled in the template. 

2. Open the desired document associated with the template. 

3. Select FILE > PROPERTIES…. 

4. Click PROPERTIES on the left pane. 

5. Select the Transaction Code(s) field. 

6. Enter the iView/portal page ID or the screen ID in the Transaction Code(s) field. For multiple 

pages or IDs, separate each with a comma. 

7. Click OK. 

8. Select FILE > SAVE to save your document. 
 

Viewing Help Content for an SRM Screen 

If the SHOW_ID property is set to false, any user with access to an SRM screen can view help 

content for the screen using the Help link: 

 
This modification affects the Help link for every SRM screen. Be sure to verify that 

help content is ready for each available SRM screen before performing the following 

steps. The Help link links blindly to a page that matches its ID. 

1. In the wpintegration.js file, ensure that the SHOW_ID property is set to false. 

2. Save the wpintegration.js file. 

3. Click Publish. 

4. Refresh the SRM screen displayed in the web browser. 

 
You may need to clear your browser's cache or Temporary Internet Files. 

5. In the desired Business Server Pages (BSP) application screen, select the Help link to open a 

new browser window that displays help content for the screen. 
 

Enabling Help for SAP CRM 

To implement and use context-sensitive help for SAP CRM with the application, you will perform 

four procedures: 

 Create a template. 
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 Configure SAP CRM to send help requests to the application's website. 

 Record an SAP CRM document with the application and republish the website 

to make the document available for context-sensitive help. 

 Request context-sensitive help from SAP CRM. 

 

Creating a Template for Use with SAP CRM 

Context-sensitive help for SAP CRM is driven by context identifiers. Each screen in SAP CRM 

has a unique context identifier and these are gathered collectively for a procedure and 

automatically inserted into the transaction code property of a document. Context identifiers are 

used to call context-specific help on the screen in which the end user is working. 

Transaction code is a term and property used to identify a process, and it is used in two separate 

instances: 

 Transaction code property: The Server matches this document property to 

the associated SAP CRM screen when a call for help is made from SAP CRM. 

 Transaction code block: In a document, this block displays the transaction 

code pertaining to the document created. 

 

1. Create a template. 

 
A project administrator typically creates and customizes templates. For more 

information, refer to Using Author Templates (on page 317). 

2. Select the Blocks tab. 

3. Select Purpose. 

4. Turn off the display of the Transaction Code block in a document. 



Chapter 18: Creating Online Help 

450 Hewlett Packard Enterprise Develoment LP 

 

5. Select the Properties tab. 

6. Enable the Transaction Code property. 

7. Select FILE > SAVE. 

8. Click the Publications tab. 

9. Select Website. 

10. Select Transaction Code(s) from the Build from Property field. 

11. Select Comma(,) from the Multiple Values Separated By field. 

12. Select FILE > SAVE. 
 

Publishing the Website 

As part of website publishing, you will also generate quick launch pages to enable communication 

between the application website and SAP CRM. For information on publishing the website, refer 

to Publishing the Website (on page 414). 

 

Configuring SAP CRM to Send a Help Request to the Website 

The SAP system administrator must configure SAP CRM to send help requests to the website. 

This configuration is specified by adding variants to the Plain HtmlHttp tab of the SR13 

transaction code. 

1. Log into SAP CRM via the SAP GUI. 

2. Enter the transaction code SR13. 

 

3. On the Dynamic Help tab, delete any existing entries. 

4. Click . 
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5. Select the PlainHtmlHttp tab. 

 

6. Complete the following fields: 

Field Description 

Variant Enter a variant name. 

Example: YourCompanyHelp 

Platform Enter a platform. 

Example: ITS. 

Area Enter an area. 

Example: XML_DocU 

Server Name Enter the webserver name. 

Example: MySite 

Path On the web server, locate the redirect.html. This 

file is found in http://[webservername]/[website 

name]/website/xml/assets/redirect.html. 

Copy the URL beginning with [website name], and 

paste into the Path field. 

Example: [website 

name]/website/xml/assets/redirect.html 

Append ?csh= to the end of the path name 

Example: [website 

name]/website/xml/assets/redirect.html?c

sh= 

 
This path name cannot exceed 64 

characters. 
 

Language Enter the language key. 

Example: For German, enter DE. 

Default Select this checkbox if the language specified is the 

default help language. 

1. Click  . 
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Recording an SAP CRM Document 

1. Log into SAP CRM. 

2. Perform one of the following options: 

If You Want To Then 

Record and edit the entire document Use the template created in Creating a Template 

for Use with SAP CRM 2007 (see "Creating a 

Template for Use with SAP CRM" on page 449), 

to  record and edit the document using the Editor 

and the procedures described in Creating Online 

Help (on page 423). 

Go to Step 3. 

Insert steps into a previously recorded 

document 

Update the template associated with the 

document. 

Open the document. 

Select the Simulation tab. 

Select Insert > Steps > From New Recording. 

Record the steps in SAP CRM using the Editor 

and the procedures described in Recording 

Procedural Content (on page 51). 

Go to Step 3. 

 

 
The recorder does not automatically gather transaction codes for screens containing an 

embedded SAP HTML GUI; however, you can obtain the transaction codes in this 

environment if you have integrated ANCILE Help Launchpad with the SAP system 

you are displaying within the embedded HTML GUI. 

In the above scenario, select Help > [Custom] Help within the transaction displayed in 

the HTML GUI. Review the web address field displayed in the new browser window, 

and identify the transaction code for this transaction. Copy the code and paste it into 

the Transaction Code property of the document you are currently recording. 

 

3. In the application, select FILE > PROPERTIES. 
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4. Select Properties. 

 

5. Ensure the context identifier(s) have been inserted into the Transaction Code value field. 

6. Click OK. 

7. Save the document. 

8. Add the document to the website using the procedures described in Building a Website (on 

page 393). 

9. Publish the document using the procedures described in Publishing Content. 

10. Republish the website using the procedures described in the Building a Website (on page 

393). 

 
When the website is republished, the document will be available for the end user via 

the help icon in SAP CRM 2007. 

 

 

Requesting Help from SAP CRM 2007 

1. Log into SAP CRM as an end user. 
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2. Navigate to the desired screen. 

 

3. Click the help icon (?) for the screen. 

 
The website searches for available help for the screen based on the context identifier 

specified in the document. 

4. SAP CRM 2007 will open a new browser window displaying the following potential help 

options: 

 If a single help document has been created, the document displays in the new 

browser window. 

 If more than one help document has been created, a list of documents displays 

in the browser window. 

 If no help document has been created, an HTTP 404 (Page Not Found) error 

displays in the new browser window. 

 

Enabling Help for Oracle E-Business 

To implement and use context-sensitive help for Oracle E-Business with the application, you will 

perform six procedures: 

 Create a template for use with Oracle E-Business. 

 Publish the website. 

 Specify a designated author account for Oracle E-Business. 

 Record an Oracle E-Business document with the application and republish the 

website to make the document available for context-sensitive help. 

 Modify an Oracle E-Business end user account for use with context-sensitive 

help. 

 Request context-sensitive help from Oracle E-Business. 

 



Chapter 18: Creating Online Help 

 

Hewlett Packard Enterprise Develoment LP 455 

 

 

Creating a Template for Use with Oracle E-Business 

Context-sensitive help for Oracle E-Business is driven by context identifiers. Each screen in 

Oracle has a unique context identifier. Context identifiers are gathered collectively for a procedure 

and when inserted into the transaction code property of a document, will call context-specific help 

on the screen in which the end user is working. 

Transaction code is a term and property used to identify a process, and it is used in two separate 

instances: 

 Transaction code property: The website matches this document property to 

the associated Oracle screen when a call for help is made from Oracle. 

 Transaction code block: In a document, this block displays the transaction 

code pertaining to the document created. For Oracle documents, it is 

recommended that the display of this block be disabled within the template. 

 

1. In the application, create a template. 

 
A project administrator typically creates and customizes templates. For more 

information, refer to Creating Online Help (on page 423). 

2. Select the Blocks tab. 

3. Select Purpose. 

4. Turn off the display of the Transaction Code block in a document. 

5. Select the Properties tab. 

6. Ensure the transaction code property is selected. 

7. Select FILE > SAVE. 

8. Click the Publications tab. 

9. Select Website. 
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10. Select Transaction Code(s) from the Build from Property field. 

11. Select Comma(,) from the Multiple Values Separated By field. 

12. Select FILE > SAVE. 
 

Publishing the Website 

The website must be published to a web server that is accessible by Oracle E-Business before 

authors can record documents. As part of website publishing, you will also generate quick launch 

pages to enable communication between the website and Oracle E-Business. 

For information on publishing the website, Publishing the Website (on page 414). 

 

Specifying an Author Account for Oracle E-Business 

The Oracle system administrator must create a designated author account in Oracle E-Business. 

This account communicates with the website to generate the screen data necessary to request help 

from Oracle E-Business. 

You must log into Oracle E-Business using the designated author account in order to record help-

ready documents. Context-sensitive help is not available when logged via the author account. 

For more information on creating user accounts, refer to the Oracle E-Business documentation. 

1. On the website server, locate the csh_capture_context.html file. For example: 

http://[webservername]/[website name]/website/xml/assets/csh_capture_context.html. 

2. Copy the URL, including the filename. 

 

3. Paste the URL, including the filename, into the Applications Web Help Agent profile setting 

User column for the author in Oracle E-Business. 

 
For more information on setting system profile values, refer to the Oracle E-Business 

documentation. 

4. Save the author settings. 
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Recording an Oracle E-Business Document 

1. Log into Oracle E-Business using the author account created in Specifying an Author Account 

for Oracle E-Business (on page 456). 

2. Create a new document using the template created in Creating a Template for Use with Oracle 

E-Business (on page 455). 

3. Perform one of the following options: 

If You Want To Then 

Record and edit the document and 

gather context identifiers later 

Record and edit the document using the Editor 

and the procedures described in the Creating 

Content user manual. 

Go to Step 4. 

Record the document and gather 

context identifiers as you complete the 

document 

Record the document, pausing the recorder after 

each screen recorded. For more information on 

recording, editing, and using the recorder 

toolbar, refer to Recording Procedural Content 

(on page 51), Editing and Formatting: Basics (on 

page 91), Editing and Formatting: Procedural 

Content (see "Specifying Simulation Editor 

Options" on page 40). 

Click the help icon for each screen. 

 
This will open a new browser window 

containing the context identifier for 

the screen. 

Repeat until context identifiers for all screens 

within the procedure have been collected. 

Go to Step 6. 

4. After you are finished recording, revisit the Oracle screens and click on the help icon on each 

screen captured in the recorded document. 

 
This will open a new browser window containing the context identifier for 

the screen. 
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5. Repeat Step 4 until context identifiers for all screens within the procedure have been 

collected. 

 

6. Highlight and copy the context identifier string from the browser window. 

7. Open the document created in Step 2. 

8. Select FILE > PROPERTIES. 

9. Select Properties. 

 

10. Paste the context identifier string into the Transaction Code property of the document. 

11. Click OK. 

12. Save the document. 

13. Add the document to the website using the procedures described in Building a Website (on 

page 393). 

14. Publish the document using the procedures described in Publishing Content. 

15. Republish the website using the procedures described in the Building a Website (on page 

393). 
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When the website is republished, the document will be available for the end user via 

the help icon in Oracle. 

 

Perform the following optional configuration steps to create a link to Oracle Help from the 

website: 

16. Navigate to the website. For example: http://[webservername]/[web\-site 

name]/website/xml/assets. 

17. Locate the .Website.xslt file. 

18. Create a backup of the file. 

19. Open the original file in Notepad or an XML Editor. 

20. Edit the following variables: 

Field Description 

<xsl:variable name="sys\-

temHelpLocation" 

select="''"/> 

The URL for the default help in Oracle. 

Example: <xsl:variable name="systemHelpLo\-

cation" 

select="'http://acmeoraclehelp.com/index.htm'"/> 

<xsl:variable name="sys\-

temHelpTitle" select="''"/> 

The Help title that displays to an end user. 

Example: <xsl:variable name="systemHelpTi\-tle" 

select="'Oracle Help'"/> 

21. Select FILE > SAVE. 
 

Modifying Oracle E-Business End User Accounts for Context-Sensitive Help 

You must modify all existing user accounts to enable context-sensitive help. An Oracle 

administrator creates end user accounts based on the needs of the company. While there are 

several options for defining system profile values for existing users, this procedure demonstrates 

defining a system profile value for an individual user. 

1. Log into Oracle as a system administrator. 
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2. Navigate to the system profile values. 

 

3. Define system profile values for the user. 

 
Refer to the Oracle documentation for information about the System Profile Values 

Site, Application, Responsibility, and User, and to choose the system profile value that 

is most appropriate for your end user community. If you are using multiple locales on 

the website, you must specify the account by User. 

4. On the website server, locate the redirect.html file. For example: http://[webserver 

name]/[website name]/website/xml/assets/redirect.html. 

5. Copy the URL, including the filename. 

 

6. Perform one of the following options: 

If You Want To Then 

Create an end user account for Oracle 

E-Business 12 

Paste the URL into the Applications Web Help 

Agent profile setting User column for the end 

user in Oracle. 

Create an end user account for Oracle 

E-Business 11.5 

Paste the URL into the Applications Web Help 

Agent profile setting User column for the end 

user in Oracle. 

Append ?rwd=true to the end of the URL string. 

Example: http://[webserver name]/[website 

name]/website/xml/assets/redi\-

rect.html?rwd=true. 

 

 
For more information on setting system profile values, refer to the Oracle documentation. 

7. Save the end user settings. 
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Requesting Help from Oracle E-Business 

1. Log into Oracle E-Business as an end user. 

2. Navigate to the desired screen. 

 

3. Click the help icon for a screen. 

 
The website searches for available help for the screen based on the publication settings 

specified in the template and the context identifier specified in the document. 

4. Oracle E-Business will open a new browser window displaying the following potential help 

options: 

 If a single help document has been created, the document displays in the new 

browser window. 

 If more than one help document has been created, a list of documents displays 

in the browser window. 

 If no help document has been created, an HTTP 404 (Page Not Found) error 

displays in the new browser window. 
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Context-Sensitive Help for Siebel 

Context-sensitive help allows you to provide end users with quick and convenient access to help 

via an online performance support system. End users request help from the Server via a direct link 

in Siebel. 

To implement and use context-sensitive help for Siebel you will perform three procedures: 

 Create a custom help menu in Siebel. 

 Record a Siebel document with the application and make this document 

available for context-sensitive help. 

 Request help from Siebel. 

For information on supported versions of Siebel, refer to the Technical Specifications.  

 

Creating a Siebel Custom Menu and Publishing the Website 

Obtaining the Siebel Custom Menu eScripts 

Download the Siebel Custom Menu eScripts from the Product Support Center. The following 

scripts were authored by ANCILE for use only by customers and partners. These scripts contain 

JavaScript code that redirects Siebel's existing Help link to a help page created with the 

application. 

 Service_PreCanInvokeMethod_Server.txt 

 ServicePreInvokeMethod_Browser.txt 

 

Creating a Custom Menu In Siebel 

 
We recommend creating a custom menu in the test environment and migrating the 

changes to the production environment after the changes have been complied and 

tested. 

 
All actions within this procedure are performed in Siebel using Siebel Tools. For 

information on supported versions of Siebel, refer to the Technical Specifications. 

1. Create a new project to house changes needed to add a context-sensitive help link from Siebel 

to the website. Be sure to include a name and description for the project. 
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2. Check out the context-sensitive help project. 

3. Check out the menu used in the target application. 

4. Create a new symbolic string for the menu item using the following values: 

 
A symbolic string must be created for each locale. 

Field Description 

Name Enter a name for the symbolic string. 

Current String Value Enter the string value. 

Project Enter the project name created in Step 1. 

Definition Enter a definition. 

Comment Enter any amplifying information about the string. 

5. Save the string. 

6. Create a new business service using the following values: 

Field Description 

Name Enter a name for the service. 

Project Enter the project name created in Step 1. 

Class Enter the class. 

Comment Enter any amplifying information about the service. 

7. Save the service. 

8. Create a new Business Service Method called HP ART. 

9. Right-click on the business service you created in Step 6. 

10. Select Edit Server Scripts. 

11. Select eScript. 

12. Paste the provided script into the Service_PreCanInvokeMethod method. 

13. Save the server script. 

14. Right-click on the business service you created in Step 6. 

15. Select Edit Browser Scripts. 

16. Select eScript. 
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17. Paste the provided script into the Server_PreInvoke method. 

18. Replace [Server Name] with the URL of the redirect.html page on the website. 

19. Save the browser script. 

20. Using Siebel Tools, create a new command using the following values: 

Field Description 

Name Enter a name for the command. 

Project Enter the project name you created in Step 1. 

Business Service Enter the business service you created in Step 6. 

Display Name Enter a display name for the command. 

Show Pop-up Ensure the Show Pop-up box is selected. 

21. Save the command. 

22. Create a new menu item for the menu project using the following values: 

Field Description 

Name Enter a name for the menu item. 

Caption Enter the string reference created in Step 4. 

Command Enter the command created in Step 20. 

Position Select the appropriate position. 

23. Save the menu project. 

24. Compile, test, and migrate the changes to the production environment. 
 

Publishing the Website 

The website must be published to a web server that is accessible by Siebel before authors can 

record documents. As part of website publishing, you will also generate quick launch pages to 

enable communication between the website and Siebel. 

For information on publishing the website, refer to Publishing the Website (on page 414). 

For information on supported versions of Siebel, refer to the Technical Specifications. 
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Creating Content and Requesting Help 

Recording and Publishing a Siebel Document 

1. Record a Siebel document using the procedures described in Recording Procedural Content 

(on page 51). 

 
The recorder will automatically gather the view names for each screen as the author 

records the document and hard code the names into the document meta data. 

2. Edit the document using the procedures described in Editing and Formatting: Basics (on page 

91) and Editing and Formatting: Procedural Content (on page 105). 

3. Publish the document to the website using the procedures described in Building a Website (on 

page 393). 

4. Republish the website using the procedures described in Publishing the Website (on page 

414). 
 

Requesting Help From Siebel 

1. Log into Siebel as an end user. 

2. Navigate to the desired screen. 

 

3. Select HELP > [HELP NAME]. 

 
The help name is specified when you create the help menu option. For more 

information, refer to Creating a Custom Menu In Siebel 8 (see "Creating a Custom 

Menu In Siebel" on page 462). 

4. Siebel will open a new browser window displaying the following potential help options: 

 If a single help document has been created, the document displays in the new 

browser window. 

 If more than one help document has been created, a list of documents displays 

in the browser window. 
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 If no help document has been created, an HTTP 404 (Page Not Found) error 

displays in the new browser window. 

1. Choose from the following options: 

If You Want To Then 

Select a help document Click on the hyperlink for the document you 

wish to view. 

Access the Siebel Help Center Click Siebel Help in the upper left. 

Return to Siebel Close the browser window. 
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Configuring PeopleSoft for Use with Context-Sensitive Help 

Context-sensitive help allows you to provide end users with quick and convenient access to help 

via an online performance support system. End users request help from the server via a direct link 

in the PeopleSoft application. For information on supported versions of PeopleSoft, refer to the 

Technical Specifications. 

 

Creating a Template for Use with PeopleSoft 

Context-sensitive help for PeopleSoft is driven by context identifiers. Each screen in PeopleSoft 

has a unique context identifier and these are gathered collectively for a procedure and 

automatically inserted into the transaction code property of a document. Context identifiers are 

used to call context-specific help on the screen in which the end user is working. 

Transaction code is a term and property used to identify a process, and it is used in two separate 

instances: 

 Transaction code property: The server matches this document property to 

the associated PeopleSoft screen when a call for help is made from PeopleSoft 

. 

 Transaction code block: In a document, this block displays the transaction 

code pertaining to the document created. 

 

1. In the application, create a template. 

 
A project administrator typically creates and customizes templates. For more 

information, refer to Using Author Templates (on page 317). 

2. Select the Blocks tab. 
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3. Select Purpose. 

4. Turn off the display of the Transaction Code block in a document. 

5. Select the Properties tab. 

6. Enable the Transaction Code property. 

7. Select FILE > SAVE. 

8. Click the Publications tab. 

9. Select Website. 

10. Select Transaction Code(s) from the Build from Property field. 

11. Select Comma(,) from the Multiple Values Separated By field. 

12. Select FILE > SAVE. 
 

Publishing the Website 

As part of website publishing, you will also generate quick launch pages to enable communication 

between the website and PeopleSoft. For information on publishing the website, refer to 

Publishing the Website (on page 414). 

 

Recording a PeopleSoft Document 

1. Record a document using the procedures described in Recording Procedural Content (on page 

51). 

 
The recorder will automatically gather the view names for each screen as the author 

records the document and will insert the names into the document metadata. 

2. Edit the document using the procedures described in Editing and Formatting: Basics (on page 

91) and Editing and Formatting: Procedural Content (see "Specifying Simulation Editor 

Options" on page 40). 
 

Requesting Help from PeopleSoft 

1. Log into PeopleSoft as an end user. 

2. Navigate to the desired screen. 

3. Click HELP. 
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4. PeopleSoft will open a new browser window displaying the following potential help options: 

 If a single help document has been created, the document displays in the new 

browser window. 

 If more than one help document has been created, a list of documents displays 

in the browser window. 

 If no help document has been created, a zero search result window displays. 

 
If stay-on-top is enabled, the help document remains on top of the Peoplesoft screen. 

Stay-on-top help uses an Active X control to support this functionality. If a user does 

not have Active X installed on the computer, a prompt to install the control is 

displayed. 

1. Choose from the following options: 

If You Want To Then 

Select a help document Click on the hyperlink for the document you 

wish to view. 

Return to PeopleSoft Click Peoplesoft Help. 
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Appendix A: Configuring Java Access 
Bridge for Recording 

When you first record a Java application, the Recorder will detect if Java Access Bridge (JAB) 

has been configured appropriately for the Java application being recorded. If the application 

detects that JAB has not configured properly, a message appears advising that JAB needs to be 

configured for the Java Runtime Environment (JRE). The message may be similar to: "For best 

results recording this application, configure Java Access Bridge into this Java Runtime 

Environment." 

 
The warning message will display the Java Runtime Environment that needs 

configured for the application you are recording. You may want to make note of this 

file in case multiple files display during the configuration process. 

 
 

Configuring Java Access Bridge 

1. Browse to the application's installation folder. 

 
The default location is C:\Program Files (x86)\[applicationdirectory]\ or C:\Program 

Files\[applicationdirectory]. 

2. Locate and double-click the jinitcfg.exe file. 

3. Click Next. 

4. Select the Java Runtime Environment used to run the Java application and the corresponding 

JAB version. 

 
If the JRE path you need to configure is not listed, you may also manually locate the 

JRE (if it is in a self-contained application) by clicking the Browse button. 

5. Select Always replace existing files. 

6. Click Next. 

7. Click Next. 
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8. Click Finish after the configuration is complete. 

9. Start the recording process again. 
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Glossary of Terms 

Annotation 
A note added to content by another author or a reviewer. 

Annotation Set 
The collection of reviewer notes on a particular document. 

Application Mode 
One of three available recording modes. Allows the author to capture actions in one target 

application. 

Assessment Page 
A page in a course that consists of questions, answers, and optional images. Assessment pages can 

be used as self-tests throughout the course or can be inserted into an assessment section for 

tracking via a Learning Management System (LMS). 

Assessment Section 
Part of a course that records an end user's answers and sends results to a Learning Management 

System (LMS) for tracking. 

Author 
A user who creates or edits content. 

Auto Playback 
A simulation playback mode that automatically runs the lesson without user interaction. In this 

mode, the application performs the actions to complete the simulation with the user as an 

observer. 

Batch 
An operation performed on more than one document (for example, the batch publishing of 

content). 

Block 
A content element containing the information required to render a discrete item in all available 

views. Types include step, note, free text, and the header and footer areas. A Free Text Block 

contains user-defined formatted text. A Note Block contains notation text and a single pre-defined 
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icon graphic. A Step Block contains the information that describes a discrete action, including the 

screen image for the action. 

Branch 
An alternate sequence of steps used to accomplish a secondary flow within a course or simulation. 

Branching Table 
A table inserted into the procedural section of a document to direct users to make a decision 

regarding going to other steps or options. 

Callouts 
Numbered objects or notes that allow you to bring attention to specific controls and regions on 

screen images within a published document. 

Configuration Information 
A section within a document that contains configuration information and can be output as a 

publication. 

Course 
A collection of informational content and optional assessment tools such as multiple choice, drag-

and-drop, and fill-in-the-blank. 

Course Homepage 
A web page generated that contains the link to the published course. 

Course Package 
A container for multiple content files output to a single master SCORM package. 

Cue Card 
A publication type created from the application's content and typically used in context-sensitive 

help. 

Definition 
Within the glossary functionality, amplifying information about a term used in the target 

application. A term can have multiple definitions based on the context of the document. 

Desktop Mode 
One of three available recording modes. Allows the author to capture the complete desktop and 

actions across a series of applications. 

Document 
A set of instructions, images, and associated objects intended for use as online help or 

performance support. 

The XML content produced by the application as a result of recording author actions in a target 

application; includes the document, simulation, and screenflow views. 
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Drag and Drop Action 
A simulation action indicating mouse input is required. This action is used to identify a click, 

drag, and release mouse action required to navigate to the next step in a simulation or to answer a 

question in a drag-and-drop assessment page within a course. 

Edit Action 
A simulation action indicating text input is required. This action is used to identify a string of 

keyboard input (text input) required to navigate to the next step in a simulation. 

Editor 
The application used to create, record, and modify documents, simulations, and courses. 

End User 
Any person who accesses performance support content through a website. 

Express Publish 
The process of publishing only those documents that have been modified since the last publish 

operation. 

Flash 
A file format developed by Adobe; this output type is used to display content within courses and 

simulations. 

Glossary 
The function that enables the management of terms and definitions. Also, the name of an ANCILE 

Info Pak application.  

Guided Help 
Published HTML content designed to be used during task execution. 

Hint 
The nonessential data (for example, a user name) required to complete a simulation. Hints can be 

provided to the student during playback of the simulation. 

Hotspot 
A resizable box surrounding an action location in a simulation or course. 

Inbox 
Folder location containing source content to be published or leveraged. 

Key Action 
A simulation action indicating keyboard input. This action is used to identify a specific keystroke 

or sequence of keystrokes required to navigate to the next step in a simulation. 

Lesson, Course 
A component of an eLearning course. A lesson contains pages and is typically used as an 

introduction to a section. 
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Lesson, Simulation 
The output of a recording and subsequent editing that simulates a task in a software application. 

Link 
A hyperlink within a document, a course, or a website page. 

Outbox 
Folder location containing content that has been published. 

Overview 
The introduction section of a document that contains purpose, trigger, prerequisites, menu paths, 

and helpful hints; included in Work Instructions, Quick References, and Cue Cards after 

publishing. 

Page 
A page contains the content of the eLearning course. Page layout is governed by the use of 

stencils. There are two different page types available: standard content and assessment.  

Passing Grade 
Specifies the minimum percentage of correct responses that the user must achieve to pass the test. 

Phrase 
A group of culture-specific boilerplate text items that are placed into a content block by default. 

Playback 
The interactive output mode of a simulation. Simulator supports four types of playback: Standard 

Tutorial, Auto Playback Tutorial, Self-Test Tutorial, and Assessment Tutorial. 

Preloader 
A performance-enhancing feature that enables preloading of the simulation or course on the target 

computer before the content begins to execute. 

Properties 
Metadata such as document title, owner, and version used to describe content. In addition to the 

standard built-in properties, custom properties may be created. 

Publication 
Content that is outputted to a publication; a publication is meant to be consumed by an end user. 

Publish Format 
The output format of published content. Available formats include Flash simulations and PDF. 

Publish Type 
The output type of published content. Available types include work instruction, cue card, and 

simulation. 

Quick Reference 
A type of procedural publication often used in end user training. 
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Quick Start Panel 
An interface feature of the Editor that provides expedited access to the recording and editing 

functions. 

Recorder 
The functionality that captures author actions in one or more target applications to produce a 

formatted document, simulation, and screenflow. 

Redo 
An editing option that allows the author to reverse the last Undo action performed. 

Resources 
Links or documents that can be added to a course to provide additional information. 

Screenflow 
A diagram representing the flow of steps in a task. 

Section 
A section represents a single, contiguous group of blocks in a document. In the document 

arrangement, a block must belong to a section. Each section element consists of a sequential array 

of cross-references to the available blocks. Similar items within a document can be grouped into 

discrete sections, and publications can include/exclude particular sections. A section cannot 

contain another section. 

Self-Test 
A simulation playback mode that includes no instructions, hotspot objects, notes, audio playback, 

or step status bar information. In this playback mode, the user is encouraged to remember and 

perform all necessary steps for testing purposes. 

Simulation 
A set of instructions, images, and associated objects intended for export as interactive output. 

Simulation Assessment 
A simulation playback mode with no instructions, hotspot objects, notes, audio playback, or step 

status bar information. In this mode, the user is encouraged to answer questions regarding material 

and to remember and perform all necessary simulation steps for testing and grading purposes. 

Skin 
The skin files define the style of the interface elements. Using skins, you can change the colors of 

the interface areas, set new fonts properties, use different images for icons in the interface, etc. 

Stencil 
A layout tool governing the design of a course page. 

Step 
One of a series of actions that collectively form the procedure captured in the document or 

simulation. 
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Student Guide 
A collection of concepts, procedures, and exercises related to a series of tasks or a process. 

Style 
A group of formatting options that relate to paragraphs or character text.  

Task Pane 
The area of the editing application that provides access to items such as annotations, document 

layout, and simulation steps. 

Template 
A set of document, simulation, and course options that control formatting and content. Each 

content file is created from a template which determines the basic structure for content and 

specifies the content settings. The template also specifies information about the types and formats 

of content that can be published. 

Term 
The name of a field or option in the target application being documented. A term can have one or 

more definitions. 

Testing Information 
A section that contains testing scenarios and history, and can be output as a publication. 

Text to Speech (TTS) 
Converting text into voice output using speech synthesis techniques. 

Tooltip 
A type of note that displays during simulation playback when the user hovers over the specified 

area. 

Undo 
An editing option that allow the author to reverse the last action performed. Undo caches up to 

twenty steps. 

User 
The consumer of final published content via online help or the website. 

View 
A way of displaying content to an author or user; there are four views of  content available: 

document, simulation, screenflow, and course. 

Voice Over 
An option allowing for the inclusion of an audio file during simulation or course playback. 

Website 
A collection of performance support materials such as procedures, simulations, and courses that 

are available to end users via a web browser. 
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Work Instruction 
A type of content output typically used in user training that contains end user procedural 

information, including screen shots and field description tables. 

XML 
Extensible Markup Language; the source format of application content. 

XSL 
Extensible Stylesheet Language; the file used to control the format of the content displayed in an 

XML file. 
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close • 103 

printing • 102 

searching • 263 
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E 
edit block • 149, 150 

editing • 92, 96, 106, 115, 122, 128, 141, 

149, 150, 172, 236 

actions • 128 

introduction • 92, 106, 172 

note text • 122 

notes • 122 

redo • 63, 96 

standard simulation objects • 115 

steps • 115 

undo • 63, 96 

editor 

exit • 28 
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create • 33 

embedding • 226 

enable • 19 
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generate • 165 

tasks • 165 

user-specific data • 165 
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exit • 28 

editor • 28 

F 
file • 103 

close • 103 

flexible stencils • 182 

font size • 153 

modifying • 153 

format text • 186 

formatting • 92, 106, 172 

introduction • 92, 106, 172 

note • 122, 124, 125 

G 
general properties • 116 
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Help • 27 
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action • 112 
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examples • 143 
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installation • 9 
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instert steps from simulation • 108 
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action • 110 
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