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Over view  of  t he QALoad  Conduct or  
Use the QALoad Conductor to configure, run, and monitor a load test that ut i l izes the scripts created in  the 
Script Development Workbench. The Conductor controls the QALoad Players and manages tests whi le they 
are running. When the Conductor process stops for any reason during a load test, the associated Player 
processes automatical ly terminate. 

The primary windows in the Conductor are: 

!  Conductor Start Page - This is the page that appears when you first open the Conductor. From the Start Page, you 
can open an existing Conductor session, create a new session, configure the Conductor, or open the Test 
Configuration Wizard.  

Once you create or open a session, the main Conductor window appears. The Conductor's in terface is 
dynamic — it  changes depending whether you are sett ing up a test or running a test.  

!  Test Setup Interface - This is the first window that appears when you open a session in the Conductor. Before 
running a test, you must set up general test options, configure Player workstations, assign compiled test scripts to 
Players, and set up monitoring options. You then save the test setup in a file called a session ID. Once you have 
configured and saved a test session ID, you can reuse it without re-entering any test information. 

The Test Setup Interface presents two ways you can enter in formation about your test:  

!  The Visual Designer is the Conductor's main window. The Visual Designer graphical ly displays 
a col lect ion of icons and nodes that represent your test session. Use th is to enter in formation 
about your test and set up the machines and scripts for the test. 

!  The Grid View window presents another way to perform these funct ions. The Grid View is a 
dockable window that contains two tabs in  which you can enter the in formation for your test 
session.  

!  Runtime Window - While a test is running, the Conductor interface changes to the Runtime Window, which facilitates 
monitoring of individual machines and Players, and displays real-time test results. You can view default graphs of 
performance data that are created for you by the Conductor and create custom graphs based on the data being 
collected during the test. You can save custom graph layouts in the session ID file and reuse them in future tests. 
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Using  t he Conduct or  St ar t  Page 
When you first  start  the Conductor, the Start  Page displays. This provides a concise select ion of opt ions to 
help you start  defin ing or modifying a Conductor session.  

From the Start  Page, you can perform the fol lowing tasks: 

Recent  Session 
In  the Recent Sessions sect ion, you can: 

!  Create a new test session 

!  Open an existing session 

Tasks 
In  the Tasks sect ion, you can: 

!  Open the Test Configuration Wizard 

!  Create monitoring tasks 

!  Edit monitoring tasks 

!  Discover and verify Player machines 

!  Configure the Conductor session options 

Help 
Use the select ions in t  he Help sect ion to access the QALoad onl ine help and Compuware's FrontLine 
website. 

Note: If you select the Don't  show this panel again option, you'll skip the start page and go directly to 
the Conductor Session Startup dialog box when you open the Conductor. To display the Start Page again 
when you open the Conductor, you must open a session, go to Tools>Opt ions>Startup, and select Show 
Start  Page. 
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About  Set t i ng  Up  a Test  
When you set up a load test, you set opt ions related to general Conductor behavior as well  as in formation 
about your specific test environment. Before you can successful ly set up a load test, you must have 
recorded and compiled one or more test scripts. For in formation about recording a test script , see 
Developing Scripts. 

Determining General Conductor Behavior 
General Conductor opt ions you set are appl icable for al l  tests run unt i l  you change the opt ions. Conductor 
opt ions are related to the fol lowing: 

!  Viewing options for real-time results 

!  Global Player options 

!  Player machine performance data 

!  Options for runtime reporting 

!  And more... 

All of the above information, and more, can be configured on the Conductor's Options dialog box. 

Set t ing Up a Specific Test  Session 
To prepare the Conductor for a specific test, save information and parameters specific to that test in to a 
reusable session ID fi le (.id). You must enter the fol lowing types of in formation to set up a test 's session ID 
fi le: 

!  General information about the test such as a description, the size of the database, the length of the test, and any 
notes or comments 

!  Information about the test script(s) included in the test, including script name, middleware/protocol type, pacing, 
whether to include external data, and so on 

!  Information about the workstations where the QALoad Players reside, including which script is assigned to each 
workstation, how many virtual users are assigned to each workstation, the machine name, and so on 

All of the above information can be entered and saved when you set up a test from the Conductor's main 
window or by using the Test Configurat ion Wizard. Once you open the new session in  the Conductor, you 
can do the fol lowing: 

!  (Optional) configuration for server monitoring 

!  (Optional) integration with other Compuware products 

Generat ing Random Number Seeds 
Random number seeds are used to in ject random delays in  script  execut ion for each load test. The seed (or 
value) is automatical ly generated by QALoad. The random value used with in the end of t ransact ion 
funct ion is used to generate the pacing t ime. The Player uses a system-generated sequence of numbers, so 
that each virtual user (VU) has i ts own seed value. 
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Set t ing  Up  a Test  Session  
You can enter al l  the in formation necessary for your session ID fi le in  the Conductor using one of the 
fol lowing methods: 

!  Grid View window 

!  Visual Designer 

!  Test Configuration Wizard 
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Con f igur ing  t he Conduct or  
There are several sett ings for the Conductor that you should review before beginning your load test. 

To set  Conduct or  session opt ions t hat  are not  speci f ic t o one t est : 

1. Do one of the following: 

!  From the Conductor Start  Page, cl ick Session  Opt ions in  the Tasks area. 

OR 

!  With a session open, cl ick Tools>Opt ions. 

2. On the Options dialog box, set options related to post-test activity, warnings and prompts, runtime grids, timing 
settings, interface refresh intervals, Conductor/Player communications, monitoring intervals, and more. For detailed 
descriptions of the options that are available, see Options dialog box.  

3. When you are finished, click OK to save your changes. Any options you set apply to all tests until you change them. 
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Check ing  Out  Vi r t ual  User  Licenses 
If you are l icensed to run mult iple copies of the Conductor, for example so different work groups have 
access to QALoad, you can check out virtual user l icenses before running a load test to ensure that enough 
are avai lable for your test run.  

If you do not choose to check out your l icenses before start ing a test, QALoad prompts you after you start  
the test and attempts to check out the appropriate number of l icenses. We recommend that you check 
your l icenses out manually before start ing so you can be sure you have enough virtual users avai lable 
before beginning your test run. 

To check  out  vi r t ual  user  l icenses: 

1. From the Conductor menu, select Tools>Licensing. The License Information dialog box appears.  

!  If you are l icensed for concurrent l icensing (mult iple Conductors) the Conductor 
queries your l icense server to determine how many l icenses are current ly avai lable, and 
returns the results to th is dialog box. Go to step 2. 

!  If you have a node-locked l icense (a single Conductor), then most of the opt ions on 
th is dialog box are unavai lable, as you wil l  not need to, or be able to, check out virtual 
user l icenses. Al l  virtual users for which you are l icensed are avai lable only to th is 
Conductor. Cl ick OK to return to your test setup. 

2. In the Licensing Operations area, select Check Out Virtual User Licenses, then type how many virtual user 
licenses you want to check out in the Number of Licenses field. 

3. Click Check Out. The licenses are checked out to your Conductor, and are unavailable to any other Conductor 
workstations on the network. 

When you are done using your l icensed virtual users, check them back in  so they are once again avai lable 
to other Conductor workstat ions on your network. 

To check  in  vi r t ual  user  l icenses: 

1. From the Conductor menu, choose Tools>Licensing. The License Information dialog box appears.  

2. If you have licenses checked out, the Check in Virtual User License option is automatically selected for you. 

3. Click Check In. The licenses are made available to other Conductor workstations on the network. 
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Runn ing  t he Conduct or  f r om  t he Com m and  Line 
The fol lowing procedure describes how to run the Conductor from the command l ine. 

To st ar t  t he Conduct or  f rom  t he com m and prom pt : 

Type conductor <session_file_name> /l /e /a /t  

The appl icable parameters are defined in the fol lowing table. 

Param eter Def in i t i on  

/l (Opt ional)  Creates a log fi le showing error messages 
and test status. 

/e (Opt ional)  Exits the Conductor when the test 
completes. 

/a (Optional) Launches Analyze when the test 
completes. 

/t (Opt ional)  Executes Conductor at a set t ime. Val id 
t ime formats are /txx:xx or 
/txx/xx/xx /txx:xx. 

 

The Conductor start  page appears.  
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Set t ing  Up  a Test  

Creat ing a New Session  

To creat e a new  load t est  session: 

1. Do one of the following: 

!  From the Start  page, cl ick New . 

!  From the Visual Designer window, cl ick Fi l e>New . A confirmation dialog box prompts 
you to Save or discard changes to your current session. 

The Create New Session dialog box appears. 

2. In the Name field, type a name for the new session. 

3. (Optional) In the Description field, type a description for the new session. 

4. (Optional) Select Launch  Test  Con f igurat ion  Wizard to start  the Test Configurat ion Wizard, 
which walks you through creat ing a load test session. If you do not select th is opt ion, the new test session 
opens in Conductor's Visual Designer, where you can manually configure the load test session. 

 

Opening an Exist ing Session 
When you open the Conductor, the Conductor Start  Page appears. Use these procedures to open an 
exist ing session. 

Note: If you choose not to display this page, the Conductor opens to the Visual Designer window. You can 
choose to show the Start Page again in the Startup page of the Conductor Sessions Options dialog box. 

To creat e a new  session  f rom  t he Conduct or  St ar t  page: 

1. Do one of the following: 

!  In  the Recent Sessions area, cl ick the name of the session to open. 

OR 

!  Click Open  Session , then select the name of the appropriate saved session, and cl ick Open . 

2. The Conductor's Visual Designer opens with the session you selected displayed. You can make any changes to the 
session or run the load test. 

To open an exist ing  session in  t he Visual  Designer : 

1. From the Visual Designer window, click File>Open. A confirmation dialog box prompts you to Save or discard 
changes to your current session.  

2. Select the name of the appropriate saved session, and click Open. The selected test session opens in Conductor's 
Visual Designer, where you can manually configure the load test session. 
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About  the Test  Configurat ion Wizard 
The Test Configurat ion Wizard consists of a series of screens that guide you th rough the process of sett ing 
up a load test. Use the Test Configurat ion Wizard to select scripts, configure the script 's transact ion 
sett ings, select players or groups to assign to the test, and specify desired Virtual User configurat ions. You 
also can add scripts to an exist ing session using the Test Configurat ion Wizard. Once you setup your load 
test with the Test Configurat ion Wizard, you can run the test immediately without addit ional 
configurat ion. 

You can use the Test Configurat ion Wizard to: 

Create a New Test Session Using the Test Configurat ion Wizard 

Modifying an Exist ing Test Session Using the Test Configurat ion Wizard 

 

Creat ing a Test  Session Using the Test  Configurat ion Wizard 
The Test Configurat ion Wizard guides you through the process of sett ing up a load test. Use the series of 
screens in  the Test Configurat ion Wizard to: 

1. Select scripts 

2. Configure the script's transaction settings 

3. Select players or groups to assign to the test 

4. Specify desired Virtual User configurations  

You can open the Test Configurat ion Wizard from the Conductor Start  page or with a test session open in 
the Conductor.  

To access t he Test  Conf igurat ion W izard f rom  t he Conduct or  St ar t  page: 

1. Do one of the following: 

!  In  the Tasks area, cl ick Test  Con f igurat ion  Wizard to open the first  screen of the 
wizard. 

OR 

!  In  the Recent Sessions area, cl ick New  to open the Create New Session dialog box. Select the 
Launch  Test  Con f igurat ion  Wizard opt ion.  

Note: If you do not select the Launch Test Configuration Wizard option, the new test session 
opens in Conductor's Visual Designer, where you can manually configure the load test session. 

2. In the Name field, type a name for the new session. 

3. (Optional) In the Description field, type a description for the new session. 

4. Click Next to start configuration of your test session. 

To access t he Test  Conf igurat ion W izard w i t h a session open in Conduct or : 

Cl ick Fi l e>New , then fol low steps 2 through 4 above. 
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Modifying a Test  Session Using the Test  Configurat ion Wizard 
You can use the Test Configurat ion Wizard to add a script  to an open test session by fol lowing the steps for 
each screen in the Test Configurat ion Wizard. 

To st ar t  t he process of  adding a scr ip t  using t he Test  Conf igurat ion W izard: 

On the toolbar, cl ick the Test  Con f igurat ion  Wizard button. The Select Script  to Configure dialog box 
appears.  

 

Ant icipat ing Error Condit ions 
You know before beginning a load test that errors are a possibi l i ty, but you may not always want them to 
stop your progress during test ing.  

QALoad helps ant icipate error condit ions and determine, before running the test, how Players react to non-
fatal errors. By sett ing one opt ion, you can instruct a Player to cont inue as i f no error was encountered, 
stop running immediately, or restart  at  the beginning of the transact ion. 

Note: When the Conductor process stops for any reason during a load test, the associated Players 
automatically terminate. 

 

 

Managing Large Amounts of Test  Data 
With a large number of virtual users, i t  is possible to create a t im ing fi le contain ing hundreds of thousands 
of t im ing records for each checkpoint. Attempting to graph just a few of those checkpoints can slow down 
QALoad Analyze considerably.  

For example, i f a t im ing fi le contained 250,000 t im ing records for each data point, at tempting to graph 
even one checkpoint means that QALoad Analyze must paint 250,000 lines on the graph. Since most 
monitors only have 1024 pixels across the screen, the 250,000 data points would most ly be plotted atop 
one another and the results would be unreadable. 

Now imagine attempting to graph the data of several data points of that size. The sheer amount of data 
could easi ly overwhelm a workstat ion. And every t ime you move the window, resize the window, or right-
cl ick on the graph, QALoad Analyze has to re-draw the graph. You could conceivably spend enormous 
amounts of t ime simply attempting to graph data. 

To make large amounts of data manageable, QALoad Analyze provides an opt ion that al lows you to 
determine how to th in data. That is, how to determ ine how many data points to plot. 

When your test is running and your Conductor is col lect ing t im ing in formation from your Player 
machines, the sheer amount of data can take up more of your resources than you would l ike to expend. 
Use QALoad's Timing Data Thinning opt ion to th in the amount of t im ing data being transferred back to 
the Conductor during the test so that your test can run longer without stressing your resources.  

 

Removing Used Datapool Records After a Test  
You can remove used datapool records from a Central datapool after a test completes by sett ing the Strip 
Datapool funct ion before you run the test. Use th is funct ion when running a test where you have data in  
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the external datapool that  can only be used once by one virtual user at a t ime. (For example, when running 
transact ions that have unique data constraints.) When act ivated, the Strip Datapool funct ion marks each 
piece of data in  the datapool that is used during your test. When the test is over, the Strip Datapool 
funct ion prompts you to remove the ident i fied used data from the datapool. If you run the test again, only 
new data is used for your subsequent test. 

To use t he St r ip  Dat apool  f unct ion: 

1. With the current test's session ID file open, do one of the following: 

!  Click the script  icon for the appropriate script  to display the Script Propert ies 
panel on the right-hand of the window. In the Ex ternal  Data area, cl ick Cen t ral  
Datapool  field and cl ick the brow se [...] button in  the adjacent field.  

OR 

!  In  Grid View window's Script  Assignm en t  tab, cl ick the brow se [...] button in  the Ex ternal  
Data field of the appropriate script . When the Script Propert ies dialog box appears, cl ick 
Cen t ral  Datapool . 

2. In the Central Datapool dialog box, click the browse [...] button to select the Central Datapool file, then select the 
Strip check box. Click OK. 

3. At the end of your test, a Strip Datapools prompt appears asking if you wish to go to the Strip Datapools screen. 
Click Yes. 

4. The Strip Central Datapool dialog box appears with the Strip option selected. Click the Strip button. 

5. When you are finished, click Close.  

 

Validat ing Scripts in Conductor 
Before running a test, you should run your script  in  a simple test to ensure that i t  runs without errors. You 
can val idate UNIX or Win32 scripts in  the Conductor. 

 

Enabling Expert  User   
When you enable the Expert  User, th is VU col lects more detai led in formation about requests that are made 
while the script  is running. Every main request and subrequest logs the amount of server and network t ime 
used. This helps diagnose why page loads may be taking longer than expected. You enable Expert  User 
from the Conductor, ei ther before or during a load test. Expert  User uses the exist ing custom counter 
support so Conductor can graph the custom counter in formation. Once the load test is complete, you can 
view the data in  Analyze.  

Note: Currently, Expert User capability is provided only for the WWW middleware. 

You can enable the Expert  User: 

Before a load test begins from the Visual Designer or Grid View windows. 

During a load test from the Runtime window. 

To enable Exper t  User  bef ore t he load t est  begins: 

1. Do one of the following: 
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!  Using the Visual  Designer: 

a. Click an individual player machine in the script test setup node to display the Player Properties panel on the 
right-hand side of the window. 

b. Click the browse [...] button in the Expert User Options field to open the Expert User Options dialog box.  

OR 

!  Using the Grid View  window: 

a. Click the Machine Assignment tab.  

b. In the Middleware field for the appropriate WWW script, click the browse [...] button  to display the Expert 
User Options dialog box.  

2. Click Enable Expert User timings. 

3. In the Virtual User Number field, type the Virtual User (VU) number to represent the Expert User. The default VU 
number is zero (0). 

4. Click OK. 

To enable Exper t  User  dur ing t he load t est : 

1. In the Runtime window, click Actions>Set Expert User Options. The Update Expert User Options dialog box 
displays listing all the scripts that support Expert User counters. 

2. Click the scripts in which you want to enable Expert User, then click OK. 

Note: Selecting Expert User Scripts at the top level enables or disables expert user on all associated scripts. 

 

Overview of Expert  User 
Expert User provides an easy, logical guide for dri l l ing down to the root performance problems for 
appl icat ions. It  enables you to break web pages down into their individual components, providing more 
detai led response t ime data. Response t ime for each component is broken into network and server t ime.  

More detai led in formation helps troubleshoot appl icat ion performance problems. The abi l i ty to see t im ing 
fi les on a component level can spot l ight where the majori ty of t ime is being spent. A breakdown of 
network and server t imes per component can ident i fy areas for improvement in  either the network or 
server hardware or configurat ion, or in  appl icat ion performance. 

The main funct ional i ty is provided by a special virtual user (VU). When you enable the Expert User, th is 
VU col lects more detai led in formation about requests that are made while the script  is running. Every 
main request and subrequest logs the amount of server and network t ime used. This helps diagnose why 
page loads may be taking longer than expected. For example, a part icular subrequest, such as css, gif, h tml, 
and so forth, may be taking more t ime to download from the server than other requests. Expert  User data 
can show you th is. It  also can help you determine whether the problem is a network or a server problem.   

You enable Expert  User from the Conductor, ei ther before or during a load test. Expert  User uses the 
exist ing custom counter support so Conductor can graph the custom counter in formation. 

Once the load test is complete, you can view the data in  Analyze. The Analyze Workspace includes an 
Expert User tab, from which you can access detai l  reports and graphs on server and network data. The pre-
defined reports include an Expert User report .  

Note: Currently, Expert User capability is provided only for the WWW middleware. 
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Assigning Scripts to the Test  Session 

Script  Assignment  

Use the Assign  Scripts button on the Visual Designer toolbar, or the Script  Assignm en t  tab in  the Grid 
View window to set up any scripts that have previously been recorded and compiled. Any script  you add 
here is included in your load test, and one virtual user is automatical ly assigned to your script . After sett ing 
up your scripts here, you must assign addit ional virtual users to your script  from the Propert i es pane in the 
Visual Designer, or from the M ach ine Assignm en t  tab in  the Grid View window.  

You can also add scripts to a test session using the Test Configurat ion Wizard. For more in formation, see 
About the Test Configuration Wizard. 

 

Adding a Script  to a Test  

To add a scr ip t  t o a t est  session: 

1. On the Visual Designer toolbar, click Assign Scripts...  

OR 

In the Grid View  window, cl ick the Script  Assignm en t  tab, then cl ick New  in the toolbar. The 
Assign Scripts dialog box displays. 

2. In the Middleware Type box, select your middleware type.  

3. From the list of available scripts that appears in the Available Scripts pane, highlight a script name and click . 
The script is moved to the Selected Scripts pane. 

Note: To select more than one script, hold down the Ctrl key and click then scripts to select, the click . 

To select all scripts in the Available Scripts pane, click . 

4. Click Next to display the script transaction configuration dialog box. 

5. In the Selected Scripts pane, highlight a script.  

6. In the Transactions field, specify the maximum number of transactions that you want each virtual user running this 
script to run. Once a workstation executes the number you specify, script execution continues with the line following the 
End_Transaction command rather than jumping to the beginning of the transaction loop. 

7. Enter a value, in seconds, in the Pacing field. Pacing is the time interval between the start of a transaction and the 
start of the next transaction for each virtual user running a script. 

8. Enter a value in the Sleep Factor % field to specify the percentage of any originally-recorded delay to preserve in 
the script (for example, a value of 80 means preserve 80% of the original delay). Valid values are 0-1000, or Random. The 
default value is 100%. 

9. To apply these options to all scripts in the Selected Scripts pane, click Apply this to all selected scripts. 

10. Click Finish to save your changes to the current session ID file. 

 

Replacing a Script  in a Test  

You can replace a script  in  a test session using the Visual Designer or the Grid View window. Use the 
fol lowing procedure to replace a script  in  a test: 
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To replace a scr ipt  using t he Visual  Designer : 

1. In the Conductor's menu bar, click Actions>Replace Script. The Select Replacement Script dialog box appears. 

2. In the Middleware Type field, select the middleware environment of the replacement script. 

3. Select the replacement script, then click OK. 

4. Assign the script to Player machines, if necessary. 

To replace a scr ipt  using t he Gr id View  w indow : 

1. In the Grid View window, click the Machine Assignment tab. 

2. In the Script Name field, select the script to replace, then select the new script from the drop-down dialog box. 

3. Assign the script to Player machines, if necessary. 

Removing a Script  or a Player from a Test  

To rem ove a scr ipt  f rom  a t est : 

1. Right-click on the script icon for the appropriate script, then select Remove Script. 

2. In the confirmation dialog box, click Remove. 

To rem ove al l  scr ip t s f r om  a t est : 

1. Click Actions>Remove All Scripts. 

2. In the confirmation dialog box, click Remove. 

To rem ove a single Player  f rom  a t est : 

1. In the script test setup node, right-click on the Player to remove, then select Remove Selected. 

2. In the confirmation dialog box, click Remove. 

To rem ove al l  Players f r om  a t est : 

1. Click Actions>Remove All Players/Groups. 

2. In the confirmation dialog box, click Remove. 

 

Assigning Player Machines 

Machine Assignment 

Use the Assign  Players/ Groups button on the Visual Designer toolbar, or use the M ach ine Assignm en t  
tab in  the Grid View window to open the Assign Players/Groups dialog box and assign scripts to specific 
Player workstat ions. You also can drag and drop individual Player machines in  selected script  test setup 
nodes in the Visual Designer. 
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Saving Machine Configurat ions 

After configuring the machines to use for a load test , you can save the machine configurat ion in formation 
in to a configurat ion fi le (.cfg) that can be reused in later tests. This saves you significant t ime sett ing up 
later tests. A configurat ion fi le includes in formation about which machines on the network were used as 
Player machines. You can save mult iple configurat ions under different names. By default , when first  using 
QALoad, the Conductor uses a configurat ion fi le named Default.cfg. The Conductor saves any changes 
to your machine configurat ions to th is fi le unless you save your configurat ion to a new fi le with a different 
name.   

You can open or save .cfg fi les from the M anage Players/ Groups dialog box. The .cfg field always displays 
the act ive configurat ion. 

To creat e a new , em pt y .cf g f i le: 

1. On the Conductor toolbar, click Tools>Manage Players. The Manage Players/Groups dialog box displays. 

2. Click File>New>Player or click the New icon  on the toolbar. 

3. In the Player Information area of the window, type a name in the Machine [hostname or IP] field. 

4. Click File>Save as... On the Save As dialog box, specify a name for the new file and click Save. 

5. Add the necessary Player and agent machines using the fields and buttons on the Manage Players/Groups dialog 
box. The machines you configure are saved automatically to the file you just created. 

To renam e t he cur rent  .cf g f i le: 

1. On the Manage Players/Groups dialog box, click File>Save As... 

2. On the Save As dialog box, specify a name for the new file and click Save. 

3. Make any necessary changes to the configuration. Your changes are saved automatically to the file you just created. 

To open a previously creat ed .cf g  f i le: 

1. On the Manage Players/Groups dialog box, click File>Open. The Open Machine Configuration dialog box displays. 

2. Choose the .cfg file to open. 

Note: The .cfg file only stores information about Player machines. It does not store information specific to a 
test, such as script names or settings. Test specific information is saved in the session ID file. A session ID file 
for a specific test saves the name of the .cfg file associated with that test, and opens it automatically when the 
session ID file is opened. You can change the .cfg file at any time without being concerned about the session 
ID file. 
 

 

Removing a Script  or a Player from a Test  

To rem ove a scr ipt  f rom  a t est : 



Conductor 

17 

1. Right-click on the script icon for the appropriate script, then select Remove Script. 

2. In the confirmation dialog box, click Remove. 

To rem ove al l  scr ip t s f r om  a t est : 

1. Click Actions>Remove All Scripts. 

2. In the confirmation dialog box, click Remove. 

To rem ove a single Player  f rom  a t est : 

1. In the script test setup node, right-click on the Player to remove, then select Remove Selected. 

2. In the confirmation dialog box, click Remove. 

To rem ove al l  Players f r om  a t est : 

1. Click Actions>Remove All Players/Groups. 

2. In the confirmation dialog box, click Remove. 

 

Assigning Scripts to Player Workstat ions  

Once you've added scripts to your test session, you must assign scripts to Player workstat ions and set up 
Virtual User configurat ions. You can use: 

!  the drag and drop method from the Players/Groups panel 

!  the toolbar in the Visual Designer 

!  the Machine Assignment tab in the Grid View  

Note: You cannot run multiple OFS scripts with different Forms Environment settings or different 
Connection Mode settings on the same player. 

To assign p layers using t he drag and drop m et hod f rom  t he Players/ Groups panel : 

Note: Use the Player Properties panel in the Visual Designer to set the optional Expert User options for 
WWW scripts. 

1. Select a machine or group from the list in the Players/Groups window, then drag and drop it into the appropriate 
script test setup node. The Configure All Players/Groups dialog box appears. 

2. Use the arrow keys in each field to set the following options: 

!  Start i ng VUs - Number of Virtual Users to launch the script  on the machine when the 
test begins. 

!  Ending VUs - Number of Virtual Users at the end of the test.  

!  VU increm en t  - Number of virtual users to add at in tervals throughout the test. 

Note: If you add incremental virtual users, you must designate the time interval and the ending 
virtual users. 

!  Tim e in terval  - Time interval at  which incremental virtual users should be added to the test. 

!  M ode -  The test mode for the machine. You can select th read based or process based. 
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3. To use these options for all players and groups in the script, click Assign to all selected players and groups. 

4. Click Finish. 

5. Click File>Save in the Conductor main menu. 

 

To assign p layers using t he t oolbar  in  t he Visual  Designer : 

Note: Use the Player Properties panel in the Visual Designer to set the optional Expert User options for 
WWW scripts. 

1. Click the appropriate script icon in the Visual Designer. 

2. Click the Assign Players/Groups button  in the toolbar. The Assign Players/Groups dialog box appears. 

3. Select the Player machine or group, then click Next to display the Configure All Players/Groups dialog box. 

4. Click the arrows in the fields to set the following options: 

!  Start i ng VUs - Number of Virtual Users to launch the script  on the machine when the 
test begins. 

!  Ending VUs - Number of Virtual Users at the end of the test.  

!  VU increm en t  - Number of virtual users to add at in tervals throughout the test. 

Note: If you add incremental virtual users, you must designate the time interval and the ending 
virtual users. 

!  Tim e in terval  - Time interval at  which incremental virtual users should be added to the 
test. 

!  M ode -  The test mode for the machine. You can select th read based or process based. 

5. To use these options for all players and groups in the script, click Assign to all selected players and groups. 

6. Click Finish. 

7. Click File>Save in the Conductor main menu. 

To assign p layers using t he Gr id View : 

1. In the Machine Assignment tab, click the down arrow in the Player Name field, then select a player from the list. 

2. (Optional - WWW only) In the Middleware field, click the browse [...] button to open the Expert User Options dialog 
box. If you enable the Expert User, select the Virtual User number to represent the Expert User. 

3. Click each of the following fields to set options for: 

!  Start i ng VUs - Type the number of Virtual Users to launch the script  on the machine 
when the test begins. 

!  Ending VUs - Type the number of Virtual Users at the end of the test.  

!  VU Increm en t  - Use the arrows in the field to set the number of virtual users to add at 
in tervals throughout the test. 

!  Tim ing In terval  - Cl ick the brow se [...] button in  the field to open the Set Time 
Interval dialog box. Set the t ime interval at  which incremental virtual users should be 
added to the test. 

Note: If you add incremental virtual users, you must designate the t ime interval and the 
ending virtual users. 
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!  M ode -  Use the arrows in  the field to select the test mode for the machine. You can select 
th read based or process based. 

4. Click File>Save in the Conductor main menu. 

 

 

Set t ing Script  Propert ies 

Enabling and Disabling Applicat ionVantage Mode 

Use the Script Propert ies panel to enable Appl icat ionVantage mode. This opt ion is only avai lable i f 
Appl icat ionVantage is instal led on the Player machine.  

Note: Setup the ApplicationVantage settings using the Tools menu, then selecting Manage Players to 
open the Manage Players/Groups dialog box. 

To enable Appl icat ionVant age m ode f rom  t he Scr ip t  Proper t ies panel : 

Cl ick the script  icon for the appropriate script  to display the Script Propert ies panel on the right-had 
side of the window. In the Script Propert ies panel, cl ick the Appl i cat ionVan tage M ode field, then use the 
arrow key to enable or disable Appl icat ionVantage mode. Select ing: 

!  True enables ApplicationVantage mode 

!  False disables Appl icat ionVantage mode 

Set t ing External Data Opt ions 

Use the external data opt ions to add or remove attached fi les, specify a central datapool fi le, or specify 
local datapool fi les used by your script . You can setup external opt ions using the Script Propert ies panel  in  
the Visual Designer,  or using the Grid View window. 

To assign a Local  Dat apool  f i le used by t he scr ipt : 

Note: A local datapool file must reside in the directory \ QALoad\ Datapools on the Player workstation. 

1. Do one of the following: 

!  In  the Visual Designer, cl ick the script  icon for the appropriate script  to display 
the Script Propert ies panel  on the right-hand side of the window, then cl ick the brow se 
[...] button in  the Local  Datapools field. The Script Propert ies dialog box appears with 
the Attached Fi les window displayed. 

OR 

!  In  the Grid View window, select the Script  Assignm en t  tab, then cl ick the brow se [...] button 
in  the Ex ternal  Data column. The Script Propert ies dialog box appears. Cl ick Local  Datapools. 

2. Click Add. The Choose a Local Datapool File dialog box appears. 

3. Select a file, and click Open. 
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Note: If adding a shared datapool to a script using remote machines, it is possible to overwrite datapools. 
This will counteract the shared datapool automatic stripping. To avoid this, use the FTP Transer functionality 
in the Workbench. 

4. Repeat steps 2 and 3 to include additional datapool files. 

5. Click OK.  

To assign at t ached f i les used by t he scr ip t : 

1. Do one of the following: 

!  Open the Script Propert ies panel for the appropriate script , then cl ick the brow se [...] 
button in  the At tached Fi les field. The Script Propert ies dialog box appears with the 
Attached Fi les window displayed. 

OR 

!  In  the Grid View window, select the Script  Assignm en t  tab, then cl ick the brow se [...] button 
in  the Ex ternal  Data column. The Script Propert ies dialog box appears. Cl ick At tached Fi les. 

2. Click Add. The Choose a file to attach dialog box appears. 

3. Select a file, and click Open.  

To assign a Cent ral  Dat apool  f i le used by t he scr ipt : 

1. Do one of the following: 

!  Open the Script Propert ies panel for the appropriate script , then cl ick the brow se [...] 
button in  the Cen t ral  Datapool  field. The Script Propert ies dialog box appears with the 
Central Datapool window displayed. 

OR 

!  In  the Grid View window, select the Script  Assignm en t  tab, then cl ick the brow se [...] button 
in  the Ex ternal  Data column. The Script Propert ies dialog box appears. Cl ick Cen t ral  
Datapool . 

2. Click Browse. The Choose a Central Datapool File dialog box appears. 

3. Select a file, and click Open. 

4. (Optional) Select Rewind to rewind the records from this datapool at the end of a test. This enables you to reuse the 
records in a subsequent test of this session. 

5. (Optional) Select Strip to remove the datapool records from the test so that they cannot be used again. 

 

Set t ing M iddleware Opt ions for Cit rix and SAP 

You can set the fol lowing custom opt ions for Citrix and SAP middlewares: 

M iddlew are 
Type 

Opt ion  Descript i on  

Citrix Hide Graphical User Interface 
for Citrix Users 

Runs Citrix in  "windowless" mode. 

SAPGUI Hide Graphical User Interface Runs SAP in "windowless" mode. 
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for SAP Users 

 

You can setup Citrix and SAP middleware opt ions using the Script Propert ies panel in  the Visual Designer 
or in  the Grid View window. 

To set  t he m iddlew are opt ions in  t he Visual  Designer 's Scr ip t  Proper t ies panel : 

1. Click the appropriate Citrix or SAP script icon . The Script Properties panel appears on the right-hand of the 
window. 

2. Select the Hide Citrix/SAP graphical user interface field, and use the arrow key to select the desired middleware 
option. You can select: 

!  True - to h ide the graphical user in terface 

!  False - to display the graphical user in terface 

3. Click OK. 

To set  t he m iddlew are opt ions in  t he Gr id View  w indow : 

1. In the Script Assignment tab, select the appropriate Citrix or SAP script. 

2. In the Middleware column, click the browse [...] button. The Middleware Options dialog box appears. 

3. Select Hide graphical user interface during replay to run the script in windowless mode. 

4. Click OK. 

Set t ing Debugging Opt ions for a Script  

If you encountered errors whi le val idat ing or test ing a script , use QALoad's debugging opt ions to monitor 
the Player(s) that generated errors whi le they are running or after the test.  

You can watch a virtual user execute a script  on a Player Workstat ion while i t  is running. To monitor 
selected virtual users at runt ime, enable the Debug Trace opt ion before you run your test. Each virtual user 
for which you enabled Debug Trace displays messages on i ts assigned Player workstat ion indicat ing which 
commands are being executed. 

You can instruct the Conductor to generate and save detai ls about the script  execut ion of selected virtual 
users by enabl ing Logfi le Generat ion before you run your test. This appl ies to Citrix, ODBC, Oracle, Oracle 
Forms Server, SAP, Winsock, or WWW only.  

You can set the Debug Options using the Script Propert ies panel in  the Visual Designer, or using the Grid 
View window. 

To enable t he Debug opt ions: 

1. Do one of the following: 

!  In  the Visual Designer, cl ick the script  icon for the appropriate script  to display the Script 
Propert ies panel on the right-hand side of the window, then cl ick the brow se [...] button in the 
Debug Opt ions field. The Debug window of the Script  Propert ies dialog box appears. 

OR 
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!  In  the Grid View window, select the Script  Assignm en t  tab, then cl ick the brow se  [...] button 
in  the Debug Opt ions column, for the appropriate script . The Debug window of the Script 
Propert ies dialog box appears. 

2. On the Debug Options dialog box, you can choose the following options:  

!  To enable the Debug Trace opt ion: in  the Debug Trace Virtual User Range area, choose which 
virtual users (i f any) to monitor. You can choose None or Al l  Virtual Users, or choose Virtual 
User(s) and then type the numbers assigned to the virtual users you want to monitor. You can 
monitor individual virtual  users or ranges of virtual users.  

!  To enable Logfi le Generat ion: in  the Logfi le Generat ion Virtual User Range area, choose which 
virtual users (i f any) to monitor. You can choose None or Al l  Virtual Users, or choose Virtual 
User(s) and then type the numbers assigned to the virtual users you want to monitor. You can 
monitor individual virtual  users or ranges of virtual users.  

3. Click OK to save your changes.  

4. From the Conductor's main menu, click File>Save to save your test session ID. 

5. Run your test as usual.  

Note: Some log files are generated automatically when you run a test in the Script Development 
Workbench or Player.  

 

Set t ing Error Handling Opt ions 

You can configure the behavior of a virtual user when an error occurs during the load test so that the test 
aborts or cont inues execut ing. You can set the Error Handling Options using the Script Propert ies panel in  
the Visual Designer, or using the Grid View window. 

To set  t he Er ror  Handl ing opt ions: 

1. Do one of the following: 

!  In  the Visual Designer, cl ick the script  icon for the appropriate script  to display the Script 
Propert ies panel on the right-hand side of the window, then cl ick the brow se [...] button in the 
Error Handl ing field. The Error Handling page of the Script  Propert ies dialog box appears. 

OR 

!  In  the Grid View window, cl ick the Script  Assignm en t  tab, then cl ick the brow se [...] button 
in  the Error Handl ing field for the appropriate script  . The Error Handling page of the Script 
Propert ies dialog box appears. 

2. Select the option you want applied to the script. You can select: 

!  Abort, stopping further execut ion of t ransact ions. Use th is opt ion when errors wi l l  make the 
virtual user inval id for execut ing more transact ions. 

!  Continue execut ing and ignore the error. Select th is opt ion when errors are not cri t ical to the 
performance of the load test 

!  (WWW, SAPGUI, and Citrix scripts only) Restart  the transact ion from the beginning. When 
you select th is opt ion, you must type a number for the attempts made to restart  the transact ion 
in  the M ax im um  restart  at tem pts field.  

Note:The transaction count increases for each transaction that is restarted. 
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3. (Optional) Select Apply Error Handling to all scripts in this session. This ensures that all scripts in the session 
respond to errors the same way. 

Set t ing Script  Pacing 

Script Pacing is the t ime interval between the start  of a transact ion and the beginning of the next 
transact ion on each workstat ion running the script . For example: i f a transact ion is designed to dupl icate 
the process of someone handl ing incoming telephone cal ls and those cal ls arrive at a rate of 40 per 
hour/per person, set the pacing rate at 90 seconds. The default  pacing value is one second, which enables 
the Conductor to control runaway virtual users. 

Note: QALoad randomly schedules transactions so that each transaction executes on an average according 
to this predetermined rate. When a transaction completes faster than its pacing rate, QALoad delays the 
execution of the next transaction for that workstation so that proper pacing is met. Since we do not normally 
time events according to this predetermined rate, QALoad randomly accelerates or delays the pacing on a 
workstation-by-workstation basis. However, on the average, QALoad provides pacing according to the value 
that you assign. 

You can set the Pacing rate using the Script Propert ies panel in  the Visual Designer, or using the Grid View 
window. 

To set  t he Pacing rat e: 

1. Do one of the following:  

!  In  the Visual Designer, cl ick the script  icon for the appropriate script  to display the Script 
Propert ies panel on the right-hand side of the window, then cl ick the brow se [...] button in the 
Pacing field. The Set Script  Pacing dialog box appears. 

OR 

!  In  the Grid View window, cl ick the Script  Assignm en t  tab, then cl ick the brow se [...] button 
in  the Pacing field. The Set Script  Pacing dialog box appears. 

2. Use the arrows in each field to set the pacing rate. You can set Hours, Minutes, Seconds, and Milliseconds. 

3. Click OK. 

 

 

Set t ing the Service Level Threshold 

Use the service level threshold to specify a response t ime that is used to compare against incoming 
response t ime data. The threshold appears as a horizontal l ine in  the runt ime Graphs view. 

Service level thresholds are similar to thresholds that can be specified for real-t ime graphs in the 
Conductor, but are l im ited to transact ion t ime and must be specified before a test runs. 

Set the Service Level Threshold in  the Visual Designer's Script  Propert ies panel. 

To set  t he service level  t h reshold: 

1. In the Visual Designer, click the script icon for the appropriate script to display open the Script Properties 
panel on the right-hand side of the window. 
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2. In the Service Level Threshold field, click the browse [...] button to open the Set Service Level Threshold dialog 
box. 

3. Use the arrow keys in the Hours, Minutes, and Seconds fields to set the threshold. 

4. Click OK. 

Set t ing the Sleep Factor Percentage 

Use the Sleep Factor % field to specify the percentage of any original ly recorded delay to preserve in  the 
script . QALoad records the actual delays between requests and inserts the DO_SLEEP command in the 
script  to mimic those delays when the script  is played back in  a test. You can maintain the exact length of 
the recorded delays at playback, or shorten them by entering a smaller percentage of the original ly 
recorded delay to play back. For example, i f you recorded a delay of 10 seconds, then DO_SLEEP (10); is 
wri t ten to your script . Then, i f a Sleep Factor of 50% is specified here, the Player sleeps for 5 seconds at that 
statement when the test is executed.   

Val id values for Sleep Factor % are 0-1000%, and Random. Random causes the Player to sleep for a 
randomly selected durat ion between 0 and 100. A value of 100% causes the script  to execute at exact ly the 
same speed at which i t  was recorded; therefore, you can simulate the performance of faster users by 
specifying a lower Sleep Factor % value.  

Hint : Enter a value of zero during unit testing to eliminate the actual sleeps from the script. After you unit 
test the script, you can restore the original recorded delays by changing the Sleep Factor to a higher 
percentage. 

You can set the sleep factor percentage using the Script Propert ies panel in  the Visual Designer, or using 
the Grid View window. 

To set  t he Sleep Fact or  percent age: 

1. Do one of the following: 

!  In  the Visual Designer, cl ick the script  icon for the appropriate script  to display 
the Script Propert ies panel  on the right-hand side of the window. 

OR 

!  In  the Grid View window, cl ick the Script  Assignm en t  tab, then cl ick the Sleep Factor 
% field for the appropriate script . 

2. In the Sleep Factor % field, do  one of the following: 

!  Click the arrow in the field to select Random  or 100 

OR 

!  Type the number represent ing the percent of the original ly recorded delay to keep in the script . 

3. In the Conductor, click File>Save.  

Set t ing Opt ions for Large Amounts of Timing Data 

Your load test probably includes a large number of checkpoints and virtual users in  order to adequately test 
your system. When your test is running and your Conductor is col lect ing t iming in formation from your 
Player machines, the sheer amount of data can take up more of your resources than you'd l ike to expend. 
Use QALoad's Timing Data Thinning opt ion to th in the amount of t im ing data being transferred back to 
the Conductor during the test so that your test can run longer without stressing your resources.  



Conductor 

25 

You can set the Timing Options using the Script Propert ies panel in  the Visual Designer, or using the Grid 
View window. 

To open t he Tim ing Opt ions d ialog  box: 

!  In the Visual Designer: 

1. Click the script icon for the appropriate script to display the Script Properties panel on the right-hand side of 
the window. 

2. In the Timing Options field in the Script Properties panel, click the browse [...] button. The Timing page of the 
Script Properties dialog box appears. 

!  In the Grid View window: 

0. Click the Script Assignment tab. 

1. In the Timing Options column, click the browse [...] button. The Timing page of the Script Properties 
dialog box appears. 

To set  t im ing opt ions: 

In  the Timing Options area of the dialog box, select opt ions for checkpoints and for custom counter data 
col lect ion. For more in formation on these opt ions, refer to Timing Options. 

To t h in t im ing dat a: 

1. In the Timing Data Thinning area of the dialog box, choose one or both of the following: 

!  Th in  coun ter t im ing data by to control the amount of counter t im ing data that is 
col lected and saved in the t im ing fi le. Do not select th is opt ion i f you want to col lect al l  
avai lable t im ing data for counters. 

!  Th in  checkpoin t  t im ing data by to control the amount of checkpoint t im ing data 
that is col lected and saved in the t im ing fi le. Do not select th is opt ion i f you want to 
col lect al l  avai lable t im ing data for checkpoints. 

3. Do one of the following: 

!  Select Script  to th in data by script . In  the Sum m ary in terval  field, type the number of 
seconds between each data col lect ion. 

!  Select Vi rtual  User to th in data by virtual user. In  the Sum m ary in terval  field, type the 
number of seconds between each data col lect ion. 

Note: Thinning by script minimizes the amount of data collected. 

4. The average is sent to the Conductor for inclusion in the timing file, rather than every value. 

5. Click OK. 

6. Save your changes to your test session ID file by choosing File>Save from the Conductor main menu. 

 

 

Set t ing the Number of Transact ions 

Use the Transact ions field to set the number of t ransact ions that each Virtual User running the script  
should run. Once the workstat ion executes the number of t ransact ions that you specify, script  execut ion 
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cont inues with the l ine fol lowing the End Transact ion command rather than jumping to the beginning of 
the transact ion loop. 

You can set the number of t ransact ions using the Script Propert ies panel in  the Visual Designer, or using 
the Grid View window. 

To set  t he num ber  of  t r ansact ions in  t he Visual  Designer : 

1. Click the script icon for the appropriate script. The Script Properties panel displays on the right-hand side of 
the window. 

2. In the Transactions field, type the number of transactions that each Virtual User should run. 

3. From the Conductor menus, click File>Save. 

To set  t he num ber  of  t r ansact ions in  t he Gr id View  w indow : 

1. Click the Script Assignment tab. 

2. In the Transactions column for the appropriate script, use the arrow keys to select the number of transactions that 
each Virtual User should run. 

3. From the Conductor menus, click File>Save. 

Set t ing Player Propert ies 

Specify Virtual User Configurat ions 

Once you've selected the scripts and configured the transact ion sett ings, you must assign Player machines 
and groups, and set the Virtual User configurat ions. You can set the Virtual User configurat ions using: 

!  the toolbar in the script test setup node in the Visual Designer 

!  the Player Properties panel in the Visual Designer 

!  the Machine Assignment tab in the Grid View 

!  the toolbar in the main Visual Designer window 

To set  t he Vir t ual  User  conf igurat ions in  t he scr ipt  t est  set up  node: 

1. Click the appropriate Player in the script test setup node in the Visual Designer.  

2. Click the Configure All button  in the script test setup node toolbar. The Configure All Players/Groups dialog 
box appears. 

3. Click the arrows in the fields to set the following options: 

!  Start i ng VUs - Number of Virtual Users to launch the script  on the machine when the 
test begins. 

!  Ending VUs - Number of Virtual Users at the end of the test.  

!  VU increm en t  - Number of virtual users to add at in tervals throughout the test. 

Note: If you add incremental virtual users, you must designate the time interval and the ending 
virtual users. 

!  Tim e in terval  - Time interval at  which incremental virtual users should be added to the test. 
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!  M ode -  The test mode for the machine. You can select th read based or process based. 

5. To use these options for all players and groups in the script, click Assign to all selected players and groups. 

6. Click Finish. 

7. Click File>Save in the Conductor main menu. 

To set  t he Vir t ual  User  conf igurat ions using t he Player  Proper t ies panel  of  t he Visual  Designer : 

1. Click the individual Player in the script test setup node in the Visual Designer. The Player Properties panel displays 
on the right-hand side of the window. 

2. In the [Starting VUs] field, type the number of Virtual Users to launch the script on this machine when the test 
begins. 

3. (Optional) In the [VU Increment] field, type the number of virtual users that should be added at intervals. When you 
fill in this field, you must also fill in the Time Interval and Ending VUs fields. 

4. In the Ending VUs field, type the number of Virtual Users at the end of the test. 

5. In the Mode field, use the arrow to select the test mode, process-based or thread-based, for this Player. 

6. (Optional) In the Time Interval field, click the browse [...] button to display the Set Time Interval dialog box. 

Note: If you filled in the VU Increment field, you must fill in the Time Interval. 

7. Use the arrows in the Hours, Minutes, and Seconds fields to set the time interval at which incremental Virtual 
Users should be added to the test,  then click OK. 

8. Click File>Save in the Conductor main menu. 

To set  t he Vir t ual  User  conf igurat ions using t he Gr id View : 

1. In the Machine Assignment tab, click the down arrow in the Player Name field, then select a player from the list. 

2. (Optional - WWW only) In the Middleware field, click the browse [...] button to open the Expert User Options dialog 
box. If you enable the Expert User, select the Virtual User number to represent the Expert User. 

3. Click each of the following fields to set options for: 

!  Start i ng VUs - Type the number of Virtual Users to launch the script  on the machine 
when the test begins. 

!  Ending VUs - Type the number of Virtual Users at the end of the test.  

!  VU Increm en t  - Use the arrows in the field to set the number of virtual users to add at 
in tervals throughout the test. 

!  Tim ing In terval  - Cl ick the brow se [...] button in  the field to open the Set Time 
Interval dialog box. Set the t ime interval at  which incremental virtual users should be 
added to the test. 

Note: If you add incremental virtual users, you must designate the t ime interval and the 
ending virtual users. 

!  M ode -  Use the arrows in  the field to select the test mode for the machine. You can select 
th read based or process based. 

4. Click File>Save in the Conductor main menu. 

To set  t he Vir t ual  User  Conf igurat ions using t he Visual  Designer  t oolbar : 

1. Select the appropriate script test setup node, then click Review Virtual Users in the Visual Designer toolbar.  



Using the Conductor 

28 

2. Use the columns in the Review Virtual Configuration dialog box to set the Virtual User configurations for each Player 
listed. 

 

Changing the Number of Virtual Users 

Change the number of virtual users assigned to a script  using the Visual Designer or on the  Machine 
Assignment tab of the Grid View window. 

To change t he num ber  of  vi r t ual  users using t he Visual  Designer : 

1. Do one of the following: 

!  In  the Visual Designer window, select a player machine in  the appropriate script  node. 
The Player Propert ies panel displays on the right-hand of the window. Type a new value 
in  the Start i ng VUs column of the Player Propert ies panel.  

OR 

!  Click Review  Vi rtual  Users in  the Visual Designer toolbar, then type a 
new value in  the Start i ng VUs column for the selected script . Cl ick OK. 

2. If you have assigned incremental virtual users, change the values in the VU Increment  column and the Ending 
VUs column to determine how many virtual users to add at the interval specified in the Time Interval column. 

3. Select File>Save to save your changes to the current session ID file, or File>Save As to save them to a new 
session ID file.  

To change t he num ber  of  vi r t ual  users using t he Gr id View : 

1. In the Machine Assignment tab, type a new value in the Starting VUs column for the selected script. 

2. If you have assigned incremental virtual users, change the values in the VU Increment  column and the Ending 
VUs column to determine how many virtual users to add at the interval specified in the Time Interval column. 

3. Select File>Save to save your changes to the current session ID file, or File>Save As to save them to a new 
session ID file.  

 

Managing Players and Groups 

Overview of Players and Groups  

You can configure the various machines and agents that wi l l  part icipate in  a load test from a single screen. 
Cl ick Tools>M an age Players to display the M anage Players/Groups dialog box, where you can configure 
Player Machines, Player Groups, and Applicat ionVantage sett ings in formation from a single screen.  

You should use th is opt ion to update Player or Agent in formation whenever a Player or Agent is added to 
the test network, removed from the test network, or the network address of a Player or Agent has changed. 

You can col lect Player machines in to logical groups using the Group Membership opt ions in  the dialog 
box.   

Player Agen ts 

Player machines execute the virtual users that perform the transact ions recorded in your test scripts. You 
can view information on Player machines from either the Visual Designer or the Grid View window. If no 
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Player machines are l isted, you can retrieve in formation from Player machines on the local network, or you 
can add Player machines manually.  

 

 

Adding Player Machines to a Test  Session 

Follow these instruct ions to add a Player workstat ion to your pool of avai lable Players in  a test 's session ID 
fi le. 

To add a new  Player  m achine: 

1. From the Conductor's main menu, click Tools>Manage Players. The Manage Players/Groups dialog box displays. 

2. Click File>New>Player. A new page displays in the detail area of the dialog box, where you enter information and 
settings for the new Player. 

To ent er  in f orm at ion and set t ings f or  t he new  Player : 

Enter in formation for the new Player in  the fol lowing areas of the dialog box. 

In  the Player In form at ion  area: 

1. In the Machine (hostname or IP) field, type a name for the Player Machine. 

2. In the Communications [TCP] port field, type the port number the Conductor should use to communicate (using 
TCP) with this machine during a test. The default is 3032. 

3. Click Verify to check that the machine is active. The Player or Agent returns the operating system, processor type, 
amount of memory, and the maximum threads and processes available on the machine. 

Note: If a Player does not respond, a message box appears indicating that the Player is not responding. If 
the Player is not responding, one of the following scenarios is likely: 

!  The host name and/or port  number you entered may not be correct. Check your 
parameters and network connect ions, then try to send another request. 

!  The Player is not running. Start  the Player and then try to send another request.  

Expand the M ach ine Set t i ngs area (Optional): 

4. Select desired options to ping the host before attempting connection to the player,  generate IP spoof data, or 
override the default machine settings. 

5. Close the Machine Settings. 

Expand the Group M em bersh ip area (Optional): 

6. In the Available Groups pane, select a group to which you want this Player Machine added, then click Add.  

7. The selected groups are moved to the Member of Groups pane. 

8. Close the Group Membership. 

Note: You also can add a Player to a Group by dragging and dropping the Player from the list in the 
Players area to the appropriate Group in the Groups area, or by dragging and dropping a Group in there 
Groups area to a Player int he Players area. 

In  the Appl i cat ionVan tage Set t i ngs area: 

Note: The fields on this tab are available only if ApplicationVantage is installed on the Player Machine and 
Applicat ionVantage Mode is selected when you choose a script in the Script  Assignment  tab. 
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From the drop-down l ist  in  the NIC Nam e field, select the Network Interface Card (NIC) that is used by 
the machine, i f necessary.  

To save t he Player  m achine: 

Cl ick Save, then cl ick OK. The Player Machine appears in  the M anage Pl ayers and Groups dialog box 
in  the Al l  Player Machines and Groups tree. 

 

Edit ing a Player Machine  

From the Conductor's main menu, cl ick Tools>M an age Players. The Manage Player Machines and Groups 
dialog box displays. Use the fol lowing procedure to edit  Player M achines. 

To edi t  a Player  m achine: 

Select an individual Player Machine in  the Players l ist .  

In  the Player In form at ion  area: 

1. In the Communications port field, type the port number the Conductor should use to communicate (using TCP) with 
this machine during a test. The default is 3032. 

2. Click Verify to check that the machine is active. The Player or Agent returns the operating system, processor type, 
and amount of memory on the machine. 

In  the M ach ine Set t i ngs area: 

1. Open the Machine Settings area.  

2. Make any necessary selection or changes here, then close the Machine Settings.  

In  the Group M em bersh ip area (Optional): 

1. Open the Group Membership area.  

2. Add the Player to appropriate groups by selecting a group in the Available Groups pane and clicking Add.  

3. Close the Group Membership. 

In  the Appl i cat ionVan tage Set t i ngs area: 

Note: These fields are enabled only if Application Vantage is installed on the Player machine. 

!  In the NIC Name field, select the Network Interface Card (NIC) that is used by the machine.  

Save the edits to the Player machine: 

!  Click Save to save your settings for this player machine, then click OK.  

To delet e a Player  m ach ine: 

Select the Player machine in  the Players panel, then cl ick Edi t>Delete. 
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Discovering and Verifying Player Machines  

In  Conductor, you can ret rieve in formation from Player machines on the local network by doing the 
fol lowing: 

To d iscover  and inf orm at ion on Player  m achines: 

1. Click Tools>Manage Players. The Manage Players/Groups dialog box displays. 

2. Click Actions>Discover Players. QALoad Conductor queries the network for available Player workstations and 
adds the results under Player Machines in the Players area. 

To ver i f y a Player  m achine: 

1. In the Players area of the screen, select the Player machine to verify. 

2. In the Communications [TCP] port field in the Player Information area, click Verify. A confirmation dialog box 
appears when the verification is successful. 

 

 

Viewing Informat ion on Player Machines  

In  Conductor, you can ret rieve in formation from Player machines on the local network by doing the one 
of fol lowing: 

To view  in f orm at ion  on Player  m achines in  t he Visual  Designer : 

In  the script  node, select the individual Player you want to view. The information on the Player appears in  
the Propert ies panel on the right-hand side of the window.  

To view  in f orm at ion  on t he Player  in  t he Gr id View : 

Cl ick View >Grid Window  to display the Grid View window, then cl ick the M ach ine Assignm en t  tab to 
display in formation on the Player. 

 

Adding a Group 

You can combine players in to logical groups using the fol lowing procedure: 

To creat e a group: 

1. From Conductor's main menu, click Tools>Manage Players. The Manage Players/Groups dialog box displays. 

2. Click File>New> Group. The Group Information dialog box appears. 

3. In the Name field, type a name for the group. 

4. In the Description field, type a description for the group. 

To add Players t o t he group: 
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1. In the Available Players panel, select the player or players to add to the group.  

2. Click Add. The Player is moved to the Member Players pane. 

Note: You can select more than one machine by holding down the Ctrl key and selecting each Player 
Machine to select. Select all the available Player Machines by clicking Add All. 

3. Click Save, then click OK.  

 

 

Edit ing a Group  

Use the fol lowing procedure to edit  a group. 

To edi t  a group: 

1. On Conductor's main menu, select Tools>Manage Players. The Manage Players/Groups dialog box displays. 

2. Select a group in the Groups panel to display the Group Information window. 

3. Use the fields in this dialog box to change the Group Name or Description. 

4. To add a Player Machine to the group, use the procedures for adding a Player machine to a group. 

To rem ove a Player  f rom  t he group: 

1. Select the Player machine in the Member Players panel, then click Remove. 

2. Click Save to save your changes, then click OK to return to the main Conductor window. 

 

Integrat ion and Server Monitoring 

Server and Performance Monitoring 

QALoad integrates several mechanisms for merging load test response t ime data with server ut i l izat ion data 
and performance metrics. Select the method that best suits your needs, or for which you are l icensed (i f 
appl icable). Most methods produce data that is included in your load test t im ing results and processed in 
QALoad Analyze. The only except ion is Appl icat ion Vantage. Data captured from Applicat ionVantage can 
be opened in Appl icat ionVantage, but not in  QALoad.   

This sect ion briefly describes each method, and provides l inks to more detai led in formation about sett ing 
up a test that includes the appropriate method. 

!  Remote Monitoring — allows you to monitor server utilization statistics from a remote machine without installing any 
software on the remote machine. 

!  ServerVantage — integrates with your existing ServerVantage installation. You must be licensed for and have 
installed and configured the appropriate product in order to integrate with QALoad . 

!  ApplicationVantage — collects test data that you can open in ApplicationVantage.  

!  Vantage Analyzer - enables you to easily drill into specific problem transactions to determine the cause of 
bottlenecks in your production applications 

 



Conductor 

33 

Integrat ion and Monitoring Requirements 

Integration Requirements 

Appl i cat ionVan tage 

!  QALoad supports integration with ApplicationVantage 10.0 Service Pack 2, 10.1,l 10.2, and 11.0. 

!  Integration with ApplicationVantage is supported on the Windows platform only. 

ServerVan tage 

!  QALoad supports integration with ServerVantage (SVI Monitoring) 10.0, 10.1, 10.2, and 11.0. 

!  QALoad supports integration with ServerVantage (Remote Monitoring) 10.1 Service Pack 1.5 only. 

Cl ien tVan tage 

QALoad supports in tegrat ion with Cl ientVantage. QALoad is packaged with the current version of 
Cl ientVantage at t ime of release. 

Van tage Analyzer 

QALoad supports in tegrat ion with Vantage Analyzer 10.1 Service Pack 1. 

Monitoring Requirements 

In addit ion to the in tegrat ion requirements, your system may need to meet specific requirements to 
support remote monitoring. 

JVM  Requi rem en ts 

Oracle Appl icat ion Server (AS), JVM, SAP, WebLogic, WebSphere, and WebSphere MQ monitoring al l  
require JVM instal led on the Conductor machine. 

!  For Oracle AS monitoring, if monitoring Oracle AS 10g, you must use Java Virtual Machine 1.5.  

!  For SAP monitoring, you must use JVM 1.4. 

!  For WebLogic monitoring version 7 and earlier versions, use JVM 1.3. For WebLogic version 8.1, use JVM 1.4. For 
WebLogic 9, use JVM 1.5. You may also use the JVM that is distributed with the WebLogic Application Server. 

!  For WebSphere monitoring, you must use the JVM provided with the WebSphere client or server. 

!  For WebSphere MQ monitoring, you must use JVM 1.4. 

Fi le Instal l at i on  Requi rem en ts 

Oracle Appl icat ion Server (AS), SAP, WebLogic, WebSphere, WebSphere MQ, WMI, and Cold Fusion 
monitoring require the fol lowing fi les. 

Oracle AS 

For Oracle AS 10g, you must store copies of the dms.jar, xmlparserv2.jar, ons.jar, and opt ic.jar fi les from 
the monitored Oracle AS server on the Conductor machine.  

SAP Monitoring 

The SAP fi les l isted below must be placed on the Conductor machine: 

!  librfc32.dll 

!  sapjco.jar 

!  sapjcorfc 
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To obtain these fi les, instal l  the SAP Java Connector package (JCo) on the Conductor machine. The JCo 
package is avai lable from SAP. Add the locat ion of the fi les, to the Path System Variable of the Conductor 
machine. For more in formation, refer to the Requirements for SAP Remote Monitoring topic in  the 
ServerVantage Reconfigure Agent Online Help. 

WebLogic Monitoring 

The w eblogic.jar fi le must be placed on the Conductor machine. Copy the jar fi le from the l ib directory of 
the WebLogic appl icat ion  server to a separate directory in  the Conductor machine. If you are monitoring 
WebLogic version 8.1, copy the w eblogic.jar and w ebservi ces.jar fi les to the same directory. If you are 
monitoring WebLogic 9.x, copy the w eblogic.jar and w l jm xcl ien t .jar fi le to the same directory. For more 
in formation, refer to Requirements for WebLogic Remote Monitoring in  the ServerVantage Reconfigure 
Agent Online Help. 

WebSphere Monitoring 

Note the fol lowing requirements for WebSphere monitoring: 

!  The WebSphere cl ient fi les must be instal led on the Conductor machine. Instal l ing the WebSphere 
Appl icat ion Server Admin  Server software on the Conductor machine provides the necessary cl ient 
fi les. Note the directory path of the WebSphere\ AppServer\ Java fi les. For more in formation, refer 
to Requirements for WebSphere Remote M onitoring in  the ServerVantage Reconfigure Agent 
Online Help. 

!  The Java Home for the monitoring task must be setup for compatible Java version; for example, 
WebSphere\ AppServer\ Java. 

!  If authent icat ion is required and soap.cl ient.props and ssl.cl ient.props authent icat ion fi les are 
instal led in  a custom directory, you must also place copies of the fi les in  
WebSphere\ AppServer\ propert i es. 

WebSphere MQ Monitoring 

The WebSphere cl ient fi les l isted below must be placed in a directory on the Conductor machine:  

!  com.ibm.mq.jar 

!  com.ibm.mq.pcf.jar 

!  connector.jar 

The fi les may be obtained from the instal lat ion of the WebSphere Appl icat ion Server Admin Server 
software on the Conductor machine. If the instal lat ion does not include the com.ibm.mq.pcf.jar fi le, 
obtain the fi le from the IBM Support Pac MS0B. See "http:/ /www-
1.ibm.com/support/docview.wss?rs=171& uid=swg24000668& loc=en_US& cs=utf-8& lang=en".  

For more in formation, refer to Configuring W ebSphere MQ for Remote Monitoring in  the ServerVantage 
Reconfigure Agent Online Help. 

WMI Monitoring 

WMI securi ty must be enabled on the monitored server machine and the WM I service must be started. For 
more in formation, refer to Configuring WMI for Remote Monitoring in  the ServerVantage Reconfigure 
Agent Online Help. 

Cold Fusion Monitoring 

Performance Monitoring must be enabled from the Cold Fusion Administrator Page – Debugging Sett ings 
of the monitored server machine. Cold Fusion is avai lable under Windows Registry monitoring. 

Rstat Monitoring 
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ServerVantage Agent must be instal led with QALoad. 

Host  Veri f i cat ion  for QALoad M on i toring 

!  Ensure host accessibility. Add an entry for the monitored machine to the system hosts file of the Conductor 
machine. Consult the network administrator for more information. 

!  Test host availability. Type the following command at the Run command: ping <moni t or ed machi ne name>. 

 

Remote Monitoring 

Overview of Remote Monitoring 

Remote M onitoring enables you to extract data from Windows Registry, JVM , Oracle Appl icat ion Server 
(AS), SAP, SNMP, ServerVantage, Vantage Analyzer, WebLogic, WebSphere, WebSphere MQ, Rstat, and 
WMI counters on the servers under stress without instal l ing any software on the servers.  

Note: Select counters for monitor types in the application. 

To use Remote M onitoring:  

!  You must have login access to the machines you want to monitor. 

!  You must select the servers and counters to monitor on the machines you identify using the monitoring options on 
Conductor's Manage Monitoring Tasks window. 

!  To collect SNMP counters, SNMP must be enabled on the Remote Monitor machine. Refer to your operating system 
help for information about enabling SNMP. 

!  To collect Windows registry counters, you must have a valid sign-on for the servers under test.  

!  For requirements for Oracle AS, SAP, WebLogic, WebSphere, WebSphere MQ, and WMI, see Integration and 
Monitoring Requirements. 

QALoad uses the default  ports 7790 and 7788 when i t  communicates with the ServerVantage agent and 
cl ient. You can override the default  ports i f your ServerVantage instal lat ion requires i t . 

While your test is running, QALoad col lects the appropriate counter data and writes i t  to your t im ing fi le 
where you can view i t  in  Analyze after the test. What counters are avai lable? 

You can simpli fy the configurat ion process by creat ing or applying pre-defined monitoring templates. A 
monitoring template is a predefined group of counters not associated with a specific machine.  

To set up Remote Monitoring, see Creat ing a New M onitoring Task.  

 

Monitoring Counters 

About  Coun ters and Instances 

You use counters and, in  some cases, specific instances of counters when you monitor servers. 

Counters 

Counters are the numeric data values that are col lected when monitoring servers. Counters exist  for 
components such as processor, memory, processes, hard disk, and cache, with a set of counters that 
measure stat ist ical in formation.  For Windows, a large number of performance counters are provided by 
the operat ing system registry and Windows server appl icat ions. Registry counters can monitor external 
components of the environment such as databases, appl icat ions, and printers. 

Many of the counters that are col lected are points in  t ime data values, such as Process\ thread count. Some 
counters are cumulat ive, such as server logon errors, and some are averages, such as the page faults per 
second in Job Object Detai ls.  
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In  addit ion to the numeric value counters, a set of extended data counters is provided for a number of key 
performance indicators. These extended data counters can provide in tel l igent data points that have 
associated textual data for the numeric value. For example, the extended CPU usage counter's in tel l igent 
datapoint shows the top 10 processes consuming CPU at that t ime. 

Instances 

When you select a counter to monitor, the avai lable instances, or occurrences, for that counter appear. 
Counters can have several instances or no instances. For example, i f a system has mult iple processors, then 
the Processor counter has mult iple instances. For counters with mult iple instances, a l ist  of the avai lable 
instances for that counter is presented. M any counters also have an instance cal led  _Total, which is an 
aggregate of the individual instances.  

Counters for an object, such as processor, have instances that are numbered, beginning with 0 (zero). A 
machine with a single processor has an instance of _Total and 0. A dual-processor machine has instances of 
_Total, 0, and 1. Other instances are based on what is current ly running on the server, and the instance l ist  
displays these for each process name or service name that is act ive.  

Some instances represent the most recent value for the resource, for example, Processes. This is the number 
of processes in  the computer at the t ime of data col lect ion. Other instances are average values between the 
last two measurements.  

 

 

W indow s NT Regist ry Server Coun ters  

QALoad supports the fol lowing MS Windows NT Server counter categories: 

Coun ter Category Descript i on  

Act ive Server Pages This object type handles the Act ive Server Pages device on your 
system. 

Browser This object type displays Browser Stat ist ics. 

Cache The Cache object type manages memory for rapid access to fi les. Fi les 
on Windows NT are cached in main memory in  units of pages. Main 
memory not being used in the working sets of processes is avai lable to 
the Cache for th is purpose. The Cache preserves fi le pages in memory 
for as long as possible to permit  access to the data th rough the fi le 
system without accessing the disk. 

Context Index This object type handles the Content Index. 

Context Index Fi l ter This object type handles the Content Index Fi l ter. 

ICMP The ICMP object type includes the counters that describe the rates that 
ICMP Messages are received and sent by a certain ent i ty using the 
ICMP protocol. It  also describes various error counts for the ICMP 
protocol. 

IP This object type includes those counters that describe the rates that IP 
datagrams are received and sent by a certain computer using the IP 
protocol. It  also describes various error counts for the IP protocol. 

LogicalDisk A LogicalDisk object type is a part i t ion on a hard or fixed disk drive 
and assigned a drive let ter, such as C. Disks can be part i t ioned into 
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dist inct sect ions where they can store fi le, program, and page data. The 
disk is read to retrieve these i tems and writ ten to record changes to 
them. 

Memory The Memory object type includes those counters that describe the 
behavior of both real and virtual memory on the computer. Real 
memory is al located in  units of pages. Virtual memory can exceed real 
memory in  size, causing page traffic as virtual pages are moved 
between disk and real memory. 

Network Interface The Network Interface Object Type includes those counters that 
describe the rates that bytes and packets are received and sent over a 
Network TCP/IP connect ion. It  also describes various error counts for 
the same connect ion. 

Objects The Objects object type is a meta-object that contains in formation 
about the objects in  existence on the computer. This in formation can 
be used to detect the unnecessary consumption of computer resources. 
Each object requires memory to store basic in formation about the 
object. 

Paging Fi le This object displays in formation about the system's Page Fi le(s). 

PhysicalDisk A PhysicalDisk object type is a hard or fixed disk drive. It  contains 1 or 
more logical part i t ions. Disks are used to store fi le, program, and 
paging data. The disk is read to retrieve these i tems and writ ten to 
record changes to them. 

Process The Process object type is created when a program is run. Al l  the 
threads in  a process share the same address space and have access to 
the same data. 

Process Address Space Process Address Space object type displays detai ls about the virtual 
memory usage and al locat ion of the selected process. 

Processor The Processor object type includes as instances al l  processors on the 
computer. A processor is the part  in  the computer that performs 
ari thmetic and logical computat ions, and in i t iates operat ions on 
peripherals. It  executes (such as runs) programs on the computer. 

Redirector The Redirector is the object that manages network connect ions to 
other computers that originate from your own computer. 

Server The Server object type is the process that in terfaces the services from 
the local computer to the network services. 

Server Work Queues The Server Work Queues object type handles explain text performance 
data. 

SMTP Server This object type handles the counters specific to the SMTP Server. 

System This object type includes those counters that apply to al l  processors on 
the computer col lect ively. These counters represent the act ivi ty of al l  
processors on the computer. 

TCP The TCP object type includes the counters that describe the rates that 
TCP Segments are received and sent by a certain en t i ty using the TCP 



Using the Conductor 

38 

protocol. In  addit ion, i t  describes the number of TCP connect ions in  
each possible TCP connect ion state. 

Telephony This object type handles the Telephony System. 

Thread The Thread object type is the basic object that executes instruct ions in  
a processor. Every running process has at least one thread. 

UDP The UDP object type includes the counters that describe the rates that 
UDP datagrams are received and sent by a certain ent i ty using the UDP 
protocol. It  also describes various error counts for the UDP protocol. 

For in formation on the registry counters refer to the documentat ion or developer network for that product 
or the developer ki t  provided with the product. For M icrosoft  products, refer to 
http:/ /msdn.microsoft .com/ l ibrary/default .aspx.  

 

W indow s Win2K Server Regist ry Coun ters  

Remote M onitoring Agents can monitor the same Windows registry counters as PERFMON, the 
performance monitoring appl icat ion avai lable with  the Windows operat ing system. The Windows registry 
opt ion monitors machines that run Windows 2000 and XP. To retrieve Windows Registry Counters, you 
must have access, via a user name and password, to the remote machine. 

QALoad supports the fol lowing MS Windows counter categories: 

Coun ter Category Descript i on  

ACS/RSVP Service RSVP or ACS service performance counters. 

Act ive Server Pages This object type handles the Act ive Server Pages device on your 
system. 

Browser The Browser performance object consists of counters that measure the 
rates of announcements, enumerat ions, and other Browser 
transmissions. 

Cache The Cache performance object consists of counters that monitor the 
fi le system cache, an area of physical memory that stores recent ly used 
data as long as possible to permit  access to the data without reading 
from the disk. Because appl icat ions typical ly use the cache, the cache 
is monitored as an indicator of appl icat ion I/O operat ions. When 
memory is plent i ful , the cache can grow, but when memory is scarce, 
the cache can become too small  to be effect ive. 

IAS Account ing Clients IAS Account ing Clients 

IAS Account ing Server IAS Account ing Server 

IAS Authent icat ion Clients IAS Authent icat ion Clients 

IAS Authent icat ion Server IAS Authent icat ion Server 

ICMP The ICMP performance object consists of counters that measure the 
rates at which messages are sent and received by using ICMP 
protocols. It  also includes counters that monitor ICMP protocol errors. 
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IP The IP performance object consists of counters that measure the rates 
at which IP datagrams are sent and received by using IP protocols. It  
also includes counters that monitor IP protocol errors. 

LogicalDisk The Logical Disk performance object consists of counters that monitor 
logical part i t ions of a hard or fixed disk drives. Performance M onitor 
ident i fies logical disks by their a drive let ter, such as C. 

Memory The Memory performance object consists of counters that describe the 
behavior of physical and virtual memory on the computer. Physical 
memory is the amount of random access memory on the computer.. 
Virtual memory consists of the space in physical memory and on disk. 
Many of the memory counters monitor paging, which is the 
movement of pages of code and data between disk and physical 
memory. Excessive paging, a symptom of a memory shortage, can 
cause delays which in terfere with al l  system processes. 

NBT Connect ion The NBT Connect ion performance object consists of counters that 
measure the rates at which bytes are sent and received over the NBT 
connect ion between the local computer and a remote computer. The 
connect ion is ident i fied by the name of the remote computer. 

Network Interface The Network Interface performance object consists of counters that 
measure the rates at which bytes and packets are sent and received 
over a TCP/IP network connect ion. It  includes counters that monitor 
connect ion errors. 

Objects The Object performance object consists of counters that monitor 
logical objects in  the system, such as processes, threads, mutexes, and 
semaphores. This in formation can be used to detect  the unnecessary 
consumption of computer resources. Each object requires memory to 
store basic in formation about the object. 

Paging Fi le The Paging Fi le performance object consists of counters that monitor 
the paging fi le(s) on the computer. The paging fi le is a reserved space 
on disk that backs up committed physical memory on the computer. 

PhysicalDisk The Physical Disk performance object consists of counters that 
monitor hard or fixed disk drive on a computer. Disks are used to store 
fi le, program, and paging data and are read to retrieve these i tems, and 
writ ten to record changes to them. The values of physical disk 
counters are sums of the values of the logical disks (or part i t ions) in to 
which they are divided. 

Print  Queue Displays performance stat ist ics about a Print Queue. 

Process The Process performance object consists of counters that monitor 
running appl icat ion program and system processes. Al l  the threads in  
a process share the same address space and have access to the same 
data. 

Process Address Space The Process Address Space performance object consists of counters 
that monitor memory al locat ion and use for a selected process. 

Processor The Processor performance object consists of counters that measure 
aspects of processor act ivi ty The processor is the part  of the computer 
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that performs ari thmetic and logical computat ions, in i t iates 
operat ions on peripherals, and runs the threads of processes. A 
computer can have mult iple processors. The processor object 
represents each processor as an instance of the object. 

Redirector The Redirector performance object consists of counter that monitor 
network connect ions originat ing at the local computer. 

Server The Server performance object consists of counters that measure 
communicat ion between the local computer and the network. 

Server Work Queues The Server Work Queues performance object consists of counters that 
monitor the length of the queues and objects in  the queues. 

SMTP NTFS Store Driver This object represents global counters for the Exchange NTFS Store 
driver. 

SMTP Server The counters specific to the SMTP Server. 

System The System performance object consists of counters that apply to 
more than one instance of a component processors on the computer. 

TCP The TCP performance object consists of counters that measure the 
rates at which TCP Segments are sent and received by using the TCP 
protocol. It  includes counters that monitor the number of TCP 
connect ions in  each TCP connect ion state. 

Telephony The Telephony System. 

Thread The Thread performance object consists of counters that measure 
aspects of thread behavior. A thread is the basic object that executes 
instruct ions on a processor. Al l  running processes have at least one 
thread. 

UCP The UCP performance object consists of counters that measure the 
rates at which UCP datagrams are sent and received by using the UCP 
protocol. It  includes counters that monitor UCP protocol errors. 

For in formation on the registry counters refer to the documentat ion or developer network for that product 
or the developer ki t  provided with the product. For M icrosoft  products, refer to 
http:/ /msdn.microsoft .com/ l ibrary/default .aspx.  

 

SAP R/ 3 Rem ote Ex tended Coun ters 

The fol lowing extended SAP R/3 remote counters are provided. These counters extend the monitoring of 
your SAP R/3 system: 

Act ive Servers 

Act ive Users 

Alerts 

Buffer Stat ist ics 

CCMS Monitoring 

Connect ion Test (SM59) 

Page/Roll  Area  

Page/Roll  Area M ax 

Process Monitoring  

Spool Queue 

System Log Entries 

Top CPU Uti l izat ion 
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CPU Consumption 

Itemized Act ive Users 

Itemized Job Status 

Itemized Spool Queue 

Job Status 

Memory Usage 

Number of Dumps  

Top Load 

User Funct ion Call   

Workload Stat ist ic 

Work Processes 

 

 

SNM P Coun ters 

SNMP Counters  

SNMP Remote M onitoring uses the SNMP service to provide network and system counters. SNMP counters 
can be retrieved from any machine that is running an SNMP server. QALoad uses the default  SNMP port  
(161) and default  Community (publ ic). If necessary, you can enter a different port  and community in  the 
Configure Monitor Dialog screen when you create or edit  an SNMP monitoring task and when you create 
or edit  an SNMP monitoring template. Although SNMP does not require a user name and password, the 
SNMP agent must be configured to al low read-only access from the Conductor machine.  

In  addit ion to the standard SNMP counters supported by QALoad Remote Monitoring, you can create your 
own custom Object Ident i fier (OID) fi le with counters you define. See Customizing SNMP Counter 
Discovery for more in formation. 

Standard SNMP Counters  

Standard SNMP counters that are supported by QALoad Remote M onitoring are categorized below.  

ICMP 

i cm pIn M sgs/ sec: the rate at which ICMP messages are received 
i cm pIn Errors: the number of ICMP messages received having ICMP errors 
Icm pIn DestUnreachs: the number of ICMP Dest inat ion Unreachable messages received 
Icm pInTim eExcds: the number of ICMP Time Exceeded messages received 
Icm pIn Parm Probs: the number of ICMP Parameter Problem messages received 

Icm pInSrcQuenchs: the number of ICMP Source Quench messages received 
i cm pInRedi rects/ sec: the rate at which ICMP Redirect messages are received 
i cm pIn Echos/ sec: the rate at which ICMP Echo messages are received 
i cm pIn EchoReps/ sec: the rate at which ICMP Echo Reply messages are received 
i cm pInTim estam ps/ sec: the rate at which ICMP Timestamp messages are received 
i cm pInTim estam pReps/ sec: the rate at which ICM P Timestamp Reply messages are received 
i cm pIn AddrM asks: the number of ICMP Address Mask Request messages received 
i cm pIn AddrM askReps: the number of ICMP Address Mask Reply messages received 
i cm pOutM sgs/ sec: the rate at which ICMP messages are sent 
i cm pOutM sgs/ sec: the number of ICMP messages not sent due to ICMP errors 
i cm pOutDestUn reachs: the number of ICMP Dest inat ion Unreachable messages sent 
i cm pOutTim eExcds: the number of ICMP Time Exceeded messages sent 
i cm pOutParm Probs: the number of ICMP Parameter Problem messages sent 
i cm pOutSrcQuen chs: the number of ICMP Source Quench messages sent 
i cm pOutRedi rects/ sec: the number of ICMP Redirect messages sent 
i cm pOutEchos/ sec: the number of ICMP Echo messages sent 
i cm pOutEchoReps/ sec: the number of ICMP Echo Reply messages sent 
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i cm pOutTim estam ps/ sec: the number of ICMP Timestamp messages sent 
i cm pOutTim estam pReps/ sec: the number of ICMP Timestamp Reply messages sent 
i cm pOutAddrM asks: the number of ICMP Address Mask Request messages sent 
i cm pOutAddrM askReps: the number of ICMP Address Mask Reply messages sent 

IP 

ipForw arding: the indicat ion of whether th is ent i ty is act ing as an IP router in  respect to the forwarding of 
datagrams received by, but not addressed to, th is ent i ty. 
i pDefaul tTTL: the default  value inserted in to the Time-To-Live field of the IP header of datagrams 
originated at th is ent i ty, whenever a TTL value is not suppl ied by the transport  layer protocol. 
i pInReceives/ sec: the rate of input datagrams received from interfaces, including those received in error. 
i pInHdrErrors: the number of input datagrams discarded due to errors in  their IP headers, including bad 
checksums, version number mismatch, other format errors, t ime-to-l ive exceeded, errors discovered in 
processing their IP opt ions, and so on. 
i pInAddrErrors: the number of input datagrams discarded because the IP address in  their IP header's 
dest inat ion field was not a val id address to be received at th is ent i ty. 
i pForw Datagram s/ sec: the rate of input datagrams for which th is ent i ty was not their final IP dest inat ion, 
as a result  of which an attempt was made to find a route to forward them to that final dest inat ion. 
i pInUn know n Protos: the number of local ly-addressed datagrams receive successful ly but discarded 
because of an unknown or unsupported protocol. 
i pIn Discards: the number of input IP datagrams for which no problems were encountered to prevent their 
cont inued processing, but which were discarded (for example, for lack of buffer space). 
i pIn Del i vers/ sec: the rate of input datagrams successful ly del ivered to IP user-protocols (including ICMP). 
i pOutRequests: the number of IP datagrams which local IP user-protocols (including ICMP) suppl ied to IP 
in  requests for transmission. 
i pOutDiscards: the number of output IP datagrams for which no problem was encountered to prevent 
their t ransmission to their dest inat ion, but which were discarded (for example, for lack of buffer space). 
i pOutNoRoutes: the number of IP datagrams discarded because no route could be found to transmit them 
to their dest inat ion. 
i pReasm Tim eout : the maximum number of seconds which received fragments are held while they are 
await ing reassembling at th is ent i ty. 
i pReasm Reqds: the number of IP fragments received which needed to be reassembled at th is ent i ty. 
i pReasm OKs: the number of IP datagrams successful ly re-assembled. 
i pReasm Fai l s: the number of fai lures detected by the IP re-assembly algori thm (for whatever reason: t imed 
out, errors, etc). 
i pFragOKs: the number of IP datagrams that have been successful ly fragmented at th is ent i ty. 
i pFragFai l s: the number of IP datagrams that have been discarded because they needed to be fragmented at 
th is ent i ty but could not be, for example, because their Don't  Fragment flag was set. 
i pFragCreates/ sec: the rate of IP datagram fragments that have been generated as a result  of fragmentat ion 
at th is ent i ty. 
i pRout ingDiscards: the number of rout ing entries which were chosen to be discarded even though they 
are val id. 

SNMP 

snm pInPk ts/ sec: the rate of messages del ivered to the SNMP ent i ty from the transport  service. 
snm pOutPk ts/ sec: the rate at which SNMP Messages were passed from the SNMP protocol ent i ty to the 
transport  service. 
snm pInBadVersions: the number of SNMP messages which were del ivered to the SNMP ent i ty and were 
for an unsupported SNMP version. 
snm pInBadCom m un i tyNam es: the number of SNMP messages del ivered to the SNMP ent i ty which used a 
SNMP community name not known to said ent i ty. 
snm pInBadCom m un i tyUses: the number of SNM P messages del ivered to the SNMP ent i ty which 
represented an SNMP operat ion which was not al lowed by the SNMP community named in the message. 
snm pInASNParseErrs: the number of ASN.1 or BER errors encountered by the SNMP ent i ty when decoding 
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received SNMP messages. 
snm pInTooBigs: the number of SNMP PDUs which were del ivered to the SNMP protocol ent i ty and for 
which the value of the error-status field is tooBig. 
snm pInNoSuchNam es: the number of SNMP PDUs which were del ivered to the SNMP protocol ent i ty and 
for which the value of the error-status field is noSuchName. 
snm pInBadVal ues: the number of SNMP PDUs which were del ivered to the SNMP protocol ent i ty and for 
which the value of the error-status field is badValue. 
snm pInReadOn lys: the number val id SNMP PDUs which were del ivered to the SNMP protocol ent i ty and 
for which the value of the error-status field is readOnly. 
snm pInGen Errs: the number of SNMP PDUs which were del ivered to the SNMP protocol ent i ty and for 
which the value of the error-status field is genErr. 
snm pInTotalReqVars/ sec: the rate of M IB objects which have been retrieved successful ly by the SNM P 
protocol ent i ty as the result  of receiving val id SNMP Get-Request and Get-Next PDUs. 
snm pInTotalSetVars/ sec: the rate of M IB objects which have been altered successful ly by the SNMP 
protocol ent i ty as the result  of receiving val id SNMP Set-Request PDUs. 
snm pInGetRequests/ sec: the rate of SNMP Get-Request PDUs which have been accepted and processed by 
the SNMP protocol ent i ty. 
snm pInGetNex ts/ sec: the rate of SNMP Get-Next PDUs which have been accepted and processed by the 
SNMP protocol ent i ty. 
snm pInSetRequests/ sec: the rate of SNMP Get-Response PDUs which have been accepted and processed 
by the SNMP protocol ent i ty. 
snm pInGetRespon ses/ sec: the rate of SNMP Set-Request PDUs which have been accepted and processed 
by the SNMP protocol ent i ty. 
snm pInTraps: the number of SNMP Trap PDUs which have been accepted and processed by the SNMP 
protocol ent i ty. 
snm pOutTooBigs: the number of SNMP PDUs which were generated by the SNMP protocol ent i ty and for 
which the value of the error-status field is tooBig. 
snm pOutNoSuchNam es: the number of SNMP PDUs which were generated by the SNMP protocol ent i ty 
and for which the value of the error-status is noSuchName. 
snm pOutBadValues: the number of SNMP PDUs which were generated by the SNMP protocol ent i ty and 
for which the value of the error-status field is badValue. 
snm pOutGen Errs: the number of SNMP PDUs which were generated by the SNMP protocol ent i ty and for 
which the value of the error-status field is genErr. 
snm pOutGetRequests/ sec: the rate of SNMP Get-Request PDUs which have been generated by the SNMP 
protocol ent i ty. 
snm pOutGetNex ts/ sec: the rate of SNMP Get-Next PDUs which have been generated by the SNMP 
protocol ent i ty. 
snm pOutSetRequests/ sec: the rate of SNMP Set-Request PDUs which have been generated by the SNMP 
protocol ent i ty. 
snm pOutGetResponses/ sec: the rate of SNMP Get-Response PDUs which have been generated by the 
SNMP protocol ent i ty. 
snm pOutTraps: the number of SNMP Trap PDUs which have been generated by the SNMP protocol ent i ty. 
snm pOutTraps: indicates whether the SNMP ent i ty is permit ted to generate authent icat ionFailure traps. 

TCP 

tcpRtoAlgori thm : the algori thm used to determine the t imeout value used for retransmitt ing 
unacknowledged octets. 
tcpRtoM in : the min imum value permit ted by a TCP implementat ion for the retransmission t imeout. 
t cpRtoM ax : the maximum value permit ted by a TCP implementat ion for the retransmission t imeout. 
t cpM axConn : the l im it  on the total number of TCP connect ions the ent i ty can support. 
t cpAct i veOpens: the number of t imes TCP connect ions have made a direct t ransit ion to the SYN-SENT 
state from the CLOSED state. 
tcpAt tem ptFai l s: the number of t imes TCP connect ions have made a direct t ransit ion to the SYN-RCVD 
state from the LISTEN state. 
tcpEstabResets: the number of t imes TCP connect ions have made a direct t ransit ion to the CLOSED state 
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from either the ESTABLISHED state or the CLOSE-WAIT state. 
tcpCurrEstab: the number of TCP connect ions for which the current state is either ESTABLISHED or 
CLOSE-WAIT. 
tcpInSegs/ sec: the rate at which segments are received, including those received in error. 
t cpOutSegs/ sec: the rate at which segments are sent, including those on current connect ions but 
excluding those contain ing only retransmitted octets. 
tcpRet ransSegs/ sec: the rate at which segments are retransmitted. 
tcpIn Errs/ sec: the rate at which segments are received in error. 
t cpOutRsts/ sec: the rate at which segments contain ing the RST flag are sent. 
t cpPassiveOpen s: the total number of t imes TCP connect ions have made a direct t ransit ion to the SYN-
RCVD state from the LISTEN state. 

UDP 

udpInDatagram s/ sec: the rate of UDP datagrams being del ivered to UDP users. 
udpNoPorts/ sec: the rate of received UDP datagrams for which there was no appl icat ion at the dest inat ion 
port . 
udpInErrors: the number of received UDP datagrams that could not be del ivered for reasons other than 
the lack of an appl icat ion at the dest inat ion port . 
udpOutDatagram s/ sec: the rate at which UDP datagrams are sent.  

Solaris: Sun System 

Col l i sions/ sec: the rate of output col l isions. 
CpuUser%: the percentage of non-idle processor t ime that is spent in  user mode. 
CpuNice%: the percentage of non-idle processor t ime that is spent in  n ice mode. 
CpuSys%: the percentage of non-idle processor t ime that is spent in  system mode. 
CpuIdle%: the percentage of idle processor t ime. 
I f InPackets/ sec: the rate of input packets. 
I fOutPackets/ sec: the rate of output packets. 
I f InErrors: the total number of input errors. 
I fOutErrors: the total number of output errors. 
In terrupts/ sec: the rate of system interrupts. 
PagesIn  KBytes/ sec: the rate of pages read in from disk. 
PagesOut  KBytes/ sec: the rate of pages writ ten to disk. 
Sw apIn  KBytes/ sec: the rate at which pages are being swapped in. 
Sw apOut  KBytes/ sec: the rate at which pages are being swapped out. 

HP-UX: HP System 

AvgJobs1: the average number of jobs in  the last minute * 100. 
AvgJobs5: the average number of jobs in  the last 5 minutes * 100. 
AvgJobs15: the average number of jobs in  the last 15 minutes * 100. 
CpuUser%: the percentage of non-idle processor t ime that is spent in  user mode. 
CpuNice%: the percentage of non-idle processor t ime that is spent in  n ice mode. 
CpuSys%: the percentage of non-idle processor t ime that is spent in  system mode. 
CpuIdle%: the percentage of idle processor t ime. 
FreeM em ory KBytes: the amount of idle memory. 
FreeSw ap KBytes: the amount of free swap space on the system. 
M axProc: the maximum number of processes al lowed. 
M axUserM em  KBytes: the amount of maximum user memory on the system. 
PhysM em ory KBytes: the amount of physical memory on the system. 
Users: the number of users logged on to the machine. 

LINUX Memory 
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Avai lableSw ap KBytes: the avai lable swap on the system. 
Buf fered KBytes: the amount of memory used as buffers. 
Cached KBytes: the amount of memory cached. 
FreeM em ory KBytes: the amount of idle memory. 
Shared KBytes: the amount of memory shared. 
TotalM em ory KBytes: the total amount of memory on the system. 
TotalSw ap KBytes: the total swap size for the system. 

LINUX System 

CpuUser%: the percentage of non-idle processor t ime that is spent in  user mode. 
CpuNice%: the percentage of non-idle processor t ime that is spent in  n ice mode. 
CpuSys%: the percentage of non-idle processor t ime that is spent in  system mode. 
CpuIdle%: the percentage of idle processor t ime. 

Windows HTTP Server 

h t tpTotalFi l esSen t : the total number of fi les sent by th is HTTP server.  
h t tpTotalFi l esReceived: the total number of fi les received by th is HTTP server.  
h t tpCurren tAnonym ousUsers: the number of anonymous users current ly connected to th is HTTP server.  
h t tpCurren tNonAnon ym ousUsers: the number of non-anonymous users current ly connected to th is 
HTTP server.  
h t tpTotalAnonym ousUsers: the total number of anonymous users that have ever connected to th is HTTP 
server.  
h t tpTotalNonAnonym ousUsers: the total number of non-anonymous users that have ever connected to 
th is HTTP server.  
h t tpM ax im um Anonym ousUsers: the maximum number of anonymous users simultaneously connected 
to th is HTTP server.  
h t tpM ax im um NonAnon ym ousUsers: the maximum number of non-anonymous users simultaneously 
connected to th is HTTP server.  
h t tpCurren tConnect ions: the current number of connect ions to the HTTP server.  
h t tpM ax im um Connect ions: the maximum number of simultaneous connect ions to the HTTP server.  
h t tpConnect ionAt tem pts: the total number of connect ion attempts to the HTTP server.  
h t tpLogonAt tem pts: the total number of logon attempts to the HTTP server.  
h t tpTotalOpt ions: the total number of requests made to th is HTTP server using the OPTIONS method.  
h t tpTotalGets: the total number of requests made to th is HTTP server using the GET method.  
h t tpTotalPosts: the total number of requests made to th is HTTP server using the POST method.  
h t tpTotalHeads: the total  number of requests made to th is HTTP server using the HEAD method.  
h t tpTotalPuts: the total number of requests made to th is HTTP server using the PUT method.  
h t tpTotalDeletes: the total number of requests made to th is HTTP server using the DELETE method.  
h t tpTotalTraces: the total number of requests made to th is HTTP server using the TRACE method.  
h t tpTotalM ove: the total number of requests made to th is HTTP server using the MOVE method.  
h t tpTotalCopy: the total number of requests made to th is HTTP server using the COPY method.  
h t tpTotalM kcol : the total number of requests made to th is HTTP server using the MKCOL method.  
h t tpTotalPropf ind: the total number of requests made to th is HTTP server using the PROPFIND method.  
h t tpTotalProppatch : the total number of requests made to th is HTTP server using the PROPPATCH 
method.  
h t tpTotalSearch : the total number of requests made to th is HTTP server using the MS-SEARCH method.  
h t tpTotalLock : the total number of requests made to th is HTTP server using the LOCK method.  
h t tpTotalUn lock : the total number of requests made to th is HTTP server using the UNLOCK method.  
h t tpTotalOthers: the total number of requests made to th is HTTP server not using the OPTIONS, GET, 
HEAD, POST, PUT, DELETE, TRACE, MOVE, MKCOL, PROPFIND, PROPPATCH, MS-SEARCH, LOCK or 
UNLOCK methods.  
h t tpCurren tCGIRequests: the number of Common Gateway Interface requests current ly being serviced by 
th is HTTP server.  
h t tpCurren tBGIRequests: the number of Binary Gateway Interface requests current ly being serviced by 
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th is HTTP server.  
h t tpTotalCGIRequests: the total number of Common Gateway Interface requests made to th is HTTP 
server.  
h t tpTotalBGIRequests: the total number Binary Gateway Interface requests made to th is HTTP server.  
h t tpM ax im um CGIRequests: the maximum number of Common Gateway In terface requests 
simultaneously processed by th is HTTP server.  
h t tpM ax im um BGIRequests: the maximum number of Binary Gateway Interface requests simultaneously 
processed by th is HTTP server.  
h t tpCurren tBlockedRequests: the current number of requests being temporari ly blocked by th is HTTP 
server.  
h t tpTotalBlockedRequests: the total number of requests that have been temporari ly blocked by th is HTTP 
server.  
h t tpTotalRejectedRequests: the total number of requests that have been rejected by th is HTTP server.  

W indows FTP Server 

f tpTotalFi l esSen t : the total number of fi les sent by th is FTP server. 
f tpTotalFi l esReceived: the total number of fi les received by th is FTP server. 
f tpCurren tAnon ym ousUsers: the number of anonymous users current ly connected to th is FTP server. 
f tpCurren tNonAnonym ousUsers: the number of non-anonymous users current ly connected to th is FTP 
server. 
f tpTotalAnonym ousUsers: the total number of anonymous users that have ever connected to th is FTP 
server. 
f tpTotalNonAnon ym ousUsers: the total number of non-anonymous users that have ever connected to 
th is FTP server. 
f tpM ax im um Anon ym ousUsers: the maximum number of anonymous users simultaneously connected to 
th is FTP server. 
f tpM ax im um NonAnonym ousUsers: the maximum number of non-anonymous users simultaneously 
connected to th is FTP server. 
f tpCurren tConnect ions: the current number of connect ions to the FTP server. 
f tpM ax im um Connect ions: the maximum number of simultaneous connect ions to the FTP server. 
f tpConnect ionAt tem pts: the total number of connect ion attempts to the FTP server. 
f tpLogonAt tem pts: the total number of logon attempts to the FTP server. 

 

 

Customizing SNMP Counter Discovery  

QALoad current ly has a standard l ist  of Object Ident i fiers (OID) that i t  searches when discovering SNMP 
counters. You can create and import a l ist  of addit ional OIDs in an XML fi le. The XML fi le, cal led the 
Custom OID Fi le, in troduces addit ional SNMP counters that you want to include during the counter 
discovery phase when you create or edit  tasks and templates.   

Note: You can include multiple categories and multiple counters in the custom OID file.  

Once you create the custom OID fi le, you select i t  using the Custom OID Fi le field in  the Configure 
Monitor Dialog screen of the monitoring wizards. Since there is a one to one relat ionship between 
monitoring tasks and the custom fi le, mult iple fi les can exist . These reside in  a common, default  locat ion: 
QALoad\Monitoring\SNMP. The browse button for the Custom OID Fi le field defaults to th is locat ion. 
This directory also contains two fi les to assist  you in developing your Custom OID Fi le:  

!  OID structure.xml - a template you can use for creating your custom supplemental file. This contains the basic XML 
structure you need to create your own Custom OID file. The Table of Custom OID File Elements describes and gives 
the rules for each of the  XML elements in the structure. 

!  OID example.xml - a custom OID XML file structure. This is a sample Custom OID File.  

Custom OID Template File 
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Use the following template, located in QALoad\Monitoring\SNMP\OID structure.xml, to create your custom OID 
file: 

Back to top 

Table of Custom OID File Elements 

The fol lowing table shows each element in  the XML fi le structure, and describes i ts purpose and the rules 
that apply. 

Tag Descript i on  Rules 

<?xml version="1.0" ?> 
XML fi le header 
indicat ing fi les structural 
version. 

Must be first  element of 
fi le. 

Only one per fi le. 

<OIDCustom> 

Begin bracket for ent ire 
OID custom information. 
Used to both ident i fy 
content type and 
begin/end of fi le. 

Only one per fi le. 

Must immediately fol low 
XML version header. 

<CategoryList> 

Begin bracket for l ist  of 
categories defined in th is 
fi le. Used to help group al l  
the contained categories. 

Only one per fi le. 

Must immediately fol low 
<OIDCustom> tag. 

<Category> 

Begin bracket for an 
individual category with in 
the category l ist . Used to 
help group individual 
categories. 

One required per 
category group. 

First  instance must 
immediately fol low 
<CategoryList> tag. 
Subsequent instances 
immediately fol low 
</Category> end tag of 
previous group. 

<CategoryName>?</CategoryName> 

The display name for the 
category group. The “ ?”  
represents where the user 
defines the category 
name. 

 One required per 
category. Must 
immediately fol low 
<Category> tag. 

<Counter> 

Begin bracket for 
individual counter 
in formation contained in 
a category. Mult iple 
counters can exist  per 
category. 

One required per 
counter. 

First  instance must 
immediately fol low 
</CategoryName> tag. 
Subsequent instances 
immediately fol low 
</Counter> tag. 

<CounterName>?</CounterName> 
The display name for the 
counter. The “ ?”  
represents where the user 

One required per 
counter. 

Only one al lowed per 
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defines the counter name. counter. 

<OID>?</OID> 

The OID for the counter. 
The OID must start  with a 
period “ .”  (see example 
below). The “ ?”  represents 
where the user defines the 
OID. 

One required per 
counter. 

Only one al lowed per 
counter. 

<Units>?</Units> 

The opt ional calculat ion 
units for the counter. The 
“ ?”  represents where the 
user defines the 
calculat ion type which is 
one of the fol lowing: 

“ / sec”  – for counters that 
must take in to account 
the t ime between 
samplings. 

“ Cpu%”  – for counters 
that must take in to 
account the number of 
processors. A counter for 
which th is appl ies is 
CpuIlde%. 

“ Kbi ts/ sec”  – for 
convert ing counters that 
nat ively report  in  Kbit /sec 
to Kbytes/sec. 

Optional ly, one per 
counter. 

Only one al lowed per 
counter. 

<Descript ion>?</Descript ion> 

The opt ional descript ion 
for the counter. The “ ?”  
represents where the user 
defines the OID. 

Optional ly, one per 
counter. 

Only one al lowed per 
counter. 

</Counter> 

The end bracket for an 
individual counter 
in formation set. Used to 
denote the end of 
individual counters 
attribute in formation. 

One required per 
counter. 

</Category> 

The end bracket for an 
individual category, used 
to denote the end of a 
category and al l  of i ts 
associated counters. 

One required per 
category. 

</CategoryList> 
End bracket for l ist  of 
categories. 

Only one per fi le. 

Must immediately 
precede <OIDCustom> 
tag. 
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</OIDCustom> 
End bracket for ent ire OID 
custom information. Used 
to ident i fy the end of fi le. 

Only one per fi le. 

Must be last fi le element. 

 

Back  to top 

 Custom OID Sample File 

The sample Custom OID File shown here is located in QALoad\Monitoring\SNMP\OID example.xml: 

 

WebLogic7/ 8 Rem ote Coun ters 

The fol lowing dynamical ly discovered WebLogic remote extended counter categories are provided in 
QALoad. Each category provides counters that extend the monitoring of your WebLogic system. The 
categories, counter names, and parameters are al l  dynamical ly discovered by processing the set of MBeans 
avai lable in  the WebLogic JMX Server. 
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WebLogic Appl icat ion Runtime 

WebLogic Connector Service Runtime 

WebLogic Deployer Runtime 

WebLogic Domain Log Handler Runt ime 

WebLogic Domain Runtime 

WebLogic EJB Cache Runtime 

WebLogic EJB Component Runt ime 

WebLogic EJB Locking Runtime 

WebLogic EJB Pool Runt ime 

WebLogic EJB Transact ion Runtime 

WebLogic Ent i ty EJB Runtime 

WebLogic Execute Queue Runtime 

WebLogic JDBC Connect ion Pool Runt ime 

WebLogic JMS Connect ion Runtime 

WebLogic JMS Consumer Runtime 

WebLogic JMS Dest inat ion Runtime 

WebLogic JMS Runtime 

WebLogic JMS Server Runt ime 

WebLogic JMS Session Runtime 

WebLogic JTA Recovery Runtime 

WebLogic JTA Runtime   

WebLogic JVM Runtime 

WebLogic Log Broadcaster Runt ime 

WebLogic Message Driven EJB Runtime 

WebLogic M igratable Service Coordinator 
Runt ime 

WebLogic Server Life Cycle Runtime 

WebLogic Server Runt ime 

WebLogic Server Securi ty Runt ime 

WebLogic Servlet Runt ime 

WebLogic Stateful EJB Runtime 

WebLogic Stateless EJB Runtime 

WebLogic Time Service Runtime 

WebLogic Transact ion Resource Runtime 

WebLogic Web App Component Runt ime 

WebLogic Web Server Runt ime 

 

 

 

WebLogic9 Coun ters 

ServerVantage provides the fol lowing dynamical ly discovered WebLogic9 remote counter categories. Each 
category provides counters that extend the monitoring of your WebLogic system. The categories, counters 
names, and parameters are al l  dynamical ly discovered by processing the set of MBeans avai lable in  the 
WebLogic JMX Server. 

WebLogic App Client Component Runt ime 

WebLogic Appl icat ion Runtime 

WebLogic Cluster Runt ime 

WebLogic Component Runt ime 

WebLogic Connector Component Runt ime 

WebLogic Connector Connect ion Pool Runt ime 

WebLogic Connector Connect ion Runtime 

WebLogic Connector Service Runtime 

WebLogic EJB Cache Runtime 

WebLogic EJB Component Runt ime 

WebLogic EJB Locking Runtime 

WebLogic JVM Runtime 

WebLogic Library Runtime 

WebLogic Log Broadcaster Runt ime 

WebLogic Max Threads Constraint Runt ime 

WebLogic Message Driven EJB Runtime 

WebLogic M in Threads Constraint Runt ime 

WebLogic NonXA Resource Runtime 

WebLogic Persistent Store Connect ion Runtime 

WebLogic Persistent Store Runtime 

WebLogic Query Cache Runtime 

WebLogic Request Class Runtime 
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WebLogic EJB Pool Runt ime 

WebLogic EJB Timer Runt ime 

WebLogic EJB Transact ion Runtime 

WebLogic Ent i ty Cache Cumulat ive Runtime 

WebLogic Ent i ty Cache Current State Runtime 

WebLogic Execute Queue Runtime 

WebLogic Intercept ion Component Runt ime 

WebLogic JDBC Data Source Runtime 

WebLogic JDBC Data Source Task Runtime 

WebLogic JMS Component Runt ime 

WebLogic JMS Connect ion Runtime 

WebLogic JMS Consumer Runtime 

WebLogic JMS Dest inat ion Runtime 

WebLogic JMS Durable Subscriber Runt ime 

WebLogic JMS Pooled Connect ion Runtime 

WebLogic JMS Producer Runtime 

WebLogic JMS Remote Endpoint Runt ime 

WebLogic JMS Runtime 

WebLogic JMS Server Runt ime 

WebLogic JMS Session Pool Runt ime 

WebLogic JMS Session Runtime 

WebLogic Jolt  Connect ion Pool Runt ime 

WebLogic Jolt  Connect ion Service Runtime 

WebLogic JRockit  Runt ime 

WebLogic JTA Recovery Runtime 

WebLogic JTA Runtime 

WebLogic SAF Agent Runt ime 

WebLogic SAF Remote Endpoint Runt ime 

WebLogic Server Channel  Runt ime 

WebLogic Server Life Cycle Runtime 

WebLogic Server Life Cycle Task Runtime 

WebLogic Server Runt ime 

WebLogic Server Securi ty Runt ime 

WebLogic Servlet Runt ime 

WebLogic Task Runtime 

WebLogic Thread Pool Runt ime 

WebLogic Transact ion Name Runtime 

WebLogic Transact ion Resource Runtime 

WebLogic User Lockout Manager Runtime 

WebLogic WAN Replicat ion Runtime 

WebLogic Web App Component Runt ime 

WebLogic Web Server Runt ime 

WebLogic WLDF Archive Runtime 

WebLogic WLDF Data Access Runtime 

WebLogic WLDF Dbstore Archive Runtime 

WebLogic WLDF Fi le Archive Runtime 

WebLogic WLDF Harvester Runt ime 

WebLogic WLDF Image Creat ion Task Runtime 

WebLogic WLDF Instrumentat ion Runtime 

WebLogic WLDF Watch Noti ficat ion Runtime 

WebLogic WLDF Wlstore ArchiveRuntime 

WebLogic Work Manager Runtime 

WebLogic Wsee Operat ion Runtime 

WebLogic WSRM Remote Endpoint Runt ime 

 

 

 

 

WebSphere Rem ote Ex tended Coun ters 

The fol lowing dynamical ly discovered WebSphere remote extended counter categories are provided in 
QALoad. Each category provides counters that extend the monitoring of your WebSphere system. The 
categories, counter names, and parameters are al l  dynamical ly discovered by processing data avai lable from 
the WebSphere Performance Monitoring Infrastructure. 
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Remote monitoring supports WebSphere versions: 4.0+, 5.0, and 6.0. The counters supported vary by 
version.  

WebSphere Alarm M anager Counters 

WebSphere Bean Module   

WebSphere Cache Module   

WebSphere Connect ion Pool Module  

WebSphere DCS Stack Counters 

WebSphere High Avai labi l i ty Manager Counters 

WebSphere J2C Module   

WebSphere JVM Runtime Module  

WebSphere ORB Perf Module  

WebSphere Scheduler Module 

WebSphere Servlet Sessions Module  

WebSphere System Module  

WebSphere Thread Pool Module 

WebSphere Transact ion Module  

WebSphere Web App M odule  

WebSphere Web Services Counters 

 

 

WebSphere M Q Rem ote Ex tended Coun ters  

The fol lowing extended WebSphere MQ remote counters are provided in QALoad. These counters extend 
the monitoring of your WebSphere MQ system: 

Channel Events 

Channel Status 

Error Log Entries 

Percent Queue Depth 

Performance Events 

Queue Depth 

Queue Manager Connect ions 

Queue Manager Events 

Queue Manager Stat ist ics 

Queue Manager Up/Down 

Queue Stat ist ics 

 

 

WM I Rem ote Ex tended Coun ters 

The fol lowing extended WMI (Windows M anagement Instrument) remote counters are provided in 
QALoad. To display and use the extended counters in  task configurat ion, you must configure user access 
with the MMC (M icrosoft  Management Console) and configure the WMI agent using the ServerVantage 
Agent Console (Reconfigure Agent). These procedures are described in the topic Configuring WMI in  the 
ServerVantage Agent Configurat ion onl ine help. Once configurat ion is complete, and you select WMI 
col lector as your Server Type during task configurat ion on the Select Counters page, ServerVantage 
discovers the Windows registry counters and the extended counters for each WMI-configured server.      

These counters extend the monitoring of your WMI system: 

WMI WQL 

 
WMI Top Ten Counters: 

!  CPU Utilization % - Top Ten 

!  Memory Utilization % - Top Ten 

!  I/O Utilization % - Top Ten 

 

 

Oracle Appl i cat ion  Server Coun ters 
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ServerVantage provides the fol lowing dynamical ly discovered Oracle Appl icat ion Server (AS) remote 
extended counter categories for remote monitoring of Oracle10g Applicat ion Server performance metrics. 
Each category provides counters and parameters that extend the monitoring of your Oracle AS system. The 
Oracle AS agent dynamical ly discovers al l  avai lable counters and parameter values. The avai lable categories 
and metrics vary by instal lat ion. The Oracle AS agent supports wi ld-carded parameters and resource 
blackouts.   

Supported platforms for Oracle AS include: 

!  Solaris 

!  AIX 

!  HP 

!  Linux 

!  Microsoft Windows 2000 with Service Pack 3 or above 

!  Microsoft Windows Server 2003 (32-bit) 

!  Microsoft Windows XP (not all components are supported) 

Oracle AS Counter Categories 

Oracle AS EJB Method Metrics 

Oracle AS Enti ty Bean Metrics 

Oracle AS HTTP OC4J Metrics  

Oracle AS HTTP Server M etrics 

Oracle AS HTTP Server M odule Metrics 

Oracle AS HTTP Server Response Metrics 

Oracle AS HTTP Server Virtual Host Metrics 

Oracle AS JDBC Connect ion Metrics 

Oracle AS JDBC Connect ion Source Metrics 

Oracle AS JDBC M etrics 

Oracle AS JDBC Statement  Metrics 

Oracle AS JMS Browser Metrics 

Oracle AS JMS Connect ion Metrics 

Oracle AS JMS Consumer Metrics 

Oracle AS JMS Durable Subscript ion Metrics 

Oracle AS JMS Metrics 

Oracle AS JMS Persistence Metrics 

Oracle AS JMS Producer M etrics 

Oracle AS JMS Session Metrics 

Oracle AS JMS Store Metrics 

Oracle AS JMS Temp Dest inat ion Metrics 

Oracle AS JServ JSP Metrics 

Oracle AS JServ Metrics 

Oracle AS JServ Servlet M etrics 

Oracle AS JServ Zone Metrics 

Oracle AS JSP Metrics   

Oracle AS JVM Metrics 

Oracle AS Noti ficat ion Server Metrics 

Oracle AS OC4J Transact ion Manager M etrics 

Oracle AS PLSQL Metrics 

Oracle AS Portal Engine Metrics 

Oracle AS Process M anager Metrics   

Oracle AS Servlet Metrics 

Oracle AS Task Manager Metrics 

Oracle AS Web Module M etrics 

10g Release 2 Counter Categories 

Oracle AS Portal Cache M etrics 

Oracle AS Portal Cache Summary Metrics 

Oracle AS Portal DB Provider Metrics   

Oracle AS Portal Page M etrics   

Oracle AS Portal DB Repository Metrics  

Oracle AS Portal Web Provider Metrics 

 

 

JVM  Coun ters 
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ServerVantage provides the fol lowing stat ical ly discovered categories for mon itoring a Java Virtual M achine 
(JVM). Each category provides counters that al low the monitoring of your JVM. ServerVantage ut i l izes the 
Java Monitoring and Management API which were in troduced in J2SE 5.0 for counter data.  

JVM Class Loading 

JVM Compilat ion 

JVM Garbage Collect ion 

JVM Memory 

JVM Operat ing System  

JVM Threads 

Guideline:  

You must start  your JVM as a "JMX-enabled JVM"by insert ing the fol lowing propert ies:  

C:\...\java -Dcom.sun.management.jmxremote.port=1095 - 
Dcom.sum.management.jmxremote.ssl=false  -
Dcom.sun.management.jmxremote.authenticate=false   

For more in formation, see http:/ / java.sun.com/ j2se/1.5.0/docs/guide/management/agent.html. 

 

 

RStat  Coun ters 

ServerVantage Agent provides stat ical ly discovered categories for monitoring Unix using RStat. RStat is a 
Unix command to acquire stat ist ics about the network including socket status, in terfaces that have been 
auto-configured, memory stat ist ics, and rout ing tables. 

 

Col l ision Rate 

Context Switches 

Disk Transfer Rate 

Fifteen M inute Load Average 

Five M inute Load Average 

Incoming Packet Error Rate 

Interrupt Rate 

Network Errors 

Nice Mode CPU Uti l izat ion Percentage 

One M inute Load Average 

Outgoing Packet Error Rate 

Packets In 

Packets Out 

Page In Rate 

Page Out Rate 

Paging I/O Rate 

RPC Status 

Swap In Rate 

Swap Out Rate 

System Mode CPU Uti l izat ion Percentage 

System Uptime 

Total CPU Uti l izat ion Percentage 

Total Packet Rate 

Use Mode CPU Uti l izat ion Percentage 

 

 

Managing Counters 

Adding Coun ters to a Task  Using New  Discovery Data 
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Add counters to a monitoring task by generat ing the avai lable counter data and select ing the counters and 
instances to add to the task. 

To add count er s and inst ances t o a m oni t or ing t ask : 

1. From the Conductor menu bar, click Tools>Monitor Tasks to open the Manage Monitoring Tasks dialog window. 

2. Open or create a task. 

3. In the menu bar, click Actions>Add counter>Use new discovery counters. The Edit Existing Monitor Wizard 
appears. 

4. Follow the instructions for using the wizard to discover and add counters to the monitoring task. 

Notes:  

!  (WebLogic and WebSphere) When the monitor to which you are adding counters is managed 
by an administrat ive server, the Edit  Exist ing Monitor wizard appears and the counter discovery 
process begins immediately.  

!  (SNMP) You can supplement the counter discovery l ist  by creat ing and specifying a custom 
OID fi le. See Customizing SNMP Counter Discovery for more in formation.   

 

Adding Coun ters to a Task  Using Cached Discovery Data 

It  is possible to add counters to monitor for a machine and monitor type using cached discovery data. To 
add counters to a task using cached discovery, do the fol lowing: 

Step 1:  Select the counter to add or modify 

Step 2: Choose the instances of the counter to mon itor 

Step 3: Review the monitor defin i t ion 

Step 4: Save the task 

 

St ep 1: Select  t he count er  t o add or  m odi f y: 

1. From the Conductor menu bar, click Tools>Monitor Tasks to open the Manage Monitoring Tasks dialog window. 

2. In the menu bar, click  Actions>Add counter>Use cached discovery counters. This Add/Edit Counters dialog 
box appears. 

3. From the Available Items pane, select the Template tab or the Counter tab. 

4. To add an item, select a template or a counter, and click Add, or double-click the item to display it in the Selected 
Items pane. Click Add All to add all the items on the selected tab to the Selected Items pane.  

5. To remove an item, double-click the item in the Selected Items pane or select the item and click Remove. The item 
is returned to the Available Items pane.  

Note: Select multiple counters and templates by doing one of the following:  

!  To select nonadjacent counter i tems, cl ick a counter i tem, and then hold down Ct rl  and cl ick 
each addit ional counter i tem.  

!  To select adjacent counter i tems, cl ick the first  counter i tem in the sequence, and then hold 
down Sh i f t  and cl ick the last counter i tem.  

6. Click Next. The Choose Instances dialog box displays. 

Note: When you select a template, and some of the counters it contains are not present on the machine 
you are defining, you receive a message with a list of the counters that will not be added to the task. 
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St ep 2: Choose t he inst ances of  t he count er  t o m oni t or : 

When cl icking Nex t  in  the previous dialog box. The Choose Instances dialog box appears. 

1. Review the counters selected. When a red dot appears next to a counter, select an instance of the counter.  

2. Double-click the counter group to display the counters. 

3. Select a counter and click Edit. The Select instance for counter dialog box appears. 

4. In the Available Instance pane, select an instance and click Add. 

5. Repeat until all instances of the counter that you want to apply to the task are selected. 

6. Click Save. The Choose Instances dialog box appears.  

7. Repeat this process for each designated counter.  

8. Click Next. The Summary dialog box displays. 

St ep 3: Review  t he m oni t or  def in i t ion: 

1. In  the Review M onitor Defin i t ion dialog box, review the in formation for the monitoring machine 
you defined. 

2. Select one of the fol lowing: 

!  Set  up another m on i tor for th i s task  - returns to the Enter propert ies of the 
monitoring machine dialog box so you can add another monitor to the monitoring 
task. When complete, proceed with Step 3 below. 

!  Cont inue w i thout  adding any m ore m on i tors - cont inues in  th is dialog box. 

Note: (WebLogic and WebSphere) When you set up another monitor in a managed server environment, 
you only can add another monitor using a different administrative server.  

!  To add a WebLogic monitor, you must use the same WebLogic jar fi les and WebLogic version 
as the current monitor. 

!  To add a WebSphere monitor, you must use the same  WebSphere Home, WebSphere cl ient 
version, and WebSphere server version as the current monitor.  

3. (Optional) In  the M on i tors pane, select the monitor type and cl ick Save as Tem plate to create a 
template for th is monitoring task.  

4. (Optional) In  the M on i tors pane, select a monitor and cl ick Rem ove M on i tor to delete a monitor 
from the task. 

5. (Optional) Type a new value in  the Sam ple In terval  field. This is the frequency, in  seconds, at 
which QALoad requests data during runt ime data col lect ion. 

6. Click Nex t  to proceed to the next step, where you review and save your select ions. 

St ep 4: Save t he t ask : 

When cl icking Nex t  in  the previous dialog box, the Sum m ary dialog box appears. 

1. On the Summary dialog box, review the monitors and counters selected for the template. Click Back to return to a 
dialog box and make changes to the information. 

2. Click Finish to add the counters. 

 

Rem oving a M on i tor or a Coun ter f rom  a M on i toring Task   
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Remove a monitor or a counter from a monitoring task, by fol lowing th is procedure. 

To rem ove a count er  f r om  a m oni t or ing  t ask : 

1. In the Monitors pane of the Manage Monitoring Tasks window, select the monitor, counter, or counter family to 
delete. 

2. Click Actions>Remove Monitor/Counter.  

3. When the verification dialog box displays, click OK. 

Note: You cannot remove the last monitor on a machine, the last counter in the family, or the last family of 
counters in the task. 

 

Monitoring Templates 

About  M on i toring Tem plates 

Monitoring templates are designed to faci l i tate the configurat ion process. A monitoring template is a 
predefined group of counters not associated with a specific machine. You can create a new template for a 
monitoring task, or you can use one of QALoad's pre-defined templates. 

When you create a custom template, QALoad's New Monitoring Template wizard guides you through the 
process of defin ing the type of template you want to create, configuring the monitor propert ies, and 
adding the counters and instances of counters to the template. 

When you use one of QALoad's predefined templates, you select a stored template with the counters you 
want to monitor. The templates have counters grouped by funct ional i ty, such as Network Traffic, Response 
Time, or System Health. Where appropriate, the templates include the specif ic instances to monitor for 
each counter. 

You can add or edit  counters in  either custom or pre-defined templates. When you open a template to edit  
i t  for the first  t ime, Edit  Monitoring Template wizard guides you through the process of discovering and 
adding new counters to a template. When you've just completed the counter discovery process for a 
template, either by creat ing a new template or by opening a template for edit ing, you can select counters 
from those already avai lable in  memory by using the cached discovery.  

 

 

Custom  Tem plates  

You can create templates of the monitoring tasks that you develop so that al l  of the counters and instances 
for the task are saved. You can create new tasks and incorporate the template you created. Templates are 
saved as .xml fi les in  the Templates directory. 

You can create a template when you define a monitoring task, or you can use the New Monitor Template 
wizard to create and store a template for future use. Custom templates can be modified using either new 
discovery data or cached discovery data. 

 

 

 

 

Pre-def ined Tem plates 

About Pre-defined Templates  
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QALoad provides pre-defined templates for each monitor type. Each template includes the counters most 
commonly used for part icular task with in each monitor type.  

QALoad provides the templates form the fol lowing monitor types: 

!  Oracle Application Server 

!  JVM 

!  SAP 

!  SNMP 

!  WebLogic 

!  WebSphere 

!  WebSphere MQ 

!  Windows Registry 

!  WMI 

Note: You cannot modify pre-defined templates. 
 

Viewing Pre-defined Templates 

QALoad provides pre-defined templates for each monitor type. These include the counters most commonly 
used for part icular task. 

To access and review  pre-def ined t em plat es: 

1. In the Conductor, select Tools>Monitor Tasks to open the Manage Monitoring Tasks window.  

2. In the Manage Monitoring Tasks menu bar, click Templates>Open Existing. The Select a Monitor Template File 
dialog box appears and lists pre-defined templates and custom templates you created and saved. 

3. Double-click a monitor type, then select a template file and click Open. 

4. The template name displays in the Manage Monitoring Tasks dialog box. 

Oracle Appl icat ion Server Templates 

Oracle Application Server Template Index 

QALoad provides the fol lowing pre-defined Oracle Appl icat ion Server (AS) 10g database templates: 

Oracle AS Avai labi l i ty 

Oracle AS Performance 

 

Oracle Application Server Availabil ity 

This template monitors the avai labi l i ty of an Oracle Appl icat ion Server (AS) 10g database.  

Note: This template is only avai lable i f you have Oracle AS 10g instal led on your monitored 
server.   

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Oracle AS HTTP OC4J M et ri cs OC4JUnavai lable Total number of t imes that an oc4j JVM could not 
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be found to service requests. 

 UnableToHandleReq Total number of t imes mod_oc4j decl ined to handle 
a request. 

Oracle AS HTTP Server M et ri cs readyChildren Number of ch i ld processes that are ready to run. 

Oracle AS Process M an ager 
M et ri cs 

reqFail  Number of HTTP requests which fai l . 

 

 

Oracle Application Server Performance 

This template monitors the avai labi l i ty of an Oracle Appl icat ion Server (AS) 10g database.  

Note: This template is only avai lable i f you have Oracle AS 10g instal led on your monitored 
server.   

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Oracle AS HTTP OC4J M et ri cs ErrReqSess Specifies the total number of session requests that 
mod_oc4j fai led to route to an OC4J process. 

 SucReqSess Specifies the total number of session requests that 
mod_oc4j successful ly routed to an OC4J process. 

Oracle AS HTTP Server M et ri cs busyChildren Number of ch i ld processes act ive. 

 connect ion.avg Average t ime spent servicing HTTP connect ions. 

 request.avg Average t ime required to service an HTTP request. 

 

 

 

RStat Templates 

QALoad RStatd Health 

This template monitors the status of the Remote Procedure Call  (RPC) to the monitored Unix computer.  

The QALoad RStatd Health template uses the fol lowing RStat extended counters: 

Coun ters Descript i on  

RPC Status a Boolean rstat parameter that shows the status of the 
Remote Procedure Call  (RPC) to the monitored Unix 
computer. A status of Down means that the RSM cannot 
communicate with or col lect performance information 
about the computer from the rstatd server.  
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QALoad Server Availabil ity 

This template monitors the avai labi l i ty of UNIX servers.  

The QALoad Server Avai labi l i ty template uses the fol lowing RStat extended counters: 

Coun ters Descript i on  

System Uptime shows the amount of t ime since the monitored element 
was started. 

 

QALoad Server Performance 

This template monitors the performance of the UNIX server.  

The QALoad Server Performance template uses the fol lowing RStat extended counters: 

Coun ters Descript i on  

Context Switches shows the per-second number of CPU context switches.  

Paging I/O Rate shows the amount of CPU t ime across al l  processors that 
was spent wait ing for input and output operat ions.  

RPC Status a Boolean rstat parameter that shows the status of the 
Remote Procedure Call  (RPC) to the monitored Unix 
computer. A status of Down means that the RSM cannot 
communicate with or col lect performance information 
about the computer from the rstatd server.  

Total CPU Uti l izat ion 
Percentage 

shows the percentage of CPU that current ly is not in the 
idle state for al l  CPUs on the monitored computer. 

QALoad Server Health 

This template monitors the overal l  condit ion of the UNIX server.  

The QALoad Server Health template uses the fol lowing RStat extended counters: 

Coun ters Descript i on  

Disk Transfer Rate shows the per-second rate of disk transfers for each disk 
on the monitored element. 

Paging I/O Rate shows the amount of CPU t ime across al l  processors that 
was spent wait ing for input and output operat ions.  

Total CPU Uti l izat ion 
Percentage 

shows the percentage of CPU that current ly is not in the 
idle state for al l  CPUs on the monitored computer. 

SAP Templates 

SAP Templates 

QALoad provides the fol lowing pre-defined SAP templates: 

QALoad-SAP R3 Remote Avai labi l i ty 
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QALoad-SAP R3 Remote Performance 

QALoad-SAP R3 Remote System Errors 

 

 

QALoad-SAP R3 Remote Availabil ity 

This template monitors the avai labi l i ty of an SAP R/3 Instance. The SAP R/3 Avai labi l i ty template returns 
cri t ical in formation about  the avai labi l i ty of your SAP instal lat ion. One metric used to determine the 
avai labi l i ty of an SAP R/3 Instance is the status of the SAP col lector. 

The default  event act ion assigned to th is template issues an alarm if ei ther the specified R/3 Instance or the 
col lector goes down. The default  instance is the first  SAP Instance configured for monitoring during 
instal lat ion. 

The SAP R/3 Avai labi l i ty template uses the fol lowing SAP R/3 extended counters: 

Coun ters Descript i on  

Act ive Servers Returns the number of act ive SAP appl icat ion servers for 
a given instance. It  detects when a remote server is 
unavai lable. 

Rule:  IF  'SAP R/3 Remote Extended.Act ive Servers(SAP 
Instance: "**", Server Count: "10")' = 0 . 

QALoad-SAP R3 Remote Performance 

This template monitors the performance of your SAP R/3 Instance. 

The default  event act ion for th is template raises an event i f the number of alerts of cri t ical status is greater 
than 0, or i f the buffer h it rat io fal ls below 95%. 

Al l  the counters associated with th is template require the instance number of your SAP instal lat ion. By 
default , th is template uses the first  instance configured for monitoring during ServerVantage instal lat ion. If 
you use the task configurat ion wizard to change the instance that the template monitors, you must also 
change the instance specified in  the rule accordingly. 

The SAP R/3 Performance template uses the fol lowing SAP R/3 extended counters: 

Coun ters Descript i on  

Buffer Stat ist ic Returns different buffer stat ist ics for selected buffer name. This 
counter was chosen because buffering data is a key to the 
performance of SAP. 

Rule: IF  'SAP R/3 Remote Extended.Buffer Stat ist ic(SAP Instance: 
"**", Buffer Name: "TTAB", Stat ist ic Name: "Hit  rate SAP 
buffer(%%)")' < 95. 

 Itemized Spool Queue Return number of entries in  the spool queue that match the 
specified cri teria. 

Rule: IF   'SAP R/3 Remote Extended.Spool Queue(SAP Instance: 
"**", Request Status: "Processing")' > 10. 

Memory Usage Returns current memory usage.  

Rule: IF   'SAP R/3 Remote Extended.Memory Usage(SAP Instance: 
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"**", Count: "10", Metrics: "MB")' > 10000. 

Page/Roll  Area Returns Used Paging Area % stat ist ic. This counter was chosen 
because rol l  memory is cri t ical for work processes and page 
memory is cri t ical for in ternal data processing. 

 Work Processes Counter for monitoring SAP R/3 work processes. Returns number 
of stopped work processes.  

Rule: IF 'SAP R/3 Remote Extended.Work Processes(SAP Instance: 
"**", Process Type: "BGDDIAENQSPOUP2UPD", Process State: 
"Stopped")' > 2. 

 

   

 

QALoad-SAP R3 Remote System Errors 

This template monitors the errors and cri t ical si tuat ions that occur on a SAP R/3 system. Rules and 
thresholds are preset to appropriate values for most si tes. 

The default  sampling in terval for th is template is 5 minutes. 

The SAP R/3 Performance template uses the fol lowing SAP R/3 Remote extended counters: 

Coun ters Descript i on  

Alerts Counter for monitoring R/3 alerts. Returns number of alerts 
according to the specified cri teria. This counter checks al l  alerts 
with error (red) status.  

Rule: IF 'SAP R/3 Remote Extended.Alerts(SAP Instance: "**", 
Monitor Set: "SAP CCMS Admin Workplace", Moni tor: 
"Database", Severi ty: "Error - Red", Pattern: "*", Show Alert  Text: 
"No")' > 0. 

Itemized Spool Queue Return number of entries in  the spool queue that match the 
specified cri teria. 

Spool Queue Return number of entries in  the spool queue that match the 
specified cri teria. This counter checks al l  spool entries with 
“ Problem”  status.  

Rule: IF 'SAP R/3 Remote Extended.Spool Queue(SAP Instance: 
"**", Request Status: "Problem")' > 0. 

Work Processes Counter for monitoring SAP R/3 work processes. Returns number 
of work processes according to the specified cri teria. This counter 
checks stopped work processes.  

Rule: IF 'SAP R/3 Remote Extended.Work Processes(SAP Instance: 
"**", Process Type: "BGDDIAENQSPOUP2UPD", Process State: 
"Stopped")' > 0. 

SNMP Templates 
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SNMP Templates 

QALoad provides the fol lowing pre-defined SNMP templates: 

QALoad-HP Performance 

QALoad-Linux Performance 

QALoad-SUN Performance 

 

QALoad-HP Performance 

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

HP System  CpuIdle% CpuSys% is the percentage of idle processor 
t ime. 

 CpuSys% CpuSys% is the percentage of non-idle 
processor t ime that is spent in  system mode. 

  CpuUser% CpuUser% is the percentage of non-idle 
processor t ime that is spent in  user mode. 

 FreeMemory KBytes FreeMemory KBytes is the amount of idle 
memory. 

 FreeSwap KBytes FreeSwap is the amount of free swap space on 
the system. 

 MaxUserMem KBytes MaxUserMem is the amount of maximum user 
memory on the system. 

 Users Users is the number of users logged on to the 
machine. 

tcp  tcpInSegs/sec tcpInSegs/sec is the rate at  which segments are 
received, including those received in error. 

 tcpOutSegs/sec tcpOutSegs/sec is the rate at which segments 
are sent, including those on current 
connect ions but excluding those contain ing 
only retransmitted octets. 

 udp udpInDatagrams/sec udpInDatagrams/sec is the rate of UDP 
datagrams being del ivered to UDP users. 

 udpOutDatagrams/sec udpOutDatagrams/sec is the rate at which UDP 
datagrams are sent. 
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QALoad-Linux Performance 

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Linux  System  CpuIdle% CpuSys% is the percentage of idle processor 
t ime. 

 CpuSys% CpuSys% is the percentage of non-idle processor 
t ime that is spent in  system mode. 

  CpuUser% CpuUser% is the percentage of non-idle 
processor t ime that is spent in  user mode. 

 In terrupts/sec Interrupts/sec is the rate of system interrupts. 

  PagesIn KBytes/sec PagesIn KBytes/sec is the rate of pages read in 
from disk. 

  PagesOut KBytes/sec PagesOut KBytes/sec is the rate of pages writ ten 
to disk. 

 SwapIn KBytes/sec SwapIn KBytes/sec is the rate at which pages are 
being swapped in. 

 SwapOut KBytes/sec SwapOut KBytes/sec is the rate at which pages 
are being swapped out. 

t cp  tcpInSegs/sec tcpInSegs/sec is the rate at  which segments are 
received, including those received in error. 

 tcpOutSegs/sec tcpOutSegs/sec is the rate at which segments are 
sent, including those on current connect ions 
but excluding those contain ing only 
retransmitted octets. 

 udp udpInDatagrams/sec udpInDatagrams/sec is the rate of UDP 
datagrams being del ivered to UDP users. 

 udpOutDatagrams/sec udpOutDatagrams/sec is the rate at which UDP 
datagrams are sent. 

 

QALoad-SUN Performance 

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Sun  System  CpuIdle% CpuSys% is the percentage of idle processor 
t ime. 

 CpuSys% CpuSys% is the percentage of non-idle processor 
t ime that is spent in  system mode. 
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  CpuUser% CpuUser% is the percentage of non-idle 
processor t ime that is spent in  user mode. 

 In terrupts/sec Interrupts/sec is the rate of system interrupts. 

  PagesIn KBytes/sec PagesIn KBytes/sec is the rate of pages read in 
from disk. 

  PagesOut KBytes/sec PagesOut KBytes/sec is the rate of pages writ ten 
to disk. 

 SwapIn KBytes/sec SwapIn KBytes/sec is the rate at which pages are 
being swapped in. 

 SwapOut KBytes/sec SwapOut KBytes/sec is the rate at which pages 
are being swapped out. 

t cp  tcpInSegs/sec tcpInSegs/sec is the rate at  which segments are 
received, including those received in error. 

 tcpOutSegs/sec tcpOutSegs/sec is the rate at which segments are 
sent, including those on current connect ions 
but excluding those contain ing only 
retransmitted octets. 

 udp udpInDatagrams/sec udpInDatagrams/sec is the rate of UDP 
datagrams being del ivered to UDP users. 

 udpOutDatagrams/sec udpOutDatagrams/sec is the rate at which UDP 
datagrams are sent. 

 

       

WebLogic Templates 

WebLogic Templates 

QALoad provides the fol lowing pre-defined WebLogic templates: 

QALoad-WebLogic Avai labi l i ty 

QALoad-WebLogic EJB Performance 

QALoad-WebLogic JDBC Performance 

QALoad-WebLogic JMS Performance 

QALoad-WebLogic Performance 

QALoad-WebLogic Server Securi ty 

QALoad-WebLogic Servlet  Performance 

 

QALoad-WebLogic Availabil ity 

This template monitors the avai labi l i ty of a WebLogic server. The WebLogic Avai labi l i ty template returns 
cri t ical in formation about  the avai labi l i ty of your WebLogic instal lat ion.  

The default  sampling in terval for th is template is 5 minutes. 
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The WebLogic Avai labi l i ty template uses the fol lowing WebLogic extended counters: 

Category Coun ters Descript i on  

ExecuteQueueRun t im e ExecuteQueueRuntime_PendingRequestOldestTime Returns the t ime 
that the longest 
wait ing request 
was placed in 
the queue.  

Rule: The 
Applicat ion 
Server is not in  
running mode i f 
th is counter 
value is > 50. 

ServerRun t im e ServerRuntime_StateVal Returns current 
state of the 
server.  This 
counter provides 
a more detai led 
state than 
avai lable or not.  

Rule: The 
Applicat ion 
Server is not in  
running mode i f 
th is counter 
value is <> 2. 

ServerSecuri tyRun t im e ServerSecuri tyRuntime_LockedUsersCurrentCount Returns the 
number of 
current ly locked 
users on th is 
server.  

Rule: There are a 
h igh number of 
users locked out 
i f th is counter 
value is  > 5. 

 

      

 

 

QALoad-WebLogic EJB Performance 

This template monitors the EJB performance of a WebLogic server. The WebLogic EJB Performance 
template returns cri t ical in formation about the performance of your WebLogic instal lat ion.  

The default  sampling in terval for th is template is 5 minutes. 

The WebLogic EJB Performance template uses the fol lowing WebLogic extended counters: 
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Category Coun ters Descript i on  

EJBCacheRun t im e EJBCacheRuntime_Activat ionCount Returns the 
total number 
of t imes the 
EJB was 
act ivated. 

Rule: There is 
inefficient 
cache access i f 
the number of 
act ivat ions is > 
20. 

 EJBCacheRuntime_CacheAccessCount Returns the 
total number 
of attempts to 
access a bean 
from the 
cache.  

 EJBCacheRuntime_CachedBeansCurrentCount Returns the 
total number 
of beans from 
th is EJB Home 
current ly in  
the EJB cache.  

 EJBCacheRuntime_CacheHitCount Returns the 
total number 
of t imes an 
attempt to 
access a bean 
from the cache 
succeeded. The 
cacheHitCoun
t value 
subtract ing the 
cache miss 
count from 
the cache 
access count. 

 EJBCacheRuntime_Passivat ionCount Returns the 
total number 
of beans from 
th is EJB Home 
that have been 
passivated.  

Rule: There is 
inefficient 
cache access i f 
the number of 
passivat ions is 
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> 20. 

EJBLock ingRun t im e EJBLockingRuntime_LockEntriesCurrentCount Returns the 
number of 
current ly 
locked users 
on th is server. 

 EJBLockingRuntime_TimeoutTotalCount Returns the 
current 
number 
Threads that 
have t imed 
out wait ing for 
a lock on a 
bean.  

 EJBLockingRuntime_WaiterTotalCount Returns the 
number of 
objects wait ing 
on the lock. 

Rule: There are 
a lot  of objects 
wait ing i f the 
in terval value 
of th is counter 
is > 10. 

EJBPoolRun t im e EJBPoolRuntime_BeansInUseCurrentCount Returns the 
number of 
bean instances 
current ly 
being used 
from the free 
pool.  

 EJBPoolRuntime_IdleBeansCount Returns the 
total number 
of avai lable 
bean instances 
in  the free 
pool.  

 EJBPoolRuntime_TimeoutTotalCount Returns the 
total number 
of Threads 
that have 
t imed out 
wait ing for an 
avai lable bean 
instance from 
the free pool.  

Rule: There are 
a lot  of objects 
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t im ing out i f 
the in terval 
value of th is 
counter is  > 
20. 

 EJBPoolRuntime_WaiterTotalCount Returns the 
total number 
of Threads 
current ly 
wait ing for an 
avai lable bean 
instance from 
the free pool.  

Rule: There are 
a lot  of objects 
wait ing i f the 
in terval value 
of th is counter 
is > 10. 

EJBTransact ionRun t im e EJBTransact ionRuntime_Transact ionsCommittedTotalCount Returns the 
total number 
of t ransact ions 
that have been 
committed for 
th is EJB.  

Rule: There is 
h igh 
transact ion 
overhead i f the 
in terval value 
of th is counter 
is > 20. 

 EJBTransact ionRuntime_Transact ionsRolledBackTotalCount Returns the 
total number 
of t ransact ions 
that have been 
rol led back for 
th is EJB.  

Rule: There is 
h igh 
transact ion 
overhead i f the 
in terval value 
of th is counter 
is > 20. 

 EJBTransact ionRuntime_Transact ionsTimedOutTotalCount Returns the 
total number 
of t ransact ions 
that have 
t imed out for 
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th is EJB.  

Rule: There is 
h igh 
transact ion 
overhead i f the 
in terval value 
of th is counter 
is > 20. 

 M essageDriven EJBRun t im e MessageDrivenEJBRuntime_JMSConnect ionAlive Returns a 
boolean of the 
status of the 
connect ion. 
This counter 
displays the 
state of a JMS 
connect ion.  

Rule: The JMS 
Connect ion is 
down i f th is 
counter value 
is = 0. 

 

       

 

 

QALoad-WebLogic JDBC Performance 

This template monitors the JDBC performance of a WebLogic server. The WebLogic JDBC Performance 
template returns cri t ical in formation about the performance of your WebLogic instal lat ion.  

The default  sampling in terval for th is template is 5 minutes. 

The WebLogic JDBC Performance template uses the fol lowing WebLogic extended counters: 

Category Coun ters Descript i on  

JDBC Connect ion  Pool  
Run t im e 

Act iveConnect ionsCurrentCount Returns the current number of act ive 
connect ions. 

 Act iveConnect ionsHighCount Returns the h ighest number of act ive 
current connect ions. The count starts 
at zero each t ime the 
JDBCConnect ionPoolRuntimeMBean 
is instant iated. 

 Connect ionDelayTime Returns the number of mil l iseconds i t  
takes to get a physical connect ion 
from the database. It  is calculated as 
summary t ime to connect  divided by 
summary number of connect ions. 
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 Connect ionsTotalCount Returns the total number of JDBC 
connect ions in  th is 
DBCConnect ionPoolRunt imeMBean 
since the pool was instant iated. 

 Fai luresToReconnectCount Returns the number of attempts to 
refresh a connect ion to a database 
that fai led. Fai lure may be due to the 
database being unavai lable or a 
broken connect ion to the database. 

Rule: There are a h igh number of 
connect ion reconnect fai lures when 
th is counter value is > 1. 

 LeakedConnect ionCount  Returns the number of connect ions 
that were checked out from the 
connect ion pool but were not 
returned to the pool by cal l ing close 
(). 

Rule: There is a lot  of connect ion 
pool leakage i f th is counter value is  > 
5. 

 PoolState Current state of the connect ion pool. 
Returns True i f the pool is enabled, 
False i f the pool is disabled. 

  PrepStmtCacheMissCount Returns a count  of the cases when 
the cache does not have a cached 
statement to sat isfy a request. 

 Wait ingForConnect ionHighCount The h igh water mark of waiters for a 
connect ion in  th is 
JDBCConnect ionPoolRuntimeMBean. 
The count starts at zero each t ime the 
JDBCConnect ionPoolRuntimeMBean 
is instant iated.  

 WaitSecondsHighCount Returns the h ighest number of 
seconds a connect ion wai ted. 

Rule: There is a long wait  for the 
connect ion pool i f th is counter value 
is  > 120. 

 

    

 

QALoad-WebLogic JMS Performance 

This template monitors the JMS performance of a WebLogic server. The WebLogic JMS Performance 
template returns cri t ical in formation about the performance of your WebLogic instal lat ion.  

The default  sampling in terval for th is template is 5 minutes. 
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The WebLogic JMS Performance template uses the fol lowing WebLogic extended counters: 

Category Coun ters Descript i on  

JM SConnect ionRun t im e SessionsCurrentCount Returns the current number of 
sessions for th is connect ion. 

 SessionsTotalCount Returns the number of sessions 
on th is connect ion since the last 
reset. 

JM SRun t im e Connect ionsCurrentCount Returns the current number of 
connect ions to th is WebLogic 
Server. 

  Connect ionsTotalCount Returns the total number of 
connect ions made to th is 
WebLogic Server since the last 
reset. 

JM SServerRun t im e MessagesPendingCount Returns the current number of 
messages pending 
(unacknowledged or 
uncommitted) stored on th is 
JMS server. Pending messages 
are over and above the current 
number of messages. 

Rule: There are a large number 
of pending messages i f th is 
counter value is > 50. 

 MessagesReceivedCount Returns the number of messages 
received on th is dest inat ion 
since the last reset. 

 JM SSessionRun t im e ConsumersCurrentCount Returns the current number of 
consumers for th is session. 

 MessagesPendingCount Returns the number of messages 
pending (uncommitted and 
unacknowledged) for th is 
session.   

Rule: There are a large number 
of pending JMS Session 
messages i f th is counter value is 
> 50. 

 MessagesReceivedCount Returns the number of messages 
received on th is dest inat ion 
since the last reset. 

  MessagesSentCount Returns the number of bytes 
sent by th is session since the 
last reset. 
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QALoad-WebLogic Performance 

This template monitors the performance of a WebLogic server. The WebLogic Performance template 
returns cri t ical in formation about the performance of your WebLogic instal lat ion.  

The default  sampling in terval for th is template is 5 minutes. 

The WebLogic Performance template uses the fol lowing WebLogic extended counters: 

Category Coun ters Descript i on  

ConnectorServi ceRun t im e Connect ionPoolCurrentCount Returns the number of 
current ly deployed 
connect ion pools. 

ExecuteQueueRun t im e ExecuteThreadCurrentIdleCount Returns the number of idle 
threads assigned to the 
queue. 

 PendingRequestCurrentCount Returns the number of 
wait ing requests in  the 
queue. 

Rule: There are a large 
number of pending requests 
i f th is counter value is > 50. 

 ServicedRequestTotalCount Returns the number of 
requests that have been 
processed by th is queue. 

JM SRun t im e Connect ionsCurrentCount Returns the current number 
of connect ions to th is 
WebLogic Server.  

Rule: There are a large 
number of JMS connect ions 
i f th is counter value is > 20. 

 JTARun t im e Act iveTransact ionsTotalCount Returns the number of act ive 
transact ions on the server. 

 SecondsAct iveTotalCount  Returns the total number of 
seconds for al l  committed 
transact ions. 

 Transact ionRolledBackResourceTotalCount Returns the number of 
t ransact ions that were rol led 
back due to a resource error. 

 Transact ionTotalCount Returns the total number of 
t ransact ions processed. This 
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total includes al l  committed, 
rol led back and heurist ic 
transact ion complet ions. 

JVM Run t im e  HeapFreeCurrent Returns the current amount 
of free memory (in  bytes) in  
the JVM heap. 

 Tim eServiceRun t im e Except ionCount Returns the total number of 
except ions thrown while 
execut ing scheduled triggers. 

Rule: There are a large 
number of except ions i f the 
in terval value of th is counter 
is > 20. 

 Execut ionsPerM inute Returns the average number 
of t riggers executed per 
minute.  

 

 

 

 

 

QALoad-WebLogic Server Security 

This template monitors the securi ty of a WebLogic server. The WebLogic Server Securi ty template returns 
cri t ical in formation about  the securi ty status of your WebLogic instal lat ion.  

The default  sampling in terval for th is template is 5 minutes. 

The WebLogic Server Securi ty template uses the fol lowing WebLogic extended counters: 

Category Coun ters Descript i on  

ServerSecuri tyRun t im e Inval idLoginAttemptsTotalCount Returns the cumulat ive number of 
inval id login attempts made on th is 
server.  

Rule: Mult iple inval id login 
attempts have occurred when the 
in terval value of th is counter is > 5.  

 LockedUsersCurrentCount Returns the number of current ly 
locked users on th is server.  

Rule: There are mult iple locked 
users i f th is counter value is > 5. 

 LoginAttemptsWhileLockedTotalCount Returns the cumulat ive number of 
inval id login attempts made on th is 
server whi le the user was locked. 
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 UnlockedUsersTotalCount Returns the number t imes users 
have been unlocked on th is server. 

     

 

 

QALoad-WebLogic Servlet Performance 

This template monitors the performance of your WebLogic servlet.  The WebLogic Servlet Performance 
template returns cri t ical in formation about the servlet performance of your WebLogic instal lat ion. 

The default  sampling in terval for th is template is 5 minutes. 

The WebLogic Servlet Performance template uses the fol lowing WebLogic extended counters: 

Category Coun ters Descript i on  

ServletRun t im e Execut ionTimeAverage Returns the average t ime al l  invocat ions of the 
servlet that has executed since the task was 
created.  

Rule: The servlet is averaging h igh execut ion 
t imes i f th is counter value average is > 10. 

 Execut ionTimeHigh Returns the amount of t ime the single longest 
invocat ion of the servlet that has executed 
since the task was created. 

 Execut ionTimeTotal Returns the total amount of t ime al l  
invocat ions of the servlet that has executed 
since the task was created. 

 In ternalServlet whether th is is an Internal Servlet or not 

 Invocat ionTotalCount Returns the total number of t imes the servlet 
has been invoked. Gets the 
invocat ionTotalCount attribute of the 
ServletRuntimeMBean object. 

  ReloadTotalCount Returns the total number of t imes the servlet is 
reloaded. Gets the reloadTotalCount attribute 
of the ServletRuntimeMBean object. 

 

      

 

 

WebSphere Templates 

WebSphere Templates 

QALoad provides the fol lowing pre-defined WebSphere templates: 

QALoad-WebSphere 5.0 JDBC Performance 
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QALoad WebSphere 5.0 Performance 

QALoad-WebSphere 5.0 Web Applicat ion Performance 

 

QALoad-WebSphere 5.0 JDBC Performance 

This template monitors the performance of a WebSphere JDBC server. The WebSphere JDBC Performance 
template returns cri t ical in formation about the JDBC performance of your WebSphere instal lat ion.  

The default  sampling in terval for th is template is 5 minutes. 

The WebSphere JDBC Performance template uses the fol lowing WebSphere extended counters: 

Category Coun ters Descript i on  

JDBC 
Connect io
n  Pool  
M odule 

connect ionPoolModule.avgWaitTime Average wait ing t ime in mil l iseconds unt i l  a connect ion is granted.

  connect ionPoolModule.concurrentWaiters WebSphere extended counter for monitoring 
connect ionPoolModule.concurrentWaiters 

 connect ionPoolModule.faults Average wait ing t ime in mil l iseconds unt i l  a connect ion is granted.

 connect ionPoolModule.percentMaxed Average percent of the t ime that al l  connect ions are in  use. 

Rule: IF   'WebSphere 
connect ionPoolModule.connect ionPoolM odule.percentMaxed(Node: 
"**", Server: "**", Data Source: "al l")' > 25. 

 connect ionPoolModule.percentUsed Average percent of the pool that is in  use. 

 

      

QALoad-WebSphere 5.0 W eb Application Performance 

This template monitors the performance of a WebSphere 5.0 Web Applicat ion server. The WebSphere 5.0 
Web Applicat ion Performance template returns cri t ical in formation about the Web Applicat ion 
performance of your WebSphere instal lat ion.  

The default  sampling in terval for th is template is 5 minutes. 

The WebSphere 5.0 Web Applicat ion Performance template uses the fol lowing WebSphere extended 
counters: 

Category Coun ters Descript i on  

WebSphere 
servletSessionsM odule 

servletSessionsModule.act ivateNonExistSessions Number of requests for a 
session that no longer exists, 
presumably because the 
session t imed out. This 
counter may indicate a h igh 
number of t imeout 
condit ions. 
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 servletSessionsModule.act iveSessions The number of concurren t ly 
act ive sessions. A session is 
act ive i f WebSphere is 
current ly processing a 
request, which uses that 
session. This counter may 
indicate h igh act ivi ty.  

 servletSessionsModule.cacheDiscards Number of session objects 
that have been forced out of 
the cache. This counter may 
indicate a need for more 
memory in  the cache.  

 servletSessionsModule.inval idatedSessions Number of sessions 
inval idated. This counter 
may indicate a h igh number 
of inval idated sessions. 

 servletSessionsModule.inval idatedViaTimeout Number of requests for a 
session that no 
CountStat ist ic exists, 
presumably because the 
session t imed out. This 
counter may indicate a h igh 
number of t imeout 
condit ions. 

WebSphere 
w ebAppM odule 

webAppModule.servlets.concurrentRequests Number of requests that are 
concurrent ly processed. This 
counter may indicate h igh 
act ivi ty for an appl icat ion . 

 webAppModule.servlets.numErrors Total number of errors in  a 
servlet or Java Server Page 
(JSP). This counter may 
indicate a h igh number of 
error incidents. 

 webAppModule.servlets.responseTime Response t ime, in  
mil l iseconds, of a servlet 
request. This counter may 
indicate a slow response 
t ime of a request. 

 

 

 

 

 

QALoad WebSphere 5.0 Performance 

This template includes the fol lowing counters and categories: 
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Category Coun ters Descript i on  

WebSphere 
jvm Run t im eM odul
e 

jvmRuntimeModule.freeMemory WebSphere extended counter for 
monitoring 
jvmRuntimeModule.freeMemory 

 jvmRuntimeModule.usedMemory WebSphere extended counter for 
monitoring 
jvmRuntimeModule.usedMemory 

WebSphere 
orbPerfM odule 

orbPerfModule.concurren tRequests WebSphere extended counter for 
monitoring 
orbPerfModule.concurren tRequests 

 orbPerfModule.in terceptors.processingTime WebSphere extended counter for 
monitoring 
orbPerfModule.in terceptors.processingTime

 orbPerfModule.referenceLookupTime WebSphere extended counter for 
monitoring 
orbPerfModule.referenceLookupTime 

WebSphere 
system M odule 

systemModule.avgCpuUti l izat ion WebSphere extended counter for 
monitoring 
systemModule.avgCpuUti l izat ion 

 systemModule.freeMemory WebSphere extended counter for 
monitoring systemModule.freeMemory 

WebSphere 
th readPoolM odule 

hreadPoolModule.act iveThreads WebSphere extended counter for 
monitoring 
threadPoolM odule.act iveThreads 

 

    

WebSphere MQ Templates 

WebSphere MQ Templates 

QALoad provides the fol lowing pre-defined WebSphere MQ templates: 

QALoad-WebSphere MQ Avai labi l i ty 

QALoad-WebSphere MQ Performance 

 

QALoad-WebSphere MQ Availabil ity 

This template monitors the avai labi l i ty of a WebSphere MQ server. The WebSphere MQ Avai labi l i ty 
template returns cri t ical in formation about the avai labi l i ty of your WebSphere MQ instal lat ion.  

The default  sampling in terval for th is template is 5 minutes. 

The WebSphere MQ Avai labi l i ty template uses the fol lowing WebSphere MQ extended counters: 

Coun ters Descript i on  
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Channel Events Return the number of channel events for the curren t 
in terval. 

Queue Manager Events Reports the number of queue manager events for the 
current in terval. 

Queue Manager 
Up/Down 

Monitors the running state of a queue manager. 

 

QALoad-WebSphere MQ Performance 

This template monitors the performance of a WebSphere MQ server. The WebSphere MQ Performance 
template returns cri t ical in formation about the performance of your WebSphere MQ instal lat ion.  

The default  sampling in terval for th is template is 5 minutes. 

The WebSphere MQ Performance template uses the fol lowing WebSphere MQ extended counters: 

Coun ters Descript i on  

Performance Events This counter reports the number of 
performance events for the current 
in terval. 

 

 

 

   

WMI Templates 

WMI Templates 

QALoad provides the fol lowing pre-defined WMI templates: 

QALoad-Act ive M onitoring Avai labi l i ty  

QALoad-Citrix IMA Networking  

QALoad-Citrix Metaframe All   

QALoad-Citrix MetaFrame IMA  

QALoad-Citrix MetaFrame Zone  

QALoad-Cold Fusion  

QALoad-Generic Appl icat ion Avai labi l i ty and Performance  

QALoad-MS IIS Avai labi l i ty  

QALoad-MS IIS Performance  

 

QALoad-Active Monitoring Availabil ity  

This template includes the fol lowing counters and categories: 
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Category Coun ters Descript i on  

M em ory Avai lable M Bytes  

Processor % Processor Time  

System  System Up Time  

 

QALoad-Citrix IMA Networking  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Ci t r i x  IM A Netw ork ing Bytes Received/sec  

 Bytes Sent/sec  

 Network Connect ions  

 Netw ork  In terface Bytes Total/sec  

 

QALoad-Citrix Metaframe All  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Ci t r i x  M etaFram e XP Applicat ion Enumerat ions/sec  

 Appl icat ion Resolut ion Time 
(ms) 

 

 Appl icat ion Resolut ions/sec  

 Data Store Connect ion Fai lure  

 DataStore bytes read/sec  

 DataStore bytes writ ten/sec  

 DataStore reads/sec  

 DataStore writes/sec  

 Dynamic Store bytes read/sec  

 DynamicStore bytes 
writ ten/sec 
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 DynamicStore reads/sec  

 DynamicStore writes/sec  

 Fi l tered Appl icat ion 
Enumerat ions/sec 

 

 LocalHostCache bytes 
read/sec 

 

 LocalHostCache bytes 
writ ten/sec 

 

 LocalHostCache reads/sec  

 LocalHostCache writes/sec  

 Zone Elect ions  

 Zone Elect ions Won  

M em ory Page Reads/sec  

PhysicalDisk  % Disk Time  

Processor % Processor Time  

 

QALoad-Citrix MetaFrame IMA  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Ci t r i x  M etaFram e 
XP 

Applicat ion Enumerat ions/sec  

 Appl icat ion Resolut ion Time (ms)  

  Appl icat ion Resolut ions/sec  

 Data Store Connect ion Fai lure  

 DataStore bytes read/sec  

 DataStore bytes writ ten/sec  

 DataStore reads/sec  

 DataStore writes/sec  
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 Fi l tered Appl icat ion 
Enumerat ions/sec 

 

 LocalHostCache bytes read/sec  

 LocalHostCache bytes wri t ten/sec  

 LocalHostCache reads/sec  

 LocalHostCache writes/sec  

Term inal  Servi ces Act ive Sessions  

 Total Sessions  

 

QALoad-Citrix MetaFrame Zone  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Ci t r i x  M etaFram e 
XP 

Dynamic Store bytes read/sec  

 DynamicStore bytes 
writ ten/sec 

 

 DynamicStore reads/sec  

 DynamicStore writes/sec  

 LocalHostCache bytes read/sec  

 LocalHostCache bytes 
writ ten/sec 

 

 LocalHostCache reads/sec  

  Zone Elect ions  

  Zone Elect ions Won  

Netw ork  In terface  Bytes Total/sec  

 Current Bandwidth  

Term inal  Servi ces Act ive Sessions  

 Total Sessions  
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QALoad-Cold Fusion 

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

ColdFusion  M X 
Server 

 Avg DB Time (msec)  

 Avg Queue Time (msec)  

 Avg Req Time (msec)  

 Bytes In /  Sec  

 Bytes Out /  Sec  

 DB Hits /  Sec  

 Page Hits /  Sec  

 Queued Requests  

 Running Requests  

 Timed Out Requests  

M em ory % Committed Bytes In Use  

 Avai lable Bytes  

 Page Faults/sec  

Process % Processor Time  

 

QALoad-Generic Application Availabil ity and Performance  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Process % Processor Time  

System  System Up Time  

 

QALoad-MS IIS Availabil ity  

This template includes the fol lowing counters and categories: 
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Category Coun ters Descript i on  

System  System Up Time  

Web Servi ce Current Anonymous 
Users 

 

 Current Connect ions  

 Logon Attempts/sec  

 NonAnonymous 
Users/sec 

 

 Not Found Errors/sec  

 Total Delete Requests  

 Total Fi les Sent  

 Total Get Requests  

 Total NonAnonymous 
Users 

 

 Total Not Found Errors  

 

QALoad-MS IIS Performance  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

In ternet  
In form at ion  
Servi ces Global  

Current Blocked Async I/O 
Requests 

 

 Total Blocked Async I/O 
Requests 

 

 Total Rejected Async I/O 
Requests 

 

 URI Cache Flushes  

 URI Cache Hits  

 URI Cache Hits %  

 URI Cache M isses  

PhysicalDisk  % Disk Time  
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Process % Processor Time  

Redi rector  Current Commands  

 Network Errors/sec  

Server Work Item Shortages  

Server Work  
Queues 

Queue Length  

 Web Servi ce Not Found Errors/sec  

 

 

Windows Registry Templates 

Windows Registry Templates  

QALoad provides the fol lowing pre-defined Windows Registry templates: 

QALoad-Act ive M onitoring Avai labi l i ty 

QALoad-Citrix IMA Networking  

QALoad-Citrix Metaframe al l   

QALoad-Citrix Metaframe IMA  

QALoad-Citrix Metaframe Zone  

QALoad-Cold Fusion 

QALoad-Generic Appl icat ion Avai labi l i ty and Performance  

QALoad-MS IIS Avai labi l i ty  

QALoad-MS IIS Performance  

QALoad-Server Health  

QALoad-Windows Avai labi l i ty 

QALoad-Windows Performance 

 

QALoad-Active Monitoring Availabil ity 

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

M em ory Avai lable M Bytes This counter monitors the Act ive 
Monitoring cl ient si te and not i fies 
you when i t  is low on resources, 
where Processor t ime is > 95% for 
more than 3 in tervals. The parameter 
for th is counter is Instance.  The 
default  is   _Total. 
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Processor % Processor Time Raise an event when Act ive 
Monitoring cl ient si te is low on 
memory resources, where Avai lable 
Memory is at or below 1M B for more 
than 3 in tervals. 

System  System Up Time This counter tests the network 
connect ion between two machines 
and monitors the communicat ion 
status of the machine that receives 
communicat ion. 

 

 

 

QALoad-Citrix IMA Networking  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Ci t r i x  IM A 
Netw ork ing 

Bytes 
Received/sec(“ _Total” ) 

This counter monitors the 
total bytes received per 
second. 

 Bytes 
Sent/sec(“ _Total” ) 

This counter monitors  the 
total bytes sent per second. 

 Network Connect ions This counter monitors the 
network connect ions. 

 Netw ork  In terface Bytes Total/sec This counter monitors the 
network connect ion total 
bytes/sec. 

 

      

QALoad-Citrix Metaframe all  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Ci t r i x  M etaFram e XP Applicat ion Enumerat ions/sec This counter monitors 
appl icat ion enumerat ions /  
sec. 

 Appl icat ion Resolut ion Time 
(ms) 

This counter monitors 
appl icat ion resolut ion 
t ime. 

 Appl icat ion Resolut ions/sec This counter monitors 
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applicat ion resolut ions. 

 Data Store Connect ion Fai lure This counter monitors 
datastore connect ion fai lure. 

 DataStore bytes read/sec This counter monitors 
datastore bytes reads per 
second. 

 DataStore bytes writ ten/sec This counter monitors 
datastore bytes  wri t ten per 
second. 

 DataStore reads/sec This counter monitors 
datastore reads per second. 

 DataStore writes/sec This counter monitors 
datastore writes per second. 

 Dynamic Store bytes read/sec This counter monitors 
DynamicStore bytes read per 
second. 

 DynamicStore bytes 
writ ten/sec 

This counter monitors 
DynamicStore bytes writ ten 
per second. 

 DynamicStore reads/sec This counter monitors 
DynamicStore reads per 
second. 

 DynamicStore writes/sec This counter monitors 
DynamicStore writes per 
second. 

 Fi l tered Appl icat ion 
Enumerat ions/sec 

This counter monitors 
Fi l tered Appl icat ion 
Enumerat ions per second. 

 LocalHostCache bytes read/sec This counter monitors 
 LoadHostCache bytes read 
per second. 

 LocalHostCache bytes 
writ ten/sec 

This counter monitors 
 LoadHostCache bytes 
writ ten per second. 

 LocalHostCache reads/sec This counter monitors 
 LoadHostCache reads per 
second. 

 LocalHostCache writes/sec This counter monitors 
 LoadHostCache writes per 
second. 

 Zone Elect ions This counter monitors zone 
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elect ions. 

 Zone Elect ions Won This counter monitors zone 
elect ions won. 

M em ory Page Reads/sec This counter monitors page 
reads per second. 

PhysicalDisk  % Disk Time This counter monitors % 
disk t ime. 

Processor % Processor Time This counter monitors % 
processor t ime. 

 

    

QALoad-Citrix Metaframe IMA  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Ci t r i x  M etaFram e 
XP 

Applicat ion Enumerat ions/sec This counter monitors the 
appl icat ion enumerat ion per 
second. 

 Appl icat ion Resolut ion Time (ms) This counter monitors the 
appl icat ion resolut ion t ime. 

  Appl icat ion Resolut ions/sec This counter monitors the 
appl icat ion resolut ion. 

 Data Store Connect ion Fai lure This counter monitors the 
datastore connect ion fai lure. 

 DataStore bytes read/sec This counter monitors the 
datastore bytes read per second. 

 DataStore bytes writ ten/sec This counter monitors the 
datastore bytes writ ten per second. 

 DataStore reads/sec This counter monitors the 
datastore reads per second. 

 DataStore writes/sec This counter monitors the 
datastore writes per second. 

 Fi l tered Appl icat ion 
Enumerat ions/sec 

This counter monitors fi l tered 
appl icat ion enumerat ions per 
second. 

 LocalHostCache bytes read/sec This counter monitors 
LoadHostCache bytes read per 
second. 
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 LocalHostCache bytes wri t ten/sec This counter monitors 
LoadHostCache bytes writ ten per 
second. 

 LocalHostCache reads/sec This counter monitors 
LoadHostCache reads per second. 

 LocalHostCache writes/sec This counter monitors 
LoadHostCache writes per second. 

Term inal  Servi ces Act ive Sessions This counter monitors act ive 
sessions. 

 Total Sessions This counter monitors total 
sessions. 

 

        

         

             

QALoad-Citrix Metaframe Zone  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Ci t r i x  M etaFram e 
XP 

Dynamic Store bytes read/sec This counter monitors the dynamic 
store bytes read /  sec. 

 DynamicStore bytes 
writ ten/sec 

This counter monitors the dynamic 
store bytes writ ten /  sec. 

 DynamicStore reads/sec This counter monitors the dynamic 
store reads /  sec. 

 DynamicStore writes/sec This counter monitors the dynamic 
store writes /  sec. 

 LocalHostCache bytes read/sec This counter monitors the 
LocalHostCache bytes read /  sec. 

 LocalHostCache bytes 
writ ten/sec 

This counter monitors the 
LocalHostCache bytes wri t ten /  sec. 

 LocalHostCache reads/sec This counter monitors the 
LocalHostCache reads /  sec. 

  Zone Elect ions This counter monitors the zone 
elect ions. 

  Zone Elect ions Won This counter monitors the zone 
elect ions won. 
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Netw ork  In terface  Bytes Total/sec This counter monitors network 
connect ion total bytes. 

 Current Bandwidth This counter monitors network 
connect ion current bandwidth. 

Term inal  Servi ces Act ive Sessions This counter monitors act ive sessions.

 Total Sessions This counter monitors total sessions. 

 

 

 

QALoad-Cold Fusion 

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

ColdFusion  M X 
Server 

Avg DB Time (msec)  

 Avg Queue Time (msec)  

 Avg Req Time (msec)  

 Bytes In /  Sec  

 Bytes Out /  Sec  

 DB Hits /  Sec  

 Page Hits /  Sec  

 Queued Requests  

 Running Requests  

 Timed Out Requests  

M em ory % Committed Bytes In 
Use 

 

 Avai lable Bytes  

 Page Faults/sec  

Process % Processor Time  
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QALoad-Generic Application Availabil ity and Performance  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Process % Processor Time This counter returns the 
percentage of elapsed t ime 
that al l  threads of a process 
use the processor to execute 
instruct ions. This process 
could include code executed to 
handle certain hardware 
in terrupts or trap condit ions. 

System  System Up Time This counter monitors cri t ical 
tasks by veri fying the existence 
of processes. You can monitor 
single or mult iple tasks 
running on the system by 
select ing the Processes tab 
from the task manager and 
then select ing processes that 
you want to monitor. You can 
also monitor only certain 
instances of a task by 
specifying a Process ID to 
monitor. If you do not specify 
a Process ID, th is counter 
monitors al l  instances of the 
task. 

 

QALoad-MS IIS Availabil ity  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

System  System Up Time  

Web Servi ce Current Anonymous 
Users 

 

 Current Connect ions  

 Logon Attempts/sec  

 NonAnonymous Users/sec  

 Not Found Errors/sec  
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 Total Delete Requests  

 Total Fi les Sent  

 Total Get Requests  

 Total NonAnonymous 
Users 

 

 Total Not Found Errors  

 

 

 

QALoad-MS IIS Performance  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

In ternet  
In form at ion  
Servi ces Global  

Current Blocked Async 
I/O Requests 

 

 Total Blocked Async I/O 
Requests 

 

 Total Rejected Async 
I/O Requests 

 

 URI Cache Flushes  

 URI Cache Hits  

 URI Cache Hits %  

 URI Cache M isses  

PhysicalDisk  % Disk Time  

Process % Processor Time  

Redi rector  Current Commands  

 Network Errors/sec  

Server Work Item Shortages  

Server Work  Queues Queue Length  

 Web Servi ce Not Found Errors/sec  



Conductor 

93 

 

    

 

 

QALoad-Server Health  

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

M em ory % Committed Bytes In 
Use 

 

 Pages/sec  

PhysicalDisk  % Disk Time  

 Avg. Disk Queue Length  

Processor  % Processor Time  

System  Processor Queue Length  

 

     

 

QALoad-Windows Availabil ity  

This template monitors the avai labi l i ty of the Windows operat ing system, focusing on: 

Logons 

Securi ty 

Up t ime 

The default  sampling in terval for th is template is 5 minutes. 

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

Server Errors Access Permissions 

 Errors Granted Access  

Errors Logon 

Errors System 

Logon Total 

The M icrosoft  Windows 
Avai labi l i ty template uses these 
Server registry counters to 
monitor errors due to logon 
problems. 

To enable these counters, you 
must configure your Windows 
system to audit  logon and 
logoff events. You can do th is 
by configuring the Audit  Pol icy 
in  the User Manager for 
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Domains program. 

 Server Sessions 

Sessions Errored Out 

Sessions Forced Off 

Sessions Logged Off 

Sessions Timed Out 

The M icrosoft  Windows 
Avai labi l i ty template uses these 
Server registry counters to 
monitor how well  users’ 
sessions are running. 

If there is a large number of 
session errors, i t  is usual ly due 
to systems reboot ing often or 
network errors. 

System  System Up Time This counter returns the 
number of seconds that a 
system was avai lable for use. If 
th is number cont inues to reset 
to zero, i t  means that the 
system is reboot ing often. For a 
report  that l ists the number of 
t imes that the system has 
rebooted over a period of t ime, 
see the M icrosoft  Windows 
Avai labi l i ty Report topic. 

 

   

QALoad-Windows Performance  

This template monitors the performance of the M icrosoft  Windows system, focusing on: 

CPU 

Disk I/O 

Disk space 

Memory 

Network 

The default  sampling in terval for th is template is 5 minutes. 

This template includes the fol lowing counters and categories: 

Category Coun ters Descript i on  

LogicalDisk  % Disk Time This counter monitors the 
percentage of elapsed t ime that 
the disk services read and write 
requests, including the t ime 
that the disk driver waits in  the 
disk queue. If th is value is 
consistent ly near 100%, the disk 
is in  very heavy use. You can 
determine which processes are 
making the majori ty of the disk 
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requests by monitoring them 
individual ly. 

 % Free Space This counter monitors low free-
space situat ions. 

  Avg. Disk Queue Length This counter indicates the 
number of pending I/O service 
requests. If the returned value is 
greater than 2, there is a disk 
problem. On a mult i-disk 
subsystem, such as a striped set 
or striped with pari ty, you can 
perform a calculat ion to 
determine the presence of a disk 
problem. The basic formula is 
(Disk Queue Length) - (Number 
of Physical Disk Drives in  the 
mult i-disk configurat ion). 

For example, i f you have a 
striped set with 3 disk drives 
and a queue length of 5, then 
you get an acceptable value of 2 
(5 - 3 = 2). 

 M em ory Avai lable Bytes If the value returned by th is 
counter fal ls under 10 MB, 
virtual memory is running low. 
To resolve th is, close some 
appl icat ions or increase the 
memory sett ings. If th is counter 
is consistent ly low after an 
appl icat ion is running, i t  
usual ly indicates a system 
memory leak. 

As the value returned by th is 
counter decreases, the value 
returned by the Committed 
Bytes counter increases. This 
indicates that a process is 
al locat ing memory from the 
virtual address space but might 
not be using i t . Because the 
virtual address space is a l im ited 
resource, use these counters to 
check for appl icat ions that 
al locate memory but do not use 
i t . To resolve th is, add more 
physical memory. When an 
appl icat ion fin ishes processing, 
note the last value. If th is 
counter does not return to the 
original value, the appl icat ion 
has a memory leak or a h idden 
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process that has not properly 
terminated. 

The acceptable range for 
committed bytes should be less 
than the physical RAM. The 
default  value is 64 MB. 

 Cache Faults/sec If the value returned by th is 
counter is less than the value 
returned by the Page faults/sec 
counter, the system is paging 
too much for a normal system. 
To resolve th is, add more 
physical memory. 

 Committed Bytes This counter returns the 
amount of virtual memory (in  
bytes) that was committed, as 
opposed to memory that has 
was reserved. 

 Page Faults/sec If the value returned by th is 
counter is greater than 5, the 
system is paging too much. Add 
more physical memory. A 
consistent value of 10 or later 
needs immediate attent ion. 

 Page Reads/sec  

 Pages/sec If th is counter returns a h igh 
peak value, the system is 
experiencing a lot  of paging 
act ivi ty. A h igh value also 
indicates that your system does 
not contain enough physical 
memory to handle the demands 
placed on i t  by the appl icat ion. 
To resolve th is, add more 
physical memory. To calculate 
the % disk t ime used for paging, 
use the fol lowing calculat ion: 

(% Disk Time used for paging) = 
(Memory, Pages/sec) * (Average 
Disk Transfer/sec) * 100 

 Transit ion Faults/sec  

Paging Fi l e  % Usage Peak This counter returns the 
maximum use of your page fi le. 
If the value the counter returns 
consistent ly reaches 90%, the 
virtual address space is too 
small . You should increase the 
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size of your paging fi le. When 
the value returned by the 
counter exceeds 75%, a 
significant system performance 
degradat ion becomes 
not iceable. 

PhysicalDisk  % Disk Time  

 Avg. Disk Queue Length  

 Avg. Disk sec/Transfer  

 Disk Reads/sec  

 Disk Writes/sec  

Processor % Interrupt Time This counter monitors the 
percentage of t ime that the 
processor spent receiving and 
servicing hardware in terrupts 
during the sample in terval. 

 % Processor Time On single processor systems, i f 
the value returned by th is 
counter is consistent ly h igher 
than 90%, the CPU probably 
has a bott leneck. You should 
examine each process in  the 
system to determine which one 
is using more of the processor 
than i t  should. The process with 
the h ighest peak is general ly the 
performance bott leneck. 

 % User Time This counter monitors non-idle 
processor t ime spent in  User 
mode as a percentage of the 
sample in terval. 

Redi rector Network Errors/sec This counter indicates how 
many serious network errors 
have occurred. These errors are 
general ly logged in the system 
event log, so you can check 
there for more in formation. If 
an error occurs, take immediate 
act ion to resolve the problem. 

Server Bytes Received/sec  

 Bytes Total/sec  

 Bytes Transmitted/sec  



Using the Conductor 

98 

 Errors Logon This counter determines i f an 
unauthorized user is trying to 
access your system. 

  Work Item Shortages This counter monitors the 
number of t imes that a work 
i tem was not al located. You 
might need to increase the 
In itWorkItems and 
MaxWorkItems parameters for 
the LanMan Server i f th is 
number cont inues to increase. 

System  Context Switches/sec If the value returned by th is 
counter value is h igh, assign a 
h igher priori ty to the use of 
cri t ical sect ions or semaphores 
by the program. This achieves a 
h igher throughput and reduces 
task switch ing. 

 Processor Queue Length  

 

   

 

 

Managing Monitoring Templates 

Creat ing a New  Tem plate 

To open t he New  Moni t or ing Tem plat e w izard: 

1. In Conductor, click Tools>Monitor Tasks to open the Manage Monitoring Tasks window.  

2. Click Templates>New Template. The New Monitoring Template Wizard appears.  

3. Click Next to start the procedure. 

To creat e a new  t em plat e: 

Use the fol lowing steps in  the New Monitoring Template wizard to create a new monitoring template: 

Note: (WebLogic and WebSphere) When QALoad detects a managed server environment, you must also 
select the individual server on which to model the template. 

1. Enter the template properties 

2. Configure the monitor 

3. Server discovery (WebLogic and WebSphere) 

4. Choose the server (WebLogic and WebSphere) 

5. Process the server (WebLogic and WebSphere) 

6. Counter discovery 
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7. Choose the counters 

8. Choose the instances 

9. Review, save, and create the template 

 

Open ing an  Ex ist i ng Tem plate  

Use the fol lowing steps to apply a previously created or pre-defined template. 

To open and review  an exist ing t em plat e: 

1. In the Conductor, click Tools>Monitor Tasks to open the Manage Monitoring Tasks window. 

2. In the Manage Monitoring Tasks window, click Templates>Open Existing. The Select a Monitor Template File 
dialog box displays. 

3. In the Look in field, select a template type, then select a template and click Open. The template and its counters 
display in the Manage Monitoring Tasks window. 

Note: To apply a template to a task, use the New Monitoring Task wizard. 

Edi t i ng Instances for Tem plates  

Use the fol lowing steps to modify the instances to monitor in  a custom template: 

Step 1: Open the Edit  Template Instances Wizard 

Step 2: Choose the instances to monitor 

Step 3: Save the template 

 

St ep 1: Open t he Edi t  Tem plat e Inst ances w izard: 

1. In the Conductor, click Tools>Monitor Tasks to display the Manage Monitoring Tasks window. 

2. Open the template to edit. 

3. Click Templates>Edit instances. The Edit Template Instances Wizard appears. 

St ep 2: Choose t he inst ances of  t he count er  t o m oni t or : 

Review the counters you selected. When a red dot   appears next to a counter, you must select an 
instance for the counter.  

1. Double-click the counter group to display the counters. 

2. Select an instance for a counter and click Edit. The Select instance for counter dialog box appears. 

3. To add an instance: In the Available Instance pane, select an instance and click Add. 

4. To remove an instance: In the Selected instances pane, select an instance and click Remove. 

5. Repeat until you select all instances of the counter that you want to apply to the task. 

6. Click Save. You return to the Choose Instances dialog box.  

7. Repeat this process for each designated counter.  

8. Click Next. The Summary dialog box displays. 
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St ep 3: Save t he t em plat e: 

1. On the Summary dialog box, review the monitors and counters you have selected for the template. Click Back to 
return to a dialog box and make changes to the information. 

2. Click Back to return to the previous step and edit the instances. 

3. Click Finish to create the template. 

 

M odi fying Tem plate Coun ters Using New  Discovery Data 

When you want to add or edit  counters in  a custom template, you can generate the discovery data that you 
add to the template. The Edi t  M on i toring Tem plate wizard guides you through the process of generat ing 
and applying new discovery data. Use the fol lowing steps to modify template counters using new 
discovery: 

Step 1: Open the Edit  Monitoring Template Wizard 

Step 2: Enter propert ies of the template 

Step 3: Configure the monitor 

Step 4: Counter Discovery 

Step 5: Choose the counters 

Step 6: Choose the instances of the counter 

Step 7: Save the template 

 

St ep 1: Open t he Edi t  M oni t or ing Tem plat e w izard : 

1. In the Manage Monitoring Tasks window, open the template to edit. 

2. Click Templates>Add/Edit Counter>Use new discovery data. The Edit Monitoring Template wizard appears.  

3. Click Next in the Welcome dialog box. The Enter properties of the template dialog box displays. 

Note: (WebLogic and WebSphere) You can change the Java Settings field, if necessary. If the Java file 
location has changed, click the Browse button and select the new location. 

St ep 2: Ent er  proper t ies of  t he t em plat e: 

In  the Enter propert ies of the template dialog box, do the fol lowing: 

1. Review the template information. 

2. Type or edit the description for the template in the Description field  

3. Click Next. The Configure Monitor dialog box displays. 

Note: (WebLogic and WebSphere) You can modify any field in the Configure Monitor dialog box except 
the Admin Server field. 

St ep 3: Conf igure t he m oni t or : 

In  the Configure Monitor Dialog, do the fol lowing: 

1. Type the configuration data for the host machine, if necessary. This data is used to connect to the host machine and 
to the host database during counter discovery and runtime data collection. The required configuration data varies 
depending on the monitor type selected. Click a link below to view the required configuration details for your monitor 
type. 
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!  Oracle Appl icat ion Server 

!  JVM 

!  SAP 

!  ServerVantage 

!  SNMP 

!  WebLogic 

!  WebSphere 

!  WebSphere MQ 

!  Windows Registry 

!  WMI 

2. Click Next.  

!  WebLogic and WebSphere) The Processing Servers dialog box displays. Fol low the procedure for 
select ing a server. Once you select the server, the automatic counter discovery process begins. 

!  (Al l  other monitor types) The automatic counter discovery process begins. 

St ep 4: Count er  d iscovery: 

QALoad automatical ly performs the counter discovery. The default  maximum t ime for counter discovery is 
300 seconds. When counter discovery is complete, the Choose Counters dialog box displays. 

St ep 5: Choose t he count ers: 

When the counter discovery process completes, the Add the desi red coun ter to th i s tem plate dialog box 
appears. 

1. From the Available Items pane in the Choose Counters dialog box, select the Template tab or the  Counter tab. 

2. To add an item, select a template or a counter to monitor in the task for this machine and monitor type, and click 
Add, or double-click the item to display it in the Selected Items pane. Click Add All to add all the items on the 
selected tab to the Selected Items pane.  

3. To remove an item, double-click the item in the Selected Items pane or select the item and click Remove. The item 
is returned to the Available Items pane.  

Note: Select multiple counters and templates by doing one of the following:  

!  To select nonadjacent counter i tems, cl ick one counter i tem, and then hold down CTRL and 
cl ick each addit ional counter i tem.  

!  To select adjacent counter i tems, cl ick the first  counter i tem in the sequence, and then hold 
down SHIFT and cl ick the last counter i tem.  

4. Click Next. The Choose Instances dialog box displays. 

Note: When you select a template containing counters that are not present on the machine you are 
defining, you receive a message with a list of the counters that will not be added to the task. 

St ep 6: Choose t he inst ances of  t he count er  t o m oni t or : 

Review the selected counters. When a red dot appears next to a counter, select  an instance of the counter.  

1. Double-click the counter group to display the counters. 
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2. Select a counter and click Edit. The Select instance for counter dialog box appears. 

3. In the Available Instance pane, select an instance and click Add. 

4. Repeat until you select all instances of the counter that you want to apply to the task. 

5. Click Save. The Choose Instances dialog box appears.  

6. Repeat this process for each designated counter.  

7. Click Next. The Summary dialog box displays. 

St ep 7: Save t he t em plat e: 

1. On the Summary dialog box, review the counters and instances you have selected for the template. Click Back to 
return to a dialog box and make changes to the information. 

2. Click Finish to create the template. 

 

M odi fying Tem plate Coun ters Using Cached Discovery 

When you need to add or edit  counters in  a template that you created, you can use the cached counter 
discovery data to modify the template. 

Note: You cannot modify the counters in pre-defined templates. 

Fol low these steps to modify template counters using cached discovery: 

Step 1: Select the counter to add or remove 

Step 2: Choose the instances of the counter 

Step 3: Save the template 

 

St ep 1: Select  t he count er  t o add or  r em ove: 

1. In Conductor, click Tools>Monitor Tasks to open the Manage Monitoring Tasks window. 

2. Open the template to edit, then click Templates>Add/Edit counter>Use cached discovery data. The Edit 
Template Counters wizard appears with the Add/Edit/Remove Template Counters dialog box displayed. 

3. From the Available Items pane, select the Template tab or the Counter tab. 

4. To add an item, select a template or a counter to monitor for this machine and monitor type, and click Add, or 
double-click the item to display it in the Selected Items pane. Click Add All to add all the items on the selected tab 
to the Selected Items pane.  

5. To remove an item, select the item in the Selected Items pane and click Remove, or double-click the item to return 
it to the Available Items pane.  

Note: Select multiple counters and templates by doing one of the following:  

!  To select nonadjacent counter i tems, cl ick one counter i tem, and then hold down Ct rl  and 
cl ick each addit ional counter i tem.  

!  To select adjacent counter i tems, cl ick the first  counter i tem in the sequence, and then hold 
down Sh i f t  and cl ick the last counter i tem.  

6. Click Next. The Add/Edit/Remove Template Instances dialog box displays. 

Note: When you select a template that contains counters not present on the machine you are defining, a 
message displays with a list of the counters that will not be added. 
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St ep 2: Choose t he inst ances of  t he count er  t o m oni t or : 

1. Review the selected counters. When a red dot appears next to a counter, select an instance of the counter.  

2. Double-click the counter group to display the counters. 

3. Select a counter and click Edit. The Select instance for counter dialog box appears. 

4. In the Available Instance pane, select an instance and click Add. 

5. Repeat until you select all instances of the counter that you want to apply. 

6. Click Save. The Choose Instances dialog box appears.  

7. Repeat this process for each designated counter.  

8. Click Next. The Summary dialog box displays. 

St ep 3: Save t he t em plat e: 

1. On the Summary dialog box, review the selected monitors and counters for the template. Click Back to return to a 
dialog box and make changes to the information. 

2. Click Finish to create the template. 

 

 

 

Rem oving a Coun ter f rom  a Tem plate  

Remove a counter from a template by fol lowing th is procedure. 

To rem ove a count er  f r om  a t em plat e: 

1. In Conductor, click Tools>Monitor Tasks to open the Manage Monitoring Tasks window.  

2. Select the counter or counter family to delete. 

3. Click Templates>Remove counter.  

4. When the verification dialog box displays, click OK. 

Note: You cannot remove the only counter family in a template or the last counter in a family. 

Creating and Editing Monitoring Tasks 

Creat ing a New  M on i tori ng Task   

To open t he New  Moni t or ing Task  w izard : 

1. From the Conductor Start Page, click Configure Monitoring in the Tasks area. 

OR 

In the Conductor's Visual Designer, cl ick Tools>M on i tor Tasks to open the Manage Monitoring 
Tasks window. 

2. Click File>New. The New Monitoring Task wizard appears.  

3. Click Next to start the procedure. 

Note: You can open the Manage Monitoring Tasks window to edit or create a task by clicking the browse 
button next to the Monitor task field in the Session node.  
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To creat e a new  m oni t or ing t ask : 

Use the fol lowing steps in  the New  M on i toring Task  Wizard to create a new monitoring task: 

1. Define the monitor 

2. Configure the monitor 

3. Discover the servers (WebLogic and WebSphere) 

4. Choose the servers (WebLogic and WebSphere)  

5. Process the Server (WebLogic and WebSphere) 

6. Discover the counters 

7. Choose the counters for the monitoring task 

8. Choose the instances of the counter to monitor 

9. Review the monitor definition 

10. Save and create the monitoring task  

 

Using an  Ex ist i ng M on i toring Task   

To select  an exist ing m oni t or ing t ask : 

1. From the Conductor Start Page, click Configure Monitoring in the Tasks area. 

OR 

In the Conductor's Visual Designer, cl ick Tools>M on i tor Tasks to open the Manage Monitoring 
Tasks window. 

2. Click File>Open. The Choose an Existing Task dialog box appears. 

3. Select a task and click OK. The task displays in Manage Monitoring Tasks window. 

4. Select Enable runtime monitoring at the bottom of the window to enable the monitoring task. 

Note: You also can enable monitoring in the Session node of the Visual Designer. Use the drop-down 
arrow in the Monitor task field to select an existing task, then select Enable monitoring. You can open the 
Manage Monitoring Tasks window to edit or create a task by clicking the browse button next to the Monitor 
task field.  

Adding a M on i toring M ach ine  

Use th is procedure to add a monitor to an exist ing task.  

Note: (WebLogic and WebSphere) In a managed server environment, you only can add a monitor to a task 
from a different administrative server.  

!  For WebLogic, you must use the same WebLogic jar fi les and WebLogic version as the current 
monitor.  

!  For WebSphere, you must use the same  WebSphere Home, WebSphere cl ient version, and 
WebSphere server version as the current monitor.  

 To add a monitor to an existing task under the same administrative server, use Edit an Existing Server Group.  

To open t he New  Moni t or ing Task  w izard : 

1. In the Conductor, click Tools>Monitor Tasks to open the Manage Monitoring Tasks window. 

2. Click Actions>Add monitor. The Add Monitoring Machine wizard appears. Click Next to start the procedure. 
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Note: You can open the Manage Monitoring Tasks window to edit or create a task by clicking the browse 
button next to the Monitor task field.  

To add a m oni t or ing m achine: 

Use the fol lowing steps in  the Add M on i toring M ach ine wizard to add a monitoring machine to the task: 

Note: (WebLogic and WebSphere) When QALoad detects a managed server environment, you must also 
select the individual servers to monitor. 

1. Enter properties of the monitoring machine 

2. Configure the monitor 

3. Discover the Servers (WebLogic and WebSphere) 

4. Choose the Servers (WebLogic and WebSphere) 

5. Process the Server (WebLogic and WebSphere) 

6. Discover the counters 

7. Choose the counters for the monitoring task 

8. Choose the instances of the counter to monitor 

9. Review the monitor definition 

10. Save and create the monitoring task  

Note: See Setting Up Integration with ServerVantage for the procedure used for this monitor type. 

 

 

Edi t i ng a M on i toring M ach ine  

To open t he Edi t  Moni t or ing Machine w izard: 

1. In Conductor, click Tools>Monitor Tasks to open the Manage Monitoring Tasks window. 

2. Select a monitor in the Monitors panel, then click Actions>Edit monitor. The Edit Existing Monitor wizard 
appears.  

3. Click Next to start the procedure. 

Notes:  

!  You can open the Manage Monitoring Tasks window to edit  or create a task by cl icking the 
browse button next to the M on i tor task  field in  the Session node.  

!  (WebLogic and WebSphere) In a managed server environment, the Edit Monitor dialog box appears. Do 
one of the following: 

o Select Edit Server Group and click OK. The Edit Existing Monitor Group wizard appears. Use this 
option to add, edit, or remove monitors under the same administrative server. 

o Select Edit This Server and click OK. The Edit Existing Monitor wizard appears. Use the procedure 
for Editing a Single Server in a Managed Server Environment to edit the counters or instances of 
a single monitor in the managed server group. 

To edi t  a m oni t or ing m achine: 

Use the fol lowing steps in  the Edi t  Ex ist i ng M on i tor wizard to change the propert ies of a monitoring 
machine: 

1. Enter properties of the monitoring machine  
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2. Configure Monitor Dialog 

3. Discover the Counters 

4. Choose Counters  

5. Choose Instances  

6. Review Monitor Definition 

7. Summary  

Note: See Setting Up Integration with ServerVantage for the procedure used for this monitor type. 
 

 

Edi t i ng an  Ex ist i ng Server Group  

(WebLogic and WebSphere) In a managed server environment, you can add, edit , or remove monitors 
managed under the same administrat ive server using th is procedure.  

To open t he Edi t  Exist ing Moni t or  Group w izard: 

1. In the Conductor, click Tools>Monitor Tasks. The Manage Monitoring Tasks dialog box appears. 

2. Select a monitor, then click Actions>Edit Monitor. The Edit Monitor dialog box appears.  

3. Select Edit Server Group, then click OK. The Edit Existing Monitor Group wizard appears. 

4. Click Next. 

Note: You can open the Manage Monitoring Tasks window to edit or create a task by clicking the browse 
button next to the Monitor task field.  

To add, edi t , or  r em ove a m oni t or : 

Use the fol lowing steps in  the Edit  Exist ing Monitor Group Wizard: 

1. Enter Propert ies of the Monitoring Machine 

2. Configure Monitor Dialog 

3. Discover Servers 

4. Choose Servers 

5. Process Server 

6. Discover Counters 

7. Choose Counters 

8. Choose Instances 

9. Review Monitor Defin i t ion 

10. Summary 

 

 

Edi t i ng a Single Server i n  a M an aged Server Envi ronm en t   

(WebLogic and WebSphere) Use th is procedure to edit  the counters and instances for a single server in  a 
managed server group. 
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To open t he Edi t  Moni t or ing Machine w izard: 

1. In the Conductor, click Tools>Monitor Tasks. The Manage Monitoring Tasks dialog box appears.  

2. Select a monitor, then click Actions>Edit Monitor. The Edit Monitor dialog box appears.  

3. Select Edit This Server, then click OK. The Edit Existing Monitor wizard appears. 

4. Click Next. 

Note: You can open the Manage Monitoring Tasks window to edit or create a task by clicking the browse 
button next to the Monitor task field.  

To edi t  t he server : 

Use the fol lowing steps in  the Edi t  Ex ist i ng M on i tor wizard: 

1. Discover the counters 

2. Choose counters  

3. Choose instances  

4. Review Monitor Definition 

5. Summary  

 

Edi t i ng Instances  

Use the fol lowing procedure to edit  instances i f the counters you are monitoring: 

Step 1: Open the Edit  Instances dialog box 

Step 2: Choose the instances to monitor 

Step 3: Review the monitor defin i t ion 

Step 4: Save the task 

 

St ep 1: Open t he Edi t  Inst ances d ialog boxes: 

1. In the Conductor, click Tools>Monitor Tasks to open the Manage Monitoring Tasks window. 

2. Select the machine, the counter, or the instance to edit. 

3. Click Tools>Monitoring>Edit instances. The Edit Instances dialog box displays. 

St ep 2: Edi t  t he inst ances of  a count er : 

1. In the Choose Instances dialog box, double-click the counter group in the left-hand pane to display the counters. 

2. Select a counter and click Edit. The Select instance for counter dialog box appears. 

Note: When a counter can not be edited, the Edit button is unavailable. 

3. Perform the necessary edits. You can do the following: 

!  In  the Avai lable Instances pane, select an instance and cl ick Add. The instance is added to the 
Selected Instances pane. Repeat unt i l  you select al l  instances of the counter that you want to 
apply to the task. 

!  In  the Selected Instances pane, select an instance and cl ick Rem ove. The instance is removed 
from the Selected Instances pane and added to the Avai lable Instances pane.  
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4. Click Save. The Choose Instances dialog box displays again.  

5. Repeat this process for each counter you want to edit.  

6. Click Next. The Review Monitor Definition dialog box displays. 

St ep 3: Review  t he m oni t or  def in i t ion: 

1. Review the information for the monitoring machine you defined. 

2. Select one of the following: 

!  Set up another monitor for this task - returns to the Define Monitor dialog box so you can add 
another monitor to the monitoring task. 

!  Continue without adding any more monitors - continues in this dialog box. 

3. (Optional) Click Save as Template to create a template for this monitoring task.  

4. (Optional) Select a monitor in the Monitors pane and click Remove Monitor to delete a monitor from the task. 

5. (Optional) Type a new value in the Sample Interval field. This is the frequency, in seconds, at which QALoad 
requests data from ServerVantage during runtime data collection. 

6. Click Next. The Summary dialog box displays. 

St ep 4: Save t he t ask : 

1. Review the monitors and counters you have selected for the task. Click Back to return to a dialog box and make 
changes to the information. 

2. In the Monitoring task name field, type a name for the monitoring task.  

3. In the Description field, type a description for the task. 

4. Select a monitor in the Monitors pane, and click View Monitor Details. The Properties of dialog box displays with 
detailed information about the monitor configuration and the counters you selected. 

5. Click Finish to create the monitoring task. 

6. Select Enable runtime monitoring at the bottom of the window to enable the monitoring task. 

Note: You also can enable monitoring in the Session node of the Visual Designer. Use the drop-down 
arrow in the Monitor task field to select an existing task, then select Enable monitoring. You can open the 
Manage Monitoring Tasks window to edit or create a task by clicking the browse button next to the Monitor 
task field.  

 

Rem oving a M on i tor or a Coun ter f rom  a M on i toring Task   

Remove a monitor or a counter from a monitoring task, by fol lowing th is procedure. 

To rem ove a count er  f r om  a m oni t or ing  t ask : 

1. In the Monitors pane of the Manage Monitoring Tasks window, select the monitor, counter, or counter family to 
delete. 

2. Click Actions>Remove Monitor/Counter.  

3. When the verification dialog box displays, click OK. 

Note: You cannot remove the last monitor on a machine, the last counter in the family, or the last family of 
counters in the task. 
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Monitoring Managed Server Environments 

M on i toring M an aged Server En vi ronm en ts  

WebLogic and WebSphere servers can be configured into managed server environments, where a mult i-
server group is managed by an administrat ive server. You can create tasks and templates for managed 
server environments using the procedures for creat ing and edit ing monitoring tasks and select ing the 
servers from which to extract data.  

When you select a WebLogic or WebSphere server to monitor and QALoad detects a managed server 
environment, i t  automatical ly queries the administrat ive server for the individual servers i t  manages. Al l  
servers that QALoad discovers are l isted as avai lable servers that you can select  for monitoring. You also 
can create a template in  a managed server environment by select ing an individual server on which to 
model the template. 

Edit  the counters and instances for a single server in  a managed server group using the procedures for 
creat ing and edit ing monitoring tasks. You also can add, edit , or remove monitors managed under the 
same administrat ive server.  

 

Creat ing M on i toring Tasks for M an aged Servers  

Use the New Monitoring Task wizard to create monitoring tasks for individual servers or groups of servers 
in  a managed server environment. When you create a monitoring task for a managed server environment, 
you select an administrat ive server to monitor. QALoad queries the administrat ive server for the individual 
servers i t  manages. Al l  servers discovered are l isted as avai lable for monitoring.  

Note: When the information returned by the administrative server indicates that it does not manage any 
other servers, the counter discovery process begins for the individual administrative server. 

Once you select the servers to monitor, QALoad begins the counter discovery process for each server in  
turn. Select the counters and instances of counters to monitor on the first  server. QALoad includes these in 
the task, and then begins the counter discovery process for the next server you selected. 

 

Creat ing M on i toring Tem plates for M anaged Servers  

You can select counters and instances and save them to a template that you can use for other monitoring 
tasks.  

When you create a template in  a managed server environment, you select a server on which to model the 
template and adding the counters and instances of counters to the template.  

QALoad queries the administrat ive server for al l  the servers i t  manages. From th is l ist ,  select the server to 
use as the model when creat ing the template. QALoad's New Monitoring Template wizard guides you 
through the process of adding the counters and instances of counters to the template.  

Note: You can select only one server as a model for the template. If the server you select is unavailable, you 
are returned to the managed server selection dialog box to choose another server. 

 

Edi t i ng M on i tors i n  a M anaged Server Envi ronm en t  

In a managed server environment, you can edit  a single server or modify an exist ing group of servers in  a 
task. 

Edit  an individual server using the Edit  Exist ing Monitor wizard. You can add or remove counters and 
instances to monitor on the server. When you edit  a server group, you use the Edit  an Exist ing Server 
Group wizard.  You can add monitors, edit  the propert ies of a monitor, or remove monitors managed 
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under the same administrat ive server. You also can change the counters and instances to monitor on an 
individual machine. 

 

ServerVantage 

Overview of Server Monitoring with ServerVantage 

If you are current ly a l icensed user of Compuware's ServerVantage, you can integrate data from your 
exist ing ServerVantage deployment direct ly in to a QALoad t im ing fi le.  

For th is method to be successful, the fol lowing condit ions must be met: 

!  ServerVantage must be installed and configured correctly on your system. 

!  ServerVantage must be scheduled to monitor the specified performance counters at a time that coincides with a 
running QALoad test. 

!  You must configure the port to use for the SQL database. The port must be open on the ServerVantage database 
server so that QALoad can retrieve the counter data at the conclusion of the test. The default SQL port is1433. 

!  QALoad must be able to access the ServerVantage database server on port 139 or 445 via tcp to obtain time stamps 
at the beginning and end of the test. 

!  QALoad must be able to access the ServerVantage agent using an ICMP ping during the monitor setup.  If security 
restrictions prevent pinging the agent, an entry can be added to the host's file on the Conductor machine mapping 
the domain name of the agent to the IP address of a machine that can be pinged, such as the Conductor.  

About  ServerVan tage 

ServerVantage (formerly EcoTOOLS) monitors the avai labi l i ty and performance of appl icat ions, databases 
and servers, al lowing users to central ly manage events across al l  appl icat ion components— Web servers, 
fi rewalls, appl icat ion servers, fi le systems, databases, middleware, and operat ing systems. ServerVantage 
simultaneously monitors these components, analyzes both h istorical and real-t ime events, and correlates 
monitored in formation for problem detect ion. 

In tegrat ion with ServerVantage is configured from the QALoad Conductor. Performance counters col lected 
during a load test are included in the test 's t im ing fi le and can be sorted and displayed in QALoad Analyze 
in  much the same way as QALoad t im ing data. For more in formation about instal l ing or configuring 
ServerVantage, refer to i ts product documentat ion.  

 

Setting Up Integration with ServerVantage 

Use the fol lowing steps to set up in tegrat ion with ServerVantage: 

Step 1: Open the New M onitoring Task Wizard 

Step 2: Define and Configure the Monitor 

Step 3: Review the Monitor Defin i t ion 

Step 4: Review the Summary and Create the Task 

St ep 1: To open t he New  Moni t or ing Task  w izard : 

1. Click Tools>Monitor Tasks. 

2. Click the Set up monitoring link, then select Set up a new monitoring task, then click OK to open the New 
Monitoring Task wizard. Click Next. 
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St ep 2: To def ine and conf igure t he m oni t or : 

1. In the Define Monitor dialog box, click the arrow in the Monitor Type box and select ServerVantage. 

2. In the Control Server Database Host field, click the down arrow and select the hostname of the machine where the 
ServerVantage server is located. 

3. Click Next. The Configure Monitor dialog box displays. 

4. In the Username field, type a valid user name to access the ServerVantage server, if necessary. 

5. In the Password field, type the password that corresponds to the user name above, if necessary. 

6. Select the Override Default Database check box to provide the ServerVantage database name. When this option is 
not selected, QALoad uses the default ServerVantage database name. If you provided a different name during the 
installation of ServerVantage, select this option and type the name in the Database Name field. 

7. In the Name field in the Vantage Agent area, type the hostname of a machine(s) where a ServerVantage Agent is 
installed, and click the Add button to add it to your load test. 

8. Click Next to proceed to the next step, Review Monitor Definition. 

St ep 3: To review  t he m oni t or  def in i t ion: 

1. Review the information for the monitoring machine you defined. 

2. Select one of the following: 

!  Set up another monitor for this task - returns to the Define Monitor dialog box so you can add 
another monitor to the monitoring task. 

!  Continue without adding any more monitors - continues in this dialog box. 

3. (Optional) In the Monitors pane, select the monitor, then click Save as Template to create a template for this 
monitoring task.  

4. (Optional) In the Monitors pane, select the monitor type, then click Remove Monitor to delete a monitor from the 
task. 

5. (Optional) Type a new value in the Sample Interval field. This is the frequency, in seconds, at which QALoad 
requests data during runtime data collection. 

6. Click Next to proceed to the next step, where you review the summary and create the task. 

St ep 4: To review  t he sum m ary and creat e t he t ask : 

1. Review the monitors and counters you have selected for the task in the Summary dialog box. Click Back to return to 
a dialog box and make changes to the information. 

2. In the Monitoring task name field, type a name for the monitoring task. The task is saved so you can reuse this 
configuration of counters and instances. 

3. In the Description field, type a description for the task. 

4. Select a monitor in the Monitors pane, and click View Monitor Details. The Properties of dialog box displays with 
detailed information about the monitor. 

5. Click Finish to create the monitoring task. The Manage Monitoring Tasks window displays. 

 

Displaying ServerVantage Agent Data 

If you set opt ions to in tegrate ServerVantage resource ut i l izat ion data before running a test, that data is 
included in the result ing t im ing fi le. It  can be sorted and displayed in QALoad Analyze in  much the same 
way as QALoad t im ing data. ServerVantage data provides a summary of al l  the Agents that ServerVantage 
monitored during the load test and detai ls aggregate stat ist ics for Agent data points including min imum, 
maximum, and mean data values.  
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When you open a t im ing fi le contain ing ServerVantage Agent data, QALoad Analyze displays test data with 
QALoad t im ing data two ways: 

!  ServerVantage Agent workstations are listed in the Server Monitoring group in the Workspace tree-view, under the 
Resource Trends (ServerVantage) branch. From the Workspace, select Agent workstations to create detail or 
graphical views of the Agent data points. Specifically, you can: 

!  Display Agent data point detai ls.  

 Graph Agent data point detai ls.  

!  Detailed data point information is displayed in the Data window. The ServerVantage detail view includes data such 
as the name of the machine where you ran the ServerVantage Agent; the Agent name; and the minimum, maximum, 
and mean data values for the Agent. 

Note: ServerVantage resource utilization data is available only if you set the ServerVantage integration 
options on the QALoad Conductor’s Test Information window before executing a load test.  

  

Applicat ionVantage 

Overview of ApplicationVantage 

QALoad integrates with Appl icat ionVantage to help you analyze network performance during a load test. 
Appl icat ionVantage provides granular thread detai ls that al low network managers to ident i fy poorly 
performing appl icat ions. QALoad also provides test data that you can open in Appl icat ionVantage. 

Before QALoad can col lect network data during a load test, the fol lowing must be true: 

!  The ApplicationVantage Agent is installed on the same machine as the QALoad Conductor. You can install either the 
ApplicationVantage Agent or the ApplicationVantage Remote Agent. 

!  You have specified on which NIC to capture in the Manage Players/Groups dialog box in Conductor. How? 

At test t ime when a transact ion is started, the Player configured to capture Appl icat ionVantage data starts 
an Appl icat ionVantage trace. The trace stops when the transact ion completes. When a Player is running a 
script  that is set to run in  Appl icat ionVantage mode, every transact ion generates a new trace fi le. At the 
end of the test, these fi les are packaged into the test 's t im ing fi le. 

Hint : For information about ApplicationVantage, refer to the documentation you received with your 
purchase of this tool. 

Configuring a test to use ApplicationVantage 

Integrat ion with Appl icat ionVantage enables you to study network problems in detai l . You can set up one 
or more Appl icat ionVantage (AV) Player machines for the load test. These AV Player machines run a 
QALoad script  on a periodic basis whi le the AV Agent captures the network traffic that the script  produces. 
The result ing AV trace fi les (*.opx) are sent back to the Conductor with the regular QALoad t im ing fi le for 
analysis after the test is complete. 

To enable Appl icat ionVantage, you must be running Appl icat ionVantage 10.0 or greater. You must enable 
Appl icat ionVantage in the Propert ies window, and set the Network Interface Card (NIC) Name used by the 
machine on which the data is captured. 

Enabling ApplicationVantage  

You can enable or disable the Appl icat ionVantage for each load test on a script . To enable 
Appl icat ionVantage, you must select the opt ion, and then set the Network In terface Card (NIC) Name. 

To enable Appl icat ionVant age: 
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1. Click the script icon for the appropriate script in the Visual Designer window. The Script Properties panel 
appears on the right-hand side of the window. 

2. In the Script Properties panel, click the ApplicationVantage field, then select True.  

3. Click Tools>Manage Players. 

4. If necessary, set the NIC Name. 

 

Setting up Network Interface Card Name 

To use the Appl icat ionVantage Agent to col lect data for Appl icat ionVantage, i t  is necessary to specify 
which Network Interface Card (NIC) to capture on. This is the network in formation for the workstat ion 
where your Appl icat ionVantage Remote Agent is instal led.  

To set  up NIC Nam e:  

1. On the Conductor's toolbar, select Tools>Manage Player. The Manage Players/Groups dialog box displays with 
names of available Player machines listed in the Players area. 

2. Click the Player machine that will be running the virtual user to be captured. The information for that Player machine 
 displays in the Player Information area. 

3. If necessary, click the  button next to Application Vantage Settings to expand the information.  

4. From the drop-down list in the NIC Name field, select the NIC that is used by the machine.  

6. Click Save, then click OK. 

  

 

 

ClientVantage 

Overview of ClientVantage 

ClientVantage manages end-user appl icat ion performance and avai labi l i ty. Problems can be diagnosed by 
powerful fault  detect ion and analysis capabi l i t ies as well  as resource monitoring.  

Cl ientVantage must be instal led on the same Windows workstat ion as the QALoad Conductor and the 
QALoad Player.  

 

Vantage Analyzer 

Vantage Analyzer Integration 

Vantage Analyzer is designed for easy resolut ion of complex appl icat ion performance issues. It  enables you 
to easi ly dri l l  in to specific problem transact ions to determine the cause of bott lenecks in  your product ion 
appl icat ions. It  also enables you to find Java code and SQL statements that are consuming excessive 
resources. Troublesome memory leaks that are observed in your actual product ion servers can be quickly 
resolved.  

If you are current ly a l icensed user of Compuware's Vantage Analyzer, you can integrate data from your 
exist ing Vantage Analyzer deployment direct ly in to a QALoad t im ing fi le.  
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For th is method to be successful, the fol lowing condit ions must be met: 

!  The supported version of Vantage Analyzer must be installed and configured correctly on the same machine as 
QALoad Analyze. For more information about installing or configuring Vantage Analyzer, refer to its product 
documentation. 

!  Time has to be synchronized between the QALoad Conductor machine and the Vantage Analyzer Nucleus Server 
machine to make testing data more meaningful. The difference of the time between the two machines is saved in a 
timing file.  

 

Setting Up Integration with Vantage Analyzer 

To set  up in t egrat ion w i t h Vant age Analyzer : 

1. Open or create a session in the Conductor. From the Tools menu, choose Monitor Tasks. The Manage Monitoring 
Tasks dialog box displays. 

2. Click the Set up monitoring link and select Set up a new monitoring task. Click OK. If the Welcome to the New 
Monitoring Task Wizard appears, click Next.  

3. In the Define Monitor dialog box, click the arrow in the Monitor type box and select Vantage Analyzer. 

4. In the Nucleus Server Name or IP address field, type or select the machine host name or IP address of the machine 
where the Vantage Analyzer Nucleus server runs. 

5. Click Next. The Configure Monitor Dialog box displays. 

6. In the Username field, type the login user ID for the Vantage Analyzer Nucleus server machine (not the Nucleus 
server itself). 

7. In the Password field, type the login password for the Vantage Analyzer Nucleus server machine (not the Nucleus 
server itself). 

8. Click Next. The Review Monitor Definition dialog box displays. 

 

Capturing Vantage Analyzer Metrics 

Capture several levels of Vantage Analyzer metrics during a conductor performance tests. 

To capt ure Vant age Analzyer  m et r ics: 

1. Set up capture of J2EE/ASP.Net web application for testing within Vantage Analzyer. 

2. Click Retrieve Vantage Analzyer Data button. The Retrieve Vantage Analyzer Data dialog box appears. 

3. Configure Vantage Analyzer monitoring tasks in the dialog box and click OK. 

4.  Click the Capture Mode button to configure capture mode. The Vantage Analzyer Capture Mode-Settings dialog box 
appears.  

5. Configure capture mode and click OK. 

6. Run the test. 

Test  Setup Interface 

Overview of the Test  Setup Interface 

The Conductor provides two methods for designing a test session: the Visual Designer and the Grid View.  
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Visual Designer 

The Conductor's main window is the Visual Designer. The Visual Designer  consists of three parts that you 
use to create the test session:  

!  Visual Designer window - contains a series of nodes displayed in a tree view. The session displays as the top-level 
node, while the scripts in the session are represented as nodes underneath the session.  

!   Players/Groups panel - This is a dockable panel the appears on the left-hand side of the window. It displays all 
Players and Groups available for the session. 

!  Properties panel - This is a dockable panel the appears on the right-hand side of the window. Select a session node, 
a script icon, or a Player machine in a script node to display information and set options for each one.  

You can assign player machines to a script  by dragging a player or a player group from the Player/Groups 
panel and dropping i t  in to the script  in  the Visual Designer window. Review and update propert ies of the 
test elements in  the Propert ies panel.  

In  addit ion, the Visual Designer's toolbar provides access to standard Windows funct ional i ty, such as Print 
and Copy, as well  as quick access to Conductor setup opt ions and to QALoad Analyze.  
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Grid View 

Alternately, you can open the Grid View to enter test in formation and set up the machines and scripts for 
the test. The Grid View is a dockable window that appears at the bottom of the Visual Designer window. 
Changes made in the Grid View appear in  the Visual Designer.   

The fields you use to set opt ions for your load test are displayed in two tabs: 

!  Script Assignment tab - where you set up options for any scripts that have previously been recorded and compiled. 

!  Machine Assignment tab - where you assign scripts to specific Player workstations, starting and ending virtual users 
(VU), VU increments, and timing intervals. 

The Grid View toolbars provides access to the main funct ions of assigning scripts and players to your load 
test session. 

 

  

Using the Visual Designer 

The Visual Designer is the main window, the test setup in terface,  that displays a col lect ion of icons and 
nodes that represent your test session. The top level node is the current test session, and the chi ld nodes 
represent the scripts assigned to the session.  

Use the Visual Designer to enter in formation about your test and set up the machines and scripts for the 
test using the two panels in  the Visual Designer window:  

!  Players/Groups panel - This is a two-tabbed window that list the installed QALoad Players and any groups in which 
they are members. Assign Players and groups to individual scripts by dragging and dropping them into the script 
nodes. 

!  Properties panel - This is a dynamic panel on the right-hand side of the Visual Designer  that changes content 
depending on the view you choose. Use the Properties panel to setup and review configurations for session, script, 
and Player properties. 

o Session propert ies - Cl ick the top-level Session node to display session propert ies in  the Session 
Propert ies panel. Use the Session Propert ies panel to enable recording and set session durat ion.  

o Script propert ies - Cl ick the script  icon for any individual script  to display i ts propert ies in  
the Script Propert ies panel . Use the Script Propert ies panel to set opt ions for Appl icat ion 
Vantage, external fi les and datapools, and addit ional script  propert ies, such as debug opt ions, 
error handl ing, number of t ransact ions, and t im ing opt ions.  



Conductor 

117 

o Player propert ies - Cl ick an individual Player in  a script  node to view i t 's propert ies in  the Player 
Propert ies panel. You can set start ing and ending virtual users (VU), VU increments, mode and 
t im ing intervals, and set expert  user opt ions. 

Use the toolbar buttons to assign scripts, assign players and groups, or to open the Test Configurat ion 
Wizard, where you can easi ly configure your test session.  

 

 

 

Using the Grid View 

You can use the Grid View to enter test in formation about your test and set up the machines and scripts 
for the test. The Grid View contains two tabs:  

!  Script Assignment tab - Use this tab to set up options for any scripts that have previously been recorded and 
compiled. Any scripts you add here are included in your load test, and one virtual user is automatically assigned to 
your script on the Machine Assignment tab. After setting up your scripts here, you must assign additional virtual 
users to your script from the Machine Assignment tab.  

!  Machine Assignment tab - Use the Machine Assignment tab in the Grid View to assign scripts to specific Player 
workstations. You also assign starting and ending virtual users (VU), VU increments, and timing intervals. 

To open t he Gr id  View : 

Cl ick View >Grid Window . The Grid View pane appears below the Visual Designer window.  

  

 

Runt ime Window 

When you start  a test, the Conductor's in terface changes to an in teract ive test control stat ion cal led the 
Runtime Window. From the Runtime Window, you can observe the progress of individual scripts and 
Player machines, create real-t ime graphs, and change the behavior of scripts and Players from a running 
test to better simulate the unpredictabi l i ty of real users. This window has two unique areas: 

!  Runtime main window - The information in the main Runtime window depends on the view you select in the Active 
View field. You can view details for all test scripts, individual test scripts, all player machines, and individual player 
machines. 

!  Runtime Options Panel - The lower pane, called the Runtime Options Panel, displays data for the current view and 
the individual script you select. This is a dockable control station that allows you to change virtual user options and 
data transfer options while your test is running. The information in the Runtime Options panel is displayed in three 
tabs: Virtual User Options Tab, Script Options Tab, Global Options Tab. 
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Runn ing  a Test  

Running a Load Test  
After val idat ing a script , i t  is safe to run a load test with that script .  

To st ar t  a load t est : 

In  the Conductor, cl ick the Run  button on the configurat ion and setup toolbar, or from the Act ions menu, 
choose Run . While a test is running, the Conductor's In terface changes to provide you with real-t ime test 
opt ions. For more in formation, see Runtime Window Interface. 

Note: While any window on the desktop is re-sizing or re-positioning, all Windows applications pause. Do 
not click and hold on a window caption or border for extended periods during a load test because it delays 
message handling and may have an impact on test results. 

While a load test is running, the Conductor’s toolbar changes from the Configurat ion and Setup Toolbar to 
the Runtime Toolbar. The Runtime Toolbar buttons let  you control the test and access detai led 
in formation about the test whi le i t  is running. For more in formation, see Monitoring a Load Test. This 
gives detai led in formation  about what to expect from the QALoad Conductor whi le a test is running — 
including descript ions of the Runtime Toolbar buttons 

Running a Series of Tests 

You can also run a series of tests — a batch test. A batch test comprises mult iple session ID fi les. When you 
run a batch test, the session fi les are executed sequential ly unt i l  al l  of them are executed. The Conductor 
enables you to run mult iple batch tests without operator in tervent ion. For more in formation, see Runn ing 
a Batch Test. 

Running a Load Test  
After val idat ing a script , i t  is safe to run a load test with that script .  

To st ar t  a load t est : 

In  the Conductor, cl ick the Run  button on the configurat ion and setup toolbar, or from the Act ions menu, 
choose Run . While a test is running, the Conductor's In terface changes to provide you with real-t ime test 
opt ions. For more in formation, see Runtime Window Interface. 

Note: While any window on the desktop is re-sizing or re-positioning, all Windows applications pause. Do 
not click and hold on a window caption or border for extended periods during a load test because it delays 
message handling and may have an impact on test results. 

While a load test is running, the Conductor’s toolbar changes from the Configurat ion and Setup Toolbar to 
the Runtime Toolbar. The Runtime Toolbar buttons let  you control the test and access detai led 
in formation about the test whi le i t  is running. For more in formation, see Monitoring a Load Test. This 
gives detai led in formation  about what to expect from the QALoad Conductor whi le a test is running — 
including descript ions of the Runtime Toolbar buttons 
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Running a Series of Tests 

You can also run a series of tests — a batch test. A batch test comprises mult iple session ID fi les. When you 
run a batch test, the session fi les are executed sequential ly unt i l  al l  of them are executed. The Conductor 
enables you to run mult iple batch tests without operator in tervent ion. For more in formation, see Runn ing 
a Batch Test. 

Dialing Up/ Down Virtual Users 
QALoad's dial-up/dial-down feature in  Conductor al lows you to dynamical ly add or reduce virtual users to 
your test at the script  or Player level whi le your test is running. This enables you to adjust your running 
test according to test behavior on-the-fly, rather than stopping to re-configure playback cri teria. 

To use the dial-up/dial-down feature, you must:  

!  be licensed for at least the number of virtual users requested 

!  configure a dial-up/dial-down session before running the test 

Notes:  

!  If you have not configured a dial-up/dial-down session, you wil l  not be al lowed to add or 
suspend virtual users while the test is running. For more in formation, see Configuring a Dial-up 
Session. 

!  Dial-up/dial-down is enabled only after al l  Virtual Users configured for the test session are 
ramped up. 

!  Dial-up/dial-down is not supported for a machine assignment entry that is using a player 
group. 

When your test is running, the bottom of the Test In formation window turns in to the dockable Runtime 
Options panel, a port ion of which is shown below: 

 

When you cl ick on a Player or script  in  the test 's tree-view, the Runtime Options panel indicates how many 
virtual users are current ly running on the selected Player machine or script . You can change the number of 
running virtual users per script  or per Player by select ing the appropriate script  or Player machine in  the 
tree-view, and then typing a new number in  the Change Running To field (or by using the up/down 
arrows).  

To d ial  up  or  dow n (add or  subt ract )  vi r t ual  users dur ing  a t est : 

1. When your test is running, click on the script or Player workstation in the Runtime Window's tree-view for which you 
want to add or subtract virtual users. On the Virtual User Options tab, the Currently Running/Available field shows 
how many virtual users are currently running on that script or Player. 

2. In the Change Running To field, type a new number or use the up/down arrows to change the number. 

3. When you are done, click Apply. The Conductor will release or suspend the specified number of virtual users. 

Notes:  
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!  Your changes do not take effect until you click Apply.  
!  When you dial down a virtual user, the virtual user finishes the current transaction before going into a 

suspended state. 

 

Increase/ Decrease Runt ime Timing Updates 
While a test is running, you can change the frequency at which t im ing updates are sent from the Players to 
the Conductor in  the Runtime window. Decreasing the update in terval reduces the amount of overhead 
incurred in  large load tests due to the communicat ions between the Conductor and large numbers of 
virtual users.  

To change t he Runt im e Tim ing updat es: 

1. On the Global  Opt ions tab of the Runtime Options panel (bottom pane), choose from the 
fol lowing opt ions: 

!  No Updates: Choose th is opt ion to stop sending t im ing data while the test is running. Data 
wil l  st i l l  be col lected at the end of the test.  

!  Send Al l : Choose th is opt ion to send al l  t im ing data as i t  is compiled. 

!  Periodic Updates: Choose th is opt ion to specify a t ime interval for sending updates, then type 
the t ime interval (in  seconds) below.  

2. Click Apply. Any change takes effect immediately, and applies to all scripts in the test.  

 

 

Stopping a Load Test  
A load test is complete when al l  virtual users exit . A virtual user automatical ly exits when one of the 
fol lowing occurs: 

!  A script encounters an EXIT command. 

!  A script completes its transaction loop. 

!  A QALoad function fails and Abort on Error is set in Error Handling 

To st op  a load t est : 

Cl ick the Ex i t  Al l  Vi rtual  Users button or cl ick the Qui t  Curren t  Test  button. The Virtual User icon 

changes to  and the message, "Session aborted by User", displays. 

Adding Post -test  Comments 

If you selected the Display post  test  com m ents dialog opt ion when you configured the Conductor, the 
Post  Test  Com m ents window opens when you cl ick the Qui t  Curren t  Test  button. Type any comments, 
which are saved to the test ’s Summary Report that you can view in QALoad Analyze. 
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Adding Post -test  Comments 
By sett ing the appropriate opt ions when you configure the Conductor,  you can add comments to a 
completed test. The comments appear in  the test 's Summary Report in  QALoad Analyze. 

To conf igure t he Conduct or  f or  adding post -t est  com m ent s: 

1. Select Tools>Options. The Options dialog box appears. 

2. In the Dialog section of the Conductor Sessions page , select Display post test comments dialog. 

3. Click OK. The Conductor is now configured so that you can add comments when a test completes. 

To add post -t est  com m ent s: 

1. In the Test Completed dialog box, click Exit Test. 

OR 

In the Runtime toolbar, cl ick the Qui t  curren t  test  button. The Post Test Comments dialog box 
displays. 

2. Type any comments in the dialog box, then click OK. Your comments are saved in the Post Test Comments field of 
the Summary Report in 

3.  QALoad Analyze. 

 

Monitoring a Load Test  
When you start  a test, the QALoad Conductor’s in terface changes to an in teract ive test control stat ion, 
referred to as the Runtime Window. The Runtime Window displays in formation about the scripts, 
machines, and virtual users that are execut ing the load test. From the Runtime Window, you can observe 
the progress of individual scripts and Player machines, create and view real-t ime graphs, and start  or 
suspend scripts and Players from a running test to better simulate the unpredictabi l i ty of real users. For 
more in formation, see Runtime Window Interface. 

In  addit ion to the test data shown by default  on the Runtime Window, you can access detai led test 
in formation using the QALoad Conductor’s Runt ime Toolbar Buttons. You can: 

!  View statistics for a single virtual user 

!  View the activities of a virtual user in a browser-like window (WWW only) 

!  Step to the next request (WWW only) 

!  View the current datapool record 

!  Display the script running on a single virtual user 

!  Display messages sent from a Player workstation to the QALoad Conductor 

!  Display statistics about Conductor/Player communication 

!  Show/hide the Runtime Tree or Runtime Control Panel 

!  Exit, abort, or quit the test 

For more in formation, see Runtime Toolbar Buttons. 
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Viewing Test  Stat ist ics 

Once al l  workstat ions stop execut ing, cl ick the Qui t  Curren t  Test  button  on the toolbar to complete 
the test and automatical ly create the t im ing fi le (.t im). To compute and view test stat ist ics from the t iming 
fi le in  QALoad Analyze, open Analyze from Conductor.  

To access Analyze f rom  t he Conduct or : 

From the Conductor's Tools menu, choose Analyze.  

 

Conductor Runt ime Interface 

Runt ime Window Interface 

When you start  a test, the Conductor's in terface changes to an in teract ive test control stat ion cal led the 
Runtime Window. The Runtime Window displays in formation about the scripts, machines, and virtual  
users that are execut ing the load test.  The Runtime window is divided into two areas – the main Runtime 
window, and the dockable Runtime Options panel at the bottom of the window.  

On the Runtime Window, you can observe the progress of individual scripts and Player machines, view 
real-t ime graphs, and start  or suspend scripts and Players from a running test to better simulate the 
unpredictabi l i ty of real users. The Runtime main window dynamical ly displays test detai ls according to the 
type of in formation you select in  the Act i ve View  field. 

The lower pane, the Runtime Options panel, displays data for the current view and the individual script  
you select. This is a dockable control stat ion that al lows you to change virtual  user opt ions and data 
transfer opt ions while your test is running. 
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Runt ime Window 

When you start  a test, the Conductor's in terface changes to an in teract ive test control stat ion cal led the 
Runtime Window. From the Runtime Window, you can observe the progress of individual scripts and 
Player machines, create real-t ime graphs, and change the behavior of scripts and Players from a running 
test to better simulate the unpredictabi l i ty of real users. This window has two unique areas: 

!  Runtime main window - The information in the main Runtime window depends on the view you select in the Active 
View field. You can view details for all test scripts, individual test scripts, all player machines, and individual player 
machines. 

!  Runtime Options Panel - The lower pane, called the Runtime Options Panel, displays data for the current view and 
the individual script you select. This is a dockable control station that allows you to change virtual user options and 
data transfer options while your test is running. The information in the Runtime Options panel is displayed in three 
tabs: Virtual User Options Tab, Script Options Tab, Global Options Tab. 

 

Act ive View Details  

Detai ls for a running load test are displayed in the Runtime main window. The detai ls displayed depend on 
the opt ion you select in  the Act i ve View  field. You can choose: 
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All Virtual Users 

Virtual Users by Script  

Virtual Users by Machine 

Al l  Scripts 

Al l  Player Machines 

Graphs View 

Sessions View 

VantageAnalyzer MReports View 

All Virtual Users 

Lists the script  and player machine involved in the test and other detai l  in formation by each virtual user. 
 Double-cl ick a virtual user to display the Virtual User Info window. Select th is opt ion to view detai ls about 
each virtual user running a script  in  the test: 

Status i con : The first  column displays an icon that indicates the status of the virtual user. A moving icon 
represents a running virtual user; a st i l l  icon represents a virtual user that hasn't  yet started or is suspended; 
and an icon with a checkmark through i t  represents a virtual user that has exited. A red circle with an X 
indicates errors have occurred on that virtual user, or that the test session was manually terminated using 
the Exit , Abort , or Quit  Current Test buttons. 

User: Virtual User's ident i ficat ion number assigned by QALoad. 

Script : Name of the script  the virtual user is running. 

M ach ine: Name of the Player machine on which the script  is running. 

Pass: Number of t ransact ions successful ly completed. 

Fai l : Number of t ransact ion that have fai led to complete successful ly. 

M in : Lists the shortest response t ime recorded for a transact ion on the virtual user. 

M ax : Lists the longest response t ime recorded for a transact ion on the virtual user. 

Last : Lists the most recent response t ime recorded on the virtual user. 

Status: Lists a status for the virtual user i f any errors have been encountered, or l ists the name of the 
checkpoint the user has encountered i f the opt ion Send al l  t im ing data including Checkpoint in formation 
was selected on the Runtime window of the Session  Options dialog box during test setup. Double-cl ick a 
virtual user for more in formation, or i f the error message is to long to read. 

Errors:  

Error M essage:  
Note: Double-click in any field to display the Virtual User Info dialog box with the details about each virtual 

user. 

Virtual Users by Script 

Lists Virtual User and Player machine in formation with in each assigned script . Double-cl ick a virtual user 
to display the Virtual User Info window. Select th is opt ion to view the fol lowing detai ls for each virtual 
user sorted by script : 

User: Virtual User's ident i ficat ion number assigned by QALoad. 

M ach ine: Name of the Player machine on which the script  is running. 

Pass: Number of t ransact ions successful ly completed. 

Fai l : Number of t ransact ion that have fai led to complete successful ly. 

M in : Lists the shortest response t ime recorded for a transact ion on the virtual user. 

M ax : Lists the longest response t ime recorded for a transact ion on the virtual user. 
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Last : Lists the most recent response t ime recorded on the virtual user. 

Status: Lists a status for the virtual user i f any errors have been encountered, or l ists the name of the 
checkpoint the user has encountered i f the opt ion Send al l  t im ing data including Checkpoint in formation 
was selected on the Runtime window of the Session  Options dialog box during test setup. Double-cl ick a 
virtual user for more in formation, or i f the error message is to long to read. 

Errors:  

Error M essage:  
Note: Double-click in any field to display the Virtual User Info dialog box with the details about each virtual 

user. 

Virtual Users by Machine 

Lists Virtual User and script  in formation with in each assigned player machine. Double-cl ick a virtual user 
to display the Virtual User Info window. Select th is opt ion to  view the fol lowing detai ls for each virtual  
user sorted by Player machine: 

User: Virtual User's ident i ficat ion number assigned by QALoad. 

Script : Name of the script  the virtual user is running. 

Pass: Number of t ransact ions successful ly completed. 

Fai l : Number of t ransact ion that have fai led to complete successful ly. 

M in : Lists the shortest response t ime recorded for a transact ion on the virtual user. 

M ax : Lists the longest response t ime recorded for a transact ion on the virtual user. 

Last : Lists the most recent response t ime recorded on the virtual user. 

Status: Lists a status for the virtual user i f any errors have been encountered, or l ists the name of the 
checkpoint the user has encountered i f the opt ion Send al l  t im ing data including Checkpoint in formation 
was selected on the Runtime window of the Session  Options dialog box during test setup. Double-cl ick a 
virtual user for more in formation, or i f the error message is to long to read. 

Errors:  

Error M essage:  
Note: Double-click in any field to display the Virtual User Info dialog box with the details about each virtual 

user. 

 

All Scripts 

Lists detai l  in formation for each script  assigned to the test. Select th is opt ion to display the fol lowing 
summary detai ls about every script  in  the test: 

Script : The name of the script . 

Total  Users: The total number of virtual users assigned to run the script . 

Runn ing: The total number of virtual users current ly running the script . This number may vary at different 
t imes in a single test i f you are configured for dial-up virtual users, or have configured the test as a ramp-up 
test. 

Pass: The number of t ransact ions successful ly completed. 

Fai l : The number of t ransact ions that have fai led to complete successful ly. 

Respon se Tim e: The average response t ime of al l  vi rtual users current ly running the test script . 

Th rough put : The average number of t ransact ions per second th is script  is running. 

Al l  Player m ach ines 
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Lists detai l  in formation for each player machine assigned to the test. Select th is opt ion to display the 
fol lowing summary in formation about each Player machine running the test.  

M ach ine: The machine name, preceded by an icon indicat ing whether the test is current ly running on the 
machine or fin ished. A blue checkmark indicates a successful ly completed test. 

Total  Users: The total number of virtual users control led by that Player Agent. 

Runn ing: The total number of virtual users current ly running on that Player Agent machine. 

% Processor: The percentage of the Player Agent machine's processor that is current ly in  use. 

% M em ory: The percentage of the Player Agent machine's memory that is current ly in  use. 

% Disk : The percentage of the Player Agent machine's disk space that is current ly in  use. 

Status: Lists a general status for the test. For example, Test is running. 

Graphs View 

Displays real-t ime graphs for checkpoints, performance counters, and Player machine health stat ist ics. You 
can control which types of data are graphed in addi t ion to how the graphs appear. For detai led 
in formation, refer to Graphs View. 

Sessions View 

Displays summary in formation about the test and the Player machine. For more in formation, refer to 
Session View 

VantageAnalyzer MReports View 

Displays the latest retrieved VantageAnalyzer reports. If there are no VantageAnalyzer monitoring task 
associated with the tests, the act ive view is not avai lable. For more in formation, refer to VantageAnalyzer 
MReports View. 

 

 

 

Session View 

When you select Session  in  the Act ive View field, the Conductor Runt ime Window provides summary 
in formation about the test session that is current ly running. The Session view can be printed as a report  by 
right-cl icking and choosing Prin t  from the shortcut menu. 

Note: The Session view below has been cropped to better fit this help topic, while still representing what a 
real Session view might look like.  

Cl ick on the sect ions in  the fol lowing graphic for more in formation about the Session view. 
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Graphs View 

The Graphs view in the Conductor Runt ime Window displays graphs of data col lected during the test. By 
default , the Graphs view displays graphs for response t imes, test status, and player machine health.  

Other graphs, such as user-defined checkpoints and Remote M onitoring counters, can also be plotted in  
the right pane of the Graphs view i f they were enabled for the session. 

To d isplay graphs: 

1. Right-click on a counter or other data type in the tree view that you want to plot in a graph. 

2. Choose Add Graph or Add Plot To.  
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You can also modify a graph's appearance by right-cl icking on the graph and choosing one of the 
formatt ing opt ions, such as colors and axes propert ies. To increase the visibi l i ty of a plot when you have 
mult iple plots on a graph, cl ick on a plot (or that plot 's number in  the legend) to h ighl ight i t . 

 

 

 

VantageAnalyzer MReports View 

When select ing VantageAnalyzer M Reports from the Act i ve View  field, the Conductor Runt ime Window 
provides the last retrieved VantageAnalyzer MReport. The three toolbar buttons avai lable in  th is view al low 
you to display the VantageAnalyzer Configurat ion dialog box, to refresh the VantageAnalzyer report , and 
to launch the VantageAnalyzer Performance Console.  

This view is not avai lable i f the VantageAnalyzer reports retrieval is not configured. To set up 
VantageAnalyzer reports retrieval, refer to Retrieve VantageAnalyzer Data. 

Runt ime Opt ions Panel 

This dockable control stat ion enables you to change virtual user opt ions and data transfer opt ions while 
your test is running. The information in  the Runtime Options panel is displayed in three tabs: 

Virtual User Options Tab  

Curren t l y Runn ing/ Avai lable: Displays the number of current ly running Virtual Users. 

 Change Runn ing To: Cl ick the arrows to change the number of Virtual Users in  the test.  

Apply: Cl ick to apply your changes. 

Script Options Tab 

Changes made in th is window wil l  override opt ions set during the original Script  Assignment. 
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Note: Options on this tab are available only when Virtual Users by Script  or All Scripts are selected in the 
Active View. 

Error Handl ing: Choose how to respond when an error occurs during execut ion of the transact ion. During 
large load tests, errors can sometimes indicate that the test is strain ing the l imits of the hardware/software 
in  the test ing environment. Options are: 

!  Abort Transaction — If an error occurs while a transaction is being executed, the Player should abort the current 
transaction and the virtual user who encountered the error should exit the test. Use this option when errors will make 
the virtual user invalid for executing more transactions. 

!  Continue Transaction — If an error occurs while a transaction is being executed, the Player should continue 
executing the transaction as if the error didn’t occur. Select this option when errors are not critical to the performance 
of the load test and can be safely ignored. 

!  Restart Transaction (WWW, SAPGUI, and Citrix scripts only) — If an error occurs while a transaction is being 
executed, the Player should abort the current transaction entirely and restart a new transaction from the beginning. 
Note that the transaction count will increase for each transaction that is restarted. 

Pacing: Enter a value in  th is field to change the rate of pacing. Pacing is the t ime interval between the start  
of a transact ion and the beginning of the next transact ion on each workstat ion running the script . For 
example: i f a transact ion is designed to dupl icate the process of someone handl ing incoming telephone 
cal ls and those cal ls arrive at a rate of 40 per hour/per person, set the pacing rate at 90 seconds. 

Sleep: QALoad records the actual delays between requests and inserts the DO_SLEEP command in the 
script  to mimic those delays when the script  is played back in  a test. You can maintain the exact length of 
the recorded delays at playback, or shorten them by entering a smaller percentage of the original ly 
recorded delay to play back. For example, i f you recorded a delay of 10 seconds then DO_SLEEP (10); is 
wri t ten to your script . Then, i f a Sleep Factor of 50% is specified here, the Player wi l l  sleep for 5 seconds at 
that statement when the test is executed.   

Apply: Cl ick to apply your changes to the running script . 

Cancel : Cl ick to cancel any changes you have not yet appl ied to the running script . 

Global Options Tab 

Global Options apply to al l  scripts. 

Tim ing Updates: Select when the Players in  your test should send t im ing information to the Conductor. 
You can choose: 

No Updates - No t im ing updates are sent to the Conductor 

Send Al l  - Sends al l  t im ing updates to the Conductor 

Periodic Updates - If you chose Periodic Updates, type how often, in  seconds, t im ing updates 
should be sent to the Conductor in  the (1 - 1000 Sec.) field. 

Apply: Cl ick to apply your changes to the running script . 

Cancel : Cl ick to cancel any changes you have not yet appl ied to the running script . 

 

Monitoring a Running Test  

Monitoring a Load Test  

When you start  a test, the QALoad Conductor’s in terface changes to an in teract ive test control stat ion, 
referred to as the Runtime Window. The Runtime Window displays in formation about the scripts, 
machines, and virtual users that are execut ing the load test. From the Runtime Window, you can observe 
the progress of individual scripts and Player machines, create and view real-t ime graphs, and start  or 
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suspend scripts and Players from a running test to better simulate the unpredictabi l i ty of real users. For 
more in formation, see Runtime Window Interface. 

In  addit ion to the test data shown by default  on the Runtime Window, you can access detai led test 
in formation using the QALoad Conductor’s Runt ime Toolbar Buttons. You can: 

!  View statistics for a single virtual user 

!  View the activities of a virtual user in a browser-like window (WWW only) 

!  Step to the next request (WWW only) 

!  View the current datapool record 

!  Display the script running on a single virtual user 

!  Display messages sent from a Player workstation to the QALoad Conductor 

!  Display statistics about Conductor/Player communication 

!  Show/hide the Runtime Tree or Runtime Control Panel 

!  Exit, abort, or quit the test 

For more in formation, see Runtime Toolbar Buttons. 

 

Monitoring CPU Usage 

To help you monitor the impact of running a load test on a server, QALoad can col lect data from selected 
Players about CPU usage during a load test. The stat ist ics col lected during the test are merged into the test 's 
t im ing fi le so you can view them in QALoad Analyze after the test.  

Note: During a load test, if the CPU idle time of your machine falls below 25%, check the individual 
processes on your machine. If the Players and virtual users are utilizing most of the active CPU time, you 
should use additional Player machines and fewer virtual users per Player to conduct your load test. 

 

Watching a Script  Execute 

Use the Debug tab in  the Conductor Runt ime window to view the execut ing script . Note that i t  is possible 
that you wil l  not see the execut ion of every statement. In  order to min imize network traffic between the 
Conductor and the Players, the Player sends i ts script  debug status to the Conductor once per second, so 
that the Player can execute several statements without sending a debug message to the Conductor. 

To open t he Debug t ab:  

Select a Player in  the Runt ime window, then cl ick the Debug Vi rtual  User toolbar button.  

Note: The Conductor highlights the script line that it is currently executing.  

 

Graphing Checkpoints in Conductor 

Use the Graphs view of the runt ime Conductor to create real-t ime graphs of checkpoint response t imes 
during script  execut ion. 

Note: Similar graphs are also available for post-test analysis in QALoad Analyze. 
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Checkpoints are l isted in  the tree view on the left  side of the Graphs view of the runt ime Conductor, as 
shown in the example below. Both automatic and user-defined checkpoints appear in  the Response Tim es 
folder of each running script . 

 

 

 

 

 

 

 

Creating a Graph of Checkpoint Response Times 

Before you can review checkpoint response t imes in graph form, you must select the checkpoint counters 
to include. To choose a checkpoint that should appear in  a graph, h ighl ight the checkpoint name, right-
cl ick and choose either Add Graph  to create a new graph or Add Plot  To to add a data plot to an exist ing 
graph.  

If you choose the Add Graph  opt ion, the Add Graph dialog box appears. Select the opt ions for how the 
graph should appear and cl ick OK. 

Adding Thresholds 

To better ident i fy problem checkpoints, you can set thresholds on plots or graphs that indicate the number 
of t imes the data record for that checkpoint has gone above or below the number you set. Thresholds can 
be set from the Advanced tab of the Add Graph dialog box or by right-cl icking on an exist ing graph and 
choosing Th resholds. 

Highlighting Individual Plots 

If you create several plots on a single graph, i t  may become difficult  to see individual plots. To increase a 
plot 's visibi l i ty, cl ick on a plot in  the graph or a plot 's number in  the graph's legend. When highl ighted, 
the plot appears th icker and darker on the graph. 

Saving Checkpoint Graphs to a Session ID 

Checkpoint graphs that are created in  the Conductor are automatical ly saved to the current session ID fi le. 
To remove al l  graphs you added, cl ick Graph>Restore Defaul t  Graph  Layout . 
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Graphing Remote Monitoring 

Use the Graphs view of the runt ime Conductor to create real-t ime graphs of counter data during script  
execut ion. Similar graphs are also avai lable for post-test analysis in  QALoad Analyze.  

Selecting Counters to / *Graph 

Al l  counter data that is avai lable for graphing is located in  the tree view on the left  side of the of the 
Graphs view Data window, as shown below.  

 

Scripts of any middleware type col lect the fol lowing default  counter data, which is avai lable in  the 
Conductor for real-t ime graphing: 

!  Global counters: Running VU%, total running VUs, and errors 

!  Script counters: Running VUs, response times, and transactions 

!  Player machine health: % processor, % memory used, % disk space, %disk time, % paging file 

Addit ional middleware-based graphs are also generated by default  and vary by middleware. For example, 
for the WWW middleware, several performance-based counters are automatical ly col lected and avai lable 
for graphing, including server responses and WWW traffic. You can monitor th is data to determine the 
opt imum rate of performance of the appl icat ion that is running. 

Graphing Counter Statistics 

To choose a counter that should appear in  a graph, h ighl ight the checkpoint counter name or group of 
counters (folder), right-cl ick and choose either Add Graph  to create a new graph or Add Plot  To to add a 
data plot to an exist ing graph. 

If you choose the Add Graph  opt ion, the Add Graph  dialog box appears. Select the opt ions for how the 
graph should appear and cl ick OK. 

To better ident i fy problems in the test, you can set thresholds on plots or graphs that indicate the number 
of t imes the data record for that counter has gone above or below the number you set. Thresholds can be 
set from the Advanced tab of the Add Graph  dialog box or by right-cl icking on an exist ing graph and 
choosing Th resholds.  
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Highlighting Individual Plots 

If you create several plots on a single graph, i t  may become difficult  to see individual plots. To increase a 
plot 's visibi l i ty, cl ick on a plot in  the graph or a plot 's number in  the graph's legend. When highl ighted, 
the plot appears th icker and darker on the graph. 

Saving Counter Data Graphs to a Session ID 

Counter data graphs that are created in  the Conductor are automatical ly saved to the current session ID 
fi le. To remove al l  graphs you added, cl ick Graph >Restore Defaul t  Graph  Layout . 

 

Running a Series of Tests (Batch) 

Running a Batch Test  

By sett ing the appropriate opt ions in  the Conductor, you can elect to run a series of tests as a batch, rather 
than one at a t ime. A batch test comprises mult iple session ID fi les that are executed sequential ly. 

You can create a batch test by adding a number of session ID fi les to a batch f i le. Before you can add a 
session ID to a batch fi le, the fol lowing condit ions must be true: 

!  The session must include a defined number of transactions. Sessions of unlimited transactions cannot be used in a 
batch test. 

!  All scripts to be included must exist before starting the batch test.  

To run  a bat ch t est : 

1. Select Actions>Batch Test. The Configure Batch Test dialog box appears. 

2. Select the required session ID files in the Available Session Files list and click Add to add them to the Selected 
Sessions list. 

3. If you want to run a previously defined batch, click the Load Batch File button in the toolbar to navigate to the 
directory where the batch file (.run) resides. Select it, and click OK. 

4. In the Delay Between Tests field, click the up or down arrow to set the number of seconds to wait before starting 
the next test. 

5. Click Save to save the current batch file, or click Save As... to save the batch file under a new name. 

6. Click OK to return to the main Visual Designer window 

OR 

Click Start  to begin running the batch test. 

The Conductor then executes each of the session ID fi les in  sequence.  

 

 

Adding Sessions to a Batch Test  

Before a session is added, the fol lowing condit ions must be true: 

!  The session must include a defined number of transactions. Sessions of unlimited transactions cannot be used in a 
batch test. 
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!  All scripts must exist prior to starting the batch test. This means that the files referenced in the selected session ID 
files are present in the script directory. 

A session can be placed in  a batch mult iple t imes. This feature might be used to re-run a test or to perform 
housekeeping chores, such as logging users in  or out of a host or database. 

To add a session : 

1. From the Actions menu, choose Batch Test. The Configure Batch Test dialog box displays. 

2. In the Available Session Files box, highlight the session you want to add, and click the Add button. 

If you want to run a previously defined batch, cl ick the Load button to navigate to the directory 
where the batch fi le (.run) resides. Select i t , and cl ick OK. 

The session is added to the Selected Sessions l ist  on the right side of the dialog box.  

3. In the Delay Between Tests field, click the up or down arrow to set the number of seconds to wait before starting 
the next test. 

4. Click Save to save the current batch file, or click Save As... to save the batch file under a new name. 

5. Click Start to begin running the batch test, or click OK to return to the main Visual Designer window. 

 

 

Set t ing Delays Between Tests 

You can set a fixed delay or pause between tests by specifying a value in  the Delay Betw een  Tests field on 
the Configure Batch Test dialog box. After each test  is complete, the Conductor delays for the specified 
amount of t ime before start ing the next test. To set up a series of tests, see Running a Batch Test. 

 

 

Removing a Session from a Batch Test  

To rem ove a session f rom  a bat ch  t est : 

1. Select Actions>Batch Test. The Configure Batch Test dialog box appears. 

2. Click Load Batch File and select the file you want to modify. 

3. In the Selected Sessions pane, highlight the session to remove and click Remove.  

4. Click OK. 

 

Terminat ing a Batch Test  

Stop a batch of tests the same way you would stop a single session test, by cl icking the Abort  Al l  Vi rtual  

Users or Ex i t  Al l  Vi rtual  Users on the toolbar. The Virtual User icon changes to  and the message, 
"Session aborted by User", displays. When the Conductor process stops for any reason during a load test, 
the associated Player processes automatical ly terminate. 
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Tr oub leshoot ing  

Conductor pre-test  checks 
Before a test begins, the Conductor completes the fol lowing pre-test checks of the parameter fi les and 
Players. If any of these checks fai l , the Conductor displays an error message. 

!  Are there enough Players configured to support the number of users specified in the session ID file? 

!  Does the number of users specified in the session ID file exceed the maximum number of users defined by your 
authorization key? 

!  Can the specified compiled script files be accessed? 

!  Are all Players communicating with the Conductor? (The Conductor sends a request message to all the Players to 
verify that they are up and running.)  

 

Execut ing SSL scripts that  use client  cert if icates 
If you are execut ing SSL scripts that use cl ient cert i ficates, you must manually copy the cl ient cert i ficates in  
use to the Player machine(s) execut ing the script(s). 

Manually copy the cl ient cert i ficates from the \Program Files\Compuware\QALoad\Certificates 
directory to the same default  directory on the Player machine. 

Note: On the Unix player platform, you must create the Certificates sub-directory in the QALoad 
directory. The directory name is case sensitive. 

Heartbeat  message failure on a virtual user 
When a Player machine crashes or experiences a loss of communicat ion, the heartbeat message that the 
Conductor sends out (i f enabled) fai ls. This si tuat ion is indicated in  the runt ime Conductor through a 
message on each virtual user that is affected. When the heartbeat message fai ls for a virtual user, the Status 
column of the Detai ls view of a script  displays the fol lowing message: "The Player running th is user fai led 
to respond to a heartbeat message." 

The opt ion for enabl ing a heartbeat message is located on the Player page of the Options dialog box in  the 
Conductor. 

 

Timing file is too big 
Depending on the length of the load test and the amount of data that was col lected, t im ing fi les can grow 
to excessively large sizes that become difficult  to handle. To prevent t im ing fi les from becoming too large, 
try modifying the fol lowing sett ings: 

!  Disable automatic middleware checkpoint t im ings in  the Conductor 

!  Use the Conductor's t im ing data th inning opt ions 

Both of these sett ings are located on the Timing page of the Script Propert ies dialog box.  

To access t he Scr ip t  Proper t ies d ialog box: 
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1. In the Visual Designer window, click the script icon to display the script Properties panel on the right-hand 
side of the window.  

2. In the Script Properties section, click the Timing Options field to display the browse [...] button. 

3. Click the browse [...] button. 

 

 

Tips for running QALoad tests on UNIX systems 
To successful ly run large QALoad tests on UNIX systems, you may need to make adjustments to your 
sett ings as described below: 

General (AIX, Solaris, and RedHat  Linux) 

When you attempt to run  a large number of virtual users on UNIX platforms, the virtual users do not 
always synch. If virtual users do not synch, try increasing the Virtual User Startup Delay. By default , 
QALoad Conductor sets the VU Startup Delay to 1 mil l isecond. This default  is not h igh enough for UNIX 
platforms. If the UNIX Player receives a value less than 15 mil l iseconds, the delay wil l  be 15 mil l iseconds 
or more.  

To increase t he delay: 

1. In the QALoad Conductor, click Tools>Options. 

2. Click Player in the tree view to display the Player page. 

3. In the VU Startup Delay field, type the number of milliseconds to delay virtual user startup. 

  

Solaris 

The default  fi le descriptor l im it  on Solaris has a "soft" l im it  of 64, and a "hard" l im it  of 1024 (Solaris 2.6). 
Per the Solaris 2 FAQ (refer to http:/ /www.wins.uva.n l/pub/solaris/solaris2.html), the fi le descriptor l im it  is 
described in the getrl im it() manual page as: "One more than the maximum value that the system may 
assign to a newly created descriptor. This l im it  constrains the number of fi le descriptors that a process may 
create." 

To increase th is l im it , system administrators can modify the /etc/system fi le and reboot the system. For 
example: 

* set hard limit on file descriptors 

set rlim_fd_max - 4096 

*set soft limit on file descriptors 

set rlim_fd_cur = 1024 
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