AD Bridge 2.0 System Requirements

December 2019

AD Bridge 2.0 includes new features that will enable you to bridge Linux distributions with Windows Active Directory (AD) to manage Linux clients from an AD domain using Group Policy objects.

Micro Focus recommends the fully tested and certified platforms described in this page. However, customers running on other platforms or with untested configurations will be supported until the point Micro Focus determines that the root cause is the uncertified platform or configuration. Issues that can be reproduced on the certified platforms will be prioritized and fixed according to standard defect handling policies. For more information about support polices, see Support Policies.

The documentation for this product is available in HTML and PDF formats on a page that does not require you to log in. If you have suggestions for documentation improvements, click comment on this topic at the bottom of any page in the HTML version of the documentation posted at the AD Bridge Documentation page.

To download this product, go to the Micro Focus Downloads or the Customer Center website.

System Requirements

The following sections provide the AD Bridge requirements for hardware and software:

Software Requirements

The following sections provide the AD Bridge 2.0 software requirements:

Operating Systems

Component

Operating Systems

Linux Distributions

  • RHEL 8 (Red Hat Enterprise Linux)

  • RHEL 7

  • SLES 15 (SUSE Linux Enterprise Server)

  • SLES 12

  • CentOS 8

  • CentOS 7

  • Ubuntu 16

  • Ubuntu 18

  • Oracle 8

  • Oracle 7

Microsoft Windows Server

  • Windows Server 2019 64-bit

  • Windows Server 2016 64-bit

  • Windows Server 2012 R2 64-bit

  • Windows Server 2012 64-bit

Additional Linux Requirements

Applicable packages per the Linux distributions provided here are required if they cannot automatically download and update due to enterprise constraints during the AD Bridge Linux Agent installation.

Linux Distribution

Required Linux Packages

All distributions

.NetCore system update to install .NetCore 2.2 and its prerequisites.

For more information, see Linux distribution dependencies.

RHEL 8, RHEL 7, CentOS 8, CentOS 7, Oracle 8, Oracle 7

samba
samba-client
samba-winbind
samba-winbind-clients
cifs-utils
openldap-clients 

SLES 12, SLES 15

realmd
adcli
sssd
sssd-tools
sssd-ad
samba-client
krb5-client
openldap2-client

Ubuntu 18.04

realmd
sssd
sssd-tools
libnss-sss
libpam-sss
adcli
samba-common-bin
oddjob
oddjob-mkhomedir
packagekit
krb5-user
cifs-utils
keyutils 

Ubuntu 16.04

ntpdate
samba
krb5-config
krb5-user
winbind
libpm-winbind
libnss-winbind
cifs-utils 

Additional Microsoft Software Requirements

Component

Operating Systems

Active Directory

  • Windows Server 2019 64-bit

  • Windows Server 2016

  • Windows Server 2012 R2

  • Windows Server 2012

Hardware Requirements

This section provides sizing information for our base resource recommendation. Your results may vary based on the hardware available, the specific environment, the specific type of data processed, and other factors. It is likely that larger, more powerful hardware configurations exist that can handle a greater load. If you have questions, please consult with Consulting Services.

Executed in an environment with approximately one million Active Directory objects:

Component

CPU

Memory

Storage

Microsoft Windows Server

4 CPU (x64)/cores 2.0 GHz

16 GB

100 GB

Linux Agent

 

256 MB

350 MB

Application Integrations

Component

Integrated Systems

Linux Agent

Linux Distributions

GPEdit Extension (snap-in)

Windows Server, Group Policy Management Console (GPMC)

Browsers

Chrome, Firefox and Internet Explorer

For server versions, see Software Requirements.