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Overview
This manual describes how to install and configure Micro Focus COBOL Analyzer (CA), a suite of software
products for analyzing and modernizing legacy applications.
COBOL Analyzer provides insight into the technical reality of complex application portfolios, including
•
•
•
•

Tools for application and program level understanding, utilizing extensive metrics, reports, diagrammatic
views and querying tools to support myriad of business initiatives.
Quality Assessment with standard code quality queries to serve as a guidance to a code quality practice
in both development and maintenance phases.
Portability Assessment to help you generate various HTML reports to identify points of interest for
migrations.
In depth analysis tools to promote efficiency in the performance of daily tasks such as field changes,
understanding of data propagation through a program, and dead code removal.

Business Rule Manager mines business logic from program code and encapsulates the logic in business
rules.
While all products are installed with COBOL Analyzer, each product is licensed separately.
CA can be deployed in a multi-user environment or single users with a local database. The multi-user
environment gives users access to a common repository of application objects. Repository setup is the
responsibility of a master user, leaving team members free to focus on their tasks. The database for the
repository is assumed to be the customer's own.
CA installations consist of the following components:
•
•
•

The CA Server which hosts CA workspace files and related support files.
CA Clients which host the link files used to connect to workspaces on the server.
For single user setups, the CA software is installed on the developer's machine and includes an option
to install a local database.

This manual also describes how to install and configure the database client used to connect to repositories,
for sites at which the database client is not already installed. If you store repositories in Oracle or DB2, a
database client must be installed wherever the CA client or CA server is installed.

Installation Tasks
The table below describes the tasks involved in installing COBOL Analyzer and the order in which the tasks
must be performed.
Task

Order

Notes

Install CA on Server

1

This is for multi-user environments only.

Install CA on Clients

2

The CA package optionally installs SQL Server Express.
This is enough for a small sized repository (up to 10 GB).

Each task is described and explained in the chapters of the Installation Guide.

Deployment
The figure below shows the standard CA deployment scenario. The role each machine performs and its
key relationships are described in the following sections.
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Mainframe and Network Server
The mainframe typically hosts the application to be modeled in CA. Application source files are
downloaded from the mainframe (and, if necessary, a network server) to the CA server via FTP or SFTP.

Repository Server
The Repository Server hosts the database for one or more multiuser repositories, one repository per CA
workspace. This server provides centralized, network-accessible storage for parsed data and analysis
output.

CA Server
The CA Server hosts workspaces, workspace support files (including the copies of application source files
CA creates at workspace loading), and workspace output. This server leverages multiple processes to
enhance parsing performance in online or batch mode.
Parsed data is sent via ODBC to the repository server. Some analysis output is stored on the CA server as
well.
Note: In a multi-user environment, the CA Server cannot reside on the same machine as the CA
Repository. The installation program is the same for the CA client and CA server.

CA Client
CA Clients host the link files that let team members connect to workspaces on the CA server. These clients
access repository data stored in the repository server via ODBC.
Note: The installation program is the same for the CA client and CA server.

Single User Installation
You can configure COBOL Analyzer to build a workspace on one machine for a single user. You can use
Microsoft SQL Server Express - installed by default - to create a workspace on your local machine. CA
creates a database for the workspace "on the fly," with no intervention on your part. If you do use SQL
Server Express, bear in mind that the Windows user who creates the workspace must have been
configured with appropriate permissions in SQL Server Express. The user who installed SQL Server
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Express will always have the appropriate permissions. See the SQL Server Express documentation for
configuration instructions.
Restriction: The database size limit when using the SQL Server Express option is 10 GB.

Database Setup
If you use Microsoft SQL Server, the DBA must set up a SQL Server database for each workspace
repository you plan to create. CA users typically supply Windows credentials to access the repository.

SQL Server Database Setup
If you use Microsoft SQL Server, you must set up a SQL Server database for each workspace repository
you plan to create. If CA users will connect to the repository through a SQL Server login account, make
sure the server authentication property is set to SQL Server and Windows Authentication mode, as
described below.
The following instructions assume you are using the SQL Server Management Studio tool for SQL Server
2008. The procedure for the SQL Server Management Studio Express tool for SQL Server 2005 is similar.
Note: For Windows XP installations using the Italian locale, you must set the Time format in the
Control Panel Regional Language Options to "HH:mm:ss" before attempting to verify an CA
workspace with a SQL Server repository. Click Settings > Control Panel > Regional and Language
Options > Customize > Time and choose "HH:mm:ss" from the Time format drop-down.
1. Choose Start > Programs > Microsoft SQL Server 2008 > SQL Server Management Studio.
2. In the Connect to Server screen, select:
•
•
•

Database engine in the Server type drop-down.
The server on which you want to create the repository database in the Server name drop-down.
Windows Authentication in the Authentication drop-down.

3. Click Connect. The Microsoft SQL Server Management Studio window opens. In the Object Explorer
pane, expand the folder for the server. Click Databases and choose New Database... from the rightclick menu. The New Database window opens.
4. Select the General page. In the Database name field, enter the name of the database for the
repository. Modify the logical name and initial sizes of the database and log files if needed, then click
OK. The new database is displayed in the Object Explorer pane.
Note: Check the SQL Server Management Studio documentation for details on other database
settings.
5. If CA users will connect to the workspace repository through a Windows user account, skip the
remaining steps. If CA users will connect to the workspace repository through an SQL Server login
account, click the server name in the Object Explorer pane and choose Properties from the right-click
menu. The Server Properties window opens.
6. Select the Security page. In the Server authentication area, select SQL Server and Windows
Authentication mode, then click OK.
7. In the Object Explorer pane, click Security > Logins and choose New Login... from the right-click
menu. The Login - New window opens.
8. Select the General page. In the Login name field, enter the database login name, then choose SQL
Server authentication. Enter the password for the database login in the Password and Confirm
password fields, then click OK. The new login is displayed in the Object Explorer pane.
9. In the Object Explorer pane, expand the database you created for the workspace repository. Click
Security > Users and choose New User... from the right-click menu. The Database User - New window
opens.
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10.Select the General page. Define the database user:
•
•

•

In the User name field, enter the database user name.
In the Login name field, enter the database login name. Use the browse button to browse for the
login name.
Note: You specify the login name, not the database user name, when you create or connect to
a workspace, so it is usually best to make the user name and login name the same.
In the Database role membership pane, check db_owner, then click OK. The new user is displayed
in the Object Explorer pane.
Tip: You can use the same login and database user for multiple databases/workspaces.

You can configure COBOL Analyzer to build a workspace on one machine for a single user. You can use
Microsoft SQL Server Express - installed by default - to create a workspace on your local machine. CA
creates a database for the workspace "on the fly," with no intervention on your part. If you do use SQL
Server Express, bear in mind that the Windows user who creates the workspace must have been
configured with appropriate permissions in SQL Server Express. The user who installed SQL Server
Express will always have the appropriate permissions. See the SQL Server Express documentation for
configuration instructions.
Restriction: The database size limit when using the SQL Server Express option is 10 GB.
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Hardware and Software Requirements
The following sections describe the hardware, disk space, operating system, and software requirements for
CA installations.

Repository Server Hardware Requirements
The table below lists the hard drive storage requirements for the Repository Server. For other hardware
recommendations, check with support services.
Type

Requirement

Notes

Hard Drive Storage

Variable

Minimum of 20 GB disk space needed for the
software installation of the RDBMS and the
CA template database. Plus approximately
60x the size in bytes of the application source
code modeled in CA (e.g., 100 MB source =
6 GB).

Repository Server Software Requirements
The table below lists the software requirements for the Repository Server.
Type

Requirement

SQL Server

MS SQL Server 2012, 2014, 2016 or 2017

CA Server Hardware Requirements
The table below lists the hardware requirements for CA Server installations. Hardware requirements may
vary depending on the size of the application you are analyzing.
Type

Requirement

Notes

Processor

2.6 GHz Dual Core or 2x 3.0+ GHz
Processors

Dual processing capability with multiple cores
in a processor or separate physical
processors.

Physical Memory

3 GB RAM

Virtual Memory

1 GB to 3 GB

Hard Drive Storage

Variable

For CA workspaces, approximately 40x size
in bytes of the application source code
modeled in CA (for example, 100 MB source
= 4 GB).
For CA software, minimum 200 MB.

CA Server Software Requirements
The table below lists the software requirements for CA Server installations.
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Type

Requirement

Operating System

Microsoft Windows Server 2008, 32-bit and 64-bit
Microsoft Windows Server 2012, 32-bit and 64-bit
Microsoft Windows Server 2016, 32-bit and 64-bi
Microsoft Windows 7, 32-bit and 64-bit
Microsoft Windows 8, 32-bit and 64-bit
Microsoft Windows 10, 32-bit and 64-bit

Pre-Requisite Software

Note: The pre-requisite software is automatically
installed by the installer.
•
•
•

Windows Installer 4.5
Sentinel RMS License Manager
.NET Framework 3.5 Service Pack 1

•
•
•
•

Note: On Windows Server 2008 and Windows
Server 2012, .NET Framework is a feature and
installing it is different from that on older versions.
For information on how to enable it, see the
Microsoft Support Blog.
.Net Framework 4.0
Visual C++ 2012 Redistributable 11.0.61030
Visual C++ 2017 Redistributable 14.11.25325.0
SQL Server 2014 Express (optional install)

Internet Explorer 6.0 or higher (optional)

Required to view HTML report outputs.

Microsoft Office (optional)

Required by CA tools with reporting capabilities to save to
Microsoft Office file formats. Excel is required for standard
deviation charts in the Executive Report.

Microsoft Visio (optional)

Required to generate output as Microsoft Visio .VSD files.
Note: Visio .VDX files are XML-based and may be
generated without Visio being installed on the CA client.

OpenJDK JRE 8.0 or higher (optional)

Required for Java parsing.

CA Client Hardware Requirements
The table below lists the hardware requirements for CA Client installations. Hardware requirements may
vary depending on the size of the application you are analyzing.
Type

Requirement

Notes

Processor

3.0 GHz Processor

Single processor (single or dual core).

Physical Memory

1GB RAM

Virtual Memory

1GB to 3GB

Hard Drive Storage

Variable

For CA software, minimum 200MB.

CA Client Software Requirements
The table below lists the software requirements for CA Client installations.
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Type

Requirement

Operating System

Microsoft Windows Server 2008, 32-bit and 64-bit
Microsoft Windows Server 2012, 32-bit and 64-bit
Microsoft Windows Server 2016, 32-bit and 64-bit
Microsoft Windows 7, 32-bit and 64-bit
Microsoft Windows 8, 32-bit and 64-bit
Microsoft Windows 10, 32-bit and 64-bit

Pre-Requisite Software

Note: The pre-requisite software is automatically
installed by the installer.
•
•
•

Windows Installer 4.5
Sentinel RMS License Manager
.NET Framework 3.5 Service Pack 1

•
•
•
•

Note: On Windows Server 2008 and Windows
Server 2012, .NET Framework is a feature and
installing it is different from that on older versions.
For information on how to enable it, see the
Microsoft Support Blog.
.Net Framework 4.0
Visual C++ 2012 Redistributable 11.0.61030
Visual C++ 2017 Redistributable 14.11.25325.0
SQL Server 2014 Express (optional install)

Internet Explorer 6.0 or higher (optional)

Required to view HTML report outputs.

Microsoft Office (optional)

Required by CA tools with reporting capabilities to save to
Microsoft Office file formats. Excel is required for standard
deviation charts in the Executive Report.

Microsoft Visio (optional)

Required to generate output as Microsoft Visio .VSD files.
Note: Visio .VDX files are XML-based and may be
generated without Visio being installed on the CA
Client.

OpenJDK JRE 8.0 or higher (optional)
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Required for Java parsing.

CA Performance Optimization Guidelines
This section describes the optimal performance environments in which to run COBOL Analyzer, including
selecting the right hardware configuration for specific types of usage, and optimizing the CA configuration
for the selected configuration. The suggestions for performance improvements are focused on the
repository build phase of the workspace.
The most time-consuming and hardware-intensive aspects of running COBOL Analyzer are the source
verification and database loading during the workspace build phase. The guidelines include suggestions for
improving performance by using multiple Queue Processors and taking advantage of multiple CPU cores,
using the parallel verification option which determines the number of used Queue Processors, and
guidelines for defining the number of Queue Processors needed for a given configuration of available
machines and database server power.
There are two deployment scenarios for COBOL Analyzer:
•
•

Single User - this is typically a mobile user, such as a consultant on a laptop, who uses the repository
for demonstration or assessment purposes.
Enterprise Installations - several computers are used (one for a database server, one for workspace and
multiple user machines).

Choosing Hardware Configuration
Single User (One Machine)
Minimum Hardware Requirements
Type

Requirement

Processor

1.8 GHz, minimum dual core

Physical Memory

2 GB RAM

Hard Drive Storage

HDD with at least 20 GB free space

Notes

For CA workspaces, approximately
60x size in bytes of the application
source code modeled in CA (for
example, 100 MB source = 6 GB).

With this minimum hardware configuration you can run COBOL Analyzer and analyze sources.
Suggested Upgrades
The analysis time increases when the number of analyzed sources rises. To reduce the analysis time we
recommend you use one of the suggested upgrades:
1. A high speed Solid State Drive (SSD) for storing database tables. This can be added as an external
drive; however USB 3.0 or eSATA must be used. This will improve the verification performance by 25%
over the minimum configuration.
2. Use a quad core processor such as Intel Core i7 2670QM or any other quad core QE/QM processor.
This improves the verification performance by 50% over the minimum system configuration.

CA Performance Optimization Guidelines
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Note: You must run additional Queue Processors to benefit from the additional cores. See the
Choosing the Optimal Amount Of Queue Processors section for details.
Note: Improved verification performance means that if the project verification takes 100 minutes, and
you get 33% performance improvement, the verification time is reduced to 67 minutes.
Recommended Configuration 1
This configuration gives 33% improved verification performance. The changes from the minimum
configuration are marked in bold.
Type

Requirement

Processor

2.0 GHz, 2 cores

Physical Memory

4 GB

Hard Disk Drive

SSD with at least 20 GB free space

Notes

For CA workspaces, approximately
60x size in bytes of the application
source code modeled in CA (for
example, 100 MB source = 6 GB).

Recommended Configuration 2
Recommended Configuration 2 gives 50% improved performance of verification. The changes from the
minimum configuration are marked in bold.
Type

Requirement

Processor

2.0 GHz, 4 cores

Physical Memory

4 GB

Hard Disk Drive

Any type with at least 20 GB free
space

Notes

For CA workspaces, approximately
60x size in bytes of the application
source code modeled in CA (for
example, 100 MB source = 6 GB).

Performance Configuration
The Performance Configuration is a combination of all upgrades. It gives 66% improved verification
performance. The changes from the minimum configuration are marked in bold.
Type

Requirement

Processor

2.0 GHz, 4 cores

Physical Memory

4 GB

Hard Disk Drive

SSD with at least 20 GB free space

Notes

For CA workspaces, approximately
60x size in bytes of the application
source code modeled in CA (for
example, 100 MB source = 6 GB).

Enterprise Installation (Multiple Users Using Separate
Database Server)
A typical environment where large projects will be verified on a regular basis usually consists of 3 types of
components:
1. Database server (MS SQL Server).
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2. CA server with the workspace files. This is the machine where CA is installed and where the CA
workspace folder is located.
Note: There can be more than one workspace.
3. Processing node(s). This is one or more computers running Queue Processors, or hosting the users of
the tool.

Database Server
Minimum hardware requirements
Type

Requirement

Notes

Processor

2.6 GHz Dual Core or 2x 3.0+ GHz
Processors

Dual processing capability with
multiple cores in a processor or
separate physical processors.

Physical Memory

3 GB RAM

Hard Disk Drive

For CA workspaces, approximately
60x size in bytes of the application
source code modeled in CA (for
example, 100 MB source = 6 GB).

The minimum configuration can be up to four concurrent Queue Processors while providing reasonable
response time. To improve performance, one of the following upgrades should be used:
1. Use faster storage, for example use SSD or storage arrays in RAID0. SSD improves the performance of
verification by 33%. 2x SCSI 15000 rpm gives a similar performance improvement.
2. Use 8 GB of RAM. Increasing the amount of RAM improves the performance of verification by 15%
when using more Queue Processors.
3. Network latency between database server and repository server and users should be less than 1ms.
Recommended hardware configuration
This is the recommended hardware configuration. The changes from the minimum configuration are
marked in bold.
Type

Requirement

Note

Processor

2.6 GHz Dual Core or 2x 3.0+ GHz
Processors

Dual processing capability with
multiple cores in a processor or
separate physical processors.

Physical Memory

8 GB RAM

Hard Disk Drive

SSD or SCSI 15000 rpm in RAID0

For CA workspaces, approximately
60x size in bytes of the application
source code modeled in CA (for
example, 100 MB source = 6 GB).

Performance Configuration
You get 33% improved performance of verification.
Type

Requirement

Processor

Xeon CPU E5310 or Core i7 3770

Physical Memory

8 GB

Note

CA Performance Optimization Guidelines
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Type

Requirement

Note

Hard Disk Drive

2x SCSI 15000 rpm RAID0 or 240GB
SSD

Note: Performance configuration can support up to 16 concurrent Queue Processors. Note that user
activity through the online tool should be counted as an active Queue Processor.

CA and Workspace Server
The repository server stores the COBOL Analyzer workspace folder and files. It is shared on the network
so that other users can access it.
Warning: Micro Focus does not recommend combining the CA server and database server (and even
processing node) for machines with limited resources.
Minimum hardware requirements for Repository Server are:
Type

Requirement

Hard Disk Drive

Minimum of 20 GB disk space
For CA workspaces, approximately
needed for the software installation of 60x size in bytes of the application
the database software.
source code modeled in CA (for
example, 100 MB source = 6 GB).

Note

Storing your workspace on an SSD
drive improves verification
performance by 5%-15%, depending
on your project.

Processing Node/Nodes
This is the machine that runs the Queue Processors and the processes that they kick off. The minimum
configuration lets you run a single Queue Processor.
Minimum System Requirements
Type

Requirement

Processor

3.0 GHz single core or 2 GHz dual core

Physical Memory

2 GB

Virtual Memory

1 GB to 3 GB

Hard Disk Drive

1 GB

The minimum system lets you analyze small volumes of sources and use the basic functionality of the tool.
To determine the optimal amount of Queue Processors for your Processing node see Choosing the
Optimal Amount of Queue Processors. To improve the performance, some of the following upgrades can
be used:
1. Use more CPUs or CPU cores. COBOL Analyzer scales very well so the performance improvement
matches the CPU cores added - verification performance is improved by 90% when CPU cores are
doubled. The limit is eight physical cores that exclude hyper threading, with 16 queue processors. Each
concurrent Queue Processor instance needs up to an additional 2GB of RAM. Make sure your database
server can support the additional Queue Processors, see Database Server.
2. Use more computers as processing nodes.
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Recommended Configuration (66% improved performance of verification)
Type

Requirement

Processor

3 GHz quad core CPU

Physical Memory

4 GB

Hard Disk Drive

4 GB

As these processing nodes communicate extensively with the database server, a low-latency network is
required between processing node(s) and database server.
Note: For best results, the computers must be on the same local network. You can use a repository
server or a database server (or both) as processing nodes, provided that MS Windows is installed.

Software Configuration
Verification Information
Verification is the process of analyzing the code loaded into CA. The verification process demands a lot of
CPU power. COBOL Analyzer is designed to use a single CPU core for the main application, but each
Queue Processor can run on a separate CPU core. The Queue Processors can even run on multiple
computers to help with the verification database loading. There are two ways of initiating the verification
process. The first is the online tool (COBOL Analyzer) and the second is through the Batch Refresh
Process (BRP).

Parallel Verification
By default COBOL Analyzer uses serial verification both for the online tool and for BRP. If you have a
multicore CPU, it is better to use parallel verification.
To enable it in COBOL Analyzer:
1. Click Options > Workspace Options.
2. Click Verification > Parallel Verification tab.
3. Select either
• Run Parallel Verification in the online tool
• Run Parallel Verification in BRP
4. Adjust the Minimum Queue Processors to improve performance when using an optimized number of
CPU cores.
Note: On a quad core CPU you get up to 4 times better performance provided that you use the
optimal number of Queue Processors.

Choosing the Optimal Number of Queue Processors
The optimal number of Queue Processors is related to the number of physical CPU cores available.
If you have X physical CPU cores you should use at least X Queue Processors. Using more Queue
Processors than physical CPU cores slightly increases performance but depending on your system setup it
could also slow down the verification because of the large number of concurrent IO operations.
Note: Micro Focus recommends using <number-of-physical-CPU-cores> multiplied by two.

CA Performance Optimization Guidelines
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Using More Computers
You can start a new Queue Processor on another computer to help the current verification.
Note: CA must be installed on the computer that launches a Queue Processor.
1. Open Micro Focus COBOL Analyzer Administration and click Administer > Build New Connection.
This creates a local .rwp file to connect to the workspace that needs help during the verification and
database loading.
2. Click Administer > Launch Queue Processor. The Launch Queue Processor window opens.
3. Specify the local .rwp file for the workspace and enter the number of Queue Processors that you want
to start.
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Installing and Uninstalling COBOL
Analyzer
Before running an installation program described in this section, make sure you have administrative
permissions for the machine on which you are performing the installation. If you do not have administrative
permissions, the installation program will not let you continue.
Note: You can run the Windows Installer (.msi) installation programs "silently." That is particularly
useful when you are installing clients on a network. Check with support services for the appropriate
sequence of commands.

Installing CA on the Server or Client
The CA Server hosts CA workspace files and related support files. CA Clients host the link files used to
connect to workspaces on the server. Follow the instructions in this section to install CA on the client or
server. The Micro Focus License Manager is packaged with the installation.
Note: Having the CA server and the database on separate machines could improve performance. The
installation program is the same for the CA client and CA server.
1. Double-click COBOLAnalyzer.exe. Note that there might be a version number in the name of
the .exe file.
2. Change the installation directory if not installing to the default location.
3. Select which optional installs you want to include:
•
•

Microsoft SQL Server - Express Edition
Web Client

4. Read the End User License Agreement and check I agree to the End User License Agreement.
5. Click Install.

Uninstalling COBOL Analyzer
Follow the instructions below to uninstall an COBOL Analyzer product. Make sure you close any open CA
programs before running the uninstall program.
1. Click Start > Control Panel > Programs > Programs and Features > Uninstall a program
2. In the Uninstall or change a program window, right-click the product you want to uninstall, then click
Uninstall. You are prompted to confirm that you want to uninstall the product. Click Uninstall.

Installing and Uninstalling COBOL Analyzer
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Post-Installation Administrative Tasks
Before you can work in COBOL Analyzer, you must complete the basic administrative tasks described in
this section. You are prompted to perform the first of these tasks, configuring the CA, when you complete
the installation.

Configuring COBOL Analyzer
Use the Configuration Manager in the COBOL Analyzer Administration tool to configure CA options and
displays for the programming languages, dialects, character sets, and products in use at your site.
If you configure your CA for COBOL, for example, you will see only the CA options and displays
appropriate for COBOL modernization. You need to configure your CA for PL/I as well, you can come back
to the Configuration Manager later and select PL/I in addition to COBOL.
Note: The COBOL Analyzer Administration tool will prompt to be run with elevated privileges. This is
required because some features of the tool require write access to the Program Files directory.
1. Open the Configuration Manager window.
•
•

If you are installing CA, the Configuration Manager window opens after you finish the installation.
If you have previously installed CA and want to reconfigure it, choose Start > Programs > Micro
Focus > > Administration. The COBOL Analyzer Administration window opens. In the Administer
menu, choose Configure Micro Focus . The Configuration Manager window opens.
Note: If CA is open, you are prompted to exit. Click OK, then close CA.

2. Select each programming language, dialect, and character set in use at your site. Select each CA
product you want to use at your site. The core Application Analyzer product is always selected. Select
Additional Tools to enable tools not used in typical CA configurations. When you are satisfied with your
choices, click OK.
Note: If you modify your CA configuration, make sure you upgrade workspaces created under the
previous configuration.
Note: The COBOL Analyzer Administration tool will prompt to
be run with elevated privileges. This is required because some
features of the tool require write access to the Program Files
directory.

Licensing
Although COBOL Analyzer and Business Rule Manager) are both installed by the COBOL Analyzer
installer, each product is licensed separately. Follow the instructions in the topics listed below to manage
your licenses.

Upgrading Customers
A customer upgrading from Modernization Workbench version 3.1 or later may use the existing license key
to enable COBOL Analyzer for the same number of users.
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Concurrent Use
You can license COBOL Analyzer and Business Rule Manager for concurrent use. In this mode, one
license key for the purchased number of end users will be registered to a license server and each user
instance will contact it for authorization.

COBOL Analyzer Licensing
A Sentinel RMS license server is installed with COBOL Analyzer.
Depending on the licensing model in use at your site, you can manage your license:
•
•

Locally, using the installed Sentinel RMS license server.
Remotely, using a Sentinel RMS license server that has been configured to manage licenses centrally.
Note: The remote license server uses the same software as the local license server that is
installed with COBOL Analyzer.

You will need to apply a license in the Micro Focus License Administration to use COBOL Analyzer. To start
the Micro Focus License Administration, choose Start > All Programs > Micro Focus License Manager
> License Administration.
•

If you use a local license server, you can apply a license using an authorization code or a licensing file
in the Install tab of the License Administration.
•

•

Authorization code: Enter the 16-character license authorization code for COBOL Analyzer, then
click Authorize.
• Licensing file: Enter your downloaded license file (.mflic) by browsing or dropping the file, then click
Install Licenses.
If you use a remote license server, click Options > Advanced Configuration, then click Change in the
License server field. Enter the IP address or server name of the license server, then click Save.

Your License System Administrator can tell you which licensing model your site uses and provide you with
the name of the remote license server if needed. For complete information, including how to configure a
remote license server, refer to the help provided with the License Administration tool.

Business Rule Manager Licensing
Trial licenses are not provided for Business Rule Manager. Before you can work with it, you must enter the
16-character license authorization code:
•

Choose Start > Programs > Micro Focus License Manager > License Management System. In the
Licensing System Administration tool, click the Authorize tab, then enter the authorization code in the
Enter authorization code field and click Authorize.

Creating a Shared Folder for Workspaces
The folder in which you plan to create workspaces must be shared with team members. It is typically more
convenient to share the folder before you create workspaces, but you can do it afterward if necessary, then
refresh the workspace path as described in Getting Started in the CA documentation set.
Follow the instructions below to create a shared folder for workspaces. You must be an administrator to
create a shared folder.
1. On the CA server, create a folder for CA workspaces.
2. Select the folder and choose Sharing and Security from the right-click menu. The Properties dialog for
the folder opens. In the Sharing tab for the Properties dialog, select Share this folder on the network
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(or, on a machine in a Windows domain, Share this folder). Enter the share name in the Share name
field and click Apply.
Note: Do not embed spaces in the share name. Doing so may cause other users to be unable to
access the folder.
3. Click Permissions. The Permissions for Folder dialog opens. Specify the appropriate permissions for
users sharing the folder and click OK.

Upgrading Workspaces
When you modify your CA configuration, you must upgrade every workspace created with the previous
configuration. Only the master user can upgrade a workspace.
1. Choose Start > All Programs > Micro Focus > COBOL Analyzer > COBOL Analyzer
Administration. The CA Administration window opens.
2. In the Administration window, choose Administer > Upgrade Workspace. The Upgrade workspace
dialog opens.
3. Choose the workspace you want to upgrade, then click Open. A Workspace Upgrade window opens.
4. Click Start to begin the upgrade. In the Workspace Upgrade window you see the upgrade process (The
parts that are being upgraded are highlighted and the checkbox next to each upgraded part is checked
when the upgrade is complete.) You can Pause the upgrade and Resume it later.
Note: Upgrades that have stopped due to an error can be reset from the File menu.
5. (optional) Click Workspace Upgrade > File >Export DDL Script to export the DDL script to perform
the upgrade and give it to a DBA.
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Troubleshooting the Installation
Follow the instructions in this section to troubleshoot an CA installation.

Troubleshooting Workspace Access
The folder in which you plan to create workspaces must be shared with team members. If users are unable
to access workspaces, it may be because:
•
•
•

You have not shared the folder for workspaces. Share the folder, then refresh the workspace path as
described in Getting Started in the CA documentation set.
You shared the folder for workspaces after creating a workspace. Refresh the workspace path as
described in Getting Started in the CA documentation set.
You embedded spaces in the value of the Share name field for the folder. Remove the spaces, then
refresh the workspace path as described in Getting Started in the CA documentation set.
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