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Introducing Enterprise Analyzer
Micro Focus Enterprise Analyzer (EA) offers centralized storage and analysis of enterprise application
portfolios:

• Language-specific parsers generate a common repository of application objects, in the industrial-
strength DBMS of your choice.

• Sophisticated analysis tools give you convenient interactive access to the repository, in a multiuser
environment that facilitates exchange of information and insight across the enterprise.

The result is a single easy-to-use interface in which you analyze assets written in modern languages like
Java and C# alongside assets written in legacy languages like COBOL and PL/I. And in which you perform
the analysis with industry-leading tools that offer deep, detailed, and comprehensive insight into complex
modern distributed applications.

Enterprise Analyzer Products
Enterprise Analyzer is a suite of PC-based software products for storing, analyzing, and re-architecting
enterprise applications. The products are deployed in an integrated environment with access to a common
repository of program objects. Language-specific parsers generate repository models that serve as the
basis for a rich set of diagrams, reports, and other documentation. Each product is separately licensed.

 

 

Enterprise Analyzer
Enterprise Analyzer is a robust set of non-invasive interactive tools that work with source code, system
files, DDL, screen maps, and more. Use it for analyzing and documenting legacy systems at both the
application and program levels.

Use Enterprise Analyzer at the application level to:
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• Create diagrams of applications.
• Perform change analysis across applications.
• Estimate application complexity and effort.

Use Enterprise Analyzer at the program level to:

• Perform program analysis in stages.
• Perform impact analysis on a program.
• Model and search the repository.

Enterprise View
Enterprise View (EV) is a Web server-based tool that offers IT executives "at-a-glance" application portfolio
management (APM). EV charts and tables provide powerful graphical insight into APM trends and current
status, on dashboards that make it easy to drill down from the "big picture" captured at the highest level to
the lower-level details that support it.

With EV you can:

• Create, distribute, and gather responses to surveys about your organization’s application portfolio and
business processes.

• Mine application complexity metrics from the EA repository.
• Track survey and repository metrics in EV's rich variety of interactive charts, displayed on dashboards

structured to show the rollup of data from lower to higher levels.

For users who need to drill down even deeper into an application portfolio, EV lets you search, filter, and
analyze EA repository data. You can:

• Query the repository for information about application objects.
• Search, browse, and edit business rules and triggers.

Business Rule Manager
Business rule mining encapsulates your application’s business logic, making the application easier to
understand, document, and test. It lowers the risk and cost of maintenance and enhancement, and ensures
that all business logic is implemented in modernization efforts.

A business rule is a named container for program code that performs a discrete task in a business process.
It identifies and documents the code segment that performs this task. A business rule named Calculate
Date Difference, for example, might consist of this segment:

COMPUTE WS-DATE-VARIANCE = WS-C-CARD-DATE-CCYYMM - WS-TODAYS-DATE-CCYYMM.

Business Rule Manager (BRM) offers a powerful set of tools for autodetecting, and autodocumenting,
business rules. You can batch edit rule attributes; create custom attributes suited to your particular needs;
match input/output data elements with the business names you’ve assigned to them in your project
glossary; and much more.

How Enterprise Analyzer Models Applications
Enterprise Analyzer is a model-based technology that generates information about legacy applications at
two levels:

• Application-level information describes the relationships between the objects that comprise an
application: its programs, copybooks, JCLs, BMS files, and so forth.

• Object-level information describes the relationships between the abstract syntactical constructs that
comprise an object: its sections, paragraphs, statements, conditions, variables, and so forth.
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At both levels, the models are conceived as Entity Relationship Diagrams (ERDs). Each object or construct
the parser generates is modeled as an entity in one of the diagrams. The models are represented in tree
form to users.

Understanding Application-Level Information
The object model for an application defines the relationships between the objects that comprise the
application. These can be physical objects, like program source files or JCLs, or logical objects that identify
abstract program elements: entry points, data stores, screens, jobs, and the like.

The relationships between objects describe the ways in which they interact. In the figure, the source file
GSS.CBL defines the GSS program. The program, in turn, reads the data file GSS.FCSTSEC.

Understanding Object-Level Information
The construct model for an object defines its syntax. It shows in abstract form how the syntactical
constructs that comprise the object (its sections, paragraphs, statements, conditions, variables, and so
forth) are related. A variable, for example, can be related in the construct model to its declaration, a
dataport (if it is used in an I/O statement), or a condition (if the condition uses an expression of which the
variable forms a part).

The figure shows a portion of the construct model for the GSS program. The model shows that the
program executes a PERFORM statement if the value of the variable EIBRESP satisfies the condition
EIBRESP NOT EQUAL DFHRESP(NORMAL).

If you are interested in investigating other uses of EIBRESP in the program, you can navigate to the
declaration of the variable in the construct model, and from the declaration to each instance of the
variable’s use in the program.

Workspaces and Projects
Enterprise Analyzer uses the familiar notions of workspace and project to help users organize application
source files conveniently. A workspace is a named container for one or more applications. Every
workspace has a corresponding database repository of model objects.

You can divide a workspace up into projects that represent different applications or different portions of an
application. You might have a project for the batch portion of an application and another project for the
online portion, for example. You can also use a project to collect items for discrete tasks: all the source files
affected by a change request, for example.
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When you set up a workspace in Enterprise Analyzer, the system creates a default project with the same
name as the workspace. You can create new projects and move or copy entities between projects as
needed.

A workspace can contain objects coded in different programming languages. You can create multiple
workspaces on the same machine.

Single-User versus Multiuser Environments
Enterprise Analyzer can be deployed in a single-user or multiuser environment:

• In a single-user environment, the workspace repository resides on the local machine, and can be
accessed by the owner of the machine only. Limited facilities exist for sharing work with other users.

• In a multiuser environment, the workspace repository resides on a database server, and can be
accessed by any user with appropriate database privileges.

Most installations deploy Enterprise Analyzer in a multiuser environment. Single-user mode typically is
reserved for special needs.

The guidelines that follow for multiuser environments apply equally to single-user environments. For
installation instructions, see the installation guide for your product.

Multiuser Environment Basics
A multiuser Enterprise Analyzer environment gives members of a development team common access to a
workspace repository on a database server. Workspace setup is the responsibility of a master user, leaving
team members free to focus on their tasks. Common access makes it easy to share insights across the
team, and ensures that team members view the same source and work with the same option settings.

Deployment Scenario
The figure below shows a standard deployment scenario for the Enterprise Analyzer multiuser
environment. The role each machine performs and its key relationships are described below. Keep in mind
that the view is logical. Machine roles can be combined or separated as required.
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Mainframe and Network Server
The mainframe hosts the application to be modeled in Enterprise Analyzer. Application source files are
downloaded from the mainframe (and, if necessary, a network server) to the Enterprise Analyzer server via
FTP or SFTP.

Enterprise Analyzer Server
The Enterprise Analyzer server hosts workspaces, workspace support files (including the copies of
application source files the product creates at workspace loading), and workspace output. This server
leverages multiple processes to enhance parsing performance in online or batch mode.

Parsed data is sent via ODBC to the database server. Some analysis output is stored on the EA server as
well.

Database Server
The database server hosts the database for one or more multiuser repositories. This server provides
centralized, network-accessible storage for parsed data and analysis output.

The EA server, Enterprise View Web Server, and EA clients access the database server via ODBC. For
guidance on database setup, see the installation guide for your product.

Enterprise Analyzer Client
EA clients host the link files that let team members connect to workspaces on the EA server. These clients
access repository data stored in the database server via ODBC.

Enterprise View Web Server
The Enterprise View web server hosts services used by intranet and internet clients to display charts and
to access web-based view of repositories.

Enterprise View Web Client
Enterprise View web clients provide multiuser access to charts and workspace repository data via the
Enterprise View web server.

EA Privileges
Privileges in a multiuser environment work on two assumptions:

• Team members typically do not need to modify files until they have completed analysis and are ready to
test a proposed change.

• The team lead is best situated to make the change and reverify the modified file.

For these reasons, the EA multiuser environment has no need for file checkout and locking of the kind seen
in conventional multiuser environments.

Understanding Master Users
The user who creates a workspace on a Enterprise Analyzer server machine is referred to as its owner.
Initially, only the owner has master user privileges for the workspace.

The master user can delete the workspace, upgrade the workspace configuration, register and verify
source files, modify source, autoresolve decisions, perform restricted Clipper searches, create, assign, and
delete tags, and so forth. The master user can also designate new master users for the workspace.
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Ordinary users connect to the workspace from Enterprise Analyzer client machines. These users can
perform any task not restricted to the master user: analyze programs, mine business rules, extract
components, and so forth.

If you do not have master user privileges for a workspace, you will not see menu choices for privileged
methods. The same team member can be a master user for one workspace and an ordinary user for
another.

Understanding Workspace Security Policies
When you create a workspace, you can choose from two workspace security policies:

• The Simple Security Policy recognizes two classes of users, master users and ordinary users.
• The Three-Group Security Policy recognizes a third class of users, subject matter experts (SMEs), with

special privileges to create, assign, and delete tags.

In each policy, the master user can create new master users.

Using the Optional File Server
When you create a workspace, you can restrict Windows access to workspace source files to master
users, while using the optional File Server to make the source files available in EA only to ordinary users.
As long as you set up workspace folder privileges correctly, ordinary users can view and analyze sources
in the product, but cannot access them otherwise. For file server installation instructions, see the
installation guide for your product.

Public and Private Visibility
In a multiuser environment, the user who creates a workspace resource (a project or a Clipper list, for
example) is referred to as its owner. Only the owner can share the resource with other users.

A shared, or public, resource is visible to other members of your team. A private resource is not. If a public
resource is protected, team members can view but not edit or delete the resource. A Clipper list, for
example, is always protected.

You can turn sharing on and off in the tool you use to create the resource. Look for a symbol like this one

for a shared project  to indicate that the resource is shared.

Protecting Projects
By default, projects are unprotected: any user to whom the project is visible can add source files, include or
exclude objects.

Note: Only a master user or the owner of a shared unprotected project can delete it.

The project owner or master user can designate a project as protected, in which case no user can delete or
modify the project, including the project owner or master user: the project is read-only, until the project
owner or master user turns protection off.

Turn on protection by selecting the project in the Repository pane and choosing Project > Toggle
Protection. Choose Project > Toggle Protection again to turn it off. Look for a symbol like this one  to
indicate that a project is protected.

Dropping Indexes
If you are a master user with responsibility for verifying source files in a multiuser environment, you will
almost always want to drop database indexes to improve verification performance. You will be prompted to
drop indexes when you verify the application, or you can drop indexes at a time of your own choosing by
selecting Prepare > Drop Repository Indexes.
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When you drop indexes, you are prompted to restore the indexes when you analyze the files. If you want to
restore indexes at a time of your own choosing, choose Prepare > Restore Repository Indexes.

Computing Statistics
You typically need to gather statistics for your system before the optimizer for your RDBMS can determine
the most efficient way to execute SQL statements. If you are a master user with responsibility for verifying
source files in a multiuser environment, you will almost always want to gather system statistics after
verification to improve performance of the Enterprise Analyzer analysis tools.

Note: Check with your DBA before gathering system statistics. In Oracle, you must have
GATHER_SYSTEM_STATISTICS privileges to execute this method. Make sure to restore indexes
before gathering system statistics.

To gather system statistics, choose Prepare > Compute Database Statistics. You can view the generated
statistics in your RDBMS.
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Enterprise Analyzer Basics
This section describes elementary EA tasks: how to create a workspace and project, register and verify
source files, use the browser and other EA windows, set options, and export system diagrams and reports.

Creating a Workspace in Oracle or DB2
You create a workspace on the Enterprise Analyzer server machine. Other users connect to the workspace
from Enterprise Analyzer client machines. The workspace repository resides on a database server, and
can be accessed by any user with database privileges to the repository.

Note: Do not modify the name of the workspace after you create it. Doing so will cause unpredictable
results.

Before creating a workspace, you must configure an ODBC data source name (DSN) for the database that
holds the workspace repository, as described in the installation guide for your product. You will need the
following DSN configuration information to create the workspace:

• The data source name.
• The database schema name your DBA created for the repository.
• The database user name and password that give access to the schema.
• If required by your DBMS, the name of the tablespace your DBA created for the repository. If the DBA

also created a tablespace for database indexes, you will need the name of that tablespace as well.

The folder in which you plan to create workspaces must be shared with team members. It’s usually more
convenient to share the folder before you create workspaces, but you can do it afterward if necessary, then
refresh the workspace path.

It is the responsibility of the workspace creator to designate users for security policies. Perform this task as
soon as you have finished creating the workspace, then periodically edit the list of users as required.

1. Choose Start > Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The Administration window opens.

2. Choose Administer > New Workspace. The Create new workspace dialog opens.

3. In the Create new workspace dialog, double-click the New Workspace icon for the RDBMS in use at
your site or select it and click OK. The New workspace dialog opens.

4. In the New workspace dialog, choose the location for the workspace in the Save in drop-down. In the
File name field, enter the name of the workspace. Choose a name that describes the legacy application
as closely as possible. Click Save. The Define Connection Parameters dialog opens.

5. In the Define Connection Parameters dialog, click the Connection tab. On the Connection tab, enter:

• The ODBC data source name you defined at ODBC data source configuration. If you have not
defined a data source name, or want to use a different data source name, click ODBC Manager to
open the data source name configuration dialog, then follow the instructions for ODBC data source
configuration in the installation guide for your product.

• The database schema name your DBA created for the workspace repository.
• The database user name and password that give access to the schema.
• If required by your DBMS, the name of the tablespace your DBA created for the repository. If your

DBA also created a tablespace for database indexes, enter the name of that tablespace in the
Tablespace for Indexes field. These fields are displayed only for DBMSs that require a tablespace
name to be specified.

6. Click the Security tab. In the Policies list box, select:
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• Simple Security Policy if you want to enforce a workspace security policy that recognizes two
classes of users, master users and ordinary users.

• Three-Group Security Policy if you want to enforce a workspace security policy that recognizes a
third class of users, subject matter experts (SMEs), with special privileges to create, assign, and
delete tags.

7. In the Files access group box on the Security tab, select:

• Direct sources access via Windows share if your site does not restrict Windows access to
workspace source files to the master user.

• Secure sources access via EA file server if your site restricts Windows access to workspace
source files to the master user, while using the optional file server to make the source files available
in the product to ordinary users. Make sure the values for the server name and port number fields
are correct.

Note: For File Server installation and setup instructions, see the installation guide for your product.

8. Click OK.

Note: If you created the workspace in a non-shared folder, you are warned to that effect and
prompted to share the folder. After you share the folder, make sure to refresh the workspace path.

You are notified that the workspace was created successfully. Enterprise Analyzer creates a workspace
file (.rwp) and a folder with the same name in the specified location. The workspace folder contains
support files and subfolders for EA output. A project with the same name as the workspace is displayed
in the Repository Browser.

Creating a Workspace in SQL Server
You create a workspace on the Enterprise Analyzer server machine. Other users connect to the workspace
from Enterprise Analyzer client machines. The workspace repository resides on a database server, and
can be accessed by any user with database privileges to the repository.

Note: Do not modify the name of the workspace after you create it. Doing so will cause unpredictable
results.

The folder in which you plan to create workspaces must be shared with team members. It’s usually more
convenient to share the folder before you create workspaces, but you can do it afterward if necessary, then
refresh the workspace path.

It is the responsibility of the workspace creator to designate users for security policies. Perform this task as
soon as you have finished creating the workspace, then periodically edit the list of users as required.

You can use Microsoft SQL Server Express to create a workspace on your local machine. Enterprise
Analyzer creates a database for the workspace "on the fly," with no intervention on your part. If you do use
SQL Server Express, keep in mind that the Windows user who creates the workspace must have been
configured with appropriate permissions in SQL Server Express. The user who installed SQL Server
Express will always have the appropriate permissions. See the SQL Server Express documentation for
configuration instructions.

Note: For Windows XP installations using the Italian locale, you must set the Time format in the
Control Panel Regional Language Options to "HH:mm:ss" before attempting to verify an EA
workspace with a SQL Server repository. Click Settings > Control Panel > Regional and Language
Options > Customize > Time and choose "HH:mm:ss" from the Time format drop-down.

1. Choose Start > Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The Administration window opens.

2. Choose Administer > New Workspace. The Create new workspace dialog opens.

3. In the Create new workspace dialog, double-click the New Workspace icon for the RDBMS in use at
your site or select it and click OK. The New workspace dialog opens.
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4. In the New workspace dialog, choose the location for the workspace in the Save in drop-down. In the
File name field, enter the name of the workspace. Choose a name that describes the legacy application
as closely as possible. Click Save. The Define Connection Parameters dialog opens.

Note: This dialog does not open for Microsoft SQL Server Express. The product starts creating the
workspace immediately.

5. In the Define Connection Parameters dialog, click the Connection tab. Define the connection:

• In the Server field, enter the server name. The server name must be of the form <machine>\<SQL
server>.

• In the Database Name field, enter the database name your DBA created for the workspace
repository.

• In the Integrated Security drop-down, select the integrated security provider interface in use at your
site. Choose:

• Windows Authentication if users connect to the workspace repository through a Windows user
account.

• Server Authentication if users connect to the workspace repository through an SQL Server
login account.

• If you chose Server Authentication, enter the database login name in the User Name field and the
login password in the Password field.

Note: The database user name and login name are typically, but not always, the same. If you
have trouble connecting, it may be because you are specifying the database user name rather
than the login name.

6. Click the Security tab. In the Policies list box, select:

• Simple Security Policy if you want to enforce a workspace security policy that recognizes two
classes of users, master users and ordinary users.

• Three-Group Security Policy if you want to enforce a workspace security policy that recognizes a
third class of users, subject matter experts (SMEs), with special privileges to create, assign, and
delete tags.

7. In the Files access group box on the Security tab, select:

• Direct sources access via Windows share if your site does not restrict Windows access to
workspace source files to the master user.

• Secure sources access via EA file server if your site restricts Windows access to workspace
source files to the master user, while using the optional file server to make the source files available
in the product to ordinary users. Make sure the values for the server name and port number fields
are correct.

Note: For File Server installation and setup instructions, see the installation guide for your product.

8. Click OK.

Note: If you created the workspace in a non-shared folder, you are warned to that effect and
prompted to share the folder. After you share the folder, make sure to refresh the workspace path.

You are notified that the workspace was created successfully. Enterprise Analyzer creates a workspace
file (.rwp) and a folder with the same name in the specified location. The workspace folder contains
support files and subfolders for EA output. A project with the same name as the workspace is displayed
in the Repository Browser.

Creating a Workspace Using the Workspace Build Wizard
The Workspace Build Wizard helps you create an Enterprise Analyzer workspace. Stepping through it, you
add your source files, associate files with source types and analyze the files so that they are ready to be
used in Enterprize Analyzer.
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Note: To use the wizard, you must have SQL Server Express installed on the machine.

Designating Users for Security Policies
When you create a workspace, you choose from two workspace security policies:

• The Simple Security Policy recognizes two classes of users, master users and ordinary users.
• The Three-Group Security Policy recognizes a third class of users, subject matter experts (SMEs), with

special privileges to create, assign, and delete tags.

In each policy, the master user can create new master users.

Designating Users in a Simple Security Policy
A Simple Security Policy recognizes two classes of users, master users and ordinary users. Initially, only
the workspace creator has master user privileges. The master user can designate new master users as
described in this section.

1. Choose Start > Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The Administration window opens.

2. Choose Administer > Edit Users. The Edit Users dialog opens.

3. In the Edit Users dialog, select the workspace (.rwp file) for which you want to edit users and click
Open. The Security dialog opens.

4. The Security dialog displays a list of users who have connected to the workspace in the Known Users

list box and a list of master users in the Master Users list box. Select a known user and click the 

button to move the known user into the list of master users. Select a master user and click the  button
to move the master user into the list of known users.

Note: Click Refresh at any time to update the lists.

5. To create a new master user, click (New User...) in the Master User list box. A dialog opens prompting
you to enter the name of the new master user. Enter the name and click OK.

6. When you are satisfied with your entries, click Close.

Designating Users in a Three-Group Security Policy
A Three-Group Security Policy recognizes a third class of workspace users in addition to master users and
ordinary users: subject matter experts (SMEs), with special privileges to create, assign, and delete tags.
Initially, only the workspace creator has master user privileges. The master user can designate SMEs and
new master users as described in this section.

1. Choose Start > Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The Administration window opens.

2. Choose Administer > Edit Users. The Edit Users dialog opens.

3. In the Edit Users dialog, select the workspace (.rwp file) for which you want to edit users and click
Open. The Security dialog opens.

4. The Subject Matter Experts and Master Users tabs of the Security dialog display a list of users who
have connected to the workspace in the Known Users list box and a list of subject matter experts and

master users, respectively, in the opposite list box. Select a known user and click the  button to move
the known user into the list of subject matter experts or master users. Select a master user and click the

 button to move the subject matter expert or master user into the list of known users.
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Note: Click Refresh at any time to update the lists.

5. To create a new subject matter expert or master user, click (New User...) in the Subject Matter Experts
or Master Users list box. A dialog opens prompting you to enter the name of the new subject matter
expert or master user. Enter the name and click OK.

6. When you are satisfied with your entries, click Close.

Refreshing the Workspace Path
The folder in which you plan to create workspaces must be shared with team members. It’s usually more
convenient to share the folder before you create workspaces, but you can do it afterward if necessary, then
refresh the workspace path as described below. You can also use the refresh path feature when you move
a workspace.

Note: For instructions on how to share a workspace folder, see the installation guide for your product.

1. Click Start > Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The Administration window opens.

2. Click Administer > Refresh Workspace Path. The Select workspace dialog opens.

3. Select the workspace (.rwp file) you want to refresh and click Open. The Workspace directory network
path dialog opens. The Workspace directory network path dialog opens.

4. In the Workspace directory network path dialog, enter the path of the workspace in the text field. The
path must be of the form \machine_name\share_name\workspace_folder_name, where
machine_name is the name of the machine where the shared folder resides, share_name is the value
of the Share name field on the Sharing tab of the Properties dialog for the shared folder, and
workspace_folder_name is the name of the folder for the workspace.

Note: The shared folder is the folder that contains the .rwp file for the workspace, not the
workspace folder. The workspace folder (containing support files and subfolders for EA output)
resides on the same level as the .rwp file.

5. Click OK.

Connecting to a Workspace in Oracle or DB/2
Once a workspace has been created on the Enterprise Analyzer server machine, other users can connect
to the workspace from EA clients. When you connect to a workspace, you create a link file with connection
information that points to the workspace. Because the connection information is already stored in the file,
you don’t have to enter it again when you reopen the workspace connection. Like a workspace file, a link
file has a .rwp extension.

Before connecting to a workspace, you must configure an ODBC data source name (DSN) for the
database that holds the workspace repository you want to link to, as described in the installation guide for
your product. You will need the following DSN configuration information to connect to the workspace:

• The data source name.
• The database schema name your DBA created for the repository you want to link to.
• The database user name and password that give access to the schema.

1. Choose Start > Programs > Micro Focus > Enterprise Analyzer. The Open Existing workspace
dialog opens above the Enterprise Analyzer main window. Click Cancel to dismiss the dialog.

2. Choose File > Build New Connection. The Define Server Workspace Connection dialog opens.

3. In the Define Server Workspace Connection dialog, select the ODBC driver for the RDBMS in use at
your site in the Database Provider drop-down. In the Required Parameters group box, enter:
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• The ODBC data source name you defined at ODBC data source configuration. If you have not
defined a data source name, or want to use a different data source name, click ODBC Manager to
open the data source name configuration dialog, then follow the instructions for ODBC data source
configuration in the installation guide for your product.

• The database schema name your DBA created for the workspace repository.
• The database user name and password that give access to the schema.

Note: The Tablespace and Tablespace for Indexes fields are for future use.

4. When you are satisfied with your entries in the Define Server Workspace Connection dialog, click the
Browse button for the Save Link As (.rwp) field. The Save Server Workspace Connectivity dialog
opens.

5. In the Save Server Workspace Connectivity dialog, choose the location for the workspace link in the
Save in drop-down. In the File name field, enter the name of the link. Click Save. The linked workspace
opens in the Enterprise Analyzer main window. EA creates a link file (.rwp) in the specified location.

Connecting to a Workspace in SQL Server
Once a workspace has been created on the Enterprise Analyzer server machine, other users can connect
to the workspace from EA clients. When you connect to a workspace, you create a link file with connection
information that points to the workspace. Because the connection information is already stored in the file,
you don’t have to enter it again when you reopen the workspace connection. Like a workspace file, a link
file has a .rwp extension.

1. Choose Start > Programs > Micro Focus > Enterprise Analyzer. The Open Existing workspace
dialog opens above the Enterprise Analyzer main window. Click Cancel to dismiss the dialog.

2. Choose File > Build New Connection. The Define Server Workspace Connection dialog opens.

3. In the Define Server Workspace Connection dialog, click the Connection tab. Define the connection:

• In the Server field, enter the server name. The server name must be of the form <machine>\<SQL
server>.

• In the Database Name field, enter the database name your DBA created for the workspace
repository.

• In the Integrated Security drop-down, select the integrated security provider interface in use at your
site. Choose:

• Windows Authentication if you connect to the workspace repository through a Windows user
account.

• Server Authentication if you connect to the workspace repository through an SQL Server login
account.

• If you chose Server Authentication, enter the database login name in the User Name field and the
login password in the Password field.

Note: The database user name and login name are typically, but not always, the same. If you
have trouble connecting, it may be because you are specifying the database user name rather
than the login name.

4. When you are satisfied with your entries in the Define Server Workspace Connection dialog, click the
Browse button for the Save Link As (.rwp) field. The Save Server Workspace Connectivity dialog
opens.

5. In the Save Server Workspace Connectivity dialog, choose the location for the workspace link in the
Save in drop-down. In the File name field, enter the name of the link. Click Save. The linked workspace
opens in the Enterprise Analyzer main window. EA creates a link file (.rwp) in the specified location.
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Opening a Workspace
The procedure for opening a workspace is the same whether you created the workspace or simply
connected to it. You can also open a workspace by double-clicking it in the file system. You don’t have to
close a workspace before opening another workspace.

1. Choose Start > Programs > Micro Focus > Enterprise Analyzer. The Open Existing workspace
dialog opens above the Enterprise Analyzer main window.

Note: If Enterprise Analyzer is already open, choose File > Open Workspace.

2. Click the tab you want to work in:

• In the Existing tab, choose the drive and folder for the workspace you want to open. A list of
workspaces in the selected folder is displayed in the righthand pane. Double-click the workspace you
want to open, or select it and click OK.

• In the Recent tab, double-click the recently opened workspace you want to open, or select it and
click OK.

Note: If you created the workspace in a previous release of Enterprise Analyzer, the system
prompts you to upgrade the workspace to the new release. Click Yes.

The workspace is displayed in the Enterprise Analyzer window. If a workspace was already open in the
window, the selected workspace replaces it.

Registering Source Files
Before you can analyze application source files in Enterprise Analyzer, you need to load, or register, the
source files in a workspace.

Note: In a multiuser environment, only a master user can register source files.

The EA creates copies of the registered files on the server machine (or locally in a single-user
environment) in the Sources folder for the workspace. These are the files you view and edit in the EA tools.
You can restore a file to its original state, update it to its current state, or export it as necessary.

Source files must have recognized DOS file extensions before they can be registered. You can view and
add to the recognized extensions in the Workspace Registration options window. Files without extensions
are checked for content, and if the content is recognized, the files are registered with appropriate
extensions appended.

EA assumes that input source files are ASCII files in DOS format. Occasionally, files may be converted
incorrectly from other formats to DOS-based ASCII with an extra special character (like “M”) at the end of
each line. While Enterprise Analyzer accepts these files as input, some EA tools may not work correctly
with them. Make sure all source files are in valid ASCII format.

You can register source files in compressed formats (ZIP or RAR), as well as uncompressed formats.
Enterprise Analyzer automatically unpacks the compressed file and registers its contents.

Note: EA extracts compressed source files using the command line syntax for archiver versions most
widely in use. If you use newer archiver versions, specify the command line syntax in the Archivers
tab of the User Preferences window.

Workspace Registration options determine registration behavior. The default values for these options are
preset based on your configuration and should be appropriate for most installations.
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1. In the Repository Browser, create a project for the source files you want to register, or use the default
project. To create a project, choose Project > New Project. The Create Project dialog opens. Enter the
name of the new project and click OK. The new project is displayed in the Repository Browser.

2. Select the project in the Repository Browser, then copy-and-paste ( Ctrl+C and Ctrl+V) or drag-and-
drop (if UAC is disabled) the file or folder for the source files you want to register onto the Repository
Browser. You are notified that you have registered the files successfully and are prompted to verify the
files. Click Close. The Repository Browser displays the contents of the new workspace either by folder,
or by type, depending on the tab you have selected - Folders or Types. The former displays the
contents of the repository in the same folder structure as the one they have on the host environment,
the latter displays them by object type.

Note: When updating or adding new sources through the EA main window, the files or folders
being registered will be included into the selected folder in the Folders view. Registration into the
Types view will copy the selected files and folders directly to the root Sources folder, i.e. they will
not be copied into any other existing folders. If you are registering files or folders in Folders view,
make sure you've selected in the tree the exact folder in which you want them to be registered. If
you haven't selected any folder, they will be copied into the root Sources folder.

Important: Before registering your source files, you must create a folder structure that replicates
the original. This helps to avoid errors when you work with homonyms. Micro Focus recommends
putting each application in a separate folder, putting system files that are common for more than
one application in one directory. After you do that, register your sources by selecting the folders
and including them in the project as described in step 2.

Note: In the notification dialog, select Never ask again if you do not want to be prompted to verify
files. On the Environment tab of the User Preferences window, select Ask user about verification
if you want to be prompted again.

Host Environment Source Compatibility
When you register your source files, it is essential that they are organized in the same folder structure as
the one on your host environment. This allows EA to create the correct relationships when connecting
programs with their copybooks, JCLs with the proper version of the procedures that are used, etc. Run-
time connections are also established based on this structure. Furthermore, this structure allows for having
several members with the same name, i.e. homonyms.

The sources to be loaded into EA should be in folders named after the PDS libraries on the Mainframe and
those folders should be the ones loaded.

Example

There is an enterprise organization with 3 data centers: Data Center 1 with one Mainframe, Data Center 2
with two Mainframes, and Data Center 3 with one Mainframe.

The following image shows the folders in a Windows environment:
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And this is what the three data center folders look like after they have been copied to the workspace:

 

20 | Enterprise Analyzer Basics



 

Resolving Include Files
When trying to resolve include files (copybooks, PL/I includes, JCL procedures, etc.), the EA Parser will
look at all folders trying to find names that match the included file. If only one match is found, it will use that
file. If more than one match is found, EA Parser takes the following steps to resolve which of the matching
include files is the one to use:

1. It checks if one of the folders is listed under Search Path in the Homonyms tab in Project Options.
The folder can be listed as:

• an absolute location:

C:\Workspaces\FS Doc\Sources\Data Center 1\DC1 Mainframe 1\SYS1.COPYLIB

• or as a relative location under the Sources folder:

Data Center 1\DC1 Mainframe 1\SYS1.COPYLIB

2. It looks for proximity of the included file to the including file in the source folder structure:

• First it looks at files that are in the same folder as the "including" source.
• Then it looks at files in the dependent folders.
• And then - up the folder hierarchy.
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3. Finally folder names will be matched and the "include" folder that has a name with a better match to the
source folder name will be selected.

Resolving Program-to-Program Calls
When resolving call relationships between programs, it is possible to reach a point where there is more
than one candidate for a called program. In this case EA works the same way as with includes (see
Resolving Include Files), but since the program objects themselves don't have folders, the folders of the
source files that generated them are used.

Note: This same algorithm applies to any relations between non-legacy entities (e.g. PROGRAM
reads TABLE, TRANSACTION starts PROGRAM, etc.).

Resolving Control Cards
Control cards can be any members explicitly mentioned in the JCL. When parsing JCLs, EA will look for a
file with the member name in the JCL in a folder with a name matching the PDS name from the mainframe.

Resolving JCL Procedures
When looking for JCL procedures, the parser uses the JCLLIB statement, if present. If there is only one
copy of the searched procedure, that copy is used. Otherwise, if more than one copy is available, the
libraries specified with the JCLLIB statement are used to pick the right one.

Example:

Path to the JCL file: <workspace_path>\Sources\APP1\MYJCL\MYJOB.JCL

//MYJOB1   JOB     ...
//MYLIBS1  JCLLIB  ORDER=CAMPBEL.PROCS.JCL
//S1       EXEC    PROC=MYPROC1

In this case the procedure <workspace_path>\Sources
\APP1\CAMPBEL.PROCS.JCL\MYPROC1, if present, will be used.

Queue Processor
There are various ways to set parameters for the Queue Processor.

To launch the Queue Processor

1. Start EA Administration.
2. Open Administer > Launch Queue Processor or press F7.

The Launch Queue Processor window opens.
3. In the Serve workspace field type the name of the workspace you want to use or press the ... button to

browse for a workspace.
4. Check the Processing Mode - Conversion, Verification or both.
5. Choose the number of processors to start . The number depends on your system capabilities.
6. Check Produce Log File if you want to produce a log file and then click OK to start the verification or

Cancel to quit.

Check Workspace Queue
Check workspace Queue displays the queued processes that are waiting in queue for the current
workspace. To view them:
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1. Open Start Menu> Micro Focus> Enterprise Analyzer > Enterprise Analyzer Administration.
2. Select Tools > Check Workspace Queue. The Select workspace window opens.
3. Select a workspace file (.rwp) and click Open. A message with the number of queued records is

displayed.

Manage Queue
1. Click Start> Micro Focus>Enterprise Analyzer>Enterprise Analyzer Administration to start the

Enterprise Analyzer Administration.Manage Queue shows the processes that are waiting to be
processed. After the Queue processor has finished the list is automatically cleared.

2. Click Tools > Manage Queue. The Manage Queue window opens.

It contains a list of all processes waiting to be processed by the Queue Processor. The available actions
are:

• File> Close - closes the window.
• Record> Delete - if you delete an item from the list it remains unverified and you must re-verify the

sources again.
• Record > Unlock - unlocks records that are locked due to some verification error.
• Record >Select All - selects all records from the queue list.
• Record> Unselect All - deselects all records from the queue.
• Queue > Refresh - refreshes the queue list.
• Queue> Show All - shows all records for the queued processes.
• Queue> Auto Refresh - automatically refreshes the list.

Verifying Source Files
Parsing, or verifying, an application source file generates the object model for the file. Only a master user
can verify source files.

You can verify a single file, a group of files, all the files in a folder, or all the files in a project. It’s usually
best to verify an entire project. Enterprise Analyzer parses the files in appropriate order, taking account of
likely dependencies between file types.

Note: You need not verify copybooks. Copybooks are parsed when the including source file is
verified.

If your RPG or AS/400 Cobol application uses copy statements that reference Database Description
or Device Description files, or if your MCP Cobol application uses copy statements that reference
DMSII DASDL files, you need to generate copybooks for the application before you verify program
files.

Workspace and Project Verification options determine verification behavior. The default values for these
options are preset based on your configuration and should be appropriate for most installations.

1. In the Repository Browser, select the project, folder, or files you want to verify and choose Prepare >
Verify.

2. You are prompted to drop repository indexes to improve verification performance. Click Yes. You will be
prompted to restore the indexes when you analyze the files.

The parser builds an object model for each successfully verified file. For an unsuccessfully verified file, the
parser builds an object model for as much of the file as it understands.
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How Verification Results Are Indicated
If you have not verified a workspace file, the file is displayed in the Repository pane in bold type. Since the
system has not generated an object model of the file’s contents, only the file itself is displayed.

A verified file shows all the objects in the model generated for the file. Verification results are denoted as
follows:

• A blue dot  means that the parser has verified the file successfully.
• A red dot  means that the parser has encountered an error in the file.
• A yellow dot  means that the parser has encountered an error in the file, but that the file has been

successfully verified under the relaxed parsing option.

Note: When you edit a file, the modified file and any dependent files are invalidated, and need to be
verified again. You can learn more about how objects are invalidated and how the system refreshes
the repository in Preparing Projects in the product documentation set.

Quick Inventory
Quick Inventory is a project related option that automatically registers and verifies referenced files using
JCL or PCT files as a starting point. Start by enabling and configuring Quick Inventory, register the JCL or
PCT files to be used as the starting points, then verify those files. If you have set all paths correctly, the
product will register and verify the external files. Enterprise Analyzer finds its dependencies registers them
in the project, and verifies them.

To enable Quick Inventory:

1. In Enterprise Analyzer open Options > Project Options.
2. On the Quick Inventory tab check Enable Quick Inventory and click Apply.

Quick Inventory first searches the workspace and if the files are not found there you need to specify the
directory where your sources are located. There is a list of pre-defined source types that are supported by
Enterprise Analyzer.

To edit, add, delete or select a search path where you want the Quick Inventory to look for sources:

1. In Enterprise Analyzer open Options > Project Options.

Click the Quick Inventory tab.
2. There is a list with pre-defined search paths suggestions with the names of the object types most

commonly used. Select a suggestion, right-click the selected suggestion and then click Edit.

a. Enter the search path to the sources. For example: COBOL = c:\Sources
\COBOL_Applications_Directory.

Note: Make sure you enter the correct path. Otherwise EA is not able to find the sources.

b. Press Enter, then check the search path to select it and click Apply.
3. If the sources are located in more than one directory (for example if you need to search in more than

one COBOL directory outside the workspace), you have to add another entry to the Search Path list.
Right-click in the list of suggested directories and then click Add. A new item is created in the list. Enter
the values you need. For example: COBOL = C:\Sources\COBOL_Applications_Directory_1.

Add a new entry for each separate directory you need to search.
4. To delete an entry select it and right-click on it, then click Delete.
5. Click OK to save the changes, or Cancel to undo them and get back to the main Enterprise Analyzer

window.
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Using the Enterprise Analyzer Main Window
The Enterprise Analyzer main window lets you view and edit projects, set product options, and open EA
tools. The window’s state is saved across sessions.

Open a pane in the main window by selecting the appropriate choice in the View menu. Resize a pane by
using the mouse to grab its border with another pane, called a splitter, and dragging it to a new location.
Close a pane by clicking the  button in the upper righthand corner.

Menus
Enterprise Analyzer menus let you access Enterprise Analyzer tools and other product functionality. Menus
are displayed only for the products you have enabled in the Configuration Manager. The table below shows
the relationship between products and menus.

Note: The screens shown in the product documentation set display the menu bar with all products
installed.

Most Enterprise Analyzer menu choices have equivalent choices in the right-click menu. Menu selections
for panes in the main window are available only if the pane has the focus.

Product Menu

Enterprise Analyzer Analyze

Enterprise View Profile

Business Rule Manager Extract

Toolbars
You can access a Enterprise Analyzer menu function by clicking its tool bar icon. The tool tip for an icon
tells you what it does. Place your cursor over the icon for a moment. The tool tip will display.

A tool bar is displayed only if its corresponding menu is displayed. You can change the position of a tool bar
by grabbing the delimiter at the left of the tool bar and dragging it to a new location.

Project Filtering
Filter the projects in the repository browser to see only the one(s) that you want to work with. The Project
filter field is on the toolbar. Enter the name of the project you want to see in the Project filter and all other
project will be hidden. The filter string is saved when closing and reopening the workspace. To clear the
filter, delete the text in the input box and press Enter.

Use wildcards and regular expressions to refine the project filtering.

Note: An asterisk wildcard is assumed at the end of the filter name.

Example

If you have 5 projects named Project 1 through Project 5 and enter Project [1-3] in the
project filter, only Project 1, Project 2, and Project 3 will be shown in the browser. If no
projects match the filter, the Browser will be empty.
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Using the Repository Browser Pane
The Repository Browser pane shows the contents of the repository for the current workspace. It has two
tabs:

Folders Displays the contents of the repository in the same folder structure as the one they have in the
host environment. This allows for elements with the same name (homonyms) to be loaded and
displayed.

Types Displays the contents of the repository by project, object type, and object relationship.

Each of the two tabs consists of the following elements:

Browser Shows the objects in the repository of the current workspace in a tree structure. Depending on
the tab you have selected in the Repository Browser pane, the contents are displayed either by
type or by folder.

Search Lets you execute various searches in the repository of the current workspace.

In the Browser window, hover your cursor over an object to display a tool tip that describes the object in
more detail.

Using the Search Assistant
The Search Assistant is integrated in the Repository pane. It searches all sources in the current
workspace. The results are displayed in a tree in the browser window, either by type or by folder,
depending on the tab you have selected in the Repository pane - Folders or Types. The information in the
tree is grouped in three levels:

• Project level - shows the projects that contain objects
• Folder level - shows the relative folder structure. If there are more than one folder levels they are

grouped and displayed with slashes - Folder1/Folder2/Folder3(n). The number in brackets
indicates the number of search result objects in the folder.

• Object level - shows the objects that are the result of the search.

You can customize the search options in Options > User Preferences > Search Assistant where you can
choose the object types filter. You can also set the maximum time a search can take as well as the
maximum number of results that are displayed in Options > Workspace Options > Search Assistant.

To use the Search Assistant:

1.
Type in a search string in the search box and click . The search returns all workspace objects
whose names match the search criteria.

2. Drill down the tree to see the relationship types and available methods for the objects.
3. Double-click an object in the search result tree to see its source code.

Note: To see the source code of a declaration, double-click it or right-click and select Go To
Source.

4. Right-click the search result objects in the Browser to see the list of available context-sensitive actions
for the selected objects.

Note: Multiselect is also available for the items in the search result tree.

To reset a search or change the search criteria in the search field:

1. Click the "x" button in the left corner of the search field.

The search is reset and the last Browser view you used is displayed.

26 | Enterprise Analyzer Basics



Enterprise Analyzer keeps a history of the searches you have done so when you start typing a search
string, it lets you select from a list of search strings you have previously used that begin with the same
characters as the ones you have typed.

Using the Browser
The Browser displays the sources in the repository of the current workspace, organized in a tree.
Depending on the tab you have selected in the Repository pane, the contents are displayed either by type
or by folder. Switch between them to browse the repository in different ways.

• Type view - shows the object model for the workspace, organized in a tree form by project, object type,
and object relationship.

• Folder view - shows the sources in the tree in the same folder structure as the one they have in the host
environment.

Note: When you work with homonyms, you will see a number in parentheses after the name of the
object if there is more than one instance of it.

Selecting Objects

Select an object in the Browser by clicking it with the left mouse button. You can select all, select multiple,
or type-ahead select.

Use the Select choices in the Edit menu to select objects based on their verification status. The choices
operate on the entire list in the Search tab and on the objects under the selected workspace, project, or
folder in the Browser.

The Project drop-down displays the current project. You can navigate quickly to another project in the
Browser by clicking the project name in the drop-down.

Note: In the Folders view, you can use mutliselect for objects in different folders on the same level.

You cannot use multiselect for child and parent nodes.

You cannot use multiselect across projects.

Selecting All

To select all the objects in the tree or all the objects in the selected node, choose Edit > Select All. To
deselect the objects, choose Edit > Unselect All.

Selecting Multiple

To select a range of objects, hold down the Shift key, click the first object in the range, then click the last
object in the range. To select objects that are not in a range, hold down the Control key, then click each
object you want to select.

Using the Type-Ahead Select Functions

Use the simple type-ahead select function to select displayed objects as you type. To use the simple
function, make sure the Browser tab is current, then type the characters you want to match.

Note: You cannot use the simple type-ahead select function in the Search tab.

Use the advanced type ahead select function to select objects in the Browser or Search tab whether or not
they are currently displayed. To use the advanced function, click an object that has the same type as the

object you want to select, then click the  button next to the  button at the bottom of the Repository

pane (or if the filter subtree function is enabled, next to the  button). From the drop-down menu, choose:

• Select to match text explicitly.
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• Wildcard Select to match text using wildcard patterns.

Enter the text you want to match in the field next to the  button. The tool selects matched objects as

you type, as long as they are in the same subtree. Click the  button to repeat the select with the same
criterion.

To select multiple objects, enter the text you want to match in the field next to the  button, then click the

adjacent  button. From the drop-down menu, choose:

• Select All to select multiple objects that match text explicitly.
• Wildcard Select All to select multiple objects that match text using wildcard patterns.

The tool selects matched objects as long as they are in the same subtree. Click the  button to repeat
the select with the same criterion.

Expanding Subtrees

Click the  symbol next to an item to expand its subtree one level. Click the  symbol to collapse the
subtree one level.

In the Repository Browser, select an item and choose Expand Subtree in the right-click menu to expand
all its subtree levels in a single step. Select an item and choose Save Subtree in the right-click menu to
export the label text for expanded subtree levels to a text file.

Note: For subtrees with a great many objects, you can improve browser display performance by
filtering the subtree and/or by lowering the fetch buffer size in the General tab of the Workspace
Options window.

Filtering Subtrees

For a subtree with a great many objects, you can improve browser display performance by showing only
objects of interest in the subtree. To filter out objects from a subtree, select the subtree, then enter the text

you want to match in the field next to the  button at the bottom of the Repository pane (or if the type-

ahead select function is enabled, next to the  button). Click the adjacent  button and choose Filter
from the drop-down menu.

The tool filters out unmatched objects from the subtree, and places a  symbol next to the subtree in the
browser display. The filter and filter text are persistent for the subtree across sessions. To remove the filter
and its text, enter an empty string in the text field and choose Filter again.

Refreshing the Browser

In a multiuser environment, you need to refresh the browser after another user adds, deletes, or modifies a
workspace file. Choose View > Refresh Browser to refresh the browser.

Viewing the Entire Workspace

By default, the Browser tab displays repository trees for projects only. These trees show only objects you
can act on in the browser. To view all the objects in the workspace, choose View > Entire Workspace, or
select (none) in the Project drop-down. Choose View > Entire Workspace again, or select a project in
the Project drop-down, to display the project only.

Using the Legacy Search Tab
The Legacy Search tab displays a sorted list of workspace objects returned by a search filter. Select
objects in the Legacy Search tab the same way you do in the Browser tab.
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To execute an existing search filter, choose Edit > Search Criteria. In the Filter Name drop-down, choose
the filter for the search, then click Find. The results are returned in the Search tab.

Note: By default, the results list shows two attributes of an object: its name and file type. Use the
General tab of the Workspace Options window to display additional attributes.

Creating a Search Filter

You can use predefined filters to search for objects in the Repository pane or create your own filters. You
cannot modify a predefined filter.

1. Choose Edit > New Criteria. The Search dialog opens.

 

 

2. Choose any allowed combination of the following:
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• To filter on object type, select the Entity Type check box and choose the entity type in the pane
below.

• To filter on object name, select the Object Name Like check box and enter a matching pattern for
the name in the accompanying field. You can use wildcard patterns allowed in LIKE statements by
Visual Basic for Applications (VBA).

• To filter on verification status, select the Where Parse Status check box and choose the status in
the group box below.

• To filter on a text string in the source, select the Scan Legacy Sources For check box, then specify
the search criterion. Select the check boxes below the drop-down if you want the search to match
case, skip comments, and/or match whole lines.

3. In the Filter Name drop-down, enter the name of the search filter and click Save.

4. To edit a search filter, select it in the Filter Name drop-down and follow the instructions for creating a
filter. To delete a search filter, select it in the Filter Name drop-down and click Delete. To clear a search
filter, select it in the Filter Name drop-down and click Clear.

Note: To execute a search directly from the Search dialog, select the search filter in the Filter
Name drop-down and click Find. The results are returned in the Search tab.

Specifying a Search Criterion

Follow these instructions to specify a search criterion in find and replace operations and in search filters.

1. Click the radio button for the type of pattern matching you want to use.

2. In the combo box:

• Select the pattern for the text you want to match. The drop-down lists matching patterns from
previous searches.

• Enter a new matching pattern by typing in the combo box. You can enter plain character strings,
Posix regular expressions, or wildcard patterns allowed in LIKE statements by Visual Basic for

Applications (VBA). For regular expressions and wildcard patterns, click the  button next to the
drop-down to display a pop-up menu of elements you can insert in the pattern. Click an element to
insert it. The matching pattern is saved when you execute the search.

Using Wildcard Patterns in Searches

In most searches you perform in the EA tools, you can use wildcard patterns allowed in LIKE statements by
Visual Basic for Applications (VBA). The table below shows the wildcard characters and what they match.

Character Matches

? Any single character.

* Zero or more characters.

# Any single digit (0–9).

[charlist] Any single character in charlist.

[!charlist] Any single character not in charlist.

To match the special characters left bracket ([), question mark (?), number sign (#), and asterisk (*),
enclose them in brackets. The right bracket (]) cannot be used within a group to match itself, but it can be
used outside a group as an individual character.

Specify a range of characters in a charlist by using a hyphen (–) to separate the upper and lower bounds of
the range. [A-Z], for example, results in a match if the corresponding character position in a string contains
any uppercase letters in the range A–Z. You can specify multiple ranges in brackets without delimiters.
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Finding and Replacing Text in Source Files
You can find and replace text in source files from the Browser or Search tab of the Repository pane. Use
the Editor to replace text in a selection of source code.

1. In the Browser or Search tab, select the source files or the node that contains the source files you want
to search and choose:

• Edit > Find if you simply want to search.
• Edit > Replace if you want to search and replace.

2. The Find and Replace dialog opens. Click the tab for the operation you want to perform.

Note: The find functionality in the Find tab is bidirectional. You can search up or down, and specify
that the search wrap. The find functionality in the Replace tab is unidirectional. Otherwise, the find
functionality is identical in each tab. The remaining steps assume that you want to both search and
replace.

3. In the Find What combo box, specify the search criterion. Select the check boxes below the drop-down
if you want the search to match case and/or match whole words.

4. In the Replace With combo box, select the replacement text. The drop-down lists text strings from
previous replace operations. Enter new replacement text by typing in the combo box. If you used regular

expressions for the find, click the  button next to the drop-down to display a list of elements you can
insert in the replacement text field.

5. Click Find Next. When the search finds a match, click Replace. You are prompted to confirm the
replacement. Click Yes. Click Find Next again to find the next match, or click Replace All to replace all
matching text.

Using the Editor and Viewer
The Editor lets you view and edit the source code for a file. The Viewer lets you view renderings of logical
objects like screens and transformation target models. Double-click a file in the Repository pane to view it
in the Editor or Viewer. Choose File > Recent Sources to open a file from a list of recently opened files.

Editing Source
Edit file source as you would text in a word processor (cut-and-paste, drag-and-drop, undo, and so forth).
Click File > Save to save your changes. Edits are saved in the copy of the file maintained in the
\Workspace\Source subfolder.

Note: When you edit a file, the modified file and any dependent files are invalidated, and need to be
verified again. Only a master user can edit and verify source in a multiuser environment.

Finding and Replacing Source in a Selection
To find and replace source in a selection of text, select the text, then follow the instructions for the source
file find and replace function.

Viewing a List of Errors
For a source files with errors or warnings, right-click in the Editor and choose:

• Errors > View Errors from the popup menu to list the errors and warnings in a separate pane below the
Editor. Choose Edit > Errors > View Errors again to hide the pane.

• Errors > Next Error from the popup menu to navigate to the offending source code for the next error in
the list.

• Errors > Previous Error to navigate to the offending source code for the previous error in the list.
• Errors > Severity Filter from the popup menu to filter the list by severity.
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Note: You can set a severity filter for all your workspaces in the Editor User Preferences.

• Errors > Copy Errors in the pop-up menu to copy the list of errors and warnings to the clipboard.

To hide the Editor and show only the list of errors and warnings for the selected file, right-click in the
Repository pane and choose Show Errors in the pop-up menu. Double-click the source file in the
Repository pane to show the Editor again.

Extracting and Expanding Copybooks (Cobol, MFS Only)
To extract source code as a copybook, select the code you want to extract, then choose Edit > Extract
Copybook. A dialog box opens, where you can enter the name of the new copybook. Click OK. The new
copybook is added to the repository and the extracted code is replaced by a COPY statement referencing
the new copybook.

To expand COPY statements, choose Edit > Expand Copy Statements. The added lines of code are
highlighted and a comment line is inserted to identify the source copybook.

Commenting Out Source
To comment out a block of source, select the block and choose Edit > Comment Block. To uncomment
the block, select it and choose Edit > Uncomment Block.

Printing Source
To print the source for a file, choose File > Print.

Setting Editor User Preferences
Use the Editor tab of the User Preferences window to specify the display characteristics of the Editor.

1. Choose Tools > User Preferences. The User Preferences window opens. Click the Editor tab.

2. In the Font drop-down, select the display font for source code.

3. Select the Colorize Text check box if you want to use a color scheme to identify source elements, then
specify the color of each source element.

4. In the Show Errors pane, select the check box for each type of error you want to show in the error list.

Specifying the Color of Items
You use a standard Windows color control to specify a color scheme for source elements and other items.
Use the Palette tab to select a color from the Windows palette. Use the System tab to match the color of a
standard Windows element. Depending on the element, you can specify the foreground color, background
color, and/or font color.

Using the Object Information Pane
The Object Information pane displays comments you have entered for an object. Select an object in the
Repository pane and choose View > Object Information to show the Object Information pane.

Enter comments for an object by selecting the object in the Repository pane and choosing Properties in
the right-click menu. In the Description tab, enter your comment in the text area and click OK.

Note: You cannot use this method to enter comments for a workspace (that is, when an entire
workspace is displayed in the Repository Browser). Use the General tab of the Workspace Options
window to enter comments for a workspace.
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Viewing Object Properties
The properties of an object describe its characteristics: its language, complexity metrics, relationships, and
the like. Select an object in the Repository pane and choose View > Properties to display a set of tabs
with object properties. The table below describes the tabs in the Properties window.

Note: In other EA tools, use the right-click menu or the View menu to display the properties of the
selected object.

Tab Description

Description Displays comments you have entered for the object.

General Displays the name and other general information for the object.

Internal Displays verification option settings and other internal information for
the object.

System Displays system information for the object.

Statistic Displays the complexity metrics for the object and their values.

Relationships Displays the relationships of the object. Only the first relationship level
is shown but if you want to explore a particular branch you can do it by
double-clicking the object. Select Restricted to the current project
to restrict relationships to those in the current project. Select
Workspace wide to show all the relationships of the object in the
workspace.

Object Tags Displays the tags assigned to the object.

Viewing Inventory Reports
Inventory Reports give high-level statistics for source file types in the current workspace: number of files of
each type, whether verified, number of lines of source code (verified files only), and the like. To generate an
Inventory Report, choose Prepare > Inventory Report. The table below describes the columns in the
Inventory Report.

Column Description

Type The source file type.

Source Lines The number of lines of source code in verified files of the specified
type.

Quantity The number of source files of the specified type.

Unverified The number of source files of the specified type for which verification
was not attempted.

Note: Copybooks do not need to be verified. Copybooks are
parsed when the including source file is verified.

Verified The number of successfully verified source files of the specified type.

Erroneous The number of unsuccessfully verified source files of the specified
type.

Relaxed The number of source files of the specified type that were verified
despite errors, under the relaxed parsing option.

Missing The number of missing support files (copybooks, JCL procedures, and
the like).
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Viewing Key Object Relationships with Query
Repository
The Query Repository feature lets you home in on key relationships of an object: all the programs that call
another program, or all the programs that update a data store, for example. From the results, you can
launch further queries without having to return to the Repository Browser. You can create printable
relationship reports and export them to a variety of standard formats.

1. In the Repository pane, select the workspace, project, folder, files, or objects you want to view
relationships for and choose Query Repository > <Relationship> in the right-click menu. The Query
Repository results pane opens over the Editor/Viewer.

2. To launch a query from the results, select one or more objects in the right-hand column and choose
Query Repository > <Relationship> in the right-click menu.

Using the Activity Log
The Activity Log is a chronological record of your activities in the current session. Choose View > Activity
Log to show the Activity Log pane.

Viewing Errors
If the parser generated errors or warnings for a file, double-click the Activity Log entry for the file or select
the entry and choose Expand in the right-click menu to show a list of the errors and/or warnings. Double-
click a message to navigate to the offending source in the Editor. Choose Collapse in the right-click menu
to collapse the list.

Viewing History
To view Activity Log entries across sessions, choose History in the right-click menu. Click a date to view
the session log. To clear the session log, right-click in the log and choose Clear Log in the pop-up menu.
To clear a log entry, select the entry and choose Delete in the right-click menu.

Copying Records
To copy Activity Log records to the clipboard, select the records and choose Copy in the right-click menu.

Generating Reports
To generate a report from the Activity Log, right-click in the log and choose Report in the pop-up menu.

Clearing the Log
To clear the Activity Log, right-click in the log and choose Clear Log in the pop-up menu. To clear a log
entry, select the entry and choose Delete in the right-click menu.

Hiding a Column
To hide a column in the Activity Log, right-click in the log and deselect the column name in the Columns
choice in the pop-up menu. Select the column name to show the column again.

Creating a To Do List
A to do list is a record of tasks you need to perform before completing your project. You can create a to do
list for a workspace, project, folder, source file, or extracted object.
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1. In the Repository Browser, select a workspace, project, folder, source file, or generated object and
choose View > ToDo List. The ToDo List window opens.

2. If you selected:

• A workspace, project, or folder, choose Edit > Add to enter a task for the item and all the items it
contains. Otherwise, choose Add forItem to enter a task for the workspace, project, or folder only.

• A source file or generated object, choose Edit > Add to enter a task for the item.

3. The New Properties dialog opens. In the Subject field, enter the name of the task. In the Content field,
enter a description of the task. Click OK. The task is listed in the ToDo List window.

Viewing a To Do List
To view the to do list for an item, select the item in the Repository Browser and choose View > ToDo List.
Use the options in the ToDo List window Edit menu to mark a task as done, delete a task, or view its
properties. You can generate a report from a to do list by choosing File > Report.

Using Tool Windows
When you open a Enterprise Analyzer tool, the window for the tool appears above the product main
window. Simply move the tool window if you want to work in the main window again. A tool window’s state
is saved across sessions. Close a tool window by clicking the  button in the upper righthand corner.

Tool windows are modeless: in principle, you can open as many tool windows as you want. In practice,
Enterprise Analyzer will prompt you to close an “unprotected” tool window if the activity you want to
perform could result in a repository change. An unprotected tool window cannot be updated to reflect a
concurrent repository change.

In tool windows with lists, you can select all, select multiple, size columns, and sort by column.

Resizing Panes
Resize a pane in a tool window by using the mouse to grab its border with another pane, called a splitter,
and dragging the border to a new location. To control how panes are resized when you resize the window,
select the splitter and choose one of the following in the right-click menu:

• For a vertical splitter, Keep First preserves the size of the panes to the left of the splitter. For a
horizontal splitter, Keep First preserves the size of the panes above the splitter.

• For a vertical splitter, Keep Second preserves the size of the panes to the right of the splitter. For a
horizontal splitter, Keep Second preserves the size of the panes below the splitter.

• Keep Proportion preserves the length and width ratio of the panes on either side of the splitter.

Moving Panes
Move a pane in the window by grabbing its title bar to show the “virtual rectangle” for the pane. The virtual
rectangle is a dotted color frame that you can drag to the position in the window at which you want the
pane to appear. When you are satisfied with the new position, release the mouse button. The other panes
in the window are adjusted as necessary.

Note: You may have to drag the virtual rectangle beyond the edge of the tool window to achieve the
effect you want.

To swap the positions of the panes on either side of a splitter, select the splitter and choose Swap in the
right-click menu. To change the color of the splitter when it is selected (and of its virtual rectangle), select
the splitter and choose Color in the right-click menu. Use the standard Windows color control to specify the
color.
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Setting Options
Enterprise Analyzer options control the look and feel of the product tools and how they perform their tasks.
The Tools menu gives you access to three sets of options:

• Workspace Options control the appearance and behavior of EA tools for the current workspace.
• Project Options control the appearance and behavior of EA tools for the current project.
• User Preferences control the appearance and behavior of the Editor, Interactive Analysis, and Change

Analyzer across workspaces, and miscellaneous other tasks.

Each tool has an Options choice in the View menu that lets you set the options for that tool.

Note: Many options are preset based on your choices in the Enterprise Analyzer Configuration
Manager. For more information, see the installation guide for your product.

Tool options are described in detail in the relevant sections of the documentation set. This section shows
you how to manage option sets and how to set general EA and environment options

Managing Option Sets
An option set is a particular configuration of settings for one of the option groupings. In a given Project
Options set, for example, you might choose to show GO TO statements in the Interactive Analysis Callie
tool, while in the other Project Options sets you would not.

Option sets let you switch back and forth between configurations in the same session, without having to
change settings manually. You can also use them to ensure uniform results across your team by sharing
customized settings with team members.

Understanding the Options Manager Window
Use the Options Manager to define custom options sets. Choose Tools > Options Manager to open the
Options Manager window.

The figure below shows the Options Manager window at startup, with the tab for the Workspace Options
grouping selected. For each grouping, there is an initial read-only default option set, denoted by a 
symbol, that reflects your current EA configuration. The active option set is displayed in bold type in the
Options Manager tab for the grouping. You make an option set active by assigning it. Assignments persist
across Enterprise Analyzer sessions.

The user who defines a custom option set is referred to as its owner. Only the owner can share a custom
option set with other users, as indicated by a  symbol. A shared option set cannot be deleted or
unshared if it is being used. The Used By drop-down at the bottom of the owner’s Options Manager
window lists the names of option set users. The owner’s name appears in the Owner column in the Options
Manager window displayed to other users (but not in the owner’s Options Manager window).

The initial default option set is always shared with other users. An owner can designate another option set
as the default, provided the option set is shared. The new default option set will automatically be assigned
to every user who has not explicitly defined a custom option set. A default option set cannot be modified or
deleted.
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Creating an Option Set
If there is only a “(Default)” option set for the grouping, select it and click Edit. Otherwise, select any option
set and click Edit. Options Manager displays the available tabs for the selected options grouping.

Modify the options displayed on each tab as necessary and click Apply. When you are satisfied with your
choices, click OK. The new option set is displayed in the Options Manager window with the name of the
grouping.

Note: If a default option set already uses one of the grouping names, Options Manager prepends
“Copy of” to the name.

Renaming an Option Set
To rename an option set, select it and click Rename. The system displays the current name in an edit box.
Enter the new name in the edit box and click outside the box.

Editing an Option Set
To edit an option set, select it and click Edit, then follow the instructions for creating an option set. You
cannot edit a default option set.

Copying an Option Set
To copy an option set, select it and click Copy. Options Manager prepends “Copy of” to the name of the
copied option set.
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Deleting an Option Set
To delete an option set, select it and click Delete. You cannot delete a default option set, or a shared option
set that has been assigned by another user.

Sharing an Option Set
To share an option set, select it and click Sharing. The button is a toggle. Select it again to revoke sharing.
You cannot revoke sharing for an option set that has been assigned by another user.

Making an Option Set the Default
To make a custom option set the default, share it first, then select it and click Default.

Note: In the Project Options tab, a dialog opens that prompts you to select or create a new project.
Select the project and click OK.

The new default option set is automatically assigned to every user who has not explicitly defined a custom
option set. A default option set cannot be modified or deleted.

Assigning an Option Set
To make an option set active, select it and click Assign.

Note: In the Project Options tab, a dialog opens that prompts you to select or create a new project.
Select the project and click OK.

Importing and Exporting Option Sets
To import an option set, click Import. A Load dialog opens, where you can specify the option set you want
to import.

To export an option set, select it and click Export. A Save dialog opens, where you can specify the name
and location of the option set.

Setting General Options
Use the General tab of the Workspace Options window to specify the description of the workspace
displayed in the Object Information pane, the attributes displayed in the Repository pane Search tab, and
the browser fetch buffer size.

1. Choose Options > Workspace Options. The Workspace Options window opens. Click the General tab.

2. In the Workspace description field, enter a description of your workspace. This description is shown in
the Object Information pane.

3. In Repository Browser (Search), check the boxes for the object attributes that should be displayed in the
Search tab of the Repository pane. Click Select All to check all the attributes.

Note: Only attributes in the repository model for an object are displayed. That is, if you choose
Cyclomatic Complexity, and only JCL files appear in the Search tab results list, the attribute will not
be displayed in the list, because Cyclomatic Complexity is not an attribute of a JCL file.

4. In the Browser Fetch Buffer Size field, enter the size of the buffer Enterprise Analyzer uses to
populate the repository tree. When you expand a node in the Repository Browser, Enterprise Analyzer
populates the display from a buffer that contains the objects last fetched from the repository. For very
large repositories, you may want to lower the buffer size so that you can work with objects in the
Repository Browser while the product performs subsequent fetches.
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Setting Environment User Preferences
Use the Environment tab of the User Preferences window to specify whether you want to be prompted to
verify source files after registering them and the scope of relationships shown in the Object Properties
window.

1. Choose Tools > User Preferences. The User Preferences window opens. Click the Environment tab.

2. In After new files are registered, choose:

• Verify registered files if you want Enterprise Analyzer to verify files after they have been registered.
• Ask user about verification if you want to be prompted to verify files after they have been

registered. Available whether or not Verify registered files is selected.

3. In Show relationships in the object properties view window, choose whether you want to restrict the
relationships displayed in the Relationships tab of the Object Properties window:

• Restricted to the current project if you want to restrict the relationships of the object to those in the
current project.

• Workspace wide if you want to display all the relationships of the object in the current workspace.

4. For Java support, specify the path of the folder for the Java Runtime Environment (JRE) on your
machine in the Path to JRE Folder field. If you do not enter a path, the current version specified in the
Windows registry is used. You must use JRE version 1.5 or later.

Note: If your application was compiled with a previous version of the JRE, specify the path of the
Java SE runtime library (rt.jar) used to compile the application in the Enter classpath to JAR
Files and/or path to external Java file root directories field in Workspace Options > Verification
> Settings.

Setting Archivers User Preferences
The EA registration process extracts compressed source files using the command line syntax for archiver
versions most widely in use. Use the Archivers tab of the User Preferences window to specify the
command line syntax for newer archiver versions.

1. Choose Tools > User Preferences. The User Preferences window opens. Click the Archivers tab.

2. In the Command Line for Archiver drop-down, choose the archiver whose command line syntax you
want to specify.

3. In the Unpack All field, enter the command line syntax for the unpack all operation.

4. In the Extract File field, enter the command line syntax for the extract file operation.

Setting Export Options
Use the Export Options tab of the Project Options window to specify where Enterprise Analyzer stores
generated files. The default location is the \<Workspace Home>\Output folder.

1. Choose Options > Project Options. The Project Options window opens. Click the Export Options tab.

2. In the Target directory field, enter the folder you want Enterprise Analyzer to store generated files in.

3. Deselect the Move Files check box if you want to copy generated files to both the default and the
specified directories.

Adding a Selectable Item
Many options windows allow you to add an item to a list of available items. In the Extensions tab of the
Workspace Registration options, for example, you can add an extension to the list of recognized
extensions.
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Add an item by right-clicking in the selection pane and choosing Add in the pop-up menu. The EA displays
an empty text field next to a selected check box. Enter the name of the item in the text field and click
outside the field.

Note: If you are entering a file extension, make sure to enter the dot (.).

Edit an item by selecting it and choosing Edit in the right-click menu. Delete an extension by selecting it
and choosing Delete in the right-click menu.

Working with Reports and Diagrams
When you generate a diagram or report in the Enterprise Analyzer, you typically have the option of saving it
to a file or printing it. You can save to a wide variety of standard formats.

Note: Word must be installed to save reports to RTF and Word. Excel must be installed to save
reports to Excel, CSV, and TXT. Visio 2002 must be installed to save a diagram to Visio. Visio 2002 is
not required to save to Visio XML.

Click Page Setup in a report window to set up the page for a printed report. Click Print to print the report.
The Print dialog opens, where you can set options for the print job. Click OK.

Click Save in a report window to export a report. A Save As dialog opens, where you can specify the name,
location, and file type of the report.

Using the Guide for a Tool
Many Enterprise Analyzer tools have guides that you can use to get started quickly in the tool. The guides
are help-like systems with hyperlinks that you can use to access functions otherwise available only in
menus and other program controls.

To open the guide for a tool, choose View > Guide. Use the table of contents in the Page drop-down to
navigate quickly to a topic.

Purge Activity Log
Activity Log grows in size. To remove unwanted information, use Purge Activity Log to permanently delete
contents from the database.

1. Open Micro Focus Enterprise Analyzer Administration.

2. Click Tools > Purge Activity Log. The Purge Activity Log window opens.

3. Select a date from which to delete Activity Log data.

• Click Delete to proceed with log deletion. This will actually delete items from the Activity Log history
table in the database.

• Click Close to exit without any change.

40 | Enterprise Analyzer Basics


	Contents
	Introducing Enterprise Analyzer
	Enterprise Analyzer Products
	Enterprise Analyzer
	Enterprise View
	Business Rule Manager

	How Enterprise Analyzer Models Applications
	Understanding Application-Level Information
	Understanding Object-Level Information

	Workspaces and Projects
	Single-User versus Multiuser Environments
	Multiuser Environment Basics
	Deployment Scenario
	Mainframe and Network Server
	Enterprise Analyzer Server
	Database Server
	Enterprise Analyzer Client
	Enterprise View Web Server
	Enterprise View Web Client

	EA Privileges
	Understanding Master Users
	Understanding Workspace Security Policies
	Using the Optional File Server
	Public and Private Visibility
	Protecting Projects

	Dropping Indexes
	Computing Statistics


	Enterprise Analyzer Basics
	Creating a Workspace in Oracle or DB2
	Creating a Workspace in SQL Server
	Creating a Workspace Using the Workspace Build Wizard
	Designating Users for Security Policies
	Designating Users in a Simple Security Policy
	Designating Users in a Three-Group Security Policy

	Refreshing the Workspace Path
	Connecting to a Workspace in Oracle or DB/2
	Connecting to a Workspace in SQL Server
	Opening a Workspace
	Registering Source Files
	Host Environment Source Compatibility
	Resolving Include Files
	Resolving Program-to-Program Calls
	Resolving Control Cards
	Resolving JCL Procedures


	Queue Processor
	Check Workspace Queue
	Manage Queue
	Verifying Source Files
	How Verification Results Are Indicated

	Quick Inventory
	Using the Enterprise Analyzer Main Window
	Menus
	Toolbars
	Project Filtering
	Using the Repository Browser Pane
	Using the Search Assistant
	Using the Browser
	Selecting Objects
	Selecting All
	Selecting Multiple
	Using the Type-Ahead Select Functions

	Expanding Subtrees
	Filtering Subtrees
	Refreshing the Browser
	Viewing the Entire Workspace

	Using the Legacy Search Tab
	Creating a Search Filter
	Specifying a Search Criterion
	Using Wildcard Patterns in Searches

	Finding and Replacing Text in Source Files

	Using the Editor and Viewer
	Editing Source
	Finding and Replacing Source in a Selection
	Viewing a List of Errors
	Extracting and Expanding Copybooks (Cobol, MFS Only)
	Commenting Out Source
	Printing Source
	Setting Editor User Preferences
	Specifying the Color of Items

	Using the Object Information Pane
	Viewing Object Properties
	Viewing Inventory Reports
	Viewing Key Object Relationships with Query Repository
	Using the Activity Log
	Viewing Errors
	Viewing History
	Copying Records
	Generating Reports
	Clearing the Log
	Hiding a Column

	Creating a To Do List
	Viewing a To Do List

	Using Tool Windows
	Resizing Panes
	Moving Panes

	Setting Options
	Managing Option Sets
	Understanding the Options Manager Window
	Creating an Option Set
	Renaming an Option Set
	Editing an Option Set
	Copying an Option Set
	Deleting an Option Set
	Sharing an Option Set
	Making an Option Set the Default
	Assigning an Option Set
	Importing and Exporting Option Sets

	Setting General Options
	Setting Environment User Preferences
	Setting Archivers User Preferences
	Setting Export Options
	Adding a Selectable Item

	Working with Reports and Diagrams
	Using the Guide for a Tool
	Purge Activity Log


