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Upgrading to Enterprise Developer
This guide provides information on upgrading applications from earlier Micro Focus mainframe
development environments to Enterprise Developer for Visual Studio. It highlights the differences between
the old and new products, and offers solutions on how to keep your application working in the same way as
before. The guide also introduces the new concepts and features of the Integrated Development
Environment.

Note: This documentation uses the name Enterprise Developer to refer to Enterprise Developer for
Visual Studio. The full product name is used only when it is necessary to differentiate between
products.

Benefits of Upgrading

You get a number of important benefits by upgrading to Enterprise Developer from earlier Micro Focus
development systems or other COBOL systems.

Enterprise Developer uses a proven industry Integrated Development Environment that supports
thousands of clients for developing and deploying critical business applications. Enterprise Developer
enables unified, collaborative, and cost-effective development through rich, industry-standard tooling and at
the same time it helps minimize skills shortages, expands market reach and accelerates time-to-delivery to
meet today’s agile business requirements.

Licensing Changes
For a number of years Micro Focus used the Micro Focus License Management System for Net Express
and Server Express.

Micro Focus now uses two standard industry technologies for license management, Micro Focus AutoPass
and Sentinel RMS. New product releases use AutoPass and Sentinel RMS.

For more on the Micro Focus License Administration tool, see Managing Licenses in the Enterprise
Developer help.

Resolving conflicts between reserved keywords and data
item names

Micro Focus continues to enhance the COBOL language, for example, by expanding the list of reserved
COBOL words and adding new keywords to it as part of new levels of the COBOL language. Each Micro
Focus release corresponds to a particular level. You can use the MFLEVEL Compiler directive to enable
Micro Focus-specific reserved words in your code and change the behavior of certain features to be
compatible with a specific level of the language.

If you use Enterprise Developer to compile applications created with an older Micro Focus product, and
these applications use data names that are now reserved keywords in Enterprise Developer, you receive a
COBOL syntax error COBCH0666 ("Reserved word used as data name or unknown data description
qualifier"). To work around this issue and continue using some of the reserved words as data names in
your source code, you can either:

• use the REMOVE Compiler directive to remove individual keywords from the reserved words list
• set the MFLEVEL Compiler directive to a lower level which corresponds to the level your applications

are at (see the information about MFLEVEL of some Micro Focus products further down this section).
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This removes all reserved keywords which have been added for levels above that level from the
reserved words list.

You can set both directives from the command line, in your source code, or in the Additional Directives
field in the project's COBOL properties.

Setting directives from the command line

To use REMOVE from an Enterprise Developer command prompt, type the following:

cobol myprogram.cbl remove(title) ;

The command above removes TITLE as a keyword from the language so you can use it as an identifier in a
COBOL program.

To use the set of reserved words that was used for Net Express v5.1 WrapPack 5, use this command line:

cobol myprogram.cbl mflevel"15" ;

Setting directives in the source code

To set either one of the directives in your source code, type the following starting with $ in the indication
area of your COBOL program:

$set remove "ReservedWord"

Or:

$set mflevel"nn"

Setting directives in the IDE

To set either one of the directives in the project's properties:

1. In the IDE, click Project > <myproject> Properties > COBOL.
2. Type MFLEVEL"nn" or REMOVE "ReservedWord" in Additional Directives.
3. Click File > Save All.

Importing Existing COBOL Code into Enterprise
Developer

You can open, edit, compile and debug individual COBOL files in Enterprise Developer or you can open a
Net Express project file from within Enterprise Developer which imports the code and converts the project
to a Visual Studio COBOL project.

To load a file in the IDE

You can open your existing COBOL files in Enterprise Developer as standalone files and edit them without
a project. Either double-click such a file in Windows Explorer or, in the IDE click File > Open > File and
browse to select the file and open it.

There is basic support in the IDE for editing, compiling and debugging of files that are not part of a project.
To take advantage of all features that the IDE offers for compiling, editing and debugging, , it is
recommended to add the file to a project. The easiest way to add a standalone file to a project is to right-
click in the editor, click Create COBOL Project and then specify your preferences for the new projects.

To import Net Express projects

The Net Express project format is not the same as the project format in Enterprise Developer for Visual
Studio so it is not possible to edit Net Express projects in Enterprise Developer directly.

You can open a Net Express project in Visual Studio using the Net Express Project Import wizard. The
wizard converts the Net Express project into one or more Visual Studio projects. Click File > New > Import
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Net Express Project. The wizard analyzes your Net Express project, converts it to the appropriate project
type and sets Compiler directives as needed.

To import files into an existing project

In Visual Studio, you can add COBOL files to a project using the Add Existing COBOL Items in Solution
Explorer. Enterprise Developer imports the files into the project and, if specified in the Add Existing
COBOL Items wizard, scans the files to determine which files are programs or copybooks and sets the
appropriate build actions on them. It also sets the COBOL dialect and EXEC SQL directives as specified in
Tools > Options > Micro Focus Tools > Directives > COBOL.

To scan files and set Compiler directives

After importing your existing sources into a project in the new IDE, you need to set the required Compiler
directives.

In Visual Studio, to set Compiler directives on native COBOL files, use the file properties, or the Determine
Directives command from the context menu for the files in Solution Explorer. This triggers file scanning
and sets directives as specified in Tools > Options > Micro Focus Tools > Directives > COBOL.

Recompile all source code
Application executables that were compiled using earlier Micro Focus products must be recompiled from
the sources using Enterprise Developer.

If you do not recompile, you may receive an error. The exact error depends on the operating system you
are running.

You can recompile from the IDE or the command line.

Differences between Enterprise Developer and Earlier
Micro Focus Products

COBOL applications developed and built using previous Micro Focus IDEs, such as Net Express or Server
Express, can now be developed and built with Enterprise Developer. However there are some differences
in behavior and in terminology, which are described here.

Overview of the Differences
This COBOL system is integrated with Microsoft Visual Studio. The techniques you use to develop and
debug native COBOL applications are much the same as the techniques you use with Visual Studio to
develop nonCOBOL applications.

The development environment is Visual Studio, which provides all the functionality to manage projects and
debug applications. It includes:

• Templates for native COBOL projects such as mainframe applications, Windows applications and
console applications, and also the ability to add your own COBOL project type

• COBOL language colorization when editing and debugging
• Information provided when hovering over COBOL variables
• COBOL sensitive debugging including watch windows and breakpoints

COBOL applications previously built in the Micro Focus IDEs can be built with Visual Studio. The main
differences between the IDEs are as follows:
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Solutions,
projects and
source file folders

A solution is a container holding one or more projects that work together to create an
application. The solution and its projects are reflected in the file system as folders,
with solution folder containing the project folders, and the project folders containing
the main COBOL source files. The folder tree shown in Solution Explorer mirrors the
folder tree on disk.

If your solution has files that are shared across multiple projects, such as copybooks,
you can create a folder for the shared files in the solution. COBOL copybooks can be
held in folders outside the solution or project folders. You specify the location of the
copybooks in the project properties.

Copybook
extensions and
source file
extensions

The default extensions for source files are cbl, cob, and cpy. You can define other
copybook extensions, using the COPYEXT Compiler directive. In addition,
alternative file extensions need to be identified to the text editor, so that the files can
be found when searching.

To specify that a certain extension is a copybook, you need to add it to the list of
copybook extensions (in Tools > Options > Text Editor > Micro Focus COBOL >
Advanced > Copybook extensions), and then add it to your project (type
copyext(ext1,ext2) in Additional Directives on the COBOL page in your
project's properties).

To associate extensions and extensionless files with COBOL, go to Tools > Options
> Text Editor > File Extensions.

Source code
character values

We recommend that you replace any non-text characters representing hexadecimal
values with a hexadecimal character string definition.

In Net Express and Mainframe Express, COBOL source files are written using the
ANSI character set and can contain characters using the full range of hexadecimal
values from 00 to FF. When a source file is written to disk characters with values
below hex 20 are NULL protected, that is, a character pair is written to disk,
NULL(hex 00) followed by the original character.

Executables
created in Visual
Studio

In Visual Studio, each project creates a single executable, either an .exe or a .dll.You
can build native COBOL projects to .int or .gnt code, and package these as a Micro
Focus library file (.lbr). To choose the type of executable, its location and other build
settings, specify these in the project's properties.

Build
configurations

Previously, you specified how to build a project in Build Settings and Project Settings.
In Visual Studio, you specify this in a build configurations, such as the default Debug
or Release configuration, or in a configuration that you create.

Running or
debugging an
application

Where a solution has multiple projects, you need to ensure that the application's
executable can locate the dependent project executables (.dll) and their symbol (.idy)
files. To do this, you have several options:

• In the exe project, add references to the projects that create the dlls. Specify
where the symbol files are located using Debug > Options and Settings.

• Specify that your projects put their output executables in the same folder as the
solution executable (such as a bin folder). Copy the symbol files to this folder
when building the dll, by setting up a post build event in the project's properties.
See Project > Properties > COBOL > Advanced > Build Events.

Navigating the
source

In Net Express or Mainframe Express, when you have built a COBOL application,
context information is often used for program navigation. Visual Studio does not
provide the same capability but you can achieve the same result by using one or
more of the following options:
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• Edit > Find and Replace > Find in Files. The results of the find are displayed in
the Find Results tab. You can then double-click an item within the find results and
the source file is then loaded into a text editor view at the identified location.

• In the program editor, position the cursor on an object, right-click, and select Go
To Definition or press F12. This shows the definition of the object in a popup
window.

• In the program editor, position the cursor on an object, right-click, and select Find
All References or press Shift+F12. This lists all instances of the object in the
Find Symbol Results window.

Build results in
the Output view
and the Error List

When you build an application, you can view the build results in the Output view and
the Error List. You can double-click a build message to identify a source. You can
also double-click an item in the Error List to load the source file into a text editor at
the relevant location. Turn on these panes, using View > Output and View > Error
List.

Tips: Visual Studio IDE Equivalents to IDE Features in
Earlier Products
The following table shows Mainframe Express and Net Express IDE features and their corresponding
equivalents and locations in Visual Studio.

Functionality In Mainframe Express In Net Express In Enterprise Developer for
Visual Studio

Project Control

Project filename *.MVP *.APP *.cblproj

Add file to project To create a new file from
the supported types in
the project directory, click
File > New, specify the
type of file to create, and
click OK. Click Project >
Add Files to add existing
files to the project.

To create a new file from
the supported types in
the project directory, click
File > New, specify the
type of file to create, and
click OK. Click Project >
Add Files to Project to
add existing files to the
project.

Right-click the project in Solution
Explorer. Choose Add > New Item
to create a new file from the
supported types in the project
directory. To add an existing file,
choose Add > Existing Item and
browse to the location of the file to
select it. This adds a link in the
project to the file and by default
moves it to the project directory. To
add existing COBOL files, choose
Add Existing COBOL Items.

Copybook path Via Workgrouping Click Project >
Properties, then click
IDE and specify the
COBCPY environment
variable.

Choose Project >
projectProperties, click the
Dependency Paths tab, and set
Type to COBOL Copybook
Paths.

Build settings for the
project:

• COBOL
• CICS including BMS
• IMS (DBD, PSB,

MFS)
• Assembler
• Preprocessor
• Additional Directive

ALT+F7 or click Project >
Build Settings for
Project and select the
corresponding tabs

ALT+F7 or click Project >
Build Settings and
select the corresponding
tab

Click Project > project
Properties, go to the COBOL tab
and choose a configuration in the
Configuration field. To create a
new build configuration or to edit
one, click Build > Configuration
Manager.
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Functionality In Mainframe Express In Net Express In Enterprise Developer for
Visual Studio

Execution environment
settings:

• General
• Assembler
• COBOL
• JCL

Click Project > Project
Settings and then click
the Execution tab

The execution
environment is Micro
Focus Server

The execution environment is
Enterprise Server.

Debug settings:

• DateWarp
• Stored Procedures

• Click Debug >
DateWarp

• Click Project >
Debug Settings and
check Enable Stored
Procedures
Debugging

• Click Debug >
DateWarp.

Specify debug settings in the
project's properties - click Project
> project Properties and click the
Debug tab.

Editing

Suggest Word/Content
Assist

CTRL+G CTRL+G Press CTRL+Space or, if specified
in the IDE options, IntelliSense
suggestions are displayed
automatically as you type.

Locate F12 (or context menu
Locate)

F12 (or context menu
Locate)

F12

COBOL Find CTRL+Shift+F12 (or
context menu COBOL
Find)

CTRL+Shift+F12 (or
context menu COBOL
Find)

Shift+F12

Compress
Tool bar compress 
(or context menu
Compress)

Tool bar compress 
(or context menu
Compress)

Check the Breakpoints window
(click Debug > Windows >
Breakpoints) to see a list of all
breakpoints.

Bookmark CTRL+F2 CTRL+F2 CTRL+B, T

Compiling

Single file Compile CTRL+F7 (or click check

mark )

CTRL+F7 (or click check

mark )

In Solution Explorer, right-click
the file you want to compile and
click Compile.

Note: This applies to native
code only.

Build

F7 (or click build ) F7 (or click build )

F6

Build All ALT+B A ALT+B A Click Build > Build <project>

Debugging

Start Debugging Alt+D A Alt+D A Choose Debug > Start
Debugging or press F5

Stop Debugging Shift+F5 Shift+F5 Choose Debug > Stop
Debugging

Restart Debugging Ctrl+Shift+F5 Ctrl+Shift+F5 Choose Debug > Restart

Run F5 F5 F5

Step
F11 (or click step ) F11 (or click step )

F11
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Functionality In Mainframe Express In Net Express In Enterprise Developer for
Visual Studio

Step All Ctrl+F5 Ctrl+F5 No IDE equivalent. Keep pressing
F11 to continue stepping through
the code.

Run Thru Run > Run Thru Run > Run Thru Click Debug > Step Over.

Run Return Run > Run Return Run > Run Return Click Debug > Step Out.

Run to Cursor Shift+F10 (or context
menu)

Shift+F10 (or context
menu)

While debugging, choose Run To
Cursor from the editor context
menu or press Ctrl+F10.

Skip to Cursor CTRL+Shift+F10 CTRL+Shift+F10 No IDE equivalent. You can use
Set Next Statement from the
context menu.

Skip Statement ALT+D, I or click Debug
> Skip Statement .

Debug > Skip Statement F10 or Debug > Step Over

Skip Return ALT+D, K or click Debug
> Skip Return

Debug > Skip Return No IDE equivalent. You can use
Set Next Statement from the
context menu.

Examine data item' Shift+F9 Shift+F9 Shift+F9

Breakpoint set F9 F9 Double-click in the left margin of
editor next to the a line of code, or
right-click the line and choose
Breakpoint > Insert Breakpoint,
or press F9.

Conditional Breakpoint Click Debug >
Breakpoint > Set
Advanced.

Click Debug >
Breakpoint > Set
Advanced.

Right-click a breakpoint in the
editor or in the Breakpoints
window and click Condition.

Break on Data Change Via list view Via list view You can break on data change in
native COBOL projects, by right-
clicking and choosing Add
COBOL Watchpoint

Attach to Process No equivalent. Click Debug > Debug
settings and enable
Attach to running
process

Click Debug > Attach to Process,
or Ctrl+Alt+P

Just-In-Time Debugging Click Options > Debug
and set Error handling
when running programs
outside of the IDE to
Just-In-Time Debugging

Click Options > Debug
and set Error handling
when running programs
outside of the IDE to
Just-In-Time Debugging

Click Tools > Options >
Debugging > Just-In-Time
Debugging, and check Micro
Focus Native Debugger.

Note: This applies to native
code only

Upgrading from Net Express to Enterprise Developer
The following topics show you the process of moving existing Net Express applications into Enterprise
Developer for Visual Studio.
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An introduction to the process of upgrading your
COBOL applications
The following topics show you the process of moving existing Net Express applications into Enterprise
Developer for Visual Studio. This information assumes one of the following starting points:

• You currently use Net Express just for debugging, and edit files and compile projects by other means
(START 1)

• You currently use Net Express for all your development tasks (START 2)
• You currently use Net Express for .NET in Visual Studio 2008 (START 3)

The steps to move to Enterprise Developer are illustrated below:
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After following this process you will be able to use the Enterprise Developer for Visual Studio features to
improve development and modernize your applications.

Compile at the Command Line Using Existing Build
Scripts
Application executables that were compiled using earlier Micro Focus products must be recompiled from
the sources using Enterprise Developer. If you do not recompile, you may receive an error. The exact error
depends on the operating system you are running.

Most Net Express projects should compile cleanly using your existing build scripts and makefiles without
any changes to your code, as Enterprise Developer can use the cobol and cbllink commands to
create .int and .gnt files. By specifying the ILGEN compiler directive you can also use these commands
to create .NET-compatible .exe files, or use the JVMGEN directive to create JVM-compatible .exe files.

Fixing compilation issues

You might encounter some problems when compiling your Net Express applications in Enterprise
Developer.

Micro Focus continues to enhance the COBOL language, for example, by expanding the list of reserved
COBOL words and adding new keywords to it as part of new levels of the COBOL language (each Micro
Focus release corresponds to a particular level). Applications created with an older Micro Focus product
might use data names that are now reserved keywords in Enterprise Developer, which can result in a
COBOL syntax error COBCH0666 ("Reserved word used as data name or unknown data description
qualifier"). See Reserved Words Table for a comprehensive list of reserved words and level at which they
are supported.

Also, these Net Express compiler directives are no longer supported:

01SHUFFLE

64KPARA

64KSECT

AUXOPT

CHIP

DATALIT

EANIM

EDITOR

ENSUITE

EXPANDDATA

FIXING

FLAG-CHIP

MASM

MODEL

OPTSIZE

OPTSPEED

PARAS

PROTMODE

REGPARM

SEGCROSS

SEGSIZE

SIGNCOMPARE

SMALLDD

TABLESEGCROSS

TRICKLECHECK

WB2

WB3

WB

In addition, the pseudovariables of the following Net Express environment variables are obsolete and can't
be used:

BASENAME
FILENAME
PATH
TARGETDIR

You should consider using the following methods to solve these problems:

• Rewrite the source to avoid using these keywords in your code and directives files.
• Use the REMOVE Compiler directive to remove individual keywords from the reserved words list.
• Use the MF or MFLEVEL compiler directive to select an earlier version of Micro Focus COBOL that your

code is compatible with. For example, setting MFLEVEL"12" ensures compatibility with Mainframe
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Express 3.0 and 3.1; Net Express 4.0, 5.0, and 5.1; and Server Express 4.0, 5.0, and 5.1. Refer to 
Reserved Words Table for the value to use to ensure support for your existing reserved words.

Setting REMOVE and MFLEVEL directives from the command line

To use REMOVE from a Enterprise Developer command prompt, type the following:

cobol myprogram.cbl remove(title) ;

The command above removes TITLE as a keyword from the language so you can use it as an identifier in a
COBOL program.

To use the set of reserved words that was used for Net Express v5.1 WrapPack 5, use this command line:

cobol myprogram.cbl mflevel"15" ;

Setting REMOVE and MFLEVEL directives in the source code

To set either one of the directives in your source code, type the following starting with $ in the indication
area of your COBOL program:

$set remove "ReservedWord"

Or:

$set mflevel"nn"

Single-threaded run-time system

The single-threaded run-time system is not available in Enterprise Developer on Windows. Instead, both
single-threaded and multi-threaded applications run using the multi-threaded run-time system. This has no
effect on your existing applications.

Debugging Without a Project
Having compiled your existing code into the required format, it is possible to debug your code using the
debugger in the same way that you did with Net Express, even before you create a Enterprise Developer
project in the IDE and import the code into it (although with the lack of a project, elements of the program
have no context and the scope of debugging is limited).

You can cause debugging to be triggered at a specific point in your code by using the CBL_DEBUGBREAK
and CBL_DEBUG_START library routines. You can also use the debug_on_error runtime tunable to enable
the debugger to start when your a running program terminates with a run-time system error.

Run your program. When the routines or tunable trigger debugging, Visual Studio starts, displaying the
source file at the current line of code being executed. You can then make use of the debugging features of
Enterprise Developer which include:

• Step into the next statement at the current line of code and suspend execution.
• Step over the next statement at the currently executing line of code without entering it, and suspend

execution. The method will be executed normally.
• Return from a method or paragraph that has been stepped into, and suspend execution. The remainder

of the code inside the method is executed normally.
• Resume execution of the program from a suspended line of code.
• Display values of all variables contained on the current execution line.

Create a project and import source
Follow these steps to use your source files in a new project in Enterprise Developer. These instructions are
correct with Visual Studio 2017:

1. In Visual Studio, click File > New > Project.
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2. In the New Project dialog box, expand Installed > COBOL. Click Native.

This gives you a list of the following project types. The main difference between these types is the
nature of the artefacts they build, and after creating a project, you can easily change its type and output
accordingly.

• Windows Application - creates a project that builds a single executable .exe by default, and is
best used for graphical applications.

• Console Application - creates a project that builds a single executable .exe, and is best used for
character-based applications that use the console subsystem. You can configure it to build an .exe
file for each source program.

• Link Library - creates a project that builds a single .dll file.
• INT/GNT - creates a project that, by default, outputs one .int file for each of your source programs.

You can change the build order to .gnt by right-clicking the project in Solution Explorer and choose
Properties, select the COBOL tab, and choose Compile to .gnt.

Click Enterprise Server, and then click Native. This gives you a list of the following project types.

• Enterprise Server Application - creates a project that builds a single executable .dll by default,
and is best used for applications that incorporate COBOL program service interfaces.

• Mainframe Subsystem Application - creates a project that builds an executable .dll for each
COBOL source file by default, and is best used for CICS, IMS and JCL applications.

The other fields in this dialog box specify the folder structure in which your project will be placed:

• Name - the name of the project.
• Location - the folder in which the project will be created. If you specify a folder that doesn't exist,

Visual Studio will create it.
• Solution - a solution is a container in which you can group logically-related projects. Only one

solution can be open in Visual Studio at a time. At this stage you can either create a new solution
that will use the name specified, or add the project to the solution currently open in Visual Studio.

You can check Create directory for solution in order to give the solution a different name to the
project name. This is useful when you are likely to have several projects in the same solution.

3. Right-click your project in Solution Explorer and select Add > Existing Item.
4. Click Add and navigate to the folder containing the files you want to add to the project.
5. Choose the files you want to add and then click Add.

Those files are then added to the project in Solution Explorer. These files are copied, not moved, to the
project folder in the file system. If you click the down arrow on the Add button, you can choose Add as
Link, which adds a reference to the file in the project but neither moves or copies the original. Added

files have the icon ; linked files are indicated by the icon .

Note: If you right-click your project in Solution Explorer and choose Add Existing COBOL Items,
you choose a folder instead of individual files. All files in that folder with the extensions listed in the
Specify Source Files page of the import wizard are then added to the project in Solution Explorer.
You can only add files as links using this method.

Adding copybooks

You can add copybooks to your projects in the same way as COBOL files, by right-clicking your program,
choosing Add > Existing Item and browsing to a copybook. However, it is not compulsory to add
copybooks to your project. You can set the copybook dependency paths for your project from the Project
Properties > Dependency Paths page. Copybooks are not compiled at build time due to the file's Build
Action property being automatically set to None. (You can also set this property for COBOL source files
too, to keep a file in the project but not include a built version in any output.)

By default, Enterprise Developer identifies files as copybooks by their .cpy extension. You can specify
other file extensions as copybooks in the IDE preferences - click Tools > Options > Text Editor > Micro
Focus COBOL > Advanced > Copybook Extensions, and enter the additional values in the text box.
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Alternatively, you can add the copybook with unknown extension to your project and then reference the file
from within a COBOL program using the COPY statement. Enterprise Developer then recognizes that
extension as a copybook but only across the current solution.

Setting Compiler directives

Some Compiler directives are set on project creation, and differ between the Debug and the Release
configurations. To add directive to your project, right-click on the project in Solution Explorer and choose
Properties. On the COBOL tab, you can see directives that are set by the IDE in the Build Settings text
box. Enter others in the Additional Directives text box as a space-separated list.

If you use a separate text file to manage your directives, you can reference this instead by entering the
USE"directives file" directive. You should enter a path relative to the project directory.

Building the project

Having added all the files and made any necessary configuration changes, you can compile and link the
COBOL source and generate the output. Right-click the project in Solution Explorer and click Build.

If your source code contains tab stops compilation might fail, as while a COBOL tab is eight characters
long, the IDE's tab is four characters long, and lines of code might be starting in the sequence number and
indicator areas section (columns one to seven) of the program instead of from column eight.

You can fix this problem using the SOURCETABSTOP(n) compiler directive, where n is the number of space
characters by which to expand tab characters during compilation.

Using Enterprise Developer for Visual Studio

Understanding the structure of Enterprise Developer solutions

On creating a new project, the following files are created in the file system with the following structure:

...
   |_Location
     |_Solution
     | |_Name
     |   |_bin
     |   | |_x86
     |   | | |_Debug
     |   | | |_Release
     |   | |
     |   | |_x64
     |   |   |_Debug
     |   |   |_Release
     |   | 
     |   |_obj
     |   | |_x86
     |   | | |_Debug
     |   | | |_Release
     |   | |
     |   | |_x64
     |   |   |_Debug
     |   |   |_Release
     |   | 
     |   |_Properties
     |
     |_Solution.sln
     |_Name.cblproj
     |_Name.dep
     |_Program1.cbl
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If you select the Create Directory for Solution option when creating a solution, the structure is slightly
different.

In the Solution folder:

• Solution.sln - a description of the solution and what it contains.
• Name.cblproj - the project file that is opened in Visual Studio, which holds the description of the project

and all its related configuration and directives information.
• COBOL source files - when you create a project, a skeleton COBOL source file Program1.cbl is

added for most of the project templates.

In the Name folder:

• ..\bin - this is the default location of build artefacts. With this folder are the subfolders x86\Debug
that contains the executables or libraries, and .idy file for each of the project's COBOL source files.
The .idy files contain information required for debugging your application. When you use the Release
build configuration, build output goes to a subfolder x86\Release and no .idy files are created.

Debug and Release are standard build configurations that you launch from the Visual Studio task bar.
They use a different set of compiler directives as well as outputting different files. You can create your
own build configurations by clicking Build > Configuration Manager and choosing New from the
Active solution configurations drop-down list.

The x86 folder exists because the default output platform is 32-bit. If you change this to be 64-bit, you
will instead find your ouptut in an x64 folder.

• ..\obj - this also has x86\Debug subfolders, and contains an .obj file for each source file, used in
intermediate build stages. The obj folder also holds supporting information such as logs and file lists.

Note: The project file .cblproj is an msbuild file, much like a makefile but consisting of XML that
you can extend and modify to customise your builds. You can use this directly from command line, as
it uses the same build environment as the IDE, and behavior is identical. This means you can have a
single source of configuration information that makes your build process easier to maintain.

If you open a command prompt and change to the Location folder, you can execute the msbuild
command, without needing to specify the .cblproj file.

Finding your way around the IDE's features

• Solutions and projects

A solution is a container holding one or more projects that work together to create an application. The
solution has the extension .sln. A COBOL project has the extension .cblproj and a C# project has
the extension .csproj.

Solution Explorer shows the solution that is open and the projects therein.

You can use the project's properties pages to display a list of the files in your solution with file details
like output file type and location, COBOL dialect, and the number of errors generated by the file. To
display the properties, click Project > Name Properties.

• COBOL editor

The COBOL editor provides help such as column cut and paste, and background syntax checking,
which underlines errors with red wavy lines (also known as "squigglies"), which you can then hover over
to display details of the syntax error.

When you are editing, you can insert code snippets and navigate forward and backward quickly, and the
Find All References option enables you to search for references of any COBOL data items, section
and paragraph names in the solution.

You can customize the editor to display line numbers, adjust colorization, tabs, and margins, from the
Text Editor > Micro Focus COBOL > Advanced page in Tools > Options.

When developing code, the editor provides IntelliSense that helps you write syntactically correct code
and, in .NET COBOL code, helps when you need to type more complicated constructs, such as the
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code to override the members that a class inherits from a base class or the code for implementing an
interface.

The Light Bulbs feature for implementing an interface helps complete incomplete interface declarations.
A Light Bulbs appears at the beginning of the declaration: click it and choose the missing member(s) of
the inheriting interface.

When you encounter a COPY statement, or data item that is defined in a copybook, if you put your
cursor on that code and press F12 the appropriate copybook opens in the editor at the relevant line. You
can also do this by right-clicking the line and selecting Show copybook name.

• Setting Compiler directives

Many Compiler directives are set automatically by certain configuration options in the IDE, but you can
explicitly add directives to your project. Right-click on the project in Solution Explorer and choose
Properties. In the COBOL tab, you can see directives that are set by the IDE in the Build Settings text
box. Enter others in the Additional Directives text box as a space-separated list.

If you use a separate text file to manage your directives, you can reference this instead by entering the
USE"directives file" directive. You should enter a relative path.

• Build Tools, the Output Pane and the Error List

Build configurations define how to build a project or solution. There are default configurations of Debug
and Release for each project type, and you can create your own specific configurations.

The Output window shows the results of your build together with errors. You can double-click an error
and navigate directly to the appropriate line in the source code. You can do the same from the Error
List.

• Debugging

When you debug the application, you can step through the code, hover over a data item to see its value,
and watch data item values in a variety of ways. You can specify breakpoints on a range of conditions,
such as when an expression is true or changes, or when a line is hit a specified number of times.

In native code, you can set COBOL watchpoints on data items and watch for changes in the area of
memory associated with the watchpoints. When the memory changes or a condition associated with the
watchpoint has been met, the debugger breaks on the line that follows the line on which the data
change occurred.

Also in native code, you can use the Memory window to watch the contents of the memory that is
associated with data items or expressions.

Change the Defaults to Replicate Your Existing Project
Structure

Change the location of source files

To add an existing COBOL source file to your project, right-click the project in Solution Explorer and choose
Add > Existing item. You can then browse to the sources you want to add.

• If you click Add, Enterprise Developer makes a copy of the file, which it saves in the project folder. Any
edits you make to this file do not get applied to the original.

• If you click Add As Link, a reference to the original file, rather than a copy of it, is added to the project
in Solution Explorer. If you then open the file in Visual Studio, any edits are applied to the file in its
original location.

You can also drag files from Windows Explorer and drop them into your project in Solution Explorer. This
also makes a copy of the file and leaves the original in place.

To remove a file from your project, but not delete the file on disk (whether added as a link or not), right-click
the file in Solution Explorer and choose Exclude From Project.
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Change the location of built files

By default, built artefacts for the Debug configuration are created in the ..\Location\Solution\Name
\bin\x86\Debug folder.

You might want to change this, so that several developers can save built items in the same folder for
example. To do this, right-click the project in Solution Explorer and choose Properties. In the COBOL tab,
change the value of the Output path field to the preferred folder. (We recommend you always use relative
paths when entering this value.) When the project builds, the output files will be saved in this folder, and the
folder created if it doesn't already exist.

To change the output path for the Release configuration, select Release Configuration in the COBOL
property page and change the value of the output path.

Change the type of built files

The default output and target types when you create a project depend on the project type. You can change
these settings on the project Properties page. Use the following table to show the default output and target
types for each project and the possible changes once the project has been created :

Project type Output type Target type Possible output
types

Possible target type

Native Console application .exe single .dll, .exe single, multi

Windows application .exe single .dll, .exe single, multi

Link library .dll single .dll, .exe single, multi

Enterprise Server
application

.dll multi .dll, .exe single, multi

INT/GNT application .int multi .int,.gnt multi

Managed Console application .exe single .dll, .exe single

Windows application .exe single .dll, .exe single

Link library .dll single .dll, .exe single

Procedural multi-
output project

.dll multi .dll, .exe multi

Best Practice in Enterprise Developer Development

Break down large projects

Projects with a large number of source files and build artefacts can be hard to navigate and slow to build. If
you find this the case. we recommend that you review the contents of large projects and split them into
separate projects (and possible separate solutions) in which you group items that are logically related.
These projects can still be built in the same output folder if required.

For example:

• If you have different versions of a product for different customers, keep common source in one project
and a separate project for each customer. You could also have a master solution into which you add
projects from other solutions by right-clicking a solution and selecting Add > Existing Project.

• If you have core code that is rarely changed or recompiled, keep that in one project and have separate
projects for those areas that change regularly.
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Referencing common sources

To avoid repetition and reduce maintenance effort, you should consider keeping all your Compiler directive
settings in a directives file and reference this file in each project. Similarly you should keep copybooks in a
single project and add this project as a dependency to your COBOL projects.

If using .NET COBOL code and multiple projects, use project references rather than file references.

Create templates

After creating and configuring a project, you can save the settings as a template that can be reused and
distributed to other users. It can be added to the list of project types available when clicking File > New >
Project and then expanding Installed > COBOL.

To create a template of the open project, click File > Export Template and follow the steps explained in the
Export Template Wizard.

Use relative paths

Keep source relative to a base path and avoid full paths so that code is portable and easy to use with
source control systems. You should also avoid using network shares or drives.

Modernize Your Applications and Processes

Following industry standard development practices

Many source code control systems and Agile tools can be integrated into the Visual Studio IDE.

You should also consider using continuous integration, which involves the automatic building and testing of
an application after a change occurs to the source code. This method traps errors sooner in the
development life cycle and can greatly improve efficiency and reduce costs.

Interface modernization

Enterprise Developer enables you to use Visual Studio's built-in design tools to create more intuitive user
interfaces. By wrapping existing procedural COBOL in an wrapper class you can integrate your code into
Windows Forms (WinForms) and Windows Presentation Foundation (WPF) technology, and WebForms for
ASP.NET browser-based applications.

Multi-user applications

Enterprise Developer includes a Run Unit API to enable multiple users to simultaneously use an application
based on COBOL code that was designed originally for a single user.

Developing Web-based applications

You can use Enterprise Developer to migrate existing, core applications to a service oriented architecture
as Web services, and deploy them using Micro Focus COBOL Server and Enterprise Server, so that you
can develop COBOL-based software components to be invoked across the Web.

You can do this by creating an Enterprise Server application

Developing .NET applications

Both new and existing COBOL can be compiled as .NET code. This enables you to:

• Reuse existing COBOL business logic and data access across the .NET environment
• Access .NET Framework classes and features from COBOL applications including Windows Forms and

Web Forms
• Create and extend composite applications consisting of COBOL, C#, VB.NET, C++ and ASP.NET

Upgrading to Enterprise Developer | 19



• Reuse and extend Open ESQL applications

Both procedural and native OO COBOL are supported within the .NET framework. Native OO COBOL
classes can inherit classes written in other Microsoft .NET languages and vice versa.

The .NET COBOL syntax includes many extensions to the COBOL language to support .NET features; for
example, the TRY ... CATCH syntax to enable exception handling in COBOL.

There are also certain directives that help integrate your .NET COBOL with other languages in the .NET
environment. For example, you can now expose the Linkage section and entry points in your COBOL to
other managed languages by compiling with the ILSMARTLINKAGE directive.

Modernizing Dialog System applications

Enterprise Developer provides the following support for Dialog System applications:

• Dialog System run-time system and run-time components.
• Panels V2.
• Dialog System painter.
• GUI class library and OLE class library. These libraries are needed if you migrate an existing Dialog

System application that was extended using those libraries.

Projects for building the GUI and OLE class libraries from source are also supplied. Additionally, a
project file for the Base class library was added in Enterprise Developer 2.0.

• Visual Studio plug-in to associate screensets in Visual Studio with Dialog System. Double-clicking a
screenset in Solution Explorer in Enterprise Developer starts the Dialog System painter.

• Sample applications demonstrating a range of modernization techniques.
• Supporting documentation in this Help explaining the significant elements of the sample code.

You can modernize Dialog System applications within Enterprise Developer. You migrate an application to
Enterprise Developer and from there you can run the application without change, or modernize it over time.

Modernization techniques include:

• A Windows Forms form replacing a Dialog System dialog, where the form can contain .NET controls.
See the Customer + .NET WinForm sample CustomerWinForm.sln.

• A Windows Forms control wrapped as an ActiveX control and used on a Dialog System dialog. See the
Customer + .NET GridView User Control sample custgrid.sln.

• A WPF user control hosted by a Windows Forms user control, which is then exposed as ActiveX ready
for use by Dialog System. See the Customer + .NET WPF GridView User Control sample
CustGridWPF.sln

• A .NET code application interacting with Dialog System as native COBOL .dll. See the .NET COBOL
Customer sample ManagedCustomer.sln.

Data File Tools

Enterprise Developer comes with two versions of the Data File Tools utility: Data File Tools and Classic
Data File Tools.

The Classic Data File Tools is the utility that was previously available in Net Express. It includes the Data
File Converter, Data File Editor, IMS Database Editor, Segment Layout Editor and the Record Layout
Editor. This utility is only available on Windows.

Data File Tools is a new version of the utility and comprises the Data File Editor and the Structure File
Editor. This utility is available on both Windows and UNIX.
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Upgrading from Mainframe Express to Enterprise
Developer

Advantages to upgrading to Enterprise Developer
Micro Focus recognizes the investment that our mainframe clients have made in Mainframe Express - and
the great working partnerships we have established as these products have evolved. It is these close
working relationships that have formed the development and release of the new generation of mainframe
development applications.

In Enterprise Developer we have created a product that represents the natural evolution of Mainframe
Express: it's a seamless transition into the next generation of mainframe IDEs. It protects your existing
investment and future-proofs your operation going forwards. Lapsed Mainframe Express users will quickly
become converts - this is a feature-rich product with appeal right across the board.

Whatever your level of engagement with Mainframe Express, as an existing Micro Focus customer we
developed Enterprise Developer to maximize the investment you have made in our technology and protect
it moving forward.

Using the Enterprise Developer enhancements and modern IDEs have numerous advantages such as,
among others:

Improved
productivity

This is achieved through:

• Using the very latest IDE technology in a powerful integrated development
environment

• Replicating mainframe environment on Windows; through easier sharing of
development resources.

• Ready access to mainframe-based elements while removing unnecessary burden on
the host.

• Fast and easy customization with major source control systems, integration with
existing development lifecycle, and built-in extended IDE user interface for higher
developer acceptance and productivity gains.

• Providing the tools to allow you to edit, compile, debug, execute and test applications
on all supported Micro Focus UNIX and Linux environments including z/Linux, AIX,
HP-UX etc. One development tool can now meet your development requirements
today and in the future.

• Enabling cross-language application development which results in better quality and
increased competitiveness.

• Achieving faster time to market
• Using workstations to shorten the mainframe development and unit test cycles, and

deliver new products and features faster.

Improved
efficiency

Improve efficiency when performing day to day mainframe development activities on or
off mainframe, enabling access to standard IDEs of choice, smart editor, instantaneous
compilations, advanced test and debugging capabilities.

Address
mainframe
skills shortage

Using COBOL from within standard IDEs helps reduce the gap between the mainframe
COBOL and Java or C# developers by providing a unifying, collaborative and dynamic
development environment. Non-COBOL developers, can quickly and easily adapt to the
COBOL language, and get up to speed in no time.

For a full list of the advantages of using Enterprise Developer, see the Enterprise Developer data sheet and
white papers on the Micro Focus Web site.
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Approaches to upgrading your applications
There are different approaches to upgrading existing mainframe applications to Enterprise Developer in
order to modernize them.

Starting over and rewriting your application in Enterprise Developer is not recommended as this means
more costs, the need to do more testing and, potentially, incurs more risks.

You can keep the existing application intact and only create new front ends in Enterprise Developer that will
interact with the application.

Or, and this might be the best approach and lower risk one in most situations, is to upgrade your
applications and processes using incremental steps. In order to reduce the maintenance backlog and
ensure that the applications have the flexibility and agility that the business needs. Using this approach:

• You upgrade your application one small step at a time, testing the change and planning for the next one
on each phase.

• Start by only moving a small subset of the files in Enterprise Developer. This could mean only a small
number of the people on your teams are involved with making the changes.

• Maintain the application using both Enterprise Developer and Mainframe Express.

Considerations when upgrading to Enterprise
Developer
The following describes how you can move existing files and data from Mainframe Express to Enterprise
Developer:

Sources

You copy the COBOL programs and copybooks in the Enterprise Developer project directory or,
alternatively, from the Enterprise Developer you link to them in the original location where they are used by
Mainframe Express.

Data

• Data files - you can reuse the .dat files in Enterprise Developer. There is a Data File Tools utility for
editing data files.

• DB2
• IMS files - you can reuse the existing .dbd, .psb, and .mfs files after recompiling them in Enterprise

Developer.
• XDB

Metadata

• Data catalog - you need to create a new catalog in Enterprise Developer.
• CICS resource definition files (dfhdrdat.*) - you can copy the existing files and use them in

Enterprise Developer after performing a caspcupg to upgrade them.

Configuration

• Regions - now available as instances of Enterprise Server which you need to create and configure.

Accessing the Mainframe

Enterprise Developer uses its own version of Mainframe Access OS/390 and z/OS Server that provides
access to host resources for environments. A single installation of Mainframe Access can support all of
these products, providing connectivity to any number of DB2, IMS, and CICS systems located anywhere in
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an enterprise. It can also provide access to JES facilities, VSAM and non-VSAM data sets, and data
controlled by external library management products such as Panvalet, Librarian and Endevor. It includes
the Drag and Drop utility, the Remote Job Step Execution (RJSE) facility for execution of one or more steps
of a job on a remote z/OS host, Compare and Synchronization Monitor, and SourceConnect.

How to upgrade an application created with Mainframe
Express to Enterprise Developer
The following provides an outline of the incremental approach to upgrading a Mainframe Express
application to Enterprise Developer where you use both development products to maintain the application
while gradually moving the sources to the new IDE.

Tasks to perform in Mainframe Express

1. Review your Mainframe Express application using the following guidelines:

• Create an inventory of the sources it uses, the copybook dependencies, data files, SQL, JCL and
IMS files, third party utilities, integrated preprocessors.

• Check what workgroups are used and what the workflow processes are, what repositories are used
to store the sources, what the build scripts and command line parameters are, how the application
accesses the mainframe.

Note: Use the MFECL command-line utility of Mainframe Express to export the project details
to an .xml file which will include all project details at a glance - files in use, workgroups, output
and dependency folders, Compiler directives, project and file options. The command to use is:

mfecl /exportxml project-name.mvp [ xml-filename.xml]

• Review the XML file to see what information it includes:

The file provides details about the project and file settings, as well as of the workgroup levels. You
are going to use this information when you are configuring the new projects in Enterprise Developer.

• Analyze the strengths and weaknesses of your application in the Mainframe Express environment
and to what extent it meets the business requirements. The application might be a good candidate
for being modernized by upgrading it to Enterprise Developer.

2. Select a subset of source files. Initially, we recommend that you identify a small group of source files
from a larger Mainframe Express application to move over to Enterprise Developer. For example, select
the source files responsible for a single operation of an application. As you become familiar with this
process, you can more readily identify appropriate file groupings regardless of size.

3. Prepare your original application as follows:
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• Replace any hard-coded paths in your Mainframe Express project with concatenated ones – to do
this, in Mainframe Express, click Project > Convert Paths to Relative.

• Back up the sources.

Tasks to perform in Enterprise Developer

1. Create a Mainframe Subsystem Application solution/project for your initial subset of source files as
follows:

Note: After this initial step, you can add projects to this solution and create additional solutions and
projects as you continue to populate your Mainframe Express sources into Enterprise Developer.

a. In Visual Studio, click File > New > Project.
b. In the New Project dialog box, expand Installed > COBOL.
c. Expand Enterprise Server > Native.
d. Select Mainframe Subsystem Application.
e. Specify a name, Location, and Solution name; then click OK.

Tip: To emulate workgrouping behavior in Visual Studio, create several different projects in a
single solution that each represent an individual level in the workgroup. For each project, you then
specify the paths to the copybooks used in that respective workgroup level.

2. Configure the project in Enterprise Developer:

a. First, turn off the automatic directive determination so you can set compiler directives manually:

a. From the main menu, click Tools > Options.
b. In the left pane, expand Micro Focus Tools > Directives; then click COBOL.
c. In the right pane, uncheck Determine directives of files; then click OK.

b. Configure the project properties:

a. From the Solution Explorer, double-click the Properties entry for your project.
b. Using the provided tabs, specify the same project properties as are specified for the original

Mainframe Express project, listed in that project's xml-filename.xml file.
3. Import the source files by linking them to the new project. This enables you to keep the source files in

their original location, and does not create copies of the files in the Enterprise Developer project
directory.

a. In the Solution Explorer, right-click the project; then select Add > Existing Item from the context
menu.

b. Browse to the directory that stores the sources of your Mainframe Express application.
c. Select the files to add; then click Add As Link.

4. Set individual file properties:

a. In the Solution Explorer, right-click a file in your project; then select Properties from the context
menu.

b. Set the properties for the selected file as specified in the xml-filename.xml file.
c. Click OK.

5. Set Enterprise Server options:

a. From the Visual Studio menu, click Tools > Options, expand Micro Focus Tools, and then click
Enterprise Server.

b. Check the following options:

Automatically start the associated server
Automatically enable dynamic debugging

c. Click OK.
6. Verify Rumba+ Desktop options. For CICS and IMS applications, you use the Micro Focus Rumba+

Desktop TN3270 emulator to connect to and run your application. Rumba+ Desktop is provided with
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Enterprise Developer. To ensure that Visual Studio is configured to use the embedded Rumba+
Desktop emulator:

a. In Visual Studio, click Tools > Options.
b. Expand Micro Focus Tools, and click TN3270 Display.
c. Ensure that the Rumba (Embedded) display option is selected.
d. Ensure that Connect automatically is checked.
e. Click OK.

7. Build the solution:

a. In the Solution Explorer, right-click the solution; then select Build > Build Solution from the context
menu.

b. Check the Output window for the progress and the result of the build.

Tasks to perform in Enterprise Server

1. Using the Server Explorer in the IDE, create an enterprise server region on which to run compiled
applications. Select the template most appropriate for your CICS, IMS, or JCL application. Associate the
new enterprise server region with your project. See To create a new enterprise server for details.

2. Configure the enterprise server region to match the configuration provided in the xml-filename.xml
file. See Configuring the Server Instance Environment for details.

Run the application

Run the application from Enterprise Developer in debug mode. To do this:

JCL applications

1. Right-click the JCL file in your project; then select Submit JCL from the context menu.

This starts the enterprise server region and submits your JCL.
2. Debug the application to thoroughly test it.

CICS and IMS applications

1. On the Server Explorer, right-click your enterprise server region; then select Mainframe TN3270
Display from the context menu.

This starts the enterprise server region, starts the embedded Rumba Display, and connects to your
application running on theenterprise server region.

2. Debug the application to thoroughly test it.

Configure Mainframe Access (MFA)

If your application uses sources on the mainframe, configure MFA to access them. See the Mainframe
Access Installation Guide and the Working with Mainframe Files topic for details.

Distribution tasks

Once you have an application running smoothly in all areas, you can distribute it to your development and
QA teams, making it available for others to import into Enterprise Developer.

Distributing a solution/project

In Visual Studio, you can create a customized template for each solution or project. Each template includes
all project components, definitions of all properties and other configuration information. Then, each user
would be able to import the templates from a shared network location into their Visual Studio environments.
See the Visual Studio help for more information on how to create, configure and distribute custom project
templates.

Distributing an enterprise server region
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You can export an existing enterprise server region to make it available for import into another
VSInstallDir\IDE\Extensions\nnnnnnnn.nnn\Etc\ServerTemplates\ environment. To do
this, see To export an enterprise server instance and To import an enterprise server .

Mainframe Express Functionality That Works
Differently in Enterprise Developer for Visual Studio
Some features of Mainframe Express work differently in Enterprise Developer or are superseded by
features provided by the new IDE. The following list shows some of these differences:

Feature in Mainframe Express Feature in Enterprise Developer

Analysis Option Enterprise Developer offers integrated code analysis
functionality.

AppMaster Builder (AMB) and Structured COBOL (S-
COBOL) source code

AppMaster Builder is not available in Enterprise
Developer for Visual Studio; however, it is fully integrated
into the Enterprise Developer for Eclipse product.

Automatic Catalog Import Available through the MFA Drag and Drop interface as
well as the option to catalog from the command line. Data
connect functionality is being checked.

CICS resource definitions You can reuse any existing CICS resource definitions in
Enterprise Developer after executing the caspcupg
command.

Cut-down resource definitions (PCT, FCT, PPT) are not
supported.

Command line utility (MFECL) The equivalent to MFECL is not available in Enterprise
Developer; however, command-line options for much of
the tooling are available. In addition, you can use the
standard facilities of the IDE. For example, you can use
the MSBUILD utility to compile your sources, and
PowerShell to manage solutions and projects.

Database Access If your application running under Enterprise Server
accesses a database but contains no explicit connection
logic, you must define the database as an XA resource
(XAR) in your enterprise server instance.

Easytrieve

Mainframe Express provided integrated support for
Easytrieve through an add-on option which allowed
Easytrieve applications to be edited, compiled and tested
within the Mainframe Express IDE.

Easytrieve is now available. Contact Micro Focus
Customer Care for details.

Editor Autofix The editor in Enterprise Developer includes an
AutoCorrect feature. Other editor features that can help
increase your productivity in writing code are IntellISense
suggestions and code snippets.

Interactive AMS Not available.

MAS SDK

a collection of utilities to automatically compile
downloaded source and provide reports on the outcome.
These are part of Mainframe Express and Studio 6.0 (Net
Express) and were developed for Windows.

Not available.

MFA Server A newer version of MFA Server is available with
Enterprise Developer.
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Feature in Mainframe Express Feature in Enterprise Developer

MFENTMAP, the Entry Point Mapping facility Run-time system support for MFENTMAP is available and
any existing configuration files will work.

Outline View Displays the copybook dependencies of projects within
Solution Explorer.

PL/I PL/I application development is fully supported within
Enterprise Developer, and PL/I applications are
supported using CICS, IMS or JCL.

The PL/I language, Micro Focus Open PL/I, is fully
integrated.

Regions Enterprise Developer provides support for full, multi-
tasking enterprise server regions.

Source code control systems

Mainframe Express used the Microsoft Common Source
Code Control (SCC) Interface to enable you to use the
functions of a SCC-compliant source control manager
with your IDE.

Enterprise Developer comes with an industry-standard
integrated development environment that provides access
to any SCC tooling with the appropriate plugin. For
example:

• Enterprise Developer provides integration with Micro
Focus Enterprise Sync, a change management
system for mainframe development.

• Enterprise Developer provides integration with
Endevor, a full-function change control system for the
mainframe with signout controls and extensive user
customization.

• You can use the Visual Studio Team Foundation
Server (TFS) plug-in or install VisualSVN in order to
access sources from SVN.

Template projects In Enterprise Developer, you can create templates from
both projects and regions and distribute them to your
developers.

You can use Visual Studio functionality to create custom
project templates for COBOL applications. For more
information, see the Visual Studio help.

Export and import commands for regions are available
from Server Explorer inside the IDE.

Third-party preprocessors You can embed Third-party preprocessors in Enterprise
Developer in a manner similar to how this was done in
Mainframe Express. See Preprocessor Properties for
details.

Syntax checking is supported for ECMs and for COBSQL.

Time-Sharing Option (TSO)

Mainframe Express supported the use of TSO
commands, CLISTs and REXX execs, which could be run
in TSO interactive (or foreground) sessions or in TSO
batch (or background) sessions, using the IDAEFT01
(IKJEFF01) utility.

Enterprise Developer supports TSO batch (IKJEFTxx).

WinRunner

A screen capture utility that was supplied with some
versions of Mainframe Express.

You can now use the products from the Micro Focus Silk
portfolio.

Workgrouping Not available in Enterprise Developer for Visual Studio;
however workgroup emulation is available in the
Enterprise Developer for Eclipse product.
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Feature in Mainframe Express Feature in Enterprise Developer

XDB tooling Fully supported as a Start option, and can also be
accessed from within the IDE.

Tip: After upgrading, we suggest that you start with the Getting started with Micro Focus Enterprise
Developer tutorial to help you become familiar with the new IDE. Afterwards, move on to the tutorials
that provide details for using Enterprise Developer to develop mainframe applications, such as the
CICS, JCL, and IMS tutorials.

Upgrading from Studio Enterprise Edition (Windows)
Studio Enterprise Edition (Windows) used Visual Studio 2008. You upgrade projects created with it to
Enterprise Developer for Visual Studio.

Moving your existing applications to Enterprise Developer

Studio Enterprise Edition (Windows) uses Visual Studio 2008. You can open any solutions created with it in
Enterprise Developer and the newer version of Visual Studio handles the conversion:

1. Open your COBOL solution created with Visual Studio 2008 in Enterprise Developer.

This starts the Review Project and Solution Changes wizard that will upgrade the project to the most
recent format supported by the version of Visual Studio installed with Enterprise Developer.

2. Click OK to confirm.

Visual Studio performs a one-way upgrade of the projects in the solution and loads it inside the IDE. A
migration report is also displayed in your browser.

3. You might see an Update COBOL Project Properties dialog box offering to update any additional
directives with project properties. It is recommended to review and accept the suggested changes.

Micro Focus recommends you set Compiler directives using the project's properties and not using the
additional directives field to help avoid some unexpected build issues. For example, if additional
directives included the LIST() directive, the conversion removes it and enables the Generate listing file
project's property. Enterprise Developer includes more project property equivalents of Compiler
directives and includes the wizard you see to help you move any directives specified in additional
directives to the properties of the project.

4. Check the report for any errors and warnings.
5. Build your project to ensure it compiles cleanly.
6. You can continue to maintain and develop your application in Enterprise Developer. See the New

Features section in the Enterprise Developer help for information about the features it offers.

Best Practice in Enterprise Developer Development
Break down large projects

Projects with a large number of source files and build artefacts can be hard to navigate and slow to build. If
you find this the case. we recommend that you review the contents of large projects and split them into
separate projects (and possible separate solutions) in which you group items that are logically related.
These projects can still be built in the same output folder if required.

For example:

• If you have different versions of a product for different customers, keep common source in one project
and a separate project for each customer. You could also have a master solution into which you add
projects from other solutions by right-clicking a solution and selecting Add > Existing Project.

• If you have core code that is rarely changed or recompiled, keep that in one project and have separate
projects for those areas that change regularly.
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Referencing common sources

To avoid repetition and reduce maintenance effort, you should consider keeping all your Compiler directive
settings in a directives file and reference this file in each project. Similarly you should keep copybooks in a
single project and add this project as a dependency to your COBOL projects.

If using .NET COBOL code and multiple projects, use project references rather than file references.

Create templates

After creating and configuring a project, you can save the settings as a template that can be reused and
distributed to other users. It can be added to the list of project types available when clicking File > New >
Project and then expanding Installed > COBOL.

To create a template of the open project, click File > Export Template and follow the steps explained in the
Export Template Wizard.

Use relative paths

Keep source relative to a base path and avoid full paths so that code is portable and easy to use with
source control systems. You should also avoid using network shares or drives.

Modernize Your Applications and Processes

Following industry standard development practices

Many source code control systems and Agile tools can be integrated into the Visual Studio IDE.

You should also consider using continuous integration, which involves the automatic building and testing of
an application after a change occurs to the source code. This method traps errors sooner in the
development life cycle and can greatly improve efficiency and reduce costs.

Interface modernization

Enterprise Developer enables you to use Visual Studio's built-in design tools to create more intuitive user
interfaces. By wrapping existing procedural COBOL in an wrapper class you can integrate your code into
Windows Forms (WinForms) and Windows Presentation Foundation (WPF) technology, and WebForms for
ASP.NET browser-based applications.

Multi-user applications

Enterprise Developer includes a Run Unit API to enable multiple users to simultaneously use an application
based on COBOL code that was designed originally for a single user.

Developing Web-based applications

You can use Enterprise Developer to migrate existing, core applications to a service oriented architecture
as Web services, and deploy them using Micro Focus COBOL Server and Enterprise Server, so that you
can develop COBOL-based software components to be invoked across the Web.

You can do this by creating an Enterprise Server application

Developing .NET applications

Both new and existing COBOL can be compiled as .NET code. This enables you to:

• Reuse existing COBOL business logic and data access across the .NET environment
• Access .NET Framework classes and features from COBOL applications including Windows Forms and

Web Forms
• Create and extend composite applications consisting of COBOL, C#, VB.NET, C++ and ASP.NET
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• Reuse and extend Open ESQL applications

Both procedural and native OO COBOL are supported within the .NET framework. Native OO COBOL
classes can inherit classes written in other Microsoft .NET languages and vice versa.

The .NET COBOL syntax includes many extensions to the COBOL language to support .NET features; for
example, the TRY ... CATCH syntax to enable exception handling in COBOL.

There are also certain directives that help integrate your .NET COBOL with other languages in the .NET
environment. For example, you can now expose the Linkage section and entry points in your COBOL to
other managed languages by compiling with the ILSMARTLINKAGE directive.

Modernizing Dialog System applications

Enterprise Developer provides the following support for Dialog System applications:

• Dialog System run-time system and run-time components.
• Panels V2.
• Dialog System painter.
• GUI class library and OLE class library. These libraries are needed if you migrate an existing Dialog

System application that was extended using those libraries.

Projects for building the GUI and OLE class libraries from source are also supplied. Additionally, a
project file for the Base class library was added in Enterprise Developer 2.0.

• Visual Studio plug-in to associate screensets in Visual Studio with Dialog System. Double-clicking a
screenset in Solution Explorer in Enterprise Developer starts the Dialog System painter.

• Sample applications demonstrating a range of modernization techniques.
• Supporting documentation in this Help explaining the significant elements of the sample code.

You can modernize Dialog System applications within Enterprise Developer. You migrate an application to
Enterprise Developer and from there you can run the application without change, or modernize it over time.

Modernization techniques include:

• A Windows Forms form replacing a Dialog System dialog, where the form can contain .NET controls.
See the Customer + .NET WinForm sample CustomerWinForm.sln.

• A Windows Forms control wrapped as an ActiveX control and used on a Dialog System dialog. See the
Customer + .NET GridView User Control sample custgrid.sln.

• A WPF user control hosted by a Windows Forms user control, which is then exposed as ActiveX ready
for use by Dialog System. See the Customer + .NET WPF GridView User Control sample
CustGridWPF.sln

• A .NET code application interacting with Dialog System as native COBOL .dll. See the .NET COBOL
Customer sample ManagedCustomer.sln.

Data File Tools

Enterprise Developer comes with two versions of the Data File Tools utility: Data File Tools and Classic
Data File Tools.

The Classic Data File Tools is the utility that was previously available in Net Express. It includes the Data
File Converter, Data File Editor, IMS Database Editor, Segment Layout Editor and the Record Layout
Editor. This utility is only available on Windows.

Data File Tools is a new version of the utility and comprises the Data File Editor and the Structure File
Editor. This utility is available on both Windows and UNIX.
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Upgrading from Server Express and Studio Enterprise
Edition (UNIX)

You upgrade existing distributed applications created with Server Express to Visual COBOL for Eclipse.

Similarly, you upgrade mainframe applications created with Studio Enterprise Edition (UNIX) to Enterprise
Developer for Eclipse.

For more information on how to upgrade, check the Upgrade Guide in the product help for Visual COBOL
or Enterprise Developer for Eclipse available on the Micro Focus Customer Care site - https://
www.microfocus.com/documentation/enterprise-developer/.

Differences between Enterprise Developer and Net
Express and Mainframe Express

You can upgrade COBOL applications that were developed in Net Express to Visual COBOL or Studio
Enterprise Edition and Mainframe Express to Enterprise Developer without the need to change their code.

All references to Net Express and Server Express in this guide relate to the variants of those products that
provided Mainframe Subsystem Support as part of the Studio Enterprise Edition bundle.

This guide lists the differences between Net Express, Mainframe Express and Enterprise Developer in the
following areas:

Compiling and
building

Having created a project in Enterprise Developer, you can either use the IDE or the
command line to build.

Run-time systems There are some differences between the run-time systems supplied with Enterprise
Developer and those supplied with Net Express and Mainframe Express. This,
however, will not affect your existing applications and they will continue to run under
Enterprise Developer - you only need to recompile the applications from the source
code with Enterprise Developer.

Run-time system
technologies

Some technologies behave differently and require some upgrade work.

Restrictions and
unsupported
features

Some features of Net Express and Mainframe Express are not available in
Enterprise Developer. However, there are alternative techniques for many of these
features.

Editing and
debugging

Much of the Net Express and Mainframe Express functionality for editing and
debugging is available in Enterprise Developer, but sometimes with a different
name and with a slightly different behavior. In addition there are some new features
such as background parsing, which highlights errors as you type and code
completion techniques that provide easy access to language elements, enabling
you to select and insert them simply.

Visual Studio
integration

Enterprise Developer is integrated with Microsoft Visual Studio, which provides the
functionality to manage projects and debug applications. You can compile your
COBOL to native or .NET COBOL code.

Applications previously built in Net Express or Mainframe Express can be
developed and run within the Visual Studio IDE.
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Summary of Differences
The majority of the applications created with Net Express, Mainframe Express will continue to work in
Enterprise Developer without any changes. However, there are some differences between these
development systems you should consider when you upgrade to Enterprise Developer.

Compiling and Building Differences

There are several aspects of compiling and building applications that behave differently in Enterprise
Developer. You might need to change the project properties and update some of the Compiler directives
and settings that you previously used.

Output File Formats on
page 40

Each project compiles into a single file (.dll, .so or .exe), or to multiple files of
the same file type with one output file for each source file (.dll, .so, .exe, .int,
or .gnt). As well as an .lbr file, which contains a collection of .int and .gnt files
on Windows, you now can use a .dll as the container for application
components.

Compiler directives on
page 41

When you upgrade your source code to Enterprise Developer some Compiler
directives that were specifically designed for 16-bit systems now produce an
error on compilation because they are no longer relevant. You should remove
them from your code and directives files before you compile.

Linking on page 41 The static run-time system and the single-threaded run-time system on
Windows are no longer required and they are not shipped with Enterprise
Developer. Applications built with Enterprise Developer are now linked to the
shared or dynamic run-time systems.

Called Programs and
Dependencies on page
42

At run time, called programs are found in the same way as before. However,
there are some new ways to set COBPATH and copy files into a common
folder.

File Handler on page
42

The File Handler .obj files are not available in Enterprise Developer.
Enterprise Developer uses the File handler packaged in the mffh.dll file
instead.

OpenESQL Assistant on
page 43

The OpenESQL Assistant data source names (DSNs) in Enterprise Developer
must be configured as ODBC, ADO.NET, or XDB DSNs.

SQL Compiler Directive
Options on page 43

When you upgrade your to Enterprise Developer, some SQL applications
could require additional SQL Compiler directive options to avoid compiler
errors.

XML PARSE Statement
on page 43

In Net Express, the default setting for the XMLPARSE Compiler directive is
COMPAT, which causes the XML PARSE statement to return information and
events for IBM Enterprise COBOL Version 3. In Enterprise Developer, the
default is XMLPARSE(XMLSS), which returns information and events for IBM
Enterprise COBOL Version 4.

Run-Time System Differences

There are some differences between the run-time systems supplied with Enterprise Developer and those
supplied with Net Express and Mainframe Express. These, however, do not affect your existing applications
if you recompile them from the source code in Enterprise Developer.

OpenESQL on page 43 Enterprise Developer sets the BEHAVIOR SQL Compiler directive option to
MAINFRAME by default to provide optimal performance. To revert to the
default behavior exhibited in Net Express, set the BEHAVIOR directive to
UNOPTIMIZED.
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Single-Threaded Run-Time
System on page 43

The single-threaded run-time system is not available in Enterprise
Developer on Windows. Instead, both single-threaded and multi-threaded
applications run using the multi-threaded run-time system. This has no
effect on your existing applications.

Static-Linked Run-Time
System on page 43

The static-linked run-time system is not available in Enterprise Developer.
Instead, you now link native code to the shared or dynamic run-time
system. This has no effect on your existing applications.

Enterprise Developer Co-
existing with Earlier Micro
Focus Products on page
43

Some additional configuration is required to ensure Enterprise Developer
and Studio Enterprise Edition work properly when installed on the same
machine.

Restrictions and Unsupported Features

Some features in earlier Micro Focus products are not available in Enterprise Developer. However there
are alternative techniques for many of these features.

CBL2XML Utility on page
44

The CBL2XML utility is currently available as a command line tool only.

DBMS Preprocessors on
page 44

Earlier Micro Focus products supported DBMS preprocessor versions that
are not supported in Enterprise Developer. For a list of currently supported
DBMS preprocessors, see the Database Access Support with Native
COBOL and Database Access Support with .NET COBOL topics in your
Enterprise Developer documentation.

Form Designer on page
44

Form Designer is the Net Express tool for creating user interfaces for CGI-
based Internet and intranet applications. Form Designer and the HTML
page wizard are not available in Enterprise Developer.

Host Compatibility Option
(HCO) on page 44

Mainframe Express provided a user interface for the Host Compatibility
Option (HCO) feature. This user interface is not available in Enterprise
Developer; however the HCO Create Database, DDL Processor, DCLGEN,
Export Data, and Import Data tools are available via batch command line
invocation.

INTLEVEL Support on
page 44

The INTLEVEL directive is rejected by the Compiler in Enterprise
Developer.

NSAPI on page 44 There is no support for NSAPI in Enterprise Developer.

Online Help System on
page 44

Net Express provided the Online Help System for creating online help from
character-based applications, and displaying it on screen. It is not available
in Enterprise Developer and the Online Help System information file type
(.HNF) is not supported.

OpenESQL on page 44 In both Net Express and Studio Enterprise Edition, support is provided for
Oracle OCI in OpenESQL. Enterprise Developer does not support Oracle
OCI in OpenESQL.

SQL Option for DB2 on
page 44

In the Mainframe Express and Net Express IDEs, you could invoke SQL
Option for DB2 from the main menu within the IDE. For Enterprise
Developer, SQL Option for DB2 is not available from the main menu in the
IDE. Instead, all SQL Option for DB2 tools are available from Start > All
Programs > Micro Focus Enterprise Developer > Data Tools > SQL
Option for DB2.
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Run-Time Technology Differences

Some technologies behave differently in Enterprise Developer and this might affect how you upgrade
existing applications.

Dialog System on page
45

Support for Dialog System applications is available in Enterprise Developer
for Visual Studio.

File Handling on page 45 The way you integrate your own security modules into Fileshare has
changed. Also, the FILEMAXSIZE setting is different for Enterprise
Developer and for Net Express.

Test Coverage on page
45

Code coverage for native COBOL applications available from within the
IDE in Enterprise Developer integrates the Test Coverage functionality.

Editing and Debugging Differences

Much of the edit and debug functionality in Net Express and Mainframe Express is available in Enterprise
Developer, but some of it has a different name or slightly different behavior. In addition there are some new
features such as background parsing.

Interface Mapping
Toolkit on page 45

Workflow Capture for the Interface Mapping Toolkit is not supported in
Enterprise Developer. This means Interface Mapping Toolkit users can no
longer create service interfaces based on captured workflows in Enterprise
Developer. 

Mixed Language
Debugging on page
46

With Net Express you could debug mixed language applications. Enterprise
Developer does not support mixed language debugging of native code.

Program Breakpoints
on page 46

Program breakpoints are breakpoints that stop execution each time a specified
program or entry point within the program is called. They are supported in
Enterprise Developer, but by default their behavior is different from their
behavior in Net Express

Remote Debugging on
page 46

The Net Express animserv utility used for debugging programs remotely has
been replaced by cobdebugremote (or cobdebugremote64 when
debugging 64-bit processes) in Enterprise Developer.

Source Pool View on
page 46

The source pool view in Net Express showed all source files available in the
project directory, regardless of whether or not they are used in the current build
type. This view is not available in Enterprise Developer.

Backward Compatibility with Earlier Micro Focus
Products

Backward Compatibility with Studio Enterprise Edition

File Control
Description (FCD)

The FCD format for file handling operations in 32-bit applications defaults to
FCD3 in Enterprise Developer; in Studio Enterprise Edition, it defaulted to
FCD2.

Backward Compatibility with Net Express and Net Express with .NET 5.1

Treatment of
DBCS
literals

In Net Express, under the NCHAR directive, if an alphanumeric literal contained only
DBCS characters, then the literal was treated as class NCHAR. In Enterprise Developer,
this is not true, and you are required to prefix literals in the procedure division with N to
achieve equivalent behavior (for example: IF N"dbcs-chars" = data-item-1.),
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which is significant when performing comparisons, where NCHAR literals get padded with
double byte spaces. In Enterprise Developer, all literals that are surrounded by quotes
without any character specified (B", N", etc...) are always treated as alphanumeric.

Note: In the following scenario, the literal is still treated as a NCHAR literal:

01 data-item pic N value "dbcs-charaters".

Default working mode In versions of Visual COBOL R4 and earlier, the default working mode set by
the COBMODE environment variable was 32-bit. With the current release of
Visual COBOL and Enterprise Developer, it is 64-bit.

Format of the index files In Net Express, the default setting of the IDXFORMAT option was 4. With the
current release of Enterprise Developer, it is 8.

FILEMAXSIZE File
Handler configuration
option

In Net Express, the default setting for FILEMAXSIZE was 4. With the current
release of Enterprise Developer, it is 8.

Applications developed using Net Express 5.1 or Net Express with .NET 5.1 might require some changes
when you move it to Enterprise Developer. In particular, Enterprise Developer does not include support for
the following functionality that was available in Net Express 5.1:

• Debugging tools:

• Animator
• FSView
• Remote development

• Diagnostic tools:

• FaultFinder

The FaultFinder tool has been removed from the current version of Enterprise Developer. This
includes the removal of the following tunables:

• faultfind_level
• faultfind_outfile
• faultfind_recsize
• faultfind_config
• faultfind_cache_enable

You should either remove these tunables from your application or set the tunable
cobconfig_error_report=false in your configuration file.

• Runtime/Deployment support:

• Single-threaded run-time system
• Static-linked run-time system

• Programming features:

• Btrieve
• ISAPI
• NSAPI

Coexisting with Earlier Micro Focus Products

Important: Enterprise Developer cannot co-exist with Visual COBOL on the same machine.
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Run-time system
error due to
COBCONFIG

A run-time system error occurs if the COBCONFIG environment variable is set when
you run Enterprise Developer applications or when you use Enterprise Developer to
edit or create projects and the configuration file it refers to contains entries that are
not valid for Enterprise Developer.

For example, this might happen if you have Net Express or Studio Enterprise Edition
installed and COBCONFIG is set for it.

To work around this issue, ensure that Enterprise Developer is not running and then
modify the configuration file by doing one of the following:

• If the invalid tunable is not needed by another application, remove it from the run-
time configuration file.

• Add the following as the first line in the configuration file:

set cobconfig_error_report=false

• Unset COBCONFIG (or COBCONFIG_) or set it to another configuration file that
does not contain the invalid tunable for the particular session you are running in.

Licensing error
due to
environment
settings

The message "Micro Focus License Manager service is not running" can occur when
you invoke a Net Express, Mainframe Express or Studio Enterprise Edition utility from
Enterprise Developer. This happens when the tool is invoked with Enterprise
Developer environment settings while it requires the Net Express or Studio Enterprise
Edition ones.

This happens when you edit files such as .dat that have a file association with Net
Express or Studio Enterprise Edition. This can also happen when invoking a utility
within the Net Express or Studio Enterprise Edition products as an external tool from
Enterprise Developer.

You can workaround this problem in Enterprise Developer as follows:

1. Create a batch file that unsets COBREG_PARSED before the tool is invoked. The
batch file contains:

Set COBREG_PARSED=
Call [PathToUtility] %1

Where PathToUtility is the path to the Net Express or Studio Enterprise Edition
utility.

2. In the Visual Studio IDE, add the batch file instead of the utility itself as an external
tool.

This ensures that the proper environment is established when running that tool.

Performance
Monitoring
Issue

Having an Enterprise Developer product and Studio Enterprise Edition 6.0 or Server
Enterprise Edition 6.0 installed on the same machine, and trying to uninstall one of
them, breaks performance monitoring and it is not possible to see the Enterprise
Server performance counters. To resolve this problem, run the installer of the product
you wish to retain on your machine, and repair the installation.

Directives Scan

The default options for directives scan (click Tools > Options > Micro Focus Tools > Directives >
COBOL in the IDE) have been changed since the previous Micro Focus products based on Visual Studio.
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Backward Compatibility with Earlier Versions of Enterprise Developer

Updated
run-time
system

Enterprise Server now provides an execution environment capable of running applications
that were each built using different development products. A consequence of this is that If
your application has a main COBOL executable (.exe) that was built with a version of
Enterprise Developer prior to version 2.3, you should ensure that the executable is rebuilt
and packaged with the new run-time system. This does not affect mainframe subsystem
projects deployed to Enterprise Server. You can rebuild from the IDE or the command line.

Other COBOL subprograms built with previous versions of Enterprise Developer are not
required to be rebuilt.

Calling
program
search
order

In previous versions of Enterprise Developer (and earlier Micro Focus products) you could
use a run-time tunable to define a specific order in which the run-time system searches for
called sub-programs. Due to changes in the run-time system, there is only one viable
specific search order, and therefore the program_search_order tunable is no longer
available; remove the tunable from any configuration you have set. The default (and only)
order used is:

• If the sub-program is already loaded, or is statically linked, it is located and the search
ends.

• If COBPATH is set, the list of paths in the variable are searched, in order; if COBPATH is
not set, the current directory is searched.

• On Windows platforms, if you are calling dynamic link libraries (.dll files) without a
specific path, the COBPATH environment variable is searched.

• The path of the calling program is searched.

If the sub-program cannot be located using one of the above methods, a run-time error is
produced.

Casspool recovery Following the detection of an unrecoverable file status error on the casspool file, a
message is displayed on the console and an ACCEPT statement is issued. This
stops processing, allowing you to fix the underlying file problem, before continuing
the job.

ACUCOBOL-GT
and RM/COBOL
file handling under
Enterprise Server

Two file handling configuration options have been introduced that enable or disable
all types of file handling for ACUCOBOL-GT and RM/COBOL data files.

ACUFH has overall control, but is enabled by default, which means that there
should be no change in behavior when handling files when not running under
enterprise server. However, ESACUFH enables and disables file handling of these
types under enterprise server, and is disabled by default. To continue handling
ACUCOBOL-GT and RM/COBOL data files, ensure both options are enabled in
your file handling configuration file.

Using parentheses
in member
reference

In .NET COBOL syntax, you may only use parentheses when referencing methods.
You can no longer specify parentheses when referencing fields or properties, as this
will produce a syntax error.

For example:

set intLength to testString::Length()

must change to:

set intLength to testString::Length

Calling RM/COBOL
compatible library
routines

Previously, to call an RM/COBOL compatible library routine, you had to set the
DIALECT"RM" Compiler directive, which ensured the correct call-convention was
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used. To set this functionality now, you must explicitly use the correct call-
convention in the CALL statement.

DIALECT"ENTCOBOL" DIALECT"ENTCOBOL" now sets NSYSMBOL"NATIONAL"; previously, this set
NSYMBOL"DBCS".

DIALECT"RM" DIALECT"RM" now sets PERFORM-TYPE"RM". If you recompile an application that
uses DIALECT"RM", the behavior may change for nested PERFORM statements. If that
is the case, explicitly set PERFORM-TYPE"MF" after DIALECT"RM" to continue with the
previous behavior.

ILUSING If you set this Compiler directive using the $set command, the imported namespace is only
applicable to programs, classes and referenced copybooks in that file. If you set the directive
through the IDE or from the command line, the imported namespace is applicable to all
programs and classes in the project or specified on the command line.

FLAGCD This Compiler directive is no longer available in Enterprise Developer. Remove it from your
code, otherwise you receive a COBCH0053 Directive invalid or not allowed here
error.

CALLFH If your code specifies the ACUFH parameter, it may now produce adverse effects when used.
You should replace it with the methods described in Configuring Access to Vision Data Files or
Configuring Access to RM/COBOL Data Files. Both of these methods offer a fuller-functioning
solution to handling these types of data files.

Compatible
ACUCOBOL-GT file
handling
environment
variables

The following environment variables, introduced for ACUCOBOL-GT compatibility,
have been replaced with other environment variables or configuration options that
you add to your File Handler configuration file. No other ACUCOBOL-GT file
handling environment variables are supported.

Redundant variable Replaced with

FILE_CASE FILECASE configuration option

FILE_PREFIX COBDATA environment variable

FILE_SUFFIX FILESUFFIX configuration option

APPLY_FILE_PATH n/a

FILE_ALIAS_PREFIX dd_ mapping

Setting these environment variables will have no effect.

Open PL/I
Compiler

Important: If you are installing this release as an upgrade to Enterprise Developer
2.2 Update 1, after the upgrade you must rebuild any applications that are compiled
using the –zp1 option.

The behavior of the –zp1 option has been reverted to that of versions of Enterprise
Developer earlier than 2.2 Update 1, with an additional correction relating to Char Varying
data items.

The behavior has been restored to that in Enterprise Developer versions earlier than 2.2
where, when compiling with –zp1, all parameters are treated as unaligned. (In Enterprise
Developer 2.2 Update 1, the behavior when compiling with –zp1 was to not treat parameters
as if unaligned).

When using the –zp1 compiler option, all Character Varying data items are now treated as if
unaligned. In previous versions of Open PL/I, for Character Varying data items, the –zp1
unaligned requirement was applied only to structure members and parameters.
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To illustrate the change, consider the following example:

zptest: proc options(main); 
 
   dcl 1 st1, 
     2 c char, 
     2 x(4) char(7) var init ('a', 'xx', 'yyy', 'zzzz'); 
 
   dcl y(4) char(7) var init ('a', 'xx', 'yyy', 'zzzz'); 
 
   dcl sub entry ((4) char(7) var); 
 
   call sub (x); 
 
   call sub (y); 
 
end; 
 
sub: proc (z); 
 
   dcl z(4) char(7) var; 
 
   dcl i fixed bin(31); 
 
  do i = 1 to hbound(z); 
      z(i)  = 'x'; 
  end; 
 
end; 

Where:

• For x and z, each char (7) var item is 7 plus 2 bytes which equals 9 and then
multiplied by 4 equals 36.

• If y were aligned on half-word by default, each array element is half-word aligned and
each equals 10 bytes (9 + 1 pad byte), and the total size equals 40 bytes.

• At call sub (x), the calling argument and parameter are matched.
• At the call sub (y), the y element size (10 bytes) is mismatched against the

parameter z element size (9 bytes) due to –zp1. This is incorrect and causes
unexpected program behavior.

Due to this correction of treating all Char Varying data items as if unaligned when using –
zp1, the size of CHAR VARYING arrays now differs from previous versions of Open-PL/I.
For example:

   dcl X(4) char(7) var; 
 
   Put skip list (size(X))  /* size is 36 bytes vs. 40 bytes in 
previous versions of Open-PL1 */ 

Backward Compatibility with Previous Versions of
Visual Studio
The following sections describe issues that you might encounter when migrating a project created using a
Micro Focus product for a version of Visual Studio earlier than Visual Studio 2017.

Using different versions of Visual Studio to edit COBOL projects

Enterprise Developer supports the Compatibility (Project Round-Tripping) feature in Visual Studio that
enables you to use different versions of Visual Studio to edit the same COBOL application without the IDE
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upgrading the project format. For example, you can create a project in Visual Studio 2012, open and edit
the project in Visual Studio 2017, then open it again in Visual Studio 2012 without the IDE forcing an
upgrade.

Compiling and Building Differences
There are several aspects of compiling and building applications that behave differently in Enterprise
Developer. You might need to change the project properties and update some of the Compiler directives
and settings that you previously used.

Output File Formats

Supported file formats - .exe and .dll

Each project compiles into a single file (.dll, .so or .exe), or to multiple files of the same file type with one
output file for each source file (.dll, .so, .exe, .int, or .gnt). As well as an .lbr file, which contains a collection
of .int and .gnt files on Windows, you now can use a .dll as the container for application components.

Building from the command line

To build a Visual Studio solution from the command line:

1. Click Start > All Programs > Micro Focus Enterprise Developer > Tools > Enterprise Developer
Command Prompt to start the Enterprise Developer command prompt.

2. From the command prompt, navigate to the project directory.
3. Run the following command to build the solution or the project:

MSBuild SolutionName.sln

or:

MSBuild ProjectName.cblproj

To view the MSBuild command line options, execute:

MSBuild /?

Building to multiple output files

Each Visual Studio project compiles into a single file (.dll or .exe).

Instead of an .lbr file, which contained a collection of .int and .gnt files on Windows, you now use a .dll as
the container for application components.

Your application can consist of multiple projects, each one building a single output file. To do this, choose
from the following techniques:

• Create multiple projects in your solution each one building to either an .exe or a .dll:

1. Import the source files by adding one file or a collection of source files to a single project.
2. Configure each project to produce either an .exe or a .dll by setting the Output type in Properties >

myProject > Application.
3. Build the solution.

• Split your project into multiple projects in your solution each one building to either an .exe or a .dll:

1. Use the Create Project from Selection wizard and split the original project into multiple projects in
the same solution.

2. Move each file to a project of its own.
3. Configure the projects to produce either an .exe or a .dll, and build the solution.

• Ensure that each project can access any dependent projects, by putting the output files from each
project in the same folder.
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Compiler directives
When you upgrade your source code to Enterprise Developer some Compiler directives that were
specifically designed for 16-bit systems now produce an error on compilation because they are no longer
relevant.

The following Compiler directives are no longer relevant and we recommend that you remove them from
your code and directives files before you compile:

01SHUFFLE
64KPARA
64KSECT
ASM
ASMLIST
AUXOPT
CHIP
DATALIT
EANIM
EARLY-RELEASE
EDITOR
ENSUITE
EXPANDDATA
FAULTFIND
FIXING
FLAG-CHIP
FLAGGED
LOGICOPT
MASM
MF-OO
MODEL
NESTCALL
OMF
OPTSIZE
OPTSPEED
PARAS
PROTMODE
REGPARM
SEGCROSS
SEGSIZE
SIGNCOMPARE
SMALLDD
TABLESEGCROSS
TARGET
TRICKLECHECK
WEBSERVER

COBOL programs that interface with Assembler modules must be compiled with the AMODE directive. The
AMODE directive was set by default in MSS; it is not set by default in Enterprise Developer.

Linking
The static run-time system and the single-threaded run-time system on Windows are no longer required
and they are not shipped with Enterprise Developer. Applications built with Enterprise Developer are now
linked to the shared or dynamic run-time systems.
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Linking from the command line

You can link applications from the Enterprise Developer command prompt with the cbllink or cblnames
commands. For example, to produce an .exe file, use:

cbllink myprogram.cbl

To compile and link your code to produce a .dll file, use:

cbllink -d myprogram.cbl

With these commands, the single-threaded and static-linking options are automatically mapped onto the
multi-threaded and shared run-time systems respectively.

Linking from the IDE

To specify what to link:

1. Click Project > myProject Properties.
2. Click the COBOL Link tab on the left-hand side of the Properties window and specify your link

settings.

Called Programs and Dependencies
At run time, called programs are found in the same way as before. However, there are some new ways to
set COBPATH and copy files into a common folder.

To build the called programs

You can build your called programs into your application executable, in which case the called programs are
found without any further configuration.

When you build the called programs into a .dll file, you can set a property to store the built .dll files in the
same folder as the application executable, provided the application project is in the same solution. To do
this:

1. In the same solution as your main application project, create a project for the called programs.
2. In the project's properties, on the Application page, set the Output type to Link Library (which

represents a Dynamic Link Library (.dll)).
3. On the COBOL page, set the Output path to the same location as that for the built application .exe file.
4. If you want to debug the .dll file together with the application, on the Debug page, set the Working

directory to point to the folder containing the built .dll file.
5. Build the project.

To set the COBPATH environment variable

Add the COBPATH environment variable to the application configuration file as follows:

1. Right-click your main project and click Add > New Item > Application Configuration File.
2. Double-click Application.config in Solution Explorer.
3. In the Name field, specify COBPATH.
4. In the Value field, specify the full path of the folder. For example:

\users\myPath\

5. Click Set.

File Handler
The File Handler .obj files are not available in Enterprise Developer. Enterprise Developer uses the File
handler packaged in the mffh.dll file instead.

If the application you are upgrading from Net Express used the File Handler .obj files, when you link your
application in Enterprise Developer the linker will emit a warning. The application will continue to operate
as before provided that you supply the mffh.dll file with it.
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OpenESQL Assistant
The OpenESQL Assistant data source names (DSNs) in Enterprise Developer must be configured as
ODBC, ADO.NET, or XDB DSNs.

SQL Compiler Directive Options
If you get errors in Enterprise Developer when compiling an object application that was created in Net
Express or Studio Enterprise Edition, recompile specifying the GEN-CLASS-VAR SQL Compiler directive
option in addition to other appropriate options.

XML PARSE Statement
In Net Express, the default setting for the XMLPARSE Compiler directive is COMPAT, which causes the
XML PARSE statement to return information and events for IBM Enterprise COBOL Version 3. In
Enterprise Developer, the default is XMLPARSE(XMLSS), which returns information and events for IBM
Enterprise COBOL Version 4.

To emulate the Net Express behavior in Enterprise Developer, specify the XMLPARSE(COMPAT) Compiler
directive option.

For a summary of the differences in event information between XMLPARSE(XMLSS) and
XMLPARSE(COMPAT), see the Special Registers topic in your Enterprise Developer documentation.

Run-time System Differences
There are some differences between the run-time systems supplied with Enterprise Developer and those
supplied with Net Express and Mainframe Express. These, however, do not affect your existing applications
if you recompile them from the source code in Enterprise Developer.

The changes in the run-time system are described in the following sections.

OpenESQL
Enterprise Developer sets the BEHAVIOR SQL Compiler directive option to MAINFRAME by default to
provide optimal performance. To revert to the default behavior exhibited in Net Express, set the BEHAVIOR
directive to UNOPTIMIZED.

Single-Threaded Run-Time System
The single-threaded run-time system is not available in Enterprise Developer on Windows. Instead, both
single-threaded and multi-threaded applications run using the multi-threaded run-time system. This has no
effect on your existing applications.

Static-Linked Run-Time System
The static-linked run-time system is not available in Enterprise Developer. Instead, you now link native
code to the shared or dynamic run-time system. This has no effect on your existing applications.

See Linking Native COBOL Code in the product Help.

Enterprise Developer Co-existing with Earlier Micro Focus Products
If you have Enterprise Developer and Net Express or Studio Enterprise Edition installed on the same
machine, you sometimes receive a run-time system error if the COBCONFIG environment variable is set
when you run Enterprise Developer applications the configuration file it refers to contains entries that are
not valid for Enterprise Developer.

To work around this issue, ensure that Enterprise Developer is not running and then modify the
configuration file by doing one of the following:

• If the invalid tunable is not needed by another application, remove it from the run-time configuration file.
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• Add the following as the first line in the configuration file:

set cobconfig_error_report=false

• Unset COBCONFIG or set it to another configuration file that does not contain the invalid tunable for the
particular session you are running in.

Restrictions and Unsupported Features
Some features in earlier Micro Focus products are not available in Enterprise Developer. However there
are alternative techniques for many of these features.

CBL2XML Utility
The CBL2XML utility is currently available as a command line tool only.

DBMS Preprocessors
Earlier Micro Focus products supported DBMS preprocessor versions that are not supported in Enterprise
Developer. For a list of currently supported DBMS preprocessors, see the Database Access Support with
Native COBOL and Database Access Support with .NET COBOL topics in your Enterprise Developer
documentation.

Form Designer
Form Designer is the Net Express tool for creating user interfaces for CGI-based Internet and intranet
applications. Form Designer and the HTML page wizard are not available in Enterprise Developer.

Host Compatibility Option (HCO)
Mainframe Express provided a user interface for the Host Compatibility Option (HCO) feature. This user
interface is not available in Enterprise Developer; however the HCO Create Database, DDL Processor,
DCLGEN, Export Data, and Import Data tools are available via batch command line invocation.

INTLEVEL Support
The INTLEVEL directive is rejected by the Compiler in Enterprise Developer.

An INTLEVEL of 1, 2, or 3 is no longer supported and causes compilation errors. Other values are
reserved for internal use and should not be used.

NSAPI
There is no support for NSAPI in Enterprise Developer.

Online Help System
Net Express provided the Online Help System for creating online help from character-based applications,
and displaying it on screen. It is not available in Enterprise Developer and the Online Help System
information file type (.HNF) is not supported.

OpenESQL
In both Net Express and Studio Enterprise Edition, support is provided for Oracle OCI in OpenESQL.
Enterprise Developer does not support Oracle OCI in OpenESQL.

SQL Option for DB2
In the Mainframe Express and Net Express IDEs, you could invoke SQL Option for DB2 from the main
menu within the IDE. For Enterprise Developer, SQL Option for DB2 is not available from the main menu in
the IDE. Instead, all SQL Option for DB2 tools are available from Start > All Programs > Micro Focus
Enterprise Developer > Data Tools > SQL Option for DB2.
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Run-Time Technology Differences
Some technologies behave differently in Enterprise Developer and this might affect how you upgrade
existing applications.

Dialog System
Support for Dialog System applications is available in Enterprise Developer for Visual Studio.

Enterprise Developer includes the Dialog System GUI component that enables you to run and modernize
Dialog System applications. You can upgrade an application to Enterprise Developer and from there, you
can run the application without change, or modernize it over time.

The application runs under Enterprise Server and the Dialog System run-time system.

File Handling
The way you integrate your own security modules into Fileshare has changed. Also, the FILEMAXSIZE
setting is different for Enterprise Developer and for Net Express.

Using security modules

The way you integrate your own security modules (fhrdrlngpwd, fhrdrpwd, fsseclog and fssecopn)
into Fileshare has changed.

In Enterprise Developer, you no longer relink Fileshare but you need to supply your own separate files,
which are .dll files. For more information, see Writing Your Own FHRdrLngPwd Module, File Access
Validation Module and Logon Validation Module in the File Handling section of your product Help.

To use fsseclog and fssecopn, you need to link one or both of them into a cobfssecurity.dll or a
shared object and place on the search path. Fileshare will issue a message indicating that it has loaded
user security modules.

Sharing data files between applications built in Enterprise Developer and others built using Net
Express

If you have applications that access the same data files, all those applications should be built with the
same FILEMAXSIZE setting otherwise file corruption may occur. However, you need to be aware that
applications built with Enterprise Developer use a default setting of FILEMAXSIZE=8, while those built in
Net Express use FILEMAXSIZE=4.

Test Coverage
Code coverage for native COBOL applications available from within the IDE in Enterprise Developer
integrates the Test Coverage functionality.

Test Coverage is also available from the command line.

Editing and Debugging Differences
Much of the edit and debug functionality in Net Express and Mainframe Express is available in Enterprise
Developer, but some of it has a different name or slightly different behavior. In addition there are some new
features such as background parsing.

Interface Mapping Toolkit
Workflow Capture for the Interface Mapping Toolkit is not supported in Enterprise Developer. This means
Interface Mapping Toolkit users can no longer create service interfaces based on captured workflows in
Enterprise Developer.
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Mixed Language Debugging
With Net Express you could debug mixed language applications. Enterprise Developer does not support
mixed language debugging of native code.

You can debug .NET COBOL and other managed languages together seamlessly.

To debug applications that contain programs in different languages, you need to debug the native COBOL
and the non-COBOL code separately.

Program Breakpoints
Program breakpoints are breakpoints that stop execution each time a specified program or entry point
within the program is called. They are supported in Enterprise Developer, but by default their behavior is
different from their behavior in Net Express

In Net Express, a program breakpoint caused execution to stop only when the Procedure Division entry
point is called, while in Enterprise Developer, a program breakpoint causes execution to stop on any entry
point to the program and on return to the program from a call.

To configure Enterprise Developer so that program breakpoints function as they did in Net Express, click
Tools > Options to display the Options dialog box, select Debugging > COBOL from the left pane, then
check Program breakpoint on main entry point only.

Remote Debugging
The Net Express animserv utility used for debugging programs remotely has been replaced by
cobdebugremote (or cobdebugremote64 when debugging 64-bit processes) in Enterprise Developer.

To debug locally-developed programs on a remote machine you must start cobdebugremote (or
cobdebugremote64 when debugging 64-bit processes) before communication can be established. See
the Enterprise Developer help for more information on cobdebugremote.

For more information, see the section on Remote Debugging in your Enterprise Developer for Visual Studio
product help.

Source Pool View
The source pool view in Net Express showed all source files available in the project directory, regardless of
whether or not they are used in the current build type. This view is not available in Enterprise Developer.

However, similar functionality is available in Enterprise Developer, by using the Project Details window,
where you can view all files in a project or solution, sort the files by various file details, access the file
properties and reset directives on them.

Tips: Visual Studio IDE Equivalents to IDE Features in
Earlier Products
The following table shows Mainframe Express and Net Express IDE features and their corresponding
equivalents and locations in Visual Studio.

Functionality In Mainframe Express In Net Express In Enterprise Developer for
Visual Studio

Project Control

Project filename *.MVP *.APP *.cblproj

Add file to project To create a new file from
the supported types in
the project directory, click
File > New, specify the

To create a new file from
the supported types in
the project directory, click
File > New, specify the

Right-click the project in Solution
Explorer. Choose Add > New Item
to create a new file from the
supported types in the project
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Functionality In Mainframe Express In Net Express In Enterprise Developer for
Visual Studio

type of file to create, and
click OK. Click Project >
Add Files to add existing
files to the project.

type of file to create, and
click OK. Click Project >
Add Files to Project to
add existing files to the
project.

directory. To add an existing file,
choose Add > Existing Item and
browse to the location of the file to
select it. This adds a link in the
project to the file and by default
moves it to the project directory. To
add existing COBOL files, choose
Add Existing COBOL Items.

Copybook path Via Workgrouping Click Project >
Properties, then click
IDE and specify the
COBCPY environment
variable.

Choose Project >
projectProperties, click the
Dependency Paths tab, and set
Type to COBOL Copybook
Paths.

Build settings for the
project:

• COBOL
• CICS including BMS
• IMS (DBD, PSB,

MFS)
• Assembler
• Preprocessor
• Additional Directive

ALT+F7 or click Project >
Build Settings for
Project and select the
corresponding tabs

ALT+F7 or click Project >
Build Settings and
select the corresponding
tab

Click Project > project
Properties, go to the COBOL tab
and choose a configuration in the
Configuration field. To create a
new build configuration or to edit
one, click Build > Configuration
Manager.

Execution environment
settings:

• General
• Assembler
• COBOL
• JCL

Click Project > Project
Settings and then click
the Execution tab

The execution
environment is Micro
Focus Server

The execution environment is
Enterprise Server.

Debug settings:

• DateWarp
• Stored Procedures

• Click Debug >
DateWarp

• Click Project >
Debug Settings and
check Enable Stored
Procedures
Debugging

• Click Debug >
DateWarp.

Specify debug settings in the
project's properties - click Project
> project Properties and click the
Debug tab.

Editing

Suggest Word/Content
Assist

CTRL+G CTRL+G Press CTRL+Space or, if specified
in the IDE options, IntelliSense
suggestions are displayed
automatically as you type.

Locate F12 (or context menu
Locate)

F12 (or context menu
Locate)

F12

COBOL Find CTRL+Shift+F12 (or
context menu COBOL
Find)

CTRL+Shift+F12 (or
context menu COBOL
Find)

Shift+F12

Compress
Tool bar compress 
(or context menu
Compress)

Tool bar compress 
(or context menu
Compress)

Check the Breakpoints window
(click Debug > Windows >
Breakpoints) to see a list of all
breakpoints.
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Functionality In Mainframe Express In Net Express In Enterprise Developer for
Visual Studio

Bookmark CTRL+F2 CTRL+F2 CTRL+B, T

Compiling

Single file Compile CTRL+F7 (or click check

mark )

CTRL+F7 (or click check

mark )

In Solution Explorer, right-click
the file you want to compile and
click Compile.

Note: This applies to native
code only.

Build

F7 (or click build ) F7 (or click build )

F6

Build All ALT+B A ALT+B A Click Build > Build <project>

Debugging

Start Debugging Alt+D A Alt+D A Choose Debug > Start
Debugging or press F5

Stop Debugging Shift+F5 Shift+F5 Choose Debug > Stop
Debugging

Restart Debugging Ctrl+Shift+F5 Ctrl+Shift+F5 Choose Debug > Restart

Run F5 F5 F5

Step
F11 (or click step ) F11 (or click step )

F11

Step All Ctrl+F5 Ctrl+F5 No IDE equivalent. Keep pressing
F11 to continue stepping through
the code.

Run Thru Run > Run Thru Run > Run Thru Click Debug > Step Over.

Run Return Run > Run Return Run > Run Return Click Debug > Step Out.

Run to Cursor Shift+F10 (or context
menu)

Shift+F10 (or context
menu)

While debugging, choose Run To
Cursor from the editor context
menu or press Ctrl+F10.

Skip to Cursor CTRL+Shift+F10 CTRL+Shift+F10 No IDE equivalent. You can use
Set Next Statement from the
context menu.

Skip Statement ALT+D, I or click Debug
> Skip Statement .

Debug > Skip Statement F10 or Debug > Step Over

Skip Return ALT+D, K or click Debug
> Skip Return

Debug > Skip Return No IDE equivalent. You can use
Set Next Statement from the
context menu.

Examine data item' Shift+F9 Shift+F9 Shift+F9

Breakpoint set F9 F9 Double-click in the left margin of
editor next to the a line of code, or
right-click the line and choose
Breakpoint > Insert Breakpoint,
or press F9.

Conditional Breakpoint Click Debug >
Breakpoint > Set
Advanced.

Click Debug >
Breakpoint > Set
Advanced.

Right-click a breakpoint in the
editor or in the Breakpoints
window and click Condition.

Break on Data Change Via list view Via list view You can break on data change in
native COBOL projects, by right-
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Functionality In Mainframe Express In Net Express In Enterprise Developer for
Visual Studio

clicking and choosing Add
COBOL Watchpoint

Attach to Process No equivalent. Click Debug > Debug
settings and enable
Attach to running
process

Click Debug > Attach to Process,
or Ctrl+Alt+P

Just-In-Time Debugging Click Options > Debug
and set Error handling
when running programs
outside of the IDE to
Just-In-Time Debugging

Click Options > Debug
and set Error handling
when running programs
outside of the IDE to
Just-In-Time Debugging

Click Tools > Options >
Debugging > Just-In-Time
Debugging, and check Micro
Focus Native Debugger.

Note: This applies to native
code only

Upgrading from ACUCOBOL-GT
There are conceptual and behavioral differences between Enterprise Developer and ACUCOBOL-GT, part
of the Micro Focus extend® product family, and these differences can affect the way you upgrade existing
applications to Enterprise Developer.

Refer to the Compatibility with ACUCOBOL-GT section for guidance and best practice on moving your
applications to Enterprise Developer. It covers:

• Supported ACUCOBOL-GT features, including detailed information on support for compiler options and
standard library routines.

• Syntactical differences between the two COBOL dialects, including workarounds or equivalent syntax
where applicable.

• Detailed support of compatible ACUCOBOL Windowing syntax.
• Details on how to configure your applications to continue using your Vision data files.
• Details on converting your GUI projects using an import wizard.

Compatibility with ACUCOBOL-GT
The following sections describe supported ACUCOBOL-GT features and how to enable them.

Converting ACUCOBOL-GT Applications
With Enterprise Developer you can build, compile and debug ACUCOBOL-GT applications. Certain
Compiler directives are provided to enable compatibility with some of ACUCOBOL-GT's language
extensions, data files, and other behaviors.

After you have converted your application, you must run, license, and distribute your programs in the same
manner as other Micro Focus programs. There is currently no clone of the ACUCOBOL-GT runtime known
as wrun32.

This section describes the ACUCOBOL-GT compatibility features, such as how they are enabled within
Enterprise Developer, and also the potential problems you may encounter with some aspects of the
converted source code.

Enabling ACUCOBOL-GT Compatibility
Compile your ACUCOBOL-GT source code with certain Compiler directives that enable support for
ACUCOBOL-GT syntax, data types, and other behaviors. A number of traditional ACUCOBOL-GT compiler
options are also available.
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Compiler Directives for ACUCOBOL-GT Compatibility
There are a number of Compiler directives that provide compatibility with ACUCOBOL-GT. Use the
DIALECT"ACU" directive to set all of these directives at once.

By setting DIALECT"ACU" you enable certain reserved words, data type storage behavior, and more. See
ACU DIALECT setting for full details of the directives that are set.

You can set this directive in your source code directly, through the COBOL project options interface in your
IDE or from the command line.

Compiler Option Support

You can use many of the ACUCOBOL-GT compiler options when compiling, by setting then with the
ACUOPT Compiler directive. A list of the supported options is listed in this section.

Alternatively, you can compile using a clone of the ACUCOBOL-GT compiler known as ccbl.exe . This
executable is located in the bin directory found here: %ProgramFiles(x86)%\Micro Focus
\Enterprise Developer. ccbl.exe compiles to .int code unless you specify one of the ccbl's native
code options, in which case it produces .gnt code.

Setting Compiler Options
You can set the ACUCOBOL-GT compiler options by using the ACUOPT Compiler directive, or from a
command line utility.

This COBOL system supports many of the compiler options available with the ACUCOBOL-GT (Acu)
compiler. To specify these options use the ACUOPT Compiler directive along with the traditional ACU
compiler option name.

For example:

ACUOPT(-option)

Or:

ACUOPT(--option)

ACUOPT automatically sets the ACU directive, which turns on overall ACUCOBOL-GT compatibility.

NOACU or NOACUOPT are not allowed.

Alternatively, you can compile using a clone of the ACUCOBOL-GT compiler known as ccbl.exe . This
executable is located in the bin directory found here: %ProgramFiles(x86)%\Micro Focus
\Enterprise Developer. ccbl.exe compiles to .int code unless you specify one of the ccbl's native
code options, in which case it produces .gnt code.

Supported ACUCOBOL-GT Compiler Options
There are a number of ACUCOBOL-GT Compiler options supported in Enterprise Developer, which you
enable using the ACUOPT Compiler directive.

General Support Notes

Enterprise Developer supports the following ACUCOBOL-GT compiler functionality:

• Grouping of options
• CBLFLAGS environment variable
• Replacement of @ by the base name of the source file.

The following compiler options are available:

Standard Options

The standard options enable you to control certain compile time options, such as verbose output and
renaming the object file.
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The following compiler options are supported in Enterprise Developer when using ccbl from the command
line or the ACUOPT Compiler directive.

Option Definition

-e This option must be followed by a file name (as the next
separate argument). When specified, this option causes
the error listing to be written to the specified file instead of
the screen. This file is removed if no errors are found.

-o This option must be followed by a file name (as the next
separate argument), which becomes the name of the
object file instead of source-name.acu. This file is
removed if the compiler detects errors in the source.

-v This option has multiple applications:

• If it is the first and only option on the command line,
then the compiler runs in "Version" mode. Using -v,
you can display version information, the copyright
notice, and other information.

• Otherwise, if it is used in combination with other
options, it causes the compiler to be verbose about its
progress.

Because -v is the lead-in sequence for the video options,
this option should be specified by itself.

-w This option causes warning messages to be suppressed
(a warning condition is never a fatal compilation error).
Suppressing warning messages can be helpful when you
are converting programs from another COBOL dialect
that uses slightly different syntaxes.

-x This causes the CBLFLAGS environment variable to be
ignored.

Native Object Code Options

The native object code option enables you to execute object files that contain native instructions for select
families of processors.

The following compiler option is supported in Enterprise Developer when using ccbl from the command
line.

Option Definition

-n The Compiler produces native code specific to the bit
arrangement and local machine. There is no support for
cross-generation of native code.

Listing Options

The listing options enable you to control listing information generated with an object file.

The following compiler options are supported in Enterprise Developer when using ccbl from the command
line or the ACUOPT Compiler directive.

Note: The results of these options will differ from how they appear in ACUCOBOL-GT COBOL, as
they map to listing Compiler directives in Enterprise Developer.
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Option Definition

-La This option maps to the ERRLIST Compiler directive.

-Lc This option maps to the XREF and RESEQ Compiler
directives.

-Lf This option maps to the COPYLIST Compiler directive.

-Li This option maps to the ERRLIST Compiler directive.

-Ll This option maps to the FORM Compiler directive.

-Lo This option maps to the LIST Compiler directive.

-Ls This option maps to the DATAMAP Compiler directive.

-Lw This option maps to the LISTWIDTH Compiler directive.

Internal Table Options

The Internal Table options available in ACUCOBOL-GT are not required in Enterprise Developer. The
following options are accepted by the compiler, but are ignored.

Option Definition

-Td Identifier and statement table — sets the maximum
number of items in each statement. The default value is
4096.

-Te Subscript statement table — sets the maximum size for
OCCURS statements. The default value is 256.

Compatibility Options

The compatibility options enable you to control the compatibility with certain other COBOL systems.

The following compiler options are supported in Enterprise Developer when using ccbl from the command
line or the ACUOPT Compiler directive.

Option Definition

-Ca This option causes simple ACCEPT and DISPLAY
statements to be treated in accordance with ANSI
semantics. Specifying this option is the same as
specifying FROM CONSOLE for all simple ACCEPT
statements and UPON CONSOLE for all simple DISPLAY
statements. You can control this behavior for individual
ACCEPT or DISPLAY statements by specifying an explicit
FROM/UPON phrase.

-Ci This option sets the compiler to be compatible with
ICOBOL for certain COBOL constructs.

-Cr This option sets the compiler to RM/COBOL compatibility
mode.

-Cv This option sets the compiler to IBM DOS/VS
compatibility mode.

Source Options

The source options enable you to modify the way that the Compiler treats the physical source files.
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The following compiler options are supported in Enterprise Developer when using ccbl from the command
line or the ACUOPT Compiler directive.

Option Definition

-Sa This causes the compiler to assume that the input source
is in the standard ANSI source format.

-Sd Setting this option causes debugging lines marked with D
in the indicator area to be treated as normal source lines
instead of comment lines. This is equivalent to supplying
the phrase WITH DEBUGGING MODE in the SOURCE-
COMPUTER paragraph.

-Sp With this option you can specify a series of directories to
be searched when the compiler is looking for COPY
libraries. This option is followed (as the next separate
argument) by the set of directories to search.

-St This option forces the compiler to use the terminal source
format.

-S1..-S9 Specifying a digit with -S uses alternate tab stops in
source files. When this option is used, tabs will be set
every # columns apart, where # is the number specified.
For example, -S4 will set tab stops at every fourth
column. Tab stops always start in column 1.

Reserved Word Options

The reserved word options enable you to override the behavior of reserved words and synonyms.

The following compiler options are supported in Enterprise Developer when using ccbl from the command
line or the ACUOPT Compiler directive.

Option Definition

-Rc Allows you to change a reserved word. This option must
be followed by two separate arguments: The first is the
reserved word you want to change. The second is the
word that you want to use instead. For example,

-Rc TITLE NAME

will allow you to use "TITLE" as a user-defined word and
will cause the word NAME to be treated as the reserved
word TITLE. You may not specify a word that is already
reserved as the new reserved word. This option may be
repeated to transform multiple reserved words.

-Rn Allows you to make a reserved word a synonym for
another reserved word. This option must be followed by
two separate arguments: The first is the reserved word for
which you want a synonym. The second is the word that
functions as the synonym. For example,

-Rn COMP COMP-5

causes COMP-5 to be treated the same as the reserved
word COMP. This option may be repeated to make
multiple synonyms.
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-Rw This option allows you to suppress a particular reserved
word. The option must be followed (as the next separate
argument) by the reserved word you want to suppress.
This option may be repeated to suppress multiple
reserved words. This option also allows you to suppress
some non-reserved words, such as control names (for
example, entry-field and label) or property
names (for example, max-text and bitmap-
number).

Data Storage Options

The data storage options control the behavior of certain data items and how they are stored.

The following compiler options are supported in Enterprise Developer when using ccbl from the command
line or the ACUOPT Compiler directive.

Option Definition

-D1 This option causes any data item whose underlying type
is binary to be stored in one byte if that data item has only
one or two digits. Normally, such a data item would be
stored in two bytes.

-D2 This option causes COMPUTATIONAL data items to be
treated as if they were declared as COMPUTATIONAL-2.
This is the default when you are using RM/COBOL
compatibility mode.

-D5 This option causes data items declared as BINARY to be
treated as if they were declared as COMPUTATIONAL-5.
This causes the values to be stored in the host machine's
native byte-ordering instead of the machine-independent
byte-ordering normally used. This option should be used
with caution, because it can lead to programs that are not
portable.

-D6 This option causes unsigned data items declared as
PACKED-DECIMAL to be treated as if they were declared
as COMPUTATIONAL-6. This saves one-half of a byte
because the compiler will not generate any storage for
the sign.

-D7 This option allows you to match one of the binary storage
conventions used by Micro Focus COBOL. That
convention is identical to the ACUCOBOL-GT -Dm
convention, except that a PIC 9(7) data item (unsigned) is
stored in 3 bytes instead of 4 and a PIC 9(12) data item
(unsigned) is stored in 5 bytes instead of 6. When you
use this option, the size of a binary item is determined as
follows (the value in the table is the number of bytes
occupied by the data item):

Number of          Signed             
Unsigned 
9's in PIC         Storage            
Storage
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1 - 2              1                  
1
3 - 4              2                  
2
5 - 6              3                  
3
7                  4                  
3
8 - 9              4                  
4
10 - 11            5                  
5
12                 6                  
5
13 - 14            6                  
6
15 - 16            7                  
7
17 - 18            8                  
8

-Da This allows you to specify the data alignment modulus for
level 01 and level 77 data items. Normally, level 01 and
level 77 data items are aligned on a 4-byte boundary
(modulus 4). This is optimal for 32-bit architectures. You
can specify an alternate alignment boundary by following
this option with the desired modulus. This should be
specified as a single digit that immediately follows the -
Da as part of the same argument. For example, -Da8
specifies that data should be aligned on 8-byte
boundaries, which can provide improved performance on
a 64-bit machine.

-Db This causes COMPUTATIONAL data items to be treated
as if they were declared as BINARY data items. This is
the default when you are using VAX COBOL compatibility
mode.

-DCa This selects the ACUCOBOL-GT storage convention. It is
the default setting. This convention is also compatible
with data produced by RM/COBOL (not RM/COBOL-85)
and previous versions of ACUCOBOL-GT. It also
produces slightly faster code.

-DCb This selects the MBP COBOL sign storage
convention.Note that the MBP COBOL sign storage
convention for USAGE DISPLAY directly conflicts with
that used by IBM COBOL and some other COBOLs. As a
result, signed USAGE DISPLAY items in the MBP format
are correctly understood only when the program is
compiled with -Dcb. This is unlike the other sign
conventions in which the run-time can usually extract the
correct value even when a mismatched sign convention is
specified at compile time.

Also note that MBP COBOL does not have the COMP-2
storage type. The convention that ACUCOBOL-GT
implements (Positive: X"0C"; Negative: X"0D") was
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chosen because MBP COBOL most closely matches the
sign storage of other COBOLs that use that convention.

-DCi This selects the IBM storage convention. It is compatible
with IBM COBOL, as well as with several others including
RM/COBOL-85. It is also compatible with the X/Open
COBOL standard.

-DCm This selects the Micro Focus storage convention. It is
compatible with Micro Focus COBOL when the Micro
Focus ASCII sign-storage option is used (this is the Micro
Focus default).

-DCn This causes a different numeric format to be used. The
format is the same as the one used when the -Dci
option is used, except that positive COMP-3 items use
X"0B" as the positive sign value instead of X"0C". This
option is compatible with NCR COBOL.

-DCr This selects the Realia sign storage convention. Sign
information for S9(n) variables is stored using the
conventions for Realia COBOL, and their conversion to
binary decimal is the same as that performed by the
Realia compiler.

-DCv This creates numeric sign formats that are compatible
with VAX COBOL. These are identical to the IBM formats,
except that unsigned COMP-3 fields place X"0C" in the
sign position, instead of X"0F". The ANSI definition of
COBOL does not state how signs should be stored in
numeric fields (except for the case of SIGN IS
SEPARATE). As a result, different COBOL vendors use
different conventions. By using the options -Dca, -Dci,
-Dcm, -Dcn, or -Dcv, you may select alternate sign-
storage conventions. Doing so is useful in the following
cases:

• If you need to export data to another COBOL system
and need to match its sign-storage convention.

• If you are importing data from another COBOL
system, and that data contains key fields with signed
data. Keys are treated alphanumerically, so if you use
the incorrect sign-storage convention, ACUCOBOL-
GT will not find a matching key when it is doing a
READ.

The storage-convention affects how data appears in
USAGE DISPLAY, COMP-2, and COMP-3 data types.

-Dd31 This option supports data items with up to 31-digits or 16
bytes. When this option is in effect, you may use as many
as 31 X or 9 symbols in a PIC, instead of the usual 18.
The maximum number of bytes in a COMP-X or COMP-N
data item, whose picture contains only "X" symbols, is 16,
instead of the usual 8. Intermediate results are calculated
to 33 digits instead of the usual 20.
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-Df This option changes the way the compiler treats data
items declared as COMP-1 and COMP-2. Some
compilers use COMP-1 and COMP-2 to specify single-
and double-precision floating-point data items.
ACUCOBOL-GT, however, assigns a different meaning to
COMP-1 and COMP-2 and uses FLOAT and DOUBLE to
specify floating-point data items.When the -Df option is
used, the compiler treats data items declared as COMP-1
as if they were declared FLOAT and data items declared
as COMP-2 as if they were declared DOUBLE. With the -
Df option, you have the following correspondence:

COMP-1   FLOAT    single precision
COMP-2   DOUBLE   double precision

The -Df option makes it easier to compile code originally
written for another compiler — one that used COMP-1
and COMP-2 to specify floating point data items. The -
Df option lets you compile such code without having to
change COMP-1 and COMP-2 to FLOAT and DOUBLE.

-Di This option causes the compiler to initialize Working-
Storage. Normally, the compiler will initialize all data items
to spaces or the value specified with the -Dv option,
except for those items given a VALUE clause. If this
option is specified, data items are initialized according to
their type:

• Alphabetic, alphanumeric, alphanumeric edited, and
numeric edited items are initialized to spaces.

• Numeric items are initialized to zero.

• Pointer items are initialized to null.

• Index items are initialized to 1.

Automatic initialization applies only to Working-Storage
and does not apply to any item that (a) is given a VALUE
clause, (b) is EXTERNAL, or (c) is subordinate to a
REDEFINES phrase.

-Dl1/2/4/8 This option allows you to limit the maximum alignment
modulus that will be used for SYNCHRONIZED data
items. Normally, a synchronized data item is aligned on a
2-, 4-, or 8-byte boundary depending on its type. This
option allows you to specify an upper bound to the
modulus used. This is specified as a single digit that
immediately follows the -Dl as part of the same
argument. For example, -Dl4 specifies that the
maximum synchronization boundary is a 4-byte boundary.
If you want to make programs that are compliant with the
88/Open COBOL specification, you should specify -Dl4.

-Dm This option causes any data item whose underlying type
is binary to be stored in the minimum number of bytes
needed to hold it. Normally, binary types are stored in
two, four, or eight bytes. This option allows storage in any
number of bytes ranging from one to eight.
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-Dq Causes the QUOTE literal to be treated as an
apostrophe, or single quotation mark, rather than as a
double quotation mark ("). One exception to this is the HP
COBOL TRANSFORM verb, in which QUOTE is always
treated as a double quotation mark.

-Ds This causes USAGE DISPLAY numeric items with no
SIGN clause to be treated as if they were described with
the SIGN IS TRAILING SEPARATE clause. Several
versions of RM/COBOL behave this way (all versions
before 2.0, and some versions afterward).

-Dv This option allows you to specify the default byte (initial
value) used to initialize any data item not otherwise
initialized when the program is loaded. The option must
be followed by an equals sign (=) and the decimal value
of the byte to use (for all current platforms, this is the
ASCII value of the desired character). For example, to fill
memory with the NULL character, use -Dv=0. To fill
memory with the ASCII space character, use -Dv=32.

-Dw32 This option is checked for compatibility with the system's
bit arrangement.

-Dw64 This option is checked for compatibility with the system's
bit arrangement.

Truncation Options

The truncation options enable you to control the truncation of certain data items.

The following compiler options are supported in Enterprise Developer when using ccbl from the command
line or the ACUOPT Compiler directive.

Option Definition

-Dz All binary and packed-decimal data types ignore their
PICTURE when determining the largest value they can
hold. The PICTURE is not used when moving to a
nonnumeric destination (the largest possible value
determines the number of digits moved instead).

-noTRUNC All binary data types ignore their PICTURE when
determining the largest value they can hold. However, the
PICTURE is used when moving data from a binary
number to a nonnumeric data item. The name of this
option is similar to the name used by some other COBOL
systems that behave this way.

-truncANSI Full ANSI COBOL rules are in place. Each numeric data
item stores values up to its PICTURE in size. A small
number of USAGE types provide exceptions (such as
COMP-X and COMP-5). Values larger than allowed by
the PICTURE are truncated using the standard size rules
when the data item is the target of a MOVE statement;
however, COMP-5 items do use their PICTURE when
moving a value to a nonnumeric data item. The results of
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an arithmetic overflow (without the SIZE phrase) are
undefined.

Comments:

The -Dz truncation option is not supported in .NET COBOL.

Video Options

The video options enable you to control the behavior of certain items displayed to screen.

The following compiler options are supported in Enterprise Developer when using ccbl from the command
line or the ACUOPT Compiler directive.

Option Definition

-Vc This option causes any ACCEPT statement that contains
a numeric or numeric edited receiving field to be treated
as if the CONVERT phrase were also specified.

-Vd This option causes non-USAGE DISPLAY numeric items
to be converted to USAGE DISPLAY before the screen
display occurs.

This option is always on.

Warning and Error Options

The warning and error options enable you to set the error threshold before a object file will stop executing.

The following compiler options are supported in Enterprise Developer when using ccbl from the command
line or the ACUOPT Compiler directive.

Option Definition

-a This flag is now obsolete and should not be used.

-Qm This option specifies the number of errors the compiler
reports before it exits. The option must be followed by a
positive numeric argument, which is the maximum
number of errors the compiler reports before it exits. The
default value is 100.

Debugging Options

The debugging options enable you to generate and execute object files suitable for debugging.

The following compiler options are supported in Enterprise Developer when using ccbl from the command
line or the ACUOPT Compiler directive.

Note: The results of these options may differ slightly from how they appear in ACUCOBOL-GT
COBOL, as they map to the debugging Compiler directives in Enterprise Developer.

Option Definition

-Ga, -Gd, -Gl, -Gs, -Gy These options map to the ANIM Compiler directive
setting.
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-Gz This option maps to the NOANIM Compiler directive
setting.

Miscellaneous Options

The miscellaneous options enable you to control a number of aspects of the generated object files, such as
bounds checking and optimization.

The following compiler options are supported in Enterprise Developer when using ccbl from the command
line or the ACUOPT Compiler directive.

Option Definition

-Za Causes the compiler to generate code to test array
references at run time. If an index is used which is out-of-
bounds, the run-time system displays an error message
showing the index value and the allowed bounds. (This
causes some extra code to be generated and prevents
certain table optimizations from occurring, so it should be
turned off once a program is fully debugged.) With this
option, the compiler does not re-use previously computed
index values.

-Zc This compact option optimizes for smaller code instead of
faster code.

This option is accepted by the compiler, but is ignored.

-Zd Although still supported, this option has been replaced by
the -Gd option. Both options produce the same results.

-Zg Enables the use of segmentation (overlays) in the source.
If this option is not used, section numbers will be ignored.

This option is accepted by the compiler, but is ignored.

-Zi Causes the program to be compiled as if it had the IS
INITIAL PROGRAM phrase specified in its
PROGRAM-ID paragraph.

-Zl All data items may be larger than 64 KB. This option is
obsolete.

-Zn This turns off ACUCOBOL-GT's local optimizer. This is
useful primarily to see if the optimizer is introducing errors
in the generated object code. This option also prevents
the compiler from re-using previously computed index
values.

This option is accepted by the compiler, but is ignored.

-Zs Although still supported, this option has been replaced by
the -Gy option. Both options produce the same results.

-Zy This option lets you treat ACCEPT FROM DATE as
ACCEPT FROM CENTURY-DATE, and ACCEPT FROM
DAY as ACCEPT FROM CENTURY-DAY. If you use this
option, the 4-digit year format will be used for ACCEPT
FROM DATE providing that:
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• The receiving field is numeric or numeric edited and
contains eight or more integer digits; or

• The receiving field is not numeric or numeric edited
and contains eight or more character positions.

If neither of the above conditions applies, then ACCEPT
FROM DATE will return its normal 6-digit format even if
you use -Zy.

-Zr0 This option tells the compiler not to allow recursive
PERFORMs. Event procedures require the ability to do
recursive PERFORMs.

-Zr1 This option tells the compiler to allow recursive
PERFORMs. Event procedures require the ability to do
recursive PERFORMs.

32- and 64-Bit Code Generation
When compiling with the DIALECT"ACU" directive, the Compiler generates intermediate code that is bit
independent. By using ccbl, you can specify 32 or 64-bit intermediate code.

When compiling for generated code you must specify 32 or 64-bit. Enterprise Developer is bit-specific and
does not support cross-bit generation.

To produce bit-specific code, use ccbl from either a 32-bit or 64-bit command prompt.

ACUCOBOL-GT Conversion Issues

The syntax of most ACUCOBOL-GT source programs when submitted to run on this COBOL system will
be accepted and run successfully. However, sometimes this COBOL system might reject some of the
syntax in the original source program, or might cause your program to behave unexpectedly at run-time.

The following is not an exhaustive list of the restrictions of using ACUCOBOL-GT source code in Enterprise
Developer. In most cases, if your code includes ACUCOBOL-GT features not supported by Enterprise
Developer, you will receive a Compiler error.

Complementary ACUCOBOL-GT Technologies
In ACUCOBOL-GT, you can utilize a number of complementary technologies in your applications. In
Enterprise Developer, there are a number of technologies that provide equivalent or similar functionality.

You should compile your source code with the DIALECT"ACU" Compiler directive to give the fullest
ACUCOBOL-GT emulation in Enterprise Developer. If problems persist relating to any of the ACUCOBOL-
GT technologies listed below, refer to the documentation for the corresponding Micro Focus technology to
help remediate your code.

ACUCOBOL-GT technology Corresponding technology Notes

AcuConnect Thin Client None All syntax relating to this technology
should be removed from your source.

AcuServer Fileshare You can connect to your Vision files
through AcuServer, but the
functionality is limited.

Acu4GL Database Connectors Full documentation is available from
the Product Documentation section of
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the Micro Focus Customer Support
website (https://
www.microfocus.com/en-us/support/
documentation/).

AcuXDBC and AcuODBC XDBC Full documentation is available from
the Product Documentation section of
the Micro Focus Customer Support
website (https://
www.microfocus.com/en-us/support/
documentation/).

Xcentrisity for BIS Xcentrisity for BIS Full documentation is available from
the Product Documentation section of
the Micro Focus Customer Support
website (https://
www.microfocus.com/en-us/support/
documentation/).

XML Extensions XML Extensions Full documentation is available from
the RM/COBOL product
documentation set in the Product
Documentation section of the Micro
Focus Customer Support website
(https://www.microfocus.com/en-us/
support/documentation/).

AcuSQL OpenESQL preprocessor Set the DIALECT"ACU" Compiler
directive in your source to enable this
preprocessor.

Configuration Files and Configuration Variables
ACUCOBOL-GT configuration files and configuration variables are not supported in Enterprise Developer.

Enterprise Developer uses different configuration files and variables. You need to review your existing
ACUCOBOL-GT configuration to determine which settings are relevant for use and which settings have
Enterprise Developer equivalents.

For example, some configuration settings for handling Vision files can be set in the default File Handler in
Enterprise Developer.

Some ACU configuration variables are not necessary or applicable in Micro Focus COBOL (for example,
PERFORM_STACK), and the functionality of others is covered by the Micro Focus compile and run-time
options (for example, A_CHECKDIV).

Multi-threading Implementation
The ACUCOBOL-GT multi-threading model differs from the multi-threading model implemented in
Enterprise Developer.

The ACUCOBOL-GT model contains some additional syntax not supported in Enterprise Developer. Refer
to Multi-threaded Programming for details of supported syntax and concepts in Enterprise Developer.

Screen Descriptions
Enterprise Developer and extend® differ in their support for some of the Screen Description phrases.

In Enterprise Developer, the following phrases of the Screen Description entry are not supported and
should be removed from your programs:
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AFTER
BEFORE
EXCEPTION

Truncation Options in .NET COBOL Code
The -Dz truncation option is not supported in .NET COBOL.

It is, however, supported in native COBOL, using the ACUOPT Compiler directive.

Unsupported Library Routines

The following ACUCOBOL-GT library routines are not (or will ever be) supported in Enterprise Developer
and will produce a COBRT097 Acu library routine is and will remain unimplemented
error. You should remove any calls to the following routines from your source code to avoid producing the
error.

Note: This list may contain customer-specific routines that are not found in the ACUCOBOL-GT
product documentation.

C$ASYNCPOLL

C$ASYNCRUN

C$CHAIN

C$CHARTERR

C$CONFIG

C$EXCEPINFO

C$GETVARIANT

C$GETEVENTDATA

C$GETEVENTPARAM

C$GETERRORFILE

C$GETNETEVENTDATA

C$KEYMAP

C$PRODKEY

C$RESOURCE

C$SERVER-EXTENSION

C$SETERRORFILE

C$SETEVENTDATA

C$SETEVENTPARAM

C$SETVARIANT

C$TOJIS

KEISEN1

KEISEN2

KEISEN-SELECT

SYSID

W$BROWSERINFO

W$FORGET

W$GETC

W$GETCHAR

W$GETCGI

W$GETURL

W$INPUTMODE

W$KEYBUF

W$MENU

W$MOUSE

W$PALETTE

W$POSTURL

W$STATUS

$HP-CURRENT-DATE

$HP-TIME-OF-DAY

There is also another list of library routines that are not currently supported, but may be in the future.
These also produce a run-time error COBRT098 The library routine is not available in
Visual COBOL (routine-name) Please contact Micro Focus Customer Care for
information and must be removed from your source code whilst they are not supported.

ASCII2HEX

ASCII2OCTAL

HEX2ASCII

KEISEN

OCTAL2ASCII

C$CODESET

C$DISCONNECT

C$EXTINFO

C$FILESYS

C$JAVA

C$KEYPROGRESS

C$LOCALPRINT

C$OPENSAVEBOX

C$PARSEXFD

C$RCONVERT

C$RECOVER

C$REDIRECT

C$SOCKET

C$SYSLOG

R$IO

REG_OPEN_KEY

REG_CLOSE_KEY

REG_CREATE_KEY

REG_DELETE_KEY

REG_ENUM_KEY

REG_QUERY_VALUE

REG_SET_VALUE

REG_OPEN_KEY_EX

REG_CREATE_KEY_EX

REG_DELETE_VALUE

REG_ENUM_VALUE

REG_QUERY_VALUE_EX

REG_SET_VALUE_EX

S$io

$WINHELP

W$BITMAP

W$FLUSH

W$FONT

W$PROGRESSDIALOG

W$TEXTSIZE

WIN$PLAYSOUND

WIN$PRINTER
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C$PING

For a list of currently supported library routines, refer to ACUCOBOL-GT Library Routines.

Using Pipes to Assign Filenames When Using the Vision File Handler
When assigning filenames, you cannot use certain pipes to assign a filename in the ASSIGN clause of the
SELECT statement if you are using the Vision file handler.

The ACUCOBOL-GT syntax of assigning a file using the -P, -D, and -F syntax is not supported in
Enterprise Developer; for example:

select test-file assign to "-P %TMP% cmd /c dir *.* > %TMP%"

If your applications use this syntax, you should remove it from your SELECT statements.

For more information on the pipes that are supported, read Programming > File Handling > File Handling
Guide > Filenames > Setting Up Pipes.

ACUCOBOL-GT File Handling
Enterprise Developer allows you to continue to use your existing ACUCOBOL-GT data files, including
Vision indexed data files.

Those files can also continue to be used through AcuServer, with minimal changes to your code required.

Alternatively, you can convert your Vision files to Micro Focus format. There is no need to convert your
sequential data files.

Configuring Access to Vision Files

Note: For these options to take effect, the ACUFH configuration option must be set ON; by default,
this is ON. For these options to take effect under Enterprise Server, ESACUFH must also be set ON;
by default, this is OFF.

To handle Vision files, you map a file to a compatible IDXFORMAT in the File Handler configuration file.

Within the configuration file, you can map an IDXFORMAT to all files in a particular folder, all files with a
specific file extension, or a single file. See Format of the Configuration File for the tags that you can use for
the mapping, and the order in which settings in these tags are applied.

The order that the mapping is applied is important, as conflicting settings can be overwritten; for example,
the following excerpt of the configuration file sets all files in c:\files\rmfiles to IDXFORMAT 21 and
all files with a .DAT extension to IDXFORMAT 17:

[FOLDER:C:\\files\\rmfiles]
IDXFORMAT=21

[*.DAT]
IDXFORMAT=17

If there is a .DAT file in c:\files\rmfiles, the mappings are applied according to the type of tag. In the
case above, mappings in the extension tag are applied after mappings in the FOLDER tag, and so
the .DAT file in that directory has an IDXFORMAT of 17.

By default, the File Handler handles all sequential and relative data files, but if you want to handle them
through the Vision file handler, use the INTEROP=ACU configuration option; however, in cases where the
INTEROP and IDXFORMAT mappings conflict, the INTEROP setting will override IDXFORMAT for your
Vision indexed data files.

File Limits
When using Vision files in Enterprise Developer, there are a number of file limits that affect file handling
operations.
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The following limits are in addition to the ones imposed in Enterprise Developer; see Limits in the File
Handling Reference section.

Note: The limits listed on this page override any listed in the File Handling Reference section when
handling Vision files.

Maximum record size: 64 MB (67,108,864)

Maximum number of indexed keys: 1 primary + 119 alternates

Maximum number of segments per key: 16

Maximum indexed key size: 250 bytes

Vision Related Utilities

Vision provides a series of utilities that enable you to manipulate Vision files from the command line.

Each utility is available in a 32-bit and a 64-bit version, located in %ProgramFiles(x86)%\Micro
Focus\Enterprise Developer\binn and \binn64 respectively.

Commands

vutil32 Rebuilds a file that has become corrupt, or one that contains a large number of deleted
records that you want to remove from the file.

vio32 Enables you to collect a group of files together into archives, and allows you to extract some
or all of these files from these archives.

logutil32 Enables you to examine and edit an ACUCOBOL-GT transaction log file.

acusort Enables you to sort or merge Vision files.

Converting Vision Files

You can access your Vision files using the File Handler, but if you prefer to convert them to Micro Focus
format, as part of a migration, using one of the following:

ACU2MFDataMigration
utility

Use ACU2MFDataMigration.exe, a utility available as a product sample, in
a solution named ACU2MFDataMigration. The utility contains Help on how to
complete the conversion wizard.

Data File Converter Use the Micro Focus Data File Converter to convert your Vision files to Micro
Focus format.
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DFCONV command line
utility

Use DFCONV from the command line, specifying Vision as the input format
for the file.

Configuring Access to Data Files Through AcuServer
Configure your converted applications to access data files through AcuServer.

Note: It is assumed that your environment and server is already configured correctly for using
AcuServer.

Syntax:

To access a data file through AcuServer, the following syntax must be passed to the file handler:

acurfap://servername:[port]:path\to\file

acurfap://
The protocol to use for AcuServer. This does not change.

servername
The name of the AcuServer server.

port
The server port to use when connecting to AcuServer. This is optional, and if omitted, the
default port number is used.

path/to/file
The path name to the file.
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Specifying the file explicitly:

You can specify the full syntax in the SELECT statement. For example, the following statement connects to
the server asvr1, on port 3011, then locates the file idx1 at C:\idx\.

...
select acusvridx assign to acurfap://asvr1:3011:c:\idx\idx1.
...

Specifying the file implicitly:

If you are not explicitly using the AcuServer syntax in your SELECT statement, for example:

...
select acusvridx assign to idx1.
...

you must specify it in the COBDATA environment variable using the syntax described above:

set COBDATA=%COBDATA%; "acurfap://servername:port:path/to/file"

The following example connects to the server asvr2, on the default port, then locates the file in the
SELECT statement at c:\idx\.

set COBDATA=%COBDATA%; "acurfap://asvr2::c:\idx"

If a path name is specified in COBDATA, it is prepended to the file name before file name mapping takes
effect.

You must also compile with FILETYPE=17 if you are using a sequential file, or if your file handling
configuration file does not specify IDXFORMAT=17 for the Vision file.

File name mapping:

If you have used any ACUCOBOL file name mapping techniques to specify an AcuServer file, you will need
to update the configuration to use Micro Focus file name mapping. Use the following table as a guide to
some of the equivalents in this COBOL system.

ACUCOBOL variable Replace with

FILE_CASE FILECASE configuration option

FILE_PREFIX COBDATA environment variable

FILE_SUFFIX FILESUFFIX configuration option

APPLY_FILE_PATH n/a

FILE_ALIAS_PREFIX dd_ mapping

Restrictions

The encryption and password protection features are not supported in Enterprise Developer.

ACUCOBOL-GT Library Routines
This COBOL development system provides a number of ACUCOBOL-GT library routines in native
and .NET COBOL code.

C$CALLEDBY
Returns the name of the caller of the currently running COBOL program or spaces if no caller exists or if
the caller is unknown.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.
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Usage
CALL "C$CALLEDBY" 
    USING CALLING-PROGRAM
    GIVING CALL-STATUS

Parameters

CALLING-PROGRAM PIC X(n)   Contains the name of the calling program or spaces if no
caller exists or if the caller is unknown. The run-time
system will use as much space for the name or spaces as
the COBOL program allows. If the object being called is in
an object library, the program returns the PROGRAM-ID.
If the object is not in an object library, the disk name is
returned.

CALL-STATUS PIC S99 This parameter receives one of the following values:

1 - Routine called by another COBOL program
0 - Routine is the main program; no caller exists
-1 - Caller unknown; routine not called by a COBOL
program

Compatibility Issues

None.

C$CALLERR
Retrieves the reason why the last CALL statement failed. For accurate information, it must be called before
any other CALL statement is executed.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "C$CALLERR" 
    USING ERR-CODE, ERR-MESSAGE

Parameters

ERR-CODE PIC X(2)

This parameter receives one of the following values:

01 Program file missing or inaccessible

02 Called file not a COBOL program

03 Corrupted program file

04 Inadequate memory available to load program

05 Unsupported object code version number

06 Recursive CALL of a program

07 Too many external segments

08 Large-model program not supported (returned only by run-time systems that do not support large-model
programs)
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09 Exit Windows and run "share.exe" to run multiple copies of "wrun32.exe" (returned only by Windows run-
time systems)

14 Japanese objects are not supported (returned only by run-time systems that do not support Japanese
objects)

ERR-MESSAGE PIC X(n) (optional)   

This routine may optionally be passed a second alphanumeric parameter. This parameter is filled in with a
descriptive message about the error encountered.

Compatibility Issues

• Only ERR-CODE 01 is returned in this COBOL system.
• ERR-MESSAGE is always set to SPACES.

C$CHDIR
Changes the current working directory.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "C$CHDIR" 
    USING DIR-NAME, ERR-NUM

Parameters

DIR-NAME PIC X(n) Contains the name of the new directory, or spaces.

The "@[DISPLAY]:" for Thin Client support is allowed. For
example:

C$CHDIR "@[DISPLAY]:C:\path"

In Thin Client environments, to get the current default
directory on the display host, DIR_NAME should contain
"@[DISPLAY]:" followed by spaces.

ERR-NUM PIC 9(9) COMP-4 (optional)   Holds the returned error number, or zero on success.

Comments

If a second USING parameter is passed, it must be described as PIC 9(9) COMP-4. This parameter will be
set to ZERO if the directory change is successful. Otherwise, it will contain the operating system's error
number.

If DIR-NAME contains spaces, then the current default directory is returned in it. In this case, ERR-NUM is
not used. Otherwise, DIR-NAME should contain the name of a directory to make the new default directory.
On Windows machines, this can include a drive letter. If you pass ERR-NUM, it will be set to zero if the
change was successful. Otherwise, ERR-NUM will contain the error value returned by the operating
system.

On some systems (such as VMS), it is legal to switch to a directory that does not exist, while other systems
(Windows, UNIX) do not allow it.

The behavior of this routine is affected by the FILENAME_SPACES configuration variable. The value of
FILENAME_SPACES determines whether spaces are allowed in a file name.

IMPORTANT

If you use C$CHDIR, create a CODE_PREFIX configuration entry to locate your object files. Ensure that all
of the search locations specified by the CODE-PREFIX are full path names. Do not use the current
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directory or any relative path names in the CODE_PREFIX. Without a full path name, the run-time system
may be unable to find your object files if it needs to re-open them.

For example, the run-time system must occasionally re-open an object file when:

• you are using the source debugger
• the program contains segmentation (overlays)
• you are using object libraries

If the object file was initially found in the current directory or a directory specified relative to the current
directory, and you then change the current directory with the C$CHDIR routine, the run-time system will not
be able to find the object file if it needs to re-open it. This will cause a fatal error and your program will halt.

If you use C$CHDIR and you are running in debug mode, be sure to set CODE_PREFIX in the
configuration file, not in the environment. You may set CODE_PREFIX in the environment when you are
not in debug mode.

Compatibility Issues

• "@[DISPLAY]" is not supported in this COBOL system.
• The FILENAME_SPACES configuration variable is not supported in this COBOL system. To use

filenames that contain spaces, enclose them in quotation marks.
• The CODE_PREFIX configuration variable is not supported in this COBOL system.

C$COPY
Creates a copy of an existing file.

Syntax:
CALL "C$COPY"
   USING source-file, dest-file, [file-type,]
   [GIVING status]

Parameters:
source-file

PIC X(n)

dest-file
PIC X(n)

file-type
PIC X

status
Any numeric type

On Entry:
source-file

The path name of the file to be copied

dest-file
The path name of the destination file

file-type
The file organization of the source file.It must be one of: S (for sequential), R (for relative)
or I (for indexed).

This defaults to S if not specified.
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On Exit:
copy-status

Returns zero if the copy is successful, or non-zero if not.

Comments:

To obtain an extended file status code for this operation, define status as comp xx comp-x and follow the
example in Extended File Status Codes.

C$DELETE
Deletes a file.

Syntax:
CALL "C$DELETE"
   USING file-name, [file-type,]
   [GIVING status]

Parameters:
file-name

PIC X(n)

file-type
PIC X

status
Any numeric type

On Entry:
file-name

The pathname of the file to be deleted

file-type
The file organization of the filename. It must be one of: S (for sequential), R (for relative) or
I (for indexed).

This defaults to S if not specified.

On Exit:
status

Returns zero if the delete is successful, or non-zero if not.

Comments:

To obtain an extended file status code for this operation, define status as comp xx comp-x and follow the
example in Extended File Status Codes.

C$FILEINFO
Retrieves some operating system information about a given file.

Syntax:
CALL "C$FILEINFO"
   USING file-name, file-info
   GIVING status

Parameters:
file-name
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PIC X(n)

file-info
Define the following group

01 file-info
  03 file-size  pic x(8) comp-x.
  03 file-date  pic 9(8) comp-x.
  03 file-time  pic 9(8) comp-x.

status
Any numeric type

On Entry:
file-name

The name of the file

On Exit:
file-info

The group item to receive the file information

status
Returns zero if the delete is successful, or non-zero if not.

Comments:

To obtain an extended file status code for this operation, define status as comp xx comp-x and follow the
example in Extended File Status Codes.

C$GetLastFileOp
Retrieves the last COBOL I/O operation performed.

Use this library routine within a declarative procedure after an I/O error has occurred.

Syntax:
CALL "C$GetLastFileOp" USING operation

Parameters:
operation

PIC X(20)

On Exit:

operation The name of the last I/O operation performed. The valid operations returned are:

Close

Commit

Delete

DeleteFile

Open

ReadLock

ReadNextLock

ReadNextNoLock

ReadNoLock

ReadPreviousLock

ReadPreviousNoLock

Rewrite

Rollback

Start

StartTransaction

Unlock

UnlockAll

Write
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Comments:

If the operation is longer than 20 characters, it is truncated to the right.

If the value SPACES is returned that indicates that no operation is available.

C$JUSTIFY
C$JUSTIFY performs left or right justification of data and centering of data.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "C$JUSTIFY" 
    USING DATA-ITEM, JUSTIFY-TYPE

Parameters

DATA-ITEM Any data item 

This data item contains the data to be justified.

JUSTIFY-TYPE PIC X

This optional parameter contains one of three literal values:

L   indicates left justification

R indicates right justification

C indicates centering

If this parameter is omitted, then "R" is implied.

Description

This routine removes all leading and trailing spaces from DATA-ITEM and justifies the remaining data as
indicated by JUSTIFY-TYPE. The resulting string is returned in DATA-ITEM. If centering is chosen, there
will be one more space on the right than on the left if an odd number of spaces is used.

Compatibility Issues
None

C$LIST-DIRECTORY
The C$LIST-DIRECTORY routine lists the contents of a selected directory. Each operating system has a
unique method for performing this task. C$LIST-DIRECTORY provides a single method that will work for all
operating systems.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "C$LIST-DIRECTORY" 
    USING OP-CODE, parameters 
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Parameters

OP-CODE PIC 99 COMP-X Indicates which C$LIST-DIRECTORY operation to
perform. The operations are described below.

Parameters vary depending on the op-code chosen.

Parameters provide information and hold results for the op-code specified. These parameters are
described below.

Description

C$LIST-DIRECTORY allows you to get the names of files residing in a given directory. It accomplishes this
through three distinct operations. The first operation opens the specified directory. The second operation
returns the filenames in the list, one-at-a-time. The third operation closes the directory and deallocates all
memory used by the routine. C$LIST-DIRECTORY has the following operation codes (defined in
acucobol.def):

LISTDIR-OPEN (VALUE 1)
Opens the specified directory. It has two parameters:
Directoryname PIC X(n)
Contains the name of the directory to open. This directory must exist, and you must have
permissions to read the directory. You may use remote name syntax if AcuServer is
installed on the remote machine. The "@[DISPLAY]:" for Thin Client support may be used.
For example:

C$LIST-DIRECTORY using listdir-open, 
"@[DISPLAY]:C:\path", pattern 

Pattern PIC X(n)
Specifies the type of filename for which to search. This routine supports "wildcards,"
meaning that the character "*" will match any number of characters, and the character "?"
will match any single character. For example, you can search by file suffix (*.def) or by a
common part of a file name (acu*).

If the call to LISTDIR-OPEN is successful, RETURN-CODE contains a handle to the list. The value in
RETURN-CODE should be moved to a data item that is USAGE HANDLE. That data item should be
passed as the directory handle to the other C$LISTDIRECTORY operations. If the call to LISTDIR-OPEN
fails (if the directory does not exist, contains no files, or you do not have permission to read the directory),
RETURN-CODE is set to a NULL handle.

LISTDIR-NEXT (VALUE 2)
Reads each filename from the open directory. It has two parameters:
Handle USAGE HANDLE
The handle returned in the LISTDIR-OPEN operation.

Filename PIC X(n)
The location of the next filename to be returned. If the directory listing is finished, it is filled
with spaces.

The call to LISTDIR-NEXT can include an additional argument, LISTDIR-FILE-INFORMATION (defined in
"acucobol.def"), which receives information about the returned file name. This is an optional group item
which returns information about the following data items:

LISTDIR-FILE-TYPE
The file type can be one of the following:

B = block device
C = character device
D = directory
F = regular file
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P = pipe (FIFO)
S = socket
U = unknown

LISTDIR-FILE-CREATION-TIME
The creation time is the date (and time) that the file was originally created.

LISTDIR-FILE-LAST-ACCESS-TIME
The last access time is the date (and time) that the file was last accessed by some
application (usually when the file was queried in some way).

LISTDIR-FILE-LAST-MODIFICATION-TIME
The last modification time is the date (and time) the file was last written to.

LISTDIR-FILE-SIZE
The size of the file is given in bytes.

LISTDIR-CLOSE (VALUE 3)
Releases the resources used by the other operations. It must be called to avoid memory
leaks. It has one parameter, handle, which is the same data item used by the LISTDIR-
NEXT operation.

Handle USAGE HANDLE
The handle returned in the LISTDIR-OPEN operation.

Note: Because the supported file types vary by operating system, The data items in the above list
have slightly different meanings depending on your operating system. Even on operating systems that
support these values, some file systems may not. Some versions of the UNIX® operating system may
change these values when permissions are changed. Refer to your operating system documentation
for specific definitions.

Example

The following example lists the contents of a directory with repeated calls C$LISTDIRECTORY:

WORKING-STORAGE SECTION.
copy "def/acucobol.def".
01  pattern       pic x(5) value "*.vbs".
01  directory     pic x(20) value "/virusscan".
01  filename      pic x(128).
01  mydir         usage handle.
PROCEDURE DIVISION.
MAIN.
* CALL LISTDIR-OPEN to get a directory handle.
    call "C$LIST-DIRECTORY" 
       using listdir-open, directory, pattern.
    move return-code to mydir.
    if mydir = 0
       stop run
    end-if.
* CALL LISTDIR-NEXT to get the names of the files.  
* Repeat this operation until a filename containing only 
* spaces is returned.  The filenames are not necessarily 
* returned in any particular order.  Filenames may be 
* sorted on some machines and not on others.
    perform with test after until filename = spaces
       call "C$LIST-DIRECTORY" 
          using listdir-next, mydir, filename
    end-perform.
* CALL LISTDIR-CLOSE to close the directory and deallocate
* memory. Omitting this call will result in memory leaks.
    call "C$LIST-DIRECTORY" using listdir-close, mydir.
    stop run.
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Compatibility Issues

• You must compile with the DIALECT"ACU" Compiler directive when using this library routine.
• "@[DISPLAY]" is not supported in this COBOL system.

C$MAKEDIR
Creates a new directory.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

C$MAKEDIR can make a directory only one level lower than an existing directory and cannot create more
than one level at a time.

Usage
CALL "C$MAKEDIR" 
    USING DIR-NAME GIVING STATUS-CODE

Parameters

DIR-NAME PIC X(n) Contains the name of the directory to be created. This
should be either a full path name or a name relative to the
current directory. You may use remote name syntax in
combination with AcuServer to create a directory on a
remote machine.

The "@[DISPLAY]:" annotation for Thin Client support
may also be specified. For example:

C$MAKEDIR "@[DISPLAY]:C:\path"

STATUS-CODE Numeric data item. Receives the return status of the call to create a directory.
A return status of zero indicates that the directory was
successfully created; a status of one ("1") indicates
otherwise.

The behavior of this routine is affected by the
FILENAME_SPACES configuration variable. The value of
FILENAME_SPACES determines whether spaces are
allowed in a file name.

Compatibility Issues

• "@[DISPLAY]" is not supported in this COBOL system.
• The FILENAME_SPACES configuration variable is not supported in this COBOL system. To use

filenames that contain spaces, enclose them in quotation marks.

C$MEMCPY (Dynamic Memory Routine)
Copies bytes between any two memory locations.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "C$MEMCPY" 
    USING, BY VALUE, DEST-PTR, SRC-PTR, NUM-BYTES
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Parameters

DEST-PTR USAGE POINTER or USING BY
REFERENCE

Contains the address of the first byte of the destination.

SRC-PTR USAGE POINTER or USING BY REFERENCE Contains the address of the first byte of the source.

NUM-BYTES USAGE UNSIGNED-INT or an unsigned
numeric literal

Indicates the number of bytes to copy.

Description

This routine copies NUM-BYTES bytes of memory from the address contained in SRC-PTR to the address
contained in DEST-PTR. This routine is functionally similar to the M$COPY (Dynamic Memory Routine)
routine except that parameters are passed by value instead of by reference. This routine can be used in
cases where M$PUT and M$GET are not adequate. Note that this routine is relatively dangerous to use. It
does not perform any error checking and can easily cause memory access violations if you pass it incorrect
data. In other words, this routine is a very low-level routine and should be used cautiously.

You do not need to pass POINTER data items for SRC-PTR and DEST-PTR. If you prefer, either or both
can be replaced by a data item passed BY REFERENCE. If you do this, then the address of the data item
is passed to C$MEMCPY. For example, you can copy 10 bytes to DEST-ITEM from the memory address
contained in SRC-PTR with:

     CALL "C$MEMCPY" 
        USING BY REFERENCE DEST-ITEM, BY VALUE SRC-PTR, 10

Compatibility Issues

None.

C$MYFILE
Returns the filename of the disk file containing the currently executing program.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

This is especially useful if the disk file is an object library.

Usage
CALL "C$MYFILE" 
    USING PROGRAM-NAME 
    GIVING CALL-STATUS

Parameters

PROGRAM-NAME PIC X(n) Indicates the name of the disk file containing the currently
executing program, if known. The run-time system will
use as much space for the name of the file as the COBOL
program allows. This parameter will contain the filename
just as the run-time system received it. For example, if an
object library is loaded as ../ardir/myarlib.lib,
and a program in myarlib.lib calls this routine,
PROGRAM-NAME will have a value of ../ardir/
myarlib.lib.

CALL-STATUS PIC S99. This parameter receives one of the following values:
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1 - PROGRAM-NAME was filled successfully

-1 - Program name unknown

Compatibility Issues

None.

C$NARG
This routine returns the number of parameters passed to the current program.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "C$NARG" 
    USING NUM-PARAM

Parameter

NUM-PARAM COMP-1

Description

This routine must be called with one USING parameter that must be a COMP-1 data item. This data item is
filled in with the number of parameters. If the calling program is a subprogram, then this will be the number
of USING items in the CALL statement that initiated the program. If the calling program is a main program,
then this will be the number of CHAINING parameters passed from the runcbl command line or the CHAIN
statement that initiated the program. C$NARG works only when the program is a called subroutine. It does
not work with the "CALL RUN" form of the CALL verb.

Compatibility Issues

• This routine is not supported in .NET COBOL.
• Set the Compiler directive COMP1(BINARY) to set ACUCOBOL-GT behavior for COMP-1 data items.
• The "CALL RUN" statement is not supported in this COBOL system.
• In ACUCOBOL-GT COBOL, the number of parameters passed is calculated by the number of

parameters specified in the USING phase of the CALL statement in the calling program. In this COBOL
system, the number of parameters passed is calculated by the number of parameters the calling
program actually receives.

C$PARAMSIZE
This routine returns the number of bytes actually passed by the caller for a particular parameter.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "C$PARAMSIZE" 
    USING PARAM-NUM, 
    GIVING PARAM-SIZE
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Parameters

PARAM-NUM numeric parameter This value is the ordinal position in the Procedure
Division's USING phrase of the parameter whose size
you want to know.

PARAM-SIZE any numeric data item This item receives the number of bytes in the data item
actually passed by the caller.

Description

This routine returns the actual size (in bytes) of a data item passed to the current program by its caller. You
pass the number (starting with 1) of the data item in the Procedure Division's USING phrase, and C
$PARAMSIZE will return the size of the corresponding item that was actually passed. This can be useful for
handling data items of unknown size.

For example, suppose that you wanted to write a routine that could convert any data item to upper-case, up
to 10000 bytes in size. This routine could look like this:

IDENTIFICATION DIVISION.
PROGRAM-ID.  MAKE-UPPERCASE.

DATA DIVISION.
WORKING-STORAGE SECTION.
77  PARAM-SIZE    PIC 9(5).

LINKAGE SECTION.
77  PASSED-ITEM   PIC X(10000).

PROCEDURE DIVISION USING PASSED-ITEM.
MAIN-LOGIC.
   CALL "C$PARAMSIZE" USING 1, GIVING PARAM-SIZE
   INSPECT PASSED-ITEM( 1 : PARAM-SIZE ) 
      CONVERTING "abcdefghijklmnopqrstuvwxyz" 
      TO "ABCDEFGHIJKLMNOPQRSTUVWXYZ"
  EXIT PROGRAM.

In this example, if you do not use C$PARAMSIZE, you have to pass a full 10000 bytes to this routine or you
get a memory usage error. By using C$PARAMSIZE and reference modification, only the memory actually
passed is referenced, and there is no error. C$PARAMSIZE works only when the program is a called
subroutine. It does not work with the "CALL RUN" form of the CALL verb.

If you pass a subitem of a linkage item in a CALL statement and the subprogram calls C$PARAMSIZE with
requesting the size of the parameter, it will get the size as described in the linkage section of the calling
program, unless that subitem is the first item of the linkage item. In that case, the size returned will be the
size of the original item.

Compatibility Issues

• This routine is not supported in .NET COBOL.
• In this COBOL system, the size of the item as specified in the calling program is always returned.

C$REGEXP
This routine allows you to search strings using regular expressions.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.
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Usage
CALL "C$REGEXP" 
    USING OP-CODE, parameters
    GIVING return-value

Parameters

OP-CODE: Numeric data item.

Op-codes specify the operation to perform. Each operation is defined in acucobol.def and is described
in detail below. Op-codes include:

Code Operation

1 AREGEXP-GET-LEVEL

2 AREGEXP-COMPILE

3 AREGEXP-MATCH

4 AREGEXP-RELEASE-MATCH

5 AREGEXP-RELEASE

6 AREGEXP-NUMGROUPS

7 AREGEXP-GETMATCH

20 AREGEXP-LAST-ERROR

parameters: Type varies (defined in acucobol.def).

Parameters vary depending on the operation selected. They provide information and hold results.

return-value: Numeric data item.

Unless otherwise noted, each operation returns a value or a status in return-value. Its contents vary by
operation and the result of the operation.

Description

This routine allows you to use a regular expression to search a text string.

A regular expression is a formula for matching strings that have a certain pattern. For a complete
description of regular expressions, see the POSIX 1003.2 standard appropriate for your platform. Windows
platforms use the CAtlRegExp library; UNIX platforms use the POSIX C routines native to the platform.

A simple use of C$REGEXP is outlined in the following steps.

1. Use the AREGEXP-GET-LEVEL op-code to validate that the host platform provides support for regular
expressions.

2. Validate and compile your regular expression with op-code AREGEXP-COMPILE. Your program should
include an error handling routine in the event that the compiler finds an error in the expression.

3. Use op-code AREGEXP-MATCH to apply a compiled regular expression to a string to search for a
match. You may want to do this iteratively to find all matches in the string.

4. Use op-codes AREGEXP-NUMGROUPS and AREGEXP-GETMATCH to work with subexpression
matches.

5. Manage the memory used by this routine with op-codes AREGEXP-RELEASE-MATCH and AREGEXP-
RELEASE.

Op-codes and Parameters

AREGEXP-GET-LEVEL (op-code 1)
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This operation indicates whether regular expression support is available on the host. Its usage is:

CALL "C$REGEXP" USING AREGEXP-GET-LEVEL GIVING return-value

The value of return-value can be one of the following (defined in acucobol.def):

AREGEXP-NONE 0 regular expression processing is not
available

AREGEXP-WINDOWS   1   Windows regular expressions
supported

AREGEXP-POSIX 2 POSIX regular expressions supported

AREGEXP-COMPILE (op-code 2)

This operation compiles a regular expression to ensure that it has a valid form, returning a handle to the
compiled regular expression or NULL if there is an error. Its usage is:

CALL "C$REGEXP" USING AREGEXP-COMPILE, reg-expr, flags
                GIVING return-value

reg-expr

Must be a NULL-terminated regular expression. It must be NULL-terminated because trailing spaces are
allowed in regular.

flags

(Optional) is the sum of one or more of the following values (defined in acucobol.def):

AREGEXP_COMPILE_IGNORECAS
E    

1 Ignore case when matching patterns.
(Windows or UNIX)

AREGEXP_COMPILE_BASIC 2 Change the type of regular
expression from extended to basic.
(UNIX only) (For an explanation of
extended and basic, see the POSIX
1003.2 standard.)

AREGEXP_COMPILE_NO_SPECIAL 4 Treat all characters as ordinary
characters with no special meaning.
(UNIX only)

AREGEXP_COMPILE_NO_SUB 8 When matching, determine only if
there is a match, without returning the
offsets of the match. (UNIX only)

AREGEXP_COMPILE_NEWLINE 16   Treat newlines as special (end-of-line
marker) characters. (UNIX only)

AREGEXP_COMPILE_NO_REGEXP 32 Treat reg-expr as text, not as a
regular expression.

return-value contains a handle to the compiled expression, or NULL if an error occurred.

AREGEXP-MATCH (op-code 3)

This operation applies a regular expression to a string, and returns a handle. The match-start parameter
must be initialized before AREGEXP-MATCH is attempted, as it specifies the start position in which
matching should begin. To see if there is a match you need to check match-start; If it is 0, there is no
match. Its usage is:

CALL "C$REGEXP" USING AREGEXP-MATCH,
   reg-expr-handle, string, length, match-start, match-end
   GIVING return-value
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reg-expr-handle is a handle to a regular expression returned by
AREGEXP-COMPILE.

string is the string to test for a match.

length is the length of string. If length is zero, the size of string is
used.

match-start as an input parameter, match-start indicates where the
matching should begin. As an output parameter, it returns
the index of the start of the pattern that matched.

match-end returns one byte beyond the pattern that matched. To test
the string for additional matches, start a new AREGEXP-
MATCH after setting match-start to match-end.

return-value contains a handle to the match or zero if no match is
found or an error occurred.

AREGEXP-RELEASE-MATCH (op-code 4)

This operation frees memory that is allocated when AREGEXP-MATCH is called. Return-value is not used.
Its usage is:

CALL "C$REGEXP" USING AREGEXP-RELEASE-MATCH match-handle

match-handle is a handle to a match returned by AREGEXP-MATCH.

AREGEXP-RELEASE (op-code 5)

This operation frees the memory allocated when AREGEXP-COMPILE is called. Return-value is not used.
Its usage is:

CALL "C$REGEXP" USING AREGEXP-RELEASE reg-expr-handle

reg-expr-handle is a handle to a regular expression returned by
AREGEXP-COMPILE.

AREGEXP-NUMGROUPS (op-code 6)

This operation returns the number of substrings that matched any subgroups in the regular expression. Its
usage is:

CALL "C$REGEXP" USING AREGEXP-NUMGROUPS match-handle
                GIVING return-value

match-handle is a handle returned by AREGEXP-MATCH.

return-value returns the number of matches.

Depending on the construction of a regular expression, it is possible for a subgroup of the regular
expression to match multiple substrings. This operation reports the number of instances found in the last
AREGEXP-MATCH operation. For more information, rules, and examples, see the POSIX 1003.2
documentation or one of the many books available on regular expressions.

AREGEXP-GETMATCH (op-code 7)

This operation returns a set of indices into a string passed to AREGEXP-MATCH that match the
subexpression of the regular expression. Its usage is:

CALL "C$REGEXP" 
    USING AREGEXP-GETMATCH, match-handle, group, 
    idx-start, idx-end
    GIVING return-value

The parameters are defined as follows:
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match-handle is a handle returned by AREGEXP-MATCH.

group is a number between 1 and the value returned by
AREGEXP-NUMGROUPS.

idx-start returns an index into the beginning of the string that
matches the subexpression of the regular expression.

idx-end returns an index to the end of the string that matches the
subexpression of the regular expression.

return-value returns 1 if the operation succeeds, and zero if there is
an error.

AREGEXP-LAST-ERROR (op-code 20)

This operation returns the last error code returned by a call to C$REGEXP. Its usage is:

CALL "C$REGEXP" USING AREGEXP-LAST-ERROR GIVING return-value

The error value is returned in return-value. The possible error values (described in acucobol.def) have
the following meanings:

AREGEXP-ERROR-NO-ERROR 0 No error

AREGEXP-ERROR-NO-MEMORY 1 Insufficient memory to handle the
request

AREGEXP-ERROR-BRACE-
EXPECTED

2 A closing brace is missing

AREGEXP-ERROR-PAREN-
EXPECTED

3 A closing parenthesis is missing

AREGEXP-ERROR-BRACKET-
EXPECTED   

4 A closing bracket is missing

AREGEXP-ERROR-UNEXPECTED 5 An unknown error occurred

AREGEXP-ERROR-EMPTY-RANGE 6 An empty range was given

AREGEXP-ERROR-INVALID-
GROUP

7 The group provided was invalid

AREGEXP-ERROR-INVALID-RANGE 8 An invalid range was given

AREGEXP-ERROR-EMPTY-
REPEATOP

9 A repeat operator was given on an
empty subexpression

AREGEXP-ERROR-INVALID-INPUT 10 The input was invalid

AREGEXP-ERROR-INVALID-
HANDLE

11 The handle is not a regular
expression handle or a match handle

AREGEXP-ERROR-INVALID-
ARGUMENT

12 One of the arguments given is invalid

AREGEXP-ERROR-INVALID-CALL-
SEQ

13 The order of C$REGEXP operations
is an invalid sequence.

AREGEXP-ERROR-NO-MATCH 14   The regular expression did not find a
match in the given string.

Note: If the error code returned does not match a value in the list, it may be that the value is coming
from the host's regular expression library. See the documentation for the host's regular expression
library.
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Compatibility Issues
None.

C$RERR
Returns extended file status information for the last I/O statement.

Syntax:
CALL "C$RERR" USING extend-stat [text-message, status-type]

Parameters:
extend-stat

PIC X(5) or larger

text-message
PIC X(n)

Note: This optional parameter is ignored in this COBOL system.

status-type
PIC 9

Note: This optional parameter is ignored in this COBOL system.

On Exit:

extend-stat Returns the extended file status caused by the last file I/O

Comments:

The statuses returned are listed in the file status table found in Appendix E of the ACUCOBOL-GT product
documentation. If the file status (first two characters) is 30, the remainder of the information is the
operating system's status code explaining what caused the error. On some systems, the operating system
requires more than two digits for its status codes. That is why the C$RERR routine may be passed a field
that is larger than four characters.

Whenever an error 30 occurs, the operating system's status value is returned in this extended field. The
number returned is a left-justified decimal value. If the receiving field is too small, the right-most digits are
returned. If the receiving field is too large, the excess characters are filled with spaces.

C$RERRNAME
Returns the name of the last file used in an I/O statement.

Use it in conjunction with C$RERR to diagnose file errors.

Syntax:
CALL "C$RERRNAME" USING file-name

Parameters:
file-name

PIC X(n)

On Exit:

file-name The name of the last file that was involved in an I/O statement.
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Note: The filename is the one specified in the ASSIGN clause.

C$RUN
ACUCOBOL-GT for Windows supports an alternate method for running other programs. This is through the
library routine C$RUN. This library routine works identically to the SYSTEM library routine, except that the
calling program does not wait for the called program to finish. Instead, both programs run in parallel.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "C$RUN"
    USING COMMAND-LINE,
    GIVING STATUS-VAL

Parameters

COMMAND-LINE PIC X(n) Contains the operating system command line to execute.

STATUS-VAL Any numeric data item Returns 0 if successful or -1 if not.

Description

C$RUN sets STATUS-VAL to -1 if the call fails or to 0 if it succeeds.

C$RUN is implemented only under the Windows version of ACUCOBOL-GT. On other systems, it always
returns 1.

C$RUN is supported in Thin Client environments. To execute a program on the display host in a thin client
environment, add the prefix @[DISPLAY]: to the name of any program that resides on the client machine.
For example:

C$RUN "@[DISPLAY]:C:\notepad myfile.txt

Compatibility Issues
"@[DISPLAY]" is not supported in this COBOL system.

C$SLEEP
This routine causes the program to pause in a machine efficient fashion.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "C$SLEEP" 
    USING NUM-SEC

Parameter

NUM-SEC Numeric or alphanumeric parameter The number of seconds to sleep.

This parameter is a an unsigned fixed-point numeric
parameter, or an alphanumeric data item containing an
unsigned fixed-point number.
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Description

This routine can be used to impose slight delays in loops. For example, you might want to introduce a delay
in a loop that is waiting for a record to become unlocked. Calling C$SLEEP will allow the machine to
execute other programs while you wait.

The C$SLEEP routine is passed one argument. This argument is the number of seconds you want to
pause. For example, to pause the program for five and a half seconds, you could use either of the following:

CALL "C$SLEEP" USING 5.5
CALL "C$SLEEP" USING "5.5"

The amount of time paused is only approximate. Depending on the granularity of the system clock and the
current load on the machine, the time paused may actually be shorter or longer than the time requested.
Typically, the time paused will be within one second or one-tenth of a second of the amount requested
(unless the machine is excessively loaded).

If the sleep duration is zero, this function does nothing. If the sleep duration is signed, this function
generates a run-time system error.

Compatibility Issues
None

C$SYSTEM
This routine combines the functionality of "SYSTEM" and "C$RUN". It allows you to run other programs
from inside a COBOL application in a variety of ways.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

C$SYSTEM adds the following capabilities to the original capabilities of SYSTEM and C$RUN:

1. Uniform programming interface for all options
2. Asynchronous operation (C$RUN) added to UNIX hosts
3. Windows hosts can specify minimized, maximized, or hidden windows
4. Smart shell selection for Windows

Usage
CALL "C$SYSTEM" 
    USING CMD-LINE, FLAGS
    GIVING EXIT-STATUS

C$SYSTEM can be used to execute a program in Thin Client environments. To execute a program on the
display host in a thin client environment, add the prefix "@[DISPLAY]:" to the name of any program that
resides on the client machine. For Example:

C$SYSTEM "@[DISPLAY]:C:\notepad myfile.txt"

Parameters

CMD-LINE PIC X(n) Contains the operating system command line to execute.

FLAGS Numeric unsigned (optional) Supplies the options for the operation. If omitted, acts as
if "0" was specified.

EXIT-STATUS Any numeric data item Returns the called program's exit status.

Flags

The FLAGS field specifies various options about how the command should be run. Determine the value of
the FLAGS field by adding together the values corresponding to the following options:
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CSYS-ASYNC (value 1) This option causes the command to run independently of
the COBOL program. After starting the command, the
COBOL program continues. When this option is specified,
EXIT-STATUS returns undefined results. When this flag is
not used, the COBOL program waits for the command
executed to finish before the COBOL program continues.
CSYS-ASYNC is functional only on Windows and UNIX
systems.

Note: On UNIX machines, specifying CSYS-
ASYNC with a program that tries to do input or
output to the terminal is not supported.

CSYS-NO-IO (value 2) For character-based systems, the run-time normally sets
the terminal to its default state prior to running the
command, and resets it back to the state needed by the
run-time when the command finishes. This option
ensures that the called application runs correctly if the
application uses the screen. However, CSYS-NO-IO also
causes the run-time to "forget" the contents of the screen.
This happens because the command executed may
display information on the screen that ACUCOBOL-GT is
not aware of. Because of this, windows created after a
call to C$SYSTEM may not correctly restore the screen
contents when these windows are closed. You can avoid
this problem by re-initializing the screen after C$SYSTEM
returns. You can do this by erasing the screen or closing
a floating or pop-up window that covers the entire screen
(the window must have been created by the C$SYSTEM
call).

If the command to be executed will not perform any
screen I/O, then you can request that C$SYSTEM retain
ACUCOBOL-GT's memory of the original screen by using
the CSYS-NO-IO option. This will avoid the problem
described above. The option has no effect in Windows,
where the command runs in its own window.

CSYS-MAXIMIZED (value 4) This option causes the command to run in a maximized
window. This is functional only when you are running
under Windows.

CSYS-MINIMIZED (value 8) This option causes the command to run in a minimized
window. In addition, the COBOL program remains the
active program retaining the keyboard focus and keeping
the active appearance. This is functional only when you
are running under Windows.

CSYS-COMPATIBILITY (value 16) This option causes the command to run in a window that
is compatible with the way the SYSTEM library routine
works. Use this option if you want to modify a call to
SYSTEM and change this call to C$SYSTEM. There are
very few differences between the default behavior of
SYSTEM and C$SYSTEM, so this option is rarely
needed. The only known difference involves the Microsoft
Word application. If you use SYSTEM to start Microsoft
Word, it always starts in a "normal" sized window, that is,
the window size suggested by Windows. If you use C
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$SYSTEM to start Microsoft Word (with no FLAGS
specified), then Word adopts the last window size it
previously used. Supplying a flag of CSYS-
COMPATIBILITY causes C$SYSTEM to behave the same
as SYSTEM. Of course, if you prefer the behavior of C
$SYSTEM, the flag should not be used. In comparison
with SYSTEM, C$SYSTEM generally conforms more
closely to the way Windows itself launches programs. The
CSYS-COMPATIBILITY flag is recommended only if you
change a SYSTEM call to a C$SYSTEM call and you
observe a difference you do not like.

CSYS-HIDDEN (value 32) This option runs the command in a hidden window. Note
that some applications, particularly those that routinely
interact with the user, may get confused if you "hide" the
command. This works well, however, for executing system
tasks that do not have a user interface, such as executing
a batch file that renames a series of files. This option is
functional only when you are running under Windows.

CSYS-SHELL (value 64) When this option is specified, C$SYSTEM uses the host's
command-line processor (the host's shell) to execute the
command. Otherwise, the command may be executed
without the command-line processor. This option affects
only Windows (non-Windows versions always use the
host's shell). For Windows applications that create their
own windows, you should avoid using the shell the
application will not receive the initial window size request
specified in FLAGS. For ".COM" and ".BAT" programs,
and other built-in shell commands such as COPY and
DIR, you must use the shell or the command may not
execute.

The effect of this option is to prefix the command with the
value of the COMSPEC environment variable and "/C".
Under Windows, this will usually result in a prefix like "C:
\COMMAND.COM /C".

CSYS-DESKTOP (value 128) This option is for applications running in the thin client
environment. It indicates that the application wants to run
the command on the client system rather than the
application server. When the command executes, unless
the CSYS-ASYNC option is also specified, the thin client
appears to "hang" while the application waits for the
command's termination status. This behavior can be
avoided with the CSYS-ASYNC flag. The CSYS-ASYNC
flag causes the command to be run asynchronously.

If CSYS-DESKTOP is specified but the calling program is
not running under thin client, the flag is ignored and the
command is run on the same machine as the calling
application.

CSYS-INHERIT-HANDLES (value 256) This option causes the new process to inherit each
inheritable handle owned by the calling process. This
includes stdin, stdout, stderr, and other file
handles that the calling process has open.
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Note that because the called process inherits many open
files, it is vulnerable to running out of file handles.

This option is needed when an Alternate Terminal
Manager run-time calls C$SYSTEM to run a batch
program which in turn calls another Alternate Terminal
Manager run-time. Without this option, the called program
will not display any output to the screen.

Comments

The C$SYSTEM routine submits CMD-LINE to the host operating system as if it were a command keyed in
from the terminal. The maximum allowable length for the command line is 1024 bytes.

Note: Applications that run under Windows but that do not create their own windows should use the
CSYS-SHELL flag to execute .COM, .BAT, and built-in shell commands such as COPY and DIR.

You should specify only one window size flag (CSYS-MAXIMIZED, CSYS-MINIMIZED, CSYS-
COMPATIBILITY, or CSYS-HIDDEN). In the absence of any window size flag, the command runs in a
normal window whose size is determined by the operating system. Windows programs can set their own
window size. This will override the window size suggested by FLAGS. Essentially, the value of FLAGS is
only a suggestion to the application.

Options that are not meaningful to the host system are ignored. Meaningful options in the same FLAGS
setting are still applied.

The status of a call to C$SYSTEM is placed in EXIT-STATUS. This is usually the exit status of the executed
program, or is -1 if C$SYSTEM failed. Note that Windows will return 1 from commands that are built into
COMMAND.COM because COMMAND.COM does not return an exit status for built-in functions.

Compatibility Issues

• CYS-NO-IO (value 2) is ignored
• The following op-codes are Windows only: CSYS-MAXIMIZED (value 4), CSYS-MINIMIZED (value 8),

CSYS-HIDDEN (value 32), CSYS-SHELL (value 64), CSYS-INHERIT-HANDLES (value 256).
• CSYS-INHERIT-HANDLES (value 256) only has an effect when the program is run from the command

prompt.
• Thin client functionality is not supported in this COBOL system; therefore:

• "@[DISPLAY]" syntax is not supported.
• Flag CSYS-DESKTOP (value 128) is not supported.

C$TOUPPER and C$TOLOWER
These routines translate text to upper- or lower-case.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "C$TOUPPER" 
    USING TEXT-DATA, VALUE TEXT-LEN

CALL "C$TOLOWER" 
    USING TEXT-DATA, VALUE TEXT-LEN

Parameters

TEXT-DATA PIC X(n) Contains the data to translate to upper- or lower-case.
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TEXT-LEN USAGE UNSIGNED-INT, or a numeric literal Contains the number of characters to translate.

Description

C$TOUPPER translates the first TEXT-LEN characters in TEXT-DATA to upper-case. C$TOLOWER
translates them to lower-case. No size checking is done on TEXT-DATA, so you must ensure that TEXT-
LEN has a valid value. VALUE must be included in the calling statement. If it is omitted, the program will
very likely encounter memory errors. These routines only translate characters with a numeric value of
0-128. Anything above that (such as é, with a value of 130) must be mapped to its associated upper- or
lower-case character using the configuration variable UPPER-LOWER-MAP.

Compatibility Issues

• Calls to these routines immediately call the Micro Focus library routines CBL_TOUPPER and
CBL_TOLOWER.

I$IO
The I$IO routine provides an interface to the file handler.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

An operation code and some number of additional parameters (depending on the operation called) are
passed to the routine. The return code is set automatically after the call. The external variable F-ERRNO is
set according to any errors found. F-ERRNO may not be reset on entry to I$IO, and should be checked only
if I$IO returns an error condition.

Usage
CALL "I$IO" 
    USING OP-CODE, parameters

Parameters

• OP-CODE Numeric parameter

Specifies the file handling routine to be performed. This table shows which operation corresponds to
each operation code. The operations are detailed in the description below:

Code Operation

1 OPEN-FUNCTION

2 CLOSE-FUNCTION

3 MAKE-FUNCTION

4 INFO-FUNCTION

5 READ-FUNCTION

6 NEXT-FUNCTION

7 PREVIOUS-FUNCTION

8 START-FUNCTION

9 WRITE-FUNCTION

10 REWRITE-FUNCTION

11 DELETE-FUNCTION

12 UNLOCK-FUNCTION
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Code Operation

13 REMOVE-FUNCTION

14 SYNC-FUNCTION

15 EXECUTE-FUNCTION

16 BEGIN-FUNCTION

17 COMMIT-FUNCTION

18 ROLLBACK-FUNCTION

19 RECOVER-FUNCTION

21 IN-TRANSACTION-FUNCTION

• parameters vary depending on the op-code chosen

The remaining parameters vary depending on the operation selected. They provide information and
hold results for the operations specified. All parameters are passed by reference. Parameters may be
omitted from those operations that do not require them.

Description

All parameters passed to I$IO are passed by reference. This applies even to parameters that are integer
values in the corresponding file handling routines. All numeric parameters should be passed to I$IO as
SIGNED-SHORT values. The I$IO routine provides any necessary addressing conversions. Note that a
parameter must be in the correct format for its type. Parameters that are PIC X must be terminated by a
LOW-VALUES character.

Except for the MAKE function, I$IO will automatically terminate any PIC X parameters with a LOW-
VALUES byte for you. Also, you do not have to specify SYNC for level 01 or level 77 parameters because
they are automatically synchronized by ACUCOBOL-GT.

The file filesys.def is a COBOL COPY file that contains many useful definitions for use with I$IO. It
contains definitions for the I$IO codes along with the F-ERRNO error values and many useful pre-declared
variables that are of the proper type and usage.

The behavior of this routine is affected by the FILENAME_SPACES configuration variable. The value of
FILENAME_SPACES determines whether spaces are allowed in a file name.

Note: The run-time system configuration variable FILE_PREFIX is ignored by the I$IO routine.

Compatibility Issues

• filesys.def is not supplied in this COBOL system.
• The FILENAME_SPACES configuration variable is not supported in this COBOL system.

M$ALLOC (Dynamic Memory Routine)
Allocates a new area of dynamic memory.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "M$ALLOC" 
    USING ITEM-SIZE, MEM-ADDRESS
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Parameters

ITEM-SIZE Numeric parameter This indicates the number of bytes to allocate. This must
be greater than zero.

MEM-ADDRESS USAGE POINTER This holds the return value, either the address of the
allocated memory or NULL if the allocation fails.

Comments

The maximum amount of memory you may allocate in one call depends on the host machine, but is at least
65260 bytes for all machines (providing that much memory is available). M$ALLOC adds some overhead to
each memory block allocated. This ranges between 4 and 16 bytes depending on the machine
architecture. Also, each operating system will typically add its own overhead. The debugger's U command
reports the amount of memory you have currently allocated via M$ALLOC. The overhead added by M
$ALLOC is included in the total shown, but the operating system's overhead is not. Memory allocated by M
$ALLOC is initialized to binary zeros (LOW VALUES).

If you try to allocate more memory than the environment can give you, M$ALLOC will return NULL, and no
memory will be allocated.

Compatibility Issues

None.

M$COPY (Dynamic Memory Routine)
Copies a region of memory from one location to another.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "M$COPY" 
    USING DEST-PTR, SRC-PTR, NUM-BYTES

Parameters

DEST-PTR USAGE POINTER Contains the address of the first byte of the destination
region.

SRC-PTR USAGE POINTER Contains the address of the first byte of the source
region.

NUM-BYTES Numeric parameter Indicates the size of the memory region to be copied.

Description

This routine copies NUM-BYTES from the address contained in SRC-PTR to the address contained in
DEST-PTR. Note that this routine is relatively dangerous to use. No boundary checking is performed to
ensure that the address range is valid, so memory access violations may result if you pass it incorrect data.

This routine is functionally similar to the C$MEMCOPY routine except that parameters are passed by
reference instead of by value. For example, you can copy 10 bytes to DEST-PTR from the memory address
contained in SRC-PTR with:

     CALL "M$COPY" 
        USING DEST-PTR, SRC-PTR, 10

Compatibility Issues

None.
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M$FILL (Dynamic Memory Routine)
Sets a region of memory to a constant value.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "M$FILL" 
    USING DEST-PTR, BYTE-VALUE, NUM-BYTES

Parameters

DEST-PTR USAGE POINTER Contains the address of the first byte of the region to be
filled.

BYTE-VALUE Alpha-numeric parameter Contains the value with which to fill the memory region.

NUM-BYTES Numeric parameter Indicates the size of the memory region.

Description

This routine fills NUM-BYTES with BYTE-VALUE starting at address DEST-PTR. The parameters are
passed BY REFERENCE. This routine does not do any boundary checking to make sure that the address
range is valid.

Compatibility Issues

None.

M$FREE (Dynamic Memory Routine)
Frees a previously allocated piece of memory.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "M$FREE" 
    USING MEM-ADDRESS

Parameter

MEM-ADDRESS USAGE POINTER Must point to a memory area previously allocated by M
$ALLOC.

Comments

Use M$FREE to release a memory block allocated by M$ALLOC. This memory is returned to the pool of
memory available for use by the run-time system. On most operating systems, this memory is still
associated with the run-time system's process, so it cannot be used by any other processes. On a few
systems, this memory may be made available to the operating system for re-use by other processes.

It is an error to attempt to use a block of memory once it has been freed. It is also an error to free a block of
memory more than once or to free a memory address that has never been allocated. Any of these errors
can lead to memory access violations. The run-time system attempts to detect these errors and avoid
them, but it cannot detect all such errors.

Compatibility Issues

None.
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M$GET (Dynamic Memory Routine)
Retrieves data from an allocated memory block.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "M$GET" 
    USING MEM-ADDRESS, DATA-ITEM, DATA-SIZE, DATA-OFFSET

Parameters

MEM-ADDRESS USAGE POINTER Must point to a memory area previously allocated by M
$ALLOC.

DATA-ITEM Any data item Data from the memory block will be stored in this item.

DATA-SIZE Numeric parameter (optional) The number of bytes to move from the memory block. If
omitted, then the number of bytes is set to the size of the
memory block (excluding overhead bytes).

DATA-OFFSET Numeric parameter (optional) The location within the memory block from which to start
the move. The first location is position 1. If omitted, this
value defaults to 1.

Description

This routine retrieves data from the memory block at MEM-ADDRESS and stores it in DATA-ITEM.
Regardless of the value of DATA-SIZE, no bytes are copied from past the end of the memory block. Note
that the size of DATA-ITEM is not checked.

Compatibility Issues

None.

M$PUT (Dynamic Memory Routine)
Stores data in an allocated memory block.

Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

Usage
CALL "M$PUT" 
    USING MEM-ADDRESS, DATA-ITEM, DATA-SIZE, DATA-OFFSET

Parameters

MEM-ADDRESS USAGE POINTER Must point to a memory area previously allocated by M
$ALLOC.

DATA-ITEM Any data item This is the data that will be stored in the memory block.

DATA-SIZE Numeric parameter (optional) The number of bytes to move to the memory block. If
omitted, then the number of bytes is set to the size of the
memory block (excluding overhead bytes).

DATA-OFFSET PIC 9(n), USAGE DISPLAY or COMP-4
(optional)

The location within the memory block from which to start
the move. The first location is position 1. If omitted, this
value defaults to 1.
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Description

This routine copies DATA-ITEM into the memory pointed to by MEM-ADDRESS for DATA-SIZE bytes.
Regardless of the value of DATA-SIZE, no bytes are copied that exceed the size of the memory block at
MEM-ADDRESS.

Compatibility Issues

None.

RENAME
Renames a file.

Syntax:
CALL "RENAME"
   USING source-file, dest-file, [status,] [file-type]
   

Parameters:
source-file

PIC X(n)

dest-file
PIC X(n)

status
Any numeric type

file-type
PIC X

On Entry:
source-file

The path name of the file to be copied

dest-file
The path name of the destination file

file-type
The file organization of the source file. It must be one of: S (for sequential), R (for relative)
or I (for indexed).

This defaults to S if not specified.

On Exit:
status

Returns zero if the rename is successful, or non-zero if not.

Comments:

To obtain an extended file status code for this operation, define status as comp xx comp-x and follow the
example in Extended File Status Codes.

WIN$VERSION
Returns version information for Windows and Windows NT host platforms.
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Note: This ACUCOBOL-GT library routine is available in this COBOL version. Any compatibility
issues in this COBOL system are in the Compatibility Issues section at the end of the topic.

This routine provides more information about the system than is returned by the ACCEPT FROM
SYSTEM-INFO statement.

Usage
CALL "WIN$VERSION" 
    USING WINVERSION-DATA

Parameters

WINVERSION-DATA Group item as follows: 01  WINVERSION-DATA. 
    03  WIN-MAJOR-VERSION     PIC X 
COMP-X. 
    03  WIN-MINOR-VERSION     PIC X 
COMP-X. 
    03  WIN-PLATFORM          PIC X 
COMP-X. 
        88  PLATFORM-WIN-31   VALUE 
1. 
        88  PLATFORM-WIN-95   VALUE 
2. 
        88  PLATFORM-WIN-9X   VALUE 
2. 
        88  PLATFORM-WIN-NT   VALUE 
3. 
    03  WIN-WORDSIZE          PIC X 
COMP-X. 
        88  WIN-WORDSIZE-16   VALUE 
1. 
        88  WIN-WORDSIZE-32   VALUE 
2. 
        88  WIN-WORDSIZE-64   VALUE 
3. 
    03  WIN-
BUILDNUMBER                 PIC X(4) 
COMP-X. 
    03  WIN-
CSDVERSION                  PIC 
X(128). 
    03  WIN-SERVICEPACK-
MAJOR           PIC X COMP-X. 
    03  WIN-SERVICEPACK-
MINOR           PIC X COMP-X. 
    03  WIN-
SUITEMASK                   PIC X(4) 
COMP-X. 
    03  WIN-
PRODUCTTYPE                 PIC X 
COMP-X. 
        88 WIN-NT-
WORKSTATION           VALUE 1. 
        88 WIN-NT-DOMAIN-
CONTROLLER     VALUE 2. 
        88 WIN-NT-
SERVER                VALUE 3. 

WINVERSION-DATA is found in the COPY library
winvers.def.
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Comments

Upon return from WIN$VERSION, all of the data elements contained in WINVERSION-DATA are filled in. If
you call WIN$VERSION and the host machine is not a Windows or Windows NT system, the fields are set
to zero.

The following list provides a description of each WINVERSION-DATA field. For a list of possible values for
any given field, see the Microsoft operating-system-version Web page.

• WIN-MAJOR-VERSION - The major version number reported by Windows.
• WIN-MINOR-VERSION - The minor version number reported by Windows.
• WIN-PLATFORM - Provides a general description of the host system. If the host is Windows NT/

Windows 2000, the value is set to PLATFORM-WIN-NT. If the host is Windows 98, the value is set to
PLATFORM-WIN-9X.

• WIN-WORDSIZE - This item is set to WIN-WORDSIZE-32 for a 32-bit operating system, and WIN-
WORDSIZE-64 for a 64-bit operating system.

• WIN-BUILDNUMBER - Identifies the build number of the operating system.
• WIN-CSDVERSION - Indicates the latest Service Pack installed on the system. If no Service Pack has

been installed the string is empty.
• WIN-SERVICEPACK-MAJOR - Indicates the major version number of the latest Service Pack installed on

the system. If no Service Pack has been installed the value is 0.
• WIN-SERVICEPACK-MINOR - Indicates the minor version number of the latest Service Pack installed on

the system. If no Service Pack has been installed the value is 0.
• WIN-SUITEMASK - This is a bit mask that identifies the product suites available on the system.
• WIN-PRODUCTTTYPE - Identifies additional information about the system.

Compatibility Issues

The copybook winvers.def is not available in this COBOL system.

The following fields are not supported in this COBOL system:

• WIN-BUILDNUMBER

• WIN-CSDVERSION

• WIN-SERVICEPACK-MAJOR

• WIN-SERVICEPACK-MINOR

• WIN-SUITEMASK

• WIN-PRODUCTTTYPE

These fields will return spaces or zeroes, as appropriate.

ACUCOBOL-GT Windowing Syntax
Your COBOL system provides some support for ACUCOBOL-GT windowing syntax that enables you to
draw lines and boxes on the terminal screen, and create virtual terminal windows on a physical terminal. All
ACCEPT and DISPLAY statements then act within the current window (except for ACCEPT format 1, 2, or
3 statements, DISPLAY format 1 statements, and DISPLAY WINDOW/LINE/BOX statements). The syntax
also enables underlying displays to be kept and restored.

Note: This functionality is supported in native COBOL only.

Windowing Syntax Summary

Your COBOL system includes the following syntax to support windowing:

• BEFORE TIME phrase in ACCEPT statement
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Format 5 of the ACCEPT statement has the BEFORE TIME phrase, which enables you to specify a
timeout period. If the user does not enter data during this period, the statement is terminated
automatically.

• DISPLAY WINDOW

DISPLAY WINDOW creates a terminal window (a rectangular region of the screen) and makes it the
current window. This is like a virtual terminal, in which screen positions used by subsequent ACCEPT/
DISPLAY statements are relative to the top left corner of the window.

• DISPLAY LINE

DISPLAY LINE enables you to draw lines on the terminal (real or virtual). The best mode available on
the terminal is used automatically. Used with the DISPLAY BOX statement, the DISPLAY LINE
statement enables you to draw forms on the terminal.

• DISPLAY BOX

DISPLAY BOX enables you to draw boxes on the terminal. The best mode available on the terminal is
used automatically. Used with the DISPLAY LINE statement, the DISPLAY BOX statement enables you
to draw forms on the terminal.

• CLOSE WINDOW

CLOSE WINDOW removes a window. If you specify the window as being a POP-UP window, the
underlying display can be restored.

Enabling Windowing Support

In order to use the windowing syntax, you must use the PREPROCESS"window1" Compiler directive.

You can specify this directive in one of two ways.

• In your source file, use the following line:

$SET preprocess"window1"

• From the command line, include the PREPROCESS"window1" directive:

cobol prog.cbl preprocess"window1" color endp;

The PREPROCESS "window1" directive must be the last Compiler directive apart from NOERRQ,
AUTOCLOSE or COLOR. If an error is encountered, the Compiler asks if you wish to continue, and waits
for your response. In order to disable this function, you must specify the NOERRQ directive after
PREPROCESS"window1".

Windowing Support Syntax

The following sections give details of the windowing syntax enabled by the PREPROCESS"window1"
directive.

The ACCEPT Statement

BEFORE TIME time-out

General Rules:

1. The BEFORE TIME phrase allows you to automatically terminate an ACCEPT statement after a certain
amount of time has passed. The timeout value specifies the time to wait in hundredths of a second. For
example, "BEFORE TIME 500" specifies a timer value of 5 seconds.

2. The user must enter data to the ACCEPT statement before the timer elapses. As soon as the user
starts entering data, the timer is canceled and the user may take as much time as desired to complete
the entry. If the user does not enter any data before the timer elapses, then the ACCEPT statement
terminates.
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The CLOSE WINDOW Statement

Format:
CLOSE WINDOW window-save-area

Syntax Rules:

1. window-save-area must be an elementary data item described with a PIC X(10) clause. It must have
been the object of a POP-UP AREA phrase in a DISPLAY WINDOW statement.

General Rules:

1. The CLOSE WINDOW statement is used to remove popup windows created by the POP-UP AREA
option of the DISPLAY WINDOW statement.

2. window-save-area must have been the object of a POP-UP phrase of a DISPLAY WINDOW statement
that has been executed in this run unit. Furthermore, since that execution, it must not have been the
object of a CLOSE WINDOW statement, nor can it have been modified by any other statement.
Violation of these rules causes undefined results.

3. The CLOSE WINDOW statement restores the contents of the terminal screen that was in the active
window when the corresponding DISPLAY WINDOW statement executed. In other words, the window
that was created by that DISPLAY WINDOW statement is removed from the screen and replaced by the
contents of the screen which were under that popup window.

4. The window that was active when the corresponding DISPLAY WINDOW statement executed becomes
the active window, thereby becoming the top window and overlaying any other windows that might be
present.

Comments:

The current window is selected by closing windows identified by their respective window-save-area data
items, as in the following example:

If five popup windows are created, a, b, c, d and e in that order:

• If d is closed, c becomes current.
• If b is then closed, a becomes current.
• If e is subsequently closed, c becomes current again.

The DISPLAY Statement

Format: for Format 1
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Format: for Format 2
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Format: for Format 3

 

 

Syntax Rules:

1. line-num is a numeric literal or data item that specifies the line position on the terminal screen. It must
be a non-negative integer.

2. col-num is a numeric literal or data item that specifies the column position on the terminal screen. It
must be a non-negative integer.
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3. length is a numeric literal or data item that specifies the window-width, line-width or box-width in
character positions. It must be a non-negative integer.

4. height is a numeric literal or data item that specifies the number of lines in the window, line or box. It
must be a non-negative integer.

5. title is a non-numeric literal or alphanumeric data item.
6. save-area is an elementary data item described by a PIC X(10) clause.
7. COLUMN and COL are equivalent.
8. REVERSE and REVERSED and REVERSE-VIDEO are equivalent.
9. The COLOR phrase is supported only when the preprocessor directive COLOR is used. This adds

support for existing non-Micro Focus syntax.
10.Exactly one of the SIZE or LINES phrases must be specified for a Format 2 DISPLAY statement.
11.identifier-1, identifier-2, integer-1 and integer-2 must take a value in the range 0 through 7 as follows:

0 black

1 blue

2 green

3 cyan

4 red

5 magenta

6 brown or yellow

7 white

12.identifier-3 and integer-3 must take a value which is obtained by adding together the appropriate values
from the following:

Color Foreground Background

Black 1 32

Blue 2 64

Green 3 96

Cyan 4 128

Red 5 160

Magenta 6 192

Brown 7 224

White 8 25

Note:

The foreground color values for use with the COLOR phrase are different from the standard Micro Focus
color values for FOREGROUND-COLOR, BACKGROUND-COLOR and so on.

In addition you can specify the following video attributes with the following values:

Reverse video 1024

Low intensity 2048

High intensity 4096

Underline 8192
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Blink 16384

13.If a COLOR phrase is present at the same time as FOREGROUND-COLOR and/or BACKGROUND-
COLOR, then the colors defined in the COLOR phrase are ignored, but any non-color attributes are
actioned (where appropriate).

General Rules: for All Formats

1. The LINE and COLUMN phrases must specify a line or column on the physical screen.
2. On color systems, both the settings given in COLOR or FOREGROUND-COLOR and BACKGROUND-

COLOR and other attribute settings (for example blink) are used. On monochrome systems, all color
information supplied is ignored, and only other attribute settings used.

3. Not all combinations of attributes are supported on all systems. For example, on a standard DOS PC,
set to monochrome mode, REVERSE and UNDERLINE are mutually exclusive - only one of these
attributes is actioned.

General Rules: for DISPLAY WINDOW statement Format 1 (DISPLAY WINDOW)

1. The DISPLAY WINDOW statement creates and makes current a terminal window. The terminal window
is a rectangular region of your screen. Any ACCEPT or DISPLAY statements (apart from another
DISPLAY WINDOW/LINE/BOX or a Format 1, 2 or 3 ACCEPT or Format 1 DISPLAY as described in
your Language Reference) affect only the current window. Furthermore, line and column numbers for all
ACCEPT and DISPLAY statements (apart from another DISPLAY WINDOW/LINE/BOX or a Format 1, 2
or 3 ACCEPT or Format 1 DISPLAY as described in your Language Reference) are computed from the
upper left-hand corner of the current window. That is, the current window defines a virtual terminal
screen which occupies some area of your physical screen.

2. The initial window is set to the entire screen.
3. The only way to change the current window is with another DISPLAY WINDOW statement or with the

CLOSE WINDOW statement.
4. The LINE NUMBER phrase sets the top line of the window. Line number one refers to the top line of the

screen. Line numbers are relative to the screen, and not to the current window.
5. If the LINE NUMBER phrase is not specified, is specified as zero, or is off the physical screen, the top

line of the screen is used.
6. The COLUMN NUMBER phrase sets the left-most column of the window. Column number one refers to

the left side of the screen. Column numbers are relative to the screen, and not to the current window.
7. If the COLUMN NUMBER phrase is not specified, is specified as zero, or is off the physical screen,

column number one is used.
8. The SIZE phrase sets the number of columns the window contains. If this causes the window to extend

past the right edge of the screen, the window's width extends off the screen.
9. If the SIZE phrase is not specified or is specified as zero, the window extends to the right edge of the

screen.
10.The LINES phrase sets the number of rows the window contains. If this causes the window to extend

past the bottom of the screen, the window extends off the screen.
11.If the LINES phrase is not specified or is specified as zero, the window extends to the bottom edge of

the screen.
12.When the ERASE phrase is specified, the window is cleared immediately after it is created. Otherwise

the window's contents are not changed. Clearing a window sets it to spaces.
13.The BOXED phrase causes a box to be drawn around the new window. The box is drawn outside the

window. Any portions of the box that lie off the screen are not drawn.
14.The terminal's line drawing set is used to draw the box. If the terminal does not have a line drawing set,

equivalent ASCII characters are used. If the POP-UP phrase is also specified, the box overlays any
other boxes on the screen. If this phrase is not specified, the box drawn is attached to any other boxes it
intersects. When a boxed non-popup window intersects a boxed popup window, if the popup window is
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created first, when it is closed the points where the two window boxes intersected is not redrawn. That
is, intersection characters remain even though there is no longer an intersection.

15.The ERASE phrase is implied by the BOXED phrase.
16.The REVERSED phrase exchanges the window's foreground and background colors. This affects every

ACCEPT and DISPLAY statement in the new window.
17.The REVERSED phrase implies the ERASE phrase. This usually causes the entire window to be set to

reverse video spaces when it is initially created.
18.The SHADOW phrase causes the window to appear to float over the screen giving a three-dimensional

effect.
19.If the color value for either foreground or background is set to 0 in the COLOR field, then the

corresponding color of the default system attribute is used.
20.The TITLE phrase causes the title to be printed in the window's border. This has its effect only if the

BOXED phrase is also specified.
21.Titles can be placed in one of six positions in the border region: top left, top center, top right, bottom left,

bottom center and bottom right. If TOP or BOTTOM is not specified, TOP is used. If LEFT, CENTERED
or RIGHT is not specified, CENTERED is used.

22.The NO SCROLL phrase is treated as documentary only; the Windows preprocessor displays a
message confirming this.

23.The NO WRAP phrase is treated as documentary only; the Windows preprocessor displays a message
confirming this.

24.The POP-UP AREA phrase causes your COBOL system to save system information prior to creating
the new window. This information can be used by the CLOSE WINDOW statement to subsequently
remove the new window and restore the underlying windows. This gives a popup window.

25.The save-area data item is filled in with system information. This data item must not be subsequently
modified in any way or results are undefined. It can be referenced in a CLOSE WINDOW statement to
restore an earlier window to the screen and re-establish that window as the current window.

General Rules: for DISPLAY LINE statement Format 2 (DISPLAY LINE)

1. The DISPLAY LINE statement enables you to draw vertical and horizontal lines in a machine- and
terminal-independent manner. The lines are drawn using the best mode available on the display device.
Used together with the DISPLAY BOX statement, this provides the ability to draw forms on your screen.
The DISPLAY LINE statement does not affect the positioning of full screen ACCEPT and DISPLAY
statements.

2. Lines are drawn so that when they intersect other lines on the screen, the appropriate intersection
character is used. This is done so that when the end of a line intersects another line, the appropriate
corner or three-way intersection is used.

3. If the SIZE phrase is specified, the line drawn is horizontal. The value of length gives the size of the line
in screen columns. If the LINES phrase is used instead, the line drawn is a vertical line and height
describes the number of screen rows to use.

4. Lines never wrap around or cause scrolling. If the LINES or SIZE phrase would cause the line to leave
the current window, the line is truncated at the edge of the window. If LINES or SIZE is zero, no line is
drawn.

5. The value of line-num gives the starting row of the line. The value of col-num gives the starting column.
Lines are always drawn to the right or downward as appropriate. line-num and col-num must specify a
position that is contained in the current window.

6. If the LINE NUMBER or COLUMN NUMBER phrases specify a point outside the physical screen, that
is, line-num = 0 or 24 (or your screen's maximum), or col-num = 0 or > 80, no line is drawn.

7. The TITLE phrase has effect only when drawing horizontal lines. When specified, title-string is printed in
part of the line.

8. The title can be printed near the right side, near the left side or in the center of the line depending on
the RIGHT, LEFT or CENTERED phrase specified. If none is specified, CENTERED is used.

104 | Upgrading to Enterprise Developer



9. The REVERSE phrase exchanges the foreground and background color of the line.

General Rules: for DISPLAY BOX statement Format 3 (DISPLAY BOX)

1. The DISPLAY BOX statement enables you to draw a box in a machine- and terminal-independent
manner. The boxes are drawn using the best mode available on the display device. If the lines used in
drawing a box intersect other lines already present on the screen, the appropriate intersection
characters are used. The DISPLAY BOX statement does not affect the positioning of full screen
ACCEPT and DISPLAY statements.

2. The location of the box is specified by providing the location of the upper-left corner. The size of the box
is specified by providing a height and a width.

3. If the LINE NUMBER or COLUMN NUMBER phrases specify a point outside the physical screen no box
is drawn.

4. The SIZE phrase specifies the width of the box. The LINES phrase specifies its height. If the SIZE
phrase is not specified, or zero, or such that the box would extend beyond the physical screen or the
edge of the window, the box extends to the right edge of the current window. If the LINES phrase is not
specified, or zero, or such that the box would extend beyond the physical screen, the box extends to the
bottom of the current window.

5. The REVERSE phrase operates in the same manner as it does for a DISPLAY WINDOW statement.
6. The TITLE phrase operates in the same manner as it does for the DISPLAY WINDOW statement.

Windowing Restrictions

• This feature is not guaranteed to be intermediate code compatible, so you might need to recompile your
source code between product releases.

• When using the ACCEPT or DISPLAY statements with this windowing syntax, you must include the AT
LINE NUMBER syntax (see your Language Reference) or items do not appear in the windows.

• You should not use cobprintf() with these DISPLAY statements.
• You should not use COPY REPLACING or REPLACE statements.
• The windowing syntax is supported only for fixed format COBOL source.
• The following reserved words have been introduced by the windowing syntax, so you should avoid

specifying them as user-defined words:

BOX BOXED CENTERED COLOR (if COLOR directive used) POP-UP SCROLLSHADOW WINDOW
WRAP

• You should use only the ACCEPT and DISPLAY statements documented in your Language Reference
with this windowing syntax.

• When using windowing syntax, the ANS85 Compiler directive is implied. You must not unset this
directive either explicitly or implicitly.

• Alphanumeric literals must not be continued over the end of any line which includes a windowing
statement.

• Some syntax errors, for example, spelling PROCEDURE DIVISION incorrectly, are flagged, but might
result in spurious error messages for following source lines.

• Windowing syntax errors are serious errors, but are flagged in the form:

 xnnn-P******* 

• The -P cob flag should not be used with windowing syntax . You should instead use "-C list".
• Column 73 must not be used within source programs which use windowing syntax, as this column is

always treated as being set to a space character.
• The Compiler asks if you wish to continue after any error occurs. You can disable this function by using

the NOERRQ directive. You should not, however, use the NOERRQ directive when compiling from
within the Development Environment.

If no error occurred, or if an error occurred but you replied "no" to the question "do you wish to
continue", the Compiler returns a zero error return code.
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• Each of the following statements must appear on a line by itself:

DISPLAY WINDOW DISPLAY BOX DISPLAY LINE CLOSE WINDOW EXIT PROGRAM
• The windowing subsystem is initialized automatically upon encountering the first windowing statement.
• If an application switches between using windowing syntax and other types of Accept/Display syntax, it

must close down the windowing system completely before starting to use other types of Accept/Display
syntax; otherwise the ACCEPT and DISPLAY statements may not have the desired effects.

You can create a subroutine to explicitly close the windowing system by compiling the following
subprogram:

$set preprocess "window1" autoclose
procedure division
para-1.
exit program.

You then call this subprogram before switching to another type of Accept/Display syntax. The
AUTOCLOSE preprocessor directive causes the EXIT PROGRAM statement to close down the
windowing system before exiting the subprogram. The windowing subsystem is reinitialized upon
encountering another windowing statement. Each time the windowing subsystem initializes, the
background screen and contents are redisplayed.

• When a window is active, or has been active in the run unit, use of the DISPLAY SPACES UPON CRT
statement clears the window to spaces but leaves attributes unchanged.

ACUCOBOL-GT Windowing Error Messages

The following errors might be encountered during preprocessing.

Unexpected numeric literal

Unexpected alphanumeric literal

Unsupported keyword or noise word

Unrecognized clause to DISPLAY WINDOW

Unrecognized clause to DISPLAY LINE

Unrecognized clause to DISPLAY BOX

Unrecognized clause to ACCEPT FROM SCREEN

This keyword has already been used

This keyword conflicts with another

This reserved word is used incorrectly

Wrongly formed or ordered clause with keyword

Error during preprocessing - no further details

Unknown COPY file specified

WINDOW1 preprocessor cannot handle free format

SCROLL/WRAP clause processed as comment The edit/compile/animate loop returns to an
incorrect line within your source program after
returning an error.

Windowing Supplementary Information

When the first windowing statement in your program is encountered the screen is redisplayed. This is
expected behavior and does not affect your program in any way.
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Upgrading from RM/COBOL®

There are a number of settings in Enterprise Developer that are designed specifically to ensure that your
existing RM/COBOL source code can compile and run in Enterprise Developer.

Refer to the Compatibility with RM/COBOL section for guidance and best practice on moving your
applications to Enterprise Developer. It covers:

• Supported RM/COBOL features, including detailed information on support for data types and
subprograms.

• Syntactical differences between the two COBOL dialects, including workarounds or equivalent syntax
where applicable.

• Details on how to configure your applications to continue using your RM/COBOL data files.

Compatibility with RM/COBOL
Enterprise Developer provides compatibility with the RM/COBOL programming language, enabling you to
migrate RM/COBOL programs to this COBOL environment.

You can:

• Convert applications written in RM/COBOL to the Micro Focus COBOL language, and enhance them
using the advanced language and development features offered by Enterprise Developer.

• Retain the use of the selected COBOL on some machine environments while moving to Enterprise
Developer on others. You might want to maintain a common set of source programs which are suitable
for all environments.

A COBOL dialect setting (DIALECT"RM") provides most of the compatibility required to migrate; however, it
should only be used in a native COBOL environment.

Note: Any error messages and numbers that are returned when you compile your program in
Enterprise Developer or when you execute the resulting code are different in the two environments.
This should present no problems, but is something of which you should be aware.

Converting RM/COBOL Applications
By default, this COBOL system already supports much of the RM/COBOL syntax and behavior. Additional
RM/COBOL-specific syntax that has been added for compatibility is documented in the section RM/COBOL
Syntax Support in your Language Reference.

You can also enable additional RM/COBOL behavior using certain Compiler directives. Using these
directives when you submit your RM/COBOL source programs to this COBOL system ensures that most of
the programs are accepted the first time they are submitted; however, they are only intended for use in a
native COBOL environment. There are still certain compatibility issues between the two COBOL systems,
which are detailed, with any possible work-arounds, in the RM/COBOL Conversion Issues section.

Configuring Your Application for Visual Studio
As an RM/COBOL user, you can modernize your applications for Enterprise Developer by using the
DIALECT"RM" Compiler directive, which enables compilation and run-time behavior highly compatible with
RM/COBOL.

Note: If your RM/COBOL source code uses RM/Panels syntax, refer to the RM/Panels Conversion
Example for your IDE instead.

This tutorial demonstrates migrating your RM/COBOL source code to Enterprise Developer using the
Visual Studio IDE. It takes you through creating a new project, setting the appropriate Compiler directives,
importing the RM/COBOL source into the project, and then building it.
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The modernization process utilizes the Micro Focus enhanced ACCEPT/DISPLAY syntax run-time support
module (Adis) to emulate some of the behaviors expected in RM/COBOL.

Create a Native Enterprise Developer Project

The first task is to create a project. Visual Studio uses the concept of a 'solution' to hold one or more
related projects. Unless you specify an existing solution when creating a project, a new one is created for
you.

1. In Visual Studio, create a new project by clicking File > New > Project. 

The New Project dialog box appears.

2. Expand Installed > COBOL.

3. Select Native.

4. From the list of project types, select Micro Focus INT/GNT. 

Alternatively, select Console Application to create a native command line application, or select Link
Library to create a library usable by other applications.

5. In the Name field, specify a name for the project.

6. In the Location field, specify a location for the project.

7. Click OK. 

The project is created within a solution of the same name, and then opened, ready to edit. The next task
is to edit the project properties.

Set the DIALECT"RM" Compiler Directive for the Project

Set the DIALECT"RM" directive in the project's properties so that it applies to all programs within the
project unless you explicitly override it at the program level.

1. In Solution Explorer, double-click Properties, which is listed under the name of the project you created
in the previous step. 

A tabbed list of properties for the project appears.

2. Select COBOL. 

The COBOL-specific project properties pane appears.

3. In the COBOL dialect field, select RM/COBOL.

Tip: If the project contains any variable or literal names that are considered reserved words, you
can use the REMOVE Compiler directive to remove them from the reserved words list, thus
allowing them to be used in the code: in Additional Directives, type REMOVE"<reserved-
word>". Repeat this directive, separated by a space, for each <reserved-word>. If you are
required to remove a number of reserved words, you could store each REMOVE directive in a
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directives file (e.g. rsvdwrds.dir), and then use the USE"rsvdwrds.dir" directive to apply the
directives all at once. This method is ideal if you need to remove the same reserved words from
more than one project.

4. Click File > Save All to save the project. 

The RM/COBOL dialect is applied to any program within the project, unless that program overrides it by
setting the DIALECT directive explicitly within the source code.

The next task is to add some RM/COBOL source code to the project.

Import your RM/COBOL Source Code
Import one or more of your source files into the project.

Note: You may use your own source code, but for this tutorial we are going to use the sample RM/
COBOL program listed in Appendix A - RM/COBOL source file.

1. Open a plain-text editor, copy and paste the sample code in Appendix A - RM/COBOL source file into a
new document.

2. Save the file with a .cbl extension.

3. In Solution Explorer, right-click the project name and select Add > Existing Item.

4. Browse to the file that you created in the previous steps, select it, then click Add. 

Note: If the file is not displayed, to the right of the File name field, change the file type filter to display All Files (*.*).

The file is added to the project, and is displayed in the Solution Explorer.

Tip: You can drag the file into the project from Windows Explorer, and drop it on the project name
to add it directly to the project.

5. Click File > Save All to save the project.

The next task is to add some configuration files to the project.

Add Adis Support to the Project
Add Adis support to your project to alter the default behavior of the enhanced ACCEPT and DISPLAY
statements in Micro Focus COBOL.

Enterprise Developer ships with a version of Adis that contains a configuration intended for modernizing
RM/COBOL applications.

1. In Solution Explorer, right-click the project name and select Add > Existing Item.

2. Browse to %COBDIR%\etc, then double-click ADISCTRL. 

Note: If the file is not displayed, to the right of the File name field, change the file type filter to display All Files (*.*).
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The file is added to the project, and is displayed in the Solution Explorer.

Tip: You can drag the file into the project from Windows Explorer, and drop it on the project name
to add it directly to the project.

3. To select the correct Adis configuration:

a) Using an  Enterprise Developer command prompt, navigate to the project directory (that is, the
directory containing ADISCTRL).

b) Enter ADISCF. 

The adiscf.exe window appears.
c) Press F6, then select the RM2VCOB configuration. 

See Appendix B - ADISCTRL settings for RM2VCOB, Appendix C - Adis key mappings for
RM2VCOB, and Appendix D - Adis key function mapping for RM2VCOB for a full list of the settings.

d) Press Esc twice to exit. 

Note: if you are prompted to exit without saving, press N, F4, then Esc twice again.

4. To verify the correct build properties are set for Adis:

a) In Solution Explorer, right-click ADISCTRL and select Properties. 

The properties for the file appear in the Properties pane.
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b) Ensure that: 
• Build Action is set to None.
• Copy to Output Directory is set to Copy if newer.

5. Click File > Save All to save the project.

Note: If you need to configure the keyboard keys for this environment, see Keyboard Configuration
Utility (Keybcf).

The next step is to compile the project and run the application.

Build and Run the Project
Build the project(s) within the solution and then run the application.
1. Click Build > Build Solution. 

The Application Output window displays information about the progress of the build result.

The build checks for any files that have changed and does two things:
• Compiles any files affected by the changes.
• Relinks the built files if necessary.
If there are any problems, they are displayed in the Error List window. Double-click an entry to jump to
the particular area of the code in error.

2. Press F5 to run the application. 

The following appears:
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3. Press any key to end the application.

This concludes the tutorial in which we have created an Enterprise Developer project, configured it to be
highly compatible with RM/COBOL source code, and then run a small RM/COBOL program.

Appendices

Appendix A - RM/COBOL Source File
If you do not want to test the conversion process using one of your RM/COBOL source files, you can use
the source listed in this appendix.

       identification division.
       program-id. RmProgram1.
 
       environment division.
       configuration section.
 
       data division.
        Working-Storage section.
        01 singleChar  PIC X.
 
       PROCEDURE DIVISION.
 
       Main.
       
           DISPLAY "Simple Display Tests in RM" ERASE  
           DISPLAY "ABC FCOLOR BLUE" AT 0203 CONTROL "FCOLOR=BLUE"  
           DISPLAY "ABC BCOLOR CYAN" AT 0304
                     CONTROL "BCOLOR=CYAN"
           DISPLAY "ABC FCOLOR MAGENTA" AT 0405
                     CONTROL "FCOLOR=MAGENTA"  
           DISPLAY "ABC FCOLOR GREEN"    AT 0506
                     CONTROL "FCOLOR=GREEN"    
           DISPLAY "ABC BCOLOR BROWN"   AT 0607
                     CONTROL "BCOLOR=BROWN"
           DISPLAY "Any Key to Continue..." AT 1002
                     CONTROL "BCOLOR=BLACK, FCOLOR=WHITE"  
                     
           ACCEPT singleChar at 1025.
           goback.
       end program RmProgram1.

Appendix B - ADISCTRL Settings for RM2VCOB

This is a complete list of the Adis options and settings for the RM2VCOB configuration used in the tutorial.
The settings in bold are the ones that differ from the default Adis configuration.

Setting
no.

Description Value

1 User function keys enable/disable - function keys are enabled. 2

2 Range of data keys accepted. 3

3 Prompt character. [_] x'5F'

4 Prompt character used in PIC G fields. [ iQ] x'8151'

5 Pre-display of fields before an accept - enables the predisplay of numeric-edited fields with
numeric editing when the cursor moves into them. No other predisplay occurs.

1

6 Accept in a SECURE field. 2

7 Auto-skip between fields. 2
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Setting
no.

Description Value

8 Termination of an accept - keying or retyping a data character in the last available character
position of an ACCEPT operation, provided auto-skip between fields is enabled.

3

9 Validation control if accept is terminated by a function key. 1

10 End of field effects - the cursor stays at the end of field, and overtyping is rejected. 2

11 Filed overflow buffers enable/disable - displaced data is not saved in an overflow buffer. 2

12 Auto-restore during backspace in replacement editing mode - RM backspace. Deleted
characters are removed and characters to the right are shifted left, same as when in
insertion editing mode.

3

13 Accepts into numeric edited fields - input is accepted as for alphanumeric fields and is
normalized to remove illegal characters on exit from the field.

1

14 Accepts in non-edited numeric fields - all non-edited numeric fields are treated as
alphanumeric fields.

3

15 Enable/disable auto-clear or pre-clear - pre-clear mode: the field is cleared to spaces or
zeroes. Pressing the Undo key does not restore the original contents of the field.

4

16 Force field to be updated if it is not altered - the data item is always updated even if the field
is not altered. This setting has effect only if the field is numeric or numeric-edited and the
original data item did not contain any numeric data, or if the field is right justified and the
original contents of the field were not.

2

17 Remembering where the end of field is - the enhanced ACCEPT/DISPLAY syntax notes the
position of the last character entered into a field during an ACCEPT operation. This setting
provides justification of RM-style numeric fields.

2

18 Rm style numeric data entry - the RM/COBOL 85 style of numeric and numeric-edited data
entry is enabled.

3

19 Restricting maximum field size to one line. 1

20 Control of cursor positioning after an accept - the cursor is left at its current position. 2

21 Control of whether UPDATE clauses perform implicit CONVERTs - the CONVERT clause is
implied.

2

22 Selection of the function key list to be used. 1

23 Select of the action for COLUMN + n clauses - a 'COLUMN + 1' clause leaves a one-
character gap between the two fields.

2

24 Selection of the default action if no color specified. 1

25 Control of whether cursor left/right keys can exit a field - the keys cannot exit a field. 2

26 left justification of free-format edited numerics - the field is left-justified, provided RM-
numeric handling is switched off. This is controlled by ACCEPT/DISPLAY option 18.

2

27 Validation control on FULL/REQUIRED fields. 1

28 Control of Adis keys defined as function keys. 2

29 Control of the read screen option for an accept. 1

30 Control of whether protected fields are skipped. 1

31 Control of special action for Kanji modifier characters. 1

32 Selection of the units used when calculating timeout. 1

33 Control of whether timeout is reset on each keystroke - the timer is reset each time a
character is entered.

2

34 Control of line feed before first DISPLAY on a screen. 2
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Appendix C - Adis Key Mappings for RM2VCOB

This is a complete list of the Adis key mappings for the RM2VCOB configuration used in the tutorial. The
settings in bold are the ones that differ from the default Adis configuration.

No. Function Setting No. Function Setting

0 Terminate accept Enabled 14 Backspace
character

Enabled

1 Terminate
program

Enabled 15 Retype character Disabled

2 Carriage Return Enabled 16 Insert single
character

Disabled

3 Cursor left Enabled 17 Delete character Enabled

4 Cursor right Enabled 18 Restore character Disabled

5 Cursor up Enabled 19 Clear to end of
field

Enabled

6 Cursor down Enabled 20 Clear field Enabled

7 Move to start of
screen

Enabled 21 Clear to end of
screen

Disabled

8 Move to next tab
stop

Enabled 22 Clear screen Disabled

9 Move to previous
tab stop

Enabled 23 Set insert mode Enabled

10 Move to end of
screen

Enabled 24 Set replace mode Enabled

11 Move to next field Enabled 25 Reset field (Undo) Disabled

12 Move to previous
field

Enabled 26 Move to start of
field

Function

13 Change case of
character

Disabled 27 Move to mouse
position

Disabled

Appendix D - Adis Key Function Mapping for RM2VCOB

This is a complete list of the Adis key function mappings for the RM2VCOB configuration used in the
tutorial. The settings in bold are the ones that differ from the default Adis configuration.

Function Mapped to

Number Name Validate Align Number Name

0 Terminate accept - - 255 Undefined

1 Terminate
program

Y N 1 Terminate
program

2 Carriage Return Y N 0 Terminate accept

3 Cursor left Y N 3 Cursor left

4 Cursor right Y N 4 Cursor right

5 Cursor up Y N 12 Move to
previous field
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Function Mapped to

Number Name Validate Align Number Name

6 Cursor down Y N 11 Move to next
field

7 Move to start of
screen

Y N 7 Move to start of
screen

8 Move to next tab
stop

Y N 11 Move to next field

9 Move to previous
tab stop

Y N 12 Move to previous
field

10 Move to end of
screen

Y N 10 Move to end of
screen

11 Move to next field - - 255 Undefined

12 Move to previous
field

- - 255 Undefined

13 Change case of
character

Y N 13 Change case of
character

14 Backspace
character

Y N 14 Backspace
character

15 Retype character Y N 15 Retype character

16 Insert single
character

Y N 16 Insert single
character

17 Delete character Y N 17 Delete character

18 Restore character Y N 18 Restore character

19 Clear to end of
field

Y N 19 Clear to end of
field

20 Clear field Y N 55 RM Clear Field

21 Clear to end of
screen

Y N 21 Clear to end of
screen

22 Clear screen Y N 22 Clear screen

23 Set insert mode Y N 58 Insert toggle

24 Set replace mode - - 255 Undefined

25 Reset field (Undo) Y N 21 Reset field
(Undo)

26 Move to start of
field

Y N 26 Move to start of
field

27 Move to mouse
position

Y N 27 Move to mouse
position

Compiler Directives for RM/COBOL Compatibility
You can set a number of Compiler directives in your RM/COBOL source programs that enable a program to
emulate RM/COBOL behavior.
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The main directive that sets the majority of RM/COBOL behavior is DIALECT"RM". Setting this directive
automatically sets additional Compiler directives; see the topic RM Dialect Settings for full details of the
directives set.

Previously, compatibility was achieved by compiling with the RM Compiler directive. The newer
DIALECT"RM" directive sets and extends the compatibility given by RM, but you should only use it in a
native COBOL environment. It is recommended that you use DIALECT"RM" for all new migrations from
RM/COBOL to native MF COBOL, unless you normally set the ANSI switch when you submit your RM/
COBOL source programs to the RM/COBOL system. If you do, set the RM"ANSI" directive when you
compile your programs.

We also recommend that you set the NOMF directive when you submit your RM/COBOL source programs
to this COBOL system. This ensures that only those words which are treated as reserved words under the
ANSI '74 COBOL standard are regarded as reserved words by this COBOL system.

Setting the NORM directive disables the syntax enabled when the RM directive was set, and automatically
resets the additional Compiler directives and syntax that RM originally set.

The final states of the additional directives set when you use the NORM directive are not necessarily the
same as their initial default states.

Compiling RM/COBOL Programs Without DIALECT"RM"

The following issues may occur when compiling your RM/COBOL programs without the DIALECT"RM"
Compiler directive:

• Directive settings will revert to Enterprise Developer defaults. Refer to the MF Dialect setting and RM
Dialect setting sections of the DIALECT Compiler directive topic for the differences; you can explicitly
set any of the directives to override the default set by the MF dialect. You can also use the SETTINGS
directive to output a list of directive settings in effect.

• RM/COBOL reserved words that are not reserved in Enterprise Developer will not be treated as
reserved words: this can cause errors such as "verb expected" or other such syntax errors. In some
cases, you can use an ADDRSV directive to resolve this. In other cases, you must modify the syntax in
the source to avoid the RM/COBOL reserved word; often there is an equivalent syntax in Enterprise
Developer that uses a different reserved word.

• The CRT STATUS value for ACCEPT statements will not be converted to RM/COBOL numeric values.
The CRT STATUS for an ACCEPT statement will be the Enterprise Developer three-byte value, where
each byte has a different meaning - the second byte frequently contains the RM/COBOL numeric value.

• In the ASSIGN clause of a file control entry, the device types SORT-WORK, CARD-PUNCH, CARD-
READER, CASSETTE and DISC will not be recognized as valid device types. You must modify the
program to specify an equivalent device type supported by Enterprise Developer. Device types with a
prefix of PRINTER and an additional character, for example, PRINTER1 or PRINTER?, will not be
treated as printers; you must shorten the device type to just PRINTER.

• The ASSIGN clause of a file control entry will not assume DYNAMIC when the ASSIGN directive
specifies "EXTERNAL". You must either override the ASSIGN"EXTERNAL" directive, or modify the
program to specify DYNAMIC explicitly in the ASSIGN clause.

• Indexed file key-name references will not be implicitly qualified by the file-name in the file control entry
or READ/START statements. Ambiguous reference errors may occur if the qualification is required for
uniqueness of reference when the same key-name has been used for more than one file; in this case
you must explicitly add the qualification OF file-name to the reference for Enterprise Developer.

• The CODE-SET clause is not allowed in the file control entry; it can be specified only in the file
description entry. Move any CODE-SET clause specified in the file control entry to the file description
entry.

• COLLATING SEQUENCE clauses may be repeated in the file control entry for an indexed file and the
lexically last such clause specified takes precedence.

• Constant-expressions are fully supported for RM/COBOL syntax in Enterprise Developer, but Enterprise
Developer computes a 64-bit result, as opposed to RM/COBOL's 32-bit result. This is only a problem if
the expression or any sub-expression result exceeds 32 bits in the RM/COBOL program; in this case,
Enterprise Developer will likely have a different result.

116 | Upgrading to Enterprise Developer



• Empty groups are not allowed. Modify the program to eliminate empty groups by including a subordinate
data item in the group or by removing the group itself. A warning message COBCH0217 or COBCH0256
is produced for an empty group when DIALECT"RM" is set, but a severe error COBCH0217 or
COBCH0256 is produced when DIALECT"RM" is not set.

• Byte-storage mode is used for binary data items, which can result in different length file records and
redefinition issues. The IBMCOMP directive will restore word-storage mode, but will also cause length
specifiers in data description entries to increase to the word size that is at least as large as the length
specifier, which is different from RM/COBOL behavior. A better solution might be to provide length
specifiers for all binary data item usage clauses.

• RECORD DELIMITER IS LINE-SEQUENTIAL or BINARY-SEQUENTIAL does not set the record
delimiting technique for the file. Specify the record delimiting technique in the ORGANIZATION clause
or with the SEQUENTIAL directive.

• VALUE OF LABEL data-name-1 is allowed, but treated as documentary. If data-name-1 is not defined in
the program, it will not be defined implicitly. In this case, any references to data-name-1 will receive
compilation errors, and you must change the program to remove the reference or define data-name-1
explicitly.

• Records are not variable length unless records of different length are explicitly defined, even if there are
OCCURS DEPENDING ON clauses in the record description entry, or the RECORD CONTAINS clause
specifies a range of record sizes. You can use the RECMODE"RMCOBOL" directive to cause records to
be variable length in the same manner as RM/COBOL.

• Implicit data-name definition for forward references does not take place without the DIALECT"RM"
directive, except for the external file-name data-name specified in the ASSIGN clause or the FILE-ID
clause. Implicit definition relates to forward references in clauses such as CRT STATUS, CURSOR,
FILE STATUS and others. The explicit definition must be added to the program to avoid compilation
errors. Even with DIALECT"RM" set, an E-level error message, which can be ignored or suppressed, is
generated; this error indicates that the implied definition might not be the desired definition.

• The ERASE clause in a screen description entry cannot be specified without EOS or EOL. A simple
ERASE clause must be changed to BLANK SCREEN. An ERASE LINE clause must be changed to
ERASE EOL or BLANK LINE.

• The SYNCHRONIZED clause follows Enterprise Developer specifications instead of RM/COBOL
specifications. This may result in file record size differences or redefinition issues. It may be necessary
to insert explicit definition of slack characters in record descriptions for groups that have an odd length,
especially if the group or elementary items of odd length are subject to an OCCURS clause.

• The USAGE COMP/COMPUTATIONAL clause in a data description entry does not produce the
informational message COBCH1210 COMP processed as DISPLAY (future occurrences not
indicated).

• Procedure Division headers that specify a nonnumeric returning or giving data item are not permitted
unless there is a prototype that specifies the RM call-convention (1024).

• Procedure-names cannot be the same as data-names. When DIALECT"RM" is set, a procedure-name
that is the same as a data-name produces an informational COBCH0305 message; when DIALECT"RM"
is not set, a procedure-name that is the same as a data-name produces a serious COBCH0305
message and the two categories of names must be disjoint in the source program.

• A comparison of a nonnumeric literal that contains only digits to a display unsigned numeric data item
or literal does not preserve RM/COBOL behavior.

• Character set handling for files does not preserve RM/COBOL behavior.
• I/O statements that result in a serious error at run time do not terminate the program when there is no

applicable declarative but a file status data item is declared. The file status data item must be checked
after each I/O statement to see if a serious error has occurred.

• I/O defaults to expect Enterprise Developer file formats. You need to set the FILETYPE"21" directive for
I/O with existing RM/COBOL format files or convert those files to Micro Focus format files.

Note: Converting the file format does not convert the format of data items in the file. If the data
items are not also converted, directives that define data format may be required, such as
COMP"UNPACKED", COMP1"BINARY", COMP6"3", IBMCOMP and SIGN"EBCDIC".

If FILETYPE"21" is not specified, I/O status values will be different than in RM/COBOL.

Upgrading to Enterprise Developer | 117



• ACCEPT/DISPLAY syntax and behavior differs significantly, requiring revision of the source program to
achieve behavior expected from the RM/COBOL program. Some of the revisions for behavior might not
be necessary if the RM/COBOL ADISCTRL and COBKEYMAP files are used, but Enterprise Developer
does not send all the forms of ACCEPT/DISPLAY to ADIS; the CONSOLE IS CRT clause or the
DISPLAY"CRT" directive might resolve this issue. Also:

• Pop-up windows are not available without setting DIALECT"RM".
• The TAB syntax for ACCEPT can be restored with an ADDRSV"TAB" directive.
• The reverse syntax for ACCEPT/DISPLAY can be restored with an ADDRSV"REVERSE" directive.
• The ACCEPT statement will not allow the ERASE phrase; a separate DISPLAY SPACE ERASE

statement before the ACCEPT is required.
• The Enterprise Developer defaults will apply with respect to the MODE IS BLOCK, HIGH-LIGHT,

BEEP and ECHO.
• The UNIT and ECHO phrases are not supported without setting DIALECT"RM".

• ACCEPT/DISPLAY statements with a group operand for the primary operand produce a COBCH1654
Should be elementary; MODE IS BLOCK assumed when certain phrases are used. When the
error does not occur, the group operand will be treated similar to a screen ACCEPT/DISPLAY, with
elementary items being the fields and FILLER items treated as empty space between fields on the
screen. You must add the MODE IS BLOCK phrase to such ACCEPT/DISPLAY statements to obtain
RM/COBOL behavior of treating the group as a single field.

• ACCEPT/DISPLAY statements position fields on the screen as explained for Enterprise Developer and
not as they are for RM/COBOL. The program must be modified to make the positioning behave as
desired.

• ACCEPT statements that specify the ON EXCEPTION identifier-1 syntax do not compile. The
identifier-1 item in the ON EXCEPTION phrase must be removed. The data item referenced by the CRT
status clause, which may need to be added, can be used to obtain the status of the ACCEPT statement,
but be aware that its format is not the same as identifier-1 as specified in the ON EXCEPTION phrase.
When DIALECT"RM" is set, the format of the CRT status data item is converted to match RM/COBOL's
format if the ON EXCEPTION phrase is specified in the ACCEPT statement.

• ACCEPT statements that specify UPDATE or CONVERT revert to Enterprise Developer behavior for
these phrases.

• ACCEPT statements cannot specify ERASE. The ERASE must be performed in a separate DISPLAY
statement preceding the ACCEPT statement. This is also true of using the CONTROL phrase to specify
ERASE in the control-string specified in the CONTROL phrase.

• ACCEPT statements do not beep by default. The RM"BEEP" directive can be specified to restore the
RM/COBOL default beep, but that will also set old RM compatibility. Instead, you should modify the
program to specify BEEP in ACCEPT statements where BEEP is desired.

• CALL statements cannot specify figurative constants or symbolic characters in the USING phrase.
• CALL statements with numeric literals as arguments might not preserve the original form of the literal as

specified in the source for the actual argument value.
• CALL statements do not use an alignment of 1 for BY CONTENT temporaries, but instead align the

temporary variable per the value of the ALIGN directive.
• CALL statements must have a numeric RETURNING/GIVING argument. The RM/COBOL feature of any

type for RETURNING/GIVING arguments is not supported except when the 1024 call-convention is
specified.

• CALL "SYSTEM" is not RM/COBOL compatible unless the call-convention is set to 1024, either by the
DEFAULTCALLS"1024" directive, a prototype for SYSTEM that specifies the 1024 call-convention, or an
explicit call-convention specified in the CALL statement.

• CANCEL of non-nested program behaves as if the program were nested in an IL program.
• CLOSE statements for a line sequential file cannot specify the NO REWIND phrase.
• DELETE FILE statements do not perform a USE procedure declared for the file when an error occurs.
• DISPLAY statements that specify a figurative constant with positioning information and do not specify

the SIZE phrase are not converted to a single-byte literal.
• The WITH NO ADVANCING phrase for simple (ANSI) ACCEPT and DISPLAY statements is not handled

in the same way as in RM/COBOL when the DISPLAY"CRT" directive is set and DIALECT"RM" is not.
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• MOVE statements that move a nonnumeric literal, including a figurative constant, that contains non-digit
characters to a numeric item, substitute 0 for the sending item and produce a COBCH1026 Source
literal is nonnumeric - substituting zero error. The nonnumeric literal should be
changed to contain only digits or not be used as the sending item in a MOVE operation to a numeric
data item.

• MOVE statements that move a nonnumeric data item to a display unsigned numeric item do not
preserve RM/COBOL behavior.

• OPEN statements set retry lock unconditionally, which differs from RM/COBOL behavior, where this is
conditional on there being a USE procedure and file status data item.

• By default, Enterprise Developer's default file locking mode is EXCLUSIVE, whilst RM/COBOL's default
locking mode is AUTOMATIC. Use the Compiler directive FILESHARE to change the default behavior,
or change the file's SELECT statement and add the LOCK MODE AUTOMATIC clause.

RM/COBOL Data Types

When you compile your programs with the DIALECT"RM" Compiler directive, all data types behave in the
same way that they do in RM/COBOL.

If you do not compile with the DIALECT directive, you can still preserve RM/COBOL behavior for certain
data types by using certain other Compiler directives: COMP, COMP1, COMP2, and COMP-6.

RM/COBOL Conversion Issues

The syntax of most RM/COBOL source programs when submitted to run on this COBOL system will be
accepted and run successfully. However, sometimes this COBOL system might reject some of the syntax in
your original RM/COBOL source program, or might cause your program to behave unexpectedly at run-
time.

This section contains the known problems which you may encounter. Hints are also given on how you can
either rectify the cause of such errors, or emulate the RM/COBOL type of behavior in this COBOL system.

Producing Executable Code

The following section covers the known issues when submitting RM/COBOL source programs to this
COBOL system. Where possible, work-arounds and resolutions are also provided.

Perform Statements
PERFORM statements are not treated in the same way by both COBOL systems. This COBOL system
uses a stack-based perform handling system, while the RM/COBOL system associates a return address
with a specific procedure name.

As a result, under the RM/COBOL system, all end-points to PERFORM statements are always active until
they are used. However, under this system, only the end-point of the last PERFORM statement is active at
any one time.

You must set the PERFORM-TYPE directive with the RM parameter if this COBOL system is to emulate
the behavior of RM/COBOL PERFORM statements.

ACCEPT FROM CENTURY-DATE and FROM CENTURY-DAY
In Enterprise Developer, to use the FROM CENTURY-DATE and FROM CENTURY-DAY phrases with the
ACCEPT statement, set the RM Compiler directive.

Alternatively, use the following equivalent phrases with the ACCEPT statement:

• FROM DATE YYYYMMDD, which is the equivalent of FROM CENTURY-DATE.
• FROM DAY YYYYDDD, which is the equivalent of FROM CENTURY-DAY.

procedure division.
ACCEPT data-name-1 FROM DATE YYYYMMDD.
ACCEPT data-name-2 FROM DAY YYYYDDD.
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CURSOR phrase not available in ACCEPT statement

The CURSOR phrase from RM/COBOL is not supported in Enterprise Developer. In Enterprise Developer,
you must use the data item specified in the CURSOR clause in the special-names paragraph. To obtain the
offset in the accepted field as returned by RM/COBOL for the CURSOR phrase of the ACCEPT statement,
do the following:

1. Set the data item specified in the CURSOR clause to have the line and column where the ACCEPT
statement begins. If the ACCEPT statement is not positioned and will start at the current cursor
location, the CBL_GET_CRSR library routine can be used to get the current cursor position; note that
CBL_GET_CRSR returns zero-relative position information, which must be adjusted to one-relative
position information when setting the location in the data item specified by the CURSOR clause.

2. Save the start column in another data item.
3. Execute the ACCEPT statement (without a CURSOR phrase since it is not supported).
4. Subtract the original start column from the current column in the data item specified in the CURSOR

clause and store this as the offset.

Nested COPY statements with REPLACING phrase
In Enterprise Developer, you cannot specify text replacement as part of a nested COPY statement when
text replacement is already active as part of a COPY statement.

If you attempt to use COPY REPLACING in a file copied with a COPY REPLACING statement, an error
code COBCH0062 COPY replacement not supported is displayed on compilation.

Duplicate Paragraph-names

In Enterprise Developer, if you have duplicate paragraph-names, in different sections, and then call a
paragraph-name from outside its section, an error is produced unless you have explicitly referenced the
paragraph-name and its section. In RM/COBOL, by just calling the paragraph-name, it assumes you are
calling the next declaration of the paragraph-name found.

To ensure that references to duplicate paragraph-names are correctly resolved, you must qualify a
reference to a duplicate paragraph-name by adding the section-name in which it is declared.

Example

If your source code contains the following:

      .... 
      perform para-2. 
      .... 
 sect-1 section. 
      para-1. 
      .... 
      para-2. 
      .... 
 sect-2 section. 
      para-2. 
      ....

RM/COBOL will resolve the reference to para-2 in the PERFORM statement by using the declaration of
para-2 in the sect-1 SECTION. In Enterprise Developer, however, you must qualify the reference to the
duplicate paragraph-name in your source code by using the PERFORM para-2 OF sect-1 statement.

Figurative Constants and the USING Phrase
In Enterprise Developer, to use figurative constants in the USING phrase of a CALL statement or as values
of level 78 constants, set the DIALECT"RM" Compiler directive.

Alternatively, the figurative constant can be replaced by the equivalent non-numeric literal, such as " " for
SPACE or "0" for ZERO.
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File Not Found Errors
Enterprise Developer and RM/COBOL differ in the environment variables that they use to locate program
and data files.

If your source code produces a file not found error, ensure the correct paths are set in the correct
environment variables. In Enterprise Developer, set COBPATH to locate program files and COBDATA to
locate data files. The RUNPATH environment variable used in RM/COBOL, is not used in Enterprise
Developer.

Indexed File Error on Open
Enterprise Developer and RM/COBOL differ in how they handle record length fields and some data fields
when you open an RM/COBOL indexed file.

In Enterprise Developer, when you try to open an RM/COBOL indexed file, you may receive either a run-
time error COBRT161 Illegal intermediate code or a file status code 39 A conflict has been
detected between the fixed file attributes and the attributes specified for
that file in the program.

You must ensure that you read in the same size records that were created in RM/COBOL.

In Visual Studio, hover over the level 01 item of the file description to display the length of the record.

If the length of the file description does not match that which was processed in RM/COBOL, check the
following:

• In RM/COBOL, you can set the RECORD CONTAINS nn CHARACTERS clause to be a different length
than the actual length specified in the record description. If this clause is greater than the actual
description, you must pad the record description with filler bytes to match the RECORD CONTAINS
clause.

• If you have signed numeric display data in your file, Enterprise Developer will treat the sign as a
separate byte if you are using the RM directive without "ANSI" specified. If these fields are stored as
sign internal, you must use RM"ANSI" or do not use the RM directive at all.

LIKE Relational-operator Not Available
Enterprise Developer and RM/COBOL differ in the way that they allow you to use regular expressions.

RM/COBOL has a LIKE relational-operator. Enterprise Developer does not support the LIKE relational-
operator. Instead, use the C$REGEXP library routine. C$REGEXP uses a call convention of zero, so when
using it in a DIALECT"RM" program, where the default call convention is 1024, the call convention must be
specified in the CALL statement for C$REGEXP.

The regular expressions supported by C$REGEXP differ somewhat from those used by the RM/COBOL
LIKE relational-operator and between Windows and UNIX, so adjustments may be required in the regular
expression syntax used.

Linkage Section in Main Program

In RM/COBOL, if the main program has a Linkage Section, it is initialized by the parameter passed on the
command line. In Enterprise Developer, you must use the command_line_linkage tunable or the
COMMAND-LINE-LINKAGE Compiler directive to pass parameters from the command line to the Linkage
Section.

Nested OCCURS DEPENDING Clauses
In Enterprise Developer, if you are using nested OCCURS DEPENDING clauses, you must set the
ODOSLIDE Compiler directive.
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Numbering of Segments

In Enterprise Developer, you can only specify segment numbers in the range 0 to 99 inclusive, which
conforms to segment number limit specified in the ANS X3.23-1985 COBOL standard. In RM/COBOL, you
can specify segment numbers greater than 99.

If your source code has segment numbers greater than 99, recode the program. Make sure that any new
segment numbers you allocate do not clash with an already existing segment number. Segment numbers
between 0 and 49 inclusive are used by Enterprise Developer to indicate fixed portions of your object
program, while segment numbers 50 to 99 inclusive indicate independent segments.

For details on the use of segmentation and segment numbers in your source programs, see COBOL
Language Reference in the product Help.

Program Identification and Data Names

In Enterprise Developer, you cannot use the same name for the Program-ID and a data item in the
program; each name should be unique. RM/COBOL permits the name of the Program-ID paragraph and a
data item to share the same name.

REMARKS Paragraph
In Enterprise Developer, if your program uses the REMARKS paragraph in the Identification Division, you
must set the DIALECT"RM" Compiler directive.

Alternatively, mark the paragraph as comment lines.

Reserved Words
In Enterprise Developer, setting certain Compiler directives (such as RM and ANS85) activates certain
reserved words that you cannot use as names for your data items.

If you attempt to use a reserved word, you receive a COBCH0666 ("Reserved word used as data
name or unknown data description qualifier") COBOL syntax error.

To continue to use the reserved word as a data name, you can:

• Use the REMOVE Compiler directive, to unreserve that particular keyword.
• Set the MFLEVEL Compiler directive to an appropriate level, to unreserve all keywords above that level.

See Compiler Directives in the product Help.

Example

Your RM/COBOL source program may contain the following lines of code:

     .... 
     03 sort   pic 99. 
     .... 
     move 1 to sort

If you submit this to Enterprise Developer, you will receive an error because the SORT verb is reserved.
However, if you specify the REMOVE"SORT" Compiler directive when you submit this source program, you
will not receive the error.

SAME AS Clause Not Available When Defining Data Structures
Enterprise Developer and RM/COBOL differ in the way that they allow you to reuse existing data structures.

In Enterprise Developer, use the TYPEDEF clause to define your base data structure, and then use the
USAGE clause to create data structures of the same type.

data division.
working-storage section.
01 atype is typedef.
   03 var1 pic x(10) value "brown".
   03 var2 pic x(10) value "blue".
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   03 var3 pic x(10) value SPACE.
01 a1 usage atype.
procedure division.
display var2 of a1.

The result of the display statement is blue.

The SAME AS clause used in RM/COBOL is not supported in Enterprise Developer.

Source Code in Columns 73 to 80
Enterprise Developer ignores any of the code in your source programs which lies within columns 73-80
inclusive.

Code in these columns could be the result of expanding TAB characters in your source program, instead of
standard TAB stops. If your source program contains TAB stops, convert them to spaces.

If your RM/COBOL program used the >>IMP MARGIN-R AFTER END OF RECORD directive for long
source records, remove that directive from the source and use the Enterprise Developer
SOURCEFORMAT"variable" directive. Note that source lines longer than 256 bytes are not supported and
will be truncated with a message at compile-time.

RM/COBOL implementor defined directives >>IMP for source format, >>LISTING ON/OF and >>PAGE are
not supported.

START WHILE LIKE Not Available
Enterprise Developer and RM/COBOL differ in the way that they allow you to select records from and
indexed organization file.

RM/COBOL allows a WHILE LIKE filter in the START statement. The filter is passed to the file manager
and only records that match the filter are returned to the COBOL program for processing. Enterprise
Developer does not support such a filtering mechanism. The COBOL program must retrieve all the records
and filter them in the program, which is less efficient, but at least emulates the RM/COBOL feature. The C
$REGEXP library routine can be used to apply a regular expression filter similar to what the WHILE LIKE
phrase in RM/COBOL would apply in the file manager.

Undeclared Data Items in Clauses

In Enterprise Developer, you receive a COBCH0250 STATUS field data-name missing or
illegal error if a data item used in the File Status clause is not declared in the Working-Storage section.
In RM/COBOL, you do not have to declare the data item in Working Storage.

With the DIALECT"RM" directive, serious error COBCH0250 is no longer generated by Enterprise
Developer for the undeclared items. Instead, a non-serious COBCH1787 is generated. This error can be
suppressed or ignored. It indicates that a default definition has been provided. The default definition is the
same as the one supplied by RM/COBOL, but it might not be the desired definition. If it is not the desired
definition, modify your program to define the data item as desired.

User-names Longer than 127 Bytes are Truncated
In RM/COBOL, you can specify user-names (data-names, procedure-names, program-names, etc) up to
240 characters long. In this COBOL system, user-names longer than 127 bytes in length are truncated and
a warning message is produced.

Solution:

Results may be affected if the truncated user-name is used with XML Extensions, to export or import XML
documents; therefore, we recommend that you keep user-names to 127 bytes or less.
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Using Relative Path Names
If your RM/COBOL application relies on the EXPANDED-PATH-SEARCH configuration option to locate files
specified with a relative path name, you must set the COPYSEARCH"RM-EXPANDED" Compiler directive
in Enterprise Developer for equivalent behavior.

When running your application under the DIALECT"RM" emulation, COPYSEARCH"RM" is set by default,
which only emulates the standard RM/COBOL directory search sequence when trying to resolve relative
path names. You must override this setting with the COPYSEARCH"RM-EXPANDED" Compiler directive
on your individual programs or application.

Running the Code

Once you have successfully submitted your RM/COBOL source program to this COBOL system and
produced executable code, you might encounter difficulties when you try to run this code under this
system. Alternatively, the code might run but you might find that its behavior under this COBOL system is
not exactly the same as under the RM/COBOL system. The following sections detail known areas of
difficulty you might encounter, and offer hints on how you can avoid them.

Table Bound Checking
If you try to run a program under this COBOL system which contains a subscript value greater than the
size of the table to which it refers, the run-time system will produce an error indicating this. Under the RM/
COBOL system, however, no such table bound checking is done.

Therefore, if you wish to disable table bound checking in this COBOL system, you must use the
NOBOUND directive.

If you use the NOBOUND directive when running intermediate code, you will be able to access data
beyond a table's bounds by using a subscript value greater than the table size. Use of the NOBOUND
directive when you are producing intermediate code will also disable bound checking when running
generated code. However, if you wish to access data beyond a table's bounds when running generated
code, you must also use the directive NOBOUNDOPT.

Note: When you use the NOBOUNDOPT directive, performance will be impaired.

ACCEPT Fields at the Edge of the Screen

If your program contains an ACCEPT statement for a numeric data item at a position on the screen where
the definition of the numeric data item would cause the ACCEPT field to go beyond the right-hand edge of
the screen, both COBOL systems will truncate the input value. In RM/COBOL, the input value will be
aligned into the ACCEPT field as an alphanumeric field, whereas in Enterprise Developer, the input value
is aligned as a numeric field.

Change the definition of the relevant PICTURE clause from numeric to alphanumeric. Alternatively, change
the PICTURE clause so that the field does not go beyond the edge of the screen.

Example

If your program contains the following statement:

ACCEPT data-item AT COLUMN NUMBER 75.

where data-item is a numeric data item defined as PIC 9(10), a value of 123456 entered into the
ACCEPT field will be held under Enterprise Developer as "0000123456". However, in RM/COBOL, the
value in the ACCEPT field would be held as "1234560000". To allow Enterprise Developer to emulate the
RM/COBOL behavior, alter the definition of the data item in your program to PIC X(10) or PIC 9(6).

C$CARG Not Supported
The RM/COBOL C$CARG library routine is not supported.

Calls to C$CARG must be changed to use C$DARG, which is supported and provides equivalent
functionality.
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Display of Input Data in Concealed ACCEPT Fields

If you have specified OFF and ECHO clauses for the same ACCEPT statement in your program, RM/
COBOL will conceal any data entered during input for that statement but on completion of input will display
the data. Enterprise Developer will not display the data for this ACCEPT statement once input has been
completed.

If you want to display the data input for an ACCEPT statement with the OFF and ECHO clauses specified,
you must add a DISPLAY statement after the ACCEPT statement.

Embedded Control Sequences in DISPLAY Statements
In Enterprise Developer, you cannot embedded control sequences within data items that you want to be
displayed.

Such characters are ignored at run time as they are hardware dependent.

Remove the control sequences from your source program and replace with the equivalent Micro Focus
COBOL syntax; for example, use the syntax WITH UNDERLINE to replace <left-arrow>]4m.

End of File Notification

The first time you unsuccessfully try to READ a sequential file in either COBOL system because you have
reached the end of the file, status key 1 in the FILE STATUS is set to 1 and status key 2 is set to 0. This
indicates that there is no next logical record. If you try to READ the same file again, without it either having
been previously closed and reopened, or it having been successfully started, Enterprise Developer
continues to indicate that there is no next logical record. However, if you try to READ the same file again
under RM/COBOL, status key 1 is set to 9 and status key 2 is set to 6.

A solution to the different file statuses returned for the circumstances given above will depend on the way
in which your source program is coded. We suggest that you include tests for the values 1 and 0 in status
key 1 and 2 of the file status, respectively, at the same time as you test for the values 9 and 6 in these
status keys.

The EXCEPTION STATUS Clause
Enterprise Developer and RM/COBOL differ in their treatment of the EXCEPTION STATUS clause during
an ACCEPT statement.

The EXCEPTION STATUS values returned differ between the two COBOL languages. See The ACCEPT
Statement for a list of statuses returned in Enterprise Developer.

In Enterprise Developer, the EXCEPTION STATUS value is undefined if the preceding CALL statement
does not contain the ON EXCEPTION or ON OVERFLOW phrase. In RM/COBOL, it will always return a
value of zero in those cases.

File Status Codes

If your program is set to return RM/COBOL file status codes, but does not use a file status, or does not
have a Declaratives section acting upon your data file, file I/O errors are reported by the run-time system.
The extended file status reported may initially seem incorrect, but due to differences in the file handling of
the different COBOL systems, the second byte of the reported error code needs to be converted from
binary to ASCII. For example, if an error of 9/051 is reported, convert 051 to its ASCII character
equivalent, which is 3 (0x33 in hexadecimal); therefore, the true RM/COBOL file status is actually 93.

Field Wrap-Around

If, when using binary data items (that is, RM/COBOL COMPUTATIONAL-1 format items) an arithmetic
operation gives a value which exceeds the capacity of the data item, and there is no ON SIZE ERROR
clause, Enterprise Developer wraps-around the value of the item. However, in RM/COBOL, the data item is
set to the limit of its capacity.
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You should specify an ON SIZE ERROR clause to highlight such problems.

Example

In RM/COBOL, the following lines of code result in the value +32767 being stored in the data item, CALC-
ITEM. However, Enterprise Developer sets CALC-ITEM to -32768:

01 calc-item         pic s9(4)  comp-1.

 procedure division. 
      .... 
     move 32767 to calc-item. 
     add 1 to calc-item.

File and Record Locking
Certain versions of RM/COBOL contain some software errors in the way in which locks for files and records
are handled. These errors do not occur in Enterprise Developer.

The errors fixed when upgrading to Enterprise Developer are:

• Indexed files do not detect or acquire locks if they are opened for output. This is regardless of whether
you specify the WITH LOCK phrase

• Relative and sequential files cannot be locked exclusively
• Files which are opened for input can detect record locks, although the RM/COBOL documentation

states that they cannot. When the RM directive is set in Enterprise Developer, record locks can still be
detected by files opened for input

• The first record in a sequential file opened for input-output is locked whenever any other record in that
file is locked

Initialization of Working Storage

Enterprise Developer initializes all working storage items without VALUE clauses to SPACES .The RM/
COBOL system initializes all working storage items to SPACES, unless you have placed numeric data
items between data items with VALUE clauses.

If this feature causes you any problems, because your program relies on the initial value given to the
system, add a VALUE clause with the appropriate value to your source program and resubmit it.

Example

The RM/COBOL system initializes the following group item to SPACES:

01 group-item. 
     03 item-1     pic x. 
     03 item-2     pic 99. 
     03 item-3     pic x.

However, if item-1 and item-3 have value clauses associated with them, the RM/COBOL system initializes
the second byte of item-2 to hexadecimal value 0 when item-2 is defined as USAGE COMP (signed or
unsigned) or USAGE DISPLAY (unsigned only).

Numeric Fields Containing Illegal Characters When Using a DEPENDING ON Phrase of an OCCURS
Clause

In Enterprise Developer, if you fail to initialize a numeric data item that is used in a DEPENDING ON
phrase of an OCCURS clause appropriately, a COBRT163 Illegal character in numeric field
error is displayed at run time, because the data item is initialized to SPACES if no value is specified. In RM/
COBOL, the data item is initialized to ZERO, and therefore, the error does not occur.

ON SIZE ERROR Phrase

In Enterprise Developer, the ON SIZE ERROR condition exists when the value resulting from an arithmetic
operation exceeds the capacity of the specified picture-string. In RM/COBOL, the ON SIZE ERROR
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condition exists when the value resulting from an arithmetic operation exceeds the capacity for the
associated data item.

Ensure that the capacity of any data items in your source programs is specified by a picture-string; for
example, COMPUTATIONAL-1 data items.

Open EXTEND of Nonexistent File

In Enterprise Developer, because setting the RM Compiler directive sets the NOOPTIONAL-FILE Compiler
directive, if you try to open a non-existent file for I-O or EXTEND the run-time system will give an error
message. For I-O, RM/COBOL does the same. However, for EXTEND, RM/COBOL creates the file and
opens it as if you had specified OUTPUT.

The following options are available:

• Add the keyword OPTIONAL to the SELECT statement. This makes Enterprise Developer create the file
and open it for OUTPUT

• Create the empty file before running your program
• Specify the OPTIONAL-FILE Compiler directive. This makes Enterprise Developer create the file and

open it for OUTPUT. However, the behavior with files opened for I-O will now differ from RM/COBOL

Printer Output is Written to Disk
By default, Enterprise Developer writes all output intended for a printer to disk.

To send output to a physical printer, you must map the filename using the dd_LPT1 environment variable
or, if your system supports the lp printer spooler, you should use:

dd_LPT1=">lp";export dd_LPT1

With the DIALECT"RM" directive, the ASSIGN-PRINTER"" directive is set. In this case, a file assigned to a
printer without a file-name in the ASSIGN clause is given a file-name that matches the file-name specified
in the SELECT clause. Thus, to redirect the output file, set an environment variable dd_file-name to the
desired destination.

Screen Column Number Specification

Enterprise Developer permits you to specify screen column numbers up to and including 999, but RM/
COBOL permits you to specify column numbers greater than 999. If you try to run an RM/COBOL source
program containing a column number greater than 999 in Enterprise Developer, the column number is
truncated so that only the last three digits are used. If truncation of the column number occurs for an item
to be displayed on the screen, the position of that item on the screen in Enterprise Developer will differ
from its position in RM/COBOL.

Trailing Blanks in Line Sequential Files

Enterprise Developer always removes trailing blanks from line sequential records before writing the record.
RM/COBOL removes trailing blanks from such records only if the FD entry contains 01 level records of
different sizes. This will not cause you any problems when you run your converted RM/COBOL programs in
Enterprise Developer. However, you may receive errors at run time if any REWRITE operations on line
sequential files change the length of the records.

Change the file organization to sequential, or move an alternative padding character (for example, LOW-
VALUES) to the end of the record before it is written. This ensures that full-length records are written.

You also need to ensure that the T run-time switch is not set, as this might also change the size of the
record. See Run-time Switches in the product Help.

Undefined Results of MOVE and Arithmetic Operations
Enterprise Developer and RM/COBOL differ in the results of MOVE statements, arithmetic operations, and
comparisons that involve numeric and alphanumeric data items.
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You can overcome most of these incompatibilities by redefining the data items involved, or by recoding the
comparisons. If you submit a program in Enterprise Developer containing an alphanumeric to numeric data
item MOVE statement, a warning message will be displayed indicating this.

Example

If you submit a source program containing the following data items and procedural statements, the
specified test will fail at run time:

 01 numeric-field        pic 9(5). 
 procedure division. 
     move "abc" to numeric-field. 
     if numeric-field = "00abc" 
         ....

When the RM Compiler directive is set, Enterprise Developer partially emulates the behavior of RM/
COBOL for alphanumeric to numeric MOVEs by treating the numeric item as an alphanumeric item which
is right justified. However, the above example will still fail because RM/COBOL treats the literal ABC as
numeric, and places 00ABC in the numeric item. To make the statement run successfully in Enterprise
Developer, amend the test in the source program to:

     if numeric-field = " abc"

and resubmit the source program.

Using the Correct Calling Convention

We recommend that to use the RM/COBOL library routines provided in Enterprise Developer, you explicitly
set the 1024 call-convention in the CALL statement.

program-id. Program1.
Special-Names.
call-convention 1024 is RM.
...

procedure division.

call RM "SYSTEM" using "cmd.exe /c mkdir sys02".
   
goback.
end program Program1.

RM/COBOL Library Routines
The following RM/COBOL routines are available in this COBOL system.

C$Century
Updates your COBOL programs to handle the year 2000 issue.

Note: When calling this routine, ensure you are using the 1024 calling convention.

This library routine retrieves the first two digits of the current year.

Syntax:
CALL "C$Century" USING value-buffer

Parameters:
value-buffer

A two-byte data item with a format of either unsigned numeric display (NSU) or
alphanumeric display (ANS).
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On Exit:

value-buffer The first two digits of the current year.

Comments:

You can achieve the same result using the standard COBOL command ACCEPT data-name FROM DATE
YYYYMMDD and then referencing the data name.

C$ConvertAnsiToOem
Converts a buffer containing ANSI characters to a buffer containing the corresponding OEM characters.

When calling this routine, ensure you are using the 1024 calling convention.

This is supported on Windows only.

Syntax:
CALL "C$ConvertAnsiToOem" USING ansi-buffer, oem-buffer
[, char-count]

Parameters:
ansi-buffer

PIC X(n)

oem-buffer
PIC X(n)

char-count
PIC 9(n)

On Entry:

ansi-buffer The ANSI characters to be converted to OEM characters.

char-count The number of characters to be converted.

Note: If omitted or if the value is invalid, the actual size of the shorter of ansi-buffer
and oem-buffer is used.

On Exit:

oem-buffer The converted OEM characters.

C$ConvertOemToAnsi
Converts a buffer containing OEM characters to a buffer containing the corresponding ANSI characters.

Note: When calling this routine, ensure you are using the 1024 calling convention.

Syntax:
CALL "C$ConvertOemToAnsi" USING oem-buffer, ansi-buffer
[, char-count]

Parameters:
oem-buffer

PIC X(n)

ansi-buffer
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PIC X(n)

char-count
PIC 9(n)

On Entry:

oem-buffer The OEM characters to be converted to ANSI characters.

char-count The number of characters to be converted.

Note: If omitted or if the value is invalid, the actual size of the shorter of ansi-buffer
and oem-buffer is used.

On Exit:

ansi-buffer The converted ANSI characters.

C$DARG
Returns information about a parameter passed in the USING or GIVING phrases of the CALL statement
that called a subprogram.

Restriction: This routine is supported in native COBOL only.

When calling this routine, ensure you are using the 1024 calling convention.

This information identifies the type and length of the argument and, when the argument is numeric or
numeric edited, the number of digits and scale factor for the argument.

Syntax:
CALL "C$DARG" USING argument-number, argument-description

Parameters:
argument-number

pic 9(n)

argument-description
01 ARGUMENT-DESCRIPTION.
    02 ARGUMENT-TYPE PIC 9(2) BINARY(2).
    02 ARGUMENT-LENGTH PIC 9(8) BINARY(4).
    02 ARGUMENT-DIGIT-COUNT PIC 9(2) BINARY(2).
    02 ARGUMENT-SCALE PIC S9(2) BINARY(2).
    02 ARGUMENT-POINTER POINTER.
    02 ARGUMENT-PICTURE POINTER.

On Entry:

argument-
number

The ordinal position of the argument in the USING phrase of the CALL statement. The
value zero returns the description of the GIVING phrase of the CALL statement.

On Exit:

argument-
description

Details of the passed parameter. Those details include:

argument-
type

The type of data item; see the table in the Comments section.
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argument-
length

The number of character positions of the data item.

argument-
digit-count

The number of digits defined in the PICTURE character-string for an
argument that is a numeric or numeric edited data item as indicated by
the ARGUMENT-TYPE field value; otherwise, the value zero is returned
for nonnumeric data items. The digit count for a numeric or numeric
edited data item does not include any positions defined by the
PICTURE symbol P, which represents a scaling position.

argument-
scale

The power of 10 scale factor (that is, the position of the implied or
actual decimal point) for an argument that is a numeric or numeric
edited data item as indicated by the ARGUMENT-TYPE field value;
otherwise, the value zero is returned for nonnumeric data items. If the
PICTURE symbol P was used in the description of the data item, the
absolute value of the ARGUMENTSCALE value will exceed the
ARGUMENT-DIGIT-COUNT value; in this case, a positive scale value
indicates an integer with P scaling positions on the right of the
PICTURE character-string and a negative scale value indicates a
fraction with P scaling positions on the left of the PICTURE character-
string

argument-
pointer

This parameter is not returned in this COBOL system.

argument-
picture

This parameter is not returned in this COBOL system.

Comments:

Use the C$NARG library routine to obtain the number of arguments passed in the CALL statement.

The actual number of arguments may exceed the number of formal arguments declared in the Procedure
Division header of the program that calls C$DARG. All of the actual arguments can be accessed using C
$DARG even though there is no formal argument name available for accessing the actual arguments
beyond the number of formal arguments.

The following table is used to indicate the data type specified in the ARGUMENT TYPE field:

Type Number RM/COBOL Data Type Type Number RM/COBOL Data Type

0 NSE 16 ANS

1 NSU 17 ANS (justified right)

2 NTS 18 ABS

3 NTC 19 ABS (justified right)

4 NLS 20 ANSE

5 NLC 21 ABSE

6 NCS 22 GRP (fixed length)

7 NCU 23 GRPV (variable length)

8 NPP 25 PTR

9 NPS 26 NBSN

10 NPU 27 NBUN

11 NBS 32 OMITTED
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Type Number RM/COBOL Data Type Type Number RM/COBOL Data Type

12 NBU

Restriction: Data type OMITTED (type number 32) is not supported in this COBOL system.

C$Delay
Relinquishes the CPU for a length of time specified in seconds.

Note: When calling this routine, ensure you are using the 1024 calling convention.

This library routine allows other programs to run while the current program waits.

Syntax:
CALL "C$Delay" USING seconds

Parameters:
seconds

PIC 9(n)v999, where n is a digit from 1 to 7

On Entry:

seconds The number of seconds.

Comments:
The amount of delay is not exact. It depends upon the particular machine configuration and the load on the
machine.

C$GetEnv
Returns the value of an environment variable.

Note: When calling this routine, ensure you are using the 1024 calling convention.

Syntax:
CALL "C$GetEnv" USING name, value [, return]

Parameters:
name

PIC X(n)

value
PIC X (n)

return
PIC 9(n) BINARY, where n can be a digit from 1 to 9

On Entry:

name The name of the environment variable.

On Exit:

value The value of the environment variable, returned from the call.
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return The result code returned from the call: zero for success and non-zero for failure.

Comments:

On UNIX, environment variable names are case-sensitive. On Windows, environment variable names are
not case-sensitive.

C$GetLastFileName
Retrieves the last filename used in a COBOL I/O statement (including OPEN and CLOSE).

Note: When calling this routine, ensure you are using the 1024 calling convention.

Syntax:
CALL "C$GetLastFileName" USING filename

Parameters:
filename

PIC X(30)

On Exit:

filename The name of the filename used in the last I/O operation.

Comments:

For REWRITE and WRITE statements, the COBOL filename associated with the specified file record-name
is provided.

If the filename is longer than 30 characters, it is truncated to the right.

C$GetLastFileOp
Retrieves the last COBOL I/O operation performed.

Note: When calling this routine, ensure you are using the 1024 calling convention.

Use this library routine within a declarative procedure after an I/O error has occurred.

Syntax:
CALL "C$GetLastFileOp" USING operation

Parameters:
operation

PIC X(20)

On Exit:

operation The name of the last I/O operation performed. The valid operations returned are:

Close

CloseUnit

Delete

DeleteFile

DeleteRandom

ReadRandom

Rewrite

RewriteRandom

Start

Unlock
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Open

ReadNext

ReadPrevious

Write

WriteRandom

Comments:

If the operation is longer than 20 characters, it is truncated to the right.

If the value SPACES is returned that indicates that no operation is available.

C$GetNativeCharset
Retrieves information about the native character set in effect for the current run unit.

Note: When calling this routine, ensure you are using the 1024 calling convention.

The native character set specifies how non-numeric data is encoded in memory and on data files.

Syntax:
CALL "C$GetNativeCharset" USING charset-name [, codepage-number]

Parameters:
charset-name

PIC X(n)

codepage-number
PIC 9(n)

On Exit:

charset-name The name of the character set in use for the current run unit after the call.

Note: For Windows, the name will have a value of “ANSI” or “OEM”. On UNIX,
the value will be “NONE”.

codepage-
number

The codepage number of the character set in use for the current run unit after the call.

Note: For Windows, the codepage number will be the system ANSI codepage
number if charset-name contains “ANSI” and will be the system OEM codepage
number if charset-name contains “OEM”. On UNIX, the value will be 0.

Comments:

The native character set for a run unit on Windows can be either ANSI or OEM.

The native character set for a run unit on UNIX is determined by the locale settings for the system.

C$LogicalAnd
Performs a bitwise logical AND operation on two or more non-numeric or numeric operands.

When calling this routine, ensure you are using the 1024 calling convention.

Syntax:
CALL "C$LogicalAnd"
[GIVING result]
 USING operand1 {operand2} ...
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Parameters:
result

PIC 9(n)

operand1
A non-numeric or numeric operand

operand2, 3, etc
A non-numeric or numeric operand that must be of the same data type as operand1

Note: If any non-numeric operand2 is shorter than operand1, it is assumed
to be padded on the right with binary zeroes.

On Entry:

operand1, 2, 3, etc Non-numeric or numeric operands, which must be of the same data type as
operand1.

On Exit:

result The result of the operation or operand1.

Comments:

For non-numeric USING operands, the bitwise logical AND of all the operands replaces the value of
operand1. The value of result is set to a non-zero value if any character of operand1 is non-zero after the
operation completes and zero otherwise.

For numeric USING operands, each operand is converted, if necessary, to a 32-bit binary integer. These
32-bit binary values are logically ANDed together. If the GIVING phrase is specified, the result of this
operation is stored in result and the value of operand1 is not modified. If the GIVING phrase is not
specified, the result of this operation is stored in operand1.

C$LogicalComplement
Performs a bitwise logical One's Complement operation on a non-numeric or numeric operand.

When calling this routine, ensure you are using the 1024 calling convention.

Syntax:
CALL "C$LogicalComplement"
[GIVING result]
 USING operand

Parameters:
result

PIC 9(n)

operand
A non-numeric or numeric operand

On Entry:

operand A non-numeric or numeric operand.

On Exit:

result The result of the operation or operand.
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Comments:

If operand refers to a non-numeric data item, the bitwise logical One’s Complement of the value of operand
replaces the value of operand. The value of result is set to a non-zero value if any character of operand is
non-zero after the operation completes and zero otherwise.

If operand refers to a numeric data item, the operand is converted, if necessary, to a 32-bit binary integer.
The 32-bit binary value is logically One’s Complemented. If the GIVING phrase is specified, the result of
this operation is stored in result and the value of operand is not modified. If the GIVING phrase is not
specified, the result of this operation is stored in operand.

C$LogicalOr
Performs a bitwise logical OR operation on two or more non-numeric or numeric operands.

When calling this routine, ensure you are using the 1024 calling convention.

Syntax:
CALL "C$LogicalOr"
    [GIVING result]
     USING operand1 {operand2} ...

Parameters:
result

PIC 9(n)

operand1
A non-numeric or numeric operand

operand2, 3, etc
A non-numeric or numeric operand that must be of the same data type as operand1

Note: If any non-numeric operand2 is shorter than operand1, it is assumed
to be padded on the right with binary zeroes.

On Entry:

operand1, 2, 3, etc Non-numeric or numeric operands, which must be of the same data type as
operand1.

On Exit:

result The result of the operation or operand1.

Comments:

For non-numeric USING operands, the bitwise logical inclusive OR of all the operands replaces the value
of operand1. The value of result is set to a non-zero value if any character of operand1 is non-zero after the
operation completes and zero otherwise.

For numeric USING operands, each operand is converted, if necessary, to a 32-bit binary integer. These
32-bit binary values are logically inclusive OR'd together. If the GIVING phrase is specified, the result of
this operation is stored in result and the value of operand1 is not modified. If the GIVING phrase is not
specified, the result of this operation is stored in operand1.

C$LogicalXor
Performs a bitwise logical exclusive OR operation on two or more non-numeric or numeric operands.

When calling this routine, ensure you are using the 1024 calling convention.
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Syntax:
CALL "C$LogicalXor"
    [GIVING result]
     USING operand1 {operand2} ...

Parameters:
result

PIC 9(n)

operand1
A non-numeric or numeric operand

operand2, 3, etc
A non-numeric or numeric operand that must be of the same data type as operand1

Note: If any non-numeric operand2 is shorter than operand1, it is assumed
to be padded on the right with binary zeroes.

On Entry:

operand1, 2, 3, etc Non-numeric or numeric operands, which must be of the same data type as
operand1.

On Exit:

result The result of the operation or operand1.

Comments:

For non-numeric USING operands, the bitwise logical exclusive OR of all the operands replaces the value
of operand1. The value of result is set to a non-zero value if any character of operand1 is non-zero after the
operation completes and zero otherwise.

For numeric USING operands, each operand is converted, if necessary, to a 32-bit binary integer. These
32-bit binary values are logically exclusive OR'd together. If the GIVING phrase is specified, the result of
this operation is stored in result and the value of operand1 is not modified. If the GIVING phrase is not
specified, the result of this operation is stored in operand1.

C$LogicalShiftLeft
Performs a logical shift left operation on a non-numeric or numeric operand.

When calling this routine, ensure you are using the 1024 calling convention.

Syntax:
CALL "C$LogicalShiftLeft"
[GIVING result]
 USING operand [shiftcount]

Parameters:
result

PIC 9(n)

operand
A non-numeric or numeric operand

shiftcount
PIC 9(n)
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On Entry:

operand A non-numeric or numeric operand.

shiftcount The number of positions to shift during the operation.

On Exit:

result The result of the operation.

Comments:

If operand refers to a non-numeric data item, the value of the data item is shifted left by the number of bit
positions specified by shiftcount. Any bits shifted off the left end are lost and zero-valued bits are shifted
into the right end. The value of result is set to a non-zero value if any character of operand is non-zero after
the operation completes and zero otherwise.

If operand refers to a numeric data item, the operand is converted, if necessary, to a 32-bit binary integer.
The 32-bit binary value is logically shifted left by the number of bit positions specified by shiftcount. If the
GIVING phrase is specified, the result of this operation is stored in result and the value of operand is not
modified. If the GIVING phrase is not specified, the result of this operation is stored in operand.

C$LogicalShiftRight
Performs a logical shift right operation on a non-numeric or numeric operand.

When calling this routine, ensure you are using the 1024 calling convention.

Syntax:
CALL "C$LogicalShiftRight"
[GIVING result]
 USING operand [shiftcount]

Parameters:
result

PIC 9(n)

operand
A non-numeric or numeric operand

shiftcount
PIC 9(n)

On Entry:

operand A non-numeric or numeric operand.

shiftcount The number of positions to shift during the operation.

On Exit:

result The result of the operation.

Comments:

If operand refers to a non-numeric data item, the value of the data item is shifted right by the number of bit
positions specified by shiftcount. Any bits shifted off the right end are lost and zero-valued bits are shifted
into the left end. The value of result is set to a non-zero value if any character of operand is non-zero after
the operation completes and zero otherwise.
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If operand refers to a numeric data item, the operand is converted, if necessary, to a 32-bit binary integer.
The 32-bit binary value is logically shifted right by the number of bit positions specified by shiftcount. If the
GIVING phrase is specified, the result of this operation is stored in result and the value of operand is not
modified. If the GIVING phrase is not specified, the result of this operation is stored in operand.

C$NARG
Returns the number of parameters passed in the USING phrase of a CALL statement to the
subprogram that contains the call to C$NARG.

Arguments specified explicitly as OMITTED in the USING list of the CALL statement are included in the
count. The GIVING argument is not included in the count.

Note: When calling this routine, ensure you are using the 1024 calling convention.

Syntax:
CALL "C$NARG" USING parameter-count

Parameters:
parameter-count

PIC 9(3) BINARY, COMP-4 or COMP-1

On Exit:

parameter-count The number of parameters passed.

C$OSLockInfo
Returns the process ID of the process that has the record locked when a lock request fails. This routine
should be called immediately after a lock request has failed.

Note: When calling this routine, ensure you are using the 1024 calling convention.

Note: This routine is supported on UNIX only.

Syntax:
CALL "C$OSLockInfo" USING processid

Parameters:
processid

A four-byte, unsigned COMP-4 numeric item.

On Exit:

processid The ID of the process that has the record locked.

Comments:

This routine will return a zero if run on Windows.

C$SecureHash
Produces a 20-byte message digest from an input text string using the secure hash algorithm (SHA-1).

Note: When calling this routine, ensure you compile using DIALECT"RM".
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Syntax:
CALL "C$SecureHash" USING message-text [message-length]
                    GIVING message-digest

Parameters:
message-text

PIC X(n)

message-length
PIC 9(n)

message-digest
PIC X(n)

On Entry:

message-
text

Its value is the input text string to the secure hash algorithm. While the secure hash
algorithm supports messages of length 2**64 or less bits (2**61 or less bytes), this
implementation is limited to messages of length 2**32 or less bits (2**29 or less bytes).

message-
length

Its value specifies the number of bytes of message-text to be considered when producing
the message digest. Thus, the value must be less than or equal to the length of data item
referenced by message-text. If message-length is omitted, the entire value of the data item
referenced by message-text is used, as if LENGTH OF message-text had been specified
for message-length.

On Exit:

message-
digest

It must be an identifier that references a nonnumeric data item of exactly 20 bytes in length.
The message digest result from the secure hash algorithm is returned in the referenced data
item. The message digest value is stored in the form most significant byte at lowest address
to least significant byte at highest address regardless of the memory architecture of the
machine on which C$SecureHash is called.

When there is insufficient memory for C$SecureHash to do its work, the contents of
message-digest are set to all binary zeroes. This only occurs when a memory area slightly
larger than the size of the message text cannot be allocated. The secure hash algorithm
used by C$SecureHash, other than the length limitation, is the one defined as the secure
hash standard by Federal Information Processing Standard (FIPS) Publication 180-1, which
is often referred to as SHA-1.

Comments:

One example of the usefulness of a message digest is storing a password in a secure form. Since
message-digest is produced using a one-way hash of the password, it is computationally infeasible to
recover the password from the message-digest value. (However, if the password is easy to guess or find in
a dictionary, a computer program can be used to search for a password that hashes to a given message-
digest value.)

Note: The input text string “abc” (length = 3 bytes) produces the hash value:

x"A9993E364706816ABA3E25717850C26C9CD0D89D"

Since this is a well-known test result for the secure hash algorithm (documented in FIPS Pub 180-1), “abc”
is not recommended as a password value. Message digests are also often used to verify that a message
has not been changed from its original value. This involves computing the message-digest of the original
message-text and transmitting it in a secure manner, either on a separate secure channel or by using
encryption of message-digest to guarantee that it is not modified during transmission. The receiver of the
message can then compute the message digest from the received message-text and verify that the
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resulting message-digest matches the one supplied. If they match, it is extremely unlikely that the message
text has been modified during transmission.

C$SetEnv
Sets or clears the value of an environment variable.

Note: When calling this routine, ensure you are using the 1024 calling convention.

Setting the value of an environment variable with C$SetEnv updates the corresponding environment
variable immediately in the process space of the current run unit. Thus, when the RM/COBOL run-time
system uses environment variables for such actions as file access name resolution, the call to C$SetEnv
will have an immediate effect on that run unit.

Syntax:
CALL "C$SetEnv" USING name, value [, return]

Parameters:
name

PIC X(n)

value
PIC X(n)

return
PIC 9(n) BINARY, where n can be a digit from 1 to 9

On Entry:

name The name of the environment variable to set or clear.

value The value to which the environment variable is set. A value of SPACES indicates that the
environment variable should be deleted.

On Exit:

return The result code returned from the call: zero for success and non-zero for failure.

Comments:

On UNIX, environment variable names are case-sensitive. On Windows, environment variable names are
not case-sensitive.

C$RERR
Returns the expanded I/O completion status, based on an error code received at run-time.

This routine returns either a four-character or an eleven-character extended status code, depending upon
the length of the data item specified in the USING phrase. This status is for the last attempted I/O
operation. The value returned conforms to ANSI COBOL 1985.

Syntax:
CALL "C$RERR" USING extended-status

Parameters:
extended-status

PIC X(4) or PIC X(11)
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On Exit:

extended-status The data item into which the expanded I/O completion status is stored in ASCII
characters.

Comments:

If extended-status is four characters in length, the first two character positions contain the same digits as
would the file status data item on completion of the I/O operation. The last two character positions provide
additional information about the file status. In cases where only two digits for a status are shown, the last
two character positions will contain ASCII zeroes. Although most statuses contain only the decimal digits 0
to 9, note that the hexadecimal digits A to F are possible in some character positions. Refer to Appendix A:
Runtime Messages of the RM/COBOL User's Guide for a full list of status codes.

If extended-status is eleven characters in length, the first two character positions (positions one and two)
contain the same digits as would the file status data item on completion of the I/O operation. In cases
where Appendix A shows only two digits for a status, the remaining nine character positions contain ASCII
blanks. In cases where Appendix A shows four digits for a status, character position three contains an
ASCII comma, character positions four and five contain the last two digits of the status, and the remaining
six character positions contain ASCII blanks. For permanent errors, that is, when the first two digits are 30,
character position three contains an ASCII comma, character positions four and five contain a two-digit OS
code (see the table below), character position six contains an ASCII comma, and character positions seven
through eleven contain a five-digit, OS-specific error code. Refer to the Input/Output Errors section of the
RM/COBOL User's Guide.

Table 1: The two-digit OS codes

Code Description

00 Unknown OS error

01 File Manager Detected error

04 UNIX error

06 Btrieve error

10 Open File Manager error

11 C Library error

12 MS-Windows error

15 RM/InfoExpress Server error

16 RM/InfoExpress Client error

21 RM/InfoExpress WinSock error

DELETE
Deletes a file.

Note: When calling this routine, ensure you are using the 1024 calling convention.

Syntax:
CALL "DELETE" USING file-name [exit-code]

Parameters:
file-name

PIC X(n)

exit-code
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PIC S9(4) BINARY

On Entry:

file-name The full or relative pathname of the file to be deleted.

On Exit:

exit-code The exit code of the command upon return from the operating system: zero for success and
non-zero for failure.

Comments:

The values for the old-name parameter may be quoted with double quotes (") or single quotes ('). When the
name is quoted, the quotes are removed, but the name is not otherwise modified. If the name is not
quoted, the first control character terminates the name on Windows and the first white space character
terminates the name on UNIX. On Windows, trailing spaces are removed from unquoted names.

The old-name data item must be less than 1024 characters in length.

RENAME
Renames a file.

Note: When calling this routine, ensure you are using the 1024 calling convention.

Syntax:
CALL "RENAME" USING old-name new-name [exit-code]

Parameters:
old-name

PIC X(n)

new-name
PIC X(n)

exit-code
PIC S9(4) BINARY

On Entry:

old-name The source filename.

new-name The target filename.

On Exit:

exit-code The exit code of the command upon return from the operating system: zero for success and
non-zero for failure.

Comments:

The values for the old-name and new-name parameters may be quoted with double quotes (") or single
quotes ('). When the name is quoted, the quotes are removed, but the name is not otherwise modified. If
the name is not quoted, the first control character terminates the name on Windows and the first white
space character terminates the name on UNIX. On Windows, trailing spaces are removed from unquoted
names.

The old- and new-name data item must be less than 1024 characters in length.
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SYSTEM
Executes an arbitrary operating system command.

Restriction: This routine is supported in native COBOL only.

When calling this routine, ensure you are using the 1024 calling convention.

Syntax:
CALL "SYSTEM" USING command-line [repaint-screen] [exit-code]

Parameters:
command-line

PIC X(n)

repaint-screen
PIC X

exit-code
PIC S9(4) BINARY

On Entry:

command-line An alphanumeric data item that contains the command line to be passed to the operating
system. The command is the contents of command-line with trailing white spaces
suppressed. The command does not need to be null-terminated.

repaint-screen This parameter is ignored in this COBOL system.

On Exit:

exit-code The exit code for the command, returned from the operating system. The value returned is
dependent on the underlying operating system. A value of 0, however, indicates success and a
non-zero value indicates an error.

Comments:

The implementation of this library routine is identical to the existing Micro Focus version of SYSTEM.

This version of the SYSTEM command is used when the calling convention is 1024. This may be specified
explicitly in the CALL, by using the DEFAULTCALLS Compiler directive, or by specifying the DIALECT"RM"
Compiler directive.

RM/COBOL File Handling
When you migrate your RM/COBOL applications to Enterprise Developer, you can continue to use the
same data files.

Alternatively, you can use a data migration tool to convert an RM/COBOL data file to Micro Focus format.
The data migration tool is available as a product sample, as a solution named RMMFDataMigration.

Configuring Access to RM/COBOL Indexed Data Files

Note: For these options to take effect, the ACUFH configuration option must be set ON; by default,
this is ON. For these options to take effect under Enterprise Server, ESACUFH must also be set ON;
by default, this is OFF.

To handle RM/COBOL indexed data files, you map a file to IDXFORMAT=21 in the File Handler
configuration file.
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Within the configuration file, you can apply IDXFORMAT 21 to all files in a particular folder, all files with a
specific file extension, or a single file. See Format of the Configuration File for the tags that you can use for
the mapping, and the order in which settings in these tags are applied.

The order that the mapping is applied is important, as conflicting settings can be overwritten; for example,
the following excerpt of the configuration file sets all files in c:\files\rmfiles to IDXFORMAT 21 and
all files with a .DAT extension to IDXFORMAT 17:

[FOLDER:C:\\files\\rmfiles]
IDXFORMAT=21

[*.DAT]
IDXFORMAT=17

If there is a .DAT file in c:\files\rmfiles, the mappings are applied according to the type of tag. In the
case above, mappings in the extension tag are applied after mappings in the FOLDER tag, and so
the .DAT file in that directory has an IDXFORMAT of 17.

By default, the File Handler handles all sequential and relative data files, but if you want to handle them
through the RM/COBOL file handler, use the INTEROP=RM configuration option; however, in cases where
the INTEROP and IDXFORMAT mappings conflict, the INTEROP setting will override IDXFORMAT for your
RM/COBOL indexed data files.

File Limits
When using RM/COBOL indexed files in Enterprise Developer, there are a number of file limits that affect
file handling operations.

The following limits are in addition to the ones imposed in Enterprise Developer; see Limits in the File
Handling Reference section.

Note: The limits listed on this page override any listed in the File Handling Reference section when
handling RM/COBOL indexed files.

Maximum record size: 64 MB (67,108,864)

Maximum number of indexed keys: 1 primary + 119 alternates

Maximum number of segments per key: 16

Maximum indexed key size: 250 bytes

RM/COBOL File Status Codes

RM/COBOL file status codes take a 2-digit form in the file status data item (by combining the values of the
Status Key 1 and Status Key 2 columns), or a 4-character or 11-character extended file status code that
can be retrieved using the C$RERR standard library routine.

RM/COBOL file status codes are always returned when the FILETYPE=21 Compiler directive is in effect. If
you set the DIALECT"RM" Compiler directive, this automatically sets FILETYPE=21, thus producing RM/
COBOL file status codes.

If you are running under a different dialect or FILETYPE setting, but want to continue to return RM/COBOL
file status codes, do the following:

• Set environment variable COBFSTATCONV to the RM/COBOL setting:

set COBFSTATCONV=rmstat

• Set the COBFSTATCONV Compiler directive.

If your program is set to return RM/COBOL file status codes, but does not use a file status, or does not
have a Declaratives section acting upon your data file, file I/O errors are reported by the run-time system.
The extended file status reported may initially seem incorrect, but due to differences in the file handling of
the different COBOL systems, the second byte of the reported error code needs to be converted from
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binary to ASCII. For example, if an error of 9/051 is reported, convert 051 to its ASCII character
equivalent, which is 3 (0x33 in hexadecimal); therefore, the true RM/COBOL file status is actually 93.

Status Key 1 Status Key 2 Extended File Status
Code

Description

3 5 9/013 File not found.

3 5 9/188 Filename too large.

3 7 9/035 Incorrect access
permission.

3 7 9/037 File access denied.

3 8 9/138 File is closed with lock -
cannot open.

3 8 9/210 File is closed with lock.

4 1 9/141 File already open - cannot
be opened.

4 2 9/142 File not open - cannot be
closed.

4 3 9/143 REWRITE/DELETE not
after successful READ

4 6 9/146 No current record defined
for sequential read.

4 7 9/147 Wrong open or access
mode for READ/ START.

4 8 9/148 Wrong open or access
mode for WRITE.

4 9 9/149 Wrong open or access
mode for REWRITE/
DELETE.

9 3 9/065 File locked.

9 8 9/071 Bad indexed file format.

9 8 9/139 Record length or key
inconsistent.

9 9 9/068 Record is locked.

Debugging .NET COBOL Using RM/COBOL Indexed Files

When you debug a .NET COBOL application, there is a danger that an RM/COBOL indexed file will
become corrupted when debugging ends, as the file is not closed correctly by default.

To ensure the file is closed correctly when debugging ends, you should set the
RMFM_PRETEND_FORCE_CLOSED=YES environment variable. For .NET COBOL applications, it is not
strictly necessary to set this variable, as the File Handler can usually close the file correctly, although,
setting this variable will ensure any data file is always closed correctly.

1. In Solution Explorer, right-click project-name and select Add > New Item.
2. In the Add New Item dialog box, select Application Configuration File, update the Name field (if

required), then click Add.

The application file is added to the project.

146 | Upgrading to Enterprise Developer



3. In Solution Explorer, right-click the file, then select Edit.

The Application Settings dialog box appears.
4. On the Environment tab, enter the following, then click Set:

• Name: RMFM_PRETEND_FORCE_CLOSED
• Value: YES

5. Click OK.
6. Rebuild and then debug your project.

Enabling CTF to Trace RM/COBOL Data Files
Enable the Micro Focus Consolidated Tracing Facility (CTF) to trace activity with your RM/COBOL data
files.

To enable CTF:

• Set the following environment variables:

set MFTRACE_CONFIG=ctf.cfg
set MFTRACE_LOGS=pathname   *> if not set, logs are stored in the current 
folder.

• In ctf.cfg, set the following:

mftrace.dest                = textfile
mftrace.level.mf.rts        = info
mftrace.comp.mf.rts#eprintf = true

• Set the following environment variable:

set A_CONFIG=rmfm.cfg    *> rmfm is your RMFM configuration file

• In rmfm.cfg, set the following:

DEFAULT_FILESYSTEM RMFM
FILE_TRACE 3   *> values 0-9 set amount of activity traced.

When you run your program, a log-file is produced that includes the activity with the RM/COBOL data files.

For more information on CTF, see Introduction to the Consolidated Tracing Facility.

Data File Utilities

The following utilities are available to use with your RM/COBOL data files:

Indexed File Recovery (recover1) utility

The recover1 utility recovers data stored in an RM/COBOL indexed file . It is a standalone program; that
is, it does not require use of the Runtime Command to be executed.

Note:

• Unless specifically stated otherwise, the name recover1 refers to both the UNIX (recover1) and
Windows (recover1.exe) versions of the recover1 program.

• If the output window of the Windows version of the recover1 program disappears upon
successful completion and you want that window to remain visible, set the Persistent property
to True for the recover1 program.

• The recover1 utility does not use the environment variable RUNPATH to locate files. It is best to
specify the full pathname of the indexed file to be recovered or to run recover1 from the current
directory in which the indexed file resides.

Recovery command

The Indexed File Recovery (recover1) utility is executed by issuing the following command:

recover1 indexed-file drop-file [options] ...
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indexed-file
The filename of the indexed file to be recovered. The name is not resolved through any
environment variables.

drop-file
The name of the file where recover1 places any unrecoverable records found in the
indexed file, as discussed in Recovery process description. If drop-file specifies an
environment variable name, the environment variable value will be resolved before opening
the dropped record file.

options
Zero or more command line options, as described in Recovery command options. Options
are specified with letters that must be preceded with a hyphen (-) or a slash (/). Option
letters may be specified in uppercase or lowercase. Certain option letters allow an optional
pathname as part of the option format. The presence or absence of the pathname is
determined by whether or not the next non-white space character following the option letter
is a hyphen or slash, whichever one was used preceding the option letter.

Note: The option introducer character slash is supported for Windows compatibility and should not be
used on UNIX, where it can be confused with an absolute pathname; that is, a pathname that begins
with a slash. Nevertheless, either the hyphen or the slash may be used to introduce option letters on
Windows and UNIX. In the option formats given, only the hyphen is shown, but the hyphen may be
replaced with a slash.

Recovery command options

Recovery command options can be specified in either of the following two ways:

• Depending on the operating system, they can be placed into the Windows registry or the UNIX resource
file:

• In the Windows registry, the Command Line Options property provides command line options for the
Indexed File Recovery utility when Recovery is selected on the Select File tab of the RM/COBOL
Properties dialog box.

• In the UNIX resource file, the Options keyword, described in Command Line Options, provides
command line options for the Indexed File Recovery utility in the global resource file /etc/default/
recover1rc and the local resource file ~/.recover1rc.

• They can be specified in the Recovery Command itself.

The following options may be specified to modify the behavior of the Indexed File Recovery (recover1)
utility.

I Use the I option to cause recover1 to test only the file integrity and then stop. The file will not be
modified in any way. Specifying the I option causes both the T and Z options to be ignored. If no
problems are discovered, the exit code is set to 0. If a problem is discovered, the exit code is set to 1.
The I option has the following format:

-I

The default is for recover1 to do a complete recovery of the indexed file if the file is marked as needing
recovery. See the Y and Z options in this topic for additional options that modify the behavior of the
Indexed File Recovery utility.

Note: The integrity scan is a quick test of the file and is not comprehensive. Some problems,
such as records with invalid duplicate keys, will not be detected. Indexed files with no errors
detected by the integrity scan may still receive “98” errors or other I/O errors.

K Use the K option to indicate that the Key Information Block (KIB) should be assumed to be invalid and,
optionally, to specify a template file for recovering the KIB. The K option has the following format:

-K [template-file]
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If no template-file is specified, the user will be prompted either for a template file or for enough
information to rebuild the KIB. If template-file is specified, it should be the name of a valid indexed file
with the same format as the file being recovered. This file will be used as a template. The required KIB
information is read from the KIB of the template file. The template file can be a backup copy of the file
being recovered, if the backup occurred before the file was damaged, or, it can be a file created by
performing an OPEN OUTPUT in a COBOL program with the proper file control entry and file
description entry for the file being recovered. An OPEN OUTPUT must have been performed on the
template file, but it need not contain any records. A template file must be specified if the KIB is corrupt
and the file uses either an enumerated code set or an enumerated collating sequence. The default is
to check the KIB for validity and, if it is found to be invalid, prompt for either a template file or
information to rebuild the KIB. The name of the template file is not resolved through any environment
variables.

Warning: A template file with the wrong block size can cause the loss of a large percentage of
the recoverable records in your file.

L Use the L option to write information about errors encountered while recovering the file to a log file.
The L option has the following format:

-L [log-file]

Only the first 100 errors will be logged. In addition to errors, a number of informational lines about the
indexed file and its recovery are written to the log file, including information about sort memory (see
the M option regarding sort memory). If log-file specifies an environment variable name, the
environment variable value will be resolved before opening the log file; this allows the use of the name
PRINTER to send the log information to the print device. If log-file is omitted in the L option, the default
value of log-file is PRINTER. If the L option is not specified, the default is not to write a log file.

Note: Environment variables can be set using synonyms set in the Windows registry or the
UNIX resource file.

M Use the M option to specify the number of megabytes of memory to allocate to the sort algorithm used
in phase 4, build node blocks. The M option has the following format:

-M [MB-of-memory]

where MB-of memory is a number in the range 0 to 2000. Allocating more memory generally results in
faster execution of recover1 and causes fewer node blocks to be built. If this option is not specified, a
suitable number will be computed; in this case, sort memory is limited to no more than 40 million
bytes. When a log file is written (see the L option), a line is written into the log file to show the
maximum effective sort-memory size. If the M option is specified without a number of megabytes, the
default value of 50 is used.

Note: Specifying a number for MB-of-memory that is too large for your system may result in
very poor system performance.

Q Use the Q option to cause recover1 to perform its work without displaying information or asking the
operator questions. The Q option has the following format:

-Q

If the file is marked as needing recovery, or has a non-zero Open For Modify Count, then it will be
recovered. Otherwise, no action occurs. This behavior can be modified by using the Y option. The
default is to display information and ask questions, which must be answered by the operator.

T Use the T option to indicate that unused space should be truncated and returned

to the operating system. The T option has the following format:

-T

Specifying the T option will result in a minimal size indexed file, but may reduce performance if records
are subsequently added to the indexed file. The default is not to truncate the file. When the file is not
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truncated, any empty blocks remain part of the file and are available for use in adding new records to
the file.

Note: Some versions of UNIX do not support the operating system call required to

truncate a file.

Y Use the Y option to cause recover1 to assume that the operator wants to answer “y” to all possible
questions and therefore not stop to wait for a response. The Y option has the following format:

-Y

Using the Y option will cause a file to be recovered even if it is not marked for recovery, including the
case of when the Q option is also specified. The default is to wait for a response from the operator
after a question is displayed.

Z Use the Z option to reset the Open For Modify Count to zero, without performing a full recovery. The Z
option has the following format:

-Z

If the file is marked as needing recovery, the Z option is ignored. The default is to treat a non-zero
Open For Modify Count as indicating that the file needs recovery.

Note: Use the Z option with caution. Resetting the Open For Modify Count to zero without
performing a full recovery may leave the file in a corrupted state.

Recovery process description

If the recover1 program is successful, the exit code is set to 0. If the recover1 program is canceled by the
operator, the exit code is set to 2. Otherwise, the exit code is set to 1.

You may produce a list of the support modules loaded by the recover1 program by defining the
environment variable RM_DYNAMIC_LIBRARY_TRACE. The listing will indicate which Terminal Interface
support module is used, only the terminfo module is included with Visual COBOL. The Automatic
Configuration File module is not included with Visual COBOL. This information is most helpful when
attempting to diagnose a problem with support modules.

Note: The information will be visible only if you enter the recover1 command without any parameters.
In this case, recover1 will show the proper form for the command and the list of support modules.

The recover1 program attempts to recover the indexed file in place; that is, the program rebuilds the
internal file structure in the actual file being recovered. If necessary, the Key Information Block (KIB) is
rebuilt and any corrupted data blocks are repaired. Corrupt data blocks may result in loss of some data
records. Because of this feature, it is strongly recommended that you either backup the file or copy the
indexed file to be recovered to some other directory or pathname as additional security. Any records that
cannot be successfully reindexed into the file due to invalid duplicate key values, or invalid record sizes, are
decompressed (if compression is selected for the file), converted to the native code set, and then written to
drop-file. recover1 should be able to handle most kinds of indexed file corruption problems, but some fatal
errors may still cause the recovery to fail. Any fatal error is displayed and causes the program to terminate.
Broken hardware should be suspected in many of these cases.

drop-file can be in fixed- or variable-length format; this is set by recover1 based on whether indexed-file is
fixed- or variable-length format. Records placed in drop-file were those undergoing change at the time of
the system failure that required recovery or have invalid record sizes. Investigate any records appearing in
drop-file and make the appropriate corrections to indexed-file.

The four phases of processing

The recover1 program’s processing consists of up to four separate phases, which are run in the following
order:
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1. Integrity Scan. If the Q option or Y option is specified, the Integrity Scan phase is disregarded unless it
is forced to occur by the specification of the I option or L option. This phase reads the entire file in a
forward direction checking for simple errors, and produces a summary report showing the state of the
file and an estimate of the number of records recover1 can recover. The indexed file is not modified
during this phase.

2. Repair Blocks. The Repair Blocks phase, which is always run, reads and writes the file in a backward
direction repairing corrupt data blocks, converting non-data blocks to empty blocks, and rebuilding some
internal file structures.

3. Move Data Blocks. The Move Data Blocks phase is run only when the truncate file

option (T) is specified. This phase reads and writes parts of the file moving highnumbered data blocks
(near the end of the file) to lower-numbered available blocks to maximize the amount of space at the
end of the file that can be truncated and returned to the operating system when recover1 finishes.

4. Build Node Blocks. The Build Node Blocks phase, which is always run, reads data blocks and writes
node blocks in the file in a forward direction, rebuilding the entire node structure for each key of the file.

Note:

• After the Integrity Scan phase, if the Estimated Recoverable records value is zero or very low, and
the number of corrupt data blocks is very close to the total number of data blocks found, the
number of keys that allow duplicates may be incorrect, either because the KIB is corrupt or the
user provided incorrect key information to recover1.

• After the Integrity Scan phase, if most of the blocks are invalid, the Disk Block Size or the Disk
Block Increment may have been incorrectly specified or the KIB may be corrupt.

• During the Repair Blocks phase, a count of blocks that could be read but not written may be
displayed. This count may indicate the presence of a hardware problem with your disk.

Recovery support module version errors

During initialization, the recovery utility locates and loads various support modules, and, on UNIX, the
terminfo Terminal Interface support module. Also, at initialization, the recovery utility verifies that each
support module is the correct version for the recovery utility. If a support module is not the correct version,
the following message is displayed:

RM/COBOL: module-name version mismatch, expected 12.0n.nn,found n.nn.nn.

When the previous message is displayed, the recovery utility terminates with the following message:

Recover1: Error invoking mismatched recover1 and support module.

Recovery example

An example run through the Indexed File Recovery utility is described in Figure 1 through Figure 4. The
recovery session is started in this example by the following command:

recover1 master.inx dropout1

Figure 1 shows information about the file master.inx.

Under the name of the file to be recovered, a description of the state of the file is displayed. Any of the
following messages may appear:

• This file has not been marked as needing recovery!
• The Open For Modify Count for this file is not zero: count
• File has been marked as corrupted due to a previous error.
• KIB is corrupt. Using template file: template-file
• KIB is corrupt. Enter a template filename (press Enter for manual entry).

If the KIB is corrupt, and a template filename is not entered, recover1 will prompt the user for the required
KIB information before continuing.

If more keys exist than can appear on this screen, as many as possible appear, after which you are asked if
you want to see the remaining key descriptors. This continues until all keys are shown. You are then asked
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to verify that this is the file you want to recover. Entering N terminates the program. Entering Y continues
the program.

                 Indexed File Recovery Utility
                   Recover1 for Visual COBOL
Indexed File: master.inx

This file has not been marked as needing recovery!

Disk Block Size:        1024   Minimum Record Length:  80
Disk Block Increment:   1024   Maximum Record Length:  80
Number of Index Blocks:  170   Number of Records:     150

  Key  Position Size Remarks
PRIME     1      8
    1     9      8 
    2     17     8   duplicates allowed

Is this the file you wish to recover (y/n)?

Figure 1: Indexed File Recovery Utility: File Recovery Verification

Figure 2 shows a summary of the information that is gathered during the file integrity scan.

You are then asked if you would like to proceed with the recovery process. Entering N terminates the
program. Entering Y continues the program. The “Average record length” is computed by adding the length
of all the records in the file and dividing by the number of records. The “Average data size” is computed by
adding the size that the record actually occupies in the file and dividing by the number of records. This size
allows you to determine how much your data can be compressed.

                Indexed File Recovery Utility
                  Recover1 for Visual COBOL
Indexed File: master.inx

Drop File: dropout1

This file has not been marked as needing recovery!

Disk Block Size:        1024 Minimum Record Length:  80
Disk Block Increment:   1024 Maximum Record Length:  80
Number of Index Blocks:  170 Number of Records:     150
Phase: Integrity Scan        Estimated Recoverable: 150

           |   Total |   Total |   First |   Last  |
Block Type | Found   | Corrupt | Corrupt | Corrupt |
KIB        |     1   |       0 |         |         |
Data       |   102   |       0 |         |         |
Node       |    61   |       0 |         |         |
Empty      |     6   |       0 |         |         |
Invalid    |     0   |       0 |         |         |
Unreadable |     0   |       0 |         |         |

Average data size: 14, Average record length: 80
Do you wish to proceed with recovery (y/n)?

Figure 2: Indexed File Recovery Utility: recover1 Summary

Figure 3 shows the information that is displayed while recover1 is rebuilding the node blocks for the prime
key.

                Indexed File Recovery Utility
                  Recover1 for Visual COBOL
Indexed File: master.inx

Drop File: dropout1
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This file has not been marked as needing recovery!
    
Disk Block Size:        1024 Minimum Record Length:  80
Disk Block Increment:   1024 Maximum Record Length:  80
Number of Index Blocks:  170 Number of Records:     150
Phase: Build Node Blocks     Estimated Recoverable: 150
 
Key being processed:                        PRIME
Records recovered:                            100
Records written to drop file:
Block being processed:                         13
Number of data blocks moved (for truncate):     5

Figure 3: Indexed File Recovery Utility: recover1 Statistics

Figure 4 shows the information that is displayed after recover1 terminates successfully. The two lines
regarding truncation are shown only when the T option is specified.

             Indexed File Recovery Utility
               Recover1 for Visual COBOL
Indexed File: master.inx 

Drop File: dropped

This file has not been marked as needing recovery!     

Disk Block Size:        1024 Minimum Record Length: 126
Disk Block Increment:   1024 Maximum Record Length: 126     
Number of Index Blocks:  120 Number of Records:     100
Phase: Build Node Blocks     Estimated Recoverable: 100

Key being processed:                        PRIME          
Records recovered:                            100
Records written to drop file:
Block being processed:                        120
Truncate option specified - number of data blocks moved:   4
Truncate action successful - new Number of Index Blocks: 112

Recovery successful.

Figure 4: Indexed File Recovery Utility: recover1 Finished Successfully

In the example shown in Figure 5, the KIB of the file has been corrupted, and key information must be
entered for the file to be recovered. This example shows manual entry of KIB information, however, it is
recommended that a template file be used with the -K option to recover the KIB information. Underlined
characters have been entered by the user.

The recovery session is started by the following command:

recover1 master.inx dropout1 -k

Note: Entering incorrect information about how many keys, or which keys, can have duplicate values
may cause unpredictable results.

             Indexed File Recovery Utility
                Recover1 for Visual COBOL
Indexed File: master.inx

Last error was 98,38 at 9:29 on 03-21-2008    
 
Are any of the keys in this file segmented (split) (y/n)? y
Key #: PRIME Segment #: 2 Starting Position? 10 Length? 5
             Another Segment (y/n)? n
             Total Key Length = 13 Duplicates Permitted (y/n)? n
Another Key (y/n)? n
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Figure 5: Indexed File Recovery Utility: Entering Key Information

Figure 6 shows an example of entering the remainder of the KIB information. Underlined characters have
been entered by the user.

              Indexed File Recovery Utility
                 Recover1 for Visual COBOL
Indexed File: master.inx

Last error was 98,38 at 9:29 on 03-21-2008

Minimum Record Length (in bytes)? 80
Maximum Record Length (in bytes)? 80               
Disk Block Size (in bytes)? 1024
User Block Size (1=none/2=in bytes/3=in records)? 1     
Data Compression (y/n)? y    Space Character Value? 32   Zero Character 
Value? 48
Key Compression  (y/n)? y    Space Character Value? 32
File Version Number (0/2/3/4)? 4   Atomic I/O Enabled (y/n) y          
File Lock Limit (in GB)? 2
Disk Block Increment (in bytes)?  1024     
Allocation Increment (in blocks)? 8
Force Write Data Blocks (y/n)? n    Force Write Index Blocks (y/n)? n     
Force to Disk (y/n)? n              Force File Closed (y/n)? n
Code Set (1=none/2=ASCII/3=EBCDIC)? 1
Collating Sequence (1=none/2=ASCII/3=EBCDIC)? 1     
     
Is this information correct (proceed with recovery) (y/n)? y

Figure 6: Indexed File Recovery Utility: Entering KIB Information

After the key and KIB information has been successfully entered, the recovery process proceeds the same
as before, beginning with Figure 1. If a template file had been specified on the command line or a template
filename had been entered when prompted, the screens prompting for the key and KIB information would
not have been displayed. A template file must be specified if the KIB is corrupt and the file uses either an
enumerated code set or an enumerated collating sequence.

Recovery program error messages

Error status initializing file manager

recover1 was unable to initialize the RM/COBOL file management system for the reason indicated by
status. The usual cause for this error is that a buffer pool has been configured that is too large to be
allocated. See the BUFFER-POOL-SIZE keyword of the RUN-FILES-ATTR configuration record for
instructions on changing the buffer pool size.

Truncate option not supported

recover1 detected that the truncated function was not supported on the system when the user requested
file truncation. Truncation of the file is not possible.

recovery terminating - no records recoverable!

recover1 detected corruption in the indexed file and no records could be recovered. In this case, recover1
terminates at the end of the integrity scan to protect the user from erroneously deleting all the records from
the file. This error may indicate that the block size, the block size increment, or the number of keys that
allow duplicates has been incorrectly specified, or the KIB may be corrupt.

Error status on template file

recover1 was unable to initialize the RM/COBOL file management system for the reason indicated by
status. The usual cause for this error is that a buffer pool has been configured that is too large to be
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allocated. See the BUFFER-POOL-SIZE keyword of the RUN-FILES-ATTR configuration record for
instructions on changing the buffer pool size. recover 1 detected an error in the KIB of the template file
specified by the user. The user may enter another template file, may enter the KIB information manually, or
may enter a Ctrl- C to terminate recover 1.

Cannot write near end of file - check "ulimit"

recover1 detected that blocks near the end of the file can be read but not written, but other blocks of the file
may be both read and written. This error may indicate that the operating system file size limit (ulimit) may
be smaller than the size of the file. Set the file size limit correctly or use an account with sufficient privileges
and run recover1 again.

RM/Panels
RM/COBOL's RM/Panels is a graphical user interface that uses panels (screens) and controls defined in a
Panel Library file. The RM/Panels application interacts with the panels and controls through a RM/COBOL
program runpan2.cob. The runpan2 application has been converted to be compatible with Micro Focus
COBOL, so that RM/COBOL applications that use RM/Panels can be converted to run in Enterprise
Developer, when compiled with the Dialect"RM" Compiler directive.

An RM/Panels application has the following:

• Panel Library: The panel library file is a binary file. It is loaded at run time by the runpan2 program.
Each panel definition within the file includes information on sizes, background text, attributes, and
controls. The name of the library file is passed to runpan2 by setting the value of RMP-LIBRARY. The
RM/COBOL library file is used without any modifications because runpan2 expects the file format to be
in RM/COBOL format. Refer to your RM/Panels Reference Manual for information on the RM/Panels
Designer and the creation and editing of the Panel Library.

• Working Storage definition for each panel: Generally, each panel will have a <panelname>.ws file
associated with it. The fields in the file represent the data for the controls defined on the panel. This file
should not be edited manually; the fields are generated by the RM/Panels Designer.

• Procedural code for each panel: Each panel will also have procedural code in a <panelname>.prc
file that defines the functions for interacting with the panel. This file can be edited manually, if
necessary.

• rmpanels.ws: This copybook contains the fields for controlling the panels and controls, such as the
current and next field values. This file also specifies the name of the program that loads the library file.
The RMP--RUNTIME field value should be set to either:

• runpan2.dll on Windows; or
• cobrunpan2 (32-bit), or cobrunpan264 (64-bit) on UNIX

In addition to these elements taken from the original RM/COBOL application, the following additional
elements are required for the application to run correctly in Enterprise Developer:

• ADISCTRL: This file specifies a number of settings that control how ADIS handles ACCEPT and
DISPLAY commands. The instance of the file in the application's path needs to have the RM-Panels
configuration selected.

• The Dialect"RM" Compiler directive: This directive will most likely already be set as part of the
conversion process from RM/COBOL. If this is not set, some features of ADIS and runpan2 may not
behave as expected.

For more details on the actual conversion process, see Conversion Example.

Restrictions and Limitations

The following restrictions apply when using applications that contain RM/Panels
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No Panel Editor in
Enterprise Developer

The RM/Panels product includes both a run-time system and a designer/
editor of the panels. The RM/Panels Designer, the application that enables
you to create or modify RM/Panels library files, is not available in Enterprise
Developer. However, the RM/COBOL version can still be used to modify the
library files.

No End-User Panel
Editor

In RM/COBOL, you can enable an option to bring up the Panel Editor at run-
time. This is not supported in the Enterprise Developer version of RM/
Panels.

Character-based controls
only

On Windows, controls are always character-based. In some versions of RM/
COBOL, certain controls could be converted on-the-fly to Windows controls.
This is not supported in the Enterprise Developer version of RM/Panels.

RM/Panels applications
not interchangeable
between platforms

RM/Panels applications designed for Windows are not compatible on UNIX
platforms and vice versa. This is because of the difference in line terminators
and line draw characters between the two platforms.

Modeless operation not
supported

The utility function (RMP--U-SMD), which initiates modeless operation, has
no effect.

Panels 2.0 support only There were significant changes to the Panels library file between versions
1.0 and 2.0. The runpan2 program will support the Panels 2.0 library file
only. Refer to the RM/Panels Reference Manual for instruction on converting
from version 1.0 to 2.0.

Converting RM/Panels Applications

Converting an existing RM/COBOL program to run in Enterprise Developer can be simple or complex,
depending on the portability of the syntax and data types used in the program. Generally, the Dialect"RM"
Compiler directive is sufficient to allow an RM/COBOL program to compile in Enterprise Developer.

See the section Converting RM/COBOL Applications for details about converting the application to run
under Enterprise Developer.

The additional steps you need to take for applications that include RM/Panels are:

ADISCTRL The ADISCTRL configuration file controls how the Micro Focus Adis routine handles
ACCEPT and DISPLAY statements. It contains a configuration required for applications
using RM/Panels syntax.

The default location for this file is %ProgramFiles(x86)%\Micro Focus\Enterprise
Developer\etc. If this location is not writable, copy the file to another location, and edit
and use that copy in your application.

The first ADISCTRL file in the executable path should be set to the predefined configuration
RM-Panels in order for the display and keyboard behavior to function correctly. This is done
by running the adiscf.exe utility while in the directory of the ADISCTRL file you plan to
use.

Note: ADISCTRL also contains a general RM2VCOB configuration for modernizing
RM/COBOL applications, but it is the RM-Panels configuration that you must use if
your application contains RM/Panels syntax.

RMP--
RUNTIME

This is a field declared in the rmpanels.ws copybook that specifies the runpan2 library.
You need to edit this value in the copybook from your RM/COBOL application and ship it
with the other converted files for the application.

RMP--RUNTIME is set to runpan2 in the original RM/COBOL rmpanels.ws copybook. In
Enterprise Developer, the value needs to identify the library that contains the runpan2 entry
point. On Windows, that is runpan2.dll (the .dll extension is required to locate the
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library file); on UNIX, that is cobrunpan2 (32-bit) or cobrunpan264 (64-bit) (do not
include the .so suffix of the library file).

Conversion Example: Using Visual Studio

The following is an example conversion from RM/COBOL to Enterprise Developer using Visual Studio as
the IDE.

The application in this example is called qdemo, and has two panels: custinfo and message.

The following files are from the original RM/COBOL application:

• qdemo.cbl: Main COBOL program file
• custinfo.prc: Procedural code for the custinfo panel
• cusinfo.ws: Data for the custinfo panel
• message.prc: Procedural code for the message panel
• message.ws: Data for the message panel
• rmpanels.ws: Control data for RM/Panels
• qdemo.lib: RM/Panels library file

The following files are available from Enterprise Developer:

• ADISCTRL: The ADIS configuration file for ACCEPT/DISPLAY statements.

Creating a Visual Studio Project for the RM/Panels Application

The first task is to create a project. Visual Studio uses the concept of a 'solution' to hold one or more
related projects. Unless you specify an existing solution when creating a project, a new one is created for
you.

1. In Visual Studio, click File > New > Project.
2. In the New Project dialog box, expand Installed > COBOL. Then, click Native.
3. From the list of project types, select Windows Application 

Choosing Windows Application is important because that will cause the program to use runw.exe
instead of run.exe.

4. In the Name field, type vc_qdemo as the name for the project.
5. In the Location field, specify a location for the project.
6. Click OK. 

The project is created within a solution of the same name, and then opened, ready to edit. The next task
is to add the supporting files to the project.

Set the DIALECT"RM" Compiler Directive for the Project

Set the DIALECT"RM" directive in the project's properties so that it applies to all programs within the
project unless you explicitly override it at the program level.

1. In Solution Explorer, double-click Properties, which is listed under the name of the project you created
in the previous step. 
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A tabbed list of properties for the project appears.

2. Select COBOL. 

The COBOL-specific project properties pane appears.

3. In the COBOL dialect field, select RM/COBOL.

4. Click File > Save All to save the project. 

The RM/COBOL dialect is applied to any program within the project, unless that program overrides it by
setting the DIALECT directive explicitly within the source code.

The next task is to add some RM/COBOL source code to the project.

Download the Tutorial Files

The source files required to run the tutorial are available from the Micro Focus Community web site.

Note: To download the files, you do not need to be a registered user of the Community web site, but
to post comments or questions about the tutorial, on the forum, you will need to register and join the
Visual COBOL group.

1. Visit the Micro Focus Community web site.

2. Click Select Product, then choose Visual COBOL. 

The Visual COBOL group appears.

3. Click the Visual COBOL Files tab. 

A list of Articles appears.

4. Click the appropriate Visual COBOL RM/Panels Conversion entry for your platform.

5. Click the Download icon to the right of the zip filename in the Attachments list, and save the .zip file.

6. Extract the contents of the .zip file to the project directory.

Import the RM/Panels Source Code
Import the required source files into the project.

1. In Solution Explorer, right-click Program1.cbl, select Delete, then click OK to confirm deletion. This is
a default file that Visual Studio creates, but it is not required for the tutorial.

2. In Solution Explorer, right-click the project name and select Add > Existing Item.

3. Browse to the location that you downloaded the source to, select the following files, then click Add. 

• qdemo.cbl: Main COBOL program file
• custinfo.prc: Procedural code for the custinfo panel
• cusinfo.ws: Data for the custinfo panel
• message.prc: Procedural code for the message panel
• message.ws: Data for the message panel
• rmpanels.ws: Control data for RM/Panels
• qdemo.lib: RM/Panels library file
• ADISCTRL: The ADIS configuration file for ACCEPT/DISPLAY statements.

Note: If the files are not displayed, to the right of the File name field, change the file type filter to display All Files (*.*).
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The files are added to the project, and is displayed in the Solution Explorer.

Tip: You can drag the files into the project from Windows Explorer, and drop them on the project
name to add them directly to the project.

4. Click File > Save All to save the project.

The next task is to add some configuration files to the project.

Configure Adis Support for RM/Panels
After importing the Adis configuration file, you must configure it to handle the enhanced ACCEPT and
DISPLAY statements in a way that RM/Panels is expecting it to.

Enterprise Developer ships with a version of Adis that contains a configuration intended for applications
that include RM/Panels syntax.

1. Using an  Enterprise Developer command or shell prompt, navigate to the project directory (that is, the
directory containing ADISCTRL).

2. Enter ADISCF. 

The adiscf.exe window appears.

3. Press F6, then ensure that the RM-Panels configuration is selected. 

4. Press Esc twice to exit. 

Note: if you are prompted to exit without saving, press N, F4, then Esc twice again.

5. To verify the correct build properties are set for Adis:

a) In Solution Explorer, right-click ADISCTRL and select Properties. 

The properties for the file appear in the Properties pane.
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b) Ensure that: 

• Build Action is set to None.
• Copy to Output Directory is set to Copy if newer.

c) Repeat these steps and set the same properties for qdemo.lib.

6. Click File > Save All to save the project.

The next step is to configure the IDE so that it recognizes the appropriate copybooks.

Configure the Supported Copybook Extensions
Configure Visual Studio to recognize the appropriate RM/COBOL file extensions as copybooks in
Enterprise Developer.

1. On the Tools menu, select Options. 

The Options dialog box appears.

2. In the left-hand pane, select Text Editor > Micro Focus COBOL > Advanced. 

The Advanced settings appear in the right-hand pane.

3. For the list of values of the Copybook Extensions option, append ,.prc,.ws to the end of the list,
then click OK. 

Files with the extension .prc or .ws are now recognized as copybooks for all projects in Visual Studio.

Note: If the COPY statements in your source code reference any of these files without specifying
the extension, you should also set the COPYEXT"prc,ws" Compiler directive in your project.

Build and Run the Application
Build the project within the solution and then run the application.

1. Click Build > Build Solution. 

The Application Output window displays information about the progress of the build result.

If there are any problems, they are displayed in the Error List window. Double-click an entry to jump to
the particular area of the code in error.
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2. Press F5 to run the application. 

The following appears:

3. When you have finished viewing the demonstration, click the Close button in the top right-hand corner.

This concludes the tutorial in which we have created a project in Enterprise Developer, configured it to
accept RM/Panels syntax, and then run a small program that demonstrates that.

Writing Programs

RM/Panels provides a powerful set of standard run-time functions for writing application programs. To use
RM/Panels effectively, you must understand the general approach to using these standard run-time
functions and have some familiarity with the specific usage of each one. Utility functions, which allow you to
control the overall behavior of the RM/Panels run-time system, rather than manipulate individual panels,
are also described.

This section discusses the basic processes of activating a panel library, setting parameters, executing
standard run-time functions, including required copy files, error detection, and the appropriate screen
handling strategy, followed by a detailed description of each RM/Panels standard run-time and utility
function.

Standard Run-Time Function Basics

Activating a Panel Library

Before your application can use or access individual panels, it must activate the library in which they are
contained. The panel library remains active until a different library is activated. Related panels should be
grouped into libraries so that RM/Panels does not have to repeatedly change from one library to another.

A library is activated by moving the filename of the library into the variable RMP--LIBRARY. The library
becomes active the next time an RM/Panels standard run-time function is used.

Example:

MOVE "libraryname.LIB" TO RMP--LIBRARY.

Setting Run-Time Parameters

Parameters are variables that are set to control the execution of RM/Panels. Two types of parameters are
used with RM/Panels standard run-time functions:

• Required, which are those parameters that must be set to valid values in order for a standard run-time
function to execute correctly.

• Optional, which are those parameters that can be set to override the default behavior specified for the
panel. Optional parameters are always reset to their default values by the RM/Panels run-time system
after the function is executed. This prevents later executions of the standard run-time function from
inheriting the overridden behavior.
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Some optional parameters are controlled by SET statements. The following example sets an optional
parameter for the DISPLAY PANEL standard run-time function that displays field/control values along with
panel text.

Example

SET RMP--SHOW-FIELDS TO TRUE.

Other optional parameters are controlled by MOVE statements. The following example sets a required
parameter for the DISABLE FIELD FOR INPUT standard run-time function. This parameter identifies which
field/control to disable.

Example

MOVE "CUSTOMER-NUMBER" TO RMP--FIELD-NAME.

All the parameters for RM/Panels standard run-time functions are listed in Appendix B, Standard, Utility,
and Extended Run-Time Functions and Parameters, and are contained in the master copy file,
RMPANELS.WS; see Appendix A, Master Copy File RMPANELS.WS for a description of RMPANELS.WS.

Executing Standard Run-Time Functions

Use the PERFORM statement to execute RM/Panels standard run-time functions. The following example
demonstrates the execution of the DISPLAY PANEL standard run-time function for a panel called
MYPANEL.

Example

PERFORM RMP--DP-MYPANEL.

(The procedure RMP--DP-MYPANEL is contained in a panel-specific copy file, MYPANEL.PRC; see
Required Copy Files for more information.

The naming of RM/Panels standard run-time functions follows a strict pattern. The name is made up of
three parts:

• The prefix, RMP--.
• An abbreviation for the desired RM/Panels standard run-time function. (See Appendix B, Standard,

Utility, and Extended Run-Time Functions and Parameters for a complete list of standard run-time
function abbreviations.)

Examples are DP (DISPLAY PANEL) and RP(REMOVE PANEL).
• The panel name.

This naming convention makes it easy to use the RM/Panels standard run-time functions, even in programs
using multiple panels.

Required Copy Files

Each application program that uses RM/Panels requires the master copy file RMPANELS.WS.

Note In some situations you may wish to use one of the other versions of RMPANELS.WS (RMPANELS.LNK
and RMPANELS.EXT). See Appendix A, Master Copy File RMPANELS.WS for details on using these copy
files.

RMPANELS.WS must be copied into the Working-Storage Section of the application program. The master
copy file contains a parameter block used to pass parameters between the application program and the
RM/Panels run-time system. Appendix A contains a complete description of RMPANELS.WS.

Each application program must also contain a pair of panel-specific copy files for each panel it uses. These
two copy files are the interface between your application program and the RM/Panels run-time system. The
Panel Editor automatically produces these copy files when you create a panel. The copy files are named
with the first eight characters of the panel name, followed by the extensions, .WS and .PRC. For example, a
program that used a panel named MYPANEL would require the copy files:

162 | Upgrading to Enterprise Developer



• MYPANEL.WS

• MYPANEL.PRC

These panel-specific copy files are described below, with MYPANEL representing the panel name variable.

MYPANEL.WS

MYPANEL.WS sets up a 100-byte work area for the panel that never needs to be directly modified or
referenced by your application program. This work area exists solely for the use of RM/Panels.

MYPANEL.WS also contains declarations for each field/control on the panel. This area is called MYPANEL-
WS. These fields are declared in the same manner as any other data item in the Working-Storage Section
of a COBOL program. These field declarations are used both as the source of field/control values for RM/
Panels displays and as the destination for RM/Panels accepts. The order of these fields/controls is dictated
by the Panel Configuration and should not be changed manually. Values, however, can be moved in or out
of the fields/controls at any time.

MYPANEL.WS must be copied into the Working-Storage Section of your application program.

Example of contents of MYPANEL.WS:

01MYPANEL-WS.
  03 FILLER      PIC X(100) VALUE "MYPANEL    0050".
  03 CUST-CITY   PIC X(15).
  03 CUST-NAME   PIC X(30).
  03 CUST-NUMBER PIC 9(5).

MYPANEL.PRC

MYPANEL.PRC contains procedures that execute RM/Panels standard run-time functions, such as
displaying or removing panels and entering panel fields/controls. MYPANEL.PRC must be copied into the
Procedure Division of your application program.

Example of partial contents of MYPANEL.PRC:

RMP--AF-MYPANEL.
     CALL RMP--RUNTIME USING RMP--AF 
     RMP--PARAMETERS MYPANEL-WS
RMP--EE-MYPANEL.
     CALL RMP--RUNTIME USING RMP--EE 
     RMP--PARAMETERS MYPANEL-WS

Sample Program

The following sample program shows the minimum requirements for an RM/Panels program. This program,
which displays a panel and then removes it, is called MINIMUM. It uses a panel called MYPANEL in the
panel library called MYPANEL.LIB.

IDENTIFICATION DIVISION. 
PROGRAM-ID. MINIMUM. 
ENVIRONMENT DIVISION. 
DATA DIVISION.
WORKING-STORAGE SECTION.
  COPY "RMPANELS.WS". 
  COPY "MYPANEL.WS".
PROCEDURE DIVISION. 
MAIN-PROCEDURE.
  MOVE "MYPANEL.LIB" TO RMP--LIBRARY. 
  PERFORM RMP--DP-MYPANEL.
  PERFORM RMP--RP-MYPANEL. 
  STOP RUN.

  COPY "MYPANEL.PRC".
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Error Detection

Every RM/Panels standard runtime function sets a status value. This value is contained in the variable
RMP--STATUS in master copy file RMPANELS.WS. The possible status values and error conditions are as
follows:

Status value Description

0 The function executed successfully.

1 The field/control name is invalid.

2 The occurrence number is invalid.

3 The function number is invalid.

4 The attribute is invalid.

5 The panel is not in this library

6 The library does not exist.

7 The library configuration is invalid.

8 The panel does not contain any fields/controls.

9 The panel contains no input fields/controls.

10 The panel is not displayed.

11 The palette number is invalid.

12 Help message is not defined.

13 Error message is not defined.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. user's
guide

15 The field/control is disabled.

16 A window error has occurred.

20 The menu command name is invalid.

22 There is no pulldown menu on this panel.

1001 API parameter is missing.

1002 API message is not defined.

1003 API pulldown option is invalid.

1004 API pulldown option is uncheckable.

The following condition-names are declared in RMPANELS.WS to help in interpreting errors.

05 RMP--STATUS PIC 9(4).
   88 RMP--VALID-FUNCTION        VALUE 0.
   88 RMP--FIELD-INVALID         VALUE 1.
   88 RMP--OCCUR-INVALID         VALUE 2.
   88 RMP--FUNCTION-INVALID      VALUE 3.
   88 RMP--ATTRIBUTE-INVALID     VALUE 4.
   88 RMP--PANEL-INVALID         VALUE 5.
   88 RMP--LIBRARY-INVALID       VALUE 6.
   88 RMP--CONFIG-INVALID        VALUE 7.
   88 RMP--NO-FIELDS             VALUE 8.
   88 RMP--NO-INPUT-FIELDS       VALUE 9.
   88 RMP--PANEL-NOT-DISPLAYED   VALUE 10.
   88 RMP--PALETTE-INVALID       VALUE 11.
   88 RMP--NO-HELP-DEFINED       VALUE 12.
   88 RMP--NO-ERROR-DEFINED      VALUE 13.
   88 RMP--IO-ERROR              VALUE 14.
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   88 RMP--CONTROL-DISABLED      VALUE 15.
   88 RMP--WINDOW-ERROR          VALUE 16.
   88 RMP--MENU-COMMAND-INVALID  VALUE 20.
   88 RMP--NO-PULLDOWN           VALUE 22.
   88 RMP--API-PARAM-MISSING     VALUE 1001.
   88 RMP--API-MSG-NOT-DEFINED   VALUE 1002.
   88 RMP--API-PD-OPTION-INVALID VALUE 1003.
   88 RMP--API-UNCHECKABLE       VALUE 1004.

Screen Handling

RM/Panels supports three different methods of handling screens in COBOL application programs. In
addition to the two common approaches of coding individual fields or accepting an entire screen definition,
RM/Panels uses a third approach based on a programming technique called the event loop.

The event loop is common in programming graphical user interfaces. It frees you from having to direct all
the activity of complex screens. The basic activities of the screen are performed automatically, but every
event is reported to the application program to allow special processing when desired. RM/Panels applies
this concept to COBOL screen handling to provide full-screen entry with field level control and a minimum
of coding. The three methods are contrasted in the following sections.

In summary, remember the following steps when writing pop-up panels:

1. Create the pop-up panel as a window or set RMP--WINDOW to TRUE before displaying.
2. Reset the keyboard focus when returning to the main panel.
3. Do not let terminating condition(s) of the pop-up panel fall back to the main panel.

Individual Field Method

The individual field method of COBOL screen handling requires that you write or generate all the code
needed to control each input field individually. This method requires a series of ACCEPT statements, as
shown in the following example:

ACCEPT FIELD-1 LINE 10 POSITION 40. 
ACCEPT FIELD-2 LINE 11 POSITION 40. 
ACCEPT FIELD-3 LINE 12 POSITION 40.

This approach is usually embellished with code allowing the user to select or move between input fields.
Help messages, prompts, validations, and special features may also be added. However, what begins as a
simple series of ACCEPT statements soon grows into unmanageable code.

The benefit of building input logic in this method is that total control is possible at the field level. The
disadvantage is that all screen handling responsibility is borne by the programmer, who must produce a
cumbersome amount of code to add or modify the field level logic, add or delete fields, or move existing
fields on the screen.

Entire Screen Method

The second common method of COBOL screen handling is to do an enhanced ACCEPT statement of an
entire screen definition through the Screen Section or some other extension. This approach eliminates the
need for extensive coding involved in controlling each individual field, but it also removes the ability to
smoothly integrate field level logic and special features because the application program only gains control
under a limited set of circumstances.

Event Loop Method

The event loop method enables sophisticated screen handling with tremendous flexibility and greatly
reduced coding.

There are three components in an event loop:

• Loop control. This specifies the condition or conditions that terminates the loop.
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• Execution of an event. One event occurs on each repetition of the loop, until the loop control conditions
are met.

• Event testing. One or more checks by the application program to evaluate events. Rather than dictating
each event, the application program responds to the current event.

Example of an RM/Panels Event Loop
PERFORM UNTIL F3-KEY-PRESSED    (Loop Control) 
     PERFORM RMP--EE-PANELNAME  (Execution) 
     EVALUATE RMP--LAST-FIELD
        WHEN "CUSTOMER-NUMBER"  (Event Test)
           PERFORM VALIDATE-CUSTOMER-NUMBER
        WHEN "CUSTOMER-STATE"   (Event Test)
           PERFORM VALIDATE-CUSTOMER-STATE 
     END-EVALUATE
END-PERFORM.

The event is input to a field/control on the screen, which is performed by the procedure RMP--EE-
PANELNAME. This procedure executes the RM/Panels EXECUTE EVENT standard run-time function. The
EXECUTE EVENT standard run-time function accomplishes the following:

• Checks the parameters passed to it to see what event to perform
• Performs the event (field/control input)
• Sets parameters to indicate what event was executed and what event should be executed next
• Returns control to the application program

Each time the EXECUTE EVENT standard run-time function is performed, only one event is executed, thus
the application program can always intercept control after any event. It then has the ability to perform
special processing or force a particular event to occur.

There are many advantages to using the event loop method:

1. Writing tedious screen handling code is eliminated.
2. Adding special field/control level logic is made easier.
3. Field/control level logic is insulated from changes in field/control entry order and position.
4. Size of screen handling code is dependent upon the amount of special processing to be done, rather

than the number of fields/controls on the screen.
5. Adding new fields/controls does not affect the event loop unless the fields/controls require special

processing.
6. Event loops can be nested, which allows multiple panels to be used on the screen. The following

section describes the use of multiple panels and special considerations in nesting event loops.

Using Multiple Panels

RM/Panels is designed to support windowed applications, where panels can be displayed (or “pop-up”) at
different locations on the screen. While simple to produce, this type of application requires a few special
considerations. The following describes the three steps to writing pop-up applications.

1. Detect a request for a pop-up panel. The first step in coding a windowed application is detecting the
conditions that indicate the need to display the pop-up panel. This can be any condition, but is
commonly a special keystroke, push button, or menu command. The detection is usually a test inside an
event loop based on the EXECUTE EVENT standard run-time function. This is illustrated by the
following code fragment:

DEMONSTRATE-FUNCTION. 
   PERFORM RMP--EE-PANEL5.
   IF F3-KEY AND (RMP--LAST-FIELD = "CUST-SHIP-CODE") 
      PERFORM SHIP-CODE-DETAILS

When the F3 key is pressed during the entry of the CUST-SHIP-CODE field, the SHIP-CODE-DETAILS
procedure, which controls the pop-up panel, is performed.
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2. Display, use, and remove the pop-up panel. A pop-up panel is used like any other panel, but with one
important difference. The “Make panel a window” parameter must be selected, or at run-time execution,
RMP--WINDOW should be set to TRUE before the panel is displayed. Failure to do one of these will
prevent the panel from being removed from the display properly.

The following code fragment shows how the pop-up panel is displayed, used, and removed:

SHIP-CODE-DETAILS.
    PERFORM RMP--DP-PANEL6.
    SET RMP--FIRST-FIELD TO TRUE. 
    PERFORM RMP--EE-PANEL6
       WITH TEST AFTER UNTIL ESCAPE-KEY. 
    PERFORM RMP--RP-PANEL6.

Since this panel was created with the windowing option selected, the code is no different from the
usage of a normal panel. The panel is displayed, an event loop is used for user input, and then the
panel is removed, restoring the screen contents.

3. Resume execution of the original event loop. The event loop is based on the ability of the EXECUTE
EVENT standard run-time function to perform an input event and set up the next input event. Because
the previous step includes an event loop that actually executes inside the original event loop, the
internal variables determining which field/control should be entered next are set for the pop-up panel.
One of these must be reset so that the keyboard focus moves to a field/control on the main panel. There
are three ways to do this:

a. Set RMP--REPEAT-EVENT to TRUE.

This returns keyboard focus to the last field/control that had it on the panel.
b. Set RMP--FIRST-FIELD to TRUE.

This sets keyboard focus to the first enabled field/control on the panel.
c. Move the name of a field to RMP--NEXT-FIELD.

This specifically moves keyboard focus to that field/control.

Also, care must also be taken not to allow the terminating condition from the inner loop to terminate the
original loop. The following program prevents this problem by moving zero to RMP--EXCEPTION-
NUMBER, so that the Escape key condition is false upon resuming the original loop. The following code
follows the sample shown in the first step.

   SET RMP--REPEAT-EVENT TO TRUE 
   MOVE 0 TO RMP--EXCEPTION-NUMBER.

Standard Run-Time Functions

The RM/Panels run-time system is an RM/COBOL-85 object program that must be available to and
distributed with your application.

Note: In version 1.0 of RM/Panels, there was only one RM/Panels run-time system program,
runpanel.cob. Version 1.1 introduced an additional run-time system program, rmputil.cob. Both
of these programs must be distributed with applications written using RM/Panels version 1.1. In
version 2.1 of RM/Panels, there is only one run-time system program, runpan2.cob.

The RM/Panels run-time system provides a powerful set of standard run-time functions that allows the
application to manipulate panels. The following table gives the name and abbreviation of each RM/Panels
standard run-time function.

Function Abbreviation

ACCEPT FIELD AF

CHANGE PANEL PALETTE CPP

CHECK MENU OPTION CMO
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Function Abbreviation

CLEAR ALL FIELDS CAF

DISABLE ALL FIELDS DA

DISABLE FIELD FOR INPUT DFI

DISABLE MENU OPTION DMO

DISPLAY ALL FIELDS DAF

DISPLAY FIELD DF

DISPLAY PANEL DP

ENABLE ALL FIELDS EA

ENABLE FIELD FOR INPUT EFI

ENABLE MENU OPTION EMO

EXECUTE EVENT EE

INITIALIZE ALL FIELDS IAF

INITIALIZE FIELD IF

POPUP MENU PUM

REMOVE PANEL RP

SET FIELD ATTRIBUTE SFA

SET SCROLL BAR RANGE SSR

SHOW FIELD ERROR SFE

SHOW FIELD HELP SFH

SHOW PANEL ERROR SPE

SHOW PANEL HELP SPH

UNCHECK MENU OPTION UMO

VALIDATE ALL FIELDS VAF

VALIDATE FIELD VF

Each standard run-time function is described in the following section. All parameters for RM/Panels
standard run-time functions are defined in Appendix B, Standard, Utility, and Extended Run-Time Functions
and Parameters.

Configurable Keys

The RM/Panels run-time system takes special action on several keys. The field termination codes that RM/
Panels recognizes as each key can be controlled by the application program. If the key values are set to
zero, RM/Panels assumes the key is not to be used. The seven configurable keys and their interpretation
by RM/Panels are as follows:

Help This key causes the automatic help facility to display help information for the field/control
during the ACCEPT FIELD or EXECUTE EVENT standard run-time functions.
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Enter This key is interpreted as the termination of normal input into a field/control. If a validation
test fails, the user is forced to reenter the field/control, and an error message is displayed (if
created). In the EXECUTE EVENT standard run-time function, preparations are made to
enter the next field/control.

Next Field This key is interpreted as the termination of normal input into the current field/control and as
a request to move to the next field/control. The default key is the Down Arrow key.

Prev Field This key is interpreted as the termination of normal input into the current field/control and as
a request to move to the previous field/control. The default key used is the Up Arrow key.

Next Group This key is interpreted as the termination of normal input into the current field/control and as
a request to move to the first field/control in the next group of fields/controls. The default key
is the Tab key.

Prev Group This key is interpreted as the termination of normal input into the current field/control and as
a request to move to the first field/control in the previous group of fields. The default key is
the Shift-Tab key combination.

Pulldown This key is interpreted as a request to shift input focus to the pulldown menu, if present.

See Appendix A, Master Copy File RM/PANELS.WS for more information.

ACCEPT FIELD

Execution
PERFORM RMP--AF-PANELNAME

Description

This standard run-time function performs the entry of a single panel field/control by the user. It is similar to
a standard COBOL ACCEPT statement, except that RM/Panels sets all the parameters and can perform
many supporting activities automatically. Many characteristics of the field/control can then be modified
through the Panel Editor, without requiring program changes or recompilation.

Note: While much more powerful than an ACCEPT statement, this standard run-time function is not
the preferred method of allowing user input in RM/Panels. Use the EXECUTE EVENT standard run-
time function as the primary method to allow user input. Use ACCEPT FIELD when only one field/
control is needed.

Required Parameters

The program must set the name of the field/control to be accepted in RMP--FIELD-NAME. If the field/
control occurs more than once, the occurrence number must be specified in RMP--FIELD-OCCUR. The
occurrence numbers are equivalent to COBOL subscripts and begin at 1.

Returned Values

The value entered by the user is stored in the appropriate field/control within panelname.WS. The field/
control termination code indicating the ending key is returned in RMP--EXCEPTION-NUMBER.

Additional Usage Notes

• Before this standard run-time function can be executed, the panel must be displayed.
• User Input Errors. If validation is specified for the field/control and an error is detected, the behavior of

RM/Panels depends on the way in which user input was terminated. If the input was terminated by the
auto-exit property or by pressing the Enter key, the error message is displayed and the user is forced to
reenter the field/control. If input was terminated in any other way, control is returned to the application
program and RMP--INVALID-INPUT is TRUE. If you want the error message displayed under these
circumstances, you must execute the SHOW FIELD ERROR standard run-time function. This approach
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differs somewhat from the handling of invalid input during the execution of the EXECUTE EVENT
function. During the execution of the ACCEPT FIELD function, RM/Panels assumes that the auto-exit
property and the Enter key indicate a normal termination of input. The user should not be allowed to
proceed if the input is invalid. During the EXECUTE EVENT function, RM/Panels assumes that many
other keys also indicate normal termination of input.

Note: If accelerator values are used for any fields/controls, check both the exception value and
RMP--VALID-INPUT. Accelerator keys can affect code logic.

• Disabled Fields/Controls. In the Panel Editor or at run-time execution, a field/control can be specified as
not allowing entry. This characteristic does not apply to the ACCEPT FIELD standard run-time function.
It only applies to standard run-time functions that allow input of more than one field/control. RM/Panels
assumes that if a field/control is specifically identified for the ACCEPT FIELD standard run-time
function, it should allow input regardless of the allow input characteristic. This can be quite useful. For
example, ACCEPT FIELD might be used to allow input of a key field/control in a maintenance program,
and then EXECUTE EVENT might be used to allow updating of the non-key fields/controls.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

1 The field/control name is invalid.

2 The occurrence number is invalid.

5 The panel is not in this library

6 The library does not exist.

10 The panel is not displayed.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

CHANGE PANEL PALETTE

Execution
PERFORM RMP--CPP-PANELNAME

Description

This standard run-time function redisplays a panel and all its fields/controls using a new palette.

Required Parameters

RMP--PALETTE must be set with the number of the palette to be used. You must have previously defined
the palette number in the panel library with a value ranging from 1 to 99. A value of 0 causes the panel to
display using the default palette for the panel.

Additional Usage Notes

Before this standard run-time function can be executed, the panel must be displayed. However, the default
panel palette can be overridden at the time the panel is displayed.
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RMP--STATUS Values

Status value Description

0 The function executed successfully.

6 The library does not exist.

10 The panel is not displayed.

11 The palette number is invalid.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

CHECK MENU OPTION

Execution
PERFORM RMP--CMO-PANELNAME

Description

This standard run-time function places a check next to a pulldown menu command when it is displayed.

Required Parameters

The application program must set the name of the menu command to be checked in RMP--COMMAND-
NAME.

Returned Values

None.

Additional Usage Notes

This standard run-time function is valid only for pulldown menu commands that can be checked.

An inverse standard run-time function, UNCHECK MENU OPTION is also available.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

20 The menu command name is invalid.

CLEAR ALL FIELDS

Execution
PERFORM RMP--CAF-PANELNAME
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Description

This standard run-time function inserts spaces in all alphanumeric fields/controls and zeros in all numeric
and date fields/controls on the panel. It is the equivalent of issuing an INITIALIZE statement to each field
defined in panelname.WS.

Required Parameters

None.

Returned Values

The value for each field/control in the panel is stored within panelname.WS.

Additional Usage Notes

• The panel does not need to be displayed before clearing the fields/controls.
• This standard run-time function is similar to the INITIALIZE ALL FIELDS standard run-time function.

However, the INITIALIZE ALL FIELDS standard run-time function sets all fields/controls to their default
values, which may not be zero or spaces.

• This standard run-time function does not display the fields/controls on the screen.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

DISABLE ALL FIELDS

Execution
PERFORM RMP--DA-PANELNAME

Description

This standard run-time function causes all fields/controls on the panel to be disabled for input.

Required Parameters

None.

Additional Usage Notes

This function does not redisplay the fields/controls with their disabled attributes. Use the DISPLAY ALL
FIELDS or DISPLAY PANEL standard run-time function after the DISABLE ALL FIELDS standard run-time
function to show the change in their status.
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RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

DISABLE FIELD FOR INPUT

Execution
PERFORM RMP--DFI-PANELNAME

Description

This standard run-time function prevents input to a field/control that was specified as allowing input in the
Panel Editor. Many times a certain field/control should be input, or not input, based on the value of another
field/control. This standard run-time function allows a field/control to be disabled for input at run-time
execution, rather than at panel creation time, increasing the flexibility of the EXECUTE EVENT standard
run-time function.

Required Parameters

The program must set the name of the field/control to be disabled in RMP--FIELD-NAME. If the field/control
occurs more than once, all occurrences of the field/control will be disabled.

Optional Parameters

RMP--SUPPRESS-EVENT-RESET can be set to TRUE to prevent RMP--NEXT-FIELD and RMP--NEXT-
OCCUR from being reset.

Returned Values

The values of RMP--NEXT-FIELD and RMP--NEXT-OCCUR are reset, based upon the new input status of
the fields/controls on the panel.

Additional Usage Notes

• This standard run-time function resets the next field/control to be entered because generally the
standard run-time function is used within an event loop and the new input status of the field/control
should take effect immediately.

• An inverse standard run-time function, ENABLE FIELD FOR INPUT, is also available.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

1 The field/control name is invalid.

5 The panel is not in this library
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Status value Description

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

DISABLE MENU OPTION

Execution
PERFORM RMP--DMO-PANELNAME

Description

This standard run-time function disables a command on a pulldown menu. It does not apply to menu titles.
The command appears on the menu with the disabled attribute, but the user is not able to select it.

Required Parameters

The application program must set the name of the menu item to be disabled in RMP--COMMAND-NAME.

Returned Values

None.

Additional Usage notes

An inverse standard run-time function, ENABLE MENU OPTION is also available.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

20 The menu command name is invalid.

DISPLAY ALL FIELDS

Execution
PERFORM RMP--DAF-PANELNAME

Description

This standard run-time function displays the values of all fields/controls on the panel. It should be used as
the primary method of displaying field/control values. Use a related standard run-time function, DISPLAY
FIELD when only one field/control is to be displayed.
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Required Parameters

None.

Additional Usage Notes

• This standard run-time function is intended primarily for displaying only field/control values. When you
want to display both the panel text and graphics at the same time, you need to use the DISPLAY PANEL
standard run-time function.

• Before this standard run-time function can be executed, the panel must be displayed.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

10 The panel is not displayed.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

DISPLAY FIELD

Execution
PERFORM RMP--DF-PANELNAME

Description

This standard run-time system function displays the value of a single field/control on the panel. It is similar
to a standard DISPLAY statement, except that RM/Panels sets all the parameters. Many characteristics of
the field/control can then be modified solely through the Panel Editor, without requiring program changes or
recompilation.

Note: While much more powerful than a standard DISPLAY statement, this standard run-time system
function is not the preferred method of displaying field/control values in RM/Panels. Use the DISPLAY
ALL FIELDS and DISPLAY PANEL standard run-time system functions as the primary method of
displaying field/control values. Use DISPLAY FIELD when only one field/control is to be displayed.

Required Parameters

The program must set the name of the field/control to be displayed in RMP--FIELD-NAME. If the field/
control occurs more than once, the occurrence number must be specified in RMP--FIELD-OCCUR. The
occurrence numbers are equivalent to COBOL subscripts and begin at 1.

Additional Usage Notes

• Before this standard run-time system function can be executed, the panel must be displayed.
• Setting RMP--FIELD-OCCUR to 0 will display all occurrences of a repeating field/control.
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RMP--STATUS Values

Status value Description

0 The function executed successfully.

1 The field/control name is invalid.

2 The occurrence number is invalid.

5 The panel is not in this library

6 The library does not exist.

10 The panel is not displayed.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

DISPLAY PANEL

Execution
PERFORM RMP--DP-PANELNAME

Description

This standard run-time function displays a panel on the screen.

Required Parameters

RMP--LIBRARY must be set to the name of the panel library which contains the panel.

Note: Since this value is never changed by RM/Panels, it does not need to be set for each panel used
in the same library.

Optional Parameters

RMP--BEEP can be set to TRUE to produce a beep when displaying the panel.

RMP--CLEAR can be set to TRUE to erase the entire video screen and set the color of the screen to the
background color of the panel.

RMP--PALETTE can be set to select a specific palette other than the default for the panel.

RMP--PANEL-LINE can be set to 999 to center the panel vertically or it can be set to any non-zero value
to display the panel on a specific starting line.

RMP--PANEL-POS can be set to 999 to center the panel horizontally or it can be set to any non-zero value
to display the panel on a specific starting column position.

RMP--SHOW-FIELDS can be set to TRUE to display all field/control values with the panel.

RMP--WINDOW can be set to TRUE or FALSE to override the default windowing characteristic of the panel.

Additional Usage Notes

• If the value in RMP--PALETTE is 0 or invalid, the panel is displayed using the default palette for the
panel.

• Displaying the field/control values with the panel is much faster than displaying the panel, then the
fields/controls.
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RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

11 The palette number is invalid.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

ENABLE ALL FIELDS

Execution
PERFORM RMP--EA-PANELNAME

Description

This standard run-time function causes all fields/controls on the panel to be enabled for input.

Required Parameters

None.

Additional Usage Notes

This standard run-time function does not redisplay the fields/controls with their enabled attributes. Use the
DISPLAY ALL FIELDS or DISPLAY PANEL standard run-time function after the ENABLE ALL FIELDS
standard run-time function to show the change in their status.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

ENABLE FIELD FOR INPUT

Execution
PERFORM RMP--EFI-PANELNAME

Description

This standard run-time function allows input to a field/control that was specified as not allowing input in the
Panel Editor. Many times a certain field/control should be input, or not input, based on the value of another
field/control. This standard run-time function allows a field/control to be enabled for input at run-time
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execution, rather than at panel creation time, increasing the flexibility of the EXECUTE EVENT standard
run-time function.

Required Parameters

The application program must set the name of the field/control to be enabled in RMP--FIELD-NAME. If the
field/control occurs more than once, all occurrences of the field/control are enabled.

Optional Parameters

RMP--SUPPRESS-EVENT-RESET can be set to TRUE to prevent RMP--NEXT-FIELD and RMP--NEXT-
OCCUR from being reset.

Returned Values

The values of RMP--NEXT-FIELD and RMP--NEXT-OCCUR are reset, based upon the new input status of
the fields/controls on the panel.

Additional Usage Notes

• This standard run-time function resets the next field/control to be entered because generally the
standard run-time function is used within an event loop and the new input status of the field/control
should take effect immediately.

• An inverse standard run-time function, DISABLE FIELD FOR INPUT, is also available.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

1 The field/control name is invalid.

5 The panel is not in this library

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

ENABLE MENU OPTION

Execution
PERFORM RMP--EMO-PANELNAME

Description

This standard run-time function enables a command on a pulldown menu. It does not apply to menu titles.
The command appears with the normal attribute and the user is able to select it.

Required Parameters

The application program must be set to the name of the menu item to be enabled in RMP--COMMAND-
NAME.

Returned Values

None.
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Additional Usage Notes

• The next time the command is displayed, it is shown with the enabled attribute.
• An inverse standard run-time function, DISABLE MENU OPTION, is also available.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

20 The menu command name is invalid.

EXECUTE EVENT

Execution
PERFORM RMP--EE-PANELNAME

Description

This standard run-time function performs the entry of a single panel field/control, but when placed in an
event loop it allows entry of all fields/controls on the panel. Use the EXECUTE EVENT standard run-time
function as the standard method of allowing user input with RM/Panels. It provides the power of multiple
field entry with the flexibility of field-by-field control. Use a related standard run-time function, ACCEPT
FIELD when only one field/control is to be entered.

Required Parameters

There are three ways to specify which field/control receives input focus on each execution of the EXECUTE
EVENT standard run-time function:

1. If you want to begin entry on the first field/control of the panel, RMP--FIRST-FIELD must be set to
TRUE.

2. If you want to specify the next input field/control, RMP--NEXT-FIELD must be set to the field/control
name, and RMP--NEXT-OCCUR must be set to the field/control occurrence number. The RM/Panels run-
time system resets these parameters after each execution of the EXECUTE EVENT standard run-time
function, thereby preparing for the next execution.

3. If you want to resume entry on the last field/control of the panel that the user entered, RMP--REPEAT-
EVENT must be set to TRUE. This is useful if multiple panels are in use and the user is returning to a
previously accessed panel, or if invalid user input is detected.

Returned Values

The value entered for each field/control in the panel is stored within panelname.WS. The field termination
code indicating the terminating key is returned in RMP--EXCEPTION- NUMBER.

The values of RMP--LAST-FIELD, RMP--LAST-OCCUR, RMP--NEXT-FIELD, and RMP--NEXT-OCCUR
are also set to the appropriate values for the next event. Occurrence numbers are equivalent to COBOL
subscripts and begin at 1.

Under modeless operation, the following parameters are also returned:
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• RMP--LAST-PANEL contains the name of the panel for which the last EXECUTE EVENT standard run-
time function was performed.

• RMP--REQUESTED-PANEL contains the name of the panel that the user requested for the next event.
To support modeless behavior, the application program must be written so that the next EXECUTE
EVENT standard run-time function is performed for the panel named by this parameter.

Additional Usage Notes

• Before this standard run-time function can be executed, the panel must be displayed.
• User Input Errors. If validation is specified for the field/control and an error is detected, the behavior of

RM/Panels depends on the way in which user input was terminated. If the input was terminated by the
auto-exit property or by pressing any of the keys defined in RMPANELS.WS as having a special function,
the error message is displayed and the user is forced to reenter the field/control. If input was terminated
in any other way, control is returned to the application program and RMP--INVALID-INPUT is TRUE. If
you want the error message displayed under these circumstances, you must execute the SHOW FIELD
ERROR standard run-time function. This approach differs somewhat from the handling of invalid input
during the execution of the ACCEPT FIELD function. During the execution of the EXECUTE EVENT
function, RM/Panels assumes that the auto-exit property and any of the keys defined in RMPANELS.WS
indicate a normal termination of input. The user should not be allowed to proceed if the input is invalid.
During the ACCEPT FIELD function, RM/Panels assumes that only the auto-exit property and the Enter
key indicate normal termination of input.

• The simplest usage of this standard run-time function is as follows:

PERFORM RMP--EE-PANELNAME WITH TEST AFTER UNTIL F3-KEY.

This allows the user to operate all enabled panel fields/controls until the F3 key is pressed. The WITH
TEST AFTER phrase ensures that the standard run-time function is executed at least once before
testing the condition-name F3 KEY, in case the F3 key has just been pressed in another routine.

• The many parameters provided to interpret and control events make it possible to construct
sophisticated input routines. The following sample demonstrates one such routine and is followed by an
explanation of the numbered areas.

Example
1 SET RMP--FIRST-FIELD TO TRUE.
2 PERFORM WITH TEST AFTER UNTIL F3-KEY
3    PERFORM RMP--EE-PANELNAME
4      EVALUATE RMP--LAST-FIELD
5         WHEN "CUSTOMER-NUMBER"
             PERFORM CUSTOMER-VALIDATION
             IF CUST-NOT-VALID
6               SET RMP--REPEAT-EVENT TO TRUE
             END-IF
7         WHEN "CUST-BAL"
             IF CUST-BAL = 0
8               MOVE "SHIP-CODE" TO RMP--NEXT-FIELD
             END-IF
9         WHEN "SHIP-CODE"
             IF SHIP-CODE NOT = OLD-SHIP-CODE
                PERFORM VALIDATE-SHIP-CODE
                IF SHIP-CODE-NOT-VALID
10                 SET RMP--REPEAT-EVENT TO TRUE
                END-IF
             END-IF
11     END-EVALUATE
12     EVALUATE RMP--NEXT-FIELD
13        WHEN "SHIP-CODE"
             MOVE SHIP-CODE TO OLD-SHIP-CODE
14     END-EVALUATE
15 END-PERFORM.
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1. Setting RMP--FIRST-FIELD to TRUE tells RM/Panels to begin user input with the first field/control on
the panel.

2. This is the loop control, specifying the condition that terminates the event loop.
3. This is the execution of the event, the entry of a field/control. It is done with the EXECUTE EVENT

standard run-time function.
4. This is the first of the event tests. The EVALUATE statement is used to determine the field/control on the

panel that was just entered by the user.
5. This statement checks to see if the customer number was just entered. If it was entered, a validation

routine contained in the application program is performed.
6. Setting RMP--REPEAT-EVENT to TRUE forces the customer number to be reentered as the next event,

rather than moving on to the next field/control.
7. This statement checks to see if the customer balance was just entered.
8. Moving SHIP-CODE to RMP--NEXT-FIELD forces the next event to be the entry of the SHIP-CODE

field/control, rather than the next field/control on the panel.
9. This statement checks to see whether the SHIP-CODE field/control was just entered. If so, the

statement checks to see if the value changed and validates the new value.
10.Setting RMP--REPEAT-EVENT to TRUE forces reentry of the SHIP-CODE field/control.
11.This statement ends the evaluation of the last field/control entered.
12.This statement begins evaluation of the next field/control to be entered.
13.This statement checks to see whether the SHIP-CODE field/control is about to be entered. If so, it saves

the current value allowing the operations, described previously in #9, to detect a change in the value.
14.This statement ends the evaluation of the next field/control to be entered.
15.This statement ends one iteration of the loop.

This type of flexibility provides limitless possibilities. For more conceptual information on event loops,
see the discussion of Event Loop Method.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

1 The field/control name is invalid.

2 The occurrence number is invalid.

5 The panel is not in this library

6 The library does not exist.

8 The panel does not contain any fields/controls.

9 The panel contains no input fields/controls.

10 The panel is not displayed.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

INITIALIZE ALL FIELDS

Execution
PERFORM RMP--IAF-PANELNAME
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Description

This standard run-time function initializes all fields/controls to the default values specified in the panel. It is
useful because the default value can be modified with the Panel Editor and does not require program
changes or recompilation. Use the INITIALIZE ALL FIELDS standard run-time function as the primary
method to initialize fields/controls.

Use a related standard run-time function, INITIALIZE FIELD when only one field/control is to be initialized.

Required Parameters

None.

Returned Values

The default value for each field/control in the panel is stored within panelname.WS.

Additional Usage Notes

• The panel does not need to be displayed before initializing all fields/controls.
• This standard run-time function is similar to the CLEAR ALL FIELDS standard run-time function which

inserts spaces in all alphanumeric fields/controls and zeros in all numeric and date fields/controls on the
panel.

• This standard run-time function does not display the fields/controls on the screen.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

INITIALIZE FIELD

Execution
PERFORM RMP--IF-PANELNAME

Description

This standard run-time function initializes a single field/control or field/control occurrence to the default
value specified in the panel. It is useful because the default value can be modified with the Panel Editor
and does not require program changes or recompilation.

Note This standard run-time function is not the preferred method of initializing fields in RM/Panels. Use the
INITIALIZE ALL FIELDS standard run-time function as the primary method to initialize fields/controls. Use
INITIALIZE FIELD when only one field/control is to be initialized.

Required Parameters

The program must set the name of the field/control to be entered in RMP--FIELD-NAME. If the field/control
occurs more than once, the occurrence number must be specified in RMP--FIELD-OCCUR. The
occurrence numbers are equivalent to COBOL subscripts and begin at 1.
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Returned Values

The default value for each field/control in the panel is stored within panelname.WS.

Additional Usage Notes

• The panel does not need to be displayed before initializing a field/control.
• This standard run-time function does not display the field/control on the screen.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

1 The field/control name is invalid.

2 The occurrence number is invalid.

5 The panel is not in this library

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

POPUP MENU

Execution
PERFORM RMP--PUM-PANELNAME

Description

This standard run-time function displays or “pops up” one of the pulldown menus as an isolated menu, that
is, without the menu bar. The popup menu looks and works just like the pulldown menu, including enabled,
disabled, and checked options, accelerators, and mnemonics. Commands are chosen in the same way as
from the pulldown menu.

The popup menu is modal. You must make a choice or cancel the menu with the pulldown menu Cancel
button or by clicking the mouse outside the border of the menu. If a command is not selected, none of the
event type conditions reported in RMPANELS.WS is set. The popup menu does not affect the setting of
RMP--LAST-FIELD, RMP--NEXT-FIELD, or any of the other event parameters.

Required Parameters

RMP--COMMAND-NAME must be set to the name of one of the commands on the pulldown menu for this
panel.

Optional Parameters

RMP--PANEL-LINE can be set as follows:

Value Description

0 Display the pop-up menu on the same line on which it
would be displayed if selected from the pulldown menu

999 Center the pop-up menu vertically on the screen

Any other value indicates a specific line on which the pop-up menu should be displayed.
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RMP--PANEL-POS may be set as follows:

Value Description

0 Display the pop-up menu on the same column on which it
would be displayed if selected from the pulldown menu

999 Center the pop-up menu horizontally on the screen

Any other value indicates a specific column on which the pop-up menu should be displayed.

Additional Usage Notes

• This standard run-time function is only valid for panels that have a pulldown menu.
• The menu, which is to display or “pop up”, is identified by a command name rather than a menu title

because the command name is language independent and the menu title is not.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

10 The panel is not displayed.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

16 A window error has occurred.

20 The menu command name is invalid.

22 There is no pulldown menu on this panel.

REMOVE PANEL

Execution
PERFORM RMP--RP-PANELNAME

Description

This standard run-time function removes a panel from the screen. If the panel was displayed with the
default windowing option, the original contents of the screen are restored; otherwise, the area of the screen
occupied by the panel is cleared and the color of that area is set to the attribute set represented by the A
attribute code for the panel.

Required Parameters

None.

Optional Parameters

RMP--CLEAR can be set to TRUE to clear the entire screen and set the screen color to the attribute set
represented by the A attribute code for the panel.
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Additional Usage Notes

Before this standard run-time function can be executed, the panel must be displayed.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

6 The library does not exist.

10 The panel is not displayed.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

SET FIELD ATTRIBUTE

Execution
PERFORM RMP--SFA-PANELNAME

Description

This standard run-time function alters the enabled attribute code assigned to a field/control through the
Panel Editor. The attribute value remains altered until the panel is removed. This standard run-time function
allows a field/control to be displayed with different attributes based on its value or other run-time system
conditions.

Required Parameters

The program must set the name of the field/control to be changed in RMP--FIELD-NAME. If the field/
control occurs more than once, the occurrence number must be specified in RMP--FIELD-OCCUR. The
occurrence numbers are equivalent to COBOL subscripts and begin at 1.

RMP--ATTRIBUTE must be set to space or to a value in the range A through P to indicate the new attribute
for the field/control. A value of space restores the default attribute value.

Additional Usage Notes

• Before this standard run-time function can be executed, the panel must be displayed.
• This standard run-time function displays the field/control with the new attribute. However, if it is a

repeating field/control, it displays only the specified occurrence. Setting RMP--FIELD-OCCUR to 0
displays all occurrences of a repeating field/control.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

1 The field/control name is invalid.

2 The occurrence number is invalid.

4 The attribute is invalid.

5 The panel is not in this library
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Status value Description

6 The library does not exist.

10 The panel is not displayed.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

SET SCROLL BAR RANGE

Execution
PERFORM RMP--SSR-PANELNAME

Description

This standard run-time function changes the minimum, maximum, step, and page values for a scroll bar. In
some instances, these values are unknown until the RM/Panels run-time system and this function can be
used to reset them.

Required Parameters

The application program must set the name of the scroll bar in RMP--FIELD-NAME.

RMP--SB-MIN must be set to the new minimum value. RMP--SB-MAX must be set to the new maximum
value.

Optional Parameters

RMP--SB-STEP may be set to the new step value or zero to keep the current value. RMP--SB-PAGE may
be set to the new page value or zero to keep the current value.

Additional Usage Notes

• This standard run-time function always sets the minimum and maximum value for a scroll bar.
• If RMP--SB-STEP is set to 0, the step value is not changed. If RMP--SB-STEP is set to any non-zero

value, that value becomes the new step value.
• If RMP--SB-PAGE is set to 0, the page value will not be changed. If RMP--SB-PAGE is set to any non-

zero value, that value will become the new page value.
• The scroll bar thumb needs special consideration when resetting the scroll bar range. To avoid the

possibility of having two scroll bar thumbs displayed simultaneously, always do the following before
using this standard run-time function.

• Set the scroll bar value to the minimum.
• Display the scroll bar with the DISPLAY FIELD standard run-time function.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

1 The field/control name is invalid.

5 The panel is not in this library

6 The library does not exist.
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Status value Description

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

SHOW FIELD ERROR

Execution
PERFORM RMP--SFE-PANELNAME

Description

This standard run-time function displays the error message, if any, that you have defined for a field/control.
It complements the ACCEPT FIELD, EXECUTE EVENT, VALIDATE ALL FIELDS, and VALIDATE FIELD
standard run-time functions by allowing the application program to display the error message under
circumstances that prevent RM/Panels from displaying it automatically.

SHOW FIELD ERROR displays the message, waits for the user to press any key, erases the message, and
then returns control to the application program.

Required Parameters

The application program must set the name of the field/control for which the error message is to be
displayed in RMP--FIELD-NAME. No occurrence number is required, even for fields/controls with multiple
occurrences, as the error message applies to each occurrence.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

1 The field/control name is invalid.

5 The panel is not in this library

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

SHOW FIELD HELP

Execution
PERFORM RMP--SFH-PANELNAME

Description

This standard run-time function displays the help message, if any, that you defined for a field/control. It
allows you to display, rather than re-create, existing help messages in situations other than those involving
user input. (Help messages are displayed automatically when the Help key is pressed during user input.)

SHOW FIELD HELP displays the message, waits for the operator to press any key, erases the message,
and then returns control to the application program.
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Required Parameters

The application program must set the name of the field/control for which the help message is to be
displayed in RMP--FIELD-NAME. No occurrence number is required, even for fields/controls with multiple
occurrences, as the help message applies to each occurrence.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

1 The field/control name is invalid.

5 The panel is not in this library

6 The library does not exist.

12 Help message is not defined.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

SHOW PANEL ERROR

Execution
PERFORM RMP--SPE-PANELNAME

Description

This standard run-time function displays the error message, if any, that you defined for a panel. It
complements the ACCEPT FIELD, EXECUTE EVENT, VALIDATE ALL FIELDS, and VALIDATE FIELD
standard run-time functions by allowing the application program to display the existing error message in
situations other than those involving user input. (RM/Panels automatically displays error messages during
user input.)

SHOW PANEL ERROR displays the message, waits for the operator to press any key, erases the message,
and then returns control to the application program.

Required Parameters

None.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

13 Error message is not defined.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

188 | Upgrading to Enterprise Developer



SHOW PANEL HELP

Execution
PERFORM RMP--SPH-PANELNAME

Description

This standard run-time function displays the help message, if any, that you defined for a panel. It allows you
to display, rather than re-create, existing help messages in situations other than those involving user input.
(Help messages are displayed automatically when the Help key is pressed during user input.)

SHOW PANEL HELP displays the message, waits for the operator to press any key, erases the message,
and then returns control to the application program.

Required Parameters

None.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

12 Help message is not defined.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

UNCHECK MENU OPTION

Execution
PERFORM RMP--UMO-PANELNAME

Description

This standard run-time function removes a check from a pulldown menu command when it is displayed.

Required Parameters

The application program must be set to the name of the menu command to be unchecked in RMP--
COMMAND-NAME.

Returned Values

None.

Additional Usage Notes

• This standard run-time function is valid only for pulldown menu commands that can be, and are
currently, checked.

• An inverse standard run-time function, CHECK MENU OPTION, is also available.
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RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

20 The menu command name is invalid.

VALIDATE ALL FIELDS

Execution
PERFORM RMP--VAF-PANELNAME

Description

This standard run-time function validates values of all fields/controls on the panel. This is the same
validation RM/Panels performs when a user enters a value into a field/control. VALIDATE ALL FIELDS
provides a way to validate the values of fields/controls that the user has not yet entered or fields/controls
that acquired values from some means other than user input.

VALIDATE ALL FIELDS validates each field/control in sequence of entry order until all fields/controls have
been validated or an invalid field/control is found. If an invalid field/control is found, its name and
occurrence number are reported to the application program. The application program determines what
action to take next, either displaying an error message or reentering the field/control.

Required Parameters

None.

Returned Values

If no fields/controls are found to be invalid, RMP--VALID-INPUT is TRUE. If an invalid field/control is found,
RMP--INVALID-INPUT is TRUE; RMP--FIELD-NAME is set to the name of the field/control; and RMP--
FIELD-OCCUR is set to the field/control occurrence. Occurrence numbers are equivalent to COBOL
subscripts and begin at 1.

Additional Usage Notes

This standard run-time function provides the ability to validate all panel fields/controls when the user has
completed input. It is especially useful to detect required fields/controls that have not been entered.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

5 The panel is not in this library

6 The library does not exist.
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Status value Description

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

VALIDATE FIELD

Execution
PERFORM RMP--VF-PANELNAME

Description

This standard run-time function performs any validations you defined for the named panel field/control. It
does not display any error message for the field/control, but simply reports the validity of the field/control
data to the application program through RMP--VALID-INPUT.

Note This standard run-time function is not the preferred method of validating fields/controls in RM/Panels.
Use the VALIDATE ALL FIELDS standard run-time function as the primary method to validate fields/
controls. Use VALIDATE FIELD when only one field/control is to be validated.

Required Parameters

The application program must set the name of the field/control to be validated in RMP-- FIELD-NAME. If
the field/control occurs more than once, the occurrence number must be specified in RMP--FIELD-OCCUR.
The occurrence numbers are equivalent to COBOL subscripts and begin at 1.

Returned Values

If the field/control data is valid, RMP--VALID-INPUT is TRUE; otherwise RMP--INVALID-INPUT is TRUE.

Additional Usage Notes

This standard run-time function is not commonly used since field/control validation is performed whenever
a panel field/control is input.

RMP--STATUS Values

Status value Description

0 The function executed successfully.

1 The field/control name is invalid.

2 The occurrence number is invalid.

5 The panel is not in this library

6 The library does not exist.

14 A COBOL input/output error was encountered on the
panel library during execution of this function. To
determine the exact nature of the I/O error, use the C
$RERR subprogram.

Utility Functions

The RM/Panels utility functions are provided to allow you to control the overall behavior of the RM/Panels
run-time system, rather than manipulate individual panels. Unlike the RM/Panels standard run-time
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functions described previously, the utility functions are not related to individual panels, are not generated
into the panelname.PRC files, and do not require a panel work area parameter. These functions are
included in your program through CALL statements.

The following table gives the name and abbreviation of each RM/Panels utility function.

Function Abbreviation

DELETE TEMPORARY FILE DTF

END MODELESS OPERATION EMD

END POLLING EP

HIDE MOUSE CURSOR HMC

SET COLOR SCO

SET MONOCHROME SMO

SHOW MOUSE CURSOR SMC

START MODELESS OPERATION SMD

START POLLING SP

Each utility function is described in the following sections. All parameters for RM/Panels utility functions are
defined in Appendix B, Standard, Utility, and Extended Run-Time Functions and Parameters.

DELETE TEMPORARY FILE

Execution
CALL RMP--RUNTIME USING RMP--U-DTF RMP--PARAMETERS

Description

This utility function removes the temporary file that may have been created by the RM/Panels run-time
system.

If dynamic changes are made to a panel during execution of an application, RM/Panels may create a
temporary file to store the altered panel information. This file may also be created if modeless operation is
used. The temporary file should be deleted before exiting from COBOL back to the operating system to
prevent wasted disk space.

This utility function should not be performed when a CALLed program is exited, but when the COBOL run
unit itself is about to be terminated.

Note: It is recommended to always perform this utility function before terminating a COBOL run unit
that uses RM/Panels. If no temporary file has been created, the utility function does not perform any
action.

END MODELESS OPERATION

Execution
CALL RMP--RUNTIME USING RMP--U-EMD RMP--PARAMETERS

Description

This utility function tells the RM/Panels run-time system to end modeless operation, which was started with
the START MODELESS OPERATION utility function.
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END POLLING

Execution
CALL RMP--RUNTIME USING RMP--U-EP RMP--PARAMETERS

Description

This utility function instructs the RM/Panels run-time system to end the polling process, which was started
with the START POLLING utility function.

HIDE MOUSE CURSOR

Execution
CALL RMP--RUNTIME USING RMP--U-HMC RMP--PARAMETERS

Description

This utility function removes the mouse cursor from the monitor.

When RM/Panels opens a panel library, it checks for the presence of a mouse. If a mouse is found, the
mouse cursor is displayed. The mouse cursor remains visible until you remove it. You may wish to hide the
mouse cursor temporarily while performing some lengthy process, or you may wish to hide it while
executing a portion of the application that does not support the mouse. While the mouse cursor is hidden,
RM/Panels disregards any mouse events.

If your application does not wish to support the mouse at all, simply do not include rmpmouse.exe with
your application. If this file is not present, RM/Panels does not recognize the mouse.

Before exiting from COBOL back to the operating system, you should perform this utility function to hide the
mouse cursor. If you fail to do this, the mouse cursor is displayed at the operating system prompt.

Note: Mouse support is not available for UNIX systems. The HIDE MOUSE CURSOR has no effect
under Windows.

SET COLOR

Execution
CALL RMP--RUNTIME USING RMP--U-SCO RMP--PARAMETERS

Description

This utility function instructs the RM/Panels run-time system to perform all subsequent screen output with
color specifications.

This utility function does not automatically redisplay any information that is on the monitor. After executing
this function, the application program should redisplay any information it wants to have redisplayed in color.

Use this utility function to cancel the effects of a previous SET MONOCHROME utility function or the
setting of RMP--FORCE-MONO to TRUE in RMPANELS.WS. However, if RMP--FORCE-MONO remains TRUE,
the run-time system reverts to monochrome output when a different panel library is opened, because
RMP--FORCE-MONO is checked every time a library is opened. If the SET COLOR function is used to
cancel the effects of RMP--FORCE-MONO, RMP--FORCE-MONO should be set to FALSE.

SET MONOCHROME

Execution
CALL RMP--RUNTIME USING RMP--U-SMO RMP--PARAMETERS
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Description

This utility function instructs the RM/Panels run-time system to perform all subsequent screen output
without color specifications.

RMPANELS.WS contains a parameter that can be set to force monochrome operation (RMP--FORCE-
MONO), but this parameter is only checked when a panel library is opened. This utility function allows the
application program to change to monochrome operation at any time.

This utility function does not automatically redisplay any information that is on the monitor. After executing
this utility function, the application program should redisplay any information it wants to have redisplayed in
monochrome.

SHOW MOUSE CURSOR

Execution
CALL RMP--RUNTIME USING RMP--U-SMC RMP--PARAMETERS

Description

This utility function makes the mouse cursor visible on the monitor.

When RM/Panels opens a panel library, it checks for the presence of a mouse. If a mouse if found, the
mouse cursor is displayed. This mouse cursor remains visible until you remove it with the HIDE MOUSE
CURSOR utility function. After hiding the mouse cursor, you can use the SHOW MOUSE CURSOR utility
function to make the mouse cursor visible again.

When the RM/Panels run-time system opens a panel library, it automatically makes the mouse cursor
visible if it recognizes the mouse. The SHOW MOUSE CURSOR utility function is only needed if you hide
the mouse cursor and then want to restore it.

Note: Mouse support is not available for UNIX systems. The SHOW MOUSE CURSOR function has
no effect under Windows.

START MODELESS OPERATION

Execution
CALL RMP--RUNTIME USING RMP--U-SMD RMP--PARAMETERS

Description

This utility function instructs the RM/Panels run-time system to begin modeless operation. Modeless
behavior differs from modal behavior, which is the default.

In modal operation, a panel is displayed, information is entered on that and only that panel, then the panel
is removed or possibly overlaid by another panel. In modal operation, the topmost panel is the only panel
that can be accessed.

However, in modeless operation, the user can choose between a number of displayed panels. The chosen
panel is displayed again on top of the other panels, and the user can work with that panel.

By default, RM/Panels works in a modal state. When an EXECUTE EVENT standard run-time function is
performed, RM/Panels recognizes only events for the panel for which the function was performed. In a
modeless state, RM/Panels recognizes a mouse click on any displayed panel as a request to access that
panel, informs the application program which panel was chosen, and if the application program allows it,
redisplays that panel on top of the others.

This process does not complicate RM/Panels programming nearly as much as you might think. It really just
requires that a check be added to the event loop to see which panel was requested.

The following limitations apply to modeless behavior:

194 | Upgrading to Enterprise Developer



• This utility function should be executed before any panels that are to be modeless are displayed. Any
panels already displayed when this utility function is performed will be ignored.

• DISPLAY statements should not be used to place information on panels that will be modeless. The RM/
Panels run-time system will be automatically redisplaying these panels and you will not get an
opportunity to display your information.

• There is a limit of 2000 bytes of data for each panel that will be used in modeless operation.

Note: Modeless operation is not supported under Windows.

START POLLING

Execution
CALL RMP--RUNTIME USING RMP--U-SP RMP--PARAMETERS

Description

This utility function instructs the RM/Panels run-time system to begin a polling process, during which the
EXECUTE EVENT standard run-time function will report a polling event to the application program
whenever a specified amount of time has elapsed.

At first this might seem similar to the time-out event that is available for fields/controls, but the time-out
interval is relative to the time at which the field/control gained keyboard focus. The polling interval is relative
to actual clock time.

The polling event is reported only by the EXECUTE EVENT standard run-time function and is subject to
limitations. Internal processes of the RM/Panels run-time system are not interrupted to report the event,
therefore, the polling event is reported as soon as possible after the polling interval has passed. You should
allow for some delay in receiving these events. It would be unwise to count polling intervals to determine
total elapsed time, especially when a very short polling period is set, as some could be missed.

Required Parameters

RMP--POLLING-INTERVAL must be set to the polling interval in seconds. The value must be in the range
1–999999.

Appendix A: Master Copy File RMPANELS.WS

RMPANELS.WS is a master copy file that must be copied into the Working-Storage Section of each
application program that uses RM/Panels. It contains a parameter block used to pass parameters between
the program and the RM/Panels run-time system.

Appendix B lists the contents of RMPANELS.WS and describes each field contained in the file.

Note: The RM/Panels parameter block contained in RMPANELS.WS may also be passed to CALLed
programs. This allows changes to the key configuration information to be made in a “high level”
program and affect all the programs it calls.

To declare the parameter block in a called program, use RMPANELS.LNK instead of RMPANELS.WS.
RMPANELS.WS is a copy of RMPANELS.WS with the value clauses removed (but the 88-level items not
removed) so that it compiles cleanly in the Linkage Section. Never use RMPANELS.WS in the Working-
Storage Section.

Another strategy can be used to make changes in the RM/Panels parameter block available to all
programs. You can use a file called RMPANELS.EXT to declare the RMPANELS parameter block as an
external variable in the Working-Storage Section of all programs. (RMPANELS.EXT is identical to
RMPANELS.WS, but with a declaration of EXTERNAL.)

You must initialize certain variables when using RMPANELS.EXT before any program calls the RM/Panels
run-time system. The initialization needs to be done only once by one program no matter how many
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programs are involved. The external declaration of the parameter block causes the values to be retained.
The following statements initialize the necessary variables.

These statements must be included exactly as shown:

MOVE 200 TO RMP--VERSION.
MOVE X"0102030405060708090A0B0C0D0E0F"
    TO RMP--FUNCTION-CODES (1:15).
MOVE X"101112131415161718191A1B1C1D"  
    TO RMP--FUNCTION-CODES (16:14).
MOVE X"F1F2F3F4F5F6F7F8F9" 
    TO RMP--FUNCTION-CODES (30:9).
MOVE X"808182838485868788898A8B8C8D8E8F"
    TO RMP--FUNCTION-CODES (39:16).
MOVE X"909192939495969798999A9B9C9D"  
    TO RMP--FUNCTION-CODES (55:14).
MOVE X"A0A1A2A3"
    TO RMP--FUNCTION-CODES (69:4).
MOVE X"B0B1B3B4B7B8B9BA"
    TO RMP--FUNCTION-CODES (73:8).

These statements can be tailored to your preferences:

MOVE "runpan2" TO RMP--RUNTIME.
MOVE SPACE TO RMP--TEMP-FILE-NAME RMP--TEMP-FILE-DIRECTORY.
SET RMP--DEBUG RMP--PROT-PREVENT-CHAR TO TRUE.
SET RMP--GEN-HELP-SUP RMP--FORCE-MONO TO FALSE.
MOVE "001000000000000" TO RMP--HELP-KEY-VALUES.
MOVE "013000000000000" TO RMP--RETURN-KEY-VALUES.
MOVE "053000000000000" TO RMP--NEXT-FIELD-KEY-VALUES.
MOVE "052000000000000" TO RMP--PREV-FIELD-KEY-VALUES.
MOVE "058000000000000" TO RMP--NEXT-GROUP-KEY-VALUES.
MOVE "056000000000000" TO RMP--PREV-GROUP-KEY-VALUES.
MOVE "027000000000000" TO RMP--PULLDOWN-KEY-VALUES.

Contents of RMPANELS WS

01 RMP--PARAMETERS.
   03 RMP--INTERNAL-VALUES.
     05 RMP--VERSION PIC 9(4) VALUE 200.  
   03 RMP--CONFIGURATION-PARAMETERS.
     05 RMP--RUNTIME PIC X(80) VALUE "runpan2".
     05 RMP--TEMP-FILE-NAME PIC X(12) VALUE SPACE.
     05 RMP--TEMP-FILE-DIRECTORY PIC X(80) VALUE SPACE.
     05 RMP--DEBUG-SW PIC X VALUE "N".
        88 RMP--DEBUG VALUE "Y" WHEN FALSE "N".
     05 RMP--PROT-CHAR-SW PIC X VALUE "N".
        88 RMP--PROT-ALLOW-CHAR VALUE "Y".
        88 RMP--PROT-PREVENT-CHAR VALUE "N".
     05 RMP--FORCE-MONO-KEY PIC 9(3).
     05 RMP--USER-EDIT-KEY PIC 9(3).
     05 RMP--BACKSPACE-KEY PIC 9(3).
     05 RMP--GEN-HELP-SUP-SW PIC X VALUE "N".
        88 RMP--GEN-HELP-SUP VALUE "Y" WHEN FALSE "N".
     05 RMP--KEY-CONFIGURATION.
        07 RMP--HELP-KEY-VALUES PIC X(15)
                                VALUE "001000000000000".
        07 RMP--RETURN-KEY-VALUES PIC X(15)
                                VALUE "013000000000000".
        07 RMP--NEXT-FIELD-KEY-VALUES PIC X(15)
                                VALUE "053000000000000".
        07 RMP--PREV-FIELD-KEY-VALUES PIC X(15)
                                VALUE "052000000000000".
        07 RMP--NEXT-GROUP-KEY-VALUES PIC X(15)
                                VALUE "058000000000000".
        07 RMP--PREV-GROUP-KEY-VALUES PIC X(15)
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                                VALUE "056000000000000".
        07 RMP--PULLDOWN-KEY-VALUES PIC X(15)
                                VALUE "027000000000000".
   03 RMP--GENERAL-FUNCTION-PARAMS.
      05 RMP--LIBRARY PIC X(80).
      05 RMP--FIELD-NAME PIC X(30).
      05 RMP--FIELD-OCCUR PIC 9(4).
      05 RMP--FIELD-SEQ PIC 9(3).
      05 RMP--ATTRIBUTE PIC X.
      05 RMP--PALETTE PIC 99.
      05 RMP--SUPPRESS-EVENT-RESET-SW PIC X VALUE "N".
         88 RMP--SUPPRESS-EVENT-RESET VALUE "Y" WHEN FALSE "N".
      05 RMP--FORCE-MONO-SW PIC X VALUE "N".
         88 RMP--FORCE-MONO VALUE "Y" WHEN FALSE "N".
      05 RMP--POLLING-INTERVAL PIC 9(6).
   03 RMP--PANEL-DISPLAY-PARAMS.
      05 RMP--SHOW-FIELDS-SW PIC X VALUE "N".
         88 RMP--SHOW-FIELDS VALUE "Y" WHEN FALSE "N".
      05 RMP--CLEAR-SW PIC X VALUE "N".
         88 RMP--CLEAR VALUE "Y" WHEN FALSE "N".
      05 RMP--WINDOW-SW PIC X VALUE SPACE.
         88 RMP--WINDOW VALUE "Y" WHEN FALSE "N".
      05 RMP--PANEL-LINE PIC 9(3).
      05 RMP--PANEL-POS PIC 9(3).
      05 RMP--BEEP-SW PIC X VALUE "N".
         88 RMP--BEEP VALUE "Y" WHEN FALSE "N".
   03 RMP--EXECUTE-EVENT-PARAMS.
      05 RMP--EE-CONTROL-PARAMS.
         07 RMP--REPEAT-EVENT-SW PIC X VALUE "N".
            88 RMP--REPEAT-EVENT VALUE "Y" WHEN FALSE "N".
         07 RMP--FIRST-FIELD-SW PIC X VALUE "N".  
            88 RMP--FIRST-FIELD VALUE "Y" WHEN FALSE "N".
         07 RMP--NEXT-FIELD PIC X(30).
         07 RMP--NEXT-OCCUR PIC 9(3).
         07 RMP--NEXT-CURSOR-POS PIC 9(4).
         07 RMP--NEXT-FIELD-SEQ PIC 9(3).
         07 RMP--SUPPRESS-SELECTION-SW PIC X VALUE "N".
            88 RMP--SUPPRESS-SELECTION VALUE "Y" WHEN FALSE "N".
      05 RMP--EE-RETURNED-PARAMS.
         07 RMP--LAST-FIELD PIC X(30).
         07 RMP--LAST-OCCUR PIC 9(3).
         07 RMP--LAST-CURSOR-POS PIC 9(4).
         07 RMP--LAST-FIELD-SEQ PIC 9(3).
         07 RMP--EVENT-TYPE PIC X VALUE SPACE.
            88 RMP--BUTTON-PRESS VALUE "B".
            88 RMP--BOX-CHANGED VALUE "C".
            88 RMP--MENU-COMMAND VALUE "M".
            88 RMP--RADIO-BTN-PRESSED VALUE "R".
            88 RMP--LB-CHOICE-SELECTED VALUE "L".
            88 RMP--SB-MOVED VALUES ARE "S" "D" "d" "U" "u".
            88 RMP--SB-PAGE-UP VALUE "U".
            88 RMP--SB-PAGE-DOWN VALUE "D".
            88 RMP--SB-STEP-UP VALUE "u".
            88 RMP--SB-STEP-DOWN VALUE "d".
            88 RMP--SB-DRAG VALUE "S".
            88 RMP--TIME-OUT-OCCURRED VALUE "T".
            88 RMP--POLLING-OCCURRED VALUE "P".
            88 RMP--PANEL-MOVED VALUE "F".
         07 RMP--DATA-CHANGED-SW PIC X VALUE "N".
            88 RMP--DATA-CHANGED VALUE "Y" WHEN FALSE "N".
         07 RMP--PULLDOWN-PARAMETERS.
            09 RMP--COMMAND-NAME PIC X(30).
            09 RMP--COMMAND-TEXT PIC X(30).
         07 RMP--MOUSE-CLICK-TYPE PIC X VALUE SPACE.
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            88 RMP--DOUBLE-CLICK VALUE "D".
            88 RMP--SINGLE-CLICK VALUE "S".
         07 RMP--LAST-PANEL PIC X(20).
         07 RMP--REQUESTED-PANEL PIC X(20).
         07 RMP--PROT-CHAR PIC X.
         07 FILLER PIC X(96).
   03 RMP--RETURNED-VALUES.
      05 RMP--EXCEPTION-NUMBER PIC 9(3).
         88 F10-KEY VALUE 10.
         88 ESCAPE-KEY VALUE 27.
      05 RMP--MOUSE-PRESENT-SW PIC X VALUE SPACE.
         88 RMP--MOUSE-PRESENT VALUE "Y" WHEN FALSE "N".
      05 RMP--VALID-INPUT-SW PIC X VALUE SPACE.
         88 RMP--VALID-INPUT VALUE "Y".
         88 RMP--INVALID-INPUT VALUE "N".
      05 RMP--STATUS PIC 9(4) VALUE 0.
         88 RMP--VALID-FUNCTION VALUE 0.
         88 RMP--FIELD-INVALID VALUE 1.
         88 RMP--OCCUR-INVALID VALUE 2.
         88 RMP--FUNCTION-INVALID VALUE 3.
         88 RMP--ATTRIBUTE-INVALID VALUE 4.
                  88 RMP--PANEL-INVALID VALUE 5.
                  88 RMP--LIBRARY-INVALID VALUE 6.
                  88 RMP--CONFIG-INVALID VALUE 7.
                  88 RMP--NO-FIELDS VALUE 8.
                  88 RMP--NO-ENABLED-FIELDS VALUE 9.
                  88 RMP--PANEL-NOT-DISPLAYED VALUE 10.
                  88 RMP--PALETTE-INVALID VALUE 11.
                  88 RMP--NO-HELP-DEFINED VALUE 12.
                  88 RMP--NO-ERROR-DEFINED VALUE 13.
                  88 RMP--IO-ERROR VALUE 14.
                  88 RMP--FIELD-DISABLED VALUE 15.
                  88 RMP--WINDOW-ERROR VALUE 16.
                  88 RMP--MENU-COMMAND-INVALID VALUE 20.
                  88 RMP--MODELESS-DATA-OVERLOAD VALUE 21.
                  88 RMP--NO-PULLDOWN VALUE 22.
                  88 RMP--WRONG-FIELD-TYPE VALUE 23.
                  88 RMP--TOO-MANY-PANELS VALUE 40.
                  88 RMP--CANNOT-CREATE-TEMP VALUE 41.
                  88 RMP--CANNOT-OPEN-TEMP VALUE 42.
                  88 RMP--API-PARAM-MISSING VALUE 1001.
                  88 RMP--API-MSG-NOT-DEFINED VALUE 1002.
                  88 RMP--API-PD-OPTION-INVALID VALUE 1003.
                  88 RMP--API-UNCHECKABLE VALUE 1004.
     03 RMP--FUNCTION-CODES.
           05 RMP--CAF PIC X VALUE X"01".
           05 RMP--CPP PIC X VALUE X"02".
           05 RMP--DAF PIC X VALUE X"03".
     05 RMP--DF PIC X VALUE X"04".
     05 RMP--DFI PIC X VALUE X"05".
     05 RMP--DP PIC X VALUE X"06".
     05 RMP--EE PIC X VALUE X"07".
     05 RMP--EFI PIC X VALUE X"08".
     05 RMP--IAF PIC X VALUE X"09". 
     05 RMP--IF PIC X VALUE X"0A".
     05 RMP--RP PIC X VALUE X"0B".
     05 RMP--SFA PIC X VALUE X"0C".
     05 RMP--SFE PIC X VALUE X"0D".
     05 RMP--SFH PIC X VALUE X"0E".
     05 RMP--SPE PIC X VALUE X"0F".
     05 RMP--SPH PIC X VALUE X"10".
     05 RMP--VAF PIC X VALUE X"11".
     05 RMP--VF PIC X VALUE X"12".
     05 RMP--SSR PIC X VALUE X"13".
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     05 RMP--EMO PIC X VALUE X"14".
     05 RMP--DMO PIC X VALUE X"15".
     05 RMP--CMO PIC X VALUE X"16".
     05 RMP--UMO PIC X VALUE X"17".
     05 RMP--EA PIC X VALUE X"18".
     05 RMP--DA PIC X VALUE X"19".
     05 RMP--AF PIC X VALUE X"1A".
     05 RMP--PUM PIC X VALUE X"1B".
     05 FILLER PIC X(2).
     05 RMP--U-SMC PIC X VALUE X"F1".
     05 RMP--U-HMC PIC X VALUE X"F2".
     05 RMP--U-SMD PIC X VALUE X"F3".
     05 RMP--U-EMD PIC X VALUE X"F4".
     05 RMP--U-DTF PIC X VALUE X"F5".
     05 RMP--U-SMO PIC X VALUE X"F6".
     05 RMP--U-SCO PIC X VALUE X"F7".
     05 RMP--U-SP PIC X VALUE X"F8".
     05 RMP--U-EP PIC X VALUE X"F9".
     05 RMP--E-CL PIC X VALUE X"80".
     05 RMP--E-AL PIC X VALUE X"81".
     05 RMP--E-CP PIC X VALUE X"82".
     05 RMP--E-AP PIC X VALUE X"83".
     05 RMP--E-SPL PIC X VALUE X"84".
     05 RMP--E-GPL PIC X VALUE X"85".
     05 RMP--E-GPC PIC X VALUE X"86".
     05 RMP--E-SPC PIC X VALUE X"87".
     05 RMP--E-GFD PIC X VALUE X"88".
     05 RMP--E-AFD PIC X VALUE X"89".
     05 RMP--E-CFD PIC X VALUE X"8A".
     05 RMP--E-GFV PIC X VALUE X"8B".
     05 RMP--E-SFV PIC X VALUE X"8C".
     05 RMP--E-GPT PIC X VALUE X"8D".
     05 RMP--E-SPT PIC X VALUE X"8E".
     05 RMP--E-GPD PIC X VALUE X"8F".
     05 RMP--E-SPD PIC X VALUE X"90".
     05 RMP--E-GMS PIC X VALUE X"91".
     05 RMP--E-SMS PIC X VALUE X"92".
     05 RMP--E-SHM PIC X VALUE X"93".
     05 RMP--E-SPLT PIC X VALUE X"94".
     05 RMP--E-GPLT PIC X VALUE X"95".
     05 RMP--E-SLC PIC X VALUE X"96".
     05 RMP--E-GLC PIC X VALUE X"97".
     05 FILLER PIC X(6).
     05 RMP--E-GFN PIC X VALUE X"A0".
     05 FILLER PIC X(3).  
     05 RMP--E-SP PIC X VALUE X"B0".
     05 RMP--E-DC PIC X VALUE X"B1".
     05 RMP--E-DFD PIC X VALUE X"B3".
     05 RMP--E-HDP PIC X VALUE X"B4".
     05 RMP--E-RMO PIC X VALUE X"B7".
     05 FILLER PIC X(2).
     05 RMP--E-UDP PIC X VALUE X"BA".
   03 RMP--SCROLL-BAR-WS.
     05 RMP--SB-MIN PIC 9(4).
     05 RMP--SB-MAX PIC 9(4).
     05 RMP--SB-STEP PIC 9(4).
     05 RMP--SB-PAGE PIC 9(4).
     05 RMP--SB-OPERATED PIC X(30).
   03 FILLER PIC X(50).

RMPANELS WS Field Definitions

01 RMP--PARAMETERS.
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This is the group-level name used to reference the entire parameter block.

03 RMP--INTERNAL-VALUES.

This area contains values that are used solely by RM/Panels.

05 RMP--VERSIONPIC 9(4) VALUE 210.

This field allows future versions of the RM/Panels run-time system to provide backward compatibility with
the current version.

03 RMP--CONFIGURATION-PARAMETERS.

This area contains values that configure the behavior of the RM/Panels run-time system.

05 RMP--RUNTIMEPIC X(80) VALUE "runpan2".

This area contains the name of the RM/Panels run-time system program. The value clause contains the
default value. This default can be changed by individual programs at run-time execution, or can be modified
in RMPANELS.WS before programs are compiled.

05 RMP--TEMP-FILE-NAMEPIC X(12) VALUE SPACE.

If dynamic changes are made to a panel, a temporary file may be created by the RM/Panels run-time
system to store these changes. RM/Panels generates a filename if this field is blank, but if you supply a
filename here it is used instead. Supplying a filename does not require you to supply a directory in RMP--
TEMP-FILE-DIRECTORY.

05 RMP--TEMP-FILE-DIRECTORYPIC X(80) VALUE SPACE.

If dynamic changes are made to a panel, a temporary file may be created by the RM/Panels run-time
system to store these changes. RM/Panels places this file in the current working directory if this field is
blank, but if you supply a directory name here it is used instead. Supplying a directory name does not
require you to supply a filename in RMP--TEMP-FILE-NAME.

05 RMP--DEBUG-SWPIC X VALUE "N."
   88 RMP--DEBUG VALUE "Y" WHEN FALSE "N".

This parameter can be used to enable the RM/Panels debugging mode. In this mode, extensive information
is presented on the screen whenever an invalid standard run-time function request is made. The debugging
mode should be used during program development. The parameter is set by the following statement:

SET RMP--DEBUG TO TRUE.
05 RMP--PROT-CHAR-SWPIC X VALUE "N".
   88 RMP--PROT-ALLOW-CHAR VALUE "Y".
   88 RMP--PROT-PREVENT-CHAR VALUE "N".

This parameter is used to control the type of keyboard action that returns control to the application program
when a protected field/control is being entered. If RMP--PROT-ALLOW-CHAR is TRUE, a normal character
key returns control to the application program in addition to exception keys. If RMP--PROT-PREVENT-
CHAR is TRUE, only exception keys return control to the application program when a protected field/control
is being entered. The parameter is set by the following statement:

SET RMP--PROT-ALLOW-CHAR TO TRUE.
05 RMP--FORCE-MONO-KEYPIC 9(3).

This parameter is used to indicate a field termination code that toggles between color and monochrome on
the monitor, regardless of the type of video adapter or terminal being used. The parameter is set by the
following statement:

MOVE 94 TO RMP--FORCE-MONO-KEY.

or by adding a value clause:

05 RMP--BACKSPACE-KEYPIC 9(3) VALUE 75.
05 RMP--USER-EDIT-KEYPIC 9(3).
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This parameter is used to indicate a field termination code that starts the End-User Panel Editor. The
parameter is set by the following statement:

MOVE 95 TO RMP--USER-EDIT-KEY.

or by adding a value clause:

05 RMP--BACKSPACE-KEYPIC 9(3) VALUE 75.
05 RMP--BACKSPACE-KEYPIC 9(3).

This parameter is used to indicate the field termination code that is generated by the Backspace key. The
parameter is set by the following statement:

MOVE 75 TO RMP--BACKSPACE-KEY.

or by adding a value clause:

05 RMP--BACKSPACE-KEYPIC 9(3) VALUE 75.
05 RMP--GEN-HELP-SUP-SWPIC X VALUE "N".
   88 RMP--GEN-HELP-SUP VALUE "Y" WHEN FALSE "N".

This parameter is used to suppress the ability to display the panel help message when a field/control-
specific help message is displayed. This parameter is set by the following statement:

SET RMP--GEN-HELP-SUP TO TRUE.
05 RMP--KEY-CONFIGURATION.

This area contains values that identify specific keys to the RM/Panels run-time system. These keys control
RM/Panels behavior, such as displaying help messages, or moving to the previous field/control. Default
values are included, but these can be changed by individual programs at run-time execution, or modified in
RMPANELS.WS before programs are compiled.

Each entry relates to a specific type of behavior and contains room for up to five keys that RM/Panels
recognizes. The values assigned to the entry are three-digit RM/COBOL field termination codes.

The order of the values is not important. When modifying values, be careful to use three-digit values and
do not add spaces. For example:

The help function in the default configuration is assigned to the F1 key.

The F1 key is field termination code 1, so the default configuration is:

07 RMP--HELP-KEY-VALUES PIC X(15) VALUE "001000000000000".

If you want the F3 key (field termination code 3) and the F9 key (field termination code 9) to also function
as help keys, you would change the help key configuration to the following:

07 RMP--HELP-KEY-VALUES PIC X(15) VALUE "001003009000000".
07 RMP--HELP-KEY-VALUESPIC X(15) VALUE "001000000000000".

This area specifies the field termination codes that initiate the automatic help messages provided by RM/
Panels.

07 RMP--RETURN-KEY-VALUESPIC X(15) VALUE "013000000000000".

This area specifies the field termination codes that should be interpreted by RM/Panels as the Enter key.

07 RMP--NEXT-FIELD-KEY-VALUES PIC X(15) VALUE "053000000000000".

This area specifies the field termination codes that should be interpreted by RM/Panels as a request to
move to the next field/control on the panel.

07 RMP--PREV-FIELD-KEY-VALUES PIC X(15) VALUE "052000000000000".

This area specifies the field termination codes that should be interpreted by RM/Panels as a request to
move to the previous field/control on the panel.

07 RMP--NEXT-GROUP-KEY-VALUES PIC X(15) VALUE "058000000000000".
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This area specifies the field termination codes that should be interpreted by RM/Panels as a request to
move to the next group on the panel.

07 RMP--PREV-GROUP-KEY-VALUES PIC X(15) VALUE "056000000000000".

This area specifies the field termination codes that should be interpreted by RM/Panels as a request to
move to the previous group on the panel.

07 RMP--PULLDOWN-KEY-VALUESPIC X(15) VALUE "027000000000000".

This area specifies the field termination codes that should be interpreted by RM/Panels as a request to
activate a pulldown menu.

03 RMP--GENERAL-FUNCTION-PARAMS.

This area contains parameters that are used with a number of different standard run-time functions.

05 RMP--LIBRARYPIC X(80).

This parameter identifies the panel library that contains the panels to be used. It must be set before the first
panel is used, and set again whenever a new panel library is needed.

05 RMP--FIELD-NAMEPIC X(30).

This parameter is used with many standard run-time functions to identify a specific panel field/control.

05 RMP--FIELD-OCCURPIC 9(4).

This parameter is used with many standard run-time functions to identify a specific occurrence of a panel
field/control.

05 RMP--FIELD-SEQPIC 9(3).

This parameter is used with many standard run-time functions to identify a panel field/control by the order
in which it is entered on the panel.

05 RMP--ATTRIBUTEPIC X.

This parameter is used to specify an attribute value for the SET FIELD ATTRIBUTE standard run-time
function.

05 RMP--PALETTEPIC 99.

This parameter is used to select a palette for the DISPLAY PANEL and CHANGE PANEL PALETTE
standard run-time functions.

05 RMP--SUPPRESS-EVENT-RESET-SW PIC X VALUE "N". 
   88 RMP--SUPPRESS-EVENT-RESET VALUE "Y" WHEN FALSE "N".

This parameter is used with the ENABLE/DISABLE FIELD standard run-time function, but it is included
here because it controls the EXECUTE EVENT standard run-time function. It prevents RM/Panels from
resetting the values of RMP--NEXT-FIELD and RMP--NEXT-OCCUR when a field/control is enabled or
disabled.

05 RMP--FORCE-MONO-SWPIC X VALUE "N". 
   88 RMP--FORCE-MONO VALUE "Y" WHEN FALSE "N".

This parameter is used to tell the RM/Panels run-time system to operate in monochrome mode,
suppressing all colors. Because this parameter is checked by the run-time system when a library is
opened, it must be set before a library is open. Setting RMP--FORCE-MONO to TRUE after opening a
library has no effect until a new library is opened. This parameter is set by the following statement:

SET RMP--FORCE-MONO TO TRUE. 
05 RMP--POLLING-INTERVALPIC 9(6).

This parameter is used by the utility function, START POLLING, to specify a polling interval in seconds.

03 RMP--PANEL-DISPLAY-PARAMS.
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This area contains parameters for the DISPLAY PANEL standard run-time function. RMP--CLEAR-SW is
also a parameter for the REMOVE PANEL standard run-time function.

05 RMP--SHOW-FIELDS-SWPIC X VALUE "N". 
   88 RMP--SHOW-FIELDS VALUE "Y" WHEN FALSE "N".

This parameter is used to display the values of panel fields/controls at the same time the panel is
displayed. The parameter is set by the following statement:

SET RMP--SHOW-FIELDS TO TRUE. 
05 RMP--CLEAR-SWPIC X VALUE "N". 
   88 RMP--CLEAR VALUE "Y" WHEN FALSE "N".

This parameter is used to erase the entire screen before a panel is displayed, or when a panel is erased.
The parameter is set by the following statement:

SET RMP--CLEAR TO TRUE. 
05 RMP--WINDOW-SWPIC X VALUE SPACE. 
   88 RMP--WINDOW VALUE "Y" WHEN FALSE "N".

This parameter is used to override the default windowing characteristic of a panel. To force a panel to
display as a window, set the parameter by the following statement:

SET RMP--WINDOW TO TRUE.     

To force a panel to display without behaving as a window, set the parameter by the following statement:

SET RMP--WINDOW TO FALSE. 
05 RMP--PANEL-LINEPIC 9(3).     

This parameter is used to control the screen line at which a panel is displayed. Leaving this value at 0
accepts the default. Setting this parameter to 999 centers the panel vertically. Setting any other value
displays the panel at the specified line.

05 RMP--PANEL-POSPIC 9(3).     

This parameter is used to control the screen column at which a panel is displayed. Leaving this value at 0
accepts the default. Setting this parameter to 999 centers the panel horizontally. Setting any other value
displays the panel at the specified column.

05 RMP--BEEP-SWPIC X VALUE "N". 
   88 RMP--BEEP VALUE "Y" WHEN FALSE "N".

This parameter is used to generate a beep when a panel is displayed. The parameter is set by the following
statement:

SET RMP--BEEP TO TRUE. 
03 RMP--EXECUTE-EVENT-PARAMS.

These fields are parameters or returned values related to the EXECUTE EVENT standard run-time
function.

05 RMP--EE-CONTROL-PARAMS.

These parameters are used to control the behavior of a single execution of the EXECUTE EVENT standard
run-time function.

07 RMP--REPEAT-EVENT-SWPIC X VALUE "N". 
   88 RMP--REPEAT-EVENT VALUE "Y" WHEN FALSE "N".

This parameter is used to force the RM/Panels run-time system to repeat the last event executed on this
panel. It is set by the following statement:

SET RMP--REPEAT-EVENT TO TRUE.
07 RMP--FIRST-FIELD-SWPIC X VALUE "N". 
   88 RMP--FIRST-FIELD VALUE "Y" WHEN FALSE "N".     
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This parameter is used to force the RM/Panels run-time system to begin user input with the first field/
control on the panel. The parameter is set by the following statement:

SET RMP--FIRST-FIELD TO TRUE.
07 RMP--NEXT-FIELDPIC X(30).     

This parameter is set by the RM/Panels run-time system to indicate the name of the field/control that will be
entered next by the user. It may be modified by the application program to force input of a different field/
control.

07 RMP--NEXT-OCCURPIC 9(3).

This parameter is set by the RM/Panels run-time system to indicate the occurrence of the field/control that
will be entered next by the user. It may be modified by the application program to force input of a different
occurrence.

07 RMP--NEXT-CURSOR-POSPIC 9(4).

This parameter is automatically set to zero by the RM/Panels run-time system and causes the cursor to
move to the start of a field/control. By setting this parameter to a value other than zero, you can control the
character position that the cursor initially moves to in a field/control.

Note: This value may be ignored under some graphical user interfaces.

07 RMP--NEXT-FIELD-SEQPIC 9(3).     

This parameter is automatically set to zero by the RM/Panels run-time system and causes the cursor to
move to the first enabled field/control. By setting this parameter to a value other than zero, you can control
the field/control that is input next by entry order number.

07 RMP--SUPPRESS-SELECTION-SWPIC X VALUE "N". 
   88 RMP--SUPPRESS-SELECTIONVALUE "Y" WHEN FALSE "N".     

Setting this parameter to TRUE prevents the field/control being input during the next EXECUTE EVENT
standard run-time function from being displayed with the selected attribute, even though it has the
keyboard focus.

05 RMP--EE-RETURNED-PARAMS.

The parameters in this area contain values returned by the RM/Panels EXECUTE EVENT standard run-
time function.

07 RMP--LAST-FIELDPIC X(30).

This parameter is used by the RM/Panels run-time system to indicate the name of the field/control that was
just entered by the user.

07 RMP--LAST-OCCURPIC 9(3).
     

This parameter is used by the RM/Panels run-time system to indicate the occurrence of the field/control
that was just entered by the user.

07 RMP--LAST-CURSOR-POSPIC 9(4).     

This parameter is set to the location of the keyboard cursor, relative to the start of the field/control, when
input was terminated. It is set only for input type fields/controls.

Note: This value may not be reported under some graphical user interfaces.

07 RMP--LAST-FIELD-SEQPIC 9(3).

This parameter is set to the entry order number of the field/control that was just entered by the user.

07 RMP--EVENT-TYPEPIC X VALUE SPACE.
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This parameter is set by the RM/Panels run-time system to describe the type of event that just occurred. If
none of the following conditions occur, input is terminated “normally”, that is, by auto exit or by pressing a
field termination key.

88 RMP--BUTTON-PRESS VALUE "B".

This condition indicates that a push button was pressed. The name of the push button is contained in
RMP--NEXT-FIELD. The condition-name representing the button in panelname-WS is also set to TRUE.

88 RMP--BOX-CHANGED VALUE "C".     

This condition indicates that a check box was toggled. The name of the check box is contained in RMP--
NEXT-FIELD.

88 RMP--MENU-COMMAND VALUE "M".

This condition indicates that a pulldown menu command was selected. The name and text of the command
are contained in RMP--COMMAND-NAME and RMP--COMMAND-TEXT, respectively.

88 RMP--RADIO-BTN-PRESSED VALUE "R".

This condition indicates that a radio button was pressed. The name of the radio button is contained in
RMP--NEXT-FIELD.

88 RMP--LB-CHOICE-SELECTED VALUE "L".

This condition indicates that a list box choice was selected. The name of the list box is contained in RMP--
NEXT-FIELD.

88 RMP--SB-MOVED VALUES ARE "S" "D" "d" "U" "u".

This condition indicates that a scroll bar's thumb position was changed. The name of the scroll bar is
reported in RMP--SB- OPERATED because scroll bars, unlike other fields/controls, do not receive
keyboard focus. The following conditions give more detail on how the scroll bar thumb was moved.

88 RMP--SB-PAGE-UP VALUE "U".

This condition indicates that a scroll bar's thumb was moved up by clicking above the thumb.

88 RMP--SB-PAGE-DOWN VALUE "D".

This condition indicates that a scroll bar's thumb was moved down by clicking below the thumb.

88 RMP--SB-STEP-UP VALUE "u".

This condition indicates that a scroll bar's thumb was moved up by clicking on the up arrow.

88 RMP--SB-STEP-DOWN VALUE "d".

This condition indicates that a scroll bar's thumb was moved down by clicking on the down arrow.

88 RMP--SB-DRAG VALUE "S".

This condition indicates that a scroll bar's thumb was moved by dragging it.

88 RMP--TIME-OUT-OCCURRED VALUE "T".

This condition indicates that a “time out” occurred.

88 RMP--POLLING-OCCURRED VALUE "P".

This condition indicates that the polling interval established with the START POLLING utility function has
elapsed.

88 RMP--PANEL-MOVED VALUE "F".

This condition indicates that the user moved the panel and that RM/Panels has repainted the panel and its
fields. If you used a DISPLAY statement to place information on the panel, you need to display it again.

07 RMP--DATA-CHANGED-SWPIC X VALUE "N".
   88 RMP--DATA-CHANGED VALUE "Y" WHEN FALSE "N".
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This condition indicates that the value of a field/control was changed by the last event. There is no
indication of the field/control that was changed, because it is possible to change two fields/controls with
one event. When a user types input to an input field/control and then clicks on a check box, both fields/
controls change. This parameter allows you to bypass validation routines when no data has been changed
on the panel.

07 RMP--PULLDOWN-PARAMETERS.     

These parameters report the name and text of a pulldown menu command when it is selected.

09 RMP--COMMAND-NAMEPIC X(30).

This parameter reports the name of a pulldown menu command when it is selected. This name is an
internal value that is not displayed to the user. Programs should check this value, rather than the text of the
command, to maintain the logical, rather than physical, connection to the user interface.

09 RMP--COMMAND-TEXTPIC X(30).

This parameter reports the text of a pulldown menu command when it is selected. Programs are
discouraged from checking this value and should instead use RMP--COMMAND-NAME.

07 RMP--MOUSE-CLICK-TYPEPIC X VALUE SPACE.

This parameter reports the type of mouse click performed on a field/control.

88 RMP--DOUBLE-CLICK VALUE "D".

This condition indicates that the mouse was double clicked on the field/control. Fields/controls must be
configured to allow a double click.

88 RMP--SINGLE-CLICK VALUE "S".

This condition indicates that the mouse was single clicked on the field/control. All enabled fields/controls
allow a single click.

07 RMP--LAST-PANELPIC X(20).

This parameter reports the name of the panel that was most recently accessed and is useful when
implementing modeless behavior.

07 RMP--REQUESTED-PANELPIC X(20).

This parameter reports the name of an underlying panel that was selected during modeless behavior. This
tells the application program the panel that should be used for the next EXECUTE EVENT standard run-
time function to allow the panel to be elevated to the top level on the monitor.

07 RMP--PROT-CHARPIC X.

If a character key is pressed during protected field/control entry and RMP--PROT-ALLOW-CHAR is TRUE,
this parameter contains the character that was pressed and RMP--EXCEPTION-NUMBER is 0. If an
exception key is pressed, RMP--EXCEPTION-NUMBER contains the field termination code and is set to
SPACE.

07 FILLERPIC X(96).

This area is reserved for future use.

03 RMP--RETURNED VALUES.

This area contains values that are returned by the RM/Panels run-time system.

05 RMP--EXCEPTION-NUMBERPIC 9(3).
   88 F10-KEY VALUE 10.
   88 ESCAPE-KEY VALUE 27.

This parameter is used by the RM/Panels run-time system to indicate to the application the key that was
used to terminate user input. The value returned is the same value that the ON EXCEPTION clause
returns for the key.
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Level 88 condition-names are added after this parameter to allow the application program to easily interpret
the key pressed. RETURN-KEY and ESCAPE-KEY are just samples that can be renamed, deleted, or
added to. The names and values in this area are not important to the standard run-time function of RM/
Panels. They are solely for the use of the application program.

05 RMP--MOUSE-PRESENT-SWPIC X VALUE SPACE.
   88 RMP--MOUSE-PRESENT VALUE "Y" WHEN FALSE "N".     

This parameter is set by the RM/Panels run-time system whenever a library is opened. It lets the
application program know whether a mouse is present and accessible to RM/Panels.

05 RMP--VALID-INPUT-SW PIC X SPACE.   
   88 RMP--VALID-INPUT VALUE "Y". 
   88 RMP--INVALID-INPUT VALUE "N".

This parameter is used by the RM/Panels run-time system to indicate to the application program whether
user input to a field/control satisfied validation rules specified for that field/control in the panel. If the input
satisfied the rules, the value is set to Y. If the input failed to satisfy the rules, the value is set to N.

05 RMP--STATUS PIC 9(4) VALUE 0.
   88 RMP--VALID-FUNCTION VALUE 0.
   88 RMP--FIELD-INVALID VALUE 1.
   .
   .
   .
   88 RMP--NO-ERROR-DEFINED VALUE 13.
   88 RMP--IO-ERROR VALUE 14.
   88 RMP--CONTROL-DISABLED VALUE 15.
   88 RMP--WINDOW-ERROR VALUE 16.
   88 RMP--NO-PULLDOWN VALUE 22.
   88 RMP--MENU-COMMAND-INVALID VALUE 20.
   88 RMP--MODELESS-DATA-OVERLOAD VALUE 21.
   88 RMP--NO-PULLDOWN VALUE 22.
   88 RMP--WRONG-FIELD-TYPE VALUE 23.
   88 RMP--TOO-MANY-PANELS VALUE 40.
   88 RMP--CANNOT-CREATE-TEMP VALUE 41.
   88 RMP--CANNOT-OPEN-TEMP VALUE 42.
   88 RMP--API-PARAM-MISSING VALUE 1001.
   88 RMP--API-MSG-NOT-DEFINED VALUE 1002.
   88 RMP--API-PD-OPTION-INVALID VALUE 1003.
   88 RMP--API-UNCHECKABLE VALUE 1004.

This parameter is used by the RM/Panels run-time system to report the outcome of the function request. If
the function was performed successfully, a value of 0 is returned. If the function was unsuccessful, a non-
zero value is returned indicating the reason. The condition-names are provided to make it easier for the
application program to detect and interpret unsuccessful function requests.

03 RMP--FUNCTION-CODES.

These parameters contain the function codes used to identify standard, utility, and extended run-time
functions to the RM/Panels run-time system. They should not be modified and the application program
should never depend on the value or even the type of the data items. The calls to the RM/Panels run-time
system use the data names. If direct calls are used in your application programs, they must always use the
data-name and not the actual value.

03 RMP--SCROLL-BAR-WS.

These parameters contain values specific to scroll bars and their standard run-time functions.

05 RMP--SB-MINPIC 9(4).

This parameter is used to set a new minimum value for a scroll bar.

05 RMP--SB-MAXPIC 9(4).
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This parameter is used to set a new maximum value for a scroll bar.

05 RMP--SB-STEPPIC 9(4).

This parameter is used to set a new step value for a scroll bar.

05 RMP--SB-PAGEPIC 9(4).

This parameter is used to set a new page value for a scroll bar.

05 RMP--SB-OPERATEDPIC X(30).

This parameter is used to report the name of a scroll bar when its thumb position is altered.

03 FILLERPIC X(50).

This area reserved for future use.

Appendix B Standard Utility, and Extended Run-time Functions and Parameters

The following types of parameters are used with RM/Panels standard, utility, and extended run-time
functions:

• Required parameters
• Optional parameters

Required parameters are those that must be set to valid values in order for a standard, utility, or extended
run-time function to execute correctly.

Optional parameters are those that can be set to override the default behavior specified for the panel.
Optional parameters are always reset to their default values by the RM/Panels run-time system after the
function is executed. This prevents later executions of the standard run-time function from inheriting the
overridden behavior.

Extended run-time functions also use additional arguments on the CALL statement.

The following table lists the required and optional parameters for RM/Panels standard run-time functions.

Standard Run-time Function Name Abbr. Required Parameters Optional Parameters

ACCEPT FIELD AF RMP--FIELD-NAME

RMP--FIELD-OCCUR

NONE

CHANGE PANEL PALETTE CPP RMP--PALETTE NONE

CHECK MENU OPTION CMO RMP--COMMAND-NAME NONE

CLEAR ALL FIELDS CAF NONE NONE

DISABLE ALL FIELDS DA NONE NONE

DISABLE FIELD FOR INPUT DFI RMP--FIELD-NAME RMP--SUPPRESS- EVENT-
RESET

DISABLE MENU OPTION DMO RMP--COMMAND-NAME NONE

DISPLAY ALL FIELDS DAF NONE NONE

DISPLAY FIELD DF RMP--FIELD-NAME

RMP--FIELD-OCCUR

NONE

DISPLAY PANEL DP RMP--LIBRARY RMP--BEEP

RMP--CLEAR

RMP--PALETTE

RMP--PANEL-LINE
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Standard Run-time Function Name Abbr. Required Parameters Optional Parameters

RMP--PANEL-POS

RMP--SHOW-FIELDS

RMP--WINDOW

ENABLE ALL FIELDS EA NONE NONE

ENABLE FIELD FOR INPUT EFI RMP--FIELD-NAME RMP--SUPPRESS- EVENT-
RESET

ENABLE MENU OPTION EMO RMP--COMMAND-NAME NONE

EXECUTE EVENT EE RMP--FIRST-FIELD1

RMP--NEXT-FIELD1

RMP--NEXT-OCCUR1

RMP--REPEAT-EVENT1

You may select one of these
parameters to execute the
standard run-time function.

NONE

INITIALIZE ALL FIELDS IAF NONE NONE

INITIALIZE FIELD IF RMP--FIELD-NAME

RMP--FIELD-OCCUR

NONE

POPUP MENU PUM RMP--COMMAND-NAME RMP--PANEL-LINE

RMP--PANEL-POS

REMOVE PANEL RP NONE RMP--CLEAR

SET FIELD ATTRIBUTE SFA RMP--ATTRIBUTE

RMP--FIELD-NAME

RMP--FIELD-OCCUR

NONE

SET SCROLL BAR RANGE SSR RMP--FIELD-NAME

RMP--SB-MAX

RMP--SB-MIN

RMP--SB-PAGE

RMP--SB-STEP

SHOW FIELD ERROR SFE RMP--FIELD-NAME NONE

SHOW FIELD HELP SFH RMP--FIELD-NAME NONE

SHOW PANEL ERROR SPE NONE NONE

SHOW PANEL HELP SPH NONE NONE

UNCHECK MENU OPTION UMO RMP--COMMAND-NAME NONE

VALIDATE ALL FIELDS VAF NONE NONE

VALIDATE FIELD VF RMP--FIELD-NAME

RMP--FIELD-OCCUR

NONE

The following table lists the required and optional parameters for RM/Panels utility functions.

Utility Function Name Abbr. Required Parameters Optional Parameters

DELETE TEMPORARY FILE DTF NONE NONE
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Utility Function Name Abbr. Required Parameters Optional Parameters

END MODELESS OPERATION EMD NONE NONE

END POLLING EP NONE NONE

HIDE MOUSE CURSOR HMC NONE NONE

SET COLOR SCO NONE NONE

SET MONOCHROME SMO NONE NONE

SHOW MOUSE CURSOR SMC NONE NONE

START MODELESS OPERATION SMD NONE NONE

START POLLING SP RMP--POLLING-INTERNAL NONE

The following table lists the required parameters and additional arguments for RM/Panels extended run-
time functions.

Extended Run-time Function Name Abbr. Required Parameters Additional Arguments

ACTIVATE A LIBRARY E-AL NONE libraryname

ACTIVATE A PANEL E-AP NONE panelname

ADD FIELD DESCRIPTION E-AFD NONE FIELD-DESCRIPTION

CHANGE FIELD DESCRIPTION E-CFD RMP--FIELD-NAME FIELD-DESCRIPTION

CREATE A LIBRARY E-CL NONE libraryname

CREATE A PANEL E-CP NONE panelname

DELETE FIELD DESCRIPTION E-DFD RMP--FIELD-NAME NONE

DISCARD CHANGES E-DC NONE NONE

GET FIELD DESCRIPTION E-GFD RMP--FIELD-NAME FIELD-DESCRIPTION

BY NAME

GET FIELD DESCRIPTION BY
NUMBER

E-GFN RMP--FIELD-SEQ FIELD-DESCRIPTION

GET FIELD VALUE E-GFV RMP--FIELD-NAME FIELD-VALUE-DESC

GET LIBRARY CONFIGURATION E-GLC NONE LIBRARY-CONFIG-DESC

GET MESSAGE E-GMS NONE MSG-DESC

GET PALETTE DESCRIPTION E-GPLT RMP--PALETTE PALETTE-DESC

GET PANEL CONFIGURATION E-GPC NONE PANEL-CONFIG-DESC

GET PANEL LINE E-GPL NONE PANEL-LINE-DESC

GET PULLDOWN MENU PULLDOWN
OPTIONS

E-GPD NONE PULLDOWN-PD-DESC

GET PULLDOWN MENU TOP LEVEL
OPTIONS

E-GPT NONE PULLDOWN-TITLE-AREA

HIDE PANEL E-HDP NONE NONE

REMOVE MENU OPTION E-RMO RMP--COMMAND-NAME NONE

210 | Upgrading to Enterprise Developer



Extended Run-time Function Name Abbr. Required Parameters Additional Arguments

SAVE A PANEL E-SP NONE NONE

SET FIELD VALUE E-SFV RMP--FIELD-NAME FIELD-VALUE-DESC

SET LIBRARY CONFIGURATION E-SLC NONE LIBRARY-CONFIG-DESC

SET MESSAGE E-SMS NONE MSG-DESC

SET PALETTE DESCRIPTION E-SPLT RMP--PALETTE PALETTE-DESC

SET PANEL CONFIGURATION E-SPC NONE PANEL-CONFIG-DESC

SET PANEL LINE E-SPL NONE PANEL-LINE-DESC

SET PULLDOWN MENU PULLDOWN
OPTIONS

E-SPD NONE PULLDOWN-PD-DESC

SET PULLDOWN MENU TOP LEVEL
OPTIONS

E-SPT NONE PULLDOWN-TITLE-AREA

SHOW MESSAGE E-SHM NONE MSG-DESC

UPDATE PANEL E-UDP

Compatibility with XML Extensions
XML Extensions has many capabilities. The major features support the ability to import and export XML
documents to and from COBOL working storage. Specifically, XML Extensions allows data to be imported
from an XML document by converting data elements (as necessary) and storing the results into a matching
COBOL data structure. Similarly, data is exported from a COBOL data structure by converting the COBOL
data elements (as necessary) and storing the results in an XML document.

For more information about XML Extensions, refer to the XML Extensions User's Guide, available from the
Documentation section of the Micro Focus Customer Care website at https://www.microfocus.com/
documentation/enterprise-developer/.

For RM/COBOL users that utilize XML Extensions, here is a summary of compatibility issues that you need
to be aware of when working in this COBOL system. Refer to this list and the RM/COBOL Conversion
Issues list in the Compatibility with RM/COBOL section

Click a summary title for a fuller explanation and workaround, where possible.

Additional Parameter Required with XML Extensions Processing Statements
In statements that use a Document Pointer parameter, you are also required to pass an additional
Document Length parameter.

When using XML Extensions processing statements, each Document Pointer parameter must be
immediately followed by a Document Length parameter. This applies to the following statements:

• XML EXPORT TEXT
• XML IMPORT TEXT
• XML TEST WELLFORMED-TEXT
• XML VALIDATE TEXT
• XML GET TEXT
• XML PUT TEXT
• XML TRANSFORM TEXT

Note: XML FREE TEXT does not require that you use the Document Length parameter.
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Solution:

Ensure that the Document Length parameter (MY-DOCUMENT-LENGTH) is specified immediately
following the Document Pointer parameter (MY-DOCUMENT-POINTER) when calling an XML Extensions
processing statement:

When the statement is outputting data, the statement will set MY-DOCUMENT-LENGTH:

XML EXPORT TEXT
    MY-DATA-ITEM
    MY-DOCUMENT-POINTER
    MY-DOCUMENT-LENGTH
    "MY-MODEL-FILE".
IF NOT XML-OK GO TO Z.

When the statement is inputting data, you must set MY-DOCUMENT-LENGTH before the statement is
processed:

XML IMPORT TEXT
    MY-DATA-ITEM
    MY-DOCUMENT-POINTER
    MY-DOCUMENT-LENGTH *> Item size MY-DOCUMENT-POINTER points to.
    "MY-MODEL-FILE".
IF NOT XML-OK GO TO Z. 

COBOL programs using BIS
Programs in this COBOL system that are used with the Xcentrisity Business Information Server (BIS) must
end with the GOBACK statement, not the STOP RUN statement. Also, messages for the BIS trace log must
be generated by calling the B$Trace library program, not the DISPLAY statement.

Programs that are used with the BIS must not use the STOP RUN statement, as this will terminate the MF
run-time prematurely and the BIS will be unable to process any further web service requests.

In RM/COBOL, programs that are used with BIS capture the output of a DISPLAY statement and place it in
the BIS trace log. In this COBOL system, to place messages in the BIS trace log, use the B$Trace library
routine.

Solutions:

To ensure that programs used with the BIS do not prematurely terminate the MF run-time, use the
GOBACK statement in those programs.

To place messages in the BIS trace log, call the B$Trace library program, using the same identifiers or
literals, but not figurative constants, that you would use in a DISPLAY statement.

Note: Numeric data items can be of any data type and are converted to a numeric string by B$Trace.

call "B$Trace" using "Log message: " MyMessage " " MyStatus.

Conflicts Between Model File-names and XML Data Files
In this COBOL system, model file-names, as created by the compiler, are of the form program-name.xml.
You should ensure your XML data files do not share the same name as this, to avoid any conflicts.

In this COBOL system, if the ModelFileName#DataName parameter does not include a hash, it is always
treated as a model data-name, and the model file-name is assumed to be program-name.xml for the
program (or one of its callers) that executed an XML Extensions export or import statement. With this in
mind, if you do not explicitly set a model file-name, you should ensure that your XML data files do not share
the same name as your COBOL programs when performing import and export XML Extensions
statements.

Solution:

To avoid conflicts between model file-names and XML data file-names, do one of the following:
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• Ensure you set the DocumentName parameter in your import and export statements to a name other
than your COBOL program name.

• If you want to keep your XML data file-names the same as the program-name, rename the model file-
name after compilation and specify the new name in the value of the ModelFileDataName parameter
before the hash, separating it from the ModelDataName.

When using the second technique, it is recommended that the compilation be done with a script that
includes the renaming command, to avoid forgetting this step.

Notes:

In RM/COBOL, you can use the environment variable RM_MISSING_HASH to determine the meaning of
the ModelFileDataName parameter when the hash is omitted. In this COBOL system, the environment
variable is not supported.

Also, RM/COBOL v12 and later generally did not use model files because the model was embedded in the
object program file; this COBOL system is more like RM/COBOL v11 and earlier, which always used model
files. Thus, care must be taken to distribute model files with applications that use XML Extensions.

Creating an XML Model File
To create an XML model file for use with XML Extensions, compile your application with the XMLGEN
Compiler directive.

For complete information on using the XMLGEN compiler directive, see XMLGEN.

See Restricted data items with XML Extensions for a workaround to include data descriptions from other
Data Division sections of your source code.

Displaying the Status of XML Extensions Statements
In this COBOL system, use the XML-Status-Edited data item to display the status result of an XML
Extensions statement execution.

In RM/COBOL, XML-Status, the data item used to display the status result of an XML Extensions
statement execution, is defined as Display Usage. In this COBOL system, XML-Status is defined as:

03 XML-Status        PIC S9(4) COMP-5.

Therefore, an additional declaration is made in lixmldef.cpy, so that you can easily use the status result in
your code:

03 XML-Status-Edited        PIC +9(4).

When an XML Extensions statement is executed, the value of XML-Status-Edited is not set, so you need
move XML-Status to XML-Status-Edited before you can use the result.

Importing and Exporting Ambiguous Data-names

In RM/COBOL, if you attempt to export an ambiguous data-item to a model file, an error is produced. If you
attempt to import to an ambiguous data-item, the data is placed in the first occurrence of the named data-
item.

In this COBOL system, if you attempt to export an ambiguous data-item to a model file, a warning message
is produced and the first occurrence of the named data-item is exported. Similarly, If you attempt to import
to an ambiguous data-item, a warning message is displayed and the data is placed in the first occurrence
of the named data-item.

Example:

01 Group01.
    02 GroupA.
      03 NumItem     PIC s9(5).
      03 StrItem     PIC X(5).
        02 GroupB.
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          03 NumItem  PIC s9(5).
          03 StrItem  PIC X(5).

--------------------------------
<StrItem> ABCDE </StrItem>   *> this produces a warning and 
updates StrItem in GroupA

<GroupB><StrItem> ABCDE </StrItem></GroupB>  *> this updates 
StrItem in GroupB

Invalid Characters in Condition Names
In this COBOL system, if you use mark-up characters as values for condition names, this can produce
invalid XML when exporting code using XML Extensions.

Mark-up characters, such as "<", ">" or "&" used in the values for condition names will produce invalid
model files when using XML Extensions. The model files will cause parse errors when loaded by XML
Extensions using the XML parser; XML Extensions will report the parse error and be unable to perform the
requested export or import.

88 cond-name VALUE "<br/>".

Solution:

In this COBOL system, you must modify the COBOL source code, to eliminate mark-up characters in
condition-name values.

Restricted data items with XML Extensions
In this COBOL system, you cannot use data items described in any section other than the File or Working
Storage Sections, as model data names.

To export data items from or import XML data into this COBOL system, use the XMLGEN Compiler
directive to create a model file, for use with XML Extensions.

The model data names specified in the model file are determined by XMLGEN:

• XMLGEN with no parameter specified produces model data names for data items/structures in the File
Section only.

• XMLGEN(ws) produces model data names for data items/structures in the Working Storage Section
only.

Important: Data items/structures described in the Linkage Section, Communication Section, Local-
Storage Section and Thread-Local-Storage Section cannot be used as model data names in a model
file.

Solution:

Using a copybook containing your data items, compile a dummy program that copies the descriptions into
the Working Storage section, and then use the XMLGEN(ws) Compiler directive to create a model file
containing the required data items.

Notes:

The data items used at run time when the model file is used can be in any section of the data division.

Unable to Use Data Items Declared in Nested Programs
In this COBOL system, you cannot use data items declared in nested programs, as model data-names.
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Solution:

Using a copybook containing your data items, compile a dummy program that copies the descriptions into
the Working Storage section of your top-level program, and then use the XMLGEN(ws) Compiler directive
to create a model file containing the required data items.

User-names Longer than 127 Bytes are Truncated
In RM/COBOL, you can specify user-names (data-names, procedure-names, program-names, etc) up to
240 characters long. In this COBOL system, user-names longer than 127 bytes in length are truncated and
a warning message is produced.

Solution:

Results may be affected if the truncated user-name is used with XML Extensions, to export or import XML
documents; therefore, we recommend that you keep user-names to 127 bytes or less.

Using the Correct Calling Convention

In this COBOL system, XML Extensions uses the standard COBOL calling convention. If your programs
are also using the standard library routines implemented for RM/COBOL compatibility, you need to be
aware that these are called using the 1024 calling convention.

Solution:

Generally, you should explicitly use the 1024 calling convention when calling your RM/COBOL standard
library routines, but if you are using the DEFAULTCALLS Compiler directive to set this calling convention,
you will need to override it when calling to XML Extensions.

Customer Feedback
We welcome your feedback regarding Micro Focus documentation.

Submit feedback regarding this Help

Click the above link to email your comments to Micro Focus.

Copyright and Disclaimer
© Copyright 2021 Micro Focus or one of its affiliates.

The only warranties for this product and any associated updates or services are those that may be
described in express warranty statements accompanying the product or in an applicable license agreement
you have entered into. Nothing in this document should be construed as creating any warranty for a
product, updates, or services. The information contained in this document is subject to change without
notice and is provided "AS IS" without any express or implied warranties or conditions. Micro Focus shall
not be liable for any technical or other errors or omissions in this document. Please see the product's
applicable end user license agreement for details regarding the license terms and conditions, warranties,
and limitations of liability.

Any links to third-party websites take you outside Micro Focus websites, and Micro Focus has no control
over and is not responsible for information on third party sites.
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