extend System Requirements

Note: This product includes software developed by the University of California, Berkeley and its contributors.

Hardware Requirements

extend software has the following requirements:

For Windows:

  • The amount of disk space needed to install the ACUCOBOL-GT development system is typically less than 35 MB.
  • AcuBench® requires at least 20 MB for installation.
  • You need an additional 40 MB to install all of the other extend products.
  • Use of .NET controls with the runtime and thin client requires .NET Framework 4.0.
For all other platforms:
  • The amount of disk space needed to install all extend products is typically less than 35 MB.

Supported Operating Systems

Note: AcuBench no longer supports Windows XP or Windows Server 2003 (or any Windows platforms that pre-date these). This is because AcuBench utilizes a number of third-party libraries that have ceased to be supported on those platforms.

For this release, if you are running on the AIX 7.1 platform, the minimum requirement is version 7.1 Technology Level 4 (7100-04) ), and if you are running on the AIX 7.2 platform, the minimum requirement is version 7.2 SP1.

For a full list of the supported operating systems, check the Product Availability section on the Micro Focus SupportLine Web site: https://supportline.microfocus.com/prodavail.aspx.

Additional Requirements

General requirements

Linux-based platforms require glibc version 2.5 or later.

AcuServer:

  • Each server machine must be networked to UNIX, Linux, or Windows clients with TCP/IP. TCP/IP is not sold or supplied by Micro Focus.
  • All servers must have a copy of the AcuServer license management file.
  • Windows clients can run any TCP/IP software that uses a WINSOCK2 compliant ws2_32.dll.
  • Unless you have an unlimited license for AcuServer, all UNIX servers must run the current version of acushare, which is included on the AcuServer distribution media.
  • All servers must have a copy of the license file activated by the product installation script. This file is named acuserve.alc.
  • Client machines must have an ACUCOBOL-GT AcuServer-enabled runtime. All Windows runtimes Version 5.0 and later are AcuServer-enabled. To verify that your UNIX runtime is AcuServer-enabled, type runcbl -v in a Command prompt and look for this line.
    AcuServer client
  • Servers being accessed by the ACUCOBOL-GT Web runtime must have a multiple-user ACUCOBOL-GT runtime license that accommodates each concurrent user that is anticipated. (If you anticipate 100 concurrent users of the Web runtime, you need a 100-user runtime license on the server in addition to the AcuServer license file. Alternatively, runtime users can install a local or network floating license for the runtime themselves.

AcuBench:

  • Intel Pentium III CPU, 300 MHz; Intel Pentium IV, 2 GHz recommended
  • 128 MB of RAM recommended
  • 120 MB of available hard disk space recommended
  • mouse
  • 800 x 600 VGA display or better; 1024 x 768 VGA display recommended

AcuToWeb:

gcc versions
AcuToWeb requires the following gcc versions or later on the following platforms:
Platform Minimum requirement
Aix6.1 GCC 7.1.0
Aix7.1 GCC 7.1.0
Aix7.2 GCC 7.1.0
HP 11.31 PA-RISC GCC 4.3.1
HP 11.31 IA GCC 4.2.3
Linux GCC 4.8.0
Linux PPC GCC 4.1.2-46
Sun Solaris 10 GCC 3.4.3
Sun Solaris 11 GCC 4.8.2
Linux-based platforms
For Linux-based platforms, the following packages must be added:

Debian-based

libc6:i386

libstdc++6:i386

RHEL/Centos-based

libstdc++.i686

SUSE-based

libstdc++6-32bit

AIX and Solaris platforms
AIX and Solaris platforms require the Foreign Function Interface Library (libffi) is installed. More information and the installation packages can be found at the following:
AIX platforms
You can download an RPM package from:

http://www.bullfreeware.com/affichage.php?id=3638

And then install it using:

rpm -Uvh http://www.bullfreeware.com/download/bin/3638/libffi-20170516-1.aix6.1.ppc.rpm

Solaris platforms
You can download the package from:

https://www.opencsw.org/packages/libffi6/

General information on libffi can be found at:

https://cffi.readthedocs.io/en/latest/installation.html

If you are running on the Solaris 11 platform, the minimum version required to run the AcuToWeb Gateway is version 11.3.

AcuSQL:

  • Your COBOL application must run on a Windows system or a UNIX system supported by Micro Focus. Unless otherwise indicated, the references to Windows in this manual denote supported Windows operating systems. Where necessary, individual versions of those operating systems are referred to by their specific version numbers.
  • AcuSQL must be installed with the ACUCOBOL-GT development system on your Windows or UNIX system.
  • If using a database other than Microsoft SQL Server, you must have a working ODBC level 2 API connection to your database, including any required networking software support.
  • For SQL Server, if running the AcuSQL interface to Microsoft SQL Server, you must have the SQL Server client software from Microsoft. Use the Query Analyzer to see if the SQL Server client software from Microsoft is on your system. For information on opening the Query Analyzer, see the SQL Server client documentation. If the Query Analyzer opens and you are able to connect to the database, the client libraries are most likely all present. Your SQL Server data source may be hosted on one or more of the supported server operating systems.
  • If you are running the AcuSQL interface to MySQL, you must have the following software:
    • MySQL 5.0 Database Server Version 5.0.18 or later (Generally Available release). Testing was done with MySQL 5.0.18 Standard.
    • MySQL Connector/ODBC Version 3.51.11 or later (Generally Available release). Testing was done with the libmyodbc3-3.51.12.so library. This file is available from http://dev.mysql.com.
    You can check the version of your server by connecting using mysql. The version prints upon connection. For example:
    [testing ]: mysql
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 29 to server version:
    5.0.18-standard
    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
    Once in MySQL, you can also use the following:
    mysql> select version();
    +-----------------+
    | version()       |
    +-----------------+
    | 5.0.18-standard |
    +-----------------+
    1 row in set (0.09 sec)
  • If your application accesses DB2 data, IBM's DB2 Connect™ software is recommended. Access to DB2 databases has been tested with DB2 Connect. However, any vendor's properly configured ODBC level 2 API connectivity software should work. Your DB2 data source may be hosted on one (or more) of the supported operating systems.

Acu4GL (for ODBC) driver requirements:

Your ODBC driver must include the following functions:

  • all Core ODBC driver functions
  • the Level 1 function SQLColumns
  • the Level 1 function SQLTables

Depending on the method of record locking you choose, your driver may also need to support some of the following function calls:

  • SQLSetStmtOption
  • SQLSetScrollOptions
  • SQLExtendedFetch
  • SQLSetPos

See A_ODBC_LOCK_METHOD in the extend online help for more information.

To test the capabilities of your ODBC driver, we have included a driver test program on your Acu4GL for ODBC installation disks. You can also consult your driver documentation to ensure that it meets these requirements.