Data Sources
The PSI grammars contain several entities to find online security information and credentials.
The information used in the grammars is gathered from public online specifications for the credentials and private keys. Patterns were extracted from the authoritative API documentation of the vendor's own site, and confirmed by creating user examples.
For open source entities, the following original specifications were used for confirmation of the definition.
-
HTTP authentication headers: RFC 7617
-
JWT: RFC 7519
-
PEM/PKCS private keys: RFC 7468
-
XKMS signature: W3C XKMS 2.0 specification