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1
 Introducing
Modernization

Workbench
Modernization Workbench (MW) is a suite of PC-based software products for 
analyzing, re-architecting, and transforming legacy applications. The products 
are deployed in an integrated environment with access to a common repository 
of program objects. Language-specific parsers generate repository models that 
serve as the basis for a rich set of diagrams, reports, and other documentation. 

Modernization Workbench Products

Introduces Modernization Workbench products. 

The MW suite consists of customizable modules that together address the needs 
of organizations at every stage of legacy application evolution: mainte-
nance/enhancement, renovation, and modernization. Each module is sepa-
rately licensed. 
1



INTRODUCING MODERNIZATION WORKBENCH
MODERNIZATION WORKBENCH PRODUCTS
Application Analyzer

Introduces Application Analyzer. 

Application Analyzer is a robust set of non-invasive interactive tools that work 
with source code, system files, DDL, screen maps, and more. Use it for analyzing 
and documenting legacy systems at both the application and program levels. 

Use Application Analyzer at the application level to: 

• Create diagrams of applications. 

• Perform change analysis across applications. 

• Estimate application complexity and effort. 

Use Application Analyzer at the program level to: 

• Perform program analysis in stages. 

• Perform impact analysis on a program. 

• Model and search the repository. 
 2
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MODERNIZATION WORKBENCH PRODUCTS
Enterprise View

Introduces Enterprise View. 

Enterprise View hosts enterprise dashboards that track survey-based metrics for 
the applications in your portfolio. Its easy-to-use Web interface lets you: 

• Create, distribute, and gather responses to surveys about your organiza-
tion’s business processes and data. 

• Collate survey results to define the range of information to collect. 

• Display the results in charts, graphs, and tables on Enterprise View dash-
boards. 

You can also use Enterprise View to browse repositories. Its convenient Web 
interface makes it the ideal tool for managers, business analysts, testers, and 
customer support personnel who need ready access to repositories across your 
organization. 

Business Rule Manager

Introduces Business Rule Manager. 

Business rule mining encapsulates your application’s business logic, making the 
application easier to understand, document, and test. It lowers the risk and cost 
of maintenance and enhancement, and ensures that all business logic is imple-
mented in modernization efforts. 

A business rule is a named container for program code that performs a discrete 
task in a business process. It identifies and documents the code segment that 
performs this task. A business rule named Calculate Date Difference, for 
example, might consist of this segment: 

COMPUTE WS-DATE-VARIANCE = WS-C-CARD-DATE-CCYYMM - 
WS-TODAYS-DATE-CCYYMM.

Business Rule Manager (BRM) offers a powerful set of tools for autodetecting, 
and autodocumenting, business rules. You can batch edit rule attributes; create 
custom attributes suited to your particular needs; match input/output data 
elements with the business names you’ve assigned to them in your project glos-
sary; and much more. 
3



INTRODUCING MODERNIZATION WORKBENCH
HOW MODERNIZATION WORKBENCH MODELS APPLICATIONS
Application Architect

Introduces Application Architect. 

Application Architect offers a variety of advanced algorithms for slicing logic 
from program source: all the code you need for a computation, for example, or 
the code you need to "specialize" a program based on the value of a variable. You 
can create a self-contained program, called a component, from the sliced code or 
simply generate a list of sliced constructs for further analysis. 

Both the component generation and list functions are supported in the full 
version of the Component Maker tool available to users of Application Archi-
tect. The list function only is supported in the restricted version of Component 
Maker, called Logic Analyzer, available to users of Application Analyzer. 

How Modernization Workbench Models 
Applications

Introduces the Modernization Workbench object and construct models.

Modernization Workbench is a model-based technology that generates infor-
mation about legacy applications at two levels:

• Application-level information describes the relationships between the 
objects that comprise an application: its programs, copybooks, JCLs, BMS 
files, and so forth.

• Object-level information describes the relationships between the abstract 
syntactical constructs that comprise an object: its sections, paragraphs, 
statements, conditions, variables, and so forth.

At both levels, the models are conceived as Entity Relationship Diagrams 
(ERDs). Each object or construct the parser generates is modeled as an entity in 
one of the diagrams. The models are represented in tree form to users. 

Understanding Application-Level Information

Describes the Modernization Workbench object model. 

The object model for an application defines the relationships between the objects 
that comprise the application. These can be physical objects, like program 
 4



INTRODUCING MODERNIZATION WORKBENCH
HOW MODERNIZATION WORKBENCH MODELS APPLICATIONS
source files or JCLs, or logical objects that identify abstract program elements: 
entry points, data stores, screens, jobs, and the like. 

The relationships between objects describe the ways in which they interact. In 
the figure, the source file GSS.CBL defines the GSS program. The program, in 
turn, reads the data file GSS.FCSTSEC. 

Understanding Object-Level Information

Describes the Modernization Workbench construct model. 

The construct model for an object defines its syntax. It shows in abstract form 
how the syntactical constructs that comprise the object (its sections, paragraphs, 
statements, conditions, variables, and so forth) are related. A variable, for 
example, can be related in the construct model to its declaration, a dataport (if 
it is used in an I/O statement), or a condition (if the condition uses an expres-
sion of which the variable forms a part). 

The figure shows a portion of the construct model for the GSS program. The 
model shows that the program executes a PERFORM statement if the value of 
the variable EIBRESP satisfies the condition EIBRESP NOT EQUAL 
DFHRESP(NORMAL). 

If you are interested in investigating other uses of EIBRESP in the program, you 
can navigate to the declaration of the variable in the construct model, and from 
the declaration to each instance of the variable’s use in the program. 
5
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WORKSPACES AND PROJECTS
Workspaces and Projects

Describes Modernization Workbench workspaces and projects.

Modernization Workbench uses the familiar notions of workspace and project 
to help users organize application source files conveniently. A workspace is a 
named container for an application or a portion of an application. Every work-
space has a corresponding database repository of model objects.

You can divide a workspace up into projects that represent different portions of 
your application. You might have a project for the batch portion of the applica-
tion and another project for the online portion, for example. You can also use a 
project to collect items for discrete tasks: all the source files affected by a change 
request, for example.

When you set up a workspace in Modernization Workbench, the system creates 
a default project with the same name as the workspace. You can create new proj-
ects and move or copy entities between projects as needed. 

A workspace can contain objects coded in different programming languages. 
You can create multiple workspaces on the same machine.

Single-User versus Multiuser Environments

Compares Modernization Workbench single-user and multiuser environ-
ments.

Modernization Workbench can be deployed in a single-user or multiuser envi-
ronment:

• In a single-user environment, the workspace repository resides on the 
local machine, and can be accessed by the owner of the machine only. 
Limited facilities exist for sharing work with other users.

• In a multiuser environment, the workspace repository resides on a data-
base server, and can be accessed by any user with appropriate database 
privileges. 

Most installations deploy Modernization Workbench in a multiuser environ-
ment. Single-user mode typically is reserved for special needs.

The guidelines that follow for multiuser environments apply equally to 
single-user environments. For installation instructions, see the installation 
guide for your product.
 6



INTRODUCING MODERNIZATION WORKBENCH
MULTIUSER ENVIRONMENT BASICS
Multiuser Environment Basics

Introduces the Modernization Workbench multiuser environment

A multiuser Modernization Workbench environment gives members of a 
development team common access to a workspace repository on a database 
server. Workspace setup is the responsibility of a master user, leaving team 
members free to focus on their tasks. Common access makes it easy to share 
insights across the team, and ensures that team members view the same source 
and work with the same option settings.

Deployment Scenario

Provides an overview of the standard deployment scenario. 

The figure below shows a standard deployment scenario for the Modernization 
Workbench multiuser environment. The role each machine performs and its 
key relationships are described below. Keep in mind that the view is logical. 
Machine roles can be combined or separated as required. 
7
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MULTIUSER ENVIRONMENT BASICS
Mainframe and Network Server

Describes the role of the mainframe and network server.

The mainframe hosts the application to be modeled in Modernization Work-
bench. Application source files are downloaded from the mainframe (and, if 
necessary, a network server) to the Modernization Workbench server via FTP 
or SFTP.

Modernization Workbench Server

Describes the role of the workbench server.

The Modernization Workbench server hosts workspaces, workspace support 
files (including the copies of application source files the workbench creates at 
workspace loading), and workspace output. This server leverages multiple 
processes to enhance parsing performance in online or batch mode.

Parsed data is sent via ODBC to the database server. Some analysis output is 
stored on the workbench server as well.

Database Server

Describes the role of the database server.

The database server hosts the database for one or more multiuser repositories. 
This server provides centralized, network-accessible storage for parsed data and 
analysis output.

The workbench server, Enterprise View Web Server, and workbench clients 
access the database server via ODBC. For guidance on database setup, see the 
installation guide for your product.

Modernization Workbench Client

Describes the role of the workbench client.

Workbench clients host the link files that let team members connect to work-
spaces on the workbench server. These clients access repository data stored in 
the database server via ODBC.

Enterprise View Web Server

Describes the role of the Enterprise View web server.

The Enterprise View web server hosts services used by intranet and internet 
clients to display charts and to access web-based view of repositories.
 8
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MULTIUSER ENVIRONMENT BASICS
Enterprise View Web Client

Describes the role of the Enterprise View web client.

Enterprise View web clients provide multiuser access to charts and workspace 
repository data via the Enterprise View web server.

Workbench Privileges

Provides an overview of workbench privileges.

Privileges in a multiuser environment work on two assumptions:

• Team members typically do not need to modify files until they have 
completed analysis and are ready to test a proposed change.

• The team lead is best situated to make the change and reverify the modi-
fied file.

For these reasons, the workbench multiuser environment has no need for file 
checkout and locking of the kind seen in conventional multiuser environments.

Understanding Master Users

Describes Modernization Workbench master users.

The user who creates a workspace on a Modernization Workbench server 
machine is referred to as its owner. Initially, only the owner has master user priv-
ileges for the workspace. 

The master user can delete the workspace, upgrade the workspace configura-
tion, register and verify source files, modify source, autoresolve decisions, 
perform restricted Clipper searches, create, assign, and delete tags, and so forth. 
The master user can also designate new master users for the workspace.

Ordinary users connect to the workspace from Modernization Workbench 
client machines. These users can perform any task not restricted to the master 
user: analyze programs, mine business rules, extract components, and so forth.

If you do not have master user privileges for a workspace, you will not see menu 
choices for privileged methods. The same team member can be a master user for 
one workspace and an ordinary user for another. 
9
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MULTIUSER ENVIRONMENT BASICS
Understanding Workspace Security Policies

Describes workspace security policies.

When you create a workspace, you can choose from two workspace security 
policies:

• The Simple Security Policy recognizes two classes of users, master users 
and ordinary users. 

• The Three-Group Security Policy recognizes a third class of users, subject 
matter experts (SMEs), with special privileges to create, assign, and delete 
tags. 

In each policy, the master user can create new master users. 

Using the Optional File Server

Describes the workbench file server.

When you create a workspace, you can restrict Windows access to workspace 
source files to master users, while using the optional File Server to make the 
source files available in the workbench only to ordinary users. As long as you set 
up workspace folder privileges correctly, ordinary users can view and analyze 
sources in the workbench, but cannot access them otherwise. For file server 
installation instructions, see the installation guide for your product.

Public and Private Visibility

Describes the difference between public and private resources. 

In a multiuser environment, the user who creates a workspace resource (a 
project or a Clipper list, for example) is referred to as its owner. Only the owner 
can share the resource with other users. 

A shared, or public, resource is visible to other members of your team. A private 
resource is not. If a public resource is protected, team members can view but not 
edit or delete the resource. A Clipper list, for example, is always protected. 

You can turn sharing on and off in the tool you use to create the resource. Look 
for a symbol like this one for a shared project  to indicate that the resource 
is shared. 
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Protecting Projects

Describes how to protect a project. 

By default, projects are unprotected: any user to whom the project is visible can 
delete the project, add source files, or remove source files. 

The project owner or master user can designate a project as protected, in which 
case no user can delete or modify the project, including the project owner or 
master user: the project is read-only, until the project owner or master user 
turns protection off. 

Turn on protection by selecting the project in the Repository pane and choosing 
Project > Toggle Protection. Choose Project > Toggle Protection again to 
turn it off. Look for a symbol like this one  to indicate that a project is 
protected. 

Dropping Indexes

Describes how to drop and restore repository indexes.

If you are a master user with responsibility for verifying source files in a 
multiuser environment, you will almost always want to drop database indexes to 
improve verification performance. You will be prompted to drop indexes when 
you verify the application, or you can drop indexes at a time of your own 
choosing by selecting Prepare > Drop Repository Indexes.

When you drop indexes, you are prompted to restore the indexes when you 
analyze the files. If you want to restore indexes at a time of your own choosing, 
choose Prepare > Restore Repository Indexes. 

Computing Statistics

Describes how to gather system statistics for the RDBMS optimizer.

You typically need to gather statistics for your system before the optimizer for 
your RDBMS can determine the most efficient way to execute SQL statements. 
If you are a master user with responsibility for verifying source files in a 
multiuser environment, you will almost always want to gather system statistics 
after verification to improve performance of the Modernization Workbench 
analysis tools.

NOTE:  Check with your DBA before gathering system statistics. In Oracle, you 
must have GATHER_SYSTEM_STATISTICS privileges to execute this method. 
Make sure to restore indexes before gathering system statistics.
11
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To gather system statistics, choose Prepare > Compute Database Statistics. 
You can view the generated statistics in your RDBMS.
 12



 

2
 Modernization
Workbench Basics
This section describes elementary workbench tasks: how to create a workspace 
and project, register and verify source files, use the browser and other work-
bench windows, set options, and export system diagrams and reports.

Creating a Workspace in Oracle or DB/2

Describes how master users create workspaces. 

You create a workspace on the Modernization Workbench server machine. 
Other users connect to the workspace from Modernization Workbench client 
machines. The workspace repository resides on a database server, and can be 
accessed by any user with database privileges to the repository. 

NOTE:  Do not modify the name of the workspace after you create it. Doing so will 
cause unpredictable results. 

Before creating a workspace, you must configure an ODBC data source name 
(DSN) for the database that holds the workspace repository, as described in the 
installation guide for your product. You will need the following DSN configu-
ration information to create the workspace: 
13
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• The data source name. 

• The database schema name your DBA created for the repository. 

• The database user name and password that give access to the schema. 

• If required by your DBMS, the name of the tablespace your DBA created 
for the repository. If the DBA also created a tablespace for database 
indexes, you will need the name of that tablespace as well. 

The folder in which you plan to create workspaces must be shared with team 
members. It’s usually more convenient to share the folder before you create 
workspaces, but you can do it afterward if necessary, then refresh the workspace 
path. 

It is the responsibility of the workspace creator to designate users for security 
policies. Perform this task as soon as you have finished creating the workspace, 
then periodically edit the list of users as required. 

TASK

1. Choose Start > Programs > Micro Focus > Modernization Work-
bench Administration. The Administration window opens. 

2. Choose Administer > New Workspace. The Create new workspace 
dialog opens. 
 14
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3. In the Create new workspace dialog, double-click the New Workspace 
icon for the RDBMS at your site or select it and click OK. The New work-
space dialog opens. 

4. In the New workspace dialog, choose the location for the workspace in 
the Save in drop-down. In the File name field, enter the name of the 
workspace. Choose a name that describes the legacy application as 
closely as possible. Click Save. The Define Connection Parameters 
dialog opens. 
15
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5. In the Define Connection Parameters dialog, click the Connection tab. 
On the Connection tab, enter: 
• The ODBC data source name you defined at ODBC data source configu-

ration. If you have not defined a data source name, or want to use a 
different data source name, click ODBC Manager to open the data 
source name configuration dialog, then follow the instructions for 
ODBC data source configuration in the installation guide for your 
product. 

• The database schema name your DBA created for the workspace repos-
itory. 

• The database user name and password that give access to the schema. 

• If required by your DBMS, the name of the tablespace your DBA created 
for the repository. If your DBA also created a tablespace for database 
indexes, enter the name of that tablespace in the Tablespace for 
 16
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Indexes field. These fields are displayed only for DBMSs that require a 
tablespace name to be specified. 

6. Click the Security tab. In the Policies list box, select: 
• Simple Security Policy if you want to enforce a workspace security 

policy that recognizes two classes of users, master users and ordinary 
users. 

• Three-Group Security Policy if you want to enforce a workspace secu-
rity policy that recognizes a third class of users, subject matter experts 
(SMEs), with special privileges to create, assign, and delete tags. 

7. In the Files access group box on the Security tab, select: 
• Direct sources access via Windows share if your site does not restrict 

Windows access to workspace source files to the master user. 

• Secure sources access via RMW file server if your site restricts 
Windows access to workspace source files to the master user, while 
using the optional file server to make the source files available in the 
workbench to ordinary users. Make sure the values for the server name 
and port number fields are correct. 

NOTE:  For File Server installation and setup instructions, see the installa-
tion guide for your product. 

8. Click OK. 

NOTE:  If you created the workspace in a non-shared folder, you are warned 
to that effect and prompted to share the folder. After you share the folder, 
make sure to refresh the workspace path. 

STEP RESULT: You are notified that the workspace was created successfully. The 
workbench creates a workspace file (.rwp) and a folder with the same name in 
the specified location. The workspace folder contains support files and 
subfolders for workbench output. A project with the same name as the work-
space is displayed in the Repository Browser. 

Creating a Workspace in SQL Server

Describes how master users create workspaces. 

You create a workspace on the Modernization Workbench server machine. 
Other users connect to the workspace from Modernization Workbench client 
machines. The workspace repository resides on a database server, and can be 
accessed by any user with database privileges to the repository. 

NOTE:  Do not modify the name of the workspace after you create it. Doing so will 
cause unpredictable results. 
17
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The folder in which you plan to create workspaces must be shared with team 
members. It’s usually more convenient to share the folder before you create 
workspaces, but you can do it afterward if necessary, then refresh the workspace 
path. 

It is the responsibility of the workspace creator to designate users for security 
policies. Perform this task as soon as you have finished creating the workspace, 
then periodically edit the list of users as required. 

NOTE:  The following instructions assume you are using Windows Authentication 
to connect to the server. Check the SQL Server documentation for details on SQL 
Server authentication. 

TASK

1. Choose Start > Programs > Micro Focus > Modernization Work-
bench Administration. The Administration window opens. 

2. Choose Administer > New Workspace. The Create new workspace 
dialog opens. 
 18



MODERNIZATION WORKBENCH BASICS
CREATING A WORKSPACE IN SQL SERVER
3. In the Create new workspace dialog, double-click the New Workspace 
icon for the RDBMS at your site or select it and click OK. The New work-
space dialog opens. 

4. In the New workspace dialog, choose the location for the workspace in 
the Save in drop-down. In the File name field, enter the name of the 
workspace. Choose a name that describes the legacy application as 
closely as possible. Click Save. The Define Connection Parameters 
dialog opens. 
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5. In the Define Connection Parameters dialog, click the Connection tab. 
On the Connection tab, enter: 
• The server name. The server name must be of the form 

<machine>\<SQL server>. 

• The database name your DBA created for the workspace repository. 

• The integrated security provider interface. The default value supports 
Windows authentication using the Security Support Provider Interface 
(SSPI). 

• Your Windows user name and password. 

6. Click the Security tab. In the Policies list box, select: 
• Simple Security Policy if you want to enforce a workspace security 

policy that recognizes two classes of users, master users and ordinary 
users. 

• Three-Group Security Policy if you want to enforce a workspace secu-
rity policy that recognizes a third class of users, subject matter experts 
(SMEs), with special privileges to create, assign, and delete tags. 

7. In the Files access group box on the Security tab, select: 
• Direct sources access via Windows share if your site does not restrict 

Windows access to workspace source files to the master user. 

• Secure sources access via RMW file server if your site restricts 
Windows access to workspace source files to the master user, while 
using the optional file server to make the source files available in the 
 20
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workbench to ordinary users. Make sure the values for the server name 
and port number fields are correct. 

NOTE:  For File Server installation and setup instructions, see the installa-
tion guide for your product. 

8. Click OK. 

NOTE:  If you created the workspace in a non-shared folder, you are warned 
to that effect and prompted to share the folder. After you share the folder, 
make sure to refresh the workspace path. 

STEP RESULT: You are notified that the workspace was created successfully. The 
workbench creates a workspace file (.rwp) and a folder with the same name in 
the specified location. The workspace folder contains support files and 
subfolders for workbench output. A project with the same name as the work-
space is displayed in the Repository Browser. 

Designating Users for Security Policies

Introduces Modernization Workbench security policies.

When you create a workspace, you choose from two workspace security poli-
cies:

• The Simple Security Policy recognizes two classes of users, master users 
and ordinary users. 

• The Three-Group Security Policy recognizes a third class of users, subject 
matter experts (SMEs), with special privileges to create, assign, and delete 
tags.

In each policy, the master user can create new master users.

Designating Users in a Simple Security Policy

Describes how master users set up simple security policies.

A Simple Security Policy recognizes two classes of users, master users and ordi-
nary users. Initially, only the workspace creator has master user privileges. The 
master user can designate new master users as described in this section.
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TASK

1. Choose Start > Programs > Micro Focus > Modernization Work-
bench Administration. The Administration window opens. 

2. Choose Administer > Edit Users. The Edit Users dialog opens.

3. In the Edit Users dialog, select the workspace (.rwp file) for which you 
want to edit users and click Open. The Security dialog opens.
 22
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4. The Security dialog displays a list of users who have connected to the 
workspace in the Known Users list box and a list of master users in the 
Master Users list box. Select a known user and click the  button to 
move the known user into the list of master users. Select a master user 
and click the  button to move the master user into the list of known 
users. 

NOTE:  Click Refresh at any time to update the lists.

5. To create a new master user, click (New User...) in the Master User list 
box. A dialog opens prompting you to enter the name of the new 
master user. Enter the name and click OK. 

6. When you are satisfied with your entries, click Close.

Designating Users in a Three-Group Security Policy

Describes how master users set up three-group security policies.

A Three-Group Security Policy recognizes a third class of workspace users in 
addition to master users and ordinary users: subject matter experts (SMEs), with 
special privileges to create, assign, and delete tags. Initially, only the workspace 
creator has master user privileges. The master user can designate SMEs and new 
master users as described in this section.
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TASK

1. Choose Start > Programs > Micro Focus > Modernization Work-
bench Administration. The Administration window opens. 

2. Choose Administer > Edit Users. The Edit Users dialog opens.

3. In the Edit Users dialog, select the workspace (.rwp file) for which you 
want to edit users and click Open. The Security dialog opens.
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4. The Subject Matter Experts and Master Users tabs of the Security dialog 
display a list of users who have connected to the workspace in the 
Known Users list box and a list of subject matter experts and master 
users, respectively, in the opposite list box. Select a known user and 
click the  button to move the known user into the list of subject 
matter experts or master users. Select a master user and click the  
button to move the subject matter expert or master user into the list of 
known users. 

NOTE:  Click Refresh at any time to update the lists.

5. To create a new subject matter expert or master user, click (New 
User...) in the Subject Matter Experts or Master Users list box. A dialog 
opens prompting you to enter the name of the new subject matter 
expert or master user. Enter the name and click OK. 

6. When you are satisfied with your entries, click Close.

Refreshing the Workspace Path

Describes how to refresh the path of a workspace when you share the workspace 
folder after creating the workspace.
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The folder in which you plan to create workspaces must be shared with team 
members. It’s usually more convenient to share the folder before you create 
workspaces, but you can do it afterward if necessary, then refresh the workspace 
path as described below. You can also use the refresh path feature when you 
move a workspace.

NOTE:  For instructions on how to share a workspace folder, see the installation 
guide for your product.

TASK

1. Choose Start > Programs > Micro Focus> Modernization Work-
bench Administration. The Administration window opens. 

2. Choose Administer > Refresh Workspace Path. The Select workspace 
dialog opens.

3. In the Select workspace dialog, select the workspace (.rwp file) whose 
path you want to refresh and click Open. The Workspace directory 
network path dialog opens.
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4. In the Workspace directory network path dialog, enter the path of the 
workspace in the text field. The path must be of the form 
\machine_name\share_name\workspace_folder_name, 
where machine_name is the name of the machine where the shared 
folder resides, share_name is the value of the Share name field on the 
Sharing tab of the Properties dialog for the shared folder, and 
workspace_folder_name is the name of the folder for the workspace.

NOTE:  The shared folder is the folder that contains the .rwp file for the work-
space, not the workspace folder. The workspace folder (containing support 
files and subfolders for workbench output) resides on the same level as the 
.rwp file.

5. When you are satisfied with your entry, click OK.

Connecting to a Workspace in Oracle or DB/2

Describes how ordinary workbench users connect to a workspace. 

Once a workspace has been created on the Modernization Workbench server 
machine, other users can connect to the workspace from workbench clients. 
When you connect to a workspace, you create a link file with connection infor-
mation that points to the workspace. Because the connection information is 
already stored in the file, you don’t have to enter it again when you reopen the 
workspace connection. Like a workspace file, a link file has a .rwp extension. 

Before connecting to a workspace, you must configure an ODBC data source 
name (DSN) for the database that holds the workspace repository you want to 
link to, as described in the installation guide for your product. You will need the 
following DSN configuration information to connect to the workspace: 

• The data source name. 

• The database schema name your DBA created for the repository you want 
to link to. 
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• The database user name and password that give access to the schema. 

TASK

1. Choose Start > Programs > Micro Focus > Modernization Work-
bench. The Open Existing workspace dialog opens above the Modern-
ization Workbench main window. Click Cancel to dismiss the dialog. 

2. Choose File > Build New Connection. The Define Server Workspace 
Connection dialog opens. 

3. In the Define Server Workspace Connection dialog, select the ODBC 
driver for the RDBMS in use at your site in the Database Provider 
drop-down. In the Required Parameters group box, enter: 
• The ODBC data source name you defined at ODBC data source configu-

ration. If you have not defined a data source name, or want to use a 
different data source name, click ODBC Manager to open the data 
source name configuration dialog, then follow the instructions for 
ODBC data source configuration in the installation guide for your 
product. 

• The database schema name your DBA created for the workspace repos-
itory. 

• The database user name and password that give access to the schema. 

NOTE:  The Tablespace and Tablespace for Indexes fields are for future use. 

4. When you are satisfied with your entries in the Define Server Workspace 
Connection dialog, click the Browse button for the Save Link As (.rwp) 
field. The Save Server Workspace Connectivity dialog opens. 
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5. In the Save Server Workspace Connectivity dialog, choose the location 
for the workspace link in the Save in drop-down. In the File name field, 
enter the name of the link. Click Save. 
STEP RESULT: The linked workspace opens in the Modernization Workbench 
main window. The workbench creates a link file (.rwp) in the specified loca-
tion. 

Connecting to a Workspace in SQL Server

Describes how ordinary workbench users connect to a workspace. 

Once a workspace has been created on the Modernization Workbench server 
machine, other users can connect to the workspace from workbench clients. 
When you connect to a workspace, you create a link file with connection infor-
mation that points to the workspace. Because the connection information is 
already stored in the file, you don’t have to enter it again when you reopen the 
workspace connection. Like a workspace file, a link file has a .rwp extension. 

NOTE:  The following instructions assume you are using Windows Authentication 
to connect to the server. Check the SQL Server documentation for details on SQL 
Server authentication. 

TASK

1. Choose Start > Programs > Micro Focus > Modernization Work-
bench. The Open Existing workspace dialog opens above the Modern-
ization Workbench main window. Click Cancel to dismiss the dialog. 

2. Choose File > Build New Connection. The Define Server Workspace 
Connection dialog opens. 
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3. In the Define Server Workspace Connection dialog, enter: 
• The server name. The server name must be of the form 

<machine>\<SQL server>. 

• The database name your DBA created for the workspace repository. 

• The integrated security provider interface. The default value supports 
Windows authentication using the Security Support Provider Interface 
(SSPI). 

• Your Windows user name and password. 

4. When you are satisfied with your entries in the Define Server Workspace 
Connection dialog, click the Browse button for the Save Link As (.rwp) 
field. The Save Server Workspace Connectivity dialog opens. 
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5. In the Save Server Workspace Connectivity dialog, choose the location 
for the workspace link in the Save in drop-down. In the File name field, 
enter the name of the link. Click Save. 
STEP RESULT: The linked workspace opens in the Modernization Workbench 
main window. The workbench creates a link file (.rwp) in the specified loca-
tion. 

Opening a Workspace

Describes how to open a workspace. 

The procedure for opening a workspace is the same whether you created the 
workspace or simply connected to it. You can also open a workspace by 
double-clicking it in the file system. You don’t have to close a workspace before 
opening another workspace. 

TASK

1. Choose Start > Programs > Micro Focus > Modernization Work-
bench. The Open Existing workspace dialog opens above the Modern-
ization Workbench main window. 

NOTE:  If Modernization Workbench is already open, choose File > Open 
Workspace. 
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2. Click the tab you want to work in: 
• In the Existing tab, choose the drive and folder for the workspace you 

want to open. A list of workspaces in the selected folder is displayed in 
the righthand pane. Double-click the workspace you want to open, or 
select it and click OK. 

• In the Recent tab, double-click the recently opened workspace you 
want to open, or select it and click OK. 

NOTE:  If you created the workspace in a previous release of Modernization 
Workbench, the system prompts you to upgrade the workspace to the new 
release. Click Yes. 

STEP RESULT: The workspace is displayed in the Modernization Workbench 
window. If a workspace was already open in the window, the selected work-
space replaces it. 

Registering Source Files

Describes how to register source files in the repository. 

Before you can analyze application source files in Modernization Workbench, 
you need to load, or register, the source files in a workspace. Only a master user 
can register source files in a multiuser environment. 

The workbench creates copies of the registered files on the server machine (or 
locally in a single-user environment) in the Sources folder for the workspace. 
These are the files you view and edit in the workbench tools. You can restore a 
file to its original state, update it to its current state, or export it as necessary.

Source files must have recognized DOS file extensions before they can be regis-
tered. You can view and add to the recognized extensions in the Workspace 
Registration options window. Files without extensions are checked for content, 
and if the content is recognized, the files are registered with appropriate exten-
sions appended.

The workbench assumes that input source files are ASCII files in DOS format. 
Occasionally, files may be converted incorrectly from other formats to 
DOS-based ASCII with an extra special character (like “M”) at the end of each 
line. While Modernization Workbench accepts these files as input, some work-
bench tools may not work correctly with them. Make sure all source files are in 
valid ASCII format.

You can register source files in compressed formats (ZIP or RAR), as well as 
uncompressed formats. Modernization Workbench automatically unpacks the 
compressed file and registers its contents. 
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NOTE:  The workbench extracts compressed source files using the command line 
syntax for archiver versions most widely in use. If you use newer archiver versions, 
specify the command line syntax in the Archivers tab of the User Preferences 
window. 

Workspace Registration options determine registration behavior. The default 
values for these options are preset based on your configuration and should be 
appropriate for most installations. 

TASK

1. In the Repository Browser, create a project for the source files you want 
to register, or use the default project. To create a project, choose 
Project > New Project. The Create Project dialog opens. Enter the 
name of the new project and click OK. The new project is displayed in 
the Repository Browser.

2. Select the project in the Repository Browser, then drag-and-drop the 
file or folder for the source files you want to register onto the Repository 
Browser.
STEP RESULT: You are notified that you have registered the files successfully and 
are prompted to verify the files. Click Close. The Repository Browser displays 
the contents of the new workspace, organized by file type. 

NOTE:  In the notification dialog, select Never ask again if you do not want 
to be prompted to verify files. On the Environment tab of the User Prefer-
ences window, select Ask user about verification if you want to be 
prompted again. 

Verifying Source Files

Describes how to verify source files. 

Parsing, or verifying, an application source file generates the object model for 
the file. Only a master user can verify source files. 

You can verify a single file, a group of files, all the files in a folder, or all the files 
in a project. It’s usually best to verify an entire project. Modernization Work-
bench parses the files in appropriate order, taking account of likely dependen-
cies between file types. Copybooks are verified when the including source file is 
verified. 

NOTE:  If your RPG or AS/400 Cobol application uses copy statements that refer-
ence Database Description or Device Description files, or if your MCP Cobol 
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application uses copy statements that reference DMSII DASDL files, you need to 
generate copybooks for the application before you verify program files. 

For distributed languages, consult the support notes in the relevant language 
support guide for pre-verification requirements. You can find the guides in 
Start > All Programs > Micro Focus > Modernization Workbench Documen-
tation. 

Workspace and Project Verification options determine verification behavior. 
The default values for these options are preset based on your configuration and 
should be appropriate for most installations. 

TASK

1. In the Repository Browser, select the project, folder, or files you want to 
verify and choose Prepare > Verify. 

2. You are prompted to drop repository indexes to improve verification 
performance. Click Yes. You will be prompted to restore the indexes 
when you analyze the files. 

RESULT: The parser builds an object model for each successfully verified file. For 
an unsuccessfully verified file, the parser builds an object model for as much of 
the file as it understands. 

How Verification Results Are Indicated

Describes how verification results are denoted.

If you have not verified a workspace file, the file is displayed in the Repository 
pane in bold type. Since the system has not generated an object model of the 
file’s contents, only the file itself is displayed.

A verified file shows all the objects in the model generated for the file. Verifica-
tion results are denoted as follows:

• A blue dot  means that the parser has verified the file successfully. 

• A red dot  means that the parser has encountered an error in the file.

• A yellow dot  means that the parser has encountered an error in the file, 
but that the file has been successfully verified under the relaxed parsing 
option.

NOTE:  When you edit a file, the modified file and any dependent files are invali-
dated, and need to be verified again. You can learn more about how objects are 
invalidated and how the system refreshes the repository in Preparing Projects in 
the workbench documentation set.
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Using the Modernization Workbench Main 
Window

Introduces the Modernization Workbench main window.

The Modernization Workbench main window lets you view and edit projects, 
set workbench options, and open workbench tools. The window’s state is saved 
across sessions. 

Open a pane in the main window by selecting the appropriate choice in the 
View menu. Resize a pane by using the mouse to grab its border with another 
pane, called a splitter, and dragging it to a new location. Close a pane by clicking 
the  button in the upper righthand corner. 

The figure shows the Modernization Workbench main window in a typical 
configuration. 
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Menus

Introduces Modernization Workbench menus.

Modernization Workbench menus let you access workbench tools and other 
workbench functionality. Menus are displayed only for the products you have 
enabled in the Configuration Manager. The table below shows the relationship 
between products and menus. 

NOTE:  The screens shown in the workbench documentation set display the menu 
bar with all products installed.

Most workbench menu choices have equivalent choices in the right-click menu. 
Menu selections for panes in the main window are available only if the pane has 
the focus. 

Customizing Menus

Describes how to customize Modernization Workbench menus.

Modernization Workbench-specific menus are fully customizable. You control 
which menus, choices, and tool bars the system displays. You can save a menu 
bar configuration and restore it with a single mouse click. 

NOTE:  You cannot customize the Windows standard menus (File, Edit, View, 
and so forth).

TASK

1. Choose Tools > Customize Menu. If the Editor pane is open, you are 
prompted to close it. Click OK. The Customize Menu window opens.

Product Menu

Application Analyzer Analyze

Enterprise View Profile

Application Architect Architect

Business Rule Manager Extract
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2. In the Customize Menu window, deselect the menus and/or menu 
choices you want to hide. Select the menus and/or choices you want to 
show.

3. Enter a name for the specified menu configuration in the drop-down 
list below the Load button. 

4. Click Save to save the configuration without dismissing the window. 
Click OK to save the configuration and dismiss the window. 
STEP RESULT: The new configuration is applied in the Modernization Work-
bench main window. 

AFTER COMPLETING THIS TASK: To restore a menu configuration, select its name in 
the drop-down list and click Load. To restore the default configuration, select 
(default) in the drop-down list and click Load.
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Toolbars

Introduces Modernization Workbench toolbars.

You can access a Modernization Workbench menu function by clicking its tool 
bar icon. The tool tip for an icon tells you what it does. Place your cursor over 
the icon for a moment. The tool tip will display. 

A tool bar is displayed only if its corresponding menu is displayed. You can 
change the position of a tool bar by grabbing the delimiter at the left of the tool 
bar and dragging it to a new location.

Using the Repository Pane

Introduces the Modernization Workbench Repository pane.

The Repository pane displays the contents of the repository for the current 
workspace in two tabs:

• The Browser tab displays the object model for the workspace, organized in 
tree form by project, object type, and object relationship. Choose View > 
Browser to show the Browser tab. 

NOTE:  The Browser tab is commonly called the Repository Browser.

• The Search tab displays a sorted list of workspace objects returned by a 
search of the repository. Choose View > Search to show the Search tab. 

If both tabs are open, click the tabs to switch back and forth between them. In 
either tab, place your cursor over an object for a moment to display a tool tip 
that describes the object in more detail. 

Hide the Browser or Search tab by selecting it and choosing Hide in the 
right-click menu. To restore the tab, select the appropriate choice in the View 
menu. 

Selecting Objects

Describes the basic ways to select objects.

Select an object in the Repository pane by clicking it with the left mouse button. 
You can select all, select multiple, or type-ahead select.

Use the Select choices in the Edit menu to select objects based on their verifica-
tion status. The choices operate on the entire list in the Search tab and on the 
objects under the selected workspace, project, or folder in the Browser tab.
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NOTE:  If you use the Select choices in the Edit menu to select objects in the 
Browser tab based on their verification status, and all the objects have not been 
fetched, the results are returned in the Search tab.

The Project drop-down displays the current project. You can navigate quickly 
to another project in the Repository pane by clicking the project name in the 
drop-down. 

Selecting All

Describes how to select all objects.

To select all the objects in the tree or all the objects in the selected node, choose 
Edit > Select All. To deselect the objects, choose Edit > Unselect All.

Selecting Multiple

Describes how to select multiple objects.

To select a range of objects, hold down the Shift key, click the first object in the 
range, then click the last object in the range. To select objects that are not in a 
range, hold down the Control key, then click each object you want to select.

Using the Type-Ahead Select Functions

Describes how to use the type-ahead select functions.

Use the simple type-ahead select function to select displayed objects as you type. 
To use the simple function, make sure the Browser tab is current, then type the 
characters you want to match. 

NOTE:  You cannot use the simple type-ahead select function in the Search tab.

Use the advanced type ahead select function to select objects in the Browser or 
Search tab whether or not they are currently displayed. To use the advanced 
function, click an object that has the same type as the object you want to select, 
then click the  button next to the  button at the bottom of the Repository 
pane (or if the filter subtree function is enabled, next to the  button). From the 
drop-down menu, choose:

• Select to match text explicitly. 

• Wildcard Select to match text using wildcard patterns. 

Enter the text you want to match in the field next to the  button. The tool 
selects matched objects as you type, as long as they are in the same subtree. Click 
the  button to repeat the select with the same criterion. 

To select multiple objects, enter the text you want to match in the field next to 
the  button, then click the adjacent  button. From the drop-down menu, 
choose:
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• Select All to select multiple objects that match text explicitly. 

• Wildcard Select All to select multiple objects that match text using wild-
card patterns.

The tool selects matched objects as long as they are in the same subtree. Click 
the  button to repeat the select with the same criterion.

Searching for Objects

Describes how to search for objects in the workbench.

To search for workspace objects in the Repository pane, choose Edit > Search 
Criteria. The Search dialog opens. In the Filter Name drop-down, choose the 
filter for the search, then click Find. The results are returned in the Search tab.

By default, the results list shows two attributes of an object: its name and file 
type. Use the General tab of the Workspace Options window to display addi-
tional attributes. 

Creating a Search Filter

Describes how to create a search filter.

You can use predefined filters to search for objects in the Repository pane or 
create your own filters. You cannot modify a predefined filter.

TASK

1. Choose Edit > New Criteria. The Search dialog opens.
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2. Choose any allowed combination of the following:
• To filter on object type, select the Entity Type check box and choose the 

entity type in the pane below.

• To filter on object name, select the Object Name Like check box and 
enter a matching pattern for the name in the accompanying field. You 
can use wildcard patterns allowed in LIKE statements by Visual Basic for 
Applications (VBA). 

• To filter on verification status, select the Where Parse Status check box 
and choose the status in the group box below.

• To filter on a text string in the source, select the Scan Legacy Sources 
For check box, then specify the search criterion. Select the check boxes 
below the drop-down if you want the search to match case, skip 
comments, and/or match whole lines.

3. In the Filter Name drop-down, enter the name of the search filter and 
click Save.
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4. To edit a search filter, select it in the Filter Name drop-down and follow 
the instructions for creating a filter. To delete a search filter, select it in 
the Filter Name drop-down and click Delete. To clear a search filter, 
select it in the Filter Name drop-down and click Clear.

NOTE:  To execute a search directly from the Search dialog, select the search 
filter in the Filter Name drop-down and click Find. The results are returned 
in the Search tab.

Specifying a Search Criterion

Describes how to define a search criterion.

Follow these instructions to specify a search criterion in find and replace oper-
ations and in search filters.

TASK

1. Click the radio button for the type of pattern matching you want to use. 

2. In the combo box: 
• Select the pattern for the text you want to match. The drop-down lists 

matching patterns from previous searches. 

• Enter a new matching pattern by typing in the combo box. You can 
enter plain character strings, Posix regular expressions, or wildcard 
patterns allowed in LIKE statements by Visual Basic for Applications 
(VBA). For regular expressions and wildcard patterns, click the  button 
next to the drop-down to display a pop-up menu of elements you can 
insert in the pattern. Click an element to insert it. The matching pattern 
is saved when you execute the search.

Using Wildcard Patterns in Searches

Describes the supported wildcard patterns.

In most searches you perform in the workbench tools, you can use wildcard 
patterns allowed in LIKE statements by Visual Basic for Applications (VBA). 
The table below shows the wildcard characters and what they match.

Character Matches

? Any single character.

* Zero or more characters.

# Any single digit (0–9).

[charlist] Any single character in charlist.
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To match the special characters left bracket ([), question mark (?), number sign 
(#), and asterisk (*), enclose them in brackets. The right bracket (]) cannot be 
used within a group to match itself, but it can be used outside a group as an indi-
vidual character.

Specify a range of characters in a charlist by using a hyphen (–) to separate the 
upper and lower bounds of the range. [A-Z], for example, results in a match if 
the corresponding character position in a string contains any uppercase letters 
in the range A–Z. You can specify multiple ranges in brackets without delim-
iters.

Expanding Subtrees

Describes how to expand subtrees in the browser.

Click the  symbol next to an item to expand its subtree one level. Click the  
symbol to collapse the subtree one level. 

In the Repository Browser, select an item and choose Expand Subtree in the 
right-click menu to expand all its subtree levels in a single step. Select an item 
and choose Save Subtree in the right-click menu to export the label text for 
expanded subtree levels to a text file.

NOTE:   For subtrees with a great many objects, you can improve browser display 
performance by filtering the subtree and/or by lowering the fetch buffer size in the 
General tab of the Workspace Options window.

Filtering Subtrees

Describes how to improve browser display performance by showing only 
objects of interest in a subtree.

For a subtree with a great many objects, you can improve browser display 
performance by showing only objects of interest in the subtree. To filter out 
objects from a subtree, select the subtree, then enter the text you want to match 
in the field next to the  button at the bottom of the Repository pane (or if the 
type-ahead select function is enabled, next to the  button). Click the adjacent 

 button and choose Filter from the drop-down menu. 

The tool filters out unmatched objects from the subtree, and places a  symbol 
next to the subtree in the browser display. The filter and filter text are persistent 
for the subtree across sessions. To remove the filter and its text, enter an empty 
string in the text field and choose Filter again.

[!charlist] Any single character not in charlist.

Character Matches
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Refreshing the Browser

Describes how to refresh the browser.

In a multiuser environment, you need to refresh the browser after another user 
adds, deletes, or modifies a workspace file. Choose View > Refresh Browser to 
refresh the browser.

Viewing the Entire Workspace

Describes how to display all the objects in the workspace.

By default, the Browser tab displays repository trees for projects only. These 
trees show only objects you can act on in the browser. To view all the objects in 
the workspace, choose View > Entire Workspace, or select (none) in the 
Project drop-down. Choose View > Entire Workspace again, or select a project 
in the Project drop-down, to display the project only.

Finding and Replacing Text in Source Files

Describes how to find and replace text in source files.

You can find and replace text in source files from the Browser or Search tab of 
the Repository pane. Use the Editor to replace text in a selection of source code.

TASK

1. In the Browser or Search tab, select the source files or the node that 
contains the source files you want to search and choose:
• Edit > Find if you simply want to search.

• Edit > Replace if you want to search and replace.

2. The Find and Replace dialog opens. Click the tab for the operation you 
want to perform.

NOTE:  The find functionality in the Find tab is bidirectional. You can search 
up or down, and specify that the search wrap. The find functionality in the 
Replace tab is unidirectional. Otherwise, the find functionality is identical 
in each tab. The remaining steps assume that you want to both search and 
replace.

3. In the Find What combo box, specify the search criterion. Select the 
check boxes below the drop-down if you want the search to match case 
and/or match whole words.

4. In the Replace With combo box, select the replacement text. The 
drop-down lists text strings from previous replace operations. Enter 
new replacement text by typing in the combo box. If you used regular 
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expressions for the find, click the  button next to the drop-down to 
display a list of elements you can insert in the replacement text field. 

5. Click Find Next. When the search finds a match, click Replace. You are 
prompted to confirm the replacement. Click Yes. Click Find Next again 
to find the next match, or click Replace All to replace all matching text.

Using the Editor and Viewer

Describes how to use the Editor.

The Editor lets you view and edit the source code for a file. The Viewer lets you 
view renderings of logical objects like screens and transformation target models. 
Double-click a file in the Repository pane to view it in the Editor or Viewer. 
Choose File > Recent Sources to open a file from a list of recently opened files.

Editing Source

Describes how to edit source in the Editor.

Edit file source as you would text in a word processor (cut-and-paste, 
drag-and-drop, undo, and so forth). Click File > Save to save your changes. 
Edits are saved in the copy of the file maintained in the \Workspace\Source 
subfolder. 

NOTE:   When you edit a file, the modified file and any dependent files are invali-
dated, and need to be verified again. Only a master user can edit and verify source 
in a multiuser environment. 

Finding and Replacing Source in a Selection

Describes how to find and replace source in a selection.

To find and replace source in a selection of text, select the text, then follow the 
instructions for the source file find and replace function.

Viewing a List of Errors

Describes how to view a list of errors in the Editor.

For a source files with errors or warnings, right-click in the Editor and choose:

• Errors > View Errors from the popup menu to list the errors and warn-
ings in a separate pane below the Editor. Choose Edit > Errors > View 
Errors again to hide the pane.
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• Errors > Next Error from the popup menu to navigate to the offending 
source code for the next error in the list. 

• Errors > Previous Error to navigate to the offending source code for the 
previous error in the list.

• Errors > Severity Filter from the popup menu to filter the list by severity. 

NOTE:  You can set a severity filter for all your workspaces in the Editor User 
Preferences.

• Errors > Copy Errors in the pop-up menu to copy the list of errors and 
warnings to the clipboard.

To hide the Editor and show only the list of errors and warnings for the selected 
file, right-click in the Repository pane and choose Show Errors in the pop-up 
menu. Double-click the source file in the Repository pane to show the Editor 
again.

Extracting and Expanding Copybooks (Cobol, MFS Only)

Describes how to extract and expand Cobol copybooks in the Editor.

To extract source code as a copybook, select the code you want to extract, then 
choose Edit > Extract Copybook. A dialog box opens, where you can enter the 
name of the new copybook. Click OK. The new copybook is added to the repos-
itory and the extracted code is replaced by a COPY statement referencing the 
new copybook.

To expand COPY statements, choose Edit > Expand Copy Statements. The 
added lines of code are highlighted and a comment line is inserted to identify 
the source copybook.

Commenting Out Source

Describes how to comment out source in the Editor.

To comment out a block of source, select the block and choose Edit > Comment 
Block. To uncomment the block, select it and choose Edit > Uncomment 
Block.

Printing Source

Describes how to print source in the Editor.

To print the source for a file, choose File > Print.
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Restoring Line Numbers in Natural Source

Describes how to restore line numbers in Natural source.

To restore stripped line numbers in Natural source, choose Edit > Restore Line 
Numbers in Natural Source. 

Setting Editor User Preferences

Describes how to set Editor User Preferences.

Use the Editor tab of the User Preferences window to specify the display char-
acteristics of the Editor.

TASK

1. Choose Tools > User Preferences. The User Preferences window 
opens. Click the Editor tab.

2. In the Font drop-down, select the display font for source code.

3. Select the Colorize Text check box if you want to use a color scheme to 
identify source elements, then specify the color of each source element. 

4. In the Show Errors pane, select the check box for each type of error you 
want to show in the error list.

Specifying the Color of Items

Describes how to specify the color of items.

You use a standard Windows color control to specify a color scheme for source 
elements and other items. Use the Palette tab to select a color from the Windows 
palette. Use the System tab to match the color of a standard Windows element. 
Depending on the element, you can specify the foreground color, background 
color, and/or font color.

Using the Object Information Pane

Describes how to use the Object Information pane.

The Object Information pane displays comments you have entered for an 
object. Select an object in the Repository pane and choose View > Object Infor-
mation to show the Object Information pane. 
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Enter comments for an object by selecting the object in the Repository pane and 
choosing Properties in the right-click menu. In the Description tab, enter your 
comment in the text area and click OK. 

NOTE:  You cannot use this method to enter comments for a workspace (that is, 
when an entire workspace is displayed in the Repository Browser). Use the 
General tab of the Workspace Options window to enter comments for a work-
space.

Viewing Object Properties

Describes how to view object properties.

Select an object in the Repository pane and choose View > Properties to display 
a set of tabs with object properties:

• Description displays comments you have entered for the object.

• General displays the name and other general information for the object.

• Internal displays verification option settings and other internal informa-
tion for the object.

• System displays system information for the object.

• Statistic displays the complexity metrics for the object and their values.

• Relationships displays the relationships of the object. Select Restricted to 
the current project to restrict relationships to those in the current project. 
Select Workspace wide to show all the relationships of the object in the 
workspace.

• Object Tags displays the tags assigned to the object.

NOTE:  In other workbench tools, use the right-click menu or the View menu to 
display the properties of the selected object.

Viewing Inventory Reports

Describes how to view Inventory Reports.

Inventory Reports give high-level statistics for source file types in the current 
workspace: number of files of each type, whether verified, number of lines of 
code (verified files only), and the like. To generate an Inventory Report, choose 
Prepare > Inventory Report. 
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Viewing Key Object Relationships with Query Repository

Describes how to use the Query Repository feature to view key object relation-
ships.

The Query Repository feature lets you home in on key relationships of an object: 
all the programs that call another program, or all the programs that update a 
data store, for example. From the results, you can launch further queries 
without having to return to the Repository Browser. You can create printable 
relationship reports and export them to a variety of standard formats.

TASK

1. In the Repository pane, select the workspace, project, folder, files, or 
objects you want to view relationships for and choose Edit > Query 
Repository> <Relationship Type>. The Query Repository results pane 
opens over the Editor/Viewer.

2. To launch a query from the results, select one or more objects in the 
righthand column and choose Edit > Query Repository > <Relation-
ship Type>.

Using the Activity Log

Introduces the Activity Log.

The Activity Log is a chronological record of your activities in the current 
session. Choose View > Activity Log to show the Activity Log pane. 

Viewing Errors

Describes how to view errors in the Activity Log.

If the parser generated errors or warnings for a file, double-click the Activity 
Log entry for the file or select the entry and choose Expand in the right-click 
menu to show a list of the errors and/or warnings. Double-click a message to 
navigate to the offending source in the Editor. Choose Collapse in the 
right-click menu to collapse the list. 

Viewing History

Describes how to view entries across sessions in the Activity Log.

To view Activity Log entries across sessions, choose History in the right-click 
menu. Click a date to view the session log. To clear the session log, right-click in 
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the log and choose Clear Log in the pop-up menu. To clear a log entry, select 
the entry and choose Delete in the right-click menu.

Copying Records

Describes how to copy records in the Activity Log.

To copy Activity Log records to the clipboard, select the records and choose 
Copy in the right-click menu.

Generating Reports

Describes how to generate reports from the Activity Log.

To generate a report from the Activity Log, right-click in the log and choose 
Report in the pop-up menu. 

Clearing the Log

Describes how to clear the Activity Log.

To clear the Activity Log, right-click in the log and choose Clear Log in the 
pop-up menu. To clear a log entry, select the entry and choose Delete in the 
right-click menu.

Hiding a Column

Describes how to hide a column in the Activity Log.

To hide a column in the Activity Log, right-click in the log and deselect the 
column name in the Columns choice in the pop-up menu. Select the column 
name to show the column again.

Creating a To Do List

Describes how to create a to do list.

A to do list is a record of tasks you need to perform before completing your 
project. You can create a to do list for a workspace, project, folder, source file, 
or extracted object.
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TASK

1. In the Repository Browser, select a workspace, project, folder, source 
file, or generated object and choose View > ToDo List. The ToDo List 
window opens.

2. If you selected:
• A workspace, project, or folder, choose Edit > Add to enter a task for 

the item and all the items it contains. Otherwise, choose Add 
forItem to enter a task for the workspace, project, or folder only. 

• A source file or generated object, choose Edit > Add to enter a task for 
the item.

3. The New Properties dialog opens. In the Subject field, enter the name 
of the task. In the Content field, enter a description of the task. Click OK. 
The task is listed in the ToDo List window.

Viewing a To Do List

Describes how to view a to do list.

To view the to do list for an item, select the item in the Repository Browser and 
choose View > ToDo List. Use the options in the ToDo List window Edit menu 
to mark a task as done, delete a task, or view its properties. You can generate a 
report from a to do list by choosing File > Report. 

Using Tool Windows

Provides an overview of tool window behavior.

When you open a Modernization Workbench tool, the window for the tool 
appears above the workbench main window. Simply move the tool window if 
you want to work in the main window again. A tool window’s state is saved 
across sessions. Close a tool window by clicking the  button in the upper 
righthand corner. 

Tool windows are modeless: in principle, you can open as many tool windows as 
you want. In practice, the workbench will prompt you to close an “unprotected” 
tool window if the activity you want to perform could result in a repository 
change. An unprotected tool window cannot be updated to reflect a concurrent 
repository change.
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In tool windows with lists, you can select all, select multiple, size columns, and 
sort by column.

Resizing Panes

Describes how to resize tool window panes.

Resize a pane in a tool window by using the mouse to grab its border with 
another pane, called a splitter, and dragging the border to a new location. To 
control how panes are resized when you resize the window, select the splitter 
and choose one of the following in the right-click menu: 

• For a vertical splitter, Keep First preserves the size of the panes to the left 
of the splitter. For a horizontal splitter, Keep First preserves the size of the 
panes above the splitter.

• For a vertical splitter, Keep Second preserves the size of the panes to the 
right of the splitter. For a horizontal splitter, Keep Second preserves the 
size of the panes below the splitter.

• Keep Proportion preserves the length and width ratio of the panes on 
either side of the splitter.

Moving Panes

Describes how to move tool window panes.

Move a pane in the window by grabbing its title bar to show the “virtual rect-
angle” for the pane. The virtual rectangle is a dotted color frame that you can 
drag to the position in the window at which you want the pane to appear. When 
you are satisfied with the new position, release the mouse button. The other 
panes in the window are adjusted as necessary.

NOTE:  You may have to drag the virtual rectangle beyond the edge of the tool 
window to achieve the effect you want.

To swap the positions of the panes on either side of a splitter, select the splitter 
and choose Swap in the right-click menu. To change the color of the splitter 
when it is selected (and of its virtual rectangle), select the splitter and choose 
Color in the right-click menu. Use the standard Windows color control to 
specify the color.
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Setting Options

Provides an overview of Modernization Workbench options.

Modernization Workbench options control the look and feel of the workbench 
tools and how they perform their tasks. The Tools menu gives you access to 
three sets of options:

• Workspace Options control the appearance and behavior of workbench 
tools for the current workspace.

• Project Options control the appearance and behavior of workbench tools 
for the current project.

• User Preferences control the appearance and behavior of the Editor, 
HyperView, and Change Analyzer across workspaces, and miscellaneous 
other tasks.

Each tool has an Options choice in the View menu that lets you set the options 
for that tool. 

NOTE:  Many options are preset based on your choices in the Modernization 
Workbench Configuration Manager. For more information, see the installation 
guide for your product.

Tool options are described in detail in the relevant sections of the documenta-
tion set. This section shows you how to manage option sets and how to set 
general workbench and environment options

Managing Option Sets

Introduces option sets.

An option set is a particular configuration of settings for one of the option 
groupings. In a given Project Options set, for example, you might choose to 
show GO TO statements in the HyperView Callie tool, while in the other Project 
Options sets you would not. 

Option sets let you switch back and forth between configurations in the same 
session, without having to change settings manually. You can also use them to 
ensure uniform results across your team by sharing settings with team 
members. 
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Understanding the Options Manager Window

Describes the Options Manager window.

Use the Options Manager to define options sets. Choose Tools > Options 
Manager to open the Options Manager. 

The figure below shows the Options Manager window at startup, with the tab 
for the Workspace Options grouping selected. For each grouping, there is an 
initial read-only default option set, denoted by a  symbol, that reflects your 
current workbench configuration. This initial default option set is always shared 
with other users in the environment, as indicated by a  symbol. 

When you assign a Workspace or Project Options set, you make it active for the 
current workspace or selected project. When you assign a User Preferences 
option set, you make it active across all workspaces. The active option set is 
displayed in bold type in the Options Manager tab for the grouping. Assign-
ments persist across workbench sessions. 

The user who creates an option set is referred to as its owner. Only the owner 
can share an option set with other users. The owner’s name appears in the 
Owner column in the Options Manager window displayed to other users (but 
not in the owner’s Options Manager window). The Used By drop-down at the 
bottom of the owner’s Options Manager window list the names of other users 
who have assigned a shared option set. 

An owner can make a shared option set the default, in which case it cannot be 
modified or deleted. Otherwise, owners can delete a shared option set or revoke 
sharing privileges only if it is not being used.
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Creating an Option Set

Describes how to create an option set.

If there is only a “(Default)” option set for the grouping, select it and click Edit. 
Otherwise, select any option set and click Edit. Options Manager displays the 
available tabs for the selected options grouping. 

Modify the options displayed on each tab as necessary and click Apply. When 
you are satisfied with your choices, click OK. The new option set is displayed in 
the Options Manager window with the name of the grouping. 

NOTE:  If a default option set already uses one of the grouping names, Options 
Manager prepends “Copy of” to the name.

Renaming an Option Set

Describes how to rename an option set.

To rename an option set, select it and click Rename. The system displays the 
current name in an edit box. Enter the new name in the edit box and click 
outside the box.

Editing an Option Set

Describes how to edit an option set.

To edit an option set, select it and click Edit, then follow the instructions for 
creating an option set.

Copying an Option Set

Describes how to copy an option set.

To copy an option set, select it and click Copy. Options Manager prepends 
“Copy of” to the name of the copied option set. 

Deleting an Option Set

Describes how to delete an option set.

To delete an option set, select it and click Delete.
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Sharing an Option Set

Describes how to share an option set.

To share an option set, select it and click Sharing. The button is a toggle. Select 
it again to revoke sharing.

Making an Option Set the Default

Describes how to make an option set the default.

To make an option set the default, select it and click Default. In the Project 
Options tab, a dialog opens that prompts you to select or create a new project. 
Select the project and click OK.

Assigning an Option Set

Describes how to make an option set active.

To make an option set active, select it and click Assign. 

NOTE:  In the Project Options tab, a dialog opens that prompts you to select or 
create a new project. Select the project and click OK.

Importing and Exporting Option Sets

Describes how to import and export an option set.

To import an option set, click Import. A Load dialog opens, where you can 
specify the option set you want to import.

To export an option set, select it and click Export. A Save dialog opens, where 
you can specify the name and location of the option set.

Setting General Options

Describes how to set General Workspace Options. 

Use the General tab of the Workspace Options window to specify the descrip-
tion of the workspace displayed in the Object Information pane, the attributes 
displayed in the Repository pane Search tab, and the browser fetch buffer size. 

TASK

1. Choose Tools > Workspace Options. The Workspace Options window 
opens. Click the General tab. 
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2. In the Workspace description field, enter a description of your work-
space. This description is shown in the Object Information pane. 

3. In Repository Browser (Search), check the boxes for the object attri-
butes that should be displayed in the Search tab of the Repository pane. 
Click Select All to check all the attributes. 

NOTE:  Only attributes in the repository model for an object are displayed. 
That is, if you choose Cyclomatic Complexity, and only JCL files appear in 
the Search tab results list, the attribute will not be displayed in the list, 
because Cyclomatic Complexity is not an attribute of a JCL file. 

4. In the Browser Fetch Buffer Size field, enter the size of the buffer the 
workbench uses to populate the repository tree. When you expand a 
node in the Repository Browser, the workbench populates the display 
from a buffer that contains the objects last fetched from the repository. 
For very large repositories, you may want to lower the buffer size so that 
you can work with objects in the Repository Browser while the work-
bench performs subsequent fetches. 

Setting Environment User Preferences

Describes how to set Environment User Preferences.

Use the Environment tab of the User Preferences window to specify whether 
you want to be prompted to verify source files after registering them and the 
scope of relationships shown in the Object Properties window.

TASK

1. Choose Tools > User Preferences. The User Preferences window 
opens. Click the Environment tab.
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2. In After new files are registered, choose:
• Verify registered files if you want the workbench to verify files after 

they have been registered. 

• Ask user about verification if you want to be prompted to verify files 
after they have been registered. Available whether or not Verify regis-
tered files is selected.

3. In Show relationships in the object properties view window, choose 
whether you want to restrict the relationships displayed in the Relation-
ships tab of the Object Properties window:
• Restricted to the current project if you want to restrict the relation-

ships of the object to those in the current project.

• Workspace wide if you want to display all the relationships of the 
object in the current workspace.

4. For Java support, enter the path to the folder for the Java Runtime Envi-
ronment (JRE) on your machine in the Path to JRE Folder field. You can 
enter the path manually or use the  button to browse for the folder.

Setting Archivers User Preferences

Describes how to set Archivers User Preferences.

The workbench registration process extracts compressed source files using the 
command line syntax for archiver versions most widely in use. Use the 
Archivers tab of the User Preferences window to specify the command line 
syntax for newer archiver versions.

TASK

1. Choose Tools > User Preferences. The User Preferences window 
opens. Click the Archivers tab.

2. In the Command Line for Archiver drop-down, choose the archiver 
whose command line syntax you want to specify.

3. In the Unpack All field, enter the command line syntax for the unpack 
all operation.

4. In the Extract File field, enter the command line syntax for the extract 
file operation.
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Setting Export Options

Describes how to set Export Project Options.

Use the Export Options tab of the Project Options window to specify where 
Modernization Workbench stores generated files. The default location is the 
\<Workspace Home>\Output folder.

TASK

1. Choose Tools > Project Options. The Project Options window opens. 
Click the Export Options tab.

2. In the Target directory field, enter the folder you want Modernization 
Workbench to store generated files in. 

3. Deselect the Move Files check box if you want to copy generated files 
to both the default and the specified directories.

Adding a Selectable Item

Describes how to add a selectable item in options windows.

Many options windows allow you to add an item to a list of available items. In 
the Extensions tab of the Workspace Registration options, for example, you can 
add an extension to the list of recognized extensions.

Add an item by right-clicking in the selection pane and choosing Add in the 
pop-up menu. The workbench displays an empty text field next to a selected 
check box. Enter the name of the item in the text field and click outside the field. 

NOTE:  If you are entering a file extension, make sure to enter the dot (.). 

Edit an item by selecting it and choosing Edit in the right-click menu. Delete an 
extension by selecting it and choosing Delete in the right-click menu. 

Working with Reports and Diagrams

Provides an overview of diagram and report generation in workbench tools.

When you generate a diagram or report in the Modernization Workbench, you 
typically have the option of saving it to a file or printing it. You can save to a 
wide variety of standard formats.
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NOTE:   Word must be installed to save reports to RTF and Word. Excel must be 
installed to save reports to Excel, CSV, and TXT. Visio 2002 must be installed to 
save a diagram to Visio. Visio 2002 is not required to save to Visio XML. 

Click Page Setup in a report window to set up the page for a printed report. 
Click Print to print the report. The Print dialog opens, where you can set 
options for the print job. Click OK.

Click Save in a report window to export a report. A Save As dialog opens, where 
you can specify the name, location, and file type of the report.

Using the Guide for a Tool

Describes how to use the guide for a workbench tool.

Many Modernization Workbench tools have guides that you can use to get 
started quickly in the tool. The guides are help-like systems with hyperlinks that 
you can use to access functions otherwise available only in menus and other 
program controls. 

To open the guide for a tool, choose View > Guide. Use the table of contents in 
the Page drop-down to navigate quickly to a topic.
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