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About This Guide

This manual provides information about installing, deploying, and upgrading SecurelLogin.

+ Getting Started

¢ Introduction

+ Installing and Deploying in the SecurelLogin Advanced Edition Environment
+ Installing and Configuring in Active Directory Environment

+ Configuring, Installing, and Deploying In Active Directory Lightweight Directory Services
+ Installing, Configuring, and Deploying in an eDirectory Environment

+ Installing, Configuring, and Deploying in an LDAP Environment

+ Installing and Deploying in the Standalone Environment

+ Installing through the Command Line

+ Installing, Configuring, and Deploying Desktop Automation Services

+ Installing SecureLogin with Advanced Authentication

+ Installing SecurelLogin Browser Extensions

+ Installing and Uninstalling SecureLogin with AutoPass License Feature

+ Installing, Uninstalling, and Upgrading Analytics Dashboard Plug-in

+ Modifying, Repairing, or Uninstalling

¢ Upgrading Securelogin

+ Uninstalling SecureLogin

+ Extending the OpenLDAP Schema to Support Securelogin

Additional Documentation

For the latest version of this guide and other SecureLogin documentation resources, see the
SecureLogin Documentation and keep up to date on patches and versions of both SecurelLogin and
the host operating system.

Contact Information

We want to hear your comments and suggestions about this book and the other documentation
included with this product. You can use the comment on this topic link at the bottom of each page of
the online documentation, or send an email to Documentation-Feedback@microfocus.com.

For specific product issues, contact Micro Focus Customer Care at https://www.microfocus.com/
support-and-services/.

About This Guide
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1.1

1.2

Getting Started

+ Section 1.1, “System Requirements,” on page 9

+ Section 1.2, “Setting Up a Passphrase,” on page 9

System Requirements

For information about hardware and software configurations required for the successful installation
and deployment of Securelogin, see Net/Q SecurelLogin System Requirements.

Setting Up a Passphrase

A Securelogin passphrase is a combination of question and response, used as an alternative form of
identity verification. The passphrase functionality protects SecurelLogin credentials from
unauthorized access and enables users to access SecurelLogin in the offline mode. Passphrases can
also be used as a substitute authentication mode. For example, when users forget the password.
Depending on your preferences, SecureLogin passphrase questions can be generated by the
administrator or the user.

During the installation, the passphrase security is enabled to enforce the passphrase setup during
the initial login. You can disable the passphrase policy by deselecting Use Passphrase Policy in the
Advanced Settings pane of the Administrative Management utility. If a passphrase has previously

been configured, this dialog box does not display and the installation is complete.

In the initial login to Securelogin, all users are requested to save a passphrase response. It is
important that this response is easy to recall because it cannot be viewed by anyone.

WARNING: Remember the passphrase answer. You cannot access the answer if you forget it.

To set up a passphrase:

1 Specify a question in the Enter a question field.
2 Specify an answer in the Enter the answer field.
3 Specify the answer again in the Confirm the answer field.

4 Click OK. Your passphrase is saved and SecurelLogin is installed on the administration
workstation.

Getting Started
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2.1

2.2

Introduction

NetlQ Securelogin is a credential management tool that enhances the network security. It is an
enterprise single sign-on (SSO) product. It provides authentication solutions to web, Windows, host,
and legacy application-based SSO. It functions as an identity overseer for all the systems that users
access.

Securelogin securely manages and encrypts the authentication information in the directory. It stores
user names and passwords and automatically retrieves them for users when required.

Features of SecurelLogin Installer

Evaluation build for 30-days trial: Using the evaluation version, you can try out all features of
Securelogin in the 30-day trial mode without buying licenses. Contact the Micro Focus support to
get the evaluation version.

Upgrading to a license version from the evaluation version is not supported. If you plan to buy the
licenses of Securelogin, uninstall the evaluation version and install the licensed version.

Audit log for Windows and Syslog messages : In the Custom Setup window, the Auditing feature
helps to configure syslog, and enable or disable the logging Windows event messages.

Configure Syslog Server during installation: The Syslog server is installed and configured during the
installation of SecurelLogin. The Syslog server can be configured by using the installation wizard,
command line and by modifying the registry settings.

Option to Disable Logging of Windows Event Messages By Using the Installation Wizard: In NetlQ
Securelogin, logging of windows event messages are enabled by default. SecureLogin provides a
facility to disable logging of Windows event messages during installation.

Using this option, administrators can decide if workstation event messages should be logged for each
workstation. For more information, see Section 2.3, “Logging Event Messages,” on page 13.

Advanced Authentication: In the Custom Setup window, the Advanced Authentication feature
supports different methods of authentication for logging in to Active Directory, ADAM/AD LS,
eDirectory and LDAP v3.

Installation Overview

1. Launch the Securelogin executable.

2. Select the datastore. Valid datastore options are:
+ Microsoft Active Directory
+ Microsoft ADAM/AD LS

NetlQ eDirectory with Novell Client

NetlQ eDirectory with LDAP

*

*

Introduction 11
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+ LDAP v3 (non-eDirectory)
+ Standalone
3. If you select to install in NetlQ eDirectory with Novell Client or NetlQ eDirectory with LDAP
mode, you can enable SecretStore.
4. Select the features you want to install from the Custom Setup screen. Click the feature select it.
If Novell Client is installed, the default account association is Novell Client.
6. If you select to install in an Active Directory or Active Directory Application Environment, the
windows authentication credentials are used for seamless sign-on.

v

Figure 2-1 Installing Features in an Active Directory environment

Active Directory ARSI
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7. While installing in an LDAP mode, select Credential Manager, Credential Provider, or Application
mode.

Figure 2-2 Seamless Sign-on Using Novell Client or LDAP
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2.3

2.3.1

Logging Event Messages

You can log events through Windows event log and view the events by using Event Viewer. In NetlQ
Securelogin, logging of windows event messages are enabled by default. If you require to send the
events through Syslog, use one of the following options:

Forward to Syslog Server: Selecting this option allows only a single connection from a SecurelLogin
client to Syslog server and caches the events in EventLog. For example, on a citrix or a terminal
server, where users are allowed to access a single service there will be a single connection to Syslog
and all the events get cached to EventLog. This option is disabled by default.

Syslog Server: Selecting this option connects each SecurelLogin client to Syslog server and the events
gets cached only for an active SecureLogin session. This option is disabled by default.

Securelogin provides a facility to disable logging of Windows event messages during installation.
Using this option administrators can decide if workstation event messages should be logged for each
workstation.

Disabling Logging to Windows Event Log by Using the Installation
Wizard

1 Launch the NetlQ Securelogin installation wizard. Review and accept the license agreement.
2 Select the datastore.

3 In the Custom Setup screen, traverse to the Auditing menu option. Windows EventLog is
enabled by default. Deselect the option to stop logging of windows event logs to the
workstation.

NOTE: If you have disabled logging of Windows event messages using the Installation Wizard,
you must run the installation wizard once again if you want to enable it.

Installing SecureLogin with the Windows EventLog option enabled, updates the registry and creates a
registry entry named EnableWindowsEventLog. The details of this registry are as follows:

Purpose Enable/Disable sending audit events to windows event logger
Location HKEY LOCAL MACHINE\Software\Protocom\SecureLogin
Type REG_DWORD

Value 1- Enable

0 - Disable (Default)o

This setting, when used in conjunction with the Enable logging to Windows Event log preference,
helps to log Windows event messages for a specific user.

NOTE: Securelogin preferences can be managed by using administrative utilities, such as SLManager.
To ensure that administrative utilities are installed, select the Directory Administration Tools option
while installing SecureLogin.

Introduction 13



2.3.2 Disabling Logging to Windows Event Log After the Installation

1 Launch the Administrative Utility.

2 Click Preferences > Auditing. The Enable logging to Windows EventLog option is enabled by
default. To disable logging, deselect this option.

2.4 Logging of Syslog Audit Messages

Securelogin includes a facility to log Syslog audit messages. During installation, NetlQ Securelogin is
configured on each host such as Citrix, terminal servers, and so on to connect and generate logs to a
specific syslog service.

This enhances the auditing mechanism and removes the need of having another Security
Information and Event Management (SIEM) solution.

2.4.1 Installing and Configuring Syslog Auditing

+ “Installing Syslog Auditing Feature Using the Windows Installer Wizard” on page 14
+ “Configuring Syslog Auditing Using the Windows Installer Command-Line Option” on page 15
+ “Modifying the Registry Settings” on page 15

Installing Syslog Auditing Feature Using the Windows Installer Wizard

1 Select Syslog Server option under Auditing to enable the Syslog auditing feature.

If the Forward to Syslog Server option under Windows EventLog is also selected, duplicate
events gets generated in the Syslog server. For more information, see Logging Event Messages.

2 Specify the name of the server that is to be configured as the Syslog server. By default the Syslog
server address is set to 1ocalhost and the supported protocols are UDP, and TLS.

By default, the Syslog server listens to default ports for each protocol. Such as, for UDP the
Syslog server listens to 514 and for TLS the server listens to 6514.

3 Select the language in which the event message should be sent to Syslog server. The supported
languages are:

¢+ German
+ English
+ Spanish
* French
+ Japanese
+ Portuguese
+ Chinese (Traditional)
¢ Polish
The default language is English.
4 Click Next to install the Syslog Auditing feature on the workstation.

14 Introduction



Configuring Syslog Auditing Using the Windows Installer Command-Line
Option

To configure Syslog using command-line option, use the following command:

APPENDLOCAL=Syslog SYSLOGSERVERURI=protocol-type://server-name:port-
number:X SYSLOGLANGUAGEID=<language-code>

Replace language-code with the code from the following supported languages:

+ 1028 - Chinese (Traditional)
¢+ 1031- German

+ 1033 - English (Default)

+ 1034 - Spanish

+ 1036 - French

¢ 1041 - Japanese

+ 1045 - Polish

¢ 1046 - Portuguese

For example: APPENDLOCAL=Syslog SYSLOGSERVERURI=udp://localhost:514:1045

Modifying the Registry Settings
To enable/ disable Syslog audit messages, create the following registry entries:

EnableSysLog

Purpose Enable/Disable sending audit events to the syslog server

Location = HKEY LOCAL MACHINE\Software\Protocom\SecureLogin
Type REG_DWORD

Value 1- Enable

0 - Disable (Default)

SyslogServerUri

Purpose Syslog server details in the form of URI

Location HKEY LOCAL MACHINE\Software\Protocom\SecureLogin

Type REG_SZ

Value <protocol-type>://<server-name>:<port-number>:X_SYSLOGLANGUAGEID=<language-code>

For example: udp://syslog.myserver.com:514:X SYSLOGLANGUAGEID=1033

Introduction
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SyslogMessagelanguageld

Purpose Language that should be used in sending the event message to syslog server.
Location HKEY LOCAL MACHINE\SOFTWARE\Protocom\SecureLogin

Type REG_DWORD

Value Decimal value of the respective language as mentioned in section 1.3.1.2.

2.4.2 Enabling Logging to Syslog

1 Launch an Administrative Utility.

2 Click Preferences > Auditing. The Enable logging to Syslog Server option is an administrator
setting that is disabled by default. To enable logging of Syslog events on the user’s workstation,
select this option and set it to Yes.

2.5 Managing Log Settings for SecureLogin Components

The NSL Log Manager tool is used for managing the log settings for SecureLogin components. This
section explains the NSL Log Manager tool.

This tool is included as part of the Securelogin installer. To launch this tool, run the
slLoggingManager.exe file from SecureLoginTools\slLoggingManager.

NSL Log Manager can perform the following actions:

+ Configure the log settings for Novell SecureLogin components such as LDAP Client (NLdapAuth).
+ Provide support for additional components, which are missing in the SLLoggingManager tool
shipped with Securelogin.

To use NSL Log Manager, perform the following steps:

1 Launch the NSLLogManager.exe file.

It displays the status of log settings for SecureLogin components, such as LDAP Client
(NLdapAuth).

2 From the Component list, select the component for which you want to enable the log.
3 From the list in the Log Settings column, select Disabled or Enabled as per your requirement.

The new setting is automatically updated in the registry.

Introduction



3.1

3.1.1

3.1.2

Installing and Deploying in the SecurelLogin
Advanced Edition Environment

This section provides information about installing and deploying SecurelLogin in the Advanced
Edition (Azure Active Directory) environment.

+ Before You Begin

+ Installing Securelogin

+ Deploying

Before You Begin

You must install the Securelogin client after you have installed and configured Advanced Edition. For
information about installing and configuring Advanced Edition, see SecurelLogin 9 Advanced Edition
Installation and Configuration Guide.

+ Prerequisites for Installing SecurelLogin in the Advanced Edition Environment

+ Installation Overview

Prerequisites for Installing SecureLogin in the Advanced Edition
Environment

O Advanced Edition is installed and configured. See SecurelLogin 9 Advanced Edition Installation
and Configuration Guide.

O Ensure that you meet the hardware and software requirements listed in Net/Q SecurelLogin
System Requirements.

O A minimum of 128 MB is required in the Windows directory. An additional 55 MB is required for
temporary files, which is deleted after the installation is complete.

O You have administrator-level access to Advanced Edition and administration workstations.

O Join the client devices (administration workstations, user workstations, or mobile devices) to
Azure AD. For more information, see Join your work device to your organization's network.

O Install Java 1.7 or 1.8 to enable single sign-on (SSO) to Java applications on the workstation.

Installation Overview

1 Uninstall any Securelogin version prior to 3.5.x.

2 If the application type is enabled for SSO, install Citrix or Terminal Services clients.
3 Install Java 1.7 or 1.8 on the workstations, if SSO to Java applications is required.
4 Install SecureLogin on the administration workstation.

5 Create test users on the administration workstations.

Installing and Deploying in the SecureLogin Advanced Edition Environment 17
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6 Define and configure the SecurelLogin user environment, including enabling the required
applications for SSO.

7 Copy the test users’ configuration to relevant objects.

8 Install the Securelogin application on user workstations.

3.2 Installing Securelogin

¢ Installing SecureLogin on Administrator Workstations
¢ Installing SecureLogin on a User Workstation

+ Installing SecureLogin for Mobile Users and Notebook Users

3.2.1 Installing SecureLogin on Administrator Workstations

NOTE: The procedures for installing SecureLogin on administrator workstations and user
workstations are the same.

Run the NetIQSecurelLogin.exe file.

Accept the license agreement and click Next.

Select SecureLogin Advanced Edition (Azure) and click Next.
Click Install.

Click Next to view the Custom Setup screen.

Select the required features.

N o 1 A W N R

Secureloginis installed inthe C:\Program Files\NetIQ\SecureLogin folder by default.
If you want to change the location, click Browse and specify a different location. Select the
features you want to install and click Next.

8 Under Server, specify the following details:

Field Description

Address Specify the URL of the Advanced Edition web console.

For example, my-sl-advanced.eastus2.cloudapp.azure.com.

Port 443

9 Click Next > Next > Install.
10 Click Finish.

3.2.2 Installing SecureLogin on a User Workstation

Installing SecureLogin on user workstations uses the same procedure as Installing SecureLogin on
Administrator Workstations. Use industry standard application distribution packages, such as
Microsoft IntelliMirror, System Management Server, or ZENWorks to deploy and manage
Securelogin across large enterprises.
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3.2.3

3.3

Installing SecureLogin for Mobile Users and Notebook Users

Installing SecurelLogin for mobile and remote users uses the same procedure as Installing
Securelogin on Administrator Workstations.

However, ensure that the cache is saved locally, or users cannot access applications when they are
disconnected from the network. By default, the Enable cache file setting in Preferences > General is
set to Yes. You can set this at the Organization Unit level or on a per-user basis.

Deploying
After you successfully install SecureLogin on a user workstation, set up a passphrase for the user.

For more information about setting up a passphrase, see Setting Up a Passphrase.

Installing and Deploying in the SecurelLogin Advanced Edition Environment

19



20 Installing and Deploying in the SecureLogin Advanced Edition Environment



4.1

4.1.1

Installing and Configuring in Active
Directory Environment

The examples in this section apply to Microsoft Windows 2003 and 2008 Active Directory
environments with a directory server managed through an administrative workstation.

+ Section 4.1, “Before You Begin,” on page 21

+ Section 4.2, “Configuring,” on page 23

+ Section 4.3, “Installing,” on page 28

+ Section 4.4, “Deploying,” on page 29

Before You Begin

The following procedures apply to the standard configuration of a server managed through an
administration workstation. It also applies if your configuration does not separate the server from
the administration workstation.

In Active Directory’s MMC, the current datastore version (displayed in the Advanced Settings page)
might not update immediately when the directory database version is changed. To update, click OK,
then exit the MMC Properties dialog box.

+ Section 4.1.1, “Prerequisites,” on page 21

*

Section 4.1.2, “Requirements for Microsoft Windows Server,” on page 22

*

Section 4.1.3, “Installation Overview,” on page 22

*

Section 4.1.4, “Microsoft Active Directory,” on page 23

Prerequisites

+ Ensure that you meet the hardware and software requirements listed in “Net/Q SecureLogin
System Requirements”.

+ A minimum of 128 MB is required in the Windows directory. An additional 55 MB is required for
temporary files, which is deleted after installation is complete.

+ You must have administrator-level access to the server and the administration workstations.

+ Back up the existing directory.

+ You must install Java 1.7 or 1.8 to enable single sign-on to Java applications on the workstation.
+ For multiple-directory environments:

+ |dentify the domain controller to determine the directory where you will install
SecurelLogin and the order of replication.

+ Have access to the domain controller.
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4.1.3

Requirements for Microsoft Windows Server

The following information applies to the configuration of a server in a Microsoft Windows Server
2003 or Windows Server 2008 operating system environment.

+ “Internet Explorer Enhanced Security” on page 22

+ “Enabling Single Sign-On for Internet Explorer” on page 22

Internet Explorer Enhanced Security

By default, Microsoft Windows Server 2008 and 2012 install the Internet Explorer Enhanced Security
Configuration, which is designed to decrease the exposure of enterprise servers to potential attacks
that might occur through the Web content and application scripts.

If you are using Internet Explorer, some websites might not perform as expected when Securelogin
is installed. Add-ons and Browser Help Objects (BHOs), such as SSO might not be fully functional.

For more information, see the Microsoft Support Web site for knowledge base article 815141.

Enabling Single Sign-On for Internet Explorer

To enable single sign-on for Internet Explorer, disable the Microsoft’s Internet Explorer Enhanced
Security Configuration before deploying SecureLogin.

You can do this by:

+ “Enabling Web Browser Extensions” on page 22

+ “Enabling Browser Help Objects in Internet Explorer” on page 22

Enabling Web Browser Extensions

+ On both Windows Server 2008: Go to Internet Options > Advanced > Browsing, then select the
Enable Third party web browser extension (requires restart) option.

Enabling Browser Help Objects in Internet Explorer

+ In Internet Explorer 8: Open Internet Explorer, go to Tools > Internet Options > Advanced >
under Browsing section, select Enable third party web browser extensions option.

After Securelogin is installed, open Internet Explorer, go to Tools > Manage Add-ons > Tools and
Extensions and check if the SecurelLogin IE SSO Helper object Class entryis
displayed as Enabled.

Installation Overview

1 Uninstall any SecurelLogin version prior to 3.5.x.

2 Ensure that Microsoft Management Console (MMC) Active Directory plug-ins are installed on
the administration workstation.

3 Extend the directory schema for SecurelLogin versions prior to 6.0.

4 If the application type is enabled for single sign-on, install Citrix or Terminal Services clients.
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4.14

4.2

Install Java 1.7 or 1.8 on the server and workstations, if SSO to Java applications is required.
Install SecurelLogin on the administration workstation.

Create test users on the administration workstations.

00 N o u

Define and configure the SecureLogin user environment, including enabling the required
applications for single sign-on.

9 Copy the test users’ configuration to relevant objects.

10 Install the Securelogin application on user workstations.

Microsoft Active Directory

+ “Securelogin on Windows” on page 23
+ “LDAP Environment” on page 23

+ “ADAM” on page 23

SecureLogin on Windows

If an error appears during an attempted login immediately after you install SecureLogin on an Active
Directory server, click OK in the message, wait for a few minutes, then try again. This error occurs
because Active Directory takes time to synchronize. If the error continues, restart the server.

LDAP Environment

Securelogin supports Microsoft Active Directory operating in an LDAP environment. There are no
additional installation or configuration requirements. The only variation to the install is that you
select LDAP and not Microsoft Active Directory as the installation platform. For details, see
Extending the LDAP Directory Schema and Assigning Rights on the Server.

ADAM

Securelogin supports deployment in an ADAM instance. For more information, see Configuring,
Installing, and Deploying In Active Directory Lightweight Directory Services.

Configuring

Securelogin uses the directory structure and administration tools to provide centralized
management and deployment of users. In the Active Directory environment, SecurelLogin installs an
additional tab to the Active Directory Users and Computers User Properties dialog box. This dialog
box provides administrative functionality in the same utility you currently use to manage your Active
Directory users.

Before you install SecurelLogin, you must first extend the Active Directory schema. You can also
configure the user’s environment or create roaming profiles.

+ Section 4.2.1, “Extending the Active Directory Schema and Assigning Rights,” on page 24
¢ Section 4.2.2, “Configuring a User’s Environment,” on page 27

+ Section 4.2.3, “Configuring Roaming Profiles,” on page 28
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4.2.1

Extending the Active Directory Schema and Assigning Rights

Securelogin leverages the directory to store and manage Securelogin data. SecurelLogin extends the
directory schema to add six SecurelLogin schema attributes where Securelogin data is stored.

After you extend the directory schema, you must give permissions to access objects, including group
policy, organizational units, and containers. Authorizing read or write rights to the SecurelLogin
directory schema attributes is referred to as assigning user rights.

The SecurelLogin Microsoft Active Directory schema extension executable extends the schema on
the server and enables you to assign user rights. You must determine which containers and
organizational units need SecurelLogin access, and you must know their distinguished name (DN),
because you must assign rights to each container and organizational unit separately.

You can also extend the Microsoft Active Directory schema to the root of the domain and assign
rights to each container and organizational unit below the root.

IMPORTANT: Consider the following information when you extend the schema:

+ If Securelogin version 3.5.x is installed, you do not need to extend the directory schema,
because the attributes are the same. However, any new directory objects such as organizational
units still require you to assign rights.

+ If the Microsoft Active Directory instance is deployed by copying and running the
adsscheme. exe file from another location, you must copy the entire folder containing the
Microsoft Active Directory schema and configuration files to the new preferred location. The
Microsoft Active Directory schema and configuration files must be located in the same folder in
order for the Active Directory instance to successfully deploy.

+ “Extending the Schema” on page 24
+ “Assigning User Rights” on page 25
+ “Refreshing the Directory Schema” on page 27

Extending the Schema

The following instructions apply to the configuration of the Microsoft Active Directory instance
stored and administered on a separate server from the Active Directory server domain controller.
1 Log in to the server as an administrator.
2 Click Schema Extension Tools > Active Directory Extension.
or

If you are installing from the Securelogin installer package, locate the SecurelLoginTools
folder and double-click adSchema . exe.

@ Securelogin - Active Directory Schema  [£3)

* Extend Active Directory Schema:

" Assign User Rights

OK | Cancel
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3 Select Extend Active Directory Schema.
4 Click OK.
The following Securelogin attributes are added to the Directory schema:
¢ Protocom-SSO-Auth-Data
+ Protocom-SSO-Entries
¢ Protocom-SSO-Entries-Checksum
¢ Protocom-SSO-Profile
¢ Protocom-SSO-SecurityPrefs
¢ Protocom-SSO-Security-Prefs-Checksum

A confirmation message is displayed.

IMPORTANT: If the Microsoft Active Directory instance is deployed by copying and running the
adsschema. exe file from another location, you must copy the entire folder containing the
Microsoft Active Directory Schema and configuration files to the new preferred location. The
Microsoft Active Directory Schema and configuration files must be located in the same folder in
order for the Active Directory instance to successfully deploy.

5 Click OK to return to the Active Directory Schema dialog box.

Now that directory schema is extended, you must assign access rights to the relevant containers
and organizational units.

If you have previously extended the schema, a message listing the existing schema appears.
Ignore this message.

6 Click OK in the Active Directory Schema dialog box.

7 Continue with “Assigning User Rights” on page 25 to assign user access rights to the relevant
containers and organizational units.

Assigning User Rights

You must assign permission to objects in the directory to store data against the new Securelogin
schema attributes. You assign rights to all objects that access SecurelLogin, including user objects,
containers, group policies, and organizational units.

When you assign rights to containers and organizational units, the rights filter down to all associated
user objects, so unless you are required to do so, it is not necessary to assign rights at the individual
user object level.

1 Run adsschema.exe, which is found in the Securelogin\Tools\Schema\ADS directory.

@ Securelogin - Active Directory Schema  [s5)

{* Bxtend Active Directory Schema

(" Assign User Rights

QK | Cancel
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2 Select Assign User Rights, then click OK. The Assign Rights to This Object dialog box is displayed.

Assign rights to this object X

Please enter a container object to assign rights to.
These rights will be inherited by all user objects below
this container.

Eg. “tn=users,dc=company,dc=com”

If you unchedk the AES Encryption box,
SecureLogin will use 3DES encryption,

[+ AES Encryption

QK | Cancel

For example, if you assign rights to Users container, the User container definition is:

cn=users, dc=www, dc=training, dc=com

To assign rights to an organizational unit, such as Marketing, in the domain www.company.com,
the definition is:

ou=marketing, dc=www, dc=company, dc=com

IMPORTANT: The AES Encryption option is selected by default to use AES256 Encryption. If you
unselect this option then the container will use 3DES encryption. It is recommended to use
AES256 encryption.

IMPORTANT: You can run adsschema.exe again with AES Encryption option unselected but it
does not change to 3DES encryption. Use s1lmanager.exe to enable 3DES encryption.

NOTE: Rights Assignment does not work on top level Domain (root) or Group. It is
recommended to assign rights on organizational unit using adsschema.exe.

Specify your container or organizational unit definition in the Assign rights to this object field.
The confirmation dialog box appears.

Click OK to return to the Active Directory Schema dialog box.

5 Repeat Step 2 to Step 4 to assign rights to all required user objects, containers and

organizational units.

If you see an error message indicating Error opening specified object: -
2147016661, it means that rights have already been assigned to the object.

If you see an error message indicating Error opening specified object: -214716656,
it means that you have attempted to assign rights to an object that does not exist in the
directory. Check your punctuation, syntax, and spelling, and repeat the procedure.

After all required rights are successfully assigned, click OK to return to the Active Directory
Schema dialog box.

Click Cancel.
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4.2.2

NOTE: You can extend rights to objects at any time after the schema is extended. If you add
organizational units, you need to rerun the adschema . exe tool and assign rights to the new object
to permit Securelogin data to write to the directory.

Refreshing the Directory Schema

1 Run Microsoft Management Console (MMC) and display the Active Directory Schema plug-in.
2 Right-click Active Directory Schema, then select Reload the Schema.

3 On the Console menu, click Exit to close the MMC.

In a multiple-server environment, schema updates occur on server replication.

Configuring a User’s Environment

Securelogin provides centralized management and deployment of user configuration by usingthe
directory structure and administration tools. In Active Directory environment, SecurelLogin installs
an additional tab to the Active Directory Users and Computers User Properties dialog box. This dialog
box provides SecureLogin administrative functionality in the same utility you currently use to
manage your Active Directory users.

Configuring a user's SecurelLogin environment includes:

+ Setting preferences.

+ Creating password policies (optional).

+ Enabling single sign-on to applications.

+ Creating passphrase questions for selection (optional).

Configure Securelogin on a test user account before installing SecureLogin on user workstations.

The following table shows the options available for deploying and distributing the user
configuration. For information on deploying and distributing configuration, see “Distributing
Configurations”in the Net/Q SecurelLogin 9.1 Administration Guide.

Table 4-1 Deployment and Distribution Options

User Configuration Options Description

Copy Settings Copies the SecurelLogin configuration from one object in the same
directory to another object

Export and import Distributes the configuration by using an XML file.
Directory object inheritance Inherits the configuration from a higher level directory object, such as a
Group policy.

Corporate Configuration redirection Specifies a directory object from which the configuration is inherited.
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4.2.3

4.3

43.1

Configuring Roaming Profiles

Enterprises often create roaming profiles for specific groups of users, defined by their organizational
role or function, such as field engineers connecting from remote locations or accounting staff
working at different locations. For these users, you can create a roaming profile and set the path to
the target user’s profile.

For more information about creating roaming profiles in an Active Directory environment, see the
Microsoft Support website. (http://support.microsoft.com/kb/314478)

NOTE: During loading, SecureLogin loads the users profile, effectively locking that profile and
preventing the users credential data from being copied to the roaming profile.

To prevent SecurelLogin from causing problems with existing user roaming profiles, select the enable
Roaming Profile feature.

This feature gets installed by default, if the workstation is a Citrix or Terminal Server. You can also set
the registry setting ForceHKLMandNoDPAPI to 1 for Roaming Profile activation, if it was not initially
installed.

Installing

After you have extended the Active Directory schema as described in “Extending the Schema” on
page 24 and assigned permissions to the required directory objects as described in Assigning User
Rights, you can install the SecurelLogin application on the administration and user workstations.

+ Section 4.3.1, “Installing on Administrator Workstations,” on page 28

+ Section 4.3.2, “Installing on a User Workstation,” on page 29

+ Section 4.3.3, “Installing for Mobile Users and Notebook Users,” on page 29

Installing on Administrator Workstations

NOTE: Procedures for installing on administrator workstations and user workstations are the same.

The following procedure uses the Microsoft Windows Vista 64-bit installer.

1 Runthe NetIQSecureLogin.exe file.
2 Accept the license agreement.Click Next. The License Agreement page is displayed.
3 Select Microsoft Active Directory. Click Install.
4 Click Next to view the Custom Setup screen.
This screen includes all the features. Select the required features.

5 Securelogin is by default installed in the C:\Program Files\NetIQ\SecureLogin folder.
If you want to change the location, click Browse and specify a different location. Select the
features you want to install and click Next.
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4.3.2 Installing on a User Workstation

Installing SecurelLogin on user workstations uses the same procedure as Installing. Use industry
standard application distribution packages such as Microsoft IntelliMirror, System Management
Server, or Novell ZENWorks to deploy and manage Securelogin across large enterprises.

4.3.3 Installing for Mobile Users and Notebook Users

Installing SecurelLogin for mobile and remote users uses the same procedure.

However, ensure that the cache is saved locally, or users cannot access applications when they are
disconnected from the network. By default, the Enable cache file setting in the Preferences in
Preferences > General is set to Yes. You can set this at either the Organization Unit level or on a per-
user basis.

4.4 Deploying

After you have successfully installed SecureLogin on a user workstation, you can set up a passphrase
for the user.

For information about setting up a passphrase, see Setting Up a Passphrase.
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Configuring, Installing, and Deploying In
Active Directory Lightweight Directory
Services

This section provides information on configuring, installing, and deploying SecurelLogin in Active
Directory Application Mode (ADAM) or Active Directory Lightweight Directory Services (AD LDS).

The instructions and examples provided in this section apply to Microsoft Windows Active Directory
environments with a directory server managed through an administration workstation.

Securelogin supports deployment in an ADAM instance. Active Directory is responsible for the
network authentication while ADAM stores and provides SecurelLogin configuration data, settings,
policies, and application definition. For example, if a user logs in to the network and authenticates
successfully to Active Directory, the user can then access ADAM for the user’s single sign-on data.

For comprehensive information on ADAM, see Microsoft website.

¢ Section 5.1, “Prerequisites,” on page 31

+ Section 5.2, “Language Support,” on page 32

+ Section 5.3, “Supported Platforms,” on page 32

+ Section 5.4, “ADAMconfig.exe and LDIFDE.exe,” on page 32
+ Section 5.5, “Configuring,” on page 33

+ Section 5.6, “Installing,” on page 41

+ Section 5.7, “Deploying,” on page 42

5.1 Prerequisites

+ Ensure that you meet the hardware and software requirements listed in “Net/Q SecureLogin
System Requirements”.

+ Ensure that your operating system has the latest version of Microsoft Windows Installer.
+ Download and save the ADAM application.
You can download the ADAM application from Microsoft Download Center.
+ Install AD LDS server role. For the installation procedure, refer Microsoft website
+ Assign permissions to a network service account.
¢ Create an ADAM instance.

+ Back up the existing Active Directory server.
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5.2

5.3

5.4

+ For multiple-directory environments:

+ |dentify the domain controller to determine the directory where you will install
SecurelLogin and the order of replication.

+ Have access to the domain controller.

+ From Securelogin 8.8 onwards, TLS 1.2 is utilized for secured communication over the
networks. It is not recommended to use TLS 1.1 because it is less secure than TLS 1.2. However,
if your environment does not allow using TLS 1.2, see Enabling TLS 1.1 In SecureLogin.

Language Support

Support for SecurelLogin deployed in ADAM mode is provided in English only.

Supported Platforms

+ Microsoft Windows Server 2016
+ Microsoft Windows Server 2012 R2
+ Microsoft Windows Server 2008 R2

ADAMconfig.exe and LDIFDE.exe

ADAMconfig.exe relies on Microsoft’s LDAP Data Interchange Format Directory Extension
(1difde.exe) to run properly. However Microsoft distributes two versions of this file, one for
Active Directory and another for ADAM. Only the version distributed with an ADAM installation is
suitable for use with ADAMconfig.exe. You must be located in the same folder as
ADAMconfig.exe unless you have edited the default system path.

During the install process, SecureLogin checks for 1difde.exe file. If the required version is not
found, the following warning is displayed.

Figure 5-1 Warning message

9 The version of Idifde.exe inuse on the host O35 is missing o invalid,

The Microsaft import/expart tility: [difde . exe is required ko impork
and export From Active Directory inbo DA,

Microsoft distributes multiple versions of this utility, The wersion
distributed. with ADAMis required. IF ADAM is installed it will
usually be here:

ciwindowsADar Idifde. exe

Pledse copy it'tothe same directory ds AdamConfig.exe,

It i strongly advised ko rectify this problérn before continuing,

bro-weow sill- wish:bo continue?

Yes [i/lx}
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If the correct version of Idifde.exe is installed in a customized file path, click Yes to continue.
Otherwise, click No. It launches the ADAM configuration wizard.

Figure 5-2 ADAM Configuration Wizard

ﬂ Securelogin ADAM Configuration wizard x

a NetiQ. Microsoft Active Directory containers/organizational units

Each Microsoft Active Directory domain; container or organizational
O unit that contains Securelogin users must be identfied in the

u following list

NetlQ® CMN=Users, DC=NSLBLRQA.DC=COM
Securelogin

if you uncheck the AES Encryption box, SecureLogin will use 3DES
encryption.

W AESEncoption | Add.. |  Edi. | Femowe |
< Badk | Mext = I Firish | Cancel |

IMPORTANT: The AES Encryption option is selected by default. If you unselect this option then the
container will use 3DES encryption. It is recommended to use AES Encryption for new containers and
new deployments.

If you run ADAMconfig.exe with AES Encryption option unselected, it will not use 3DES encryption.
Use slmanager.exe to enable 3DES or AES encryption. It is recommended to use AES256
encryption.

IMPORTANT: You can run ADAMconfig.exe on existing containers with AES Encryption option
selected but it does not change the default old encryption. Use slmanager.exe to enable AES
Encryption for existing containers.

Configuring

The instructions provided in this section apply to the configuration of the ADAM instance stored and
administered on a separate server from the Active Directory server domain controller. Follow the
same instructions even if your configuration does not separate the Active Directory server and the
ADAM instance server.

Configuring, Installing, and Deploying In Active Directory Lightweight Directory Services 33



Active Directory and AD LDS instance

SecurelLogin supports deployment in an AD LDS instance. Active Directory is responsible for network
authentication, while AD LDS is responsible for storing and providing the SecurelLogin configuration
data, setting, policies, and application definitions. For example, if a user logs in to the network and
authenticates successfully to Active Directory, the user can then access AD LDS for the user’s single
sign-on data.

For more information on AD LDS, see Microsoft website.

You can download the ADAM application from the Microsoft website. (https://www.microsoft.com/
en-in/download/details.aspx?id=4201)

Also read the ADAM release notes from the ADAM Service Pack 1 available at the Microsoft
Knowledge Base article KB902838. (http://support.microsoft.com/kb/902838)

The following are the tasks involved in configuring SecureLogin in an ADAM environment:

+ Section 5.5.1, “Creating a Network Service Account and Assigning Permissions,” on page 34
¢ Section 5.5.2, “Configuring ADAM Schema,” on page 35

¢ Section 5.5.3, “Creating an ADAM Instance,” on page 35

+ Section 5.5.4, “Extending the Schema by Using ADAM Configuration Wizard,” on page 37

¢ Section 5.5.5, “Enabling TLS 1.1 In Securelogin,” on page 41

5.5.1 Creating a Network Service Account and Assigning Permissions

A service account is an user account that is created explicitly to provide a security context for
services running on Microsoft Windows Server 2003. The application pools use service accounts to
assign permissions to Web sites and applications running on Internet Information Services (IIS). You
can manage service accounts individually to determine the level of access for each of the application
pool in a distributed environment.

Creating a Network Service Account enables the ADAM instance. To create a Network Service
Account:

1 Click Start > All Programs > Administrative Tools > Active Directory Users and Computers. The
Active Directory Users and Computers page is displayed.
2 Select View > Advanced Features. The Advanced Features option is enabled by default.

3 Select the Domain Controllers folder and locate the Domain Controller of your single sign-on
enabled domain.

4 Right-click the Domain Controller and select Properties. The [Domain] Properties page is
displayed.

5 Select the Security tab.
If the Network Service account is not on the list of Group or user names, add it.
6 Select the Network Service account.
7 In the Permissions for Administrators section, select Allow to Create All Child Objects.

8 In the Permissions for Administrators field, select Allow to Delete All Child Objects.
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NOTE: Selecting Delete All Child Objects has no effect for SecureLogin, but allows the ADAM
instance to be cleaned properly when it is uninstalled.

9 Click OK to close the [Domain] Properties dialog box.

5.5.2 Configuring ADAM Schema

Securelogin leverages the directory to store and manage Securelogin data. Six schema attributes
are added to the directory schema. After the ADAM schema has been extended with these
attributes the relevant containers, organizational units (ou) and user objects must be permitted to
Read and Write Securelogin data. The SecureLogin ADAM Configuration Wizard automatically
extends the ADAM instance schema and assigns directory access permissions to selected objects.

The following are the attributes added to the schema:

¢ Protocom-SSO-Auth-Data

¢ Protocom-SSO-Entries

+ Protocom-SSO-SecurityPrefs

+ Protocom-SSO-Profile

* Protocom-SSO-Entries-Checksum

+ Protocom-SSO-Security-Prefs-Checksum

5.5.3 Creating an ADAM Instance

Browse to the ADAM set up file that you downloaded from the Microsoft website.
Double-click to run the ADAMredistX86.exe file.

Click Next.

Accept the license agreement, then click Next.

Select the ADAM and ADAM administration tools option.

Click Next.

Select A unique instance.

In the Instance name field, specify a name for the ADAM instance.

Click Next.
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In LDAP port number, specify the ADAM instance port number.
In the SSL port number, specify the ADAM instance SSL port number.

NOTE: The default LDAP port number is 50000 and the SLL port number is 50001. However if
Active Directory is not installed on your workstation, the default LDAP port number is 389. The
default SSL port number is 636.

It is recommended to use the default values. However if required, the values can be manually
changed.

IMPORTANT: Ensure to make a note of the LDAP port number and the SSL port number because
this information is required for further configuration.
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11 Click Next.
12 Select No, do not create an application directory partition.
13 Click Next.

14 Accept the default locations for ADAM files in the Data files and Data recovery files fields or click
Browse to select an alternate location.

15 Click Next.
16 Select the Network service account.
or
Select This account and provide the credentials for the selected service account.

We recommend you to select Network service account. Nevertheless, you can specify an
account with a static password.

NOTE: The selected service account must have permissions to register a Service Connection
Point (SCP) and permission to install SecureLogin.

17 Click Next.
18 Select Currently logged on user: SECURELOGIN\Administrator.

NOTE: The selected account must have administrator level permissions. In this example, the
default is selected as the current user. So, the administrator administers this ADAM instance.

or

If an alternative account or group is preferred, select This account and specify the account or
group name and credentials.

19 Click Next.
20 Select Do not import LDIF files for the instance of ADAM.
21 Click Next.

22 Review the setup options in the Selections window to confirm that the required options are
selected.

23 Click Next to continue with the installation.

or

Click Back to change selected options and continue the installation.
24 Click Next after confirming the ADAM instance creation settings.

25 Click Finish to create the ADAM instance. The Completing the Active Directory Application
Environment Setup Wizard page is displayed after the ADAM instance is created.

If required, you can review the Windows Event log to ensure the ADAM instance is created
without errors.

36 Configuring, Installing, and Deploying In Active Directory Lightweight Directory Services



Reviewing the Windows Event Log

1 Go to From the Windows Start menu, select Programs > Administrative Tools > Event Viewer.
The Windows Event Viewer displays with the ADAM (Instance#) displayed in the Event Viewer
hierarchy.

2 Double-click ADAM (Instance#) to view the Event log.
If an error icon is displayed, double-click to view the error details.
After the ADAM instance is successfully created, execute the instructions provided Section 5.5.4,

“Extending the Schema by Using ADAM Configuration Wizard,” on page 37 to automatically extend
the ADAM instance schema and assign Read and Write Rights to directory user objects.

5.5.4 Extending the Schema by Using ADAM Configuration Wizard

The SecurelLogin ADAM configuration wizard extends the ADAM directory schema with SecurelLogin
attributes, creates ADAM partitions, and assigns selected directory objects read and write
permissions to the Securelogin attributes. The wizards creates corresponding user proxy objects in
Active Directory. This includes the directory hierarchy to the ADAM instance. This can be used to
synchronize user object structure after the initial configuration of SecurelLogin.

The ADAM schema can be extended manually at the command line using the MSUserProxy. LDF
and sso-adam-schema.LDF files. These files are located in the
\SecureLogin\Tools\Schema\ADAM folder of the SecureLogin installer package. We
recommend that you perform this procedure with the assistance of our Technical Support.

Prerequisites

Before running the SecurelLogin ADAM Configuration Wizard:
1. Copy the AdamConfig.exe file found in \SecureLogin\Tools\Schema\ADAM to server or
the administrator workstation.

2. Copy dsacls.exe from Windows Support Tools to the ADAM folder on the server or
Administrator workstation.

Using the ADAM Configuration Wizard

The ADAM Configuration Wizard extends the ADAM directory schema with Securelogin attributes,
creates ADAM partitions, and assigns selected directory objects with read and write permissions to
the Securelogin attributes.

The wizard creates corresponding user proxy objects for user objects in Active Directory, including
the directory hierarchy to the ADAM instance and can be used to synchronize user object structure
after initial configuration of Securelogin.

To run the ADAM configuration wizard:

1 Loginto the ADAM instance, server, or the administration workstation (if it is separate) as an
administrator or an user with administrator permissions.

2 Browse to the AdamConfig.exe file, double-click to run it. The Welcome to the Securelogin
ADAM Configuration Wizard page is displayed.
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Ensure that you have all the Active Directory and ADAM administrator account details required.

NOTE: The ADAM schema can be extended manually at the command line using the MS-
UserProxy.ldf and sso-adam-schema. 1df files. These files are located in the Tools
folder of the installer package.

3 Click Next.
4 Configure ADAM instance for NetlQ Securelogin.

Select this option during the first instance of configuration. Although the ADAM configuration is
required only once, selection of this option on subsequent executions does not have any
adverse effects.

The ADAM configuration wizard copies across the selected Active Directory user data to the
ADAM instance, including the directory hierarchy.

NOTE: Directory synchronization for a large number of users can adversely affect the network
performance. You can delay the directory synchronization to a more convenient time.

You can run the ADAM configuration wizard at any time to synchronize the updated Active
Directory user data.

5 Select the Configure Microsoft Active Directory synchronization option.

6 (Optional) Select Synchronize now option.

NOTE: Each time a new organizational unit or user object is created in Active Directory, the
ADAM configuration wizard or the SyncAdam. cmd command file must be executed to
synchronize with the ADAM instance and assigned read and write permissions.

The SyncAdam. cmd cannot be run before running the ADAM configuration wizard.

7 Click Next. The Microsoft Active Directory user account page is displayed.
8 Select Current Microsoft Active Directory, the click Next.
or

Select Select Microsoft Active Directory user account and specify the account details in the User,
Password, and Domain fields, then click Next. The ADAM instance location page is displayed.

NOTE: The account selected in this page is used to access and copy the Active Directory object
data for synchronization with the ADAM instance, so it must have Read permission. This
account must not have Write permission.

By default, the current account (that is, the one to which you are logged in) is selected.
However, any user account that has Active Directory read permission is valid.

9 Click Next. The ADAM instance location page is displayed.

10 Accept the default values or specify the alternative Server and Port values as required, then
click Next.

+ The default server value is localhost. Select an alternate server if you are hosting your
ADAM instance on another computer.

+ The default port value is 50000. Specify an alternate port number if this is not the ADAM
instance server port.

11 Click Next. The Microsoft Active Directory containers/organizational units page is displayed.
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All containers and organizational units that include SecurelLogin users are specified here, so you
can assign Securelogin rights and select for Microsoft Active Directory synchronization.

12 Click the Add.The Domain, Container or Organizational unit dialog box is displayed.

13 Specify the full distinguished name in the Enter distinguished name of domain, container or
organizational unit field.

14 Click OK.

If the specified distinguished name of the domain, container, or organizational unit is invalid, an
error message is displayed. In that case, click OK. You return to the dialog box. Specify the
correct distinguished name of the domain, container, or organizational unit.

15 Click OK when the required objects are added to the list.
Review the selected configuration options.
16 Click Back to change details or click Finish finish the configuration.

The SecureLogin ADAM Configuration - Termination dialog box is displayed if the configuration
was not able to complete successfully. If this occurs, review the text box to investigate cause of
termination. If a solution to the problem is determined, click Close and repeat execution of the
SecurelLogin ADAM Configuration Wizard.

17 Click Close.

Viewing Objects Using the ADAM ADSI Edit Tool

The ADSI Edit Tool is a Microsoft Management Console (MMC) snap-in which you can use to view all
objects in the directory, including the schema and configuration information, modify objects, and set
access control lists on the objects.

You can use the ADSI Edit tool to check and review SecureLogin ADAM configuration. To do this:

Click Start > Programs > ADAM > ADAM ADSI Edit.

Select ADAM ADSI Edit in the hierarchy pane to view the ADAM Instance details.
Select Connect to from the Action menu.

Specify a name for the connection in the Connection name field.

Specify the ADAM instance server name in the Server name field.

Specify the ADAM instance port name in the Port name field.

Select Distinguished name (DN) or naming context.

Specify the Distinguished Name in the Distinguished name (DN) or naming context field.
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Select Connect using these credentials. This is the account through which you wish to connect to
the ADAM instance.

In this example, The account of the currently logged on user is selected
10 Click OK. The ADSI Edit tool displays the selected ADAM instance.
11 Right-click the Users container to display the context menu.

12 Select Properties. The CN=Users Properties dialog box is displayed.

To confirm if the schema attributes are added successfully or not, scroll down the Attributes table
window and verify if the six attributes in Section 5.5.2, “Configuring ADAM Schema,” on page 35 are
listed or not. Repeat this for each container and or organizational unit containing SecurelLogin users.
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If the attributes are not displayed, run the ADAM configuration wizard again and ensure that you
specify the correct container, organizational unit, and user objects.

Adding Users or User Groups to Manage SecureLogin In ADAM Instance

To assign LDS rights to a specific user or user group, perform the following steps:

1 Click Start > Administrative Tools > ADSI Edit.

2 Inthe console tree, click Configurations > CN=Roles.

3 Double-click CN=Administrators to open CN=Administrators Properties.
4 In Attribute Editor, select the member attribute and click Edit.

5 Click Add Windows Account... or Add DN... in the Multi-valued Distinguished Name With Security
Principal Editor window to add users or user groups that you want to assign LDS rights.

6 Click OK.

Synchronizing Data from Active Directory to an ADAM Instance

The Active Directory to ADAM Synchronizer is a command-line tool that synchronizes data from
Active Directory forest to a configuration set of an ADAM instance. You can use this to ensure that
new users are added to Active Directory have objects representing their SecurelLogin data created in
the ADAM instance.

To synchronize data from Active Directory to an ADAM instance:

1 Navigate to SecurelLogin\Tools of the SecurelLogin installation package.

2 Double-click the syncadam. cmd file.

After the synchronization is complete, you can look at the log file - SyncAdam. 1og, to ensure that
the synchronization process is complete.

It is recommended that you synchronize regularly, when new organizational units are created or
when Active Directory user are changed. You can add the process to the Windows Schedules Tasks.

During the synchronization, the following processes are automatically synchronized:

+ A new container or organizational unit in Active Directory is created as a corresponding
container in ADAM.

+ A new user in Active Directory is created as ADAM user proxy.

+ Arenamed user object in Active Directory causes the corresponding user proxy to be renamed
in ADAM.

+ A moved user object in Active Directory causes the corresponding user proxy to be moved in
ADAM. This requires both user object source container and destination container in
synchronization scope.
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5.5.5

5.6

5.6.1

However, the following processes are not automatically synchronized:

+ Deleted user objects in Active Directory are not deleted in ADAM by default. This is because od
security concerns. You can override this by manually editing SyncAdam.config. However, this is
not recommended unless there is a good reason because username might conflict with a
‘zombie’ user, or performance issues.

+ Deleted, moved, or renamed containers and organizational units in Active Directory are not
synchronized to ADAM. Changes to existing container or OU objects in Active Directory must be
manually synchronized to ADAM by using the ADSI Edit tool or any other directory editor. For
example, if an OU is renamed in Active Directory, it must be renamed in ADAM. Because of
security concerns, synchronization does not run if existing containers and OUs do not match in
Active Directory and ADAM.

Enabling TLS 1.1 In Securelogin

WARNING: Installing SecurelLogin with TLS 1.1 is less secure than using TLS 1.2. It can open your
deployment environment to security threats.

Perform the following steps to modify the registries. The registry modification is necessary to enable
TLS 1.1 in Securelogin.

1 Click Start > Run to open the Run dialog box.

2 Specify regedit and click OK to open Registry Editor.

3 Navigate to the

HKEY_LOCAL_MACHINE > SOFTWARE > Protocom > SecureLogin key.

4 Right click and click New > DWORD.

5 Rename the DWORD to AllowTLSv1.1.

6 Edit the AllowTLSv1.1 value to 1.

Installing

+ Section 5.6.1, “Installing on Administrator Workstations,” on page 41
+ Section 5.6.2, “Installing SecurelLogin on a User Workstation,” on page 42

+ Section 5.6.3, “Installing for Mobile Users and Notebooks,” on page 42

Installing on Administrator Workstations

The following procedures apply for manual installation and are applicable to installing SecurelLogin
on small number of workstations or notebook computers.

It is recommended that you deploy and manage SecurelLogin across large enterprise by using
industry standard application distribution packages such as Systems Management Server (SMS),
Novell ZENworks, and Microsoft IntelliMirror.

NOTE: The procedures for installing on administrator workstation and user workstations are the
same.
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The procedures explained in the following section uses the Microsoft Windows Vista 64-bit installer.

Log in to the workstation as an administrator.
Run the NetlQSecurelLogin.exe file.

Accept the license agreement.Click Next.
Click Next.

Select Microsoft ADAM/AD LS

Click Install.
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6 Click Next to view the Custom Setup screen.

7 Securelogin is by defaultinstalled in the C: \Program Files\NetIQ\SecureLogin folder. If
you want to change the location, click Browse and specify a different location. Select the
features you want to install and click Next.

5.6.2 Installing SecureLogin on a User Workstation

The procedure for installing SecurelLogin on a user workstation is the same as the procedure for a
administration workstation.

Follow the instructions given in Installing on Administrator Workstations.

5.6.3 Installing for Mobile Users and Notebooks

Installing SecureLogin for mobile users and notebooks follows the same procedure as explained in
Chapter 5.6, “Installing,” on page 41.

It is important that you save the cache locally. Otherwise, users who are disconnected from the
network are unable to access the applications. By default, the Enable cache in the Preferences
properties table option is set to Yes. You can set this at either the organizational unit level or on a
per-user basis.

5.7 Deploying
Securelogin provides centralized management and deployment of user configuration by using the

directory structure and administration tools.

You can manage users through the Administrative Management Utility accessed from the Windows
Start menu.

The following section explain the various tasks involved in deploying SecurelLogin in an ADAM
environment:

¢ Section 5.7.1, “Configuring a User’s Environment,” on page 43
+ Section 5.7.2, “Administering SecurelLogin In an ADAM Environment,” on page 43

+ Section 5.7.3, “Setting Up a Passphrase,” on page 43
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5.7.1

5.7.2

5.7.3

Configuring a User’s Environment

Securelogin provides a range of options for deployment and distribution of user configurations. We

recommend that SecureLogin configuration is installed on test user accounts prior to deployment.
Configuring a user’s Securelogin includes:

+ Setting preferences
+ (Optional) Creating password policies
+ Enabling single sign-on for required applications.

+ (Optional) Creating passphrase questions for user selection

Administering SecureLogin In an ADAM Environment

Securelogin users are managed through the Administrative Management utility. Through this you
can manage users at the container, organizational unit, and user object levels.

NOTE: You can administer Securelogin using the Administrative Management utilities, such as
SLManager.

1 Launch the Administrative Management utility.
2 Specify your username, password, and tree name

You can substitute the IP address of an eDirectory server for the tree name.

Setting Up a Passphrase

After you successfully install SecureLogin on a user workstation, set up a passphrase for the user.

For more information, see Chapter 1.2, “Setting Up a Passphrase,” on page 9.
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6.1

6.1.1

6.1.2

Installing, Configuring, and Deploying in an
eDirectory Environment

Choosing to install SecureLogin in an eDirectory environment installs SecureLogin on networks that
are running eDirectory. This option provides you a secure, centralized storage of user login data by
performing encryption on the workstation before the data is saved to eDirectory.

NOTE: The procedures for installing on administrator workstations and user workstations are the
same.

+ Section 6.1, “Installing SecureLogin,” on page 45

+ Section 6.2, “Configuring and Deploying,” on page 46

Installing Securelogin

+ Section 6.1.1, “Prerequisite,” on page 45

¢ Section 6.1.2, “Installation Procedure,” on page 45

Prerequisite

Ensure that you meet the hardware and software requirements listed in Net/Q SecureLogin System
Requirements.

Installation Procedure

Log in to the workstation as an administrator.

Run the NetIQSecureLogin.exe file.

Accept the license agreement.Click Next. The License Agreement page is displayed.
Select NetlQ eDirectory with Novell Client. Click Install.

Click Next to view the Custom Setup screen.
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Securelogin is by default installed in C:\Program Files\NetIQ\SecureLogin folder. If
you want to change the location, click Browse and specify a different location. Select the
features you want to install and click Next.

Installing, Configuring, and Deploying in an eDirectory Environment

45


https://www.microfocus.com/documentation/securelogin/9.1/pdfdoc/system-requirements/system-requirements.pdf#secureloginsysreq
https://www.microfocus.com/documentation/securelogin/9.1/pdfdoc/system-requirements/system-requirements.pdf#secureloginsysreq

6.2 Configuring and Deploying

To make Securelogin functionality available to users and save users’ single sign-on information, you
must first extend the eDirectory schema. You can also provide additional security through Novell
SecretStore and by requiring users on shared workstations to log out securely.

The ndsschema. exe file is found in Securelogin\Tools\Schema\NDS directory extends the
eDirectory schema and grants rights to existing users so that they can use Securelogin.

To extend the schema of a given tree, you must have sufficient rights over the [root] of the tree. In
addition, make sure that you have Novell Client 4.91 or later installed on your machine.
1 Run ndsschema.exe.

Extending the schema might take some time to filter throughout your network, depending on
the size of your network and the speed of the links.

When the eDirectory schema is extended, the following attributes are added:
¢ Prot:SSO Auth
+ Prot:SSO Entry
¢ Prot:SSO Entry Checksum
¢ Prot:SSO Profile
+ Prot:SSO Security Prefs
+ Prot:SSO Security Prefs Checksum

2 Specify the eDirectory context so that SecurelLogin can assign rights to User objects under that
context.

Assign User Rights S

For users to be able to save their Securelogin details into
MDS they wil need rights to the Securelogin attributes on
their user objects.

This tool will assign the appropriate rights to all users in
the container specified and below. An empty value will
add the attributes starting from [Foot].

Context

If you unchedk the AES Encryption box then,
SecureLogin will use 30ES Encryption.

[+ AFS Encryption

K | Cancel

IMPORTANT: The AES Encryption option is selected by default to use AES256 Encryption. If you
unselect this option then the container will use 3DES encryption. It is recommended to use
AES256 encryption.
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IMPORTANT: You can run ndsschema.exe again with AES Encryption option unselected but it
does not change to 3DES encryption. Use s1lmanager.exe to enable 3DES encryption.

NOTE: Rights Assignment works on root level and organizational unit level.

At the prompt, define a context where you want the User objects' rights to be updated, allowing
users access to their own single sign-on credentials.

If you do not specify a context, rights begin at the root of the eDirectory tree.

Only the rights on Container objects are inherited. These rights flow to sub-containers, so that
users can read attributes. User rights are not inherited.

If the installation program displays a message similar to:
-601 No Such Attribute

you have probably entered an incorrect context or included a leading dot in the context.
(Optional) Grant rights to local cache directories.

Users on Windows XP must have workstation rights to their local cache directory locations. To
grant rights, do one of the following:

+ Grantrights to the user’s cache directory. For example,
c:\programfiles\novell\securelogin\cache\v2slc\username

or
c:\users\<usersv2slc>\applicationdata ona Windows Vista machine.

The default location is the user’s profile directory or the user’s application directory. By
default, the user already has rights to this directory. However, if the user specified an
alternative path during the installation, you might need to grant rights to the cache
directory.

If user selects the non-default directory to store the cache, the SecureLogin\cache is
appended to the specified path.

+ During the installation, specify a path to a location that the user has rights to (for example,
the user’s documents folder).
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1.1

Installing, Configuring, and Deploying in an

LDAP Environment

Lightweight Directory Access Protocol (LDAP) is an open-directory structure that provides fast access

to the directory.

The LDAP authentication client uses LDAP to connect to a server and securely administer
applications enabled for single sign-on.

Securelogin supports LDAP authentication over Secret Socket Layer (SSL) connections only.

The instructions and examples in this section apply to the majority of LDAP compliant directories.

Specific examples are given for Sun Java System Directory Server and a directory server managed
through an administration workstation. If you have implemented another LDAP directory
environment, refer to the particular documentation or contact Product Support for help.

+ Section 7.1, “Prerequisites,” on page 49

+ Section 7.2, “Installing,” on page 50

+ Section 7.3, “Configuring,” on page 52

+ Section 7.4, “Deploying,” on page 55

Prerequisites

NOTE: The instructions apply to the standard architecture of the directory managed using an
administration workstation.

O Ensure that you meet hardware and software requirements listed in the “NetlQ SecurelLogin
System Requirements”.

O Ensure that you provide a valid root CA certificate on every workstation during SecurelLogin

installation. The installation fails if the valid root CA certificate is not specified. When you install

or migrate Securelogin in LDAP environment, ensure that certificates used are certified by

Certification Authority (CA). Server Certificates are installed and available on your LDAP server.

IMPORTANT: Ensure that the Subject Name or Subject Alternative Name of the
certificate in eDirectory matches with the SecureLogin LDAP server name.

a

Administrator access to the server, directory, and administration workstation.

O If you intend to enable single sign-on for Java applications, install Java 1.7 or 1.8 on
workstations prior to installing SecureLogin. You can download this from the Java website.

O Back up the existing directory.

O Securelogin uses TLS 1.2 for more secured communication over the networks. It is not

recommended to use TLS 1.1. However, if your environment does not allow using TLS 1.2, see

Enabling TLS 1.1 In SecureLogin.
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1.2

7.2.1

Installing

The LDAP option installs SecureLogin into an LDAP environment with eDirectory.

You can specify more than one LDAP server for the SecurelLogin installation. Although the dialog box
in the installation program allows you to specify only three LDAP servers, you can specify additional
servers by modifying the responsefile. ini file.

The LDAP option does not require Client for Open Enterprise Server for Windows. However, if Client
for Open Enterprise Server is installed on the workstation, Client for Open Enterprise Server is the
initial authentication or Credential Provider. If you want LDAP authentication to be the initial
authenticator, you must uninstall Client for Open Enterprise Server.

1 Login to the workstation as an administrator.
2 Runthe NetIQSecureLogin.exe file.
3 Accept the license agreement and click Next.
4 Select NetlQ eDirectory with LDAP as the datastore.
5 Click Next.
6 Click Install.
7 Click Next.
8 In the Custom Setup window, select the features you want to install.
9 Click Next.
10 In the LDAP Server Information window, specify the server address, port and the root CA

certificate path.

NOTE: Securelogin supports the following certificate formats:
+ BASE64 (*.b64)
+ PEM (*.pem)

IMPORTANT: It is mandatory to specify the root CA certificate path when installing SecureLogin
in the LDAP mode. Specifying the root CA certificate is also mandatory when migrating to the
LDAP mode using s1MigrationHelper.exe. Although it is not recommended, but if you do
not wish to specify the root CA certificate path, see “Installing SecureLogin in the LDAP Mode
Without Root CA Certificate” on page 50 to install SecureLogin without a certificate.

Installing SecureLogin in the LDAP Mode Without Root CA
Certificate

WARNING: Installing SecurelLogin without a root CA certificate makes SecurelLogin and the LDAP
server open to security threats. It is not recommended to install SecureLogin without the root CA
certificate.
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Perform one of the following methods to install SecureLogin in the LDAP mode without the root CA
certificate.
+ Installing SecureLogin in the LDAP Mode Without the Root CA Certificate Using Command Line

+ Installing SecurelLogin in the LDAP Mode Without the Root CA Certificate Using Responsefile.ini
(Silent Installation)

Installing SecureLogin in the LDAP Mode Without the Root CA Certificate
Using Command Line
Perform the following steps to install the SecurelLogin in the LDAP mode without the root CA
certificate:

1 Login as an administrator.

2 Launch the command prompt.

3 Navigate to the location where the Securelogin installer package is saved.

4 Runthe NetIQSecureLogin.exe installer file with the INSTALLWITHOUTCACERT=Yes

parameter. For example:

NetIQSecurelogin.exe INSTALLWITHOUTCACERT=Yes

NOTE: You can use the INSTALLWITHOUTCACERT=Yes parameter and continue the remaining
installation with the GUI installer. For example, NetlQSecurelogin.exe /install
INSTALLWITHOUTCACERT=Yes.

5 Perform the following steps to modify the registries. The registry modification is necessary to
prevents Securelogin to check for root CA certificate.

5a Click Start > Run to open the Run dialog box.

5b Specify regedit and click OK to open Registry Editor.

5c Navigate to the HKEY_LOCAL_MACHINE > SOFTWARE > Novell > Login > LDAP key.
5d Right click and click New > DWORD.

5e Rename the DWORD to CACertNotProvided.

5f Edit the CACertNotProvided valueto 1.

For more information, see Chapter 9, “Installing through the Command Line,” on page 63.

Installing SecureLogin in the LDAP Mode Without the Root CA Certificate
Using Responsefile.ini (Silent Installation)

IMPORTANT: Upgrading Securelogin using the responsefile. ini file is not supported.

Perform the following steps to install the SecureLogin in the LDAP mode without the root CA
certificate using the responsefile.ini file:

1 Log in as an administrator.
2 Specify INSTALLWITHOUTCACERT=YES in the responsefile.ini file.

3 Launch the command prompt.
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4 Navigate to the location where the Securelogin installer package is saved.

5 To install SecureLogin on all the target machines with the responsefile. ini file, run the
following command.

NetIQSecureLogin.exe /install X PRIMARYSTORE=LDAP
PATHTOISS="c:\temp\responsefile.ini" /quiet

6 Perform the following steps to modify the registries. The registry modification is necessary to
prevents SecurelLogin to check for root CA certificate.

6a Click Start > Run to open the Run dialog box.

6b Specify regedit and click OK to open Registry Editor.

6¢ Navigate to the HKEY_LOCAL_MACHINE > SOFTWARE > Novell > Login > LDAP key.
6d Right click and click New > DWORD.

6e Rename the DWORD to CACertNotProvided.

6f Edit the CACertNotProvided valueto 1.

For more information, see “Installing SecureLogin Using The Responsefile.ini File” on page 73.

7.2.2 Enabling TLS 1.1 In SecurelLogin

WARNING: Installing SecurelLogin with TLS 1.1 is less secure than using TLS 1.2. It can open your
deployment environment to security threats.

Perform the following steps to modify the registries. The registry modification is necessary to enable
TLS 1.1 in Securelogin.

Click Start > Run to open the Run dialog box.

Specify regedit and click OK to open Registry Editor.

Navigate to the HKEY_LOCAL_MACHINE > SOFTWARE > Protocom > SecureLogin key.

Right-click and click New > DWORD.

Rename the DWORD to AllowTLSv1.1.

Edit the AllowTLSv1.1 value to 1.
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7.3 Configuring

To install or upgrade Securelogin in an LDAP directory environment, you must extend the LDAP
schema with Securelogin attributes. However, no change is required to Microsoft Active Directory
(AD) schema.

You must manually assign read and write access to the new Securelogin attributes. Due to a wide
variety of LDAP-compliant directories, NetlQ does not provide a specific tool for assigning
permissions to directory attributes.
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7.3.1

If the LDAP directory and Microsoft AD are synchronized, SecureLogin can seamlessly pass a users’
AD’s credentials to LDAP so that users enter their login credentials only once.

+ Extending the LDAP Directory Schema and Assigning Rights on the Server
¢ Using LDAP on eDirectory

Extending the LDAP Directory Schema and Assigning Rights on
the Server

Installing SecureLogin on the server requires extending the LDAP schema and assigning user rights to
record data against these attributes.

SecureLogin Attributes

Table 7-1 Attributes

Attribute To Be Mapped LDAP Mapping

Prot:SSO Auth

Prot:SSO Entry protocom-SSO-Entries

Prot:SSO Entry Checksum protocom-SSO-Entries-Checksum
Prot:SSO Profile protocom-SSO-Profile

Prot:SSO Security Prefs protocom-SSO-Security-Prefs

Prot:SSO Security Prefs Checksum protocom-SSO-Security-Prefs-Checksum

NOTE: These mappings are case-sensitive. Extend the LDAP schema on all servers if you want them
to act as failover servers.

If you intend to use Microsoft Group Policy (GPO) support, NetlQ recommends that you re-extend
the Securelogin directory schema extensions to include the new schema extensions for GPO
support.

If the LDAP-compliant directory extension is deployed using the 1dapschema. exe file copied from
rather run from the Securelogin installer package, then you need to copy the entire LDAP folder
containing the LDAP schema files to your preferred location.

Extending the Schema on the LDAP Server

1 Login to the server as administrator.

2 Run ldapschema.exe found in the \Securelogin\Tools\Schema\LDAP directory of the
Securelogin distribution package. The Securelogin - Active Directory Schema dialog box is
displayed.

or
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7.3.2

Click Schema Extension Tools and click LDAP Compliant.
3 Inthe LDAP Server field, provide the IP address or the name of the LDAP server.

4 In the Admin User field, provide the distinguished name (DN) for the server administrator. For
example, CN=admin

5 Provide the password and select the relevant directory mode (in this example, eDirectory), then
click Update Schema. The certificate information is displayed.

6 Click Accept.

7 When the Schema Extension dialog box is displayed, click Close.

NOTE: LDAP schema extension is replicated to all servers in the LDAP Group, and not to all
servers in the tree. Schema extensions are LDAP group specific and must be repeated for each
LDAP group. By default, each NetWare server is in its own LDAP group, which means that by
default LDAPSchema.exe must be run on every LDAP server.

Assigning Rights to Schema Attributes

You must assign permissions to objects in the directory to store data against the new Securelogin
attributes. Assign permissions to all objects that access SecurelLogin Assigned User Rights.

The application does not start if you have not set permission to access SecurelLogin schema
attributes.

NOTE: LDAP implementations are varied. Therefore, SecureLogin does not provide a specific tool for
each variation for assigning permissions.

The following permissions are recommended for successful implementation:

+ Securelogin administrators are assigned read and write access to all SecurelLogin attributes on
all objects.

+ Users are assigned read and write access to all SecurelLogin attributes on their user objects.

+ Users are assigned read access to the SecurelLogin attributes on organizational units from which
they need to read organizational policies or corporate settings.

Using LDAP on eDirectory

All the functionality that is available in NMAS is also available in the LDAP Authentication client for
Securelogin. The LDAP client enables you to provide multilevel authentication (for example, a
biometric device and a password).

When you use LDAP on eDirectory, the LDAP password can come from one of two places:

+ The eDirectory password
+ The NMAS Simple password

The eDirectory password takes precedence. The Simple Password exists if used in an eDirectory
password does not exist.

If a user types a password that does not match the eDirectory password, LDAP attempts to match
the simple password.
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7.4.1

Deploying

Securelogin provides centralized management and deployment of user configuration by using the
directory structure and administration tools in the same utility. We recommend that you configure
Securelogin on a test user account before deployment.

Use the industry standard application distribution packages such as ZENWorks, Systems
Management Server, and Microsoft IntelliMirror to deploy and manage Securelogin across large
enterprises.

Securelogin can also be installed, configured, and features can be added and removed using

Microsoft Windows Installer (MSIExec) options and parameters from the command line or provided

through a batch file.

Prior to installing Securelogin, ensure the LDAP certificate file is saved in the default certificate
location of the LDAP log, for example, securelogin\rootcert.der. This certificate is used only
in non-eDirectory environments.

NOTE: Copying the LDAP Certificate is necessary only in the Active Directory or Non-eDir LDAP
compliant directories. This step is not necessary in the default eDirectroy environments.

¢ Section 7.4.1, “Distribution Options,” on page 55

¢ Section 7.4.2, “Configuring in a Non-eDirectory LDAP or Active Directory Environment,” on
page 56

+ Section 7.4.3, “Logging in to LDAP Directory,” on page 56
¢ Section 7.4.4, “Contextless Login,” on page 57
+ Section 7.4.5, “Setting Up Passphrase,” on page 58

Distribution Options

Securelogin provides the following options for deployment and distribution of user configurations:

Table 7-2 Distribution Options

Options Descriptions

Copy settings Copies Securelogin configuration from one object in a directory to
another object in the same directory.

Export and import Uses an XML file to distribute the configuration.

Directory object inheritance Inherits the configuration from a higher-level directory object, for
example, a Group Policy.

Corporate configuration re-direction Redirect configurations of a specified directory of a different group to
the directory.
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7.4.2

7.4.3

Configuring in a Non-eDirectory LDAP or Active Directory
Environment

1 Add a key in the registry HIVE.

2 Browse to HKEY LOCAL MACHINE\SOFTWARE\Novell\Login\LDAP.
3 Create a registry key of the STRING value.

4 Name the registry key as CertFilePath.

5 Specify the path to your certificate.

NOTE: *Anonymous bind needs to be enabled on the server for Non-eDirectory, Active Directory
and also eDirectory environments.

+ To encrypt LDAP credentials and update the system registry when anonymous bind is disabled
in Active Directory, see “Updating the System Registry” on page 56.

+ To encrypt LDAP credentials and update the system registry when TLS is enabled in eDirectory,
see “Updating the System Registry” on page 56.

Logging in to LDAP Directory
1 Loginto the LDAP directory using your user account or administrator account credentials.
2 Provide your username and password, and click OK.

If you cannot view the full LDAP login dialog, click Advanced to expand the dialog box. If this
information is blank, then populate as needed.

+ Server: Specify the name of the LDAP server.
+ Port: Specify the port used by the LDAP server. The default port number is 636.

+ NMAS authentication: Select NMAS if you want to use advanced authentication to login to
eDirectory.

As an administrator, you might need to include a system registry update as part of the Securelogin
deployment strategy. See “Updating the System Registry” on page 56.

Updating the System Registry

Configure the operation of SecurelLogin by setting registry key values on users’ machines. The keys
are located in the local machine hive of the registry. The values that populate the Advanced tab of
the Securelogin dialog box are located at:

HKLM\Software\Novell\Login\LDAP

Configuration Settings
+ Server History List (3.51.100 or later)

HKEY LOCAL MACHINE\Software\Novell\Login\LDAP\Servers\server#
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Replace the # by using a numeric value. In SP1, each server item should be a multistring value
(REG_MULTI SZ), and can be either an IP address, or DNS name of the server. These values can
be set from the installation dialogs or by an installation script. The port value can also be
specified along with the server in a new line. By default, port 636 will be used.

Context Based Search (3.51.109 or later)

HKEY_LOCAL_MACHINE\SOFTWARE \Novell\Login\LDAP\LDAPSearch\ContextBasedS
earch

DWORD value, set to ' 1' for context-based search. Also, specify the set of contexts to search,
such as Contextl, Context2 or Context3 oftype REG SZ, each specifying the exact
context to search.

No explicit context validation is done except that LDAP search returns an appropriate error in
case an invalid context is specified

+ Search Attributes (3.51.109 or later)

HKEY LOCAL MACHINE\SOFTWARE\Novell\Login\LDAP\LDAPSearch\SearchAttribu
tes

REG MULTI SZ value, set to list of search attributes to be used in LDAP search. Any publicly
readable attribute can be specified, for example fullName, givenName, sn, cn, uidand
in AD environment you can specify samAccountName.

CertFilePath (3.51.200 or later)
HKEY LOCAL MACHINE\Software\Novell\Login\LDAP\CertFilePath

REG_SZ value lets the user to specify a valid certificate file path for non-eDirectory servers. This
requires the user to create another registry entry NonEdirLdap of type REG_DOWORD.
CertFilePath is considered only if NonEdirLdap is present and set to 1.

For more information, see Registry Settings for SecureLogin in LDAP mode

Contextless Login

When Securelogin is configured in the LDAP mode, a login page is displayed when Securelogin is
launched.

The login page requires a user distinguished name (DN) and password. The LDAP Authentication
client provides a contextless login. This feature allows you to type part of your fully distinguished
name (DN) rather than the full string that some users might find confusing.

Table 7-3 Contextless Login

If

Then

More than one match is found. A login page is displayed that allows the user to select the login account.

Multiple IDs exist. The client lists all user IDs that begin with (for example, Westbye Tim), then

selects the Domain Name for his or her user ID and login.
You can search using the user’s given name, surname and display name.

Surname (sn) and given name (givenname) are the default values.
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7.4.5

To enable LDAPAuth to perform search even when anonymous bind is disabled,ldapce.exe utilty is
used. Using this utility, an administrator can create encrypted credentials for any user. The encrypted
credentials must be stored in a specific registry. For detailed information on LDAPCE Utility, see
“Using the LDAPCE Utility to Encrypt LDAP Credentials” on page 58.

Using the LDAPCE Utility to Encrypt LDAP Credentials

The 1dapce.exe is a command-line utility used to encrypt the credentials of an authorised user
who has rights to browse the LDAP directory tree. The utility encrypts the authorized LDAP user’s
distinguished name and password into a string which is then stored in the
LDAPContextlessSearchBindCreds registry key file.

Location Type Name
HKEY LOCAL MACHINE/SOFTWARE/Protocom/ REG_SZ LDAPContextlessSearchBindcreds
SecureLogin/

NOTE: The Idapce.exe utility is unsupported and is only available on request. It is not distributed
with Securelogin package.

The syntax is:
ldapce.exe <user DN> <password> [output file]
Where,

¢ <user DN> is the the full distinguished name of the LDAP user.
+ <password> isthe password of the LDAP user.

+ [output file] isthe name of the output file to which the encrypted string is written. If this
option is omitted, the string is displayed on the screen.

Setting Up Passphrase

After you have successfully installed SecureLogin on a user workstation, you can set up a passphrase
for the user.

For more information, see Section 1.2, “Setting Up a Passphrase,” on page 9.
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8.1

8.1.1

8.1.2

8.1.3

Installing and Deploying in the Standalone
Environment

Standalone installation operates on a workstation that is independent of a network or corporate
directory system. Standalone installation is intended for individual users, in addition to providing a
platform for SecurelLogin SSO version control, review and testing.

Getting Started

Securelogin can be installed in a standalone mode that operates on a user’s workstation. It is
independent of a network or corporate directory system. Standalone mode installation allows single
sign-on to applications on individual workstations, provides a platform for SecureLogin version
control, review, and testing.

+ Section 8.1.1, “Prerequisites,” on page 59

+ Section 8.1.2, “New Installations,” on page 59

+ Section 8.1.3, “Unsupported Features,” on page 59

+ Section 8.1.4, “Installation Overview,” on page 60

Prerequisites

+ You must have administrator level access to the workstation.

+ Take a backup of the existing workstation cache directory.

New Installations

A new installation of SecurelLogin that is installed in standalone mode is installed in seamless mode.
Your workstation login credentials are used to start SecureLogin.

If you upgrade from a previous versions of SecurelLogin, you are prompted to migrate to seamless
mode.

Unsupported Features

The following features are not supported in a standalone install:

+ All smart card functionalities, including
+ Smart card configuration for single sign-on
+ Smart card password login
+ The passphrase question and answer security system

+ AES datastore encryption
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8.1.4

8.2.1

60

*

*

*

*

*

Audits using syslog server
Citrix and Terminal services
Advanced Authentication
Desktop Automation Service

Directory Administration Tools

Installation Overview

NOTE: The ?syspassword variable does not work in standalone mode. As smart card options
cannot be selected in a standalone mode installation, smart card login to standalone mode installs is
not supported.

Securelogin standalone mode operates on a user’s workstation, which is independent of a network
or, corporate directory system. In addition to providing a platform for SecurelLogin review and
testing, the standalone mode is intended to provide SecurelLogin for individual workstations.

1.
2.
3.

Backup the existing workstation directory.
Uninstall any SecurelLogin version prior to 3.5.x.

Ensure that the Microsoft Management Console’s Active Directory plug-ins are installed on the
administration workstation.

Define and configure the Securelogin environment, including enabling single sign-on of the
required applications.

Copy test user configurations to relevant objects.

Install the SecurelLogin application on user workstation.

8.2 Installing

*
*

*

1
2
3
4

(9}

Section 8.2.1, “Installing in a Standalone Workstation,” on page 60
Section 8.2.2, “Upgrading from an Earlier Version,” on page 61

Section 8.2.3, “Creating a New User Account,” on page 62

Installing in a Standalone Workstation

Log in to the workstation as an administrator.
Run the NetlQSecureLogin.exe file.
Accept the license agreement.Click Next. The License Agreement page is displayed.

Select Standalone (Trial/Testing/Demonstration) as the datastore. Click Install. If dependant
components like NICI, NMAS are not present, they are installed.

Click Next to view the Custom Setup screen.

6 The Securelogin is by default installed in C:\Program Files\NetlQ\SecureLogin folder. If you

want to change the location, click Browse and specify a different location. Select the features
you want to install and click Next.
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Upgrading from an Earlier Version

The previous versions of SecurelLogin supported creating multiple SecureLogin accounts for a single
workstation account.

To maintain backward compatibility, SecureLogin supports multiple users created in previous
versions.

After upgrading, you are prompted to either continue using multiple accounts or choose one
account and migrate to seamless standalone mode.

If you have been using SecurelLogin in standalone mode in one account, you are automatically
migrated to seamless standalone mode after providing your username and password on first log in.

Setting Up Multiple User Accounts

Securelogin consolidates the accounts by leveraging the Windows account to verify the user. This
results in one Securelogin user for each Windows account.

After upgrading, the following message appears.

Figure 8-1 Seamless migration message

Securelogin

Do waou wish ko Migrate to Seamless Standalone mode?

Yes Mo |

+ If you wish to manage the users through their Windows accounts, click Yes and migrate to
seamless standalone mode. This deletes all other user accounts but it does not delete the one
you are requested to selected.

+ If you have previously configured SecureLogin with multiple users, click No to continue
accessing them.

The Securelogin Standalone dialog is displayed. The dialog box retains all the user accounts
retained from the previous SecurelLogin configuration.

You can then select from two options:

+ If you had earlier selected Yes, select the user or the account that will continue to be user
future Securelogin account.

+ If you had earlier selected No, select the user account that you require now. This list
displays all the accounts retained for future log in.

Specify the password. Securelogin is now active for the selected user and the SecurelLogin icon
appears in the notification area.

Managing SecurelLogin After upgrading

For mobile users and notebook users, SecurelLogin is managed through the Personal Management

Utility. To start the Personal Management Utility, double-click the SecureLogin icon &l on the
notification area, or right-click the icon and select Manage Logins.
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8.2.3 Creating a New User Account

When Securelogin is started after a new installation on a standalone workstation, the Standalone
dialog is displayed.

1 Click Create User. The Create User page is displayed

2 Specify the Username and Password.

3 Re-enter the password to verify.

4 Click OK.
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9.1

9.2

Installing through the Command Line

This section describes how to install SecureLogin through the command line. The installer command-
line options and parameters are provided directly from the command line or supplied through a
batch file.

The range of the available command-line options and parameters depend on the version of the
Windows installer.

NOTE: The examples provided in this section are based on Windows installer version 3.0 or above.

+ Section 9.1, “Installation Overview,” on page 63
+ Section 9.2, “SecurelLogin Properties and Values,” on page 63

+ Section 9.3, “Windows Installer Command Line Options,” on page 74

Installation Overview

Prerequisite
Securelogin requires the latest Microsoft Windows Installer.

1 Login as an administrator.
2 Launch the command prompt.
3 Browse to the location where you have saved the Securelogin installer package.

4 Run NetIQSecureLogin.exe.
The installation options are explained in the following sections:

+ Securelogin Properties and Values

+ Windows Installer Command Line Options

Securelogin Properties and Values

Use the following property values to install SecurelLogin.

+ Section 9.2.1, “Installing in eDirectory Environment,” on page 64

+ Section 9.2.2, “Installing in the LDAP v3 (non-eDirectory) Environment,” on page 66

+ Section 9.2.3, “Installing in the Microsoft Active Directory Environment,” on page 67

+ Section 9.2.4, “Installing in the Azure Active Directory Environment,” on page 68

+ Section 9.2.5, “Installing in the Active Directory Application Mode Environment,” on page 68
+ Section 9.2.6, “Installing in the Standalone Environment,” on page 68

+ Section 9.2.7, “Commands for Installing the Features,” on page 68
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9.2.1

*

Section 9.2.8, “Examples,” on page 72

*

Section 9.2.9, “Silent Install,” on page 72

*

Section 9.2.10, “Installing SecurelLogin Using The Responsefile.ini File,” on page 73

*

Section 9.2.11, “Example of a Response File,” on page 73

NOTE: All commands described in this section display details on the user interface. Use option /
quiet to stop displaying details on the user interface and option /passive for minimal details on
the user interface. For example: NetlQSecurelogin.exe /install /quiet X_PRIMARYSTORE=MAD.

Installing in eDirectory Environment

When you install or migrate SecureLogin in LDAP environment, ensure that certificates used are
certified by Certification Authority (CA). Server Certificates are installed and available on your LDAP
server.

IMPORTANT: Installing SecurelLogin without a root CA certificate makes SecurelLogin and LDAP
server vulnerable. It is not recommended to install SecureLogin without the root CA certificate.

Ensure to provide a valid root CA certificate on every workstation during SecurelLogin installation.
The installation fails if the valid root CA certificate is not specified. However, if you want to install

Securelogin without the root CA certificate, see Installing SecureLogin in the LDAP Mode Without
Root CA Certificate.

Use the following command to upgrade Securelogin without a root CA certificate:
NetIQSecurelLogin.exe /install INSTALLWITHOUTCACERT=Yes

Ensure that the Subject Name or Subject Alternative Name of the certificate in eDirectory
matches with the SecurelLogin LDAP server name.

Table 9-1 Command Options for Installing in the eDirectory Environment

Installation Mode Command Line Parameters Description

eDirectory in NDS NetIQSecurelogin.exe / Use this command to install SecureLogin

Credential Provider mode install X PRIMARYSTORE=NDS jn Credential Provider mode on
eDirectory.
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Installation Mode

Command Line Parameters

Description

eDirectory in LDAP
Credential Provider Mode

NetIQSecureLogin.exe /
install X PRIMARYSTORE=LDAP
APPENDLOCAL=SeamlessLDAPGin
a
LDAPSERVERADDRESS=192.168.1
.255

CERTPATH=c: \temp\<certifict
ate file> /log log.txt

Use this command to install SecureLogin
in LDAP Credential Provider Mode on
eDirectory.

The default port is 636.

To add another port, include the
LDAPPORT in the command line.

Forexample, NetIQSecurelLogin.exe
/install X PRIMARYSTORE=LDAP
APPENDLOCAL=SeamlessLDAPGina
LDAPSERVERADDRESS=192.168.1.25
5 LDAPPORT=359

CERTPATH=c: \temp\<certifictate
file> /log log.txt

eDirectory in LDAP
Credential Manager Mode

NetIQSecureLogin.exe /
install X PRIMARYSTORE=LDAP
APPENDLOCAL=SeamlessLDAPCre
d
LDAPSERVERADDRESS=192.168.1
.255
CERTPATH=c:\temp\<certifict
ate file> /log log.txt

Use this command to install SecureLogin
in Credential Manager mode on
eDirectory.

The default port is 636.

To add another port, include the
LDAPPORT in the command line.

For example,

NetIQSecureLogin.exe /install

X PRIMARYSTORE=LDAP

APPEND LOCAL=SeamlessLDAPCred
LDAPSERVERADDRESS=192.168.1.255
LDAPPORT=389

CERTPATH=c: \temp\<certifictate
file> /log log.txt

eDirectory in LDAP
Application Mode

NetIQSecureLogin.exe /
install X PRIMARYSTORE=LDAP
APPENDLOCAL=LDAPApp
LDAPSERVERADDRESS=192.168.1
.255

CERTPATH=c: \temp\<certifict
ate file> /log log.txt

Use this command to install SecurelLogin
in LDAP Application Mode on eDirectory.

The default port is 636.

To add another port, include the
LDAPPORT in the command line.

For example,

NetIQSecurelLogin.exe install

X PRIMARYSTORE=LDAP
APPENDLOCAL=LDAPApp
LDAPSERVERADDRESS=192.168.1.255
LDAPPORT=389

CERTPATH=c: \temp\<certifictate
file> /log log.txt
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9.2.2

Installing in the LDAP v3 (non-eDirectory) Environment

When you install or migrate SecurelLogin in the LDAP environment, ensure that certificates used are
certified by Certification Authority (CA). Server Certificates are installed and available on your LDAP
server.

WARNING: Installing SecurelLogin without a root CA certificate makes SecurelLogin and the LDAP
server open to security threats. It is not recommended to install SecureLogin without the root CA
certificate.

IMPORTANT: Ensure that you provide the valid root CA certificate on every workstation during
Securelogin installation. The installation fails if the valid root CA certificate is not specified.
However, if you want to install SecureLogin without the root CA certificate, see “Installing
Securelogin in the LDAP Mode Without Root CA Certificate” on page 50.

IMPORTANT: Ensure that the Subject Name or Subject Alternative Name of the certificate
in eDirectory matches with the SecureLogin LDAP server name.

IMPORTANT: Use the following command to upgrade SecurelLogin without a root CA certificate:

NetIQSecurelLogin.exe /install INSTALLWITHOUTCACERT=Yes

Table 9-2 Command Options for Installing in the LDAP v3 (non-eDirectory) Environment

Installation Mode Command Line Parameters Description
LDAP Credential Provider NetIQSecureLogin.exe / Use this command to install SecurelLogin
mode install X PRIMARYSTORE=LDAP in LDAP Credential Provider mode on

APPENDLOCAL=SeamlessLDAPGina any LDAP-compliant directories (non-
X NONEDIRLDAP=1

eDirectory).
LDAPSERVERADDRESS=192.168.1.

255 The default port is 636.
CERTPATH=c:\temp\<certificta
te file> /log log.txt To add another port, include the

LDAPPORT in the command line.
For example,

NetIQSecureLogin.exe /install
X PRIMARYSTORE=LDAP
APPENDLOCAL=SeamlessLDAPGina
X NONEDIRLDAP=1
LDAPSERVERADDRESS=192.168.1.25
5 LDAPPORT=389

CERTPATH=c: \temp\<certifictate
file> /log log.txt

Installing through the Command Line



9.2.3

Installation Mode

Command Line Parameters

Description

LDAP Credential Manager NetIQSecureLogin.exe /

Mode install X PRIMARYSTORE=LDAP
X NONEDIRLDAP=1
APPENDLOCAL=SeamlessLDAPCred

Use this command to install SecurelLogin
in Credential Manager mode on any

LDAP-compliant directories (non-
eDirectory).

LDAPSERVERADDRESS=192.168.1.

255

The default port is 636.

CERTPATH=c: \temp\<certificta

te file> /log log.txt

To add another port, include the
LDAPPORT in the command line.

For example,

NetIQSecurelogin.exe /install

X PRIMARYSTORE=LDAP
X NONEDIRLDAP=1

APPENDLOCAL=SeamlessLDAPCred
LDAPSERVERADDRESS=192.168.1.25

5 LDAPPORT=389

CERTPATH=c: \temp\<certifictate

file> /log log.txt

LDAP Application Mode NetIQSecurelLogin.exe /
install X PRIMARYSTORE=LDAP
X_NONEDIRLDAP:l
APPENDLOCAL=LDAPApp

Use this command to install SecurelLogin
in LDAP Application Mode on any LDAP-
compliant directories (non-eDirectory).

LDAPSERVERADDRESS=192.168.1. The default port is 636.

255

CERTPATH=c:\temp\<certificta T0add another port, include the

te file> /log log.txt

LDAPPORT in the command line.

For example,

NetIQSecureLogin.exe /install

X PRIMARYSTORE=LDAP
X NONEDIRLDAP=1
APPENDLOCAL=LDAPApp

LDAPSERVERADDRESS=192.168.1.25

5 LDAPPORT=389

CERTPATH=c: \temp\<certifictate

file> /log log.txt

Installing in the Microsoft Active Directory Environment

Table 9-3 Command Options for Installing in Active Directory Environment

Installation Mode

Command Line Parameters

Description

Complete install
install

NetIQSecureLogin.exe /
X PRIMARYSTORE=MAD

Use this command to install SecurelLogin
on Microsoft Active Directory, without

prompting users for any selection.

With group policies enabled NetIQSecureLogin.exe /

Use this command to install SecureLogin

install X_PRIMARYSTORE=MAD  on Microsoft Active Directory with

APPENDLOCAL=GPO

support for group policy.
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9.2.4 Installing in the Azure Active Directory Environment

Table 9-4 Command Options for Installing in Azure Active Directory Environment

Installation Mode Command Line Parameters Description

Complete install NetIQSecurelLogin.exe / Use this command to install SecurelLogin
install on Azure Active Directory, without
X_PRIMARYSTORE=SLAE prompting users for any selection.

With group policies NetIQSecurelLogin.exe / Use this command to install SecurelLogin

enabled install X PRIMARYSTORE=SLAE on Azure Active Directory with support
APPENDLOCAL=GPO for group po||cy

9.2.,5 Installing in the Active Directory Application Mode Environment

Table 9-5 Command Options for Installing in Active Directory Application Mode Environment

Installation Mode Command Line Parameters Description

Complete install NetIQSecurelLogin.exe / Use this command to install
install X PRIMARYSTORE=ADAM Securelogin on Microsoft Active
Directory Application Mode, without
prompting users for any selection.

With group policies enabled NetIQSecurelLogin.exe / Use this command to install
install X PRIMARYSTORE=ADAM Securelogin on Microsoft Active
APPENDLOCAL=GPO Directory Application Mode with

support for group policy.

9.2.6 Installing in the Standalone Environment

Table 9-6 Command Options for Installing in Standalone Mode

Installation Mode Command Line Parameter Description

Complete install NetIQSecurelLogin.exe / Use this command to install
install SecureLogin in a standalone mode,
X_PRIMARYSTORE=DUMMY without any user interface.

9.2.7 Commands for Installing the Features

When installing SecureLogin, GPO and RunAtStartup features are installed by default. You can
choose to install various features such as support for smart card and support for Citrix.

Use the following table as reference to specify these features when installing SecurelLogin.

TIP: APPENDLOCAL can be used to install any specific feature using the feature name. For enabling
multiple features, specify the feature names separated by a comma.
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For example: To install DAS, and SmartCard, use APPENDLOCAL in the following manner:

APPENDLOCAL=DAS, SmartCard

Table 9-7 Commands for Installing Features

Command Line Value Description Example

Parameters

INSTALLDIR Installation Installs SecurelLogin in the INSTALLDIR=C:\Program
folder specified folder or directory. Files\NetIQ\SecureLogin\

X CACHEDIR Cache folder Installs SecureLogin in the X CACHEDIR=%LOCALAPPDATA%

specified folder or directory.

X PRIMARYSTORE=
MAD

Install SecurelLogin on
Microsoft Active Directory.

NetIQSecurelLogin.exe /
install
X PRIMARYSTORE=MAD

SMARTCARD

Installs smartcard support.

APPENDLOCAL=SmartCard

Smart card support is installed only
if Actividentity ActivClient is
detected on the machine.

Set the cryptographic service
provider and smart card DLL file by
defining the X_CSP and
X_SMARTCARDLIB properties.

X CSp=Microsoft Base Smart
Card Crypto Provider
X_SMARTCARDLIB=C:\Windows
\System32\basecsp.dll

Desktop

Installs desktop and tray icon
for Securelogin.

ADDLOCAL=Desktop

MMC AD

Installs Active Directory MMC
Snapin and Active Directory
query extension.

ADDLOCAL=MMC AD

MMC_GPO_EDIT

Installs Active Directory MMC
Snapin for GPO editor.

ADDLOCAL=MMC_GPO_EDIT

Citrix Installs Citrix support. ADDLOCAL=Citrix

CitrixSeamless Installs Citrix support for APPENDLOCAL=CitrixSeamles
seamless sign-on. s

CitrixAgent Installs Citrix Agent support.  APPENDLOCAL=CitrixAgent

TerminalServer Installs general configurations APPENDLOCAL=TerminalServe
of Terminal Server. r

TSSeamless Installing this feature allows =~ APPENDLOCAL=TSSeamless

seamless sign-on using
eDirectory, AD, LDAP etc.
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Command Line Value Description Example
Parameters

TSAgent Installs files and registry for APPENDLOCAL=TSAgent
Terminal Server Virtual
Channels to allow seamless
sign-on to remote terminal
servers.

AAF2 Installs files that are required APPENDLOCAL=AAF2
to configure Advanced
Authentication.

HELP Installs SecurelLogin help files. APPENDLOCAL=HELP

DAS Installs files that are required APPENDLOCAL=DAS
to configure Desktop
Automation Services for Kiosk
mode.

LDAPPORT Port address  Specifies the LDAP port LDAPPORT=389
address.

SecureWorkstati Installs SecureWorkstation. APPENDLOCAL=SecureWorksta
on tion

Admin Specifies installing the APPENDLOCAL=Admin
directory administration tools.

SMARTCARDLIB Specifies the PKCS#11 XisMARTCARDLIB="C:\Resour
encryption library to use. ces\acpkcs20lrc.dll"

The value is supplied as the
name of the desired DLL file.

Ccsp Specifies a cryptographic X CSP="ActivCard Gold
service provider. Cryptographic Service

. ) ) Provider"
It is typically a string constant

from
HKEY_LOCAL_MACHINE\SO
FTWARE\Microsoft\Cryp
tography\
Defaults\Provider.

GPO Installs Microsoft Group Policy APPENDLOCAL=GPO
Support for ADAM, AD and AD
LDS.

MinMem Installing this feature will APPENDLOCAL=MinMem
allow you to set the minimum
and maximum working set
sizes for the specified
Securelogin process.

RoamProfile Installs settings that change APPENDLOCAL=RoamProfile
seamless sign-on process to
allow roaming files to log off
cleanly.
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Command Line Value Description Example
Parameters
DisableCache It disables the local file cache APPENDLOCAL=DisableCache
for offline support. Do not
install this feature if a local
cache is required.
SeamlessMAD Uses the Windows credentials APPENDLOCAL=SeamlessMAD
for seamless sign on in the
Active Directory environment.
VCRedist * * Installs Visual C++ APPENDLOCAL=VCRedist 11 x
Redistributable Package 86
APPENDLOCAL=VCRedist 11 x
64
APPENDLOCAL=VCRedist 10 x
64
APPENDLOCAL=VCRedist 10 x
86
*3S0 WinSSO, Enables SSO support for APPENDLOCAL=WinSSO
JavaSSoO, various platforms respectively.
TermsSSO APPENDLOCAL=JavaSS0O
IESSO, APPENDLOCAL=TermSSO
FireFoxSSQOJS,
ChromeSSO, APPENDLOCAL=DotNetSSO
EdgeSSO,
DotNetSSO
Auditing Installs files to audit APPENDLOCAL=Auditing
Securelogin events.
WindowsEventLog Logs Windows event APPENDLOCAL=WindowsEventL
messages. og
SysLogCacheForw Installing this feature forwards APPENDLOCAL=SysLogCacheFo
ard the events logged in Windows rward
Event Log to the Syslog server.
SysLog Installing this feature sends APPENDLOCAL=SysLog
audit messages to the Syslog
server.
Tools Installing tools required for APPENDLOCAL=Tools

the administrative tasks. For

example, SlapTool for
provisioning.
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9.2.8

9.2.9

Examples

This section lists some examples that you can use in your environment.

+ Selecting Mode and Feature

+ Installing with User Interface Option

Selecting Mode and Feature
The following example installs SecurelLogin in the following setup.

+ Microsoft Active Directory mode
+ Support for Group Policy

+ Securelogin is not launched at the completion of the installation

NetIQSecurelLogin.exe
/install X_PRIMARYSTORE=MAD APPENDLOCAL=GPO

Installing with User Interface Option

The following example installs SecurelLogin in the following setup:

+ eDirectory mode.
+ Securelogin is not launched at the completion of the installation
+ User is prompted to restart after the installation is complete.

NetIQSecurelLogin.exe /install X PRIMARYSTORE=NDS APPENDLOCAL=INSTALLADMIN

Silent Install

A silent install provides InstallShield Wizard with instructions for installing SecureLogin. To use a
silent install, you must use a response file.

A response file is a text file (responsefile. ini) containing sections and keys. The response file is
created during installation in <WidowsVolume>\NSLFiles\responsefile. ini. It captures your
responses to the dialogs that you encounter during the installation. This is later used as an input for
silent installation. It is recommended that you do not modify the responsefile.ini.

IMPORTANT: During silent install, the PATHTOISS property must contain the absolute path to
responsefile.ini. Ifitis a relative or invalid path, then SecureLogin installation is aborted.

For instance,

+ An administrator runs the graphical installer on a single machine. During the install, the
administrator selects the configuration he or she wants to roll out to the machines of the target
users.

+ At the end of the installation a response file is created and available located in <windows
Volume>\NSLFiles. It contains the command line properties required to replicate the
graphical installation the administrator has done.

+ The administrator can take this response file and copy it to the target machines or to a mapped
network drive for use with target machine installs.
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9.2.10

9.2.11

Installing SecureLogin Using The Responsefile.ini File

IMPORTANT: Upgrading SecureLogin using the responsefile.ini file is not supported.

To install SecurelLogin on all target machines with responsefile.ini, run the following
command:

NetIQSecureLogin.exe /install X PRIMARYSTORE=LDAP
PATHTOISS="c:\temp\responsefile.ini" /quiet /log /log.txt

Replace value of X_PRIMARYSTORE with one of the following values:

+ MAD - Microsoft Active Directory

SLAE - Advanced Edition

ADAM - Active Directory Application Mode
NDS - NetlQ eDirectory with Novell Client
LDAP - NetlQ eDirectory with LDAP

*

*

*

*

If you try to install NSL using responsefile.ini in any of LDAP modes (like Gina/CP, CM and App mode),
then these modes have certain prerequisites like NICI, NMAS etc. So it is important to pass value for
Data store along with responsefile.ini.

For example:
NetlQSecurelogin.exe X_PRIMARYSTORE=LDAP PATHTOISS="C\Users....\responsefile.ini" /quiet
Installation fails if we do not specify the X_PRIMARYSTORE, as prerequisites are not met.

If prerequisites like NICI and NMAS is already present in the workstation, then do not specify
X_PRIMARYSTORE value in command line

You can create a new response file or edit one from a previous installation. During the installation,
the responsefile.ini is created in the <WindowsVolume>\NSLFiles folder.

IMPORTANT: Non-English users must first run MST with transform file and then run the update
sequentially.

Example of a Response File

INSTALLDIR=C:\Program Files\NetIQ\SecureLogin\

X CACHEDIR=%LOCALAPPDATA%

X PRIMARYSTORE=MAD

X NONEDIRLDAP=No

ADDLOCAL=SmartCard, GPO,MinMem, RoamProfile, DisableCache, SeamlessMAD, WinSSO, JavaSSO,
TermSSO, IESSO, FireFoxSS0JS, ChromeSS0O, EdgeSSO, DotNetSSO, Admin, MMC AD,MMC GPO_Edit, T
ools,Citrix,CitrixSeamless,CitrixAgent, TerminalServer,TSSeamless, TSAgent,AAF2,DAS,
SysLogCacheForward, SysLog, RunAtStartup, Desktop,CredStore, DirectorySignon, SSOAut, Pr
imaryStore,WindowsEventLog,Auditing, VCRedist 11 x86,VCRedist 11 x64,VCRedist 10 x6
4,VCRedist 10 x86

LDAPSERVERADDRESS=LDAP server address

LDAPPORT=636

LDAPSERVERADDRESS=LDAP server address

LDAPPORT=636

CERTPATH=

LDAPSERVERADDRESS1=

LDAPPORT1=
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CERTPATH1=

LDAPSERVERADDRESS2=

LDAPPORT2=

CERTPATH2=

X SMARTCARDLIB=C:\Windows\System32\basecsp.dll
X CSpP=Microsoft Base Smart Card Crypto Provider
X STOREONCARD=

LOCATIONFORXML=

DASSERVER=

DASCONFIGOBJECT=

X SYSLOGSERVERURI=tls://localhost:6514
X_SYSLOGLANGUAGEID:#1033

X AAFSERVERNAME=164.99.91.104
X_AAFSERVERPORT=443

X AAFEVENTNAME=Windows logon

74

9.3

For more information, see “Commands for Installing the Features” on page 68.

Windows Installer Command Line Options

The following table lists the Windows Installer command line options used to manually install,
uninstall, and configure SecurelLogin. For example use the following command to install SecureLogin:

NetIQSecurelLogin.exe /install

Table 9-8 Windows Installer Command Line Options

Command Usage

/install Installs SecureLogin.

/repair Repairs an existing SecurelLogin installation.

/layout Installs or configures a product on a network.

REMOVE Removes the specified features. Specify the features that are not required separated
by comma.

ADDLOCAL Installs only the specified features. Specify the features that are required separated
by comma.

APPENDLOCAL Installs additional features in addition to the default features. Specify the features
that are required separated by comma.

/uninstall Uninstalls SecureLogin.

/help Displays the help and quick reference options.

/quiet Installs without user interaction.

/passive Installs with a progress bar.

/norestart No restart after installation.

/forcerestart Always restarts after installation.

/log Writes a log file after installation. By default, the log file is created in the $TEMP%

folder.
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Command Usage

/lang Installs in a specific locale. The default locale is English (1033). Supported locales are:

*

*

*

* & o o

1028 - Chinese
1036 - French
1031 - German
1041 - Japanese
1034 - Spanish
1045 - Polish
1046 - Portugese

Switches Supported by SLTray.exe

The switches explained in the following table apply to all versions and modes of SecurelLogin:

Table 9-9 Switches

Switch Usage

/displaymenu Displays the system menu of SecureLogin from the notification area icon.
/shutdown Shuts down Securelogin, if it is running.

/nochange Does not watch for user changing in eDirectory or SecretStore mode.
/reload Reloads SecurelLogin.

/runstartup Starts the startup scripts configured as part of SecurelLogin client.
/writereg Writes to the registry after reload.

NOTE: Use this with the reload switch.
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10.1

Installing, Configuring, and Deploying
Desktop Automation Services

Desktop Automation Services (DAS) is a software component service that runs locally on the
workstation to handle unique use cases associated with workstations or kiosks (multiple users using
the same workstation during the day or during other shifts).

DAS provides a way to execute selective and configurable lists of user operations from virtually any
scripting or programming medium on the Microsoft Windows operating system. This allows you to
change the behavior of the workstation based on how you work, instead of how a computer works.
This provides you the best and most flexible computing experience while saving time and mouse
clicks, and adding productivity improvements.

+ Section 10.1, “Installing DAS,” on page 77
+ Section 10.2, “Configuring DAS,” on page 84
+ Section 10.3, “Deploying DAS,” on page 86

Installing DAS

The ARS.exe is the center of DAS. You can configure this object with an independent set of
instructions by using an XML document that is obtained through an entry in the Windows registry.
The XML document can be obtained either locally on the workstation or through the directory
services. The XML document is called the action file and the file is named actions.xml.

Each action is a set of configurable user-level operations such as mapping a drive, testing for
establishing an authenticated connection to a directory, and running or shutting down an
application. The flexibility of the code to test for conditions or have action triggers such as hot keys
provides tremendous flexibility to change the behavior of the workstation to fit your needs.

After you have configured the ARS. exe object, its actions are available individually or in
combination from any scripting interface that is available on Windows, for example, VBScript,
JavaScript, login scripts, and batch files.

NOTE: If you have an earlier version of DAS or ARS installed on your workstations, uninstall these
versions prior to installing the new version of DAS.

In this Section

+ Installing DAS in an eDirectory Environment
+ Installing DAS in Other LDAP Environments
+ Installing DAS in Active Directory, ADAM, or Standalone Environments

+ Installing DAS by Using the Modify Option
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78

*

*

1
2

N o un b

Accessing DAS
Tips for Installing DAS

Installing DAS in an eDirectory Environment

Log in to the workstation as an administrator.

From the SecureLogin\Client, select the appropriate install package and double-click it to
begin the install process. The Installation Wizard for Securelogin is displayed.

Click Next. The License Agreement page is displayed.

The Destination Folder page is displayed. By default, the program is saved in C: \Program
Files\NetIQ\SecureLogin\.

Accept the default folder or click Change and navigate to your desired folder.
Select eDirectory as the directory where Securelogin stores its data.

Click Next. The protocols page is displayed

Select how you want SecurelLogin to access eDirectory.

If the Novell Client is installed, the installation program recommends the Novell Client for
Windows option. Otherwise, LDAP is recommended.

This dialog box is displayed only if you have Novell Client for Windows installed on your
machine. Otherwise, LDAP is auto-selected as the protocol.

Click Next. The smart card option page is displayed.

9 Click Yes if you want to use a smart card. If you do not want to use a smart card, proceed with

10
11

12
13
14
15

16
17

Step 11.

9a Select a cryptographic service provider from which Securelogin requests PKI credentials
through a Microsoft Crypto API.

9b Select a PKCS#11 compatible library required for accessing the smart card, then click Next.

This specifies the location of the Cryptographic Token Interface installed as part of the
smart card vendor’s software. These API files are used by SecureLogin to communicate
with the smart card.

Click No if you do not want to use smart card support. Proceed with Step 11.
Select the eDirectory features that you want to install, then click Next.

You can select both Novell SecretStore Client and Novell NMAS Methods.
Click Next.

Select the NMAS Methods.

Click Next. The installation features page is displayed.

Select Install Desktop Automation Services.

If you are installing DAS on a kiosk or shared desktop, deselect Start SecureLogin on Windows
startup. By default, this option is selected.

DAS handles starting and stopping for SecureLogin.
Click Next. The location for the DAS configuration file page displayed.

Select the location for the configuration file.
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18
19
20
21

If you choose Local, the registry settings set for ARS . exe use the actions.xml file located in the
Program Files\NetIQ\SecurelLogin\Desktop Automation Services folder of the
workstation.

Click Next. The program is ready to install.
Click Install.
Click Finish. By default, the Launch ReadMe option is selected

You are prompted to restart your system. Select Yes to restart the system for Desktop
Automation Services to take effect.

When you install DAS in eDirectory mode with the Novell Client, you might see an error indicating
Error in parsing xml file during install appears. This occurs because the server or the
specified config object is invalid.

To fix the problem, ignore the message and proceed with the install. After the installation or restart;

1
2

3

Log in as an administrator.
Set the ConfigObject and ConfigTree registries values correctly.

The ConfigObject is the ArsControl Object and ConfigTree - Server or the Tree
information. The registry settings are at HKLM\ Software\Novell\Login\ARS.

Run ARSControl /RegServer.

Installing DAS in Other LDAP Environments

1
2

Log in to the workstation as an administrator.

From the SecurelLogin\Client, select the appropriate install package and double-click it to
begin the install process. The Installation Wizard for Securelogin is displayed.

Click Next. The License Agreement page is displayed.

The Destination Folder page is displayed. By default, the program is saved in C: \Program
Files\NetIQ\SecureLogin\.

ccept the default folder.
or

Click Change and navigate to your desired folder.

5 Select Novell eDirectory as the directory where Securelogin stores its data.

Click Next. The protocols page is displayed
Select how you want SecurelLogin to access eDirectory.

If the Novell Client is installed, the installation program recommends the Novell Client for
Windows option. Otherwise, LDAP is recommended.

This dialog box is displayed only if you have Novell Client for Windows installed on your
machine. Otherwise, LDAP is auto-selected as the protocol.

Click Next. The smart card option page is displayed.
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9

10
11

12
13
14
15
16
17

18
19
20
21

Click Yes if you want to use a smart card. If you do not want to use a smart card, proceed with
Step 11.

9a Select a cryptographic service provider from which SecurelLogin requests PKI credentials
through a Microsoft Crypto API.

9b Select a PKCS#11 compatible library required for accessing the smart card, then click Next.

This specifies the location of the Cryptographic Token Interface installed as part of the
smart card vendor’s software. These API files are used by SecureLogin to communicate
with the smart card.

Click No if you do not want to use smart card support. Proceed with Step 11.
Select the install features that you want to install, then click Next.

You can select both Novell SecretStore Client and Novell NMAS Methods.
Click Next.

Select the NMAS Methods.

Click Next. The installation features page is displayed.

Select Desktop Automation Services as the feature that you want to install.
Click Next. The location for the DAS configuration file page displayed.

Select the location for the configuration file.

If you choose Local, the registry settings set for ARS.exe use the actions.xml file located in
the Program Files\NetIQ\SecureLogin\Desktop Automation Services folder of
the workstation.

Click Next. The program is ready to install.
Click Install.
Click Finish. By default, the Launch ReadMe option is selected

You are prompted to restart your system. Select Yes to restart the system for Desktop
Automation Services to take effect.

Installing DAS in Active Directory, ADAM, or Standalone

Environments

With this release of SecurelLogin, you can install DAS in Active Directory mode, as well as in ADAM
mode and standalone mode.

10.1.3
1
2
3
4
80

Log in to the workstation as an administrator.

From the SecureLogin\Client, select the appropriate install package and double-click it to
begin the install process. The Installation Wizard for SecurelLogin is displayed.

Click Next. The License Agreement page is displayed.

The Destination Folder page is displayed. By default, the program is saved in C: \Program
Files\NetIQ\SecureLogin\.You can accept the default folder or choose to change. To
change, click Change and navigate to your desired folder.

Accept the default folder. or choose to change. To change, click Change and navigate to your
desired folder.

or
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11

12
13

14
15
16
17

Click Change and navigate to your desired folder.

Select the directory where SecurelLogin stores its data.

In this example, Microsoft Active Directory is selected.

Click Next. The LDAP Authentication Setup page is displayed.

As an Active Directory user, you can use DAS only with local configuration. The default value for
the configuration file is Local.

Select when you want to log in to LDAP.

+ If you select After successfully logging into Windows, you are prompted to associate the
login user with your LDAP distinguished name.

+ If you select When Securelogin starts, you are prompted to specify the LDAP server
information.

Click Next. The smart card option page is displayed

Click Yes if you want to use a smart card. If you do not want to use a smart card, proceed with
Step 11.

9a Select a cryptographic service provider from which SecurelLogin requests PKI credentials
through a Microsoft Crypto API.

9b Select a PKCS#11 compatible library required for accessing the smart card, then click Next.

This specifies the location of the Cryptographic Token Interface installed as part of the
smart card vendor’s software. These API files are used by SecurelLogin to communicate
with the smart card.

Click No if you do not want to use smart card support. Proceed with Step 11.
Select Install Desktop Automation Services as the install feature that you want to install.

If you are installing DAS on a kiosk or shared desktop, deselect Start SecureLogin on Windows
startup. By default, this option is selected.

DAS handles starting and stopping for SecurelLogin.
Click Next. The location for the DAS configuration file page displayed.
Select a location for the configuration file.

If you choose Local, the registry settings set for ARS . exe use the actions.xml file located in
the Program Files\NetIQ\SecureLogin\Desktop Automation Services folder of
the workstation.

Click Next. The program is ready to install.
Click Install.
Click Finish. By default, the Launch ReadMe option is selected

You are prompted to restart your system. Select Yes to restart the system for Desktop
Automation Services to take effect.

10.1.4 Installing DAS by Using the Modify Option

1

2

Launch Securelogin after you have successfully upgraded to or installed version 7.0. The
Program Maintenance page appears.

Select Modify, then click Next. The Custom Setup page appears.
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3 Select Desktop Automation Services then click Next.
4 Click Install. DAS is installed.

DAS is installed in the same folder as Securelogin. It is typically installed at C: \Program
Files\NetIQ\SecureLogin\Desktop Automation Services unlessyou choose a different
destination folder for the installation.

After you have successfully installed DAS through the Modify option, DAS initializes the ConfigObject
and ConfigTree registry keys, which are related to DAS network configuration.

To use the DAS XML script from the network, you must modify these registry keys.

+ For information on modifying the ConfigObject registry key, see “ConfigObject” on page 85.

+ For information on modifying the ConfigTree registry key, see “ConfigTree” on page 85.

Accessing DAS

After you install DAS, the services are available individually or in combination through a DAS
executable that can be accessed from any scripting interface available on Microsoft Windows, such
as VBScript, JavaScript, login scripts, and batch files.

+ “Accessing DAS through the Command Line Utility” on page 82

+ “Accessing DAS through VBScript” on page 82

+ “Accessing DAS through JavaScript” on page 83

+ “Accessing DAS through Visual Basic” on page 83

Accessing DAS through the Command Line Utility

shortcut target = “C: \Program Files\NetIQ\SecurelLogin\Desktop Automation
Services\ARS.exe" startup

NOTE: If you set up the workstation to automatically log in and you want DAS to start automatically,
place a DAS shortcut in the Windows Startup group under the Start > Programs > Startup file
directory.

Accessing DAS through VBScript

<SCRIPT LANGUAGE = "VBScript">
Sub physiciansApps
Dim as
Set as = CreateObject ("ARS.Control")
ars.Execute ("Run Physicians Applications")
End Sub

</SCRIPT>
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Accessing DAS through JavaScript

You can launch a DAS action through a JavaScript within an HTML page and launch the applications,
log out, and perform other defined actions.

+ To set up a link on the HTML page, specify the following:

<a href='javascript:var ars = new ActiveXObject ("ARS.Control");
ars.Execute ("Physicians Application"”", null);'>Physicians Application
Group</a>

+ To set up a function call in the HTML page, specify the following:

function das onclick logout ()
{var ars = new ActiveXObject ("ARS.Control") ;
ars.Execute ("logoff", null);}

NOTE: You might get an ActiveX content warning from Internet Explorer 6.0 or later. To avoid
the warning, select Tools > Internet Options > Advanced within Internet Explorer. Scroll down to
the Security tab and select Allow active content to run in files on My Computer, then click OK.

Accessing DAS through Visual Basic

<Assembly: Guid ("ABB6194C-DDEC-4369-8ADF-E29BB367EDOC") >
Module Modulel
Sub Main ()
Dim arsObj As ARS.IARS = New ARS.CARSControl
arsObj.Execute ("Run Physicians Applications")

End Sub

End Module

10.1.6 Tips for Installing DAS

+ You can refresh the DAS configuration through the command line by using the ARS/refresh
command. For example, ARS.exe/refresh refreshes ARS . exe.

The other way to refresh the DAS configuration is to restart the ARSControl.exe process or
reboot the workstation.

The ARS/refresh command is better for managing your environments and does not force a
reboot when you make an update to the actions.xml file.

+ You can close DAS through the command line byusing the ARS /shutdown command. For
example, ARS.exe /shutdown shuts down the ARSControl.exe

¢ Set up the actions.xml file by using the standard template provided in the Tools folder or
modify the file based on the use case scenarios that you have developed with your users.

+ You can have different actions.xml files managed locally on the unique workstations in order
to have special use cases and common workstations pointing to eDirectory.
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+ Set up the workstation to have auto-admin login to a local workstation ID.

For more information, see the Novell Cool Solutions Web site. (http://www.novell.com/
coolsolutions/tools/14071.html)

+ Provide a logout button in the Windows Quick Launch toolbar and provide a logout icon on the
desktop for the convenience of users. You can also provide a hot key combination such as Ctrl+L.

For example, you can use a shortcut target =“C: \Program
Files\NetIQ\SecureLogin\Desktop Automation Services\ARS.exe” logoff. This is
your shortcut properties target setting.

Figure 10-1 Logoff Shortcut Option

Logoff Properties

[ Generali Shartcut !Eu:umpatil:uilit_l,l' Securty | Netware Version |

@ Logaff

Target type: Application

Target location: Desktop Automation Services

qin'\Deskiop Automation Serviceshars.exe” logoff
|

Target: |

Start in; | "C:A\Program Filez\MovelhSecureLogintDeszktop |

Shaortcut key: | Mane |

Run: | MHaormal window ol

Caomment: | |

[ Find T arget. .. l [ Change lcon... ] [ Advanced... ]

I ]S ] [ Cancel

10.2 Configuring DAS

+ Section 10.2.1, “Editing Environment Registry Keys,” on page 85
+ Section 10.2.2, “Managing DAS Logs,” on page 86
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10.2.1

Editing Environment Registry Keys

After DAS is successfully installed, it initializes some registry keys. You must edit the registry keys to

configure the system for your workstation.

To view and edit the registry keys:

1 Click Start > Run, type RegEdit, then click OK. The Registry Editor is displayed.
2 Browse to HKEY_LOCAL_MACHINE\SOFTWARE \Novell\ARS.

3 Modify the following keys to adapt the installation to your workstation environment:

Key Name Value

Description

ConfigFile C:\Program
Files\NetIQ\Securelogin
\Desktop Automation
Services\actions.xml

The value is the default value.

ConfigObject cn=ARSControl
ou=ARS
0=CHIP
ConfigTree IP address of the directory:

XXX XXX XXX XXX

The default value is null.

This is the pathname for the actions.xml
file that defines the actions for the
workstation.

Use this key only when you are referring to an
actions.xml file loaded locally to the
workstation.

If you are using a directory-based
actions.xmnl file, set the key value to null
(blank).

This is the value of the fully distinguished
name (DN) of an ARSControl object.

This key is the object in the directory that
stores the actions.xml file.

This value can be the tree name or the IP
address of the eDirectory tree that contains
the ARSControl object.

Leave the key blank if the ConfigFile key
is used with a locally installed actions.xml
file on the workstation.

NOTE: The tree name must be specified for
DAS to access an ARSControl object.

The server on which the object is residing
must be SLP enabled.
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10.3

10.3.1

Managing DAS Logs

You can configure the ARSControl.exe application for four levels of logging. These logs are stored in
the location $1ocalAppdata%\SecureLogin\Logs\SSODebug.txt. You can enable or disable
DAS logging manually by updating the registry settings or using the SecurelLogin Logging Manager.
For more information on SecurelLogin Logging Manager refer, Section 2.5, “Managing Log Settings
for SecureLogin Components,” on page 16.

To enable the DAS logs using the registry settings, perform the following:

1 Click Start -> Run, enter RegEdit, then click Ok. The Registry Editor is displayed.
2 Browse to HKLM\ SOFTWARE\Protocom\SecureLogin\Logging\

3 Right click and add a new key entry of type DWORD and name it as DAS.

4 Set the value for the DAS key entry as follows:

Table 10-1 DAS Log Registry Key Values

Value Name or Log Type
0 Debug

1 Information

2 Warning

3 Fatal

NOTE: To disable the DAS logs, delete the respective DAS key entry from the registry.

Deploying DAS

Each deployment of DAS is unique to your use case, user target group, application mix, and other
factors.

In the following sections, we list some of the best practices and some common debugging issues that
you can consider during your deployment.
+ Section 10.3.1, “Best Practices for Deploying DAS,” on page 86

+ Section 10.3.2, “Common Debug Issues,” on page 87

Best Practices for Deploying DAS

+ Develop specific use case scenarios with the users on multi-user workstations.

+ If you are currently using network login scripts, analyze them to determine the steps that can be
streamlined or determine specific actions such as mapping the drives that can be accounted.

+ Prepare an inventory of all the applications and their versions on the workstation.

Determine if there are any security policies or other technical aspects that might affect the
deployment.
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+ Make a note of the processes running in the task manager when a user is logged in to the
network. This helps to determine whether there are any applications that must be auto-
launched or excluded during a logout event.

+ If a use case requires applications to be shut down as part of user logout or a time-out event,
access each application carefully to ensure that Desktop Automation Service does not have any
adverse effect in the application sessions. For example, terminal emulator sessions or unsaved
logout (graceful logout).

Analyze each application to determine the best way to handle a fast shutdown.

+ When updating actions.xml files, if you want to activate the latest changes without
rebooting the workstation, issue a command to the workstation to ARS. exe to reload the
actions.xml: "C:\Program Files\NetIQ\SecureLogin\Desktop Automation
Services\ars.exe" [frefresh

10.3.2 Common Debug Issues

+ The action names are case-sensitive. Ensure that you follow a common naming convention,
such as always using lowercase.

+ The DAS log file(SSODebug. txt) indicates the syntax errors (if any) in the actions. xml file. If
the syntax errors are not indicated, run each section separately to determine the error while
parsing the actions.xml is executed.

+ Enable the log file and set the log level to 3 (Fatal) on development workstations to help debug
the issues. After you have completed the testing, set the log level to zero to have minimal
logging.

+ Delete the SSODebug. txt file after you have tested at log level 3 because the file size is large.

+ eDirectory can centrally store different workstation behaviors that require different DAS
configuration files.

Configure the client in the registry to point to the desired DAS configuration object in the
eDirectory.

You can also have the different actions.xml files managed locally on the unique workstations
and have the other common workstations point to eDirectory.

+ When forcing the ICA Client to shut down with DAS, you should provide a pause before forcing
the shutdown.

When DAS tries to shut down the ICA Client, it sends a WM_CLOSE message to the Citrix client.
The Citrix client resends the message to the published application t If there is a timeout or if the
application is slow to respond, DAS quickly forces the shutdown and does not allow the Citrix
application to gracefully shut down. Adding a pause addresses the timing requirement.

+ Add pauses in the actions.xml file if you notice any unusual behavior or observe that some
use cases are not met as expected. There might be some timing issues with certain event
executions, so you should ensure that you set the correct values for the serial = true or false
parameters.
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Installing SecurelLogin with Advanced
Authentication

Prerequisites:

*

*

Advanced Authentication must be installed.

If you are using Advanced Authentication with TLS 1.2, you must install .NET 4.5 in the system.

For information about installing Advanced Authentication, see Advanced Authentication- Server
Installation and Upgrade.

To install SecurelLogin, perform the following steps:
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10
11
12

Run the NetIQSecurelLogin.exe file.

Accept the license agreement.

Click Next to view the Setup Options screen.

Select the desired datastore.

Click Next to view the Ready to Install screen.

Click Install.

Click Next to view the Custom Setup screen.

From the Custom Setup screen, select Advanced Authentication.
Click Next to view the Cache File Location screen.

The location is auto-populated, but you can click Browse to select an alternative folder to store
the user settings.

NOTE: Ensure the users have write access for the specified folder.

Click Next to view the Advanced Authentication Server screen.

In the Advanced Authentication Server screen, enter the Server Address, Port and Event Name.
Click Next.

Securelogin is by default installed in C: \Program Files\NetIQ\SecureLogin folder.
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Installing SecureLogin Browser Extensions

Securelogin supports single sign-on for web applications using Internet Explorer, Mozilla Firefox, and
Google Chrome browsers. To enable single sign-on for web applications in Mozilla Firefox and
Google Chrome, you must install the Single Sign-on Assistant extension or NetlQ Securelogin SSO
Extension in the respective browser.

Single Sign-on Assistant provides a secure single sign-on experience for Access Manager,
CloudAccess, and SecureLogin users by allowing automatic authentication for configured
applications. NetlQ recommends that you use Single Sign-on Assistant instead of NetlQ SecurelLogin
SSO Extension.

IMPORTANT: The Single Sign-on Assistant extension is supported for SecurelLogin 8.5.3 and later. You
must remove the NetlQ SecureLogin SSO Extension from your browser before installing Single Sign-
on Assistant extension.

Download and install the required SecurelLogin browser extension for Google Chrome and Mozilla
Firefox using the following information:
+ Section 12.1, “Installing Single Sign-on Assistant in Google Chrome,” on page 91

+ Section 12.2, “Installing Single Sign-on Assistant in Microsoft Edge (Chromium-based),” on
page 92

¢ Section 12.3, “Installing Single Sign-on Assistant in Microsoft Edge (HTML-based),” on page 92
+ Section 12.4, “Installing Single Sign-on Assistant in Mozilla Firefox,” on page 92

+ Section 12.5, “Installing NetlQ Securelogin Extension in Google Chrome,” on page 93

+ Section 12.6, “Installing NetlQ Securelogin Extension in Mozilla Firefox,” on page 93

+ Section 12.7, “Configuring HTML Basic Authentication for SecureLogin Using Single Sign-on
Assistant,” on page 94

12.1 Installing Single Sign-on Assistant in Google Chrome

1 If NetlQ Securelogin SSO Extension is installed, perform Step 2. Otherwise, continue from
Step 3.

2 Perform the following steps in the Google Chrome browser to remove NetlQ SecurelLogin SSO
Extension:

1. Click More Tools > Extensions.

2. Locate NetlQ SecurelLogin SSO Extension.

3. Click the delete icon to remove NetlQ SecureLogin SSO Extension.
3 In the Google Chrome browser, click More Tools > Extensions > Get more extensions.
4 Specify Single Sign-on Assistant in the search field.

5 Locate and click Single Sign-on Assistant in search results.
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6 Click ADD TO CHROME.
7 Click Add extension.

8 To perform auto update in the chrome browser, click Settings > Extensions > Update extensions
now to force update the extension manually.

12.2 Installing Single Sign-on Assistant in Microsoft Edge
(Chromium-based)

You can install the Single Sign-on Assistant extension from the Microsoft store. After installation, you
must apply the appropriate settings in SecurelLogin. In the Preferences > Web page, ensure that
Microsoft Edge settings are applied.

NOTE: Installing the Single Sign-on Assistant extension from the Chrome web store is not supported.

Perform the following steps to install Single Sign-on Assistant:

1 In Microsoft Edge, click Extensions > Get extensions for Microsoft Edge.
2 Specify Single Sign-on Assistant in the Search field.

3 Locate and click Single Sign-on Assistant in the search results.

4 Click Get > Add extension to start installation.

5 Restart Edge.

12.3 Installing Single Sign-on Assistant in Microsoft Edge
(HTML-based)

In Microsoft Edge, click Settings and more > Extensions > Explore more extensions.
Specify Single Sign-on Assistant inthe Search field.

Locate and click Single Sign-on Assistant in the search results.

Click Get to start installation.

When the installation is complete, click Launch to switch to Edge.

Read the notification about what the extension is allowed to do, and select Turn it on.
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Restart Edge.

12.4 Installing Single Sign-on Assistant in Mozilla Firefox

NOTE: Single Sign-on Assistant is supported for Mozilla Firefox 50 and later.

1 If NetlQ Securelogin SSO Extension is installed, perform Step 2. Otherwise, continue from
Step 3.

2 Perform the following steps in the Mozilla Firefox browser to remove NetlQ SecurelLogin SSO
Extension:

1. Click Add-ons > Extensions.
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2. Locate NetlQ SecurelLogin SSO Extension.
3. Click Remove to remove NetlQ Securelogin SSO Extension.
In the Mozilla Firefox browser, click Add-ons > Extensions.
Specify Single Sign-on Assistant in the Search all add-ons field.
Locate Single Sign-on Assistant in the search results and click Install.
Click Accept and Install... in the End-User License Agreement window.
Click Add when the Mozilla Firefox browser prompts to add Single Sign-on Assistant extension.
Click OK.
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For accessing applications that are local to your system, after installing the extension select Allow
access to file URLs under the Single sign-on Assistant. This allows SecureLogin to login and fill the
form for local files such as file:///C:/dev/test.html.

12.5 Installing NetlQ SecurelLogin Extension in Google
Chrome

1 In the Google Chrome browser, click Settings > Extensions > Get more extensions.
2 Specify NetlQ Securelogin SSO Extension in the search field.

3 Click NetlQ Securelogin SSO Extension and follow the on-screen prompts.

If you already have an older version of NetlQ SecureLogin SSO Extension installed, it is recommended
to install the Single Sign-on Assistant plug-in.

12.6 Installing NetlQ SecurelLogin Extension in Mozilla
Firefox

NOTE: NetlQ SecurelLogin SSO Extension is supported for Mozilla Firefox 50 and later.

1 Download NetlQ Securelogin SSO Extension for Mozilla Firefox from the NetlQ Product
download site.

1a Inthe product download site, select the product as SecureLogin and the version as
Securelogin 8.5, then click Submit Query.

1b From the search result click NetlQ SecurelLogin 8.5.
1c Click proceed to download and follow the on-screen prompts.
2 In the Mozilla Firefox browser, click Add-ons > Extensions.

3 Drag the downloaded NetlQ Securelogin SSO Extension to the Extensions page of Mozilla
Firefox.

NOTE: If you download the extension using Google Chrome, the extension is downloaded as a
.zip file. You must drag the complete zip file to install the extension in Mozilla Firefox.

4 Click Install.
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12.7

For accessing applications that are local to your system, after installing the extension select Allow
access to file URLs under the NetlQ Securelogin SSO Extension. This allows Securelogin to login and
fill the form for local files, such as file:///C:/dev/test.html.

Configuring HTML Basic Authentication for
Securelogin Using Single Sign-on Assistant

IMPORTANT: HTML Basic Authentication does not process the message box command of
Securelogin in Mozilla Firefox. The message box command is processed only when the user interacts
with the HTML page.

SecurelLogin supports HTML Basic Authentication when using Single Sign-on Assistant 3.3 with
Google Chrome and Mozilla Firefox. It provides authentication in the following three scenarios.

Default: This scenario does not require a single sign-on script. It creates the credential set for the
respective authentication prompts and saves the credentials for the subsequent single sign-on
operations to provide seamless sign-on. It uses the following format for the credential set.

Domain "Realm"

Using the Single Sign-on Scripts: Perform the following steps to write your own single sign-on script
or application definitions to enable HTML Basic Authentication.

Right-click the SecurelLogin system tray icon and click Manage.

Right-click Applications and click New.

In New Application, select New Application Definition.

In Type, select Generic.

In Name, specify CredentialSelection.

Click OK.

Navigate to Applications > Generic > CredentialSelection.
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Specify your application definitions in Definition. The following is a sample application
definition:

if "abc.xyz.123.com" -in ?domain

debugprint "Setting credential to domain credentials"
Set ?Credential apptest-correct

else
Set ?Credential apptest-wrong
endif

NOTE: For multiple HTML Basic Authentication requests, you can use the same CredentialSelection
type with a custom definition for each URL.

Using the System Credentials: Seamless sign-on to authentication prompts is achieved when user
logs into Windows. The following is a sample application definition:
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if "abc.xyz.123.com" -in ?domain
set ?Credential "-SYSCREDENTIAL"

endif
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13.1

13.2

Installing and Uninstalling SecurelLogin
with AutoPass License Feature

AutoPass License Server (APLS) can be integrated with NetlQ SecureLogin 9.1 using the Ul or through
the Command line. Following sections provide the details on installation and uninstallation process
of AutoPass License feature:

+ Section 13.1, “Install AutoPass License Feature Using NetlQ SecurelLogin Ul,” on page 97
+ Section 13.2, “Install AutoPass License Feature Using Command Line,” on page 97

¢ Section 13.3, “Uninstall AutoPass License Feature,” on page 98
Prerequisite:

Install AutoPass License Server. For more information, see Install.

Install AutoPass License Feature Using NetlQ
SecurelLogin Ul

Perform the following to integrate APLS with Securelogin:
1. Runthe NetIQSecurelLogin.exe file.

If NetlQ SecurelLogin 9.1 is already installed, use the Modify option to integrate APLS.
2. Select AutoPass License from the Custom Setup window.

3. Provide the IP address of the server where APLS is installed.

NOTE: If you are installing SecureLogin in the same machine where APLS is present, then you
must provide hostname.

4. By default, the port is 5814. You can change the port as per your configuration.

Install AutoPass License Feature Using Command Line

Prerequisite
SecurelLogin requires the latest Microsoft Windows Installer.

1. Login as an administrator.

2. Launch the command prompt.

3. Browse to the location where you have saved the Securelogin installer package.
4

. RunNetIQSecurelLogin.exe.

For more information about installing SecureLogin using Command Line, refer Installing through the
Command Line.
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When installing SecureLogin, GPO and RunAtStartup features are installed by default.

Use the following table as reference to specify APLS feature when installing SecureLogin.

TIP: APPENDLOCAL can be used to install any specific feature using the feature name. For enabling
multiple features, specify the feature names separated by a comma.

For example: To install DAS, and SmartCard, use APPENDLOCAL in the following manner:
APPENDLOCAL=DAS, SmartCard

Table 13-1 Command for Installing APLS Feature

Command Line Value Description Example
Parameters
AutoPassLicense Installs APLS feature for the APPENDLOCAL=AutoPassLicen
license count. se
LICENSE_SERVER_ADDRESS=1O
.71.130.107

13.3 Uninstall AutoPass License Feature

Perform the following to remove APLS integration with SecurelLogin:

1. Runthe NetIQSecureLogin.exe file.
2. Click Uninstall.

3. Deselect AutoPass License from the feature tree.
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14.1

Installing, Uninstalling, and Upgrading
Analytics Dashboard Plug-in

Install the Analytics Dashboard plug-in to share and represent SecurelLogin analytics data to
Analytics Dashboard. This installation establishes a connection between SecurelLogin and NetlQ
Access Manager.

+ Section 14.1, “Prerequisites for Installing Analytics Dashboard Plug-in,” on page 99
+ Section 14.2, “Installing Analytics Dashboard Plug-in,” on page 100

¢ Section 14.3, “Uninstalling Analytics Dashboard Plug-in,” on page 100

+ Section 14.4, “Upgrading Analytics Dashboard Plug-in,” on page 100

Prerequisites for Installing Analytics Dashboard Plug-in

Ensure that the following components of Access Manager 5.0.2 are installed and configured:
+ Administration Console
+ |dentity Server
+ Analytics Server

For more information about installing Access Manager components, see NetlQ Access Manager 5.0
Installation and Upgrade Guide.

Ensure the following with respect to NetlQ Securelogin:

+ NetlQ Securelogin 8.8 or above must be installed.

+ The Syslog Auditing feature is enabled with either Forward to SysLog Server or SysLog Server. Set
the fields as follows:

+ Specify the Analytics Server address in the Server Address field.
+ Specify the Port as 1469 with either TCP or UDP connection.

For more information, see Logging of Syslog Audit Messages

NOTE: This plug-in integrates with Access Manager 5.0.2. Following are some limitations of the plug-
in:

¢ Only a TCP or UDP connection on port 1469 is supported.

+ Only English localization is supported.

+ It is not supported with Access Manager container deployment.
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14.2

14.3

14.4

Installing Analytics Dashboard Plug-in

Perform the following steps to install the Analytics Dashboard plug-in:

1 Download Access Manager Analytics Dashboard.

2 Navigate to Plugin/SecureLogin.

3 Runthe sh plugin install.sh script.

4 For the install confirmation, This will Install Analytics Server. Would you like to continue (y/n) ?

Entery

NOTE: In case of cluster deployment, plug-in must be installed on all the nodes.

NOTE: In case of Access Manager channel deployment, plug-in must be installed manually from </
opt/novell/channel/dashboard/Plugins/SecureLogin/>.

Uninstalling Analytics Dashboard Plug-in

Perform the following steps to uninstall the Analytics Dashboard plug-in:

1 Navigate to Plugin/SecureLogin.
2 Runthe sh plugin uninstall.sh script.

3 For the uninstall confirmation, This will Uninstall Analytics Server. Would you like to continue (y/
n)?

Entery

NOTE: In case of cluster deployment, plug-in must be uninstalled from all the nodes.

NOTE: In case of Access Manager channel deployment, plug-in must be uninstalled manually from
</opt/novell/channel/dashboard/Plugins/SecureLogin/>.

Upgrading Analytics Dashboard Plug-in

Perform the following steps to upgrade the Analytics Dashboard plug-in:

1 Navigate to Plugin/SecureLogin.
2 Runthe sh plugin upgrade.sh script.

3 For the upgrade confirmation, This will Upgrade Analytics Server. Would you like to continue (y/
n)?

Entery

NOTE: To upgrade from Beta release of the plug-in to the Analytics Dashboard Plug-in 1.0, you must
have Access Manager 5.0 SP2 Analytics Dashboard.
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NOTE: In case of cluster deployment, plug-in must be upgraded on all the nodes.

NOTE: In case of Access Manager channel deployment, plug-in must be upgraded manually from </
opt/novell/channel/dashboard/Plugins/SecureLogin/>.
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5 Modifying, Repairing, or Uninstalling

If you have Securelogin already installed, the Installation Wizard detects the installation and offers
you several options for changing the existing configuration.

Table 15-1 |Installer Options for Changing Existing Configuration

Option Description

Modify Use the Modify operation to uninstall features installed during installation. However, you
cannot change the options that are not listed. For example, you cannot use Modify to change
the platform.

For details about installing additional features, see Using the Modify Option to Install Features.

Repair Use the Repair operation if you want to install any missing components. The installation
program detects the previously installed components and re-installs them.

Uninstall Use the Uninstall operation if you want to uninstall SecureLogin and do a fresh install. For
example, you installed an evaluation version of SecurelLogin in the standalone mode. After a
successful evaluation, you now want to install SecureLogin throughout your organization,
which is using eDirectory.

NOTE: When you perform the modify operation, you must not change the data store of SecureLogin.
You can modify the features of SecurelLogin but should not modify the data store.

15.1 Using the Modify Option to Install Features

If you have not installed some of the features such as Smartcard during the initial installation of
Securelogin, you can to do it later through the Modify option.

The following example explains installing Smartcard through the Modify option:

1 Runthe NetIQSecurelLogin.exe file.

2 Select Modify.

3 Select a datastore.

4 From the Custom Setup screen, select Smartcard.

5 Click Next to install.

15.2 Modify Option and Group Policy Objects Support

During a fresh install of SecurelLogin, the Group Policy Objects support can be selected and installed
in Active Directory Application Mode (ADAM) or Active Directory (AD) environments only.
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If you are using the Modify option in a non-AD or ADAM environment, the GPO option still shows as
an selectable option even though GPQO's are not supported in non-AD or ADAM environments.
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16.1

16.2

16.2.1

Upgrading SecurelLogin

*

Section 16.1, “Prerequisites for Upgrading SecurelLogin,” on page 105

*

Section 16.2, “Planning for the SecurelLogin Upgrade,” on page 105

*

Section 16.3, “Upgrading Securelogin,” on page 108

*

Section 16.4, “Upgrading Desktop Automation Services,” on page 108

*

Section 16.5, “Upgrading Advanced Authentication,” on page 109

Prerequisites for Upgrading SecurelLogin

Before upgrading Securelogin, perform the following tasks:

O Identify mobile and kiosk workstation users.
O Complete the migration plan.
O Back up your Securelogin data by exporting to an XML file.

O Stop Securelogin. You cannot run the application during an upgrade.

Planning for the SecurelLogin Upgrade

+ Section 16.2.1, “Developing a Migration Plan,” on page 105
+ Section 16.2.2, “Example of a Migration Plan,” on page 106

Developing a Migration Plan

To ensure a smooth transition, it is recommend that you develop a migration plan. You must
determine the following information to develop the migration plan:
O Version of Securelogin:
+ Set to run on the directory.
¢ Installed on the administration workstation.
+ Installed on each user workstation.
Time frame within which you must complete the full upgrade
Deployment method (automated or manual)
Total number of users
Which containers/organizational units each user belongs to

Kiosk mode users

Qaoaoaaaoaaq

Laptop users
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16.2.2

O Users, if any, you need to upgrade first

O Applications required to be SecurelLogin enabled

Example of a Migration Plan

You can develop and document migration plans in various ways. The following is an example of one
of ways.

Scenario:
Acme is an organization with a total of 30,000 employees.

+ 16,000 employees are allocated a fixed workstation
+ 3,000 employees are laptop users
+ 11,000 employees access applications in Kiosk mode
The network environment is Microsoft Active Directory, and SecurelLogin version 3.5 is

implemented. All users are managed from one administration workstation. ZENworks is used for
application distribution and deployment generally occurs overnight.

Sales OU users have laptops for mobile access to the network. The Central Administration OUs
contain a combination of static workstations and laptop users. Manufacturing and Purchasing OU
users are mobile; workstations are accessed in Kiosk mode. Users in the remaining OUs are each
allocated a workstation for their sole use.

The Java functionality provided by the new version of SecurelLogin is eagerly awaited by users in the
Sales group, so they have volunteered to test the upgrade. After the upgrade is successfully deployed
to the Sales group, Securelogin is deployed in stages to the rest of Acme.

Upgrade Order

1. Directory and test user

Sales

Central Administration and Human resources
Account Marketing

Manufacturing and Purchasing

o vk W

Administration Workstation

Week 1

Day 1: Upgrade the server directory, extend the schema, and assign rights to the organizational
units. Ensure that all containers and organizational units have the following:

+ Directory database version 3.5

+ Stop tree walking

Create a test user in the Sales OU and change the setting for the user object to directory database
version value 7.0.

Test single sign-on enabling of required application.
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Day 2: On successful deployment of the upgrade for the test user, manually set the directory
database version to 6.0 on the Sales OU to enable full upgrade functionality.

Deploy the SecurelLogin upgrade on all Sales OU workstations/laptops. Assist Sales users with single
sign-on enabling for Java applications.

Ensure that all laptop users have the SecureLogin Cache setting enabled to ensure that the cache is
stored locally.

Day 3: Monitor any upgrade issues for the upgraded Sales OU users. If all issues have been resolved
successfully, install the SecurelLogin upgrade on all laptops and workstations associated with the
Central Administration and Human Resources OUs.

Set the directory database version to 6.0 on the Central Administration and Human Resources OUs
to enable full upgrade functionality.

Day 4: Install the SecurelLogin upgrade on workstations associated with the following OUs:

+ Accounting

+ Marketing
Day 5: Review and resolve any issues.
Day 6: Install the SecurelLogin upgrade on workstations associated with the following OUs:

+ Manufacturing

¢ Purchasing

Review any upgrade issues encountered by Central Administration OU users. If there are no
problems, change the directory database version to 6.0 setting for the following OUs:

+ Accounting

+ Marketing

Week 2

Day 7: All users now have upgraded the SecurelLogin application installed.
Review and resolve any issues.
Upgrade the administration workstation.

Day 8: If all issues are resolved successfully, change the directory database version to 6.0 for all
remaining OUs.

Ensure that the following OUs are also enabled simultaneously to provide service for mobile and
Kiosk users:

+ Manufacturing

+ Purchasing

The changeover is planned to occur at midnight and all users have been requested to log out prior to
or at this time and wait until 12.10 am before logging back in.

Day 9: Migration is completed. Review of the migration plan commences.
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16.3 Upgrading SecurelLogin

+ Section 16.3.1, “Supported Upgrade Paths,” on page 108
¢ Section 16.3.2, “Upgrading Using the Installer,” on page 108
+ Section 16.3.3, “Upgrading Through the Command Line,” on page 108

For information about how to migrate the datastore, see “Migrating the Datastore Using the
sIMigrationHelper Tool” in the NetIQ SecurelLogin 9.1 Administration Guide.

16.3.1 Supported Upgrade Paths

For the supported upgrade paths, see the release-specific Release Notes on the SecurelLogin
documentation website.

16.3.2 Upgrading Using the Installer

Run NetIQSecurelLogin.exe.
Click Proceed.
The Installation Wizard is launched. Click Next.

1
2
3
4 The license agreement page appears. Accept the license agreement.
5 Click Next. The Ready to Install the Program page appears.

6

Click Upgrade.

16.3.3 Upgrading Through the Command Line

+ Use the following command to update silently:

NetIQSecurelLogin.exe /install | / quiet

+ Use the following command to upgrade SecurelLogin without a root CA certificate:
NetIQSecurelLogin.exe /install INSTALLWITHOUTCACERT=Yes

+ Use the following command to upgrade SecurelLogin with a root CA certificate:

NetIQSecurelLogin.exe /install CERTPATH=C:\temp\cert.b64 /quiet

IMPORTANT: Upgrading Securelogin using the responsefile. ini file is not supported.

For more information, see Chapter 9, “Installing through the Command Line,” on page 63.

16.4 Upgrading Desktop Automation Services

During an upgrade, if Desktop Automation Services (DAS) is already present, the program upgrades
DAS and is a part of SecurelLogin. The configuration of DAS is retained.
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16.5 Upgrading Advanced Authentication

During an upgrade, if Advanced Authentication is selected, all files and registries related to the
Advanced Authentication feature are copied.

NOTE:

1 After upgrading Securelogin, the re-authentication method needs to be the same as configured
for the Advanced Authentication feature. To ensure this, navigate to Edit Wizard > Re-
Authentication and select the appropriate login method.

2 After upgrading Securelogin, the older 4.x interface to connect to Advanced Authentication 4.x
server is displayed along with newer interface. To resolve this, the user needs to uninstall the
4.x SecureLogin Advanced Authentication plug-in and use the latest interface which connects to
5.x Advanced Authentication server.
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1 7 Uninstalling SecurelLogin

Remove the Securelogin installation program through the Add/Remove Programs.

1 Click Start > Control Panel > Add /Remove Programs.
2 Select NetlQ Securelogin.

3 Click Remove.
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Extending the OpenLDAP Schema to
Support SecurelLogin

1 Copy SecurelLoginSSO.schema and SecureLoginSS02. schema to the /etc/openldap/
schema folder. The OpenLDAP schema files can be found on the SecurelLogin CD in the path of

<CD>/Securelogin/Tools/Schema/OpenLDAP.

2 Editthe slapd.conf file, and ensure that the following lines are included:

#include /etc/openldap/schema/core.schema
include /etc/openldap/schema/core.schema

include /etc/openldap/schema/cosine.schema

include /etc/openldap/schema/inetorgperson.schema
include /etc/openldap/schema/misc.schema

include /etc/openldap/schema/openldap.schema

# NetIQ ADDED THE FOLLOWING LINE

include /etc/openldap/schema/SecureLoginSSO.schema
include /etc/openldap/schema/SecureLoginSS02.schema

3 Edit the 1dap. conf file and ensure that the following lines are included:

#

# LDAP Defaults

# See ldap.conf(5) for details

# This file should be world readable but not world writable.

#BASE dc=example, dc=com
#URI 1ldap://ldap.example.com ldap://ldap-master.example.com:666

#SIZELIMIT 12
#TIMELIMIT 15
#DEREF never

HOST openldap.com

PORT 636

TLS_CACERT /ssl/certs/cacert.pem
TLS REQCERT demand

4 Open the core.schema file and make the following changes:
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objectclass ( 2.5.6.4 NAME 'organization'
DESC 'RFC2256: an organization'
SUP top STRUCTURAL
MUST o
MAY ( userPassword $ searchGuide $ seeAlso $ businessCategory $
x121Address $ registeredAddress $ destinationIndicator $
preferredDeliveryMethod $ telexNumber $ teletexTerminalldentifier $
telephoneNumber $ internationaliSDNNumber $
facsimileTelephoneNumber $ street $ postOfficeBox $ postalCode $
postalAddress $ physicalDeliveryOfficeName $ st $ 1 $ description $
protocom-SSO-Entries $ protocom-SSO-Auth-Data $ protocom-SSO-Security-
Prefs $ protocom-SSO-Entries-Checksum $ protocom-SSO-Security-Prefs-
Checksum $ protocom-SSO-Profile ) )

objectclass ( 2.5.6.5 NAME 'organizationalUnit'
DESC 'RFC2256: an organizational unit'
SUP top STRUCTURAL
MUST ou
MAY ( userPassword $ searchGuide $ seeAlso $ businessCategory $
x121Address $ registeredAddress $ destinationIndicator $
preferredDeliveryMethod $ telexNumber $ teletexTerminalldentifier $
telephoneNumber $ internationaliSDNNumber $
facsimileTelephoneNumber $ street $ postOfficeBox $ postalCode $
postalAddress $ physicalDeliveryOfficeName $ st $ 1 $ description $
protocom-SSO-Entries $ protocom-SSO-Auth-Data $ protocom-SSO-Security-
Prefs $ protocom-SSO-Entries-Checksum $ protocom-SSO-Security-Prefs-
Checksum $ protocom-SSO-Profile ) )

objectclass ( 2.5.6.6 NAME 'person'

DESC 'RFC2256: a person'

SUP top STRUCTURAL

MUST ( sn $ cn )

MAY ( userPassword $ telephoneNumber $ seeBAlso $ description $
protocom-SSO-Entries $ protocom-SSO-Auth-Data $ protocom-SSO-Security-
Prefs $ protocom-SSO-Entries-Checksum $ protocom-SSO-Security-Prefs-
Checksum $ protocom-SSO-Profile ) )
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