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Silk4NET
Silk4NET is the Silk Test plug-in for Microsoft Visual Studio. Silk4NET enables you to efficiently create and
manage functional, regression, and localization tests directly in Visual Studio. With Silk4NET, you can
perform the following tasks within Visual studio:
•
•
•
•
•
•

Record tests.
Develop tests using Visual Basic .NET.
Develop tests using C#.
Run tests as a part of a test plan in the Microsoft test environment.
Run tests as a part of your build process.
View test results.

For information on the tested versions of Visual Studio, refer to the Release Notes.
Silk4NET supports the testing of a broad set of application technologies.
For information about new features, supported platforms, and tested versions, refer to the Release Notes.
Designed for realizing automation benefits even when applied to complex tests, Silk4NET brings true test
automation capability directly to the developer’s preferred environment and lets you easily cope with
changes made in the test application. Additionally, the powerful testing framework of Silk4NET enables
high reusability of tests across multiple test projects, which further increases the achievable Return On
Investment (ROI). With less time spent on building and maintaining testing suites, your QA staff can
expand test coverage and optimize application quality.
Note: If you have opted not to display the start screen when you start Silk4NET, you can check for
available updates by clicking Help > Check for Product Update.
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Getting Started with Silk4NET
Silk4NET enables you to create and execute automated functional and regression tests. Perform the
following actions to get started with Silk4NET:
1. Create a Silk4NET project.
2. Create automated Silk4NET tests, either by recording actions or keywords, or by manually scripting the
tests.
3. Add the Silk4NET tests to your project. A project can include any combination of recorded tests and
manually scripted tests.
4. Execute the tests.
5. Analyze the test results.

Getting Started with Silk4NET
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Creating a Silk4NET Project
1. Click Silk4NET > New Project or File > New Project . The New Project dialog box displays.
2. Under Installed > Templates, click Visual Basic or Visual C#, select Test and then select Silk4NET
Project.
3. Type a name for the project into the Name field.
For the tutorial, type Tutorial.
4. Optional: Type a name for the solution into the Solution field.
5. Click OK. The Project Created dialog box opens.
6. Click Yes to start recording a new test or click No to create an empty project.
For the tutorial, click No.
If you have selected to start recording, the Add New Item dialog box opens.
7. In the Add New Item dialog box, select which type of test you want to record.
•
•

To bundle the recorded actions into one or more keywords, select Silk4NET Keyword-Driven Test.
To record the test without creating keywords, select Silk4NET Test.

8. If you have selected to start recording, type a name for the new test into the Name text box in the Add
New Item dialog box.
9. Click Add.
10.If you have selected to record a new Silk4NET test, the Select Application dialog box opens. Select
the tab that corresponds to the type of application that you want to test:
•
•
•

If you are testing a standard application that does not run in a browser, select the Windows tab.
If you are testing a web application or a mobile web application, select the Web tab.
If you are testing a native mobile application, select the Mobile tab.
11.To test a standard application, if you have not set an application configuration for the current project,
select the application from the list.
12.To test a web application or a mobile web application, if you have not set an application configuration for
the current project, select one of the installed browsers or mobile browsers from the list.
a) Specify the web page to open in the Enter URL to navigate text box. If an instance of the selected
browser is already running, you can click Use URL from running browser to record against the
URL currently displayed in the running browser instance. For the tutorial, select Internet Explorer
and specify http://demo.borland.com/InsuranceWebExtJS/ in the Enter URL to navigate text box.
b) Optional: If you want to test a web application on a desktop browser with a predefined browser size,
select the browser size from the Browser size list.
For example, to test a web application on Apple Safari and in a browser window which is as big as
the screen of the Apple iPhone 7, select Apple iPhone 7 from the list.
c) Optional: Select an Orientation for the browser window.
d) Optional: Click Edit Browser Sizes to specify a new browser size and to select which browser sizes
should be shown in the Browser size list.
13.To test a native mobile application (app) if you have not set an application configuration for the current
project:
a) Select the mobile device, on which you want to test the app, from the list.
b) Select the native mobile application.
•
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If you want to install the app on the mobile device or emulator, click Browse to select the app file
or enter the full path to the app file into the App file text field. Silk4NET supports HTTP and UNC
formats for the path.

•
•
•

If you want to use an app that is already installed on an Android device, select the app from the
Package/Activity list or specify the package and the activity in the Package/Activity field.
If you want to use an app that is already installed on an iOS device, specify the Bundle ID.
If you want to use an app that is available in Mobile Center, specify the App identifier.

14.Click OK. If you have selected an existing instance of Google Chrome on which you want to replay a
test method, Silk4NET checks whether the automation support is included. If the automation support is
not included, Silk4NET informs you that Google Chrome has to be restarted. The application and the
Recording window open.
If you have selected to create an empty Silk4NET test, a new solution containing the Silk4NET project is
created. Additionally, a Silk4NET test is created in the project with the following language-specific file
name:
•
•

UnitTest1.vb
UnitTest1.cs
Note: You can also use the context menu in the Solution Explorer to add Silk4NET projects to an
existing solution.

Creating a Silk4NET Project
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Adding a Silk4NET Test to a Project
You can only add Silk4NET tests to an existing Silk4NET or Test project. If no Silk4NET or Test project
exists, create a Silk4NET or Test project before you try to create a Silk4NET test.
1. Click Silk4NET > New Test or Project > Add New Item .
Note: If your solution contains more than one Silk4NET projects, select the project to which you
want to add the new test from the list in the Project Selector.
The Add New Item dialog box opens.
2. Under Installed, click one of the following:
•
•

If your project is a Visual Basic project, click Common Items > Silk4NET Test.
If your project is a Visual C# project, click Visual C# Items > Silk4NET Test.

3. Type a name for the test into the Name field and click Add. The Create a Silk4NET Test dialog box
opens.
4. Select how you want to create your Silk4NET test by clicking one of the following option buttons:
Record a Silk4NET test

Record actions and verifications against your application under test
and generate a new test containing the recorded automation
statements.

Create an empty Silk4NET
test

Create an empty test that can be filled with automation statements
later on.

For the tutorial, click Create an empty Silk4NET test.
5. Click OK.
6. If you have selected to record a new Silk4NET test, the Select Application dialog box opens. Select
the tab that corresponds to the type of application that you want to test:
•
•
•

If you are testing a standard application that does not run in a browser, select the Windows tab.
If you are testing a web application or a mobile web application, select the Web tab.
If you are testing a native mobile application, select the Mobile tab.
7. To test a standard application, if you have not set an application configuration for the current project,
select the application from the list.
8. To test a web application or a mobile web application, if you have not set an application configuration for
the current project, select one of the installed browsers or mobile browsers from the list.
a) Specify the web page to open in the Enter URL to navigate text box. If an instance of the selected
browser is already running, you can click Use URL from running browser to record against the
URL currently displayed in the running browser instance. For the tutorial, select Internet Explorer
and specify http://demo.borland.com/InsuranceWebExtJS/ in the Enter URL to navigate text box.
b) Optional: If you want to test a web application on a desktop browser with a predefined browser size,
select the browser size from the Browser size list.
For example, to test a web application on Apple Safari and in a browser window which is as big as
the screen of the Apple iPhone 7, select Apple iPhone 7 from the list.
c) Optional: Select an Orientation for the browser window.
d) Optional: Click Edit Browser Sizes to specify a new browser size and to select which browser sizes
should be shown in the Browser size list.
9. To test a native mobile application (app) if you have not set an application configuration for the current
project:
a) Select the mobile device, on which you want to test the app, from the list.
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b) Select the native mobile application.
•

•
•
•

If you want to install the app on the mobile device or emulator, click Browse to select the app file
or enter the full path to the app file into the App file text field. Silk4NET supports HTTP and UNC
formats for the path.
If you want to use an app that is already installed on an Android device, select the app from the
Package/Activity list or specify the package and the activity in the Package/Activity field.
If you want to use an app that is already installed on an iOS device, specify the Bundle ID.
If you want to use an app that is available in Mobile Center, specify the App identifier.

10.Click OK. If you have selected an existing instance of Google Chrome on which you want to replay a
test method, Silk4NET checks whether the automation support is included. If the automation support is
not included, Silk4NET informs you that Google Chrome has to be restarted. The application and the
Recording window open.
If you have selected to record the test, the recorded test is added to your project. If you have selected to
add an empty test, an empty Silk4NET test is added to your project.
Note: You can also use the context menu in the Solution Explorer to add Silk4NET tests to your
Silk4NET or Test project.

Adding a Silk4NET Test to a Project
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Recording a Silk4NET Test
1. Click Silk4NET > New Test or Project > Add New Item .
Note: If your solution contains more than one Silk4NET projects, select the project to which you
want to add the new test from the list in the Project Selector.
The Add New Item dialog box opens.
2. Under Installed, click one of the following:
•
•

If your project is a Visual Basic project, click Common Items > Silk4NET Test.
If your project is a Visual C# project, click Visual C# Items > Silk4NET Test.

3. Type a name for the test into the Name field and click Add. The Create a Silk4NET Test dialog box
opens.
4. Select Record a Silk4NET test and click OK.
5. If you have not set an application configuration for the current project, select the tab that corresponds to
the type of application that you are testing:
•
•
•

If you are testing a standard application that does not run in a browser, select the Windows tab.
If you are testing a web application or a mobile web application, select the Web tab.
If you are testing a native mobile application, select the Mobile tab.
6. To test a standard application, select the application from the list.
7. To test a web application or a mobile web application, if you have not set an application configuration for
the current project, select one of the installed browsers or mobile browsers from the list.
a) Specify the web page to open in the Enter URL to navigate text box. If an instance of the selected
browser is already running, you can click Use URL from running browser to record against the
URL currently displayed in the running browser instance. For the tutorial, select Internet Explorer
and specify http://demo.borland.com/InsuranceWebExtJS/ in the Enter URL to navigate text box.
b) Optional: If you want to test a web application on a desktop browser with a predefined browser size,
select the browser size from the Browser size list.
For example, to test a web application on Apple Safari and in a browser window which is as big as
the screen of the Apple iPhone 7, select Apple iPhone 7 from the list.
c) Optional: Select an Orientation for the browser window.
d) Optional: Click Edit Browser Sizes to specify a new browser size and to select which browser sizes
should be shown in the Browser size list.
8. To test a native mobile application (app) if you have not set an application configuration for the current
project:
a) Select the mobile device, on which you want to test the app, from the list.
b) Select the native mobile application.
•

•
•
•

If you want to install the app on the mobile device or emulator, click Browse to select the app file
or enter the full path to the app file into the App file text field. Silk4NET supports HTTP and UNC
formats for the path.
If you want to use an app that is already installed on an Android device, select the app from the
Package/Activity list or specify the package and the activity in the Package/Activity field.
If you want to use an app that is already installed on an iOS device, specify the Bundle ID.
If you want to use an app that is available in Mobile Center, specify the App identifier.

9. Click OK. If you have selected an existing instance of Google Chrome on which you want to replay a
test method, Silk4NET checks whether the automation support is included. If the automation support is
not included, Silk4NET informs you that Google Chrome has to be restarted. The application and the
Recording window open.
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10.Perform the interactions, which you want to record, with your application under test.
For additional information about recording a mobile application, see Recording Mobile Applications. For
information about the actions available during recording, see Actions Available During Recording.
11.When you are finished with recording, click Stop. The Recording Complete dialog box opens. From
this dialog box, you can click Playback to replay the recorded test.
•
•

If you are using Visual Studio 2010, you can also access the Test View in Visual Studio, where you
can replay and manage your tests.
If you are using Visual Studio 2012 or later, you can also access the Test Explorer in Visual Studio,
where you can replay and manage your tests.

The recorded interactions are added as a file to your project. The default file name of the generated file is
UnitTest<Index>.cs or UnitTest<Index>.vb, depending on the default programming language of
your project. For example, if you are recording the first test for a Visual Basic project, the name of the
generated file is UnitTest1.vb
Note: You can also create a new project and record the new test into the new project.

Recording a Silk4NET Test
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Running Silk4NET Tests
By default, Silk4NET 19.5 or later uses a 64bit JVM for keyword-driven tests. To run keyword-driven tests
with Silk4NET, set the default processor architecture under Test > Test Settings > Default Processor
Architecture in the Visual Studio menu to x64. Alternatively, you can specify your own 32bit JVM for
Silk4NET by setting the SILK_KEYWORD_DRIVEN_JAVA_HOME environment variable.
This topic describes how you can run your Silk4NET tests in Visual Studio.
1. To view all the tests that are available in the selected project or solution:
•
•

In Visual Studio 2010, click Test > Windows > Test View.
In Visual Studio 2012 later, click Test > Windows > Test Explorer.

2. In the Test View or the Test Explorer, depending on which version of Visual Studio you are using,
select the tests that you want to execute.
3. Right-click on your selection and click one of the following:
•
•

In Visual Studio 2010, click Run Selection.
In Visual Studio 2012 or later, click Run Selected Tests.

To run all tests in the selected project or solution, click Run All in the Test View or the Test Explorer,
depending on which version of Visual Studio you are using.
4. If you are testing a web application, the Select Browser dialog box opens. Select the browser and click
Run.
5. Optional: If necessary, you can press both Shift keys at the same time to stop the execution of the test.
6. When the test execution is complete, the Playback Complete dialog box opens. Click Explore Results
to examine the results of the tests with TrueLog or click OK to close the dialog box.
Note: When you execute your tests, and Visual Studio starts the components that are needed for the
execution of the tests, Visual Studio will clean up everything when the test execution is finished,
terminating the Open Agent and all open browser windows.
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Enabling TrueLog
For new Silk4NET scripts, TrueLog is enabled by default. You can enable or disable TrueLog by checking or
un-checking the Enable TrueLog check box in the TrueLog tab of the Script Options dialog box. To open
the Script Options dialog box, click Silk4NET > Edit Options.
To enable TrueLog for existing Silk4NET scripts, which are using the Visual Studio Unit Testing Framework,
you have to replace the TestClass attribute of all test classes in the script with the SilkTestClass
attribute.
To enable TrueLog for existing Silk4NET scripts:
1. Open the script that contains the test class for which you want to enable TrueLog.
2. Add the SilkTestClass attribute to the test class.
By default, the TrueLog is created in the TestResults sub-directory of the directory, in which the Visual
Studio solution file and the results of the Visual Studio Unit Testing Framework are located. To specify a
different location for the TrueLog, click Silk4NET > Edit Options to open the Script Options dialog box
and click Browse to the right of the TrueLog file field.
The Visual Studio solution file is the file in which the Silk4NET scripts are located. When the Silk4NET test
execution is complete, a dialog box opens, and you can click Explore Results to review the TrueLog for the
completed test.
Examples
To enable TrueLog for a class in a Visual Basic script, use the following code:
<SilkTestClass()> Public Class MyTestClass
<TestMethod()> Public Sub MyTest()
' my test code
End Sub
End Sub
To enable TrueLog for a class in a C# script, use the following code:
[SilkTestClass]
public class MyTestClass {
[TestMethod]
public void MyTest() {
// my test code
}
}

Enabling TrueLog
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Analyzing Test Results
After running a test, you can review the test results and analyze the success or failure of the test run.
1. Run a Silk4NET test. When the execution is finished, the Playback Complete dialog box opens.
2. Click Explore Results to examine the results of the tests.
3. Click through the results.
Silk4NET captures a screenshot whenever a test fails.
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