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Overview of File Compare/Merge
File Compare/Merge is a graphical file and folder comparison and merge tool delivered with StarTeam. It
enables you to compare the contents of two files or folders, and manually or automatically merge the
contents. The File Compare/Merge panes highlight differences using a configurable color scheme, and
dynamic action buttons display in the highlighted areas to simplify the merging process.
There are three versions of File Compare/Merge, and how you start File Compare/Merge determines which
features are available. The ability to edit text files in a File Compare/Merge pane depends on which version
of File Compare/Merge you are using, and what type of files you are comparing and merging. The following
sections describe editing capabilities in each version of File Compare/Merge.
Note: You cannot edit the actual historical revision of a file in the StarTeam repository.

Main File Compare/Merge
The main File Compare/Merge window is displayed using menu commands in the client, and allows you to
edit a local file, a merged base file, and a copy of a repository revision. When it opens in a separate
window you are able to do the following:
•

•
•
•

Compare the contents of a local file with the tip revision stored in the StarTeam repository. You can also
edit the contents of the local file from within the File Compare/Merge window, and save the changes for
check-in.
Compare two revisions of a file listed on the History tab in the StarTeam application window. Editing the
content of historical revisions is not allowed.
Merge the contents of a local file with the tip revision in the StarTeam repository. The merge results are
stored locally, and the file status is changed to Modified in StarTeam so you can check in the file.
Edit the temporary local copy of a repository revision and save it as a file with a different name.

The main File Compare/Merge gives you the option of viewing a third pane for displaying the merge results.
You can edit the contents in the third pane and save your merged results.
You can start File Compare/Merge using context menus on selected files in the StarTeam client, or by
checking in an older version of a file which causes a merge situation. You can also access File Compare/
Merge directly from the View Compare/Merge tool.
Embedded File Compare/Merge
In the embedded File Compare/Merge no editing is possible. This view gives you a quick way to do a
comparison of text in two files or versions of the same file, as well as compare properties of non-file items
such as change requests. If you are comparing two text files, It performs a dynamic comparison of two
selected files, or the selected repository file with your local working copy. It displays the text contents of
both files in an embedded pair of panes at the bottom of the StarTeam window. These embedded panes
only compare the contents of two text files, and do not permit editing or merging.
If you are comparing the properties of two non-file items, only the property values of each selected item
display in the embedded panes.
When the embedded File Compare/Merge is activated, it immediately compares the files or properties
when you do one of the following:
•
•
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Select a file or other item in the upper pane, or the History pane. The comparison is between the local
working copy of the item and the selected item revision in StarTeam.
Select two items in the History pane. The comparison is between the two historical revisions in
StarTeam.
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•

Select a linked item in the Link pane. The comparison is between the selected item revision and its
previous revision.

Standalone File Compare/Merge
In the standalone File Compare/Merge you can edit all files being compared and merged. The standalone
is started outside of the StarTeam client from the Windows Start menu. This File Compare/Merge
compares files, folders, and images, and it can merge the contents of two text files or two folders. Unlike
the main File Compare/Merge, the standalone version does not compare any local files with files that are in
the StarTeam repository. It compares and merges two or three files, folders, or images that are on your
local computer or network. You can edit text file contents directly in the File Compare/Merge panes, and
you can move lines or blocks of text between the panes. You can also move folders between the panes
during a folder comparison or merge.

Overview of File Compare/Merge
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File Compare/Merge UI
This topic describes the UI for File Compare/Merge (FCM).
There are three versions of File Compare/Merge:
•
•
•

Embedded , where the FCM panes are embedded at the bottom of the StarTeam client window. These
panes are for comparison only.
In a separate pop-up window inside the StarTeam client where you can compare and merge local files
and repository files.
In a standalone window outside the StarTeam client where you can compare and merge local files and
folders, and compare and move images.

Each version provides different features and functions and is explained briefly below:
Embedded File Compare/Merge
The embedded File Compare/Merge enables you to quickly compare the contents of a local text file and a
repository file, or two repository files. This view does not allow editing or merging.

Main File Compare/Merge
The main File Compare/Merge in the client enables you to compare local files with repository files, and edit
or merge the contents. Each compare/merge session is displayed on a separate tab in the File Compare/
Merge window.
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Standalone File Compare/Merge
The standalone File Compare/Merge runs outside the StarTeam client and provides the following features:
•
•
•

A two or three-way file compare/merge.
A two or three-way folder compare/merge.
A two or three-way image comparison.

Three-way File Compare/Merge
The following image is an example of a three-way session.

File Compare/Merge UI
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Folder Compare/Merge
The following is an image of a folder compare/merge session.
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Image Comparison
FCM has the ability to compare two or three images, and move or swap them, but not to edit them.

FCM Menus and Toolbar
The main and standalone File Compare/Merge windows have a main menu, a context menu, and a toolbar.
The embedded File Compare/Merge has a context menu only, no main menu or toolbar.
The menus provide specific actions for comparing, editing, and merging files and folders. They are dynamic
depending on which version of File Compare/Merge you are in, what type of files you are comparing, and
how many panes you are using. In the main and standalone File Compare/Merge windows, a toolbar
provides buttons for frequently used commands.
File Comparison Panes
The file comparison panes contain the contents of the files or folders being compared. In the main and
standalone File Compare/Merge windows, dynamic action buttons for editing appear on color differences
blocks. You can choose to display a two-way or three-way vertical or horizontal comparison mode.
Colors Representing Difference Types
File comparison and folder comparison in the Compare Pane of View Compare/Merge highlight difference
types in color, with each color representing a certain difference type. For example, it highlights inserted or
deleted items in green, changed items in yellow, and moved or renamed items in blue. You can modify the
default color for differences in the File Compare/Merge Options dialog box, accessed from the File
Compare/Merge window under Tools > Options .

File Compare/Merge UI
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Comparing and Merging Files
This procedure presents the basic high-level tasks involved in comparing and merging a local file with a file
in the StarTeam repository.
1.
2.
3.
4.

Start a File Compare/Merge session to compare two files.
Resolve any differences between the files in the File Compare/Merge window.
Generate a report of the changes made during the File Compare/Merge session.
Save the merge changes.
Note: You can also merge the contents of the two files.
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File Compare/Merge Options
Option settings globally impact product behavior. Many options are provided to enable you to configure File
Compare/Merge to function in a way that you desire. Option settings are provided at a general level and for
both file and folder comparisons at a more granular level.
The File Compare/Merge options are available using Tools > Options on the main menu of the File
Compare/Merge window, or pressing CTRL+SHIFT+P. A tree hierarchy on the left side of the File
Compare/Merge Options dialog box divides the File Compare/Merge options into three main categories,
General, File Comparison, and Folder Comparison. Clicking on a node in the hierarchy displays its
corresponding page of option settings in the right side of the dialog box.
You can reset the options to their default values by deleting the config.properties user settings file
found in your <user home>\.fcm folder. (For example, in Windows it would be C:\Documents and
settings\<user home>\.fcm\config.properties).

Setting File Compare/Merge Options
You can use the File Compare/Merge options to configure its behavior and screen display. You can only set
options in the main and standalone File Compare/Merge windows. The options available depend on which
version of File Compare/Merge you are using. For example, if you are using the main File Compare/Merge
in the client, folder options are not available since you can not compare folders in this version. All options
are available in the standalone File Compare/Merge.
To set File Compare/Merge options
1. Start File Compare/Merge.
2. On the File Compare/Merge menu, choose Tools > Options ( Ctrl+O ).
3. Select the page of options you want to change: General, File Comparison, or Folder Comparison.
There are general options, and options specific to file or folder comparisons and merges.
4. Make the changes you want, then click OK .
Note: You can reset the options to their default values by deleting the config.properties user
settings file found in your <username>\.fcm folder. (For example, in Windows it would be C:
\Documents and settings\<user home>\.fcm\config.properties).

File Compare/Merge Options
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General (File Compare/Merge Options)
These are general options for File Compare/Merge. To access these options, choose Tools > Options >
General .
Open Panes For:

Opens File Compare/Merge ready for making the selected type of
comparison on start-up: A File Comparison, A Folder Comparison, or the
Last Type of Comparison made.
This option is not available when launching File Compare/Merge from within
the client.

File History Limit

Populates the file history list with a maximum value. You can view the file
history by clicking the DOWN ARROW to the right of Open New
Comparison on the toolbar.
This option is not available when launching File Compare/Merge from within
the client.

Immediately Start
Starts a comparison as soon as the file/folder is opened. If this option is not
Comparison As New File/ set, open the file/folder to compare, and click Reload Content on the toolbar
Folder Is Entered
to begin the comparison.
This option is not available when launching File Compare/Merge from within
the client.
Open Comparison In
Read-only Mode

Opens files that you are comparing in read-only mode.
This option is not available when launching File Compare/Merge from within
the client.

Allow Editing For Readonly Files/Folders

Allows you to edit read-only files/folders.

Darken Pane While In
Read-only Mode

Darkens the UI pane to indicate the file/folder is read-only,

Enable Quick Start

Places the File Compare/Merge Quick Start icon in your Windows System
Tray. (Note: This could be invisible if File Compare/Merge cannot find the
required .dll file.)

This option is not available when launching File Compare/Merge from within
the client.

This option is not available when launching File Compare/Merge from within
the client.
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Allow Only One Running
Instance

Allows starting of only one instance of File Compare/Merge .

3-way Merge: Start With
Empty Center Pane

Opens an empty third pane on switching to a 3-way merge..

3-way Merge: Allow
Editing Only In Center
Pane

Allows you to only edit the center pane (merged results) on switching to a 3way merge.

| General (File Compare/Merge Options)

This option is not available when launching File Compare/Merge from within
the client.

This option is not available when launching File Compare/Merge from within
the client.

This option is not available when launching File Compare/Merge from within
the client.
3-way Merge: Put Left
Scroll Bar on Center
Pane

Adds a left scroll bar to the center pane for a 3-way merge.

Tabs: On Bottom

Locates tabs containing your file/folder comparisons at the bottom of the UI
by default. If this option is off, the tabs are located at the top of the UI just
beneath the toolbar.
This option is not available when launching File Compare/Merge from within
the client.

Tabs: Start New
Comparison In A New
Tab

Starts new comparisons in a new tab by default.

Tabs: Show Only One
Comparison

Only allows one file/folder comparison. Selecting this option disables the
Start New Comparison in a New Tab option.

This option is not available when launching File Compare/Merge from within
the client.

This option is not available when launching File Compare/Merge from within
the client.
For Next/Previous
Change: Always Adjust
Scroll Bar

Automatically adjusts the scroll bar to the location of the next or previous
change.

For Next/Previous
Change: Adjust Scroll
Bar Only If The
Difference Is Off Screen

Automatically adjusts the scroll bar to the location of the difference if it is not
visible on the screen.

General (File Compare/Merge Options)
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File Comparison (File Compare/Merge
Options)
These option apply only to file comparisons. To access these options, choose Tools > Options > File
Comparison .
Main File Comparison Options
Below are the options available on the first page of the File Comparison node.
Ignore All White
Space

ASCII characters 0x01 to 0x20 are removed from the text.

Ignore Leading and Ignores all leading or trailing white space in a line.
Trailing White Space
Ignore Differences in
End-Of-Line
Separators (CR and
LF)

Ignores differences in end-of-line CR LF separators when comparing files. There
are Windows (CR LF), Unix (LF) and Mac (CR) line endings that can affect your
file comparisons. This is especially useful if you are comparing files that have
been generated on a variety of operating systems.

Ignore Case

Ignores differences in character case within lines.

Insert Spaces
Instead of Tabs

Inserts spaces instead of tabs.

Tab Size

Specifies the tab size.

Show Invisible
Characters

Shows invisible characters in the editor panes, such as the trailing carriage return
and/or line feed (CR LF) characters, and tabs and spaces.
This option does not affect the end-of-line characters used when files are saved it only displays them visually in the editor pane. You can change the line endings
using the Change Line Separator On Load, Use Line Separator On Enter,
Change Line Separator On Copy, Change Line Separator On Paste, and
Change Line Separator On Save Options.

Change Line
Designates line separators. You can choose from Platform Specific, No
Separator When File Change, Windows, Unix, or Mac.
Opens
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Insert Line
Separator On Enter

Determines the line separator to use whenever you enter a new line in the view
pane. You can choose from Auto (need reload), Platform Specific, Windows,
Unix, or Mac.

Change Line
Separator On Copy

Determines the line separator that will be used in the copied text whenever you
copy text in the view pane. You can choose from Platform Specific, No Change,
Windows, Unix, or Mac.

Change Line
Separator On Paste

This setting determines the line separator that will be used in pasted text. Using
the combo box, you can choose from Auto (need reload), Platform specific, No
change, Windows, Unix, or Mac.

Change Line
Separator On Save

Determines the line separator that will be used when saving changes. You can
choose from Platform Specific, No Change, Windows, Unix, or Mac.
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Editor Font

Changes the View pane editor font and size.

Show Line Numbers Displays line numbers on the left side of each of the editor panes.
When File Opened,
Auto Scroll To
Difference

Scrolls automatically to the first difference found in your file comparison.

When File Opened,
Reset Scroll to
Beginning

Scrolls automatically to the beginning of the file in your file comparison.

Default Encoding

Specifies an encoding value to apply to your files. The Default Encoding value is
System-Dependent, and it is applied to any new files that you open in File
Compare/Merge.

Change Encoding
For Opened Files

Changes the encoding automatically for files that you currently have loaded in File
Compare/Merge. The value that you select for the encoding in the Default
Encoding option is applied.

Inherit Encoding
From Opened File

Specifies that if you replace the current file in a file comparison, the file that you
open automatically inherits the encoding of the file that it is replacing. Without this
setting activated, the file gets its encoding from the Default Encoding option.

Preliminary
Comparison:

Internally compare two files (or two versions of the same file) first to decide if they
are the same. If they are the same, then prompts the user that "Files are identical.
Continue opening diff?". These options let you use a different set of settings when
doing this initial comparison, than when doing the comparison which is actually
displayed.
Preliminary
Comparison: No
Comparison

Does not perform an initial comparison, and never
displays a prompt. In this case, if you compare two
identical files, FCM just launches and shows the
files.

Preliminary
Comparison: Do
Comparison Ignoring
All Settings

Performs a comparison which ignores the settings.

Preliminary
Comparison: Do
Comparison Using All
Settings

Performs a comparison which uses all the settings.

Preliminary
Comparison: Do
Comparison Firstly
Ignoring And then
Using All Settings

First performs a comparison ignoring the settings. If
this comparison indicates there is a difference, the
FCM performs another comparison using the
settings. If the second comparison says there is a
difference, then it prompts the user. The intent of
this last option is to prompt if either type of
comparison (Ignoring All Settings and Using All
Settings) indicates that the files are the same.

Inline Differences
Use this options to control how inline differences are handled.

File Comparison (File Compare/Merge Options)
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Show Inline differences

Performs detailed inline comparisons on changed lines highlighting
insertions, changes, and so on.

Compare Lines By
Characters As A Block

Compares and highlights differences inside a sequence of changed lines. All
characters in the lines are scanned, and the text is divided by lines. You must
enable Show Inline Differences to activate this option.

Compare Lines By
Characters

Compares the characters in each line with the characters in the opposite line.
For example, characters in the first line of the sequence are compared with
the characters in the first line of the opposite sequence, characters in the
second line of the sequence are compared with the characters in the second
line of the opposite sequence and so on. This option is automatically
activated when you enable Show Inline Differences.

Compare Lines By
Words

Splits lines into words (or lexemes) using standard separators, and compares
them. You must enable Show Inline Differences to activate this option.

Separate Differences

Enables you to Compare Lines By Characters, Compare Lines By Words,
or Compare Lines By Words - Best Choice. The default setting is to
compare lines at a granular level, by characters. Normally, File Compare/
Merge presents sequences of differences for changed lines as a block. In
other words, you can perform operations, such as Replace, Append, or
Delete only on the block. If you have enabled this option, File Compare/
Merge does not combine the sequences in a block. Instead it considers each
pair of changed lines as a block. You must enable Show Inline Differences
to activate this option.

Best Choice

Compares all pairs of lines and selects the best ones. You must enable
Show Inline Differences to activate this option.

Minimum Word Size

Represents the minimum number of characters between separators that is
considered as a word. You must enable Show Inline Differences to activate
this option.

Acceptance Weight
(Words*100+Chars)

Provides the criteria for File Compare/Merge to decide which lines should be
considered a match and have their differences highlighted. The acceptance
weight is equal to the number of hit words multiplied by 100, plus the total
number of equal (matched) characters in the comparing lines. You must
enable Show Inline Differences to activate this option.

Color Background

Highlights the background of the different characters in the line. You must
enable Show Inline Differences to activate this option.
The Highlight Characters option is not available with this option selected.

Strikethrough

Crosses out the characters in the line to show differences.
You can also activate the Highlight Characters option along with this option.

Strikethrough And
Highlight

Crosses out and highlights the characters in the line to show differences.

Underscore

Underscores he characters in the line to show differences.
You can also activate the Highlight Characters option along with this option.

Underscore and
Highlight
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Underscores and highlights he characters in the line to show differences.

Left Color/Right Color

Changes the color within the line. You can set colors for both the right and
left editor panes.

Smart Comparison
You can apply these settings to compare files at a more granular level.
Advanced Search Of
Differences

Uses a special algorithm to finds swapped blocks and perform efficiently on
large files, enabling you to use this option to improve performance when
comparing large files. This option must be selected to enable the Detect
swapped blocks option.

Detect Swapped
Blocks

Detects swapped blocks of text. The Advanced Search Of Differences option
must be selected to enable the Detect swapped blocks option, Hide Links
Between Unselected Blocks, Shorten Differences, and Include Only
Blocks With Unique Lines options are automatically selected by default with
this option activated

Hide Actual Difference Hides actual difference links between selected blocs. You can optionally
Links Between
activate this option when you activate Detect Swapped Blocks.
Selected Blocks
Hide Links Between
Unselected Blocks

Hides links between unselected blocks. This option is activated by default if you
choose to Detect Swapped Blocks.

Shorten Differences

Prevents Detect Swapped Blocks from creating expanded blocks (appending
identical lines to blocks of changed lines).

Include Repeated
Blocks

Includes repeated blocks. You can optionally activate this option when you
activate Detect Swapped Blocks.

Ignore Repeated
Blocks

Ignores repeated blocks. You can optionally activate this option when you
activate Detect Swapped Blocks.

Include Only Blocks
With Unique Lines

Ignores blocks not containing unique lines when a comparison is performed if
Detect Swapped Blocks is activated.

Patterns
Use this option page to edit a list of patterns (or regular expressions) that are used in file comparisons.
These options are useful for filtering out unimportant changes that you do not necessarily want to see in
the editor panes.
Patterns conform to the standard syntax of Regular Expressions. For examples, see http://
www.regular-expressions.info/.
Ignore

Allows you to ignore specified patterns during a file comparison. To ignore patterns, check
this option, and then choose one or more options from the pattern list to ignore. You can
also create new patterns using New to open the Ignorable Pattern dialog box where you
can enter regular expression syntax to search for sequences of characters.

Allow Gluing
of Blocks
Separated By
Pattern-like
Lines

Allows you choose to glue lines that are empty, or that contain only braces. You can also
modify the existing patterns, or add your own patterns.
For example, if you have three lines of differences that you want to move from
file1.txt to file2.text, and those different lines are separated only by blank lines
or lines with braces in them, without this option, you would have to resolve each line of
difference separately.

File Comparison (File Compare/Merge Options)
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When Allow gluing of blocks separated by pattern-like lines is enabled AND a pattern
( custom or predefined ) is enabled, then AND ONLY THEN, the "Glue delimiter lines"
button
is displayed in the FCM toolbar. Selecting this toolbar button merges the three
lines of differences into a single difference, because the lines between the differences
match the glue pattern of “empty line” specified in the FCM Pattern options. Now, it only
takes one click of a button to move all three lines of differences from one file to the other.
New/Change/ Enables you to add new patterns, change existing patterns, or remove existing patterns.
Remove
New and Change display the Patterns dialog box where you define the pattern.
Ignorable
Uses New and Change to display the a dialog box where you define a pattern.
Pattern/Glue
In the Glue Pattern dialog box , you also have an option to add file extension(s) to apply
Pattern
dialog boxes the glue pattern to. If you are applying the glue pattern to more than one file type,
separate them with commas. For example: java, cpp, c, h, hpp.
Name

Specifies the name for the pattern. The name displays in the
corresponding pattern/glue list exactly as you enter it in the dialog.

Pattern

Specifies the pattern (expression). You can use regular expression
syntax. For example, ^[\t]*//.*$ or [{}\s]*.

Left Text Box

Provides a place to type sample test text.

Right Text
Box

Displays the results after performing a pattern test.

Test

Applies the pattern to the sample test text. The results display in the
text box on the right of the dialog.

Report Transformers
The Report Transformer options page enables you to define new transformers, edit existing transformers,
or remove transformers from the list. These options are available whenever you choose to generate a
report (click Generate Report in the toolbar). You can choose to use an empty transformer, use one of the
predefined transformers, or create your own.
Report Transformers
List

Displays the list of report transformers available for use in transforming XML
files to various outputs.

Add/View & Edit

Allows you to add, view, or edit a report transformer XSL file using the Report
Transformer Configuration dialog box.

Remove

Allows you to remove a selected report transformer from the list.

Color Preferences
Use the Color Preferences to control the colors displayed for file comparisons in the editor panes.
Changes to the colors apply to each of the editor panes.
Text Type
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Assign distinct background colors to aid in identifying differences and similarities in files.
This option displays a list of the types of text that can be color coded in the File
Compare/Merge window. The Background Color button automatically changes colors to
reflect the type of text selected. The text preview area shows the current color
configuration settings. You can change the background color for the following types of
text:
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– Unchanged text line
– Changed text line
– Inserted text line
– Deleted text line
– Conflict text line
– Transposed text line
– Transposed and changed text line
– Transposed inserted text line
– Frozen text line. Note that this is also referred to as Made change (Advanced merge
mode) in the Text type drop down list . This type of text represents lines in the nonresult panes that have been merged.
Background
Color

Displays the color of the selected Text Type. This button also launches the Select Color
dialog box where you can specify a different color.

Comparing Two Local Files
To compare local files using the standalone File Compare/Merge
1. From the Windows desktop, choose Start > Program Files , navigate to your StarTeam program
installation group, and choose File Compare Merge .
2. Click the Open New Comparison button at the top right of each editor pane, and browse to the files
you want to compare.
Note: The Open New Comparison button displays a list of your previously opened files.
3. Right-click in any pane and choose Switch Comparison Modes to specify a comparison display layout.
Tip: You can open additional file comparison windows by pressing Ctrl+N .
4. Edit the files by typing directly in the edit panes, or by using the dynamic editing buttons in the color
difference blocks.
5. Optionally, right-click in one of the panes and choose Generate Report.
6. Choose File > Print to print the report.
Note: If you want a report of your changes, you must generate the report before closing the File
Compare/Merge window.
7. Choose File > Save All to save all changes, or click the Save Changed Text File button above each
pane to save each changed file individually.
8. Optionally, test your changes to ensure there are no problems, then check the change files into
StarTeam.

Comparing a Local File with a Repository File
1. Select a StarTeam repository file to compare with your local file.
Note: You can select the tip revision a file in the upper pane, or a previous revision on the History
tab.

File Comparison (File Compare/Merge Options)
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2. Right-click the selected file and choose Compare Contents.
The File Compare/Merge session opens in a separate window, with each file in its own edit pane.
3. Click the down arrow to the right of the Switch Comparison Modes toolbar button and select a
comparison mode.
4. Perform any required edits to the files directly in the edit panes.
Tip: You can also use the embedded Compare panes to quickly compare two files. Selecting two files
in StarTeam, and choose Tools > Compare . You can view files but you cannot edit files in the
embedded Compare panes.

Comparing Images
You can use the standalone File Compare/Merge to compare two images on your computer. You cannot
edit the files directly, but you can swap the contents of one image with the contents of another one.
File Compare/Merge provides a toolbar with a few common actions that control the editor pane display. It
also includes some image comparison tools for zooming in and out, and moving the file around.
1. From the Windows desktop, choose Start > Program Files , navigate to your StarTeam program
installation group, and choose File Compare Merge .
2. Choose File > New Image Comparison ( Ctrl+Alt+N ) to open a new image comparison tab.
3. Click the Open New Comparison button at the top right of each editor pane, and browse to the images
you want to compare.
Note: The DOWN ARROW to the right of the Open New Comparison button stores a history of
your previously-opened images. You can open the Save File As dialog box by clicking the DOWN
ARROW to the right of the Save Changed Text File button.
4. (Optional) Click the DOWN ARROW to the right of the Switch Comparison Modes toolbar button and
choose either a 2-Way Vertical or 2-Way Horizontal display.
5. (Optional) Click Zoom In, Zoom Out, or Move on the toolbar to examine your image in more detail.
6. (Optional) Use the double left or right-arrow buttons at the top of the image comparison panes to
replace one image with the other.
The content of the source image replaces the contents of the target image without change the filename.
7. Click the Save Changed Image button at the top of the pane that contains the changed image, or close
the image comparison pane and you will be prompted to save your file if you have modified it.
Tip: You can open additional image comparison windows by choosing File > New Image
Comparison on the File Compare/Merge main menu, or by pressing Ctrl+Alt+N .

Comparing Historical File Contents
You can only compare historical File contents using the main or embedded File Compare/Merge in the
StarTeam client. You cannot edit historical File revisions.
1. Click the History tab and select two revisions to compare.
2. Choose Tools > Compare .
The embedded compare panes display the contents of the two files at the bottom of the StarTeam
window.
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Note: You can also compare the properties of two non-File items, such as a change request, or two
revisions of the same non-File item. Select the two non-File items, then choose Tools > Compare .
This opens the embedded double-paned compare view at the bottom of the window and displays the
properties of the two selected items.

Merging Two Local Files
Use the standalone File Compare/Merge to compare and merge the contents of two files on your computer.
1. Click Start > All Programs > Micro Focus > StarTeam Cross-Platform Client <version> > File
Compare Merge.
2. Click the Open New Comparison button at the top right of each editor pane.
Browse to the files you want to compare, or enter the path for each file in the directory field above each
pane.
Tip: The DOWN ARROW to the right of the Open New Comparison button above each pane
stores a history list of the previously-opened files in that pane from which you can choose.
By default, the files are immediately compared, and displayed in the panes with line numbers.
File Compare/Merge highlights the differences between the two files using colors and linked lines, with
the linked lines connecting the related differences in the two files. You can set the colors used in the
editor panes in the File Compare/Merge Options dialog box on the Color Preferences page for File
Comparisons.
3. Right-click in any pane and choose Switch Comparison Modes.
Choose 3-Way Vertical, 3-Way Horizontal, or 3-Way Mixed.
In the 3-Way Vertical and 3-Way Horizontal comparison modes, the merged base file is in the center
pane. In the 3-Way Mixed comparison mode, File Compare/Merge places the merged base file in the
lower pane.
Tip: You can open additional file comparison windows by choosing File > New Comparison on
the File Compare/Merge main menu, or by pressing Ctrl+N .
4. Perform any required edits to the files directly in the edit panes.
File Compare/Merge provides a context menu and toolbar with the most commonly used actions that
you will need to perform in the editor panes.
5. Optionally, right-click in one of the panes and choose Generate Report.
To print the report, choose File > Print .
Note: If you want a report of your changes, you must generate it before closing the File Compare/
Merge session.
6. Choose File > Save All to save all of your changes, or click Save Changed Text File button above
each pane to save them individually.
7. Optionally, test the modified file to ensure there are no problems with it.
8. Check in the file.

Editing Files in a File Compare/Merge Session
1. Start a main or standalone File Compare/Merge session on two files you want to compare.
The File Compare/Merge panes display the differences between the two files in color differences blocks.
2. Edit the files by modifying text directly in the edit panes.
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Use standard editing techniques or use the dynamic editing buttons in the color differences blocks.
Note: You cannot modify the actual revision of a file in the StarTeam repository. If one of the files you
are comparing is a revision in the repository, File Compare/Merge creates a temporary copy of the file
locally, which you can also edit and save locally with a different filename.

Saving Files Modified in a File Compare/Merge Session
If you edit a file during a File Compare/Merge session, you can save the edited file from the File Compare/
Merge window, or be prompted to save the edits when you exit File Compare/Merge.
1. Start File Compare/Merge and make your edits and/or merge the files.
The Save Changed Text File button becomes active above each pane containing modifications. It is
located to the right of the File Path/Name field directly above the editing pane.
2. Save the modified files using one of the methods below:
•
•

•
•

•

Click the Save Changed Text File button above each pane that contains the edits you want to save.
The file is saved with the existing name and path, which is displayed in the File Path/Name field.
Click the DOWN ARROW beside the Save Changed Text File button and choose Save As to save
the file with a different name and/or path than that displayed in the File Path/Name field. A file
browser opens for selecting the path and specifying the filename.
Choose File > Save All to save all files that have been modified in File Compare/Merge with their
current names and paths.
Choose File > Close Current Pane to close the current tab pane containing a File Compare/Merge
session. The Save Results dialog box opens and prompts you to save the files that have changed.
Check the specific files you want to save and click Yes. The files are saved with their current name
and path.
Choose File > Exit to close all the active File Compare/Merge sessions. The Save Results dialog
box opens and prompts you to save all files that have changed. Check the specific files you want to
save and click Yes. The files are saved with their current name and path.
Note: If you edit the temporary copy of a file revision from the StarTeam repository, unless you
explicitly save that file to a different location with a new name, File Compare/Merge assigns the file a
new name and saves it in a temp folder in your local home folder. The naming convention is the word
star, followed by numbers (for example, star23276.xml). The file extension remains the same as
the original file.

Merging a Local File with the Tip Revision
You can use File Compare/Merge to merge the contents of a local working file with the tip revision of the
file in StarTeam. For example, if the file in your working folder has been modified, but is not based on the
tip (latest) revision of this file, it is marked with a Merge status. This status usually occurs when you and
another person have both been working on a file, but the other person has checked it in before you. To
check in your edits without losing the edits of the other person, you can compare the contents of the files,
reconcile the differences between them, and merge the contents into one file.
To merge a local file with the tip revision
1. Select a file in StarTeam with a file status of Merge or Unknown, and choose File > Check Out .
A message appears giving you the option to merge the contents of the two files.
2. Click Yes to merge the contents.
The File Compare/Merge window opens in a 3-way Vertical comparison mode. The two files you are
comparing display in the right and left panes, and a center pane displays the merged base file. If you
want to use a different comparison layout, right-click in one of the panes and choose Switch
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Comparison Modes. You can choose either 3-way Horizontal or 3-way Mixed comparison mode. In
the 3-way Mixed mode, the base file is in the lower pane.
Note: You can edit in all the panes in the standalone File Compare/Merge, and you can replace or
append text in the base file with highlighted text from the left and right panes.
3. Edit and/or merge the contents of the files using one or more of the following methods:
•

•
•

Perform an automatic merge: Right-click in a File Compare/Merge pane and choose Nonconflicting
Parts Auto Merge or Full Auto Merge. Nonconflicting Parts Auto Merge places only the
nonconflicting portions of the two compared files into the base file. Full Auto Merge parses the two
files, examines the changes, and automatically decides whether to keep or add each change to the
final base version of the file.
Edit any of the files directly. You can perform common text-editing actions such as type, cut, copy,
paste, and undo.
Copy text from the right and left panes using buttons that appear in the top right corner of the color
differences blocks. These buttons appear dynamically when you hover the mouse cursor over a color
differences block. If you do not select specific text to copy to the center pane, File Compare/Merge
copies the entire highlighted block of text.
Note: You can also use the toolbar and the context menu to navigate in the panes, control scrolling
behavior, search for text, and perform other basic actions.

4. Optionally, right-click in one of the panes and choose Generate Report.
To print the report, choose File > Print .
Note: If you want a report of your changes, you must generate it before closing the File Compare/
Merge window.
5. Choose File > Exit when you are satisfied with the merged results.
File Compare/Merge closes, and updates the file status to Modified in StarTeam.
6. Optionally, test the modified file to ensure there are no problems with it.
7. Check in the file.
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Folder Comparison (File Compare/Merge
Options)
These option settings apply only to folder comparisons which are only available in the external version of
File Compare/Merge, accessed from the Start Menu. To access these options, choose Tools > Options >
Folder Comparison .
Main Folder Comparison Options
In a single paragraph, describe the major components in the diagram.
Tree Font

Sets the font style and size displayed in the result panes.

Ignore Extensions

Designates any file extensions to ignore while comparing folders, for example,
dll;exe

Show Only Extensions

Designates only specific file extensions to show while comparing folders.

Ignore Folders

Enables you to list folders that you wish to ignore while comparing folders.

Do Not Show Empty
Folders

Ignores empty folders while comparing folders.

Use Compact View

Uses a compacted view if you have files in one folder that do not exist in
another folder (files to be inserted). The view showing the folder without those
files displays a collapsed color block as a line indicating that the files are not in
the other folder. If the option is not selected, the view displays a full color block
representing the missing files for the folder that does not contain the files.

Highlight Uncommitted Highlights uncommitted changes in the View pane.
Changes
Hide Unmodified
Components

Hides all folders in which there are no differences so the only folders visible in
the tree are the ones with differences.

Smart Comparison
You can apply these settings to compare folders at a more granular level.File Compare/Merge uses these
options to find similar files regardless of folder structure and folder names.
Option

Description

Use File Names In File
Matching

Specifies whether to use the file name or the content for comparison. If true,
the file name is used to identify files that are the same. If false, the content will
be used to identify files which are the same.

Match Files By Name
If true, File Compare/Merge uses the file name to compare file contents when
When No Content Match the application cannot find any matches in the contents.
Is Found
Use Folder Names In
Folder Matching
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Specifies whether to use the folder name for comparison. If true, the folder
name is used to identify folders that are the same. If false, File Compare/
Merge matches folders regardless of the name.

Option

Description

Maximum Number Of
Lines In Matching Files

Specifies the number of lines read when comparing the contents of two files.
Differences past the specified maximum number of lines are ignored

Rate Of Proximity In File The percentage of similarity in comparing files with similar content.
Matching
Use Alternative Tree Diff This algorithm behaves as follows:
Algorithm
The original folder structure for matched files is not kept and you cannot see
(by using the quick switch button on the toolbar) the conventional comparison
results and make appropriate copy operations.
Only the first encountered file that conforms to the matching criterion is kept.
Uses a different approach to match folders that contain similar files.
Report Transformers
The Report Transformer options page enables you to define new transformers, edit existing transformers,
or remove transformers from the list. These options are available whenever you choose to generate a
report (click Generate Report in the toolbar). You can choose to use an empty transformer, use one of the
predefined transformers, or create your own.
Report Transformers
List

Displays the list of report transformers available for use in transforming XML
files to various outputs.

Add/View & Edit

Allows you to add, view, or edit a report transformer XSL file using the Report
Transformer Configuration dialog box.

Remove

Allows you to remove a selected report transformer from the list.

Color Preferences
Use the Color Preferences to control the colors displayed for file comparisons in the editor panes.
Component
Type

Displays a list of the types of components that can be color coded in the File
Compare/Merge window. The Background Color button automatically changes colors
to reflect the type of component selected. The text preview area shows the current
color configuration settings.

Background
Color

Displays the color of the selected Component Type. This button also launches the
Select Color dialog box where you can specify a different color.

Comparing Folders
Using the standalone File Compare/Merge, you can compare and restructure folders on your computer.
You can also start a file comparison from a folder comparison. If you have not modified the General options
settings, File Compare/Merge automatically begins comparing folders as soon as you select them.
File Compare/Merge provides a context menu and toolbar with the most commonly used actions that you
will need to perform in the editor panes.
1. From the Windows desktop, choose Start > Program Files , navigate to your StarTeam program
installation group, and choose File Compare Merge.
2. Choose File > New Folder Comparison ( Ctrl+Shift+N ) to open a new folder comparison tab.
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Note: Using the New Folder Comparison command opens the folder comparison results with
Auto Commit On. To open a folder comparison with Auto Commit Off, choose File > New
Folder Merge . Once File Compare/Merge is opened, you can click Auto Commit Mode on the
toolbar to toggle between Auto Commit On or Auto Commit Off.
3. Click the Open New Comparison button at the top right of each editor pane, and browse to the folder
you want to compare.
Note: Alternatively, you can type the path to each folder to the left of the Save Changed Text File
button, or click the drop-down arrow on the Open New Comparison button and select a folder
from the history list.
By default, File Compare/Merge immediately compares the selected folders, and the results display in
the two panes of the File Compare/Merge window. You can change this and other default settings in the
File Compare/Merge Options dialog box on the General and Folder Comparison pages.
4. Optionally, right-click and choose Switch Comparison Modes to choose a different comparison mode
display.
If you choose one of the 3-Way comparison modes, you will have a third pane.
5. Perform any required changes to the folders directly in the edit panes. You can move, delete, and copy
folders from one pane to the other, and are prompted to commit your changes.
If there are differences between individual files in the folders you are comparing, you can also start a file
comparison from the folder comparison pane. Double-click the file in the folder comparison pane, or
selecting it and click Open New Comparison on the toolbar. A new file comparison pane opens
displaying the contents of the two files where you can edit, merge, and save your changes.
File Compare/Merge highlights the differences between the two folders using colors and linked lines, with
the linked lines connecting the related differences between the panes.
Tip: You can open additional folder comparison windows by choosing File > New Folder
Comparison on the File Compare/Merge main menu, or by pressing Ctrl+N .

Merging Folders
Merging folders is quite similar to merging files, except you are merging folder contents instead of file
contents. However, if two files in a folder have differences, you can open a file comparison on those files
from the folder comparison pane.
You can only merge folders using the standalone File Compare/Merge.
1. From the Windows desktop, choose Start > Program Files , navigate to your StarTeam program
installation group, and choose File Compare Merge.
2. Choose File > New Folder Comparison ( Ctrl+Shift+N ), or File > New Folder Merge ( Ctrl+Shift
+M ) to open a new folder comparison tab.
Note: Using the New Folder Merge command opens the folder comparison results with Auto
Commit Off. To open a folder comparison with Auto Commit On, choose File > New Folder
Comparison . Once File Compare/Merge is opened, you can click Auto Commit Mode on the
toolbar to toggle between Auto Commit On or Auto Commit Off.
3. Click the Open New Comparison buttons above each editor pane, and browse to the folders you want
to compare.
Alternatively, you can click the DOWN ARROW to the right of the Open New Comparison button and
select a folder from the history list, or you can type the path for each folder in the directory to the left.
By default, File Compare/Merge immediately compares the selected folders, and the results display in
the two panes of the File Compare/Merge window. You can change this and other default settings in the
File Compare/Merge Options dialog box on the General and Folder Comparison pages.
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4. Optionally, right-click and choose Switch Comparison Modes to choose a different comparison mode
display.
If you choose one of the 3-Way comparison modes, you will have a third pane for viewing and editing
the merged base folder.
5. Perform any required changes to the folders directly in the edit panes. You can move, delete, and copy
folders from one pane to the other, and are prompted to commit your changes.
The toolbar and context menus are different for folder compare/merge than for file compare/merge. For
folder comparisons, you have items for moving or copying files and folders left or right, deleting files and
folders from the right or left panes, and several options for expanding/collapsing tree nodes.
6. Optionally, double-click a file with differences to open a new File Comparison pane and resolve the
differences.
7. Optionally, right-click in one of the panes and choose Generate Report.
To print the report, choose File > Print .
Note: If you want a report of your changes, you must generate it before closing the File Compare/
Merge window.
8. Select Save Changes To Disk on the toolbar to save your changes when you are finished.
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Generating Reports from a File Compare/
Merge Session
This procedure describes how to generate a difference report from File Compare/Merge session. It
assumes that you are in a compare/merge session and want to generate a report of your changes before
you commit them and close the session.
1. Right-click in a File Compare/Merge pane and choose Generate Report to open the Report dialog box.
Note: If you are in the main or standalone File Compare/Merge window, you can use the Generate
Report toolbar button.
2. Choose a report generator (transformer) from the drop-down list in the Report dialog box.
3. Optionally, when available, modify the report parameters to customize the report appearance.
4. Click Next to preview the report.
5. Click Save and browse to the target location for the report.
Choose a file extension that is valid for the output type (format) of the transformer you selected, and
click Save.
6. Click Close in the Report dialog box.
Note: To print your report, open it in an appropriate application such as a text editor or a browser, and
print.

28

| Generating Reports from a File Compare/Merge Session

Customizing Compare and Merge Reports
This procedure describes how to use customized report transformer. (.xsl stylesheets). You need to
understand how to create an .xsl stylesheet to use as a template for creating a report transformer, or
you need access to one created by someone else.
To use a custom .xsl transform stylesheet
1. Choose Tools > Options in the File Compare/Merge window and expand the File Comparison or
Folder Comparison node.
Select the Report Transformers page.
2. Click Add to open the Report Transformer Configuration dialog box.
3. Type a name for the report transformer, and choose the type of report you want to generate from the
Output Type drop-down list.
4. Click Select XSL Template and browse to your custom .xsl stylesheet
You can modify the stylesheet in the edit box of the Report Transformer Configuration dialog box. If
you do modify the file, click Save XSL Template to save it with an .xsl extension.
5. Click OK to close the Report Transformer Configuration and return to the File Compare/Merge
Options dialog box.
Your new report transformer is added to the list of available report transformers in the Report dialog box
that opens when you generate a report in a View Compare/Merge session.
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File Compare/Merge Actions
These are the actions you can perform in File Compare/Merge using menus and toolbar buttons. All of
these are available in the standalone File Compare/Merge. Subsets of these are available in the main and
embedded File Compare/Merge.
These actions are common to file and folder comparisons and merges.
Action

Description

New File/Folder/Image Comparison

Opens a new file, folder, or image comparison pane.

Undo ( Ctrl+Z )

Undoes or redoes previous actions.

Redo ( Ctrl+Y )
Enable/Disable Independent Scrolling

Controls whether the panes scroll independently or
together. If the toolbar button is Enabled (up), as you
scroll in one file, the other file automatically scrolls to
match the two files. If the toolbar button is Disabled
(pressed), the panes use independent file scrolling.

Reload Content ( F5 )

Reloads the contents of both files. Before reloading the
contents, a Save Results dialog box opens giving you the
option of saving your results first.

Postponed Opening On/Off

Specifies immediate or delayed file opening. This action
is controlled with a toolbar button. With the button in the
Postponed Opening Off position (not pressed), as you
open a new file, the comparison is immediately
performed. With toolbar button in the Postponed Opening
On (pressed), the comparison is delayed until this toolbar
button turns it on.

Swap Panes

Swaps the left and right panes.

Switch Comparison Modes

Opens the panes in a two-way or three-way horizontal,
vertical, or mixed layout. A three-way layout enables you
to have a third pane between the two files you're
comparing, in which you can merge the two files into a
common base version.
When you are in a three-way merge layout, you have
additional toolbar actions available for automatically
merging the two files into a final base version of the file.
See Common Parts Auto Merge, Full Auto Merge, and
Highlight Changes in this table.
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Generate a Report

Opens the Report dialog box where you can select a
report name, output type. and report transformer to apply
to the report.

Print Comparison Report

Prints the comparison report you generated using
Generate Report.

Center/Move Splitter

Enables you to automatically center the splitter bar
between the panes using a menu item, or move the
splitter with the mouse to resize one of the panes.

Maximize/Minimize Panes ( Ctrl+M )

Minimizes or maximizes the selected pane.
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Action

Description
There are also menu items for maximizing/minimizing/
restoring the upper/left or lower/right panes in a three-way
comparison.

These actions are specific to file and folder comparisons and merges, and correspond to buttons on the
toolbar.
Action

Description

Copy

Copies the selected text or files/folders to the left or right
pane, or to the base pane in a three-way comparison.
Copied filed or folders are marked with a check mark, and
you are prompted to commit the changes.
There are specific toolbar buttons for doing this, and
when you hover the mouse cursor over a highlighted
area, a Copy button also displays in the pane in the
highlighted area.

Delete

Deletes the highlighted text or files/folders from the left,
right, or base pane. Deleted files or folders are marked
with a circle icon containing an X, and you are prompted
to commit the changes.
There are specific toolbar buttons for doing this, and
when you hover the mouse cursor over a highlighted
area, a Delete button also displays in the pane.

Move Image

Moves the image by clicking and dragging on the image
when the Move Image toolbar button is pressed.

Append Text (Alt+Shift+Right)

Appends the selected text from one pane the other pane
or panes. The button for appending text appears when
the mouse cursor hovers over a highlighted area.
When you hover the mouse cursor over a highlighted
area, an Append button also displays a highlighted area
of the pane.

Insert/Replace Text ( Alt+Right )

Inserts or replaces the selected text from one pane the
other pane or panes.
When you hover the mouse cursor over a highlighted
area, an Insert or Replace button also displays a
highlighted area of the pane.

Find Specified Text ( Ctrl+F )

Searches for a text string or regular expression in a textbased file. You can choose whether to use case
sensitivity and whole words only.

Previous Change ( F7 or Alt+Up )

Quickly navigates to the next or previous change in the
selected pane. In addition to menu commands, there are
toolbar buttons, and buttons at the bottom of each pane in
the scroll bar that navigate your changes.

Next Change ( F8 or Alt+Up )
Go To Line ( Ctrl+G )

Opens the Go To Line dialog box where you can specify
the line number to go to.

Inline Differences

Displays or hides inline differences when the toolbar
button is pressed. You can customize how inline
differences are displayed in the File Compare/Merge
Options dialog box available on the Tools menu.
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Action

Description

Split Differences

Splits blocks of changed lines to represent inserted or
deleted blocks (by default, signified by a light green
color).

Highlight Changes

Used in conjunction with a three-way comparison, it
prevents File Compare/Merge from automatically
recalculating differences on any file modifications, and
helps you see which blocks were inserted or deleted to or
from the base file.

Nonconflicting Parts Auto Merge

Used in conjunction with a three-way comparison,File
Compare/Merge places only the nonconflicting portions of
the two compared files into the base file.

Full Auto Merge

Used in conjunction with a three-way comparison, File
Compare/Merge parses the two files from top to bottom,
examines the changes and automatically decides
whether to keep or add each change to the final base
version of the file.

Encoding

Enables you to specify a desired character encoding
(codepage) for the displayed files using the Charset
Selection dialog box.
File Compare/Merge displays encoding information in the
bottom-right corner of the Status Bar. You can doubleclick the encoding icon to open the Charset Selection
dialog box.

Save Changes to Disk

Saves changes to your folders to disk. When you make a
change to folders, the changed folder or file is marked
with a check mark, an you are prompted to commit the
change.

Auto Commit

Specifies immediate or deferred committing of changes to
disk.

Enable/Disable Synchronized Selection

Enables automatic selection of the same file in both
panes, or all panes in a three-way comparison. This is
enabled by default. If turned off using the toolbar, only the
file in the pane with focus is selected.

Expand/Collapse All Nodes In Tree

Expands or collapses all the nodes in the tree. These
actions are available on the toolbar.

Expand Only Tree Nodes Containing Changes

Expands only tree nodes that contain changes in the
folders. These actions are available on the toolbar.

Extend/Compact View

Toggles between a compact and extended view of your
folder comparisons. The compact view collapses empty
color blocks into single lines. The default is a compacted
view.

Smart Tree Diff

Performs a smart comparison on the folders, highlighting
differences such as renamed and modified components
or cross-linked components.

Show/Cut Plain Differences

Enables you to see differences that conform to folder
structure and file names simultaneously, with differences
found by the smart comparison feature (Smart Tree Diff).
This toolbar button is only available if you have enabled
the smart comparison feature by pressing Smart Tree
Diff on the toolbar.
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Action

Description
The Show/Cut Plain Differences button never displays
on the toolbar if you have chosen to use the Alternative
Tree Diff Algorithm on the Smart Comparison page for
folder comparisons in the File Compare/Merge Options.

Zoom

Zooms in or out on the images being compared when
clicking the plus or minus toolbar buttons.

Drag and Drop

Allows you to drag and drop content from one pane to the
other. You can move or copy the content depending on
whether you use the Ctrl key when dragging.
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File Compare/Merge Keyboard Shortcuts
This table presents the keyboard shortcuts for use in File Compare/Merge.
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Action

Keyboard Shortcut

New File Comparison

Ctrl+N

New Folder Comparison

Ctrl+Shift+N

New Folder Merge

Ctrl+Shift+M

New Image Comparison

Ctrl+Alt+N

Save All

Ctrl+Shift+S

Print

Ctrl+P

Undo

Ctrl+Z

Redo

Ctrl+Y

Cut

Ctrl+X

Copy

Ctrl+C

Paste

Ctrl+V

Find

Ctrl+F

Find Next

F3

Find Previous

Shift+F3

Go To Line

Ctrl+G

Previous Change

F7 or Alt+Up

Next Change

F8 or Alt+Down

Next Tab

F6

Previous Tab

Shift+F6

Maximize/Minimize Pane

Ctrl+M

Center Splitter

Ctrl+H

Move Splitter

Ctrl+Shift+S

Reload

F5

Open Options Dialog Box

Ctrl+O

Replace Text Left To Right (2–way merge)

Alt+Right

Replace Text Right To Left (2–way merge)

Alt+Left

Append Text Left To Right (2–way merge)

Alt+Shift+Right

Append Text Right To Left (2–way merge)

Alt+Shift+Left

Delete Text in Left Pane (2–way merge)

Alt+Ctrl+Left

Delete Text in Right Pane (2–way merge)

Alt+Ctrl+Right

Move Text Up

Alt+Shift+Up

Move Text Down

Alt+Shift+Down

Replace Text Center To Left

Alt+<

Replace Text Center To Right

Alt+>
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Action

Keyboard Shortcut

Replace Text Left To Center

Alt+M

Replace Text Right To Center

Alt+/

Append Text Left To Center

Alt+Shift+M

Append Text Right To Center

Alt+Shift+/

Append Text Center To Left

Alt+Shift+<

Append Text Center To Right

Alt+Shift+>
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Applying Character Encoding to Files
By default, when you open a file in File Compare/Merge, it uses the system-dependent default encoding for
the loaded file. The file character set encoding is displayed on the Status Bar, in two or three boxes (one
for each pane). Initially, these boxes display the text Enc:Default when the files are opened. You can
change this encoding for each file in the File Compare/Merge panes.
To apply a character encoding to a file
1. Click the Character set encoding box on the File Compare/Merge Status Bar that corresponds to the
pane containing the file you want to change.
This opens the Charset Selection dialog box which displays a list of character sets.
2. Select the desired character set from the list.
If you selected a valid character set, the file immediately switches to that character set.
3. Close the Charset Selection dialog box.
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Tell Us What You Think
We welcome your feedback regarding Micro Focus documentation.
Submit feedback regarding this Help
Click the above link to email your comments to Micro Focus.
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