Release Notes

TrackRecord 06.01.01

December 19, 2002

 

 

Obtaining the Latest Release Notes
System Requirements
What's New
Technical Notes
Known Issues
Contacting Compuware Technical Support


Obtaining the Latest Release Notes  back to top 

If you accessed this document from the product CD or from the program shortcuts on your desktop, you may not be reading the latest release notes. For the most recent information, go to FrontLine, Compuware's technical support web site. After logging onto FrontLine, select your product from the drop-down list and click Go. On the left side of the page, click the Documentation link. You will find the latest release notes listed with the other product documentation.

System Requirements  back to top

This section describes the minimum requirements for running the TrackRecord Windows Client.

Client Requirements

Web Browser Requirements

The following system requirements are necessary for users to access the WebServer through a browser from their client machine:

Optional Components

The following sections detail the minimum system requirements necessary for installing each optional TrackRecord component.

Database Server (FairCom) Requirements

The following minimum system requirements are necessary to install a server that will house the database. This component can be installed on a central server on your network. A minimum of one server must be installed on a network for database access.

AutoAlert Requirements

The following minimum system requirements are necessary for installing TrackRecord's email notification service:

Note: Microsoft Outlook is recommended on the Server where AutoAlert is installed to facilitate configuration and testing of the mail profile.

WebServer Requirements

The following minimum system requirements necessary for machine upon which the WebServer component is installed:


What's New  back to top

This section describes the new features available in this release.

Release 06.01.01

Performance Enhancements

Significant performance enhancements have been made to TrackRecord's Windows Client and WebServer. In particular, you should notice improvements in the display and update of Outline Reports.

Windows XP Support

TrackRecord 06.01.01 includes support for Windows XP platforms (32-bit version only).

Guided Tour

TrackRecord now includes an online tour containing product overview information, user interface descriptions, and an overview of the basic tasks that can be performed with the product. You can access the tour by clicking the taskbarís Start menu and choosing Guided Tour from the TrackRecord program files, by selecting the Guided Tour from the Help menu within the TrackRecord Windows Client, or by clicking the WebServer's Guided Tour link. In order to view the Guided Tour from the WebServer, a Flash player is required.

WebServer Search

Find database information quickly with the new WebServer search functionality. The WebServer now offers a simple search to allow you to find items that contain a specified text string. For example, you can search for all defect items that contain a specific name in any field.

Improved WebServer Security

The latest security techniques and the best practices for protecting your data are now available when using the TrackRecord WebServer. The WebServer now works with the Secure Sockets Layer (SSL) protocol for securely transmitting sensitive data.

WebServer Usability Enhancements

Track an item's changes through the WebServer's new Change History button. When clicked, a window appears that provides an audit trail that lists when an item was created or modified. A Printable Page button has also been added that displays WebServer information in a printer friendly format. In addition, TrackRecord's WebServer online help has been greatly enhanced to include more topics and easier navigation. To access the help files from within the WebServer, select the Help link.

Improved Installation

TrackRecord's installation has been redesigned to provide an intuitive installation wizard that walks you through the steps for installing TrackRecord components. Because the installation has undergone significant changes, Compuware recommends that you read the installation documentation even if you are familiar with the product.

Release 06.01.00

Improved AutoAlert Functionality

TrackRecord's AutoAlert Administration utility notifies users via email of changes that might be of interest to them. AutoAlert includes the following enhancements:

WebServer File Attachment

WebServer users can now attach files to forms, open attachments, and delete attached files. For example, a WebServer user may want to attach a Microsoft Word document or screenshot to a defect. This feature is available for users with Microsoft Internet Explorer and Microsoft Internet Information Server (IIS) 4.0 or later or users with Netscape Enterprise Web server 4.1.

Check Database Scheduling

The Check Database feature (used to check database items, correct errors, and promote database integrity) can now be scheduled to run automatically. This feature requires Microsoft Internet Explorer 4.0 or later.

Enhanced Documentation

TrackRecord's online help and user manuals have been greatly enhanced to include more topics and easier navigation. To access the help files or user guide from the Start menu, navigate to the TrackRecord program files.


Technical Notes  back to top

This section includes technical information that may affect how you use the product.

Upgrading From Previous TrackRecord Releases

The TrackRecord directory structure has changed and databases are now installed in a different default location. As a result, after you upgrade to TrackRecord 06.01.01, you must copy the subfolders of your TrackRecord database folder to the new database folder. The following table lists the default location for TrackRecord 5.x and 6.x databases:

VersionSuiteDefault Installation Directory
TrackRecord 5.xQACenterx:\Program Files\Compuware\TrackRecord\Server\Databases
TrackRecord 5.xDevCenterx:\Program Files\Numega\DevCenter\Server\Databases
TrackRecord 06.00.00 and 06.01.00QACenter and DevPartner Enterprise Editionx:\Program Files\Compuware\TrackRecord Server\Databases
TrackRecord 06.01.01QACenter and DevPartner Enterprise Editionx:\Program Files\Compuware\TrackRecord\Databases

Notice to Novell Users for CSLM Server

Although setting up CSLM 3.2 on a Novell server is documented in the License Installation Guide, Compuware no longer supports running the Client/Server License Manager (CSLM) server on Novell network servers with QADirector 04.05.01 or TrackRecord 06.01.01. Compuware stated their intention to drop this support in previous product release notes.

Customers who are running the License Manager server on Novell will need to migrate to one of the following supported platforms: Windows 2000, Windows NT, and UNIX versions for Sun Solaris, SunOS, HP-UX, AIX, VMS (new in CSLM 3.2) and LINUX.

Notice to Netscape Users

You will experience performance problems if you run the TrackRecord WebServer on a machine running Windows and using the Netscape 4.7x browser and attempt to log into the WebServer on the same machine.

Other Notes

File Attachments

The TrackRecord limit on file attachment size per item is 12 MB. After attachment, these files are compressed, stored in attach.dat, and can only be viewed through the TrackRecord client or WebServer. Their compressed physical size when stored in the database can be notably smaller than the original file size.

Using the Check Database Feature

Compuware recommends that you run Check Database from the same client machine each time to keep all resulting information in one log file.

Automatic Update of TrackRecord Server Database

When you upgrade TrackRecord 05.00.00 client or server to TrackRecord 06.00.00 or later, TrackRecord automatically updates its database. You will receive a warning message that only an administrator can update the database. Other users cannot connect to the database until the administrator makes the update. Note that TrackRecord 06.01.01 does not update a 06.00.00 database-- they are fully compatible.

Opening Concurrent Databases

If 12 databases are opened concurrently and you attempt to open an additional database, an error will display. To open additional databases, modify the FairCom Server configuration. To do so, perform the following procedure:

  1. Stop the FairCom server.
  2. In Windows Explorer, open the configuration file ctsrvr.cfg in the TrackRecord directory. The path is C:\Program Files\Compuware\TrackRecord by default.
  3. Modify the FILES configuration parameter to a higher value. Compuware recommends that this value be set to the number of TrackRecord databases residing on the server multiplied by 60 (ex. for 10 databases, 10 x 60 = 600 files).
  4. Save and exit the file.
  5. Restart the FairCom server. For detailed instructions on starting and stopping the FairCom server, consult the Installation Guide.

Notes for the Active Users Dialog Box

Multiple instances of users and machine names occur in the Active Users dialog box when there are two or more sessions of TrackRecord open with this user name. This can occur in the following instances:

Note: The total number of users listed as logged into the database does not necessarily reflect the total number of licenses being used.

Cautions When Creating Fields

The maximum length of a field name is 31 characters.

If you are using the WebServer, ensure that there are no spaces at the end of a field name when creating and naming a new field. This precaution will prevent errors when opening your Web page.

Windows NT Error #2041

If you receive a Windows NT error #2041 message when attempting to start the FairCom server, follow these steps to correct the issue:

  1. On the machine on which the FairCom is installed, search for and delete all *.fcs files.
  2. Restart the FairCom server. For detailed instructions on starting and stopping the FairCom server, consult the Installation Guide.
  3. If the FairCom server is unable to start successfully, open the configuration file ctsrvr.cfg in the TrackRecord directory. The default path is C:\Program Files\Compuware\TrackRecord.
  4. Delete any lines beginning with the text DUMP.
  5. Save and exit the ctsrvr.cfg file.

Non-supported Languages

TrackRecord does not support double-byte languages, such as Japanese, Korean, and Chinese or right-to-left languages, such as Hebrew and Arabic.

Moving or Renaming the "Databases" and "Backups" Folders

Compuware recommends that you do not move or rename TrackRecord's Databases or Backups folders. Doing so will cause a loss in TrackRecord functionality. However, you can safely move and rename the subfolders.

Using AutoAlert with MAPI

After the AutoAlert software is installed, you must create a mailbox and mail profile for AutoAlertís use. You can do so using your preferred information service, such as the Microsoft Exchange Server. To do so, follow these steps:

  1. Create a mailbox for AutoAlertís use. Consult your mail serviceís documentation for instructions on creating mailboxes.
  2. Create a profile named AutoAlert that has access to the mailbox.
  3. Since access to the mailbox is through a service, the service must run as a user that can access the mailbox.

Note: For multiple domain networks, this requires a trust relationship between the domains.

Creating New Users When Using AutoAlert

When creating a new user, any queries marked for electronic notification that apply to the new user will return all results during the next AutoAlert poll. This may result in a large volume of AutoAlert emails being sent to the new user during the first AutoAlert poll.

Troubleshooting WebServer Login Failure

If a WebServer login fails, you will not receive an error message from within DCOMCNFG. Instead, when an attempt is made to login to a database through the WebServer, you will receive an automation error indicating that the configured identity is not correct. This is due to a DCOMCNFG login failure. To remedy this situation, ensure that the log in information is correct and ask a network administrator to grant the NT account "log on as a service" privileges.

Administrative Changes While Running the WebServer

When making changes to the type structure, templates, user and group administration, rules, etc., these changes will not be reflected to the WebServer component if there are active Web session processes running. To ensure that your updates are immediately reflected in the WebServer, follow these steps:

  1. On the WebServer machine, open the Task Manager.
  2. Click the Processes tab.
  3. Select TRWebSessionHost and click the End Process button. Repeat this step for all instances of TRWebSessionHost.
  4. Select TRWebDBHost and click the End Process button.
  5. Exit the Task Manager.
  6. Log on to the WebServer.

Default WebServer Settings

If both Microsoft Internet Information Server (IIS) and Netscape Enterprise Server (iPlanet) are installed on the WebServer machine, the WebServer will use IIS by default.

Disabling the FairCom Service

To ensure that the FairCom remains stopped, disable the FairCom service as described in the Installation Guide.


Known Issues  back to top

This section describes known issues related to the current release of TrackRecord.

Installation

Uninstalling Previous Versions of TrackRecord

If TrackRecord version 06.01.00 or earlier is installed on your computer, or if you have a Beta version installed, Compuware strongly recommends that you uninstall the previous version. If prompted, reboot your PC before proceeding with the installation of TrackRecord.

Windows Client and WebServer Installed on the Same Machine

If the TrackRecord Windows client is installed on the same machine as the WebServer and a Web session consumes a license prior to the Windows Client, the Windows Client will not start. This happens because as Web clients log into the WebServer, license calls are made from the WebServer machine to the License server. To remedy this situation, follow these steps:

  1. Ensure that all users are logged off of the WebServer.
  2. From the WebServer machine, open the Task Manager.
  3. Click the Processes tab.
  4. Select Nmdbinfo.exe and click the End Process button.

Note: If you receive an access denied error, try again in 40 minutes. If this is too long to wait or you still receive an access denied error, reboot your machine.

WebServer

WebServer Calendar Button

The calendar button works with Microsoft Internet Explorer only.

Viewing a File Attachment in the WebServer

When viewing a file attachment in the WebServer, select the attachment before clicking the WebServer's Open link. Failure to do so will result in an error message.

WebServer Licensing Issue

If an evaluation license is installed on the server and users attempt to access the WebServer, an error message such as maximum number of users reached will be displayed followed by a cgi/itemview.dll error message. In order for the WebServer to work properly, a temporary or permanent license is required. This can be configured with the License Administration Utility.

Check Box Items in the WebServer

The check box field is read-only in a WebServer Outline Report.

Printing Outline Reports

When printing an Outline Report in the WebServer, click in the frame containing the data that you wish to print before clicking the Print icon.

Modifying or Renaming the Attachments Field

Compuware recommends that you do not rename or modify an Attachments field or its underlying type. Doing so will result in an error when attempting to attach a file in the WebServer.

Sorting Columns in an Outline Report

In the WebServer, Outline Report columns are read-only and can only be sorted in the TrackRecord Windows Client. To change the way your Outline Report columns are sorted, follow these steps:

  1. Close any open WebServer sessions.
  2. If you have not already done so, open the TrackRecord Windowís Client.
  3. Open the Outline Report that you wish to configure.
  4. Select a parent header.
  5. From TrackRecordís View menu, choose Sort>column name. Repeat this step for each column you wish to sort.
  6. Repeat steps 3-5 for each parent header.
  7. After you have completed your changes, save the Outline Report.
  8. Log in to the WebServer and open the modified Outline Report.

Accessing the WebServer with Netscape Enterprise Server

When using Netscape Enterprise Server (iPlanet), access the WebServer with the fully qualified hostname. Otherwise, you will have difficulty logging out of TrackRecord.

Integration

TrackRecord and Reconcile Synchronization

Synchronization between Reconcile and TrackRecord may become slow when done with large numbers of requirements. To improve synchronization speed, open the Requirement type in the TrackRecord Type Editor, rename the Project field, and remove the associated field tags. Then, open each existing requirement item in TrackRecord and manually clear the Project field (set the value to <none>). For more information or assistance, please contact technical support.

Administrative

Team Member Association

In the default schema, "Team Member" is a special type that identifies a user and is associated with the TR_User tag. Although you may create a child type of Team Member, do not attempt to create a child of the child type of Team Member. Doing so will cause unexpected results.

This is an example of a correct association:

Team Member
Manager
Read-only user

This is an example of an incorrect association:

Team Member
Manager

QAManager (Unexpected results will occur)

Read-only user

Deleting Multiple Fields

When you delete multiple fields, it is best to note the order that the fields were deleted. If you recreate the fields, you must do so in the reverse order that they were originally created. Then, perform a database rebuild and a Check Database to ensure data integrity.

Deleting Hidden Fields

Before deleting fields, ensure that the field is not hidden.

Creating New Types

When creating a new assignment type, ensure that you select the type and click New. Do not double-click the assignment type to open the dialog box. Doing so will create empty items and can result in loss of data integrity.

Associating a Release With a VCS Label

If you receive a Canít find project in source control error while attempting to associate a release with a VCS label, the release type may not know which TrackRecord project, and consequently VCS project, to associate the label with. To associate a VCS project with a release, you must add a field to the Release type and then associate a VCS label. To do so, follow these steps:

  1. From the Administrator menu, choose Edit Types. You must be logged in as a user with administrative rights.
  2. Select the Release type and click the Edit button. The Type Editor appears.
  3. From the Insert Field menu, choose Single Line Text.
  4. Move and click your mouse at the bottom of the release type. The Field Properties dialog box appears.
  5. On the General tab, enter a name for the field. For example, you may want to enter VCS Project.
  6. Click the Properties tab.
  7. Select VCS project/dir.
  8. Click OK. The new field will appear in the Type Editor.
  9. Click the Save and Close button to exit the Type Editor.
  10. Follow the procedure in the TrackRecord Userís Guide for associating a release with a VCS label.

Note: You must associate the new field with the same VCS project that the parent TrackRecord project is associated with.

Miscellaneous

Using the Search Capability 

Part of TrackRecord's  performance enhancements include batching information. This may cause TrackRecord to appear to have a slight delay before initial results from a search can be viewed. In fact, the search information is being batched prior to being displayed, and the entire search is faster.

Creating Queries From an Outline Report

If you intend to duplicate a query, create it from the Query Editor rather than from an Outline Report.

Search Parameters

The search string is limited to 33 characters. If it is not possible to modify the search string to fit these parameters, create a query to search for the string.

Cut/Copy/Paste Actions

The cut, copy, and paste buttons and actions from the Edit menu in the TrackRecord Windows client are currently unusable. Instead, use the Ctrl+X, Ctrl+C, and Ctrl+V shortcut keystrokes.

Importing Duplicate Items

When importing duplicate items into the database, ensure that the Discard Duplicates option is selected. Otherwise, the existing item in the database will also be deleted.

Stack Bar Graphs

The stack bar graph only displays results from the first page of an Outline Report. To display your Outline Report in a graph, select bar or pie graphs instead.


Contacting Compuware Technical Support  back to top

Compuware Technical Support can assist you with all your technical problems, from installation to troubleshooting.

Before Contacting Technical Support
Prior to contacting technical support, gather the following information:

Telephone
USA and Canada: 800.538.7822
Other locations: 248.865.5444

FrontLine Support Web Site
Refer to Compuware's Frontline support web site for fast access to critical information about your product. You can read and print documentation, download product fixes, review frequently asked questions, or directly e-mail Compuware with questions or comments. The first time you access FrontLine, you are required to register and obtain a password.

Compuware Corporate Web Site
Refer to Compuware's corporate web site at http://www.compuware.com for information about Compuware technical support policies and problem resolution process.

Mail
Compuware Corporation
31440 Northwestern Highway
Farmington Hills, MI 48334-2564

 

End of TrackRecord Release Notes
(C) 2002 Compuware Corporation. All rights reserved. Unpublished rights reserved under the Copyright Laws of the United States.