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Introduction to VisiBroker
For the CORBA developer, Micro Focus provides VisiBroker for Java, 
VisiBroker for C++, and VisiBroker for .NET to leverage the industry-leading 
VisiBroker Object Request Broker (ORB). These three facets of VisiBroker 
are implementations of the CORBA 3.0 specification. See “VisiBroker CORBA 
Compliance” for further details.

VisiBroker Overview
VisiBroker is for distributed deployments that require CORBA to 
communicate between both Java and non-Java objects. It is available on a 
wide range of platforms including different hardware, operating systems, 
compilers and Java Development Kit (JDK) versions. VisiBroker solves all 
the problems normally associated with distributed systems in a 
heterogeneous environment.

VisiBroker includes:

•     VisiBroker for Java, VisiBroker for C++, and VisiBroker for .NET, three 
implementations of the industry-leading Object Request Broker.

•     VisiNaming Service, a complete implementation of the Interoperable 
Naming Specification in version 1.3.

•     GateKeeper, a proxy server for managing connections to CORBA Servers 
behind firewalls.

•     VisiBroker Console, a GUI tool for easily managing a CORBA environment.

•     Common Object Services such as VisiNotify (implementation of 
Notification Service specification), VisiTransact (implementation of 
Transaction Service specification), VisiTelcoLog (implementation of 
Telecom Logging Service specification), VisiTime (implementation of Time 
Service specification), and VisiSecure (security service).
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VisiBroker Documentat ion

VisiBroker Features
VisiBroker offers the following features:

•     “Out-of-the-box” security and web connectivity.

•     Seamless integration to the J2EE Platform, allowing CORBA clients direct 
access to EJBs.

•     A robust Naming Service (VisiNaming), with caching, persistent storage, 
and replication for high availability.

•     Automatic client failover to backup servers if primary server is 
unreachable.

•     Load distribution across a cluster of CORBA servers.

•     Full compliance with the OMG's CORBA 3.0 Specification.

•     Integration with the JBuilder integrated development environment.

•     Enhanced integration with other Micro Focus products including 
AppServer.

VisiBroker CORBA Compliance
VisiBroker 8.5 is compliant with version 3.0 of the CORBA specification from 
the Object Management Group (OMG). All changes between the earlier 
version 2.6 and version 3.0 are implemented. Note that VisiBroker: 

•     Supports General Inter-ORB Protocol (GIOP) to standard 1.2; GIOP 1.3-
related features are not implemented.

•     Does not support the CORBA Component Model (CCM) or Fixed types. 

For more details, refer to the CORBA specification located at http://
www.omg.org/.

VisiBroker Documentation
The VisiBroker documentation set includes the following:

•     VisiBroker Installation Guide—describes how to install VisiBroker on your 
network. It is written for system administrators who are familiar with 
Windows or UNIX operating systems.

•     Security Guide—describes Micro Focus’s framework for securing 
VisiBroker, including VisiSecure for VisiBroker for Java and VisiBroker for 
C++.

•     VisiBroker for Java Developer's Guide—describes how to develop 
VisiBroker applications in Java. It familiarizes you with configuration and 
management of the VisiBroker ORB and how to use the programming 
tools. It also describes the IDL compiler, the Smart Agent, the Location, 
Naming and Event Services, the Object Activation Daemon (OAD), the 
Quality of Service (QoS), the Interface Repository, the Interface 
Repository, and Web Service Support.

•     VisiBroker for C++ Developer's Guide—describes how to develop 
VisiBroker applications in C++. It familiarizes you with configuration and 
management of the VisiBroker ORB and how to use the programming 
tools. It also describes the IDL compiler, the Smart Agent, the Location, 
Naming and Event Services, the OAD, the QoS, Pluggable Transport 
Interface, RT CORBA Extensions, and Web Service Support.

http://www.omg.org/
http://www.omg.org/
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VisiBroker Documentat ion

•     VisiBroker for .NET Developer's Guide—describes how to develop 
VisiBroker applications in a .NET environment.

•     VisiBroker for C++ API Reference—provides a description of the classes 
and interfaces supplied with VisiBroker for C++.

•     VisiBroker VisiTime Guide—describes Micro Focus's implementation of the 
OMG Time Service specification.

•     VisiBroker VisiNotify Guide—describes Micro Focus's implementation of 
the OMG Notification Service specification and how to use the major 
features of the notification messaging framework, in particular, the 
Quality of Service (QoS) properties, Filtering, and Publish/Subscribe 
Adapter (PSA).

•     VisiBroker VisiTransact Guide—describes Micro Focus's implementation of 
the OMG Object Transaction Service specification and the Micro Focus 
Integrated Transaction Service components.

•     VisiBroker VisiTelcoLog Guide—describes Micro Focus' implementation of 
the OMG Telecom Log Service specification.

•     VisiBroker GateKeeper Guide—describes how to use the VisiBroker 
GateKeeper to enable VisiBroker clients to communicate with servers 
across networks, while still conforming to the security restrictions 
imposed by web browsers and firewalls.

The documentation is typically accessed through the Help Viewer installed 
with VisiBroker. You can choose to view help from the standalone Help 
Viewer or from within a VisiBroker Console. Both methods launch the Help 
Viewer in a separate window and give you access to the main Help Viewer 
toolbar for navigation and printing, as well as access to a navigation pane. 
The Help Viewer navigation pane includes a table of contents for all 
VisiBroker books and reference documentation, a thorough index, and a 
comprehensive search page.

Important

Updates to the product documentation are available on the web at https://
supportline.microfocus.com/productdoc.aspx.

Accessing VisiBroker Online Help Topics in the 
Standalone Help Viewer
To access the online help through the standalone Help Viewer on a machine 
where the product is installed, use one of the following methods:

Windows

•     Click Start > Programs > VisiBroker > Help Topics

or

•     Open the Command Prompt and go to the product installation \bin 
directory, then type the following command:

help

UNIX

Open a command shell and go to the product installation /bin directory, 
then enter the command:

help

https://supportline.microfocus.com/productdoc.aspx
https://supportline.microfocus.com/productdoc.aspx
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Tip

During installation on UNIX systems, the default is to not include an entry 
for bin in your PATH. If you did not choose the custom install option and 
modify the default for PATH entry, and you do not have an entry for 
current directory in your PATH, use ./help to start the help viewer.

Accessing VisiBroker online help topics from 
within the VisiBroker Console
To access the online help from within the VisiBroker Console, choose Help > 
Help Topics.

The Help menu also contains shortcuts to specific documents within the 
online help. When you select one of these shortcuts, the Help Topics viewer 
is launched and the item selected from the Help menu is displayed.

Documentation conventions 
The documentation for VisiBroker uses the typefaces and symbols described 
below to indicate special text:

Platform conventions
The VisiBroker documentation uses the following symbols to indicate 
platform-specific information:

Contacting Micro Focus
Our Web site gives up-to-date details of contact numbers and addresses. 

Further Information and Product Support
Additional technical information or advice is available from several sources. 

The product support pages contain a considerable amount of additional 
information, such as: 

•     The Product Updates section of the Micro Focus SupportLine Web site, 
where you can download fixes and documentation updates. 

Convention Used for
italics Used for new terms and book titles.
computer Information that the user or application provides, sample 

command lines and code.
bold 
computer

In text, bold indicates information the user types in. In code 
samples, bold highlights important statements.

[ ] Optional items.
... Previous argument that can be repeated.
 > Two mutually exclusive choices.

Symbol Indicates
Windows All supported Windows platforms
UNIX UNIX platforms
Solaris Solaris only
Linux Linux only
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Contact ing Micro Focus

•     The Examples and Utilities section of the Micro Focus SupportLine Web 
site, including demos and additional product documentation. 

To connect, enter http://www.microfocus.com in your browser to go to the 
Micro Focus home page, then click Support. 

Note: 

Some information may be available only to customers who have 
maintenance agreements. 

If you obtained this product directly from Micro Focus, contact us as 
described on the Micro Focus Web site, http://www.microfocus.com. If you 
obtained the product from another source, such as an authorized 
distributor, contact them for help first. If they are unable to help, contact 
us. 

Also, visit: 

•     The Micro Focus Community Web site, where you can browse the 
Knowledge Base, read articles and blogs, find demonstration programs 
and examples, and discuss this product with other users and Micro Focus 
specialists. 

•     The Micro Focus YouTube channel for videos related to your product.

Information We Need
However you contact us, please try to include the information below, if you 
have it. The more information you can give, the better Micro Focus 
SupportLine can help you. But if you don't know all the answers, or you 
think some are irrelevant to your problem, please give whatever 
information you have. 

•     The name and version number of all products that you think might be 
causing a problem. 

•     Your computer make and model. 

•     Your operating system version number and details of any networking 
software you are using. 

•     The amount of memory in your computer. 

•     The relevant page reference or section in the documentation. 

•     Your serial number. To find out these numbers, look in the subject line 
and body of your Electronic Product Delivery Notice email that you 
received from Micro Focus. 

Contact information
Our Web site gives up-to-date details of contact numbers and addresses. 

Additional technical information or advice is available from several sources. 

The product support pages contain considerable additional information, 
including the Product Updates section of the Micro Focus SupportLine Web 
site, where you can download fixes and documentation updates. To 
connect, enter http://www.microfocus.com in your browser to go to the 
Micro Focus home page, then click Support. 

If you are a Micro Focus SupportLine customer, please see your SupportLine 
Handbook for contact information. You can download it from our Web site or 
order it in printed form from your sales representative. Support from Micro 

http://www.microfocus.com
http://www.microfocus.com
http://www.microfocus.com
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Focus may be available only to customers who have maintenance 
agreements.

You may want to check these URLs in particular:

•     https://www.microfocus.com/product-trials/corba/
index.aspx?productname=VisiBroker (VisiBroker trial software)

•     http://supportline.microfocus.com/
xmlloader.asp?type=home&redirectpage=temporary.asp?aspneturl=/
websync/productupdatessearch.aspx (updated VisiBroker files and other 
software)

•     https://supportline.microfocus.com/productdoc.aspx. (documentation 
updates and PDFs)

To subscribe to Micro Focus electronic newsletters, use the online form at:
http://www.microfocus.com/Resources/Newsletters/infocus/newsletter-
subscription.asp

https://www.microfocus.com/product-trials/corba/index.aspx?productname=VisiBroker
https://www.microfocus.com/product-trials/corba/index.aspx?productname=VisiBroker
http://supportline.microfocus.com/xmlloader.asp?type=home&redirectpage=temporary.asp?aspneturl=/websync/productupdatessearch.aspx
http://supportline.microfocus.com/xmlloader.asp?type=home&redirectpage=temporary.asp?aspneturl=/websync/productupdatessearch.aspx
http://supportline.microfocus.com/xmlloader.asp?type=home&redirectpage=temporary.asp?aspneturl=/websync/productupdatessearch.aspx
https://supportline.microfocus.com/productdoc.aspx
https://supportline.microfocus.com/productdoc.aspx
http://www.microfocus.com/Resources/Newsletters/infocus/newsletter-subscription.asp
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Using the License Manager
You can use the License Manager to add, register, and remove your Micro 
Focus product licenses. This section describes how to use the License 
Manager GUI features.

Starting the License Manager
The License Manager can be started from the VisiBroker Console:

1 Start the VisiBroker Console.

2 From the Tools menu, select License Manager.

The License Manager can also be started by running an executable:

Windows

•     Run the lmadmw executable found in the <install_dir>\bin directory.

UNIX

•     Run the lmadm executable found in the <install_dir>/bin directory.

Viewing license information
The License Manager displays the licenses you have applied to products on 
the local machine. To see more detailed information about each license, 
click the license node in the left-hand navigation tree. The content pane on 
the right displays product details and operations that you can perform on 
the selected node.

Adding licenses
In some cases, you will need to apply multiple licenses to one installation. 
This will happen if you purchase optional products that can be added onto a 
base product. Applying a second or subsequent license to the same product 
installation is similar to the first.

Before you can add a new node-locked product license you will need:

•     The Serial Number and Key, or the activation file for each license. 
These will arrive in an email from Micro Focus.

•     A username and password

This is needed for product registration. Note that the main 
bdn.borland.com address is no longer in use. However:

•     If you have an existing Borland Developer Network account, you can 
use the credentials for that account.

•     If you have a Borland Developer Network login, but have forgotten 
your password, go to https://members.borland.com/login.aspx and 
select the Reset my password link.

•     If you do not have an account, for example because you are a new 
VisiBroker user, you can create one at http://visireg.microfocus.com/srs5/
new_user.jsp. 

https://members.borland.com/login.aspx 
http://visireg.microfocus.com/srs5/new_user.jsp
http://visireg.microfocus.com/srs5/new_user.jsp
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Import ing l icenses

•     You can alternatively create an account using the VisiBroker Product 
Registration Wizard, during the registration/activation process 
described in “Product Registration” in the VisiBroker Installation 
Guide.

•     Internet access. This is required if you want to use the Direct or Web 
page methods for activating your license. This can be from any system—
not necessarily the system on which your product is installed.

To add a product license, follow these steps:

1 Click Serial > Add. The Add Serial Number dialog opens.

2 Enter the Serial Number and license Key, and click OK. The new serial 
number will appear in red letters in a list of Unregistered serial numbers 
in the License Manager navigation tree.

3 Select the New serial number, and select Register from the Serial menu. 
The Product Registration Wizard steps you through the registration 
process. For more information about using the wizard see “Product 
Registration” in the VisiBroker Installation Guide.

Importing licenses
In some cases, you will need to import a license from a file. To import a 
product license, follow these steps:

1 Click License > Import. The Import License dialog opens.

2 Locate the license file using the Import License navigation tool, and click 
OK.

Removing licenses
To remove a product license, do one of these operations:

•     Right-click the license node in the navigation tree, and select Delete.

•     Select the license node in the navigation tree, and select Delete from the 
License menu. 
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VisiBroker Console
The VisiBroker Console provides a graphical user interface that lets you 
examine the VisiBroker infrastructure that is running on your network. The 
VisiBroker Console can run on any machine from which users want to view 
or modify the distributed system. 

Starting and logging on to the VisiBroker Console
To start the VisiBroker Console:

1 Launch the VisiBroker Console:

Windows

Click Start > Programs > VisiBroker > VisiBroker Console or open a 
Command Prompt, and type:

vbconsole

Note

To recognize the vbconsole command, your path system variable 
must include the <install_dir>\bin directory, or you can enter the 
path explicitly.

UNIX

Open a command shell and type:

vbconsole

Note

To recognize the console command, your path system variable must 
include the <install_dir>/bin directory, or you can enter the path 
explicitly.

The Administration Security Credentials screen appears.

Figure 1 Administration Security Credentials screen with default 
credential settings

2 Enter your User identity, Password, and Realm. 
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VisiBroker Console menus

To use the Micro Focus default credential settings, enter the password:

admin

3 Click OK. 

The VisiBroker Console appears.

VisiBroker Console menus
The VisiBroker Console provides these main menus:

•     Console 

•     View 

•     Tools 

•     Help 

Console menu
The following table describes the commands on the Console menu.

View menu
The following table describes the commands on the View menu.

Console menu 
command Description
Refresh Manually causes state information shown in the VisiBroker 

Console to be updated.
Preferences Opens the Preferences dialog box which you can use to set 

Console and configuration settings. See “Setting VisiBroker 
Console preferences” for information about setting 
preferences in this dialog.

Import Preference... You can import Preferences from, or export them to, a file 
(by default, ui.properties). See “Importing and 
exporting Console preferences” for how to do this.

Export Preference...

Set Identity Sets the credentials (User identity, Password, and Realm) 
used for authentication during hub and agent discovery.

Exit Dismisses the VisiBroker Console.

View menu 
command Description
Messages Shows or hides the errors window.
Tool Bar Shows or hides the tool bar at the top of the VisiBroker 

Console window.
Status Bar Shows or hides the status bar at the bottom of the VisiBroker 

Console window.
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Sett ing Vis iBroker Console preferences

Tools menu
The following table describes the commands on the Tools menu.

Help menu
This menu provides you with access to each of the online Help documents 
and the About screen for the VisiBroker Console.

The About screen contains tabs that display some important information 
about your Micro Focus software.

Setting VisiBroker Console preferences
VisiBroker Console preferences enable you to specify configuration, 
operation, and appearance settings used by the VisiBroker Console.

To set VisiBroker Console preferences:

1 Start the VisiBroker Console and choose Preferences from the Console 
menu. The Preferences dialog box appears with a list of preferences 
grouped into the following categories:

a General: controls user interface options and settings.

b Security: provides properties relating to the administration and 
management of the security environment.

c VisiBroker: controls user interface options for the VisiBroker Console.

2 Navigate through the tabs and select the preferences as desired.

3 Click OK.

You can alternatively set your preferences by importing a set of predefined 
preference values from a properties file; and you can export the 
preferences you have set to a properties file. See “Importing and exporting 
Console preferences” for how to do this.

The following sections provide details on each set of preferences.

Tools menu command Description
License Manager Launches the License Manager. See “Using the License 

Manager” for details.
VisiBroker Properties File 
Editor

Opens an editor allowing you to edit the VisiBroker 
properties file.

VisiBroker Web Service 
Stub Generator

Opens a wizard that helps you to configure and 
generate the necessary Web Service artifacts and 
stub code from a CORBA IDL file.

About screen tab Description
About Displays the VisiBroker Console version number and 

copyright information.
General System 
Information

Displays various system configuration settings that 
VisiBroker has detected such as the operating system, 
Java version, Java vendor, Java Compiler, and so forth.

Java Properties Shows the Java virtual machine property settings in use 
by VisiBroker.
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General preferences
The General preferences provide settings to control various VisiBroker 
Console user interface elements. This tab provides the following options:

•     Look and feel: Sets the display format and behavior of the VisiBroker 
Console windows. The available options are: Metal, CDE/Motif, Windows 
(Microsoft Windows platforms only), or Borland.

•     Tab memory: Specifies the view state information the VisiBroker Console 
uses. The following options are available:

•     Don't remember last visited tab pane: Tells the VisiBroker Console 
to open each node in the tree with the General tab displayed on the 
right.

•     Remember last visited tab pane by type: Tells the VisiBroker 
Console to open a node on the same type of tab (on a similar node) 
that was most recently viewed. For example, if the Properties tab is 
currently in view and you click on another node that has a Properties 
tab, the VisiBroker Console first displays the Properties tab for that 
node.

•     Remember last visited tab pane by type and name: Tells the 
VisiBroker Console to open a node that had been expanded earlier in 
the VisiBroker Console session to the tab that was last in view when 
that node was selected.

•     Sound beep on errors: If checked, the VisiBroker Console sounds an 
alarm when an error occurs.

•     Enable debug output: Tells the VisiBroker Console to report debugging 
information in the Errors pane at the bottom of the VisiBroker Console.

•     HTML Browser Setup: Specifies the path to the Web browser you wish 
to use with the VisiBroker Console. Use the Browse button to locate an 
installed Web browser.

Security preferences
The Security preferences provide settings relating to the administration and 
management of the security environment. This tab provides the following 
options:

•     Default realm: Specifies the name of the authentication realm used by 
the VisiBroker Console to interact with each AppServer.

•     Default user: Specifies the user name used by the VisiBroker Console.

•     Enable Security: Determines how the VisiBroker Console handles 
security:

•     When checked, enables the VisiBroker Console to communicate with an 
agent, whether it has security enabled or not. When the VisiBroker 
Console receives a request from an agent with security enabled, 
however, the VisiBroker Console must first pass the user's login 
credentials (realm, user name, and password) to that agent for 
authentication before the VisiBroker Console can access services on 
that agent.

•     When not checked, the VisiBroker Console will communicate only with 
agents that do not have security enabled.
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VisiBroker preferences
The VisiBroker tab is used to specify user interface options for the 
VisiBroker Console. This tab provides the following options:

•     Remove Stale Service Reference: Enable this option to remove all 
stale VisiBroker services references that were configured in the My 
Services folder of the VisiBroker Console main view.

•     Enable DNS Lookup: Enable this option to have the VisiBroker Console 
resolve any related DNS information to display in the Console. For 
example, the Console would display an IP address as its registered host 
name.

Note

Because any DNS lookup is an expensive resource operation, the 
VisiBroker Console provides this option to enable or disable DNS lookup.

Importing and exporting Console preferences
To import a defined set of preference values:

1 Choose Import Preference from the Console menu.

2 Browse to the location of the properties file containing your predefined 
preferences. By default, this is <install_dir>\ui.properties.

3 Select the file and press OK.

To export your defined preference values to a file:

1 Choose Export Preference from the Console menu.

2 Browse to where you want to save the properties file, and enter a name 
for it if you do not want to use the default. The default name and location 
is <install_dir>\ui.properties.

3 Select the file and press OK.

The properties file has one property per line, in the format 
<preference_name>;<preference_value>. For example:

osagent.port;osagent.port.list=14000
user.interface;console.location=491,92
user.interface;debug=1
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