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Micro Focus Academic Program - Release
Notes

These release notes contain information that might not appear in the Help. Read them in their entirety
before you install the product.

Note: This document contains a number of links to external Web sites. Micro Focus cannot be
responsible for the contents of the Web site or for the contents of any site to which it might link. Web
sites by their nature can change very rapidly and although we try to keep our links up-to-date, we
cannot guarantee that they will always work as expected.

Overview

The Micro Focus Academic Program brings contemporary software development tools and technologies to
COBOL development helping to bridge the gap between the old and the new.

COBOL applications still run many of the world’s business systems, therefore teaching the COBOL
language is a great way to prepare your university ‘s students for a robust IT career, in today’s economy.

The Micro Focus Academic Program is designed to support the education and use of the COBOL language
within the academic setting. This program supports our academic partner community through the use of
our COBOL development tools and materials within the classroom.

This program will enable your University to quickly join this growing league of similar academic
organizations in support of the promotion and education of the COBOL language.

Welcome! We’re excited to have you join our growing academic community.

Product Description

The Micro Focus Academic Program Edition package comprises the following products:

Visual
COBOL

Delivers the richest development experience for COBOL programming available using
Eclipse or Microsoft's Visual Studio 2010 or Visual Studio 2012 integrated development
environments, on Windows, and Eclipse on UNIX. Visual COBOL supports the
development and deployment of both JVM or .NET managed COBOL and of native COBOL
applications. Variants of Visual COBOL include:

• Visual COBOL for Visual Studio 2010 and Visual COBOL for Visual Studio 2012.

Visual COBOL for Visual Studio 2010 and Visual COBOL for Visual Studio 2012 each
target a different version of the COBOL run-time system - COBOL Server and COBOL
Server 2012 respectively.

Ensure that, after you've edited the project in the preferred version of Visual Studio, you
compile your source code in that version of Visual COBOL which targets the version of
the COBOL run-time in which you want your applications to run.

• Visual COBOL for Eclipse.

Enterprise
Developer

A contemporary development suite for Microsoft Visual Studio 2010 or for Eclipse that
allows mainframe developers to maintain, develop and modernize mainframe applications
regardless of whether these are to be deployed back on the mainframe or onto an
alternative platform. Enterprise Developer supports IBM COBOL, IBM PL/I, IBM Assembler,
IBM CICS, IBM IMS, IBM JCL, IBM DB2, IBM z/OS file formats and common batch utilities
including SORT. This means you can develop and maintain the core mainframe online and
batch applications under Enterprise Developer, then deploy them back on the mainframe or
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migrate them onto one of the Micro Focus Linux, UNIX or Windows based production
platforms. Variants include:

• Enterprise Developer for Visual Studio
• Enterprise Developer for Eclipse

Micro Focus Academic Program differs from the full version of these products in a number of ways. The
differences are:

• You cannot deploy applications on other machines, so Micro Focus COBOL Server and Enterprise
Server are not supplied.

• An authorization code for Micro Focus Rumba is not supplied.
• Micro Focus Academic Program is supplied for Academic use only. It is not to be used for any

commercial purposes. You must be a registered Micro Focus Academic Program Partner in order to
use this software.

For more information follow the link in the Electronic Product Delivery email for the End User License
Agreement.

Reporting Issues

For the latest information and discussions on this product, or to report issues, visit the Micro Focus
Community Web site.

To check the latest documentation of this product online, go to the Micro Focus Infocenter.

System Requirements

Hardware Requirements

Visual COBOL and Enterprise Developer for Visual Studio

Visual COBOL and Enterprise Developer have the following requirements in addition to the requirements of
Microsoft Visual Studio. See the Visual Studio documentation for details of the Microsoft requirements.

The disk space requirements are:

• 58MB for the Sentinel RMS license server
• 200MB for Micro Focus COBOL integration into Visual Studio

Note: This includes the space needed to cache information locally so that you can modify the
installation without the original source media.

Visual COBOL and Enterprise Developer for Eclipse

The disk space requirements for Windows are:

• Approximately 42MB for the Sentinel RMS license server.
• At least 680MB for Visual COBOL and 1GB for Enterprise Developer.

Note: This includes the space needed to cache information locally so that you can modify the
installation without the original source media.

The disk space requirements for UNIX/Linux are:

• Between 26 and 35 MB for the Sentinel RMS license server depending on the platform.
• Between 206 and 427 MB for Visual COBOL depending on the platform.
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Important: The UNIX installation requires extra disk space that equals the size of the product you
install.

Operating Systems Supported
Note: You can produce 64-bit and 32-bit applications on 64-bit operating systems.

The supported Windows platforms are:

• Windows XP 64-bit SP2
• Windows XP 32-bit SP3
• Windows Vista SP1 32/64-bit
• Windows 7 32/64-bit
• Windows 8 32/64-bit
• Windows Server 2008 SP2 32/64-bit
• Windows Server 2008 R2 32/64-bit
• Windows Server 2012 32/64 bit

Note:

• Enterprise Developer is currently supported on Windows 7, Windows 8, Windows Server 2012,
and Windows Server 2008 only.

• Visual COBOL for Visual Studio 2012 and COBOL Server 2012 are not supported on versions of
Windows earlier than Windows 7.

The supported UNIX and Linux platforms are:

• POWER running AIX 6.1 TL7 SP5/7.1 TL1 SP5 - 32/64-bit
• x86-64 running Red Hat Linux 5.5/5.8/6.3, Oracle Linux 6.3 with Red Hat Kernel compatibility mode,

Oracle Linux 6.3 with Unbreakable Enterprise Kernel - 32/64-bit
• SPARC running Solaris 10/11 - 32/64-bit
• x86-64 running Solaris 10/11 - 32/64-bit
• x86-64 running SuSE SLES 11/11 SP2 - 32/64-bit
• System Z running SuSE SLES 11 SP2 - 32/64-bit
• System Z running Red Hat Linux 6.2/6.3- 32/64-bit
• HP IA 11.31 - 32/64-bit

Software Requirements
Note: If you use the Micro Focus Web Installer to install this product, it checks your system and
installs the missing prerequisite software.

Important: This release requires version 10000.2.990 or later of the Micro Focus licensing software.
For local servers, you do not need to install it separately, as the setup file installs a new Visual
COBOL client and a new licensing server on the same machine.

If you have a network server, you must update the license server before installing the product as the
client is not able to communicate with license servers of versions older than 10000.2.660. On
Windows, you can check the version of your license server by clicking Help > About in the Micro
Focus Licensing System Administration tool. To check the version of the license server on UNIX,
run /var/microfocuslicensing/bin/mfcesver or /var/microfocuslicensing/bin/
cesadmintool.sh.

You can download the new version of the license server software from the Micro Focus SupportLine
Web site: http://supportline.microfocus.com/websync/SLM.aspx.
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Windows:

If you choose to install using the full image, you need to install the following software beforehand:

• A full version of Microsoft Visual Studio 2010 or Microsoft Visual Studio 2012 (Premium, Professional,
or Ultimate), or the the respective version of the Microsoft Visual Studio Integrated Shell.

Note:

• Microsoft Visual Studio Express Edition is not supported.
• You can download the Visual Studio Integrated Shell from the Microsoft Download Center. If

you choose to install the Shell, ensure you run the installer to complete the installation - run
vsintshell.enu.exe from the location where you installed the download.

The following functionality, tools and features have additional requirements:

Visual Studio IDE

• Microsoft Windows SDK is required if you are using Visual Studio Shell. See the Microsoft Download
Center and search for Windows SDK.

• Microsoft .NET Framework 4.0 if you are using Visual COBOL for Visual Studio 2010. This is included
with the above versions of Visual Studio.

• Microsoft .NET Framework 4.5 if you are using Visual COBOL for Visual Studio 2012. This is included
with Visual Studio 2012.

• Visual Studio 2010 Service Pack 1 is required if you are using Visual COBOL for Visual Studio 2010
and Visual COBOL for Visual Studio 2012 on the same machine. In addition, when building a native
COBOL project that contains resources you must replace the cvtres.exe in the bin and bin64
directories of your Visual COBOL installation with the version of the file which gets installed with Visual
Studio 2010 SP1. You can download Service Pack 1 for Visual Studio 2010 from the Microsoft
Download Center.

Enterprise Server for .NET

• Microsoft .NET Framework 4.0
• Microsoft SQL Server 2008 R2. (For beta or development installations, SQL Server Express 2008 R2 is

sufficient.)

You can download Microsoft's SQL Server from http://www.microsoft.com/sqlserver/en/us/get-sql-
server/try-it.aspx.

• A TN3270 terminal emulator. Micro Focus Rumba is supplied with this product.

Note: You also need to enable IIS and some additional Windows features. Read the Quick Start
section in your Enterprise Server for .NET help for further instructions on how to set up your operating
environment.

Java

• The Java Development Kit (JDK), version 1.6 (u27 or later) or version 1.7 (u05 or later), is required for
compiling Java. The JDK is downloadable from www.oracle.com. After installing the JDK, you must put
the tools.jar file for the JDK on your classpath, using a command similar to:

 set classpath=jdk-install-directory\lib\tools.jar

•

OpenESQL

• Database access is supported using the OpenESQL preprocessor with applications compiled as .NET
managed code to access relational databases using ODBC 3.0-compliant drivers. Refer to your driver
vendor's documentation to determine whether your driver is suitable for use with OpenESQL.
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• Dynamic SQL using the SQL Descriptor Area (SQLDA) is not currently supported for OpenESQL
applications compiled with the SQL(DBMAN=ODBC) directive.

• For COBOL stored procedures, please review requirements specified in the SQL CLR Integration
section below.

SQL CLR Integration for Visual Studio 2010
The following software is required to use the SQL CLR integration feature, which is specifically for the
development and deployment of COBOL stored procedures under Microsoft SQL Server.

Projects based on the SQL CLR Database Project template require:

• Visual Studio Professional 2010, Premium 2010, or Ultimate 2010
• SQL Server 2008 R2 targeting .NET CLR v2.0 frameworks (2.0, 3.0, 3.5)

Projects based on the SQL Server Database Project template require:

• All of the following:

• Visual Studio Shell 2010, Visual Studio Professional 2010, Premium 2010, or Ultimate 2010
• Subsequent installation of:

• Visual Studio 2010 SP1 (for any previously installed edition of Visual Studio 2010)
• Microsoft SQL Server Tools (SSDT SDK)

• Any of the following:

• SQL Server 2008 R2 targeting .NET CLR v2.0 frameworks (2.0, 3.0, 3.5)
• SQL Server 2012 targeting .NET CLR v4.0 framework (4.0) or .NET CLR v2.0 frameworks (2.0, 3.0,

3.5)
• SQL Server Azure targeting .NET CLR v4.0 framework (4.0) or .NET CLR v2.0 frameworks (2.0, 3.0,

3.5)

SQL CLR Integration for Visual Studio 2012
The following software is required to use the SQL CLR integration feature, which is specifically for the
development and deployment of COBOL stored procedures under Microsoft SQL Server.

Projects based on the SQL Server Database Project template require:

• Either of the following:

• Visual Studio Shell 2012 and Microsoft SQL Server Tools (SSDT SDK)
• Visual Studio Professional 2012, Premium 2012, or Ultimate 2012

• Any of the following:

• SQL Server 2008 R2 targeting .NET CLR v2.0 frameworks (2.0, 3.0, 3.5)
• SQL Server 2012 targeting .NET CLR v4.0 framework (4.0), or .NET CLR v2.0 frameworks (2.0, 3.0,

3.5)
• SQL Server Azure targeting .NET CLR v4.0 framework (4.0) and also .NET CLR v2.0 frameworks

(2.0, 3.0, 3.5)

Important: The SQL CLR Database project template is not supported with Visual Studio 2012.
Projects based on the SQL CLR Database project template are automatically upgraded to use the
SQL Server Database project template when opened in Visual COBOL for Visual Studio 2010.

Windows Forms

• Microsoft Visual Studio is required for using the Service Interfaces feature to generate Windows Forms
and ASP.NET Web site test clients.

• Microsoft Internet Information Service (IIS) is also required for generating Windows Forms test clients.
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Other Requirements

• If you use XML Extensions, it has the same requirements as RM/COBOL version 12 for 32-bit
Windows. (See the RM/COBOL User's Guide, Second Edition or later.) Additionally, XML Extensions
may be used in conjunction with Terminal Server.

Important: This release requires version 10000.2.990 or later of the Micro Focus licensing software.
For local servers, you do not need to install it separately, as the setup file installs a new Visual
COBOL client and a new licensing server on the same machine.

If you have a network server, you must update the license server before installing the product as the
client is not able to communicate with license servers of versions older than 10000.2.660. On
Windows, you can check the version of your license server by clicking Help > About in the Micro
Focus Licensing System Administration tool. To check the version of the license server on UNIX,
run /var/microfocuslicensing/bin/mfcesver or /var/microfocuslicensing/bin/
cesadmintool.sh.

You can download the new version of the license server software from the Micro Focus SupportLine
Web site: http://supportline.microfocus.com/websync/SLM.aspx.

Installation

Installation restrictions and requirements
Before starting the installation you should consider the following:

• Visual COBOL and COBOL Server cannot coexist on the same machine.
• Visual COBOL and Enterprise Developer cannot coexist on the same machine.
• If, when you install Visual COBOL for Visual Studio 2010, the machine does not have Microsoft Visual

C++ 2010 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The
installation of Microsoft Visual C++ 2010 Redistributable Runtime adds a number of .dll files, without
digital signatures, into the winsxs directory.

• If, when you install Visual COBOL for Visual Studio 2012, the machine does not have Microsoft Visual
C++ 2012 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The
installation of Microsoft Visual C++ 2012 Redistributable Runtime adds a number of .dll files, without
digital signatures, into the winsxs directory.

• If you are installing this as an upgrade, make sure that none of the product files are in use when you
start the installation.

• You need to be logged in with a user-ID that has write access to the registry structure under
HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation
software can set the environment appropriately. You also need to be logged on with Administrator
privileges.

• Before installing this product , make sure that any existing Micro Focus Directory Server (MFDS) or
CCITCP2 Windows serviceprocess from an existing product is stopped and uninstalled. Do this as
follows:

1. Stop the service, using either the Windows Service Management Console GUI or from a command
line prompt by typing: net stop mf_ccitcp2 Only one instance of the MFDS or CCITCP2 service
can run on a Windows machine.

2. Uninstall the MFDS or CCITCP2 service.

For MFDS, from a command line prompt enter: mfds -u

For CCITCP2: ccitcp2 -u

To run an earlier version of MFDS as a service after you have installed a later version:
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1. Stop and uninstall the MFDS service, as described above.
2. Reinstall the earlier version, as follows:

a. Open an  Visual COBOL command prompt.
b. Install the service. Enter the following command: mfds -i
c. Start the service. Enter the following command: net start mf_ccitcp2

Note: The two versions use different paths for environment and registry values, so the list of
configured Enterprise Servers might be different depending on which version has been started,
since, by default, different MFDS data repositories are used.

MFDS 5.1 and later are able to import or use Enterprise Server configuration data generated by earlier
versions of MFDS, but 5.0 or earlier versions of MFDS might not be able to read data generated by later
versions.

It is possible to run MFDS from a command prompt ("mfds") rather than as a service, but by default the
"mfcobol" port is used (86) and this can only be used by one process at a time

Downloading the Product
1. Use the download links in your Electronic Product Delivery email.

For more information follow the links for the installation instructions and the End User License
Agreement.

Installing the Products

Windows

To use the Web Installer:

1. Double-click the productname_webinstaller.exe file.
2. Click Start in the Web Installer dialog and follow the instructions to install the prerequisite software and

the product.

Alternatively, you can use the setup file on your machine and install the product as follows:

1. Run the productname.exe file and follow the wizard instructions to complete the installation.

UNIX

To use the Web Installer:

1. Give the Web installer file execute permissions:

chmod +x webinstallerfilename

2. Run the installer with superuser permissions:

./webinstallerfilename

If you don't run this as superuser, you will be prompted to enter the superuser password during the
install.

Alternatively, you can use the setup file on your machine and install the product as follows:

1. Give execute permissions to the setup file:

chmod +x setupfilename

2. Run the installer with superuser permissions:

./setupfilename

If you don't run this as superuser, you are prompted to enter the superuser password during the install.
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To install in a different location use the -installlocation="Location" parameter to specify an
alternative directory location. For example:

./webinstallerfilename -installlocation="full path of new location"

or

./ -installlocation="full path of new location"

You can see details about which additional parameters can be passed to the install script if you enter
the -help option.

Note:

• The installation of this product could affect the SafeNet Sentinel licensed components running
on your machine. During installation licensing is shutdown to allow files to be updated. To
ensure the processes running on your machine are not affected, you need to use the –
skipsafenet option, which skips the installation of SafeNet:

./ -skipsafenet

• To protect the SafeNet Sentinel installation from accidental updating you can create an empty
file named SKIP_SAFENET_INSTALL in /var/microfocuslicensing/ as follows:

touch /var/microfocuslicensing/SKIP_SAFENET_INSTALL

While the file is present, the SafeNet installer does not make changes to the installation or
shutdown the running license daemons. If later licensing needs to be updated, remove the file
and install Sentinel RMS server manually.

3. Set up the environment:

./opt/microfocus/<ProductName>/bin/cobsetenv

Important: These commands set the environment only for the current shell. You need to execute
them for each new shell that you start.

To avoid having to run cobsetenv for every shell, add these commands to the shell initialization
files (etc/profile, etc/bashrc, etc.)

4. To verify that your product is installed, execute:

cob -Version

5. Double-click the product icon (automatically installed on your desktop) to start Eclipse.

Note: The installer automatically creates a shortcut icon for the product on the desktop for the user
for which you ran the install script. If you need to create desktop icons for other users' desktops on
the same machine, or if the icon was not created on the desktop for the root user, run the following
shell script as the user you need to login as: $COBDIR/bin/createdesktopicon.sh

Installing into Different Eclipse Packages

Micro Focus Visual COBOL uses Eclipse 3.7. If you want to use Visual COBOL in other Eclipse packages
based on version 3.7, you must also install the Visual COBOL update site, and the RSE and AspectJ
plugins. Follow the procedure below to do this.

Important: We recommend you back up all existing Eclipse configuration files first.

1. Install Visual COBOL as directed above.
2. Copy the required Visual COBOL resources to your existing Eclipse as follows:

For Windows environments

1. Extract the contents of the following .zip files in %ProgramFiles(x86)%\Micro Focus
\Visual COBOL\eclipse\installer to a temporary folder:

• ajdt_2.1.3_for_eclipse_3.7.zip
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• RSE-runtime-3.3.zip

2. Copy the extracted folders to <your existing Eclipse>\eclipse\dropins.
3. Copy %ProgramFiles(x86)%\Micro Focus\Visual COBOL to <your existing Eclipse>

\eclipse\dropins.
4. Rename each of the folders:

• From ajdt_2.1.3_for_eclipse_3.7 to AJDTUpdateSite
• From RSE-runtime-3.3 to RSEUpdateSite
• From to COBOLUpdateSite

5. Move the the contents of the <your existing Eclipse>\eclipse\dropins
\RSEUpdateSite\eclipse folder up a level (that is, to <your existing Eclipse>\eclipse
\dropins\RSEUpdateSite) and delete the empty folder.

6. Copy the eclipse.ini file in %ProgramFiles(x86)%\Micro Focus\Visual COBOL
\eclipse\installer to <your existing Eclipse>\eclipse, overwriting the existing file.

3. Restart Eclipse.

After Installing

Visual COBOL and Enterprise Developer for Visual Studio

You are now ready to run Visual COBOL or Enterprise Developer. From the Windows taskbar click Start >
All Programs > Micro Focus Product Name > Product Name for Visual Studio.

Note: The Start menu is not available on Windows 8. You use the Start screen to invoke programs.

Please refer to the Start Here and Product Information sections in your product Help. Here, you will find
information on getting started including tutorials and demonstration programs.

Note:

• If you have problems trying to view the Micro Focus help, ensure that the Visual Studio Help
Library is pointing to local help. From the Visual Studio menu click Help > Manage Help Systems
> Choose online or local help and check the I want to use local help button.

• To view the help in Visual Studio 2012, ensure that the Visual Studio Help Library is pointing to
local help. From the Visual Studio menu click Help > Set Help Preferences > Launch in Help
Browser.

• For full details of the Visual Studio 2012 Help system, see the locally installed Microsoft Help
Viewer 2.0 Help, which is available from Help menu in the IDE.

• In Visual Studio 2012, clicking Help > Micro Focus Product Help > Product Documentation
results in the message "Cannot find requested topic on your computer". If you see this message,
click Micro Focus Visual COBOL 2.1 Update 1 for Visual Studio 2012 in the Contents tab to
display the documentation as expected.

• If you install Visual COBOL for Visual Studio 2012 and its documentation is not available in the
Microsoft Help Viewer, perform the following steps:

1. In Visual Studio 2012, click Help > Add and Remove Help Content.
2. Choose the Manage Content tab.
3. Check the Disk radio button, then navigate to the folder containing the Visual COBOL for

Visual Studio 2012 documentation. By default, this is C:\Program Files (x86)\Micro
Focus\Visual COBOL for Visual Studio 2012\help.

4. Select helpcontentsetup.msha and click Open.
5. In the content list, click Add next to the Visual COBOL 2.1 entry.
6. Click Update.
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7. Click Yes on the User Account Control and Microsoft Help Viewer 2.0 dialog boxes to enable
the update to continue.

The documentation for Visual COBOL for Visual Studio 2012 is added to the Microsoft Help
Viewer.

Note:

This problem only occurs if you install Visual COBOL for Visual Studio 2012 while
documentation for Visual Studio 2012 is being downloaded or updated, which typically
happens when you install Visual Studio 2012 or run it for the first time.

Visual COBOL and Enterprise Developer for Eclipse

If you have used Eclipse from the same workspace before, the Eclipse perspective settings are not reset
after installating any Micro Focus product. To pick up any new features, you must reset the COBOL
perspective after installation:

1. Make sure you are in the COBOL perspective by clicking Window > Open Perspective > COBOL.
2. Click Window > Reset Perspective.
3. Click OK.
4. Reapply any customizations.

Installing X Windows on Windows

Some features of Visual COBOL and Enterprise Developer on Windows require an X Windows installation,
hence Micro Focus ViewNowX is provided with the product. To install, run the file
ViewNow_X_Server.exe in your Visual COBOL installation. By default this will be in the
%ProgramFiles(x86)%\Micro Focus\Visual COBOL\ViewNowX folder.

ViewNowX requires that your client machine has Microsoft Visual C++ 2008 SP1 Redistributable Package
(x86) installed. If it is missing from your machine, the ViewNowX installation will offer a link to download the
package.

Repairing

Windows

If any product files, registry settings or shortcuts are accidentally removed at any point, you can perform a
repair on the installation to replace them.

To repair your installation on versions of Windows Vista or later:

1. From the Control Panel, click Uninstall a program under Programs.
2. Right-click your Micro Focus product and select Repair.

To repair your installation on older versions of Windows, such as Windows XP:

1. Click Start Menu > Control Panel > Add/Remove Programs.
2. Click your Micro Focus product in the list of installed programs.
3. Click Click here for support information.
4. Click Repair.

UNIX

If a file in the installation of the product becomes corrupt, or is missing, we recommend to reinstall the
product.
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Uninstalling

Windows

To uninstall the product, you cannot simply delete its files from your hard disk. To uninstall the product:

1. Log in with the same user-ID as you used when you installed the product.
2. Click Uninstall a program under Programs (or Add/Remove Programs on older versions of

Windows) in Control Panel.
3. On older versions of Windows such as Windows XP, ensure that Show Updates (at the top of the Add

or Remove Programs dialog) is checked, so that any hot fixes or WrapPacks are listed.
4. Click View installed updates in the left-hand pane.
5. Select the product and click Remove or Uninstall as appropriate.

When you uninstall, the only files deleted are those that the installation software installed. If the product
directory has not been removed, delete any unwanted files and subdirectories within it using Windows
Explorer.

Note: The installer creates separate installations for Micro Focus Visual COBOL , Enterprise Server
for .NET, and Micro Focus License Manager. Uninstalling only Visual COBOL does not automatically
uninstall Enterprise Server for .NET, the Micro Focus License Manager or any of the prerequisite
software.

Enterprise Server for .NET must be uninstalled before you remove Visual COBOL. To completely
remove the product you must uninstall the Micro Focus License Manager as well.

You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.

Some registry entries are not removed by the uninstallation process and you need to manually delete
them.

The following folders might not be removed:

• Micro Focus Product Name folder in the Start menu - you can delete it manually.
• %systemdrive%\Users\Public\Documents\Micro Focus - includes the binaries and the log

files of the samples which you have built.
• %ProgramData%\Micro Focus - includes some data files used by the Micro Focus licensing system.
• %Program Files%\Micro Focus - you can delete it manually.

UNIX

Note: Before you uninstall the product, ensure that the Enterprise Server Regions and the Micro
Focus Directory Service (MFDS) are stopped.

To uninstall this product:

1. Execute as root the Uninstall_VisualCOBOL21.sh script in the $COBDIR/bin directory.

Note: The installer creates separate installations for the product and for Micro Focus License
Manager. Uninstalling the product does not automatically uninstall the Micro Focus License Manager
or the prerequisite software. To completely remove the product you must uninstall the Micro Focus
License Manager as well.

To uninstall Micro Focus License Manager:

1. Execute as root the UnInstallMFLicenseServer.sh script in the /var/
microfocuslicensing/bin directory.

The script does not remove some of the files as they contain certain system settings or licenses.
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You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.

Disclaimer
This software is provided "as is" without warranty of any kind. Micro Focus disclaims all warranties, either
express or implied, including the warranties of merchantability and fitness for a particular purpose. In no
event shall Micro Focus or its suppliers be liable for any damages whatsoever including direct, indirect,
incidental, consequential, loss of business profits or special damages, even if Micro Focus or its suppliers
have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation
of liability for consequential or incidental damages so the foregoing limitation may not apply.

Micro Focus is a registered trademark.

Copyright © Micro Focus 1984-2013. All rights reserved.

This product includes software developed by Computing Services at Carnegie Mellon University (http://
www.cmu.edu/computing/)".
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