# Contents

Micro Focus Visual COBOL 2.3 for Visual Studio Release Notes  ..................5

**Installation**  ........................................................................................................ 6
  - System Requirements ....................................................................................... 6
  - Hardware Requirements .................................................................................. 6
  - Operating Systems Supported ....................................................................... 6
  - Software Requirements .................................................................................. 6
  - Additional Software Requirements ................................................................. 8
  - Installation Restrictions and Requirements ..................................................... 12

Installing Visual COBOL for Visual Studio .......................................................... 13
  - Downloading the Product .............................................................................. 13
  - Product Co-Existence ..................................................................................... 13
  - Installing as an Upgrade .................................................................................. 13
  - Installing ......................................................................................................... 14
  - Visual COBOL Installation Options ................................................................. 14
  - Installing from a Server ................................................................................... 15
  - Installing on Microsoft Terminal Server and Citrix ......................................... 15
  - Windows Compatibility Mode ......................................................................... 19
  - After Installing ............................................................................................... 20
  - Reparining ...................................................................................................... 21
  - Uninstalling .................................................................................................... 21

**Licensing Information**  ................................................................................... 23
  - To activate Visual COBOL Personal Edition ..................................................... 23
  - To request and activate a 30-day trial license for Visual COBOL ......................... 24
  - To buy and activate a full unlimited license ...................................................... 25
  - To start Micro Focus License Administration ................................................... 25
  - Installing licenses ........................................................................................... 25
    - If you have a license file .............................................................................. 25
    - If you have an authorization code ............................................................... 25
  - To obtain more licenses ................................................................................... 26

**New Features in Visual COBOL 2.3** ................................................................. 27
  - Integration with Visual Studio 2015 ................................................................. 27
  - General Enhancements and Updates ............................................................... 27
  - Building applications ...................................................................................... 27
  - COBOL Editor ................................................................................................. 28
  - Code Analysis ................................................................................................ 28
  - Code Coverage ................................................................................................ 29
  - Command Line Compilation and Linkage ....................................................... 29
  - Compiler Directives ......................................................................................... 29
  - Converting Additional Directives to Project's Properties .................................. 29
  - Data File Structure Command Line Utility .................................................... 29
  - Data File Tools (Technology Preview) .............................................................. 29
  - Database Access ............................................................................................. 30
  - File Handling .................................................................................................. 31
  - Library Routines ............................................................................................. 31
  - Managed COBOL Syntax ............................................................................... 32
  - Micro Focus Unit Testing Framework ............................................................ 32
  - Microsoft Azure Support ............................................................................... 32
  - Personal Edition Licensing ............................................................................. 32
  - Preprocessors ................................................................................................. 32
  - Profiler ........................................................................................................... 33
These release notes contain information that might not appear in the Help. Read them in their entirety before you install the product.

**Product Description**

Visual COBOL enables you to develop COBOL applications within Microsoft Visual Studio. You use the Visual Studio integrated development environment (IDE) to edit, compile and debug COBOL applications. The IDE provides all the functionality to manage projects and build applications.


---

**Important:** Application executables that were compiled using earlier Micro Focus products must be recompiled from the sources using Visual COBOL.
System Requirements

Hardware Requirements

Visual COBOL has the following requirements in addition to the requirements of Microsoft Visual Studio. See the Visual Studio documentation for details of the Microsoft requirements.

The maximum disk space requirements are, approximately:

<table>
<thead>
<tr>
<th>Visual COBOL</th>
<th>Sentinel RMS License Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.2Gb</td>
<td>75MB</td>
</tr>
</tbody>
</table>

- This includes the space needed to cache information locally so that you can modify the installation without the original source media.
- The disk space requirements include the versions of JRE and .NET Framework supplied with the setup file.

Operating Systems Supported

**Note:** If you are using Visual COBOL on a 64-bit operating system, you can produce either 32-bit or 64-bit applications.


**Note:**

- Visual COBOL for Visual Studio is not supported on versions of Windows earlier than Windows 7.
- The Enterprise Server feature is not supported on Windows XP.

Software Requirements

**Note:**

- The setup file will check your machine for whether the prerequisite software is installed and will install any missing prerequisites and the product components.
- Besides the software listed below, the setup file also installs the 32-bit Java 8 Update 51.

**Visual Studio IDE**

This product requires Microsoft's Visual Studio - either the Visual Studio Integrated Shell or a more advanced version of Visual Studio.

The following advanced editions of Visual Studio are required:

- Professional, Premium, or Ultimate (for Visual Studio 2012)
- Professional, Premium, Ultimate or Community Edition (for Visual Studio 2013)
Professional, Enterprise or Community Edition (for Visual Studio 2015)

If there is no Visual Studio installed on your machine, the setup file for Visual COBOL for Visual Studio 2012 or 2013 will install the Visual Studio Integrated Shell.

Important:


• Code generation issues in Microsoft's 64-bit JIT (just-in-time) compiler delivered as part of .NET version 4.6 can result in incorrect execution of some COBOL code compiled to .NET. Version 4.6 of the .NET Framework is currently shipped as default with Visual Studio 2015 and Microsoft's Windows 10. The problems include incorrect execution of MOVE and STRING statements applied to alphanumeric operands, and incorrect execution of the ROUNDED phrase for arithmetic statements.

Some of these issues only seem to be reproducible in COBOL language applications compiled to .NET and some can be reproduced in other languages (C# or Visual Basic).

These problems have been reported and acknowledged by Microsoft and it is our belief that they either have resolutions or are working on fixes for all of them.

Until these issues have been confirmed as resolved by Microsoft, Micro Focus recommends that managed COBOL code should not be executed on the .NET Framework 4.6 platform. For further information about these issues and guidelines on how to disable the latest version of the 64-bit JIT compiler, see RyuJIT Bug Advisory and Troubleshooting RyuJIT.

• Visual COBOL for Visual Studio 2015 does not support Visual Studio 2015 Shell as the Shell has a number of restrictions to COBOL development. The Visual Studio 2015 Shell is not included in the setup for Visual COBOL for Visual Studio 2015 and before you start the installation, ensure that there is an advanced edition of Visual Studio 2015 installed on your machine.

Note:

• On Windows 8.1 RT, Windows 8.1 or Windows Server 2012 R2, you must have the Windows update KB 2919355 before you install Visual Studio 2015. Download KB 2919355 from the Microsoft Download Center.

• Microsoft Visual Studio Express Edition is not supported.

• You can download the Visual Studio Integrated Shell from the Microsoft Download Center. If you choose to install the Shell, ensure you run the installer to complete the installation - run vsintshell.enu.exe from the location where you installed the download.

  Note that some Visual Studio features might not be available with the Shell. This includes WCF or the Visual Studio 2013 Connected IDE experience in the Visual Studio 2013 Shell - the help for more details.

The following software is also required:

• Microsoft Windows SDK is required if you are using the Visual Studio Shell. See the Microsoft Download Center and search for Windows SDK.

• Microsoft .NET Framework 4.5. This is included with Visual Studio 2012.

• Microsoft .NET Framework 4.5.1. This is included with Visual Studio 2013.

• Microsoft .NET Framework 4.6. This is included with Visual Studio 2015.

Internet Explorer 10

Internet Explorer 10 (IE 10) is required by the installation of Visual Studio 2013. If you are installing Visual COBOL on a machine that has no Visual Studio 2013 installed, the setup file installs Visual Studio 2013 Shell provided that IE 10 is installed beforehand. You can download IE 10 from Microsoft's Web site.
IIS Express

IIS Express is required if you want to use the Web development tools. You can download IIS Express from the Microsoft Download Center.

Other Requirements

**Important:** This release requires version 10000.2.990 or later of the Micro Focus License Administration tool. For local servers, you do not need to install it separately, as the setup file installs a new Visual COBOL client and a new licensing server on the same machine.

If you have a network server, you must update the license server before installing the product as the client is not able to communicate with license servers of versions older than 10000.2.660. On Windows, you can check the version of your license server by clicking Help > About in the Micro Focus License Administration tool.

You can download the new version of the license server software from the Micro Focus SupportLine Web site: http://supportline.microfocus.com.

Additional Software Requirements

To ensure full functionality for some Visual COBOL features, you might be required to obtain and install additional third-party software in addition to the prerequisite software installed automatically by the Visual COBOL setup file. The following information specifies the third-party software required for each feature.

- Application server JCA support for Enterprise Server
- COBOL on Microsoft Azure on page 9
- Java Development Kit (JDK) on page 9
- Consolidated Trace Facility on page 9
- Database Access on page 9
- Database Access - COBSQL (Pro*COBOL) on page 10
- Database Access - OpenESQL on page 10
- Database Access - DB2 ECM on page 11
- Windows Forms on page 12
- XML Extensions on page 12

Application server JCA support for Enterprise Server

Restriction: This feature applies only when the Enterprise Server feature is enabled.

Java EE 5 and Java EE 6 are supported for the deployment of EJBs generated using the Interface Mapping Toolkit, as follows:

- Java EE 5 includes support for EJB 3.0 and Java Connector Architecture 1.5
- Java EE 6 includes support for EJB 3.1 and Java Connector Architecture 1.6

The following Java application servers are supported using the following JDKs:

<table>
<thead>
<tr>
<th>Application Servers</th>
<th>JDK (vendor)</th>
<th>Java EE</th>
<th>COBOL RA</th>
</tr>
</thead>
<tbody>
<tr>
<td>JBoss 5.1.0</td>
<td>1.6 (Oracle)</td>
<td>5</td>
<td>x</td>
</tr>
<tr>
<td>JBoss 6.1.0</td>
<td>1.6 (Oracle)</td>
<td>6</td>
<td>x</td>
</tr>
<tr>
<td>JBoss 7.1.1</td>
<td>1.7 (Oracle)</td>
<td>6</td>
<td>x</td>
</tr>
<tr>
<td>Oracle WebLogic 10.3.5</td>
<td>1.6 (Oracle)</td>
<td>5</td>
<td>x</td>
</tr>
<tr>
<td>Application Servers</td>
<td>JDK (vendor)</td>
<td>Java EE</td>
<td>COBOL RA</td>
</tr>
<tr>
<td>---------------------</td>
<td>--------------</td>
<td>---------</td>
<td>----------</td>
</tr>
<tr>
<td>Oracle WebLogic 12.1.1</td>
<td>1.6/1.7 (Oracle)</td>
<td>6</td>
<td>X</td>
</tr>
<tr>
<td>IBM WebSphere 7.0</td>
<td>1.5 (IBM)</td>
<td>5</td>
<td>X</td>
</tr>
<tr>
<td>IBM WebSphere 8.0</td>
<td>1.6 (IBM)</td>
<td>6</td>
<td>X</td>
</tr>
<tr>
<td>IBM WebSphere 8.5</td>
<td>1.6/1.7 (IBM)</td>
<td>6</td>
<td>X</td>
</tr>
</tbody>
</table>

**COBOL on Microsoft Azure**

*Back to Top*

Microsoft Azure requires additional software. See the Microsoft Microsoft Azure web site for a full list of the required software, but the following is a summary of the main prerequisites:

- Microsoft Azure Tools version 2.6 for the version of Visual Studio you have installed - this includes the Microsoft Azure SDK
- Visual Studio's Visual Web Developer feature
- IIS7 with ASP.NET and WCF HTTP Activation, Static Content, IIS Management Console and HTTP Redirection.
- Microsoft's Web Deployment Tool version 2.1 or later

**Java Development Kit (JDK)**

*Back to Top*

**Native COBOL and Java Interoperability** Oracle's Java Platform, Enterprise Edition (Java EE) 7 or Java 8 is required to execute COBOL JVM code and for native COBOL and Java interoperability. The setup file installs Java 8 u51 32-bit. You can download Oracle's Java EE from Oracle's Web site and install it anywhere on your machine.

**Compiling Java** Either the IBM or the Oracle Java Development Kit (JDK), version 1.5 or later, is required for compiling Java.

**Interface Mapping Toolkit (IMTK)**

*Restriction:* This feature applies only when the Enterprise Server feature is enabled.

The JDK is required for generating Java interfaces from the Interface Mapping Toolkit or the `imtkmake` command.

- **Java Beans** Your Java client needs to be compiled with JDK 1.6 or greater.
- **EJBs** Use the same JDK vendor and version that is used by the application server.

After installing the JDK, you need to set up your Java environment.

*Back to Top*

**Consolidated Trace Facility**

- The Microsoft .NET Framework 2.0 or later is required for the CTF Viewer. It is available from the Microsoft .NET downloads area.

*Back to Top*

**Database Access**

*Back to Top*
Before you can use Visual COBOL to develop and deploy SQL applications that use COBSQL, DB2 ECM, or OpenESQL, ensure any third-party software prerequisites are installed and the environment is set properly.

### Database Access - COBSQL (Pro*COBOL)

*Note:* COBSQL (Pro*COBOL) is supported for native COBOL only.

#### Availability

<table>
<thead>
<tr>
<th>Feature/Platform</th>
<th>32-bit</th>
<th>64-bit</th>
</tr>
</thead>
<tbody>
<tr>
<td>x86-64 running Windows</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>

#### XA Switch Module

When the Enterprise Server feature is enabled, the Oracle XA switch module is provided for COBSQL (Pro*COBOL), and is available on the same platforms as are indicated in the *Availability* section above.

#### Certification of RDBMS Precompilers for Native COBOL

Certification of RDBMS precompilers with Micro Focus products is the responsibility of the RDBMS vendor, rather than Micro Focus. Certification information can be found within the relevant Oracle documentation. If you have an Oracle MetaLink account, document # 43208.1 provides details of all language compilers certified by Oracle for use with their precompilers.

#### Preprocessors

COBSQL supports the following database preprocessors:

- Sybase Open Client Embedded SQL/COBOL Version 11.1 or later
- Oracle Pro*COBOL Version 11.1 (11gR1) or later
- Informix Embedded SQL/COBOL Version 7.3 or later

#### Compiling

On x86 and x86-64 platforms, when compiling with COBSQL for use with Oracle, do not use the COBSQL directive option NOMAKESYN, since this directive results in COMP host variables, and on Intel platforms these are incompatible with the native byte order expected by Oracle.

#### Testing

For this version, COBSQL was tested with Oracle 11.1, 11.2, and 12.1.

### Database Access - OpenESQL

#### Availability

<table>
<thead>
<tr>
<th>Feature/Platform</th>
<th>Native and .NET Managed COBOL 32-bit</th>
<th>Native and .NET Managed COBOL 64-bit</th>
</tr>
</thead>
<tbody>
<tr>
<td>x86-64 running Windows</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

#### XA Switch Modules

When the Enterprise Server feature is enabled, the ODBC One-phase Commit and the SQL Server XA switch modules are provided and are available on the same platforms as are indicated in the *Availability* section above.

To build the SQL Server XA module, you must have the Windows Software Development Kit (SDK) installed for your version of Windows.

#### Native COBOL

- OpenESQL supports access to relational databases using ODBC 3.0-compliant drivers
- Refer to your driver vendor's documentation to determine whether your driver is suitable for use with OpenESQL
.NET Managed COBOL

OpenESQL has been tested against the following ADO.NET data providers:

- Microsoft provider for SQL Server
- Microsoft provider for Oracle
- IBM DB2
- Oracle Data Provider for .NET (ODP.NET)
- OleDb
- Managed ODBC .NET providers
- Npgsql PostgreSQL 9.4

SQL CLR Integration

The following software is required to use the SQL CLR integration feature, which is specifically for the development and deployment of COBOL stored procedures under Microsoft SQL Server.

Projects based on the SQL Server Database Project template require:

- Either of the following:
  - Visual Studio Shell 2012 Update 1 or later and Microsoft SQL Server Tools (SSDT SDK)
  - Visual Studio 2012 Update 1 or later Professional, Premium, or Ultimate
  - Visual Studio Shell 2013 and Microsoft SQL Server Tools (SSDT SDK)
  - Visual Studio 2013 Professional, Premium, Ultimate or Community Edition
  - Visual Studio Shell 2015 and Microsoft SQL Server Tools (SSDT SDK)
  - Visual Studio 2015 Professional, Enterprise or Community Edition
- Any of the following:
  - SQL Server 2008 R2 targeting .NET CLR v2.0 frameworks (2.0, 3.0, 3.5)
  - SQL Server 2012 targeting .NET CLR v4.0 framework (4.0, 4.5) or .NET CLR v2.0 frameworks (2.0, 3.0, 3.5)
  - SQL Azure Database targeting .NET CLR v4.0 framework (4.0, 4.5) or .NET CLR v2.0 frameworks (2.0, 3.0, 3.5)

**Important:** The SQL CLR Database project template available in previous versions of Visual COBOL is no longer supported. Projects based on the SQL CLR Database project template are automatically upgraded to use the SQL Server Database project template when opened in Visual COBOL for Visual Studio 2012.

Testing

For this version, OpenESQL was tested with:

- Oracle 11.1, 11.2 and 12.1
- DB2 LUW 9.5, 9.7, 10.1, 10.5
- PostgreSQL 9.4

**Note:** Micro Focus provides compatibility for PostgreSQL but does not directly contribute to or support the PostgreSQL open source project. Any issues relating to PostgreSQL functionality should be addressed through an open source support vendor.

Database Access - DB2 ECM
Availability

<table>
<thead>
<tr>
<th>Feature/Platform</th>
<th>32-bit</th>
<th>64-bit</th>
</tr>
</thead>
<tbody>
<tr>
<td>x86-64 running Windows</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

**XA Switch Module**
When the Enterprise Server feature is enabled, the DB2 XA switch module is provided and is available on the same platforms as are indicated in the Availability section above.

**Certification of RDBMS Precompilers for Native COBOL**
Certification of RDBMS precompilers with Micro Focus products is the responsibility of the RDBMS vendor, rather than Micro Focus. You can find IBM document certification information for DB2/COBOL applications within the IBM Information Center for DB2, in the topic Support for database application development in COBOL.

**Preprocessor**
DB2 ECM supports the following database preprocessors:
- IBM DB2 LUW Version 9.5 or later
- IBM DB2 Connect Version 9.5 or later

**Testing**
For this version, DB2 ECM was tested with DB2 LUW 9.5, 9.7, 10.1, and 10.5.

**Windows Forms**
- Microsoft Visual Studio is required for using the Interface Mapping Toolkit (IMTK) to generate Windows Forms and ASP.NET Web site test clients.
- Microsoft Internet Information Service (IIS) is also required for generating Windows Forms test clients.

**XML Extensions**
- XML Extensions has the same requirements as Visual COBOL. Both 32-bit and 64-bit versions are available. See the XML Extensions for Visual COBOL, available from the Visual COBOL product documentation section of the Micro Focus SupportLine Web site for more details.
- Additionally, XML Extensions may be used in conjunction with Terminal Server.

**Installation Restrictions and Requirements**
Before starting the installation you should consider the following:
- Visual COBOL and Enterprise Developer cannot coexist on the same machine.
- If, when you install Visual COBOL for Visual Studio, the machine does not have Microsoft Visual C++ Redistributable Runtime already installed, it is installed as required by Visual COBOL. The installation of Microsoft Visual C++ Redistributable Runtime adds a number of .dll files, without digital signatures, into the winsxs directory.
- If, when you install Visual COBOL for Visual Studio 2012, the machine does not have Microsoft Visual C++ 2012 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The installation of Microsoft Visual C++ 2012 Redistributable Runtime adds a number of .dll files, without digital signatures, into the winsxs directory.
- If, when you install Visual COBOL for Visual Studio 2015, the machine does not have Microsoft Visual C++ 2013 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The installation of Microsoft Visual C++ 2013 Redistributable Runtime adds a number of .dll files, without digital signatures, into the winsxs directory.
- You need to be logged in with a user-ID that has write access to the registry structure under HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation
software can set the environment appropriately. You also need to be logged on with Administrator privileges.

- Before installing this product, make sure that any existing Micro Focus Directory Server (MFDS) or CCITCP2 Windows service (on Windows) from an existing product is stopped and uninstalled. On Windows, do this as follows:
  1. Stop the MFDS and CCITCP2, using either the Windows Service Management Console GUI (services.msc) or from a command line prompt by typing:

     `net stop mf_ccitcp2`

     Only one instance of the MFDS or CCITCP2 service can run on a Windows machine.
  2. Uninstall the MFDS or CCITCP2 service.

     For MFDS, from a command line prompt enter: `mfds -u`

     For CCITCP2: `ccitcp2 -u`

To run an earlier version of MFDS as a service after you have installed a later version:

1. Stop and uninstall the MFDS service, as described above.
2. Reinstall the earlier version, as follows:
   a. Open a Visual COBOL command prompt.
   b. Install the service. Enter the following command: `mfds -i`
   c. Start the service. Enter the following command: `net start mf_ccitcp2`

   **Note:** The two versions use different paths for environment and registry values, so the list of configured enterprise servers might be different depending on which version has been started, since, by default, different MFDS data repositories are used.

MFDS 5.1 and later are able to import or use Enterprise Server configuration data generated by earlier versions of MFDS, but 5.0 or earlier versions of MFDS might not be able to read data generated by later versions.

It is possible to run MFDS from a command prompt ("mfds") rather than as a service, but by default the "mfcobol" port is used (86) and this can only be used by one process at a time.

### Installing Visual COBOL for Visual Studio

#### Downloading the Product

You can download Visual COBOL from the Micro Focus SupportLine Web site and from the *Product Updates* section.

#### Product Co-Existence

- Visual COBOL and COBOL Server cannot coexist on the same machine.
- Visual COBOL and Enterprise Developer cannot coexist on the same machine regardless of which IDE (Visual Studio or Eclipse) you install.

#### Installing as an Upgrade

- This release will not upgrade previous versions of the product. Any previous releases and HotFixes of the product installed on your machine must be uninstalled before installing 2.3.
- Before installing this release as an upgrade, ensure you create a back-up of your Enterprise Server configuration. To do this, on the Enterprise Server Administration home page, click **Export** and then
select Export Enterprise Server configuration and Security Manager definitions. This creates a backup folder in the \c:\programdata\micro focus\Enterprise Developer\MFDS. You can restore the Enterprise Server configuration after installing this release - click Import on the Enterprise Server Administration home page.

Installing

Note:
• This version of the product is a full install.
• Before installing, check Installation Restrictions and Requirements. Also, see Installing as an Upgrade first for important information, if you have an earlier version of Visual COBOL installed on your machine.

To install this product:

1. Run the vcvs2012_23.exe file (or vcvs2013_23.exe, vcvs2015_23.exe) and follow the wizard instructions to install the prerequisite software and the product.

Note:
• When the installation has completed, on some editions of Windows you might receive a notification that Visual Studio 2012 has compatibility issues. This is a known Microsoft issue. To resolve it, follow the instructions in the notification for obtaining help online, or download the KB2781514 update for Visual Studio 2012 from the Microsoft Download Center.
• If you are installing onto a machine that has an existing Micro Focus product that uses an older Sentinel RMS License Manager, you might be prompted to remove it and install the Micro Focus License Administration. By doing this you maintain the existing Sentinel RMS license files while adding the Micro Focus License Administration. If you are unsure about existing licenses on your computer or removing the Sentinel RMS License Manager, consult your System Administrator. If you want to proceed, remove Sentinel RMS License Manager by using Program and Features (Windows Vista or later), and rerun the installation file.
• Trial licenses cannot be used with remote desktop services. If you want to use your product in this way, please contact Micro Focus SupportLine to obtain a relevant license.
• We recommend that you install any updates for Visual Studio and the .NET Framework that are available at the Microsoft Download site.
• If you install JDK you might be prompted to install the latest update. The latest update is not required for use with Visual COBOL but you can install it if you wish.

Visual COBOL Installation Options

To install Visual COBOL you run vcvs2012_23.exe which contains a number of product .msi files (Windows Installer packages). When run, vcvs2012_23.exe performs some initial system checks then sequentially installs the .msi files.

Note: The following applies to vcvs2013_23.exe when installing the product for Visual Studio 2013.
The following applies to vcvs2015_23.exe when installing the product for Visual Studio 2015.

vcvs2012_23.exe can take a number of parameters, enabling you to specify a number of different types of installation:
• Standard Installation

Format: vcvs2012_23.exe
Summary: Full installation including License Manager and Visual COBOL. During installation you can specify options including the location to which the components are installed.
• Non-interactive Installation

**Format:**
vcvs2012_23.exe /passive

**Summary:**
Full installation, but the components are installed non-interactively using default options and directories.

• Silent Installation

**Format:**
vcvs2012_23.exe /q

**Summary:**
Full installation, but the components are installed non-interactively with no user interface, using default options and directories.

• Modified Silent Installation

**Format:**
vcvs2012_23.exe /q InstallFolder=d:\otherdirectory

**Summary:**
Full installation, but the components are installed non-interactively with no user interface, and Visual COBOL is installed to d:\otherdirectory.

To see what parameters you can use, execute the following from the command line:
vcvs2012_23.exe /?.

**Note:**
- Log files that are created during installation are saved in the folder specified by the TEMP environment variable. To change the location or name of the files, use the /log parameter on your setup command line and specify the path and file name, for example: filename /log d:\temp \log.txt. This creates a log file, named log.txt, in the d:\temp directory.

### Installing from a Server

There are two methods for installing this product on users' machines using a server. You can:

• Copy the product onto the server and then use Setup under control of a third-party software distribution package, such as Microsoft's Systems Management Server (SMS), to install the product onto multiple users' machines.

  This method of installation and the associated file are not supported by Micro Focus. They are provided on an "as is" basis and have not been tested in any form. You can use them at your own discretion.

• Install onto the server. Then users run Setup to install from the server onto their own machines.

Both methods give you control of what options the user can install and mean you do not have to send the installation media to every user, as they install from the server instead.

### Installing on Microsoft Terminal Server and Citrix

**Note:** This document is a work-in-progress. Check the documentation for Visual COBOL in the *Product Documentation* section of the Visual COBOL SupportLine Web site for its most recent version.

Microsoft Terminal Server and Citrix (TS/Citrix) are environments for running multiple instances of a single user product. They are not platforms where a single-user product can be made to perform as a multi-user product.
When running Visual COBOL on TS/Citrix machine, there might be some implications to components of Visual COBOL which could cause potential conflicts between a ‘per-user session’ compared to the standard ‘per machine’ setup. The following components of Visual COBOL require special configuration:

- Eclipse workspaces and projects
- The Enterprise Server component - the Run-Time System product for JCL, CICS and IMS operations
- The database management service

You can use Visual COBOL with TS or with any Citrix version certified for use with Visual Studio; however, a separate end-user license is required for each user who accesses Visual COBOL, even if it is running on a single machine. See your End User License Agreement for clarification.

**Note:** Micro Focus Visual COBOL does not officially support TS/Citrix. However, it will run on any prerequisite Operating System that is supported under TS/Citrix.

**Capacity planning**

Multi-user capacity planning for TS/Citrix does not scale linearly, and the calculations required for this planning are not directly related or specific) to any Micro Focus technology. Micro Focus recommends that you consult with Microsoft or Citrix Systems, respectively, about the server sizing and capacity planning, based on hosting the required number of “rich” Windows 7 or Windows 8 desktops (e.g. using a singleton desktop build as a baseline).

**Installing Visual COBOL**

To install Visual COBOL for use with TS/Citrix:

1. Log on to the physical terminal or Citrix server with a user ID that has administrator privileges.
2. Use the download links in your Electronic Product Delivery email.
3. Follow the links for the installation instructions and the End User License Agreement.

**Configuring Visual COBOL components**

Further configuration is required for the following Visual COBOL components:

**Customizing the installation of Visual COBOL for Visual Studio**

On TS/Citrix, end-users accessing an application get their own copy (called a “clone”) of an initial set of the application’s configuration settings. Within their clone of the application, each end-user is then able to apply some changes to the initial configuration settings - for example, change any color and font settings, the screen-layout of windows, some of the shortcut keys among others. The modified settings are then preserved on a per-user basis.

This mechanism enables you to customize the configuration settings within the initial Visual COBOL installation which is then replicated at the individual users's machines when they are using a clone of the application. While this does not prevent the developers from changing the initial settings within their clone of the application, it does favor team work by providing all team members with a preconfigured environment, that has the same settings, behavior and look as a start.

Follow the steps below to customize Visual COBOL for Visual Studio on the TS/Citrix machine and apply the changes to the clones of the product.

**Caution:** The following instructions involve changing the registry settings on the TS/Citrix machine. Take extra care when editing the registry as incorrect entries might corrupt your system. It is recommended that you back up any valued data on your computer in advance. Micro Focus recommends you also create a backup copy of the master location, after step 8. Alternatively, copy EDsettings.reg to a safe location.

1. Log onto the TS/Citrix machine as a TS/Citrix administrator.
2. Install Visual COBOL.
TS/Citrix stores a collection of settings in the server’s registry, under `HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\Software\xxxx`. This document refers to this location as the master location.

**Note:** The Visual COBOL settings are stored under different locations in the registry. For example:

- `HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\11.0\MicroFocus\Settings` - stores the options specified in **Tools > Options**.
- `HKEY_CURRENT_USER\Software\Micro Focus\Visual COBOL\2.3\Interface Mapping Toolkit` - stores the settings for IMTK
- `HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\11.0\MicroFocus\COBOL Tools\Client Generation` - stores the settings for IMTK client generation

Micro Focus recommends you create a backup copy of any settings in the master location, after step 8. Alternatively, copy `EDsettings.reg` to a safe location.

3. Log off from the TS/Citrix account.
4. Log on as a user that has the privileges of the standard end-user (a developer).

TS/Citrix now clones the contents of the master location to `HKEY_CURRENT_USER\Software\xxxx`. This document refers to this location as the user location.

5. Customize Visual COBOL as required for a first time user within your development teams - modify any default settings, default layout of views within Eclipse, etc.

6. Save the user location within the registry:
   a. Using the Registry Editor, export the contents of the user location to a file - for example `EDsettings.reg`.
   b. Edit `EDsettings.reg` with a plain text editor and replace all `HKEY_CURRENT_USER\Software\xxxx` entries with `HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\Software\xxxx`. For example, replace `HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\11.0\MicroFocus\Settings\xxxx` entries with `HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\Software\MicroFocus\Settings`.

7. Log off from TS/Citrix.
8. Log on as a TS/Citrix administrator again.
9. Copy the contents of the user location back to the master location:
   a. Using the Registry Editor, delete the master location, then import the settings from the `EDsettings.reg` file.
   b. Log off from TS/Citrix.

**Projects**

Create and configure template projects to distribute among your users. Templates must not include fully qualified paths. You can store the projects in a source control system and make them available so that individual users can import them into their own workspace.

**Enterprise Server Installation Options**

When you install Visual COBOL, the setup file also installs the Enterprise Server component on the same machine. There are different ways in which you can configure and use Enterprise Server regions in TS/Citrix environments. This topic outlines two of the methods and explains what the implications of choosing them are:

- **Use the Enterprise Server component as part of Visual COBOL installed on the TS/Citrix machine**

  On the client machines, the developers each use a clone of Visual COBOL. They also use a clone of Enterprise Server to create and manage multiple server instances as required.
While this option provides the greatest flexibility, it also consumes the largest footprint per user.

- **Install Enterprise Server or Enterprise Test Server on a separate server**

  You can install Enterprise Server\(^1\) or Enterprise Test Server\(^2\) on a separate server that does not have TS/Citrix installed. By default, Enterprise Server installs and runs as a single-instance product and, within an Enterprise Server, you can operate a number of server instances. Each server provides session and state management for COBOL applications, as well as optionally interfacing with external resource managers to coordinate resource updates.

  There are two ways to provide server instances to the developers using Visual COBOL on the TS/Citrix machine:
  
  - Configure one server instance per developer by specifying different ports. We recommend defining five-digit port numbers where digits one through three identify the developer and four through five identify a unique port. For example: port number 10123 defines a TN3270 listener for developer 1, and port number 10223 defines a TN3270 listener for developer 2.

  This option provides a dedicated enterprise server for testing purposes for each developer, but restricts each developer to that one enterprise server instance.

  This scenario creates the largest footprint per developer.

---

1. Micro Focus Enterprise Server provides full application server support for COBOL applications that require high-performance and mainframe subsystem emulation. Enterprise Server is designed as a multi-user environment.

2. Micro Focus Enterprise Test Server is an IBM mainframe application test execution environment on Windows. Enterprise Test Server enables mainframe IT organizations to perform a variety of pre-production testing on low cost commodity hardware, avoiding unnecessary cost and delay. Built on proven technology, Enterprise Test Server exponentially expands the test capacity and enables testing to scale up easily to meet delivery timelines and quality standards driven by today’s business requirements.
Or:

- Create and configure one server instance per application for use by a single development team. Use a different port number for each instance as explained above, using the first three digits to differentiate between applications.

**Micro Focus Rumba**

To use Micro Focus Rumba on a TS/Citrix machine, ensure you install a license for this type of environment. Contact Micro Focus Sales for more information.

**ViewNow Installation**

To use ViewNow on a TS/Citrix machine, ensure you install a license for this type of environment. Contact Micro Focus Sales for more information.

**Windows Compatibility Mode**

In Windows Vista and Windows Server 2008, if you have problems starting Enterprise Server instances using the Micro Focus Enterprise Server Administration HTML GUI, ensure that none of the Enterprise Server program files are configured to use a Windows compatibility mode. You can check for compatibility modes by examining the file properties for the program file using Windows Explorer:

1. Open the **Properties** dialog box for the file.
2. Click the **Compatibility** tab.
3. Ensure that **Run this program in compatibility mode for** is not checked.
4. Click **Show settings for all users** and ensure that **Run this program in compatibility mode for** is not checked.
5. Click **OK** on both dialogs to update the file properties.

Verify that `<install-dir>ase\bin\mfds.exe` is not set to run in a compatibility mode.

- For 32-bit Enterprise Server, check `bin\cas*.exe` and `bin\mfcs.exe`
• For 64-bit Enterprise Server, check `bin\win64\cas*.exe` and `bin\win64\mfcs.exe`.

**After Installing**

You are now ready to run Visual COBOL. From the Windows taskbar click **Start > All Programs > Micro Focus Visual COBOL > Visual COBOL for Visual Studio nnnn**.

> **Note:** The Start menu is not available on Windows 8 and Windows Server 2012. You use the Start screen to invoke programs.

**Code generation issues in .NET Framework version 4.6**

- Code generation issues in Microsoft’s 64-bit JIT (just-in-time) compiler delivered as part of .NET version 4.6 can result in incorrect execution of some COBOL code compiled to .NET. Version 4.6 of the .NET Framework is currently shipped as default with Visual Studio 2015 and Microsoft’s Windows 10. The problems include incorrect execution of MOVE and STRING statements applied to alphanumeric operands, and incorrect execution of the ROUNDED phrase for arithmetic statements.

Some of these issues only seem to be reproducible in COBOL language applications compiled to .NET and some can be reproduced in other languages (C# or Visual Basic).

These problems have been reported and acknowledged by Microsoft and it is our belief that they either have resolutions or are working on fixes for all of them.

Until these issues have been confirmed as resolved by Microsoft, Micro Focus recommends that managed COBOL code should not be executed on the .NET Framework 4.6 platform. For further information about these issues and guidelines on how to disable the latest version of the 64-bit JIT compiler, see [RyuJIT Bug Advisory](#) and [Troubleshooting RyuJIT](#).

> **Note:**

For applications created with earlier Micro Focus products or earlier versions of Visual COBOL, note the following:

**Building Applications**

If, after upgrading to this version of Visual COBOL, you start receiving unexpected build errors when compiling an existing multi-project solution, this may be a result of enabling parallel project builds in this release. These are a couple of examples of issues that might be causing these errors:

- Using file references to project outputs in the same solution. You need to use project-to-project references instead.

  Use **Project > Project Dependencies** to manage the project dependencies and build order within your solution.

- A customized build process such as one that is using pre- or post- build events.

If resolving any of these issues does not help resolve the build errors, consider disabling the parallel build support - click **Tools > Options > Projects and Solutions > Build and Run** and set maximum number of parallel project builds to 1.

> **Note:** Parallel builds are not supported with Personal Edition licensing.

**Database Access**

Managed applications using SQL(DBMAN=ODBC) that were compiled in Visual COBOL 2.1 Update 1 must be recompiled in Visual COBOL 2.3.

**Existing Applications**

Application executables that were compiled using earlier Micro Focus products must be recompiled from the sources using Visual COBOL.
Please refer to the *Start Here* and *Product Information* sections in your product Help. Here, you will find information on getting started including tutorials and demonstration programs.

**Note:**

- To view the help in Visual Studio 2012, ensure that the Visual Studio Help Library is pointing to local help. From the Visual Studio menu click **Help > Set Help Preferences > Launch in Help Browser**.
- For full details of the Visual Studio 2012 Help system, see the locally installed Microsoft Help Viewer 2.0 Help, which is available from Help menu in the IDE.
- On Windows 8 and Windows Server 2012, an issue with Microsoft Help Viewer 2.0 and Internet Explorer’s security being turned on can cause the Help content to be displayed as raw HTML code. To resolve the issue, you need to turn off the Internet Explorer Enhanced Security Configuration (IE ESC) for both administrators and users. Check the Microsoft Windows help for more information on how to do this.
- To view the help in Visual Studio 2013, ensure that the Visual Studio Help Library is pointing to local help. From the Visual Studio menu click **Help > Set Help Preferences > Launch in Help Browser**.
- For full details of the Visual Studio Help system, see the locally installed Microsoft Help Viewer 2.1 Help, which is available from Help menu in the IDE.
- To view the help in Visual Studio 2015, ensure that the Visual Studio Help Library is pointing to local help. From the Visual Studio menu click **Help > Set Help Preferences > Launch in Help Browser**.
- For full details of the Visual Studio Help system, see the locally installed Microsoft Help Viewer 2.2 Help, which is available from Help menu in the IDE.

**Repairing**

If any product files, registry settings or shortcuts are accidentally removed at any point, you can perform a repair on the installation to replace them.

To repair your installation on versions of Windows Vista or later:

1. From the **Control Panel**, click **Uninstall a program** under **Programs**.
2. Right-click your Micro Focus product and select **Repair**.

**Uninstalling**

To uninstall the product, you cannot simply delete its files from your hard disk. To uninstall the product:

1. Log in with the same user-ID as you used when you installed the product.
2. Click **Uninstall a program** under **Programs** in **Control Panel**.
3. Select the product and click **Remove** or **Uninstall** as appropriate.

When you uninstall, the only files deleted are those that the installation software installed. If the product directory has not been removed, delete any unwanted files and subdirectories within it using Windows Explorer.

**Note:** The installer creates separate installations for Micro Focus Visual COBOL and Micro Focus License Administration. Uninstalling only Visual COBOL does not automatically uninstall the Micro Focus License Administration or any of the prerequisite software.

To completely remove the product you must uninstall the Micro Focus License Administration as well.

You can optionally remove the prerequisite software. For instructions, check the documentation of the respective software vendor.

Some registry entries are not removed by the uninstallation process and you need to manually delete them.
The following folders might not be removed:

- **The Micro Focus Product Name folder** in the Start menu - you can delete it manually.
- `%systemdrive%\Users\Public\Documents\Micro Focus` - includes the binaries and the log files of the samples which you have built.
- `%ProgramData%\Micro Focus` - includes some data files used by the Micro Focus licensing system.
- `%Program Files%\Micro Focus` - you can delete it manually.

To silently uninstall the product, you need the setup file and you need to execute the following at the command line:

```
start /wait install-file.exe /quiet /uninstall
```

In addition, the following registry entries are not removed. These are created the first time that an Enterprise Server that has been enabled for performance monitoring starts up:

- Micro Focus Server\Performance\Active Servers
- Micro Focus Server\Performance\PerfIniFile
Licensing Information

Note:

- If you have purchased licenses for a previous release of this product, those licenses will also enable you to use this release.
- Personal Edition licensing is only available with Visual COBOL for Visual Studio 2015
- The latest version of the SafeNet licensing software is required. See the Software Requirements section in this document for more details.
- Your entitlement for using this product is governed by the Micro Focus End User License Agreement and by your product order. If you are unsure of what your license entitlement is or if you wish to purchase additional licenses, contact your sales representative or Micro Focus SupportLine.

To activate Visual COBOL Personal Edition

Having activated Visual COBOL Personal Edition, you can use it for a limited period of 365 days. After this period, you can either register a new Personal Edition license for 365 days or enter an authorization code in order to continue using it, either for a 30-day trial or full license of Visual COBOL. To do this:

1. Start Visual COBOL.

   If you have not installed a license for Visual COBOL, starting the IDE and trying to create a COBOL project opens the Micro Focus Visual COBOL Product Licensing dialog box. If you cancel this dialog box, you can invoke it again from Help > Micro Focus Product Help > Product Licensing.

2. Click I want to activate the free product.

3. Ensure that the email address used to register the product is in the Email address text entry field. If you haven't registered your email address yet, click registration page and follow the instructions on that page.

4. Select one of the following options:

   Automatic Use this if you have Internet access.

   1. Click Activate License to activate your copy of Visual COBOL Personal Edition.

   Manual Use this if you are not connected to the Internet.

   1. Click Send email.

      This opens your default email client and creates a new email filled in with the details to send to Micro Focus about activating your copy of the free Personal Edition of the product.

      Note: If there is no mail client installed on your machine, click next to Send email, and click Display fields. You will be presented with a template that includes the email address, the subject and the contents of an email to send to Micro Focus using a mail client of your choice. Do not modify the details.

      You will receive a response email with details about your authorization request.

   2. Paste the contents of the response email in the designated field in the Micro Focus Visual COBOL Product Licensing dialog box.

   3. Click Activate License.
To request and activate a 30-day trial license for Visual COBOL

1. In the IDE, click Help > Micro Focus Product Help > Product Licensing.

   This opens the Micro Focus Visual COBOL Product Licensing dialog box.

2. Type your email address in the Email address text entry field.

   You need to use the same email address you used for the registration.

3. Select one of the following options:

   **Automatic** Use this if you have Internet access.

   1. Click Activate License to activate the trial license for Visual COBOL.

   **Important:** After clicking Finish, if you click the Cancel button in the progress dialog box to stop the activation process, the trial license might have registered on Micro Focus servers but not yet be registered on your machine. If you request a trial again then you can get a message saying that a trial license has already been used. If this happens, you should contact a Micro Focus Sales representative to obtain a new license.

   You can do this by sending an email to VCBuyNow@microfocus.com, or selecting Help > Micro Focus > Buy Now and using the contact options in the dialog box.

   **Manual** Use this if you are not connected to the Internet.

   1. Click Send email.

      This opens your default email client and creates a new email filled in with the details to send to Micro Focus about activating the trial license for Visual COBOL.

      **Note:** If there is no mail client installed on your machine, click next to Send email, and click Display fields. You will be presented with a template that includes the email address, the subject and the contents of an email to send to Micro Focus using a mail client of your choice. Do not modify the details.

   2. Send the email.

      You will receive a response email with details about your authorization request.

   3. Paste the contents of the response email in the designated field in the Micro Focus Enterprise Developer Product Licensing dialog box.

   4. Click Activate License.

      This displays a message confirming your request for authorization has been successful.

   5. Click Close.

After activation, you can see how many days your trial license has remaining by selecting Help > Micro Focus > Product Licensing, or by using Micro Focus License Administration.
To buy and activate a full unlimited license

To buy a license for Visual COBOL, contact your sales representative or Micro Focus SupportLine.
For instructions on using the Micro Focus Licensing Administration Tool, see Licensing in the Visual COBOL help.

To start Micro Focus License Administration

From the Windows Taskbar click Start > All Programs > Micro Focus License Manager > License Administration.

Note: On Windows 8 and Windows Server 2012, you use the Start screen to invoke programs.

Installing licenses

If you have a license file

1. Start Micro Focus License Administration.
2. Click the Install tab.
3. Do one of the following:
   • Click Browse next to the License file field and select the license file (which has an extension of .mflic).
   • Drag and drop the license file from Windows Explorer to the License file field.
   • Open the license file in a text editor, such as Notepad, then copy and paste the contents of the file into the box below the License file field.
4. Click Install Licenses.

Alternatively, you can install the license file from within the IDE as follows:

1. Start Visual COBOL.
2. Click Help > Micro Focus Product Help > Product Licensing to open the Product Licensing dialog box.
3. Ensure I have a full Visual COBOL license is checked.
4. Click Browse next to the License file field.
5. Select the license file (which has an extension of .mflic), and then click Open.
6. Click Authorize to install the license.
   You should see a dialog box with a confirmation that the licenses have been installed successfully.

If you have an authorization code
Authorizing your product when you have an Internet connection

*Note:* This topic only applies if you have an authorization code.

The following procedure describes how to authorize your product using a local or network license server. The license server is set up automatically when you first install the product.

1. Start Micro Focus License Administration.
2. Click the **Install** tab.
3. Type the authorization code in the **Enter authorization code** field.
4. Click **Authorize**.

If you change the name of the machine running your license server after it has granted licenses, the licenses stop working.

Authorizing your product when you don't have an Internet connection

*Note:* This topic only applies if you have an authorization code.

This method of authorization is required if your machine does not have an Internet connection or if normal (automatic) authorization fails.

1. Start Micro Focus License Administration.
3. Make a note of the contents of the **Machine ID** field. You will need this later.
4. Do one of the following:
   - If your machine has an Internet connection, click the SupportLine Web link in the Manual Authorization Information window.
   - If your machine does not have an Internet connection, make a note of the Web address and type it into a Web browser on a machine that has an Internet connection.

   The Micro Focus SupportLine Manual product authorization Web page is displayed.
5. Type the authorization code in the **Authorization Code** field. The authorization code is a 16-character alphanumeric string supplied when you purchased your product.
6. Type the Machine ID in the **Machine ID** field.
7. Type your email address in the **Email Address** field.
8. Click **Generate**.
9. Copy the generated license string (or copy it from the email) and paste it into the box under the **License file** field on the Install page.
10. Click **Install Licenses**.

To obtain more licenses

If you are unsure of what your license entitlement is or if you wish to purchase additional licenses for Visual COBOL, contact your sales representative or Micro Focus SupportLine.
New Features in Visual COBOL 2.3

Enhancements are available in the following areas:

Integration with Visual Studio 2015

This release provides a new Visual COBOL flavor that takes advantage of the new features of Visual Studio 2015, including:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Light Bulbs</strong></td>
<td>You can use the light bulb feature (💡) to quickly implement interfaces or add the USING directive.</td>
</tr>
<tr>
<td><strong>Compatibility (Project Round-Tripping)</strong></td>
<td>Visual COBOL supports the Visual Studio project round-tripping feature which enables you to work with COBOL projects in Visual Studio 2012, Visual Studio 2013 or in Visual Studio 2015 without the need to upgrade the project file.</td>
</tr>
<tr>
<td><strong>.NET Framework 4.6 Compatibility</strong></td>
<td>Provides support for creating managed COBOL applications that target version 4.6 of the .NET Framework.</td>
</tr>
<tr>
<td><strong>Microsoft Help Viewer 2.2</strong></td>
<td>Provides support for the Micro Focus Help in Microsoft Help Viewer 2.2.</td>
</tr>
</tbody>
</table>

General Enhancements and Updates

- Menu items - the following Micro Focus utilities were previously available under the Tools > Micro Focus menu and have been moved as follows:
  - ADO.NET Connection Editor - now accessed from View > Micro Focus SQL Tools.
  - OpenESQL Assistant - now accessed from View > Micro Focus SQL Tools.
  - OpenESQL Configuration Utility - now accessed from View > Micro Focus SQL Tools.
  - Web Service Client - now accessed by creating a new project of type "Web Service Client Application from JSON/REST" - click File > New > Project > COBOL > Native > Web Service Client Application from JSON/REST.
- Managed COBOL project properties - a new setting, Expose group linkage items to managed code, is now available on the COBOL tab in the properties of managed COBOL projects. Checking this sets the ILSMARTLINKAGE directive that specifies that group linkage items in your code are to be exposed as properties of a class. A related button, Options, enables you to also specify whether to remove specific prefixes from the names of COBOL data items, whether to make the new classes serializable, expose Linkage Section items as nested classes of the program class or to limit the property generation to non-redefining elementary items.
- Resetting the file properties - a new button, Use Project Defaults, on the file property pages of COBOL files in native projects now enables you to reset the file properties of COBOL files in native COBOL projects.

Building applications

Visual COBOL now supports Visual Studio's parallel builds for COBOL projects. Parallel building enables you to build multiple projects faster on multi-CPU machines. Following this change, in order for your multi-project solutions to build in parallel successfully, ensure that the project dependencies and build order are...
set correctly for your solution using **Project > Project Dependencies**. For more information about parallel building, see **Tips on Building COBOL** in your product help and your product Release Notes.

**Note:** Parallel builds are not supported with Personal Edition licensing.

## COBOL Editor

The COBOL editor includes the following enhancements and new features:

- Improved Intellisense writing assistance for COBOL in both native and managed COBOL:
  - Context sensitive suggestions - IntelliSense only shows suggestions that are relevant for the position of the cursor in the code or for the type of project.
  - Enhanced completion lists - lists include any relevant COBOL verbs, clauses and words, copybooks, code templates, data items and section and paragraph names.
  - Intelligent assistance with completing statements - when you have entered a COBOL verb, IntelliSense shows suggestions for the relevant clauses and identifiers that you can use to complete the statement.
  - Automatic completion for single items - IntelliSense automatically inserts single suggestions in the code.
  - Qualifying non-unique names - IntelliSense qualifies data items whose names are not unique.
  - Configuration preferences for IntelliSense - enable you to configure what suggestions appear in the completion lists, whether suggestions are added in insert or overwrite mode, and the case of the inserted words.
  - Snippets - code snippets are now included in the IntelliSense suggestions.
- **$IF-$ELSE-$END** statement colorization - parts of a $IF Compiler-control statement that are not executed are now colored in grey.
- **$REGION** statement - support is provided for the $REGION Compiler-control statement. You can use $REGION - $END-REGION to surround blocks of code that you want to folded or expand in the editor.
- Copybook glyphs (균) in the left-hand margin on a copy line - indicate that a copybook can be expanded inline.
- Creating copybooks from selection of code - a new context menu command, **Extract to Copybook** in the editor enables you to move a selection of COBOL code into a new copybook file. The file is added to the project and the code in the original program is replaced with a COPY statement that refers the new copybook.
- Expanded copybook view - provides indicators for read-only copybooks
- Outlining - outlining is now available on comment blocks, paragraphs and on $REGION and $IF statements.
- Task List comments - the COBOL editor now provides support for Visual Studio-style Task List comments in COBOL. Typing TODO, HACK or UNDONE in the code immediately after the declaration of the COBOL comment (*>, *>> or * in column 7) creates a task that appears in the **Task List** window.

## Code Analysis

Visual COBOL now offers more advanced code analysis features and enables you to run various analysis queries (rules and groups of rules called rule sets) against your code to ensure adherence to standards such as standards for coding or performance.

You can run analysis rules against programs in a project in the IDE at user request or you can run analysis rules at the end of a project's build.
Code Coverage

Visual COBOL now provides support for code coverage of native COBOL applications directly from within the IDE where code coverage uses the Test Coverage functionality. You can produce code coverage reports for applications running in the COBOL run-time and for applications that run in Enterprise Server. To produce reports, you need to enable code coverage in a project's properties, compile your application and then run your application with code coverage to produce the relevant reports. For applications that require an Enterprise Server instance, you start the enterprise server with code coverage.

Command Line Compilation and Linkage

When using the cbllink command to compile and link, there is a new -y option. Use this option to create an executable that includes support to be able to run on Windows XP and Windows Server 2003.

Compiler Directives

The following Compiler directives are new in this release:

- **EOF-1A** Treats a 0x1a character in the source file as the end of file.
- **NLS-CURRENCY-LENGTH** Specifies the number of bytes to allocate for the currency symbol in a PIC field.
- **NULL-ESCAPE** Treats a 0x00 character in the source file as an escape character for other non-printable characters in the source code.

The following Compiler directives contain new parameters in this release:

- **DBSPACE** The new parameter 'MIXED' extends the DBSPACE directive to be able to evaluate data items in programs that contain a mix of single-byte and double-byte strings.

Converting Additional Directives to Project’s Properties

The Update Project Properties utility allows you to convert additional directives in your project to project properties. This option is presented on opening a project. You can select to not show this dialog again by unchecking Check Additional Directives for project properties in Tools > Options > Micro Focus > General.

Data File Structure Command Line Utility

The Data File Structure Command Line (DFSTRCL) utility is a DOS-based command line utility that enables you to create record layout (.str) files from COBOL debug information (.idy) files. You can use the utility to process a single .idy file or batch process up to 100 .idy files.

Data File Tools (Technology Preview)

*Note:* This is a technology preview feature only. It is being made available to allow you to test and provide feedback on this new capability; however, this feature is not intended for production use and it
is not supported as such. Furthermore, Micro Focus does not guarantee that this feature will be delivered at a GA level and if it is, then the functionality provided might differ considerably from this technology preview.

The Data File Tools (Technology Preview) is a new standalone text editor in which you can create and edit data files. By nature of it being a 'technology preview' product, it does not currently include all the functionality that was available in the previous version of Data File Tools - now referred to as Classic Data File Tools. If you require any of the functionality not provided in this version, you can still use the classic version by accessing it in the usual way.

To run Data File Tools (Technology Preview), type `mfdatatools2` from Visual COBOL's command prompt or a terminal.

To use the new editor directly from the Visual Studio IDE, clear the `Use classic data file tools` check box, available from `Tools > Options > Micro Focus > Data File Tools`. When cleared, the Data File Tools (Technology Preview) version is used, when possible. When this editor does not support the action you are attempting to complete, Classic Data File Tools is used instead. This check box is selected by default.

Database Access

The following new features have been added as part of database access support:

**COBSQL**

This release provides:

- Selection and configuration of the Oracle Pro*COBOL preprocessor for compiling COBSQL applications in a project's properties on the SQL tab.
- Support for COBOL directives `SOURCEFORMAT(TERMINAL)` and `SOURCEFORMAT(VARIABLE)` for Pro*COBOL applications.

**DB2 ECM**

This release provides:

- Support for the MFHCO environment variable across all platforms by default. See the `HCO DB2` compiler directive option topic for details.
- A new DB2 compiler directive option, `OPTPER (NOOPTPER)`, that enhances performance for CHARSET EBCDIC processing. See the `OPTPER DB2` compiler directive option topic for details.
- A new DB2 directive option, `BINDDIR`, which specifies an alternative directory in which to write the DBRM file created during compilation. See the `BINDDIR DB2` compiler directive option topic for details.

**OpenESQL**

This version of Visual COBOL supports the following new OpenESQL features:

**ADO.NET Connection Editor**

- The ADO.NET Connection Editor has been redesigned using a series of Wizards that guide you through the processes of adding, copying, and removing connections.
- Context help is now provided for the main window, and each Wizard page and dialog box.

**Date/Time Processing**

This release provides streamlined datetime processing for ODBC and ADO.NET.

**Performance**

This release includes a new SQL compiler directive option, `OPTPER (NOOPTPER)`, that enhances performance for CHARSET EBCDIC processing. See the `OPTPER SQL` compiler directive option topic for details.
PostgreSQL

In this release, PostgreSQL 9.4 has been tested with OpenESQL and OpenESQL Assistant using the following PostgreSQL software:

Server software PostgreSQL EnterpriseDB version 9.4.4
Client software
- psqlODBC driver version 09.03.04.00
- Npgsql ADO.NET 4.0 driver version 2.2.5

In this release, PostgreSQL 9.4 has been tested with OpenESQL and OpenESQL Assistant on the following platforms:
- Windows 32-bit
- Windows 64-bit

Note: Micro Focus provides compatibility for PostgreSQL but does not directly contribute to or support the PostgreSQL open source project. Any issues relating to PostgreSQL functionality should be addressed through an open source support vendor.

SQL Server

This release provides support for the SQL Server OUTPUT clause.

XA Switch Modules

Restriction: This feature applies only when the Enterprise Server feature is enabled.

In this release, the XA interface has been redesigned to provide:
- Consistent look and feel for SQL Server, DB2, and Oracle user personalization
- Consistent look and feel for both RM dynamic and static registration (SQL Server, DB2, Oracle, generic one-phase commit)
- Additional support for two instances of the same switch module using Web Services applications via the new XAID compiler directive

File Handling

This release contains the following new configuration options:

ACUFH Enables or disables the use of the ACU file handler (ACUFH), which is required to handle Vision and RM/COBOL indexed files.
ESACUFH Enables or disables the use of the ACU file handler (ACUFH) for file handling operations running under Enterprise Server. ACUFH must also be enabled for this option to take effect.

Library Routines

The following library routines are new in this release:

CBL_MANAGED_SESSION_GET_USERDATA Retrieves user data saved in the current RunUnit.
CBL_MANAGED_SESSION_SET_USERDATA Sets user data in the current RunUnit.

The following library routines contain new parameters in this release:

CBL_LOCATE_FILE You can now specify a file name that is a null-terminating string, which has resulted in three new values available for the user-mode parameter.
Managed COBOL Syntax

The following enhancements have been made to the managed COBOL syntax:

- The `TYPE OF type-name[ANY...]` syntax enables you to obtain the `System.Type` (.NET) or `java.lang.Class` (JVM) object for a generic class, interface, or delegate.
- The `self::` or `super::` syntax is no longer required to access inherited data within a subclass.
- The `ATTRIBUTE-ID` syntax enables you to define new attribute types, which can be used in various contexts.

Micro Focus Unit Testing Framework

**Note:** This is a technology preview feature only. It is being made available to allow you to test and provide feedback on this new capability, but it is not intended for production use and is not supported as such. Furthermore, Micro Focus does not guarantee that this feature will be delivered at a GA level and if it is, then the functionality provided might differ considerably from this technology preview. During the preview, you are encouraged to share your feedback and experiences via the Micro Focus community forum - [http://community.microfocus.com/microfocus](http://community.microfocus.com/microfocus).

The Micro Focus Unit Testing Framework is an xUnit style testing framework, available from the command line, for procedural COBOL applications.

It includes much of the architecture you would expect in an xUnit framework. The test runner is a 32- or 64-bit executable that you run from aVisual COBOL command prompt. A test fixture or suite is a COBOL program compiled to `.dll` that can include the setup, the test case code, and the teardown associated with the test case.

Test results are available in a number of formats. By default, results are displayed to screen and to a `.txt` file, but you can use additional parameters on the command line to produce reports in JUnit format.

Microsoft Azure Support

Visual COBOL support for Microsoft Azure has been updated to version 2.6 of the Microsoft Azure SDK. Support has been added to the product for making any future versions of the Microsoft Azure SDK available before the next major release of Visual COBOL. Micro Focus will deliver support for these only upon customers’ requests.

Personal Edition Licensing

This release includes a Personal Edition licensing option for Visual COBOL for Visual Studio 2015.

Preprocessors

Support has been added in the IDE for enabling and using multiple preprocessors with your projects.

A new page, **Preprocessors**, has been added to the project's and the files' properties of native COBOL applications to enable you to choose one or more preprocessors to use when building your application and to specify their order of execution.
New reporting capability is now available for user preprocessors: resp-main code 18 indicates that a buffer contains a data name to be marked as modified by the immediately preceding preprocessed line. The data name may be qualified and resp-more contains the column information for the reference.

Profiler

Visual COBOL now provides support for Profiler for native COBOL applications directly from within the IDE. To produce reports, you need to:

1. Enable Profiler in the COBOL property page for a project.
2. Compile your application to apply the changes.
3. Run your application with Profiler to produce the relevant reports.

REST service interfaces

RESTful service interfaces utilizing JSON as the media type in request and response messages are now supported using the Interface Mapping Toolkit. This enables you to extend COBOL applications using modern transport payloads and protocols.

RM/COBOL Compatibility

This release includes improved support for RM dialect applications. Please consult with Micro Focus before considering a transition from RM/COBOL to Visual COBOL.

Single File Support

The recommended way to work with files within Visual COBOL is to include them in a project. For situations where you might want to quickly open edit a single file, Visual COBOL now provides support for native COBOL files in the IDE when the file is not opened as part of a project. There is limited support for the IDE editing, compiling and debugging features as full support requires a project file.

To enable full IDE support for single files, Visual COBOL provides a path for creating projects from them - right-click such files in the editor, and click Create COBOL Project.

Tunables

This release of Visual COBOL contains the following updates to tunables:

- **default-cancel_mode**: A new parameter, and default, has been introduced for this tunable; see `default-cancel_mode` for more information.
- **subsystem-cancel_mode**: A new parameter has been introduced for this tunable; see `subsystem-cancel_mode` for more information.

Updated Run-time System

COBOL Server has been updated to provide an execution environment capable of running applications that were each built using different development products. A consequence of this is that if your application has a main COBOL executable (.exe) that was built with a previous version of Visual COBOL, you should
ensure that the executable is rebuilt and packaged with the new run-time system. You can rebuild from the IDE or the command line.

Other COBOL subprograms built with previous versions of Visual COBOL are not required to be rebuilt.
Known Issues

Refer to the Known Errors and Restrictions topic in the Product Information section of your product Help. In addition, note the following:

Enterprise Server

- The Historical Statistics Facility may generate incorrect records for SSTM-enabled enterprise servers.
- On Windows 10, if you are using Microsoft's EDGE browser to access the Enterprise Server Administration GUI, issues with EDGE can cause the automatic refresh feature to display a dialog asking whether you want to resubmit a form. To work around this issue, cancel the resubmit request and then refresh the server list page or the Home page of Enterprise Server Administration. You can also turn off the automatic refresh by setting the Auto-refresh interval setting on the Home page of Enterprise Server Administration to 0.

Expanded Copybook View (in Visual Studio 2012)

- When you add a COPY statement in a COBOL program and then show it in Expanded Copybook View, the line for the copybook statement is read-only. If you then perform an Undo in the COBOL program, the COPY statement is removed while the contents of the copybook is still shown in the program.
- Replace All does not work inside the Expanded Copybook View
- For copybooks with file extensions that are not traditionally associated with COBOL you must first add the file extension to the list of known copybooks extensions in Tools > Options > Text Editor > File Extensions before you can show them in Expanded Copybook View.

ICETOOL Emulation

ICETOOL emulation for managed code is not available in this release.

Installation

- Visual COBOL for Visual Studio 2015 does not support Visual Studio 2015 Shell as the Shell has a number of restrictions to COBOL development. The Visual Studio 2015 Shell is not included in the setup for Visual COBOL for Visual Studio 2015 and before you start the installation, ensure that there is an advanced edition of Visual Studio 2015 installed on your machine.

Linking

Changes in the C compiler in Visual Studio 2015 affect the way you link COBOL object code and C object code built with that version of Visual Studio in the same executable. In this scenario, you must use the Microsoft link utility and the C runtime libraries directly from Visual Studio, rather than the Micro Focus cbllink utility, the Microsoft link utility and the libraries supplied with Visual COBOL. You might also need to specify some additional C runtime libraries - see the Microsoft documentation for more details.

Note that when using COBOL and C object code together, Micro Focus recommends you build and keep the COBOL and C executables separate, and use import libraries and the Micro Focus C functions for calling COBOL (see "C functions for calling COBOL" in the product help) to resolve calls between them.
Remote debugging
Remote debugging does not work for programs running on AIX or HP machines, if you are trying to debug using Visual COBOL installed on a Linux machine.

Resource Adapters
Trying to deploy the local resource adaptor mfcobol-localtx.rar to WebLogic may fail with a ClassCastException. To work around this issue, you need to deploy mfcobol-xa.rar first, then need to undeploy this file and deploy the local one, mfcobol-localtx.rar. If there are issues deploying using the WebLogic GUI, you can use the command line. If there are issues with this as well, try reducing the length of the command (for example, by moving the file to a location with a shorter path).

REST/JSON IMTK implementation and the same-origin policy (SOP)
HTTP requests sent from scripts within a web browser to REST services deployed on an enterprise server might fail due to the same-origin policy (SOP). Some browsers might implement (or support plugins that implement) techniques for relaxing SOP such as cross-origin resource sharing (CORS) that enable sending cross-origin requests successfully. For REST services, Enterprise Server does not implement a method for relaxing SOP. This means that browsers that implement CORS (or any other SOP relaxation technique) might still forbid requests made from scripts due to Enterprise Server not implementing the equivalent technique on the server side.
Significant Changes in Behavior or Usage

This section describes significant changes in behavior or usage. These changes could potentially affect the behavior of existing applications or impact the way the tools are used.

Where present, the numbers that follow each issue are the Support Incident Numbers followed by the Reported Problem Incident (RPI) number (in parentheses).

- **Building**
- **Converting Additional Directives to Projects’ Properties**
- **CAS Security**
- **CAS XA Switch modules**
- **Compiler**
- **Data Tools Converter**
- **File Handling - External File Handler**
- **J2EE Connector**
- **MF Server Administrator (GUI)**
- **Visual Studio IDE**
- **Updated Run-Time System**

**Building**

*Back to the list*


  If, after upgrading to this version of Visual COBOL, you start receiving unexpected build errors when compiling an existing multi-project solution, this may be a result of enabling support for parallel project builds. These are a couple of examples of issues that might be causing these errors:

  - Using file references to project outputs in the same solution. You need to use project-to-project references instead.

    Use **Project > Project Dependencies** to manage the project dependencies and build order within your solution.

  - A customized build process such as one that is using pre- or post-build events.

    If resolving any of these issues does not help resolve the build errors, consider disabling the parallel build support - click **Tools > Options > Projects and Solutions > Build and Run** and set maximum number of parallel project builds to 1.

*Note: Parallel builds are not supported with Personal Edition licensing.*

**Converting Additional Directives to projects’ properties**

*Back to the list*

Starting with this release, an **Update Project Properties** dialog box might start to appear when you are opening existing COBOL solutions. The dialog box recommends converting some of the directives specified in **Additional directives** to project’s properties. This is to address an issue where you might try to set file properties that differ from the project directives and the directives specified in **Additional directives** that have a property equivalent take precedence over the file properties. As a result of this you might receive unexpected build issues when building your applications.
This dialog box helps eliminate the issue by converting the directives specified in Additional directives to project properties.

If you do not want the IDE to perform this check, click Tools > Options > Micro Focus > General and uncheck Check Additional Directives for project properties.

CAS Security

Back to the list

- The Enterprise Server External Security Facility now includes MLDAP ESM Module 2.0, with a new algorithm for identifying the best-matching resource-access rule and ACE for resource-access security checks. This algorithm is faster and matches most customers' expectations. The new algorithm also provides an optional "username substitution" feature. It can be enabled by setting "rule substitutions" to "yes" in the [Operation] section in the Security Manager configuration text area. When this is enabled, the string "$(user)" in a resource-rule name will be replaced with the name of the user that makes the request. For example, a DATASET rule named "USERS.$(user).*" would apply to datasets with the requesting user's name as the second qualifier. In rare cases, customers with complex, ambiguous resource-access security rules might see experience changes in behavior as a result of the new algorithm. The old algorithm is still supported and can be enabled by setting "version 1 authentication" to "yes" in the [Operation] section of the Security Manager configuration.

CAS XA Switch modules

Back to the list

- The XA switch modules now support dynamic registration.

Compiler

Back to the list

- For native COBOL, the size limit of the Data Division now stands at 2GB -1.

38 | Significant Changes in Behavior or Usage
Data Tools Converter

Back to the list

• DFCONV now returns the correct return-code; previously, it would always return 0.

File Handling - External File Handler

Back to the list

• Custom file handlers (using DYNREDIR) are now called for each part of a concatenated file.
  2795077 (1096322)

J2EE Connector

Back to the list

• This release provides a new command-line argument to Java, mf.ssl.algorithm, which can be set to an appropriate algorithm.
  2799213 (1096684)

MF Server Administrator (GUI)

Back to the list

• Passwords that entered through either the MFDS or the ESMAC interface now use the same encoding.
  2792382 (1096011)

Visual Studio IDE

Back to the list

• Changes in the C compiler in Visual Studio 2015 affect the way you link COBOL object code and C object code built with that version of Visual Studio in the same executable. In this scenario, you must use the Microsoft link utility and the C runtime libraries directly from Visual Studio, rather than the Micro Focus cbllink utility, the Microsoft link utility and the libraries supplied with Visual COBOL. You might also need to specify some additional C runtime libraries - see the Microsoft documentation for more details.

  Note that when using COBOL and C object code together, Micro Focus recommends you build and maintain the COBOL and C executables as separate projects, and use import libraries and the Micro Focus C functions for calling COBOL (see “C functions for calling COBOL” in the product help) to resolve calls between them.

• The default warning level for new COBOL project is now "Include recoverable errors (Level E)". This also includes "Severe errors only (Level S)" and unrecoverable (Level U) errors. Micro Focus recommends you set the warning level on the COBOL page in a project's properties to "Include warnings (Level W)" where appropriate to help avoid potential coding problems.

Updated Run-Time System

Back to the list

• COBOL Server now provides an execution environment capable of running applications that were each built using different development products. A consequence of this is that if your application has a main COBOL executable (.exe) that was built with a version of Visual COBOL prior to version 2.3, you should ensure that the executable is rebuilt and packaged with the new run-time system. You can rebuild from the IDE or the command line.

  Other COBOL subprograms built with previous versions of Visual COBOL are not required to be rebuilt.
Resolved Issues

The numbers that follow each issue are the Support Incident Numbers followed by the Reported Problem Incident (RPI) number (in parentheses).

- .NET ESQL Support
- .NET Run-Time System
- Adis
- CAS (COBOL App Server) General
- CAS Admin Console
- CAS Security
- CAS XA Switch Modules
- CASRDO
- Compiler
- Data Tools Editor (Classic)
- Data Tools Layouts
- Debugger
- Designer
- Documentation
- ecijava
- ES Cluster
- File Handling - External File Handler
- File Handling - Fileshare
- Intellisense
- Interface Mapping Toolkit General
- Interface Mapping Toolkit Mapper in Visual Studio
- LE370 Support
- Library
- Managed Code Compiler
- MF Common Client
- MF Communications Server
- MF Directory Server
- MF Server Administrator (GUI)
- MLDAP API Interface
- NCG
- RM COBOL
- Run-Time System
- SQL - COBSQL
- SQL - DB2 ECM
- SQL - OpenESQL
- Visual Studio IDE
- Visual Studio - Native Debugging
- XML Extensions
- XML syntax support preprocessor
- XML syntax support runtime

.NET ESQL Support

Back to the list
• When compiling for ODBC, the OpenESQL preprocessor failed to generate correct SQL code for some large SQL statements.
  2832617 (1100892)
• When compiling a WCF Service application with the SQL(DBMAN=ADO) directive, the OpenESQL preprocessor attempted to generate SQL interface code, resulting in a COBCH002 error.
  2827979 (1100367)
• The GetHire stored procedure sample showed that a COBOL CLR stored procedure could cause an exception to be thrown when using stored procedure definition files, and when compiled without SQL(DIALECT=MAINFRAME).
  2827854 (1100318)
• Run-time exceptions sometimes resulted from dynamic COBOL calls in stored procedures.
  2819325 (1099263)
• The OpenESQL runtime sometimes generated an index out of range error on SQL statements in managed applications when the PID generated by the OpenESQL preprocessor for each method was not unique.
  2815075 (1098749)
• A problem where a stored procedure that uses DIALECT=MAINFRAME could throw an exception if the HCOSS stored procedure remapping table had not been deployed to the database has been fixed.
  2809927 (1097972)
• The OpenESQL preprocessor did not support SELECT statements coded with a colon (:) on host variables after the INTO clause for ORACLE PROCOB migration applications.
  2596427 (1086198)
• The OpenESQL preprocessor has been enhanced to allow the use of PIC S9(5) COMP-5 host variables for INTEGER data on programs migrated from Pro*COBOL.
  2596426 (1086197)
• When using SQL(DATE=EXTERNAL) with Oracle, timestamp values were formatted incorrectly. This has been change to correctly format timestamp values according to the setting of NLS_TIMESTAMP_FORMAT.
  2596425 (1086196)
• When SQL(PROCOB) is set, Oracle date and timestamp result types fetched into PIC X(n) host variables are truncated without warning.
  2596424 (1086195)
• An SQLCODE incompatibility existed between Pro*COBOL and OpenESQL ADO.NET. This has been corrected. Setting SQL(PROCOB) now also sets SQL(CHECKSINGLETON). When SQL(PROCOB) is set, OpenESQL error codes in the SQLCA are converted to Pro*COBOL-compatible error codes, which are controlled by a new file, mfpcoods.txt. This file is delivered in %ProgramData%\Micro Focus \SQLCODES by default.
  2595728 (1087599)
• The OpenESQL runtime for ADO.NET returned times using a 12-hour clock. It now returns times using a 24-hour clock.

.NET Run-Time System

Back to the list

• A run unit created with the RuntimeServices RunUnit class no longer causes an exception to occur if no COBOL code has been executed inside it before the RunUnit is terminated with a StopRun() method.
  2826239 (1100198)
• You now receive a correct error code when the product does not find a file located on a network drive.
  2822161 (1099619)
**Resolved Issues**

**Adis**

*Back to the list*

- Paste now works as expected when pasting into numeric items under MS(2) with ACCEPT statements.
  2800091 (1096820)
- When the MS Compiler directive is set, ACCEPT with EMPTY-CHECK now supports manually entering of a zero for numeric items and a space for alphanumeric items.
  2795831 (1096324)
- When using ACCEPT WITH UPDATE with the MS Compiler directive, the pre- and post- display behavior is now the same as that of the MS compiler.
  2795709 (1096311)

**CAS (COBOL App Server) General**

*Back to the list*

- When using an EXCI link and a PPT defined with commarea 32767, the modified commarea was not reflected back to the caller.
  2830739 (1100654)
- It is possible to configure a Visual Studio or an Eclipse project to perform emergency debugging of an application running in an enterprise server even when the server is operating in production mode (with dynamic debugging disabled). To prevent this, starting with this HotFix, you can use the environment variable ES_PRODUCTION in the server’s [ES-Environment]. When set to Y, this variable prevents the IDE from initiating a debug session.
  2825848 (1100160)
- When using a secure region and when the environment variable ES_ESM_DISABLE_DFLTUSER_ESMAC is set to Y, clicking on the Home button in the signon page now correctly opens the MFDS page.
  2824772 (1099949)
- When the casspool.dat file is shared across multiple servers (excluding cluster scenarios), ESMAC displays all jobs, including those that are not running in the current server. However, it is only possible to cancel jobs that are running in the current server. For other jobs the CANCEL button is disabled.
  2824230 (1099917)
- It is now possible to start a BATCH printer in ESMAC if its name consists of space characters only but an exit name is provided.
  2819122 (1099216)
- When using ESMAC, Enterprise Server now correctly loads the MFESMAC resource class, when necessary. Previously, it was loading the ESMAC class.
  2814789 (1098652)
- You can now use the environment variable ES_ESM_DISABLE_DFLTUSER_ESMAC in order to disable the ESMAC default user. When this variable is set, the "DEFAULT" button on the logon screen is disabled and a valid userid and password must always be entered.
  2813092 (1098438)
- DBCS fields are now processed correctly when the PS attribute is set in the DSECT rather than defined in the MAP in single field, groups and OCCURs.
  2811683 (1098233)
- Web service timeout values are no longer truncated to two digits.
  2792860 (1096024)
- An issue with dynamic debugging has been fixed where, previously, the ports that were freed were not being reallocated.
• An artificial restriction on the size of cookies passed when invoking ESMAC requests has been removed. Previously, this was causing Run-Time exceptions.

• The characteristics of an FCT that references a cataloged file are now refreshed on each file open.
• If a file was already present, the date for an open request was not sent to the file handler.
• Open and close operations are no longer recorded in the transaction logs and replicated by extension when they are associated with open input requests.
• A secondary node in a group no longer attempts to take over the role of a primary node. The entire group now initializes correctly and all roles are assigned as expected.
• Microsoft's Internet Explorer versions 10 and 11, by default, does not use the current form name. As a result, when invoking the javascript functions, the form name was not correct and the product behavior was wrong. This has now been fixed.

CAS Admin Console

Back to the list

• This release provides a number of enhancements to the CAS administration console:
  • Improvements have been made to the log-in mechanism for situations where you are using an External Security Manager to secure the MFDS and Enterprise Server, and you are logged on to MFDS and ESMAC using different user accounts – for example, "user1" and "user2", respectively. If you navigate from ESMAC to MFDS and you log off "user1" from the MFDS, this will now automatically log off "user2" from ESMAC as well.
  • When using an external security manager, if you sign off from ESMAC, the sign on screen no longer preserves and displays the userID of the last user that was logged on.
  • An issue with the "Home" link in the ESMAC sign on page when the environment variable ES_ESM_DISABLE_DFLTUSER_ESMAC is set has been resolved.

CAS Security

Back to the list

• A memory leak occurred in the External Security Facility's MLDAP ESM Module in some HotFix releases of COBOL Server 2.2 Update 2.

• When using the Enterprise Server External Security Facility with the audit feature, some audit events generated by ESF Admin requests (such as ADDGROUP or ALTGROUP commands specifying many group members) may include too much information to fit in a single audit event. These parameters are now split across multiple audit events of category 5, type 3. Each split parameter has a unique number (per process), and each piece of a split parameter has a sequence number. The original event will contain a string with the split parameter identifier.

• The new resource access authorization processing in Enterprise Server's MLDAP ESM Module (LDAP-based security), introduced in HotFix releases of COBOL Server 2.2 Update 2, now correctly handles cases where multiple access control entries have the same rank. For example, this may apply when all group mode is enabled and an Access Control List (ACL) contains Access Control Entries (ACE) for different groups the user belongs to.

• In COBOL Server 2.2 Update 2 HotFix 06 only, when Enterprise Server External Security is used with the "Version 2 Authentication" mode enabled, some ACEs might not be processed or applied. This has been fixed.
When using the Enterprise Server External Security Facility (ESF) with auditing enabled, and using the ESF Admin API (programmatically or with the Enterprise Server Administration web interface or the esfadmin command-line tool) to make certain changes to security data, very large audit events could be generated. In some circumstances these could cause the Audit Manager process to crash or hang the program making the request. This has been corrected by truncating parameter information for very large security administration requests.

When using Enterprise Server External Security Facility (ESF) with the optional Referential Integrity User Exit, integrity constraints are now ignored for Access Control List (ACL) actors containing wildcard characters. This enables ESF Admin actions that include resource access control ACLs containing wildcard actors.

The optional ESF Referential Integrity user exit module no longer fails with an LDAP “filter error” message when processing certain resource-rule commands, such as ALTRESOURCE, for resource rules with names that include an asterisk, ‘*’.

The “referential integrity” sample user exit module for Enterprise Server External Security no longer causes the MFDS process (Enterprise Server Administration) to terminate when external security with the exit is configured for MFDS, and MFDS is used to add a user or to perform some other security administration tasks.

A new MFDS command line startup option (-b) is now available. Specifying -b disables the establishment of anonymous MLDAP API sessions.

This release enables you to prevent an Enterprise Server Monitor and Control (ESMAC) user from displaying an enterprise server's environment variable settings using the “Env. Vars.” button or the direct URL. To enable this feature, you need to create a new element (ENV*) in the LDAP schema in the CN=MFESMAC group below CN=Enterprise Server Resources.

This release includes an updated copy of the supplied LDIF import files that contain this change. Once this element is installed in the security manager, you can control the visibility of the environment variables page by configuring the group/user access rights using the microfocus-MFDS-Resource-ACE attribute.

The number of security manager user group members displayed by the Enterprise Server Administration and the esfadmin tool is no longer limited to a maximum of 1024.

Trying to use the SNMP audit emitter with Enterprise Server no longer fails with a run-time system error 114.

The MLDAP ESM Module, part of the Enterprise Server External Security Facility, now supports "nested" user groups where one user group can contain another user group. Members of the contained group belong to both groups. This enables administrators to define very large user groups as well as hierarchies of user groups.

A new option, "LITERAL=YES" has been provided in the Enterprise Server External Security Facility's Administration API, and in the esfadmin command-line utility. When this is set, ‘*’ is not interpreted as a wildcard when using any of the administrator's LIST commands. This is particularly useful for listing resource access rules that include ‘*’ in their name. Search the product documentation for esfadmin for more information.
CAS XA Switch modules

Back to the list

• Oracle and OCI XA switch modules leaked memory when using user personalization.
  2830922 (1100676)

CASRDO

Back to the list

• When trying to access the Catalog page from casrdo45, the JESSPOOL class was checked instead of DATASET.
  2819633 (1099350)
• The ESMAC Spool view is now sorted correctly when using a filter criteria.
  2798643 (1096681)

Compiler

Back to the list

• A program compiled with the INIT-BY-TYPE directive that contains ‘PROGRAM-ID IS INITIAL’ syntax and declarations of index names or data items now produces correct intermediate code.
  2831469 (1100741)
• Programs compiled with DIALECT”RM” and containing ‘PROGRAM-ID .. AS’ syntax now execute as expected.
  2830956 (1100700)
• The CP preprocessor used in conjunction with the COBSQL preprocessor now correctly replaces any text affected by the COPY... REPLACING statement.
  2826558 (1100370)
• When using the WINDOW1 preprocessor, specification of the AUTOCLOSE option no longer prevents subsequent preprocessor options from being actioned.
  2822206 (1099687)
• The output from the SETTINGS compiler directive now also appears for programs specified via the ILSOURCE option.
  2822102 (1099604)
• The XML GENERATE statement now functions as expected in programs containing the DECIMAL POINT IS COMMA clause.
  2821786 (1099599)
• The XML GENERATE statement now executes correctly when the specified FROM operand is a group containing nested ODO tables (which is only possible with the ODOSLIDE directive).
  2821779 (1099600)
• The INITBYTYPE compiler directive no longer causes spurious flag messages with DIALECT(OSVS).
  2820920 (1099488)
• The LINE-COUNT Compiler directive now operates as expected.
  2817442 (1098979)
• The maximum size of data items in a program compiled with the DIALECT(ENTCOBOL) directive now correctly reflects the respective mainframe values in the latest version of Enterprise COBOL.
  2816030 (1098926)
• The Compiler now rejects the use of special register names as arguments for reserved word altering directives. You can only specify standard reserved words with these directives.
2813931 (1098542)
• Data names that start with a numeric digit and contain DBCS characters are now accepted by the Compiler, as expected.

2813223 (1098456)
• A MOVE operation of an alphanumeric literal to an unsigned numeric DISPLAY field under RM/COBOL emulation now executes as expected.

2812561 (1098446)
• Data names longer than 30 characters are now flagged when specifying the FLAG option with a mainframe argument and not just when using the equivalent full DIALECT.

2810924 (1098133)
• Compiling a program with the COBSQAL preprocessor, which contains a COPY REPLACING statement with trailing spaces in the replacement pseudo text, now works as expected.

2807470 (1097737)
• Compilation of a program containing a GO TO statement that references an undeclared procedure name, and has the RESTRICT-GOTO directive set no longer results in a run-time exception.

2807280 (1097616)
• A user function that specifies a PIC 1 item as a RETURNING field now receives an appropriate compile-time error.

2806037 (1097470)
• The addressability of a linkage data item is now checked correctly.

2805523 (1097453)
• Compilation with a mainframe dialect, of a program containing a CALL statement with a mixture of non-01 level group items and literals, now proceeds as expected with no internal error produced.

2803613 (1097190)
• A debugger query of a condition name with a negative literal VALUE now returns the expected result.

2801993 (1097607)
• The combination of a mainframe dialect and SOURCEFORMAT(FREE) no longer produces unexpected compiler errors referring to tokens being in the wrong area of source.

2800332 (1096911)
• The specification of an alphanumeric literal in the VALUE clause of a DBCS data item (i.e. the G\N prefix is missing) is now accepted as an MF extension. This still generates an error under mainframe dialects, but can be hidden/suppressed like any other flag message.

2798426 (1096574)
• Under DIALECT"MF", the Report Group description entry now permits the NEXT GROUP NEXT PAGE clause without a LINE clause.

2798367 (1097201)
• It is now possible to specify fixed-point numeric literals without a trailing separator space before the next token or operator. This provides a better mainframe emulation.

2797274 (1096469)
• A new CP option, ANYCOPYCASE, now provides more flexibility in matching the case of copybook names.

2797035 (1096494)
• Previously, numeric items that used a decimal point and the OR sign were truncated when using the MS display syntax under MS(2).

2795709 (1096308)
• DBSPACE(MIXED) directive has been implemented to allow comparison of mixed single and double-byte spaces to the SPACE figurative constant.
When importing a Visual COBOL source file, the generation of a CBLast (COBOL Abstract Symbol Table) file no longer hangs when instructed to process a COBOL.DIR file.

Mixing alphanumeric and national items in intrinsic functions which only allow one type now produces a syntax error.

A source line longer than the maximum supported by the compiler no longer receives an error about truncation if the line is simply a comment.

An error during compilation, when creating .int files when the COBDATA directive is set, has been fixed.

Data Tools Editor (Classic)

It is now possible to associate data files with specific .STR files. This information is stored in the .pro file for the respective data file.

Data Tools Layouts

Creating a record or a segment layout file no longer fails when the COBOL names contain double-byte characters.

Debugger

Pointer values no longer get incorrectly byte-swapped when their value is accepted.

Trying to view the values of data-items that contain UTF-8 data no longer corrupts the values.

Designer

When importing using the Designer, you now receive an "Source Code Import Wizard Detected Errors Page" if there are parsing errors. See your product help for more details. Previously, the import process proceeded even when there were parsing errors. If errors or warnings were reported but the FD and 01 extraction process ran to completion, the errors will be reported but the "Next" button is enabled to allow the partially extracted data items to be imported. The "Back" button is also enabled allowing the process to be repeated once the errors are fixed. If a severe parsing error occurred, the errors are reported and, since they must be fixed, the "Next" button is not enabled.

Documentation

The product help now includes the optional attributes for the ‘container’ objectclass definition used by Enterprise Server external security.
• The product help now includes information about how to retrieve the Run-Time System error code from a file status code returned as a decimal value. For example, if you receive 14657 as a value for the file status, this is a decimal value. This converts to 3941 HEX. The second byte of this value, 41, must be converted to Decimal before looking at the RTS error code - thus this HEX value then represents an extended file status code of 9/065 which means the error code is COBRT065, a locked file status.

• The MFJSTATS topic has been updated to clarify that this refers to a COBOL SORT operation.

• The Micro Focus Infocenter documentation for Visual COBOL for Visual Studio has been updated with the correct instructions to launch the Net Express Project Import wizard.

• The product documentation about the START statement and Relation Conditions now states that THEN may be used instead of THAN.

• The topic "Using the CP Preprocessor to Expand Copybooks" in the product documentation has been updated to include the following text: If the MODE=ANSI option is specified to the Oracle precompiler, Pro*COBOL, then you should additionally use CP's SY directive to ensure that the SQLCA gets populated correctly.

• The default setting for the ES_ESM_PLTPISEC variable is NONE.

• Additional information has been added to the description of the CASSI1400 error message.

• The AdminAPI resource class has been documented for ESF features.

• The Enterprise Server documentation for Retain Periods has been updated to include additional information specific to spool output.

• The LISTCAT topic in the documentation has been updated to reflect accurate column headings and descriptions for output format.

• Topic amended to refer to entry_point_mapper rather than entry_name_mapper.

• Details on MF_MVSJOB environment variable added.

• The documentation for Visual COBOL and Enterprise Developer 2.2 Update 2 for Visual Studio 2010 on the Micro Focus Infocenter now correctly lists Microsoft's Visual Studio Service Pack 1 as a prerequisite. The installation instructions also provide instructions about how to install the product if your machine is not connected to the Internet.

• The Micro Focus Communications Server now supports rotational log files. To enable this feature, you need to edit the mf-server.dat file, which resides in the product's bin directory (Windows), or the $COBDIR/etc directory (UNIX). The mf-server.dat file contains details of this feature under the [logging] paragraph, and full documentation is provided in the online help under "Server Instance Diagnostics: CS Console".
• NONCONNECTED has been added to the list of attributes of DECLARE.

ecijava

Back to the list

• Stateless Java ECI requests no longer cause memory leaks in MFCS as a result of abandoned sessions.
  2822108 (1099645)

ES Cluster

Back to the list

• When issuing an ENQ change request in a cluster environment, the request to change the lock type was being sent to the GLM but not processed locally. It is now also being processed locally.
  2826218 (1100148)

• During a cluster RECONNECT request, each cluster client sends a list of active locks and the GLM re-populates the Global ENQ. Since the introduction of the VSAM shared options, the lock may also contain a tca ptr which is used to store the client's casmgr information. This is required for lock with persistence server. A pointer set to low-value was sent as part of a GIVELOCK request, but on the GLM that value was not used. This causes a run-time system error 114 in casgreqt on the RECONNECT/ GIVELOCKS function. This fix allocates the required tca for client casmgr for a RECONNECT request, sets up the pointer depending on the lock persistence type as well as the clients casmgr PID.

File Handling - External File Handler

Back to the list

• You now receive an RC16 error message, if a PDSM file is missing from a list of concatenated DD's.
  2821187 (1099770)

• Indexed files are no longer corrupted when their file size limit is reached.
  2817599 (1099359)

• When lock mode is set to ‘automatic’, with single record locking, the lock from the previous operation is released at the start of the next file operation; this is to avoid an ABBA deadlock situation occurring.
  2816981 (1099052)

• A new file handler configuration file option (STRICTLSEQ) has been added. Only use this option if instructed to by Support.
  2814458 (1099019)

• RM and ACU files accessed from Visual COBOL no longer crash with a 114 error for I/O operations on a non-existent optional file opened for input. An appropriate error code is now returned.
  2809718 (1098141)

• MFSORT now takes the record length from a previous output file, if its record length is specified, rather than defaulting to the value in the SORTIN statement.
  2808188 (1098243)

• The rollback recovery process is now working as expected.
  2802180 (1097066)

• This release provides a new format of the dataset allocation override rules file that supports multiple conditions.
  2783138 (1095007)

• The ACUFH interface between the MF File Handler and the RM File Manager will no longer report an 05 status (optional file created) to more than one COBOL run unit for creation of the same file. The 05 status will be reported to the COBOL run unit that actually created the file. The RM File Manager that
runs under ACUFH and the Micro Focus File Handler for Visual COBOL now includes optimizations that enable it to use pread and pwrite system calls and to report status 99 (record locked) quicker. These optimizations match the optimizations added to the RM File Manager within RM/COBOL.

- The file handler configuration file (extfh.cfg) now supports the following options:
  - ACUFH=ON/OFF - enables or disables any calls to ACUFH. ON by default.
  - ESACUFH=ON/OFF - enables or disables calls to ACUFH while running under Enterprise Server. OFF by default.

Note: As a result of this change, calls to ACUFH are now disabled by default when running under Enterprise Server.

**File Handling - Fileshare**

*Back to the list*

- Copying an ESDS file no longer causes an RTS114 error.
  2811583 (1098244)
- When a file is closed under Enterprise Server, the file's details are correctly removed from Fileshare. Previously, some details were not removed.
  2810549 (1098111)
- When handling indexed files, the correct .IDX file is now being processed.
  2803247 (1097279)

**Intellisense**

*Back to the list*

- IntelliSense suggestions now correctly include MS Office Interop types.
  (612071)

**Interface Mapping Toolkit General**

*Back to the list*

- The Interface Mapping Toolkit was not properly recognizing 64-bit applications, and would not generate 64-bit DLL files.
  2792065 (1096292)

**Interface Mapping Toolkit Mapper in Visual Studio**

*Back to the list*

- Creating and editing service interfaces now works as expected if you have Visual COBOL (or Enterprise Developer) for different versions of Visual Studio installed on the same machine.
  2792066 (1095977)

**LE370 Support**

*Back to the list*

- The Language Environment utilities are now available as Java managed code.
  2826067 (1100134)
- Mainframe Language Environment support (LE Services) is now available in Micro Focus Visual COBOL and COBOL Server.
  2799388 (1097806)
• The Language Environment functions CEEGMT, CEEUTC and CEELOCT now return the number of seconds to millisecond precision.
  2796098 (1098276)
• The I-S-Info field of the Language Environment (LE) Feed-Back group has been changed from a pointer to a PIC S9(9) BINARY item.

Library

Back to the list
• Using a dd_ environment variable to specify the path used in CBL_LOCTE_FILE now works as expected.
  2822153 (1099632)

Managed Code Compiler

Back to the list
• Very large screen section records no longer produce unpredictable errors when generating managed COBOL code.
  2830002 (1100580)
• Programs that contain report-writer syntax, and are compiled with either PERFORMTYPE(RM) or PERFORMTYPE(OSVS), now behave as expected.
  2824931 (1099963)
• When forming externalised names for ILSMARTLINKAGE, any double-byte hyphen (or similar) characters are now removed from the name.
  2822491 (1099668)
• For class programs containing COBOL files declared in the OBJECT section, it is now possible to explicitly add the program to a run unit. Previously, this would cause a run-time exception.
  2819597 (1099963)
• The use of the SCREEN SECTION CONTROL phrase in .NET unverifiable code no longer causes the generation of illegal code.
  2818736 (1099170)
• An INITIALIZE statement applied to a file record, which is not otherwise referenced, now correctly initializes the whole record area.
  2817756 (1099017)
• Verification or run time errors are no longer produced when NUMPROC(ACOS) is specified, and a level 88 item is declared for a numeric item in the Linkage section of your program.
  2815137 (1098693)
• Opening a XAML file in a WCF client project no longer causes an unhandled exception to be generated.
  2813004 (1098525)
• You can now use an external member reference as a target operand for the INITIALIZE statement. In previous versions of the product, you could not.
  2812151 (1098318)
• In previous versions of the product, compilation errors resulted when the NOILNATIVE directive was specified when compiling programs that used the OCCURS ANY syntax for defining tables. This is no longer the case, and the NOILNATIVE directive has no effect on such tables.
  2809432 (1097893)
• The INITIALIZE statement is now working as expected when applied to a group item where an OCCURS subgroup follows a FILLER data item. Previously, this could produce bad code, initializing incorrect areas of the group.
2805149 (1097372)  
- For class programs containing COBOL files declared in the OBJECT section, it is now possible to explicitly add the program to a run unit. Previously, this would cause a run-time exception.

2802641 (1099053)  
- When compiling for managed code (.NET or JVM), a zero length literal used as a value for a PIC N data item no longer crashes compilation with run-time error 181.

2799176 (1096677)  
- If a method has an optional parameter with a default value of System.Reflection.Missing.Value, and that parameter was omitted in a method invocation expression, that parameter was being passed as null, instead of the correct default value. This affected a number of methods - for example, Microsoft.Office.Interop.Excel.

2796911 (1096408)  
- Comparisons between PIC N or PIC G items and ALL hex-literals are now working correctly.

2795393 (1096266)  
- Managed code that includes operands of the form 'typedef-name AT pointer' now generates correctly.

MF Common Client

Back to the list

- The Micro Focus Common Client, used by COBOL Web Service proxies and other components, now allows HTTP URLs with certain characters such as "":". It also no longer rejects correct URLs with "%xx" escape sequences.

2828629 (1100520)

MF Communications Server

Back to the list

- Certain Enterprise Server administration actions such as notifying a running enterprise server of a security update could cause MFCS to hang.

2784219 (1095045)

MF Directory Server

Back to the list

- The generated HTML fragment displayed for an individual resource entity element when using the Enterprise Server Administration HTML GUI to administer an external Security Manager was overflowing a fixed size buffer. This is now allocated based on the actual length required.

2828732 (1100545)

- Corrected the resource entity that the Enterprise Server Administration GUI checks to determine whether the external Security Manager administration pages are accessible to a logged on user. The correct resource entity is "User Administration" under the "Enterprise Server Administration" resource class.

2828553 (1100539)

- Require read permission before returning repository data for authenticated users if MFDS is started with the -b option.

2828228 (1100364)

- Access to password data is prevented on the security manager edit page in the Enterprise Server Administration HTML GUI.

2827942 (1100333)
• When MFDS is secured using an external Security Manager, it does not display internal security configuration pages which no longer have an effect.
  2827786 (1100314)
• Correct display of user session data in the Enterprise Server Administration HTML GUI.
  2826210 (1100161)
• An issue with the persistency of the audit output option in the MF Directory Server security configuration has been resolved.
  2824201 (1099902)
• Honor the trace flags values set in an Enterprise Server XML configuration file when importing it into MFDS via the -g command line option.
  2823855 (1099846)
• An issue with storing certificate passphrase in the Enterprise Server Administration HTML GUI form data has been resolved.
  2820846 (1099448)
• The resistance of the Enterprise Server Administration HTML GUI log-on page to cross-site scripting attacks has been increased.
  2819223 (1099212)
• Improve browser caching control to increase security of the Enterprise Server Administration HTML GUI.
  2819218 (1099209)
• An issue with storing certificate passphrase in the Enterprise Server Administration GUI has been resolved.
  2819212 (1099207)
• The Enterprise Server Administration web page makes additional authorization checks before displaying screens.
  2819069 (1099192)
• The Enterprise Server Administration web page no longer displays sensitive session data.
  2818974 (1099178)
• Password length restriction has been fixed in the Enterprise Server Administration login page.
  2818973 (1099179)
• Enterprise Server Historical Statistics Facility (HSF) configuration can now be exported and imported via the mfds -x and -g command-line options.
  2815030 (1098695)
• Previously, the Enterprise Server Administration journal export to text truncated the exported file.
  2802793 (1097108)
• It is now possible to expand and collapse items within the tree view of the external security manager security resources in Enterprise Server Administration.
  2801421 (1096979)
• The MFDS GUI now correctly displays external Security Manager resource ACL strings that are greater than 3K byte length.
  2800727 (1096978)
• The MFDS -x XML export option was not exporting Windows Monitoring and Management configuration values for enterprise server instances.
  2794382 (1096428)
MF Server Administrator (GUI)

Back to the list

• If access to Enterprise Server Administration is restricted by use of an MLDAP ESM-based external Security Manager, you can now configure a user to have access to the "Security" menu item but not to the "Options" menu item.
  2804728 (1097916)
• Previously, when expanding or collapsing items in the tree view for external Security Manager within Enterprise Server Administration, items associated with a user or a group no longer would always move to the top of the resource list.
  2803399 (1097848)
• If MFDS is configured to use an external Security Manager with the Windows "user" class, it is not possible to edit the users from the MFDS GUI and you receive a warning.

MLDAP API Interface

Back to the list

• The MLDAP ESM module now recognizes a wider range of errors that indicate that the specified LDAP server is unavailable and, if configured, the server will retry to establish a connection.
  2799921 (1098128)
• The MFDS GUI and the ESFADMIN utility now display the pages with LDAP query results.
  2681539 (1092705)

NCG

Back to the list

• A bug in accepting a field containing double-byte and single-byte characters has been fixed.
  2829369 (1100513)
• A bug during compilation has been fixed, which caused a Run-Time System error 114 when generating 32-bit programs using the OPT directive, containing decimal operations.
  2819838 (1099305)
• An error has been fixed in COMPUTE statements of the following form: COMPUTE a = b / constant where a and b are COMP-3 or DISPLAY; a has greater than 19 digits and b has less than or equal to 19 digits, and constant is a literal which is a power of 10 (such as 10, 100, 1000, etc.)
  2808008 (1097715)

RM COBOL

Back to the list

• The RM File Manager for Visual COBOL now provides a mechanism for avoiding RM indexed file corruption while debugging in managed code.

  In Visual COBOL for Eclipse, to avoid file corruption, you need to manually set the environment variable RMFM_PRETEND_FORCE_CLOSED to YES in the Debug Configuration.

  Visual COBOL for Visual Studio is preconfigured to avoid file corruption. If necessary, you can also specify the RMFM_PRETEND_FORCE_CLOSED variable in a project's Application Configuration File (App.config).

  See your product help for more details.
  2796890 (1096699)
Run-Time System

Back to the list

- The RM/COBOL version of the “SYSTEM” library routine now supports the return of an exit-code, for native COBOL applications.
  2830238 (1100599)
- On a 32-bit Enterprise Server running on Windows, tasks that are blocked in the operating system can now be canceled without terminating the SEP process.
  2807997 (1097918)
- An error in generated code when initializing comp-2 data items from fractional literal values has been fixed.
  2800938 (1096960)
- The tunables default_cancel_mode and subsystem_cancel_mode both have a new setting, which enables programs to remain in memory after they are canceled; this is opposed to the default behavior, which physically removes .dll files and shared objects from memory when they are canceled.
  2690881 (1096628)

SQL - COBSQL

Back to the list

- The COBSQL preprocessor generated an error when it encountered a host variable declared as "01 HV PICTURE S9(9) VALUE ZERO COMP."
  2826093 (1100163)
- COBSQL now honors the position of the $SET statements in copybooks that are expanded inline in the editor by the CP preprocessor.
  2825364 (1100308)
- COBSQL examined hostvars in commented lines, causing compilation errors.
  2824211 (1099928)
- CCOBSQL now processes COPY... REPLACING COBOL data items' level correctly.
  2813839 (1098531)
- The COBSQL preprocessor inserted a NULL character in front of each non-printable character, causing errors when processing Pro*COBOL (i.e., when COBSQTLTYPE=ORACLE8).
  2809551 (1097939)
- COBSQL did not always correctly handle COPY... REPLACING with text exceeding the 72 column.
  2809404 (1097890)
- COBSQL incorrectly handled COPY... REPLACING when the level numbers of data items in the copybook were being replaced.
  2807898 (1097765)
- COBSQL was not recognizing the DECLARATIVES statement in some scenarios.
  2804183 (1097346)
- COBSQL now processes COPY...REPLACING statements correctly.
  2779818 (1094538)

SQL - DB2 ECM

Back to the list

- The DB2 ECM incorrectly generated code to process SET CURRENT PACKAGE PATH, resulting in SQLCODE -4952 when executed.
2817342 (1098963)
• HCO incorrectly handled .bnd files. The new DB2(BINDDIR) directive resolves this issue.

2815734 (1098893)
• The DB2 ECM preprocessor incorrectly generated COBDB0103S errors when a fixed CHAR host variable was defined as greater than 254 characters.

2803193 (1097169)
• When FILLER was used in group host variable structure, the DB2 ECM raised an SQL4914 error.

2802547 (1097091)

SQL - OpenESQL

Back to the list

• For managed-code projects, PF_RO_CURSOR and other BEHAVIOR primitive directives were not available from the User Interface.

2833926 (1101049)
• Some problems related to using ASSOCIATE with the Host Compatibility Option for SQL Server where the stored procedure name was supplied in a host variable have been fixed.

2831480 (1100747)
• HCO with SQL Server (HC OSS) using the ADO.NET run-time system exhibited a problem retrieving result set locators on the second call and subsequent calls to a stored procedure.

2830688 (1100659)
• The SQL CLR wrapper program generated by the Generate SPD File tool caused errors during deployment when it contained one or more data types exceeding 8000 bytes in size. To eliminate these errors, the Generate SPD File tool now generates the SQL CLR wrapper program with MAX SIZE = -1.

2830545 (1100650)
• PIC X host variables passed to the server as variable-length data with trailing blank suppression sometimes caused OpenESQL to return different query results than some earlier versions of this COBOL development product.

2829810 (1100685)
• When generating a COBOL wrapper program, the Generate SPD File tool did not support the passing of all parameters for a SQL CLR Stored Procedure definition routine as fixed length. To resolve this, a new option, GENFIXEDLENGTH, has been added.

2829499 (1100629)
• A number of issues with PostgreSQL record logic and error handling have been fixed in OpenESQL's run-time systems for ODBC and ADO.NET.

2828058 (1100338)
• When the SQL(PROCOB) directive is set, OpenESQL for ADO.NET now supports anonymous PL/SQL blocks and the following host variable types: SQL-CURSOR SQL-ROWID SQL-BFILE SQL-BLOB SQL-CLOB SQL-NCLOB.

2825199 (1100003)
• When compiling with the SQL(PROCOB) directive, the OpenESQL preprocessor sometimes generated incorrect SQL code when a host variable reference in COBOL was split over multiple lines.

2825194 (1099997)
• When using the SQL(CHECK) directives with SQL TYPE CLOB host variables, compilation sometimes failed.

2819480 (1099342)
• Windows GUI projects compiled with the SQL compiler directive might throw a MicroFocus.COBOL.Program.COBOLStopRunException on GOBACK.
2816463 (1098907)
• The insertion of more that 8000 characters into a SQL Server VARCHAR(MAX) column from a PIC X(n) host variable caused a data truncation error.

2814679 (1098675)
• When SQL(TARGETDB=ORACLE) was set and the FOR UPDATE clause was used to enable row locking, this combination could sometimes trigger a runtime failure. SQL(TARGETDB=ORACLE) is no longer required to enable row locking via FOR UPDATE clauses on queries.

2814613 (1098624)
• A 114 error on DISCONNECT sometimes occurred due to a long-standing bug in Oracle ODBC drivers. This release provides a workaround. The ODBC specification states that the ODBC row status array is an array of 2-byte integers, but some Oracle ODBC drivers from Oracle 11 onwards have been observed to use either 4-byte or 8-byte integers. The OpenESQL runtime for ODBC now automatically detects the element size used by the driver when an Oracle connection is opened, and adapts its behavior accordingly.

2813428 (1098480)
• OpenESQL now supports OUTPUT clauses in SQL Server INSERT, UPDATE, and DELETE statements. HCO for SQL Server now supports the DATA-CHANGE-TABLE-REFERENCE clause.

2812940 (1098424)
• An SQLCA error message occurred when inserting a record into a table using a SQL CLR stored procedure with a VARCHAR (max) column where the host variable was more than 8000 bytes.

2812261 (1098390)
• The OpenESQL preprocessor incorrectly generated a COBES0100 error when compiling code that contained GEN-GV-FROM-GROUP and the same host variable used multiple times in same SQL statement.

2811682 (1098231)
• The OpenESQL preprocessor reported an error for LOCK TABLE statements encountered when using an Oracle database with the SQL(CHECK) compiler directive option.

2808579 (1097797)
• When using the SQL compiler directive option to compile a program that contained no SQL statements, a 153 trap occurred when the OpenESQL preprocessor encountered SQLCODE defined as COMP.

2808076 (1097758)
• The OpenESQL preprocessor sometimes generated a "COBCH0302 IF....ELSE or scope-delimiter mismatch" error if a program defined SQLCODE separately as COMP.

2807937 (1097702)
• The OpenESQL preprocessor sometimes generated a STOP RUN rather than a GOBACK at the program end, which sometime caused improper termination for subroutines not coded with one or more GOBACK statements.

2807272 (1097624)
• The OpenESQL preprocessor produced a COBES0125 or COBES0112 error message when it encountered indicator variable arrays used with non-host array variables.

2805207 (1097457)
• COBOL SQL CLR stored procedures can now open connections to other databases using EXEC SQL CONNECT statements. For type 6 CONNECT statements, this requires using a post-deployment script to alter the connection string for the OpenESQL runtime such that it runs with EXTERNAL_ACCESS privilege. For other CONNECT statement formats, INSAFE privilege is required. Use SQL Server authentication rather than Windows authentication for external connections.

2804010 (1097230)
• In some situations, the OpenESQL pre-compiler incorrectly generated a COBES0125 error, "<variable> should be defined with an OCCURS clause".

Resolved Issues | 57
2802029 (1097036)
• The ODBC ECM incorrectly generated swap logic for COMP fields on singleton SELECTs in managed applications which could result in field corruption if the variable was used in a WHERE clause.

2801806 (1097049)
• The OpenESQL Assistant generated copybooks using the same size for DATETIME2 columns regardless of their definitions. The OpenSQL Assistant now generates PIC X(26) for DATETIME2(6), and PIC X(29) for all other DATETIME2 definitions.

2799778 (1096776)
• A problem that affected the use of ‘select *’ in OpenESQL subqueries has been fixed.

2799720 (1096751)
• A problem with array fetches into PIC N NATIONAL host variables has been fixed in the ODBC run-time system for OpenESQL.

2799002 (1096790)
• The OCI run-time now handles the NULL indicator correctly when running in 64-bit mode.

2792566 (1096149)
• OpenSQL for JDBC now supports positioned updates with PostgreSQL.
• The THREAD SQL compiler directive option mishandled threads in certain scenarios.
• In certain scenarios, OpenSQL incorrectly handled host variables defined as SQL TYPE DBCLOB when inserting or fetching DBCS data.
• OpenSQL for JVM now supports spaces between the start of an ODBC, JDBC, date, time or timestamp escape marker and its associated date, time or timestamp literal string when the SQL(DETECTDATE) directive is set.
• Use of the tinyint (pic s99 comp-5) host variable sometimes resulted in bad code generation for some OpenSQL runtime systems. Tinyint is now fully supported on all OpenSQL runtime systems.
• The OpenSQL run-time now truncates DBCS character strings cleanly at a whole character boundary.
• Using CHARSET(EBCDIC) in a DBCS locale caused problems with the OpenSQL runtime systems for ADO and JDBC. This has been corrected by changing the behavior to be consistent with the ODBC runtime. In particular, SO/SI characters are now correctly inserted and removed for EBCDIC and ASCII data respectively.
• The one-phase ODBC switch module now handles commit and rollback API calls from applications and uses DSNRLI correctly, together with handling of global temporary tables by HCOSS applications.

Visual Studio IDE

Back to the list

• Adding a new “Web Form using Master Page” item to a Web project now works correctly in Visual Studio versions 2012 or later.

2815524 (1098743)
• When converting a Net Express project that does not contain any executable targets (exe, lib or dll), the Net Express Project Import wizard now creates a project that holds the application-level dependencies so they get copied into the main output directory.

2815290 (1098720)
• If, after using the Compile command from the file context menu in Solution Explorer to compile a COBOL file in your project, you use Compile to compile an IMS file, the IDE no longer recompiles the COBOL file.

2809825 (1098153)
• It is now possible to debug a 64-bit core dump from a 64-bit native Mainframe Subsystem Application project.

2804416 (1097366)
• When using a COBOL Web Site project that references a COBOL assembly, the editor may have incorrectly shown syntax errors even though a build would have succeeded.

2804043 (1097341)

• When adding a new WPF item that contained both XAML and COBOL partial classes to a project, the code editor used the wrong source format for the COBOL part of the code.

2800293 (1096909)

• In a Micro Focus INT/GNT project that is configured to package the output as an .lbr, the .lbr file will now include any files in the projects that have their Build Action property set to Content.

2799868 (1096821)

• Setting an SQL compiler directive on a project that contains a Windows Form prevented the IDE from opening the form in Design view.

2612622 (1094509)

• The Light Bulbs feature in Visual Studio 2015 replaces Smart Tags. Light Bulbs provide functionality similar to the one Smart Tags provided in previous versions of Visual Studio. The COBOL Smart Tags (in Visual Studio 2012 and 2013) and the Light Bulbs feature (in Visual Studio 2015) now provide limited support for managed COBOL language features including interfaces, attributes and generic types. Other improvements include support of these features within inline copybooks as well as various performance and stability improvements.

• Saving temporary COBOL projects in Visual Studio now works as expected.

• It is now possible to publish SQL Database projects that target a version of the .NET Framework later than version 4.0 and when your machine is configured to use the Japanese locale.

• Under certain circumstances, Show All Copybooks failed to expand inline copybooks.

• When debugging, if you attempt to query the value of an unassigned linkage item you are now prompted to allow memory to be allocated for that item.

• An issue with the colorization of some string literals has been resolved.

• The Namespace Smart Tag now supports managed COBOL language features including interfaces, attributes and generic types, can be used within inline copybooks, and has had a number of other performance and stability improvements.

• When debugging COBSQL programs in applications that compile to .int or .gnt files, the caret position is now set correctly.

• Adding a new "Web Form using Master Page" item to a Web project now works correctly in Visual Studio versions 2012 or later.

• Under some conditions when editing a COBOL source file, the editor ignored the source format set in the project's properties and treated the file as fixed format.

• An issue where new files added to a managed project were not included in the build has been fixed.

• The Namespace Smart Tag now supports managed COBOL language features including interfaces, attributes and generic types, can be used within copybooks shown inline in the editor, and has a number of performance and stability improvements.

• When editing .NET managed COBOL in the editor, if referencing a class member that matches a COBOL reserved word (for example, my-str::Length), the member is now correctly identified and has the correct color and IntelliSense functionality.

• While debugging, clicking on a line containing a COPY statement or stepping into a copybook which was part of a program which had not been previously opened could result in an unpredicted behavior.

• If you set the warning level in a project to include recoverable errors (Level E), this setting is now enforced when building the project and you no longer receive warnings and informational messages in the build output or in the Error List window.

• The 'Set explicitly no SQL' setting in the properties of COBOL files now works correctly for the Oracle Pro*COBOL and XDB preprocessors.

• The file extension filters included in the Save File As dialog for COBOL programs now work correctly.

Visual Studio - Native Debugging

Back to the list
• You can now enable debugging of CGI programs when invoking them multiple times. To do this, check "Return to waiting state when debugging" on the Debug tab of your project's properties.

2794496 (1096442)

**XML Extensions**

*Back to the list*

• The XML model file must be accessible to the XML extensions run-time environment. To make the file accessible, either add it to the system path, or move it to the directory from which the program is run.

2822399 (1099702)

**XML Syntax Support Preprocessor**

*Back to the list*

• XMLElement no longer reports an error if a prefix is not properly declared and no validation is specified.

2823420 (1099786)

**XML Syntax Support Run-Time**

*Back to the list*

• The Compiler no longer errors preprocessed lines containing non-ASCII characters in the indicator area. Previously, this could cause user programs using the htmlpp preprocessor to fail to compile.

2805067 (1097977)

• The XML I/O run-time used to read the whole document into memory which caused an out-of-memory error.

2801337 (1096999)

• The namespace prefix in the namespace declaration is now handled correctly when the element itself does not contain a prefix.

2799691 (1098150)
Updates and SupportLine

Our Web site gives up-to-date details of contact numbers and addresses.

Further Information and Product Support

Additional technical information or advice is available from several sources.

The product support pages contain a considerable amount of additional information, such as:
- The WebSync service, where you can download fixes and documentation updates.
- The Knowledge Base, a large collection of product tips and workarounds.
- Examples and Utilities, including demos and additional product documentation.

To connect, enter http://www.microfocus.com in your browser to go to the Micro Focus home page.

Note: Some information may be available only to customers who have maintenance agreements.

If you obtained this product directly from Micro Focus, contact us as described on the Micro Focus Web site, www.microfocus.com. If you obtained the product from another source, such as an authorized distributor, contact them for help first. If they are unable to help, contact us.

Information We Need

However you contact us, please try to include the information below, if you have it. The more information you can give, the better Micro Focus SupportLine can help you. But if you don't know all the answers, or you think some are irrelevant to your problem, please give whatever information you have.

- The name and version number of all products that you think might be causing a problem.
- Your computer make and model.
- Your operating system version number and details of any networking software you are using.
- The amount of memory in your computer.
- The relevant page reference or section in the documentation.
- Your serial number. To find out these numbers, look in the subject line and body of your Electronic Product Delivery Notice email that you received from Micro Focus.

On Windows, if you are reporting a protection violation you might be asked to provide a dump (.dmp) file. To produce a dump file you use the Unexpected Error dialog box that is displayed when a protection violation occurs. Unless requested by Micro Focus SupportLine, leave the dump setting as Normal (recommended), click Dump, then specify a location and name for the dump file. Once the dump file has been written you can email it to Micro Focus SupportLine.

Alternatively, you might be asked to provide a log file created by the Consolidated Tracing Facility (CTF) - a tracing infrastructure that enables you to quickly and easily produce diagnostic information detailing the operation of a number of Micro Focus software components.

On Windows, you can use the Micro Focus SupportLine Support Scan Utility, mfsupportinfoII, to create either:
- a .log file that contains the details about your environment, Micro Focus SupportLine products, and settings.
- a .zip archive that includes the same information as the .log file plus some product configuration files from c:\ProgramData and the product installation log files.
MFSupportInfoII.exe is stored in <install-dir>\bin.

To run mfsupportinfoII:

1. Start a 32-bit Enterprise Developer command prompt.
2. Enter MFSupportInfoII at the command prompt to start the utility.
3. Create a .log file or a .zip archive as follows:
   a. To create a .log file, click File > Save.
      This prompts to save the .log file, MFSupportInfo_Log_MachineName/YYYY-MM-DD_HH-MM-SS.log, in the %temp% directory.
   b. To create a .zip archive, click Tools > Create Zip Package.
      This creates a .zip archive, MFSupportInfo_Log_MachineName/YYYY-MM-DD_HH-MM-SS.zip, in the %temp% directory.
4. Send the diagnostic information to your Micro Focus SupportLine representative:
   The following requires an Internet connection and an Email client:
   a. Click Tools > Email Log to SupportLine to open the Email Log dialog box.
   b. Fill in the required fields and click Send.
      If the machine is not connected to the Internet or if there are no Email clients installed, copy either the .log file or the .zip archive to a machine that is connected to the Internet. Use your Email client to email the files to Micro Focus SupportLine at supportline@microfocus.com together with the Support Incident (SI) number, if available, and any additional details that might be useful to diagnose the issues that you are experiencing.

Creating Debug Files

If you encounter an error when compiling a program that requires you to contact Micro Focus SupportLine, your support representative might request that you provide additional debug files (as well as source and data files) to help us determine the cause of the problem. If so, they will advise you how to create them.
Disclaimer

This software is provided "as is" without warranty of any kind. Micro Focus disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Micro Focus or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Micro Focus or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Micro Focus is a registered trademark.

Copyright © Micro Focus 1984-2015. All rights reserved.