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Third Party Systems
The software is designed to run in an environment containing third party elements meeting certain prerequisites. These 
may include operating systems, directory services, databases, and other components or technologies. See the 
accompanying prerequisites list for details.

The software may require a minimum version of these elements in order to function. Further, these elements may require 
appropriate configuration and resources such as computing, memory, storage, or bandwidth in order for the software to be 
able to perform in a way that meets the customer requirements. The download, installation, performance, upgrade, 
backup, troubleshooting, and management of these elements is the responsibility of the customer using the third party 
vendor’s documentation and guidance.

Third party systems emulating any these elements must fully adhere to and support the appropriate APIs, standards, and 
protocols in order for the software to function. Support of the software in conjunction with such emulating third party 
elements is determined on a case-by-case basis and may change at any time.
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About This Guide

 Chapter 1, “Minimum Requirements,” on page 5
 Chapter 2, “Installing the Client Tools,” on page 7
 Chapter 3, “Installing the Report Viewer,” on page 9
 Chapter 4, “Data Analytics Tools,” on page 11
 Chapter 5, “Report Designer,” on page 21
 Chapter 6, “Report Viewer,” on page 39

This guide is written to provide procedural information for installing and using the Micro Focus File 
Reporter 4.1 Client Tools.

Audience
This manual is intended for network administrators who manage network storage resources as well 
as data owners responsible for reporting on metadata and permissions for unstructured data in 
Windows file systems and Microsoft 365 document libraries in OneDrive for Business, SharePoint 
Online, and Teams collaborative environments.

Feedback
We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comment feature at the bottom of each page of the 
online documentation.

Documentation Updates
For the most recent version of the Micro Focus File Reporter 4.1 Client Tools Guide, visit the Micro 
Focus File Reporter Documentation Web site. 

Additional Documentation
For additional Micro Focus File Reporter documentation, see the following guides at the Micro Focus 
File Reporter Documentation Web site: 

 Micro Focus File Reporter 4.1 Installation Guide
 Micro Focus File Reporter 4.1 Administration Guide
 Micro Focus File Reporter 4.1 Database Schema and Custom Queries Guide

Documentation Conventions
In this documentation, a greater-than symbol (>) is used to separate actions within a step and items 
in a cross-reference path.
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When a single pathname can be written with a backslash for some platforms or a forward slash for 
other platforms, the pathname is presented with a backslash. Users of platforms that require a 
forward slash, such as Linux*, should use forward slashes as required by your software.

When a startup switch can be written with a forward slash for some platforms or a double hyphen 
for other platforms, the startup switch is presented with a forward slash. Users of platforms that 
require a double hyphen, such as Linux, should use double hyphens as required by your software.
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1 1Minimum Requirements

1.1 Minimum Requirements for Installation
 Any 64-bit multi-core processor Windows workstation.

Note that significant analytic workloads with the Data Analytics tool might be directly impacted 
by the number and speed of available cores.

 .NET 6.0 Desktop Runtime (will be installed if not already present).
 A DirectX 10 compatible card is required to use the Data Analytics tool.
 Report Viewer: Minimum of 8 GB RAM.

Depending on the size of report loading, exporting, and processing, this number might need to 
be significantly increased.

 Data Analytics: Minimum of 12 GB RAM.

NOTE: For the Data Analytics tool, a minimum of about 1 KB per scan data entry (or 1 GB per 
million entries) is required.
Depending on the type of analysis, such as the Pivot Grid, and the number of entries in a single 
scan, this number might need to be significantly increased.

 Minimum of 250 MB disk space.
 Report Designer and Data Analytics users must be members of the SrsAdmins group.
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2 2Installing the Client Tools

1 From the root of the FileReporter_4.1.iso image, copy the FileReporter-
ClientTools-4.1-x64-xx.exe file to all Windows workstations where you will run the 
Client Tools.

2 From the Windows workstation, double-click FileReporter-ClientTools-4.1-x64-
xx.exe.

3 Agree to the license terms and conditions, then click Install.
4 When notified that the setup was successful, click Close.

The Data Analytics and Report Designer icons are added to the Start menu.
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3 3Installing the Report Viewer

1 From the root of the FileReporter_4.1.iso image, copy the FileReporter-
ReportViewer-4.1-x64-xx.exe file to all Windows workstations where you will run the 
Report Viewer.

2 From the Windows workstation, double-click FileReporter-ReportViewer-4.1-x64-
xx.exe.

3 Agree to the license terms and conditions, then click Install.
4 When notified that the setup was successful, click Close.

The Report Viewer icon is added to the Start menu.
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4 4Data Analytics Tools

 Section 4.1, “Using the Analytics Tools,” on page 11
 Section 4.2, “Using the Dashboard,” on page 13
 Section 4.3, “Using the Tree Map,” on page 15
 Section 4.4, “Using the Pivot Grid,” on page 16

The Micro Focus File Reporter Client Tools are designed to provide members of the administrators 
group expanded abilities in analyzing data and designing reports. The Client Tools are run from a 
Windows workstation.

The analytics tools are an integrated set of data visualization applications that include a Dashboard, 
Pivot Grid, and Tree Map.

To make use of the Data Analytics Tools, you must first have performed File System metadata scans 
for one or more Scan Targets you wish to analyze. For details on setting up File System scans, see 
Creating a Scan Policy in the File Reporter 4.1 Administration Guide.

4.1 Using the Analytics Tools
These procedures briefly introduce you to some of the capabilities of each of the applications. You 
will discover more capabilities as you work with each of the applications on your own. 

1 From the Start menu, select File Reporter 4.1 Data Analytics.
The login screen appears:

2 Enter your login credentials and click Login.

A selection dialog box similar to the following appears:
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3 Expand the shares and volumes. 

4 Double-click the File System scan you want to analyze.
The data from the scan is presented in the Dashboard.
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4.2 Using the Dashboard
NOTE: The exercises in the remainder of this chapter introduce you to some of the very basic 
analytical features of the Analytics Tools. Through familiarizing yourself with these basic features, 
you will become proficient enough with these tools to try more advanced features.

1 In the Filters region of the Dashboard, deselect one or two of the check boxes and observe how 
the changes are reflected in the Summary Data, Top Extensions by Size, and Summary regions of 
the Dashboard.

2 In the Files Created by Year region, click a specific year.
3 Observe the changes in the Summary Data, Top Extensions by Size, and Summary regions of the 

Dashboard.
The graphical displays in the Summary Data, Top Extensions by Size, and Summary regions of the 
Dashboard are driven by the Filters region and the selected years from the Files Created by Year 
and Files Modified by Year regions.

4 In the Summary Data region, place the cursor over a pie graph section and observe how 
sectional-specific information appears in a balloon.

5 Double-click the pie graph section and observe how the Dashboard drills down to show data 
specific to the selected section in the Summary Data, Top Extensions by Size, and Summary 
regions.

6 Right-click a section of the new pie graph and select Details Grid to view the individual 
filenames.

7 From the grid, right-click a file and select Open Folder to open the folder where the file is 
located.
Data Analytics Tools 13



The Dashboard gives you the ability to easily access any files you might want to know about.
8 Close the grid.
9 Drill up to the originally displayed data by clicking the Drill Up arrow pertaining to the Summary 

Data region of the Dashboard.
10 In the Top Extensions by Size region, place the cursor over one of the bars and observe how 

sectional-specific information appears in a balloon.
11 In the Top Extensions by Size region, right-click and select Export to Image.
12 Save the image to a location on your desktop.

The graphic can now be used in a presentation or report.

13 In the Files Created by Year region, double-click a year span and observe how the displayed data 
in the other regions is updated to data pertaining to the selected year.

14 Right-click the selected year span and select Clear Master Filter to have the graph span all of the 
years again.

15 In the Files Modified by Year region, double-click a year span and observe the change in the 
displayed data in the Dashboard.

16 Place the cursor over a bar in the Top Extensions by Size region, right-click and select Print 
Preview.

17 Observe that in addition to printing, you can save the graph as a PDF or email the graph.
18 Close the Print Preview page.
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4.3 Using the Tree Map
The Tree Map lets you view graphical representations of hierarchical file system data and in the 
process, gain insight very quickly.

1 From the Dashboard, click Load from Database.
2 Browse to select the file system scan you want and double-click it.
3 Click Tree Map.

4 Observe how the Tree Map is presented according to file extension type with the specific color 
assignments detailed in the File Extension region.
Each of the squares in the Tree Map represents a single file in the scanned storage resource. The 
squares are represented according to the file size, relative to all of the other files in the scan.

5 Click one of the larger squares to view the details of the file in the Properties region.
6 Right-click the file and select Open Parent Folder to open the folder where the file resides.

This gives you the ability to easily access any files you might want to know more about.
7 Expand the file system so it is displayed in the Folders region.
8 Click one of the folders to see the group of files that reside in that folder.

The files belonging to a selected folder are outlined by a magenta colored outline.
9 Right-click a folder and select Set Scope to drill down and view the contents of the folder in the 

Tree Map.
10 In the Folders region, right click the listed scan and select Reset Root Scope.
11 Click Owner.
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The Tree Map now displays files according to owners.
12 Using the color classifications in the Owner region, observe which users are storing the largest 

files.
13 Click Date Range > Access Date.
14 Observe how the data in the Tree Map is now classified according to when files were last 

accessed.
This is one of the most powerful means in File Reporter of quickly determining the relevance of 
data being stored on network storage resources. 

4.4 Using the Pivot Grid
The Pivot Grid gives you the ability to visually analyze data according to combinations of variables. 

1 From the Dashboard, click Load from Database.
2 Browse to select the file system scan you want and double-click it.
3 Click Pivot Grid.

4 From the Pivot Fields region, select Size (residing in the Measures folder) and drag it up to the 
area marked Drop Data Items. 

5 Again in the Pivot Fields region, select Owner and drag and place it in the area marked Drop Row 
Fields Here. 

6 Observe the totals now calculated for the two data variables.
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7 From the Pivot Fields region, expand Access Time to locate Access Time (Month) and drag it up to 
the area marked Drop Column Fields Here.

8 Click the filter icon from the Access Time (Month) filter that you just placed.
Data Analytics Tools 17



9 Deselect all but one month and OK.
10 Click the Chart tab.
11 Highlight three consecutive rows to view the data analyzed as graphs in the Chart region.

12 From the Chart Presets options, experiment with different chart views of the data.
13 Double-click a selected cell from the table to access the Scan Data Details table specifying all of 

the files accessed by that user during that month.
14 From the Scan Data Details table, right-click a file and select Open Folder to open the parent 

folder of the file.
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With the parent folder open, you can examine the file, move it to another location, or delete it.
15 Click the Reports tab.
16 Again, highlight three consecutive rows.
17 Click Generate Report.
18 Observe that you have the option to print the report or export it to a number of different 

formats.
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5 5Report Designer

 Section 5.1, “Using the Report Designer,” on page 21
 Section 5.2, “Creating a Report,” on page 23
 Section 5.3, “File System Paths Selector,” on page 24
 Section 5.4, “Report Layout Templates,” on page 27
 Section 5.5, “Custom Query Report Layouts,” on page 28

Report Designer allows you to design reports locally from a Windows workstation while offering 
significantly more reporting design capabilities to those of the browser-based administrative 
interface.

5.1 Using the Report Designer
NOTE: You must be a member of the SrsAdmins group to design reports using Report Designer. The 
name SrsAdmins is the default name (which you can change) of the File Reporter administrators 
group created during the installation of the Engine.

1 From the Start menu, launch the File Reporter 4.1 Report Designer.

2 Enter the login credentials and click Login.
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3 Familiarize yourself with the Report Designer interface.
All Custom Query Reports are listed. Those that have not been designed using the Report 
Designer Layout interface are displayed with the green-bannered text icon, while those 
designed using the Report Designer have the blue notebook icon.
All of the options on the toolbar are available by selecting a report and right-clicking.
New Custom Query Report:  Click to create a new Custom Query Report by launching the 
Query Editor.
Rename: Click to rename a selected Custom Query Report.
Copy: Click to create a copy of the report definition of a selected report.
Delete:  Click to delete a selected Custom Query Report.
Refresh: Click to refresh the list of saved reports.
Edit Query: Click to edit the SQL commands pertaining to a selected Custom Query Report 
through the Report Designer’s Query Editor.
Design Report Layout: Launches the Report Designer Layout interface. For more information on 
the Report Designer Layout interface, see Section 5.5, “Custom Query Report Layouts,” on 
page 28.
Clear Report Layout: Click to clear custom design settings created using the Report Designer 
Layout interface. This is a nonreversible procedure.
Visit Community Portal: Click to access the File Query Cookbook website. 
File Query Cookbook is a community website for sharing Custom Query reports and layouts 
created through the Report Designer. You can utilize a shared Custom Query report by simply 
copying the SQL commands in a shared Custom Query report “recipe.” You can also download 
shared layouts created through the Report Designer.
Access Online Templates: Click to directly access the list of all available Custom Query reports 
shared on the File Query Cookbook website. From the Custom Query Recipes page, you can 
filter your search by category, database host, and more. 
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Filter: The cell directly below the Report Name column heading is a report filter that lists saved 
Custom Query reports according what you enter. For example, if you were to enter the word 
access, the listed Custom Query reports would be only those with the word access in the 
report name.
[Report Type]: By default, this check box is selected so that it displays only Custom Query 
Reports, which are the only reports that can be designed using the Design Editor. You can 
deselect the check box to view all of your reports. 
Edit Filter: Use this button to further refine your filtering using Boolean operators.

5.2 Creating a Report
NOTE: For details and examples of the supported database functions, tables, and views that you can 
utilize in Custom Query reports, refer to the Micro Focus File Reporter 4.1 Database Schema and 
Custom Queries Guide.

1 Click New Custom Query Report.
2 Specify a descriptive name, then click Create.

The Report Designer Query Editor is launched.

3 Update the query as desired in the text editor.
4 Click Execute Query to get a preview of the Custom Query Report.
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5 Click Save.
6 Close the Query Editor.

5.3 File System Paths Selector
 Section 5.3.1, “Overview,” on page 24
 Section 5.3.2, “Assigning Paths to a Report Definition,” on page 25
 Section 5.3.3, “Removing Paths from a Report Definition,” on page 26
 Section 5.3.4, “Scan Types,” on page 26
 Section 5.3.5, “Understanding the Relation to Custom Queries,” on page 27

5.3.1 Overview
File Reporter 4.1 introduces a File System Paths selector for use with Custom Query reports.

This feature provides the following benefits for Custom Query report design:

 An easy-to-use approach for changing target paths for complex Custom Queries.
 A convenient interface for adding or changing target paths for existing Custom Queries without 

needing to modify any SQL text.
 A powerful interface for advanced report users to create manageable report templates for Data 

Owners.
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Add: Click to add selected path from the tree list to the target paths list.

Remove: Click to remove a path from the target paths list.

File System: Select to include File System scan paths in the tree list.

Permissions: Select to include Permissions scan paths in the tree list.

Save: Click to save the changes made to the target paths list.

Cancel: Click to cancel any current edits.

5.3.2 Assigning Paths to a Report Definition
To assign one or more file system paths to a Custom Query report definition:

1 Click the File System Paths ribbon item to open the File System Target Paths dialog box. 
This ribbon item may be found in the following locations:
 The Edit ribbon page group of the Main form containing the Custom Query Reports list.
 The Parameters ribbon page group of the Query Editor form.
 The Report Data ribbon page group of the Report Layout Designer form.
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2 Select one or more target paths by using one of the following methods:
 Double-click a path entry in the tree list on the right.
 Select (highlight) one or more path entries in the tree list on the right then click Add in the 

toolbar on the left.
 Drag-and-drop one or more selected path entries from the tree list on the right into the 

selected paths list on the left.
3 Click Save.

5.3.3 Removing Paths from a Report Definition
To remove one or more assign File System paths from a Custom Query Report definition:

1 Open the File System Target Paths dialog box. 
For details, see Step 1 in Section 5.3.2, “Assigning Paths to a Report Definition,” on page 25.

2 Select the paths to remove in the selected path list on the left.
To select a path to remove, select (highlight) the entries for selection then click an associated 
check box.

3 Click Remove to remove the selected items from the paths list.
4 Click Save.

5.3.4 Scan Types
 “Understanding Scan Types” on page 26
 “Filter by Scan Type” on page 26

Understanding Scan Types
The File System and Permissions columns in the paths tree list indicate whether the associated path 
is currently available as a File System metadata scan entry or a Permissions scan entry.

The paths tree list is populated from data obtained from the most recent File System or Permissions 
scans. If a share or path is not visible in the tree list, a new File System or Permissions scan must be 
performed before that path will appear.

Note that the path indicator does not determine the type of Custom Query itself, but rather provides 
feedback indicating which scan data is currently available. Depending on the nature of the Custom 
Query, one or both scan types may be desired. 

Filter by Scan Type
If a particular Custom Query is only defined around data collected solely from a File System or 
Permissions scan, it may be useful to filter the paths tree list by that scan type.

By default, both scan types are enabled and paths from the latest scans of both types are displayed.
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To filter by a specific scan type, simply deselect the scan type you wish to hide. For example, to only 
display paths from current Permissions scans:

1 Deselect the File System check box at the top of the paths tree list.
2 Verify the Permissions check box remains selected.

5.3.5 Understanding the Relation to Custom Queries
File System Target Paths provides a list of target paths for the associated Custom Query. How the 
Custom Query makes use of these paths is determined by the associated SQL queries themselves.

During execution of a Custom Query within the tools provided by File Reporter, a temporary table is 
injected into the SQL session providing the select paths along with metadata which the SQL query 
can make use of for shaping the query results based on those paths.

For more information on File System Target Paths injection with Custom Query reports, see File 
System Target Paths in the File Reporter 4.1 Custom Query Guide.

5.4 Report Layout Templates
 Section 5.4.1, “Saving the Layout as a Template,” on page 27
 Section 5.4.2, “Using a Saved Template,” on page 27

5.4.1 Saving the Layout as a Template
When working with the Report Designer, you might create a layout design that you want to utilize as 
a template for future Custom Query Reports. You can do so using Save As File.

1 In Report Designer, open the Custom Query Report whose design you want to save as a 
template.

2 Select Save > Save As File.
3 Name and save the layout.

The layout is saved as a .repx (Report Definition XML) file.

5.4.2 Using a Saved Template
You can use saved .repx files as design templates for Custom Query Reports.

NOTE: You can also use the sample report layouts and SQL queries that are available from the File 
Query Cookbook website. Both the SQL queries and report layouts can be customized as needed.

You can access the File Query Cookbook at https://filequerycookbook.com.

1 In Report Designer, open the Custom Query Report you want to design using a saved template.
2 Click Open, then select the .repx file you want to use for designing your report.

The report is updated with the design from the .repx file.
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5.5 Custom Query Report Layouts
After you have created a Custom Query Report, either through the Report Designer Query Editor or 
the Query Editor built into the browser-based administration interface, you can design the layout of 
the report. 

NOTE: This exercise introduces you to some of the very basic design features of the Report Designer. 
Through familiarizing yourself with the basic features, you will become proficient enough in the 
interface to try more advanced features.

For a more detailed explanation of features in the Report Designer, refer to the Report Designer for 
WinForms section referenced in this documentation: https://devexpress.github.io/dotnet-eud/
interface-elements-for-desktop/articles/report-designer.html.

1 From the listed Custom Query Reports, select the one you want to design.

2 Click Design Report Layout.
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3 Create a report header.
3a Place the pointer in the upper section of the layout grid. 
3b Right click and select Insert Band > Report Header.

A new ReportHeader band appears on the grid.
4 Resize Page 1 and add a page break.

4a Place the pointer on the bottom border of the new band and using the vertical ruler as a 
guide, extend the band to fill the first page.
For example, to fill the first page, you might extend the border down to the 8" mark.

4b From the Standard Controls region, click and drag a Page Break to the bottom of the band.
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5 Insert and design a chart.
5a From the Standard Controls region, click and drag a Chart to the band.

The Chart Designer is launched.

5b In the Chart Designer, below the Chart menu, click the + that pertains to the Series option 
and select the Bar option.
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5c Click the Date tab and expand Query Results.
5d Click and drag Category to the Argument cell.
5e Click and drag cat_size to the Value cell.
5f Click the Options tab and in the Name field, replace Series 1 with Category Size.
5g Below the Chart menu, click the XY-Diagram option.
5h In the Options tab, select the Rotated check box.
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5i Below the Chart menu, select Titles, click the +, and select Title.
5j In the Options tab, in the Lines field, replace Chart Title with a more descriptive name.

For example, File Extensions by Category.
5k Below the Chart menu, select Category Size.
5l Click the Properties tab, scroll down and under the Elements heading and expand View. 

5m Change the Color Each setting to Yes.
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5n Click OK.

5o In the upper right-hand corner of the newly-placed chart, click the arrow to access the 
Chart Tasks menu and select Run Designer.

5p Click the legend and from the Options tab, deselect the Visibility check box so the legend 
no longer appears.
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5q Click OK.
5r In the Report Designer, expand the view of the chart to take up more of the page.

6 Insert labels.
6a From the Toolbox, click and drag Label to a position centered below the chart.

6b Double-click within the label and specify the label name.
For example, Total Size.

6c Adjust the font size and style to your preferences.
7 Create new fields.

7a From the Field List, expand the Query Results.
7b Right-click Query Results and select Add Calculated Field.
7c In the Design region of the Property Grid for claculatedField1, change the (Name) 

setting to cfTotalSize.
7d While still in the Property Grid, under the Data heading, click the ellipses (...) pertaining to 

the Expression field.
This launches the Expression Editor.

7e In the bottom-left column, select Functions.
7f In the empty field at the top of the middle column, type sum to locate the Sum function, 

then double click Sum to place the function in the top text box of the Expression Editor. 
7g In the bottom-left column, select Fields and then in the middle column, double-click 

cat_size.
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7h Click OK to save the new filed and close the Expression Editor.
7i Right-click Query Results and select Add Calculated Field.
7j In the Design region of the Property Grid for claculatedField1, change the (Name) 

setting to cfTotalSize_String.
7k While still in the Property Grid, under the Data heading, click the ellipses (...) pertaining to 

the Expression field.
7l In the top text box of the Expression Editor, type Byte so that ByteString() appears.

7m From the middle column, double-click cfTotalSize that you created earlier and click OK.
8 Place the new fields.

8a From the Field List, hold down the Control key, select the two new fields you just created, 
then drag them to the Total Size label on the grid. 

8b Adjust the size so that both fields will appear to the right of the Total Size label.
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8c Adjust the font size and style to your preferences.
9 Preview the report.

9a Click Download All Data.
9b When the warning dialog box appears, click Yes.
9c Click the Print Preview tab to observe how the report is going to look at this point.
9d Make any desired format changes.

10 Create a header for Page 2.
10a Click the Report Designer tab.
10b In the Report Designer, scroll down below the page break so that you are working on Page 

2 of the report.
10c At the top of the page, right-click and select Insert Band > PageHeader.
10d From the Tool Box, click and drag a Table to the location of the new page header.
10e Replace the names of the three new table cells with the following names:

 Category
 Size
 File Count

10f Select the File Count cell, right-click, then select Insert > Column to Right.
10g Change the table cell name to Percent of Total.
10h Resize the table cells to your preferred width.
10i Adjust the font size and style to your preferences.
10j Resize the depth of the page header so it is limited to the depth of the table.

11 Create a new calculated field for Percent of Total.
11a Right-click Query Results and select Add Calculated Field.
11b In the Design region of the Property Grid for claculatedField1, change the (Name) 

setting to cfPercentofTotal.
11c While still in the Property Grid, under the Data heading, click the ellipses (...) pertaining to 

the Expression field.
11d From the middle column of the Expression Editor, double-click cat_string.
11e Hit the space bar and then enter the following string: * /100 
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11f Complete the string by double-clicking cfTotalSize from the middle column of the 
Expression Editor.

11g Click OK.
12 Insert the table content.

12a Click below the header, hold down the Control key, and from the Field List, select the 
following fields in this order:
 category
 cat_size_string
 file_count
 cfPercentofTotal

12b Drag the fields to a location below the header.
12c Line up the tables cells with the headings.
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12d Click the Print Preview tab to view how the report will look.
12e Make any needed adjustments.

13 Click Save > Save to Database.
By saving the report to the database you enable the File Reporter Report Generator to use the 
report design for updated reports.
In addition to saving the report to the database, you can save the report as a file where you can 
import it into another file, such as a Word file or PowerPoint presentation.
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6 6Report Viewer

The Report Viewer lets you to view all stored reports locally from a Windows workstation. Because 
the Report Viewer utilizes the resources of the Windows workstation, rather than those of the 
Engine, the Report Viewer can display stored reports much faster in most instances.

In comparison to the viewing capabilities of the browser-based administrative interface, the Report 
Viewer offers more capabilities. For example, with the Report Viewer you can change the visual 
display parameters of the report.

1 Launch the File Reporter File Viewer application.

2 Click Open, browse to the location of your stored reports, then click Open.
To determine where stored reports are located, in the File Reporter administrative interface, 
select Configuration > Stored Reports and view the location in the Stored Reports Folder field. 
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3 (Optional) Adjust the view to your preferences using the tools discussed below.
Bookmarks: Click to toggle between the report Document Map being displayed and not 
displayed.
Many Pages: Click to specify the number of pages you want displayed.
Zoom Out: Click to see more of the report page at a reduced size.
Zoom: Click to change the zoom level of the report preview.
Zoom In: Click to get a close-up view of the report.
Page Color: Click to change the color for the background of the report pages.
Watermark: Click to insert a ghosted text or image behind the content of each page of the 
report. A watermark is often used to indicate how a document is to be treated specifically.
The Watermark dialog box lets you specify your watermark settings. Your watermark can either 
be in text or graphic form.
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4 (Optional) Save the Report using the tools discussed below.
Save: Click to save the report. The report is saved as a .PNRX file, meaning that in this format, 
the report can only be opened through the Report Viewer.
Export To: Click to export the report to a new format. Each selected format option brings up a 
dialog box where you can provide specifics on how you want the report exported.
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